XYComHelp

 关于XY.Graphics

XY.Graphics是由 mikespook & swill 制作，用于动态页面开发时对BMP、JPG、JPEG、GIF（非动画、非透明）、PNG（非动画、非透明）格式图象进行操作的COM组件。

声明

本产品为免费软件，你可以在任何其他程序中使用、分发或销售。但不得对本软件进行任何形式的反工程、修改或独立销售。在你传播本软件时请保证软件的完整性。同时由于你在使用本软件时不需要支付任何费用，这也就意味着本软件的作者不承担任何由于本软件极其附属产品在某些情况下所带来的任何损失。同样，作者也没有义务解答本手册涉及范围以外的任何关于本软件的其他问题。

再次重申，本产品为免费软件，不是自由软件。作者没有公开代码的义务。所以请勿在未支付作者开发费用的情况下索要本软件的任何源程序或设计文档。

目录

如何安装

接口说明

程序示例

辅助工具

获取更多有偿服务

版本

v1.0.0.184 XY.Graphics 2005年4月（当前版本）
v1.0.0.168 XY.Graphics 2005年1月
v1.0.0.153 XY.Graphics 2004年12月
v1.0.0.56 XY.Graphics 2004年11月
v1.0.0.50 XY.Graphics 2004年10月
v1.1.0.9 XY.Watermark 2004年6月
v1.0.0.5 XY.Watermark 2004年4月

版权所有 © 2002-2005 mikespook & swill 保留所有权利。


 如何安装

进入组件所在目录输入如下命令：

H:\projects\COM\debug>regsvr32 XY.dll

当你不在需要该软件，请进入组件所在目录输入如下命令：

H:\projects\COM\debug>regsvr32 XY.dll /u

并在从新启动你的IIS服务器之后删除软件及相关文件。


 公开接口
属性
方法

Arc
ASCIIArt
BlackWhite, BlackWhiteEx
Circle
Clipping
Close
Emboss, EmbossEx
ErrorOption
Gray, GrayEx
ImageOut
Invert, InvertEx
Line
MirrorX, MirrorXEx
MirrorY, MirrorYEx
New
Open
OpenFromRS
Pie
Rectangle
Reload
Resize
Save
SaveAs
SaveToRS
SetBrush
SetFont
SetPen
SetText
SetWatermark
Zoom


 XY.Graphics公开接口
属性 Copyright

获取当前组件的版权。

语法

XY.Graphics.Copyright


属性 Ext

获取当前图象文件的扩展名类型。当使用Open方法打开一个图象文件后该属性有效。

语法

XY.Graphics.Ext

说明

类型 | 值 | 说明
BMP | 0 | Windows 3.x 位图
JPG，JPEG | 1 | 联合摄影专家组
GIF | 2 | 图形互换格式
PNG | 3 | 便携型网络图形


属性 Height

获取或设置图象高度。

语法

XY.Graphics.Height


属性 IsTrans

设置或者获取当前绘制文字与水印的方法是否使用背景透明。

语法

XY.Graphics.IsTrans

说明

类型 | 值 | 说明
False | 0 | 假
True | 1 | 真


属性 LastError

获取最后一个错误的描述。

语法

XY.Graphics.LastError


属性 PixelFormat

获取或设置当前图象文件的像素格式。当获取像素格式时只对BMP位图有效，其他类型默认为系统像素格式。

语法

XY.Graphics.PixelFormat

说明

值 | 说明
-1 | 自定义
0 | 设备
1 | 1位
4 | 4位
8 | 8位
15 | 15位
16 | 16位
24 | 24位
32 | 32位


属性 TransColor

设置或者获取当前绘制文字与水印的透明色。

语法

XY.Graphics.TransColor

说明

该属性为三字节整型值，分别表示R（红）G（绿）B（蓝）三种颜色。


属性 Version

获取当前组件的版本号。

语法

XY.Graphics.Version

说明

格式为“xx.xx.xx.xx”分别对应主版本号、次版本号、发行版本号、编译版本号。


属性 Width

获取或设置图象宽度。

语法

XY.Graphics.Width


方法 Arc

绘制曲线。

语法

XY.Graphics.Arc(Left, Top, Right, Bottom, X1, Y1, X2, Y2)

参数

Left, Top

曲线所在矩形左上顶点坐标。

Right, Bottom

曲线所在矩形右下顶点坐标。

X1, Y1

曲线启始坐标。

X2, Y2

曲线结束坐标。


方法 ASCIIArt

将一个图象转换成ASCII字符组成的图形。

语法

XY.Graphics.ASCIIArt(Width, Height)

参数

Width

一个字符替代图象中区域的像素宽度

Height

一个字符替代图象中区域的像素高度

说明

鉴于字符宽度高度比例，建议参数宽度和高度的比例为1:2或1:3。

示例


方法 BlackWhite, BlackWhiteEx

黑白化图象。BlackWhiteEx为BlackWhite的扩展方法，可指定一个区域进行部分黑白化。

语法

XY.Graphics.BlackWhite()

XY.Graphics.BlackWhiteEx(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 Circle

绘制圆。

语法

XY.Graphics.Circle(X, Y, Radii)

参数

X, Y

圆心坐标。

Radii

半径。


方法 Clipping

剪裁图象。

语法

XY.Graphics.Clipping(Left, Top, Right, Bottom)

参数

Left

左上顶点横坐标。

Top

左上顶点纵坐标。

Right

右下顶点横坐标。

Bottom

右下顶点纵坐标。


方法 Close

关闭图片，释放资源。

语法

XY.Graphics.Close

说明

虽然在使用Open或New方法创建图象时会自动释放前一个图象所占资源，但是我们还是强烈推荐使用Close方法来关闭图象以释放资源。


方法 Emboss, EmbossEx

浮雕化图象。EmbossEx为Emboss的扩展方法，可指定一个区域进行部分浮雕化。

语法

XY.Graphics.Emboss()

XY.Graphics.EmbossEx(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 ErrorOption

设置当组件发生异常时处理的行为方法。

语法

XY.Graphics.ErrorOption(Show, Break, SaveLog)

参数

Show

在页面上显示错误内容，默认为不显示。

Break

当发生错误时中断ASP页面的执行，默认为不中断。

SaveLog

保存错误日志于辅助工具设置的日志文件中，默认为不保存。当设置为保存日志文件而未设置日志文件路径时，默认保存路径于Windows安装目录（如：C:\WINNT\）。

说明

通过使用本方法可在开发时获得最佳的调试信息及状态。


方法 Gray, GrayEx

灰度化图象。GrayEx为Gray的扩展方法，可指定一个区域进行部分灰度化。

语法

XY.Graphics.Gray()

XY.Graphics.GrayEx(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 ImageOut

直接输出图象。

语法

XY.Graphics.ImageOut(Ext)

参数

Ext

输出图象的类型。

类型 | 值 | 说明
BMP | 0 | Windows 3.x 位图
JPG，JPEG | 1 | 联合摄影专家组
GIF | 2 | 图形互换格式
PNG | 3 | 便携型网络图形


方法 Invert, InvertEx

反色图象。InvertEx为Invert的扩展方法，可指定一个区域进行部分反色。

语法

XY.Graphics.Invert()

XY.Graphics.InvertEx(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 Line

以SetPen方法设置的画笔绘制直线。

语法

XY.Graphics.Line(X1, Y1, X2, Y2)

参数

X1, Y1

直线启始坐标。

X2, Y2

直线结束坐标。


方法 MirrorX, MirrorXEx

水平镜像图象。MirrorXEx为MirrorX的扩展方法，可指定一个区域进行部分水平镜像。

语法

XY.Graphics.MirrorX()

XY.Graphics.MirrorXEx(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 MirrorY, MirrorYEx

垂直镜像图象。MirrorYEx为MirrorY的扩展方法，可指定一个区域进行部分垂直镜像。

语法

XY.Graphics.MirrorY()

XY.Graphics.MirrorYEx(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 New

建立一个新图象。

语法

XY.Graphics.New(Width, Height, BKColor)

参数

Width

图象宽度。

Height

图象高度。

BKColor

背景颜色。


方法 Open

打开一个图象。

语法

XY.Graphics.Open(FileName)

参数

FileName

图象在服务器上的真实路径。


方法 OpenFromRS

从Recordset对象中获得一个图象。

语法

XY.Graphics.OpenFromRS(RS, FieldName)

参数

RS

ADODB.Recordset对象。如：

Set RS = Server.CreateObject("ADODB.Recordset")

FieldName

RS对象中图象所在字段的标识名称。


方法 Pie

绘制饼图。

语法

XY.Graphics.Pie(Left, Top, Right, Bottom, X1, Y1, X2, Y2)

参数

Left, Top

饼图所在矩形左上顶点坐标。

Right, Bottom

饼图所在矩形右下顶点坐标。

X1, Y1

饼图启始坐标。

X2, Y2

饼图结束坐标。


方法 Rectangle

绘制矩形。以SetPen方法设置的画笔绘制矩形边框，以SetBrush方法设置的画刷绘制矩形内部。

语法

XY.Graphics.Rectangle(Left, Top, Right, Bottom)

参数

Left, Top

矩形左上顶点坐标。

Right, Bottom

矩形右下顶点坐标。


方法 Reload

重新打开一个图象。当使用Open方法打开一个图象文件后该方法有效。

语法

XY.Graphics.Reload()


方法 Resize

修改图象大小。

语法

XY.Graphics.Resize(Width, Height)

参数

Width

图象宽度。

Height

图象高度。


方法 Save

保存图象到原文件。当使用Open方法打开一个图象文件后该方法有效。如果需要另存为新文件名或者使用New方法建立的图象，请使用SaveAs方法。

语法

XY.Graphics.Save()


方法 SaveAs

保存图象到指定文件名。

语法

XY.Graphics.SaveAs(FileName)

参数

FileName

图象在服务器上的真实路径。


方法 SaveToRS

保存图象到Recordset对象。

语法

XY.Graphics.SaveToRS(RS, FieldName, Ext)

参数

RS

ADODB.Recordset对象。如：

Set RS = Server.CreateObject("ADODB.Recordset")

FieldName

RS对象中图象所在字段的标识名称。

Ext

Recordset中存储图象的格式。

类型 | 值 | 说明
BMP | 0 | Windows 3.x 位图
JPG，JPEG | 1 | 联合摄影专家组
GIF | 2 | 图形互换格式
PNG | 3 | 便携型网络图形


方法 SetBrush

设置画刷。

语法

XY.Graphics.SetBrush(Color, Style)

参数

Color

颜色。

Style

样式。

类型 | 值 | 示例
实 | 0
网格 | 1
斜格 | 2
空 | 3
左斜纹 | 4
右斜纹 | 5
横纹 | 6
竖纹 | 7


方法 SetFont

设置文字。

语法

XY.Graphics.SetFont(Name, Size, Style, Color, BKColor)

参数

Name

字体。

Size

字号。

Style

样式。可使用“或”运算叠加。

类型 | 值 | 示例
粗体 | 8 | Example
斜体 | 4 | Example
下划线 | 2 | Example
空删除线 | 1 | Example

Color

颜色。

BkColor

背景颜色。


方法 SetPen

设置画笔。

语法

XY.Graphics.SetPen(Color, Width, Style)

参数

Color

颜色。

Width

宽度。

Style

样式。

类型 | 值 | 说明
实线 | 0
虚线 | 1
点线 | 2
虚点线 | 3
虚点点线 | 4
空 | 5
实线 | 6 | 当宽度大于1时使用抖动色绘制


方法 SetText

绘制文字。

语法

XY.Graphics.SetText(X, Y, Alpha, Rolling, Text)

参数

X, Y

绘制文字的坐标。

Alpha

透明度(0-100)。

Rolling

旋转角度。

Text

文字。


方法 SetWatermark

绘制水印图象。

语法

XY.Graphics.SetText(X, Y, Alpha, FileName)

参数

X, Y

绘制水印图象的坐标。

Alpha

透明度(0-100)。

FileName

水印图象在服务器上的真实路径。


方法 Zoom

缩放图象。

语法

XY.Graphics.Zoom(Ratio)

参数

Ratio

缩放比例。


 程序示例

在Demo目录下有六个ASP程序示例，分别为：

获取客户端IP地址，并以图片的形式输出。

在图片上增加图象水印。

绘制图表。

ASCII艺术。

从Recordset对象中读取或者保存图象。

设置异常处理开关，调整组件异常处理的方法。

详细请参考示例中的代码注释。

下载示例


 辅助工具

说明

使用该工具可以方便的设置当组件发生异常时处理的行为方法，如在页面上显示错误内容、当发生错误时中断ASP页面的执行、保存错误日志于日志文件中。亦可使用ErrorOption方法在运行期动态调整设置。

使用方法

选择您所需要的功能，并填写相应的内容即可。

建议

强烈建议在程序调试期打开显示错误信息及保存日志功能，以方便调试。


 获取更多有偿服务

如果你对本组件有更进一步的要求，并且愿意支付一定的酬劳作为答谢，请直接同我们联系。我们的联系方式是：

电子邮件：mikespook@163.com

MSN： mikespook@hotmail.com

网站： http://www.xxiyy.com

同时，如果你需要在线或面对面（限上海地区）技术支持或技术培训亦可同我们联系。