入门

通过创建简单但功能齐全的 Web 站点，使您熟悉 Dreamweaver MX 可视化设计、手工编码和各种应用程序开发工具。

此部分包含以下各章：

  • 简介
  • 在 Dreamweaver 中创建您的第一个 Web 站点
  • 在 Dreamweaver 中编辑代码
  • 了解 Web 应用程序
  • 在 Dreamweaver MX 中开发 Web 应用程序
  • 在 Windows 中安装 Web 服务器
  • 示例 ColdFusion 站点的设置
  • 示例 ASP.NET 站点的设置
  • 示例 ASP 站点的设置
  • 示例 JSP 站点的设置
  • 示例 PHP 站点的设置
  • 数据库连接答疑


简介

本指南旨在介绍如何使用 Macromedia Dreamweaver MX，其对象是对本软件主要特性尚不熟悉的用户。本指南中的课程引导您完成创建一个简单但具备一定功能的 Web 站点的过程。

Macromedia Dreamweaver MX 是一种专业的 HTML 编辑器，用于对 Web 站点、Web 页和 Web 应用程序进行设计、编码和开发。无论您喜欢直接编写 HTML 代码的驾驭感还是偏爱在可视化编辑环境中工作，Dreamweaver 都会为您提供帮助良多的工具，丰富您的 Web 创作体验。

利用 Dreamweaver 中的可视化编辑功能，您可以快速地创建页面而无需编写任何代码。不过，如果您更喜欢用手工直接编码，Dreamweaver 还包括许多与编码相关的工具和功能。并且，借助 Dreamweaver，您还可以使用服务器语言（例如 ASP、ASP.NET、ColdFusion 标记语言 (CFML)、JSP 和 PHP）生成支持动态数据库的 Web 应用程序。

备注： 本指南并不是一本诠释 Dreamweaver MX 所有功能的全面的说明手册，而且也不是介绍 Web 设计的入门教材。有关 Dreamweaver 的更详细信息，请参见 Dreamweaver“帮助”（从“帮助”菜单选择“使用 Dreamweaver”）。
下一页


学习 Dreamweaver 基础知识

要开始学习使用 Dreamweaver，请首先从这一《入门》指南开始（请参见如何使用本指南）。然后继续学习其他资源，例如教程、帮助系统和支持中心（请参见其他资源）。


如何使用本指南

本指南分为若干章节。您不妨按顺序依次阅读各章节；要么，您亦可以阅读本简介的其余部分，然后开始阅读最符合您的兴趣和经验的章节。在每一章中，我们建议您按课程顺序阅读各课程，这些课程的顺序是经过精心设计的，大略模拟创建一个 Web 站点的常见工作流程。

下列清单描述了每一章的内容：

  • 本简介说明如何安装 Dreamweaver 并介绍 Dreamweaver 工作区。请首先阅读本章，然后阅读您感兴趣的其他任何章节。

    • 备注： 在此版本的 Dreamweaver 中，对工作区的许多方面都进行了更改，因此，即使您以前曾使用过 Dreamweaver，也最好阅读本简介。

  • 在 Dreamweaver 中创建您的第一个 Web 站点面向以前曾创建过 Web 页但从未使用过 Dreamweaver 的人士。该章节提供一些基础知识，介绍如何使用 Dreamweaver 的可视化创作工具创建小型但具有一定功能的静态 Web 站点。
  • 在 Dreamweaver 中编辑代码主要面向手工编码人员（例如 Macromedia HomeSite 用户），但它还适用于已使用可视化工具并想要开始编辑代码的人士。该章节提供与使用 Dreamweaver 的代码编辑工具有关的基础知识。
  • 了解 Web 应用程序提供与 Web 应用程序有关的概念性背景知识。
  • 在 Dreamweaver MX 中开发 Web 应用程序面向以前已创建过静态页面（无论是否使用 Dreamweaver）并希望学习使用 Dreamweaver 创建数据库驱动的 Web 应用程序的人士。它引导您完成创建一个简单 Web 应用程序的过程。
  • 设置指导集提供与安装 Web 服务器和使用各种服务器语言设置动态站点有关的信息。
  • 教程集提供与实现某些常见任务有关的详细指导。

本指南中的这些课程使用随 Dreamweaver 提供的页面布局和示例内容。如果喜欢用自己的布局和内容创建第一个 Dreamweaver 站点，您可以这样做，但如果使用所提供的示例内容将会更容易学习这些课程。


其他资源

Dreamweaver 包括了多种资源，将帮助您快速了解该程序并熟练创建您自己的 Web 站点和页面。这些资源包括：

  • 一套教程，它提供与特定主题有关的更深入的课程，并且对于特定领域所提供的信息要比《入门》指南中的其余部分所提供的信息更详尽。
  • Dreamweaver“帮助”，包括与使用 Dreamweaver 的所有方面有关的全面信息，并且包括《入门》和教程的 HTML 版本。Dreamweaver“帮助”在操作系统提供的帮助查看器中显示：Microsoft HTML 帮助 (Windows) 或 Apple 帮助 (Macintosh)。
  • “使用 Dreamweaver”是 Dreamweaver“帮助”（不包括《入门》和教程）的内容的 PDF 版本，提供与使用 Dreamweaver 命令和功能有关的信息。在该 PDF 版本中不包括某些参考主题；有关这些主题的信息，请参见 Dreamweaver“帮助”。在您的 Dreamweaver CD 中提供该 PDF 文件。

此外，您还可在 Dreamweaver支持中心 找到定期更新的提示、技术说明、示例、教程和信息。

有关 Dreamweaver 的信息性和指导性资源的更多信息，请参见学习 Dreamweaver。


字形约定

Dreamweaver“帮助”中采用以下字形约定：

  • 菜单项按如下格式显示：“菜单名称”>“菜单项名称”。子菜单中的项按如下格式显示：“菜单名称”>“子菜单名称”>“菜单项名称”。
  • Code 字体:指示 HTML 标签和属性的名称以及在示例中使用的文字。
  • Italic code 字体:指示代码中可替换的项（有时称作元符号）。
  • Bold roman 文本:指明让您逐字输入的文本。


安装和运行 Dreamweaver

此节描述运行 Dreamweaver 的系统要求（请参见系统要求）并解释如何安装 Dreamweaver（请参见安装 Dreamweaver）。它还解释如何在多用户操作系统（例如 Windows XP 或 Mac OS X）中自定义 Dreamweaver 以满足您自己的偏爱（请参见在多用户环境中使用 Dreamweaver）。


系统要求

以下硬件和软件是运行 Dreamweaver 所必需的。

Microsoft Windows 的系统要求：
  • Intel Pentium II 处理器或等效处理器，300 MHz 或更快
  • Windows 98、Windows 2000、Windows NT（具有 Service Pack 3 或更高版本）、Windows ME 或 Windows XP
  • Netscape Navigator 4.0 版或更高版本或 Microsoft Internet Explorer
  • 96 MB 的可用内存 (RAM)（建议采用 128 MB 内存）
  • 275 MB 的可用磁盘空间
  • 分辨率可达 800 x 600 像素的 256 色显示器（建议颜色为百万颜色，分辨率达到 1024 x 768 像素）
  • CD-ROM 驱动器
Apple Macintosh 系统要求：
  • Power Macintosh G3 或更高版本
  • Mac OS 9.1、Mac OS 9.2.1 或 Mac OS X 10.1 或更高版本
  • Mac OS Runtime for Java (MRJ) 2.2 或更高版本（包括于 Dreamweaver MX CD 中）
  • Netscape Navigator 4.0 版或更高版本或 Microsoft Internet Explorer
  • 96 MB 的可用内存 (RAM)（建议采用 128 MB 内存）
  • 275 MB 的可用磁盘空间
  • 分辨率可达 800 x 600 像素的 256 色显示器（建议颜色为百万颜色，分辨率达到 1024 x 768 像素）
  • CD-ROM 驱动器


安装 Dreamweaver

请遵循以下步骤在 Windows 或 Macintosh 计算机上安装 Dreamweaver。

备注： 在某些操作系统中，只有在您对计算机具有管理权限后，才能安装或卸载 Dreamweaver。有关更多信息，请参见在多用户环境中使用 Dreamweaver。

要安装 Dreamweaver，请执行以下操作：
  1. 将 Dreamweaver CD 插入计算机的 CD-ROM 驱动器。
  2. 请从下列方法中选择其一：
    • 在 Windows 中，选择“开始”>“运行”。单击“浏览”并从 Dreamweaver CD 上选择 Dreamweaver MX Installer.exe 文件。在出现“运行”对话框后，单击“确定”开始安装。
    • 在 Macintosh 上，双击“Dreamweaver MX Installer”图标。
  3. 按照屏幕上的指导执行。
  4. 如果出现提示，则重新启动您的计算机。


在多用户环境中使用 Dreamweaver

在多用户操作系统（例如 Windows NT、Windows 2000、Windows XP 或 Mac OS X 中），应用程序通常安装在所有用户都可以从该处运行这些应用程序的文件夹中，例如 C:\Program Files (Windows) 或 Applications 文件夹 (Macintosh)。在多用户操作系统中，只有具有管理权限的用户才可以将应用程序安装到此类文件夹中。

您可以通过多种方式自定义 Dreamweaver。Dreamweaver 禁止任何用户的自定义配置影响任何其他用户的自定义配置。为了达到这个目的，当您首次在 Dreamweaver 可以识别的某个多用户操作系统中运行它时，该应用程序将为您创建各种配置文件的拷贝。这些用户配置文件存储在一个属于您的文件夹中。

备注： 在较早的操作系统（Windows 98、Windows ME 和 Mac OS 9.x）中，即使将操作系统配置为支持多个用户，所有用户仍共享一组 Dreamweaver 配置文件。

如果您在安装 Dreamweaver MX 后重新安装或升级了 Dreamweaver，Dreamweaver 会自动制作现有用户配置文件的备份拷贝；这样一来，如果您已手工自定义了这些文件，仍然可以访问已做的更改。有关手工自定义配置文件的信息，请参阅“Macromedia 支持中心”上的“自定义 Dreamweaver”。

在从多用户系统卸载 Dreamweaver 时，Dreamweaver 可以为您删除每一用户配置文件夹。


注册 Dreamweaver MX

若要获得更多的 Macromedia 支持，最好以电子方式或通过邮件注册您的 Macromedia Dreamweaver MX 的拷贝。

在注册后，您可以登录以接收与 Macromedia 升级产品和新产品有关的最新通知。您还可以登录，以获得与 www.macromedia.com 和 www-euro.macromedia.com Web 站点上提供的产品更新和新内容有关的即时电子邮件通知。

若要注册 Macromedia Dreamweaver MX，请执行以下操作之一：
  • 选择“帮助”>“联机注册”并填写电子表格。
  • 选择“帮助”>“书面注册”，打印该表格，并将表格邮寄到表格中所示的地址处。


首次探讨Dreamweaver 工作区

在 Windows 中，Dreamweaver MX 提供了两种可供选择的工作区布局：一种将全部元素置于一个窗口中的集成布局和一种非常类似于 Dreamweaver 4 的浮动布局。

在 Macintosh 中，只能使用浮动布局。

此节说明如何在 Windows 中选择初始工作区布局（请参见选择工作区布局（仅适用于 Windows））。此节还描述了 Windows 和 Macintosh 中工作区的主要元素（请参见窗口和面板概述和菜单概述）。


选择工作区布局（仅适用于 Windows）

在 Windows 中首次启动 Dreamweaver 时，会出现一个对话框，您可以从中选择一种工作区布局。如果您以后改变了主意，可以使用“参数选择”对话框切换到一种不同的工作区。

若要选择工作区布局，请执行以下操作：

选择下列布局之一：

Dreamweaver MX 工作区是一个使用 MDI（多文档界面）的集成工作区，其中全部“文档”窗口和面板被集成在一个更大的应用程序窗口中，并将面板组停靠在右侧。建议大多数用户使用它。

备注： 本指南中的大部分内容假定您使用的是集成 Dreamweaver MX 工作区。

HomeSite/代码编写者样式的 Dreamweaver MX 工作区是同样的集成工作区，但是将面板组停靠在左侧，布局类似于 Macromedia HomeSite 和 Macromedia ColdFusion Studio 所用的布局，而且“文档”窗口在默认情况下显示“代码”视图。建议 HomeSite 或 ColdFusion Studio 用户以及其他需要使用熟悉的工作区布局的手工编码人员使用这种布局。若要选择这种布局，请选择“Dreamweaver MX 工作区”选项，然后选择“HomeSite/代码编写者样式”选项。

备注： 在这两种集成工作区布局的任何一种布局中，您都可以在工作区的任何一侧停靠面板组。

Dreamweaver 4 工作区是一种与 Dreamweaver 4 中所用布局相类似的工作区布局，其中每个文档都位于自己的独立浮动窗口中。面板组停靠在一起，但并不是停靠在一个更大的应用程序窗口中。仅建议喜欢使用更熟悉的工作区的 Dreamweaver 4 用户使用这种布局。


窗口和面板概述

以下是 Dreamweaver 的工作区中提供的窗口和其他元素的简要说明。与如何使用这些窗口有关的某些细节在本指南的后面提供；有关更详细信息，请参见 Dreamweaver“帮助”（“帮助”>“使用 Dreamweaver”）。

“欢迎使用”窗口提供有关针对各种目的设置工作区的提示，并为使用过 Dreamweaver 早期版本的用户提供有关新功能的信息。

“插入”栏包含用于将各种类型的对象（如图像、表格和层）插入到文档中的按钮。每个对象都是一段 HTML 代码，允许您在插入它时设置不同的属性。例如，您可以在“插入”栏中单击“图像”图标插入一个图像。如果您愿意，可以不使用“插入”栏而使用“插入”菜单插入对象。

“文档”工具栏包含按钮和弹出式菜单，它们提供各种“文档”窗口视图（如“设计”视图和“代码”视图）、各种查看选项和一些普通操作（如在浏览器中预览）。

“文档”窗口显示您当前创建和编辑的文档。

属性检查器用于查看和更改所选对象或文本的各种属性。每种对象都具有不同的属性。

面板组是一组停靠在某个标题下面的相关面板的集合。若要展开一个面板组，请单击组名称左侧的展开箭头；若要取消停靠一个面板组，请拖动该组标题条左边缘的手柄。

“站点”面板使您可以管理组成站点的文件和文件夹。有关更多信息，请参见设置本地站点。它还提供了本地磁盘上全部文件的视图，非常类似于 Windows 资源管理器 (Windows) 或 Finder (Macintosh)。

Dreamweaver 提供了许多此处未说明的其它面板、检查器和窗口，如“历史记录”面板和代码检查器。若要打开 Dreamweaver 面板、检查器和窗口，请使用“窗口”菜单。


菜单概述

此节提供 Dreamweaver 中各菜单的简要概述。

“文件”菜单和“编辑”菜单包含用于“文件”菜单和“编辑”菜单的标准菜单项，例如“新建”、“打开”、“保存”、“剪切”、“拷贝”和“粘贴”。“文件”菜单还包含各种其他命令，用于查看当前文档或对当前文档执行操作，例如“在浏览器中预览”和“打印代码”。“编辑”菜单包括选择和搜索命令，例如“选择父标签”和“查找和替换”，并且提供对键盘快捷方式编辑器和标签库编辑器的访问。“编辑”菜单还提供对 Dreamweaver 菜单中“参数选择”的访问，但对 Mac OS X 系统的 Macintosh 除外。

“查看”菜单使您可以看到文档的各种视图（例如“设计”视图和“代码”视图），并且可以显示和隐藏不同类型的页面元素以及不同的 Dreamweaver 工具。

“插入”菜单提供插入栏的替代项，以用于将对象插入您的文档。

“修改”菜单使您可以更改选定页面元素或项的属性。使用此菜单，您可以编辑标签属性，更改表格和表格元素，并且为库项和模板执行不同的操作。

“文本”菜单使您可以轻松地设置文本的格式。

“命令”菜单提供对各种命令的访问；包括根据您的格式参数选择设置代码格式的命令、创建相册的命令，以及使用 Macromedia Fireworks 优化图像的命令。

“站点”菜单提供一些菜单项，这些菜单项可用于创建、打开和编辑站点，以及用于（在 Macintosh 上）管理当前站点中的文件。

“窗口”菜单提供对 Dreamweaver 中的所有面板、检查器和窗口的访问。

“帮助”菜单提供对 Dreamweaver 文档的访问，包括用于使用 Dreamweaver 以及创建对 Dreamweaver 的扩展的帮助系统，并且包括各种语言的参考材料。

除了菜单栏菜单外，Dreamweaver 还提供多种上下文菜单，您可以利用它们方便地访问与当前选择或区域有关的有用命令。若要显示上下文菜单，右击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 窗口中的某一项。上下文菜单中的所有项都可以在菜单栏菜单中找到。


查看示例站点

本指南中使用的示例出自一个名叫 Global Car Rentals （全球租车公司）的虚构公司的小型示例站点。在开始学习这些课程前，请在浏览器中查看示例站点，以了解在您的整个课程学习期间将创建哪些内容。

若要在浏览器中查看示例站点，请执行以下操作：
  1. 打开 Dreamweaver 应用程序文件夹中的 Samples 文件夹。然后依次打开 GettingStarted 文件夹和 FinalSite 文件夹。
  2. 双击 FinalSite 文件夹中的 index.htm 文件以在浏览器中查看该站点。
  3. 在查看了示例站点后，请继续阅读本指南中您感兴趣的任一章节。
上一页


在 Dreamweaver 中创建您的第一个 Web 站点

本章提供一系列简短的课程，指导您完成在 Macromedia Dreamweaver MX 中使用可视化创作工具创建简单的静态 Web 站点的过程。有关在 Dreamweaver 中使用手工编码工具的信息，请参见在 Dreamweaver 中编辑代码；有关创建数据库驱动动态 Web 应用程序的信息，请参见了解 Web 应用程序。

本章中课程的顺序是按照创建一个站点可能的工作流程安排的。当创建自己的站点时，您可以按照任何最适合您的工作流程进行。

若要创建静态 Web 站点，请执行以下操作：
  1. 规划和准备（请参见设置本地站点和将资源添加到您的站点）。
  2. 创建页（请参见创建并保存新页）。
  3. 对页进行布局和设置（请参见调整布局和设置页面标题）。
  4. 向页中添加内容（请参见添加具有样式的文本和添加图像）。
  5. 将页链接在一起（请参见添加页之间的文本链接和为图形化链接创建鼠标经过图像）。
  6. 发布您的站点（请参见在浏览器中预览和设置远程站点，然后发布）。
下一页


设置本地站点

使用 Dreamweaver 创建 Web 站点最常见的方法就是在您的本地磁盘上创建并编辑页，然后将这些页的拷贝上传到一个远程 Web 服务器使公众可以访问它们。可以通过其他方法（例如在您的本地计算机上运行 Web 服务器，或将文件上传到模拟调试服务器，或像使用本地磁盘一样使用安装的磁盘）使用 Dreamweaver，但本指南中的课程假设您在本地磁盘上进行操作，然后上传到远程服务器。

在 Dreamweaver 中，站点 是下列任意一项的简称：

  • Web 站点：一组位于服务器上的页，使用 Web 浏览器访问该站点的访问者可以对其进行浏览。
  • 远程站点：服务器上组成 Web 站点的文件，这是从您的（创作者的）角度而不是访问者的角度来看的。
  • 本地站点：与远程站点上的文件对应的本地磁盘上的文件。您在本地磁盘上编辑文件，然后将它们上传到远程站点。
  • Dreamweaver站点定义：本地站点的一组定义特性，以及有关本地站点和远程站点对应方式的信息。

通常，创建 Web 站点是从对其进行规划开始的：决定要创建多少页、每页上显示什么内容以及页是如何互相连接起来的。不过，在本课中，您将创建一个非常简单的站点，因此不需要太多的规划：它将只包含两个 Web 页，其间具有链接。因此，对于此站点，您可以跳过规划，进入创建站点定义阶段。

您将使用“站点定义”对话框创建站点定义。您可以以两种视图中的任意一种来填写此对话框：“基本”或“高级”。“基本”方法指导您一步一步地完成站点设置。如果您宁愿在没有指导的情况下编辑站点信息，则可以随时单击“高级”选项卡。

以下过程介绍如何设置“基本”版本对话框中的选项，该版本的对话框也叫做“站点定义向导”。如果需要有关如何在“高级”版本中设置选项的详细信息，请单击“高级”选项卡，然后单击“帮助”按钮。

若要定义站点，请执行以下操作：
  1. 选择“站点”>“新建站点”。（即从“站点”菜单中选择“新建站点”。）

    2. 即会出现“站点定义”对话框。

  2. 如果对话框显示的是“高级”选项卡，则单击“基本”。

    3. 出现“站点定义向导”的第一个屏幕，要求您为站点输入一个名称。

  3. 在文本框中，输入一个名称以在 Dreamweaver 中标识该站点。该名称可以是任何所需的名称。例如，您可以将站点命名为“Global Car Rental”。
    这是所描述的功能的图片。
  4. 单击“下一步”进入下一个步骤。

    5. 出现向导的下一个屏幕，询问您是否要使用服务器技术。

  5. 选择“否”选项指示目前该站点是一个静态站点，没有动态页。
    这是所描述的功能的图片。

    6. 如果要设置站点来创建 Web 应用程序，则需要选择动态文档类型，例如 Macromedia ColdFusion、Microsoft Active Server Page (ASP)、Microsoft ASP.NET、Sun JavaServer Page (JSP) 或 PHP Hypertext Preprocessor (PHP)，然后提供有关应用程序服务器的信息（有关更多信息，请参见在 Dreamweaver MX 中开发 Web 应用程序）。

  6. 单击“下一步”进入下一个步骤。

    7. 出现向导的下一个屏幕，询问您要如何使用您的文件。

  7. 选择标有“编辑我的计算机上的本地拷贝，完成后再上传到服务器（推荐）”的选项。

    8. 在站点开发过程中有多种使用文件的方式，但为了学习本课程，请选择此选项。

  8. 文本框允许您在本地磁盘上指定一个文件夹，Dreamweaver 将在其中存储站点文件的本地版本。若要指定一个准确的文件夹名称，通过浏览指定要比键入路径更加简便易行，因此请单击该文本框旁边的文件夹图标。

    9. 随即会出现“选择站点的本地根文件夹”对话框。

  9. 在“选择站点的本地根文件夹”对话框中，先浏览到本地磁盘上可以存放所有站点的文件夹。现在不要单击“确定”。

    10. 备注： 此站点文件夹最后将包含多个站点，因此不要选择站点文件夹作为本地根文件夹。马上您将在站点文件夹中为该特定站点创建一个本地根文件夹。

    如果您尚未创建站点文件夹，现在就可以创建一个（使用“选择站点的本地根文件夹”对话框中的文件夹创建按钮），并将该文件夹命名为“Sites”。站点文件夹的推荐位置取决于您的操作系统：

    • 在 Windows 中，如果您还没有用来存储站点文件的位置，则在 C 驱动器根目录创建一个文件夹并将其命名为“Sites”。即该文件夹的路径是 C:\Sites。
    • 在 Mac OS 9 中，如果您还没有存储站点的位置，则在磁盘驱动器的根目录创建一个文件夹并将其命名为“Sites”。
    • 在 Mac OS X 中，您的主文件夹 (/Users/your_user_name) 包含一个名为“Documents”的文件夹。定位到该文件夹，并且在其中创建名为“Sites”的文件夹。
  10. 还是在“选择站点的本地根文件夹”对话框中，在您的 Sites 文件夹中创建一个新文件夹。将这个新文件夹命名为“GettingStarted”，然后单击“确定”退出“选择站点的本地根文件夹”对话框。

    11. 这个新文件夹就是您的站点的本地根文件夹。
    这是所描述的功能的图片。

  11. 单击“下一步”进入下一个步骤。

    12. 出现向导的下一个屏幕，询问您如何连接到远程服务器。

  12. 现在，从弹出式菜单中选择“无”。单击“下一步”进入下一个步骤。

    13. 该向导的下一个屏幕将出现，其中显示您的设置概要。

  13. 单击“完成”完成设置。

    14. 您可以稍后设置有关远程站点的信息（请参见设置远程站点，然后发布）；目前，本地站点信息对于开始创建页已经足够了。

    将出现一个警告，通知您 Dreamweaver 将创建站点缓存。站点缓存是 Dreamweaver 存储有关站点信息的一种方式，可以使多个站点操作速度更快。

  14. 单击“确定”允许 Dreamweaver 创建站点缓存。

“站点”面板现在显示当前站点的新本地根文件夹，同时显示一个图标允许您以分层树视图查看所有本地磁盘。该图标标为“桌面”(Windows) 或“计算机”(Macintosh)。

“站点”面板通常显示您站点中的所有文件和文件夹，但是目前站点中不包含任何文件或文件夹。当站点中存在文件时，“站点”面板中的文件列表将充当文件管理器，允许您拷贝、粘贴、删除、移动和打开文件，就象在计算机桌面上一样。

如果您已经具有一组要用来创建 Web 站点的本地 HTML 文件，则可以使用“站点”面板中的文件浏览器将这些文件拷贝到新创建站点的文件夹中。但是，在开始使用自己的文件之前，您可能要使用 Dreamweaver 附带的文件来完成本指南中的课程。

如果您在远程服务器上已经具有了一个 Web 站点并要使用 Dreamweaver 来编辑该站点，请参见使用 Dreamweaver 编辑现有 Web 站点。


将资源添加到您的站点

在创建了本地站点之后，如果您已为该站点创建了资源（图像或其他内容片断），则将这些资源放置在本地站点根文件夹内的一个文件夹中。那么当您要向页中添加内容时，这些资源将随时可用。

Dreamweaver 附带“Global Car Rental”站点的图像和文本文件。如果要创建“Global Car Rental”的页，您必须将站点的图像拷贝到您的站点的本地根文件夹中。可以使用“站点”面板完成此操作。

这些资源在一个名为“Design”的文件夹中。为了简单起见并和本《入门》指南中其余的部分保持一致，请将整个 Design 文件夹拷贝到您的站点中，然后在该文件夹中进行操作。

若要将图像的文件夹拷贝到您的站点的本地根文件夹中，请执行以下操作：
  1. 如果尚未打开“站点”面板，则选择“窗口”>“站点”将其打开。

    2. 即会显示“站点”面板。（如果“站点”面板已经打开，则执行该步骤后不会显示“站点”面板。如果未显示“站点”面板，则再次选择“窗口”>“站点”显示该面板。）

  2. 在“站点”面板中，展开“桌面”(Windows) 或“计算机”(Macintosh) 图标以查看可用的磁盘。
  3. 按需要展开文件夹以打开 Dreamweaver 应用程序文件夹。
  4. 展开 Samples 文件夹。
  5. 展开 Samples 文件夹中的 GettingStarted 文件夹。
  6. 选择 GettingStarted 文件夹中的 Design 文件夹，然后按 Ctrl+C 组合键 (Windows) 或 Command+C 组合键 (Macintosh) 拷贝该文件夹。

    7. Design 文件夹包含一个名为“Assets”的文件夹，而 Assets 文件夹又包含与站点相关的多个资源（其中包括一个 images 子文件夹）。

  7. 还是在“站点”面板中，滚动到您的站点的本地根文件夹（您在定义站点时创建的文件夹）并选择该文件夹。然后按 Ctrl+V 组合键 (Windows) 或 Command+V 组合键 (Macintosh) 将 Design 文件夹的拷贝粘贴到您的站点中。


创建并保存新页

设置完站点后，您就可以创建 Web 页来填充站点了。

当启动 Dreamweaver 时，将自动创建一个空的 HTML 文档。在继续之前，请关闭该文档。

若要关闭默认的空文档，请执行以下操作：

选择“文件”>“关闭”。

若要创建新页，请执行以下操作：
  1. 选择“文件”>“新建”。

    2. 即会出现“新建文档”对话框。
    这是所描述的功能的图片。

  2. 在左边的类别列表中，选择“页面设计”类别。

    3. 对话框内中间列的列表重新标为“页面设计”。即会出现一组预先设计的页面设计。

  3. 在“页面设计”列表中向下滚动，选择名为“文本：文章 D（具有导航条）”的项。

    4. 备注： 还有一项具有相似的名称。一定不要选择名为“文本：文章 D”的项，该项没有导航条。

    在对话框的右侧显示该页的一个小预览图像。
    这是所描述的功能的图片。

    如果愿意，您可以使用所提供的任何其他页面设计创建页，或通过从“基本页”类别中选择一项创建没有预设格式的页。本课的其余部分假设您正在使用“文本：文章 D（具有导航条）”页面设计。

  4. 确保选择了该对话框右下角的“文档”单选按钮。
  5. 单击“创建”。

    6. 新文档窗口中将出现一个新页，该页使用您选择的布局。该页填有占位符“Lorem ipsum”文本以显示当添加了实际文本后页面设计的外观。
    这是所描述的功能的图片。

  6. 保存您的文档。
若要保存新页，请执行以下操作：
  1. 选择“文件”>“保存”。
  2. 在“保存为”对话框中，浏览到站点根文件夹中的 Design 文件夹。

    3. 提示：站点根文件夹是您在设置本地站点中设置站点时创建的文件夹。

  3. 输入文件名“index.htm”。
  4. 单击“保存”。

    5. 文件名现在显示在文档窗口标题条上“无标题文档”名称后的括号中。


调整布局

预先设计的页提供了一个起始点，但是它们不太可能完全符合您自己的页所需要的布局。

若要修改页的布局，请使用 Dreamweaver 的布局工具。本指南将提及某些工具，但若要获得更多信息，请参见使用表格显示内容、在布局视图中对页进行布局和制作层动画。

首先，删除您不需要的布局元素。为了创建“Global Car Rental”页布局，请删除若干多余的表格和单元格。请参见删除多余的元素。

然后添加图像占位符并调整表格列的宽度（使用 Dreamweaver 的布局视图）使所有内容正好合适。请参见添加图像占位符和列设置为自动伸展。


删除多余的元素

在任何预先设计的页面设计中都可能存在最终页不需要的元素。您可以选择这些元素并将它们删除。

如果您正在创建“Global Car Rental”页，标准页面设计中以下元素是多余的：

  • 页顶部导航链接中的两个链接
  • 主文本列上面的标题区域
  • 侧栏列中标题旁边的小框
  • 页底部的版权栏

删除元素的一般步骤是选择该元素然后按Backspace 键 (Windows) 或 Delete 键 (Macintosh)。以下步骤说明如何选择并删除每个多余的元素。完成后，检查以确保已删除了所有要删除的元素，然后保存该文档。

若要删除多余的导航链接，请执行以下操作：
  1. 选择“查看”>“表格视图”>“标准视图”以确保您正在以标准视图查看表格。
  2. 在文档的导航条中，将鼠标指针从具有“Sic Amet”链接的表格单元格拖到具有“Consectetur”链接的表格单元格。
    这是所描述的功能的图片。

    3. 两个表格单元格都将高亮显示，指示它们已被选中。

  3. 按Backspace 键 (Windows) 或 Delete 键 (Macintosh)。

    4. 表格单元格即被删除。其他的表格单元格（“Lorem”、“Ipsum”和“Dolor”链接）自动扩展以填满表格的宽度。

若要删除多余的文本列标题，请执行以下操作：
  1. 在文本列的顶部，单击单词“Title”。
    这是所描述的功能的图片。
  2. 在“文档”窗口底部的标签选择器中，单击最左侧的 <table> 标签，该标签出现在 <body> 标签的右侧，与它紧挨着。（如果在浮动工作区中无法看到 <body> 标签，则加宽文档窗口。）
    这是所描述的功能的图片。
  3. 按Backspace 键 (Windows) 或 Delete 键 (Macintosh) 删除包含标题的表格。

    4. 备注： 标签选择器中有两个 <table> 标签，这是因为标题区域是一个嵌套在另一个表格中的表格。在本例中，您应该删除外面的表格，它是由最左边的 <table> 标签表示的。

若要删除侧栏标题中多余的框，请执行以下操作：
  1. 在右侧列中单词“News”的左侧，在包含感叹号的框中单击。
    这是所描述的功能的图片。
  2. 在标签选择器中，单击最右边的 <td> 标签以选择感叹号周围的框。
    这是所描述的功能的图片。
  3. 按Backspace 键 (Windows) 或 Delete 键 (Macintosh)。
若要删除多余的版权栏，请执行以下操作：
  1. 滚动到页的底部。单击底部版权栏中的任意位置。
  2. 在标签选择器中，单击最左边的 <table> 标签，即紧靠 <body> 标签右边显示的那个标签。然后按 Delete 键删除包含版权信息的表格。
若要检查并保存页，请执行以下操作：
  1. 查看页以确保您已删除了多余的元素。

    2. 您的页看起来应该和下面的图像类似：
    这是所描述的功能的图片。

  2. 保存您的文档。


添加图像占位符

现在创建占位符来代替您将在稍后添加的图像。

若要添加图像占位符，请执行以下操作：
  1. 单击主文本列的开始位置（即文本顶部左侧，正好在文本第一个黑体字之前）。然后按Enter 键 (Windows) 或 Return 键 (Macintosh) 在文本之前放置一个空行。然后单击这个新的空行。
    这是所描述的功能的图片。

    2. 插入点现在应该单独在一行上。如果不是，请将插入点放置在空行上。

  2. 选择“插入”>“图像占位符”。
  3. 在“图像占位符”对话框中，输入占位符的名称（例如“SplashImage”）以及宽度和高度。对于“Global Car Rental”页，输入的宽度为 523，高度为 220。

    4. 备注： 占位符名称必须以字母开头，只能包含字母和数字。

  4. 单击“确定”。

    5. 随即会出现一个具有指定尺寸的灰色框。这就是图像的占位符，用于帮助您对页进行布局，而无需使用最终的图像。
    这是所描述的功能的图片。

  5. 您可能需要加宽文档窗口以查看右侧的文本列。


列设置为自动伸展

index.htm 页中右边的侧栏文本列是固定宽度的。要使它随着访问者调整浏览器窗口的大小改变宽度，请让该列设置为自动伸展。然后调整包含图像占位符的宽列的宽度。

若要使左边的列设置为自动伸展，请执行以下操作：
  1. 如果未显示插入栏，则选择“窗口”>“插入”显示插入栏。
  2. 在插入栏上，单击“布局”选项卡。
  3. 单击“布局视图”按钮切换到布局视图。
  4. 阅读信息对话框，然后单击“确定”。

    5. 对于页中的每个表格，都会在表格的左上角显示一个绿色的选项卡。该选项卡上标有“布局表格”。

  5. 在文档窗口中，单击您插入的图像占位符上方左侧的“布局表格”选项卡，选择包含两个文本列的表格。

    6. 两个文本列中每列的上方都有一个列标题，显示每列的宽度。

  6. 如果文档窗口太窄以致于无法显示右侧列的全部内容，则加宽您的文档窗口。

    7. 即使在您加宽了文档窗口之后，其他“布局表格”选项卡也可能遮住右侧列标题中显示宽度的数字。不要单击其他的“布局表格”选项卡。

  7. 小心地单击右侧列上的列标题。（一定要单击右侧列中绿色“布局表格”选项卡顶部的上方。）

    8. 随即会出现一个弹出式菜单。
    这是所描述的功能的图片。

  8. 在弹出式菜单中选择“列设置为自动伸展”。

    9. 出现一个标题为“选择间隔图像”的对话框，提示您选择一个间隔图像。

    备注： 如果您已经选择了间隔图像，则不出现此对话框；在本例中，右边的列现在已设置为自动伸展的列。如果不显示该对话框，则跳过此过程其余的步骤。

  9. 在“选择间隔图像”对话框中，选择“使用现存的间隔图像文件”选项并单击“确定”。

    10. 出现另一个对话框，标题为“选择间隔图像文件”。

  10. 在“选择间隔图像文件”对话框中，浏览到您的本地根文件夹并打开 Assets 文件夹。然后打开 Images 文件夹并选择 spacer.gif，随后单击“确定”(Windows) 或“打开”(Macintosh)。

    11. 右侧的列现在已设置为自动伸展列；在浏览器中，在以固定的宽度绘制左侧的列之后，右侧列的宽度将尽可能地伸展。

若要调整主文本列的宽度，请执行以下操作：
  1. 单击左侧列上方的列标题，并从出现的弹出式菜单中选择“使单元格宽度一致”。

    2. 左侧的列现在已设置为固定的宽度（等于图像的宽度加上单元格边距和单元格间距）。

  2. 单击插入栏中的“标准视图”按钮切换回标准视图。
  3. 保存您的文档。


设置页面标题

您可以设置页面的多种属性，包括其标题、背景颜色、文本颜色等。（若要设置页面属性，请选择“修改”>“页面属性”。） 但是如果您只想设置页面标题（显示在浏览器标题条中的标题），则可以在文档工具栏中完成该操作。

若要为您的文档设置页面标题，请执行以下操作：
  1. 如果文档工具栏不可见，则选择“查看”>“工具栏”>“文档”。

    2. 即会出现 Dreamweaver 的文档工具栏。在集成工作区中，默认情况下它显示在文档区域的顶部；在浮动工作区中，它显示为文档窗口的一部分。
    这是所描述的功能的图片。

  2. 在“标题”文本框中（其中显示“无标题文档”），键入该页的标题，例如“Global Car Rental 主页”。然后按Enter 键 (Windows) 或 Return 键 (Macintosh) 查看文档窗口标题条中页面标题的更新。
  3. 保存您的文档。


添加具有样式的文本

您可以在文档窗口中键入文本，或从另一个源（例如 Microsoft Word 文件）拷贝并粘贴文本。请参见添加文本。然后，您可以使用“CSS 样式”面板对文本进行格式设置。请参见将样式添加到文本。

在输入文本之前，通过选择“查看”>“设计”确保您正在设计视图中。


添加文本

当您在设计视图中输入文本并对其进行格式设置时，Dreamweaver 创建基础 HTML 代码。若要直接输入代码，请使用代码视图。有关代码视图的信息，请参见在 Dreamweaver 中编辑代码。

Dreamweaver 附带的预先设计的页包含占位符“Lorem ipsum”文本，如果您的页基于预先设计的页，则当准备好开始添加内容时，您将需要用自己的文本替换占位符文本。但是，在您完成设计和布局之前在适当的位置保留占位符文本将非常有用，这样您或您的客户可以查看布局，而不会被文本分散注意力。

若要将文本添加到您的页，请执行以下操作：
  1. 单击三下左边列顶部（图像占位符下面）的粗体占位符文本以选择整个粗体段落。
  2. 键入“Safety Tips”（或者，如果愿意，可以键入您自己的标题文本）。
  3. 选择水平线下面的三个占位符文本段落。
  4. 键入以下文本（或者，如果愿意，可以键入您自己的文本）：

    5. The safety of our loyal customers is important to us.Read these safety tips to ensure that your next trip goes off without a hitch!

  5. 在右边的列中，单击三下单词“News”并键入“Globe-Trotter Promotions”将其替换。
  6. 在“站点”面板中，在您的 Assets 文件夹中找到 promotions.txt 文件。双击该文件的图标将其打开。

    7. 此文件包含 Global Car Rentals 特别促销的拷贝。

    备注： 在此示例站点中，包含该拷贝的文件是一个文本文件。对于其他站点，提供给您的可能是 Microsoft Word 生成的 HTML 文档；您可以导入该 HTML 并使用 Dreamweaver 的“导入 Word HTML”命令对其进行清理。有关更多信息，请参见打开现有文档。

    请注意，该文本文件显示在新的文档窗口中，沿左侧显示一个深色的竖条。此窗口在代码视图中，因为该文件不是 HTML 文件，所以不能切换到设计视图。
    这是所描述的功能的图片。

    备注： 如果愿意，可以在页上使用您自己的文本，而不使用所提供的文本。

  7. 在 promotions.txt 文档窗口中，按 Control+A 组合键 (Windows) 或 Command+A 组合键 (Macintosh) 选择所有文本，然后选择“编辑”>“拷贝”来拷贝该文本。
  8. 在 index.htm 文档窗口中，选择右侧列下面单元格中的所有占位符文本，然后选择“编辑”>“粘贴”。

    9. 文本被粘贴到表格中。

  9. 在单词“Rent”（您刚粘贴的文本的第二段）之前单击，然后选择“插入”>“水平线”以便在两个促销之间放置一条水平线。
  10. 保存您的文档。
  11. 切换到 promotions.txt 文件。选择“文件”>“关闭”关闭该文件。


将样式添加到文本

在 HTML 中设计文本的样式有多种方法。一种方法是使用层叠样式表 (CSS) 来定义特定的 HTML 标签以按照特定方式设置格式。

本课说明如何从预先设计的样式表创建简单的 CSS 样式表，然后将新样式表应用于文本并修改样式。

若要创建 CSS 样式表，请执行以下操作：
  1. 选择“文件”>“新建”。
  2. 在“新建文档”对话框中，从左边的类别列表中选择“CSS 样式表”类别。

    3. 对话框内中间列的列表重新标为“CSS 样式表”。随即会出现一组预先设计的样式表。

  3. 在“CSS 样式表”列表中，选择一个样式表。对于“Global Car Rental”站点，选择“基本：Verdana”，该样式表通过指定 body、td 和 th 标签的字体对它们进行重新定义。然后单击“创建”。
    这是所描述的功能的图片。

    4. Dreamweaver 将创建一个新的文本文件，该文件包含一小组预先定义的 CSS 样式。

  4. 选择“文件”>“保存”来保存新的 CSS 文件。 将其保存在站点的 Assets 文件夹中并命名为“text.css”（或任何其他所需的名称）。
  5. 选择“文件”>“关闭”以关闭该 CSS 文件。
若要使用 CSS 样式设置文本的样式，请执行以下操作：
  1. 在“窗口”菜单中，选择一个 HTML 文件（例如 index.htm）。

    2. 备注： 如果您的系统参数选择设置为不显示文件扩展名，则 index.htm 文件在“窗口”菜单中显示时其名称为“index”。

  2. 选择“窗口”>“CSS 样式”以显示“CSS 样式”面板。
  3. 在“CSS 样式”面板的顶部，单击“编辑样式”单选按钮显示可用的样式。

    4. 如果以前没有为该文档定义样式，则没有样式可用。

  4. 在“CSS 样式”面板的底部，单击“附加样式表”按钮。
    这是所描述的功能的图片。

    5. 即会出现“链接外部样式表”对话框。

  5. 在“链接外部样式表”对话框中，单击“浏览”定位一个样式表。
  6. 在“选择样式表文件”对话框中，浏览到并选择您在 Assets 文件夹中创建的新样式表，然后单击“确定”(Windows) 或“选择”(Macintosh) 附加该样式表。
  7. 在“链接外部样式表”对话框中，单击“确定”附加该样式表。

    8. 该样式表的名称和内容显示在“CSS 样式”面板中。样式表中定义的样式将应用到 HTML 文档的文本中。例如，正文文本以 Verdana 显示。

  8. 保存您的文档。
若要编辑样式表中的样式，请执行以下操作：
  1. 在“CSS 样式”面板的顶部，单击“编辑样式”单选按钮显示可用的样式。
  2. 在“CSS 样式”面板中选择 CSS 文件的名称，然后单击“CSS 样式”面板底部的“编辑样式表”按钮。
    这是所描述的功能的图片。

    3. 即会出现一个对话框，显示该样式表中样式的名称。

  3. 选择其中的一个样式，例如 body，然后单击“编辑”。

    4. 即会出现“CSS 样式定义”对话框。
    这是所描述的功能的图片。

  4. 输入文本的大小，例如 13 像素。按需要调整其他选项。
  5. 单击“确定”重新定义样式。
  6. 编辑其他的样式。为了创建“Global Car Rental”站点中使用的样式，请将 body、td 和 th 样式的大小设置为 13 像素。
  7. 编辑完样式后，单击“保存”按钮保存您的更改并关闭样式表对话框。

    8. 更改后的样式将应用于您的文档。例如，正文文本以 13 像素的 Verdana 显示。


添加图像

在本课中，您可以将图像添加到正在处理的页。如果您具有自己的图像，则可以改用这些图像，但是第一次尝试添加图像时，我们建议使用 Dreamweaver 的示例站点提供的图像。

如果您尚未按照将资源添加到您的站点中说明的过程将“Global Car Rental”站点的资源拷贝到您的站点的本地根文件夹，现在请完成该操作。

若要将图像添加到您的文档，请执行以下操作：
  1. 如果您尚未保存文档，请保存您的文档。

    2. 您可以将图像插入未保存的文档中，但是如果这样做，将出现一个对话框，通知您用于图像的 URL 将是到该图像的完整本地路径。如果您采取此方法，Dreamweaver 将在您保存文档时修复 URL，但是在添加图像之前保存文档是最简单的方法。

  2. 若要插入图像以代替现有的图像占位符，请双击该占位符。例如，若要在“Global Car Rental”页的左上角插入公司徽标，请双击标有“image (100 x 50)”的小占位符。

    3. 即会出现“选择图像源”对话框。

  3. 在靠近此对话框的底部，确保“相对于”弹出式菜单设置为“文档”。

    4. 有关文档相对 URL 和根目录相对 URL 的信息，请参见关于文档位置和路径。

  4. 浏览到 Assets 文件夹中的某个图像（例如 logo.jpg）。
  5. 单击“确定”或“选择”(Windows) 或者“打开”或“选择”(Macintosh) 插入该图像。

    6. 在文档窗口中，该图像显示在刚才占位符所在的位置。

  6. 单击您在添加图像占位符中创建的大图像占位符将其选中。（不要双击该占位符。）

    7. 您可以使用与用于另一个占位符的相同方法用图像替换此占位符，但是以下说明提供了一种替代方法。

  7. 确保“站点”面板和属性检查器正在显示（如果它们不可见，则选择“窗口”>“站点文件”和“窗口”>“属性”）。
  8. 在属性检查器中，从“源文件”文本框的“指向文件”图标拖到“站点”面板。（确保是从“源文件”文本框旁边的“指向文件”图标而不是“链接”文本框旁边的那个“指向文件”图标开始拖动的。）当您指向 Assets 文件夹时继续按住鼠标按钮（如果该文件夹关闭）；该文件夹将打开。当您指向 images 文件夹时仍继续按住鼠标按钮；该文件夹也将打开。继续按住鼠标按钮，直到鼠标指针在 vintage.jpg 文件上为止。松开鼠标按钮以选择 vintage.jpg。
    这是所描述的功能的图片。

    9. 在文档窗口中，该图像显示在刚才占位符所在的位置。如果显示错误的图像，则查看“源文件”文本框中的文件名；如果您选择了错误的文件，则再次拖动“指向文件”图标。

  9. 若要在没有插入占位符的位置插入图像，请在设计视图中单击将插入点放置在需要显示图像的位置，然后选择“插入”>“图像”。

    10. 如果您插入一个图像，而该图像的图像文件不在您的站点的本地根文件夹中，则 Dreamweaver 提供选项自动将该图像拷贝到站点中。

  10. 保存您的文档。


设置背景颜色

在 Dreamweaver 附带的预先设计的页中，表格单元格的背景颜色大多设置为灰色；对于大多数站点，您将需要更改颜色来匹配站点的颜色方案。

若要设置表格单元格的背景颜色，请执行以下操作：
  1. 如果未打开属性检查器，则选择“窗口”>“属性”将其打开。
  2. 如果属性检查器已折叠（只显示其标题条），则单击标题条中的扩展箭头将其展开。
  3. 如果属性检查器未显示所有属性，则单击属性检查器右下角的扩展箭头查看所有属性。
    这是所描述的功能的图片。
  4. 按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 单击某个单元格以选择该单元格。例如，在“Global Car Rental”示例页中，现在有一个表格单元格包含汽车租赁公司的徽标图像；按住 Ctrl 键或 Command 键单击这个包含徽标图像的单元格。

    5. 属性检查器的下半部分显示单元格属性。如果属性检查器的下半部分不可见，则单击属性检查器右下角的扩展箭头查看所有属性。

  5. 在属性检查器中，单击显示在两个“背景”标签中下面那个标签旁边的“背景颜色”按钮。
    这是所描述的功能的图片。

    6. 即会出现颜色选择器，鼠标指针变为滴管的形状。
    这是所描述的功能的图片。

  6. 选择一种颜色。您可以在颜色选择器的调色板中选择颜色，或单击显示上的任意位置来选择所单击像素的颜色。例如，单击 Global 徽标图像的背景使表格单元格的背景颜色与图像的背景颜色一致。

    7. 表格单元格的背景颜色变为您所选择的颜色。

  7. 为每个要更改其背景颜色的表格单元格重复该过程。在“Global Car Rental”示例页中，更改所有导航条表格单元格和第二列文本中标题单元格（该单元格现在包含文本“Globe-Trotter Promotions”）的背景颜色，使它们都与 Global 徽标的背景颜色一致。
  8. 保存您的文档。


查看代码

让我们暂时休息一下看看当您将内容添加到页时 Dreamweaver 在执行哪些操作。当您添加文本、图像和其他内容时，Dreamweaver 生成 HTML 代码。

Dreamweaver 允许您以下面两种方式中的任意一种查看文档：设计视图（在设计视图中文档看起来与它在浏览器中的外观非常相似）和代码视图（您可以在代码视图中看到基础 HTML 代码）。您还可以使用同时显示代码视图和设计视图的拆分视图。

若要查看文档的 HTML 代码，请执行以下操作：
  1. 如果文档工具栏尚不可见，则选择“查看”>“工具栏”>“文档”。
  2. 在文档工具栏中，单击“显示代码视图和设计视图”按钮。
    这是所描述的功能的图片。

    3. 窗口拆分，显示基础 HTML 代码。
    这是所描述的功能的图片。

    您可以在代码视图中编辑代码。对代码进行的更改在您刷新视图之前不会出现在设计视图中。

若要让代码更改显示在设计视图中，请执行以下操作之一：
  • 单击设计视图中的任意位置。
  • 单击文档工具栏中的“刷新”按钮。
    这是所描述的功能的图片。

Dreamweaver 提供了许多高级功能帮助您在代码视图中进行编码，有关更多信息，请参见在 Dreamweaver 中编辑代码。

当您处理自己的页时，您可以使用任何一个最适合的视图。我们假设在本章剩下的部分中您将使用设计视图。

若要只显示设计视图，请执行以下操作：
  1. 如果文档工具栏尚不可见，则选择“查看”>“工具栏”>“文档”。
  2. 在文档工具栏中，单击“设计视图”按钮。
    这是所描述的功能的图片。


创建第二页

在本课中，您将为您的站点创建第二页；在下一课（添加页之间的文本链接）中，您将创建页之间的链接。

创建第二页可以使用多种方法。在本课中，您将通过拷贝第一页来创建第二页，因此第二页将与第一页具有相同的布局。

备注： 如果您要从头开始创建自己的布局，则可以使用 Dreamweaver 表格编辑工具或布局视图。其他的布局方法包括框架和层。但是，本课中不涉及这些可选方法。

在一个较复杂的站点中，确保所有页都具有相同布局的最佳方式就是使用模板。有关阅读哪些部分来了解表格编辑、布局视图、框架、层和模板的信息，请参见其他参考资料。

您在“Global Car Rental”站点中创建的第二页是客户服务页。您将通过以下方法创建客户服务页：制作主页 (index.htm) 的拷贝，然后删除不应该出现在客户服务页上的内容，最后添加新内容。

有关如何添加文本和对文本进行格式设置的更多信息，请参见添加具有样式的文本。

若要创建第一页 (index.htm) 的拷贝，请执行以下操作：
  1. 在“站点”面板中，右击 (Windows) 或按住 Control 键单击 (Macintosh) 您创建的第一页的文件名，即 index.htm（或您为该文件指定的任何其他名称）。
  2. 从上下文菜单中选择“复制”。

    3. 随即会显示该文件的拷贝。

    提示： 如果拷贝没有立即显示，则单击“站点”面板中的“刷新”按钮使其显示出来。

  3. 选择新的复制文件。稍停片刻，然后再次单击它使文件名可以编辑（这与在 Windows 资源管理器和 Finder 中使用的方法相同）。
  4. 为新文件指定一个新名称，例如 customerService.htm。
若要从新页中删除多余的内容，请执行以下操作：
  1. 通过在“站点”面板中双击新的 customerService.htm 页将其打开。

    2. 查看文档窗口的标题条以确保您正在查看 customerService.htm 文件。标题条应该显示“Global Car Rental 主页”，然后是一个文件夹名称和一个文件名；文件名应该是 customerServe.htm（或您在前面的步骤中为其命名的任何其他名称）。

  2. 在 customerService.htm 页中，通过单击大图像（在主文本列中显示汽车的图像）将其选中。
  3. 在标签选择器中，单击 <td> 标签。
  4. 按Backspace 键 (Windows) 或 Delete 键 (Macintosh)。

    5. 将删除该表格单元格中的所有内容，包括图像和文本。

  5. 保存您的文档。
若要将文本添加到新页，请执行以下操作：
  1. 在“站点”面板中，找到 Assets 文件夹中的 custServInfo.htm 文件。双击该文件的图标将其打开。

    2. 此文件包含要添加到客户服务页的内容。如果您在创建自己的站点，您将在此处添加自己的内容，但是为了本课程的需要，为您提供了此内容。

  2. 在 custServInfo.htm 文档窗口中，选择“查看”>“代码”查看 HTML 代码。
  3. 还是在 custServInfo.htm 文档窗口中，按 Control+A 组合键 (Windows) 或 Command+A 组合键 (Macintosh) 选择文件中的全部内容。

    4. 如果在进行此操作时您不在代码视图中，则可能需要多次按 Control+A 组合键或 Command+A 组合键才能选中全部内容；如果插入点在一个表格单元格中，“全选”最初只是选择该单元格。为了简单起见，在选择全部内容之前先切换到代码视图。

  4. 按 Control+C 组合键 (Windows) 或 Command+C 组合键 (Macintosh) 拷贝所有内容。
  5. 切换回 customerService.htm 文档。在现在为空的主文本列（左边的宽列）中单击。
  6. 选择“编辑”>“粘贴 HTML”。

    7. 您从 custServInfo.htm 文件拷贝的 HTML 代码被粘贴到此文档中。（如果您选择“编辑”>“粘贴”而不是“编辑”>“粘贴 HTML”，则 HTML 代码会被当作文本粘贴到设计视图中。如果在此步骤中 HTML 代码显示在设计视图中，则选择“编辑”>“撤消”并重试。）

    已将 text.css 样式表附加到此页上，因此将自动对文本进行格式设置。


添加页之间的文本链接

您可以在站点创建过程的任何阶段创建链接。如果您按顺序学习本指南中的课程，那么您现在应该已经掌握了如何创建页并在页中放置内容；接下来在本课中您将学习在已创建的页之间创建链接。

以下是另外两种为站点创建链接的常见方法：

  • 先创建一组空白页，然后在它们之间添加链接，最后向页中添加内容。
  • 在您创建页时，指定链接至尚不存在的页；随后，以您已链接的文件名创建页。
若要创建从客户服务页到 index.htm 的链接，请执行以下操作：
  1. 如果客户服务页不是当前页，则切换到该页。（如果该页未打开，则在“站点”面板中双击它的图标将其打开。）
  2. 在左边宽文本列的底部，选择单词“Home Page”。

    3. 如果在创建页时没有向客户服务页左边的列中添加文本，则在该文本列中输入单词“Home Page”并将其选中。

  3. 如果属性检查器未打开，则选择“窗口”>“属性”将其打开。
  4. 单击属性检查器中“链接”文本框旁边的文件夹图标。浏览到站点本地根文件夹中的 index.htm 文件。


为图形化链接创建鼠标经过图像

鼠标经过图像是当站点的访问者用鼠标指针指向该图像时发生变化的图像。例如，当访问者指向页上的某个按钮时该按钮可能会变亮。

鼠标经过图像由两个图像组成：当页最初载入浏览器时显示的图像，以及鼠标指针移到原始图像上时显示的图像。

备注： 当创建鼠标经过图像时，确保使用两个具有相同尺寸的图像。

若要创建鼠标经过图像，请执行以下操作：
  1. 如果主页 (index.htm) 不是当前页，则切换到主页。（如果该页未打开，则在“站点”面板中双击它的图标将其打开。）
  2. 在文档窗口中，将插入点放置在要显示鼠标经过图像的位置。例如，在“Global Car Rental”主页上，双击标有“Lorem”的导航条表格单元格并按Backspace 键 (Windows) 或 Delete 键 (Macintosh) 删除该文本，并将插入点保留在该单元格中。
  3. 选择“插入”>“交互式图像”>“插入鼠标经过图像”。
    这是所描述的功能的图片。
  4. 在“插入鼠标经过图像”对话框中，在“图像名称”文本框中为该图像键入一个名称，例如“home-image”。

    5. 这样就为该图像指定了一个专用的名称，可以在 HTML 代码中方便地识别该图像。

  5. 在“原始图像”文本框中，单击“浏览”；然后浏览到站点 images 文件夹（Assets 文件夹中）中的 btnHome.jpg 文件。确保“相对于”弹出式菜单设置为“文档”；然后单击“确定”或“选择”(Windows)，或者单击“打开”或“选择”(Macintosh)。

    6. “原始图像”文本框指示当页最初在浏览器中显示时显示哪个图像。

  6. 在“鼠标经过图像”文本框中，单击“浏览”；然后浏览到站点 images 文件夹中的 btnHome_on.jpg。确保“相对于”弹出式菜单设置为“文档”；然后单击“确定”或“选择”(Windows)，或者单击“打开”或“选择”(Macintosh)。

    7. “鼠标经过图像”文本框指示当鼠标指针指向浏览器中的图像时显示哪个图像。

  7. 确保选择了“预载鼠标经过图像”选项，这样当在浏览器中打开该页时就载入鼠标经过图像，保证了当用户将鼠标指针移到原始图像时图像间的快速转换。
  8. 在“按下时，前往的 URL：”文本框中，单击“浏览”按钮并浏览到 index.htm。

    9. index.htm 文件就是您正在编辑的文件，因此该步骤使鼠标经过图像链接到您在其上放置鼠标经过图像的页。让链接指向该链接所在的页看上去可能是多余的，但是您还将在其他页上使用同一组导航鼠标经过图像，因此该链接将允许访问者从其他包含此导航条的页返回 index.htm 页。

  9. 单击“确定”关闭该对话框。

    10. 指定的原始图像显示在文档中。

  10. 保存您的文档。

备注： 在 Dreamweaver 文档窗口中用鼠标指针指向鼠标经过图像时它们不会发生变化；鼠标经过图像只在浏览器中起作用。为了确保鼠标经过图像正常工作，您应该在浏览器中预览您的文档。有关预览的信息，请参见在浏览器中预览。

对于“Global Car Rental”站点，在另外两个导航条表格单元格（分别标有“Ipsum”和“Dolor”的两个单元格）中再创建两个鼠标经过图像：一个鼠标经过图像使用 btnCustomerService.jpg 和 btnCustomerService_on.jpg 图像，链接到 customerService.htm；另一个鼠标经过图像使用 btnLocations.jpg 和 btnLocations_on.jpg 图像，链接到 locations.htm.。请注意，您尚未创建 locations.htm 文件；只是在“插入鼠标经过图像”对话框的“单击时，转到 URL”文本框中键入该文件名。


拷贝导航条

创建了工作的导航条之后，您便可以在所有页上重复使用它了。在本课中，您将拷贝导航条表格单元格并将它们粘贴到您的第二个页中。

有多种在 Dreamweaver 中重复使用内容的方法，包括库项目、模板和代码片断。

若要将导航条拷贝到另一页中，请执行以下操作：
  1. 在 index.htm 文件中，单击包含“Home”鼠标经过图像的表格单元格。
  2. 在标签选择器中，选择最右侧的 <tr> 标签。

    3. 将选中包含三个导航条鼠标经过图像的表格行。

  3. 选择“编辑”>“拷贝”。
  4. 切换到 customerService.htm 文件。
  5. 单击标有“Lorem”的导航条表格单元格。
  6. 在标签选择器中，选择最右侧的 <tr> 标签。
  7. 选择“编辑”>“粘贴”。

    8. 即会粘贴导航条鼠标经过图像代替现有的表格单元格。

  8. 保存您的文档。


在浏览器中预览

设计视图可以使您对页在浏览器中的外观有一个大概的了解，但如果要确切地了解页的外观，只能在浏览器中进行预览。每种浏览器的每个版本都有其自身的特点；Dreamweaver 力求生成在不同的浏览器间显示时外观尽可能相似的 HTML，但有时差异是无法避免的。（这正是为什么 Dreamweaver 不直接显示预览的原因；Dreamweaver 不可能模仿所有不同浏览器的全部不同的行为。）

“在浏览器中预览”显示当您发布这些页时它们的外观。

若要预览页，请执行以下操作：
  1. 如果 index.htm 不是当前文档，则切换到该文档。（如果它未打开，则将其打开。）
  2. 按 F12 键。

    3. 如果您的主浏览器没有运行，则它将启动。它显示索引页。

    备注： Dreamweaver 应该自动检测到您的主浏览器并使用它来进行预览。如果不显示预览，或者如果它未显示在您预期的浏览器中，则切换回 Dreamweaver（如果需要）并选择“文件”>“在浏览器中预览”>“编辑浏览器列表”。 即会显示“在浏览器中预览”参数选择对话框；将正确的浏览器添加到列表中。有关更多信息，请单击“参数选择”对话框中的“帮助”按钮。

  3. 移动鼠标指针指向鼠标经过图像查看图像是否变化。单击链接确保它们正常工作。


设置远程站点，然后发布

现在，您已创建了一个小型且功能齐全的 Web 站点。下一步就是通过将文件上传到远程 Web 服务器来发布该站点。

在继续之前，您必须具有对远程 Web 服务器（例如您的 ISP 的服务器、您的客户所拥有的服务器、公司中的 Intranet 服务器，或者 Windows 计算机上的 IIS 或 RWS 服务器）的访问权。如果您尚不具有对这样一个服务器的访问权，请与您的 ISP、客户或系统管理员联系。

您的远程根文件夹为空时最适合以下过程的进行。如果您的远程站点已经包含文件，则在远程站点（在服务器上）中创建一个空文件夹，然后将该空文件夹用作您的远程根文件夹。

以下过程假设您已经设置了一个本地站点。有关更多信息，请参阅设置本地站点。

若要连接到远程站点，请执行以下操作：
  1. 选择“站点”>“编辑站点”。
  2. 选择一个站点（例如“Global Car Rental”），然后单击“编辑”。
  3. 单击对话框顶部的“基本”选项卡。
  4. 当设置本地站点时，您已填写了“基本”选项卡中的前几个步骤，因此单击几次“下一步”，直到向导顶部高亮显示“正在共享文件”步骤。
    这是所描述的功能的图片。
  5. 在标有“您如何连接到远程服务器？”的弹出式菜单中，选择一种连接到远程站点的方法。

    6. 连接到 Internet 上的服务器的最常见方法是使用“FTP”；连接到您的 Intranet 上的服务器的最常见方法是使用“本地/网络”。如果您不确定此处要选择哪种方法，请询问服务器的系统管理员。

  6. 如果您选择“FTP”，则输入以下选项：
    • 输入服务器的主机名（例如 ftp.macromedia.com）。
    • 在询问哪个文件夹包含您的文件的文本框中，输入服务器上从 ftp 根文件夹到远程站点的根文件夹的路径。如果您不确定，请咨询您的系统管理员。

      • 在许多情况下，此文本框应该留空。

    • 在相应的文本框中输入您的用户名和密码，然后单击“测试连接”。
    • 如果连接不成功，请咨询您的系统管理员。
  7. 如果您选择“本地/网络”，则单击文本框旁边的文件夹图标，然后浏览到远程站点的根文件夹。
  8. 单击“下一步”。
  9. 不要启用该站点的存回和取出。

    10. 如果您和您的同事正在创建一个较大的站点，则存回和取出功能可帮助您防止互相覆盖彼此的文件。但是，对于此站点，您不需要此功能。

  10. 单击“下一步”。
  11. 单击“完成”以完成远程站点的设置。
  12. 再次单击“完成”完成对站点的编辑。
若要将您的页上传到远程站点，请执行以下操作：
  1. 在“站点”面板中，选择站点的本地根文件夹。
  2. 单击“上传文件”按钮。
    这是所描述的功能的图片。

    3. 所有站点文件将被上传到远程站点。

  3. 在浏览器中打开您的远程站点以确保正确上传了所有内容。


其他参考资料

Dreamweaver 是一个庞大的应用程序，具有许多强大的功能。本指南只涉及一些基础知识。

《入门》这一章着重介绍使用设计视图创建静态站点。有关代码视图和在 Dreamweaver 中手工编码的信息，请参见在 Dreamweaver 中编辑代码。有关创建数据库驱动 Web 应用程序基础知识的信息，请参见了解 Web 应用程序和在 Dreamweaver MX 中开发 Web 应用程序。

有关《入门》这一章中所涉及主题的更多详细信息，请参见 Dreamweaver“帮助”中的以下主题：

  • 了解工作区
  • 设置 Dreamweaver 站点
  • 设置文档
  • 在布局视图中对页进行布局
  • 插入文本和设置文本格式
  • 插入图像
  • 创建鼠标经过图像
  • 在浏览器中预览页面
  • 设置远程文件夹

除了有关特定主题的信息之外，Dreamweaver“帮助”还提供有关其他资源的信息，例如 Macromedia 支持中心和在线论坛。有关这些资源的信息，请参见欢迎使用 Dreamweaver。

上一页


在 Dreamweaver 中编辑代码

尽管 Web 开发人员可以利用 Macromedia Dreamweaver MX 提供的各种可视化工具，但许多开发人员还是使用编码工具来完成工作。Dreamweaver 具有许多新功能，为您提供了所需的专业编码环境。

本章简要介绍了 Dreamweaver 所提供的新的专业编码环境。有关更多信息，请参见Dreamweaver 中的编码。

下一页


切换到编码工作区

如果您在安装期间没有这么做的话，您现在可以使工作区在外观和感觉上类似于 HomeSite 和 ColdFusion Studio 的流行编码环境。

备注： Macintosh 用户不能更改工作区。

若要采用新的编码工作区，请执行以下操作：
  1. 选择“编辑”>“参数选择”，然后从左侧的分类列表中选择“常规”。

    2. 即会显示“常规”分类。
    这是所描述的功能的图片。

  2. 单击“更改工作区”按钮。

    3. 即会显示“工作区设置”对话框。
    这是所描述的功能的图片。

  3. 选择“Dreamweaver MX 工作区”选项，然后选择“HomeSite/编码器样式”选项。
  4. 单击“确定”两次以关闭“参数选择”对话框。
  5. 关闭 Dreamweaver，然后重新启动它。


将文件夹拷贝到您的站点

在开始这些课程前，您需要设置站点并将文件夹拷贝到该站点。“站点”面板中的集成文件浏览器使您可以查看本地硬盘和网络。当所处理的文件不在“站点”面板上显示的当前站点中时，这一功能将十分有用。

若要将页面拷贝到您的站点中，请执行以下操作：
  1. 如果“站点”面板尚未打开，则选择“窗口”>“站点”以打开它。
  2. 在“站点”面板中，从“站点”弹出式菜单中选择您已在上一章中定义的站点的名称。

    3. 如果您尚未定义一个站点，请参见设置本地站点。您需要在继续前定义一个站点。

    从弹出式菜单中选择站点名称后，Dreamweaver 将显示该站点中的文件。

  3. 展开“桌面”(Windows) 或“计算机”(Macintosh) 图标可以看到可用的磁盘。
  4. 根据需要展开文件夹以访问 Dreamweaver 应用程序文件夹，然后展开 Samples 文件夹。
  5. 在 Samples 文件夹中，展开 GettingStarted 文件夹，然后选择 Code 文件夹，并且按 Ctrl+C 组合键 (Windows) 或 Command+C 组合键 (Macintosh) 以拷贝它。
  6. 滚动回“站点”面板的顶部，然后选择站点文件夹。
  7. 按 Ctrl+V 组合键 (Windows) 或 Command+V 组合键 (Macintosh) 将文件夹的拷贝粘贴到您的站点中。


查看已完成的页面

在您开始前，可以查看已完成的页面以查看页面的大致情形。当然，页面可能会发生变化。

若要查看已完成的页面，请执行以下操作：
  1. 如果“站点”面板尚未打开，则选择“窗口”>“站点”以打开它。
  2. 展开“桌面”(Windows) 或“计算机”(Macintosh) 图标可以看到可用的磁盘。
  3. 根据需要展开文件夹以访问 Dreamweaver 应用程序文件夹，然后展开 Samples 文件夹。
  4. 在 Samples 文件夹中，展开 GettingStarted 文件夹，然后展开 FinalSite 文件夹。
  5. 在 FinalSite 文件夹中，双击 index.htm 以打开它，然后双击 location_comp.htm。

    6. Dreamweaver 将在“文档”窗口中显示这些页面。

  6. 在完成后关闭这些页面。


打开多个页面

使用“站点”面板打开本课所需的多个页面。

若要打开多个页面，请执行以下操作：
  1. 如果“站点”面板尚未打开，则选择“窗口”>“站点”以打开它。
  2. 在您的站点中，展开 Code 文件夹。
  3. 双击 index.htm 以打开它，然后双击 location_start.htm。

    4. 这两个文件是本课所需的文件。

  4. 在“文档”窗口中，单击工具栏上的“显示代码视图”按钮，或者选择“查看”>“代码”以切换到“代码”视图并查看文件的源代码。
  5. 若要在各页面间迅速切换，请按下 Ctrl+Tab 组合键或单击页面底部的选项卡（仅限 Windows）。

    6. 备注： 您必须最大化页面才可以看到这些选项卡。


通过拖动添加图像

在本课中，您将为“位置”页向主页添加一个按钮，这类似于用于“主页”和“客户服务”的按钮。可以在页面上直接输入代码，单击“插入”栏中的图像图标，或者使用图像 (IMG) 标签编辑器（选择该图像，右键单击 (Windows) 或按住 Control 键的同时单击 (Macintosh)，然后选择“编辑标签”）。

另一个选择是从图像的文件夹拖动图像。

若要通过拖动添加一个图像，请执行以下操作：
  1. 如果 index.htm 尚未打开，则在“代码”视图中打开它。
  2. 在“文件”面板组中，打开“资源”面板（“窗口”>“资源”）。
  3. 选择用于 btnLocations.jpg 的图像文件。
  4. 将该图像文件拖入页代码中，然后将其放置在代码中以用于第一个表格中的第三个单元格。

    5. 提示： 查找用于“主页”和“客户服务”按钮的代码。在用于上述两个按钮的两个单元格后面的表格单元格的结束 </td> 标签前放置“位置”图像。

    Dreamweaver 在插入点处插入代码以创建图像。

  5. 选择“文件”>“保存”。


使用标签选择器添加链接

现在，您将使添加的按钮链接到“位置”页。除了手动输入用于链接的代码和使用“插入”栏添加链接外，您还可以使用标签选择器添加链接。

若要借助于标签选择器编写代码，请执行以下操作：
  1. 如果 index.htm 尚未打开，则在“代码”视图中打开它。
  2. 在用于第一个表的代码中，查找并选择您在上一节中插入的“位置”按钮的代码。

    3. 备注： 确保您高亮显示整个 <img> 标签。

  3. 用右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 选定文本，然后从弹出式菜单中选择“插入标签”。

    4. 随即会出现标签选择器。

  4. 依次选择“HTML 标签”、“页元素”、“常规”，然后在右侧的窗格中选择“A”。

    5. 备注： 您还可以选择“HTML 标签”，然后在右侧的窗格中选择“A”标签，而不必首先选择“页元素”、“常规”。

  5. 单击“插入”。

    6. 即会出现锚标签 (<a>) 的标签编辑器。
    这是所描述的功能的图片。

  6. 在“HREF”文本框中，输入 location_start.htm 或单击“浏览”按钮浏览到该文件。

    7. 备注： 如果您想要链接到一个 Web 页，请输入该页的 URL。

  7. 单击“确定”以关闭标签编辑器。
  8. 单击“关闭”以关闭标签选择器。

    9. Dreamweaver 将代码插入您的页面中以创建该链接。

  9. 在“文档”窗口中，选择“文件”>“保存”。


编辑标签

接下来，您将使用标签检查器查找“位置”页面中的特定标签并迅速对其进行更改。

若要使用标签检查器编辑一个标签，请执行以下操作：
  1. 如果 location_start.htm 尚未打开，则在“代码”视图中打开它。
  2. 如果标签检查器尚未打开，则执行以下操作之一打开它：
    • 选择“窗口”>“标签检查器”。
    • 在“代码”面板组中，单击“标签检查器”选项卡。

      • 标签检查器向您提供您的页面中的所有标签的结构化视图。它还显示每一标签的属性。
      这是所描述的功能的图片。

  3. 在“文档”窗口的“代码”视图中，找到标题为“Rental Locations”的文本。
  4. 在下面的标题后的段落标签之间选择不换行的空格实体 (&nbsp;)：
    5. <p><FONT SIZE="+2" COLOR="#FF6600">Rental Locations</FONT></p>
<p>
&nbsp;</p>
  5. 选择“插入”>“表格”，然后在“插入表格”对话框中单击“确定”以接受默认值。

    6. Dreamweaver 插入表格代码。

  6. 单击工具栏上的“刷新”按钮。

    7. “标签检查器”面板进行更新，这样焦点位于您刚插入的“Table”标签上。属性列表出现在该标签下。

  7. 在“文档”窗口中，单击几个不同的标签以查看标签检查器是如何更新该标签以及该标签显示的属性的，然后再次单击“Table”标签以便其属性出现在标签检查器中。
  8. 在“标签检查器”面板中，单击 align 属性旁边的空文本框。

    9. 随即出现弹出式菜单的箭头。

  9. 单击弹出式菜单箭头，然后选择“center”。

    10. Dreamweaver 在“文档”窗口中更改该代码。

  10. 单击工具栏上的“显示设计视图”按钮或选择“查看”>“设计”以看到该表格。
  11. 在“文档”窗口中，选择“文件”>“保存”。


查找与标签有关的信息

如果您需要与标签的属性和属性值有关的帮助，则您可以在 Dreamweaver 中查找参考信息。

若要查找与一个标签有关的信息，请执行以下操作：
  1. 如果 location_start.htm 尚未打开，则在“代码”视图中打开它。
  2. 在“文档”窗口中，在 body 标签中选择文本“bgcolor”。
  3. 用右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 选定文本，然后从弹出式菜单中选择“参考”。

    4. 随即打开“参考”面板并显示与 bgcolor 属性有关的信息。

    备注： 您还可以选择“窗口”>“参考”以访问“参考”面板。此面板集成在“代码”组面板的开发环境中。

  4. 有关特定标签属性的信息，请从弹出式菜单中选择该属性。
    这是所描述的功能的图片。


使用代码提示添加图像

在此课程中，您将向“位置”页添加一个徽标。

若要手动将代码添加到页面上，只需在“文档”窗口中单击并开始键入即可。您还可以使用在 Dreamweaver 中提供的新的代码提示功能以加快工作速度。

若要借助于代码提示编写代码，请执行以下操作：
  1. 如果 location_start.htm 尚未打开，则在“代码”视图中打开它。
  2. 查找用于包含文本“The International Car Rental Specialists”的表格行的代码；在代码中为位于该文本前面的单元格选择非换行的空格实体 (&nbsp;)：
    3. <td rowspan="2" bgcolor="#424973">&nbsp;</td>
  3. 键入图像标签的左尖括号 (<)。

    4. 在插入点处出现标签列表。

    备注： 您可以通过选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从左侧的分类列表中选择“代码提示”，设置延迟的时间长度。您可以通过按空格键打开“代码提示”，并且您可以通过按 Esc 键随时关闭“代码提示”。

  4. 从列表中选择 img 标签，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh) 以插入该标签。

    5. 提示： 若要迅速滚动到一个标签，请键入该标签的第一个字母。

  5. 按空格键可以显示该标签的属性列表。
  6. 键入 src，然后按下 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    7. “浏览”按钮随即出现在您刚键入的代码下。

  7. 选择“浏览”按钮以定位到该图像文件，或者输入图像文件路径 Assets/images/logo.jpg。
  8. 按下空格键，选择 alt 属性，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  9. 键入 Logo，然后将光标移到在单词 Logo 后出现的引号的右侧。
  10. 按空格键，选择 align 属性，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    11. 即会显示 align 属性的已知值列表。

  11. 从该列表中选择 top，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  12. 键入右尖括号 (>) 以完成该标签。
  13. 在“文档”窗口中，选择“文件”>“保存”。

若要将属性添加到现有标签中，请将插入点置于恰好在该标签的结束尖括号 (>) 之前的地方并按空格键。即会显示属性列表。添加该属性并指定该属性的值（如果它具有值）。


检查您的更改

在对您的代码进行任何更改后，您可以立即获得可视化的反馈。

若要看到您的代码的可视化表示形式，请执行以下两个操作之一：
  • 单击工具栏上的“显示设计视图”按钮或选择“查看”>“设计”。
  • 通过按 F12 键在 Web 浏览器中查看该页。若要关闭浏览器并返回到您的代码，请按 Alt-F4 组合键（仅限 Windows）。


使用“插入”栏添加链接

现在，您将要添加指向您插入的徽标图像的链接，以便在用户单击该链接时打开主页。

用来创建链接的一个方法是，只需将锚标签 (<a>) 放置在代码中图像标签的周围，并且设置该锚标签的属性（可以借助于代码提示或不借助于代码提示）。添加链接的另一个方法是使用“插入”栏。

若要借助“插入”栏编写代码，请执行以下操作：
  1. 如果 location_start.htm 尚未打开，则在“代码”视图中打开它。
  2. 高亮显示您要插入的 logo.jpg 图像的代码。

    3. 备注： 确保您高亮显示整个 <img> 标签。

  3. 在“插入”栏的“常用”选项卡中，单击“超链接”按钮。

    4. 即会显示“超链接”对话框，同时显示已输入的图像标签。
    这是所描述的功能的图片。

  4. 在“链接”文本框中，输入 index.htm 或单击文件夹图标以浏览到该文件。

    5. 备注： 若要链接到一个 Web 页，请输入该页的 URL。

  5. 单击“确定”。

    6. Dreamweaver 在您的页面中插入该代码，以便创建环绕该图像的链接。

  6. 选择“文件”>“保存”。


打印您的代码

您可以打印您的代码以脱机编辑它、将它存档或分发它。

若要打印代码，请执行以下操作：
  1. 在“代码”视图中打开一页。
  2. 选择“文件”>“打印代码”。

    3. 提示： 若要带行数一起打印，则在打印前选择“查看”>“代码视图选项”>“行数”。


其他参考资料

有关 Dreamweaver 中手工编码功能的信息，请参见 Dreamweaver 中的编码。

有关在 Dreamweaver 的可视化设计环境中工作时访问您的代码的信息，请参见 在设计视图中编辑代码。

上一页


了解 Web 应用程序

Web 应用程序是许多 Web 页的集合，这些 Web 页与用户进行交互、相互之间进行交互、并与 Web 服务器上的多种资源（包括数据库）进行交互。在开始建立您自己的 Web 应用程序之前，您应该熟悉本章中讨论的主题。

本章包含以下主题：

  • Web 应用程序是什么？
  • Web 应用程序如何工作
  • 访问数据库
  • 创作动态页
  • 选择服务器技术
  • 常用术语
下一页


Web 应用程序是什么？

Web 应用程序是一个包含多个页的 Web 站点，这些页存储在 Web 服务器上，其部分内容或全部内容是未确定的。只有当用户请求 Web 服务器中的某个页时，才确定该页的最终内容。因为页的最终内容基于用户的操作随请求的不同而变化，所以这种页称为动态页。

建立 Web 应用程序就是为了解决多种问题。本节介绍 Web 应用程序的一般用途并给出一个简单的示例。


Web 应用程序的一般用途

对于用户和开发人员，Web 应用程序都有许多用途，包括以下几方面：

  • 使用户可以快速方便地在一个内容丰富的 Web 站点上查找信息。

    • 这种 Web 应用程序使用户能够搜索、组织和浏览所需的内容。典型的示例包括公司的 Intranet、Microsoft MSDN 和 Amazon.com。

  • 收集、保存和分析用户提供的数据。

    • 过去，在 HTML 表单中输入的数据以电子邮件消息的形式发送给员工或 CGI 应用程序进行处理。而 Web 应用程序可以将表单数据直接保存到数据库，并且可以提取数据并创建基于 Web 的报表以进行分析。典型的示例包括网上银行页、商店结帐页、调查和用户反馈表单。

  • 对内容不断变化的 Web 站点进行更新。

    • Web 应用程序使 Web 设计人员不需要再频繁地更新站点的 HTML。内容提供方（例如新闻编辑）向 Web 应用程序提供内容，Web 应用程序将自动更新站点。典型的示例包括 Economist 和 CNN。


Web 应用程序示例

Clay 是一名专业的 Web 设计人员，同时也是 Dreamweaver 的长期用户，他负责为一个拥有 1000 名员工的中型公司维护 Intranet 和 Internet 站点。一天，人力资源部的 Jill 来询问 Clay 一个问题。人力资源部正在实施一个员工健身计划，该计划对员工完成的每英里步行、骑自行车或跑步进行积分。每个员工都必须通过电子邮件将他/她每月所完成的总英里数报告给 Jill。月末，Jill 将收集所有电子邮件并根据每个员工的总积分奖励他们少量现金。

Jill 的问题是这个健身计划太成功了。参与这个计划的员工太多，以致于每个月末 Jill 都要被这些电子邮件淹没。Jill 询问 Clay 是否有一个基于 Web 的解决方案。

Clay 建议采用一个基于 Intranet 的 Web 应用程序来执行以下任务：

  • 让员工使用简单的 HTML 表单在 Web 页上输入他们的英里数
  • 将员工的英里数存储在数据库中
  • 根据英里数数据计算健身积分
  • 允许员工跟踪他们每月的进展情况
  • 使 Jill 在每个月末只要点击一下就可以访问总积分

Clay 利用 Dreamweaver MX，使这个应用程序在午餐时间前便得以完成并开始运行，Dreamweaver MX 中具有快速方便地建立此类应用程序所需的多种工具。


Web 应用程序如何工作

Web 应用程序是一组常规和动态 Web 页的集合。常规 Web 页是当接到用户请求时不会发生更改的页：Web 服务器将该页发送到请求 Web 浏览器，而不对其进行修改。相反，在将动态 Web 页发送到请求浏览器之前，服务器将对该页进行修改。页发生更改的特性便是称其为动态的原因。

例如，您可以设计一个页来显示健身结果，并让某些信息（例如员工姓名和结果）在接到员工请求时再确定。


处理常规 Web 页

一般的 Web 站点由一组相关的 HTML 页和文件组成，这些页和文件驻留在运行 Web 服务器的计算机上。

Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。当用户单击 Web 页上的某个链接、在浏览器中选择一个书签、或在浏览器的“地址”文本框中输入一个 URL 并单击“转到”时，便生成一个页请求。

常规 Web 页的最终内容由网页设计人员确定，当接到请求时，内容不发生更改。这里有一个示例：

<html>
<head>
<title>Call Department</title>
</head>
<body>
<strong>Call Department</strong><br>
Talk to someone in Sales.
</body>
</html>

该页的每一行 HTML 代码都是在将页放置到服务器之前由设计人员编写的。因为 HTML 在放置到服务器后不发生更改，所以这种页称为静态页。

备注： 严格来说，“静态”页可能不是完全静态的。例如，一个鼠标经过图像或一个 Flash 影片可以使静态页活动起来。但是，本帮助系统所说的静态页是在发送到浏览器时不进行修改的页。

当 Web 服务器接收到对静态页的请求时，服务器将读取该请求，查找该页，然后将其发送到请求浏览器，如下图所示：

此图像显示 Web 服务器是如何为静态页处理请求的。

至于 Web 应用程序，当用户请求页时，代码的某些行尚未确定。必须先由某种机制确定这些行才能将该页发送到浏览器。这种机制将在下一节中进行讨论。


处理动态页

当 Web 服务器接收到对常规 Web 页的请求时，服务器将该页发送到请求浏览器，而不进行进一步的处理。当 Web 服务器接收到对动态页的请求时，它将作出不同的反应：它将该页传递给一个负责完成页面的特殊软件扩展。这个特殊软件叫做应用程序服务器。

应用程序服务器读取页上的代码，根据代码中的指令完成页，然后将代码从页上删除。所得的结果将是一个静态页，应用程序服务器将该页传递回 Web 服务器，然后 Web 服务器将该页发送到请求浏览器。当该页到达时，浏览器得到的全部内容都是纯 HTML。此图是流程的视图：

此图像显示 Web 服务器是如何为动态页处理请求的。


访问数据库

应用程序服务器使您可以使用服务器端的资源，例如数据库。例如，动态页可以指示应用程序服务器从数据库中提取数据并将其插入页的 HTML 中。有关更多信息，请参见数据库初学者指南。

从数据库中提取数据的指令叫做数据库查询。查询是由名为 SQL（结构化查询语言）的数据库语言所表示的搜索条件组成的。SQL 查询被写入页的服务器端脚本或标签中。

应用程序服务器不能直接与数据库进行通信，因为数据库的专用格式所呈现的数据无法解密，这类似于在“记事本”中打开的 Word 文档无法解密。应用程序服务器只能通过数据库驱动程序作为媒介才能进行通信。数据库驱动程序是在应用程序服务器和数据库之间充当翻译程序的软件。

在驱动程序建立通信之后，将对数据库执行查询并创建一个记录集。记录集是从数据库的一个或多个表中提取的数据子集。记录集将返回给应用程序服务器，而数据将应用到动态页中。

这是一个用 SQL 编写的简单的数据库查询：

SELECT lastname, firstname, fitpoints
FROM employees

该语句将创建一个三列的记录集，并用包含数据库中所有员工的姓、名和健身积分的行填充该记录集。有关更多信息，请参见SQL 入门。

这是一个对数据库进行查询并将数据返回给浏览器的过程图解：

此图像显示 Web 服务器在请求动态页时是如何与一个数据库进行交互的。

只要数据库有适当的数据库驱动程序，您几乎可以将任何数据库用于您的 Web 应用程序。

如果您计划建立小型低成本的应用程序，则可以使用基于文件的数据库，例如用 Microsoft Access 创建的数据库。如果您计划建立稳定的、对业务至关重要的应用程序，则可以使用基于服务器的数据库，例如用 Microsoft SQL Server、Oracle 9i 或 MySQL 创建的数据库。

如果您的数据库位于 Web 服务器之外的系统上，则应确保两个系统间有快速连接，以便您的 Web 应用程序可以快速有效地工作。


创作动态页

创作动态页就是先编写 HTML，然后将服务器端脚本或标签添加到 HTML 中，使该页成为动态页。 当您查看结果代码时，将显示语言嵌入在页的 HTML 中。因此，这些语言称为 HTML 嵌入式编程语言。以下示例使用 ColdFusion 标记语言 (CFML)：

<html>
<body>
<b>Call Department</b><br>
<!--- embedded instructions start here --->
<cfset department="Sales">
<"cfoutput">
   Talk to someone in #department#.
<"cfoutput">
<!--- embedded instructions end here --->
</body>
</html>

此页中嵌入的指令执行以下操作：

  1. 创建一个名为“department”的变量并为其分配字符串“Sales”。
  2. 在 HTML 代码中编写变量的字符串值“Sales”。

应用程序服务器将以下页返回给 Web 服务器：

<html>
<body>
<b>Call Department</b><br>
Talk to someone in Sales.
</body>
</html>

Web 服务器将该页发送到请求浏览器，浏览器将其显示如下：

Call Department
Talk to someone in Sales.

所使用的脚本编制语言或基于标记的语言取决于服务器技术。以下是 Dreamweaver MX 所支持的五种服务器技术最常用的语言：

服务器技术 | 语言
ColdFusion | ColdFusion 标记语言 (CFML)
ASP.NET | Visual Basic C#
ASP | VBScript JavaScript
JavaServer Page (JSP) | Java
PHP | PHP

有关更多信息，请参见选择服务器技术。

Dreamweaver 可以编写让页面工作所必需的服务器端脚本或标签，您也可以在 Dreamweaver 编码环境中手工编写这些脚本或标签。


选择服务器技术

您可以使用 Dreamweaver MX 通过这五种服务器技术生成 Web 应用程序：ColdFusion、ASP.NET、ASP、JSP 或 PHP。每种技术都与 Dreamweaver 中的一种文档类型相对应。为您的 Web 应用程序选择一种技术取决于多个因素，其中包括您对各种脚本编写语言的熟悉程度以及所要使用的应用程序服务器。

如果对于 Web 应用程序开发或一般的应用程序开发而言您还是新手，您可能更倾向于使用 ColdFusion，因为它提供了同样与 Dreamweaver 紧密集成的易于学习的服务器脚本撰写环境。如果您熟悉其他服务器技术，例如 JSP、PHP、ASP 或 ASP.NET，Dreamweaver 同时还提供对这些技术的极佳的支持。

您对服务器技术的选择同样取决于您计划用于 Web 应用程序的应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。例如，如果您具有 ColdFusion MX，则可以选择 ColdFusion 作为服务器技术。如果您具有对运行 Microsoft Internet Information Server 5 (IIS)（与 .NET 框架一起运行）的服务器的访问权限，则可以选择 ASP.NET。如果您具有对含有 PHP 应用程序服务器的 Web 服务器的访问权限，则可以选择 PHP；如果您具有对含有 JSP 应用程序服务器（例如 Macromedia JRun）的 Web 服务器的访问权限，则可以选择 JSP。

在 Dreamweaver MX CD（仅限 Windows 版本）和 Macromedia Web 站点上可获得 ColdFusion MX 的开发人员版本。

有关应用程序服务器的更多信息，请参见设置应用程序服务器。

要了解有关 ColdFusion 的更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）或访问 Macromedia Web 站点。

要了解有关 ASP.NET 的更多信息，请访问 Microsoft Web 站点。

要了解有关 ASP 的更多信息，请访问 Microsoft Web 站点。

要了解有关 JSP 的更多信息，请访问 Sun Web 站点。

要了解有关 PHP 的更多信息，请访问 PHP Web 站点。


常用术语

本节列出了常用的术语。

应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。有关更多信息，请参见Web 应用程序如何工作。

常见的应用程序服务器包括 Macromedia ColdFusion、Macromedia JRun Server、Microsoft .NET 框架、IBM WebSphere 和 Apache Tomcat。

数据库是存储在表中的数据的集合。表的每一行组成一个数据记录，每一列组成记录中的一个域，如下所示。

数据库驱动程序是在 Web 应用程序和数据库之间充当翻译程序的软件。数据库中的数据是以专用格式存储的。数据库驱动程序使 Web 应用程序可以读取和操作本来无法解密的数据。

数据库管理系统（DBMS，或数据库系统）是用于创建和操作数据库的软件。常见的数据库系统包括 Microsoft Access、Oracle 9i 和 MySQL。

数据库查询是从数据库中提取记录集的操作。查询是由名为 SQL 的数据库语言所表示的搜索条件组成的。例如，查询可以指定在记录集中只包含某些列或某些记录。

动态页是在发送到浏览器之前由应用程序服务器在运行时自定义的 Web 页。有关更多信息，请参见Web 应用程序如何工作。

记录集是从数据库中一个或多个表中提取的数据子集，如以下示例中所示：

关系型数据库是包含两个或多个表的数据库，这些表共享数据。下面的数据库中有两个表共享 DepartmentID 列，所以是关系型数据库。

服务器技术是应用程序服务器用于在运行时修改动态页的技术。

Dreamweaver MX 开发环境支持以下服务器技术：

  • Macromedia ColdFusion
  • Microsoft ASP.NET
  • Microsoft ASP
  • Sun JavaServer Page (JSP)
  • PHP Hypertext Preprocessor (PHP)

您也可以使用 Dreamweaver 的编码环境为任何未列出的其他服务器技术开发页。

静态页是在发送到浏览器之前未由应用程序服务器在运行时修改的 Web 页。有关更多信息，请参见处理常规 Web 页。

Web 应用程序是一个包含多个页的 Web 站点，这些页存储在 Web 服务器上，其部分内容或全部内容是未确定的。只有当用户请求 Web 服务器中的某页时，才确定该页的最终内容。因为页的最终内容基于用户的操作，随请求的不同而变化，所以这种页称为动态页。

Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。当用户单击在浏览器中打开的 Web 页上的某个链接、在浏览器中选择一个书签，或在浏览器的“地址”文本框中输入一个 URL 并单击“转到”时，便生成一个页请求。

常见的 Web 服务器包括 Microsoft Internet Information Server、Microsoft Personal Web Server、Apache HTTP Server、Netscape Enterprise Server 和 iPlanet Web Server。

上一页


在 Dreamweaver MX 中开发 Web 应用程序

在本章中，您将了解如何使用 Dreamweaver MX 快速着手开发动态的数据库驱动的 Web 应用程序。动态 Web 应用程序开发的强大之处在于能够以 Web 形式提供数据库存储的信息。

在您完成此课程后，您将了解如何将数据库信息合并到您的 Web 站点中。您将使用包含三个数据表（位置、意见和区域）的现有数据库，为 Global Car Rental 站点开发 Web 应用程序。您还将使用 Dreamweaver 创建简单的 SQL 查询以从该数据库提取数据。

在此课程中，您将建立以下动态页：

  • 允许站点访问者向公司发送意见的插入页
  • 列出客户的意见和联系信息的详细信息页
下一页


开始前的准备工作

在《入门》指南的末尾提供了便捷的设置指南，可逐步引导您完成用于创建动态页的 Dreamweaver 工作环境的设置。

对于应用程序服务器，请参见相应的设置指南。

示例 ColdFusion 站点的设置

示例 ASP.NET 站点的设置

示例 ASP 站点的设置

示例 JSP 站点的设置

示例 PHP 站点的设置

完成以下任务：

  • 配置您的系统
  • 配置 Dreamweaver 以用于您选定的应用程序服务器
  • 定义与数据库的连接

本章中的屏幕示例显示“Macromedia ColdFusion”对话框。不过，您可以在 Dreamweaver MX 支持的以下其他所有服务器模型中完成本章中的课程： ColdFusion、PHP、ASP.NET、ASP 和 JSP。


打开要使用的文档

开发数据库应用程序的一个很好的起始点就是创建存储在数据库中的记录的列表。在本章建立的应用程序中，您将列出数据库的客户意见表中的信息。稍后，您将创建一个动态 Web 页，该 Web 页使客户可以将意见和问题直接插入数据库。

在创建这些页面时，让我们从确定您将使用的文档的位置开始。

  1. 执行以下操作之一以打开“站点”面板：
    • 在“文件”面板组中，单击扩展箭头以显示“站点”面板。
    • 选择“窗口”>“站点”。
    • 按 F8 键。

      • “站点”面板随即打开。
      这是所描述的功能的图片。

  2. 在“站点”弹出式菜单中，选择为您的服务器页定义的“Global Car”站点。
  3. 在“站点”面板中，双击 customerComment 文件以打开它。

    4. 该文档即会在文档窗口中打开。

  4. 如果您当前正在“代码”视图中查看文档，则在文档工具栏中单击“显示设计视图”按钮或“显示代码视图和设计视图”按钮，以便您在完成该课程时可以使用所提供的屏幕示例作为检查点。

    5. 您将编辑部分已完成的页面。
    这是所描述的功能的图片。


定义记录集

现在，您将创建一个记录集以选择您要显示的数据。记录集是数据库查询从数据库提取的信息的子集。（在 ASP.NET 中，记录集称为数据集。）数据库查询由搜索条件组成，搜索条件定义在记录集中所包含的内容。然后，您使用提取的信息作为您的动态页的内容的来源。

Dreamweaver MX 提供易于使用的接口以创建简单的 SQL 查询；因此，您不需要了解 SQL，就可以在 Dreamweaver 中创建记录集。

您将创建一个记录集，该记录集选择来自 Global 数据库的 COMMENTS 表中的所有值。

  1. 在 Dreamweaver 中，通过执行以下操作之一打开“记录集”或“数据集”(ASP.NET) 对话框：
    • 在插入栏的“应用程序”选项卡中，单击“记录集”或“数据集”(ASP.NET) 按钮。
      这是所描述的功能的图片。
    • 选择“窗口”>“绑定”以打开“绑定”面板，然后单击加号 (+) 按钮并选择“记录集”或“数据集”(ASP.NET)。
    • 单击“应用程序”面板组的扩展箭头，然后在“绑定”面板中单击加号 (+) 按钮并选择“记录集”或“数据集”(ASP.NET)。

      • 即会出现“记录集”或“数据集”对话框。如果您所看到的对话框看起来比下面的对话框更复杂，则单击“简单”按钮。
      这是所描述的功能的图片。

  2. 在“名称”文本框中，输入 rsComments。
  3. 在“数据源”弹出式菜单 (ColdFusion) 或“连接”弹出式菜单（其他服务器页类型）中，选择“connGlobal”。

    4. “记录集”或“数据集”对话框根据来自数据库的数据更新。
    这是所描述的功能的图片。

  4. 在“表格”弹出式菜单中，确保已选择“COMMENTS”。
  5. 在“列”中，选择“全部”。

    6. 您将接受默认值以请求完整的记录集。

  6. 在“排序”弹出式菜单中，选择“LAST_NAME”，然后在第二个弹出式菜单中选择“升序”。

    7. 检索出的记录按客户姓氏以字母顺序列出数据。
    这是所描述的功能的图片。

  7. 单击“测试”以测试记录集或数据集。
    这是所描述的功能的图片。

    8. 在“测试 SQL 指令”窗口中显示来自与您的记录集或数据集选择条件匹配的数据库的记录。

  8. 单击“确定”关闭“测试 SQL 指令”窗口。
  9. 单击“确定”关闭“记录集”或“数据集”对话框。

    10. 记录集即会出现在“绑定”面板中。

    提示： 如果您没有看到所有记录集域，则单击记录集 (rsComments) 前面的加号 (+) 按钮以展开记录集显示。


显示数据库记录

接下来，您将创建一页，该页列出当前存在于 COMMENTS 表中的记录。您将动态生成该页，而不是手动输入相关信息。

您将从创建一个表来建立数据列表结构开始。

  1. 在 customerComment 文档中，将插入点放置在“Customer Comments”后，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh) 设置将在哪里插入该表。
  2. 通过执行以下操作之一插入一个表：
    • 在“插入”栏中，单击“常用”选项卡，然后单击“表格”按钮或将该按钮拖入文档中。
      这是所描述的功能的图片。
    • 在“插入”栏中，单击“布局”选项卡，然后单击“表格”按钮或将该按钮拖入文档中。
    • 选择“插入”>“表格”。

      • 即会出现“插入表格”对话框。
      这是所描述的功能的图片。

  3. 在该对话框中，设置以下选项：

    4. 在“行数”中，输入 2。

    在“单元格填充”中，输入 2。

    在“列数”中，输入 4。

    在“单元格间距”中，输入 2。

    在“宽度”中，输入 80。

    完成后的对话框应类似于以下对话框：
    这是所描述的功能的图片。

  4. 单击“确定”。

    5. 该表格即会插入到文档中。
    这是所描述的功能的图片。

  5. 在该表格的顶行中，添加用于表格项的标签文字：

    6. 在该表格的第一个单元格中，输入 First Name。

    在下一个单元格中，输入 Last Name。

    在随后的单元格中，输入 E-mail Address。

    在最后的单元格中，输入 Comments。

  6. 保存您的文档（“文件”>“保存”）。


向表格添加动态域

您现在已作好准备，可以向表格添加记录集域了。

  1. 如果“绑定”面板尚未打开，则通过执行以下操作之一打开“绑定”面板。
    • 选择“窗口”>“绑定”。
    • 单击“应用程序”面板组的扩展箭头，然后选择“绑定”面板。
  2. 通过执行以下操作之一将“FIRST_NAME”域添加到该表格中：
    • 将插入点置于“First Name”标签文字下的表格单元格中，然后在“绑定”面板中选择“FIRST_NAME”并单击“插入”。
    • 将“FIRST_NAME”从“绑定”面板中拖入表格单元格中。
  3. 重复第 2 步以将“LAST_NAME”、“EMAIL”和“COMMENTS”添加到该表格中。

    4. 您的页面看起来应类似于下面的页面：
    这是所描述的功能的图片。

  4. 保存您的文档。


设置重复的区域

您创建的表格只包含一行数据。若要看到所有记录，请将该表格行设置为重复的区域。该页将为匹配记录集搜索要求的每一记录重复日期记录。

  1. 在文档窗口中，通过执行以下操作之一选择底部的表格行：
    • 将指针置于第一个单元格中，然后向右拖动以选择该行中的所有单元格。
    • 在其中一个单元格中单击，然后在标签选择器中单击 <tr> 标签。
    • 将指针置于该表格行的左侧，在指针更改为箭头后单击表格行边框以选择该行。
  2. 通过执行以下操作之一设置重复的区域：
    • 在“服务器行为”面板中，单击加号 (+) 按钮，然后选择“重复区域”。
    • 在插入栏的“应用程序”选项卡中，单击“重复区域”按钮。
    • 选择“插入”>“应用程序对象”>“重复区域”。

      • 随即会显示“重复区域”对话框。
      这是所描述的功能的图片。

  3. 在该对话框中，接受默认设置，然后单击“确定”。

    4. 该表格行出现在选项卡式的轮廓中。
    这是所描述的功能的图片。

  4. 保存您的文档。


查看您的页面

接下来，您将保存这些页面，然后您将查看这些页面以了解您开发的应用程序的工作方式。若要查看页面在服务器处理时的外观，您可以使用“实时数据”视图。

  1. 在仍选择 customerComment 的情况下，执行以下操作之一查看您的页面中的数据：
    • 在“文档”工具栏中，单击“实时数据视图”按钮。
      这是所描述的功能的图片。
    • 选择“查看”>“实时数据”。

      • 该页面根据从数据库提取的客户数据的列表更新。
      这是所描述的功能的图片。


创建插入记录表单

您将为该 Global Web 站点创建的下一页是客户意见页。您希望客户输入意见并将它们直接插入到数据库中。您要将该页连接到 Global 数据库的 Comments 表中。

Dreamweaver 包括若干应用程序对象，它们可以帮助您迅速、方便地创建 Web 应用程序页面。您将使用应用程序对象创建插入页。“插入记录”应用程序对象创建 HTML 表单、链接到（或绑定到）数据库的数据域以及创建动态页所必需的服务器脚本。


添加“插入记录表单”应用程序对象

您可以使用“插入记录表单”应用程序对象创建链接到数据库的各域的表单。应用程序对象使您可以选择要包括在该表单中的域、标签文字域以及选择要插入的表单对象的类型。用户在表单域中输入数据并单击“提交”按钮后，新的记录即插入数据库中。您还可以设置在成功提交记录后要打开的页面，以使提交者知道该数据库已更新。

  1. 在“站点”面板中，找到名为“customerInsert”的文件，然后双击该文件以打开它。

    2. 该文档即会在文档窗口中打开。
    这是所描述的功能的图片。

  2. 将插入点置于文档中“possible”一词之后，然后按 Enter 键或 Return 键以设置该应用程序对象将被插入到的位置。
  3. 执行以下操作之一插入记录插入对象：
    • 在插入栏的“应用程序”选项卡中，单击“插入记录表单”按钮。
      这是所描述的功能的图片。
    • 选择“插入”>“应用程序对象”>“插入记录表单”。

      • 即会显示“插入记录表单”对话框。
      这是所描述的功能的图片。

  4. 在“数据源”(ColdFusion) 或“连接”弹出式菜单中，选择“connGlobal”。
  5. 在“表格”弹出式菜单中，确保已选择“COMMENTS”。
  6. 在“插入后，转到”或“如果成功，则转到”(ASP.NET) 文本框中，单击“浏览”。
  7. 在出现的对话框中，选择名为 insertOK 的文件，然后单击“确定”以关闭该对话框。

    8. 您已选择了一页，该页显示给站点访问者以确认收到他们所提交的信息。


创建插入表单

在“插入记录表单”对话框的“表单域”部分中，您定义访问者将数据输入到的表单。

  1. 在“插入记录表单”对话框中，通过执行以下操作删除您不想包括在该表单中的域。

    2. 选择“COMMENT_ID”，然后单击减号 (-) 按钮。

    选择“TELEPHONE”，然后单击减号 (-) 按钮。

    选择“SUBMIT_DATE”，然后单击减号 (-) 按钮。

    选择“ANSWERED”，然后单击减号 (-) 按钮。

  2. 如果您为 ASP.NET 创建一页，则通过执行以下操作更改表单域的字母顺序：

    3. 在“列”列表中，选择“COMMENTS”，然后单击下箭头按钮以将 COMMENTS 置于 LAST_NAME 下。

    在“列”列表中，选择“EMAIL”，然后单击下箭头按钮以将其置于 LAST_NAME 下。

  3. 在“表单域”列表中，选择 FIRST_NAME 以指定该域在表单中显示的方式。
  4. 在“标签文字”域中，输入 First Name。

    5. 这是将显示在文本域旁的 HTML 表单中的标签文字。

  5. 通过执行以下操作之一为域设置表单对象类型：
    • 如果您使用 ASP.NET，则在“显示为”中接受默认值“文本域”，并且在“提交为”弹出式菜单中，将默认值 WChar 更改为 VARCHAR。
    • 如果您使用其他服务器页类型，则在“显示为”中接受默认值“文本域”，并且在“提交为”中接受默认值“文本”。
  6. 在“默认值”域中，键入 Enter your first name 以设置该域中的初始文本，让用户知道要提供哪一类型的信息。

    7. 在您完成设置后，“FIRST_NAME”项应类似于以下情形。
    这是所描述的功能的图片。

  7. 为 LAST_NAME 和 EMAIL 表单域重复第 3 步到第 6 步。

    8. 在“默认值”文本框中，输入您要在该域（当它在表单中显示时）中出现的初始文本。

  8. 选择 COMMENTS 来设置该域的值。
  9. 在“标签文字”域中，输入 Comments。
  10. 通过执行以下操作之一设置“COMMENTS”表单域的值。
    • 如果您正使用 ASP.NET，则在“显示为”弹出式菜单中选择“文本域”，然后在“提交为”弹出式菜单中选择“VARCHAR”。
    • 如果您正使用其他服务器页类型，则在“显示为”弹出式菜单中选择“文本域”，在“提交为”弹出式菜单中接受默认值“文本”。
  11. 在“默认值”文本框中，输入最初将在该表单的这一域中出现的文本，或者将此域保留为空白。

    12. 在您完成设置后，对话框应类似于以下情形：
    这是所描述的功能的图片。

  12. 单击“确定”关闭该对话框。

    13. “插入记录表单”应用程序对象即被插入文档中。
    这是所描述的功能的图片。

  13. 保存您的文档。


将文件拷贝到服务器

下一步，您将保存所做的更改，并将已经更新的文件拷贝到服务器中。在拷贝了这些文件后，您将查看插入记录页，添加意见或问题，并提交数据以测试该应用程序。

  1. 在“站点”面板中，选择 customerInsert，然后单击“上传文件”按钮（蓝色的上箭头）以将本地文件拷贝到您的服务器中。
  2. Dreamweaver 将询问您是否要将关联文件拷贝到服务器，选择“是”。

    3. 备注： 对于某些服务器模型，Dreamweaver 在您的本地文件夹中创建 Connections 文件夹。您还必须将该文件夹拷贝到远程服务器上，以使 Web 应用程序能够正常工作。在“站点”面板中，选择 Connections 文件夹，然后单击“上传文件”按钮以将该文件夹拷贝到您的服务器。

  3. 在选择了 customerInsert 的情况下，选择“文件”>“在浏览器中预览”或按 F12 键 (Windows) 以查看您的文档。
  4. 在表单中输入测试数据，然后在文档中单击“插入记录”按钮以提交您的数据。

    5. 信息在数据库中进行更新，并且显示 insertOK 页。


查看更新

现在，我们将查看您对数据库进行的更改。您可以通过打开在本课程的第一部分中创建的 customerComment 文档来查看更改，或者可以通过查看数据库来查看更改。

  • 在 Dreamweaver 中，在“站点”面板中双击名为 customerComment 的文档，选择“文件”>“在浏览器中预览”，然后选择要在其中查看页面的浏览器。

    • 您输入的记录出现在“客户意见”列表中。

  • 在 Dreamweaver 中，在“数据库”面板（“窗口”>“数据库”）内找到 connGlobal 数据库图标，单击“表格”前面的加号 (+) 按钮以查看数据库中表格的列表。右击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) COMMENTS 表，然后选择“查看数据”。

    • 数据库中记录的列表随即出现；您刚输入的意见作为表格中最后的项出现。


其他参考资料

《入门》指南简单讲述了一小部分工具，可用来创建动态的、数据驱动的页。您已了解如何创建记录集来定义要在您的 Web 站点中使用的数据。您还使用 Dreamweaver 应用程序对象创建了有效的 Web 应用程序，您可以通过该应用程序与数据库存储的数据交互。

有关在 Dreamweaver 中建立 Web 站点的信息，请参见在 Dreamweaver 中创建您的第一个 Web 站点。有关使用 Dreamweaver 编码功能的信息，请参见在 Dreamweaver 中编辑代码。

有关《Dreamweaver MX 入门》指南中此部分涉及的主题的详细信息，请参见联机指南《使用 Dreamweaver MX》（“帮助”>“使用 Dreamweaver MX”）中的以下主题：

  • 为您的页面存储和检索数据
  • 定义动态数据的来源
  • 向 Web 页添加动态内容
  • 创建记录集导航链接
  • 迅速建立插入页
  • 逐块建立插入页
上一页


在 Windows 中安装 Web 服务器

要开发和测试动态 Web 页，您需要一个正常工作的 Web 服务器。本章介绍大多数 Windows 用户如何在本地计算机上安装和使用 Microsoft Web 服务器。

Macintosh 用户可以使用网络计算机公司或 Web 宿主公司的 Web 服务器。Macintosh OS X 10.1 用户可以在其本地计算机上使用 Apache Web 服务器。有关 Apache 服务器的更多信息，请访问 Apache Web 站点。但是请注意，Apache 服务器的根文件夹与本指南中讨论的 Microsoft 服务器的根文件夹 (Inetpub\wwwroot) 不同。

本章包含以下几节：

  • 入门
  • 安装 Personal Web Server
  • 安装 Internet Information Server
  • 测试 Web 服务器
  • Web 服务器基础

备注： Macromedia 不为第三方软件（例如 Microsoft Personal Web Server）提供技术支持。如果您需要帮助，请与 Microsoft 技术支持联系。

下一页


入门

如果您是一个 Windows 用户，您可以在计算机上安装并运行以下 Web 服务器：Microsoft Personal Web Server (PWS) 或 Internet Information Server (IIS)（PWS 的全功能版本）。您还可以在联网的 Windows 计算机上安装 Web 服务器以供工作组中的其他开发人员使用。

备注： Windows Millennium Edition (Me) 不支持任何版本的 PWS 或 IIS。有关更多信息，请参见 Microsoft Web 站点。

您的计算机上可能已经安装了 PWS 或 IIS。请查看文件夹结构中是否包含一个 C:\Inetpub 或 D:\Inetpub 文件夹。PWS 和 IIS 在安装过程中将创建该文件夹。

如果该文件夹不存在，则执行以下操作之一：

  • Windows 98：将 PWS 安装文件从 Windows 98 光盘复制到您的硬盘上。该文件位于“Add-Ons”文件夹下的“PWS”文件夹中。然后安装该 Web 服务器。有关说明，请参见安装 Personal Web Server。
  • Windows NT Workstation：从 Microsoft Web 站点 下载 NT 4.0 Option Pack。Option Pack 包括 PWS 安装文件。然后安装该 Web 服务器。有关说明，请参见安装 Personal Web Server。

    • 备注： 要安装 NT 4.0 Option Pack，您的计算机上必须安装有 Service Pack 6 或更高版本。从 Microsoft Web 站点 下载 Service Pack。

  • Windows NT Server：您的系统上应该已经安装并运行了 IIS。如果还没有，请进行安装或让系统管理员为您安装。
  • Windows 2000：您的系统上可能已安装了 IIS。如果还没有，则应进行安装。有关更多信息，请参见安装 Internet Information Server。
  • Windows XP Professional：您的系统上可能已安装了 IIS。如果还没有，则应进行安装。有关更多信息，请参见安装 Internet Information Server。

相关主题

Web 服务器基础


安装 Personal Web Server

Windows 98 和 NT Workstation 用户应该安装 PWS。如果您是 Windows NT Server、Windows 2000 或 Windows XP Professional 用户，则请安装 IIS。有关更多信息，请参见安装 Internet Information Server。

备注： Windows Millennium Edition (Me) 不支持任何版本的 PWS。有关更多信息，请参见 Microsoft Web 站点。

您可以将 PWS 和 Dreamweaver MX 安装在同一个 Windows 系统上。确保系统上安装了 Microsoft Internet Explorer 4.01 或更高版本，否则将不能安装 PWS。

要安装 PWS，请执行以下操作：
  1. 双击 Windows 98 光盘上的 PWS 安装文件或您从 Microsoft Web 站点下载的文件。
  2. 按照安装向导进行操作。
  3. 当询问您的默认 Web 发布主目录时，请接受默认目录：

    4. C:\Inetpub\wwwroot

  4. 单击“完成”结束安装过程。

安装了 Web 服务器后，您可以对其进行测试。请参见测试 Web 服务器。

相关主题

Web 服务器基础


安装 Internet Information Server

Windows NT Server、Windows 2000 和 Windows XP Professional 用户应该安装 IIS。如果您是 Windows 98 或 NT Workstation 用户，则请安装 PWS。有关更多信息，请参见安装 Personal Web Server。

如果您是 Windows NT Server 用户，您的系统上应该已经安装并运行了 IIS。如果还没有，请进行安装或让系统管理员为您安装。

如果您是 Windows 2000 或 Windows XP Professional 用户，请确保您的系统上安装并运行了 IIS。方法是查找 C:\Inetpub 文件夹。如果该文件夹不存在，则您的系统上可能没有安装 IIS。

要在 Windows 2000 和 XP Professional 上安装 IIS，请执行以下操作：
  1. 在 Windows 2000 中，选择“开始”>“设置”>“控制面板”>“添加/删除程序”；在 Windows XP 中，选择“开始”>“控制面板”>“添加/删除程序”。
  2. 选择“添加/删除 Windows 组件”。
  3. 选择 IIS 框并按照安装说明进行操作。

安装了 Web 服务器后，您可以对其进行测试。请参见测试 Web 服务器。

相关主题

Web 服务器基础


测试 Web 服务器

要测试 Web 服务器，请先创建一个简单的文件扩展名为 .htm 或 .html 的 HTML 页，并将其保存到计算机的 Inetpub\wwwroot 文件夹中。该 HTML 页可以由一行组成，例如：

<p>My web server is working.</p>

将该页另存为 myTestFile.htm。然后，通过一个 HTTP 请求在 Web 浏览器中打开该测试页。如果 PWS 或 IIS 正在您的本地计算机上运行，则在 Web 浏览器中输入以下 URL：

http://localhost/myTestFile.htm

如果 PWS 或 IIS 运行在联网的计算机上，则将联网计算机名用作域名。例如，如果运行 PWS 或 IIS 的计算机的名称是“kojak-pc”，则在浏览器中输入以下 URL：

http://kojak-pc/myTestFile.htm

备注： 有关计算机名的更多信息，请参见Web 服务器基础。

如果浏览器显示您的页，则说明 Web 服务器运行正常。

如果浏览器未能显示该页，请检查服务器是否正在运行。双击任务栏中的 Web 服务器图标（该图标的外观像握着 Web 页的手）。将出现“个人 Web 管理器”对话框。如果“发布”面板提示您 Web 发布已停止，请单击“启动”按钮。

如果仍无法打开该页，请检查您的测试页是否位于 Inetpub\wwwroot 文件夹中并且文件扩展名为 .htm 或 .html。


Web 服务器基础

Web 服务是响应来自 Web 浏览器的请求以提供 Web 页的软件。Web 服务器有时也叫做 HTTP 服务器。

假设您要使用 PWS 来开发 Web 应用程序。如果启动了服务器，那么桌面右下角的任务栏上将出现一个图标，提示您 PWS 正在运行。（该图标显示为握着 Web 页的手。）双击该图标将启动个人 Web 管理器，您可以使用它来管理您的 Web 页。个人 Web 管理器显示如下：

Web 服务器的默认名称是您的计算机名（在本例中为“cnadeau_pc1”）。您可以通过更改计算机名来更改服务器名称。如果您的计算机没有名称，则服务器使用“localhost”。

服务器名称代表服务器的根文件夹（或者是服务器根文件夹的别名），该根文件夹很可能是 C:\Inetpub\wwwroot。通过在计算机上运行的浏览器中输入以下 URL 可以打开存储在根文件夹中的任何 Web 页：

http://myServerName/myFileName

例如，如果服务器名称是“mer_noire”并且 C:\Inetpub\wwwroot\ 中存有名为“soleil.htm”的 Web 页，则您可以通过在本地计算机上运行的浏览器中输入以下 URL 打开该页：

http://mer_noire/soleil.htm

您还可以通过在 URL 中指定子文件夹来打开存储在根文件夹的任何子文件夹中的任何 Web 页。例如，假设 soleil.htm 文件存储在名为“gamelan”的子文件夹中，如下所示：

C:\Inetpub\wwwroot\gamelan\soleil.htm

您可以通过在计算机上运行的浏览器中输入以下 URL 打开该页：

http://mer_noire/gamelan/soleil.htm

如果 Web 服务器运行在您的计算机上，您可以用“localhost”来代替服务器名称。例如，以下两个 URL 在浏览器中打开同一页：

http://mer_noire/gamelan/soleil.htm

http://localhost/gamelan/soleil.htm

备注： 除服务器名称或“localhost”之外，还可以使用另一种表示方式：127.0.0.1（例如 http://127.0.0.1/gamelan/soleil.htm）。

相关主题

安装 Personal Web Server

安装 Internet Information Server

测试 Web 服务器

上一页


示例 ColdFusion 站点的设置

Macromedia Dreamweaver MX 随附有示例 ColdFusion 页，可以帮助您建立一个小的 Web 应用程序。本章讲述了一种在同时使用 ColdFusion 和 Microsoft Internet Information Server (IIS) 或 Personal Web Server (PWS) 时设置示例应用程序的方法。有关这些 Web 服务器的更多信息，请参见在 Windows 中安装 Web 服务器。如果将 ColdFusion MX 和其他 Web 服务器一起使用，请参见设置 Web 应用程序。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含以下几节：

  • ColdFusion 开发人员的设置清单
  • 配置您的系统
  • 定义 Dreamweaver 站点
  • 连接到示例数据库
下一页


ColdFusion 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些过程进行介绍。

配置您的系统：
  1. 确保您具有 Web 服务器。
  2. 安装 ColdFusion 应用程序服务器。
  3. 创建根文件夹。
定义 Dreamweaver 站点：
  1. 将示例文件拷贝到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。
连接到数据库：
  1. 如果您具有远程服务器配置，则将示例数据库拷贝到远程计算机。
  2. 在“ColdFusion 管理员”中创建 ColdFusion 数据源。
  3. 在 Dreamweaver 中查看连接。


配置您的系统

本节提供两种常见系统配置的说明 - 其中一种情况是 Microsoft IIS 或 PWS 安装在您的硬盘上，另一种情况是 IIS 或 PWS 安装在远程 Windows 计算机上。如果您不想使用这些配置，请参见设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

Windows 用户的本地配置，以及 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：
  1. 确保您具有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 安装 ColdFusion 应用程序服务器（请参见安装 ColdFusion MX）。
  3. 创建根文件夹（请参见创建根文件夹）。

备注： 安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 或 PWS 安装并运行在您的硬盘或远程 Windows 计算机上。（Macintosh 用户需要将 Microsoft IIS 或 PWS 安装在远程 Windows 计算机上。）通过查看文件夹的结构，可以快速检查系统上是否安装有 PWS 或 IIS。文件夹结构中是否包含 c:\Inetpub 或 d:\Inetpub 文件夹？PWS 和 IIS 在安装过程中会创建该文件夹。

如果系统上未安装 PWS 或 IIS，则现在进行安装。有关说明，请参见在 Windows 中安装 Web 服务器。

在安装了 Web 服务器之后，请安装应用程序服务器。请参见安装 ColdFusion MX。


安装 ColdFusion MX

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。

确保 ColdFusion MX 应用程序服务器安装并运行在运行 PWS 或 IIS 的系统上。（PWS 或 IIS 可能位于您的硬盘或远程 Windows 计算机上。）

您可以从 Macromedia Web 站点下载并安装 ColdFusion MX 的完全功能的开发人员版本。在 Dreamweaver CD 上也提供 ColdFusion MX Server Developer Edition 的拷贝（仅限 Windows 版本）。

若要安装 ColdFusion MX，请执行以下操作：
  1. 关闭所有打开的应用程序。
  2. 如果可行，使用管理员帐户登录到 Windows 系统。
  3. 双击 ColdFusion MX 安装程序文件。
  4. 按照安装说明进行操作。

有关更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

在安装并启动 ColdFusion 之后，为您的 Web 应用程序创建根文件夹。请参见创建根文件夹。


创建根文件夹

安装了服务器软件之后，在运行 Microsoft PWS 或 IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：
  1. 在运行 PWS 或 IIS 的系统上创建一个名为“MySampleApp”的文件夹。

    2. 创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 PWS 或 IIS Web 服务器安装在 Inetpub\wwwroot 文件夹中。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

  2. 确保为该文件夹启用了读权限和脚本权限。

    3. 如果您正在使用 PWS，则双击任务栏中的 Web 服务器图标启动 Personal Web Manager。（该图标显示为握着 Web 页的手。）在 Personal Web Manager 中，单击“高级”图标。随即会出现“高级选项”对话框。选择“主页”并单击“编辑属性”。即会出现“编辑目录”对话框。 确保选择了“读”和“脚本”选项。出于安全原因，您不应该选择“执行”选项。

如果您正在使用 IIS，则启动 IIS 管理工具（在 Windows XP 中，选择“启动”>“控制面板”>“性能维护”>“管理工具”>“Internet 信息服务”）。在“Web 站点”>“默认 Web 站点”下，右键单击您的 MySampleSite 文件夹并从弹出式菜单中选择“属性”。在“执行权限”文本框中，确保选择了“脚本”选项。出于安全原因，请不要选择“脚本和可执行文件”选项。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。请参见定义 Dreamweaver 站点。


定义 Dreamweaver 站点

在配置完系统后，您必须将示例文件拷贝到本地文件夹并定义 Dreamweaver 站点来管理这些文件。

备注： Macromedia HomeSite 和 ColdFusion Studio 用户可以将 Dreamweaver 站点视为 HomeSite 或 Studio 项目。

若要定义 Dreamweaver 站点，请执行以下操作：
  1. 将示例文件拷贝到您硬盘上的文件夹中（请参见拷贝示例文件）。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器上的根文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


拷贝示例文件

如果尚未进行此操作，则将示例文件从 Dreamweaver 应用程序文件夹拷贝到您硬盘上的文件夹中。

若要拷贝示例文件，请执行以下操作：
  1. 在您的硬盘上创建一个名为“Sites”的新文件夹。

    2. 例如，创建 C:\Sites (Windows) 或 Hard Drive:Documents:Sites (Macintosh)。

  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 GettingStarted 文件夹。

    3. 该文件夹的路径如下所示：

    \Macromedia\Dreamweaver MX\Samples\GettingStarted\

  3. 将 GettingStarted 文件夹拷贝到 Sites 文件夹中。

拷贝 GettingStarted 文件夹之后，将该文件夹定义为 Dreamweaver 本地文件夹。请参见定义本地文件夹。


定义本地文件夹

拷贝 GettingStarted 文件夹之后，将包含 ColdFusion 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：
  1. 在 Dreamweaver 中，选择“站点”>“新建站点”。

    2. 即会出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”。
  3. 在“站点名称”文本框中，输入 GlobalCar - ColdFusion。

    4. 该名称在 Dreamweaver 中标识您的站点。

  4. 在“本地根文件夹”文本框中，指定 GettingStarted 文件夹中包含 ColdFusion 示例文件的文件夹。

    5. 您可以单击文本框旁边的文件夹图标查找并选择文件夹。在 Windows 中，该文件夹应该如下所示：

    C:\Sites\GettingStarted\Develop\coldfusion

    在 Macintosh 上，该文件夹应该如下所示：

    Hard Drive:Documents:Sites:GettingStarted:Develop:coldfusion

将“站点定义”对话框保持为打开状态。接下来您需要将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。请参见定义远程文件夹。


定义远程文件夹

在定义了本地文件夹之后，将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“分类”列表中的“远程信息”。

    2. 即会出现“远程信息”屏幕。

  2. 在“访问”文本框中，选择将文件移入和移出服务器的方式 - 直接移入移出（“本地/网络”选项）还是“FTP”。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    4. 该文件夹可能位于您的硬盘或远程计算机上。即使您在硬盘上创建文件夹，该文件夹仍然是有效的“远程”文件夹。这里是当您选择“本地/网络”访问时的示例：

    远程文件夹：c:\Inetpub\wwwroot\MySampleApp

    有关 FTP 的更多信息，请参见设置 FTP 访问的“远程信息”选项。

将“站点定义”对话框保持为打开状态。接下来您需要定义处理动态页的文件夹。请参见指定处理动态页的位置。


指定处理动态页的位置

在定义了 Dreamweaver 远程文件夹之后，请按照本节中介绍的步骤指定处理动态页的文件夹。Dreamweaver 使用此文件夹显示动态页并在您工作时连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“分类”列表中的“测试服务器”。

    2. 即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要它能够处理 ColdFusion 页，选择哪个选项无关紧要。在本例中，您可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 ColdFusion 页的服务器。

  2. 选择 ColdFusion 作为您的服务器技术。
  3. 在“访问”文本框中，选择您指定的访问远程文件夹的方法（“本地/网络”或“FTP”）。

    4. Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    5. 若要在您工作时在页中显示活动数据，Dreamweaver 将创建临时文件，将其拷贝到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。例如，如果在“远程文件夹”文本框中指定的文件夹是 c:\Inetpub\wwwroot\MySampleApp，则 URL 前缀应该如下所示：

    http://localhost/MySampleApp/

    提示： URL 前缀不应该指定站点上特定的页。

    然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见关于 URL 前缀。

  5. 单击“确定”，然后单击“完成”。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。请参见上传示例文件。


上传示例文件

在指定了处理动态页的文件夹之后，请按照本节中介绍的步骤将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须“上传”这些文件。

如果不上传文件，则某些功能（例如“实时数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“实时数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细信息页，则在浏览器中预览主页时单击指向详细信息页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：
  1. 在“站点”面板（“窗口”>“站点”）中，选择“本地文件”窗格中的根文件夹。

    2. 根文件夹应该是列表中的第一个文件夹。

  2. 单击工具栏上蓝色的向上箭头。

    3. Dreamweaver 将所有文件拷贝到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。请参见连接到示例数据库 。


连接到示例数据库

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍如何创建到示例数据库的连接。

备注： 如果您要连接到另一个数据库，请参见ColdFusion 开发人员的数据库连接。

若要创建数据库连接，请执行以下操作：
  1. 如果您具有远程服务器配置，则将示例数据库拷贝到远程计算机（请参见设置数据库（远程服务器配置））。
  2. 在“ColdFusion 管理员”中创建 ColdFusion 数据源（请参见创建 ColdFusion 数据源）。
  3. 在 Dreamweaver 中查看连接（请参见连接到数据库）。


设置数据库（远程服务器配置）

本节只适用于您具有远程服务器配置的情况，即您的 Web 服务器运行在远程计算机上的情况。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，则跳到创建 ColdFusion 数据源。

在尝试连接到示例数据库之前，请将数据库拷贝到远程计算机的硬盘。数据库文件 (global.mdb) 位于您本地硬盘上的以下文件夹中：

\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。

数据库准备就绪之后，在“ColdFusion 管理员”中创建 ColdFusion 数据源。请参见创建 ColdFusion 数据源。


创建 ColdFusion 数据源

在“ColdFusion 管理员”中创建一个名为“connGlobal”的 ColdFusion 数据源，该数据源指向示例数据库文件。

若要创建 ColdFusion 数据源，请执行以下操作：
  1. 在 Dreamweaver 中，打开一个 ColdFusion 页。
  2. 在“数据库”面板（“窗口”>“数据库”）中，单击“修改数据源”图标（面板工具栏上从右向左的第二个图标）。

    3. “ColdFusion 管理员”在浏览器中打开。

  3. 登录到“ColdFusion 管理员”并创建一个名为“connGlobal”的数据源，该数据源指向 global.mdb 数据库文件。

    4. 如果 ColdFusion 运行在您的本地计算机上，则创建一个数据源指向以下文件夹中的数据库文件：

    c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

    如果 ColdFusion 运行在远程计算机上，则创建一个数据源，该数据源指向您在设置数据库（远程服务器配置）中上传到远程计算机上的数据库文件。

    有关更多信息，请参见 Dreamweaver 中的 ColdFusion 文档（“帮助”>“使用 ColdFusion”）。

创建了 ColdFusion 数据源之后，就可以连接到 Dreamweaver 中的数据库了。请参见连接到数据库。


连接到数据库

创建了 ColdFusion 数据源（请参见创建 ColdFusion 数据源）之后，您可以使用它连接到 Dreamweaver 中的数据库。

在 Dreamweaver 中打开任意 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。您的 ColdFusion 数据源会出现在该面板中。

如果您创建的数据源未出现在该面板中，请执行以下操作之一：

  • 复查“ColdFusion 管理员”中的连接参数。
  • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
  • 查询数据库连接答疑。

如果名为“connGlobal”的数据源出现在该面板中，则为入门指南和教程设置示例 ColdFusion 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和 Dreamweaver“帮助”中的教程（“帮助”>“教程”）。

上一页


示例 ASP.NET 站点的设置

Macromedia Dreamweaver MX 随附有示例 ASP.NET 页，可以帮助您建立一个小的 Web 应用程序。本章讲述了一种设置示例应用程序的方法。

本章适用于 ASP.NET 开发人员。如果您要研究 ASP，请参见示例 ASP 站点的设置。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含以下几节：

  • ASP.NET 开发人员的设置清单
  • 配置您的系统
  • 定义 Dreamweaver 站点
  • 连接到示例数据库（本地配置）
  • 连接到示例数据库（远程服务器配置）
下一页


ASP.NET 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些过程进行介绍。

配置您的系统：
  1. 确保您具有 Web 服务器。
  2. 安装 Microsoft .NET 框架。
  3. 创建根文件夹。
定义 Dreamweaver 站点：
  1. 将示例文件拷贝到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。
连接到数据库（本地配置）：

在 Dreamweaver 中创建连接。

连接到数据库（远程服务器配置）：

将数据库拷贝到远程计算机并在 Dreamweaver 中创建连接。


配置您的系统

本节提供两种常见系统配置的说明 - 其中一种情况是 Windows 2000 或 Windows XP Professional 安装在您的硬盘上，另一种情况是 Windows 2000 或 Windows XP Professional 安装在远程计算机上。如果您不想使用这些配置，请参见设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

若要配置您的系统，请执行以下操作：
  1. 确保您具有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 安装 .NET 框架（请参见安装 .NET 框架）。
  3. 创建根文件夹（请参见创建根文件夹）。

备注： 安装 Web 服务器和 .NET 框架是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

ASP.NET 页仅使用一个 Web 服务器：Microsoft IIS 5 或更高版本。不支持 PWS。此外，因为 IIS 5 是 Windows 2000 和 Windows XP Professional 操作系统提供的服务，所以您只能使用这两个版本的 Windows 来运行 ASP.NET 应用程序。不支持 Windows 98、ME 或 NT。

确保 IIS 5 安装并运行在 Windows 2000 或 Windows XP Professional 计算机上。IIS 5 可以安装在您的硬盘（如果具有 Windows 2000 或 Windows XP Professional）或远程计算机上。如果您是 Windows 98、Windows ME、Windows NT、Windows XP Home Edition 或 Macintosh 用户，则必须在远程 Windows 2000 或 Windows XP Professional 计算机上运行 IIS 5。

一种快速检查您的系统上是否安装有 IIS 的方法是查看文件夹结构。文件夹结构中是否包含 c:\Inetpub 或 d:\Inetpub 文件夹？IIS 在安装过程中将创建该文件夹。

如果未安装 IIS，则现在进行安装。有关说明，请参见安装 Internet Information Server。

安装了 Web 服务器之后，安装 .NET 框架。请参见安装 .NET 框架。


安装 .NET 框架

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。

在 ASP.NET 中，应用程序服务器称为 .NET 框架。确保 .NET 框架安装并运行在运行 IIS 5 或更高版本的 Windows 2000 或 Windows XP Professional 系统上。（IIS 可能位于您的硬盘或远程计算机上。）

若要安装 .NET 框架，请从 Microsoft Web 站点下载框架并按照 Web 站点上的安装说明进行安装。如果您是 Windows 98、Windows ME、Windows NT、Windows XP Home Edition 或 Macintosh 用户，则必须将 .NET 框架安装在运行 IIS 5 的远程 Windows 2000 或 Windows XP Professional 计算机上。

在安装 .NET 框架后，为您的 Web 应用程序创建根文件夹。请参见创建根文件夹。


创建根文件夹

安装了服务器软件之后，在运行 Microsoft IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：
  1. 在运行 IIS 的系统上创建一个名为“MySampleApp”的文件夹。

    2. 创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 IIS Web 服务器安装在 Inetpub\wwwroot 文件夹中。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中的任何页或其子文件夹中的任何页。

  2. 确保为该文件夹启用了脚本权限。

    3. 启动 IIS 管理工具（在 Windows XP 中，选择“启动”>“控制面板”>“性能维护”>“管理工具”>“Internet 信息服务”）。在“Web 站点”>“默认 Web 站点”下，右键单击您的 MySampleSite 文件夹并从弹出式菜单中选择“属性”。在“执行权限”文本框中，确保选择了“脚本”选项。出于安全原因，请不要选择“脚本和可执行文件”选项。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。请参见定义 Dreamweaver 站点。


定义 Dreamweaver 站点

在配置完系统后，您必须将示例文件拷贝到本地文件夹并定义 Dreamweaver 站点来管理这些文件。

备注： Macromedia HomeSite 和 ColdFusion Studio 用户可以将 Dreamweaver 站点视为 HomeSite 或 Studio 项目。

若要定义 Dreamweaver 站点，请执行以下操作：
  1. 将示例文件拷贝到您硬盘上的文件夹中（请参见拷贝示例文件）。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  4. 指定一个处理动态页的文件夹（请参见指定处理动态页的位置）。
  5. 将示例文件上传到 Web 服务器（请参见上传示例文件）。


定义本地文件夹

拷贝 GettingStarted 文件夹之后，将包含 ASP.NET 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：
  1. 在 Dreamweaver 中，选择“站点”>“新建站点”。

    2. 即会出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”。
  3. 在“站点名称”文本框中，输入 GlobalCar - ASP.NET。

    4. 该名称在 Dreamweaver 中标识您的站点。

  4. 在“本地根文件夹”文本框中，指定 GettingStarted 文件夹中包含 ASP.NET 示例文件的文件夹。

    5. 您可以单击文本框旁边的文件夹图标查找并选择文件夹。在 Windows 中，该文件夹应该如下所示：

    C:\Sites\GettingStarted\Develop\aspnet

    在 Macintosh 上，该文件夹应该如下所示：

    Hard Drive:Documents:Sites:GettingStarted:Develop:aspnet

将“站点定义”对话框保持为打开状态。接下来您需要将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。请参见定义远程文件夹。


定义远程文件夹

在定义了本地文件夹之后，请按照本节中介绍的步骤将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“远程信息”。

    2. 即会出现“远程信息”屏幕。

  2. 在“访问”文本框中，选择将文件移入和移出服务器的方式 - 直接移入移出（“本地/网络”选项）还是“FTP”。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    4. 该文件夹可能位于您的硬盘或远程计算机上。即使您在硬盘上创建文件夹，该文件夹仍然是有效的“远程”文件夹。这里是当您选择“本地/网络”访问时的示例：

    远程文件夹：c:\Inetpub\wwwroot\MySampleApp

    有关 FTP 的更多信息，请参见设置 FTP 访问的“远程信息”选项。

将“站点定义”对话框保持为打开状态。接下来您需要定义处理动态页的文件夹。请参见指定处理动态页的位置。


指定处理动态页的位置

在定义了 Dreamweaver 远程文件夹之后，请按照本节中介绍的步骤指定处理动态页的文件夹。Dreamweaver 使用此文件夹显示动态页并在您工作时连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    2. 即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要它可以处理 ASP.NET 页，选择哪个选项都没有关系。在本例中，您可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 ASP.NET 页的服务器。

  2. 选择 ASP.NET VB 或 ASP.NET C# 作为您的服务器技术。
  3. 在“访问”文本框中，选择您指定的访问远程文件夹的方法（“本地/网络”或“FTP”）。

    4. Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    5. 若要在您工作时生成并显示动态内容，Dreamweaver 将创建临时文件，将其拷贝到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。例如，如果在“远程文件夹”文本框中指定的文件夹是 c:\Inetpub\wwwroot\MySampleApp，则 URL 前缀应该如下所示：

    http://localhost/MySampleApp/

    提示： URL 前缀不应该指定站点上特定的页。

    然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见关于 URL 前缀。

  5. 单击“确定”，然后单击“完成”。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。请参见上传示例文件。


上传示例文件

在指定了处理动态页的文件夹之后，请按照本节中介绍的步骤将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须“上传”这些文件。

如果不上传文件，则某些功能（例如“实时数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“实时数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细信息页，则在浏览器中预览主页时单击指向详细信息页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：
  1. 在“站点”面板（“窗口”>“站点”）中，选择“本地文件”窗格中的根文件夹。

    2. 根文件夹应该是列表中的第一个文件夹。

  2. 单击工具栏上蓝色的向上箭头。

    3. Dreamweaver 将所有文件拷贝到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。如果您的 Web 服务器运行在本地计算机上，请参见连接到示例数据库（本地配置）。如果您的 Web 服务器运行在远程计算机上，请参见连接到示例数据库（远程服务器配置）。


连接到示例数据库（本地配置）

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍在您具有本地配置的情况下（即您的 Web 服务器与 Dreamweaver 在同一台计算机上运行）如何创建到示例数据库的连接。如果您的 Web 服务器运行在远程计算机上，请参见连接到示例数据库（远程服务器配置）。

备注： 如果您要连接到另一个数据库，请参见ASP.NET 开发人员的数据库连接。

若要创建具有本地配置的连接，请执行以下操作：
  1. 在 Dreamweaver 中打开任何一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“OLE DB 连接”。

    3. 随即出现“OLE DB 连接”对话框。

  3. 输入 connGlobal 作为连接名称。
  4. 单击“模板”按钮。

    5. 随即会出现“连接字符串模板”对话框。

  5. 从模板列表中选择“Microsoft Access 2000（Microsoft Jet 4.0 提供程序）”，然后单击“确定”。

    6. Dreamweaver 随即在“OLE DB 连接”对话框中添加一个连接字符串模板。该模板包含连接字符串中所缺少信息的占位符。

  6. 对于“数据源”值，输入到硬盘上示例数据库文件的完整路径。

    7. 例如，在安装过程中 Dreamweaver 将示例数据库文件 global.mdb 放置在本地硬盘的以下文件夹中：

    c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

    备注： 根据安装 Dreamweaver 位置的不同，该路径也有所不同。

    输入此路径作为“数据源”的值：

    Data Source=c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\global.mdb;
  7. 删除“用户 ID”和“密码”行。

    8. Access 数据库不需要用户 ID 和密码。

  8. 单击“测试”。

    9. Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查到数据库的路径。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查询数据库连接答疑。
  9. 单击“确定”。

    10. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 ASP.NET 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和 Dreamweaver“帮助”中的教程（“帮助”>“教程”）。


连接到示例数据库（远程服务器配置）

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍在您具有远程服务器配置的情况下（即您的 Web 服务器运行在远程计算机上）如何创建到示例数据库的连接。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，请参见连接到示例数据库（本地配置）。

备注： 如果您要连接到另一个数据库，请参见ASP.NET 开发人员的数据库连接。

若要创建具有远程服务器配置的连接，请执行以下操作：
  1. 将示例数据库文件拷贝到远程计算机。

    2. 数据库文件 (global.mdb) 位于您本地硬盘上的以下文件夹中：

    \Macromedia\Dreamweaver MX\Samples\Database\global.mdb

    您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。不管是哪种情况，都在一张纸上记下到数据库文件的完整路径。

  2. 在 Dreamweaver 中打开任何一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  3. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“OLE DB 连接”。

    4. 随即出现“OLE DB 连接”对话框。

  4. 输入 connGlobal 作为连接名称。
  5. 单击“模板”按钮。

    6. 随即出现“连接字符串模板”对话框。

  6. 从模板列表中选择“Microsoft Access 2000（Microsoft Jet 4.0 提供程序）”，然后单击“确定”。

    7. Dreamweaver 随即在“OLE DB 连接”对话框中添加一个连接字符串模板。该模板包含连接字符串中所缺少信息的占位符。

  7. 对于“数据源”值，输入到远程计算机上示例数据库文件的完整路径。

    8. 输入您在步骤 1 中记下的路径。例如，网络计算机上的路径可能如下所示：

    Data Source=c:\users\Denman\Sites\data\global.mdb;

  8. 删除“用户 ID”和“密码”行。
  9. 单击“测试”。

    10. Dreamweaver 尝试连接到网络计算机上的数据库。如果连接失败，请执行以下操作：

    • 复查到数据库的路径。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查询数据库连接答疑。
  10. 单击“确定”。

    11. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 ASP.NET 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和 Dreamweaver“帮助”中的教程（“帮助”>“教程”）。

上一页


示例 ASP 站点的设置

Macromedia Dreamweaver MX 随附有示例 Microsoft Active Server Page (ASP)，可以帮助您建立一个小的 Web 应用程序。本章讲述了一种使用 Microsoft Internet Information Server (IIS) 或 Personal Web Server (PWS) 设置示例应用程序的方法。有关这些 Web 服务器的更多信息，请参见在 Windows 中安装 Web 服务器。如果您正在使用其他 Web 服务器，请参见设置 Web 应用程序。

本章只适用于 ASP 开发人员。如果您要研究 ASP.NET，请参见示例 ASP.NET 站点的设置。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含以下几节：

  • ASP 开发人员的设置清单
  • 配置您的系统
  • 定义 Dreamweaver 站点
  • 连接到示例数据库（本地配置）
  • 连接到示例数据库（远程服务器配置）
下一页


ASP 开发人员的设置清单

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的清单。本章的其余部分将对这些过程进行介绍。

配置您的系统：
  1. 确保您具有 Web 服务器。
  2. 安装应用程序服务器。
  3. 测试您的安装。
  4. 创建根文件夹。
定义 Dreamweaver 站点：
  1. 将示例文件拷贝到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。
连接到数据库（本地配置）：
  1. 在 Dreamweaver 中创建连接。
连接到数据库（远程服务器配置）：
  1. 在运行 Web 服务器的计算机上设置示例数据库。
  2. 在 Dreamweaver 中创建连接。


配置您的系统

本节提供两种常见系统配置的说明 - 其中一种情况是 Microsoft IIS 或 PWS 安装在您的硬盘上，另一种情况是 IIS 或 PWS 安装在远程 Windows 计算机上。如果您不想使用这些配置，请参见设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

Windows 用户的本地配置，以及 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：
  1. 确保您具有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 如果需要，安装应用程序服务器（请参见安装 ASP 应用程序服务器）。
  3. 测试您的安装（请参见测试安装）。
  4. 创建根文件夹（请参见创建根文件夹）。

备注： 安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 或 PWS 安装并运行在您的硬盘或远程 Windows 计算机上。（Macintosh 用户需要将 Microsoft IIS 或 PWS 安装在远程 Windows 计算机上。）一种快速检查计算机上是否安装有 PWS 或 IIS 的方法是查看文件夹结构。文件夹结构中是否包含 c:\Inetpub 或 d:\Inetpub 文件夹？PWS 和 IIS 在安装过程中将创建该文件夹。

如果未安装 PWS 或 IIS，则现在进行安装。有关说明，请参见在 Windows 中安装 Web 服务器。

安装了 Web 服务器之后，您通常需要安装应用程序服务器。请参见安装 ASP 应用程序服务器。


安装 ASP 应用程序服务器

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。

如果在 Windows 计算机上安装了 PWS 或 IIS，则不需要单独的 ASP 应用程序服务器。PWS 和 IIS 也可以发挥 ASP 应用程序服务器的功能。有关安装和测试 PWS 或 IIS 的更多信息，请参见在 Windows 中安装 Web 服务器。

您可以测试服务器以确保它正常工作。请参见测试安装。


测试安装

您可以按照本节中介绍的步骤通过运行测试页测试 PWS 或 IIS 的 ASP 引擎。

若要测试 PWS 或 IIS 的 ASP 引擎，请执行以下操作：
  1. 在 Dreamweaver 或任何文本编辑器中，创建一个名为“timetest.asp”的纯文本文件。
  2. 在该文件中，输入以下代码：
    3. <p>This page was created at <b>
<%= Time %>
</b> on the computer running ASP.</p>

此代码显示在服务器上处理该页的时间。
  3. 将此文件拷贝到运行 PWS 或 IIS 的 Windows 计算机上的 Inetpub\wwwroot 文件夹中。
  4. 在您的 Web 浏览器中，输入测试页的 URL，然后按回车键。

    5. 如果 PWS 或 IIS 运行在您的本地计算机上，则可以输入以下 URL：

    http://localhost/timetest.asp

测试页应该打开并显示时间，如下所示：

该指定的时间通常叫作动态内容，因为您每次请求该页它都发生变化。单击浏览器上的“刷新”生成具有不同时间的新页。

备注： 查看源代码（Internet Explorer 中的“查看”>“源文件”）将确认该页没有使用任何客户端 JavaScript 实现此效果。

如果该页未按预期方式工作，则检查是否可能存在以下错误：

  • 该文件不具有 .asp 扩展名。
  • 在浏览器的“地址”文本框中输入了该页的文件路径 (c:\Inetput\wwwroot\timetest.asp)，而不是它的 URL（例如，http://localhost/timetest.asp）。

    • 如果您（像处理普通 HTML 页那样）在浏览器中键入了文件路径，则将绕过 Web 服务器和应用程序服务器。结果，您的页将无法得到服务器的处理。

  • URL 中包含键入错误。检查是否存在错误并确保文件名后没有斜杠，例如 http://localhost/timetest.asp/。
  • 页代码中包含键入错误。

安装并测试服务器软件之后，为您的 Web 应用程序创建根文件夹。请参见创建根文件夹。


定义本地文件夹

拷贝 GettingStarted 文件夹之后，将包含 ASP 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：
  1. 在 Dreamweaver 中，选择“站点”>“新建站点”。

    2. 即会出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”。
  3. 在“站点名称”文本框中，输入 GlobalCar - ASP。

    4. 该名称在 Dreamweaver 中标识您的站点。

  4. 在“本地根文件夹”文本框中，指定 GettingStarted 文件夹中包含 ASP 示例文件的文件夹。

    5. 您可以单击文本框旁边的文件夹图标查找并选择文件夹。在 Windows 中，该文件夹应该如下所示：

    C:\Sites\GettingStarted\Develop\asp

    在 Macintosh 上，该文件夹应该如下所示：

    Hard Drive:Documents:Sites:GettingStarted:Develop:asp

将“站点定义”对话框保持为打开状态。接下来您需要将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。请参见定义远程文件夹。


定义远程文件夹

在定义了本地文件夹之后，请按照本节中介绍的步骤将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“远程信息”。

    2. 随即会出现“远程信息”屏幕。

  2. 在“访问”文本框中，选择将文件移入和移出服务器的方式 - 直接移入移出（“本地/网络”选项）还是“FTP”。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    4. 该文件夹可能位于您的硬盘或远程计算机上。即使您在硬盘上创建文件夹，该文件夹仍然是有效的“远程”文件夹。这里是当您选择“本地/网络”访问时的示例：

    远程文件夹：c:\Inetpub\wwwroot\MySampleApp

    有关 FTP 的更多信息，请参见设置 FTP 访问的“远程信息”选项。

将“站点定义”对话框保持为打开状态。接下来您需要定义处理动态页的文件夹。请参见指定处理动态页的位置。


指定处理动态页的位置

在定义了 Dreamweaver 远程文件夹之后，请按照本节中介绍的步骤指定处理动态页的文件夹。Dreamweaver 使用此文件夹显示动态页并在您工作时连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    2. 随即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要它能够处理 ASP 页，选择哪个选项无关紧要。在本例中，您可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 ASP 页的服务器。

  2. 选择 ASP JavaScript 或 ASP VBScript 作为您的服务器技术。
  3. 在“访问”文本框中，选择您指定的访问远程文件夹的方法（“本地/网络”或“FTP”）。

    4. Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入当在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    5. 若要在您工作时在页中显示活动数据，Dreamweaver 将创建临时文件，将其拷贝到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。例如，如果在“远程文件夹”文本框中指定的文件夹是 c:\Inetpub\wwwroot\MySampleApp，则 URL 前缀应该如下所示：

    http://localhost/MySampleApp/

    提示： URL 前缀不应该指定站点上特定的页。

    然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见关于 URL 前缀。

  5. 单击“确定”，然后单击“完成”。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。请参见上传示例文件。


连接到示例数据库（本地配置）

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍在您具有本地配置的情况下（即您的 Web 服务器与 Dreamweaver 在同一台计算机上运行）如何创建到示例数据库的连接。如果您的 Web 服务器运行在远程计算机上，请参见连接到示例数据库（远程服务器配置）。

备注： 如果您要连接到另一个数据库，请参见ASP 开发人员的数据库连接。

对于本地配置，您可以使用 Dreamweaver 在安装过程中创建的数据源名称 (DSN) 快速连接到示例数据库。若要了解关于 DSN 的更多信息，请参见了解 DSN。

若要创建具有本地配置的连接，请执行以下操作：
  1. 在 Dreamweaver 中打开任何一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称 (DSN)”。

    3. 出现“数据源名称 (DSN)”对话框。

  3. 输入 connGlobal 作为连接名称。
  4. 选择“使用本地 DSN”选项。
  5. 从 DSN 列表中选择“GlobalCar”。

    6. 在安装过程中，Dreamweaver 创建名为“GlobalCar”的 DSN，该 DSN 指向 Dreamweaver MX 应用程序文件夹内 Samples\Database 文件夹中的 Microsoft Access 数据库。

  6. 单击“测试”。

    7. Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查 DSN。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查询数据库连接答疑。
  7. 单击“确定”。

    8. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 ASP 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和“帮助”中的教程（“帮助”>“教程”）。


连接到示例数据库（远程服务器配置）

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍在您具有远程服务器配置的情况下（即您的 Web 服务器运行在远程计算机上）如何创建到示例数据库的连接。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，请参见连接到示例数据库（本地配置）。

备注： 如果您要连接到另一个数据库，请参见ASP 开发人员的数据库连接。

若要创建具有远程服务器配置的数据库连接，请执行以下操作：
  1. 在运行 Web 服务器的计算机上设置示例数据库（请参见在远程计算机上设置数据库）
  2. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


在远程计算机上设置数据库

在创建到示例数据库的连接之前，请在运行 Web 服务器的远程计算机上执行以下任务：将示例数据库拷贝到计算机的硬盘并在计算机上创建指向该数据库的 DSN。

若要在远程计算机上设置示例数据库，请执行以下操作：
  1. 将示例数据库文件拷贝到远程计算机。

    2. 数据库文件 (global.mdb) 位于您本地硬盘上的以下文件夹中：

    \Macromedia\Dreamweaver MX\Samples\Database\global.mdb

    您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。

  2. 确保在远程计算机上安装了 Microsoft Access Driver 版本 4.0 或更高版本。

    3. 若要确定是否已经安装了该驱动程序，请参见查看安装在 Windows 系统上的 ODBC 驱动程序。

    如果未安装该驱动程序，请下载 Microsoft 数据访问组件 (MDAC) 2.5 和 2.6 软件包并将其安装在远程计算机上。您可以从 Microsoft Web 站点免费下载 MDAC。这些软件包包含最新的 Microsoft 驱动程序，其中包括 Microsoft Access Driver。

    备注： 在安装 MDAC 2.6 前安装 MDAC 2.5

  3. 设置名为“GlobalCar”的 DSN，该 DSN 指向远程计算机上的示例数据库。

    4. 有关说明，请参见在 Windows 中设置 DSN。

在数据库、数据库驱动程序和 DSN 准备就绪之后，在 Dreamweaver 中创建数据库连接。请参见创建数据库连接。


创建数据库连接

在远程计算机上设置了示例数据库之后（请参见在远程计算机上设置数据库），在 Dreamweaver 中创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：
  1. 在 Dreamweaver 中打开任何一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称 (DSN)”。

    3. 出现“数据源名称 (DSN)”对话框。

  3. 输入 connGlobal 作为连接名称。
  4. 选择“使用测试服务器上的 DSN”选项。

    5. Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用测试服务器上的 DSN。

  5. 单击“DSN”按钮并选择您在远程计算机上设置的 DSN。
  6. 单击“测试”。

    7. Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查 DSN。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查询数据库连接答疑。
  7. 单击“确定”。

    8. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 ASP 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和 Dreamweaver“帮助”中的教程（“帮助”>“教程”）。

上一页


示例 JSP 站点的设置

Macromedia Dreamweaver MX 随附示例 JavaServer Page (JSP) 以帮助您建立一个小型 Web 应用程序。本章介绍使用 Microsoft Internet Information Server (IIS) 或 Personal Web Server (PWS) 设置示例应用程序的一种方法。有关这些 Web 服务器的更多信息，请参见在 Windows 中安装 Web 服务器。如果您正在使用其他 Web 服务器，请参见设置 Web 应用程序。

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含以下几节：

  • JSP 开发人员的设置核对表
  • 配置您的系统
  • 定义 Dreamweaver 站点
  • 连接到示例数据库（本地配置）
  • 连接到示例数据库（远程服务器配置）
下一页


JSP 开发人员的设置核对表

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的核对表。本章的其余部分将对这些过程进行介绍。

配置您的系统：
  1. 确保您具有 Web 服务器。
  2. 安装 JSP 应用程序服务器。
  3. 创建根文件夹。
定义 Dreamweaver 站点：
  1. 将示例文件拷贝到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。
连接到数据库（本地配置）：
  1. 安装 JDBC-ODBC Bridge 驱动程序。
  2. 在 Dreamweaver 中创建连接。
连接到数据库（远程服务器配置）：
  1. 在运行 Web 服务器的计算机上设置示例数据库。
  2. 在 Dreamweaver 中创建连接。


配置您的系统

本节提供两种常见系统配置的说明 - 其中一种情况是 Microsoft IIS 或 PWS 安装在您的硬盘上，另一种情况是 IIS 或 PWS 安装在远程 Windows 计算机上。如果您不想使用这些配置，请参见设置 Web 应用程序。

下面的插图显示了本节中所介绍的两种配置：

Windows 用户的本地配置，以及 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：
  1. 确保您具有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 安装 JSP 应用程序服务器（请参见安装 JSP 应用程序服务器）。
  3. 创建根文件夹（请参见创建根文件夹）。

备注： 安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 或 PWS 安装并运行在您的硬盘或远程 Windows 计算机上。（Macintosh 用户需要将 Microsoft IIS 或 PWS 安装在远程 Windows 计算机上。）一种快速检查计算机上是否安装有 PWS 或 IIS 的方法是查看文件夹结构。文件夹结构中是否包含 c:\Inetpub 或 d:\Inetpub 文件夹？PWS 和 IIS 在安装过程中将创建该文件夹。

如果未安装 PWS 或 IIS，则现在进行安装。有关说明，请参见在 Windows 中安装 Web 服务器。

在安装了 Web 服务器之后，请安装应用程序服务器。请参见安装 JSP 应用程序服务器。


安装 JSP 应用程序服务器

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。

确保 JSP 应用程序服务器安装并运行在运行 PWS 或 IIS 的系统上。（PWS 或 IIS 可能位于您的硬盘或远程计算机上。）

如果您没有 JSP 应用程序服务器，则可以从 Macromedia Web 站点下载并安装 Macromedia JRun 的试用版（全功能的 JSP 应用程序服务器）。

若要安装 JRun，请执行以下操作：
  1. 关闭所有打开的应用程序。
  2. 如果可行，使用管理员帐户登录到 Windows 系统。
  3. 双击 JRun 试用版安装程序文件。

    4. 随即会出现启动屏幕。

  4. 如果您的系统上没有 Java Runtime Environment（Java 运行时环境，JRE），则在启动屏幕上选择该选项进行安装。

    5. 因为 JRun 应用程序服务器依赖于 Java，所以必须首先在将要运行应用程序服务器的系统上安装 JRE。安装了 JRE 之后，您便可以安装 JRun 应用程序服务器了。

  5. 在启动屏幕上选择该选项安装 JRun。
  6. 按照屏幕上的说明完成安装和测试程序的步骤。
  7. 创建到 IIS 或 PWS Web 服务器的 JRun 连接程序。

    8. 有关说明，请参见 JRun 文档。

在安装并启动 JRun 之后，为您的 Web 应用程序创建根文件夹。请参见创建根文件夹。


创建根文件夹

安装了服务器软件之后，在运行 Microsoft PWS 或 IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：
  1. 在运行 PWS 或 IIS 的系统上创建一个名为“MySampleApp”的文件夹。

    2. 创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 PWS 或 IIS Web 服务器安装在 Inetpub\wwwroot 文件夹中。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中或其子文件夹中的任何页。

  2. 确保为该文件夹启用了读权限和脚本权限。

    3. 如果您正在使用 PWS，则双击任务栏中的 Web 服务器图标启动个人 Web 管理器。（该图标显示为握着 Web 页的手。）在个人 Web 管理器中，单击“高级”图标。即会出现“高级选项”对话框。选择“主页”并单击“编辑属性”。即会出现“编辑目录”对话框。 确保选择了“读”和“脚本”选项。出于安全原因，您不应该选择“执行”选项。

    如果您正在使用 IIS，则启动 IIS 管理工具（在 Windows XP 中，选择“启动”>“控制面板”>“性能维护”>“管理工具”>“Internet 信息服务”）。 在“Web 站点”>“默认 Web 站点”下，右击您的 MySampleSite 文件夹并从弹出式菜单中选择“属性”。在“执行权限”文本框中，确保选择了“脚本”选项。出于安全原因，请不要选择“脚本和可执行文件”选项。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。请参见定义 Dreamweaver 站点。


拷贝示例文件

如果尚未进行此操作，则将示例文件从 Dreamweaver 应用程序文件夹拷贝到您硬盘上的文件夹中。

若要拷贝示例文件，请执行以下操作：
  1. 在您的硬盘上创建一个名为“Sites”的新文件夹。

    2. 例如，创建 C:\Sites (Windows) 或 Hard Drive:Documents:Sites (Macintosh)。

  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 GettingStarted 文件夹。

    3. 该文件夹的路径如下：

    \Macromedia\Dreamweaver MX\Samples\GettingStarted\

  3. 将 GettingStarted 文件夹拷贝到 Sites 文件夹中。

拷贝 GettingStarted 文件夹之后，将该文件夹定义为 Dreamweaver 本地文件夹。请参见定义本地文件夹。


定义本地文件夹

拷贝 GettingStarted 文件夹之后，将包含 JSP 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：
  1. 在 Dreamweaver 中，选择“站点”>“新建站点”。

    2. 即会出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”。
  3. 在“站点名称”文本框中，输入 GlobalCar - JSP。

    4. 该名称标识您在 Dreamweaver 中的站点。

  4. 在“本地根文件夹”文本框中，指定 GettingStarted 文件夹中包含 JSP 示例文件的文件夹。

    5. 您可以单击文本框旁边的文件夹图标查找并选择文件夹。在 Windows 中，该文件夹应该如下所示：

    C:\Sites\GettingStarted\Develop\jsp

    在 Macintosh 上，该文件夹应该如下所示：

    Hard Drive:Documents:Sites:GettingStarted:Develop:jsp

将“站点定义”对话框保持为打开状态。接下来您需要将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。请参见定义远程文件夹。


定义远程文件夹

在定义了本地文件夹之后，请按照本节中介绍的步骤将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。

若要定义 Dreamweaver 远程文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“远程信息”。

    2. 即会出现“远程信息”屏幕。

  2. 在“访问”文本框中，选择将文件移入和移出服务器的方式 - 直接移入移出（“本地/网络”选项）还是“FTP”。
  3. 输入您在创建根文件夹中创建的 Web 服务器文件夹的路径或 FTP 设置。

    4. 该文件夹可能位于您的硬盘或远程计算机上。即使您在硬盘上创建文件夹，该文件夹仍然是有效的“远程”文件夹。这里是当您选择“本地/网络”访问时的示例：

    远程文件夹：c:\Inetpub\wwwroot\MySampleApp

    有关 FTP 的更多信息，请参见设置 FTP 访问的“远程信息”选项。

将“站点定义”对话框保持为打开状态。接下来您需要定义处理动态页的文件夹。请参见指定处理动态页的位置。


指定处理动态页的位置

在定义了 Dreamweaver 远程文件夹之后，请指定处理动态页的文件夹。Dreamweaver 使用此文件夹显示动态页并在您工作时连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    2. 即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要它能处理 JSP 页，选择哪个选项都可以。在本例中，您可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 JSP 页的服务器。

  2. 选择 JSP 作为您的服务器技术。
  3. 在“访问”文本框中，选择您指定的访问远程文件夹的方法（“本地/网络”或“FTP”）。

    4. Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    5. 为了在您工作时在页中显示活动数据，Dreamweaver 将创建临时文件，将其拷贝到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。例如，如果在“远程文件夹”文本框中指定的文件夹是 c:\Inetpub\wwwroot\MySampleApp，则 URL 前缀应该如下所示：

    http://localhost/MySampleApp/

    提示： URL 前缀不应该指定站点上特定的页。

    然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见关于 URL 前缀。

  5. 单击“确定”，然后单击“完成”。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。请参见上传示例文件。


连接到示例数据库（本地配置）

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍在您具有本地配置的情况下（即您的 Web 服务器与 Dreamweaver 运行在同一台计算机上）如何创建到示例数据库的连接。如果您的 Web 服务器运行在远程计算机上，请参见连接到示例数据库（远程服务器配置）。

备注： 如果您要连接到另一个数据库，请参见用于 JSP 开发人员的数据库连接。

若要创建具有本地配置的数据库连接，请执行以下操作：
  1. 安装 Sun JDBC-ODBC Bridge 驱动程序（请参见安装 Bridge 驱动程序）。
  2. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


安装 Bridge 驱动程序

在创建到示例数据库的连接之前，请在运行 Web 服务器的计算机上安装 Sun JDBC-ODBC Bridge 驱动程序。Bridge 驱动程序允许您使用 Windows 数据源名称 (DSN) 来创建连接。该驱动程序和用于 Windows 的 Sun Java 2 SDK 标准版一起提供。

若要确定是否已具有带有该驱动程序的 Java 2 SDK，请检查您的硬盘上是否有以下目录中的任何一个：

c:\jdk1.2.x

c:\jdk1.3.x

备注： Java 1.2.2 和 1.3 同于 Java 2。

如果没有 SDK，请从 Sun Web 站点进行下载。下载完安装文件之后，双击该文件以运行安装程序。按照屏幕上的说明进行操作并确保在“选择组件”对话框中选择了 Java 2 运行时环境组件。该组件应该是默认选中的。在安装 SDK 时将自动安装驱动程序。

尽管 Sun JDBC-ODBC Bridge 驱动程序用于开发低端数据库系统（例如 Microsoft Access）绰绰有余，但它不适用于进行生产。例如，该驱动程序一次只让一个 JSP 页连接到数据库（换言之，它不支持多个线程并发使用）。有关驱动程序限制的更多信息，请参见 Macromedia 支持中心上的文章 12409。

安装了 Bridge 驱动程序之后，在 Dreamweaver 中创建数据库连接。请参见创建数据库连接。


创建数据库连接

在运行 Web 服务器的计算机上安装了 Sun JDBC-ODBC Bridge 驱动程序之后（请参见安装 Bridge 驱动程序），请在 Dreamweaver 中创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：
  1. 在 Dreamweaver 中打开任何一个 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 在该面板上单击加号 (+) 按钮并从弹出式菜单中选择“Sun JDBC-ODBC 驱动程序（ODBC 数据库）”。

    3. 即会出现“ODBC 数据库（Sun JDBC-ODBC 驱动程序）”对话框。

  3. 输入 connGlobal 作为连接名称。
  4. 选择“在此计算机上使用驱动程序”选项。
  5. 用 GlobalCar 替换“URL”文本框中的 [odbc dsn] 占位符。

    6. 在安装过程中，Dreamweaver 创建名为“GlobalCar”的 DSN，该 DSN 指向 Dreamweaver MX 应用程序文件夹内 Samples\Database 文件夹中的 Microsoft Access 数据库。

    “URL”文本框应类似于：

    jdbc:odbc:GlobalCar
  6. 单击“测试”。

    7. Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查 DSN 和其他连接参数。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查询数据库连接答疑。
  7. 单击“确定”。

    8. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 JSP 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和“帮助”中的教程（“帮助”>“教程”）。


连接到示例数据库（远程服务器配置）

在安装过程中，Dreamweaver 将示例 Microsoft Access 数据库拷贝到您的硬盘。本节介绍在您具有远程服务器配置的情况下（即您的 Web 服务器运行在远程计算机上）如何创建到示例数据库的连接。如果您的 Web 服务器与 Dreamweaver 运行在同一台计算机上，请参见连接到示例数据库（本地配置）。

备注： 如果您要连接到另一个数据库，请参见用于 JSP 开发人员的数据库连接。

若要创建具有远程服务器配置的数据库连接，请执行以下操作：
  1. 在运行 Web 服务器的计算机上设置示例数据库（请参见在远程计算机上设置数据库）。
  2. 在 Dreamweaver 中创建连接（请参见创建数据库连接）。


在远程计算机上设置数据库

在创建到示例数据库的连接之前，请在运行 Web 服务器的远程计算机上执行以下任务：将示例数据库拷贝到计算机的硬盘，在计算机上创建指向该数据库的 DSN，然后在计算机上安装 Sun JDBC-ODBC Bridge 驱动程序。

若要在远程计算机上设置示例数据库，请执行以下操作：
  1. 将示例数据库文件拷贝到远程计算机。

    2. 数据库文件 (global.mdb) 位于您本地硬盘上的以下文件夹中：

    \Macromedia\Dreamweaver MX\Samples\Database\global.mdb

    您可以将该文件上传到远程计算机上的任何文件夹中，或者可以为它创建一个新文件夹。

  2. 确保在远程计算机上安装了 Microsoft Access Driver 版本 4.0 或更高版本。

    3. 若要确定是否已经安装了该驱动程序，请参见查看安装在 Windows 系统上的 ODBC 驱动程序。

    如果未安装该驱动程序，请下载 Microsoft 数据访问组件 (MDAC) 2.5 和 2.6 软件包并将其安装在远程计算机上。您可以从 Microsoft Web 站点免费下载 MDAC。这些软件包包含最新的 Microsoft 驱动程序，其中包括 Microsoft Access Driver。

    备注： 在安装 MDAC 2.6 前安装 MDAC 2.5

  3. 在远程计算机上为示例数据库设置 DSN。

    4. 有关说明，请参见在 Windows 中设置 DSN。

  4. 确保在远程计算机上安装了 Sun JDBC-ODBC Bridge 驱动程序。

    5. 您将使用该驱动程序和 DSN 来创建到数据库的连接。有关说明，请参见安装 Bridge 驱动程序。

在数据库、DSN 和 Bridge 驱动程序准备就绪之后，在 Dreamweaver 中创建数据库连接。请参见创建数据库连接。


创建数据库连接

在远程计算机上设置了示例数据库之后（请参见在远程计算机上设置数据库），在 Dreamweaver 中创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：
  1. 在 Dreamweaver 中打开任何一个 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 在该面板上单击加号 (+) 按钮并从弹出式菜单中选择“ODBC 数据库（Sun JDBC-ODBC 驱动程序）”。

    3. 即会出现“ODBC 数据库（Sun JDBC-ODBC 驱动程序）”对话框。

  3. 输入 connGlobal 作为连接名称。
  4. 选择“使用测试服务器上的驱动程序”选项。

    5. Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用测试服务器上的驱动程序。

  5. 用您在远程计算机上定义的 DSN 替换“URL”文本框中的 [odbc dsn] 占位符。

    6. “URL”文本框应类似于：

    jdbc:odbc:myDSN
  6. 单击“测试”。

    7. Dreamweaver 尝试连接到数据库。如果连接失败，请执行以下操作：

    • 复查 DSN 和其他连接参数。
    • 检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定处理动态页的位置）。
    • 查询数据库连接答疑。
  7. 单击“确定”。

    8. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 JSP 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和 Dreamweaver“帮助”中的教程（“帮助”>“教程”）。

上一页


示例 PHP 站点的设置

Macromedia Dreamweaver MX 随附示例 PHP 页以帮助您建立一个小型 Web 应用程序。本章介绍使用 Microsoft Internet Information Server (IIS) 或 Personal Web Server (PWS) 设置示例应用程序的一种方法。有关这些 Web 服务器的更多信息，请参见在 Windows 中安装 Web 服务器。如果您正在使用其他 Web 服务器，请参见设置 Web 应用程序。

如果您是 Mac OS X 用户，则可以使用随您的操作系统一起安装的 Apache Web 服务器和 PHP 应用程序服务器在本地开发 PHP 站点。有关设置信息，请参见以下 Web 站点：

  • http://developer.apple.com/internet/macosx/php.html
  • http://www.entropy.ch/software/macosx/
  • http://www.stepwise.com/Articles/Workbench/2001-10-11.01.html

设置 Web 应用程序的过程分为三步。第一步，配置您的系统。第二步，定义 Dreamweaver 站点。第三步，将应用程序连接到您的数据库。本设置指南按照该三步过程进行说明。

本章包含以下几节：

  • PHP 开发人员的设置核对表
  • 配置您的系统
  • 定义 Dreamweaver 站点
  • 连接到示例数据库
下一页


PHP 开发人员的设置核对表

若要设置 Web 应用程序，您必须配置系统、定义 Dreamweaver 站点并连接到数据库。本节提供每项任务的核对表。本章的其余部分将对这些过程进行介绍。

配置您的系统：
  1. 确保您具有 Web 服务器。
  2. 安装 PHP 应用程序服务器。
  3. 测试您的安装。
  4. 创建根文件夹。
定义 Dreamweaver 站点：
  1. 将示例文件拷贝到您硬盘上的文件夹中。
  2. 将此文件夹定义为 Dreamweaver 本地文件夹。
  3. 将 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。
  4. 指定一个处理动态页的文件夹。
  5. 将示例文件上传到 Web 服务器。
连接到数据库：
  1. 创建示例 MySQL 数据库。
  2. 在 Dreamweaver 中创建数据库连接。


配置您的系统

本节提供两种常见系统配置的说明 - 其中一种情况是 Microsoft IIS 或 PWS 安装在您的硬盘上，另一种情况是 IIS 或 PWS 安装在远程 Windows 计算机上。如果您不想使用这些配置，请参见设置 Web 应用程序。

备注： 如果您是 Mac OS X 用户，则可以使用随您的操作系统一起安装的 Apache Web 服务器和 PHP 应用程序服务器。有关更多信息，请参见 Apple Web 站点（网址是 http://developer.apple.com/internet/macosx/php.html）。其他有用的 Web 站点包括 http://www.entropy.ch/software/macosx/ 和 http://www.stepwise.com/Articles/Workbench/2001-10-11.01.html。

下面的插图显示了本节中所介绍的两种配置：

Windows 用户的本地配置，以及 Macintosh 和 Windows 用户的远程服务器配置。

若要配置您的系统，请执行以下操作：
  1. 确保您具有 Web 服务器（请参见检查是否存在 Web 服务器）。
  2. 安装 PHP 应用程序服务器（请参见安装 PHP 应用程序服务器）。
  3. 测试您的安装（请参见测试安装）。
  4. 创建根文件夹（请参见创建根文件夹）。

备注： 安装 Web 服务器和应用程序服务器是只需进行一次的任务。


检查是否存在 Web 服务器

若要开发和测试动态 Web 页，您需要一个 Web 服务器。Web 服务器是响应来自 Web 浏览器的请求以提供 Web 页的软件。

确保 Microsoft IIS 或 PWS 安装并运行在您的硬盘或远程 Windows 计算机上。（Macintosh 用户需要将 Microsoft IIS 或 PWS 安装在远程 Windows 计算机上。）一种快速检查计算机上是否安装有 PWS 或 IIS 的方法是查看文件夹结构。文件夹结构中是否包含 c:\Inetpub 或 d:\Inetpub 文件夹？PWS 和 IIS 在安装过程中将创建该文件夹。

如果未安装 PWS 或 IIS，则现在进行安装。有关说明，请参见在 Windows 中安装 Web 服务器。

在安装了 Web 服务器之后，请安装应用程序服务器。请参见安装 PHP 应用程序服务器。


安装 PHP 应用程序服务器

若要处理动态 Web 页，您需要应用程序服务器。应用程序服务器是一种软件，它帮助 Web 服务器处理包含服务器端脚本或标签的 Web 页。当从服务器请求这样一个页时，Web 服务器先将该页传递给应用程序服务器进行处理，然后再将该页发送到浏览器。

确保 PHP 应用程序服务器安装并运行在运行 PWS 或 IIS 的系统上。（PWS 或 IIS 可能位于您的硬盘或远程 Windows 计算机上。）

如果您没有 PHP，则可以从 PHP Web 站点进行下载和安装。选择 Windows 安装程序文件，该文件使用 InstallShield 安装 PHP 并配置 IIS 或 PWS。

若要在 Windows 系统上安装 PHP，请执行以下操作：
  1. 关闭所有打开的应用程序。
  2. 如果可行，使用管理员帐户登录到 Windows 系统。
  3. 双击从 PHP Web 站点下载的安装程序文件。
  4. 按照屏幕上的说明安装该程序。

安装完成后，安装程序将通知您是需要重新启动系统、重新启动服务器还是直接开始使用 PHP。

有关配置服务器的更多信息，请参见 PHP 文档，您可以从 PHP Web 站点下载该文档。

安装了 PHP 之后，您可以测试服务器以确保它正常工作。请参见测试安装。


测试安装

您可以按照本节中介绍的步骤通过运行测试页测试 PHP 应用程序服务器。

若要测试 PHP 应用程序服务器，请执行以下操作：
  1. 在 Dreamweaver 或任何文本编辑器中，创建一个名为“timetest.php”的纯文本文件。
  2. 在该文件中，输入以下代码：
    3. <p>This page was created at <b>
<?php echo date("h:i:s a", time()); ?>
</b> on the computer running PHP.</p>

该代码显示在服务器上处理该页的时间。
  3. 将此页拷贝到运行 PWS 或 IIS 的 Windows 计算机内硬盘上的 Inetpub\wwwroot 文件夹中。
  4. 在您的 Web 浏览器中，输入测试页的 URL，然后按回车键。

    5. 如果您将 PHP 安装在本地计算机上，则可以输入以下 URL：

    http://localhost/timetest.php

测试页应该打开并显示时间，如下所示：

该指定的时间称作动态内容，因为您每次请求该页它都发生变化。单击浏览器上的“刷新”生成具有不同时间的新页。

备注： 查看源代码（Internet Explorer 中的“查看”>“源文件”）将确认该页没有使用任何客户端 JavaScript 实现此效果。

如果该页未按预期方式进行工作，则检查是否存在以下可能的错误：

  • 该文件不具有 .php 扩展名。
  • 在浏览器的“地址”文本框中输入了该页的文件路径 (c:\Inetput\wwwroot\timetest.php)，而不是它的 URL（例如，http://localhost/timetest.php）。

    • 如果您（像处理普通 HTML 页那样）在浏览器中键入了文件路径，则将绕过 Web 服务器和应用程序服务器。结果，您的页将无法得到服务器的处理。

  • URL 中包含键入错误。检查是否存在错误并确保文件名后没有斜杠，例如 http://localhost/timetest.php/。

安装并测试服务器软件之后，为您的 Web 应用程序创建根文件夹。请参见创建根文件夹。


创建根文件夹

安装了服务器软件之后，在运行 Microsoft PWS 或 IIS 的系统上为您的 Web 应用程序创建根文件夹，并确保该文件夹具有必要的权限。

若要为您的 Web 应用程序创建根文件夹，请执行以下操作：
  1. 在运行 PWS 或 IIS 的系统上创建一个名为“MySampleApp”的文件夹。

    2. 创建该文件夹的合适位置是 C:\Inetpub\wwwroot\。默认情况下，您的 PWS 或 IIS Web 服务器安装在 Inetpub\wwwroot 文件夹中。Web 服务器将根据来自 Web 浏览器的 HTTP 请求提供此文件夹中或其子文件夹中的任何页。

  2. 确保为该文件夹启用了读权限和脚本权限。

    3. 如果您正在使用 PWS，则双击任务栏中的 Web 服务器图标启动个人 Web 管理器。（该图标显示为握着 Web 页的手。）在个人 Web 管理器中，单击“高级”图标。即会出现“高级选项”对话框。选择“主页”并单击“编辑属性”。即会出现“编辑目录”对话框。 确保选择了“读”和“脚本”选项。出于安全原因，您不应该选择“执行”选项。

    如果您正在使用 IIS，则启动 IIS 管理工具（在 Windows XP 中，选择“启动”>“控制面板”>“性能维护”>“管理工具”>“Internet 信息服务”）。在“Web 站点”>“默认 Web 站点”下，右击您的 MySampleSite 文件夹并从弹出式菜单中选择“属性”。在“执行权限”文本框中，确保选择了“脚本”选项。出于安全原因，请不要选择“脚本和可执行文件”选项。

现在已完成了 Web 服务器的配置，它将根据来自 Web 浏览器的 HTTP 请求提供根文件夹中的 Web 页。

在配置完系统后，您必须定义 Dreamweaver 站点。请参见定义 Dreamweaver 站点。


定义本地文件夹

拷贝 GettingStarted 文件夹之后，将包含 PHP 示例文件的文件夹定义为 Dreamweaver 本地文件夹。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：
  1. 在 Dreamweaver 中，选择“站点”>“新建站点”。

    2. 即会出现“站点定义”对话框。

  2. 如果显示向导，则单击“高级”。
  3. 在“站点名称”文本框中，输入 GlobalCar - PHP。

    4. 该名称标识您在 Dreamweaver 中的站点。

  4. 在“本地根文件夹”文本框中，指定 GettingStarted 文件夹中包含 PHP 示例文件的文件夹。

    5. 您可以单击文本框旁边的文件夹图标查找并选择文件夹。在 Windows 中，该文件夹应该如下所示：

    C:\Sites\GettingStarted\Develop\php

    在 Macintosh 上，该文件夹应该如下所示：

    Hard Drive:Documents:Sites:GettingStarted:Develop:php

  5. 将“站点定义”对话框保持为打开状态。接下来您需要将一个 Web 服务器文件夹定义为 Dreamweaver 远程文件夹。请参见定义远程文件夹。


指定处理动态页的位置

在定义了 Dreamweaver 远程文件夹之后，请按照本节中介绍的步骤指定处理动态页的文件夹。Dreamweaver 使用此文件夹显示动态页并在您工作时连接到数据库。

若要指定处理动态页的文件夹，请执行以下操作：
  1. 在高级“站点定义”对话框中，单击“类别”列表中的“测试服务器”。

    2. 即会出现“测试服务器”屏幕。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要它能处理 PHP 页，选择哪个选项都可以。在本例中，您可以使用与“远程信息”类别相同的设置（请参见定义远程文件夹），因为它们指向能够处理 PHP 页的服务器。

  2. 选择 PHP MySQL 作为您的服务器技术。
  3. 在“访问”文本框中，选择您指定的访问远程文件夹的方法（“本地/网络”或“FTP”）。

    4. Dreamweaver 输入您在“远程信息”类别中指定的设置。不要更改这些设置。

  4. 在“URL 前缀”文本框中，输入在 Web 应用程序中请求页时您将在 Web 浏览器中输入的根 URL。

    5. 为了在您工作时在页中显示活动数据，Dreamweaver 将创建临时文件，将其拷贝到 Web 站点的根文件夹，然后尝试使用 URL 前缀请求该文件。

    Dreamweaver 根据您在“站点定义”对话框中提供的信息对 URL 前缀进行最接近的推测。然而，建议的 URL 前缀可能并不正确。例如，如果在“远程文件夹”文本框中指定的文件夹是 c:\Inetpub\wwwroot\MySampleApp，则 URL 前缀应该如下所示：

    http://localhost/MySampleApp/

    提示： URL 前缀不应该指定站点上特定的页。

    然而，建议的 URL 前缀可能并不正确。如果 Dreamweaver 的建议不正确，请更正该 URL 前缀或输入一个新的 URL 前缀。有关更多信息，请参见关于 URL 前缀。

  5. 单击“确定”，然后单击“完成”。

在指定了处理动态页的文件夹之后，请将示例文件上传到 Web 服务器。请参见上传示例文件。


上传示例文件

在指定了处理动态页的文件夹之后，请按照本节中介绍的步骤将示例文件上传到 Web 服务器。即使 Web 服务器运行在本地计算机上，您也必须“上传”这些文件。

如果不上传文件，则某些功能（例如“实时数据”视图和“在浏览器中预览”）对动态页可能不能正常工作。例如，由于图像文件尚未在服务器上，“实时数据”视图中的图像链接可能是断开的。同样，如果服务器上没有详细信息页，则在浏览器中预览主页时单击指向详细信息页的链接也将导致错误。

若要将示例文件上传到 Web 服务器，请执行以下操作：
  1. 在“站点”面板（“窗口”>“站点”）中，选择“本地文件”窗格中的根文件夹。

    2. 根文件夹应该是列表中的第一个文件夹。

  2. 单击工具栏上蓝色的向上箭头。

    3. Dreamweaver 将所有文件拷贝到您在定义远程文件夹中定义的 Web 服务器文件夹。

这便完成了 Dreamweaver 站点的定义。下一步是连接到随 Dreamweaver 一起安装的示例数据库。请参见连接到示例数据库。


连接到示例数据库

在安装过程中，Dreamweaver 将 SQL 脚本拷贝到您的硬盘。您可以使用此脚本自动创建示例 MySQL 数据库。本节介绍如何创建到示例数据库的连接。

本节假设您已在本地或远程计算机上安装并配置了 MySQL。若要下载和安装数据库系统，请访问 MySQL Web 站点。

第一步是使用 SQL 脚本创建示例 MySQL 数据库（请参见创建 MySQL 数据库）。创建了数据库之后，您必须在 Dreamweaver 中创建数据库连接（请参见创建数据库连接）。


创建 MySQL 数据库

在安装过程中，Dreamweaver MX 拷贝能够创建和填充示例 MySQL 数据库的 SQL 脚本。

在开始之前，确保在本地或远程计算机上安装并配置了 MySQL。您可以从 MySQL Web 站点下载最新的版本。

若要创建示例 MySQL 数据库，请执行以下操作：
  1. 将 SQL 脚本文件 (insert.sql) 拷贝到具有 MySQL 的计算机上的 MySql\Bin 文件夹中。

    2. 该脚本文件位于您硬盘上的以下文件夹中：

    \Macromedia\Dreamweaver MX\Samples\Database\insert.sql

  2. 在具有 MySQL 的计算机上，打开命令提示符窗口。

    3. 在 Windows 中，您可以通过选择“开始”>“程序”>“命令提示符”打开命令提示符。

    备注： 在某些系统上，“命令提示符”可能位于“开始”>“程序”菜单中的“附件”下。

  3. 通过在命令提示符处输入以下命令更改为 mysql\bin 目录：
    4. > cd\
> cd mysql\bin
  4. 通过在 mysql\bin\ 提示符处输入以下命令启动 MySQL 客户端：
    5. > mysql -uUser -pPassword

例如，如果您的 MySQL 用户名（也称作帐户名）和密码分别为“Tara”和“Telly3”，则输入以下命令：

> mysql -uTara -pTelly3

如果您没有密码，则省略 -p 参数，如下所示：

> mysql -uTara

如果您在配置 MySQL 安装时未定义用户名，则输入“root”作为用户名，如下所示：

> mysql -uroot

即会显示 MySQL 客户端的命令提示符，如下所示：

mysql>
  5. 通过在 MySQL 提示符处输入以下命令创建一个新数据库：
    6. mysql>CREATE DATABASE GlobalCar;

MySQL 将创建一个新数据库，但它尚不包含任何表或记录。
  6. 通过在提示符处输入以下命令从 MySQL 客户端注销：
    7. mysql>quit
  7. 在系统命令提示符处，通过以下命令填充 MySQL 中的新 GlobalCar 数据库：
    8. > mysql -uUser -pPassword GlobalCar < insert.sql

此命令使用 insert.sql 文件将表和记录添加到您在第 5 步中创建的 GlobalCar 数据库。

创建了 MySQL 数据库之后，在 Dreamweaver 中创建到该数据库的数据库连接。请参见创建数据库连接。


创建数据库连接

设置了示例数据库之后（请参见创建 MySQL 数据库），您可以在 Dreamweaver 中创建数据库连接。

若要在 Dreamweaver 中创建数据库连接，请执行以下操作：
  1. 在 Dreamweaver 中打开任何一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 在该面板上单击加号 (+) 按钮并从弹出式菜单中选择“MySQL 连接”。

    3. 即会出现“MySQL 连接”对话框。

  3. 输入 connGlobal 作为连接名称。
  4. 在“MySQL 服务器”文本框中，指定承载 MySQL 的计算机。

    5. 输入 IP 地址或服务器名称。如果 MySQL 与 PHP 运行在同一台计算机上，则输入 localhost。

  5. 输入您的 MySQL 用户名和密码。

    6. 如果在 Windows 计算机上配置 MySQL 安装时未定义用户名，则在“用户名”文本框中输入单词“root”。如果您没有密码，则将“密码”文本框留空。

  6. 在“数据库”文本框中，输入 GlobalCar，或单击“选择”并从 MySQL 数据库列表中选择“GlobalCar”。

    7. GlobalCar 是您创建的示例 MySQL 数据库的名称（请参见创建 MySQL 数据库）。

  7. 单击“测试”。

    8. Dreamweaver 尝试连接到数据库。如果连接失败，请复查服务器名称、用户名和密码。如果连接仍失败，请检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定处理动态页的位置）。

  8. 单击“确定”。

    9. 新连接随即出现在“数据库”面板中。

为入门指南和教程设置示例 PHP 应用程序即告完成。请参见在 Dreamweaver MX 中开发 Web 应用程序和 Dreamweaver“帮助”中的教程（“帮助”>“教程”）。

上一页


数据库连接答疑

本章介绍在创建数据库连接后遇到的一些常见问题，并介绍解决这些问题的方法。本章包括以下几节：

  • Microsoft 错误信息答疑
  • ColdFusion 错误信息答疑
  • 权限问题答疑
下一页


Microsoft 错误信息答疑

本节介绍一些常见的 Microsoft 错误信息以及修正这些错误的方法。如果您将 Internet Information Server (IIS) 与 Microsoft 数据库系统（例如 Access 或 SQL Server）一起使用，则可能发生这些错误。这些错误通常在您从服务器中请求动态页时发生。

备注： Macromedia 不对 Microsoft Windows 和 IIS 等第三方软件提供技术支持。如果本节内容无法解决您的问题，请与 Microsoft 技术支持部门联系或访问 Microsoft 支持 Web 站点。

本节将讨论以下错误信息：

  • 80004005 - 未找到数据源名称并且未指定默认驱动程序（此错误信息的其他形式包括“80004005 - 驱动程序的 SQLSetConnectAttr 失败”和“80004005 - 一般性错误：无法打开注册表项‘DriverId’”）
  • 80004005 - 无法使用“（未知）”；文件已在使用（另一形式为“80004005 - Microsoft Jet 数据库引擎无法打开文件（未知）”）
  • 80004005 - 登录失败()
  • 80004005 - 操作必须使用可更新的查询
  • 80040e07 - 条件表达式中分类不匹配
  • 80040e10 - 参数太少
  • 80040e10 - COUNT 域不正确
  • 80040e14 - INSERT INTO 语句中出现语法错误
  • 80040e21 - 插入或更新时出现 ODBC 错误
  • 800a0bcd - BOF 或 EOF 为真

有关 80004005 错误的更多信息，请参见“INFO:Troubleshooting Guide for 80004005 Errors in Active Server Pages and Microsoft Data Access Components (Q306518)”(INFO：Active Server Pages 和 Microsoft 数据访问组件中 80004005 错误的疑难解答 (CHS306518)），它位于 Microsoft Web 站点。


80004005 - 未找到数据源名称并且未指定默认驱动程序

当您试图在 Web 浏览器中或以“动态数据”模式查看动态页时，此错误会出现。根据您的数据库和 Web 服务器的具体情况，该错误信息可能有所不同。其他形式包括：

  • 80004005 - 驱动程序的 SQLSetConnectAttr 失败
  • 80004005 - 一般性错误：无法打开注册表项"DriverId"

可能的原因和解决方案如下：

  • 该页找不到 DSN。确保已经在 Web 服务器和本地计算机上创建 DSN。有关更多信息，请参见在 Windows 中设置 DSN。
  • DSN 可能已设置为用户 DSN，而不是系统 DSN。请删除用户 DSN 并创建一个系统 DSN 取代它。

    • 备注： 如果不删除用户 DSN，则重复的 DSN 名称会产生新的 ODBC 错误。

  • 如果使用 Microsoft Access，则可能数据库文件 (.mdb) 已锁定。此锁定可能是因 DSN 使用不同的名称访问该数据库引起的。在 Windows 资源管理器中，从包含数据库文件 (.mdb) 的文件夹中搜索锁定文件 (.ldb) 并删除该 .ldb 文件。如果另一个 DSN 正指向同一数据库文件，则最好删除该 DSN，以防止以后出错。进行以上更改后务必要重新启动计算机。


80004005 - 无法使用“（未知）”；文件已在使用

当您使用 Microsoft Access 数据库并试图在 Web 浏览器中或以“动态数据”模式查看动态页时，此错误会出现。此错误信息的另一形式为“80004005 - Microsoft Jet 数据库引擎无法打开文件（未知）”。

可能的原因是存在权限问题。有关更多信息，请参见权限问题答疑。具体的原因和解决方案如下：

  • Internet Information Server 所使用的帐户（通常是 IUSR）对于某个基于文件的数据库或包含该文件的文件夹可能没有正确的 Windows NT 权限。请在 NT 用户管理器中检查该 IIS 帐户 (IUSR) 的权限。
  • 您可能没有创建或销毁临时文件所需的权限。请检查对该文件和文件夹的权限。确保您具有创建或销毁任何临时文件所需的权限。临时文件通常创建在数据库所在的文件夹中，但也可能创建到其他文件夹（如 /Winnt）下。
  • 在 Windows 2000 中，可能需要为 Access 数据库 DSN 更改超时值。若要更改超时值，请选择“开始”>“设置”>“控制面板”>“管理工具” >“数据源 (ODBC)”。单击“系统”选项卡，突出显示正确的 DSN，然后单击“配置”按钮。单击“选项”按钮并将“页超时”值更改为 5000。

如果仍然有问题，请参见下面的 Microsoft 知识库文章：

  • PRB：80004005 “Couldn't Use '(unknown)'; File Already in Use”（无法使用“（未知）”；文件已在使用）。
  • PRB：Microsoft Access Database Connectivity Fails in Active Server Pages（Active Server Pages 中的 Microsoft Access 数据库连接失败）。
  • PRB：“Error "Cannot Open File Unknown" Using Access”（使用 Access 时出现“无法打开未知文件”错误）。


80004005 - 登录失败()

当您使用 Microsoft SQL Server 并试图在 Web 浏览器中或以“动态数据”模式查看动态页时，此错误会出现。

如果 SQL Server 不接受或不识别您所提交的登录帐户或密码（假定您使用的是标准安全机制），或者如果 Windows NT 帐户没有映射到 SQL 帐户（假定您使用的是集成安全机制），则 SQL Server 会发生此错误。

可能的解决方案如下：

  • 如果使用标准安全机制，则可能是帐户名称和密码不正确。请使用系统管理员帐户和密码（UID=“sa”且无密码）试一试，但这必须在连接字符串语句行中定义。（DSN 不存储用户名和密码。）
  • 如果使用集成安全机制，则请检查调用该页的 Windows NT 帐户，并找到它的映射 SQL 帐户（如果存在）。
  • SQL Server 不允许在 SQL 帐户名中使用下划线。如果有人手动将 Windows NT IUSR_machinename 帐户映射到同名的 SQL 帐户，则会失败。应该将任何使用下划线的帐户映射到 SQL 上不使用下划线的帐户名称。


80004005 - 操作必须使用可更新的查询

当事件更新记录集或在记录集中插入数据时会发生此错误。

可能的原因和解决方案如下：

  • 对包含数据库的文件夹所设置的权限具有太多限制。IUSR 特权必须设置为读/写。请参见权限问题答疑。
  • 对数据库文件本身的权限未使完全的读/写特权生效。请参见权限问题答疑。
  • 数据库可能位于 Inetpub/wwwroot 目录之外。如果数据库不在 wwwroot 目录中，那么虽然您可以查看和搜索数据，但却不能更新它。
  • 数据集基于不可更新的查询。联接是数据库中不可更新查询的很好的示例。请重新构造查询，以使其可以更新。

有关此错误的更多信息，请参见“PRB:ASP 'Error The Query Is Not Updateable' When You Update Table Record”（PRB：更新表记录时出现 ASP 错误“查询不可更新”），它位于 Microsoft 知识库。


80040e07 - 条件表达式中分类不匹配

当服务器尝试处理包含“插入记录”或“更新记录”服务器行为的页，并且该服务器行为试图将 Microsoft Access 数据库中“日期/时间”列的值设置为空字符串 ("") 时，此错误会出现。

Microsoft Access 具有强大的数据分类功能；对于给定的列值有一套严格的规则。SQL 查询中的空字符串值不能存储在 Access“日期/时间”列中。目前已知的唯一解决方法是避免将空字符串 ("") 或其他任何与为该数据类型指定的值范围不对应的值插入 Access 中的“日期/时间”列或使用这种值更新“日期/时间”列。


80040e10 - 参数太少

当数据库表中不存在 SQL 查询中所指定的列时，此错误会出现。请对照 SQL 查询检查数据库表中的列名称。此错误通常是因拼写错误引起。


80040e10 - COUNT 域不正确

当您在 Web 浏览器中预览包含“插入记录”服务器行为的页并尝试使用它在 Microsoft Access 2000 数据库中插入记录时，此错误会出现。

您可能正在尝试将记录插入域名中包含问号 (?) 的数据库域。问号对于某些数据库引擎（包括 Microsoft Access）是特殊字符，不应将它用于数据库表格或域名称。

打开数据库系统并从域名中删除问号 (?)，然后更新页上引用该域的服务器行为。


80040e14 - INSERT INTO 语句中出现语法错误

当服务器尝试处理包含“插入记录”服务器行为的页时，此错误会出现。

此错误通常是因数据库中域、对象或变量的名称存在以下一个或多个问题所致：

  • 将保留字用作名称。大多数数据库都有一组保留字。例如，“date”是保留字，因而不能用于数据库中的列名称。
  • 名称中使用特殊字符。特殊字符的示例包括：

    • . / * : ! # & - ?

  • 在名称中使用空格。

当为数据库中的对象定义了输入掩码并且插入的数据与该掩码不符时，此错误也会出现。

若要修正此错误，请在指定数据库列名时避免使用“date”、“name”、“select”、“where”和“level”等保留字。另外，请清除空格和特殊字符。

有关常见数据库系统的保留字的列表，请参见以下 Web 页：

  • Microsoft Access
  • Microsoft SQL Server
  • Oracle
  • MySQL


80040e21 - 插入或更新时出现 ODBC 错误

当服务器尝试处理包含“更新记录”或“插入记录”服务器行为的页时，此错误会出现。数据库无法处理该服务器行为尝试执行的更新或插入操作。

可能的原因和解决方案如下：

  • 该服务器行为正尝试更新数据库表的自动编号域或者尝试在自动编号域中插入记录。由于自动编号域由数据库系统自动填充，因此任何用值填充这些域的尝试都会失败。
  • 服务器行为正在更新或插入的数据对于该数据库域而言是错误的类型，例如将日期插入布尔型（是/否）域，将字符串插入数值域，或者将格式不正确的字符串插入“日期/时间”域。


800a0bcd - BOF 或 EOF 为真

当您试图在 Web 浏览器中或以“动态数据”模式查看动态页时，此错误会出现。

该问题在动态页尝试显示空记录集中的数据时出现。若要解决该问题，请将“显示区域”服务器行为应用于要在页上显示的动态内容，如下所述：

  1. 突出显示页上的动态内容。
  2. 在“服务器行为”面板上，单击加号 (+) 按钮并选择“显示区域”>“如果记录集不为空则显示区域”。
  3. 选择提供动态内容的记录集并单击“确定”。
  4. 对于页上的每个动态内容元素重复步骤 1 至 3。


ColdFusion 错误信息答疑

本节介绍 ColdFusion 产生的一些常见数据库错误信息，并提供解决问题的建议。


ColdFusion - 访问被拒绝

对于 ColdFusion 4 或 5，当写入基于文件的数据库（如 Microsoft Access 或 Foxpro）并且 ColdFusion 正在通过数据源访问该数据库时，此错误会出现。此错误通常在您尝试通过 FTP 或通过复制来覆盖该文件时出现。

其解决方法是将“ColdFusion 管理员”中的“数据源”部分回收或禁用“维护数据库链接”。


ColdFusion - “操作必须使用可更新查询”错误

对于 ColdFusion 4 或 5，当尝试运行从 Microsoft Access（或其他基于文件的）数据库中更新或删除的 ColdFusion 页时，此错误会出现。

出现此错误的原因通常是 ColdFusion 在网络操作系统级别不具有写入该数据库所需的正确权限。

若要在 Windows NT 中解决此问题，请单击“开始”>“设置”>“控制面板”>“服务”。双击“ColdFusion 应用程序服务器”服务并记下启动帐户。默认情况下，它应该是系统帐户。然后，转到包含该数据库文件的文件夹并明确地向记下的帐户提供对该文件夹的完全权限。即使该文件夹声明“每个人”都具有完全权限，仍要添加 ColdFusion 启动帐户。


权限问题答疑

如果您的数据库位于 Windows NT、Windows 2000 或 Windows XP 计算机上，并且您在尝试从 Web 浏览器或以“动态数据”模式查看动态页时收到错误信息，则该错误可能是由权限问题引起的。

下面的错误消息可能是由权限问题导致的：

  • 用于 ODBC 驱动程序的 Microsoft OLE DB 提供程序错误“80004005”[Microsoft][ODBC Microsoft Access 97 驱动程序] 无法使用“（未知）”；文件已在使用。
  • 用于 ODBC 驱动程序的 Microsoft OLE DB (0x80004005) [Microsoft][ODBC Microsoft Access 驱动程序] Microsoft Jet 数据库引擎无法打开文件“（未知）”。它已被其他用户以独占方式打开，或者您缺少查看其数据的权限。
  • 用于 ODBC 驱动程序的 Microsoft OLE DB 提供程序错误“80004005”[Microsoft][ODBC Microsoft Access 97 驱动程序] 无法锁定文件。

试图访问该数据库的 Windows 帐户没有足够的权限。如果已针对经身份验证的访问对该页设置了保护，则该帐户可能是匿名 Windows 帐户（默认情况下为 IUSR_computername）或特定的用户帐户。

您必须更改权限，向 IUSR_computername 帐户提供正确的权限，这样 Web 服务器才能访问该数据库文件。此外，包含该数据库文件的文件夹还必须设置某些权限才能向该数据库写入。

如果该页本该以匿名方式来访问，则请向 IUSR_computername 帐户提供对该文件夹和数据库文件的完全控制权限，如以下过程所述。

此外，如果使用 UNC (\\Server\Share) 引用数据库的路径，请确保“共享权限”向 IUSR_computername 帐户提供完全访问权。即使共享位于本地 Web 服务器，此步骤仍然适用。

如果从另一个位置复制数据库，它可能不会自动从目标文件夹继承权限。您可能需要更改数据库的权限。

若要检查或更改数据库文件权限，请执行以下操作：
  1. 在 Windows 资源管理器中，定位该数据库文件或包含该数据库的文件夹，右击该文件或文件夹，然后选择“属性”。
  2. 如果使用 Windows 2000，请选择“安全”选项卡；如果使用 Windows NT，请选择“安全”选项卡，然后单击“权限”按钮。

    3. 备注： 只有在具有 NTFS 文件系统后，此步骤才适用。如果具有 FAT 文件系统，该对话框将没有“安全”选项卡。

  3. 如果“文件权限”对话框中的 Windows 帐户中没有列出 IUSR_computername 帐户，请单击“添加”按钮添加该帐户。
  4. 在“添加用户和组”对话框中，从“列出的名称来自”弹出式菜单中选择计算机名称。

    5. 备注： 如果使用 Windows 2000，则相应对话框名称为“选择用户、计算机或组”，相应弹出式菜单名为“查找范围：”。

    出现与该计算机关联的帐户名称的列表。如果 IUSR 帐户没有出现在“名称”列表中，请单击“显示用户”按钮。

    备注： Windows 2000 没有“显示用户”按钮。

  5. 选择 IUSR_computername 帐户，然后单击“添加”。
  6. 从“访问类型”弹出式菜单中选择“完全控制”，向 IUSR 帐户分配完全权限，然后单击“确定”。

对于所添加的安全设置，可以设置权限，以便对包含该数据库的 Web 文件夹关闭读权限。浏览该文件夹的尝试将被拒绝，但 Web 页仍可以访问该数据库。

有关 IUSR 帐户和 Web 服务器权限的更多信息，请参见 Macromedia 支持中心上的技术说明：

  • Understanding anonymous authentication and the IUSR account（了解匿名身份验证和 IUSR 帐户）
  • Setting IIS web server permissions（设置 IIS Web 服务器权限）
上一页


教程

学习如何在 Dreamweaver 中执行某些特定的常见任务。

此部分包含以下各章：

  • Dreamweaver MX 教程
  • 使用表格设计页面布局教程
  • 图像对齐和图像地图教程
  • 使用 Dreamweaver 设计文件教程
  • 使用层叠样式表进行设计教程
  • 创建主详细页集教程
  • 建立插入记录页教程


Dreamweaver MX 教程

Dreamweaver MX 教程是循序渐进的课程，旨在教授 Dreamweaver MX 的基本使用常识。建议您充分使用在 Dreamweaver 应用程序文件夹中 GettingStarted 文件夹内安装的示例文件，通篇浏览本教程。

通过完成这些实践教程，您将学会如何在创建 Web 页和 Web 应用程序时使用 Dreamweaver 的可视化环境来添加设计元素。这些教程既适用于刚出道的新手，也适用于中级 Web 设计人员 -- 他们在开发 Web 页和 Web 应用程序的过程中业已初窥门径，但寻求更上层楼。

每个教程都着重于某个特定的 Web 设计功能或主题。虽然您可以只选择浏览感兴趣的部分，但我们还是建议您按顺序完成所有教程。

您还可以在 Macromedia Web 站点 找到其他教程。

下一页


学习内容

完成每个教程大约需要 30 到 45 分钟，具体取决于您的经验。这些教程涵盖下列主题和任务：

使用表格设计页面布局教程，完成它大约需要 45 分钟，它着重于下列任务：

  • 在“标准”视图中创建和修改表格
  • 向表格添加颜色
  • 在“标准”视图中设置相对宽度的表格
  • 在“布局”视图中设计页面
  • 绘制一个布局单元格

图像对齐和图像地图教程，完成它大约需要 20 到 30 分钟，它着重于下列任务：

  • 设置图像对齐方式
  • 设置图像边距
  • 设置边距和对齐选项
  • 创建图像地图
  • 设置图像地图区域
  • 在新的窗口中打开链接的文件

使用 Dreamweaver 设计文件教程，完成它大约需要 20 到 30 分钟，它着重于下列任务：

  • 使用代码片断
  • 插入代码片断
  • 修改代码片断内容
  • 将代码保存为代码片断

使用层叠样式表进行设计教程，完成它大约需要 30 分钟，它着重于下列任务：

  • 打开“CSS 样式”面板
  • 打开工作文档
  • 设置链接样式
  • 导出样式以创建外部样式表

创建主详细页集教程，完成它大约需要 30 分钟，它着重于下列任务：

  • 创建主详细页集
  • 创建数据库记录集
  • 插入主详细页集应用程序对象
  • 查看页面

建立插入记录页教程，完成它大约需要 40 分钟，它着重于下列任务：

  • 创建插入页
  • 添加表单对象
  • 定义“插入记录”服务器行为
  • 测试您的插入页
上一页


使用表格设计页面布局教程

如果您熟悉 HTML 编码，就会知道除非您将添加到 Web 页中的文本或其他任何内容插入到一个“容器”（如层或表格）中，否则它将从一个边缘流向另一个边缘。HTML 表格是一种出色的用于设计 Web 页布局的解决方案，因为它们易于修改而且与大多数浏览器兼容。您可以使用表格来组织表格数据的布局或设置可视化元素（如 Flash 按钮、图像或文本段落）的显示。

Dreamweaver 有两种视图 - “标准”视图和“布局”视图，您可以在这些视图中设计表格。本教程中，您将学习在这两种视图中设计页面布局。在本教程的第一部分，您将在“标准”视图中工作并在页面中插入表格。在后面部分，您将在“布局”视图中工作，并且使用布局选项绘制表格和表格单元格以设计布局。

本教程着重于将表格作为一种页面布局元素来使用。通过学习本教程，您将学会如何完成下列任务：

  • 在“标准”视图中创建和修改表格
  • 向表格添加颜色
  • 在“标准”视图中设置相对宽度的表格
  • 在“布局”视图中设计页面
  • 绘制一个布局单元格
  • 添加多个布局单元格
  • 移动布局单元格或调整其大小
  • 在“布局”视图中设置相对宽度的表格
  • 在“布局”视图中设计页面
下一页


开始前的准备工作

在开始本教程之前，请先创建一个用来存储 GettingStarted 示例文件的新文件夹（如果尚未创建）。

  1. 在您的本地磁盘的根目录下，创建一个新文件夹并将其命名为 Sites，例如 C:\Sites (Windows) 或 Hard Drive:Sites (Macintosh)。

    2. 如果您使用的是 Windows XP 或 Macintosh OS X，请在您的用户文件夹内创建 Sites 文件夹。

  2. 在硬盘上的 Dreamweaver 应用程序文件夹内找到 Tutorials 文件夹。该文件夹的路径是：

    3. \Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

  3. 将 Tutorial 文件夹复制到 Sites 文件夹中。
  4. 在 Dreamweaver 中，将复制的 Tutorials 文件夹定义为本地站点。如果您不知道如何在 Dreamweaver 中定义本地站点，可以参照在 Dreamweaver 中创建您的第一个 Web 站点中提供的指导。

    5. 还可以使用 Dreamweaver“站点定义”向导来完成站点的设置过程。在 Dreamweaver 中，选择“站点”>“新建站点”，然后单击“基本”选项卡开始设置站点。


在“标准”视图中创建和修改表格

“标准”视图是典型的 Dreamweaver 设计视图。若要在“标准”视图中创建表格，可以使用“插入表格”命令。Dreamweaver 将根据您在“插入表格”对话框中选择的选项创建一个表格。通过合并和拆分单元格以及插入行和列，您可以很容易地修改初始表格结构以创建更复杂的设计。

可以使用表格单元格（在表格中每一行与列的交叉处所创建的框）来控制 Web 页中文本和图像的位置。因为您可以使表格的边框变得不可见，当观众在浏览器中查看页面时就不会看到设计的基础结构。

  1. 在 Dreamweaver 中，选择“文件”>“新建”。

    2. 即出现“新建文档”对话框。

  2. 在“空文档”列表中，选择“HTML”，然后单击“创建”以创建一个新的 HTML 文档。
  3. 在“文档”工具栏的“标题”文本域中，输入“表格设计”为文档添加一个标题。
  4. 选择“文件”>“保存”将该文档保存到本地站点文件夹中。将其命名为 tableModify.htm。


插入表格

现在您就可以在文档中插入表格了。

  1. 在“文档”窗口，将插入点放到文档中，然后执行下列操作之一：
    • 选择“插入”>“表格”。
    • 在插入栏的“常用”类别中，单击“表格”图标。
      这是所描述的功能的图片。

      • 出现“插入表格”对话框。
      这是所描述的功能的图片。

  2. 在该对话框中，设置下列选项：
    • 在“行数”文本框中，键入 2。
    • 在“列数”文本框中，键入 2。
    • 在“宽度”文本框中键入 600，然后在“宽度”文本框右边的弹出式菜单中选择像素。

      • 将宽度设置为 600 像素将创建一个固定宽度的表格。稍后，我们将在本教程中更详细地讨论表格宽度。

    • 在“边框”文本框中，键入 1 将表格和表格单元格周围的边框宽度设置为 1 个像素。
      这是所描述的功能的图片。
  3. 单击“确定”。

    4. Dreamweaver 将该表格插入到文档中。
    这是所描述的功能的图片。

  4. 执行下列操作之一来保存文档：
    • 选择“文件”>“保存”。
    • 按 Ctrl+S 组合键 (Windows) 或 Command+S 组合键 (Macintosh)。


修改表格

下一步，您将修改表格的布局。您将在表格中添加行和列，并且学习如何合并和拆分单元格以创建所需的页面布局。

  1. 在左上方的单元格中单击，然后向下拖动直到最下面的行以选择左边的一列。
    这是所描述的功能的图片。
  2. 选择“修改”>“表格”>“插入列”。

    3. 现在该表格包含三列。
    这是所描述的功能的图片。

  3. 单击左下方的单元格，然后选择“修改”>“表格”>“插入行或列”。

    4. 即出现“插入行或列”对话框。
    这是所描述的功能的图片。

    提示： 如果您想要插入特定数目的行或列，或者要选择在表格中插入行或列的位置，请选择“插入行或列”选项。

  4. 在该对话框中，设置下列选项：

    5. 对于“插入”，选择行。

    在“行数”框中，键入 2。

    对于“位置”，选择 所选之上。

  5. 单击“确定”。

    6. 表格即会更新。现在您的表格为四行三列。

  6. 保存所做的更改（“文件”>“保存”）。


合并和拆分单元格

通过合并和拆分单元格，您可以自定义表格的设计以符合布局需要。接下来，您将看到如何使用菜单选项或属性检查器来合并或拆分表格单元格。

  1. 在文档中，将指针从左上方的单元格拖到它下面的一个单元格，以选择表格左列的上面两个单元格。
  2. 选择“修改”>“表格”>“合并单元格”。

    3. 两个单元格合并成一个单元格。
    这是所描述的功能的图片。

  3. 单击第二列的第三行，然后向右向下拖动以选择第二列和第三列中的最后两行单元格。
  4. 在属性检查器中，单击“合并”按钮以合并单元格。

    5. 选定的单元格合并为一个单元格。
    这是所描述的功能的图片。

您可以拆分单个的单元格或列。

  1. 单击左上方的单元格。
  2. 在属性检查器中，单击“拆分单元格”按钮。

    3. “拆分单元格”对话框出现。
    这是所描述的功能的图片。

  3. 在该对话框中，设置下列选项：
    • 对于“把单元格拆分”，选择列。
    • 在“列数”框中，输入 2。
  4. 单击“确定”。

    5. 表格即被修改。
    这是所描述的功能的图片。


更改行高和列宽

现在调整该表格的尺寸。您将要增加表格的行间距，并且调整表格列间距。

  1. 沿表格底部边框移动指针直到指针变成一个边框选择器，然后向下拖动以调整表格大小。
    这是所描述的功能的图片。

    2. 如果您愿意，还可以使用此方法调整表格中的其他行高。

  2. 沿一个列的边框移动指针直到指针变成一个边框选择器，然后向左或向右拖动它以更改列宽。
  3. 调整完成后，保存文档。


向表格添加颜色

您可以向表格的任何部分添加颜色。您将首先向整个表格添加背景颜色，然后对表格中的单元格应用不同的背景颜色。最后，您将更改边框颜色。

  1. 在文档中，单击表格的任何一个单元格，然后在位于文档窗口左下方的标签选择器中单击 <table> 标签以选择整个表格。
  2. 如果属性检查器尚未打开，则打开属性检查器（“窗口”>“属性”）。

    3. 属性检查器中出现所选表格的属性。
    这是所描述的功能的图片。

  3. 在属性检查器中，执行下列操作之一，在“背景颜色”文本框中选择一种颜色：
    • 单击颜色选择器弹出式菜单，然后从颜色选择器中选择一种颜色。
    • 输入一个十六进制的颜色值，例如 #CC9933。
    • 输入一个网页安全色名称，如 goldenrod。

      • 将一种背景颜色应用到表格。
      这是所描述的功能的图片。

  4. 用同样的方法可以将一种背景颜色应用到表格的单元格中。在左上方的单元格中单击，然后在属性检查器的“背景颜色”文本框中选择一种不同的颜色。
  5. 如果需要，还可以向其他单元格中添加颜色。


添加边框颜色

现在，您将设置表格边框的颜色。边框颜色同时应用于表格的外边框和内边框。

  1. 在文档窗口中，选择表格。
  2. 在属性检查器的“边框”文本框中，使用颜色选择器为表格选择一种边框颜色。
  3. 完成后，请保存文档。
  4. 按 F12 键（仅限于 Windows）或者选择“文件”>“在浏览器中预览”，然后选择一种浏览器以查看文档。


在“标准”视图中设置相对宽度的表格

基于百分比的表格会根据浏览器窗口宽度的变化而伸展或收缩。（例如，如果您指定表格使用 75% 的宽度，则不管浏览器窗口有多大，表格都会伸展以填充 75% 的水平间距。这在某些情况下会很有用，例如，在调整窗口大小时确保导航菜单总能显示。

如果您想设置表格的大小而不管用户如何调整浏览器窗口的大小，可以使用基于像素的表格。如果您想让表格根据浏览器窗口的大小而伸缩，最好使用基于百分比的表格。

若要查看基于百分比的表格和基于像素的表格的不同之处，您可以在页面中分别添加这两种表格，然后在浏览器中查看。

  1. 在 Dreamweaver 中，选择“文件”>“新建”。
  2. 在“新建文档”对话框中，已经选定了“基本页”类别；在“基本页”列表中，双击“HTML”创建一个新的 HTML 文档。

    3. 文档在文档窗口中打开。

  3. 将该文件保存到本地站点文件夹。将其命名为 tableWidth。
  4. 将插入点放置在文档中。
  5. 在插入栏的“常用”选项卡中，单击“表”按钮。
  6. 在出现的对话框中，设置下列选项：

    7. 在“行数”文本框中，键入 2。

    在“列数”文本框中，键入 3。

    在“宽度”文本框中，键入 90，并在“宽度”文本框右边的弹出式菜单中选择百分比。

    在“边框”文本框中，输入 1 将表格和表格单元格周围的边框宽度设置为 1 个像素。

  7. 单击“确定”。

    8. 表格即出现在文档中。

  8. 单击中间列最上方的单元格并拖动到最下方的单元格以选择中间列。
  9. 在属性检查器中，使用颜色选择器将一种背景颜色应用于该列。


创建其宽度基于像素的表格

现在您将添加另外一个表格。其宽度基于像素的表格被设置为某个特定宽度，并且不会随着浏览器窗口大小的改变而改变。

  1. 在刚刚插入的表格后面插入一个段落回车。
  2. 在插入栏的“常用”选项卡中，单击“表”按钮。
  3. 在出现的对话框中，设置下列选项：

    4. 在“行数”文本框中，键入 2。

    在“列数”文本框中，键入 3。

    在“宽度”文本框中，键入 600，然后在“宽度”文本框右边的弹出式菜单中选择像素。

    在“边框”文本框中，键入 1 将表格和表格单元格周围的边框宽度设置为 1 个像素。

  4. 单击“确定”。

    5. 表格即出现在文档中。

  5. 单击中间列的最上方单元格并向下拖动到最下方的单元格以选择中间列。
  6. 在属性检查器中，使用颜色选择器将一种背景颜色应用于该列。
    这是所描述的功能的图片。
  7. 按 F12 键（仅限于 Windows）或者选择“文件”>“在浏览器中预览”，然后选择一种浏览器以查看文档。

    8. 调整浏览器窗口大小以查看在浏览器窗口改变时，这两个表格是怎样变化的。基于像素的表格保持大小不变，而基于百分比的表格则调整大小以符合浏览器大小。

  8. 文档查看完毕后，请关闭浏览器窗口。
  9. 保存文档。


在“布局”视图中设计页面

现在，您已经学会了如何使用“插入表格”命令，让我们看看另外一种处理表格的方法，即绘制表格布局。

接下来，您将在“布局”视图中工作，该视图允许您绘制布局单元格或布局表格并在其中添加各种内容，例如图像、文本或其他媒体等。

在“布局”视图中，您可以绘制布局单元格或布局表格以定义文档的设计区域。您可以从插入一个表格单元格或布局单元格开始。当您首先插入一个布局单元格时，Dreamweaver 将自动创建一个表格来环绕该单元格。


创建和保存新文档

  1. 在 Dreamweaver 中，选择“文件”>“新建”。
  2. 在“新建文档”对话框中，已经选定“基本页”类别。在“基本页”列表中选择“HTML”，然后单击“创建”创建一个新的 HTML 文档。

    3. 文档在文档窗口中打开。

  3. 将该文档保存到您的本地站点文件夹中，并将其命名为 tableLayout.htm。


绘制一个布局单元格

  1. 在插入栏中，单击“布局”选项卡，然后单击“布局视图”按钮从“标准”视图切换过来。
    这是所描述的功能的图片。

    2. “从布局视图开始”对话框出现，描述了“布局”视图的选项。

  2. 查看这些选项，然后单击“确定”关闭对话框。
  3. 在插入栏中提供了两个可用的“布局”选项- “绘制布局单元格”和“绘制布局表格”；这两个选项在“标准”视图中不提供。
  4. 如果属性检查器尚未打开，请选择“窗口”>“属性”将其打开。
  5. 在插入栏中，单击“绘制布局单元格”按钮。
  6. 将指针移到文档窗口；鼠标指针变成一个绘制工具（看起来像一个小十字架）。单击文档的左上角，然后拖动以绘制一个布局单元格。

    7. 释放鼠标键后，布局表格中即出现一个布局单元格。
    这是所描述的功能的图片。

    布局表格将扩展以符合文档窗口的大小，并设置页面的布局区域。白色的矩形是您刚绘制的布局单元格。您可以在布局表格的空区域内放置更多的布局单元格。

  7. 绘制另外一个单元格以便在导航按钮的上方创建一个文本区域。
    这是所描述的功能的图片。


添加多个布局单元格

接下来，您将学会如何添加一系列的布局单元格。您将在刚才创建的单元格旁边再添加三个布局单元格，以便为页面的导航按钮创建布局。

  1. 在插入栏中，单击“绘制布局单元格”按钮；然后，按住 Control 键 (Windows) 或 Command 键 (Macintosh)，以便能在表格中绘制多个单元格。
  2. 在文档窗口中，将指针放在最后绘制的那个单元格的下方，然后拖动以绘制一个布局单元格。

    3. 继续按住 Control 键 (Windows) 或 Command 键 (Macintosh)，再绘制两个布局单元格。您的屏幕看起来应该与此相似：
    这是所描述的功能的图片。

  3. 在插入栏的空白区域内单击，取消对“绘制布局单元格”工具的选择。（绘制工具将更改为选择箭头。）


移动布局单元格或调整其大小

如果您需要将单元格排成一行，您可以调整布局单元格的大小并移动它们。您可以使用布局单元格的任一调整大小手柄来改变它的大小。

只要布局表格中还有重新定位单元格所需的空间，您就可以将布局单元格移动到文档中的新位置。有时，为了进行所需的改动，您必须调整周围单元格的大小。如果您想移动一个布局单元格以在文档中重新定位，请遵循下列步骤。

  1. 单击布局单元格的边框以选择它。

    2. 在所选布局单元格的周围出现手柄。
    这是所描述的功能的图片。

  2. 执行下列操作之一：
    • 拖动该布局单元格将其移动到另外一个位置。
    • 如果布局单元格周围有空间，请相应使用向左、向右或向上箭头移动该单元格。


调整布局单元格的大小

若要精确地设计页面，您可以设置添加到文档中的单元格的大小。还可以在页面中重新定位单元格。

  1. 单击布局单元格的边框以选择它。
  2. 若要调整布局单元格的大小，请执行以下操作：

    3. 在该布局单元格的属性检查器中，键入所需的单元格宽度和高度值。例如，在“高度”文本框中键入 200 将单元格的高度设置为 200 个像素，然后在文档中单击以查看单元格宽度的变化。

备注： 如果您输入的以像素为单位的宽度或高度超过了布局表格的尺寸，或者导致该单元格覆盖了布局表格中的其他单元格，Dreamweaver 将会发出警告并将单元格宽度调整到一个有效的宽度。


向表格中添加颜色

您可以向表格的任何部分添加颜色。您将首先向整个表格添加背景颜色，然后对表格中的单元格应用不同的背景颜色。最后，您将更改边框颜色。

  1. 在文档中，单击表格的任何一个单元格，然后在位于文档窗口左下方的标签选择器中单击 <table> 标签以选择整个表格。
  2. 如果属性检查器尚未打开，则打开属性检查器（“窗口”>“属性”）。

    3. 属性检查器中出现所选表格的属性。
    这是所描述的功能的图片。

  3. 在属性检查器中的“背景颜色”文本框中，执行下列操作之一来选择一种颜色：
    • 单击颜色选择器弹出式菜单，然后从颜色选择器中选择一种颜色。
    • 输入一个十六进制的颜色值，例如 #CC9933。
    • 输入一个网页安全色名称，如 goldenrod。

      • 即将一种背景颜色应用到表格中。

  4. 单击单元格边框以选择该单元格，然后在属性检查器中选择要应用到该单元格的颜色。
  5. 如果愿意，可以向表格中的其他单元格添加背景颜色。
    这是所描述的功能的图片。
  6. 保存文档。


在“布局”视图中设置相对宽度的表格

默认情况下，当您在“布局”视图中绘制表格或单元格时，Dreamweaver 将创建具有固定列宽的表格。您可以使用“自动伸展”功能将固定宽度的表格或单元格更改为相对宽度的表格或单元格。

“自动伸展”功能允许您创建一个相对宽度的表格，并对您设置的可伸展的列应用灵活的布局，以便表格能够自动伸缩以符合浏览器窗口的大小。

有关列宽的信息出现在每个表格列上方的列标题区域。表格宽度信息出现在表格的列标题中。固定宽度的列具有特定的宽度值，如 200 像素，而自动伸展列的列标题则包含一条波浪线。在一个表格中，您只能让一个列自动伸展。您可以很容易地更改将自动伸展应用到哪个列。

您将把表格中的某一列设置为自动伸展，以便在查看表格时表格符合浏览器窗口的大小。

  1. 在文档的列标题中，单击您想使其自动伸展的表格列。
    这是所描述的功能的图片。
  2. 在出现的弹出式菜单中选择“列设置为自动伸展”。

    3. 即会出现“选择间隔图像”对话框。

  3. 在该对话框中，选择“创建间隔图像文件”。
  4. 出现“保存间隔图像文件为”对话框，接受默认值以将图像命名为 spacer.gif 并保存到一个相对于站点根目录的位置。

    5. 提示： 如果您已有一个间隔图像，则可选择该图像，那样就不用为设计的每个表格创建不同的间隔图像。

    列标题从数值更改为一条波浪线。属性检查器也将更新以反映对表格应用了自动伸展这一情况。

  5. 保存文件。
  6. 选择“文件”>“在浏览器中预览”，并选择用来查看页面的浏览器。

    7. 根据浏览器窗口大小的变化，列将自动伸展和收缩。


执行下一个步骤

在本教程中，您已经学会了如何在 Dreamweaver 中创建表格。在学习过程中，您修改了表格行和列，为表格元素设置了背景颜色，并且学会了如何在“标准”视图和“布局”视图中创建“灵活”的表格设计。

有关本教程涉及到的主题的详细信息，请参阅《使用 Dreamweaver MX 》文档或 Dreamweaver 帮助中的下列主题：

  • 设计页面布局
  • 用表格展示内容
上一页


图像对齐和图像地图教程

在 Macromedia Dreamweaver MX 中处理图像非常容易。可以使用各种 Dreamweaver 可视工具插入图像。本教程为您提供了图像选项，将图像插入页面后就可以应用这些选项。您将学习如何对齐图像和文本以及如何设置图像周围的边距。您还将学习如何使用单个图像链接到多个 Web 页。

本教程专为第一次使用 Dreamweaver 的用户设计。它介绍了 Dreamweaver 中的一些基本功能，并将帮助您了解如何对齐图像以及如何创建图像地图。

在本教程中，您将完成下列任务：

  • 设置图像对齐方式
  • 设置图像边距
  • 设置边距和对齐选项
  • 创建图像地图
  • 设置图像地图区域
  • 在新的窗口中打开链接的文件
下一页


开始前的准备工作

在开始本教程之前，请先创建一个用来存储 GettingStarted 示例文件的新文件夹（如果尚未创建）。

  1. 在本地磁盘的根目录下，创建一个新的文件夹并将其命名为 Sites，例如 C:\Sites (Windows) 或 Hard Drive:Sites (Macintosh)。

    2. 如果使用的是 Windows XP 或 Macintosh OS X，请在用户文件夹中创建 Sites 文件夹。

  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 Tutorials 文件夹。此文件夹的路径是：

    3. \Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

  3. 将 Tutorial 文件夹复制到 Sites 文件夹中。
  4. 在 Dreamweaver 中，将复制的 Tutorials 文件夹定义为本地站点。如果您不知道如何在 Dreamweaver 中定义本地站点，可以遵循在 Dreamweaver 中创建您的第一个 Web 站点中提供的说明。

也可以使用 Dreamweaver 站点定义向导来指导您完成站点设置过程。在 Dreamweaver 中，选择“站点”>“新建站点”，然后单击“基本”选项卡开始设置站点。


设置图像对齐方式

与文本一样，图像也出现在页面中的正常 HTML 流中，并且可以单独显示为一个段落或者显示为文本段落的一部分。在属性检查器中，可以使用文本对齐控件或图像对齐控件，以两种方法设置图像的对齐方式。

“文本对齐方式”定位图像插入到的段落的位置，并且可用于将图像与左边距对齐、与右边距对齐或居中对齐。“图像对齐方式”使您可以设置图像与同一段落中的其他内容（包括另一个图像）之间的关系。在 Dreamweaver 中，“对齐”弹出菜单使您可以选择图像与文本对齐的方式。

备注： 并不是所有的图像对齐选项在所有的浏览器中都有效。在本教程中，您将使用在 Microsoft Internet Explorer 和 Netscape Navigator 中有效的对齐选项。


查看已完成的文档

开始前，请查看已完成的文件，了解您将在本教程中学习完成的内容。

  1. 选择“文件”>“打开”，在出现的对话框中定位到所创建的 GettingStarted 文件夹，然后定位到 Tutorials/Completed 并打开名为 imageAlign_comp.htm 的文件。

    2. 此文件在“文档”窗口中打开。

  2. 按 F12 键（仅限于 Windows）或选择“文件”>“在浏览器中预览”并选择一个要在其中查看文档的浏览器。

    3. 此文件同时显示三个示例，它们使用适用于图像和文本的图像对齐方式和边距。

  3. 查看完此文件后关闭浏览器窗口。


打开工作文件

您将在一个部分完成的文档中工作，它在一个表格中包含三个图像和文本。该表格限定了布局，使您能够方便地看到不同的设置如何影响对齐方式。

  1. 选择“文件”>“打开”并定位到位于 Tutorials 文件夹中的 imageAlign.htm 文件。该文档与先前查看的已完成文件包含相同的图像和文本。

在“文档”窗口中，单击第一个图像（在包含文本对齐方式的表格单元格旁边）。

图像在文本所在的同一段落中。

  1. 如果属性检查器尚未打开，请将其打开（“窗口”>“属性”）。
    这是所描述的功能的图片。

    2. 在“对齐”文本框中，注意这是图像的默认对齐方式。它将图像放在文本行的基线上。

  2. 在图像仍为选中的情况下，在“对齐”弹出菜单中选择“中间”来查看该设置的效果。

    3. 第一行文本与图像的中间对齐。

  3. 在图像仍为选中时，在“对齐”弹出菜单中选择“左对齐”。

    4. 现在图像出现在左侧，文本环绕在其右侧。

    提示： 与图像位于同一段落中的文本环绕在图像周围然后流到图像的下方。如果在流动的段落中插入一个段落回车符，则它不再与图像对齐，而是出现在图像下方的新段落中。如果想在不破坏文本环绕的情况下添加边距，请使用分段符 Control+Enter (Windows) 或 Command+Return (Macintosh)。

  4. 选择“文件”>“保存”以保存更改。
  5. 选择“文件”>“在浏览器中预览”，然后选择一个要在其中预览文档的浏览器，或者按 F12 键（仅限于 Windows）在浏览器窗口中查看文档。

    6. 您将看到图像和文本已对齐。

  6. 查看完文件后，关闭浏览器窗口。


设置图像边距

正如您所看到的，将图像放在段落中时，文本紧挨着图像的边缘显示。在下一步中，您将在图像和文本之间添加边距。

可以使用属性检查器中的水平和垂直边距属性在图像周围创建边距。水平边距属性在图像的左侧和右侧添加边距，而垂直边距在图像的上方和下方添加边距。

  1. 在 image_align.htm 文档中，单击页面中的第二个图像（在包含文本“Spacing”的表格单元格旁边）。
  2. 在属性检查器中，在“垂直边距”文本框中输入 10 设置垂直边距。
  3. 将指针移到“水平边距”文本框中，输入 30，然后按 Enter 或 Return 键设置水平边距。
    这是所描述的功能的图片。

    4. 文本和图像之间随即创建一个边距。边距也影响图像和表格边框之间的距离。


设置边距和对齐选项

作为本教程这一部分的最后一步，您将为图像设置对齐和边距属性。

  1. 在 imageAlign.htm 文档中，单击页面中的第三个图像（在包含文本“Alignment and Spacing”的表格单元格旁边）。
  2. 在属性检查器中，在“对齐”弹出菜单中选择“右对齐”。

    3. 图像移到右侧。

  3. 在“水平边距”文本框中，输入 30，然后在属性检查器或“文档”窗口中的其他某个位置单击以使值更新。

    4. 图像和文本之间随即添加边距。


创建图像地图

图像地图是作为导航设备使用的图像。使用图像地图，可以在单个图像中创建多个热点（可单击的区域）并使每一个热点链接到一个不同的要打开的 URL 或文件。也可以设置链接文档的打开位置，例如可以在框架页文档的特定框架中打开文档，或在一个新的浏览器窗口中打开它。


查看已完成的文件

查看已完成的文件，了解将要创建的内容。完成的图像地图包含到其他文档的链接。您将在浏览器窗口中打开文档，查看链接是如何工作的。

  1. 选择“文件”>“打开”，在出现的对话框中，定位到所创建的 GettingStarted 文件夹，然后定位到 Tutorials/Completed 并打开名为 imagemap_comp.htm 的文件。

    2. 文档随即在“文档”窗口中打开。

  2. 按 F12 键（仅限于 Windows）或选择“文件”>“在浏览器中预览”，然后选择要在其中查看文档的浏览器。
    这是所描述的功能的图片。
  3. 在淡紫色区域上滚动指针。指针变为一个手的图形，向您表明该区域链接到另一个文档。
  4. 单击“North America”。

    5. 一个新的页面随即打开。

  5. 单击浏览器的后退按钮返回到世界地图页面。
  6. 单击另一个热点。

    7. 链接的文档在一个新的浏览器窗口中打开。

  7. 查看完页面后，关闭浏览器。


设置图像地图区域

您将创建一个图像地图，使单个图像链接到多个页面。

  1. 在 Dreamweaver 中选择“文件”>“打开”，然后定位到并打开名为 imagemap_start.htm 的文件。
  2. 在文档中单击世界地图的图像以选择它。
  3. 如果属性检查器尚未打开，则将它打开。如有必要，可再单击属性检查器右下方的扩展箭头以查看所有图像属性。
    这是所描述的功能的图片。

    4. 图像地图选项随即出现在展开的属性检查器中。

  4. 在“地图”文本框中，键入 Locations。

    5. 提示： 如果在一个文档中创建多个图像地图，那么每个地图必须有一个唯一的名称。每个图像地图也可以有多个热点。

  5. 单击“矩形热点工具”选择它。
  6. 在“文档”窗口中，在“North America”上方和左侧的区域内单击，然后将指针向右下方拖动到图像上以创建热点区域。
    这是所描述的功能的图片。

    7. 一个蓝色的层出现在图像上，并且热点属性检查器出现。
    这是所描述的功能的图片。

  7. 在“链接”文本框中，单击文件夹图标。在出现的对话框中，定位到名为 location1.htm 的文件以设置到它的链接。
  8. 在“替代”文本框中，键入 North America。

    9. 备注： 应该始终为文档中的图像（包括图像地图）设置替换文本框，这样可以为使用纯文本浏览器的页面查看者提供有关图像的说明信息。

就是这样 ， 您已设置了第一个热点。让我们再设置一个热点。


在新的窗口中打开链接的文件

您已看到各种热点工具的不同之处，这次您将使用“多边形热点”工具定义热点区域。多边形工具使您能够设置连接点以定义热点区域。

您还将学习如何在新的窗口中打开链接的文档。

  1. 在属性检查器中，单击“多边形热点工具”选择它。
  2. 在“文档”窗口中，单击希望热点从其中开始的图像，并将指针移到下一个位置；两个点之间形成一条直线。
  3. 继续在图形周围单击，将“Europe”定义为热点区域。

    4. 备注： 图像地图区域随着您的单击不断地调整和填充，请在图形周围不停地单击以覆盖要包括的区域。

  4. 绘制完图像地图后，单击属性检查器中的箭头按钮更改绘制工具的指针。
    这是所描述的功能的图片。
  5. 在“链接”文本框中，单击文件夹图标，然后浏览到名为 location3.htm 的文件并在单击热点时打开该文件。
  6. 在“目标”弹出菜单中，选择“_blank”。

    7. 当用户单击热点时，“Locations3”页将在新的窗口中打开。

  7. 在“替代”文本框中，输入 Europe。
  8. 按 F12 键（仅限于 Windows）或选择“文件”>“在浏览器中预览”，然后选择一个要在其中查看文档和测试链接的浏览器。
  9. 保存和关闭文件。


继续下面的学习

在本教程中您接触了图像的几个方面。您学习了如何使用属性检查器设置图像对齐方式、定义图像周围的边距以及创建图像地图。

有关本教程所讲述的主题的更多信息，请参阅“插入图像”一章和《使用 Dreamweaver MX》 文档和 Dreamweaver 帮助中的“链接和导航”一章。

您对下面的主题可能同样感兴趣：

  • 层叠样式表（定位）
  • 表格对齐
  • 附加行为
上一页


使用 Dreamweaver 设计文件教程

Macromedia Dreamweaver MX 随附了大量的专业化设计资源 - 页面布局文档、层叠样式表 (CSS) 和代码片断。可以使用这些资源快速学习如何创建专业化设计 Web 页。

在本教程中，您将创建一个新文档，然后插入和修改设计元素代码片断。您还将学习如何创建自己的代码片断。

本教程重点介绍以下任务：

  • 使用代码片断
  • 插入代码片断
  • 修改代码片断内容
  • 将代码保存为代码片断
下一页


开始前的准备工作

在开始本教程之前，请先创建一个用来存储 GettingStarted 示例文件的新文件夹（如果尚未创建）。

  1. 在本地磁盘的根目录下创建一个新文件夹，将其命名为 Sites，例如，C:\Sites (Windows) 或 Hard Drive:Sites (Macintosh)。

    2. 如果使用的是 Windows XP 或 Macintosh OS X，请在用户文件夹中创建 Sites 文件夹。

  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 Tutorials 文件夹。该文件夹的路径为：

    3. \Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

  3. 将 Tutorial 文件夹复制到 Sites 文件夹中。
  4. 在 Dreamweaver 中，将复制的 Tutorials 文件夹定义为本地站点。如果不知道如何在 Dreamweaver 中定义本地站点，请按照在 Dreamweaver 中创建您的第一个 Web 站点中提供的说明进行操作。

    5. 还可以使用 Dreamweaver“站点定义”向导来完成站点的设置过程。 在 Dreamweaver 中选择“站点”>“新建站点”，然后单击“基本”选项卡开始设置站点。


使用代码片断

对于创建具有专业化外观的页面布局而言，使用代码片断可以说是一种真正省时的方法。代码片断是可重用的代码块。您既可以插入 Dreamweaver 随附的现有代码片断，也可以轻松地创建自己的代码片断以在站点的页面中重新使用。可以创建 HTML、JavaScript、CFML、ASP、JSP 以及其他格式的代码片断。

首先，您将使用 Dreamweaver 随附的一些代码片断。

可以在“新建文档”对话框中创建一个基于“页面设计”文档的新文档。

  1. 选择“文件”>“新建”。

    2. 出现“新建文档”对话框。

  2. 在“常规”选项卡中，“基本页”类别已被选中。
  3. 在“基本页”文档列表中选择“HTML”，然后单击“创建”。

    4. 文档随即在“文档”窗口中打开。

  4. 在站点中将文档保存为 myCodeSnippets（“文件”>“保存”）。


插入代码片断

Dreamweaver 随附了各种可供选择的代码片断。这些代码片断位于“代码”面板中。当完成本教程时，您将插入导航代码片断、内容代码片断和脚注代码片断。

  1. 将插入点放在文档中希望插入代码片断的位置。
  2. 执行下列操作之一打开“代码片断”面板：
    • 选择“窗口”>“片断”。
    • 在“代码”面板中，单击扩展箭头（如果需要的话），然后选择“代码片断”。

      • 出现“代码片断”面板。
      这是所描述的功能的图片。

  3. 单击“导航”文件夹前面的加号 (+) 按钮查看其内容。

    4. 出现其他的文件夹。

  4. 单击 Tab 文件夹前面的加号 (+) 按钮查看其内容，然后单击 Basic Tab 以选中它。

    5. 代码片断随即显示在预览窗格中。
    这是所描述的功能的图片。

  5. 在“代码片断”面板中，单击位于“代码片断”面板底部的“插入”按钮将代码片断插入到文档中。

    6. 代码片断随即出现在文档中。
    这是所描述的功能的图片。

  6. 保存文档（“文件”>“保存”）。


添加内容代码片断

接下来，您将添加一个向其中添加内容的表格。您将在刚插入的导航表格代码片断的正下方插入代码片断。

  1. 按 Enter 键或 Return 键将插入点移到下一行。
  2. 在“代码片断”面板中，单击“内容表”文件夹前面的加号 (+) 按钮，然后单击“单像素宽的边框”文件夹前面的加号 (+) 按钮查看该文件夹中的代码片断。
  3. 单击“文本 B”选中它，然后单击“插入”将代码片断插入到文档中。

    4. 代码片断随即出现在文档中。
    这是所描述的功能的图片。

  4. 保存文档（“文件”>“保存”）。


添加脚注代码片断

现在，您将添加最后一种代码片断，即脚注内容代码片断。

  1. 按 Enter 键或 Return 键将插入点移到下一行。
  2. 在“代码片断”面板中，单击“页脚”文件夹前面的加号 (+) 按钮查看该文件夹中的代码片断。
  3. 单击“基本：摘要文本”以选中它，然后单击“插入”将代码片断插入到文档中。

    4. 代码片断随即出现在文档中。
    这是所描述的功能的图片。


修改代码片断内容

接下来，您将编辑占位符文本并应用颜色更改。您将对单元格应用背景颜色以设置您自己的配色方案。

  1. 如果属性检查器尚未打开，请将其打开（“窗口”>“属性”）。
  2. 将指针放在已插入的导航表格的第一个单元格中。该单元格包含文本“Lorem”。
  3. 在属性检查器的“背景”文本框中，单击颜色样本上的箭头以打开颜色选择器，然后选择一种颜色将其应用于此单元格的背景。

    4. 这里我们使用了紫色 #9966FF。

  4. 将指针放在包含文本“Ipsum”的单元格中。
  5. 在属性检查器的“背景”文本框中，单击颜色样本上的箭头，然后选择一种不同的颜色应用于此单元格的背景。

    6. 这里我们使用了浅紫色 #9999FF。

  6. 重复第 5 步，将同一种颜色应用于包含文本“Dolor”和“Amit”的单元格。
  7. 在包含文本内容的表格单元格中单击，然后选择一种颜色应用于该表格单元格。
  8. 进行其他所需的更改。
    这是所描述的功能的图片。
  9. 完成后保存文档。
  10. 按 F12 键（仅限于 Windows）或选择“文件”>“在浏览器中预览”，然后选择要在其中查看文档的浏览器。


将代码保存为代码片断

使用现有的代码片断非常容易，就象创建您自己的代码片断一样容易。例如，假设您想重新使用在刚创建的文档中更新的代码片断。

让我们将导航代码片断另存为新的代码片断。

  1. 在“代码片断”面板中，定位到“导航”文件夹，然后定位到 Tab 文件夹以选择将保存代码片断的文件夹。
  2. 在“文档”窗口中，单击包含文本“Lorem”的导航单元格。
  3. 在位于文档窗口左下方的标签选择器中，单击 <table> 标签。
    这是所描述的功能的图片。

    4. 在“文档”窗口中，表格被选定。

  4. 执行下列操作之一将选定内容保存为代码片断：
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 所选表格，然后选择“创建新代码片断”。
    • 在“代码片断”面板中，单击位于面板底部的加号 (+) 按钮。
      这是所描述的功能的图片。

      • 出现“代码片断”对话框。
      这是所描述的功能的图片。

  5. 在“名称”文本框中，输入描述代码片断的名称。

    6. 这里我们将代码片断示例命名为 purple navigation。

  6. 在“描述”中，输入关于代码片断的描述。
  7. 在“代码片断”面板中的代码片断名称右侧可以查看代码片断描述。
  8. 对于“代码片断类型”，选择“插入块”。这将插入完整代码块形式的代码片断，而不是环绕在应用于的文本周围的代码片断。
  9. 单击“确定”。
  10. 在“代码片断”面板中，新代码片断添加到 Tab 文件夹中。


继续下面的学习

在本教程中，您学习了如何定位、查看和插入 Dreamweaver 随附的代码片断。您还了解到创建自己的代码片断是一项很容易完成的任务。

有关本教程所介绍的主题的更多信息，请参阅Dreamweaver 中的编码。

上一页


使用层叠样式表进行设计教程

可以在 Macromedia Dreamweaver MX 中使用层叠样式表 (CSS)，在站点的多个页面中以一致的方式应用样式元素。CSS 样式非常灵活，因为样式并不局限于文本对象。对于文本、图像、表格、层等都可以定义定位样式和格式化样式。

在本教程中，您可以试用几种样式，大概了解一下 CSS 为您提供的众多样式选项中的几种。

在本教程中，您将完成以下任务：

打开“CSS 样式”面板

重定义 HTML 标签

设置链接样式

导出样式以创建外部样式表

下一页


开始前的准备工作

在开始本教程之前，请先创建一个用来存储 GettingStarted 示例文件的新文件夹（如果尚未创建）。

  1. 在本地磁盘的根目录下创建一个新文件夹，并将其命名为 Sites，例如，C:\Sites (Windows) 或 Hard Drive:Sites (Macintosh)。

    2. 如果使用的是 Windows XP 或 Macintosh OS X，请在用户文件夹中创建 Sites 文件夹。

  2. 在硬盘上的 Dreamweaver 应用程序文件夹中找到 Tutorials 文件夹。该文件夹的路径为：

    3. \Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

  3. 将 Tutorials 文件夹复制到 Sites 文件夹中。
  4. 在 Dreamweaver 中将复制的 Tutorials 文件夹定义为本地站点。如果不知道如何在 Dreamweaver 中定义本地站点，可以按照在 Dreamweaver 中创建您的第一个 Web 站点中提供的说明进行操作。

    5. 还可以使用 Dreamweaver“站点定义”向导来完成站点的设置过程。在 Dreamweaver 中选择“站点”>“新建站点”，然后单击“基本”选项卡开始设置站点。


打开工作文档

首先，您将打开一个工作文档。

  1. 在 Dreamweaver 中选择“文件”>“打开”。
  2. 在出现的对话框中，定位到所定义的本地站点中的 Tutorials 文件夹，然后双击名为 css_start.htm 的文件以选择它。

    3. 此文档随即在“文档”窗口中打开。
    这是所描述的功能的图片。

此文档包含几种元素 - 文本、表格和链接。页面中几乎没有一种元素应用了格式化样式。通过重定义 body 标签，您将定义对文档应用全局更改的样式。


打开“CSS 样式”面板

使用“CSS 样式”面板可以创建、查看、应用或编辑样式属性。

“CSS 样式”面板具有两种视图或模式。使用“应用样式”视图可应用自定义或类 CSS 样式；使用“编辑样式”视图可以对已应用于文档的样式进行更改。在这两种视图中工作时都可以创建新样式。

  1. 如果“CSS 样式”面板尚未打开，请打开它（“窗口”>“CSS 样式”）。
    这是所描述的功能的图片。
  2. 在“CSS 样式”面板中，单击面板底部的“新建 CSS 样式”按钮 (+)。

    3. “新建 CSS 样式”对话框随即出现。
    这是所描述的功能的图片。


重定义 HTML 标签

对文档中的任何标签都可以应用 CSS 样式。您要创建的第一种样式将重定义 body 标签的样式属性。

  1. 在“新建 CSS 样式”对话框中，对于“类型”选择“重定义 HTML 标签”。
  2. 在“标签”弹出菜单中选择“body”。
  3. 在“定义在”中选择“仅对该文档”。

    4. 从现在起，我们将对此文档应用该样式，稍后您会看到如何导出该样式，以便可以在站点的其他页面中使用它。您的对话框应类似于下面这样：
    这是所描述的功能的图片。

  4. 单击“确定”。

    5. “CSS 样式定义”对话框随即出现。
    这是所描述的功能的图片。

  5. 设置下列“类型”设置：

    6. 在“字体”弹出菜单中选择“Arial, Helvetica, sans serif”。

  6. 在“大小”弹出菜单中选择 12 和像素。
  7. 在“颜色”中单击颜色选择器，然后使用滴管选择白色。


设置页面背景颜色

接下来，您将使用“CSS 样式”面板中的“背景”类别设置背景选项。

  1. 在“分类”下选择“背景”。

    2. CSS 背景属性随即出现。
    这是所描述的功能的图片。

  2. 在“背景颜色”中，执行下列操作之一设置背景颜色：
    • 单击颜色选择器，然后使用滴管选择深蓝色；或者将滴管移到“文档”窗口中，然后在“全局”徽标图像中选择蓝色。
    • 在“背景颜色”文本框中输入 #333366。
  3. 单击“确定”。

    4. 对话框关闭，样式立即应用于文档。
    这是所描述的功能的图片。

  4. 在“CSS 样式”面板中选择“编辑样式”。
    这是所描述的功能的图片。

    5. 新样式连同样式属性说明一起出现在列表中。


设置链接样式

应用新样式后，几乎区分不出文档中的超级链接。让我们创建一种链接样式。

  1. 在“CSS 样式”面板中，单击位于面板底部的“新建 CSS 样式”按钮 (+)。

    2. “新建 CSS 样式”对话框随即出现。

  2. 在“类型”中选择“使用 CSS 选择器”。
  3. 在“选择器”弹出菜单中选择“a:link”。
  4. 在“定义在”中选择“仅对该文档”。
  5. 单击“确定”。

    6. “CSS 样式定义”对话框随即出现。
    这是所描述的功能的图片。

  6. 为链接设置下列“类型”属性：

    7. 在“修饰”中选择“上划线”。

    在“颜色”中的文本框中输入 #FFCC99。

  7. 单击“确定”。
  8. 要看到应用于链接的样式，必须在浏览器中查看页面，按 F12 键可以预览页面。


导出样式以创建外部样式表

您到目前为止所创建的 CSS 样式仅应用于此文档。内部样式表仅应用于用来创建它们的文档。现在，您将学习如何创建一个外部样式表，它包含您在此文档中定义的样式。

  1. 选择“文件”>“导出”>“导出 CSS 样式”。

    2. “导出 CSS 样式”对话框随即出现。

  2. 在该对话框的“保存在”(Windows) 或“位置”(Macintosh) 弹出式菜单中，定位到您的本地站点文件夹。
  3. 在“文件名”(Windows) 或“另存为”(Macintosh) 中，将该文件命名为 mystyle.css。

    4. 备注： 可以将 CSS 样式表命名为您希望的任何名称；但下面的情况除外，即名称必须小写并且不能包含空格。

  4. 单击“保存”。


附加外部样式表

您将把刚才创建的 CSS 样式表附加到站点内的另一个文档中。您将使用的文档与应用样式前的原始 css_start.htm 文件相同。

  1. 在 Dreamweaver 中，如果“站点”面板尚未打开，请打开它（“窗口”>“站点”）。
  2. 在“站点”面板中找到名为 css_start2.htm 的文件，然后双击它在“文档”窗口中将其打开。
  3. 在“CSS 样式”面板中，单击位于面板底部的“附加样式表”按钮。
    这是所描述的功能的图片。

    4. “链接外部样式表”对话框随即出现。

  4. 在“文件/URL”文本框中输入 mystyle.css 的路径；或者单击“浏览”并在出现的对话框中定位到 mystyle.css 文件，然后单击“确认”选择它。
  5. 在“链接外部样式表”对话框中，对于“添加为”选择“链接”。
    这是所描述的功能的图片。
  6. 单击“确定”。

    7. 所选样式表随即链接到当前文档，而样式属性也立即应用。


继续下面的学习

在本教程中，您学习了如何创建基本的 CSS 样式。还学习了如何导出在文档中应用的样式以创建外部 CSS 样式表。有关使用 Dreamweaver 随附的 CSS 样式表的信息，请参阅创建基于 Dreamweaver 设计文件的文档。

有关本教程所讲述的主题的更多信息，请参阅下列主题：

关于层叠样式表

创建新的 CSS 样式

创建和链接到外部 CSS 样式表

上一页


创建主详细页集教程

主详细页集是一种 Web 应用程序，它以两种格式提供从数据库中提取的信息。主页显示通过数据库搜索检索到的所有记录的列表。详细页从主页链接出来，通常提供有关主页中所选项目的更具体细节。

您可以在以下服务器模型中完成本教程：ColdFusion、ASP 和 JSP。

在本教程中，您将创建一个主详细页集。完成本教程大约需要 20 分钟（视您的经验而定），您将学习如何执行以下任务：

  • 创建主详细页集
  • 创建数据库记录集
  • 插入主详细页集应用程序对象
  • 查看页面
下一页


开始前的准备工作

如果您完成了本指南《Dreamweaver MX 入门》小节中的在 Dreamweaver MX 中开发 Web 应用程序，那么完成本教程所需的文件已经位于您的本地站点和远程站点中。

如果您没有完成这节课，则需要将“示例”文件传送到您的本地驱动器和应用程序服务器中。有关如何设置文件的说明，请参阅 Web 应用程序服务器的相关设置章节。

示例 ColdFusion 站点的设置

示例 ASP 站点的设置

示例 JSP 站点的设置

在开始学习本教程之前，必须已经完成了下列任务：

  • 配置好系统。
  • 将 Dreamweaver 配置成与所选应用程序服务器一起运行。
  • 定义好数据库连接。


创建主详细页集

数据库应用程序开发的一个好的起点是显示存储在数据库中的记录列表。您开发的主详细页集将列出公司的汽车租位，以及有关每个位置的详细信息（如电话号码和地址）。

有关 Global 位置的所有信息都存储在 Microsoft Access 数据库文件 global.mdb 中。如果您遵循了本指南相关设置章节中的说明，则您应该已经与此数据库建立了连接。如果不连接到此数据库，Web 应用程序页面将不会更新。

让我们首先选择一个工作页面。

  1. 执行下列操作之一打开“站点”面板：
    • 在“文件”面板组中，单击扩展箭头，然后选择“站点”选项卡（如果尚未选择）。
    • 选择“窗口”>“站点”。
    • 按 F8 键。

      • “站点”面板随即打开。
      这是所描述的功能的图片。

  2. 在“站点”弹出菜单中，选择所定义的 GlobalCar 站点。
  3. 在“站点”面板中，双击 locationMaster 文件将其打开。

    4. 文档随即在“文档”窗口中打开。您将对部分完成的页面进行编辑。
    这是所描述的功能的图片。


创建数据库记录集

现在您将创建一个记录集以显示存储在数据库中的数据。记录集是通过数据库查询从数据库中提取的信息的子集。（在 ASP.NET 中，记录集称为数据集。）数据库查询由搜索条件组成，后者定义记录集中包含的内容。然后您将使用提取的信息作为动态页面的数据源。

Dreamweaver MX 为创建简单的 SQL 查询提供了一个方便易用的界面 - 不懂 SQL 也可以在 Dreamweaver 中创建记录集。

您将创建一个记录集，它选择 Locations 表中的所有值。

  1. 在 Dreamweaver 中，执行下列操作之一打开“记录集”或“数据集”(ASP.NET) 对话框：
    • 在插入栏的“应用程序”选项卡中，单击“记录集”或“数据集”(ASP.NET) 按钮。
      这是所描述的功能的图片。
    • 选择“窗口”>“绑定”以打开“绑定”面板，然后单击加号 (+) 按钮并选择“记录集”或“数据集”。
    • 在“应用程序”面板组中，选择“绑定”面板，然后单击加号 (+) 按钮并选择“记录集”或“数据集”。

      • 随即出现“记录集”或“数据集”对话框。下方的屏幕显示 ColdFusion 记录集对话框。（在 ASP.NET 中，这是“数据集”对话框；对于所有服务器模型，大多数记录集选项是相同的。）
      这是所描述的功能的图片。

  2. 在“名称”文本框中，输入 rsLocations。

    3. 这是您正在定义的记录集的名称。

  3. 在“数据源”弹出式菜单 (ColdFusion) 或“连接”弹出式菜单（其他服务器页类型）中，选择“connGlobal”。

    4. “记录集”或“数据集”对话框将更新并显示 Global 数据库中第一个表格的信息。

    备注： 如果 connGlobal 连接没有出现在菜单中，单击“定义”按钮创建此连接。

  4. 在“表格”弹出菜单中，选择“LOCATIONS”。

    5. 记录集用 LOCATIONS 表中的记录进行更新。
    这是所描述的功能的图片。

  5. 对于“列”，接受默认设置“全部”。

    6. 提示： 若要限制记录集包含的信息，可以选择“选定的”，然后选择要使用的列。

  6. 单击“测试”测试记录集。

    7. 与您的记录集请求相匹配的数据库记录显示在“测试 SQL 指令”窗口中。
    这是所描述的功能的图片。

  7. 单击“确定”关闭“测试 SQL 指令”窗口。
  8. 单击“确定”关闭“记录集”或“数据集”对话框，并将记录集代码添加到您的页面中。

    9. Dreamweaver 确认记录集已添加到页面中，同时记录集出现在“绑定”面板中。

    提示： 如果没有看到所有的记录集域，单击加号按钮展开记录集的分支。


插入主详细页集应用程序对象

Dreamweaver 包含几个帮助您快速方便地创建 Web 应用程序页面的应用程序对象。

下一步，您将使用应用程序对象创建主详细页集。应用程序对象为很多常见的 Web 应用程序创建布局和服务器端脚本。您选择了几个选项后，主详细页集应用程序对象会为主页列表和包含您的详细信息的页面都生成表单和脚本。另外，应用程序对象还在主页中创建记录导航和记录计数器。

  1. 保存文档（“文件”>“保存”）。
  2. 在“文档”窗口中，locationMaster 文件应该仍是打开的，这时将插入点放在“Rental Locations”文本的后面，然后按 Enter 键或 Return 键设置应用程序对象的插入位置。
  3. 执行下列操作之一插入数据：
    • 在插入栏的“应用程序”选项卡中，单击“主详细页集”按钮或将其拖动到文档中。
    • 选择“插入”>“应用程序对象”>“主详细页集”。

      • “主详细页集”对话框随即出现。
      这是所描述的功能的图片。

  4. 在对话框的“记录集”弹出菜单中选择“rsLocations”。
  5. 在“主页域”列表中，选择“CODE”然后单击减号 (-) 按钮，将其从出现在主页列表中的数据列表中删除。
  6. 删除“主页域”列表中除 LOCATION_NAME、CITY 和 STATE_COUNTRY 以外的所有域。
  7. 在“以此连接到详细信息”弹出菜单中，选择“LOCATION_NAME”。

    8. 若要查看某个位置的详细页，需为出现在主页列表中的每个位置创建一个链接。当站点访问者单击主页中的“位置名称”时，相应的详细页将会打开。

  8. 在“传递唯一键”弹出菜单中，接受默认值“代码”并确保没有选中“数字”。

    9. CODE 域是 Locations 表中的唯一键或主键。此域包含每个记录的唯一代码（由三个字母组成）。

  9. 在“显示”中接受默认设置，每次显示十条记录。
  10. 在“详细页名称”中单击“浏览”，然后在“选择文件”对话框中定位到站点文件夹中的 locationDetail 文件。
  11. 单击“确定”。
  12. 在“详细页域”中，执行以下操作设置希望在详细页中出现的域：

    13. 在“详细页域”列表中，选择“CODE”，然后单击减号 (-) 按钮。

    选择“REGION_ID”，然后单击减号 (-) 按钮。

  13. 单击“确定”。

    14. Dreamweaver 更新主页和详细页，并为列表页和详细页都添加所有必要的服务器脚本和查询。

    主列表页更新。它包含一个数据库数据表（即记录集页导航表）和一个记录集计数器。
    这是所描述的功能的图片。

    详细页也更新。它包含一个表，其中列出了主页中每个记录的详细信息。
    这是所描述的功能的图片。


查看页面

下一步，您将保存页面，然后查看它们以了解所开发的应用程序的运行情况。若要查看页面在被服务器处理时的外观，可以在浏览器中预览页面。

  1. 在“文档”窗口中，选择 locationDetail 文档，然后选择“文件”>“保存”以保存工作。
  2. 在“站点”面板中，选择 locationDetail 文档，然后单击“上传文件”按钮（蓝色的向上箭头）将本地文件复制到服务器。
  3. 在“文档”窗口中，选择 locationMaster 文档，然后选择“文件”>“保存”保存它。
  4. 在“站点”面板中，选择 locationMaster 文档，然后单击“上传文件”按钮（蓝色的向上箭头）将本地文件复制到服务器。
  5. 在 locationMaster 仍被选定时，按 F12 键在浏览器中查看页面。测试主页到详细页的链接。
    这是所描述的功能的图片。
  6. 在数据表下方，单击“下一个”查看下十条记录的设置。

    7. 数据表、导航条和记录计数器更新。

  7. 单击位置名称之一查看详细页。

    8. 主页将唯一键传递给服务器，服务器处理查询，然后详细页打开并显示所选位置的数据。

  8. 按位于页面顶部的“位置”按钮返回到位置列表。
  9. 查看完页面后，关闭浏览器窗口。
  10. 在 Dreamweaver 中，关闭页面。


继续下面的学习

在本教程中，您学习了如何在 Dreamweaver 中创建主详细页集。

有关本教程所讲述的主题的详细信息，请参阅《使用 Dreamweaver MX》文档或 Dreamweaver 帮助中的下列主题：

  • 快速创建主/详细页
  • 逐步创建主/详细页
  • 修改主/详细页
上一页


建立插入记录页教程

本教程指导您逐步完成建立向数据库中插入信息的表单的过程。随着创建插入页，您将学习如何插入和定义表单域。还将学习如何创建表单域，使用户可以使用动态生成的菜单插入信息。

在 Dreamweaver MX 支持的所有服务器模型（ColdFusion、ASP、ASP.NET、JSP 和 PHP）中都可以完成本教程。

在本教程中，您将完成以下任务：

  • 创建插入页
  • 添加表单对象
  • 定义“插入记录”服务器行为
  • 测试您的插入页
下一页


开始前的准备工作

如果您已完成本指南的《Dreamweaver MX 入门》部分中的在 Dreamweaver MX 中开发 Web 应用程序，则您的本地站点和远程站点中已有完成本教程所需的文件。

如果您并未完成这一课，则需要将示例文件传输到本地驱动器和应用程序服务器中。有关如何设置文件的说明，请参见 Web 应用程序服务器的相应设置章节。

示例 ColdFusion 站点的设置

示例 ASP.NET 站点的设置

示例 ASP 站点的设置

示例 JSP 站点的设置

示例 PHP 站点的设置

开始学习本教程之前，必须已完成了以下任务：

  • 配置了系统。
  • 将 Dreamweaver 配置为使用所选的应用程序服务器。
  • 定义了数据库连接。


创建插入页

使用下面将要创建的插入页，站点管理员可以将新的汽车出租位置信息插入到 Global Car Rental 数据库中。

首先从一个部分完成的页面开始。在创建过程中，您还要将表单对象和动态内容添加到该页中。

首先选择一个工作页面。

  1. 执行下列操作之一打开“站点”面板：
    • 在“文件”面板组中，单击扩展箭头，然后选择“站点”选项卡（如果尚未选择）。
    • 选择“窗口”>“站点”。
    • 按 F8 键。

      • “站点”面板打开。
      这是所描述的功能的图片。

  2. 在“站点”弹出式菜单中，选择为您的应用程序服务器类型定义的 Global Car 站点。
  3. 在“站点”面板中，双击 insertLocation 文档以打开它。

    4. insertLocation 文档随即在“文档”窗口中打开。
    这是所描述的功能的图片。


添加表单对象

本插入页中已经添加有一个表格和一些表单域。文档中出现一个红色的虚线矩形框，这是表单边界。当您插入表单对象后，Dreamweaver 会自动在文档中插入表单边界。

现在将添加插入页的其余表单域，包括三个文本域、一个列表/菜单域、一个“提交”按钮和一个“重置”按钮。

另外，您还要提供表单域的标签文字。对域进行命名后，如果以后将表单域连接到数据库域，会更容易识别所使用的域。

首先查看现有的表单域之一。

  1. 如果属性检查器尚未打开，请打开它（“窗口”>“属性”）。
  2. 将鼠标指针移到右上方的单元格中，单击表单域以选择它。

    3. 属性检查器更新表单域属性的显示。
    这是所描述的功能的图片。

    “名称”域包含表单对象的名称；“字符宽度”域将域宽度设置为 30 个字符。您将在添加到表单的文本域中更新这两个域。

  3. 在文档中，将插入点放在“State or Country”标签文字右侧的表格单元格中，然后执行下列操作之一插入文本域：
    • 在插入栏中，单击“表单”选项卡，然后单击“文本域”按钮（左起第二个）或将其从插入栏拖到表格单元格中。
    • 选择“插入”>“表单对象”>“文本域”

      • 文本域表单对象随即插入到文档中。

  4. 当文本域仍被选定时，在属性检查器的“名称”文本框中输入 state_country，在“字符宽度”文本框中输入 30。
    这是所描述的功能的图片。
  5. 在文档中，将插入点放在“State”标签文字右侧的表格单元格中，然后执行下列操作之一插入“列表/菜单”：
    • 在插入栏的“表单”类别中，单击“列表/菜单”按钮或将其从插入栏拖到表格单元格中。
    • 选择“插入”>“表单对象”>“文本域”

      • 列表/菜单表单对象随即插入到文档中。
      这是所描述的功能的图片。

  6. 在属性检查器的“名称”文本框中输入 region_id。

    7. 列表/菜单对象按列表或菜单中最长项的长度生成字符宽度。我们在稍后将定义此域的菜单项和值。

  7. 插入“Telephone”文本域，然后在属性检查器中将其命名为 telephone，在“字符宽度”域中输入 30。
  8. 插入“Fax”文本域，然后在属性检查器中将其命名为 fax，在“字符宽度”域中输入 30。
  9. 在文档中，将插入点放在底部的表格单元格中。
    这是所描述的功能的图片。
  10. 执行下列操作之一，为表单添加“提交”按钮：
    • 在插入栏的“表单”类别中，单击“按钮”按钮或将其从插入栏拖到表格单元格中。
    • 选择“插入”>“表单对象”>“按钮”。

      • “提交”按钮随即插入到文档中。在属性检查器中，该按钮已有标签文字，并且“动作”被设置为“提交表单”。
      这是所描述的功能的图片。

  11. 重复第 10 步以向表单添加其他按钮。现在将添加“重置”按钮，以便用户在需要时可以重置表单。
  12. 在属性检查器中，对于“动作”，选择“重设表单”。
  13. 在“按钮名称”文本框中输入 Reset。

    14. 表单现在就完成了，它看起来象这样：
    这是所描述的功能的图片。

  14. 保存文档。


定义列表/菜单表单域

现在，您将添加让用户选择区域的文本名称的信息，从而更新列表/菜单域，并且用其数值更新数据库。这样，用户就不必进行检查以确认数字与名称是否匹配了。

  1. 在文档中，单击 Region_Id 列表/菜单表单域以选择它。

    2. 属性检查器随即用该对象的相关信息更新。
    这是所描述的功能的图片。

  2. 在属性检查器中，单击“列表值”按钮。

    3. 随即出现“列表/菜单”对话框。

  3. 在“列表值”对话框中，添加“项目标签”和“值”以匹配 REGIONS 数据库表中的数据。
  4. 在“项目标签”中，输入 North America；然后按 Tab 键，在“值”中输入 1。
  5. 单击加号 (+) 按钮以添加其他项，然后输入“South/Central America”，之后按 Tab 键，再输入“2”。
  6. 重复第 4 步和第 5 步，直到如下面的对话框中所示输入了所有区域。
    这是所描述的功能的图片。
  7. 单击“确定”关闭对话框。


定义“插入记录”服务器行为

您将使用服务器行为为应用程序创建所需的服务器脚本。您将创建表单域数据和数据库数据之间的连接，这样，完成表单并单击“提交”按钮时，信息便插入到数据库中。

  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮并从弹出式菜单中选择“插入记录”。

    2. 出现“插入记录”对话框。
    这是所描述的功能的图片。

  2. 在“数据源”(ColdFusion) 或“连接”弹出式菜单（其他服务器页类型）中，选择“connGlobal”。
  3. 在“插入到表格”弹出式菜单中选择“LOCATIONS”。
    这是所描述的功能的图片。

    4. “列”列表随即用表单域与数据库域的关联方式信息更新。

  4. 确保 REGION_ID 的值设置为“数字”或“整数”(ASP.NET)，因为“区域 ID”是数值，而非文本值。
  5. 在“插入后，转到”或“如果成功，则转到”(ASP.NET) 中，单击“浏览”并在出现的对话框中选择 LocationOK 文件，然后单击“确定”以关闭该对话框。
  6. 单击“确定”关闭“插入记录”对话框。

    7. 在“文档”窗口中，表单随即更新，并且“服务器行为”面板显示“插入记录”行为已被添加。

  7. 保存文档。


测试您的插入页

接下来，您将把已完成的页面拷贝到服务器，然后在浏览器中打开它并插入一些信息。

  1. 在“站点”面板中选择“insertLocation”，然后单击“上传文件”按钮（蓝色的向上箭头）将本地文件复制到服务器上。当询问您是否要复制相关文件时，请选择“是”。
  2. 当 insertLocation 在“文档”窗口中被选定时，选择“文件”>“在浏览器中预览”或按 F12 键 (Windows) 查看文档。
  3. 在表单中输入测试数据，然后单击“提交”按钮。

    4. 出现 locationOK 页，指示已在 Global 数据库中成功插入信息。

  4. 若要查看您已添加到数据库中的项，请执行以下操作：

    5. 在“应用程序”面板组中，选择“数据库”面板。找到 connGlobal 数据库，然后单击数据库前面的加号 (+) 以展开它。单击“表格”前面的加号 (+) 以查看数据库的各表格。右击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) LOCATIONS 表，然后选择“查看数据”。随即出现数据库记录；新记录是该数据库中的最后一项。


继续下面的学习

在本教程中，您学习了如何在 Dreamweaver 中创建动态插入记录表单。有关本教程所讲述的主题的详细信息，请参见《使用 Dreamweaver MX》 文档或 Dreamweaver 帮助中的下列主题：

  • 创建交互表单
  • 将动态内容添加到 Web 页中
  • 建立要插入记录的页面
  • 设置“插入记录表单”对话框选项
上一页


Dreamweaver 基础

学习如何使用 Dreamweaver 文档和其他资源，以及了解如何设置 Dreamweaver 工作区使其符合您自己的工作习惯。然后计划并设置站点，开始创建页面。

此部分包含以下各章：

  • 欢迎使用 Dreamweaver
  • 了解工作区
  • 规划和设置站点
  • 管理您的站点
  • 设置文档


欢迎使用 Dreamweaver

Macromedia Dreamweaver MX 是一款专业的 HTML 编辑器，用于对 Web 站点、Web 页和 Web 应用程序进行设计、编码和开发。无论您愿意享受手工编写 HTML 代码时的驾驭感还是偏爱在可视化编辑环境中工作，Dreamweaver 都会为您提供有用的工具，使您拥有更加完美的 Web 创作体验。

利用 Dreamweaver 中的可视化编辑功能，您可以快速地创建页面而无需编写任何代码。您可以查看所有站点元素或资源并将它们从易于使用的面板直接拖到文档中。您可以在 Macromedia Fireworks 中创建和编辑图像，然后将它们直接导入 Dreamweaver，或者直接在 Dreamweaver 中添加 Macromedia Flash 对象，从而优化您的开发工作流程。

Dreamweaver 还包括多种与编码相关的工具和功能，其中包括代码视图中的代码编辑工具（如代码加色和标签完成）；有关 HTML、CSS、JavaScript、CFML、ASP 和 JSP 的参考资料以及一个 JavaScript 调试器。Macromedia 的可自由导入导出 HTML 技术可导入您手工编码的 HTML 文档而不会重新设置代码的格式，您可以随后用您首选的格式设置样式来重新设置代码的格式。

Dreamweaver 现在包含并扩展了 Macromedia UltraDev 中的所有功能，以帮助您使用 ASP、ASP.NET、ColdFusion 标记语言 (CFML)、JSP 和 PHP 等服务器语言来生成由动态数据库支持的 Web 应用程序。

Dreamweaver 可以完全自定义。您可以创建您自己的对象和命令，修改键盘快捷方式，甚至编写 JavaScript 代码，用新的行为、属性检查器和站点报告来扩展 Dreamweaver 的功能。

本章包含下列章节：

学习 Dreamweaver

Web 站点创建工作流程

从哪里开始

字形约定

Dreamweaver MX 中的新增功能

HTML 和 Web 技术资源

下一页


学习 Dreamweaver

Dreamweaver 包括了多种资源，将帮助您快速了解该程序并熟练创建您自己的 Web 站点和页面。这些资源包括打印的《入门》指南、联机帮助系统和教程。此外，您可以在 Macromedia Web 站点的 Dreamweaver 支持中心找到定期更新的提示、技术说明、示例和信息。


入门指南

本《入门》指南旨在指导您使用 Dreamweaver 按步骤创建简单但比较实用的 Web 站点。它针对的是那些创建过一些 Web 页，但对 Dreamweaver 的某些方面尚不熟悉的用户。它包括的有关章节涉及创建和编辑简单的静态页、手工编辑代码以及创建动态 Web 应用程序。该指南是以印刷手册、帮助系统的一部分和 PDF 文件三种形式提供的。


教程

教程提供有关特定主题的深入课程，就《入门》指南未涉及的特定领域提供更为详细的信息。通过演练教程，您将学习如何使用 Dreamweaver 中最有用、最强大的设计功能来编辑示例 Web 站点。教程同时在印刷的《入门》指南、Dreamweaver“帮助”（在 Dreamweaver 的“帮助”菜单中，选择“教程”）和《入门》PDF 文件中提供。

如果您已经熟悉 Dreamweaver 的设计功能，但需要更多地了解如何生成 Web 应用程序，请首先学习动态页教程，这些教程将介绍如何创建与数据库连接的交互页面。


Dreamweaver 帮助

Dreamweaver“帮助”提供所有 Dreamweaver 功能的综合信息，并且为联机阅读进行了优化。Dreamweaver“帮助”在操作系统提供的帮助查看器中显示：Microsoft HTML 帮助 (Windows) 或 Apple 帮助 (Macintosh)。在这两种平台上，您都可以通过以下四种方式中的任一种查找信息：

目录用于查看按主题组织的所有信息。单击顶级条目可查看子标题。

索引与传统的打印索引相似，用于查找特定术语或概念。

搜索用于查找位于帮助系统文本中任意位置的任意字符串。

上下文关联帮助提供了一种从各个对话框、面板和检查器中打开相关帮助主题的方法。若要查看上下文关联帮助，请单击对话框中的“帮助”按钮，从面板组标题栏的“选项”菜单中选择“帮助”，或者单击检查器或其他类型的窗口中的问号。

每个帮助主题都提供了特定的按钮，通过单击这些按钮，即可在不同主题之间移动。左箭头和右箭头按钮用于移至一节中的上一个或下一个主题（按照主题在目录中列出的顺序）。


扩展 Dreamweaver

《扩展 Dreamweaver》帮助系统提供有关 Dreamweaver 文档对象模型和 API（应用程序编程接口）的信息。利用文档对象模型和 API，JavaScript 和 C 开发人员可以为 Dreamweaver 创建扩展。


Dreamweaver 支持中心

为了便于充分利用 Dreamweaver，您可以咨询基于 Web 的支持中心。Dreamweaver 支持中心 Web 站点的网址 会定期用 Dreamweaver 的最新信息进行更新，另外还将提供专业用户的建议、示例、提示、更新以及有关高级主题的信息。请经常访问该 Web 站点，以查找 Dreamweaver 的最新消息并了解如何充分利用该程序。


设计和开发人员中心

Macromedia 设计和开发人员中心 为所有 Macromedia 产品提供工具、教程以及其他内容。


Dreamweaver 联机论坛

通过访问 Dreamweaver 联机论坛，可以与其他 Dreamweaver 用户讨论技术问题并共享有用的技巧。有关访问该论坛的信息，可以查阅 Macromedia Web 站点。


键盘快捷方式

要显示默认 Dreamweaver 配置中所有键盘快捷方式的图表可以查阅 Macromedia Web 站点。


Web 站点创建工作流程

可以用多种方式创建 Web 站点。在本文介绍的工作流程中，您将首先定义站点的策略或目标。如果您是在开发 Web 应用程序，则必须根据需要设置服务器和数据库。然后再设计该站点的外观。当外观设计完成后，将生成该站点并编写页代码，以添加内容和交互控件；然后将页面链接在一起，并对该站点进行功能测试，以验证它是否符合定义的目标。您还可以在站点中包含动态页。在这一工作流程的最后，在服务器上发布该站点。许多开发人员还会安排定期的维护，以确保站点保持最新并且工作正常。

为了在开发 Web 站点时更方便地找到所需信息，《使用 Dreamweaver》文档划分为一些较大的部分，就 Web 开发总结出以下几个模块：站点规划、设计、开发、测试以及发布和维护。


关于站点规划

如果在一开始就对站点进行仔细的规划和组织，将可以为后期的工作节约时间。组织站点不仅包括确定将在哪里发布文件，还包括检查站点要求、访问者情况以及站点目标。此外，还应考虑诸如用户访问以及浏览器、插件和下载限制等技术要求。

当组织好信息并确定结构后，就可以开始创建站点。

  • 确定要采用的策略以及在规划站点时要考虑的问题。请参见规划和设置站点。
  • 使用 Dreamweaver“站点”面板设置站点的组织结构。在“站点”面板中，您可以方便地添加、删除和重命名文件及文件夹，以根据需要更改组织结构。请参见规划和设置站点和管理您的站点。
  • 您可以开始创建简单的页面，随后再将这些页面转换为较复杂的设计。在“新建文档”对话框中创建新的空白页或基于预定义页面设计的页面。请参见设置文档。

如果您是在 Web 开发小组中工作，可能还会对以下主题感兴趣：

  • 设置一个系统以防止小组成员覆盖文件；请参见使用存回/取出。
  • 使用设计备注与其他 Web 小组成员沟通；请参见使用设计备注。


关于设置 Web 应用程序

越来越多的 Web 站点都包含了动态页，动态页使访问者能够查看存储在数据库中的信息，并且一般会允许某些访问者在数据库中添加新信息或编辑信息。若要创建动态页，则必须先完成几个预备步骤。

  • 设置一个 Web 服务器和应用程序服务器，然后创建或修改 Dreamweaver 站点。请参见设置 Web 应用程序。
  • 连接到数据库。根据您的应用程序所用的服务器技术，请参见ColdFusion 开发人员的数据库连接、ASP.NET 开发人员的数据库连接、ASP 开发人员的数据库连接、用于 JSP 开发人员的数据库连接或适用于 PHP 开发人员的数据库连接。


关于手工编码

与其说手工编写 Web 页代码是 Web 站点创建工作流程中的一个步骤，不如说它是创建页面的一种方法。Dreamweaver 提供了易于使用的可视化编辑工具，但同时也提供了高级的编码工具；您可以采用任一种方法（或采用这两种方法）来创建和编辑页面。

  • 您可以在没有可视化工具的编码环境中工作；编码工具将帮助您创建和编辑代码，设置代码格式，确保代码符合标准以及调试 JavaScript 代码。请参见设置您的编码环境、Dreamweaver 中的编码和优化和调试代码。
  • 您也可以在“设计”视图这一可视化设计环境中使用某些 Dreamweaver 编码工具。请参见在设计视图中编辑代码。


有关设计 Web 页面布局

许多 Web 设计项目都从设计示例页的提要板或流程图开始。当您逐步接近最终设计时，可使用 Dreamweaver 创建实体模型示例页。实体模型通常会显示设计布局、站点导航、技术组件、主题及颜色、图形图像或其他媒体元素，但它们不包含页面的最终内容。

  • 利用 Dreamweaver 中的表工具和布局视图，您可以通过拖动并重新安排页面结构来快速地设计 Web 页。请参见使用表格显示内容和在布局视图中对页进行布局。
  • 如果要在 Web 浏览器中同时显示多个文档，则可以使用框架对文档进行布局。请参见使用框架。


关于添加内容

利用 Dreamweaver，您可以方便地在 Web 页中添加多种内容。添加资源和设计元素，如文本、图像、颜色、影片以及其他形式的媒体。

  • 在 Dreamweaver 文档中直接键入或从其他文档中导入文本，然后使用 Dreamweaver 属性检查器或“HTML 样式”面板设置文本格式。您也可以方便地创建您自己的层叠样式表。请参见插入文本和设置文本格式。
  • 使用“资源”面板可方便地组织站点中的资源；然后可以将大多数资源直接从“资源”面板拖到 Dreamweaver 文档中。请参见使用“资源”面板。
  • 插入图像（包括鼠标经过图像、图像地图和 Fireworks 切割图像）。使用对齐工具可在页面上定位图像。请参见插入图像和Dreamweaver 与其他应用程序的集成。
  • 在 Web 页中插入其他类型的媒体，如 Flash、Shockwave 和 QuickTime 影片、声音和applets。请参见插入媒体。
  • 请务必使您的内容可供残疾人士访问。请参见Dreamweaver 和辅助功能。


关于互动控件和动画

许多 Web 页都是静态的，仅包含文本和图像。Dreamweaver 使您能够超越静态页，利用互动控件和动画来吸引访问者的兴趣。您可以在访问者移动和单击时提供反馈，解释概念，显示页面元素的动画效果。简而言之，您可以让访问者在页面上看见更多的内容，执行更多的操作。

通过以下几种方法可以使用 Dreamweaver 在页面上添加互动控件和动画：

  • 使用行为来控制任务执行以响应特定的事件，例如当访问者在按钮上移过鼠标时高亮显示该按钮，在访问者单击“提交”按钮时验证表单，或者在主要页完成加载时打开另一个浏览器窗口。请参见使用 JavaScript 行为。
  • 使用时间轴可创建不需要插件、ActiveX 控件或 Java 的动画。时间轴使用动态 HTML 在一段时间内更改层的位置或图像的来源，或者在页面加载后自动调用行为操作。请参见制作层动画。


关于连接站点上的页面

独立的页面不会成为站点；您需要将各个页面链接在一起，方法是创建 HTML 链接并且通过重新使用内容为页面提供共同的外观。

  • 利用Dreamweaver，您可以创建标准的 HTML 链接（包括锚记链接和电子邮件链接），也可以方便地设置图形导航系统（如跳转菜单和导航条）。请参见链接与导航。
  • Dreamweaver 模板和库文件使您可以方便地将可重新使用的内容和页面设计应用于站点。您可以基于 Dreamweaver 模板创建新的页面，然后在模板更改时自动更新这些页面的布局。请参见管理站点资源、库和模板。


关于测试和发布站点

您的站点完成后，在准备面世并在服务器上发布站点之前，必须对站点进行测试。根据项目的大小、客户端要求以及访问者将会使用的浏览器种类，可能需要将站点移至一个模拟调试服务器，在这里可以对站点进行测试和编辑。当做出更正后，在公众可以访问的地方发布该站点。站点一旦发布，就应建立一个维护循环来确保质量，响应用户反馈和更新站点信息。

使用以下 Dreamweaver 功能可测试和发布您的站点：

  • 若要在页面添加新标签或修正您的代码，请使用 Dreamweaver“参考”面板查找 JavaScript、CSS 和 HTML 代码。请参见访问语言参考。
  • 使用 JavaScript 调试器可帮助您修正代码中的 JavaScript 错误。该调试器会让您在代码中设置断点，然后允许您在 Dreamweaver 中调试页面的同时查看代码。请参见使用 JavaScript 调试器。
  • 运行浏览器和插件检查，测试和修正文档中的链接，并运行站点报告来检查 HTML 文件是否存在常见错误。请参见测试站点。
  • 在 Dreamweaver“站点”面板中，您可以找到多个工具来管理站点，向远程服务器和从远程服务器传输文件，设置存回/取出过程来防止文件被覆盖，以及同步本地和远程站点上的文件。请参见规划和设置站点。


关于创建动态页

在 Dreamweaver 中，您可以定义动态内容的多种来源，其中包括从数据库提取的记录集、表单参数和 JavaBeans 组件。若要在页面上添加动态内容，只需将该内容拖动到页面上即可。

您可以通过设置页面来同时显示一个记录或多个记录，显示多页记录，添加用于在记录页之间来回移动的特殊链接，以及创建记录计数器来帮助用户跟踪记录。

  • 如果您不熟悉如何在 Dreamweaver 中创建 Web 应用程序，请学习使用 Dreamweaver 生成动态页。请参见为可视化开发优化工作区和Dreamweaver 动态页设计工作流程。
  • 在页面上定义和显示动态内容。请参见存储和检索页面数据、定义动态内容源、向 Web 页中添加动态内容和显示数据库记录。
  • 使用 ColdFusion 组件和 Web 服务等前沿技术来封装应用程序或业务逻辑。请参见使用 ColdFusion 组件和使用 Web 服务。
  • 如果您需要更多的灵活性，则可以创建您自己的服务器行为和交互式表单。请参见添加自定义服务器行为和创建交互式表单。


关于快速应用程序开发

Dreamweaver 提供了大量的快速应用程序开发 (RAD) 工具（包括服务器行为和应用程序对象），它们将帮助您生成高级的 Web 应用程序，而无需编写任何服务器端代码。

  • 快速创建对数据库进行搜索和修改并显示结果的页面。请参见生成主/详细页、生成搜索数据库的页面和建立修改数据库的页。
  • 通过限制对页面的访问来提供安全性。请参见生成对站点访问进行限制的页。


从哪里开始

Dreamweaver“帮助”包含为多种不同背景的读者提供的信息。若要充分利用该文档，请首先阅读对您最适合的部分。

对于 Web 设计初学者：
  1. 首先阅读《入门》指南的前两章：简介和在 Dreamweaver 中创建您的第一个 Web 站点。如果这两章中的任何一节显得太高深或太复杂，请跳过该节，以后再回头来阅读。
  2. 在Dreamweaver帮助中，阅读了解工作区、规划和设置站点、管理您的站点和设置文档。
  3. 通过阅读在布局视图中对页进行布局了解页面布局。
  4. 若要了解如何设置文本格式和在页面上包含图像，请阅读插入文本和设置文本格式和插入图像。
  5. 如果您要开始创作高质量的 Web 站点，则只需了解上述内容，但如果您准备了解如何使用更为高级的工具，则可以按顺序阅读静态页章节的其余部分。最好在较为了解如何创建 Web 页后，才开始阅读动态页章节。
对于有经验但不熟悉 Dreamweaver 的 Web 设计人员：
  1. 首先阅读《入门》指南的前两章：简介和在 Dreamweaver 中创建您的第一个 Web 站点。
  2. 在 Dreamweaver 帮助中，阅读了解工作区以详细了解 Dreamweaver 用户界面。
  3. 虽然您可能已熟悉规划和设置站点和管理您的站点中的许多内容，但请浏览这些章节，已了解这些熟悉的概念在Dreamweaver中是如何实现的。尤其要注意有关使用 Dreamweaver 设置新站点的章节。
  4. 遵循任何使您感兴趣的教程中提供的步骤，详细了解如何使用 Dreamweaver 执行特定的任务。若要在帮助系统中查看这些教程，请选择“帮助”>“教程”。
  5. 插入文本和设置文本格式和插入图像为使用 Dreamweaver 创建基本的 HTML 页提供了有用的信息。
  6. 对于其他章节，请阅读开头的概述，以确定您是否对其中的主题感兴趣。
对于有经验的手工代码编写者：
  1. 首先阅读《入门》指南的第一章和第三章：简介和在 Dreamweaver 中编辑代码。
  2. 在 Dreamweaver 帮助中，阅读了解工作区以详细了解 Dreamweaver 用户界面。
  3. 虽然您可能已熟悉规划和设置站点和管理您的站点中的许多内容，但请浏览这些章节，以了解这些熟悉的概念在Dreamweaver中是如何实现的。尤其要注意有关使用 Dreamweaver 设置新站点的章节。
  4. 请在设置您的编码环境、Dreamweaver 中的编码、优化和调试代码和在设计视图中编辑代码中阅读更多有关用 Dreamweaver 编码的内容。
  5. 对于其他章节，请阅读开头的概述，以确定您是否对其中的主题感兴趣。
对于有经验、熟悉 Dreamweaver 但要详细了解如何创建动态页的 Web 设计者：
  1. 首先阅读《入门》指南的第一章、第四章和第五章：简介、了解 Web 应用程序和在 Dreamweaver MX 中开发 Web 应用程序。
  2. 在 Dreamweaver 帮助中，浏览了解工作区以了解 Dreamweaver 用户界面的新内容。
  3. 设置 Web 服务器和应用程序服务器；请参见设置 Web 应用程序。
  4. 连接到数据库。根据您的应用程序所用的服务器技术，请参见ColdFusion 开发人员的数据库连接、ASP.NET 开发人员的数据库连接、ASP 开发人员的数据库连接、用于 JSP 开发人员的数据库连接或适用于 PHP 开发人员的数据库连接。
  5. 对于其他章节，请阅读开头的概述，以确定您是否对其中的主题感兴趣。
  6. 如果您对手工自定义 Dreamweaver 感兴趣，请阅读 Macromedia 支持中心上的“自定义 Dreamweaver”。如果要为Dreamweaver编写扩展，请阅读《扩展Dreamweaver 》（“帮助”>“扩展 Dreamweaver”）。
对于有经验但未使用过 Dreamweaver 或 UltraDev 的 Web 应用程序开发人员：
  1. 首先快速阅读《入门》指南，以熟悉有关使用 Dreamweaver 的基本知识。
  2. 在 Dreamweaver 帮助中，阅读了解工作区以详细了解 Dreamweaver 用户界面。
  3. 虽然您可能已熟悉规划和设置站点和管理您的站点中的许多内容，但请浏览这些章节，以了解这些熟悉的概念在Dreamweaver中是如何实现的。尤其要注意有关使用 Dreamweaver 设置新站点的章节。
  4. 遵循任何使您感兴趣的教程中提供的步骤，详细了解如何使用 Dreamweaver 执行特定的任务。若要在帮助系统中查看这些教程，请选择“帮助”>“教程”。
  5. 使用 Dreamweaver 设置 Web 服务器和应用程序服务器；请参见设置 Web 应用程序。
  6. 连接到数据库。根据您的应用程序所用的服务器技术，请参见ColdFusion 开发人员的数据库连接、ASP.NET 开发人员的数据库连接、ASP 开发人员的数据库连接、用于 JSP 开发人员的数据库连接或适用于 PHP 开发人员的数据库连接。
  7. 对于其他章节，请阅读开头的概述，以确定您是否对其中的主题感兴趣。
对于有经验且使用过 UltraDev 4 的 Web 应用程序开发人员：
  1. 首先阅读Dreamweaver MX 中的新增功能。
  2. 在 Dreamweaver 帮助中，浏览了解工作区以了解 Dreamweaver 用户界面的新内容。
  3. 如果您对手工自定义 Dreamweaver 感兴趣，请阅读 Macromedia 支持中心上的“自定义Dreamweaver”。如果要为Dreamweaver编写扩展，请阅读《扩展 Dreamweaver》（“帮助”>“扩展 Dreamweaver”）。


字形约定

Dreamweaver“帮助”中采用以下字形约定：

  • 菜单项按如下格式显示：“菜单名称”>“菜单项名称”。子菜单中的项按如下格式显示：“菜单名称”>“子菜单名称”>“菜单项名称”。
  • Code 字体：指示 HTML 标签和属性的名称以及在示例中使用的文字。
  • Italic code 字体：指示代码中可替换的项（有时称作元符号）。
  • Bold roman 文本：指示让您输入逐字输入的文本。


Dreamweaver MX 中的新增功能

Dreamweaver MX 包含多种多样的新功能，例如为可视化设计人员提供的新型增强模板以及多种新的编码功能。Dreamweaver 现在还包括Dreamweaver UltraDev 4 的所有应用程序开发功能，并且提供了多种新功能，其中包括从 Macromedia ColdFusion Studio 派生的代码中心工作区、更完善的运行时代码以及对最新 Web 应用程序技术的支持。


对代码和设计的完全控制

您可以使用 Dreamweaver MX 设计工具或多格式编码环境按您需要的方式生成您的站点。

新的集成工作区布局（仅限 Microsoft Windows）用多文档界面 (MDI) 提供了较为熟悉的工作环境，其中包括完全可停靠的面板和选项卡式的文档窗口。

Macromedia MX 面板管理（在 Dreamweaver MX 中）与面板在 Macromedia Flash MX 和 Fireworks MX 中的工作方式一致。根据需要将可折叠、可停靠的面板组合在一起并折叠或扩展这些面板，以实现顺畅、高度可配置的工作流程。

预设计的示例 Web 组件包含专业质量的布局，使您在设计方面取得领先的优势，同时还提供了 JavaScript 功能库，使您可以访问高级的客户端交互，而无需阅读数百页的教科书。

增强的 Dreamweaver 模板允许您设置高级的规则，以便让撰写人在不损坏站点设计的情况下输入内容。模板继承允许自定义程度更高的布局控制，而可编辑区域则使撰写人在输入时更加灵活。

站点定义向导使您可以快速而方便地设置站点（无论您是在首次生成动态站点还是在设置 ISP 帐户）。

代码提示使您可以方便地自定义菜单，当您在代码视图中进行编辑时，这些菜单将显示适当的标签属性、方法属性、函数参数和 CSS 样式。

可自定义的插入栏使您可以快速地访问 Dreamweaver MX 中的对象和行为，并且可完全扩展。

文档工具栏现在可以使用 XML 和 JavaScript 进行自定义，以适合您的需要和偏好。

文件浏览器现在集成在“站点”面板中，使您可以浏览桌面和网络卷上的资源和文件，而不必让 Dreamweaver 使用操作系统中的本机文件浏览器。

“解答”面板使您直接与 Macromedia 支持中心的联机资源相连。您可以随意检索新的内容，以确保您始终能访问最新的提示和技巧。

增强的表编辑和操作功能为在布局视图和标准视图中的表编辑生成了更完善的代码，从而优化了属性处理并确保所有布局尽可能精简，而不会损坏跨浏览器的兼容性。

层叠 JavaScript 弹出式菜单现在可以直接在 Dreamweaver MX 中创建，此功能以前仅在 Fireworks 中提供。

语法颜色现在可完全按照您个人的需要进行配置和自定义。

标准工具栏使您能够快速地访问常用的文件命令（“打开”、“保存”和“新建”）和剪贴板命令。

从代码视图打印现在允许您打印出应用了适当格式设置的源代码。


对所有最新服务器技术的强大支持

通过手工编码以及通过使用可视化对象和行为来快速生成动态的、数据库驱动的 Web 应用程序。

用于 ColdFusion、ASP、ASP.NET、JSP 和 PHP 的服务器代码库使您能够使用所有前沿的服务器端技术，以可视方式创建动态 Web 站点。使用一个开发环境即可与多种站点和后端技术集成。

“代码片断”面板使您能够存储任意代码片断以便在将来重新使用。您可以方便地重新使用复杂的代码、布局和函数。

标签库编辑器为存储有关本机和自定义标签的信息提供了集成的标签数据库。它允许您编辑现有标签的属性和导入新的标签。

数百个标签编辑器使您能够在代码视图中快速地编辑 HTML、CFML 和 ASP.NET 中特定标签的相关属性。

ASP.NET 自定义标签支持使您能将自定义 ASP.NET 服务器控件（自定义标签）导入 ASP.NET页，以及查看在标签选择器、代码提示和标签检查器中显示的结构和属性。

ASP.NET Web 表单标签现在会呈现在 Macintosh 和 Windows 上，从而支持复杂的可视化效果和编辑。通过 Web 表单标签编辑器，您可以使用验证和服务器端控件快速地创作 ASP.NET Web 表单。

ASP.NET 数据网格和数据列表对象可以在 Dreamweaver MX 中方便地创建，以进行复杂的数据显示和操作。

集成的“数据库”面板使您能够快速地查看数据库的结构和内容，以及在创建查询之前浏览表、预存过程和视图。

标签选择器显示可用于 Dreamweaver MX 的所有标签结构，其中包括通过标签库编辑器导入的自定义标签。使用它可以在页面上快速地放置和编辑标签以及查看各个标签的参考信息。

可自定义且基于 XML 的标签数据库存储有关所有可用标签的结构的信息。这一集中的信息存储机制允许代码提示、标签选择器和标签检查器等功能使用本机和自定义的导入标签。

ColdFusion MX 检测允许站点定义向导自动配置其自身，以使用本地安装的 Macromedia ColdFusion MX Developer Edition 设置 ColdFusion 站点。

ColdFusion MX 的“现场服务器调试”面板通过直接在 Dreamweaver MX 中显示调试输出优化了 ColdFusion MX 的调试工作流程。查看变量信息、查询信息和其他关键页统计信息，以及直接跳转到问题区域，所有这些操作都不需要离开开发环境。

ColdFusion 运行时代码由 Dreamweaver MX 服务器行为和对象生成，它在修补后更加面向标签，因此几乎无法与开发人员手工编写的代码区分开。

RDS 支持使您能够来回传输文件，以及使用 RDS 连接浏览 ColdFusion 服务器上数据库的结构。

JSP 标签库通过从 JSP 页提取服务器逻辑来为开发人员提供帮助。Dreamweaver MX 可以从 TLD（标签库描述符）文件中导入 JSP 标签库，并使它们可以在代码提示、标签选择器和标签检查器中使用。

完全 JavaBean 内部检查在“数据绑定”面板上显示 JavaBean 的 getProperty 和 setProperty 方法，并且可以在“组件”面板上显示 JavaBean 的所有方法和属性，使开发人员能够将 Bean 与他们的 JSP 应用程序充分集成。

动态表单对象使您只需从插入条中选择相应的表单对象即可创建数据库驱动的选择列表和其他表单元素。

服务器行为生成器来自 UltraDev 4，它已经得到改进，允许用户使用更复杂的用户界面元素（包括复选框、单选按钮组和连接菜单）来生成服务器行为。

集成的 HomeSite 5 和 ColdFusion Studio 5 包提供 HomeSite+ 的完全许可版本，它组合了 ColdFusion Studio 和 HomeSite 5，并且与 Dreamweaver MX 充分集成。


方便地获取最新标准

生成符合最新 Web 标准（包括 XML 和 Web 服务）的 Web 站点，并用前沿的开发技术使您的技能不断更新。

用于 ASP.NET、ColdFusion 和 Java 的 Web 服务内部检查使您能够利用所有前沿服务器技术中基于 XML 的最新 Web 服务标准进行内部检查和互操作。通过 Dreamweaver MX 中的 Web 服务器内部检查功能，可以将复杂的功能包括在您的 Web 应用程序中。

XML 编辑和验证使您能够导入 DTD 和架构，并确保文档的格式正确。

增强的 CSS 支持（包括 TopStyle 集成）将帮助您生成符合最新层叠样式表 (CSS) 标准的站点。Dreamweaver MX CSS 面板已得到改进，可显示内部和外部定义的样式，并支持设计时样式表。此外，多种 CSS2 构造也得到了支持。文本属性检查器也可以用于应用 CSS 样式。

XHTML 支持使您能够配置 Dreamweaver MX 来生成符合 XHTML 的代码，从而确保您的站点用最新的 HTML 设计标准不断得到更新。另外，还可使用 XHTML 转换器将遗留 HTML 文件转换为 XHTML。

第 508 节辅助功能站点报告帮助您确定站点是否符合辅助功能标准并快速而方便地查明问题。

集成辅助功能参考内容位于“参考”面板中，它为您提供有关辅助功能设计的最佳做法的上下文和背景。

用于生成符合代码的辅助功能选项在编辑循环中帮助您确保您所创建的内容符合辅助功能标准。对 Dreamweaver 进行配置，让它在将相应的标签和对象插入页面时提示您特定的辅助功能相关属性。

ColdFusion 组件支持通过 CFML，以 Web 服务的形式或通过 Flash 应用程序服务器网关来公开属性，从而为您提供模块性和可移植性更高的服务器逻辑。Dreamweaver MX 包括对内部检查、创建和编辑 ColdFusion 组件的支持。

代码验证器针对特定的浏览器配置文件或特定版本的标准（包括 XHTML 过渡版和 HTML 4.0）来提供验证报告，以确保您的文档符合相应的标准。

Macromedia Flash MX 和 Fireworks MX 中启动和编辑会加速在 Dreamweaver MX、Fireworks MX 和 Flash MX 之间进行的图形、动画和 HTML 编辑，使您能够直接从 Dreamweaver 启动和优化。

用于查看 XML、HTML 和 CFML 的标签检查器使您能够快速而方便地查看文档的结构。您可以迅速发现并清除不正确的嵌套和父关系，而无需查看初始源代码。

安全 FTP 登录与用于 Windows 的 MacSSH 和 PUTTY 集成在一起，支持通过 SSH 安全地传输来自集成 Dreamweaver FTP 客户端的登录信息。

UTF-8 字符集完全支持（在所有语言中）使您能够使用 UTF-8 编码创建和转换页面。

Mac OS X 和 Windows XP 完全支持使 Dreamweaver MX 能够在最新的操作系统中全速运行，同时还支持所有最新的用户界面改进。

Macromedia Sitespring 集成帮助您在 Dreamweaver 工作区使用生产管理和客户端管理的最佳做法。


HTML 和 Web 技术资源

下面是在 Web 上提供的一些有用资源：

HTML 4.01 规范 是 WWW 联合会为 HTML 制定的正式规范。

Index DOT HTML 是 HTML 标签、属性和值以及它们与各种浏览器的兼容性的综合列表。

XHTML 1.0 规范是可扩展超文本标记语言的正式规范。

O'Reilly XML.com 站点 提供有关可扩展标记语言 (XML) 的信息、教程和提示以及其他 Web 技术。

层叠样式表，第 1 级规范 (CSS1) 和第 2 级规范 (CSS2) 是 WWW 联合会为样式表制订的正式规范。

WebReview.com 的样式表参考指南 解释什么是 CSS 样式以及它们在哪些浏览器中使用。

Microsoft ASP 概述 页 提供有关 Active Server Page (ASP) 的信息。

Microsoft ASP.NET 页 提供有关 ASP.NET 的信息。

Sun JSP 页 提供有关 JavaServer Page (JSP) 的信息。

PHP 页 提供有关 PHP（超文本预处理器）的信息。

MySQL 站点 提供有关 MySQL 的信息。

实体表 列出在 ISO 8859-1 (Latin-1) 中使用的实体名称。

动态 HTML 事件页 提供有关 Microsoft Internet Explorer 中事件的信息。

Macromedia ColdFusion 产品页 提供有关 ColdFusion 的信息。

Macromedia JRun Server 产品页 提供有关 JRun Java 应用程序服务器的信息。

IBM WebSphere 页 提供有关 WebSphere 应用程序服务器的信息。

Chili!Soft 产品页 提供有关 Sun Chili!Soft ASP 应用程序服务器的信息。

JavaScript Bible（作者 Danny Goodman，出版商 IDG Books）全面地介绍 JavaScript 1.2 语言。

JavaScript:The Definitive Guide（作者 David Flanagan，出版商 O'Reilly & Associates）提供有关每个 JavaScript 函数、对象、方法、属性和事件处理程序的参考信息。

CGI Scripts for Fun and Profit 是一篇由 Hotwired Webmonkey 站点提供的文章，它介绍如何在页面中包括现成的 CGI（通用网关接口）脚本。

CGI 资源索引 是一个 CGI 所有相关内容的存储库，其中包括现成的脚本、文档、书籍甚至还有求职的编程人员。

Common Gateway Interface（通用网关接口）站点 包括对 CGI 的介绍。

上一页


了解工作区

若要从使用 Macromedia Dreamweaver MX 的过程中最大程度地获益，您应了解 Dreamweaver 工作区背后的基本概念，并且了解如何选择选项、如何使用检查器和面板以及如何设置最适合您工作风格的参数。

本章包含以下主题：

  • 使用 Dreamweaver 工作区
  • 使用 Dreamweaver 窗口和面板
  • 与其他应用程序一起使用 Dreamweaver
  • 自定义 Dreamweaver：基础
下一页


使用 Dreamweaver 工作区

本节描述 Windows 和 Macintosh 中工作区的主要元素，并解释如何在 Windows 中选择初始工作区布局。

在 Windows 中，Dreamweaver MX 提供了两种可供选择的工作区布局：一种将全部元素置于一个窗口中的集成布局和一种非常类似于 Dreamweaver 4 的浮动布局。请参阅选择工作区布局（仅适用于 Windows）。

在 Macintosh 中，只能使用浮动布局。请参见关于浮动工作区布局（Windows 和 Macintosh）。


选择工作区布局（仅适用于 Windows）

在 Windows 中首次启动 Dreamweaver 时，会出现一个对话框让您选择一种工作区布局。如果您以后改变了主意，可以使用“参数选择”对话框切换到一种不同的工作区。

选择工作区布局：

选择下列布局之一：

Dreamweaver MX 工作区这是一个使用 MDI（多文档界面）的集成工作区，其中全部“文档”窗口和面板被集成在一个更大的应用程序窗口中，并将面板组停靠在右侧。建议大多数用户使用它。

备注： 本帮助系统的大部分内容假定您使用的是集成 Dreamweaver MX 工作区。

HomeSite/代码编写者样式的 Dreamweaver MX 工作区这是同样的集成工作区，但是将面板组停靠在左侧，布局类似于 Macromedia HomeSite 和 Macromedia ColdFusion Studio 所用的布局，而且“文档”窗口在默认情况下显示“代码”视图。建议 HomeSite 或 ColdFusion Studio 用户以及其他需要使用熟悉的工作区布局的手工编码人员使用这种布局。若要选择这种布局，请选择“Dreamweaver MX 工作区”选项，然后选择“HomeSite/代码编写者样式”选项。

备注： 在这两种集成工作区布局的任何一种布局中，您都可以在工作区的任何一侧停靠面板组。

Dreamweaver 4 工作区这是一种与 Dreamweaver 4 中所用布局相类似的工作区布局，其中每个文档都位于自己的独立浮动窗口中。面板组停靠在一起，但并不是停靠在一个更大的应用程序窗口中。仅建议喜欢使用更熟悉的工作区的 Dreamweaver 4 用户使用这种布局。

在选择一种工作区后切换到另一种工作区：
  1. 选择“编辑”>“参数选择”。
  2. 在左侧的“分类”列表中选择“常规”类别（如果仍未选定）。
  3. 单击“更改工作区”按钮。
  4. 选择一种工作区布局，然后单击“确定”。

    5. 出现一条警告信息，通知您重新启动 Dreamweaver 后将出现新的布局。

  5. 单击“确定”退出该警告信息。
  6. 再次单击“确定”以退出“参数选择”对话框。
  7. 退出 Dreamweaver 并重新启动它。


关于集成的 Dreamweaver MX 工作区（仅适用于 Windows）

在 Windows 中的集成 Dreamweaver MX 工作区中，全部窗口和面板都被集成到一个更大的应用程序窗口中。

HomeSite/代码编写者样式工作区具有相同的元素，但是其面板组停靠在主窗口的左侧而不是右侧。在这种工作区布局中，属性检查器默认情况下处于折叠状态，“文档”窗口默认情况下以“代码”视图显示。

Macintosh 中不支持集成工作区。Macintosh 中的工作区由浮动窗口和面板组成。Windows 用户可以使用“参数选择”对话框切换到浮动工作区；有关更多信息，请参见选择工作区布局（仅适用于 Windows）。

有关窗口和面板的简要概述，请参见关于窗口和面板。有关特定窗口和面板的更多详细信息，请参见使用 Dreamweaver 窗口和面板。


关于浮动工作区布局（Windows 和 Macintosh）

在 Dreamweaver 4 样式工作区布局中，每个文档都位于自己的单独窗口中。面板组最初停靠在一起，但是可以将它们取消停靠使其位于自己的窗口中。

在浮动工作区中，当您拖动窗口或调整它们的大小时，窗口将自动彼此对齐或者与屏幕的边沿、“文档”窗口对齐。这使得在 Dreamweaver 中移动和排列不同的浮动面板和窗口更加容易。

Windows 用户可以使用“参数选择”对话框切换到将全部元素置于一个窗口中的集成工作区；有关更多信息，请参见使用 Dreamweaver 工作区。

有关窗口和面板的简要概述，请参见关于窗口和面板。有关特定窗口和面板的更多详细信息，请参见使用 Dreamweaver 窗口和面板。


关于窗口和面板

本节简要描述一些在浮动和集成工作区布局中都出现的元素。有关特定窗口和面板的更多信息，请参见使用 Dreamweaver 窗口和面板。

“欢迎使用”窗口提供有关针对各种目的设置工作区的提示，并为使用过 Dreamweaver 早期版本的用户提供有关新功能的信息。

“插入”栏包含用于将各种类型的“对象”（如图像、表格和层）插入到文档中的按钮。每个对象都是一段 HTML 代码，允许您在插入它时设置不同的属性。例如，您可以在“插入”栏中单击“图像”图标插入一个图像。如果您愿意，可以不使用“插入”栏而使用“插入”菜单插入对象。

“文档”工具栏包含按钮和弹出式菜单，它们提供各种“文档”窗口视图（如“设计”视图和“代码”视图）、各种查看选项和一些普通操作（如在浏览器中预览）。

“标准”工具栏（在默认工作区布局中不显示）包含来自“文件”和“编辑”菜单中普通操作的按钮：“新建”、“打开”、“保存”、“保存全部”、“剪切”、“拷贝”、“粘贴”、“撤消”和“重做”。若要显示“标准”工具栏，请选择“查看”>“工具栏”>“标准”。

“文档”窗口显示您当前创建和编辑的文档。

属性检查器用于查看和更改所选对象或文本的各种属性。每种对象都具有不同的属性。（在编码器样式工作区布局中，默认情况下不展开。）

“文档”窗口底部的状态栏中的标签选择器显示在“设计”视图中环绕当前选定内容的标签的层次结构。单击该层次结构中的任何标签以选择该标签及其全部内容。（它在“代码”视图中不可见，因此在编码器样式工作区布局中，默认情况下不可见。）有关更多信息，请参见使用标签选择器编辑代码。

面板组是组合在一个标题下面的相关面板的集合。若要展开一个面板组，请单击组名称左侧的展开箭头；若要取消停靠一个面板组，请拖动该组标题条左边缘的手柄。

“站点”面板使您可以管理组成站点的文件和文件夹。有关更多信息，请参见关于“站点”面板。它还提供了本地磁盘上全部文件的视图，非常类似于 Windows 资源管理器 (Windows) 或 Finder (Macintosh)。

快速启动条（在默认工作区布局中不显示）在状态栏中显示用于打开和关闭最常用面板和检查器的按钮。若要显示快速启动条并指定其中显示哪些图标，请参见设置“面板”参数。

Dreamweaver 提供了许多此处未说明的其他面板、检查器和窗口，如“历史记录”面板和代码检查器。大多数面板可以一起停靠在面板组中。若要打开 Dreamweaver 面板、检查器和窗口，请使用“窗口”菜单。“窗口”菜单中项目旁的复选标记表示指定的项目当前是打开的（虽然它可能隐藏在其它窗口后面）。若要显示一个当前未打开的项目，请从菜单中选择项目名称。

如果您找不到一个标记为打开的面板、检查器或窗口，请选择“窗口”>“排列面板”以整齐地列出全部打开的面板。


使用 Dreamweaver 窗口和面板

本节解释如何使用各种特定的窗口、工具栏、面板、检查器和 Dreamweaver 工作区的其它元素。


关于“文档”窗口

“文档”窗口显示当前文档。可以选择下列任一视图：

  • “设计”视图，这是一个用于可视化页面布局、可视化编辑和快速应用程序开发的设计环境。在该视图中，Dreamweaver 显示文档的完全可编辑的可视化表示形式，类似于在浏览器中查看页面时看到的内容。您可以配置“设计”视图以在处理文档时显示动态内容（请参见在“设计”视图中查看活动数据）。
  • “代码”视图，这是一个用于编写和编辑 HTML、JavaScript、服务器语言代码（如 Microsoft Active Server Page (ASP) 或 ColdFusion 标记语言）以及任何其他类型代码的手工编码环境。有关更多信息，请参见Dreamweaver 中的编码。
  • “代码和设计”视图使您可以在单个窗口中同时看到同一文档的“代码”视图和“设计”视图。

若要在两个视图之间快速切换，请按 Control+代字号 (~) (Windows) 或 Command+反引号 (‘) (Macintosh)。

当“文档”窗口有一个标题条时，标题条显示页面标题，并在括号中显示文件的路径和文件名。如果您做了更改但仍未保存，则 Dreamweaver 在文件名后显示一个星号。

当“文档”窗口在集成工作区布局（仅适用于 Windows）中处于最大化状态时，它没有标题条；在这种情况下，页面标题以及文件的路径和文件名显示在主工作区窗口的标题条中。


关于状态栏

“文档”窗口底部的状态栏提供与您正创建的文档有关的其他信息。

标签选择器显示环绕当前选定内容的标签的层次结构。单击该层次结构中的任何标签以选择该标签及其全部内容。单击 <body> 以选择文档的整个正文。若要设置标签选择器中某个标签的 class 或 id 属性，请右击 (Windows) 或按住 Control 并单击 (Macintosh) 该标签，然后从上下文菜单中选择一个类或 ID。

“窗口大小”弹出式菜单（仅当显示“设计”视图时可见）用来将“文档”窗口的大小调整到预定义或自定义的尺寸。请参见调整“文档”窗口的大小。

“窗口大小”弹出式菜单的右侧是页面（包括全部相关的文件，如图像和其他媒体文件）的文档大小和估计下载时间。请参见设置下载时间和大小。

有关创建新文档（以及使用 Dreamweaver 所提供的预设计文档）的信息，请参见设置文档。


调整“文档”窗口的大小

状态栏显示当前“文档”窗口的当前尺寸（以像素为单位）。若要设置窗口大小以适合几种普通显示器大小中的任何一个，请单击窗口大小并从“窗口大小”弹出式菜单中选择一种大小。对于不那么精确的大小调整，请使用操作系统的标准窗口大小调整方法，如拖动窗口的右下角。在集成工作区（仅适用于 Windows）中，您可以将“文档”窗口最大化以便它填充集成窗口的整个文档区域。

备注： 当“文档”窗口在集成工作区中最大化时，不能调整它的大小。

当“文档”窗口处于最大化状态时，出现在“文档”窗口底部的选项卡显示全部打开文档的文件名。若要切换到某个文档，请单击它的选项卡。

若要设计在某个特定大小时看起来效果最好的页面，您可以将“文档”窗口调整到任一预定义大小、编辑这些预定义大小或者创建新的大小。

备注： 显示的窗口大小反映浏览器窗口的内部尺寸（不包括边框）；显示器大小列在括号中。例如，如果您的访问者可能按其默认配置在 640 x 480 显示器上使用 Microsoft Internet Explorer 或 Netscape Navigator，则您应使用“536 x 196（640 x 480，默认）”的大小。

将“文档”窗口的大小调整为预定义的大小：

从“文档”窗口底部的弹出式菜单中选择一种大小。

更改“窗口大小”弹出式菜单中所列的值：
  1. 从“窗口大小”弹出式菜单中选择“编辑大小”。
  2. 在“窗口大小”列表中单击任一宽度或高度值，然后键入一个新值。

    3. 若要使“文档”窗口仅调整为某个特定的宽度（高度保持不变），请选择一个高度值然后删除它。

  3. 单击“描述”文本框以输入关于某个特定大小的说明性文本。
  4. 单击“确定”保存更改并返回到“文档”窗口。
向“窗口大小”弹出式菜单中添加新的大小：
  1. 从“窗口大小”弹出式菜单中选择“编辑大小”。
  2. 单击“宽度”列中最后一个值下面的空白。
  3. 输入“宽度”和“高度”的值。若要仅设置“宽度”或“高度”，只需将一个域保留为空。
  4. 单击“描述”域以输入关于所添加大小的说明性文本。
  5. 单击“确定”保存更改并返回到“文档”窗口。

    6. 例如，您可能在一个 800 x 600 像素显示器项的旁边键入 SVGA 或平均 PC，而在一个 832 x 624 像素显示器项的旁边键入 17 英寸 Mac。大多数显示器可以调整为不同的像素尺寸。

将“文档”窗口最大化（仅适用于 Windows 集成工作区）：

单击“文档”窗口标题条中的“最大化”按钮。


设置“状态栏”参数

若要为状态栏设置参数，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从左侧的“分类”列表中选择“状态栏”。（有关更多信息，请参见关于状态栏。）

“窗口大小”使您可以自定义出现在状态栏弹出式菜单中的窗口大小。请参见调整“文档”窗口的大小。

“连接速度”确定用以计算下载大小的连接速度（以 KB/秒为单位）。页面的下载大小显示在状态栏中。当在“文档”窗口中选定一个图像时，图像的下载大小显示在属性检查器中。


使用快速启动条

快速启动条显示在状态栏中，包含用以打开和关闭各种面板、检查器和窗口的按钮。

若要显示快速启动条，请在“面板”参数选择中启用“在面板和启动器中显示图标”选项。可以指定在快速启动条中显示哪些项目。有关更多信息，请参见设置“面板”参数。


使用文档工具栏

文档工具栏中包含按钮，这些按钮使您可以在文档的不同视图间快速切换：“代码”视图、“设计”视图、同时显示“代码”和“设计”视图的拆分视图以及“实时数据”视图（请参见在“设计”视图中查看活动数据）。工具栏中还包含一些与查看文档、在本地和远程站点间传输文档以及调试 JavaScript 代码有关的普通命令和选项。

若要查看或隐藏文档工具栏，请选择“查看”>“工具栏”>“文档”。

以下选项出现在文档工具栏中：

  • “显示代码视图”仅在“文档”窗口中显示“代码”视图。
  • “显示代码视图和设计视图”在“文档”窗口的一部分中显示“代码”视图，而在另一部分中显示“设计”视图。

    • 当选择了这种组合视图时，“视图选项”菜单中的“在顶部查看设计视图”选项变为可用。请使用该选项指定在“文档”窗口的顶部显示哪种视图。

  • “显示设计视图”仅在“文档”窗口中显示“设计”视图。

    • 您还可以在“查看”菜单中选择视图。

  • “标题”允许您为文档输入一个标题，它将显示在浏览器的标题条中。

    • 如果文档已经有了一个标题，则该标题将显示在该区域中。

  • “文件管理”显示“文件管理”弹出式菜单。
  • “在浏览器中预览/调试”允许您在浏览器中预览或调试文档。从该弹出式菜单中选择一个浏览器。

    • 若要向菜单中添加浏览器或者更改列出的浏览器，请选择“编辑浏览器列表”。

“刷新设计视图”当您在“代码”视图中进行更改后刷新文档的“设计”视图。

在执行某些操作（如保存文件或单击该按钮）之前，您在“代码”视图中所做的更改不会自动显示在“设计”视图中。

  • “参考”显示“参考”面板。

    • “参考”面板包含有关 HTML、CSS、JavaScript、CFML、ASP 和 JSP 的参考信息。有关更多信息，请参见访问语言参考。

  • “代码导航”允许您在 JavaScript 代码中进行导航。有关更多信息，请参见使用 JavaScript 调试器。
  • “视图选项”允许您为“代码”视图和“设计”视图设置选项，其中包括对哪个视图显示在上面进行选择。

    • 有关“代码”视图选项的更多信息，请参见设置查看参数。

    “设计”视图选项允许您同时隐藏全部的可视化助理（如表格边框、层边框和框架边框），或者根据需要显示或隐藏单个的可视化助理。这些选项还允许您查看头内容和可视化向导。这些选项还可以在“查看”菜单中找到。有关它们的更多信息，请参见选择“文档”窗口中的元素、查看和编辑头内容和在设计过程中使用可视化向导。

    当同时显示“代码”视图和“设计”视图时，两组选项都可以在菜单中使用。


使用“标准”工具栏

“标准”工具栏中包含“文件”和“编辑”菜单中的普通操作的按钮：“新建”、“打开”、“保存”、“保存全部”、“剪切”、“拷贝”、“粘贴”、“撤消”和“重做”。请像使用等价的菜单命令一样使用这些按钮。有关诸如“打开”和“保存”等操作的更多信息，请参见设置文档。

若要显示“标准”工具栏，请选择“查看”>“工具栏”>“标准”。


使用上下文菜单

Dreamweaver 广泛使用了上下文菜单，使用这种菜单可以很方便地访问与正在处理的对象或窗口有关的最有用的命令和属性。上下文菜单仅列出那些适用于当前选定内容的命令。

使用上下文菜单：
  1. 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 对象或窗口。

    2. 选定对象或窗口的上下文菜单随即出现。

  2. 从该上下文菜单中选择一个命令。
    这是所描述的功能的图片。


使用“插入”栏

“插入”栏包含用于创建和插入对象（如表格、层和图像）的按钮。这些按钮被组织到选项卡中。

显示或隐藏“插入”栏：

选择“窗口”>“插入”。

展开或折叠“插入”栏：

单击“插入”栏标题条左角处的展开箭头。

若要更改“插入”栏的方向，请执行下列操作之一（仅适用于 Macintosh）：
  • 若要将“插入”栏从水平方向更改为垂直方向，请单击右上角附近的垂直方向图标。
    这是所描述的功能的图片。
  • 若要将“插入”栏从垂直方向更改为水平方向，请单击右下角附近的水平方向图标。
    这是所描述的功能的图片。
若要显示某个特定选项卡中的按钮，请执行以下操作之一：
  • 如果“插入”栏以水平配置选项卡的形式显示，请单击一个选项卡。
  • 如果“插入”栏以垂直配置的形式显示（仅适用于 Macintosh），请单击该栏顶部的类别名称，然后从出现的弹出式菜单中选择一个类别。
插入对象：
  1. 在“插入”栏中选择适当的选项卡。
  2. 单击一个对象按钮或将该按钮的图标拖到“文档”窗口中。

    3. 根据对象的不同，可能会出现一个相应的对象插入对话框，提示您浏览到一个文件或者为对象指定参数。

绕过对象插入对话框并插入空的占位符对象：

按住 Control 键并单击 (Windows) 或者按住 Option 键并单击 (Macintosh) 该对象的按钮。

例如，若要为一个图像插入一个占位符而不指定图像文件，请按住 Control 键并单击或者按住 Option 键并单击“图像”按钮。

备注： 该过程不会绕过所有对象插入对话框。包括导航条、层、Flash 按钮和框架集在内的许多对象都不插入占位符或采用默认值的对象。

“插入”栏中包含以下几个选项卡：“常用”、“布局”、“文本”、“表”、“框架”、“表格”、“模板”、“字符”、“媒体”、“文件头”、“脚本”和“应用程序”。在当前文档中包含服务器代码（如 ASP 或 CFML 文档）时，将出现附加的选项卡。

  • “应用程序”选项卡允许您插入动态元素，如记录集、重复区域以及记录插入和更新表单。有关动态内容的信息，请参见向 Web 页中添加动态内容。
  • “字符”选项卡包含特殊字符，如版权符号、弯曲的引号和商标符号。请注意，其中的一些符号可能在 Internet Explorer 3.0 版和更早的版本以及 Netscape Navigator 浏览器中不能正确显示。
  • “常用”选项卡包含用于创建和插入最常用对象（如图像、表格和层）的按钮。
  • “表格”选项卡包含用于创建表单和插入表单元素的按钮。
  • “框架”选项卡包含普通的框架集布局。
  • “文件头”选项卡包含用于添加各种文件头元素（如 Meta 和基础标签）的按钮。
  • “布局”选项卡允许您插入表格和层，并且使您可以在以下两种表格视图之间进行选择：“标准”（默认）视图和“布局”视图。当选定“布局”视图时，您可以使用 Dreamweaver 布局工具：“绘制布局单元格”和“绘制布局表格”。有关更多信息，请参见在布局视图中对页进行布局。
  • “媒体”选项卡包含用于插入动画媒体对象或交互式媒体对象（如 Flash 按钮和文本、Java applets 和 ActiveX 对象）的按钮。有关更多信息，请参见插入媒体。
  • “脚本”选项卡允许您插入脚本、无脚本部分或服务器端包含。
  • “表”选项卡允许您插入完整的表格或特定的表格标签（如 tr、th 或 td）。
  • “模板”选项卡允许您在模板文件中插入可编辑的、可选的和重复的区域。有关更多信息，请参见关于 Dreamweaver 模板。
  • “文本”选项卡允许您插入各种文本格式设置标签和列表格式设置标签，如 b、em、p、h1 和 ul。

    • 备注： 虽然“文本”选项卡中的一些按钮看起来类似于文本属性检查器中的一些按钮，但是它们的功能不同。“文本”选项卡中的按钮仅插入代码，不反映选定内容的当前状态；如果选定内容是粗体文本，则属性检查器中的“粗体”按钮显示为选定状态，而“文本”选项卡中的“粗体”按钮则不会这样。

  • 服务器代码选项卡仅对使用特定服务器语言的页面可用，这些语言包括：ASP、ASP.NET、CFML 基础、CFML 流、CFML 高级、JSP 和 PHP。这些选项卡中的每一个都提供您可以在“代码”视图中插入的服务器代码对象。

如果给定选项卡中的对象并非同时全部可见，则“插入”栏左下角处会显示一个小箭头；若要查看该选项卡中的其余对象，请单击该箭头。

当您单击一个对象按钮时，Dreamweaver 将代码插入到文档中。在有些情况下，代码会立刻插入；而在其它情况下，会出现一个标签编辑器（请参见使用标签编辑器编辑标签）或其它对话框，允许您在插入代码前指定进一步的信息。对于有些对象，如果您在“设计”视图中插入对象则不会出现对话框，而如果在“代码”视图中插入对象则会出现一个标签编辑器。对于少数对象，在“设计”视图中插入对象会导致 Dreamweaver 在插入对象前切换到“代码”视图。

在浏览器窗口中查看页面时，有些对象（如命名锚记）不可见。若要在“设计”视图中显示标记此类不可见对象的位置的图标，请选择“查看”>“可视化助理”>“不可见元素”。若要在“设计”视图中选择不可见的对象，请单击其图标。有关更多信息，请参见关于不可见元素。

有些“常规”参数设置会影响“插入”栏。若要修改这些参数，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从左侧的“分类”列表中选择“常规”。

  • 当您插入诸如图像、表格、脚本和头元素等对象时，将有一个对话框提示您给出附加信息。若要取消这些对话框，您需要禁用“插入对象时显示对话框”选项或者在创建对象时按下 Control 键 (Windows) 或 Option 键 (Macintosh)。当您在禁用该选项的情况下插入对象时，将给该对象指定默认属性值。插入对象后，可以使用属性检查器更改对象的属性。
  • “插入”栏选项使您可以将“插入”栏的内容仅显示为图标、文本或者同时显示为文本和图标。

您可以修改“插入”栏中的任何对象或创建您自己的对象；请参见“Macromedia 支持中心”上的“自定义 Dreamweaver ”。


使用“插入”栏：应用程序

“插入”栏中的“应用程序”选项卡允许您向页面添加服务器行为。

有关更多信息，请参阅向页面添加服务器行为。


使用“插入”栏：字符

“插入”栏中的“字符”选项卡允许您插入特殊字符。

“换行符”在插入点处插入一个换行符。您还可以按下 Shift+Enter (Windows) 或 Shift+Return (Macintosh) 以插入一个换行符。

“不换行空格”在插入点处插入一个不换行的空格 (&nbsp;)。

“左引号”、“右引号”和“破折线”在插入点处插入标点符号。

“英镑符号”、“欧元符号”和“日元符号”在插入点处插入货币符号。

“版权”、“注册商标”和“商标”在插入点处插入相应的符号。

“其它字符”提供了一组特殊字符（如 é 和 ç，当在您选择了一个字符并单击“确定”后，它将插入到插入点处。


使用“插入”栏：常用

“插入”栏中的“常用”选项卡允许您插入最常用的对象。

“超级链接”和“电子邮件链接”在插入点处或在当前选定内容后面紧跟着插入超文本链接。请参阅创建链接。

“命名锚记”在插入点处放置一个命名锚记 (a name="")。出现一个对话框；可以为该锚记输入一个名称。请参阅链接到文档中的特定位置。

“插入表格”在插入点处放置一个表格。请参阅使用表格显示内容。

“描绘层”创建一个层。单击“层”按钮，然后将指针移动到“文档”窗口并拖动以定义层的大小和位置。默认情况下，Dreamweaver 创建一个由 div 标签定义的层。可以使用属性检查器选择一个不同的标签，或者使用“层”参数选择更改默认设置。请参阅在页面上创建层。

“图像”在插入点处插入一个图像。出现一个对话框，以便您可以指定一个图像文件。请参阅插入图像。

“图像占位符”在插入点处插入一个图像占位符。将出现一个对话框，使您可以为占位符指定名称和尺寸。请参阅插入图像占位符。

“Fireworks HTML”在插入点处放置一个由 Fireworks 产生的 HTML 文件。请参阅Dreamweaver 与其他应用程序的集成。

“鼠标经过图像”提示您指定两个用于定义鼠标经过图像的图像文件。鼠标经过图像是一个当指针移过它时会发生改变的图像。请参阅创建鼠标经过图像。

“导航条”插入一组用于在站点中导航的图像。请参阅创建导航条。

“水平线”在插入点处放置一个水平线。请参阅使用水平线。

“日期”在插入点处放置当前日期。出现一个对话框，您可以在其中指定日期的格式，并指示 Dreamweaver 是否应该在您每次保存文件时自动更新日期。请参阅插入日期。

“表格数据”在插入点处创建一个表格，并在其中填充某个定界的文本文件（如从 Microsoft Excel 或数据库中导出的文件）中的表格数据。请参阅导入表格式数据。

“标签选择器”允许您从分类标签的层次结构树中选择一个要插入的标签。请参阅使用标签选择器插入标签。

“注释”在 HTML 中的插入点处放置一个注释。如果您处于“设计”视图中，则会出现一个对话框；可以为注释输入文本。请参阅插入 HTML 注释。


使用“插入”栏：表单

“插入”栏中的“表单”选项卡包含用于创建表单和插入表单元素的按钮。

表单仅仅是表单元素的容器；除非选择了“查看”>“可视化助理”>“不可见元素”，否则表单边框在“文档”窗口中不可见。请参阅设置“不可见元素”参数。

在插入表单元素之前，将插入点放在表单边框之内；位于 form 标签外部的表单元素不会在所有浏览器中都显示。如果您试图在表单的外部插入表单元素，将有一个对话框询问是否在该表单元素的周围添加一个表单标签；单击“是”将创建一个包含该元素的新表单，单击“否”将插入该元素而不创建表单。

有关更多信息，请参阅创建交互式表单。

“表单”在插入点处放置一个表单。

“文本域”在插入点处放置一个文本域。在属性检查器中设置名称、大小和初始值。请参阅设置“文本域”属性检查器。

“隐藏域”在插入点处插入一个隐藏域。在属性检查器中设置名称和值。请参阅创建隐藏域。

“文本区域”在插入点处插入一个多行文本域。

“复选框”和“单选按钮”在插入点处放置相应的控件。在属性检查器中设置名称、选中后的值和初始状态。请参阅插入复选框和单选按钮。

“单选按钮组”在插入点处插入一组单选按钮。

“列表/菜单”在插入点处放置一个列表或弹出式菜单。在属性检查器中设置名称、类型和列表值。请参阅设置“列表/菜单属性”检查器选项。

备注： 术语“弹出式菜单”在 Dreamweaver 中至少可以应用到两个不同的事物上。该对象在表单中插入一个弹出式菜单域，以让访问者在填表单时选择一个值。有关插入图形弹出式导航菜单的信息，请参阅显示弹出式菜单。

“跳转菜单”在插入点处放置一个弹出式 URL 菜单。从菜单中选择一个值会将用户转到该 URL。在出现的对话框中设置值列表。请参阅创建跳转菜单。

“图像域”在插入点处放置一个图像域。在属性检查器中设置名称、大小、替换文本和源文件。请参阅创建图形化“提交”按钮。

“文件域”在插入点处放置一个文件上传域。在属性检查器中设置名称、大小和初始值。请参阅创建文件上传域。

“按钮”在插入点处放置一个按钮，该按钮具有“提交”的默认名称和值。在插入按钮前将插入点放在表单边框之内；表单外部的按钮并不是在所有浏览器中都显示。使用属性检查器设置名称、标签文字和操作。请参阅在属性检查器中设置“按钮”属性选项。

“标签文字”提供了一种在结构上将域的文本标签和该域关联起来的方法。

“域集”是表单元素逻辑组的容器标签。


使用“插入”栏：“框架”

“插入”栏中的“框架”选项卡包含用于创建普通框架集布局的按钮。请参阅使用框架。

“左侧框架”、“右侧框架”、“顶部框架”和“底部框架”中的每一个都创建一个框架集，并且向当前框架的某一侧添加一个狭窄的空框架。

“下方和嵌套的左侧框架”和“下方和嵌套的右侧框架”中的每一个都创建一个框架集，并且向当前框架的左侧或右侧添加一个狭窄的空框架，然后在这两个框架的下面添加另一个空框架。

“左侧和嵌套的下方框架”和“右侧和嵌套的下方框架”中的每一个都创建一个框架集，在当前框架的下面添加一个狭窄的空框架，然后向这两个框架的左侧或右侧添加另一个空框架。

“上方和下方框架”创建一个框架集，在当前框架的下面添加一个框架，然后在这两个框架的上面添加另一个框架。

“左侧和嵌套的上方框架”和“右侧和嵌套的上方框架”中的每一个都创建一个框架集，在当前框架的上面添加一个狭窄的空框架，然后向这两个框架的左侧或右侧添加另一个空框架。

“顶部和嵌套的左侧框架”和“上方和嵌套的右侧框架”中的每一个都创建一个框架集，向当前框架的左侧或右侧添加一个狭窄的空框架，然后在这两个框架的下面添加另一个空框架。


使用“插入”栏：“头文件”

“插入”栏中的“文件头”选项卡包含用于将元素添加到文档的 head 部分的对象。

“Meta”将一个 meta 标签插入到文档的 head 部分。出现一个对话框，您可以在其中输入 meta 属性的信息。请参阅设置 Meta 属性。

“关键字”将一个 meta name="keywords" 标签插入到文档的 head 部分。出现一个对话框，您可以在其中输入文档的关键字。请参阅设置关键字属性。

“说明”将一个“说明”meta 标签插入到文档的 head 部分。出现一个对话框，您可以在其中输入描述文档的文本。请参阅设置说明属性。

“刷新”将一个“刷新”meta 标签插入到文档的 head 部分。出现一个对话框，您可以在其中输入刷新前等待的秒数，以及是要重新载入当前页面还是转到新的页面。请参阅设置刷新属性。

“基础”将一个 base 标签插入到文档的 head 部分。出现一个对话框，您可以在其中输入文档链接的基础 URL。请参阅设置基本属性。

“链接”将一个 link 标签插入到文档的 head 部分。出现一个对话框，您可以在其中输入链接信息。请注意这不是一个超文本链接；它经常用来指定外部样式表。请参阅设置链接属性。


使用“插入”栏：“布局”

“插入”栏中的“布局”选项卡允许您在“标准”视图或“布局”视图中查看表格。在“布局”视图中，您可以绘制布局单元格和布局表格。

“插入表格”在插入点处放置一个表格。请参阅使用表格显示内容。

“描述层”创建一个层。单击“层”按钮，然后将指针移动到“文档”窗口并拖动以定义层的大小和位置。默认情况下，Dreamweaver 创建一个由 div 标签定义的层。可以使用属性检查器选择一个不同的标签，或者使用“层”参数选择更改默认设置。请参阅在页面上创建层。

“标准视图”将表格显示为网格。请参阅关于布局单元格和表格。

“布局视图”将表格显示为可以绘制、拖动和调整大小的框。请参阅关于布局单元格和表格。

“绘制布局单元格”使您可以在“文档”窗口的“设计”视图中绘制单独的表格单元格。请参阅关于布局单元格和表格。

“绘制布局表格”使您可以在“文档”窗口的“设计”视图中绘制完整表格。请参阅关于布局单元格和表格。


使用“插入”栏：“媒体”

“插入”栏中的“媒体”选项卡包含用于插入特殊的可配置对象（如插件和 applets）的按钮。

“Flash”使用 object 和 embed 标签在插入点处放置一个 Flash 影片。出现一个对话框，您可以在其中浏览到某个 SWF 文件。codebase、class id 和 pluginspage 属性已预设为 Macromedia Flash Player 的正确值；可以使用属性检查器指定影片的其它属性。请参阅设置 Flash 和 Shockwave 影片属性。

“Flash 按钮”和“Flash 文本”在插入点处放置 Flash 对象。请参阅插入 Flash 按钮对象和插入 Flash 文本对象。

“Shockwave”使用 object 和 embed 标签在插入点处放置一个 Macromedia Shockwave 影片。codebase、class id 和 pluginspage 属性已预设为 Shockwave 的正确值。出现一个对话框，以便您可以为影片指定一个 DCR 源文件，或者您也可以使用属性检查器指定一个源文件。请参阅设置 Flash 和 Shockwave 影片属性。

“Applets”在插入点处放置一个 Java applets。（Java applets仅当您在浏览器中查看文档时才会出现。）出现一个对象框，您可以在其中指定包含 applets 代码的文件，或者可以单击“取消”使源保持未指定状态。可以使用属性检查器指定 Java applets的其它属性。请参阅设置 Java applets 属性。

“参数”插入一个标签，该标签允许您将参数传递给 applets 或对象。

“ActiveX”在插入点处放置一个 ActiveX 控件。可以使用属性检查器为 ActiveX 控件指定源文件和其它属性。请参阅设置 ActiveX 属性。

“插件”使用 embed 标签插入一个文件（在插入点处），该文件需要一个用于回放的 Netscape Navigator 插件。出现一个对象框，您可以在其中指定源文件。请参阅设置 Netscape Navigator 插件属性。


使用“插入”栏：“脚本”

“插入”栏中的“脚本”选项卡允许您将与脚本撰写相关的元素插入到页面中。

“脚本”在插入点处放置一个脚本。出现一个对话框；可以选择语言并输入脚本文本。请参阅编辑脚本。

“无脚本”插入一个 无脚本部分，用于在已禁用脚本的浏览器中显示 HTML 代码。

“服务器端包含”在插入点处放置一个服务器端包含。出现一个对话框，您可以在其中为该包含选择源文件。请参阅使用 server-side include（服务器端包括）。


使用“插入”栏：“表格”

“插入”栏中的“表格”选项卡允许您插入与表格相关的标签。

“插入表格”在插入点处放置一个表格。将出现一个对话框，允许您指定表格属性，如行数和列数。请参阅使用表格显示内容。

“表格”、“表格行”、“表格标题”、“表格数据”和“表格题注”中的每一个都在插入点处插入一对与表格相关的标签（table、tr、th、td 或 caption）。请参阅使用表格显示内容。


使用“插入”栏：“模板”

“插入”栏中的“模板”选项卡允许您将文档保存为模板文件，以及将不同种类的区域插入到模板文件中。

有关更多信息，请参阅关于 Dreamweaver 模板。


使用“插入”栏：文本

“插入”栏中的“文本”选项卡允许您插入文本格式设置和段落格式设置标签。

备注： 虽然“文本”选项卡中的一些按钮看起来类似于文本属性检查器中的一些按钮，但是它们的功能不同。“文本”选项卡中的按钮仅插入代码，不反映选定内容的当前状态；如果选定内容是粗体文本，则属性检查器中的“粗体”按钮显示为选定状态，而“文本”选项卡中的“粗体”按钮则不会这样。

“字体标签编辑器”显示字体标签的标签编辑器，以便使您可以在插入标签前设置属性。请参阅使用标签编辑器编辑标签。

“粗体”、“斜体”、“强”和“强调”使用相应的 HTML 文本格式设置标签环绕选定内容。

“段落”、“块引用”和“预先格式化的文本”使用相应的 HTML 块标签环绕选定内容。

“标题 1”、“标题 2”和“标题 3”使用相应的 HTML 标题标签环绕选定内容。

“项目列表”、“编号列表”和“列表项”使用相应的 HTML 列表标签环绕选定内容。

“定义列表”、“定义术语”和“定义说明”使用相应的 HTML 定义列表标签环绕选定内容。

“缩写”和“首字母缩写词”插入标签，这些标签允许您为缩写或首字母缩写词指定完整文本，这对于搜索引擎和屏幕阅读器等有潜在的好处。


使用“插入”栏：ASP、ASP.NET、CFML 基础、CFML 流、CFML 高级、JSP 和 PHP

“插入”栏中的服务器代码选项卡包含用于插入各种服务器语言的有用代码段的按钮。这些选项卡中的每一个仅在使用特定服务器语言的文档中可用。这些选项卡中的更复杂对象提供了具有“帮助”按钮的对话框；要了解有关此类对象的信息，请单击“帮助”按钮。


使用属性检查器

属性检查器使您可以检查和编辑当前选定页面元素（如文本和插入的对象）的属性。您既可以在“设计”视图也可以在“代码”视图中选择页面元素。

若要显示或隐藏属性检查器，请选择“窗口”>“属性”。

您对属性所做的大多数更该会立刻应用在“文档”窗口中。但是对于有些属性，直到您在属性编辑文本域外单击、按下 Enter 键 (Windows) 或 Return 键 (Macintosh) 或者按下 Tab 键切换到其他属性时，才会应用更改。

属性检查器的内容根据选定的元素而变化。要了解有关特定属性的信息，请在“文档”窗口中选择一个元素，然后单击属性检查器右上角的“帮助”图标。

属性检查器最初显示选定元素的大多数属性。单击属性检查器右下角的展开箭头，可以折叠属性检查器使之仅显示最常用的属性。

提示： 在少数情况下，某些不重要的属性即使在展开的属性检查器中也可能不显示；在这些情况下，可以使用“代码”视图或代码检查器手工对这些属性进行编码，或者在“代码”视图中选择该标签然后选择“修改”>“编辑标签”。


管理面板和面板组

Dreamweaver 中的面板被组织到面板组中。每个面板组都可以展开或折叠，并且可以和其它面板组停靠在一起或取消停靠。面板组还可以停靠到集成的应用程序窗口中（仅适用于 Windows 集成工作区）。这使得能够很容易地访问所需的面板，而不会使工作区变得混乱。面板组内的面板显示为选项卡。

备注： 当一个面板组处于浮动（取消停靠）状态时，面板组的顶部会显示一个窄的空白条。在本文档中，“面板组的标题条”这个术语指的是面板组名称出现的区域，而不是这个窄的空白条。

若要展开或折叠一个面板组，请执行下列操作之一：
  • 单击面板组标题条左侧的展开箭头。
    这是所描述的功能的图片。
  • 单击面板组的标题。
在展开的面板组中选择一个面板：

单击该面板的选项卡。

取消停靠一个面板组：

通过手柄（在面板组标题条的左侧）拖动面板组，直到其轮廓表明它不再处于停靠状态为止。

将一个面板组停靠到其它面板组（浮动工作区）或停靠到集成窗口（仅适用于 Windows）：

通过手柄拖动面板组，直到其轮廓表明它处于停靠状态为止。

大多数面板仅能停靠在集成工作区中“文档”窗口区域的左侧或右侧，而另外一些面板（如属性检查器和“插入”栏）则仅能停靠在集成窗口的顶部或底部。

拖动一个浮动（取消停靠）面板组而不停靠它：

通过面板组标题条上方的条来拖动它。只要您不是通过手柄拖动面板组，它就不会停靠。

查看一个面板组的“选项”菜单：

通过单击展开箭头展开该面板组。

“选项”菜单仅当面板组展开时才可见。

提示： 即使在面板组处于折叠状态时，面板组的上下文菜单中的某些选项仍然可用；右击 (Windows) 或按住 Control 键并单击 (Macintosh) 面板组的标题条可以查看上下文菜单。

重命名面板组：
  1. 从面板组标题条右侧的“选项”菜单中选择“重命名面板组”。
    这是所描述的功能的图片。
  2. 输入一个新的名称并单击“确定”。
从面板组中取消停靠一个面板：

通过其选项卡拖动该面板，直到其轮廓表明它不再处于停靠状态为止。

该面板出现在一个由它自己组成的新的面板组中。

在面板组中停靠一个面板：

通过其选项卡拖动该面板，直到其轮廓表明它处于停靠状态为止。

若要最大化一个面板组，请执行下列操作之一：
  • 从面板组标题条中的“选项”菜单中选择“最大化面板组”。
  • 在面板组标题条的任何位置双击。

    • 面板组将垂直增长以填充全部可用垂直空间。

关闭一个面板组使它完全消失：

从面板组标题条中的“选项”菜单中选择“关闭面板组”。

该面板组即从屏幕上消失。

打开屏幕上不可见的面板组：

从“窗口”菜单中选择一个面板的名称。

更改整个面板组集合的大小（仅适用于浮动工作区）：

如同拖动以调整操作系统中任何窗口的大小一样，可以拖动以调整面板组集合的大小。例如，您可以拖动面板组集合的右下角的调整大小区域。


设置“面板”参数

使用“面板”参数选择指定哪些面板和检查器总是显示在“文档”窗口的前面，而哪些可以被“文档”窗口遮盖。您还可以使用“面板”参数选择指定图标是否出现在面板的选项卡中、是否显示快速启动条以及在快速启动条中显示哪些面板和检查器。

若要设置面板的参数，请选择“编辑”>“参数选择”，然后从左侧的“分类”列表中选择“面板”。然后选择下列任一选项：

“总在最上层”使您可以指定哪些面板总是显示在“文档”窗口的前面。默认情况下，所有面板、检查器和其他此类窗口总是“浮动”在“文档”窗口的前面。如果您在该列表中取消选择一个项目，则您可以将“文档”窗口移动到该项目的前面。

例如，若要允许“文档”窗口遮盖属性检查器，可以取消选择“属性”选项。这样，仅当属性检查器处于活动状态时，它才显示在“文档”窗口的前面。

若要允许“文档”窗口遮盖任何您已通过自定义 Dreamweaver 添加的浮动面板，请取消选择“所有其他面板”。

备注： 当全部面板都被停靠时，“总在最上层”选项在集成工作区中不适用。

“在面板和启动器中显示图标”决定是否显示快速启动条。当选定该选项时，快速启动条显示在状态栏区域中，并且在每个面板的选项卡中显示一个小图标。（请参见关于状态栏。）快速启动条中的按钮用于打开面板和检查器。

“在启动器中显示”指定在快速启动条中显示哪些项目。

指定在快速启动条中显示哪些项目：
  1. 若要向快速启动条中添加项目，请单击加号 (+) 按钮。
  2. 若要从快速启动条中删除项目，请选择该项目，然后单击减号 (-) 按钮。
  3. 若要更改快速启动条中项目的顺序，请选择列表中的一个项目，然后单击箭头按钮。

    4. 例如，若要将一个项目移动到快速启动条的右侧，可以在列表中向下移动该项目。

  4. 单击“确定”。

    5. 快速启动条将更改以显示您指定的项目。


关于“站点”面板

“站点”面板允许您定义一个站点、管理站点的本地文件、向远程站点上传文件或者从远程站点下载文件以及浏览本地磁盘上站点外部的文件。有关使用“站点”面板的详细信息，请参见管理您的站点。


关于“历史记录”面板

“历史记录”面板显示自从您创建或打开某个文档以来在该活动文档中所执行的步骤列表，列表中步骤的数目最多为指定的最大步骤数。（“历史记录”面板并不显示您在其他框架、其他“文档”窗口或“站点”面板中执行的步骤。）它允许您撤消一个或多个步骤；它还允许您重放步骤以及创建将重复任务自动化的新命令。

“历史记录”面板中的滑块（拇指）最初指向所执行的最后一个步骤。


使用“历史记录”面板

“历史记录”面板跟踪您在 Dreamweaver 中工作的每一个步骤。您可以使用“历史记录”面板一次撤消多个步骤。

如果您想撤消在文档中执行的最后一个操作，请选择“编辑”>“撤消”，就如同您在任何其它应用程序中所做的那样。（“编辑”菜单中的“撤消”命令的名称将更改以反映所执行的最后一个操作。）

“历史记录”面板还用来重放已经执行过的步骤，并且通过创建新的命令将任务自动化。有关更多信息，请参见关于任务自动化。

打开“历史记录”面板：

选择“窗口”>“其他”>“历史记录”。

撤消最后一个步骤：

在列表中将“历史记录”面板的滑块向上拖动一个步骤。这与选择“编辑”>“撤消”具有相同的效果。

撤消的步骤变为灰色。

若要一次撤消多个步骤，请执行下列操作之一：
  • 拖动滑块以指向任何一个步骤。
  • 在滑块路径上的某个步骤的左侧单击，滑块将自动滚动到该步骤，并在滚动的时候撤消所经过的步骤。

备注： 若要自动滚到某个特定的步骤，您必须单击该步骤的左侧；单击该步骤本身只是选择该步骤。选择一个步骤不同于在您的撤消历史记录中返回到该步骤。

对于撤消单个步骤来说，如果您撤消了一系列步骤，然后在文档中执行了新的操作，则您不能够重做撤消过的步骤；它们将从“历史记录”面板中消失。

设置“历史记录”面板保留和显示的步骤数：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从“分类”列表中选择“常规”。
  2. 为“历史步骤最多次数”输入一个数字。

    3. 默认值应该足够满足大多数用户的需要。这个数字越高，“历史记录”面板需要的内存就越大。这会明显地影响性能并使计算机变慢。当“历史记录”面板达到该最大步骤数时，将放弃最早的步骤。

备注： 不能对“历史记录”面板中的步骤进行重新排序。不要将“历史记录”面板看作一个任意的命令集合；应该将它看作一种按照步骤的执行顺序来查看它们的方法。

删除当前文档的历史记录列表：

在“历史记录”面板的上下文菜单中，选择“清除历史记录”。

该命令还清除当前文档的全部撤消信息；选择“清除历史记录”后，您将无法撤消被清除的步骤。（请注意“清除历史记录”并不撤消步骤；它只是从 Dreamweaver 的内存中删除这些步骤的记录。）


关于“解答”面板

“解答”面板使您可以快速访问能够帮助您有效使用 Dreamweaver 的信息。这些信息包括教程、技术说明、Dreamweaver 功能扩展和其他有用的内容。

若要从 macromedia.com 获取最新的 Dreamweaver 信息，请单击“更新”按钮。


与其他应用程序一起使用 Dreamweaver

Dreamweaver 通过使您容易地使用其他应用程序，方便了网页设计和开发过程。有关使用浏览器、HTML 编辑器、图像编辑器和动画工具等其它应用程序的信息，请参见以下主题：

  • 有关与 HomeSite 或 BBEdit 等其他 HTML 编辑器一起使用 Dreamweaver 的信息，请参见将外部 HTML 编辑器用于 Dreamweaver。
  • 您可以指定用来预览站点的首选浏览器。请参见在浏览器中预览页面。
  • 您可以从 Dreamweaver 内启动外部图像编辑器，如 Macromedia Fireworks。请参见使用外部图像编辑器。
  • 您可以配置 Dreamweaver 使其为每个文件类型启动不同的编辑器。请参见为媒体文件启动外部编辑器。
  • 有关使用 Macromedia Flash 向站点添加交互性的信息，请参见关于 Flash 内容。
  • 若要了解如何使用 Macromedia Shockwave 影片向站点添加动画，请参见插入 Shockwave 影片。
  • 有关如何使用 ColdFusion 的信息，请参见设置 Web 应用程序。


自定义 Dreamweaver：基础

使用一些基本技巧，可以自定义 Dreamweaver 使其适合您的需要，而无须了解复杂的代码或编辑文本文件。例如，您可以设置参数选择、创建自己的键盘快捷方式以及向 Dreamweaver 添加功能扩展。

有关手动自定义配置文件的信息，请参见“Macromedia 支持中心”上的“自定义 Dreamweaver”。


设置参数选择

Dreamweaver 具有用来控制 Dreamweaver 用户界面的常规外观和行为的参数选择设置以及与特定功能（如层、样式表、显示 HTML 和 JavaScript 代码、外部编辑器和在浏览器中预览等）相关的选项。本帮助系统从头至尾与关联功能或主题一起提供了大量有关特定参数选择选项的信息。

有关各种参数选择选项的信息，请参阅以下主题：

  • 设置“常规”参数
  • 激活辅助功能对话框
  • 设置“代码颜色”参数
  • 设置代码格式参数
  • 设置“代码提示”参数
  • 设置“代码改写”参数
  • 设置 CSS 样式参数
  • 使用外部编辑器、设置外部图像编辑器参数和为媒体文件启动外部编辑器（关于“文件类型/编辑器”参数选择）。
  • 设置“字体”参数
  • 设置“标记色彩”参数
  • 设置“不可见元素”参数
  • 设置层参数
  • 设置布局视图参数
  • 设置“新建文档”参数
  • 设置“面板”参数
  • 设置“在浏览器中预览参数选择”选项
  • 设置快速标签编辑器参数
  • 设置“站点”面板参数选项
  • 设置“状态栏”参数
  • 设置“验证程序”参数


设置“常规”参数

“常规”参数选择控制 Dreamweaver 的常规外观。若要更改这些参数选择，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后单击“常规”。“常规”参数选择分为两个子类别：“文档选项”和“编辑选项”。

“启动时只显示站点窗口”（仅适用于浮动工作区）在 Dreamweaver 启动时只显示“站点”面板和选定的其它面板，而不显示新的文档。

“在新窗口中打开文件”（仅适用于 Windows）使得一次打开几个文档变得更加容易。如果在禁用该选项时选择“文件”>“打开”，则打开的每个文件将显示在当前窗口中并替换当前文档。（这不适用于从“站点”菜单中打开文件、双击文件图标等情况。）在 Macintosh 中，文件总是在新的窗口中打开。

“打开只读文件时发出警告”在打开只读文件（锁定的文件）时发出警告。为您提供了解锁/取出文件、查看文件或取消的选项。

“移动文件时更新链接”确定当您移动、重命名或删除站点中的文档时 Dreamweaver 所执行的操作。您可以将该参数设置为总是自动更新链接、从不更新链接或提示您执行更新。请参阅管理链接。

“更改工作区”（仅适用于 Windows）允许您选择三种工作区布局中的任何一种：面板位于右侧的集成工作区、面板位于左侧的集成工作区（针对编码人员特制）或类似于 Dreamweaver 4 的浮动工作区。选择新工作区后，退出 Dreamweaver 并重新启动它以查看发生的更改。有关更多信息，请参阅选择工作区布局（仅适用于 Windows）。

“插入对象时显示对话框”确定当您使用“插入”栏或“插入”菜单插入图像、表格、Shockwave 影片和其它某些对象时 Dreamweaver 是否提示您输入附加的信息。如果禁用该选项，则不出现对话框，您必须使用属性检查器指定图像的源文件和表格中的行数等。对于鼠标经过图像和 Fireworks HTML，当您插入对象时总是出现一个对话框，而与该选项的设置无关。（若要暂时覆盖该设置，请在创建和插入对象时按住 Control 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh)。）

“快速表格编辑（延迟更新）”通过将列宽和行高的某些调整操作延迟到您在表格外单击时执行，使得在表格中键入变得更快速。如果启用该选项，您可以在编辑的时候通过按下 Control+空格键 (Windows) 或 Command+空格键 (Macintosh) 更新表格。

如果您正在使用适合于双字节文本（如日语字符）处理的开发环境或语言工具包，则“允许行内双字节输入”使您能够直接将双字节文本输入到“文档”窗口中。当取消选择该选项时，将显示一个用于输入和转换双字节文本的文本输入窗口；文本被接受后显示在“文档”窗口中。另请参阅设置“字体”参数。

“标题后切换到普通段落”指定在“设计”视图中于一个标题段落的结尾按下 Enter 键 (Windows) 或 Return 键 (Macintosh) 时，将创建一个用 p 标签进行标记的新段落。（标题段落是用 h1 或 h2 等标题标签进行标记的段落。）当禁用该选项时，在标题段落的结尾按下 Enter 健或 Return 键将创建一个用同一标题标签进行标记的新段落（允许您在一行中键入多个标题，然后返回并填入详细信息）。

“允许多个连续的空格”指定在“设计”视图中键入两个或更多的空格时将创建不中断的空格，这些空格在浏览器中显示为多个空格。（例如，您可以在句子之间键入两个空格，就如同在打字机上一样。）该选项主要针对习惯于在字处理程序中键入的用户。当禁用该选项时，多个空格将被当作单个空格（因为浏览器将多个空格当作单个空格）。

“使用 <strong> 和 <em> 代替 <b> 和 <i>”规定，只要您执行的操作通常会用到 b 标签和 i 标签，Dreamweaver 就应分别使用 strong 标签和 em 标签取代它们。此类操作包括在文本属性检查器中单击“粗体”或“斜体”按钮和选择“文本”>“样式”>“粗体”或“文本”>“样式”>“斜体”。若要在您的文档中使用 b 和 i 标签，请取消选择此选项。

备注： WWW 联合会不鼓励使用 b 和 i 标签；strong 和 em 标签在提供的语义信息上比 b 和 i 标签更明确。

“历史步骤最多次数”确定“历史记录”面板中保留和显示的步骤数。（默认值对于大多数用户来说应该足够使用。）如果您超过了“历史记录”面板中的给定步骤数，则将丢弃最早的步骤。请参阅关于任务自动化。

“插入栏”用以将“插入”栏显示为图标和文本、仅图标或仅文本。

“拼写字典”列出可用的拼写字典。如果字典中包含多种方言或拼写惯例（如“英语（美国）”和“英语”（英国）），则方言单独列在“字典”弹出式菜单中。


设置“字体”参数

使用“字体”参数选择设置 Dreamweaver 用以显示每种字体编码的字体。文档的编码方式确定如何在浏览器中显示文档。Dreamweaver 字体设置使您能够以喜爱的字体和大小查看给定的编码，而不影响其他人在浏览器中查看时文档的显示方式。有关为新文档设置默认编码方式的信息，请参见 设置文档。

为每种编码方式设置在 Dreamweaver 中使用的字体：
  1. 选择“编辑”>“参数选择”，然后单击“分类”列表中的“字体”。
  2. 从“字体设置”列表中选择一种编码类型，如西欧语系 (Latin1) 或日语，然后使用“字体设置”列表下面的字体弹出式菜单选择该编码方式在 Dreamweaver 中使用的字体。

    3. 备注： 您选择的字体不会影响文档在访问者的浏览器中的显示方式。

下面是对于这些选项的更加详细的说明。

“字体设置”用以指定在 Dreamweaver 中针对使用给定编码类型的文档所用的字体集。例如，若要指定日语文档使用的字体，请从“字体设置”列表中选择“日语”，然后从下面的菜单中选择一种均衡字体、一种固定字体、一种代码视图字体和一种标签检查器字体；所有采用日语编码方式的文档都将使用这些指定的字体显示。

备注： 若要在字体弹出式菜单中显示一种字体，该字体必须安装在计算机上。例如，若要查看日语文本，必须安装日语字体。

若要指定用于美国英语和全部西欧语言的字体，请从“字体设置”列表中选择“西欧语系”，然后从字体弹出式菜单中选择包含四种字体的一组字体。若要为亚洲语言设置适当的双字节字体，请选择“日语”、“繁体中文”、“简体中文”或“韩文”。（若要显示亚洲语言，您必须使用支持双字节字体的操作系统。）您还可以为“中欧”、“Cyrillic”、“希腊语”、“冰岛 Mac”或“其它”编码方式选择字体。

“均衡字体”是 Dreamweaver 用以显示普通文本（如段落文本、标题和表格）的字体。其默认值取决于系统上安装的字体。对于大多数美国系统，在 Windows 中默认值为 Times New Roman 12 pt（中），在 Macintosh 中为 Times 12 pt。

“固定字体”是 Dreamweaver 用以显示 pre、code 和 tt 标签内文本的字体。其默认值取决于系统上安装的字体。对于大多数美国系统，在 Windows 中默认值为 Courier New 10 pt（小），在 Macintosh 中默认值为 Monaco 12 pt。

“代码视图”是用于显示“代码”视图和代码检查器中所有文本的字体。其默认值取决于系统上安装的字体。

“标签检查器”是用于显示标签检查器中文本的字体。有关更多信息，请参阅用标签检查器编辑标签。


设置“标记色彩”参数

“标记色彩”参数选择使您可以自定义 Dreamweaver 用以标识模板区域、库项目、第三方标签、布局元素和代码的颜色。有关更多信息，请参阅以下主题：

  • 在模板和基于模板的文件中，可编辑区域和锁定的区域的轮廓具有不同的高亮颜色。若要自定义模板的高亮颜色，请参阅设置模板高亮显示参数。
  • 若要指定库项目的高亮颜色，请参阅设置“库”高亮显示参数。
  • 对于使用第三方标签进行标记的内容，指定其高亮颜色。有关第三方标签的更多信息，请参阅“Macromedia 支持中心”上的“自定义 Dreamweaver”。
  • 若要为布局单元格和布局表格指定高亮颜色，请参阅关于布局单元格和表格。
  • 若要指定“文档”窗口的“代码”视图或代码检查器的文本颜色，请参阅设置“代码颜色”参数。


使用快捷键编辑器

使用快捷键编辑器可以创建您自己的快捷键、编辑现有的快捷键或使用一组预定义的快捷键。

备注： 显示默认 Dreamweaver 配置下全部快捷键的图表可以在 Macromedia 网站上得到 。

编辑快捷键：
  1. 选择“编辑”>“快捷键”。

    2. 出现“快捷键”对话框。
    这是所描述的功能的图片。

  2. 设置以下任一选项：
    • “当前设置”允许您选择 Dreamweaver 中包括的一组预定义快捷键或者任何一组您自己定义的快捷键。预定义的快捷键组列在菜单的上方。例如，如果您很熟悉 HomeSite 或 BBEdit 中的快捷键，则可以通过选择相应的预定义组来使用这些快捷键。
    • “命令”允许您选择要编辑的命令类别。例如，您可以编辑菜单命令（如“打开”命令）或代码编辑命令（如“平衡大括弧”）。
    • “命令列表”显示与您从“命令”弹出式菜单中选择的类别相关联的命令以及指定的快捷键。“菜单命令”类别将该列表显示为一个树状视图，该视图拷贝了菜单的结构。其他的类别在一个平面列表中按名称（如“退出应用程序”）顺序列出命令。
    • “快捷键”显示分配给选定命令的全部快捷键。
    • “添加项 (+)”向当前命令添加一个新的快捷键。单击该按钮可以向“快捷键”文本框添加一个新的空行。输入一个新的键组合，然后单击“更改”为该命令添加一个新的快捷键。您可以为每个命令分配两个不同的快捷键；如果已经为某个命令分配了两个快捷键，则“添加项”按钮将不执行任何操作。
    • “移除项 (-)”从快捷键列表中移除选定的快捷键。
    • “按键”在您添加或更改快捷键时显示您输入的键组合。
    • “更改”将显示在“按键”文本框中的键组合添加到快捷键列表中，或者将选定的快捷键更改为指定的键组合。
    • “副本设置”拷贝当前的快捷键组。为新的快捷键组指定一个名称；它的默认名称为当前快捷键组的名称后面追加词“copy”。
    • “重命名设置”重命名当前的快捷键组。
    • “将集合导出为 HTML 文件”以 HTML 表格的格式保存当前的快捷键组，以便于查看和打印。为了便于参考，您可以在浏览器中打开该 HTML 文件并将快捷键打印出来。
    • “删除设置”删除一个快捷键组。（不能删除活动快捷键组。）
删除命令的快捷键：
  1. 从“命令”弹出式菜单中选择一个命令类别。

    2. “命令”列表显示该类别中的命令。

  2. 在“命令”列表中选择一个命令。

    3. 分配给该命令的快捷键显示在“快捷键”文本框中。

  3. 选择一个快捷键。
  4. 单击“移除项 (-)”按钮。
向命令添加快捷键：
  1. 从“命令”弹出式菜单中选择一个命令类别。

    2. “命令”列表显示该类别中的命令。

  2. 在“命令”列表中选择一个命令。

    3. 分配给该命令的快捷键显示在“快捷键”文本框中。

  3. 执行下列操作之一添加一个快捷键：
    • 如果已经分配给该命令的快捷键少于两个，请单击“添加项 (+)”按钮。“快捷键”文本框中显示一个新的空行，并且插入点移动到“按键”文本框中。
    • 如果已经分配给该命令两个快捷键，则选择其中之一。（选定的快捷键将被新的快捷键替换。）然后在“按键”文本框中单击。
  4. 按下一个键组合。

    5. 该键组合显示在“按键”文本框中。

    备注： 如果该键组合存在问题（例如，该键组合已经分配给另一个命令），则紧跟“快捷键”域下面会显示一条解释性信息，并且您可能无法添加或编辑该快捷键。

  5. 单击“更改”。新的键组合就被分配给该命令。
编辑现有的快捷键：
  1. 从“命令”弹出式菜单中选择一个命令类别。

    2. “命令”列表显示该类别中的命令。

  2. 在“命令”列表中选择一个命令。

    3. 分配给该命令的快捷键显示在“快捷键”文本框中。

  3. 选择要更改的快捷键。
  4. 在“按键”文本框中单击，然后输入一个新的键组合。
  5. 单击“更改”按钮以更改该快捷键。

    6. 备注： 如果该键组合存在问题（例如，该键组合已经分配给另一个命令），则紧跟“快捷键”域下面会显示一条解释性信息，并且您可能无法添加或编辑该快捷键。


添加功能扩展 Dreamweaver

功能扩展是一些您可以容易地添加到 Dreamweaver 中的新功能。您可以使用许多类型的功能扩展，例如用来重新格式化表格、连接到后端数据库或者帮助您为浏览器撰写脚本的功能扩展。

备注： 若要在多用户操作系统中安装所有用户都能使用的功能扩展，您必须作为管理员 (Windows) 或根 (Mac OS X) 登录。有关多用户系统的更多信息，请参见在多用户系统中自定义 Dreamweaver。

若要查找 Dreamweaver 的最新功能扩展，请使用 Macromedia Exchange 网站。您可以在此处登录并下载功能扩展（其中的许多功能扩展是免费的），还可以加入讨论组、查看用户的评论以及安装和使用功能扩展管理器。在安装功能扩展前必须安装功能扩展管理器。

功能扩展管理器是一个独立的应用程序，可用于安装和管理 Macromedia 应用程序中的功能扩展。通过从 Dreamweaver 中选择“命令”>“管理功能扩展”启动功能扩展管理器。

安装和管理功能扩展：
  1. 在 Macromedia Exchange 站点上，单击某个功能扩展的下载链接。

    2. 浏览器可能允许您选择是直接从站点打开并安装它还是将它保存到磁盘。

    • 如果您直接从站点打开功能扩展，则功能扩展管理器将自动处理安装。
    • 如果您将功能扩展保存到磁盘，则保存功能扩展包文件 (.mxp) 的合适位置是计算机上 Dreamweaver 应用程序文件夹内的 Downloaded Extensions 文件夹。
  2. 双击功能扩展包文件，或者打开功能扩展管理器并选择“文件”>“安装功能扩展”。

    3. 功能扩展将被安装在 Dreamweaver 中。有些功能扩展在 Dreamweaver 重新启动前不可访问；可能会提示您退出并重新启动该应用程序。

使用功能扩展管理器可删除功能扩展或者查看有关功能扩展的更多信息。


在多用户系统中自定义 Dreamweaver

即使在多用户操作系统如 Windows NT、Windows 2000、Windows XP 或 Mac OS X 中，您也可以自定义 Dreamweaver 以适合自己的需要。Dreamweaver 能够防止任何用户的自定义配置影响到任何其他用户的自定义配置。为了达到这个目的，当您首次在 Dreamweaver 可以识别的某个多用户操作系统中运行它时，该应用程序将为您创建各种配置文件的拷贝。这些用户配置文件存储在一个属于您的文件夹中。例如，在 Windows XP 中它们存储在 C:\Documents and Settings\username\Application Data\Macromedia\Dreamweaver MX\Configuration 中（可能在一个隐藏文件夹中），在 Mac OS X 中它们存储在主文件夹内，具体地说就是存储在 Users/username/Library/Application Support/Macromedia/Dreamweaver MX/Configuration 中。

备注： 在较早的操作系统（Windows 98、Windows ME 和 Mac OS 9.x）中，即使将操作系统配置为支持多个用户，所有用户仍共享一组 Dreamweaver 配置文件。

如果您重新安装或升级了 Dreamweaver，Dreamweaver 会自动制作现有用户配置文件的备份拷贝；这样一来，如果您已手工自定义了这些文件，您仍然可以访问已做的更改。

上一页


规划和设置站点

Web 站点是一组具有共享属性（如相关主题、类似的设计或共同目的）的链接文档。

Macromedia Dreamweaver MX 是一个站点创建和管理工具，因此使用它不仅可以创建单独的文档，还可以创建完整的 Web 站点。为了达到最佳效果，在创建任何 Web 站点页面之前，应对站点进行设计和规划。

备注： 如果您等不及，要立刻开始创建文档，可以尝试一些 Dreamweaver 文档创建工具并创建一个示例文档（请参见创建新的空白文档）。但在设置好站点之前，请不要正式开始文档开发。

创建 Web 站点的第一步是规划（请参见 第 298页的“关于站点规划和设计”）。下一步是设置站点的基本结构（请参见 第 301页的“设置 Dreamweaver 站点”）。当开始开发站点内容时，请考虑基于一个 Dreamweaver 模板建立站点（请参见关于 Dreamweaver 模板和创建 Dreamweaver 模板）。

如果已经有一个位于 Web 服务器上的站点，并且想开始使用 Dreamweaver 编辑该站点，请参见编辑 Dreamweaver 站点。

本章包括以下几节：

关于站点规划和设计

设置 Dreamweaver 站点

设置本地文件夹

设置远程文件夹

编辑 Dreamweaver 站点

使用 Dreamweaver 编辑现有 Web 站点

下一页


关于站点规划和设计

在 Dreamweaver 中，站点 这个术语可以指 Web 站点，也可以指属于 Web 站点的文档的本地存储位置。当开始考虑创建 Web 站点时，为了确保站点成功，应该按照一系列的规划步骤进行。即使创建的仅是个人主页，只有朋友和家人会看到，仔细规划站点也是有益的，它可以确保每个人都能够成功地使用站点。


确定目标

确定站点的目标是创建 Web 站点时应该采取的第一步。向自己或客户提出有关站点的问题。您希望通过 Web 站点来实现什么目标？写下目标，以便在设计过程中时刻提醒自己。目标使您可以集中注意力，针对特定的需要来设计和规划 Web 站点。

与销售产品的 Web 站点相比，提供特定主题新闻的 Web 站点应该具有截然不同的外观和导航方式。目标的复杂性将影响导航方式、使用的创作工具（Flash、Director 等），甚至影响站点的外观和行为。


选择目标用户

确定了要使用 Web 站点实现的目标之后，需要确定希望谁访问站点。这看起来可能是一个愚蠢的问题，因为大多数人希望每个人都访问他们的 Web 站点。但是，创建世界上每个人都能使用的 Web 站点是很困难的。人们使用不同的浏览器，以不同的速度连接，并且可能有也可能没有媒体插件。所有这些因素都会影响站点的使用。这就是需要确定目标用户的原因。

考虑一下谁将被您的 Web 站点吸引或者您希望吸引谁。您认为他们将使用何种计算机？哪种平台可能占主导地位（Macintosh、Windows、Linux 等）？平均连接速度是多少（33.6 Kbps 调制解调器还是 DSL）？他们将使用何种浏览器和何种显示器尺寸？您要创建的是每个人都使用同样的操作系统和浏览器的内部网站点吗？所有这些因素会极大地影响您的网页对访问者显示的方式。

选择了用户并确定他们将使用何种计算机、连接速度和浏览器后，就可以确定设计目标了。

例如，假设您的目标用户主要由使用 17 英寸显示器的 Windows 用户组成，这些用户使用 Microsoft Internet Explorer 3.0 或更高版本的浏览器。在设计网页时，应该测试您的站点在屏幕大小为 800 x 600 像素的 Windows 计算机上使用 Internet Explorer 的效果是否最好。在 Macintosh 平台上使用 Netscape Navigator 的查看者可能较少，但您仍然应该确保站点在这些计算机上能够工作，虽然它的显示可能不象对目标用户那样精确。


创建具有浏览器兼容性的站点

创建站点时，应该明白访问者可能使用各种 Web 浏览器。在已知的其他设计限制下，尽可能将站点设计为具有最大的浏览器兼容性。

目前使用的 Web 浏览器有二十多种，大多数已发行了多个版本。即使您只针对使用 Netscape Navigator 和 Microsoft Internet Explorer 的大多数 Web 用户，但您应明确并不是每个人都在使用这两种浏览器的最新版本。如果您的站点放在 Web 上，那么迟早会有人使用 Netscape Navigator 2.0 或是 AOL 向其客户提供的浏览器以及 Lynx 一类的纯文本浏览器来访问它。

在有些情况下，不需要创建具有跨浏览器兼容性的站点。例如，如果站点仅在公司的内部网上可用，而您知道公司的所有雇员都使用相同的浏览器，则可以根据浏览器的功能优化站点。同样，如果是创建在 CD-ROM 中分发的 HTML 内容，同时在该 CD 上分发某种浏览器，则可以假定所有客户都可以使用那种浏览器。

大多数情况下，对于设计用于公共查看的 Web 站点，最好使您的站点可以在尽可能多的浏览器中查看。选择一种或两种浏览器作为目标浏览器，并针对这些浏览器设计站点，但是请不时地在其他浏览器中尝试浏览本站点，以避免包括太多不兼容的内容。也可以在讨论板上贴一则消息，让别人查看您的站点。这是一种获取广泛用户反馈的好方法。

您的站点越复杂（在布局、动画、多媒体内容和交互方面），跨浏览器兼容的可能性就越小。例如，并非所有的浏览器都可以运行 JavaScript。不使用特殊字符的纯文本页面或许能够在任何浏览器中正确显示，但比起有效地使用图形、布局和交互的页面，这样的页面在美感上可能要差得多。所以，应尽量在最佳效果设计和最大浏览器兼容性设计之间取得平衡。

一个有用的方法是提供某些重要页面（如站点的主页）的多个版本。例如，可为此类页面设计一个有框架的版本和一个无框架的版本。然后可在网页中包括一个行为，将浏览器不具备框架功能的访问者自动切换到无框架版本。有关更多信息，请参见 第 695页的“使用 Dreamweaver自带的行为动作”。


组织站点结构

从一开始就认真组织站点可以减少失误并节省时间。如果没有考虑文档在文件夹层次结构中的位置就开始创建文档，最终可能会导致一个充满了文件的大而笨重的文件夹，或导致相关的文件散布在许多名称类似的文件夹中。

设置站点的常规做法是在本地磁盘上创建一个包含站点所有文件的文件夹（称作本地站点），然后在该文件夹中创建和编辑文档。当准备好发布站点并允许公众查看时，再将这些文件拷贝到 Web 服务器上。这种方法要比在实时公共 Web 站点上创建和编辑文件好，因为它允许您在公开各种更改之前，在本地站点先测试这些更改，然后在完成后立即上传本地站点文件并更新整个公共站点。

若要使用 Dreamweaver 调整您的本地站点，请参见设置 Dreamweaver 站点。使用 Dreamweaver 设置了本地站点后，就可以更轻松地执行管理站点文件、跟踪链接、更新页面等操作了。

将站点分成类别 将相关的页面放在同一文件夹中。例如，公司的通讯稿、联系信息、工作告示等可以全部放在一个文件夹中，而在线目录页可以放在另一个文件夹中。必要时可以使用子文件夹。这种组织类型使站点更容易维护和导航。

确定将图像和声音文件等项目放在何处 例如，将所有图像放在一个位置很方便，这样，当您要将图像插入页面时，就知道在何处可以找到它。设计人员有时把将在站点上使用的所有非 HTML 项目放在一个名为 Assets 的文件夹中。该文件夹中可能包含其他文件夹óó如 Images 文件夹、Shockwave 文件夹和 Sound 文件夹。或者，如果站点上的每个相关页面组之间没有许多共享资源，则每组相关页面可能有单独的 Assets 文件夹。

本地和远程站点使用同样的结构 本地站点和远程 Web 站点应该具有完全相同的结构。如果您使用 Dreamweaver 创建本地站点，然后将全部内容上传到远程站点，则 Dreamweaver 确保在远程站点中精确拷贝本地结构。


创建设计外观

如果在实际使用 Dreamweaver 开始工作之前规划了设计和布局，在以后的设计中就可以节省许多时间。方法很简单：根据所需的站点布局外观，在纸上创建一个实物模型图。还有更高级的方法，就是使用诸如 Macromedia FreeHand 或 Fireworks 等软件创建站点的合成图。重要的是要有一个布局和设计的实物模型，以便以后建立站点时可以按照它来操作。

页面布局和设计保持一致非常重要。您希望用户能够顺利地单击浏览站点的页面，而不会因为所有页面具有不同外观或者每页导航位置不同而感到困惑。


设计导航方案

需要进行规划的另一方面是导航。当您设计站点时，应考虑要给访问者留下何种印象。思考一下站点的访问者如何能够从一个区域移动到另一个区域。请考虑以下几点：

“您在此处”信息使访问者能够很容易地了解他们在站点中的位置以及如何返回到顶级页面。

搜索和索引使访问者可以很容易地找到任何正在查找的信息。

反馈为访问者提供了在站点有问题时与网站管理员（如果适合）联系的方法，以及与公司或站点相关的其他人员联系的方法。

设计导航的外观。导航在整个站点范围内应该一致。如果将导航条放在主页的页首，请尽量在所有链接的页面上都保持这样。

Dreamweaver 有两个可用于创建导航方案的导航工具。有关更多信息，请参见链接与导航。


规划和收集资源

知道了设计和布局的外观后，就可以创建和收集需要的资源了。资源可以是图像、文本或媒体（Flash、Shockwave 等）这样的项目。在开始开发站点前，请确保收集了所有这些项目并做好了准备。否则，您将不得不为找到一幅图像或创建一个按钮而经常中断开发过程。

如果您使用来自某个剪贴画站点的图像和图形，或者其他人正在创建它们，请确保将它们收集并放在站点的一个文件夹中（请参见组织站点结构）。如果您自己创建资源，在开始开发之前请确保创建所有这些资源，如果使用鼠标经过图像技术，那么其中还包括需要的任何图像。然后组织资源，以便可以在使用 Dreamweaver 创建站点时方便地访问它们。

Dreamweaver 使您可以更容易地通过使用模板和库，在各种文档中重用页面布局和页面元素。但是，用模板和库创建新页面比将模板和库应用于现有文档更容易。

如果许多页面将使用同样的布局，则可以使用模板。为该布局规划和设计一个模板，然后就可以基于此模板创建新的页面。如果决定更改所有页面的布局，仅需更改模板即可。

备注： 对于基于模板的文档，所能做的更改有一些限制。模板最好在协作环境中使用，以确保每个人使用的是同样的页面布局。对于在协作环境之外的使用，库项目可以提供更大的灵活性。

如果您知道某幅图像或其他内容将出现在整个站点中的许多页面上，则可以使用库项目；提前设计该内容并使它成为库项目。这样一来，如果以后更改该项目，使用它的所有页面中显示的都将是更新的版本。

有关重新使用页面布局和元素的更多信息，请参见管理站点资源、库和模板。


设置 Dreamweaver 站点

规划站点结构（请参见组织站点结构）后，或者如果已有现有站点，在开始开发前必须在 Dreamweaver 中指定新站点。

Dreamweaver 站点是一种组织所有与 Web 站点关联的文档的方法。可以将它看作一个项目。需要为所开发的每个 Web 站点设置一个站点。通过在站点中组织文件，可以与 FTP 一起利用 Dreamweaver 将站点上传到 Web 服务器、自动跟踪和维护链接、管理文件以及共享文件。除非定义站点，否则不能充分利用 Dreamweaver 的功能。

Dreamweaver 站点由三部分组成，具体取决于环境和所开发的 Web 站点类型：

  • 本地文件夹是工作目录。Dreamweaver 将该文件夹称为“本地站点”。有关更多信息，请参见设置本地文件夹。
  • 远程文件夹是存储文件的位置，这些文件用于测试、生产、协作等，具体取决于环境。Dreamweaver 将该文件夹称为“远程站点”。有关更多信息，请参见设置远程文件夹。
  • 动态页文件夹是 Dreamweaver 处理动态页的文件夹。有关更多信息，请参见指定可在哪里处理动态页。

若要开始，可以完整地设置一个 Dreamweaver 站点，或者就以第一步开始，设置本地文件夹。开始使用 Dreamweaver 前必须至少设置一个本地文件夹。

有两种设置 Dreamweaver 站点的方法：使用“站点定义向导”，它可以带领您逐步完成设置过程；或者使用“站点定义”对话框的“高级”设置，它使您可以根据需要分别设置本地、远程和测试文件夹。

设置 Dreamweaver 站点：
  1. 选择“站点”>“新建站点”。

    2. 出现“站点定义”对话框。

  2. 单击“基本”选项卡以使用“站点定义向导”，或者单击“高级”选项卡以使用“高级”设置。
  3. 完成 Dreamweaver 站点设置过程：
    • 对于“站点定义向导”，请回答问题并单击“前进”在设置过程中前进（请参见使用“站点定义向导”）。
    • 对于“高级”设置，根据需要完成“本地信息”类别（请参见设置本地文件夹），“远程信息”类别（请参见设置远程文件夹）和“测试服务器”类别（请参见指定可在哪里处理动态页）。

备注： 鼓励不熟悉 Dreamweaver 的用户使用“站点定义向导”；有经验的 Dreamweaver 用户可能更喜欢使用“高级”设置。


使用“站点定义向导”

可以使用“站点定义向导”设置 Dreamweaver 站点。“站点定义向导”带领您逐步完成站点设置过程。建议不熟悉 Dreamweaver 的用户使用该方法。

该向导有三个区域。每个区域根据所选设置的不同，可能有多个屏幕（称为部分）。这三个主要的区域包括：

  • 正在编辑文件是设置本地文件夹的地方。有关更多信息，请参见设置本地文件夹。
  • 正在测试文件是设置 Dreamweaver 处理动态页的文件夹的地方。有关更多信息，请参见指定可在哪里处理动态页。
  • 正在共享文件是设置远程文件夹的地方。有关更多信息，请参见设置远程文件夹。

在对话框的顶部，以粗体表示的区域名称表示您在设置过程中所处的位置。您可能不需要在所有三个区域中都设置文件夹。每个区域向您提问以帮助确定您的需要。

使用“站点定义向导”设置 Dreamweaver 站点：
  1. 选择“站点”>“新建站点”。

    2. 出现“站点定义”对话框。

  2. 单击“基本”选项卡以使用“站点定义向导”。
  3. 回答每个屏幕上的问题，然后单击“前进”前进。如果需要，请单击“后退”返回到上一个屏幕。


设置本地文件夹

本地文件夹是 Dreamweaver 站点的工作目录（请参见设置 Dreamweaver 站点）。此文件夹可以位于本地计算机上，也可以位于网络服务器上。它是您为 Dreamweaver 站点存储“过程”文件的位置。

当您设置本地文件夹后，您就建立了一个 Dreamweaver 站点。您可能还要添加远程文件夹和测试文件夹（请参见设置远程文件夹和为应用程序创建根文件夹），但开始使用 Dreamweaver 进行开发前至少需要设置一个本地文件夹。

设置本地文件夹：
  1. 选择“站点”>“新建站点”。

    2. 出现“站点定义”对话框。

  2. 如果未显示“高级”设置，请单击“高级”按钮。

    3. “站点定义”对话框的“高级”选项卡显示“本地信息”类别选项。
    这是所描述的功能的图片。

  3. 输入“本地信息”选项。

    4. 有关更多信息，请参阅设置“本地信息”类别选项。

  4. 单击“确定”。

    5. Dreamweaver 创建初始站点缓存，新的 Dreamweaver 站点显示在“站点”面板中。有关站点面板和站点管理的更多信息，请参见管理您的站点。

以后，当您准备在远程服务器上发布站点时，需要添加有关该站点的其它信息。有关信息，请参见设置远程文件夹。


设置远程文件夹

为 Dreamweaver 站点设置本地文件夹（请参见设置本地文件夹）后，可以设置远程文件夹。本地文件夹和远程文件夹使您能够在本地磁盘和 Web 服务器之间传输文件，这使您可以很容易地管理 Dreamweaver 站点中的文件。

根据环境的不同，远程文件夹是您存储用于测试、协作、生产、部署或许多其它方案的文件的位置。一般说来，远程文件夹位于运行 Web 服务器的计算机上。

备注： 如果在“本地信息”类别中指定的本地文件夹（请参见设置本地文件夹）与运行 Web 服务器的系统上为站点文件创建的文件夹相同，则不需要指定远程文件夹，因为这意味着 Web 服务器运行在本地计算机上。

确定如何访问远程文件夹并记下连接信息。收集了此信息后，使用“编辑站点”命令设置远程文件夹。如果遇到问题，请参见解决远程文件夹设置问题。

设置了远程文件夹后，可以与它连接，然后浏览并管理 Dreamweaver 站点中的文件。如果是开发动态站点，则需要添加一个用于处理动态页的文件夹（请参见指定可在哪里处理动态页）。

设置远程文件夹：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 选择现有的 Dreamweaver 站点。

    3. 如果没有定义任何 Dreamweaver 站点，请在继续前创建一个本地文件夹（请参见设置本地文件夹）。

  3. 单击“编辑”。

    4. 出现“站点定义”对话框。

  4. 如果 Dreamweaver 显示“站点定义向导”，请单击“高级”按钮。
  5. 从左侧的“分类”列表中选择“远程信息”。
  6. 选择一个“访问”选项。

    7. 有关更多信息，请参阅设置“远程信息”类别选项。

  7. 单击“确定”。
连接到远程文件夹：

在“站点”面板中，选择“站点”>“连接”，或者在“站点”面板工具栏中单击“连接到远程主机”按钮。

备注： 如果您的站点使用具有 SSH 的 FTP 访问远程文件夹，则当您试图连接到远程服务器时，将启动一个命令提示，提示您登录到 SSH 服务器。登录后在 Dreamweaver 对话框中单击“确定”。

从远程文件夹断开：

在“站点”面板中，选择“站点”>“断开”，或者在“站点”面板工具栏中单击“断开”按钮。


为 FTP 访问选择主机目录

如果选择使用 FTP 访问远程文件夹（请参见设置远程文件夹），必须确定远程文件夹的主机目录。指定的主机目录应该对应于本地文件夹的根文件夹。下面的示意图在左侧显示一个本地文件夹示例，在右侧显示一个远程文件夹示例。

如果文件夹站点的结构与本地文件夹的结构不匹配，Dreamweaver 会将文件上传到错误的位置，且文件对于站点的访问者不可见。图像和链接路径也被破坏。

远程根目录必须存在，Dreamweaver 才能连接到它。如果远程文件夹没有根目录，请创建一个根目录，或者请服务器管理员为您创建一个根目录。

如果不能确定在“主机目录”文本框中输入什么，请与服务器管理员联系。或者也可以尝试将该文本框保留为空白。在有些服务器上，根目录就是您首次使用 FTP 连接到的目录。若要确定这一点，请连接到服务器。如果出现在“站点”面板“远程文件”视图中的文件夹具有像 public_html、www 或您的登录名这样的名称，它可能就是您应该在“主机目录”文本框中使用的目录。


对 FTP 访问使用安全外壳

当您在“站点定义”对话框中选择 FTP 来访问远程文件夹时，在 Windows 中可以选择使用 SSH（安全外壳）。若要在 Windows 中激活 SSH，请参见设置 FTP 访问的“远程信息”选项。

若要在 Macintosh 中使用 SSH，请从Dreamweaver支持中心 Web 站点下载 Macintosh SSH 客户程序。


解决远程文件夹设置问题

可以使用多种方法配置 Web 服务器。下面的列表提供了关于设置远程文件夹时可能遇到的一些常见问题以及如何解决它们的信息：

  • Dreamweaver FTP 实现方案可能不适用于某些代理服务器、多级防火墙和其他形式的间接服务器访问。

    • 如果遇到 FTP 访问方面的问题，请询问本地系统管理员。

  • 对于 Dreamweaver FTP 实现，必须连接到远程系统的根文件夹。（在许多应用程序中，可以连接到任何远程目录，然后在远程文件系统中查找所需的目录。）

    • 确保将远程系统的根文件夹指定为主机目录。

    如果您有连接问题，并且使用一个单斜杠 (/) 指定了主机目录，则可能需要指定一个相对于所连接目录和远程根文件夹的路径。

    例如，如果远程根文件夹是一个更高级别的目录，则需要为主机目录指定 ../../。

  • 包含空格和特殊字符的文件名和文件夹名在传输到远程站点时经常引起问题。

    • 请使用下划线替换空格，并尽可能避免在文件名和文件夹名中使用特殊字符。具体说来，文件名或文件夹名中的冒号、斜杠、句点和撇号会引起问题。文件名或文件夹名中的特殊字符有时还可能妨碍 Dreamweaver 创建站点地图。

  • 如果遇到长文件名问题，请用较短的名称重命名。在 Macintosh 中，文件名长度不能超过 31 个字符。
  • 需要注意的是，许多服务器使用符号链接 (UNIX)、快捷方式 (Windows) 或别名 (Macintosh) 将服务器磁盘某部分中的一个文件夹和别处的另一个文件夹连接起来。

    • 例如，服务器上主目录的 public_html 子目录实际上可能是到服务器另一部分的链接。在大多数情况下，这样的别名对您连接到适当的文件夹或目录的能力没有影响，但如果您可以连接到服务器的一部分而不能连接到另一部分，则可能存在别名差异。

  • 如果遇到如“无法上传文件”这样的错误信息，说明远程文件夹的空间可能不足。有关更多详细信息，请查看 FTP 记录。

    • 总的说来，当遇到 FTP 传输方面的问题时，请检查 FTP 记录，方法是在“站点”面板中选择“窗口”>“结果”>“FTP 记录”(Windows)，或者选择“站点”>“FTP 记录”(Macintosh)。


编辑 Dreamweaver 站点

使用“站点定义”对话框的“高级”设置编辑 Dreamweaver 站点。

若要编辑 Dreamweaver 站点，请执行以下操作之一：
  • 选择“站点”>“编辑站点”，选择一个站点，然后单击“编辑”。
  • 选择“站点”>“打开站点”，然后选择一个站点。


使用 Dreamweaver 编辑现有 Web 站点

即使创建原始站点时没有使用 Dreamweaver，仍可以使用 Dreamweaver 编辑现有站点。可以编辑本地系统上的现有站点或远程系统上的站点。


使用 Dreamweaver 编辑现有本地 Web 站点

即使创建原始站点时没有使用 Dreamweaver，仍可以使用 Dreamweaver 编辑本地磁盘中的现有 Web 站点。

编辑现有本地 Web 站点：
  1. 执行以下操作之一打开“站点定义”对话框：
    • 选择“站点”>“编辑站点”，然后单击“新建”。
    • 选择“站点”>“打开站点”>“定义站点”。

      • “站点定义”对话框显示“本地信息”选项。

  2. 完成对话框。

    3. 有关更多信息，请参阅设置“本地信息”类别选项。

  3. 单击“确定”。


使用 Dreamweaver 编辑现有远程 Web 站点

即使创建原始站点时没有使用 Dreamweaver，仍可以使用 Dreamweaver 将现有远程站点（或远程站点的任何分支）拷贝到本地磁盘中并在那里编辑它。

即使只打算编辑远程站点的一部分，也必须在本地拷贝远程站点相关分支的整个结构，从远程站点的根文件夹直到要编辑的文件。

例如，如果远程站点的根文件夹名为 public_html，它包含两个文件夹 Project1 和 Project2，而您仅想处理 Project1 中的 HTML 文件，则不需要下载 Project2 中的文件，但是必须将本地根文件夹映射为 public_html，而不是 Project1。

编辑现有远程站点：
  1. 创建一个本地文件夹以包含现有站点，然后将它设置为站点的本地根文件夹（请参见设置本地文件夹）。
  2. 使用有关现有站点的信息来设置远程文件夹（请参见设置远程文件夹）。确保为远程站点选择正确的根文件夹。
  3. 单击“站点”面板中的“连接”按钮连接到远程站点。
  4. 根据要编辑的远程站点的内容量，执行以下操作之一：
    • 如果想对整个站点进行处理，请选择远程站点的根文件夹，然后单击“获取”将整个站点下载到本地磁盘。
    • 如果仅想处理站点的其中一个文件或文件夹，请在“站点”面板的“远程”视图中找到该文件或文件夹，然后单击“获取文件”将该文件下载到本地磁盘。

      • Dreamweaver 自动拷贝必要的远程站点结构，将下载的文件放在站点层次结构的正确部分中。当仅编辑站点的一部分时，通常应该选择包括相关文件。

  5. 像从头创建站点一样继续：编辑文档，预览并测试它们，将它们再次上传到远程站点。


参考资料

本节描述本章中介绍的对话框。


设置站点定义向导的“正在编辑文件”选项

此对话框的作用是命名您的 Dreamweaver 站点。

Dreamweaver 站点是一种组织所有与 Web 站点关联的文档的方法。可以将它看作一个项目。需要为所开发的每个 Web 站点设置一个站点。通过在站点中组织文件，可以与 FTP 一起使用 Dreamweaver 将站点上传到 Web 服务器、自动跟踪和维护链接、管理文件以及共享文件。除非定义站点，否则不能充分利用 Dreamweaver 的功能。

过程

为 Dreamweaver 站点输入名称。

相关主题

设置 Dreamweaver 站点


设置站点定义向导的“正在编辑文件”选项

此对话框的作用是指出您是否正在生成 Web 应用程序 - 意味着站点包含动态内容。Web 应用程序是许多网页的集合，这些网页与用户进行交互、相互之间进行交互，还与 Web 服务器上的多种资源（包括数据库）进行交互。

如果生成 Web 应用程序，则需要选择 Web 服务器上运行的服务器技术来支持动态内容。

过程
  1. 如果不打算使用服务器技术创建 Web 应用程序，请选择“否”；如果打算使用服务器技术创建 Web 应用程序，请选择“是”。
  2. 如果选择“是”，请选择一种服务器技术。

    3. 可以使用 Dreamweaver 通过五种服务器技术生成 Web 应用程序：ColdFusion、ASP.NET、ASP、JSP 或 PHP。每种技术都与 Dreamweaver 中的一种文档类型相对应。为您的 Web 应用程序选择一种技术取决于多个因素，其中包括您对各种脚本编制语言的熟悉程度以及所要使用的应用程序服务器。

相关主题

Web 应用程序是什么？

选择服务器技术


设置站点定义向导的“正在编辑文件”选项

此对话框的作用是选择开发环境。

过程
  1. 选择开发过程中用以处理文件的方法。
  2. 输入存储文件的位置，或者单击文件夹图标浏览选择文件夹。

    3. 这是 Dreamweaver 站点的工作目录ó即您为 Dreamweaver 站点存储“创建中的”文件的位置。在 Dreamweaver“站点”面板中，该文件夹被称为本地站点。

  3. 如果选择了使用 FTP 或 RDS 的方法，则可以选择每次保存时自动将文件上传到服务器。


设置站点定义向导的“正在测试文件”选项

此对话框的作用是为 Dreamweaver 选择一种访问测试服务器的访问方法。

Dreamweaver 在您工作的同时，与一个测试服务器一起工作以生成并显示动态内容。测试服务器可以是本地计算机、开发服务器、中间服务器或生产服务器。只要服务器能够处理您打算开发的动态页类型，选择哪个都无关紧要。

当您设置测试服务器时，Dreamweaver 还为您设置一个远程服务器文件夹。根据环境的不同，该文件夹是您存储用于测试、协作、生产、部署或许多其它方案的文件的位置。一般说来，远程文件夹位于运行 Web 服务器的计算机上。

在 Dreamweaver“站点”面板中，远程文件夹被称为远程站点。远程文件夹使您能够在本地磁盘和 Web 服务器之间传输文件，这使您可以很容易地管理 Dreamweaver 站点中的文件。

过程：

从弹出菜单中选择一种访问方法：

  • 本地/网络，如果访问网络文件夹，或者如果在本地计算机上运行测试服务器。
  • FTP，如果使用 FTP 连接到测试服务器。
  • RDS（远程开发服务），如果使用 RDS 连接到 Web 服务器。

    • 对于这种访问方法，远程文件夹必须位于运行 ColdFusion 的计算机上。

相关主题

设置用于测试的“本地/网络”访问选项

设置用于测试的“FTP”访问选项

设置用于测试的“RDS”访问选项


设置用于测试的“本地/网络”访问选项

此对话框的作用是在本地计算机或网络上选择一个文件夹来存储测试的文件。

过程

输入存储测试文件的本地或网络文件夹的路径，或者单击文件夹图标浏览到该文件夹。


设置用于测试的“FTP”访问选项

此对话框的作用是完成有关存储测试文件的测试服务器的 FTP 访问信息。

过程
  1. 输入测试文件上传到的 FTP 主机的主机名。

    2. FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其它的文本。特别是不要在主机名前面添加协议名。

    备注： 如果不知道 FTP 主机，请与 ISP 联系。

  2. 输入存储测试文件的文件夹路径，或者单击文件夹图标浏览到该文件夹。
  3. 输入用于连接到 FTP 服务器的登录名和密码。
  4. 单击“测试连接”测试登录名和密码。

相关主题

为 FTP 访问选择主机目录


设置用于测试的“RDS”访问选项

此对话框的作用是完成有关存储文件的测试服务器的 RDS 访问信息。

过程

单击“设置”按钮输入访问信息。

相关主题

设置 RDS 访问


设置站点定义向导的“正在测试文件”选项

此对话框的作用是指定一个 URL 前缀，以便在您工作时 Dreamweaver 可以使用测试服务器显示数据并连接到数据库。URL 前缀由域名和 Web 站点的主目录的任何一个子目录或虚拟目录组成。

过程
  1. 输入用户在浏览器中键入的 URL 以打开 Web 应用程序，但不要包括任何文件名。

    2. 假设应用程序的 URL 是 http://www.macromedia.com/mycoolapp/start.jsp。在本例中，您应该输入以下 URL 前缀：http://www.macromedia.com/mycoolapp/。

    如果 Dreamweaver 与 Web 服务器运行在同一计算机上，则可以使用 localhost 这个词来代替域名。例如，假设应用程序的 URL 是 http://buttercup_pc/mycoolapp/start.jsp，那么可以输入以下 URL 前缀：http://localhost/mycoolapp/。

  2. 单击“测试 URL”确保 URL 正常工作。

相关主题

关于 URL 前缀


设置站点定义向导的“正在共享文件”选项

此对话框的作用是确定是否设置远程服务器文件夹。

根据环境的不同，该文件夹是您存储用于测试、协作、生产、部署或许多其它方案的文件的位置。一般说来，远程文件夹位于运行 Web 服务器的计算机上。

在 Dreamweaver“站点”面板中，该文件夹被称为远程站点。远程文件夹使您能够在本地磁盘和 Web 服务器之间传输文件，这使您可以很容易地共享和管理 Dreamweaver 站点中的文件。

过程

请选择“是”设置一个远程文件夹，或者选择“否”跳过远程文件夹设置。


设置站点定义向导的“正在共享文件”选项

此对话框的作用是为 Dreamweaver 选择一种访问远程文件夹的访问方法。

过程

从弹出菜单中选择一种访问方法：

  • 本地/网络，如果访问网络文件夹，或者如果在本地计算机上运行测试服务器。
  • FTP，如果使用 FTP 连接到测试服务器。
  • RDS（远程开发服务），如果使用 RDS 连接到 Web 服务器。

    • 对于这种访问方法，远程文件夹必须位于运行 ColdFusion 的计算机上。

  • SourceSafe 数据库，如果使用 SourceSafe 数据库连接到 Web 服务器。

    • 只有 Windows 支持 SourceSafe 数据库。若要在 Windows 中使用 SourceSafe，必须安装了 Microsoft Visual SourceSafe Client 第 6 版。

  • WebDAV（基于 Web 的分布式创作和版本控制），如果使用 WebDAV 协议连接到 Web 服务器。

    • 对于这种访问方法，必须有支持此协议的服务器，如 Microsoft Internet Information Server (IIS) 5.0 或 Apache Web 服务器。

相关主题

设置远程访问的“本地/网络”选项

设置远程访问的 FTP 选项

设置 RDS 访问

设置 SourceSafe 数据库访问

设置 WebDAV 访问


设置远程访问的“本地/网络”选项

此对话框的作用是在本地计算机或网络上选择一个文件夹来存储文件。

过程

输入存储文件的本地或网络文件夹的路径，或者单击文件夹图标浏览到该文件夹。


设置远程访问的 FTP 选项

此对话框的作用是完成有关存储文件的远程服务器的 FTP 访问信息。

过程
  1. 输入文件上传到的 FTP 主机的主机名。

    2. FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其它的文本。特别是不要在主机名前面添加协议名。

    备注： 如果不知道 FTP 主机，请与 ISP 联系。

  2. 输入存储文件的文件夹路径，或者单击文件夹图标浏览到该文件夹。
  3. 输入用于连接到 FTP 服务器的登录名和密码。
  4. 单击“测试连接”测试登录名和密码。

相关主题

为 FTP 访问选择主机目录


设置站点定义向导的“正在共享文件”选项

如果您是在协作环境中工作（或者在多台计算机上独自工作），则此对话框的作用是设置 Dreamweaver 文件“存回/取出”系统。

取出文件使该文件在服务器上不可用，这样一来其他小组成员就不能编辑该文件。存回文件使其他人可以使用该文件，取出和编辑它。

过程
  1. 如果您是在小组环境中工作（或在几台不同的计算机上独自工作），请选择“是”启用文件存回/取出，或者选择“否”禁用文件存回/取出。

    2. 该选项有助于让其他人知道您已取出文件进行编辑，或者提醒您自己可能将文件的最新版本留在了另一台计算机上。

  2. 如果想在文件从“站点”面板中打开时自动取出它们，请选择“是”；如果不想在打开文件时自动取出它们，请选择“否”。

    3. 备注： 即使选择了该选项，使用“文件”>“打开”这种方法打开文件也不会取出该文件。

  3. 输入您的名称。

    4. 您的名称出现在“站点”面板中任何您取出的文件旁；这使小组成员能够在共享文件时相互交流。

    如果您在几台不同的计算机上独自工作，请在每台计算机上使用不同的取出名称（如 AmyR-HomeMac 和 AmyR-OfficePC），这样一来，当您忘记存回文件时，就可以知道文件最新版本的位置。

  4. 输入您的电子邮件地址。

    5. 当您输入电子邮件地址然后取出文件时，您的名称会以链接（蓝色并且带下划线）形式出现在“站点”面板中的该文件旁边。如果小组成员单击该链接，他们的默认电子邮件程序会打开一个新邮件，其中已填上您的电子邮件地址和对应于该文件和站点名的主题。

相关主题

使用存回/取出


站点定义向导的“总结”选项

该页显示您为站点选择的设置。

过程

执行以下操作之一：

  • 单击“后退”按钮返回到上一页更改设置。
  • 如果对设置感到满意并想让 Dreamweaver 创建站点，请单击“完成”按钮。

    • 当您单击“完成”时，Dreamweaver 会创建站点并在“站点”面板中显示它。

  • 如果不想让 Dreamweaver 创建站点，请单击“取消”按钮。


设置“本地信息”类别选项

此对话框的作用是为 Dreamweaver 站点（也称为本地站点）设置本地文件夹。

过程
  1. 在“站点名称”文本框中，输入 Dreamweaver 站点的名称。

    2. 站点名称随即出现在“站点”面板中和“站点”>“打开站点”子菜单上。使用您喜欢的任何名称；该名称仅供您参考，并不出现在浏览器中。

  2. 在“本地根文件夹”文本框中，输入本地磁盘中存储站点文件、模板和库项目的文件夹的名称，或者单击文件夹图标浏览到该文件夹。

    3. 当 Dreamweaver 解析根相对链接时，它是相对于该文件夹来解析的（请参阅 第 750页的“站点根目录相对路径”）。如果本地根文件夹尚不存在，请从文件浏览对话框中创建。

  3. 在“自动刷新本地文件列表”选项中，指定每次将文件复制到本地站点时 Dreamweaver 是否自动刷新本地文件列表。

    4. 取消选择此选项可在复制此类文件时提高 Dreamweaver 的速度，但也意味着“站点”面板的“本地”视图不会自动刷新。

    若要手动刷新“站点”面板，请单击“站点”面板的“刷新”按钮。若要只手动刷新“本地”视图，请在“站点”面板中选择“查看”>“刷新”(Windows) 或“站点”>“站点文件视图”>“刷新”[选中它](Macintosh)。

  4. 在“默认图像文件夹”文本框中，输入此站点的默认图像文件夹的路径，或者单击文件夹图标浏览到该文件夹。

    5. 此文件夹是 Dreamweaver 上传您添加到站点上的图像的位置。例如，将图像从桌面拖动到活动文档中时，Dreamweaver 将该图像添加到当前站点的默认图像文件夹中。

  5. 在“HTTP 地址”文本框中，输入已完成的 Web 站点将使用的 URL。

    6. 这使 Dreamweaver 能够验证站点中使用绝对 URL 的链接（请参阅检查页面或站点内的链接）。

  6. 对于“启用缓存”选项，指定是否创建本地缓存以提高链接和站点管理任务的速度。

    7. 如果不选择此选项，Dreamweaver 在创建站点前将再次询问您是否希望创建缓存。最好选择此选项，因为只有在创建缓存后“资源”面板（在“文件”面板组中）才有效。有关更多信息，请参阅使用“资源”面板。

相关主题

设置 Dreamweaver 站点

设置本地文件夹


设置“远程信息”类别选项

此对话框的作用是为 Dreamweaver 选择访问远程文件夹（也称为远程站点）所在的 Web 服务器的访问方法。

过程
  1. 从弹出菜单中选择一种访问方法。对话框随您的选择而改变。选择以下项之一：
    • 无，如果不打算将站点上传到服务器。
    • 本地/网络，如果访问网络文件夹，或者如果在本地计算机上运行 Web 服务器。
    • FTP，如果使用 FTP 连接到 Web 服务器。
    • RDS（远程开发服务），如果使用 RDS 连接到 Web 服务器。

      • 对于这种访问方法，远程文件夹必须位于运行 ColdFusion 的计算机上。

    • SourceSafe 数据库，如果使用 SourceSafe 数据库连接到 Web 服务器。

      • 只有 Windows 支持 SourceSafe 数据库。若要在 Windows 中使用 SourceSafe，必须安装了 Microsoft Visual SourceSafe Client 第 6 版。

    • WebDAV（基于 Web 的分布式创作和版本控制），如果使用 WebDAV 协议连接到 Web 服务器。

      • 对于这种访问方法，必须有支持此协议的服务器，如 Microsoft Internet Information Server (IIS) 5.0 和 Apache Web 服务器。

  2. 对于“本地/网络”和“FTP”访问，完成对话框。

    3. 有关更多信息，请参阅相关章节：

    设置“本地/网络”访问的“远程信息”选项

    设置 FTP 访问的“远程信息”选项

  3. 对于“RDS”、“SourceSafe 数据库”和“WebDAV”访问，选择“启用文件存回和取出”和“保存时自动将文件上传到服务器”启用这两个选项。然后单击“设置”按钮完成访问信息。

    4. 有关更多信息，请参阅相关章节：

    使用存回/取出

    设置 RDS 访问

    设置 SourceSafe 数据库访问

    设置 WebDAV 访问

  4. 单击“确定”。

相关主题

设置远程文件夹

设置 FTP 访问的“远程信息”选项

设置“本地/网络”访问的“远程信息”选项

设置 RDS 访问

设置 SourceSafe 数据库访问

设置 WebDAV 访问


设置“本地/网络”访问的“远程信息”选项

此对话框的作用是完成有关“本地/网络”访问的信息。

过程
  1. 单击“远端文件夹”文本框旁边的文件夹图标，浏览到并选择存储站点文件的文件夹。
  2. 如果希望在添加和删除文件时自动更新“站点”面板的“远程”窗格，请选择“自动刷新远程文件列表”复选框。

    3. 若要在将文件复制到远程站点时提高速度，请不要选择此选项。

    备注： 若要随时手动刷新“站点”面板，请单击“站点”面板的“刷新”按钮。若要只手动刷新“远程”窗格，请在“站点”面板中选择“查看”>“刷新远程文件”(Windows) 或“站点”>“站点文件视图”>“刷新远程文件”(Macintosh)。

  3. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。
  4. 如果希望激活“存回/取出”系统，请选择“启用文件存回和取出”。

    5. 有关更多信息，请参阅使用存回/取出。

  5. 单击“确定”。

相关主题

设置远程文件夹

设置“远程信息”类别选项


设置 FTP 访问的“远程信息”选项

此对话框的作用是完成有关 FTP 访问的信息。

过程
  1. 输入 Web 站点的文件上传到的 FTP 主机的主机名。

    2. FTP 主机是计算机系统的完整 Internet 名称，如 ftp.mindspring.com。请输入完整的主机名，不要带任何其它的文本。特别是不要在主机名前面添加协议名。

    备注： 如果不知道 FTP 主机，请与 ISP 联系。

  2. 输入您在远程站点上存储公共可见的文档的主机目录。
  3. 输入用于连接到 FTP 服务器的登录名和密码。
  4. 单击“测试”测试登录名和密码。
  5. 默认情况下，Dreamweaver 保存密码。如果希望每次连接到远程服务器时 Dreamweaver 都提示输入密码，请取消选择“保存”复选框。
  6. 如果防火墙配置要求使用被动式 FTP，请选择“使用被动式 FTP”复选框。

    7. “被动式 FTP”使您的本地软件能够建立 FTP 连接，而不是请求远程服务器建立连接。如果不能确定是否使用被动式 FTP，请询问系统管理员。

  7. 如果从防火墙后面连接到远程服务器，请选择“使用防火墙”复选框。
  8. 单击“防火墙设置”编辑防火墙主机或端口。

    9. 有关更多信息，请参阅设置“站点”参数。

  9. （仅限 Windows）选取“使用 SSH 加密安全登录”复选框以使用 SSH 进行安全 FTP 身份验证。

    10. 备注： 若要将 SSH（安全 Shell）用于 Macintosh，您必须安装从 Dreamweaver 支持中心 Web 站点下载的 SSH 客户程序。

  10. 如果希望在保存文件时 Dreamweaver 将文件上传到远程站点，请选择“保存时自动将文件上传到服务器”复选框。
  11. 如果希望激活“存回/取出”系统，请选择“启用文件存回和取出”。

    12. 有关更多信息，请参阅使用存回/取出。

  12. 单击“确定”。

相关主题

设置远程文件夹

为 FTP 访问选择主机目录

设置“远程信息”类别选项


设置 RDS 访问

此对话框的作用是使用 RDS 与远程服务器建立连接。

过程
  1. 输入安装 Web 服务器的主机的名称。

    2. 主机名可能是 IP 地址或 URL。如果不能确定，请询问管理员。

  2. 输入要连接的端口号。
  3. 输入根远程文件夹作为主机目录。例如，c:\inetpub\wwwroot\myHostDir\。
  4. 输入 RDS 用户名和密码。

    5. 备注： 如果在“ColdFusion 管理员”安全设置中设置了用户名和密码，则这些选项可能不会出现。

  5. 如果希望 Dreamweaver 记住这些设置，请选择“保存”复选框。

相关主题

设置远程文件夹

设置“远程信息”类别选项


设置 SourceSafe 数据库访问

此对话框的作用是与 SourceSafe 数据库建立连接。

备注： 只有 Windows 支持 SourceSafe 数据库。

过程
  1. 在“数据库路径”文本框中，单击“浏览”浏览所需的 VSS 数据库，或者输入完整的文件路径。

    2. 所选文件变成用于初始化 SourceSafe 的 srcsafe.ini 文件。

  2. 在“项目”文本框中，输入 VSS 数据库中您要用作远程站点根目录的项目。
  3. 在“用户名”和“密码”文本框中，输入所选数据库的登录用户名和密码。

    4. 如果不知道用户名和密码，请询问系统管理员。

  4. 单击“确定”返回到“站点定义”对话框。

相关主题

设置远程文件夹

设置“远程信息”类别选项


设置 WebDAV 访问

此对话框的作用是使用 WebDAV 协议与远程服务器建立连接。

过程
  1. 在“URL”文本框中，输入 WebDAV 服务器上您要连接到的目录的完整 URL。

    2. 此 URL 包括协议、端口和目录（如果不是根目录）。例如，http://apache1/WebDAV/mysite。

  2. 在相应的文本框中输入用户名和密码。

    3. 此信息用于服务器身份验证，与 Dreamweaver 无关。如果不能确定用户名和密码，请询问系统管理员或网站管理员。

  3. 在“电子邮件”文本框中，输入电子邮件地址。

    4. 这是必填的。它用于标识 WebDAV 服务器的所有权，并出于联系目的出现在“站点”面板中。

  4. 如果希望在每次开始新会话时 Dreamweaver 都记住密码，请单击“保存密码”复选框。
  5. 单击“确定”返回到“站点定义”对话框。

相关主题

设置远程文件夹

设置“远程信息”类别选项


使用“编辑站点”对话框选项

此对话框的作用是编辑站点。在此对话框中，可以创建新站点、编辑站点、复制站点、删除站点以及导入或导出站点。

过程
  1. 从窗口中选择一个站点。
  2. 单击一个按钮选择以下选项之一：
    • “新建”使您可以创建新站点。
    • “编辑”使您可以编辑现有站点。
    • “复制”创建所选站点的拷贝。

      • 拷贝将出现在站点列表窗口中。

    • “删除”删除所选站点。

      • Dreamweaver 会提醒您该操作无法撤消。

    • “导出”使您可以将导出的站点保存为 XML 文件。
    • “导入”使您可以选择要导入的站点的 XML 文件。
  3. 单击“完成”关闭对话框。

相关主题

设置 Dreamweaver 站点

编辑 Dreamweaver 站点

使用 Dreamweaver 编辑现有远程 Web 站点

导入和导出站点

上一页


管理您的站点

Macromedia Dreamweaver MX 使用“站点”面板帮助您组织本地和远程文件夹（也称为“站点”）中的文件。它使您能够在远程服务器上拷贝本地文件夹的结构或者在本地系统上拷贝远程文件夹的结构。由于本地站点和远程站点的结构是相同的，因此当您将文件传输到远程站点后，在本地站点中创建的相对链接仍可以继续使用。

若要在 Dreamweaver 中创建本地站点，可以使用“新建站点”命令创建站点的本地根文件夹，也可以使现有文件夹成为本地根文件夹（请参见设置本地文件夹）。您可以在新建站点时定义远程站点，也可以在稍后使用“编辑站点”命令添加该信息（请参见设置远程文件夹）。

Dreamweaver 包含大量管理站点以及与远程服务器进行文件传输的功能。当您在本地和远程站点之间传输文件时，Dreamweaver 会在这两种站点之间维持平行的文件和文件夹结构。在这两种站点之间传输文件时，如果站点中不存在必需的文件夹，则 Dreamweaver 将自动创建这些文件夹。您也可以在本地和远程站点之间同步文件；Dreamweaver 会根据需要在两个方向上拷贝文件，并且在合理的情况下删除不需要的文件。

Dreamweaver 包含能使 Web 站点上的协作更为容易的功能。您可以在远程服务器中存回和取出文件，使 Web 小组的其他成员能够看到谁正在处理某一文件。您可以在自己的文件中添加设计备注，以便同小组成员共享文件状态、优先级等方面的信息。您还可以使用“工作流程报告”功能在自己的站点上运行报告，以显示有关存回/取出状态的信息并搜索附加到文件的设计备注。

当发布站点后，您（或您所在小组的某一成员）可以继续维护该站点。在发布之前和之后，您还需要不断地对站点进行故障排除（有关更多信息，请参见第 825页的“测试站点”）。

本章包含以下几节：

  • 关于“站点”面板
  • 关于站点地图
  • 导入和导出站点
  • 从站点列表中删除站点
  • 使用存回/取出
  • 获取和上传文件
  • 同步本地和远程站点上的文件
  • 遮盖站点中的文件夹和文件
  • 使用设计备注
  • 使用报告改进工作流程
  • 关于 Dreamweaver 中的“SiteSpring”面板
  • 使用“Sitespring”面板
下一页


关于“站点”面板

“站点”面板使您能够查看站点（包括所有与选定站点关联的本地、远程和测试服务器文件）。默认情况下会显示本地站点；更改“站点”面板布局后可查看远程站点或测试服务器（请参见更改“站点”面板布局）。展开“站点”面板可得到拆分视图（请参见使用“站点”面板）。

备注： 在 Macintosh 上，“站点”面板始终为拆分视图；它不会折叠起来。

“站点”面板用于标准的文件维护操作，例如：

  • 新建 HTML 文档
  • 查看、打开和移动文件
  • 创建文件夹
  • 删除项
  • 在本地站点、远程站点和测试服务器之间传输文件
  • 用站点地图设计站点导航（请参见设置远程文件夹和使用站点地图）

“站点”面板包含一个集成的文件浏览器。除当前站点之外，您还可以在该文件浏览器中浏览本地磁盘和网络（请参见使用集成的文件浏览器）。


使用“站点”面板

默认情况下，“站点”面板集成在 Dreamweaver 集成工作区中（请参见了解工作区）。您可在必要时移动该面板或者打开和关闭它（请参见使用 Dreamweaver 窗口和面板）。您还可以展开该面板以得到站点的拆分视图。在拆分视图中，选择查看本地站点和远程站点、测试服务器或站点地图（更改“站点”面板布局）。

若要打开或关闭“站点”面板，请执行以下操作：

选择“窗口”>“站点”。

若要展开或折叠“站点”面板，请执行以下操作：

（仅限 Windows）单击“站点”面板工具栏上的“展开/折叠”按钮。

备注： 如果单击“展开/折叠”按钮展开停靠的面板，面板就会最大化，使您无法在文档窗口中工作。若要返回到文档窗口，请再次单击“展开/折叠”按钮折叠面板。如果单击“展开/折叠”按钮展开浮动的面板，面板将仍是浮动面板，并且您仍可以在文档窗口中工作。再次停靠面板之前，您必须先折叠该面板。

使用“站点”面板工具栏上的以下按钮和选项可确定“站点”面板显示的内容并传输文件：

备注： “站点文件”、“测试服务器”和“站点地图”按钮仅出现在展开的“站点”面板上。

“站点文件”视图在“站点”面板的窗格中显示远程和本地站点的文件结构。（有一个参数选择设置确定哪一种站点出现在左窗格，哪一种站点出现在右窗格；请参见设置“站点”参数。）“站点文件”视图是“站点”面板的默认视图。

“测试服务器”视图显示测试服务器和本地站点的目录结构。

“站点地图”视图根据文档相互链接的方式显示站点的地图。按下此按钮可从弹出式菜单中选择“仅限地图”或“地图和文件”。

“站点”弹出式菜单列出您已定义的站点。若要切换站点，请从该列表中选择另一个站点。若要添加站点或编辑现有站点的信息，请从该菜单的底部选择“编辑站点”（请参见设置远程文件夹）。

“连接/断开”（FTP、RDS、WebDAV 协议和 SourceSafe）用于连接到远程站点或断开与远程站点的连接。默认情况下，如果 Dreamweaver 已空闲 30 分钟以上，则将断开与远程站点的连接（仅限 FTP）。

若要更改此时间限制，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从左侧的类别列表中选择“站点”。

“刷新”用于刷新本地和远程目录列表。如果您已取消选择“站点定义”对话框中的“自动刷新本地文件列表”或“自动刷新远程文件列表”（请参见设置远程文件夹），则可以使用此按钮手动刷新目录列表。

“获取文件”用于将选定文件从远程站点或测试服务器拷贝到本地站点（如果存在该文件的现有本地拷贝，则将其覆盖）。如果打开了“启用文件存回和取出”，则本地拷贝为只读，文件仍将留在远程站点上，可供其他小组成员取出。如果关闭了“启用文件存回和取出”，则获取文件将传输具有读写特权的拷贝。

Dreamweaver 所拷贝的文件是您在“站点”面板的活动窗格中选择的文件。如果“远程”或“测试服务器”窗格处于活动状态，则选定的远程或测试服务器文件将拷贝到本地站点；如果“本地”窗格处于活动状态，则 Dreamweaver 会将选定的本地文件的远程或测试服务器版本拷贝到本地站点。有关更多信息，请参见从远程或测试服务器获取文件。

备注： 您可以获取远程和测试服务器文件，但存回和取出功能仅适用于远程文件。

“放置文件”用于将选定的文件从本地站点拷贝到远程站点或测试服务器。

Dreamweaver 所拷贝的文件是您在“站点”面板的活动窗格中选择的文件。如果“本地”窗格处于活动状态，则选定的本地文件将拷贝到远程站点或测试服务器；如果“远程”或“测试服务器”窗格处于活动状态，则 Dreamweaver 会将选定的远程或测试服务器文件的本地版本拷贝到远程站点。有关更多信息，请参见将文件上传到远程或测试服务器上。

备注： 您可以将文件上传到远程和测试服务器上，但存回和取出功能仅适用于远程文件。

如果您所放置的文件在远程站点上尚不存在，并且“启用文件存回和取出”已打开，则 Dreamweaver 会以“取出”方式将该文件添加到远程站点。如果需要不以取出状态添加文件，请单击“存回文件”按钮。

“取出文件”用于将文件的拷贝从远程服务器传输到本地站点（如果存在该文件的现有本地拷贝，则将其覆盖），并且将该文件标记为在服务器上取出。如果对当前站点关闭了“站点定义”对话框中的“启用文件存回和取出”，则此选项不可用。有关更多信息，请参见在远程站点中存回和取出文件。

“存回文件”用于将本地文件的拷贝传输到远程服务器，并且使该文件可供他人编辑。本地文件变为只读。如果对当前站点关闭了“站点定义”对话框中的“启用文件存回和取出”，则此选项不可用。有关更多信息，请参见在远程站点中存回和取出文件。

“展开/折叠”按钮（仅限 Windows）展开或折叠“站点”面板，以显示一个或两个窗格。


设置“站点”参数

您可以在“参数选择”对话框中控制“站点”面板的文件传输功能。

若要编辑“站点”面板参数选择，请执行以下操作：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)。

    2. “参数选择”对话框出现。

  2. 从左侧的类别列表中选择“站点”。

    3. 即会出现“站点”参数选择的选项。
    这是所描述的功能的图片。

  3. 按需要更改选项。

    4. 有关更多信息，请参见 设置“站点”面板参数选项

  4. 单击“确定”。

您可以通过自定义 Dreamweaver/Configuration 文件夹中的 FTPExtensionMap.txt 文件（在 Macintosh 上为 FTPExtensionMapMac.txt）来定义所传输的文件类型是作为 ASCII (TXT) 还是二进制来进行传输。有关更多信息，请参见欢迎使用 Dreamweaver。


更改文件视图列

您可以自定义“站点”面板的“本地和远程站点”列表中显示的列。您可以执行以下任意操作：

  • 将列重新排序
  • 添加新列（最多 10 列）
  • 删除列
  • 隐藏列
  • 指定将与连接到站点的所有用户共享的列

默认列为“名称”、“备注”、“大小”、“类型”、“修改时间”和“取出者”。若要按任何列排序，请在“站点”面板中单击列标题。多次单击一个列会颠倒 Dreamweaver 对该列排序所依据的顺序（升序或降序）。

备注： 不能删除默认列，重命名默认列，也不能将设计备注与默认列相关联。您可以更改默认列的排序和对齐以及隐藏默认列，但“名称”列属于例外，它不能隐藏。

若要添加、删除或更改列，请执行以下操作：
  1. 在“站点”面板上执行以下操作之一以访问“文件视图列”选项：
    • 选择“查看”>“文件视图列”(Windows) 或“站点”>“站点文件视图”>“文件视图列”(Macintosh)。
    • 选择“站点”>“编辑站点”，选择一个站点，然后单击“编辑”。然后，从“站点定义”对话框左侧的类别列表中选择“文件视图列”。

      • “站点定义”对话框显示“文件视图列”选项。
      这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关更多信息，请参见设置“文件视图列”类别选项。

  3. 单击“确定”。

相关主题

更改“站点”面板布局


在“站点”面板中打开和查看站点

当“站点”面板折叠时，它以文件列表的形式显示本地站点、远程站点或测试服务器的内容。当“站点”面板展开时，它以拆分视图的形式显示本地站点以及远程站点或测试服务器。在展开时，“站点”面板还可以显示本地站点的视觉站点地图。

备注： 在查看远程站点或测试服务器之前，必须先设置一个远程站点或测试服务器（请参见设置远程文件夹或指定可在哪里处理动态页）。在查看站点地图之前，必须先设置一个主页（请参见使用站点地图）。

若要打开现有的 Dreamweaver 站点，请执行以下操作：

在“站点”面板上，从“站点”弹出式菜单（即当前站点名称出现的地方）中选择一个站点。

备注： 若要定义 Dreamweaver 站点，请参见设置 Dreamweaver 站点。

若要在“站点”面板折叠的情况下更改当前站点视图，请执行以下操作（仅限 Windows）：

在折叠的“站点”面板上，从当前视图所出现位置的弹出式菜单中选择“本地视图”、“远程视图”或“测试服务器”。

备注： 默认情况下，“本地视图”出现在该弹出式菜单中。

若要在“站点”面板展开的情况下更改站点视图，请执行以下操作：

在展开的“站点”面板上，单击“站点”面板工具栏上的“站点文件”按钮（对于远程站点）、“测试服务器”按钮或“站点地图”按钮。

备注： 如果您使用“站点地图”按钮，则可以选择查看包含站点文件的站点地图或仅查看站点地图。有关更多信息，请参见使用站点地图。

相关主题

更改“站点”面板布局


更改“站点”面板布局

当“站点”面板处于拆分视图时，本地站点在默认情况下出现在“站点”面板的右侧。远程站点、测试服务器或站点地图在默认情况下出现在左侧。您可以切换这些显示。

若要更改“站点”面板布局，请执行以下操作：
  1. （仅限 Windows）在“站点”面板中，单击“展开/折叠”按钮展开面板（如果它尚未展开）。
  2. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)。

    3. “参数选择”对话框出现。

  3. 从左侧的类别列表中选择“站点”。

    4. 即会出现“站点”参数选择的选项。
    这是所描述的功能的图片。

  4. 从“总是显示”弹出式菜单中选择“本地文件”或“远程文件”。
  5. 选择要让“总是显示”文件出现的位置（展开的“站点”面板的右侧或左侧）。
  6. 单击“确定”。
若要更改视图区域的大小，请执行以下操作：

在展开的“站点”面板上，执行以下操作之一：

  • 拖动两个视图之间的分隔条以增加或减少右窗格或左窗格的视图区域。
  • 使用“站点”面板底部的滚动条滚动查看视图的内容。
  • 在站点地图中，拖动文件之上的箭头以更改文件之间的空间。

相关主题

更改文件视图列


在“站点”面板中处理文件

使用“站点”面板可以按文件列表的形式查看站点、打开文件、重命名文件、向站点添加新文件夹或文件或者在进行更改后刷新站点的视图。

您也可以使用“站点”面板来确定（本地或远程站点上）哪些文件在上次传输后进行了更新。有关将本地站点与远程站点同步的信息，请参见同步本地和远程站点上的文件。

若要从“站点”面板中打开一个文件，请执行以下操作之一：
  • 双击该文件的图标。
  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件的图标，然后选择“打开”。
  • 选择“文件”>“打开”(Windows) 或“站点”>“打开”(Macintosh)。
若要向站点添加新文件或文件夹，请执行以下操作：
  1. 在“站点”面板中选择一个文件或文件夹。

    2. Dreamweaver 将在当前选定的文件夹中（或者在与当前选定文件所在的同一个文件夹中）新建文件或文件夹。

  2. 对于新文件夹，请选择“站点”面板上的“文件”>“新建文件夹”(Windows) 或者选择“站点”>“站点文件视图”>“新建文件夹”(Macintosh)。

    3. 对于新文件，选择“站点”面板上的“文件”>“新建文件”(Windows) 或者选择“站点”>“站点文件视图”>“新建文件”(Macintosh)。

    备注： 或者，也可以从“站点”面板的上下文菜单中选择“新建文件”或“新建文件夹”。

  3. 输入新文件或新文件夹的名称。
  4. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
若要重命名站点中的文件或文件夹，请执行以下操作：
  1. 在“站点”面板中，选择要重命名的文件或文件夹。
  2. 执行以下操作之一，激活文件或文件夹的名称：
    • 选择“文件”>“重命名”(Windows) 或“站点”>“重命名”(Macintosh)。
    • 单击文件名，稍停片刻，然后再次单击。
    • 右击 (Windows) 或按住 CTRL 键并单击 (Macintosh)文件的图标并选择“重命名”。
  3. 键入新的名称。
  4. 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
若要刷新“站点”面板，请执行以下操作之一：
  • 选择“查看”>“刷新”(Windows) 或“站点”>“站点文件视图”>“刷新”(Macintosh)。
  • 单击“站点”面板上的“刷新”按钮（此选项刷新两个窗格）。

备注： 当您在另一个应用程序中进行了更改并返回到 Dreamweaver 时，Dreamweaver 会自动刷新“站点”面板。

若要定位并选择取出的文件，请执行以下操作：

在“站点”面板中，选择“编辑”>“选择取出文件”(Windows) 或“站点”>“站点文件视图”>“选择取出文件”(Macintosh)。

若要定位并选择在本地站点比在远程站点新的文件，请执行以下操作：

在“站点”面板中，选择“编辑”>“选择较新的本地文件”(Windows) 或“站点”>“站点文件视图”>“选择较新的本地文件”(Macintosh)。

若要定位并选择在远程站点比在本地站点新的文件，请执行以下操作：

在“站点”面板中，选择“编辑”>“选择较新的远程文件”(Windows) 或“站点”>“站点文件视图”>“选择较新的远程文件”(Macintosh)。


在“站点”面板中查找文件

您可以从“站点”面板中搜索本地和远程站点的文件。有关搜索和替换文件内文本的更多信息，请参见第 605页的“搜索和替换文本”。

若要查找本地站点中的文件，请执行以下操作：
  1. 从远程站点中打开该文件，或者在“站点”面板的“远程”视图中选择该文件。
  2. 执行以下操作之一：
    • 如果已经在文档窗口中打开该文件，请选择“站点”>“在站点定位”。
    • 如果已经在“站点”面板中选择了该文件，请右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“在本地站点定位”。

      • Dreamweaver 在“站点”面板的“本地”视图中突出显示该文件。

若要查找远程站点中的文件，请执行以下操作：
  1. 从本地站点中打开该文件，或者在“站点”面板的“本地”视图中选择该文件。
  2. 执行以下操作之一：
    • 如果已经在文档窗口中打开了该文件，请选择“站点”>“在站点定位”。
    • 如果已经在“站点”面板中选择了该文件，请右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“在远程站点定位”。

      • Dreamweaver 在“站点”面板的“远程站点”视图中突出显示该文件。

备注： 如果在文档窗口处于活动状态时选择“站点”>“在站点定位”并且当前文件不属于当前打开的站点，则 Dreamweaver 会尝试确定当前文件属于哪一个本地定义的站点；如果当前文件仅属于一个本地站点，则 Dreamweaver 将打开该站点并在其中定位文件。


使用集成的文件浏览器

通过“站点”面板中的集成文件浏览器，您可以访问桌面和本地网络（包括其他已定义的站点和与站点不关联的文件）。使用集成文件浏览器可对当前站点之外的文件执行以下操作：

  • 拖动文件
  • 删除文件
  • 重命名文件
  • 浏览网络
  • 在 Dreamweaver 或其他应用程序中打开文件
  • 站点操作，如文件传输

备注： 执行这些操作的方式与对已定义站点中的文件执行操作的方式相同（请参见关于“站点”面板）。管理文件的最佳方式是创建 Dreamweaver 站点（请参见设置 Dreamweaver 站点）。

当您将文件从一个站点拖至另一个站点（或一个与站点不关联的文件夹）时，Dreamweaver 会将拖动的文件拷贝到所拖放的位置。如果您在同一个站点中拖动某文件，Dreamweaver 会将拖动的文件从它原来的位置移动到所拖放的位置。

当您将与站点不关联的文件拖至一个站点时，Dreamweaver 会将该文件拷贝到所拖放的位置。如果您将与站点不关联的文件拖至另一个与站点不关联的文件夹，Dreamweaver 会将该文件移动到所拖放的位置。

备注： 若要移动 Dreamweaver 在默认情况下拷贝的文件，请在拖动时按住 Shift 键 (Windows) 或 Command 键 (Macintosh)。若要拷贝 Dreamweaver 在默认情况下移动的文件，请在拖动时按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。

在文件浏览器中，站点文件夹和非站点文件夹以不同的颜色显示，以便于您区分这两者。如果试图对与站点不关联的文件夹或文件执行站点操作，则 Dreamweaver 会要求您在执行该操作前定义一个 Dreamweaver 站点。

若要使用集成文件浏览器，请执行以下操作：

在“站点”面板文件树中，单击“桌面”旁边的加号 (+) (Windows) 或“计算机”旁边的扩展箭头 (Macintosh)。


关于站点地图

站点地图用于以链接图标视觉地图的形式查看 Dreamweaver 站点的本地文件夹；向 Dreamweaver 站点添加新文件；或者添加、修改或删除链接。站点地图是理想的站点结构布局工具。您可以快速地设置整个站点结构，然后创建站点地图的图形图像。

备注： 站点地图仅适用于本地站点。若要创建远程站点的地图，请将远程站点的内容拷贝到本地磁盘上的一个文件夹中，然后使用“编辑站点”命令将该站点定义为本地站点。有关更多信息，请参见设置本地文件夹。


使用站点地图

在显示站点地图之前，必须先定义站点的“主页”。站点的主页可以是站点中的任意页；它不必是站点的主要页。这种情况下，主页只是地图的起点。

若要定义站点的主页，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 即会出现“编辑站点”对话框。

  2. 选择“编辑”以打开一个现有站点。

    3. 即会出现“站点定义”对话框。

  3. 从左侧的类别列表中选择“站点地图布局”。

    4. “站点定义”对话框显示“站点地图布局”选项。
    这是所描述的功能的图片。

  4. 单击文件夹图标以通过浏览查找站点的主页，或者在“主页”文本框中键入文件路径。
  5. 单击“确定”。
若要查看站点地图，请执行以下操作：
  1. （仅限 Windows）在“站点”面板中，单击“展开/折叠”按钮展开“站点”面板（如果它尚未展开）。
  2. 选择“查看”>“站点地图”或单击“站点地图”按钮，然后选择“仅限地图”或“站点和地图”。

    3. 选择“仅限地图”以查看不包含本地文件结构的站点地图，或者选择“站点和地图”以查看包含本地文件结构的站点地图。

    备注： 如果尚未定义主页或者 Dreamweaver 在当前站点中找不到要用作主页的 index.html 或 index.htm 页，则将出现一个对话框，提示您通过单击“编辑站点”选择主页。选择一个站点，单击“编辑”，然后从“站点定义”对话框左侧的类别列表中选择“站点地图布局”。

    “站点”面板显示当前站点的站点地图或者随本地文件结构一起显示当前站点的站点地图。


查看站点地图

站点地图将 HTML 文件和其他页显示为图标。站点地图按链接在 HTML 源代码中出现的顺序来显示链接，如下所示：

  • 以红色显示的文本指示断开的链接。
  • 以蓝色显示并标有地球图标的文本指示其他站点上的文件或特殊链接（如电子邮件或脚本链接）。
  • 绿色选中标记指示您已取出的文件。
  • 红色选中标记指示他人取出的文件。
  • 锁形图标指示只读 (Windows) 或锁定 (Macintosh) 的文件。

默认情况下，站点地图从当前主页开始显示两个级别深度的站点结构。单击某页旁的加号 (+) 和减号 (-) 可显示或隐藏链接在第二级之下的页。

默认情况下，站点地图不显示隐藏文件和相关文件。隐藏文件是标为“隐藏”的 HTML 文件。相关文件是图像、模板、Macromedia Shockwave 文件或 Macromedia Flash 文件等非 HTML 页内容。有关更多信息，请参见显示和隐藏站点地图文件。


修改站点地图布局

使用“站点地图布局”选项可自定义站点地图的外观。您可以指定主页、显示的列数、图标标签文字是显示文件名还是显示页标题以及是否显示隐藏和相关文件。

若要修改站点地图布局，请执行以下操作：
  1. 执行以下操作之一，打开“站点定义”对话框：
    • 选择“站点”>“编辑站点”，然后单击“编辑”。在左侧的类别列表中选择“站点地图布局”。
    • 在“站点”面板上，选择“站点”>“布局”(Windows) 或“站点”>“站点地图视图”>“链接到新文件”(Macintosh)。

      • “站点定义”对话框显示“站点地图布局”选项
      这是所描述的功能的图片。
      。

  2. 按需要进行更改。

    3. 有关更多信息，请参见设置“站点地图布局”类别选项。

  3. 单击“确定”关闭“站点定义”对话框。
  4. 单击“完成”关闭“编辑站点”对话框（如果它尚未关闭）。


在站点地图中处理页

当您在站点地图中工作时，可以选择页、打开页进行编辑、向站点添加新页、创建文件之间的链接以及更改页标题。

若要在站点地图中选择多个页，请执行以下操作之一：
  • 按住 Shift 键单击以选择某一范围的相邻页。
  • 从视图的空白部分开始在一组文件周围拖动，以选择这些文件。
  • 按住 Ctrl 键单击 (Windows) 或按住 Command 键单击 (Macintosh)，以选择不相邻的页。
若要在站点地图中打开某页进行编辑，请执行以下操作之一：
  • 双击该文件。
  • 选择该文件，然后选择“文件”>“打开”(Windows) 或“站点”>“打开”(Macintosh)。
若要向站点添加现有文件，请执行以下操作之一：
  • 将一个文件从 Windows 资源管理器或 Macintosh Finder 中拖至站点地图中的一个文件。该页被添加到站点中，同时会在它和您拖至的文件之间创建一个链接。
  • 选择“站点”>“链接到现有文件”(Windows) 或“站点”>“站点地图视图”>“链接到现有文件”(Macintosh)，然后浏览到该文件。
若要创建新文件并在站点地图中添加链接，请执行以下操作：
  1. 在站点地图中选择一个 HTML 文件，然后执行以下操作之一：
    • 选择“站点”>“链接到新文件”(Windows) 或“站点”>“站点地图视图”>“链接到新文件”(Macintosh)。
    • 从上下文菜单中选择“链接到新文件”。

      • 出现“链接到新文件”对话框。
      这是所描述的功能的图片。

  2. 输入该链接的名称、标题和文本。
  3. 单击“确定”。

    4. Dreamweaver 将该文件保存在与选定文件相同的文件夹中。如果向隐藏分支添加一个新文件，则该新文件也会隐藏起来（请参见显示和隐藏站点地图文件）。

若要在站点地图中修改页的标题，请执行以下操作：
  1. 确保“显示页标题”选项已选定，方法是在“站点”面板中选择“查看”>“显示页标题”(Windows) 或“站点”>“站点地图视图”>“显示页标题”(Macintosh)。
  2. 选择一个页，然后执行以下操作之一：
    • 单击标题。当标题可以编辑时，输入新的标题。
    • 选择“文件”>“重命名”(Windows) 或“站点”>“重命名”(Macintosh)。
  3. 键入新名称后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

备注： 当您在“站点”面板中工作时，Dreamweaver 会自动更新指向其名称已更改的文件的所有链接。

若要在站点地图中更改主页，请执行以下操作之一：
  • 在“站点”面板的“本地”视图中，选择一个文件，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“设置为主页”。
  • 在“站点”面板的“本地”视图中，单击要设置为新主页的文件，然后选择“站点”>“设置为主页”(Windows) 或“站点”>“站点地图视图”>“设置为主页”(Macintosh)。
  • 在站点地图中选择一个文件，然后选择“站点”>“新建主页”(Windows) 或“站点”>“站点地图视图”>“新建主页”(Macintosh)。
  • 选择“站点”>“编辑站点”，然后单击“编辑”。在“站点定义”对话框类别列表中选择“站点地图布局”。浏览到新主页，然后单击“确定”。
若要在进行更改后更新站点地图显示，请执行以下操作：
  1. 在站点地图中的任意位置单击，取消选择任何文件。
  2. 选择“查看”>“刷新”(Windows) 或“站点”>“站点地图视图”>“刷新本地文件”(Macintosh)。


显示和隐藏站点地图文件

您可以修改站点地图的布局，以显示或隐藏隐藏文件和相关文件。当您需要强调关键主题或内容而隐藏不太重要的材料时，此功能非常有用。

若要使用站点地图隐藏文件，您必须将该文件标记为隐藏。当您隐藏某文件时，该文件的链接也会隐藏起来。当您显示标记为隐藏的文件时，它的图标和链接将显示在站点地图中，但名称以斜体显示。

备注： 默认情况下，相关文件已经被隐藏。

若要在站点地图中将文件标记为隐藏，请执行以下操作：
  1. 在站点地图中选择一个或多个文件。
  2. 选择“查看”>“显示/隐藏链接”(Windows) 或“站点”>“站点地图视图”>“显示/隐藏链接”(Macintosh)。
若要显示或隐藏站点地图中标记为隐藏的文件，请执行以下操作之一：
  • 选择“查看”>“显示标记为隐藏的文件”(Windows) 或“站点”>“站点地图视图”>“显示标记为隐藏的文件”(Macintosh)。
  • 选择“查看”>“布局”(Windows) 或“站点”>“站点地图视图”>“布局”(Macintosh)，打开“站点定义”对话框，然后选择“显示标记为隐藏的文件”选项。
若要在站点地图中显示相关文件，请执行以下操作之一：
  • 选择“查看”>“显示相关文件”(Windows) 或“站点”>“站点地图视图”>“显示相关文件”(Macintosh)。
  • 选择“查看”>“布局”(Windows) 或“站点”>“站点地图视图”>“布局”(Macintosh)，打开“站点定义”对话框，然后选择“显示相关文件”选项。
若要在站点地图中取消文件的隐藏标记，请执行以下操作：
  1. 在站点地图中选择一个或多个文件。
  2. 选择“查看”>“显示标记为隐藏的文件”(Windows) 或“站点”>“站点地图视图”>“显示标记为隐藏的文件”(Macintosh)。
  3. 选择“查看”>“显示/隐藏链接”(Windows) 或“站点”>“站点地图视图”>“显示/隐藏链接”(Macintosh)。


通过分支查看站点

通过使某个分支成为站点地图的焦点，可以查看站点特定部分的详细信息。

若要查看站点地图中的另一分支，请执行以下操作：

选择要查看的页，然后选择“查看”>“作为根查看”(Windows) 或“站点”>“站点地图视图”>“作为根查看”(Macintosh)。

站点地图在窗口中重新绘制，就象指定页位于站点的根目录一样。站点地图之上的“站点导航”文本框显示从主页到指定页的路径。通过一次单击选择路径中的任意项，从该级别开始查看站点地图。

若要展开和收缩站点地图中的分支，请执行以下操作：

单击分支的加号 (+) 或减号 (-)。


保存站点地图

您可以将站点地图保存为图像，然后在图像编辑器中查看（或打印）该图像。

若要创建当前站点地图的图像文件，请执行以下操作：
  1. 从站点地图中执行以下操作之一：
    • 在 Windows 中，选择“文件”>“保存站点地图”。在“保存站点地图”对话框的“文件名”文本框中输入一个名称。在“文件类型”弹出式菜单中，选择 .bmp 或 .png。
    • 在 Macintosh 中，选择“站点”>“站点地图视图”>“保存站点地图”>“将站点地图另存为 PICT”或者“站点”>“站点地图视图”>“保存站点地图”>“将站点地图另存为 JPEG”。
  2. 选择该文件的保存位置并输入图像的名称。
  3. 单击“保存”。


导入和导出站点

通过 Dreamweaver，您可以将站点导出为 XML 文件，然后将其导入回 Dreamweaver。这样，您就可以在各计算机和产品版本之间移动站点，或者与其他用户共享。

若要导出站点，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 单击“导出”按钮。

    3. 出现“导出站点”面板。

  3. 浏览到保存该站点的位置。
  4. 单击“保存”。

    5. Dreamweaver 在指定位置将站点保存为带 STE 文件扩展名的 XML 文件。

  5. 单击“完成”关闭“编辑站点”对话框。
若要导入站点，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 单击“导入”按钮。

    3. 出现“导入站点”面板。

  3. 浏览到要导入的站点（保存为 XML 文件）并将其选定。

    4. 备注： 在导入文件之前，您必须先从 Dreamweaver 中导出站点，将站点保存为 XML 文件。

  4. 单击“打开”。

    5. Dreamweaver 导入该站点，而站点名称出现在“编辑站点”对话框中。

  5. 单击“完成”关闭“编辑站点”对话框。


从站点列表中删除站点

如果您不再需要使用 Dreamweaver 中的某一站点，则可以从站点列表中将该站点删除。站点中的文件不会被删除。

备注： 当从列表中删除站点后，有关该站点的所有设置信息将永久丢失。

若要从站点列表中删除站点，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 选择一个站点名称。
  3. 单击“删除”。

    4. 出现一个对话框，要求您确认删除。

  4. 单击“是”从列表中删除站点，或单击“否”保留站点名称。
  5. 单击“完成”关闭“编辑站点”对话框。


使用存回/取出

如果您在协作环境中工作，则可以从本地和远程服务器中存回和取出文件。如果只有您一个人在远程服务器上工作，则可以使用“上传”和“获取”命令，而不用存回或取出文件（请参见获取和上传文件）。

取出文件相当于声明“我现在正在处理该文件 - 请不要动它！”。当文件取出后，Dreamweaver 会在“站点”面板上显示取出该文件的人员的名称，并且在该文件的图标旁显示一个红色选中标记（如果是小组成员取出该文件）或绿色选中标记（如果是您自己取出该文件）。

存回文件使文件可供其他小组成员取出和编辑。当您在编辑文件后将其存回时，本地版本将变为只读，一个锁形符号出现在“站点”面板上该文件的旁边，以防止您更改该文件。

Dreamweaver 不会使远程服务器上的取出文件成为只读。如果您使用 Dreamweaver 之外的应用程序传输文件，则可能会覆盖取出文件。但是，在 Dreamweaver 之外的应用程序中，.LCK 文件显示在文件层次结构中取出文件的旁边，以便于防止出现这种意外。

若要对某些站点启用或禁用存回/取出功能，请参见设置存回/取出系统。有关在本地和远程站点之间传输文件而不将文件存回或取出的信息，请参见从远程或测试服务器获取文件和将文件上传到远程或测试服务器上。

备注： 您可以将“获取”和“上传”功能用于测试服务器，但不能将存回/取出系统用于测试服务器。


设置存回/取出系统

在使用存回/取出系统之前，必须先将本地站点与一个远程服务器相关联（请参见设置远程文件夹）。

若要设置存回/取出系统，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    3. 即会出现“站点定义”对话框。

  3. 在左侧的类别列表中单击“远程信息”。

    4. “站点定义”对话框显示远程信息选项。“存回/取出”部分出现在该对话框的底部。
    这是所描述的功能的图片。

    备注： 如果您没有看到“存回/取出”选项，则说明没有设置远程服务器（请参见设置远程文件夹）。

  4. 完成“存回/取出”部分。

    5. 有关更多信息，请参见设置“存回/取出”选项。

  5. 单击“确定”。


在远程站点中存回和取出文件

使用“站点”面板或文档窗口在远程服务器上存回和取出文件。

Dreamweaver 存回/取出系统在“站点”面板中使用以下符号：

  • 绿色选中标记指示您已取出该文件。
  • 红色选中标记指示其他小组成员已取出该文件。
  • 锁形符号指示文件是只读 (Windows) 或锁定的 (Macintosh)。

如果您取出一个文件，然后决定不对它进行编辑（或者决定放弃所进行的更改），则可以撤消取出。

若要通过“站点”面板从远程服务器中取出文件，请执行以下操作：
  1. 从“站点”弹出式菜单中选择一个站点。
  2. 选择要取出的文件。

    3. 备注： 您可以在“本地”或“远程”视图中选择文件。

  3. 执行以下操作之一以取出文件：
    • 单击“站点”面板工具栏上的“取出”按钮。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“取出”。
  4. 当出现提示时，单击“是”将相关文件随选定文件一起下载，或者单击“否”禁止下载相关文件。

    5. 备注： 在取出新文件时下载相关文件通常是一种不错的做法，但是如果本地磁盘上已经有最新版本的相关文件，则无需再次下载它们。

    一个绿色选中标记出现在文件图标的旁边，指示您已将其取出。

若要通过“站点”面板将文件存回到远程服务器，请执行以下操作：
  1. 从“站点”弹出式菜单中选择一个站点。
  2. 选择取出的文件或新的文件。

    3. 备注： 您可以在“本地”或“远程”视图中选择文件。

  3. 请执行以下操作之一以存回文件：
    • 单击“站点”面板工具栏上的“存回”按钮。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“存回”。
  4. 当出现提示时，单击“是”将相关文件随选定文件一起下载，或者单击“否”禁止下载相关文件。

    5. 备注： 在存回新文件时上传相关文件通常是一种不错的做法，但是如果远程服务器上已经有最新版本的相关文件，则无需再次上传它们。

    一个锁形符号出现在文件图标的旁边，指示该文件现在为只读。

若要通过文档窗口存回或取出打开的文件，请执行以下操作之一：
  • 单击“站点”>“存回”或“站点”>“取出”。
  • 单击文档窗口工具栏上的“文件管理”图标，然后从弹出式菜单中选择“存回”或“取出”。

    • 备注： 如果您选择“站点”>“存回”或“站点”>“取出”，并且当前文件不属于当前打开的站点，则 Dreamweaver 会尝试确定当前文件属于哪一个本地定义的站点。如果当前文件仅属于一个本地站点，则 Dreamweaver 将打开该站点，然后执行存回或取出操作。

如果您取出当前处于活动状态的文件，则新的取出版本会覆盖该文件的当前打开的版本。如果您存回当前处于活动状态的文件，则根据您设置的参数选择选项（请参见设置“站点”参数），该文件可能会在存回前自动保存。

若要撤消文件取出，请执行以下操作：
  1. 选择文件。
  2. 执行以下操作之一以撤消取出：
    • 选择“站点”>“撤消取出”。
    • 在“站点”面板中右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 该文件，然后从上下文菜单中选择“撤消取出”。

该文件的本地拷贝成为只读，您对它进行的任何更改都会丢失。


获取和上传文件

如果您在协作环境中工作，则可以使用存回/取出系统在本地和远程站点之间传输文件（请参见使用存回/取出）。但是，如果只有您一个人在远程站点上工作，则可以使用“获取”和“上传”命令传输文件，而不用存回或取出文件。

备注： 如果您在文档窗口处于活动状态时选择“站点”>“获取”或“站点”>“上传”，并且当前文件不属于当前打开的站点，则 Dreamweaver 会尝试确定当前文件属于哪一个本地定义的站点；如果当前文件只属于一个本地站点，则 Dreamweaver 将打开该站点，然后执行“获取”或“上传”操作。


从远程或测试服务器获取文件

“获取”命令将文件从远程站点或测试服务器拷贝到本地站点，如下所示：

  • 如果您正在使用存回/取出系统（即，如果已选中“启用文件存回和取出”选项），则获取文件操作会产生该文件的只读 本地拷贝；该文件仍将留在远程站点或测试服务器上，可供其他小组成员取出（请参见使用存回/取出）。
  • 如果您没有使用存回/取出系统（即，如果未选中“启用文件存回和取出”选项），则获取文件操作得到的是具有读写 特权的拷贝。

    • 备注： 如果您正在协作环境中工作（即，其他人正在处理相同的文件），则不要关闭“启用文件存回和取出”功能。如果其他人在该站点上使用了存回/取出系统，则您也应该使用该系统。

您可以通过在“站点”面板的“本地”或“远程”视图中选择文件的方式来获取文件。如果“远程”视图处于活动状态，则 Dreamweaver 会将选定的远程文件拷贝到本地站点；如果“本地”视图处于活动状态，则 Dreamweaver 会将选定的本地文件的远程版本拷贝到本地站点。

若要仅获取其远程版本比本地版本新的文件，请使用“同步”命令（请参见同步本地和远程站点上的文件）。

Dreamweaver 会记录所有 FTP 文件传输活动。如果您使用 FTP 传输文件时出错，则可以借助于站点 FTP 日志来确定问题所在。

若要显示 FTP 日志，请执行以下操作：

选择“查看”>“站点 FTP 日志”。

若要从远程或测试服务器获取文件，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择一个站点。
  2. 如果您在使用 FTP 传输文件，请单击“连接”按钮打开与远程服务器的连接。

    3. 如果连接已经打开（由“断开”按钮指示），则跳过此步骤。

    如果可以在前一连接的“远程”窗格中看到远程文件，则无需单击“连接”；当您单击“获取”时，Dreamweaver 会自动连接。

  3. 选择所需文件进行下载。

    4. 通常在“远程”或“测试服务器”视图中选择这些文件，但如果愿意，也可以在“本地”视图中选择相应的文件。

  4. 执行以下操作之一以获取文件：
    • 单击“站点”面板工具栏上的“获取”按钮。
    • 从上下文菜单中选择“获取”。
    • 选择“站点”>“获取”。

      • 备注： 如果文件当前已在文档窗口中打开，则可以从文档窗口中选择“站点”>“获取”。

      出现一个对话框，询问您是否要获取相关文件。

  5. 若要下载相关文件，请单击“是”；若要跳过这些文件，请单击“否”。

    6. 如果已经有相关文件的本地拷贝，则单击“否”。

若要在任意时刻停止文件传输，请单击状态对话框中的“取消”按钮。传输可能不会立即停止。


将文件上传到远程或测试服务器上

“上传”命令将文件从本地站点拷贝到远程站点，并且通常不会更改文件的取出状态。在两种常见的情况下，您可能会使用“上传”来代替“存回”：

  • 当您不在协作环境中并且没有使用存回/取出系统时，可使用“上传”。

    • 备注： 如果您要将文件上传到远程服务器并将其存回，可使用“存回”命令（请参见在远程站点中存回和取出文件）。

  • 当您要将文件的当前版本上传到服务器上但要继续编辑它时，可使用“上传”。

    • 备注： 如果您上传先前在远程站点上不存在的文件并且正在使用存回/取出系统，则该文件将被拷贝到远程站点，然后向您取出，使您可以继续编辑。

若要仅上传其本地版本比远程版本新的文件，请参见同步本地和远程站点上的文件。

备注： 在要上传到远程或测试服务器上的文件的名称中，不要使用特殊字符（如 é、ç 或 ¥）或标点符号（如冒号、斜杠或句号）。许多服务器会在上传过程中更改这些字符，使指向这些文件的链接被破坏。

若要将文件上传到远程或测试服务器上，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择一个站点。
  2. 如果您在使用 FTP 传输文件，则可以单击“连接”打开与远程服务器的连接，这将使您能够在传输文件前看到远程服务器上的内容。

    3. 不过，单击“连接”并不是必需的操作；当您单击“上传”时，Dreamweaver 会自动连接。

  3. 选择要上传的文件。

    4. 通常在“本地”视图中选择这些文件，但如果愿意的话，可以在“远程”视图中选择相应的文件。

  4. 执行以下操作之一以放置文件：
    • 单击“站点”面板工具栏上的“上传”按钮。
    • 从上下文菜单中选择“上传”。
    • 选择“站点”>“上传”。

      • 如果文件当前已经在文档窗口中打开，则可以从文档窗口中选择“站点”>“上传”。

  5. 如果该文件尚未保存，则可能会出现一个对话框（取决于您在“参数选择”对话框的“站点”面板中设置的参数选择），让您在将文件上传到远程服务器之前对其进行保存。

    6. 若要保存该文件，请单击“是”；若要将先前保存的版本上传到远程服务器上，请单击“否”。如果选择不保存文件，则不会将上次保存后进行的任何更改上传到远程服务器上。但是，该文件会继续保持打开状态，如果需要，在将文件上传到服务器上之后，您仍可以保存更改。

    出现一个对话框，询问您是否要放置相关文件。

  6. 若要上传相关文件，请单击“是”；若要跳过这些文件，请单击“否”。

    7. 如果远程站点已经包含相关文件的拷贝，则单击“否”。若要避免将来上传时再次被询问是否上传相关文件，请选择“不要再问我”选项。

若要停止文件传输，请单击状态对话框中的“取消”按钮。传输可能不会立即停止。

Dreamweaver 会记录所有 FTP 文件传输活动。如果您使用 FTP 传输文件时出错，则可以借助于站点 FTP 日志来确定问题。若要显示该日志，请选择“查看”>“站点 FTP 日志”。


同步本地和远程站点上的文件

当您在本地和远程站点上创建文件后，可以在这两种站点之间进行文件同步。使用“站点”>“同步”命令可以向远程站点及从远程站点传输文件的最新版本。

如果远程站点为 FTP 服务器（而不是联网的服务器），则使用 FTP 来同步文件。有关使用 FTP 的更多信息，请参见设置远程文件夹。

在同步站点之前，Dreamweaver 会让您验证要将哪些文件上传到远程服务器上或从远程服务器中获取哪些文件。Dreamweaver 还将在您完成同步后确认哪些文件进行了更新。

若要在不进行同步的情况下查看哪些文件在本地站点或远程站点上较新，请执行以下操作之一：
  • 从“站点”面板中选择“编辑”>“选择较新的本地文件”或“编辑”>“选择较新的远程文件”(Windows)。
  • 选择“站点”>“站点文件视图”>“选择较新的本地文件”或“站点”>“站点文件视图”>“选择较新的远程文件”(Macintosh)。
若要同步文件，请执行以下操作：
  1. 在“站点”面板上，从“当前站点”列表弹出式菜单中选择一个站点。
  2. 选择特定的文件或文件夹。

    3. 如果要同步整个站点，请跳过此步骤。

  3. 在“站点”面板中执行以下操作之一以进行同步：
    • 选择“站点”>“同步”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“同步”。

      • 出现“同步文件”对话框。
      这是所描述的功能的图片。

  4. 完成该对话框。

    5. 有关更多信息，请参见设置“同步文件”对话框选项。

Dreamweaver 自动同步文件。如果这些文件已经同步，则 Dreamweaver 会通知您不必进行同步。


遮盖站点中的文件夹和文件

利用站点遮盖功能，您可以从“获取”或“上传”等操作中排除站点中的某些文件夹和文件类型。您可以遮盖单独的文件夹，但不能遮盖单独的文件。若要遮盖文件，必须选择文件类型，而 Dreamweaver 会遮盖该类型的所有文件。Dreamweaver 会记住每个站点的设置，因此您不必每次在该站点上工作时都进行选择。

例如，如果您在一个大型站点上工作，并且不想每天都上传多媒体文件，则可以使用站点遮盖功能遮盖您的多媒体文件夹，而系统会从您执行的站点操作中排除该文件夹中的文件。

您可以遮盖远程或本地站点上的文件夹和文件类型。遮盖功能会从以下操作中排除遮盖的文件夹和文件：

  • 放置、获取、存回和取出
  • 报告
  • 选择较新的本地文件和选择较新的远程文件
  • 整个站点范围的操作，例如检查和更改链接以及搜索/替换
  • 同步
  • “资源”面板内容
  • 模板和库的更新

备注： Dreamweaver 仅从“获取”和“上传”操作中排除遮盖的模板和库项。Dreamweaver 并不从批处理操作中排除这些项，因为这可能会使这些项与它们的实例不同步。

您可以对特定的遮盖文件夹执行操作，方法是在“站点”面板上选择该项，然后对它执行操作。直接对文件或文件夹执行的操作会取代遮盖设置。


启用和禁用站点遮盖

默认情况下启用站点遮盖功能。您可以永久禁用遮盖功能，也可以为了对所有文件（包括遮盖的文件）执行某一操作而临时禁用遮盖功能。当禁用站点遮盖功能之后，所有遮盖文件都会取消遮盖。当再次启用站点遮盖功能时，所有先前遮盖的文件将恢复遮盖。

备注： 您也可以使用“全部取消遮盖”选项来取消所有文件的遮盖，但这不会禁用遮盖；而且，若要重新遮盖所有先前被遮盖的文件夹和文件，只能逐个对各个文件夹和文件类型重新设置遮盖，没有其他方法。

若要启用或禁用站点遮盖功能，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择一个站点。
  2. 在“站点”面板上执行以下操作之一：
    • 选择“站点”>“遮盖”以显示子菜单。
    • 选择一个文件夹或文件，右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，以显示上下文菜单。
  3. 从子菜单中执行以下操作之一：
    • 选择“启用/禁用遮盖”。
    • 选择“设置”。然后，在“高级站点定义”对话框中，从左侧的类别列表中选择“遮盖”，选择或取消选择“启用遮盖”，最后单击“确定”。

对该站点启用或禁用遮盖功能。


遮盖站点文件夹和取消站点文件夹的遮盖

您可以遮盖特定文件夹，但不能遮盖所有文件夹或整个站点。当您遮盖特定文件夹时，可以同时遮盖多个文件夹。

若要遮盖站点中的特定文件夹或取消其遮盖，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择已启用站点遮盖功能的站点。
  2. 选择要遮盖或取消遮盖的文件夹。
  3. 在“站点”面板上执行以下操作之一：
    • 选择“站点”>“遮盖”>“遮盖”或“站点”>“遮盖”>“取消遮盖”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从上下文菜单中选择“遮盖”>“遮盖”或“遮盖”>“取消遮盖”。

一条穿过文件夹图标的红线将出现或消失，指示该文件夹已遮盖或取消遮盖。


遮盖特定文件类型和取消特定文件类型的遮盖

您可以遮盖指定的特定文件类型，以便 Dreamweaver 遮盖以指定形式结尾的所有文件。例如，您可以遮盖所有以 .txt 扩展名结尾的文件。您输入的文件类型不一定是文件扩展名；它们可以是任何形式的文件名结尾。

若要遮盖站点中的特定文件类型，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择已启用站点遮盖功能的站点。
  2. 执行以下操作之一：
    • 选择“站点”>“遮盖”>“设置”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“设置”。

      • 出现“高级站点定义”对话框。
      这是所描述的功能的图片。

  3. 选择“遮盖以如下内容结束的文件”复选框。
  4. 在文本框中输入要遮盖的文件类型。

    5. 例如，您可以输入 .jpg 以遮盖站点中名称以 .jpg 结尾的所有文件。

    备注： 用一个空格分隔多个文件类型；不要使用逗号或分号。

  5. 单击“确定”。

一条红线将穿过受影响的文件，指示它们已被遮盖。

提示： 某些软件会创建以特定后缀（如 .bak）结尾的备份文件。您可以遮盖这些文件。

若要取消站点中特定文件类型的遮盖，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择已启用站点遮盖功能的站点。
  2. 执行以下操作之一：
    • 选择“站点”>“遮盖”>“设置”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“遮盖”>“设置”。

      • 出现“高级站点定义”对话框。

  3. 执行以下操作之一：
    • 取消选择“遮盖以如下内容结束的文件”复选框，以取消在文本框中列出的所有文件类型的遮盖。
    • 从文本框中删除特定文件类型，以取消这些文件类型的遮盖。
  4. 单击“确定”。

红线从受影响的文件上消失，指示它们已取消遮盖。


取消所有文件夹和文件的遮盖

您可以同时取消站点中所有文件夹和文件的遮盖。此操作无法撤消；没有任何方法可以重新遮盖先前遮盖的所有项。您必须逐一重新遮盖这些项。

备注： 如果要临时取消所有文件夹和文件的遮盖，然后重新遮盖这些项，请禁用站点遮盖功能（请参见启用和禁用站点遮盖）。

若要取消站点中所有文件夹和文件的遮盖，请执行以下操作：
  1. 在“站点”面板上，从“站点”弹出式菜单中选择已启用站点遮盖功能的站点。
  2. 选择该站点中的任意文件或文件夹。
  3. 在“站点”面板上执行以下操作之一：
    • 选择“站点”>“遮盖”>“全部取消遮盖”。
    • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后选择“遮盖”>“全部取消遮盖”。

      • 备注： 该步骤还会取消对“站点”>“遮盖”>“设置”中“遮盖以如下内容结尾的文件”复选框的选择。

      穿过文件夹和文件图标的红线消失，指示站点中的所有文件和文件夹都已取消遮盖。


使用设计备注

设计备注是您为文件创建的备注。设计备注与它们所描述的文件相关联，但存储在单独的文件中。您可以使用设计备注来记录与文档关联的其他文件信息，如图像源文件名称和文件状态说明。

例如，如果将一个文档从一个站点拷贝到另一个站点，则可以为该文档添加设计备注，说明原始文档位于另一站点的文件夹。这样，您（或其他人）在更新该文档时，能够知道还需要更新原始页。

您也可以使用设计备注来记录因安全原因而不能放在文档中的敏感信息。例如，您可以在其中记录该文档是如何创建的、某一价格或配置是如何选定的或哪些市场因素影响了某一设计决策等信息。

您可以在“站点”面板上看到哪些文件有设计备注：“设计备注”图标会出现在“备注”列中。

有关使用设计备注的常规信息，请参见在设计备注中保存文件信息。有关将设计备注用于 Fireworks 的信息，请参见将 Fireworks 和 Flash 中的设计备注用于 Dreamweaver。


启用和禁用设计备注

您可以在“站点定义”对话框的“设计备注”类别中对站点启用和禁用设计备注。当启用设计备注后，如果需要，可以选择仅在本地使用它们。

若要对站点启用或禁用设计备注或者仅在本地使用设计备注，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 选择一个站点，然后单击“编辑”。

    3. 即会出现“站点定义”对话框。

  3. 单击左侧类别列表中的“设计备注”。

    4. 出现“站点定义”对话框，其中包含设计备注选项。
    这是所描述的功能的图片。

  4. 完成该对话框。

    5. 有关更多信息，请参见设置“设计备注”类别选项。

  5. 单击“确定”。


在设计备注中保存文件信息

您可以为站点中的每一文档或模板创建设计备注文件。您还可以为 applets 、ActiveX 控件、图像、Flash 影片、Shockwave 对象以及文档中的图像域创建设计备注。

备注： 如果在模板文件中添加设计备注，用该模板创建的文档不会继承这些设计备注。

若要将设计备注添加到文档中，请执行以下操作：
  1. 当文档在文档窗口中处于活动状态时，选择“文件”>“设计备注”。

    2. 您还可以在“站点”面板中选择文件，然后选择“文件”>“设计备注”。

    备注： 如果该文件驻留在远程站点上，则您必须首先取出或获取该文件，然后在本地文件夹中选择它（请参见在远程站点中存回和取出文件或获取和上传文件）。

    即会出现“设计备注”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关更多信息，请参见设置“设计备注”对话框选项。

  3. 单击“确定”以保存备注。

    4. Dreamweaver 将您的备注保存到名为 _notes 的文件夹中，与当前文件处在相同的位置。文件名是文档的文件名加上 .mno 扩展名。

    例如，如果文件名是 index.html，则关联的设计备注文件名为 index.html.mno。

若要将设计备注添加到对象中，请执行以下操作：
  1. 选择对象。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)，然后从该对象的上下文菜单中选择“设计备注”。

    3. 出现“设计备注”对话框。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“设计备注”对话框选项。

  4. 单击“确定”以保存备注。

    5. Dreamweaver 将对象的设计备注文件保存到 _notes 文件夹中，设计备注文件与对象的源文件位于相同的目录中，而不一定与对象在其中出现的文档位于相同的目录中。

若要打开与文件关联的设计备注，请执行以下操作之一：
  • 在“站点”面板中选择文件；或者打开文件，然后选择“文件”>“设计备注”。
  • 在“站点”面板的“备注”列中，双击黄色的“设计备注”图标。
若要指定自定义设计备注状态，请执行以下操作：
  1. 打开文件或对象的设计备注（请参见前面的步骤）。
  2. 单击“所有信息”标签。
  3. 单击加号 (+) 按钮。
  4. 在“名称”域中，输入 status 一词。
  5. 在“值”域中，输入状态。

    6. 如果已存在状态值，则该值将被新状态值取代。

  6. 单击“基本信息”标签并记下在“状态”弹出式菜单中显示的新状态值。

    7. 备注： 状态菜单中一次只能有一个自定义值。如果再次执行此步骤，则 Dreamweaver 将用您输入的新状态值替代第一次输入的状态值。

若要从站点中删除未关联的设计备注，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 选择站点，然后单击“编辑”。

    3. 即会出现“站点定义”对话框。

  3. 单击左侧类别列表中的“设计备注”。
  4. 单击“清理”按钮。

    5. Dreamweaver 提示您确认它应删除任何不再与站点中的文件关联的设计备注。

    如果使用 Dreamweaver 删除具有关联的设计备注文件的文件，则 Dreamweaver 同时也删除设计备注文件；所以，通常只有当您在 Dreamweaver 外删除或重命名文件后，才会出现孤立的设计备注文件。

    备注： 如果在单击“清理”前取消对“维护设计备注”选项的选择，则 Dreamweaver 删除站点的所有设计备注文件。


将 Fireworks 和 Flash 中的设计备注用于 Dreamweaver

如果您在 Macromedia Fireworks 或 Macromedia Flash 中打开一个文件并将其导出为其他格式，则 Fireworks 和 Flash 自动在设计备注文件中保存原始源文件的名称。

例如，如果您在 Fireworks 中打开 myhouse.png 并将其导出为 myhouse.gif，则 Fireworks 创建一个名为 myhouse.gif.mno 的设计备注文件。此设计备注文件包含原始文件的名称，作为绝对 file:URL。因此，myhouse.gif 的设计备注可能包含此行：

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

类似的 Flash 设计备注可能包含此行：

fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"

备注： 若要共享设计备注，用户应定义相同的站点根路径。例如，sites/assets/orig。

当您将图形导入 Dreamweaver 中时，设计备注文件随该图形一起被自动拷贝到站点中。当您在 Dreamweaver 中选择图像并选择使用 Fireworks 编辑它时（请参见第 652页的“为媒体文件启动外部编辑器”），Fireworks 将打开原始文件以供编辑。


使用报告改进工作流程

您可以使用报告改进 Web 小组中各成员之间的协作。

您可以运行工作流程报告，这些报告显示谁取出了某个文件以及哪些文件具有与之关联的设计备注。您可以通过指定名称/值参数来进一步完善设计备注报告。

有关运行其他类型报告的信息，请参见第 833页的“使用“报告”测试站点”。

备注： 您必须定义远程站点连接以运行工作流程报告。

若要运行“取出者”报告，请执行以下操作：
  1. 打开一个文档。
  2. 选择“站点”>“报告”。

    3. 出现“报告”对话框。
    这是所描述的功能的图片。

  3. 选择要报告的报告类别和要运行的报告类型。

    4. 有关更多信息，请参见设置“报告”对话框选项。

  4. 单击“运行”。

    5. 根据所选的要报告的内容，可能会提示您保存文件、定义站点或选择文件夹（如果尚未执行这些操作的话）。

    报告随即出现在（“结果”面板组的）“站点报告”面板中。

若要使用报告，请执行以下操作：
  1. 在“站点报告”面板中，单击要根据其进行排序的列标题以对结果进行排序。

    2. 您可以按文件名、行号或说明进行排序。您还可以运行若干不同的报告并让不同的“结果”面板处于打开状态。

  2. 在报告中选择任意行，然后单击“站点报告”面板左侧的“更多信息”按钮以了解有关问题的说明。

    3. 相关信息随即出现在（“代码”面板组的）“参考”面板中。

  3. 双击报告中的任何行可以在文档窗口中查看相应的代码。

    4. 备注： 如果您正在使用“设计”视图，则 Dreamweaver 将更改显示来拆分视图，从而以代码的形式显示报告的问题。

  4. 单击“保存报告”保存该报告。

在保存报告时，您可以将其导入到现有模板文件中。于是您可以将该文件导入到数据库或电子表格中并进行打印，或者使用该文件在 Web 站点上显示报告。


关于 Dreamweaver 中的“SiteSpring”面板

您可以使用“Sitespring”面板直接在 Dreamweaver 中查看所有 Sitespring。您还可以从该面板中选择一个任务，连接到 Sitespring Web 页，然后编辑该任务。您可以保存在 Sitespring 中进行的所有更改，返回到 Dreamweaver 并刷新“Sitespring”面板以查看这些更改。“Sitespring”面板将显示您的任务，同时显示这些任务的优先级、状态、结束日期和项目名称。


系统要求

若要将“Sitespring”面板用于 Dreamweaver，您的系统或服务器上必须安装有 Dreamweaver MX 和 Sitespring。如果没有 Sitespring，则您可以从 Macromedia Sitespring Web 站点下载免费的试用版。Sitespring 只与具有支持 Flash 功能的新浏览器（如 Netscape Communicator 4.06 或更高版本和 Microsoft Internet Explorer 5 或更高版本）兼容。


连接到 Sitespring 服务器

若要使用“Sitespring”面板，您必须首先连接并登录到 Sitespring 服务器。

备注： 有关使用 Macromedia Sitespring 的更多信息，请参考 Sitespring 文档。

若要从 Dreamweaver 连接到 Sitespring 服务器，请执行以下操作：
  1. 在文档窗口中，选择“窗口”>“其他”>“Sitespring”或按 F7 键。

    2. 出现“Sitespring Log In”。
    这是所描述的功能的图片。

  2. 在“Sitespring server”文本框中，输入您将连接到的 Sitespring 服务器的 URL。如果不确定此 URL 具体是什么，请与您的系统管理员联系。
  3. 在“Username”和“Password”文本框中，输入您的 Sitespring 服务器用户名和密码。“Username”文本框是区分大小写的。
  4. 如果要在计算机上保存密码，请选择“Save password and log in automatically”选项。

    5. 备注： 此选项只用于在无需输入登录信息的情况下关闭和重新打开“Sitespring”面板。如果通过 Dreamweaver 或通过应用程序本身完全注销 Sitespring，则需要重新输入该信息。

  5. 单击“Log In”连接到 Sitespring 服务器。

    6. 连接状态出现在“Sitespring 服务器”文本框的上方。“Sitespring”面板在进行连接时显示当前任务。

如果在连接到 Sitespring 时遇到困难，请与系统管理员联系。


使用“Sitespring”面板

您可以使用“Sitespring”面板查看所有任务或只查看那些与特定项目关联的任务。您可以编辑某个任务并刷新任务列表以查看所进行的更改。“Tasks”文本框显示任务、优先级、状态、结束日期和项目名称。

若要使用“Sitespring”面板，请执行以下操作：
  1. 在文档窗口中，选择“窗口”>“其他”>“Sitespring”或按 F7 键。
  2. 如果您尚未登录到 Sitespring 服务器，请进行登录（请参见连接到 Sitespring 服务器）。

    3. “Sitespring”面板显示当前任务。该面板由显示当前打开任务的“Tasks”文本框以及用于执行某些动作的菜单和图标组成。任务按任务名称进行排序。单击列标题可以按该列进行排序。“Sitespring”面板不显示具有“已挂起”或“已完成”状态的任务。
    这是所描述的功能的图片。

  3. 从以下选项中选择：
    • 从“Project”弹出式菜单中选择特定项目以便只显示与特定项目关联的任务，或者选择“Show all my tasks”以显示所有当前任务。
    • 单击“Refresh”图标刷新“Sitespring” 面板并查看对此任务进行的所有更改。

      • 备注： 在更改出现在面板中之前，您必须先在 Sitespring 中保存更改。

    • 在“Name”列中选择一个任务，然后单击“ Edit Task”按钮编辑该任务。

      • 若要编辑任务，您还必须通过“Please Log In”Web 页登录到 Sitespring。如果已经登录，则将出现与该任务关联的“ Edit Task”页。如果尚未登录，则将出现“Please Log In”Web 页。

    • 单击 Sitespring 图标直接转到 Sitespring Web 页。

      • 如果已经登录，则将出现您的 Sitespring 主页。如果尚未登录，则将出现“Please Log In”页。

    • 按 F7 键关闭“Sitespring”面板，或者单击面板的“Close”框关闭“Sitespring”面板。

      • 备注： 您最好关闭“Sitespring”面板而不要完全注销，这样就不必每次都进行登录了。

    • 单击“Log Out”链接以注销 Sitespring 或切换用户。

出现“Sitespring Log In”。您可以输入新用户名和密码以切换用户，或者关闭对话框断开连接（请参见在 Dreamweaver 中注销 Sitespring）。


在 Dreamweaver 中注销 Sitespring

当在“Sitespring”面板上单击“Log Out”链接时，您也在 Dreamweaver 中注销了 Sitespring。

若要注销 Sitespring，请执行以下操作：
  1. 在“Sitespring”面板中，单击“Log Out”链接。

    2. 出现“Sitespring Log In”。
    这是所描述的功能的图片。

  2. 关闭该对话框。

下次访问“Sitespring”面板时，您不必在连接时重新输入 URL（除非要访问其他 Sitespring 服务器），但是必须输入您的密码。


参考资料

本节提供在本章中介绍的几个对话框的有关信息。


设置“站点”面板参数选项

此对话框用于为“站点”面板设置用户参数选择。

过程
  1. 根据需要更改以下选项：

    2. “总是显示”指定始终显示哪个站点（远程或本地），以及本地或远程文件显示在哪个“站点”面板窗格中（左窗格或右窗格）。

    默认情况下，本地站点始终显示在右侧。未被选择的那个窗格（默认情况下是左窗格）是可更改窗格：此窗格可以显示另一个站点（默认情况下是远程站点）的站点地图或文件。

    “相关文件”为浏览器加载 HTML 文件时传输它加载的相关文件（例如图像、外部样式表和在 HTML 文件中引用的其他文件）显示提示。默认情况下选择“获取/取出时提示”和“放置/存回时提示”。

    提示： 若要强制显示“包括相关文件”提示（即使已取消对这些选项的选择），请在选择“获取”、“上传”、“存回”或“取出”命令的同时按住 Alt 键 (Windows) 或 Option 键 (Macintosh)。

    “FTP 连接”确定在没有任何活动的时间超出指定分钟数后，是否终止与远程站点的连接。

    “FTP 作业超时”指定 Dreamweaver 尝试与远程服务器进行连接所用的秒数。

    如果在指定时间长度之后没有响应，则 Dreamweaver 显示一个警告对话框，提示您注意这一情况。

    “FTP 传输选项”确定在文件传输过程中显示对话框时，如果经过指定的秒数用户没有响应，Dreamweaver 是否选择默认选项。

    “防火墙主机”指定您在防火墙后面时与外部服务器连接所使用的代理服务器的地址。

    如果您不在防火墙后，则此项留空不填。如果您位于防火墙后，则在“站点定义”对话框中选择“使用防火墙”选项。请参见设置远程文件夹。

    “防火墙端口”指定通过防火墙中的哪个端口与远程服务器相连。如果您不使用端口 21（FTP 的默认端口）进行连接，则需要在此处输入端口号。

    “上载选项：上载前先保存文件”指示在将文件上载到远程站点前自动保存未保存的文件。

    “编辑站点”启动“编辑站点”对话框，您可以在此对话框中编辑现有的站点或创建新站点。

  2. 单击“确定”。

相关主题

设置“站点”参数


设置“文件视图列”类别选项

此对话框用于在“站点”面板中对文件视图列进行更改。您可以更改列的顺序、添加新列或删除列。

若要更改列的顺序，请执行以下操作：

选择列名称，然后单击上箭头按钮或下箭头按钮更改选定列的位置。

备注： 您可以更改除“名称”列之外任何列的顺序。“名称”列始终是第一列。

若要添加新列，请执行以下操作：
  1. 单击加号 (+) 按钮。
  2. 在“列名称”文本框中，输入列的名称。
  3. 从“与设计备注关联”弹出式菜单中选择一个值，或者键入您自己的值。

    4. 必须将一个新列与设计备注关联，“站点”面板中才会有数据显示。

  4. 选择对齐选项以确定 Dreamweaver 在该列中对齐文本的方式。
  5. 选择或取消选择“显示”选项以显示或隐藏列。
  6. 选择“与该站点所有用户共享”选项与连接到该远程站点的所有用户共享该列。
若要删除添加的列，请执行以下操作：

选择要删除的列，然后单击减号 (-) 按钮。

备注： 该列将立即被删除，且不经确认，因此在单击减号 (-) 按钮前，请务必弄清确实要删除该列。

相关主题

更改文件视图列


设置“站点地图布局”类别选项

此对话框用于自定义站点地图的外观。

过程
  1. 在“主页”文本框中，输入指向站点主页的文件路径或单击文件夹图标浏览到该文件。

    2. 主页必须位于本地站点上。如果未指定主页，或者如果 Dreamweaver 在根目录下未能找到名为 index.html 或 index.htm 的文件，则当打开站点地图时，Dreamweaver 会提示您选择主页。

  2. 从“列”选项中选择：
    • 在“列数”文本框中，键入一个数字以设置在站点地图窗口中每行要显示的页数。
    • 在“列宽”文本框中，键入一个数字以设置站点地图列的宽度（以像素为单位）。
  3. 在“图标标签”下，选择在站点地图中与文档图标一起显示的名称表示为文件名还是页标题。
  4. 在“选项”下，选择要在站点地图中显示的文件：
    • 选择“显示标记为隐藏的文件”在站点地图中显示您已标记为隐藏的 HTML 文件。

      • 如果隐藏了某页，则其名称和链接以斜体显示。有关隐藏文件的更多信息，请参见显示和隐藏站点地图文件。

    • 选择“显示相关文件”显示该站点层次结构中的所有相关文件。

      • 相关文件是在浏览器加载主页时加载的图像或其他非 HTML 内容。

相关主题

修改站点地图布局


设置“存回/取出”选项

“存回/取出”部分用于设置文件“存回/取出”选项。

过程
  1. 如果您在小组环境中工作（或独自工作但使用几台不同的计算机），则选择“启用文件存回和取出”选项。

    2. 该选项有助于让其他人知道您已取出文件进行编辑，或者提醒您自己可能将文件的最新版本留在了另一台计算机上。

    备注： 如果您的远程访问选项是“本地/网络”、“SourceSafe 数据库”或“WebDAV”，则“启用文件存回和取出”选项是唯一的“存回/取出”选项。此部分中的其余选项只适用于 FTP 访问。

  2. 如果要在“站点”面板中双击打开文件时自动取出这些文件，则选择“打开时取出文件”选项。

    3. 备注： 即使选择了该选项，使用“文件”>“打开”这种方法打开文件也不会取出该文件。

  3. 输入取出名称。

    4. 取出名称显示在“站点”面板中已取出文件的旁边；这使小组成员在他们需要的文件已被取出时可以和相关的人员联系。

    如果您在几台不同的计算机上独自工作，请在每台计算机上使用不同的取出名称（如 AmyR-HomeMac 和 AmyR-OfficePC），这样一来，当您忘记存回文件时，就可以知道文件最新版本的位置。

  4. 输入电子邮件地址。

    5. 如果您输入了电子邮件地址，然后取出某个文件，则在“站点”面板中您的名称以链接（蓝色并带下划线）的形式显示在该文件旁边。如果某个小组成员单击该链接，则其默认的电子邮件程序将打开一个新邮件，使用该用户的电子邮件地址以及与该文件和站点名称对应的主题。

相关主题

设置存回/取出系统


设置“同步文件”对话框选项

此对话框用于设置同步文件的选项。

过程
  1. 在“同步”弹出式菜单中，选择以下选项之一：
    • 若要同步整个站点，则选择“整个‘站点名称’站点”。
    • 若要只同步选定的文件，则选择“仅限选定的本地文件”（如果您最近一次的选择是在“站点”面板的“远程”视图中进行的，则选择“仅限选定的远程文件”）。
  2. 选择拷贝文件的方向：
    • 选择“将更新文件放置到远程”选项上传修改日期新于其远程副本的所有本地文件。
    • 选择“从远程获取更新文件”下载修改日期新于其本地副本的所有远程文件。
    • 选择“获取和放置更新文件”将所有文件的最新版本放置在本地和远程站点上。
  3. 选择是否在目的地站点上删除在原始站点上没有副本的文件。（如果您在方向文本框中选择了“获取和放置”，则该选项不可用。）

    4. 如果选择“将更新文件放置到远程”并选择“删除”选项，则 Dreamweaver 将删除远程站点中没有相应本地文件的所有文件。如果选择“从远程获取更新文件”，则 Dreamweaver 将删除本地站点中没有相应远程文件的所有文件。

  4. 单击“预览”。

    5. 如果每个选定文件的最新版本都已位于本地和远程站点并且不需要删除任何文件，则将显示一个警告，通知您不需要进行任何同步。

  5. 在“同步文件”预览中，确认您要删除、放置和获取的文件。

    6. 如果您不希望 Dreamweaver 删除、放置或获取某个特定的文件，则可通过单击该文件左侧的复选框（位于“动作”列中），取消对该文件的选择。

  6. 单击“确定”。

    7. Dreamweaver 将自动进行传输（并根据需要进行删除），然后用该状态更新对话框。

  7. 若要将验证信息保存到本地文件，请单击“保存日志”。

相关主题

同步本地和远程站点上的文件


设置“设计备注”类别选项

此对话框用于启用或禁用站点的设计备注。

若要启用设计备注，请执行以下操作：
  1. 选择“维护设计备注”。
  2. 选择“上传并共享设计备注”将与站点关联的设计备注与其余的文档一起上传。

    3. 如果选择该选项，则您可以和小组的其余成员共享设计备注。在您放置或获取某个文件时，Dreamweaver 自动放置或获取关联的设计备注文件。

    如果未选择此选项，则 Dreamweaver 在本地维护设计备注，但不将这些备注与您的文件一起上传。如果您独自在站点上工作，则可以取消对该选项的选择来提供文件传输的性能。

  3. 单击“确定”。
若要禁用设计备注，请执行以下操作：
  1. 取消对“维护设计备注”的选择。
  2. 单击“清理”，如果要 Dreamweaver 删除站点的所有本地设计备注文件，则单击“是”。
  3. 单击“确定”。

    4. 出现一个对话框，询问您是否要删除现有的设计备注文件。

  4. 单击“是”将删除设计备注文件，或单击“否”将这些备注文件保留在原处。
  5. 单击“确定”关闭“站点定义”对话框。
若要仅在本地使用设计备注，请执行以下操作：

取消对“上传并共享”的选择。

当您存回/放置文件时，不会将设计备注传输到远程站点。您将仍能够从本地为站点添加和修改设计备注。

相关主题

使用设计备注

在设计备注中保存文件信息


设置“设计备注”对话框选项

此对话框用于向文件添加设计备注。

过程
  1. 在“基本信息”标签中，从“状态”弹出式菜单中选择文档的状态。
  2. 单击日期图标（在“备注”文本框的上方）在您的备注中插入当前本地日期。
  3. 在“备注”文本框中键入注释。
  4. 选择“文件打开时显示”在每次打开文件时显示设计备注文件。
  5. 在“所有信息”标签中，单击加号 (+) 按钮添加新的键/值对；选择一个键/值对并单击减号 () 按钮可以将其删除。

    6. 例如，您可以将一个键命名为 Author（在“名称”文本框中）并将值定义为 Heidi（在“值”文本框中）。

  6. 单击“确定”。

相关主题

使用设计备注

在设计备注中保存文件信息


设置“遮盖”类别选项

此对话框用于启用或禁用遮盖以及遮盖特定的文件类型。

过程
  1. 选择或取消选择“启用遮盖”复选框以启用或禁用遮盖。
  2. 选择或取消选择“遮盖以如下内容结束的文件”复选框以启用或禁用对特定文件类型的遮盖。
  3. 在文本框中输入或删除要遮盖或取消遮盖的文件的后缀。
  4. 单击“确定”。

相关主题

启用和禁用站点遮盖

遮盖特定文件类型和取消特定文件类型的遮盖

上一页


设置文档

Macromedia Dreamweaver MX 为使用各种网页设计和开发文档提供了灵活的环境。除了 HTML 文档外，还可以创建和打开 CFML、ASP、JavaScript、CSS 或基于文本的文档。

“新建文档”对话框提供了几种可以用来创建新文档的文档类型。从这个易于使用的界面，可以创建新的空白文档或模板，基于现有模板之一的文档，或者基于 Dreamweaver 自带的设计好的页面布局之一的文档或模板。使用这些设计好的基本页面布局和模板，可以快速开始开发具有专业外观的网页。

“新建文档”对话框中还有其它文档选项可用。可以选择基于文本的文档（如 JavaScript 或层叠样式表 (CSS) 文档）和动态页面文档（如 Macromedia ColdFusion、Microsoft Active Server Page (ASP) 和 PHP 页面）。如果经常使用某种文档类型，可以将其设置为创建的新页面的默认文档类型。

在 Dreamweaver 中，可以在“设计”视图或“代码”视图中轻松定义文档属性，如 meta 标签、文档标题、背景颜色和其他几种页面属性。

本章包括以下主题：

  • 使用“新建文档”对话框
  • 打开现有文档
  • 设置文档属性
  • 选择“文档”窗口中的元素
  • 在设计过程中使用可视化向导
  • 关于任务自动化
  • 参考资料
下一页


创建 Dreamweaver 文档

“新建文档”对话框显示了几种可以用来创建新页面的文档类型。当您选择“文件”>“新建”时，Dreamweaver 会打开“新建文档”对话框。如果您主要使用一种文档类型，例如 HTML 页面、ColdFusion 页面或 Active Server Pages，您可能希望设置默认文档类型。通过设置默认文档类型，当创建新文档时，不用打开“新建文档”对话框就能打开首选文档类型的新文档。

相关主题

创建新的空白文档

打开现有文档

创建基于现存模板的文档

创建基于 Dreamweaver 设计文件的文档


使用“新建文档”对话框

“新建文档”对话框为您提供了几种选择新的工作文档的选项。可以用下列方法创建新文档：

  • 可以从空白文档开始。
  • 可以使用定义文档外观的模板，并设置文档哪些部分可以编辑。
打开“新建文档”对话框：
  • 选择“文件”>“新建”。

“新建文档”对话框中包含两个选项卡：“常规”和“模板”。

常规选项卡包含各种可以用来创建新空白页的文档类型。可以从“基本页”、“动态页”和“框架集”类别中选择新的空白文档。通过在“其他”类别中选择文档，创建基于特殊文件类型（例如 CSS、JavaScript、VBScript 或文本文件）的页面。“模板”类别提供多种可供选择的文档类型，您可以根据这些类型创建空模板、HTML 模板以及可以在其中插入服务器行为的模板。

“CSS 样式表”、“页面设计”和“页面设计（有辅助功能的）”类别为您提供了预置的设计文件，您可以使用它们创建自己的页面。如果选择了“CSS 样式表”类别，您可以拷贝预先设计的样式表，然后将其应用于您的文档。

根据所选文档的类型，对话框中会出现其他选项。例如，如果选择 HTML 文档，则有使文档成为 XHTML 兼容的选项；如果选择页面设计文件，则有创建文档或创建模板的选项。

模板选项卡包含您定义的 Dreamweaver 站点的列表。可以从列出的任何站点中选择一个模板，创建基于该模板的新文档。

选择一个类别，在它右边的“文档”列表中查看可用文档类型的列表。单击列表中的文档可以提供说明，对于“页面设计”、“CSS 样式表”和“框架集”类别文档的情况，则提供所选文档的预览。

可以使用位于“新建文档”对话框底部的“参数选择”选项设置默认文档参数选择，如文档类型、编码和文件扩展名。另外还可以设置选项，自动打开新文档而不使用“新建文档”对话框。有关设置文档参数选择的信息，请参见设置“新建文档”参数。

使用“新建文档”对话框中的“获取更多内容”链接转到“Dreamweaver MX 交流中心”下载更多页面设计内容。


创建新的空白文档

可以使用“新建文档”对话框选择要创建的文档类型。

如果经常使用某种特定的文档类型，可以设置默认文档并自动打开基于已定义的默认文档的新文档。有关信息，请参见设置“新建文档”参数。

创建新的空白文档：
  1. 在 Dreamweaver 中，选择“文件”>“新建”。

    2. 出现“新建文档”对话框。“常规”选项卡已被选定。

  2. 在“类别”列表中，选择要创建的文档类别。

    3. 例如，选择“基本页”创建 HTML 文档，或选择“动态页”创建 ColdFusion 或 ASP 文档，诸如此类。

  3. 在文档列表中，选择要创建的页面类型，然后执行下列操作之一：
    • 单击“创建”。
    • 在文档列表中的项目上双击。
    • 按 Enter 键。

      • 对话框关闭，新文档出现在“文档”窗口中。


创建基于 Dreamweaver 设计文件的文档

Dreamweaver 附带了几种以专业水准开发的页面布局和设计元素文件。可以将这些设计文件 作为设计站点页面的起点。

设计文件包括遵守辅助功能标准的文档和模板、基于表格的页面布局文档和 CSS 样式表。对于“CSS 样式表”、“框架集”、“页面设计”和“页面设计（有辅助功能的 ）”类别中的项目，可以预览文档并阅读关于文档设计元素的简要说明。

当您创建基于设计文件的文档时，Dreamweaver 会创建文件的拷贝。如果设计文件包含到资源文件（如图形、Flash 元素或外部 CSS 样式表）的链接，当您保存文档时，Dreamweaver 会提示您保存相关文件的拷贝。可以为相关文件选择您自己的位置或使用 Dreamweaver 生成的默认文件夹位置（基于设计文件的源名称）。

也可以创建基于设计文件的新模板。模板中已定义了可编辑区域。可以在模板中创建新的可编辑区域。系统将提示您将文件保存为当前站点的模板。链接的文件也将拷贝到站点。

备注： 如果创建基于预定义框架页的文档，则仅拷贝框架页结构，而不拷贝框架内容。另外，需要分别保存每个框架文件。有关保存框架的信息，请参见保存框架和框架集文件。

创建层叠样式表：
  1. 打开“新建文档”对话框，选择“文件”>“新建”。
  2. 在“类别”列表中，选择“CSS 样式表”。

    3. 右边的文档列表用 CSS 样式表的选定内容更新。

  3. 在文档列表中，选择样式表预览其属性和说明，然后执行下列操作之一：
    • 单击“创建”。
    • 在文档列表中的项目上双击。
    • 按 Enter 键。

      • 对话框关闭，“文档”窗口中出现一个新的 CSS 文档。CSS 样式表在“代码”视图中打开。

  4. 选择“文件”>“另存为”。
  5. 在“另存为”对话框中，浏览到要保存文件的位置，输入文档的唯一文件名，单击“保存”。
创建页面设计文档：
  1. 打开“新建文档”对话框，选择“文件”>“新建”。
  2. 在“类别”列表中，根据设计要求选择“页面设计”或“页面设计（有辅助功能的）”。
  3. 在“页面设计”列表中选择希望新页面基于的文档。
  4. 执行下列操作之一：
    • 若要创建新文档，请选择“文档”单选按钮。
    • 若要创建新模板，请选择“模板”单选按钮。
  5. 单击“创建”。

    6. 新文档出现在“文档”窗口中。如果是创建模板，您会看到已定义了可编辑区域，系统会提示您将文档保存为当前站点的模板。

  6. 选择“文件”>“保存”保存文档。

    7. 如果文件包含到资源文件的链接，会出现“拷贝相关文件”对话框。

  7. 在“拷贝相关文件”对话框中，设置将资源拷贝到当前站点的选项。
  8. 单击“拷贝”将资源拷贝到所选文件夹并关闭对话框。


创建基于现存模板的文档

可以用“新建文档”对话框从现有模板中选择、预览和创建新文档。可以从 Dreamweaver 定义的任何站点中选择模板。

使用“新建文档”对话框“页面设计”类别中的文档也可以创建模板。将页面设计文档保存为站点中的模板后，就可以创建基于该模板的页面了。有关信息，请参见创建基于 Dreamweaver 设计文件的文档。

有关使用模板和基于模板的文档的更多信息，请参见关于 Dreamweaver 模板。

创建基于模板的新文档：
  1. 选择“文件”>“新建”打开“新建文档”对话框。
  2. 在“模板”选项卡中，在“模板用于”列表中，选择包含要使用的模板的 Dreamweaver 站点。
  3. “站点”列表中显示出所选站点中的模板（如果有模板）。
  4. 选择要使用的模板。
  5. 如果要将新文档同模板分离，取消选择“当模板改变时更新页面”选项。
  6. 单击“创建”。

    7. 随即创建一个新文档。

  7. 保存文档。


保存文档

保存文档时，不要在文件名和文件夹名中使用空格和特殊符号。具体说来就是不要在打算放到远端服务器上的文件名中使用特殊符号（如 é、ç 或 ¥）或标点符号（如冒号、破折号或句号）。很多服务器在上传文件时会更改这些符号，这会导致与这些文件的链接中断。而且，文件名不要以数字开头。

保存文档：
  1. 选择“文件”>“保存”。
  2. 在出现的对话框中，定位到要用来保存文件的文件夹。
  3. 在“文件名”文本域中，键入文件名。
  4. 单击“保存”保存文件。


打开现有文档

在 Dreamweaver 中，可打开现有 HTML 文档或任何动态文档类型，即使没有在 Dreamweaver 中创建该类型。可打开文档并利用“设计”视图或“代码”视图的创作功能，用 Dreamweaver 编辑文档。

也可以打开非 HTML 文本文件，如 JavaScript 文件、XML 文件、CSS 样式表或用字处理程序或文本编辑器保存的文本文件。

某些文件仅在“代码”视图中打开并允许在文件中编辑代码，如 CSS 文档。可以在 Dreamweaver 中工作时更新文档，然后保存文件中的更改。

如果要打开的文档是保存为 HTML 的 Microsoft Word 97、Word 98 或 Word 2000 文件，可能需要将文档导入 Dreamweaver 中而不是将其打开。导入 Word HTML 文件时，Dreamweaver 会提醒您清除 Word 插入到 HTML 文件中的无关标记标签。可以用“清理 Word 的 HTML”命令设置页面背景颜色并清理导入文件中的 CSS 样式表格式。

若要打开现有文件，请执行下列操作之一：
  1. 在 Dreamweaver 中，选择“文件”>“打开”。
  2. 在打开的对话框中，定位到并选择要打开的文件。
  3. 单击“打开”。

    4. 文档随即在“文档”窗口中打开。

    备注： 默认情况下，JavaScript、文本和 CSS 样式表在“代码”视图中打开。有关更改设置用于查看这些文件类型的外部文本编辑器的信息，请参见为媒体文件启动外部编辑器。

打开和导入 Microsoft Word HTML 文件：
  1. 在 Dreamweaver 中，选择“文件”>“导入”>“Word HTML”。

    2. “选择要导入的 Word HTML 文件”对话框打开。

  2. 在对话框中，定位到并选择要打开的文档。
  3. 单击“打开”。

    4. Dreamweaver 在新窗口中打开文档，“清理 Word 的 HTML”对话框打开。

  4. 选择“基本”或“详细”选项卡中的选项，选择要应用于文档的清理选项。

    5. 有关清理选项的更多信息，请参阅清理 Microsoft Word HTML。

  5. 单击“确定”。

Dreamweaver 将清理设置应用于新文档，并且出现一个更改记录。

  1. 保存文档。


设置文档属性

页面标题、背景图像和颜色、文本和链接颜色以及边距是每个 HTML 文档的基本属性。页面标题标识和命名文档。背景图像或背景颜色设置文档的总体外观。文本和链接颜色帮助访问者区分常规文本和超级文本，并了解哪些链接已被访问过，哪些没有。

有关完成“页面属性”对话框的信息，请参阅选择“页面属性”选项。


更改文档标题

HTML 页面的标题帮助站点访问者在浏览时跟踪所查看的内容，并在访问者的历史记录和书签列表中标识页面。如果不给页面加标题，页面会在浏览器窗口、书签列表和历史记录列表中显示为无标题文档。请注意，给文档起一个文件名（通过保存）不同于给页面加标题。若要定位站点中的所有无标题文档，请使用“站点”>“报告”命令。请参见使用“报告”测试站点。

更改页面标题：
  1. 文档打开时，执行下列操作之一：
    • 选择“修改”>“页面属性”。
    • 选择“查看”>“工具栏”（如果还没有选中它）。
    • 在文档中的空白区域右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“页面属性”。
  2. 在“标题”文本框中，输入页面标题，然后按 Enter 键或 Return 键。
  3. 如果是在“页面属性”对话框中编辑标题，单击“确定”。

    4. 标题出现在“文档”窗口的标题栏中（如果显示，也会出现在工具栏中）。页面的文件名和保存文件的文件夹出现在标题栏中标题旁边的括号中。星号表示文档包含尚未保存的更改。


设置背景图像或背景页面颜色

若要定义页面背景的图像或颜色，请使用“页面属性”对话框。如果同时使用背景图像和背景颜色，下载图像时会出现颜色，然后图像覆盖颜色。如果背景图像包含任何透明像素，则背景颜色透过背景图像显示出来。

定义背景图像或颜色：
  1. 选择“修改”>“页面属性”，或从“文档”窗口“设计”视图中的上下文菜单中选择“页面属性”。
  2. 若要设置背景图像，请单击“浏览”按钮，然后浏览并选择图像。或者，可以在“背景图像”对话框中输入背景图像的路径。

    3. 如果背景图像没有填满整个窗口，Dreamweaver 会平铺（重复）背景图像，就象浏览器所做的那样。若要防止背景图像平铺，请使用 CSS 样式表禁用图像平铺。 请参阅第 612页的“定义 CSS 样式背景属性”。

  3. 若要设置背景颜色，请单击“背景”颜色框并从颜色选择器中选择颜色。


使用颜色

在 Dreamweaver 中，很多对话框与许多页面元素的属性检查器一样，都包含可打开颜色选择器的颜色框。使用颜色选择器选择页面元素的颜色。

在 Dreamweaver 中选择颜色：
  1. 在任何对话框或属性检查器中单击颜色框。

    2. 出现颜色选择器。
    这是所描述的功能的图片。

  2. 执行下列操作之一：
    • 用滴管从调色板中选择颜色样本。“立方色”（默认）和“连续色调”调色板中的所有颜色都是网页安全色，其他调色板中的则不是。（有关更多信息，请参见关于网页安全色。）
    • 用滴管从屏幕上的任何位置位置取色 - 甚至从 Dreamweaver 窗口外（如果您单击桌面或其他应用程序，Dreamweaver 会在您单击的位置取色，但您也可以切换到另一个应用程序。这种情况下，单击 Dreamweaver 窗口继续在 Dreamweaver 中工作，或者在从 Dreamweaver 移到桌面上时按住鼠标按钮，以免切换出 Dreamweaver。）
    • 若要展开颜色选项，请使用颜色选择器右上角的弹出菜单。可以选择“立方色”、“连续色调”、“Windows 系统”、“Mac 系统”、“灰度级”和“调整到网页安全色”。

      • 请注意“立方色”和“连续色调”调色板是网页安全的，而“Windows 系统”、“Mac 系统”和“灰度级”不是。如果使用的调色板不是网页安全的，然后选择“调整到网页安全色”，则 Dreamweaver 会用最接近的网页安全色替换所选颜色。换句话说，您得到的可能并不是所看见的颜色。

    • 若要清除当前颜色但不选择另一种颜色，请单击“删除线”按钮。
    • 若要打开系统颜色拾取器，请单击“调色盘”按钮。有关更多信息，请参见关于网页安全色。


关于网页安全色

在 HTML 中，颜色或者表示成十六进制值（如 #FF0000）或者表示为颜色名称（红色）。网页安全色是指以 256 色模式运行时，无论在 Windows 还是在 Macintosh 系统中，在 Netscape Navigator 和 Microsoft Internet Explorer 中的显示相同的颜色。传统经验是，有 216 种常见颜色，而且任何结合了 00、33、66、99、CC 或 FF 对（RGB 值分别为 0、51、102、153、204 和 255）的十六进制值都代表网页安全色。

但测试显示仅有 212 种网页安全色而不是全部 216 种，原因在于 Windows Internet Explorer 不能正确呈现颜色 #0033FF (0,51,255)、#3300FF (51,0,255)、#00FF33 (0,255,51) 和 #33FF00 (51,255,0)。

Dreamweaver 中的“立方色”（默认）和“连续色调”调色板使用 216 色网页安全调色板，从这些调色板中选择颜色会显示颜色的十六进制值。

若要选择网页安全范围外的颜色，请单击 Dreamweaver 颜色选择器右上角的“调色盘”按钮打开系统颜色拾取器。系统颜色拾取器不限于网页安全色。

Netscape Navigator 的 UNIX 版本使用与 Windows 和 Macintosh 版本不同的调色板。如果专门为 UNIX 浏览器开发（或者目标用户是使用 24 位显示器的 Windows 或 Macintosh 用户或使用 8 位显示器的 UNIX 用户），请考虑使用结合了 00、40、80、BF 或 FF 对的十六进制值，这些值产生用于 Sun 系统的网页安全色。


定义默认文本颜色

为“页面属性”对话框中的常规文本、链接、访问过的链接和活动链接定义默认颜色，或者选择预设配色方案定义页面背景和文本颜色。（请参见使用颜色。）

备注： 活动链接颜色是单击链接时链接变成的颜色。有些 Web 浏览器可能不使用指定的颜色。

若要定义默认文本颜色，请执行下列操作之一：
  • 选择“修改”>“页面属性”，然后为“文本”、“链接”、“访问过的链接”和“活动链接”选项选择颜色。
  • 选择“命令”>“设定配色方案”，然后选择背景颜色以及为文本和链接设置的颜色。

    • 示例对话框显示颜色方案在浏览器中的外观。


选择“文档”窗口中的元素

若要在“文档”窗口的“设计”视图中选择元素，通常可以单击元素。如果元素不可见，必须使其可见后才能选择它。

若要选择元素，请使用下列方法：
  • 若要选择“文档”窗口中的可见元素，请单击元素或在元素上拖过。
  • 若要选择不可见元素，请选择“查看”>“可视化助理”>“不可见元素”（如果还没有选择该菜单项），然后在“文档”窗口中单击元素的标记。

    • 有些对象出现在页面上的位置并不是其代码插入的位置。例如，层可以出现在页面上的任何地方，但定义该层的代码在固定的位置。当不可见元素显示时，Dreamweaver 在“文档”窗口中显示标记以指示这类元素的代码的位置。选择标记时将选择整个元素，例如，选择层的标记将选择整个层。（请参见关于不可见元素。）

  • 若要选择完整的标签（包括其内容，如果有内容），请单击“文档”窗口左下角的标签选择器中的标签。（标签选择器在“设计”视图和“代码”视图中都出现。）标签选择器总是显示包含当前选择或插入点的标签。最左边的标签是包含当前选择或插入点的最外边的标签。下一个标签包含在那个最外边的标签中，依此类推；最右边的标签是包含当前选择或插入点的最里边的标签。

    • 在下面的例子中，插入点是段落标签 <p>。若要选择存在段落标签的表格，请选择 <p> 标签左边的 <table> 标签。
    这是所描述的功能的图片。

若要查看与所选文本或对象关联的 HTML 代码，请执行下列操作之一：
  • 在“文档”工具栏中，单击“显示代码视图”按钮。
  • 选择“查看”>“代码”。
  • 在“文档”工具栏中，单击“显示代码视图和设计视图”按钮。
  • 选择“查看”>“代码和设计”。
  • 选择“窗口”>“其它”>“代码检查器”。

有关“代码”视图的更多信息，请参见查看您的代码。

在两个代码编辑器（“代码”视图或代码检查器）中的任何一个中选择对象后，该对象通常也在“文档”窗口中被选中。在选定内容出现前，可能需要同步两个视图。请参见查看您的代码。


关于不可见元素

有些 HTML 代码在浏览器中没有可见的表示形式。例如，comment 标签不在浏览器中出现。但是，此标签在创建可选择、编辑、移动和删除这类不可见元素的页面时很有用。Dreamweaver 允许您指定在“文档”窗口的“设计”视图中是否显示标记不可见元素位置的图标。

若要显示或隐藏不可见元素的标记图标，请选择“查看”>“可视化助理”>“不可见元素”。显示不可见元素使您可以选择这些元素并在属性检查器中更改其属性；隐藏它们使您可以查看接近其在浏览器中的显示形式的页面。请注意，显示不可见元素可能会稍微更改页面的布局，将其它元素移动几个像素。因此在精确布局中，请隐藏不可见元素。

若要指示选择“查看”>“可视化助理”>“不可见元素”时显示的元素标记，可以在“不可见元素”参数选择中设置选项。例如，可以指定命名锚记可见，而换行符不可见。请参阅第 388页的“设置“不可见元素”参数”。

可以使用“插入”栏“标准”类别中的按钮创建某些不可见元素（如注释和命名锚记）（请参见使用“插入”栏）。然后可以使用属性检查器修改这些元素。


在设计过程中使用可视化向导

Dreamweaver 提供了几种可视化向导，帮助您设计文档和（大概）估计文档在浏览器中的外观。可以执行下列所有操作：

  • 立即将“文档”窗口与所需的窗口大小对齐，查看元素如何适应页面。请参见调整“文档”窗口的大小。
  • 用标尺提供定位和调整层或表格大小的可见提示。请参见显示标尺。
  • 用跟踪图像作为页面背景，帮助您拷贝在图表或图像编辑应用程序（如 Macromedia Fireworks）中创建的设计。请参见使用跟踪图像。
  • 使用网格精确定位层和调整层大小。页面上的网格标记有帮于对齐层，启用对齐后，移动层或调整层大小时层自动与最近的网格点对齐。（其他对象，如图像和段落，不与网格对齐。）不论网格是否可见，对齐都有效。请参见将层靠齐到网格。


显示标尺

标尺可以显示在页面的左边框和上边框中，以像素、英寸或厘米为单位来标记。

若要更改标尺设置，请执行以下操作之一：
  • 若要在打开和关闭状态之间切换标尺，请选择“查看”>“标尺”> “显示”。
  • 若要更改原点，请将标尺原点图标拖动到页面的任意位置。（当标尺正在显示时，该图标出现在“文档”窗口“设计”视图的左上角。）若要将原点重设到它的默认位置，请选择“查看”>“标尺”>“重设原点”。
  • 若要更改度量单位，请从“查看”>“标尺”子菜单中选择“像素”、“英寸”或“厘米”。


使用跟踪图像

将跟踪图像用作向导，重新创建在图形应用程序中模拟的页面设计。跟踪图像是放在“文档”窗口背景中的 JPEG、GIF 或 PNG 图像。可以隐藏图像、设置图像的不透明度和更改图像的位置。

仅在 Dreamweaver 中跟踪图像是可见的。当在浏览器中查看页面时，跟踪图像永远不可见。当跟踪图像可见时，页面的实际背景图像和颜色在“文档”窗口中不可见；但是，在浏览器中查看页面时，背景图像和颜色是可见的。

将跟踪图像放在“文档”窗口中：
  1. 执行下列操作之一：
    • 选择“查看”>“跟踪图像”>“载入”。
    • 选择“修改”>“页面属性”，然后单击“跟踪图像”文本框旁边的“浏览”按钮。
  2. 在出现的对话框中，选择图像文件并单击“选择”(Windows) 或“选择”(Macintosh)。
  3. “页面属性”对话框随即出现。拖动“图像透明度”滑块指定图像的透明度，然后单击“确定”。

    4. 若要随时切换到另一跟踪图像或更改当前跟踪图像的透明度，请选择“修改”>“页面属性”。

显示或隐藏跟踪图像：

选择“查看”> “跟踪图像”>“显示”。

更改跟踪图像的位置：

选择“查看”>“跟踪图像”>“调整位置”。然后执行下列操作之一：

  • 若要准确地指定跟踪图像的位置，请在“X”和“Y”文本框中输入坐标值。
  • 若要逐个像素地移动图像，请使用箭头键。
  • 若要一次五个像素地移动图像，请按 Shift 键和箭头键。
重设跟踪图像的位置：

选择“查看”>“跟踪图像”>“重设位置”。跟踪图像随即返回到文档窗口的左上角 (0,0)。

将跟踪图像与所选元素对齐：
  1. 在“文档”窗口中选择一个元素。
  2. 选择“查看”>“跟踪图像”>“对齐所选范围”。

    3. 跟踪图像的左上角随即与所选元素的左上角对齐。


查看和编辑头内容

HTML 文件由两个主要部分组成：head 部分和 body 部分。body 是文档的主要部分，也是包含文本和图像等的可见部分。head 部分是除文档标题外的不可见部分，文档标题出现在浏览器和 Dreamweaver 中的窗口标题栏中。为创建的每一个页面指定一个标题。

head 部分还包含其他重要信息，包括文档类型、语言编码、JavaScript 和 VBScript 函数和变量、搜索引擎的关键字和内容指示器以及样式定义。不需要为每一个页面都提供所有这些元素。例如，可以仅为主页提供关键字和内容指示器。可以使用“查看”菜单、“文档”窗口的“代码”视图或代码检查器查看 head 部分中的元素。

在文档的文件头部分查看元素：

选择“查看”>“文件头内容”。对于 head 内容的每一个元素，“文档”窗口的“设计”视图顶部都有一个标记。

备注： 如果“文档”窗口被设置为仅显示“代码”视图，则“查看”>“文件头内容”无效。

将元素插入文档的文件头部分：
  1. 执行下列操作之一：
    • 在“插入”栏的“文件头”类别中，单击对象按钮之一。
    • 从“插入”>“文件头标签”子菜单中选择一项。
  2. 在出现的对话框中或在属性检查器中输入元素的选项。
在文档的文件头部分编辑元素：
  1. 选择“查看”>“文件头内容”。
  2. 单击 head 部分中的图标之一以选中它。
  3. 在属性检查器中设置或修改元素的属性。

有关特定 head 元素的属性信息，请参阅以下主题：

  • 设置 Meta 属性
  • 设置标题属性
  • 设置关键字属性
  • 设置说明属性
  • 设置刷新属性
  • 设置基本属性
  • 设置链接属性


关于任务自动化

创建文档时，可能需要多次执行同一任务。本节说明如何使用“历史记录”面板使重复任务自动执行。

若要一次或两次重复执行一系列步聚，请直接从“历史记录”面板中重放它们。“历史记录”面板在您使用文档时记录您的步骤。（有关“历史记录”面板的基本信息，请参见关于“历史记录”面板。）若要使经常执行的任务自动执行，可以创建一个新命令来自动执行该任务。

一些鼠标移动（如在“文档”窗口通过单击或拖动选择对象）不能重放或保存为已保存命令的一部分。当您进行这样的移动时，“历史记录”面板中会出现一条黑线（尽管直到您执行另一个动作时，这条线才变得明显）。若要避免不能重放的动作，请在“文档”窗口内使用箭头键而不是鼠标来移动插入点。若要进行选择或扩展选择，请按住 Shift 键并按箭头键。

备注： 在执行以后要重复执行的任务时，如果出现一条黑色的鼠标移动指示线，可以撤消原来的步骤并尝试使用另一种方法（多半是使用箭头键）。

还有其他一些步骤是不能重复执行的，如将页面元素拖动到页面上的其他位置。当您执行这样的步骤时，“历史记录”面板中会出现一个带有红色小 X 的菜单命令图标。

步聚的重放与它们最初执行时完全一样；在重放步骤时不能修改它们。例如，如果以前将某个表格单元格改成了红色，那么对另一表格单元格应用该步骤也会将它的颜色改为红色；将该步骤应用于新单元格时不能指定另外的颜色。


重复步骤

若要重复已执行的最后一步，请使用“编辑”>“重复”命令，或使用快捷键 Control+Y (Windows) 或 Command+Y (Macintosh)。此命令的名称在“编辑”菜单中更改，以反映所执行的最后一步。例如，如果刚键入了一些文本，则此命令的名称为“重复键入”。（在撤消或重做操作后，不能立即使用“重复”命令。）

若要重复最近步骤以外的其他步骤或一次重复多个步骤，请使用“历史记录”面板。（有关“历史记录”面板的基本信息，请参见关于“历史记录”面板。）

注意当重放步骤时，播放的是被选中的步骤（高亮显示），而不一定是滑块当前指示的步骤。

重复一个步骤：

在“历史记录”面板中，选择一个步骤然后单击“重放”按钮。该步骤随即重放，并且“历史记录”面板中出现它的一个拷贝。

重复一系列相邻的步骤：
  1. 执行下列操作之一在“历史记录”面板中选择步骤：
    • 从一个步骤拖动到另一步骤。（不要拖动滑块，只从一个步骤的文本标签拖动到另一个步骤的文本标签。）
    • 选择第一步，然后按住 Shift 键并单击最后一步；或选择最后一步，然后按住 Shift 键并单击第一步。

      • 备注： 虽然可以选择一系列包括黑色的鼠标移动指示线的步骤，但重放这些步骤时会跳过该鼠标移动。

  2. 单击“重放”。

    3. 步骤随即按顺序重放，并且“历史记录”面板中出现一个标记为“重放步骤”的新步骤。

重复不相邻的步骤：
  1. 选择一个步骤，然后按住 Control 键 (Windows) 或Command 键 (Macintosh) 并单击其他步骤。

    2. 也可以按住 Control 键或 Command 键并单击以取消选择所选步骤。

  2. 单击“重放”。

    3. 所选步骤随即按顺序重放，并且“历史记录”面板中出现一个标记为“重放步骤”的新步骤。


将步骤应用于另一个对象

可以将“历史记录”面板中的一系列步骤应用于“文档”窗口中的任何对象。

将“历史记录”面板步骤应用于新对象：
  1. 选择对象。
  2. 在“历史记录”面板中选择相关步骤，然后单击“重放”。


将步骤应用于多个对象

如果选择文档中的多个对象然后从“历史记录”面板中将步骤应用于这些对象，则它们被看成是单个选择，并且 Dreamweaver 尝试将步骤应用于这个组合选择。例如，不能选择五个图像并同时对它们中的每一个应用相同的大小改变。大小改变是一个必须应用于每个图像而不是应用于图像组合的操作。

若要将一系列步骤应用于一组对象中的每一个对象，必须使这些步骤中的最后一步选择对象组中的下一个对象。下列过程说明了此原则在具体情况下的应用：设置一系列图像的垂直和水平间距。

设置一系列图像的垂直和水平间距：
  1. 从一个文档开始，其中的每一行由一个后跟文本的小图像（如图形项目符号或图标）组成。目的是设置图像同文本以及它上方和下方的其他图像分开。
    这是所描述的功能的图片。
  2. 如果属性检查器尚未打开，请将其打开（“窗口”>“属性”）。
  3. 选择第一个图像。
  4. 在属性检查器中，在“垂直边距”和“水平边距”文本框中输入数字以设置图像的间距。
  5. 再次单击图像，使“文档”窗口激活但不移动插入点。
  6. 按左箭头键将插入点移到图像左侧。然后按下箭头键将插入点向下移动一行，使其正好位于系列中的第二个图像的左侧。然后按 Shift 和右箭头键选择第二个图像。

    7. 备注： 不要通过单击的方式选择图像，否则将无法重放所有这些步骤。

  7. 在“历史记录”面板中，选择对应于改变图像间距和选择下一个图像的步骤。单击“重放”按钮重放这些步骤。
    这是所描述的功能的图片。

    8. 当前图像的间距随即改变并选择下一个图像。
    这是所描述的功能的图片。

  8. 继续单击“重放”直到所有图像的间距正确为止。

若要将步骤应用于另一个文档中的对象，请使用“拷贝步骤”按钮。请参见在文档间拷贝和粘贴步骤。


在文档间拷贝和粘贴步骤

每一个打开的文档都有自己的步骤历史记录。可以拷贝一个文档中的步骤并将其粘贴到另一个文档中。

备注： “拷贝步骤”（“历史记录”面板中的一个按钮）与“拷贝”（“编辑”菜单中）是不同的。不能使用“编辑”>“拷贝”拷贝步骤，尽管确实可以使用“编辑”>“粘贴”粘贴它们。

关闭文档时将清除历史记录。如果您知道在文档关闭后要使用该文档中的步骤，在关闭文档前请用“拷贝步骤”拷贝这些步骤（或保存为命令；请参见用历史步骤创建新命令）。

拷贝包括“拷贝”或“粘贴”命令的步骤时要注意：

  • 如果步骤中有一个是“拷贝”命令，不要使用“拷贝步骤”命令；可能无法按所需的方式粘贴这些步骤。
  • 如果步骤中包括一个“粘贴”命令，则不能粘贴这些步骤，除非步骤中的“粘贴”命令前还有一个“拷贝”命令。

如果将步骤粘贴到文本编辑器或“代码”视图或代码检查器中，则它们以 JavaScript 代码的形式出现。这对于您学习编写自己的脚本很有用。有关如何在 Dreamweaver 中使用 JavaScript 的更多信息，请参见编写和编辑代码。

在另一个文档中重新使用一个文档中的步骤：
  1. 从包含要重新使用的步骤的文档开始。
  2. 在“历史记录”面板中选择步骤。
  3. 单击“历史记录”面板的“拷贝步骤”按钮拷贝这些步骤。
    这是所描述的功能的图片。
  4. 打开另一个文档。
  5. 将插入点放入所需位置，或选择一个应用步骤的对象。
  6. 选择“编辑”>“粘贴”粘贴步骤。

    7. 步骤在粘贴到文档的“历史记录”面板时重放。“历史记录”面板以一个名为“粘贴步骤”的步骤显示它们。


用历史步骤创建新命令

可以将一组历史步骤保存为一个命名命令，这个命令随后在“命令”菜单中变得可用。

如果以后有可能再次使用特定的步骤系列，尤其是在下次启动 Dreamweaver 时想再次使用那些步骤，请创建和保存新命令。保存的命令会永久保留（除非删除它们），而录制的命令（请参阅第 384页的“录制命令”）将在您退出 Dreamweaverare 时被丢弃，并且拷贝的步骤序列也将在您拷贝其他内容时被丢弃。

使用“命令”>“编辑命令列表”，可以编辑放入“命令”菜单中的命令名称，也可将它们从“命令”菜单中删除。编辑和删除“命令”菜单中内置的命令（即不是您明确添加的命令）更复杂。

创建命令：
  1. 在“历史记录”面板中选择一个步骤或一系列步骤。
  2. 单击“保存为命令”按钮，或从“历史记录”面板的上下文菜单中选择“另存为命令”。
  3. 输入命令的名称并单击“确定”。

    4. 该命令随即出现在“命令”菜单中。

    备注： 在 Dreamweaver/Configuration/Commands 文件夹中，命令保存为 JavaScript 文件（有时为 HTML 文件）。

使用保存的命令：
  1. 选择一个应用命令的对象，或将插入点放在所需的位置。
  2. 从“命令”菜单中选择命令。
在“命令”菜单中编辑命令的名称：
  1. 选择“命令”>“编辑命令列表”。
  2. 选择命令重命名并输入该命令的新名称。
  3. 单击“关闭”。
从“命令”菜单中删除名称：
  1. 选择“命令”>“编辑命令列表”。
  2. 选择命令。
  3. 单击“删除”，然后单击“关闭”。


录制命令

Dreamweaver 允许录制短期使用的临时命令。这种方法与从“历史记录”面板中重放步骤（请参见重复步骤）的主要区别如下：

  • 步骤在您执行它们时录制，所以您无需在重放它们之前在“历史记录”面板中选择它们。
  • 在录制过程中，Dreamweaver 禁止执行不可录制的鼠标移动（如单击选择窗口中的某个对象，或将页面元素拖动到新位置）。
  • 如果在录制时切换到另一个文档，Dreamweaver 不录制在另一个文档中所做的改动。若要随时确定是否在进行录制，请查看鼠标指针。

Dreamweaver 一次仅保留一个录制的命令；一旦开始录制新命令，旧命令就丢失。若要保存新命令但不丢失已录制的命令，请从“历史记录”面板中保存命令；请参阅第 383页的“用历史步骤创建新命令”。

录制了命令后，可以使用“历史记录”面板保存它。

暂时录制一系列经常使用的步骤：
  1. 选择“命令”>“开始录制”，或按 Control+Shift+X (Windows) 或 Command+Shift+X (Macintosh)。

    2. 指针改变，指示您正在录制命令。

  2. 完成录制后，选择“命令”>“停止录制”，或按Control+Shift+X (Windows) 或 Command+Shift+X (Macintosh)。
重放录制的命令：

选择“命令”>“播放录制命令”，或按 Control+Shift+R (Windows) 或 Command+Shift+R (Macintosh)。

保存录制的命令：
  1. 选择“命令”>“播放录制命令”重放命令。

    2. “历史记录”面板的步骤列表中随即出现一个名为“运行命令”的步骤。

  2. 选择“运行命令”步骤并单击“保存为命令”按钮。
  3. 输入命令的名称并单击“确定”。

    4. 该命令随即出现在“命令”菜单中


参考资料

本节提供有关在本章中介绍的对话框的信息。


设置“新建文档”参数

可以定义被 Dreamweaver 设置为站点默认文档的文档类型。例如，如果站点的大多数页面是特定的文件类型（如 Cold Fusion、HTML 或 ASP 文档），可以设置自动创建指定文件类型的新文档的文档参数选择。

若要查看或设置新文档参数选择，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后单击“新建文档”类别。

设置新文档参数：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)。
  2. 在“参数选择”对话框中，在“分类”下选择“新建文档”。
  3. 设置要应用的选项：
    • 若要设置默认文档类型，请在“默认文档类型”弹出菜单下，选择在站点中创建的新页面所基于的文档类型。
    • 若要设置 Dreamweaver 文档的默认文件扩展名，必须编辑文档类型 XML 文件。在“新建文档”参数选择中单击相关链接。
    • 若要设置文档编码，请使用“默认编码”弹出菜单。例如，可以选择“西欧语系 (Latin1)”呈现基于英语字符的页面。

      • “默认编码”指定在创建新页面时要使用的编码，以及指定在未指定任何编码的情况下打开一个文档时要使用的编码。默认编码与文档一起存储在文档头中插入的 meta 标签内，它告诉浏览器和 Dreamweaver 应如何对文档进行解码以及使用哪些字体来显示解码的文本。例如：

      如果您指定“西欧字符 (Latin1)”，则插入此 meta 标签：<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">。Dreamweaver 使用您在“字体参数选择”中为“西欧字符 (Latin1)”编码指定的字体显示文档；浏览器使用浏览器用户为“西欧字符 (Latin1)”编码指定的字体显示文档。

      如果您指定“日语 (Shift JIS)”，则插入此 meta 标签：<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">.Dreamweaver 使用您为日语编码指定的字体显示文档；浏览器使用浏览器用户为日语编码指定的字体显示文档。

    • 选中“Control+N 时显示新文档对话框”(Windows) 或“Command+N 时显示新文档对话框”(Macintosh)，在使用键命令时自动创建默认文档类型的新文档。
    • 选中“使文档与 XHTML 兼容”复选框设置该选项。该选项应用于 HTML 和大多数动态文档类型。
若要更改当前文档的编码，请执行以下操作：

选择“修改”>“页面属性”，然后从“文档编码”弹出式菜单中选择一种编码。

相关主题：

设置“字体”参数


清理 Microsoft Word HTML

在 Dreamweaver 中，可以打开或者导入在 Microsoft Word 中保存为 HTML 文件的文档，然后使用“清理 Word 的 HTML”命令删除 Word 生成的无关 HTML 代码。Dreamweaver 删除的代码主要是 Word 用来格式化和显示 Word 文档的，在显示 HTML 文件时并不需要。保留原始 Word (.doc) 文件的一份拷贝作为备份，因为一旦应用了“清理 Word 的 HTML”功能，可能就无法在 Word 中再次打开 HTML 文档。“清理 Word 的 HTML”命令适用于被 Word 97 或更高版本保存为 HTML 文件的文档。

若要清理不是由 Microsoft Word 生成的 HTML 或 XHTML，请参阅清理代码。

清理 Word 的 HTML：
  1. 在 Microsoft Word 中，将文档另存为 HTML 文件。
  2. 在 Dreamweaver 中，使用下列方法之一打开 HTML 文档：
    • 选择“文件” >“导入”>“导入 Word HTML”，然后选择要打开的文件。

      • Dreamweaver 打开文件，然后自动打开“清理 Word 的 HTML”对话框。

    • 选择“文件” >“打开”，然后选择要打开的文件。

      • 如果在“HTML 代码改写”参数选择中选择了“修正或删除标签时发出警告”，则将自动生成 HTML 校正日志文件。这不属于“清理 Word 的 HTML”功能。单击“继续”退出对话框。然后，在 Dreamweaver 中，选择“命令”>“清理 Word 的 HTML”。

  3. 不论使用这两种方法的哪一种，在 Dreamweaver 试图确定文件是用 Word 的哪个版本保存的时，可能都会有一点延迟。如果 Dreamweaver 无法确定这一点，请使用弹出菜单选择正确的版本。
  4. 选择“清理 Word 的 HTML”功能应该使用的选项。“基本”选项卡显示下列选项：
    • 删除所有 Word 特定的标签删除所有 Word 特定的 HTML，包括html 标签中的 XML、文档头中的 Word 自定义元数据和链接标签、Word XML 标签、条件标签及其内容以及样式中的空段落和边距。可以使用“详细”选项卡分别选择这些选项。
    • 清理 CSS删除所有 Word 特定的 CSS，包括尽可能地移除内联 CSS 样式（当父样式有相同的样式属性时）、以 “mso”开头的样式属性、非 CSS 样式声明、表格中的 CSS 样式属性以及头中所有未使用的样式定义。使用“详细”选项卡可以进一步自定义此选项。
    • 清理< font >标签删除 HTML 标签，将默认的正文文本转换成 2 号字的 HTML 文本。
    • 修复无效的嵌套标签删除由 Word 在段落和标题（块级）标签外部插入的 font 标签。
    • 设定背景颜色允许输入十六进制值设置文档的背景颜色。如果不设定背景颜色，Word HTML 文档的背景颜色将是灰色的。Dreamweaver 设置的默认十六进制为白色。
    • 套用源格式将“HTML 格式”参数选择和 SourceFormat.txt 中指定的源格式选项应用于文档。
    • 完成时显示动作记录清理完成时显示一个警告框，其中包含有关文档改动的详细信息。
  5. 单击“确定”。

    6. 根据文档大小和所选选项数目的不同，可能需要几秒钟完成清理。您输入的参数选择自动保存为默认的“清理 Word 的 HTML”设置。


选择“页面属性”选项

使用“页面属性”对话框可以指定页面的各种选项。

若要打开“页面属性”对话框，请选择“修改”>“页面属性”。

标题指定在“文档”窗口和大多数浏览器窗口的标题栏中出现的页面标题。请参阅更改文档标题。

背景图像和背景为页面指定背景图像和背景颜色。请参阅第 373页的“设置背景图像或背景页面颜色”。

文本和链接为文本、链接、访问过的链接和活动链接定义默认颜色。请参阅第 373页的“使用颜色”。也可以使用 CSS 样式表来控制这些颜色。请参阅第 599页的“应用自定义 (Class) CSS 样式”。

左边界和顶部边界指定 body 标签中的页边距大小（仅限于 Microsoft Internet Explorer）。Netscape Navigator 忽略这些值，而是使用“边界宽度”和“边界高度”。若要获得最好的跨浏览器效果，请为两个浏览器（而不只是一个浏览器）都提供边距值，并填写四个边距值而不只是填写两个。若要确保在任何一个浏览器中都不出现边距，请将四个值都设置为 0。Dreamweaver 在“文档”窗口中不显示页边距。若要查看边距，请使用“在浏览器中预览”。

边界宽度和边界高度指定body 标签中的页边距大小（仅限于 Netscape Navigator）。Internet Explorer 忽略这些值，而是使用“左边界”和“顶部边界”。若要获得最好的跨浏览器效果，请为两个浏览器（而不只是一个浏览器）都提供边距值，并填写四个边距值而不只是填写两个。若要确保在任何一个浏览器中都不出现边距，请将四个值都设置为 0。Dreamweaver 在“文档”窗口中不显示页面边距。若要查看边距，请使用“在浏览器中预览”。

文档编码指定文档中字符所用的编码。对于英语和西欧语言，请选择“西欧语系”。其它选项包括中欧、西里尔、希腊、冰岛、日语、繁体中文、简体中文和韩文。如果找不到需要的编码选项，请选择“其它”用您的操作系统所使用的编码创建文档。所有的亚洲语言使用的都是双字节编码。

若要更改 Dreamweaver 用来显示每种编码的字体，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后选择“新建文档”。注意在“新建文档”参数选择中选择的字体不影响访问者查看页面；访问者在他们的 Web 浏览器中（为给定的编码）指定自己的字体。有关更多信息，请参阅设置“字体”参数。

跟踪图像指定用作拷贝设计时的参考的图像。请参阅第 377页的“使用跟踪图像”。该图像只供参考，当文档在浏览器中显示时并不出现。

图像透明度确定跟踪图像的不透明度，从完全透明到完全不透明。

文件文件夹显示保存当前文档的文件夹（如果当前文档已保存）。

站点文件夹显示保存当前文档的站点的本地根文件夹路径（如果当前文档已保存）。请参阅第 301页的“设置 Dreamweaver 站点”。


设置“不可见元素”参数

使用“不可见元素”参数选择可以指定当选择“查看”>“可视化助理”>“不可见元素”时可见的元素。（有关不可见元素的更多信息，请参阅第 376页的“关于不可见元素”。）

更改“不可见元素”参数选择：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后单击“不可见元素”。
  2. 选择哪种元素应该是可见的。对话框中元素名称旁边的选中标记表示当选择“查看”>“可视化助理”>“不可见元素”时，该元素是可见的。

下面是可以显示或隐藏其标记的不可见元素：

命名锚记显示标记文档中的每个命名锚记 (a name = "") 位置的图标。

脚本显示标记文档正文中的 JavaScript 或 VBScript 代码位置的图标。选择该图标可在属性检查器中编辑脚本或链接到外部脚本文件。

注释显示标记 HTML 注释位置的图标。选择该图标可在属性检查器中查看注释。

换行符显示标记每个换行符 (BR) 位置的图标。默认情况下取消选择该选项。

客户端图像地图显示标记文档中每个客户端图像地图位置的图标。

嵌入样式显示标记文档正文中嵌入 CSS 样式位置的图标。如果 CSS 样式放置在文档的 head 部分，则它们不出现在“文档”窗口中。

表单隐藏区域显示标记 type 属性设置为“隐藏”的表单域位置的图标。

表单范围在表单周围显示一个边框，以便您可以看到插入表单元素的位置。该边框显示 form 标签的范围，因此该边框内的任何表单元素都正确地包括在 form 标签中。

层锚记显示标记定义层的代码位置的图标。层本身可以在页面中的任何位置。（层不是不可见元素，只有定义层的代码才是不可见的。）选择该图标可选择层；这样即使层标记为隐藏，还是可以看见层中的内容。

对齐元素锚记显示标记接受 align 属性的元素的 HTML 代码位置的图标。包括图像、表格、ActiveX 对象、插件和小应用程序。在有些情况下，元素的代码可能与可见对象分开。

可视化服务器标签和非可视化服务器标签显示内容不能在“文档”窗口中显示不能在“文档”窗口中显示内容的服务器标签（如 Active Server Pages 标签和 ColdFusion 标签）的位置。


设置 Meta 属性

meta 标签是记录有关当前页面的信息（如字符编码、作者、版权信息和关键字）的 head 元素。这些标签也可以用来向服务器提供信息，如页面的失效日期、刷新间隔和 PICS 等级。(（PICS 是 Internet 内容选择平台，它提供了向网页分配等级（如电影等级）的方法。）

属性指定 Meta 标签是否包含有关页面的描述性信息 (name) 或 HTTP 标题信息 (http-equiv)。

值指定您在该标签中提供的信息类型。有些值（如说明、关键字和刷新）是已经定义好的，而且在 Dreamweaver 中有它们各自的属性检查器，但是您可以根据实际情况指定任何值，例如 creationdate、documentID 或 level 等。

内容是实际的信息。例如，如果为“值”指定了等级，则可以为“内容”指定初级、中级或高级。


设置标题属性

只有一种标题属性：页面标题。在大多数浏览器中查看页面时，标题会出现在浏览器标题栏和 Dreamweaver“文档”窗口的标题栏中。标题还出现在工具栏中。在“标题”文本框中输入页面标题。


设置关键字属性

许多搜索引擎装置（自动浏览网页为搜索引擎收集信息以编入索引的程序）读取关键字 meta 标签的内容，并使用该信息在它们的数据库中将您的页面编入索引。因为有些搜索引擎限制索引的关键字或字符的数目，或者当超过了限制的数目时，它将忽略所有的关键字，所以最好只使用几个精选的关键字。

在标记为“关键字”的文本框中输入关键字，并以逗号隔开。


设置说明属性

许多搜索引擎装置（自动浏览网页为搜索引擎收集信息以编入索引的程序）读取说明 meta 标签的内容。有些使用该信息在它们的数据库中将您的页面编入索引，而有些还在搜索结果页面中显示该信息（而不只是显示文档的前几行）。有些搜索引擎限制索引字符的数目，所以最好将说明限制为几个字（例如，Pork barbecue catering in Albany, Georgia佐治亚州的奥尔巴尼市提供猪肉烧烤 或 按合理的价格为全球客户进行 Web 设计）。

在标记为“说明”的文本框中输入描述性文本。


设置刷新属性

使用刷新元素可以指定浏览器在一定的时间后应该自动刷新页面 - 重新载入页面或转到不同的页面。该元素通常用于在显示了说明 URL 已改变的文本消息后，将用户从一个 URL 重定向到另一个 URL。

延迟是在浏览器刷新页面之前需要等待的时间（以秒为单位）。若要使浏览器在完成载入后立即刷新页面，请在该文本框中输入 0。

动作指定在指定的延迟后，浏览器是应该转到另一个 URL 还是刷新当前页面。若要打开另一个 URL 而不是刷新当前页面，请单击“浏览”按钮，然后浏览并选择要载入的页面。


设置基本属性

使用基本元素可以设置页面中所有文档相对路径相对的基本 URL。

Href 是基本 URL。单击“浏览”按钮浏览并选择一个文件，或在文本框中输入路径。

目标指定所有链接的文档都应该在其中打开的框架或窗口。在当前的框架页中选择一个框架，或选择下列保留名称之一：

  • _blank 将链接的文档载入一个新的、未命名的浏览器窗口。
  • _parent 将链接的文档载入父框架页或包含链接的框架窗口。如果包含链接的框架没有嵌套，则相当于 _top；链接的文档载入整个浏览器窗口。
  • _self 将链接的文档载入链接所在的同一框架或窗口。此目标是默认的，所以通常不需要指定它。
  • _top 将链接的文档载入整个浏览器窗口，从而删除所有框架。


设置链接属性

使用链接元素可以定义当前文档与其它文件之间的关系。注意 head 部分的链接元素与body 部分中的文档之间的 HTML 链接是不一样的。

Href 是您正在为其定义关系的文件的 URL。单击“浏览”按钮浏览并选择一个文件，或在文本框中输入路径。注意该属性并不表示通常的 HTML 意义上的链接文件；链接元素中指定的关系更复杂。

ID 为链接指定一个唯一标识符。

标题描述关系。该属性与链接的样式表有特别的关系；有关更多信息，请参阅World Wide Web 联合会 (WWW) 网站上的 HTML 4.0 规范的“外部样式表”部分。

Rel 指定当前文档与 Href 文本框中的文档之间的关系。可能的值包括替代、样式表、开始、下一步、上一步、内容、索引、术语、版权、章、节、小节、附录、帮助和书签。若要指定多个关系，请用空格将各个值隔开。

Rev 指定当前文档与 Href 文本框中的文档之间的相反关系（与 Rel 相对）。可能的值与 Rel 的可能值相同。

上一页


准备建立动态站点

如果您计划建立动态 Web 应用程序，可以从设置应用程序服务器和进行数据库连接开始着手。

此部分包含以下各章：

  • 设置 Web 应用程序
  • ColdFusion 开发人员的数据库连接
  • ASP.NET 开发人员的数据库连接
  • ASP 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接
  • 适用于 PHP 开发人员的数据库连接


设置 Web 应用程序

本章介绍如何配置您的系统以在 Macromedia Dreamweaver MX 中生成 Web 应用程序。

备注： 如果您想要生成随 Dreamweaver 一起安装的示例 Web 应用程序，请参见在 Dreamweaver MX 中开发 Web 应用程序。

本章包含以下几节：

  • Dreamweaver UltraDev 4 用户说明
  • 生成 Web 应用程序所需软件
  • 设置 Web 服务器
  • 设置应用程序服务器
  • 为应用程序创建根文件夹
  • 定义 Dreamweaver 站点
  • 连接到数据库
  • 排除应用程序服务器错误
下一页


Dreamweaver UltraDev 4 用户说明

如果您是 Macromedia Dreamweaver UltraDev 4 用户，则您的系统可能已进行了配置，可以生成 Web 应用程序。如果您将 UltraDev 4 随 Dreamweaver MX 一起安装，则您的所有 UltraDev 站点都已被自动导入 Dreamweaver 中。您不需要在 Dreamweaver MX 中重新定义这些站点。

但是，如果导入的站点包含使用 UltraDev 4 服务器行为生成的 Macromedia ColdFusion 页，则您必须让 Dreamweaver 知道该站点包含 UltraDev 生成的页面。这是因为 Dreamweaver MX 查找该页面上的代码模式，以在“服务器行为”面板中标识和显示服务器行为。对于 Microsoft Active Server Page (ASP) 和 JavaServer Page (JSP)，Dreamweaver MX 生成与 UltraDev 相同的代码，因此它识别并显示 UltraDev 生成的 ASP 和 JSP 服务器行为。但对于 ColdFusion 页，Dreamweaver MX 生成改进的且更易于理解的代码。因为默认情况下 Dreamweaver 查找这些新代码模式，所以它不识别 UltraDev 生成的 ColdFusion 服务器行为。如果您想要继续使用旧的服务器行为，则必须告诉 Dreamweaver 查找 UltraDev 代码模式。

若要告诉 Dreamweaver 查找由 UltraDev 4 生成的 ColdFusion 代码，请执行以下操作：
  1. 选择“站点”>“编辑站点”，然后选取您的站点并单击“编辑”，打开“站点定义”对话框。
  2. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“测试服务器”。

    3. 随即显示“测试服务器”对话框。

  3. 在“此站点包含”弹出式菜单中，选择以下选项之一：
    • 如果您想要 Dreamweaver 继续为新页生成 UltraDev 代码，则选择“仅限 UltraDev 4 页”。
    • 如果您想要 Dreamweaver 开始将改进的代码用于新页面，则选择“两个版本”。这将以渐进的方式升级 UltraDev 4 站点；经过一段时间后，该站点将主要由具有新的服务器行为的页面组成。
  4. 单击“确定”，然后单击“完成”。

如果您指定站点只包含 UltraDev 4 页，则以不同的方式处理数据库连接。有关更多信息，请参见使用 UltraDev 4 连接进行连接。


生成 Web 应用程序所需软件

若要在 Dreamweaver 中生成 Web 应用程序，您需要以下软件：

  • Web 服务器
  • 在您的 Web 服务器上运行的应用程序服务器，或者兼具应用程序服务器功能的 Web 服务器，例如 Microsoft PWS 或 IIS

备注： 在涉及 Web 应用程序的环境中，“Web 服务器”和“应用程序服务器”这两个术语均指的是软件，而非硬件。

如果您想要将数据库与应用程序一起使用，还需要以下软件：

  • 数据库或数据库系统
  • 支持您的数据库的数据库驱动程序

有关为 Web 应用程序设置数据库的信息，请参见连接到数据库。

有一些网页寄存公司可为您提供服务计划，使您能够利用他们的软件来测试并部署 Web 应用程序。如果您是 Windows 用户，则出于开发目的您可以在 Dreamweaver 所在的同一台计算机上安装所需的软件。您还可以在网络计算机（通常是 Windows NT 或 Windows 2000 计算机）上安装软件，以使小组中的其他开发人员能够处理项目。

如果您是 Macintosh 用户，则您可以使用虚拟主机服务或在远程计算机上安装所需的软件。如果您是 Mac OS 10.1 用户，则可以使用随您的操作系统一起安装的 Apache Web 服务器和 PHP 应用程序服务器从本地开发 PHP 站点。有关设置信息，请参见以下 Web 站点：

  • http://developer.apple.com/internet/macosx/php.html
  • http://www.entropy.ch/software/macosx/
  • http://www.stepwise.com/Articles/Workbench/2001-10-11.01.html


设置 Web 服务器

若要运行 Web 应用程序，您需要 Web 服务器。Web 服务器是根据 Web 浏览器的请求提供文件服务的软件。Web 服务器有时也叫做 HTTP 服务器。常见 Web 服务器包括 IIS、Netscape Enterprise Server、iPlanet Web Server 和 Apache HTTP Server。

如果您没有使用虚拟主机服务，则选择一个 Web 服务器并在您的本地计算机或远程计算机上安装它。有关更多信息，请参见服务器供应商的文档或向您的系统管理员咨询。

Windows 用户可以通过安装 PWS 或 IIS，在其本地计算机上迅速启动并运行 Web 服务器。Web 服务器可能已经安装。请检查文件夹结构中是否包含一个 C:\Inetpub 或 D:\Inetpub 文件夹。PWS 和 IIS 在安装过程中将创建该文件夹。如果您想要安装 PWS 或 IIS，请参见在 Windows 中安装 Web 服务器。

ASP.NET 页仅使用一个 Web 服务器：Microsoft IIS 5 或更高版本。不支持 PWS。此外，因为 IIS 5 是 Windows 2000 和 Windows XP Professional 操作系统提供的服务，所以您只能使用这两个版本的 Windows 来运行 ASP.NET 应用程序。不支持 Windows 98、ME 或 NT。但请注意，您可以在运行 Dreamweaver MX 的任何计算机（包括 Macintosh）上开发（而不是运行）ASP.NET 应用程序。


设置应用程序服务器

若要运行 Web 应用程序，您的 Web 服务器需要使用应用程序服务器。应用程序服务器是一种软件，用来帮助 Web 服务器处理特别标记的 Web 页。当请求这样一页时，Web 服务器先将该页发送到应用程序服务器进行处理，然后再将该页发送到浏览器。

常见的应用程序服务器包括 Macromedia ColdFusion MX、Macromedia JRun、Microsoft .NET 框架、PHP、IBM WebSphere 和 Jakarta Tomcat。Microsoft IIS 和 PWS Web 服务器还兼有 ASP 应用程序服务器的功能。应用程序服务器通常安装在运行 Web 服务器的同一系统上。

以下是本节涉及的主题：

  • 选择应用程序服务器
  • 安装 ColdFusion 应用程序服务器
  • 安装 ASP.NET 应用程序服务器
  • 安装 ASP 应用程序服务器
  • 安装 JSP 应用程序服务器
  • 安装 PHP 应用程序服务器


选择应用程序服务器

您对应用程序服务器的选择取决于多种因素，包括预算、要使用的服务器技术（ColdFusion、ASP.NET、ASP、JSP 或 PHP）和选择的 Web 服务器。

预算：某些供应商出售价格和管理成本都很高的高端应用程序服务器。而其他一些供应商则提供更易使用的、成本效益更高的解决方案（例如 Macromedia ColdFusion 和 JRun 服务器）。某些应用程序服务器被内置到 Web 服务器中（例如 Microsoft IIS 和 PWS），而其他一些应用程序服务器可以从 Internet 上免费下载（例如 Jakarta Tomcat 和 PHP）。

服务器技术：应用程序服务器使用不同的技术。Dreamweaver 支持五种服务器技术：ColdFusion、ASP.NET、ASP、JSP 和 PHP。有关更多信息，请参见选择服务器技术。下表列出了可用于 Dreamweaver 支持的五种服务器技术的常见应用程序服务器：

服务器技术 | 应用程序服务器
ColdFusion | Macromedia ColdFusion MX
ASP.NET | 具有 .NET 框架的 Microsoft IIS 5
ASP | Microsoft IIS 或 PWS Sun Chili!Soft ASP
JSP | Macromedia JRun IBM WebSphere Apache Tomcat BEA WebLogic
PHP | PHP 服务器

Web 服务器：您所选的应用程序服务器还可以取决于您要使用的 Web 服务器。确保应用程序可以和您的 Web 服务器一起使用。例如，.NET 框架只能和 IIS 5 或更高版本一起使用。


安装 ColdFusion 应用程序服务器

若要运行 ColdFusion 页，您需要 ColdFusion 应用程序服务器。此服务器可用于 Windows、Linux、Solaris 和 HP-UX 系统。

您可以从 Macromedia Web 站点下载并安装 ColdFusion MX 的完全功能的开发人员版本。在 Dreamweaver CD 上也提供 ColdFusion MX Server Developer Edition 的拷贝（仅限 Windows 版本）。

Macintosh 用户可以将虚拟主机服务与 ColdFusion 计划一起使用或在运行 Web 服务器的远程 Windows、Linux、Solaris 或 HP-UX 计算机上安装 ColdFusion。

在安装应用程序服务器后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 ASP.NET 应用程序服务器

若要开发 ASP.NET 页，您需要以下软件：

  • 运行 IIS 5 或更高版本的 Windows 2000 或 Windows XP Professional 计算机
  • Microsoft .NET 框架，您可以从 Microsoft Web 站点上下载它

从 Microsoft Web 站点下载 .NET 框架并按照该 Web 站点上的安装说明进行安装。

Macintosh 用户可以将虚拟主机服务与 ASP.NET 计划一起使用，或者在运行 IIS 5 或更高版本的远程 Windows 2000 或 Windows XP Professional 计算机上安装 .NET 框架。

在安装 .NET 框架后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 ASP 应用程序服务器

若要开发 ASP 页，您需要支持 Microsoft Active Server Pages 2.0 的应用程序服务器。以下是一些常见选择：

  • Microsoft IIS，它是 Windows NT Server、Windows 2000 和 Windows XP Professional 所附带的
  • Microsoft PWS，在 Windows 98 和 NT Workstation 中运行的 IIS 的精简版本
  • Sun Chili!Soft ASP，在 Windows、Linux、Solaris 和其他平台上运行的版本。有关更多信息，请参见 Chili!Soft Web 站点

Windows 用户可以在其本地计算机上安装并运行 IIS 或 PWS。有关说明，请参见在 Windows 中安装 Web 服务器。

Macintosh 用户可以将虚拟主机服务与 ASP 计划一起使用或在远程计算机上安装 IIS 或 PWS。

在安装 IIS 或 PWS 后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 JSP 应用程序服务器

若要开发 JSP 页，您需要支持 JavaServer Pages 的应用程序服务器。以下是一些常见选择：

  • 用于 Windows、Linux、Solaris 或 UNIX 的 Macromedia JRun。您可以从 Macromedia Web 站点下载试用版。
  • 用于各种操作系统的 IBM WebSphere。您可以从 IBM Web 站点下载试用版。
  • 用于 Windows 和 UNIX 的 Tomcat。您可以从 Jakarta Project Web 站点下载 Tomcat 的拷贝。

Macintosh 用户可以将虚拟主机服务与 JSP 计划一起使用，或在运行 Web 服务器的远程计算机上安装 JSP 应用程序服务器。

在安装 JSP 应用程序服务器后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


安装 PHP 应用程序服务器

若要运行 PHP 页，您需要 PHP 应用程序服务器，它是在 Web 上提供的开放源代码软件。应用程序服务器有用于 Windows、Linux、UNIX、HP-UX、Solaris 和 Mac OS X 系统的版本。应用程序服务器可以与下列 Web 服务器一起工作：Apache、Microsoft IIS 或 PWS、Netscape 和 iPlanet 服务器以及几乎所有支持 CGI 接口的 Web 服务器。

您可以从 PHP Web 站点下载 PHP 应用程序服务器。有关安装该服务器的信息，请参见 PHP 文档，您也可以从 PHP Web 站点下载该文档。

Macintosh 用户可以将虚拟主机服务与 PHP 计划一起使用，或在运行 Web 服务器的远程计算机上安装 PHP。如果您是 Mac OS 10.1 用户，则您可以使用随您的操作系统一起安装的 PHP 应用程序服务器。有关更多信息，请参见以下 Web 站点：

  • http://developer.apple.com/internet/macosx/php.html
  • http://www.entropy.ch/software/macosx/
  • http://www.stepwise.com/Articles/Workbench/2001-10-11.01.html

在安装 PHP 应用程序服务器后，为您的 Web 应用程序创建根文件夹。请参见为应用程序创建根文件夹。


为应用程序创建根文件夹

在安装服务器软件后，为您的 Web 应用程序在运行 Web 服务器的计算机上创建根文件夹。

确保该文件夹已由 Web 服务器发布；换言之，Web 服务器可以根据 Web 浏览器的 HTTP 请求提供此文件夹中的任何文件或其子文件夹中的任何文件。例如，在运行 PWS 或 IIS 的计算机上，Inetpub\wwwroot 文件夹或其子文件夹中的所有文件都可用于 Web 浏览器。


定义 Dreamweaver 站点

在配置了用来开发 Web 应用程序的系统后，定义用来管理您的文件的 Dreamweaver 站点。

备注： Macromedia HomeSite 和 ColdFusion Studio 用户可以将 Dreamweaver 站点视为 HomeSite 或 Studio 项目。

在您开始前，确保您满足以下要求：

  • 您具有访问 Web 服务器的权限。Web 服务器可以在您的本地计算机上运行，在像开发服务器这样的远程计算机上运行，或者在网页寄存公司维护的服务器上运行。请参见设置 Web 服务器。
  • 应用程序服务器安装并运行在运行您的 Web 服务器的系统上。请参见设置应用程序服务器。
  • 您已在运行 Web 服务器的系统上为 Web 应用程序创建了根文件夹。有关更多信息，请参见为应用程序创建根文件夹。

为您的 Web 应用程序定义 Dreamweaver 站点需执行以下三步：

  1. 将位于您的硬盘上的文件夹定义为用来存储您的站点文件工作拷贝的 Dreamweaver 本地文件夹（请参见定义本地文件夹）。
  2. 将位于正运行您的 Web 服务器的计算机上的文件夹定义为 Dreamweaver 远程文件夹（请参见定义远程文件夹）。
  3. 指定 Dreamweaver 应将在工作时要处理的动态页发送到哪里（请参见指定可在哪里处理动态页）。

在定义了 Dreamweaver 站点后，您就可以开始生成 Web 应用程序了。


定义本地文件夹

您可为您创建的每一个新 Web 应用程序定义 Dreamweaver 本地文件夹。本地文件夹是您在硬盘上用来存储站点文件的工作拷贝的文件夹。如果您没有定义本地文件夹，Dreamweaver 将无法正常工作。

定义本地文件夹还使您能够通过单击按钮来管理文件并将文件传输到 Web 服务器和从 Web 服务器接收文件。

若要定义 Dreamweaver 本地文件夹，请执行以下操作：
  1. 创建在本地硬盘上用来存储您的文件的工作拷贝的文件夹。

    2. 您最好创建子文件夹以存储图像文件和其他资源。

  2. 在 Dreamweaver 中，选择“站点”>“新建站点”。

    3. 随即显示“站点定义”对话框。

  3. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“本地信息”（它应该是默认选项）。
  4. 在“站点名称”框中，输入 Dreamweaver 站点的描述性名称。
  5. 在“本地根文件夹”框中，指定您在第 1 步中创建的文件夹。

    6. 您可以输入一个路径，或者单击文件夹图标以浏览到并选择该文件夹。

  6. 您可以根据需要完成对“本地信息”类别中的其他选项的设置（这些选项不是站点得以工作所必需的选项）。

    7. 有关这些选项的更多信息，请参见设置“本地信息”类别选项。

将“站点定义”对话框保持为打开状态。接下来您必须指定远程文件夹。请参见定义远程文件夹。


定义远程文件夹

在定义本地文件夹后，您可为 Dreamweaver 站点定义远程文件夹。远程文件夹是您为 Web 应用程序在 Web 服务器上创建的文件夹（请参见为应用程序创建根文件夹）。

如果您在定义本地文件夹中定义的文件夹可以兼具您的 Web 应用程序的根文件夹的功能，则您不需要定义远程文件夹。（这意味着该 Web 服务器正在您的本地计算机上运行。）

若要定义 Dreamweaver 远程文件夹，请执行以下操作：
  1. 如果“站点定义”对话框尚未打开，则选择“站点”>“编辑站点”，然后选取您的站点并单击“编辑”，打开该对话框。

    2. 随即显示“站点定义”对话框。

  2. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“远程信息”。

    3. 随即显示“远程信息”对话框。

  3. 在“访问”弹出式菜单中，选择以下选项之一：本地/网络、FTP 或 RDS。

    4. 根据您所做的选择，Dreamweaver 将知道您在本地文件夹和远程文件夹之间传输文件的方式。

    备注： 若要使用 RDS，远程文件夹必须位于运行 ColdFusion 的计算机上。

    您还可以通过选择“SourceSafe Database”将文件发送到 SourceSafe 应用程序中。（开发人员使用 SourceSafe 来进行文件版本控制。）如果您选择此选项，则需要定义单独的文件夹。有关说明，请参见指定可在哪里处理动态页。

  4. 在选择访问方法后，根据需要设置适当的访问选项。

    5. 有关更多信息，请参见设置“远程信息”类别选项。

将“站点定义”对话框保持为打开状态。您接下来需要定义处理动态页的文件夹。请参见指定可在哪里处理动态页。


指定可在哪里处理动态页

在 Dreamweaver 中定义远程文件夹后，指定可在其中处理动态页的文件夹。Dreamweaver 使用此文件夹生成动态内容并在您工作时连接到数据库。

通常，您指定在 Web 服务器上创建的根文件夹（请参见为应用程序创建根文件夹），因为 Web 服务器和应用程序服务器一起工作。

备注： 根文件夹可以是本地的也可以是远程的，取决于您的 Web 服务器正在哪里运行。

若要指定 Dreamweaver 可在哪里处理动态页，请执行以下操作：
  1. 如果“站点定义”对话框尚未打开，则选择“站点”>“编辑站点”，然后选取您的站点并单击“编辑”，打开该对话框。

    2. 随即显示“站点定义”对话框。

  2. 如果显示向导，则单击“高级”，然后从“类别”列表中选择“测试服务器”。

    3. 随即显示“测试服务器”对话框。Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要测试服务器可以处理您计划开发的动态页类型，选择哪个就无关紧要。

  3. 完成对话框设置，然后单击“确定”。

    4. 有关更多信息，请参见设置“测试服务器”类别选项。

相关主题

关于 URL 前缀

Dreamweaver UltraDev 4 用户说明


关于 URL 前缀

您必须指定 URL 前缀，这样 Dreamweaver MX 才能使用测试服务器的服务显示数据并在您工作时连接到数据库。Dreamweaver 使用测试服务器生成您使用“在浏览器中预览”命令时在“活动数据”窗口和您的浏览器中显示的动态内容。

Dreamweaver 还在设计时使用测试服务器建立与数据库的连接。Dreamweaver 使用设计时连接向您提供与数据库有关的有用信息，例如您的数据库中各表的名称以及表中各列的名称。

URL 前缀包含域名以及您的 Web 站点主目录的任何子目录或虚拟目录。

备注： 本节使用在 Microsoft IIS 中使用的术语。服务器不同，术语也可能不同，但相同的概念适用于大多数 Web 服务器。

主目录是服务器上映射到您站点的域名的文件夹。假设您要用来处理动态页的文件夹是 c:\sites\company\，并且该文件夹是您的主目录（即，该文件夹被映射到您站点的域名，例如 www.mystartup.com）。在该情况下，URL 前缀是 http://www.mystartup.com/。

如果您要用来处理动态页的文件夹是您的主目录的子文件夹，则您只需将该子文件夹添加到 URL。假设您的主目录是 c:\sites\company\，您的站点的域名是 www.mystartup.com，并且您要用来处理动态页的文件夹是 c:\sites\company\inventory。输入以下 URL 前缀：

http://www.mystartup.com/inventory/

如果您要用来处理动态页的文件夹不是您的主目录或其任何子目录，则您必须创建虚拟目录。

虚拟目录是实际上不包含在服务器的主目录上的文件夹，即使它看起来像是在 URL 中。若要创建虚拟目录，请为 URL 中的文件夹路径指定一个别名。假设您的主目录是 c:\sites\company，您正处理的文件夹是 d:\apps\inventory，并且您为名为 warehouse 的文件夹定义别名。输入以下 URL 前缀：

http://www.mystartup.com/warehouse/

本地主机是一个术语，表示当客户端（通常是浏览器，但在此情况下为 Dreamweaver）与 Web 服务器运行在同一系统上时您的 URL 中的主目录。假设 Dreamweaver 与 Web 服务器在同一系统上运行，您的主目录是 c:\sites\company，并且您已定义了名为 warehouse 的虚拟目录以表示您要用来处理动态页的文件夹。输入以下 URL 前缀：

http://localhost/warehouse/

若要确定在 PWS 和 IIS 4.0 中的域名和主目录，请单击“个人 Web 管理器”中的“主屏”图标并记下在“发布”区域中指定的主页。

相关主题

指定可在哪里处理动态页


连接到数据库

如果您要将数据库与 Web 应用程序一起使用，必须首先连接到该数据库。有关数据库连接的一般性论述，请参见理解数据库连接。

根据您所选择的服务器技术，Dreamweaver MX 处理数据库连接的方式也将有所不同。请参见以下各章：

  • ColdFusion 开发人员的数据库连接
  • ASP.NET 开发人员的数据库连接
  • ASP 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接
  • 适用于 PHP 开发人员的数据库连接


排除应用程序服务器错误

本节介绍一些常见的应用程序服务器错误以及排除这些错误的方法。

有关 Macromedia 应用程序服务器的更多信息，请访问 Macromedia Web 站点上的“ColdFusion and JRun Support Centers”（ColdFusion 和 JRun 支持中心）。

有关其他应用程序服务器的更多信息，请参见服务器的文档，访问供应商的 Web 站点，或者与供应商的技术支持部门联系。

本节涉及以下服务器错误：

  • ColdFusion - 405 不允许的方法
  • JRun - 语法错误：应该是标识符，而不是此标记
  • JRun - 错误 2140
  • WebSphere - 错误 403（按照规则被禁止）
  • WebSphere - 错误 404（未找到文件）


ColdFusion - 405 不允许的方法

当您验证安装时在 ColdFusion 4 或 5 上发生此错误。此错误可能是由于具有 PWS 的 FrontPage 版本导致的。确保您具有 PWS 的完全版本，而非 FrontPage 版本。

如果您具有正确的 PWS 版本，则检查 cfdocs 和 cfide 的虚拟目录名。在 PWS 中，单击“高级”图标，从该列表中选择虚拟目录，然后单击“编辑属性”。在“别名”框中，从虚拟目录名中删除所有逗号。

您可能还要将您的数据库文件存储到 Web 服务器的根文件夹外。Web 服务器可能有时候会将文件放入缓存并以独占方式锁定它们，从而导致写权限问题。将数据库存储在 Web 服务器的根文件夹之外还提供额外的安全性保证。


JRun - 语法错误：应该是标识符，而不是此标记

当尝试处理名为 default.jsp 的 JSP 页时发生此错误。

“default”一词在 JRun 中是保留关键字。若要纠正此问题，请重命名 index.jsp 或 home.jsp 页。


JRun - 错误 2140

此错误可能是由于以下几个原因导致的：

  • 未正确输入许可证密钥。从您收到的购买确认电子邮件中剪切并粘贴许可证密钥，从而避免键入错误。还要确保该许可证密钥后没有空格。
  • jsm-default 没有作为 NT 服务正确安装。

有关更多信息，请参见 JRun support center（JRun 支持中心）上的文章 12015。


WebSphere - 错误 403（按照规则被禁止）

在调用 servlet 或 JSP 时发生此错误。可能的原因和解决方案如下：

  • 您在调用 JSP 文件时使用了错误的文件名。验证 JSP 文件的文件名。纠正文件名的所有拼写、大小写或扩展名错误。确保您的 JSP 文件名是以 .jsp 结尾的。
  • 如果您未将默认端口号用于 IBM HTTP Server for AS/400 实例（端口 80），则没有添加 host:port 来作为您的虚拟主机的别名。若要查看您的虚拟主机别名，请在管理控制台中单击您的虚拟主机的“高级属性”标签。
  • 对于 JSP 文件驻留于其中的 Web 应用程序，没有支持 JSP 的 servlet。确认支持 JSP 的 servlet 已被添加到 JSP 驻留于其中的 Web 应用程序上。根据需要创建支持 JSP 的 servlet。
  • 如果您的 servlet 是在 Web 应用程序内创建的，则该 servlet 需要有一个统一资源标识符 (URI) 路径。确认 URI 路径是正确的。
  • 活动 HTTP 服务器配置中的 Pass 或 Redirect 指令阻止 JSP 或 servlet 被调用。确认活动 IBM HTTP Server for AS/400 配置中的 Pass 和 Redirect 指令是正确的。

有关更多信息，请参见 IBM Web 站点上的 FAQ（常见问题解答）。

对于涉及 WebSphere 的其他问题，请参见 IBM WebSphere Support Center（IBM WebSphere 支持中心）。


WebSphere - 错误 404（未找到文件）

在调用 servlet 或 JSP 时发生此错误。可能的原因和解决方案如下：

  • 确认 JSP 或 servlet URL 没有拼写错误。
  • 应用程序服务器进程没有足够的权限来访问包含 JSP 生成的 Java 代码和类文件的文件夹。确认 QEJBSVR 具有访问 /QIBM/UserData/WebASAdv/default/temp 或 /QIBM/UserData/WebASAdv/<username>/temp 文件夹结构的权限。
  • 发生此错误的原因可能是未能找到由您的 servlet 使用的类。确认您的 servlet 需要的所有类都位于 Web 应用程序 classpath 变量中。
  • 此错误可能是由于 HTTP 配置文件中 Pass 指令的位置错误而导致的。如果您的 Service 指令前具有 (PASS /*) Pass 指令，则永远不会引用 Service 指令。若要纠正此问题，可将 Pass 指令移到 HTTP 配置项的末尾，或者令其更具体（例如 PASS /*.html）。有关 HTTP 配置指令的更多信息，请参见 WebSphere 文档中的“Editing the HTTP configuration file to add server directives”（编辑 HTTP 配置文件以添加服务器指令）。

有关更多信息，请参见 IBM WebSphere Support Center（IBM WebSphere 支持中心）。


参考资料

本节提供此章中介绍的有关对话框的信息。


设置“测试服务器”类别选项

此对话框用于指定 Dreamweaver MX 用来处理动态页以进行网页创作的测试服务器。

Dreamweaver 需要测试服务器的服务以在您工作时生成和显示动态内容。测试服务器可以是您的本地计算机、开发服务器、模拟调试服务器或生产服务器。只要测试服务器可以处理您计划开发的动态页类型，该选择就无关紧要。

确保您在完成此对话框的设置前定义本地和远程文件夹。有关说明，请参见定义本地文件夹和定义远程文件夹。您可能经常将您的远程文件夹的设置用于您的测试服务器，因为在远程文件夹中上传的动态页通常可能是由应用程序服务器处理的。

过程
  1. 选择服务器技术。
  2. 如果您的站点所包含的旧式 ColdFusion 页具有由 Dreamweaver UltraDev 4 生成的服务器行为，则在“此页包含”框中选择以下项之一：
    • 如果您想要 Dreamweaver 在任何新页中生成改进的 ColdFusion 代码并忽略现有页中 UltraDev 生成的 ColdFusion 代码，则选择“仅限 Dreamweaver MX 文件”。如果您选择此选项，Dreamweaver 将不识别 UltraDev 4 服务器行为并将不在“服务器行为”面板中显示它们。
    • 如果您想要 Dreamweaver 继续生成与 UltraDev 相同的 ColdFusion 代码，则选择“仅限 UltraDev 4 页”。
    • 如果您想要 Dreamweaver 为所有新页面生成改进的 ColdFusion 代码，则选择“两个版本”。您可以使用此选项逐步升级站点中的页面。

      • 有关更多信息，请参见Dreamweaver UltraDev 4 用户说明。

  3. 接受默认的“测试服务器”设置，或者输入不同的设置。

    4. 默认情况下，Dreamweaver 假定应用程序服务器正运行在与您的 Web 服务器相同的系统上。如果您在“站点定义”对话框的“远程信息”类别中定义了远程文件夹，并且如果应用程序服务器运行在与远程文件夹相同的系统上（包括您的本地计算机），则接受“测试服务器”类别中的默认设置。

    如果您没有在“远程信息”类别中定义远程文件夹，则“测试服务器”类别默认为您在“本地信息”类别中定义的本地文件夹。 只有在您满足以下两个条件时，您才可以不去改动此默认设置：

    • 您的 Web 服务器和应用程序服务器均在您的本地计算机上运行。例如，您是在本地 Windows 98 系统上运行 PWS 和 ColdFusion 的 ColdFusion 开发人员。
    • 您的本地根文件夹是您的主目录的子文件夹。例如，如果您正使用 PWS 或 IIS，则您的本地根文件夹是 c:\Inetpub\wwwroot\ 文件夹的子文件夹，或是该文件夹本身。

      • 如果您的本地根文件夹不是您的主目录的子文件夹，则您必须将本地根文件夹定义为您的 Web 服务器中的虚拟目录。

      有关主目录和虚拟目录的更多信息，请参见关于 URL 前缀。

      应用程序服务器可以在与您的远程站点不同的系统上运行。例如，如果您在“远程信息”类别中选择的“访问”选项是“SourceSafe”，则您必须在“测试服务器”类别中指定不同的服务器。

  4. 在“URL 前缀”框中，输入用户在其浏览器中键入用来打开您的 Web 应用程序的 URL，但不包括任何文件名。

    5. 假定您的应用程序的 URL 是 http://www.macromedia.com/mycoolapp/start.jsp。在此情况下，您应输入以下 URL 前缀：http://www.macromedia.com/mycoolapp/。

    如果 Dreamweaver 运行在与您的 Web 服务器相同的系统上，则可以使用 localhost 一词作为您的域名的替代项。例如，假定您的应用程序的 URL 如下所示：

    http://buttercup_pc/mycoolapp/start.jsp

    您可以输入以下 URL 前缀：

    http://localhost/mycoolapp/

    有关更多信息，请参见关于 URL 前缀。

  5. 单击“确定”，然后单击“完成”。

Dreamweaver 将该新站点添加到您的站点列表中。

相关主题

指定可在哪里处理动态页

关于 URL 前缀

上一页


ColdFusion 开发人员的数据库连接

本章介绍在用 Macromedia Dreamweaver MX 开发 Macromedia ColdFusion 应用程序时如何连接到数据库。对于 ColdFusion 应用程序，通过选择在“ColdFusion 管理员”（服务器的管理控制台）中定义的 ColdFusion 数据源，就可以在 Dreamweaver 中建立连接。

本章假定您已经设置 ColdFusion Web 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机（或在对其具有网络或 FTP 访问权的系统）上设置了数据库。

本章包含以下主题：

  • 连接到数据库
  • 编辑或删除数据库连接
  • 使用 UltraDev 4 连接进行连接

若要更详细地了解数据库和数据库连接，请参见数据库初学者指南。

下一页


连接到数据库

当您在 Dreamweaver 中开发 ColdFusion Web 应用程序时，通过选择在“ColdFusion 管理员”（服务器的管理控制台）中定义的 ColdFusion 数据源，就可以连接到数据库。

备注： 如果您正在 Windows 计算机上运行 ColdFusion 5，还可以在该计算机上设置数据源名称 (DSN)。ColdFusion 4 或 5 会自动将系统 DSN 当作数据源。

在连接到数据库之前，必须先确保 Dreamweaver 知道去何处查找 ColdFusion 数据源。为了在设计时检索 ColdFusion 数据源，Dreamweaver 会将脚本放在运行 ColdFusion 的计算机上的一个文件夹中。您必须在“站点定义”对话框的“测试服务器”类别中指定该文件夹。有关更多信息，请参见指定可在哪里处理动态页。

接着，您必须在“ColdFusion 管理员”中创建 ColdFusion 数据源（如果它尚不存在）。有关更多信息，请参见创建 ColdFusion 数据源。

当创建 ColdFusion 数据源后，您可以在 Dreamweaver 中使用它来连接到数据库。有关更多信息，请参见在 Dreamweaver 中连接到数据库。

本节假定您使用的是 Dreamweaver MX 连接，而不是 Dreamweaver UltraDev 4 连接。在 UltraDev 4 中对数据库连接的处理方式有所不同。有关更多信息，请参见使用 UltraDev 4 连接进行连接。


创建 ColdFusion 数据源

在连接到数据库之前，您必须在“ColdFusion 管理员”（服务器的管理控制台）中创建一个 ColdFusion 数据源。

备注： 如果您是在 Windows 计算机上运行 ColdFusion 5，还可以在该计算机上设置 DSN。ColdFusion 5 会自动将系统 DSN 当作数据源。有关更多信息，请参见在 Windows 中设置 DSN。

若要创建 ColdFusion 数据源，请执行以下操作：
  1. 在 Dreamweaver 的“数据库”面板（“窗口”>“数据库”）中，单击“修改数据源”图标（面板工具栏上从右向左的第二个图标）。

    2. “ColdFusion 管理员”在浏览器中打开。

  2. 登录到“ColdFusion 管理员”并创建数据源。

    3. 有关指导请参见 ColdFusion 文档。

您必须提供某些特定的参数值才能创建 ColdFusion 数据源。有关特定于您的数据库驱动程序的参数值，请参见驱动程序供应商提供的文档或咨询您的管理员。

当创建 ColdFusion 数据源后，即可在 Dreamweaver 中使用它。有关更多信息，请参见在 Dreamweaver 中连接到数据库。


在 Dreamweaver 中连接到数据库

当您在“ColdFusion 管理员”中创建 ColdFusion 数据源（请参见创建 ColdFusion 数据源）后，可以在 Dreamweaver 中使用它连接到数据库。

在 Dreamweaver 中打开任意 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。您的 ColdFusion 数据源会出现在该面板中。

如果数据源未出现，请确保 Dreamweaver 知道去何处查找 ColdFusion 数据源。在“站点定义”对话框的“测试程序服务器”类别中，指定运行 ColdFusion 的计算机上的站点根文件夹。有关更多信息，请参见指定可在哪里处理动态页。


编辑或删除数据库连接

您可以在“ColdFusion 管理员”中编辑或删除 ColdFusion 数据源。在 Dreamweaver 的“数据库”面板（“窗口”>“数据库”）中，单击“修改数据源”图标（面板工具栏上从右向左的第二个图标）。“ColdFusion 管理员”在浏览器中打开。登录并修改数据源。有关指导请参见 ColdFusion 文档。

若要避免在删除或重命名 ColdFusion 数据源后出错，请在“绑定”面板中双击记录集的名称并选择新的数据源，以更新每个使用旧数据源的记录集。


使用 UltraDev 4 连接进行连接

本节介绍在使用 Dreamweaver UltraDev 4 服务器行为生成 ColdFusion 应用程序（或在 Dreamweaver MX 中使用 UltraDev 4 服务器行为生成该应用程序）的情况下如何连接到数据库。有关更多信息，请参见Dreamweaver UltraDev 4 用户说明。

本节用“UD4 ColdFusion”一词指代 UltraDev 4 连接。

本节包含以下主题：

  • 连接要求
  • 创建常规 UD4 ColdFusion 连接
  • 创建高级 UD4 ColdFusion 连接（Macintosh 用户）
  • 编辑或删除 UD4 ColdFusion 连接


连接要求

在创建 UD4 ColdFusion 数据库连接之前，必须准备好以下各项：

  • 一个 Dreamweaver 站点，它指定站点中仅包含 UltraDev 4 文件。有关更多信息，请参见指定可在哪里处理动态页
  • 一个数据库，它设置在本地计算机（或者对其具有网络或 FTP 访问权的系统）上
  • 一个适当的数据库驱动程序，它安装在运行 ColdFusion 的计算机上
  • 一个为数据库定义的 ColdFusion 数据源。有关更多信息，请参见创建 ColdFusion 数据源


创建常规 UD4 ColdFusion 连接

本节介绍如何在使用 UltraDev 4 连接的情况下创建常规数据库连接。

UltraDev 4 在 Macintosh 上的 ColdFusion 连接不支持 SQL Server 7.0 以外的数据库中的预存过程。如果您是 Macintosh 用户，并需要使用 SQL Server 7.0 以外的数据库中的预存过程，请使用 JDBC 创建一个高级 ColdFusion 连接以便在设计时连接到数据库。有关过程请参见创建高级 UD4 ColdFusion 连接（Macintosh 用户）。

若要创建常规的 UD4 ColdFusion 连接，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称”。
  3. 如果这是您为该站点创建的第一个连接，Dreamweaver 将提示您提供 ColdFusion RDS（远程开发服务）用户名和密码。

    4. 当您登录后，Dreamweaver 将连接到服务器，检索 ColdFusion 数据源并显示“数据源名称”对话框。

  4. 填写该对话框，然后单击“确定”。

    5. 有关指导请参见设置“数据源名称”对话框选项。

新连接出现在“数据库”面板上。


创建高级 UD4 ColdFusion 连接（Macintosh 用户）

Macintosh 上的 UltraDev ColdFusion 连接不支持 SQL Server 7.0 以外的数据库中的预存过程。如果您是 Macintosh 用户，并需要使用 SQL Server 7.0 以外的数据库中的预存过程，就必须创建一个高级 ColdFusion 连接。

若要在 Dreamweaver 中创建高级 ColdFusion 数据库连接，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称 - 高级”。
  3. 如果这是您为该站点创建的第一个连接，Dreamweaver 将提示您提供 ColdFusion RDS 用户名和密码。

    4. 当您登录后，Dreamweaver 将连接到服务器，检索 ColdFusion DSN 并显示“数据源名称 - 高级”对话框。

  4. 填写该对话框，然后单击“确定”。

    5. 有关指导请参见设置“数据源名称 - 高级”对话框选项。

新连接出现在“数据库”面板上。


编辑或删除 UD4 ColdFusion 连接

当您创建数据库连接后，Dreamweaver 会将连接信息存储在站点本地根文件夹下的“连接”子文件夹中的一个文件中。Dreamweaver 实际上不会为 ColdFusion 应用程序创建数据库连接，直到您在该应用程序中为页定义了记录集（请参见定义记录集）。此时，Dreamweaver 会将代码写入该文件以建立连接，并且在页中插入一个 include 指令。在运行时，服务器会在您的文档中插入连接代码。

若要更新连接，请执行以下操作：
  1. 在 Dreamweaver MX 中打开一个 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 连接列表出现在该面板上。

  2. 右击 (Windows) 或按住 Ctrl 键并单击 (Macintosh) 该连接，然后从弹出式菜单中选择“编辑连接”。

    3. 出现您曾用来创建该连接的对话框。

  3. 做出更改，然后单击“确定”。

Dreamweaver 自动更新该 include 文件，这将更新该站点中使用此连接的所有页。

若要删除连接，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ColdFusion 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 连接列表出现在该面板上。

  2. 右击 (Windows) 或按住 Ctrl 键并单击 (Macintosh) 该连接，然后从弹出式菜单中选择“删除连接”。

    3. 出现您曾用来创建该连接的对话框。

  3. 确认您要删除该连接。

若要避免在删除连接后出错，请在“绑定”面板中双击记录集的名称并选择新的连接，以更新每个使用旧连接的记录集。


参考资料

本节提供有关在本章介绍的对话框的信息。


设置“数据源名称”对话框选项

此对话框用于在用 Dreamweaver UltraDev 4 的 ColdFusion 服务器模型生成站点时定义 ColdFusion 数据库连接。

过程
  1. 输入新连接的名称。

    2. 备注： 不要在该名称中使用任何空格或特殊字符。

  2. 指定要使用的数据源的位置。
    • 如果定义数据源的计算机与 Dreamweaver 所在的计算机相同，请选择“使用此计算机上的 DSN”选项。
    • 如果定义数据源的计算机与 Dreamweaver 所在的计算机不相同，请选择“使用测试服务器上的 DSN”选项。

      • Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  3. 从列表中选择 ColdFusion 数据源。
  4. 如果需要，填写“用户名”和“密码”框。
  5. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    6. 有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    备注： 在 Microsoft Access 中不能创建架构或目录。

  6. 单击“测试”。

    7. Dreamweaver 尝试连接到数据库。如果连接失败，请复查数据源名称、密码和用户名。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  7. 单击“确定”。

    8. 新连接出现在“数据库”面板上。

相关主题

创建常规 UD4 ColdFusion 连接


设置“数据源名称 - 高级”对话框选项

此对话框用于定义 ColdFusion 数据库连接 - 如果您是使用 UltraDev 4 的 ColdFusion 服务器模型来生成站点的 Macintosh 用户，并且要使用 SQL Server 7.0 以外的数据库中的预存过程。

如果要使用 SQL Server 7.0 数据库中的预存过程，请使用常规的“数据源名称”对话框。有关指导请参见创建常规 UD4 ColdFusion 连接。

过程
  1. 输入新连接的名称。

    2. 备注： 不要在该名称中使用任何空格或特殊字符。

  2. 从列表中选择适当的 DSN。
  3. 如果需要，填写“数据源名称 - 高级”对话框中的“用户名”和“密码”框。

    4. 每个 ColdFusion 数据源的用户名和密码信息通常都保存在“ColdFusion 管理员”中。

  4. 选择“使用此计算机上的 JDBC 驱动程序”选项。
  5. 定义 JDBC 连接参数。

    6. 有关更多信息，请参见关于 JDBC 连接参数。

  6. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    7. 有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    备注： 在 Microsoft Access 中不能创建架构或目录。

  7. 单击“测试”。

    8. Dreamweaver 尝试连接到数据库。如果连接失败，请复查 JDBC 连接参数。

  8. 单击“确定”。

    9. 新连接出现在“数据库”面板上。

相关主题

创建高级 UD4 ColdFusion 连接（Macintosh 用户）

上一页


ASP.NET 开发人员的数据库连接

若要将数据库与 ASP.NET 应用程序一起使用，您需要在 Macromedia Dreamweaver MX 中创建数据库连接。本章描述如何创建数据库连接。

备注： 如果您正在开发 Microsoft Active Server Pages (ASP) 应用程序，请参见ASP 开发人员的数据库连接。

本章假定您已经设置了 ASP.NET 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机或您对其具有网络或 FTP 访问权的系统上设置了数据库。

本章包含以下几节：

  • 连接到数据库
  • 编辑或删除数据库连接

若要连接到随 Dreamweaver 一起安装的示例数据库，请参见示例 ASP.NET 站点的设置。若要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。

下一页


连接到数据库

本节描述在 Dreamweaver MX 中开发 ASP.NET 应用程序时如何连接到数据库。

在能够连接到数据库以前，必须为您的数据库获取 OLE DB 提供程序。如果想要连接到 Microsoft SQL Server 数据库，您可以使用 .NET 框架提供的 Managed Data Provider for SQL Server。有关更多信息，请参见为数据库获取 OLE DB 提供程序。

在安装了数据库提供程序之后，您就可以使用它连接到数据库。有关说明，请参见以下几节：

  • 在 Dreamweaver 中创建数据库连接
  • 使用“数据链接属性”创建连接

相关主题

适用于 ASP.NET 的示例 OLE DB 连接参数


为数据库获取 OLE DB 提供程序

ASP.NET 应用程序必须通过 OLE DB 提供程序连接到数据库。该提供程序充当允许 ASP.NET 应用程序与数据库进行通信的解释器。有关 OLE DB 和数据库提供程序作用的更多信息，请参见与数据库相接。

如果想要连接到 Microsoft SQL Server 数据库，您可以使用 .NET 框架随附的 Managed Data Provider for SQL Server。该提供程序已经针对 SQL Server 进行了优化，速度非常快，并且在安装 NET 框架时被同时安装。

如果想要连接到的数据库不是 SQL Server，那么请确保在运行 .NET 框架的计算机上安装了适用于您的数据库的 OLE DB 提供程序。当在计算机上下载并安装了 Microsoft Data Access Components (MDAC) 2.7 软件包后，您已自动安装了适用于 Microsoft Access 的 OLE DB 提供程序。

备注： 在安装 .NET 框架时，强烈建议安装 MDAC 2.7。有关更多信息，请参见安装 ASP.NET 应用程序服务器。

适用于 Oracle9i 和 Oracle8i 数据库的 OLE DB 提供程序可以从 Oracle Web 站点下载（要求注册）。您还可以从第三方供应商处购买 OLE DB 提供程序。

在拥有适用于数据库的提供程序以后，您就可以使用它在 Dreamweaver 中创建数据库连接。请参见在 Dreamweaver 中创建数据库连接。


在 Dreamweaver 中创建数据库连接

在获取适用于您的数据库的 OLE DB 提供程序后（请参见为数据库获取 OLE DB 提供程序），您可以使用它在 Dreamweaver 中创建数据库连接。

另一个选择是使用“Microsoft 数据链接属性”对话框帮助您创建连接。有关说明，请参见使用“数据链接属性”创建连接。

为 ASP.NET 创建数据库连接：
  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 该面板显示为该站点定义的连接。

  2. 单击面板上的 (+) 按钮并从弹出式菜单中选择“OLE DB 连接”或“SQL Server 连接”。

    3. 备注： 只有在希望连接到 Microsoft SQL Server 数据库时，才选择“SQL Server 连接”。

    随即出现“OLE DB 连接”或“SQL Server 连接”对话框。

  3. 完成该对话框并单击“确定”。

    4. 有关更多信息，请参见下列内容：

    • 设置“OLE DB 连接”对话框选项
    • 设置“SQL Server 连接”对话框选项

新连接随即出现在“数据库”面板上。


使用“数据链接属性”创建连接

在为数据库获取 OLE DB 提供程序后（请参见为数据库获取 OLE DB 提供程序），您可以通过使用 Windows 中的“数据链接属性”对话框创建数据库连接。

重要：只有所要使用的 OLE DB 提供程序与 Dreamweaver 安装在同一台 Windows 计算机上时，您才可以使用此方法。

使用“数据链接属性”创建数据库连接：
  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 该面板显示为该站点定义的连接。

  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“OLE DB 连接”。

    3. 随即出现“OLE DB 连接”对话框。

  3. 单击“建立”按钮。

    4. 出现“数据链接属性”对话框。该 Windows 对话框随即显示运行 Dreamweaver 的 Windows 计算机上当前安装的 OLE DB 提供程序。

  4. 完成“数据链接属性”对话框并单击“确定”。

    5. Dreamweaver 随即在“OLE DB 连接”对话框中插入一个连接字符串。

  5. 单击“测试”。

    6. Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍失败，则检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    7. 在“数据库”面板中随即显示新连接。


适用于 ASP.NET 的示例 OLE DB 连接参数

OLE DB 连接字符串合并了 ASP.NET 应用程序连接到数据库所需的全部信息。Dreamweaver 在页的服务器端脚本中插入该字符串，以便应用程序服务器随后进行处理。

Dreamweaver 为您提供了字符串模板以便为 ASP.NET 应用程序创建 OLE DB 连接字符串（请参见在 Dreamweaver 中创建数据库连接）。若要创建连接字符串，请用所需的参数值替换模板中的占位符。本节给出适用于 Microsoft Access 和 SQL Server 数据库的示例参数。

备注： 有关特定于其他数据库的参数值，请参见数据库供应商的文档或向您的系统管理员咨询。

案例 1：假设您在本地计算机上具有 .NET 框架并且想连接到名为 sdSchool.mdb 的 Microsoft Access 数据库，该数据库位于硬盘上的下列文件夹中：c:\Inetpub\wwwroot\SkyDiveSchool\data\sdSchool.mdb。下面是用于创建连接字符串的参数：

Provider=Microsoft.Jet.OLEDB.4.0;

Data Source=c:\Inetpub\wwwroot\SkyDiveSchool\data\sdSchool.mdb;

案例 2： 假设您在远程开发服务器上使用 .NET 框架并且想连接到名为 mtnSchool.mdb 的 Microsoft Access 数据库，该数据库位于服务器上的下列文件夹中：d:\users\tara\projects\MtnDrivingSchool\data\mtnSchool.mdb。下面是用于创建连接字符串的参数：

Provider=Microsoft.Jet.OLEDB.4.0;

Data Source=d:\users\tara\projects\MtnDrivingSchool\data\mtnSchool.mdb;

案例 3：假设您在名为 Savant 的联网开发服务器上使用 .NET 框架并且想连接到在服务器上名为 pubs 的 Microsoft SQL Server 数据库。您的 SQL Server 用户名是“sa”， 不需要密码。如果您使用 Managed Data Provider for SQL Server（即如果您在“数据库”面板上选择“SQL 连接”），则使用下列用于创建连接字符串的参数：

Data Source=Savant;

Initial Catalog=pubs;

User ID=sa;

Password=;


编辑或删除数据库连接

在您创建数据库连接时，Dreamweaver 将连接信息存储在一个文件内，该文件位于站点的本地根文件夹中的 Connections 子文件夹中。Dreamweaver 实际上并没有为您的 ASP.NET 应用程序创建数据库连接，直到您为应用程序中的页面定义了“数据集”（请参见定义记录集）。此时，Dreamweaver 在该文件中写入代码以建立连接，并且在您的页面中插入一条 Include 指令。在运行时，服务器会在您的文档中插入连接代码。

更新连接：
  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 该面板中随即显示连接列表。

  2. 右击连接 (Windows) 或者按住 Control 键并单击连接 (Macintosh)，然后从弹出式菜单中选择“编辑连接”。

    3. 随即显示您用来创建连接的对话框。

  3. 进行更改并单击“确定”。

Dreamweaver 自动更新包括文件，该文件自动更新站点中使用该连接的所有页面。

如果您重命名一个连接，则通过在“绑定”面板中双击记录集并在“数据集”对话框中选择新连接名称，可以更新每个使用旧连接名称的记录集。

删除连接：
  1. 在 Dreamweaver 中打开一个 ASP.NET 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 该面板中随即显示连接列表。

  2. 右击连接 (Windows) 或者按住 Control 键并单击连接 (Macintosh)，然后从弹出式菜单中选择“删除连接”。

    3. 随即显示您用来创建连接的对话框。

  3. 确认您要删除该连接。

    4. 备注： 若要避免在删除连接后收到错误信息，请通过在“绑定”面板中双击记录集的名称并在“数据集”对话框中选择新连接，更新每个使用旧连接的记录集。


参考资料

本节提供在本章中介绍的对话框的有关信息。


设置“OLE DB 连接”对话框选项

此对话框用于为 ASP.NET 连接定义数据库连接。

过程
  1. 输入新连接的名称。

    2. 备注： 在名称中不要使用任何空格或特殊字符。

  2. 输入连接字符串。

    3. 如果您需要连接字符串方面的帮助，请单击“模板”打开“连接字符串模板”对话框，从模板列表中选择 OLE DB 提供程序，然后单击“确定”。

    Dreamweaver 随即将字符串模板插入到“连接字符串”框中。用需要的信息替换字符串中的占位符。有关更多信息，请参见适用于 ASP.NET 的示例 OLE DB 连接参数。

  3. 单击“测试”。

    4. Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍失败，则检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  4. 单击“确定”。

    5. 在“数据库”面板中随即显示新连接。

相关主题

在 Dreamweaver 中创建数据库连接

为数据库获取 OLE DB 提供程序

使用“数据链接属性”创建连接

适用于 ASP.NET 的示例 OLE DB 连接参数


设置“连接字符串模板”对话框选项

该对话框用于在“OLE DB 连接”对话框的“连接字符串”框中插入字符串模板。

过程

选择一个 OLE DB 提供程序并单击“确定”。

相关主题

在 Dreamweaver 中创建数据库连接


设置“SQL Server 连接”对话框选项

该对话框用于通过 .NET 框架提供的 Managed Data Provider for SQL Server 定义到 SQL Server 数据库的连接。

过程
  1. 输入新连接的名称。

    2. 备注： 在名称中不要使用任何空格或特殊字符。

  2. 输入连接字符串。

    3. Dreamweaver 在“连接字符串”框中提供字符串模板。用需要的信息替换字符串中的占位符。有关更多信息，请参见适用于 ASP.NET 的示例 OLE DB 连接参数。

  3. 单击“测试”。

    4. Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍失败，则检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  4. 单击“确定”。

    5. 在“数据库”面板中随即显示新连接。

相关主题

在 Dreamweaver 中创建数据库连接

为数据库获取 OLE DB 提供程序

上一页


ASP 开发人员的数据库连接

若要将数据库与 Microsoft Active Server Page (ASP) 应用程序一起使用，需要在 Macromedia Dreamweaver MX 中创建数据库连接。本章介绍如何创建数据库连接。

备注： 如果您正在开发 ASP.NET 应用程序，请参见ASP.NET 开发人员的数据库连接。

本章假定您已经设置 ASP 应用程序（请参见设置 Web 应用程序）。它还假定您已经在本地计算机（或在对其具有网络或 FTP 访问权的系统）上设置了数据库。

本章包含以下几节：

  • 了解 ASP 数据库连接
  • 创建 DSN 连接
  • 创建非 DSN (DSN-less) 连接
  • 连接到 ISP 上的数据库
  • 编辑或删除数据库连接

若要连接到与 Dreamweaver 一起安装的示例数据库，请参见示例 ASP 站点的设置。若要更为详细地了解数据库和数据库连接，请参见数据库初学者指南。

下一页


了解 ASP 数据库连接

ASP 应用程序必须通过开放式数据库连接 (ODBC) 驱动程序（或对象链接）和嵌入式数据库 (OLE DB) 提供程序连接到数据库。该驱动程序或提供程序用作解释器，能够使 Web 应用程序与数据库进行通信。有关数据库驱动程序的作用的更多信息，请参见与数据库相接。下表显示了一些可以与 Microsoft Access、Microsoft SQL Server 和 Oracle 数据库一起使用的驱动程序：

数据库 | 数据库驱动程序
Microsoft Access | Microsoft Access 驱动程序 (ODBC)
Microsoft SQL Server | Microsoft SQL Server 驱动程序 (ODBC) Microsoft SQL Server 提供程序 (OLE DB)
Oracle | Microsoft Oracle 驱动程序 (ODBC) Oracle Provider for OLE DB

您可以使用数据源名称 (DSN) 或连接字符串连接到数据库。

DSN 是单个词的标识符（如 Acme），它指向数据库并包含连接到该数据库所需的全部信息。您可以在 Windows 中定义 DSN。如果您正在通过安装在 Windows 系统上的 ODBC 驱动程序进行连接，则可以使用 DSN。有关详细指导，请参见创建 DSN 连接。

连接字符串是手动编码的表达式，它标识数据库并列出连接到该数据库所需的信息。例如：

Driver={SQL Server};Server=Socrates;Database=AcmeMktg;
UID=wiley;PWD=roadrunner

如果正在通过以下各项之一进行连接，则必须使用连接字符串：

  • OLE DB 提供程序
  • 未安装在 Windows 系统上的 ODBC 驱动程序

有关详细指导，请参见以下节：

  • 创建非 DSN (DSN-less) 连接
  • 连接到 ISP 上的数据库

备注： 如果您正在通过安装 Windows 系统上的 ODBC 驱动程序建立连接，也可以使用连接字符串，但使用 DSN 要简单一些。


创建 DSN 连接

您可以使用 DSN 在 Web 应用程序和数据库之间建立 ODBC 连接。DSN 是一种名称，它包含使用 ODBC 驱动程序连接到指定数据库所需的全部参数。有关更多信息，请参见了解 DSN。

备注： 由于在 DSN 中只能指定 ODBC 驱动程序，因此如果要使用 OLE DB 提供程序，就必须使用连接字符串。有关更多信息，请参见创建 OLE DB 连接。

您可以在本地或远程 Windows 计算机上定义 DSN。以下主题介绍创建这两种连接的方法：

  • 使用本地 DSN 创建连接
  • 使用远程 DSN 创建连接

相关主题

创建非 DSN (DSN-less) 连接


使用本地 DSN 创建连接

您可以使用本地定义的 DSN 在 Dreamweaver 中创建数据库连接。如果要使用本地 DSN，必须在运行 Dreamweaver 的 Windows 计算机上定义该 DSN。

若要使用本地定义的 DSN 创建数据库连接，请执行以下操作：
  1. 在运行 Dreamweaver 的 Windows 计算机上定义一个 DSN。

    2. 有关指导请参见创建 DSN。

  2. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    3. Dreamweaver 显示为该站点定义的所有连接。

  3. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称 (DSN)”。

    4. 出现“数据源名称 (DSN)”对话框。
    这是所描述的功能的图片。

  4. 输入新连接的名称。

    5. 备注： 不要在该名称中使用任何空格或特殊字符。

  5. 选择该对话框底部的“使用本地 DSN”选项。
  6. 从“数据源名称 (DSN)”弹出式菜单中选择要使用的 DSN。

    7. 如果要使用本地 DSN 但却未定义本地 DSN，请单击“定义”打开 Windows ODBC 数据源管理器。有关指导请参见创建 DSN 连接。

  7. 如果需要，填写“用户名”和“密码”框。
  8. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    9. 有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    备注： 在 Microsoft Access 中不能创建架构或目录。

  9. 单击“测试”。

    10. Dreamweaver 尝试连接到数据库。如果连接失败，请复查该 DSN。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  10. 单击“确定”。

    11. 新连接出现在“数据库”面板上。

相关主题

使用远程 DSN 创建连接

创建非 DSN (DSN-less) 连接


使用远程 DSN 创建连接

您可以使用在远程计算机上定义的 DSN 在 Dreamweaver 中创建数据库连接。如果要使用远程 DSN，则必须在运行应用程序服务器（可能是 IIS）的 Windows 计算机上定义该 DSN。

若要用远程定义的 DSN 创建数据库连接，请执行以下操作：
  1. 在运行应用程序服务器的远程系统上定义一个 DSN。

    2. 有关指导请参见创建 DSN。

  2. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    3. Dreamweaver 显示为该站点定义的所有连接。

  3. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“数据源名称 (DSN)”。

    4. 出现“数据源名称 (DSN)”对话框。

  4. 输入新连接的名称。

    5. 备注： 不要在该名称中使用任何空格或特殊字符。

  5. 选择该对话框底部的“在测试服务器上使用 DSN”选项。

    6. Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器上的 DSN。

  6. 输入 DSN。

    7. 您可以单击“DSN”按钮以连接到服务器并从在它上面定义的 DSN 中进行选择。有关更多信息，请参见设置“选择 ODBC DSN”对话框选项。

  7. 如果需要，填写“用户名”和“密码”框。
  8. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    9. 有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    备注： 在 Microsoft Access 中不能创建架构或目录。

  9. 单击“测试”。

    10. Dreamweaver 尝试连接到数据库。如果连接失败，请复查该 DSN。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  10. 单击“确定”。

    11. 新连接出现在“数据库”面板上。

相关主题

使用本地 DSN 创建连接

创建非 DSN (DSN-less) 连接


创建非 DSN (DSN-less) 连接

您可以使用非 DSN 连接在 Web 应用程序和数据库之间创建 ODBC 或 OLE DB 连接。

您将使用连接字符串来创建该连接。连接字符串包含 Web 应用程序在服务器上连接到数据库所需的全部信息。Dreamweaver 在页的服务器端脚本中插入该字符串，以便让应用程序服务器在随后进行处理。

下面是一个连接字符串示例：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\Academy\curriculum.mdb

下面是另一个示例：

Driver={SQL Server};Server=Socrates;Database=MedCenter;
UID=mwelby;PWD=realme

本节包含以下主题：

  • 用连接字符串创建数据库连接
  • 编写连接字符串
  • 创建 OLE DB 连接


用连接字符串创建数据库连接

您可以使用连接字符串在 Web 应用程序和数据库之间创建数据库连接。

若要创建非 DSN 连接，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. Dreamweaver 显示为该站点定义的所有连接（如果有）。

  2. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“自定义连接字符串”。

    3. “自定义连接字符串”对话框如以下所示。
    这是所描述的功能的图片。

  3. 填写该对话框，然后单击“确定”。

有关更多信息，请参见以下主题：

  • 设置“自定义连接字符串”对话框选项
  • 编写连接字符串

相关主题

创建 OLE DB 连接

使用虚拟路径连接到数据库


编写连接字符串

连接字符串包含 Web 应用程序在服务器上连接到数据库所需的全部信息。Dreamweaver 在页的服务器端脚本中插入该字符串，以便让应用程序服务器在随后进行处理。

对于 Microsoft Access 和 SQL Server 数据库，连接字符串包含由分号分隔的以下参数：

Provider 指定数据库的 OLE DB 提供程序。例如，下面分别是 Access、SQL Server 和 Oracle 数据库的常用 OLE DB 提供程序的参数：

Provider=Microsoft.Jet.OLEDB.4.0;...
Provider=SQLOLEDB;...
Provider=OraOLEDB;...

有关您的 OLE DB 提供程序的参数值，请参见提供程序供应商提供的文档或咨询您的系统管理员。

如果没有包含“Provider”参数，则将使用 ODBC 的默认 OLE DB 提供程序，而且您必须为数据库指定适当的 ODBC 驱动程序。

Driver 指定在没有为数据库指定 OLE DB 提供程序时所使用的 ODBC 驱动程序。

Server 指定承载 SQL Server 数据库的服务器 - 如果Web 应用程序在另一台服务器上运行。

Database 为 SQL Server 数据库的名称。

DBQ 是指向基于文件的数据库（如在 Microsoft Access 中创建的数据库）的路径。该路径是在承载数据库文件的服务器上的路径。

UID 指定用户名。

PWD 指定用户密码。

DSN 为数据源名称（如果已使用）。根据您在服务器上定义 DSN 的方式，可以省略连接字符串的其他参数。例如，如果在创建 DSN（请参见创建 DSN）时定义其他参数，则 DSN=Results 可以是有效的连接字符串。

对于其他类型的数据库，连接字符串可能不使用上面列出的参数，或者可能对于这些参数有不同的名称或用途。有关更多信息，请参见数据库供应商提供的文档或咨询您的管理员。

下面是一个连接字符串示例，它将创建与名为 trees.mdb 的 Access 数据库的 ODBC 连接：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\Research\trees.mdb

下面是一个连接字符串示例，它将创建与位于 Gojira 服务器上名为 Mothra 的 SQL Server 数据库的 OLE DB 连接：

Provider=SQLOLEDB;Server=Gojira;Database=Mothra;UID=jsmith;
PWD=orlando8

相关主题

用连接字符串创建数据库连接

创建 OLE DB 连接

使用虚拟路径连接到数据库


创建 OLE DB 连接

您可以使用 OLE DB 提供程序与数据库进行通信。通过创建直接的 OLE DB 连接，可以消除 Web 应用程序和数据库之间的 ODBC 层，从而提高连接的速度。通过使用特定于数据库的 OLE DB 提供程序，可以消除 ODBC 中间层。

如果没有为数据库指定 OLE DB 提供程序，ASP 会使用 ODBC 驱动程序的默认 OLE DB 提供程序与 ODBC 驱动程序进行通信，而后者又与数据库进行通信。

OLE DB 仅在 Windows NT、2000 或 XP 上可用。

对于不同的数据库存在不同的 OLE DB 提供程序。您可以通过下载 Microsoft Data Access Components (MDAC) 2.5 和 2.6 软件包并将其安装在运行 IIS 或 PWS 的 Windows 计算机上（如果可行）来获取用于 Microsoft Access 和 SQL Server 的 OLE DB 提供程序。MDAC 软件包可以从 Microsoft Web 站点。

备注： 安装 MDAC 2.6 之前应确保 MDAC 2.5 已安装。

用于 Oracle9i 和 Oracle8i 数据库的 OLE DB 提供程序可以从 Oracle Web 站点（要求注册）。

在 Dreamweaver MX 中，可以通过在连接字符串中包含 Provider 参数来创建 OLE DB 连接。例如，下面分别是 Access、SQL Server 和 Oracle 数据库的常用 OLE DB 提供程序的参数：

Provider=Microsoft.Jet.OLEDB.4.0;...
Provider=SQLOLEDB;...
Provider=OraOLEDB;...

有关您的 OLE DB 提供程序的参数值，请参见提供程序供应商提供的文档或咨询您的系统管理员。

相关主题

编写连接字符串

用连接字符串创建数据库连接


连接到 ISP 上的数据库

如果您是通过商业 Internet 服务提供商 (ISP) 来工作的 ASP 开发人员，则通常不知道您上载的文件（包括数据库文件）的物理路径。如果您的 ISP 没有为您定义 DSN 或者迟迟没有这样做，则必须找到另外一种方法来创建与数据库文件的连接。一种替代方法是创建与数据库文件的非 DSN 连接，但只有当知道数据库文件在 ISP 的服务器上的物理路径时，才能定义这样的连接。

本节介绍如何使用 ASP 服务器对象的 MapPath 方法获取数据库文件在服务器上的物理路径。本节包括以下主题：

  • 了解物理和虚拟路径
  • 用虚拟路径查找文件的物理路径
  • 使用虚拟路径连接到数据库

备注： 只有当您的数据库基于文件（如 Microsoft Access 数据库，它将数据存储在 .mdb 文件中）时，本章讨论的方法才适用。


了解物理和虚拟路径

当使用 Dreamweaver 将文件上载到远程服务器后，这些文件驻留在服务器本地目录树中的某一个文件夹。例如，在运行 Microsoft IIS 的服务器上，主页的路径可能如下所示：

c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm

众所周知，此路径是文件的物理路径。

但是，用来打开文件的 URL 并不使用物理路径。它使用服务器名称或域名，后接虚拟路径，如以下示例所示：

www.plutoserve.com/jsmith/index.htm

虚拟路径 /jsmith/index.htm 代替了物理路径 c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm。

相关主题

用虚拟路径查找文件的物理路径

使用虚拟路径连接到数据库


用虚拟路径查找文件的物理路径

如果您通过 ISP 来工作，则不会总知道您上载的文件的物理路径。ISP 通常会为您提供一个 FTP 主机（可能是主机目录）以及一个登录名和密码。ISP 还指定一个 URL，用于在 Internet 上查看您的网页，如 www.plutoserve.com/jsmith/。

如果您知道该 URL，就可以获取该文件的虚拟路径 - 它是 URL 中服务器名称或域名后的路径。一旦知道虚拟路径，即可使用 MapPath 方法获取文件在服务器上的物理路径。

此外，MapPath 方法将虚拟路径当作参数，并返回文件的物理路径和文件名。下面是该方法的语法：

Server.MapPath("/virtualpath")

假定一个文件的虚拟路径是 /jsmith/index.htm，那么以下表达式将返回它的物理路径：

Server.MapPath("/jsmith/index.htm")

您可以用 MapPath 方法进行如下试验。

  1. 在 Dreamweaver 中打开一个 ASP 页并切换到代码视图（“查看”>“代码”）。
  2. 在该页的 HTML 代码中输入以下表达式。
    3. <%Response.Write(stringvariable)%>
  3. 使用 MapPath 方法获取 stringvariable 参数的值。

    4. 下面是一个示例：

    <% Response.Write(Server.MapPath("/jsmith/index.htm")) %>
  4. 切换到设计视图（“查看”>“设计”）并启用“活动数据”（“查看”>“活动数据”）以查看该页。

    5. 该页显示文件在应用程序服务器上的物理路径。当使用本节讨论的示例时，该页将显示以下物理路径：

    c:\Inetpub\wwwroot\accounts\users\jsmith\index.htm

有关 MapPath 方法的更多信息，请查询 Microsoft IIS 或 PWS 附带的联机文档。

相关主题

了解物理和虚拟路径

使用虚拟路径连接到数据库


使用虚拟路径连接到数据库

若要将非 DSN 连接字符串写入位于远程服务器上的数据库文件，您必须知道该文件的物理路径。例如，下面是一个用于 Microsoft Access 的典型非 DSN 连接字符串：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=c:\Inetpub\wwwroot\accounts\users\jsmith\data\statistics.mdb

如果您不知道文件在远程服务器上的物理路径，则可以通过在连接字符串中使用 MapPath 方法来获取该路径。

若要用 MapPath 方法创建非 DSN 连接，请执行以下操作：
  1. 将数据库文件上载到远程服务器。

    2. 记下它的虚拟路径，例如 /jsmith/data/statistics.mdb。

  2. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    3. Dreamweaver 显示为该站点定义的所有连接。

  3. 单击该面板上的加号 (+) 按钮，然后从弹出式菜单中选择“自定义连接字符串”。
  4. 输入新连接的名称。

    5. 备注： 不要在该名称中使用任何空格或特殊字符。

  5. 输入连接字符串并使用 MapPath 方法提供 DBQ 参数。

    6. 假定 Microsoft Access 数据库的虚拟路径为 /jsmith/data/statistics.mdb。如果使用 VBScript 作为脚本撰写语言，连接字符串可表示如下：

    “Driver={Microsoft Access Driver (*.mdb)};DBQ=” & Server.MapPath
("/jsmith/data/statistics.mdb")

    & 号用于串联（组合）两个字符串。第一个字符串用引号引起来，第二个字符串是由 Server.MapPath 表达式返回的。当两个字符串组合起来时，将创建以下字符串：

    Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\accounts\users\jsmith\data\statistics.mdb

    如果使用 JavaScript，表达式将基本相同，只是要使用加号 (+) 而不是 & 号来串联两个字符串：

    “Driver={Microsoft Access Driver (*.mdb)};DBQ=” + Server.MapPath
("/jsmith/data/statistics.mdb")
  6. 选择“在测试服务器上使用驱动程序”选项。

    7. Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  7. 单击“测试”。

    8. Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。

    如果连接仍然失败，请与您的 ISP 联系，确保远程服务器上已经安装了您在连接字符串中指定的数据库驱动程序。另外还需要检查 ISP 是否具有该驱动程序的最新版本。例如，在 Microsoft Access 2000 中创建的数据库将无法与 Microsoft Access Driver 3.5 一起工作。您需要 Microsoft Access 驱动程序 4.0 或更高版本。

  8. 单击“确定”。

    9. 新连接出现在“数据库”面板上。

  9. 更新现有动态页的数据库连接，并将新连接用于您新生成的任何页。

    10. 若要更新动态页的连接，在 Dreamweaver 中打开该页，在“绑定”面板或“服务器行为”面板中双击记录集名称，然后从“连接”弹出式菜单中选择您刚创建的连接。

相关主题

了解物理和虚拟路径

用虚拟路径查找文件的物理路径

创建非 DSN (DSN-less) 连接


编辑或删除数据库连接

当您创建数据库连接时，Dreamweaver 会将连接信息存储到站点本地根文件夹下“连接”子文件夹中的一个文件。Dreamweaver 实际上不会为 ASP 应用程序创建数据库连接，直到您在该应用程序中为页定义了记录集（请参见定义记录集）。此时，Dreamweaver 会在文件中写入用来建立连接的代码，并且在您的页面中插入 include 指令。在运行时，服务器会在您的文档中插入连接代码。

若要更新连接，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 连接列表出现在该面板上。

  2. 右击 (Windows) 或按住 Ctrl 并单击 (Macintosh) 该连接，然后从弹出式菜单中选择“编辑连接”，如下所示。
    这是所描述的功能的图片。

    3. 出现您曾用来创建连接的对话框。

  3. 做出更改，然后单击“确定”。

Dreamweaver 自动更新该 include（包含）文件，这将更新站点中使用此连接的所有页。

若要删除连接，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ASP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 连接列表出现在该面板上。

  2. 右击 (Windows) 或按住 Ctrl 并单击 (Macintosh) 该连接，然后从弹出式菜单中选择“删除连接”。

    3. 出现您曾用来创建连接的对话框。

  3. 确认您要删除该连接。

    4. 备注： 若要避免在删除连接后出错，请在“绑定”面板中双击记录集的名称并选择新的连接，以更新每个使用旧连接的记录集。


设置“数据源名称 (DSN)”对话框选项

此对话框用于使用 DSN 为 ASP 应用程序创建数据库连接。

任务

  • 使用本地 DSN 创建连接
  • 使用远程 DSN 创建连接

相关主题

创建 DSN


设置“选择 ODBC DSN”对话框选项

此对话框用于在创建 ASP 数据库连接时选择远程服务器上的 DSN。

备注： Dreamweaver 可以只检索用 Windows ODBC 数据源管理器创建的服务器 DSN。

过程
  1. 选择指向所需数据库的 DSN。
  2. 单击“确定”。

相关主题

使用远程 DSN 创建连接

创建 DSN


设置“自定义连接字符串”对话框选项

此对话框用于通过连接字符串定义非 DSN 数据库连接。

过程
  1. 在第一个框中输入新连接的名称。

    2. 备注： 不要在该名称中使用任何空格或特殊字符。

  2. 在第二个框中输入与数据库的连接字符串。

    3. 如果没有在连接字符串中指定 OLE DB 提供程序（即，没有包含 Provider 参数），ASP 将自动使用用于 ODBC 驱动程序的 OLE DB 提供程序。这种情况下，必须为数据库指定适当的 ODBC 驱动程序。

    如果您的站点由 ISP 承载，而您不知道数据库的完整路径，请在连接字符串中使用 ASP 服务器对象的 MapPath 方法。有关更多信息，请参见连接到 ISP 上的数据库。

  3. 如果在连接字符串中指定的数据库驱动程序没有与 Dreamweaver 安装在同一台计算机上，请选择“在测试服务器上使用驱动程序”选项。

    4. Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  4. 如果需要，请单击“高级”并输入一个架构或目录名称，以限制 Dreamweaver 在设计时所检索的数据库项数。

    5. 有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    备注： 在 Microsoft Access 中不能创建架构或目录。

  5. 单击“测试”。

    6. Dreamweaver 尝试连接到数据库。如果连接失败，请复查连接字符串。如果连接仍然失败，请检查 Dreamweaver 用来处理动态页的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    7. 新连接出现在“数据库”面板上。

相关主题

创建非 DSN (DSN-less) 连接

编写连接字符串

创建 OLE DB 连接

使用虚拟路径连接到数据库


设置“连接”对话框选项

此对话框用于管理站点的数据库连接。具体而言，您可以添加、编辑、删除或复制数据库连接。

备注： 使用“数据库”面板可以执行相同的任务。

过程
  • 若要添加新连接，请单击“新建”。
  • 若要删除现有连接，请在列表中选择连接，然后单击“删除”。
  • 若要更新现有连接，请在列表中选择连接，然后单击“编辑”。

若要复制现有连接，请在列表中选择连接，然后单击“复制”。

上一页


用于 JSP 开发人员的数据库连接

若要将数据库与 JavaServer Page (JSP) 应用程序一起使用，您需要在 Macromedia Dreamweaver MX 中创建数据库连接。本章介绍如何创建该连接。

本章假设您已设置了 JSP 应用程序（请参见设置 Web 应用程序），并且还假设您已在您的本地计算机上或者系统上（您对该系统具有网络或 FTP 访问权限）设置了数据库。

本章包含以下几节：

  • 理解 JSP 连接
  • 连接到数据库
  • 通过 ODBC 驱动程序连接
  • 编辑或删除数据库连接

若要连接到随 Dreamweaver 一起安装的示例数据库，请参见示例 JSP 站点的设置. 若要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。

下一页


理解 JSP 连接

JSP 应用程序必须通过 JDBC 驱动程序连接到某一数据库。JDBC 驱动程序充当允许 JSP 应用程序与数据库进行通信的解释器。有关 JDBC 和数据库驱动程序作用的更多信息，请参见与数据库相接。

您必须指定某些参数值以通过您的 JDBC 驱动程序进行连接。有关更多信息，请参见关于 JDBC 连接参数。有关特定于您的驱动程序的参数值，请参见驱动程序供应商的文档或向您的系统管理员咨询。

如果您具有 JDBC-ODBC Bridge 驱动程序，您还可以使用 ODBC 驱动程序（因此也可以使用 Windows DSN）。有关更多信息，请参见通过 ODBC 驱动程序连接。


连接到数据库

本节描述在 Dreamweaver MX 中开发 JSP 应用程序时如何连接到数据库。

本节假设 JSP 应用程序服务器正在本地或远程计算机上运行。（对于大多数 Macintosh 用户和许多开发小组而言，JSP 应用程序服务器在单独的开发服务器上运行。）有关更多信息，请参见设置 Web 应用程序。

在能够连接到数据库前，必须为您的数据库获取 JDBC 驱动程序。有关更多信息，请参见为您的数据库获取 JDBC 驱动程序。

在您安装了数据库驱动程序后，就可以通过该驱动程序连接到数据库。有关说明，请参见创建用于 JSP 的数据库连接。


为您的数据库获取 JDBC 驱动程序

在您尝试创建数据库连接前，确保已具有用于您的数据库的 JDBC 驱动程序。一些常见的 JDBC 驱动程序包括 Oracle Thin JDBC 驱动程序、Oracle Java Driver 和用于 Microsoft SQL Server 的 i-net JDBC 驱动程序。

数据库系统供应商（如 Oracle）通常随其系统一起提供驱动程序。您还可以从第三方供应商处购买驱动程序。例如，您可以从 i-net software 获取用于 Microsoft SQL Server 的 JDBC 驱动程序。

Sun 也在其 Web 站点上提供 JDBC 驱动程序及其供应商的可搜索数据库。

一旦具有用于您的数据库的 JDBC 驱动程序后，就可以创建数据库连接。有关说明，请参见创建用于 JSP 的数据库连接。

相关主题

安装 Sun JDBC-ODBC桥驱动程序

与数据库相接


创建用于 JSP 的数据库连接

在运行应用程序服务器的计算机上安装了用于您的数据库的适当 JDBC 驱动程序后（请参见为您的数据库获取 JDBC 驱动程序），就可以在 Dreamweaver 中创建数据库连接。

若要创建用于 JSP 的数据库连接，请执行以下操作：
  1. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. Dreamweaver 显示为该站点定义的连接。

  2. 单击加号 (+) 按钮并从弹出式菜单中选择您的驱动程序。

    3. 如果没有列出您的驱动程序，请选择“自定义 JDBC 连接”。

    随即显示一个连接对话框。

  3. 在该连接对话框中输入连接参数。

    4. 有关更多信息，请参见关于 JDBC 连接参数。

  4. 指定您要使用的 JDBC 驱动程序的位置。
    • 如果您的 JDBC 驱动程序安装在与 Dreamweaver 相同的计算机上，则选择“在此计算机上使用驱动程序”选项。
    • 如果您的 JDBC 驱动程序没有安装在与 Dreamweaver 相同的计算机上，则选择“在测试服务器上使用驱动程序”选项。

      • Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  5. 单击“测试”。

    6. Dreamweaver 尝试连接到数据库。如果连接失败，则仔细检查连接参数。如果连接仍失败，则检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

在“数据库”面板中随即显示新连接。


关于 JDBC 连接参数

JDBC 连接通常包含四个参数：驱动程序、用户名、密码和 URL（指定数据库的位置）。通常，驱动程序参数和 URL 参数的值取决于驱动程序。

本节以 Oracle Thin JDBC 驱动程序为例，演示如何在 Dreamweaver 中定义连接参数。有关其他驱动程序的连接参数，请查询驱动程序供应商的文档。

Oracle Thin JDBC 驱动程序支持 Oracle 数据库。如果您想要使用此驱动程序连接到您的 Oracle 数据库，请单击“数据库”面板上的加号 (+) 按钮并从弹出式菜单中选择 Oracle Thin Driver 驱动程序(Oracle) 。随即显示以下部分已完成的对话框：

输入连接名称并用有效的连接参数替代占位符（在方括号中）。对于 [hostname] 占位符，输入系统管理员分配给数据库服务器的 IP 地址或名称。对于 [sid] 占位符，输入数据库系统标识。如果您在同一系统上运行多个 Oracle 数据库，则使用 SID 来区分这些数据库。

例如，如果您的服务器名为 Aristotle，数据库端口为 1521，并且您在该服务器上定义了名为 patients 的数据库 SID，则您可以在 Dreamweaver 中输入以下参数值：


通过 ODBC 驱动程序连接

尽管 JSP 应用程序必须通过 JDBC 驱动程序与数据库通信，但如果您具有 JDBC-ODBC 桥驱动程序，则 JSP 应用程序可以通过 ODBC 驱动程序通信。通过 ODBC 驱动程序可以使用 Windows DSN，这简化了创建连接的任务。JDBC-ODBC 桥驱动程序充当 JSP 应用程序（与 JDBC 通信）和 ODBC 驱动程序（与 ODBC 通信）之间的解释器。此通信方式使您的 JSP 应用程序可与数据库通信。

此类型的连接有两个主要优点。首先，您可以使用 Microsoft 提供的免费 ODBC 驱动程序。其次，您可以使用 DSN 简化创建连接的任务。

要通过 ODBC 驱动程序进行连接，您必须满足以下条件：

  • 您的 JSP 应用程序服务器必须运行在 Windows 计算机上。
  • 用于您的数据库的 ODBC 驱动程序必须安装在运行应用程序服务器的 Windows 计算机上。有关更多信息，请参见检查 ODBC 驱动程序。
  • JDBC-ODBC 桥驱动程序必须安装在运行应用程序服务器的 Windows 计算机上。有关更多信息，请参见安装 Sun JDBC-ODBC桥驱动程序。

如果您满足了这些要求，就可以通过 ODBC 驱动程序进行连接了。有关说明，请参见创建 ODBC 连接。


检查 ODBC 驱动程序

确保用于您的数据库的 ODBC 驱动程序安装在运行 JSP 应用程序服务器的 Windows 计算机上。若要确定是否已安装 ODBC 驱动程序，请参见查看安装在 Windows 系统上的 ODBC 驱动程序。如果尚未安装适当的驱动程序，则您可以在运行 JSP 应用程序服务器的计算机上下载和安装 Microsoft Data Access Components (MDAC) 2.5 和 2.6 程序包。您可以免费从 Microsoft Web 站点下载 MDAC。这些程序包包含 Microsoft 提供的最新 ODBC 驱动程序。

备注： 在安装 MDAC 2.6 前安装 MDAC 2.5

如果您具有用于您的数据库的 ODBC 驱动程序，则接下来您可以安装 JDBC-ODBC 驱动程序。有关说明，请参见安装 Sun JDBC-ODBC桥驱动程序。


安装 Sun JDBC-ODBC桥驱动程序

若要通过 ODBC 驱动程序进行连接，您必须在运行 JSP 应用程序服务器的 Windows 计算机上安装 Sun JDBC-ODBC 桥驱动程序。该驱动程序和用于 Windows 的 Sun Java 2 SDK 标准版一起提供。

若要确定您是否已具有附带该驱动程序的 Java 2 SDK，请检查您的硬盘上是否有 c:\jdk1.2.2 或 c:\jdk1.3 文件夹。

备注： Java 1.2.2 和 1.3 同于 Java 2。

如果没有 SDK，您可以从 Sun Web 站点下载 SDK 并进行安装。在安装 SDK 时系统将自动安装驱动程序。

尽管 Sun JDBC-ODBC Bridge 驱动程序用于开发低端数据库系统（例如 Microsoft Access）绰绰有余，但它不适用于进行生产。例如，该驱动程序一次只让一个 JSP 页连接到数据库（换言之，它不支持多个线程并发使用）。有关驱动程序限制的更多信息，请参见 Macromedia 支持中心上的文章 12409。

在安装了桥驱动程序后，您接下来就可以创建数据库连接了。有关说明，请参见创建 ODBC 连接。


创建 ODBC 连接

在通过 ODBC 驱动程序进行连接前，请确保在运行 JSP 应用程序服务器的 Windows 计算机上安装了适当的 ODBC 驱动程序和 Sun JDBC-ODBC 桥驱动程序（请参见检查 ODBC 驱动程序和安装 Sun JDBC-ODBC桥驱动程序）。

若要在 JSP 中通过 ODBC 驱动程序进行连接，请执行以下操作：
  1. 在承载您的应用程序服务器的 Windows 系统上定义 DSN。

    2. 有关说明，请参见创建 DSN。

  2. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    3. 该面板显示为该站点定义的连接。

  3. 在该面板上单击加号 (+) 按钮并从弹出式菜单中选择“Sun JDBC-ODBC 驱动程序（ODBC 数据库）”。

    4. “Sun JDBC-ODBC 驱动程序（ODBC 数据库）”对话框随即显示。

  4. 输入新连接的名称。

    5. 备注： 在名称中不要使用任何空格或特殊字符。

  5. 用您在第 1 步中定义的 DSN 替代“URL”框中的 [odbc dsn] 占位符。

    6. “URL”框应类似于：

    jdbc:odbc:myDSN
  6. 指定用来访问数据库的用户名和密码。

    7. 如果您不需要用户名或密码，则保留这些框为空。例如，如果您的 DSN 名为 Acme 并且您不需要用户名或密码来访问数据库，则输入以下参数值：

    驱动程序:sun.jdbc.odbc.JdbcOdbcDriver

    URL:jdbc:odbc:Acme

    用户名:

    密码:

  7. 指定 JDBC-ODBC Bridge 驱动程序的位置。
    • 如果该驱动程序安装在与 Dreamweaver 相同的计算机上，则选择“在此计算机上使用驱动程序”选项。
    • 如果该驱动程序没有安装在与 Dreamweaver 相同的计算机上，则选择“在测试服务器上使用驱动程序”选项。

      • Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  8. 单击“测试”。

    9. Dreamweaver 尝试连接到数据库。如果连接失败，则仔细检查 DSN 和其他连接参数。如果连接仍失败，则检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  9. 单击“确定”。

    10. 在“数据库”面板中随即显示新连接。


编辑或删除数据库连接

在您创建数据库连接时，Dreamweaver 将连接信息存储在一个文件内，该文件位于站点的本地根文件夹的 Connections 子文件夹中。在您为应用程序中的页面定义记录集前，Dreamweaver 实际上没有为您的 JSP 应用程序创建数据库连接（请参见定义记录集）。此时，Dreamweaver 在文件中写入用来建立连接的代码，并且在您的页面中插入 include 指令。运行时，服务器将连接代码插入您的文档中。

若要更新连接，请执行以下操作：
  1. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 在面板中随即显示连接列表。

  2. 右击连接 (Windows) 或在按住 Control 键的同时单击连接 (Macintosh)，然后从弹出式菜单中选择“编辑连接”。

    3. 随即显示您用来创建连接的对话框。

  3. 进行更改并单击“确定”。

Dreamweaver 自动更新 include（包含）文件，该文件在站点中更新使用该连接的所有页面。

如果您重命名一个连接，则通过在“绑定”面板中双击记录集并在“记录集”对话框中选择新连接名称，更新使用旧连接名称的每一记录集。

若要删除一个连接，请执行以下操作：
  1. 在 Dreamweaver 中打开 JSP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 在面板中随即显示连接列表。

  2. 右击连接 (Windows) 或在按住 Control 键的同时单击连接 (Macintosh)，然后从弹出式菜单中选择“删除连接”。

    3. 随即显示您用来创建连接的对话框。

  3. 确认您要删除该连接。

若要避免在删除一个连接后收到错误信息，请通过在“绑定”面板中双击记录集的名称并在“记录集”对话框中选择新连接，更新使用旧连接的每一记录集。


设置 JSP 连接对话框选项

此对话框用于为 JSP 应用程序创建数据库连接。

过程
  1. 输入连接的名称。

    2. 备注： 在名称中不要使用任何空格或特殊字符。

  2. 输入驱动程序的连接参数。

    3. 有关示例，请参见关于 JDBC 连接参数。有关特定于驱动程序的要求，请参见驱动程序供应商的文档或向您的系统管理员咨询。

  3. 指定您要使用的 JDBC 驱动程序的位置。
    • 如果您的 JDBC 驱动程序安装在与 Dreamweaver 相同的计算机上，则选择“在此计算机上使用驱动程序”选项。
    • 如果您的 JDBC 驱动程序不安装在与 Dreamweaver 相同的计算机上，则选择“在测试服务器上使用驱动程序”选项。

      • 备注： Macintosh 用户可以忽略此步骤，因为所有数据库连接均使用应用程序服务器。

  4. 如果需要，可以通过单击“高级”并输入架构或目录名称，在设计时限制 Dreamweaver 检索的数据库项的数目。

    5. 有关更多信息，请参见限制显示在 Dreamweaver 中的数据库信息。

    备注： 您不能在 Microsoft Access 中创建架构或目录。

  5. 单击“测试”。

    6. Dreamweaver 尝试连接到数据库。如果连接失败，则仔细检查 JDBC 连接参数。如果连接仍失败，则检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    7. 在“数据库”面板中随即显示新连接。

相关主题

为您的数据库获取 JDBC 驱动程序

关于 JDBC 连接参数

通过 ODBC 驱动程序连接

上一页


适用于 PHP 开发人员的数据库连接

若要将数据库与 PHP 应用程序一起使用，需要在 Macromedia Dreamweaver MX 中创建数据库连接。本章将描述如何创建数据库连接。

对于 PHP 开发，Dreamweaver 仅支持 MySQL 数据库系统。不支持其他数据库系统，如 Microsoft Access 或 Oracle。MySQL 是可以从 Internet 免费下载并进行非商业应用的开放源码软件。有关更多信息，请参见 MySQL Web 站点。

本章假设您已设置了 PHP 应用程序（请参见设置 Web 应用程序）。还假定已在本地计算机或对其具有网络或 FTP 访问权的系统上设置了 MySQL 数据库。

本章包含以下几节：

  • 连接到数据库
  • 编辑或删除数据库连接

若要连接到 Dreamweaver 提供的示例数据库，请参见示例 PHP 站点的设置。若要了解有关数据库和数据库连接的更多信息，请参见数据库初学者指南。

下一页


连接到数据库

本节描述在 Dreamweaver 中开发 PHP 应用程序时如何连接到数据库。假定您有一个或多个 MySQL 数据库并已启动 MySQL 服务器。

创建到 MySQL 数据库的数据库连接：
  1. 在 Dreamweaver 中打开一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。
  2. 单击面板上的加号 (+) 按钮并从弹出式菜单中选择“MySQL 连接”。

    3. “MySQL 连接”对话框随即出现。

  3. 完成该对话框并单击“确定”。

    4. 有关更多信息，请参见设置“MySQL 连接”对话框选项。

新连接即出现在“数据库”面板中。


编辑或删除数据库连接

创建数据库连接时，Dreamweaver 将连接信息存储在一个文件内，该文件位于站点的本地根文件夹的 Connections 子文件夹中。直到您为应用程序中的页面定义记录集时，Dreamweaver 才实际上为 PHP 应用程序创建数据库连接（请参见定义记录集）。此时，Dreamweaver 在文件中写入用以建立连接的代码，并在页面中插入一个 include 指令。运行时，服务器会在您的文档中插入连接代码。

更新连接：
  1. 在 Dreamweaver 中打开一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 连接列表随即出现在面板中。

  2. 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 连接，然后从弹出式菜单中选择“编辑连接”。

    3. 用以创建连接的对话框随即出现。

  3. 进行更改并单击“确定”。

Dreamweaver 自动更新 include（包含）文件，该文件更新站点中所有使用该连接的页面。

删除连接：
  1. 在 Dreamweaver 中打开一个 PHP 页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 连接列表随即出现在面板中。

  2. 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 连接，然后从弹出式菜单中选择“删除连接”。

    3. 用以创建连接的对话框随即出现。

  3. 确认您是否要删除该连接。

若要避免在删除连接后出现错误，请更新每个使用旧连接的记录集，方法是在“绑定”面板中双击记录集的名称，然后在“记录集”对话框中选择一个新连接。


设置“MySQL 连接”对话框选项

此对话框用于为 PHP 应用程序创建数据库连接。

完成此对话框之前，请确保已启动 MySQL 服务器。

过程
  1. 输入新连接的名称。

    2. 备注： 在名称中不要使用任何空格或特殊字符。

  2. 在“MySQL 服务器”框中，指定承载 MySQL 的计算机。

    3. 输入 IP 地址或服务器名称。如果 MySQL 与 PHP 运行在同一台计算机上，则可输入 localhost。

  3. 输入您的 MySQL 用户名和密码。
  4. 在“数据库”框中输入数据库名称，或者单击“选择”并从 MySQL 数据库列表中选择数据库。
  5. 单击“测试”。

    6. Dreamweaver 尝试连接到数据库。如果连接失败，请复查服务器名称、用户名和密码。如果连接仍失败，请检查 Dreamweaver 用来处理动态页面的文件夹的设置（请参见指定可在哪里处理动态页）。

  6. 单击“确定”。

    7. 新连接随即出现在“数据库”面板中。

相关主题

连接到数据库


设置“选择数据库”对话框选项

此对话框用于在创建 PHP 数据库连接时从 MySQL 数据库系统中选择一个数据库。

过程

从列表中选择一个数据库并单击“确定”。

相关主题

设置“MySQL 连接”对话框选项

上一页


使用页代码

使用 Dreamweaver 中的高级编码工具创建或修改页面。

此部分包含以下各章：

  • 设置您的编码环境
  • Dreamweaver 中的编码
  • 优化和调试代码
  • 在设计视图中编辑代码


设置您的编码环境

您可以在 Macromedia Dreamweaver MX 中修改编码环境使之适合您的工作方式。例如，您可以更改查看代码的方式、设置不同的键盘快捷方式、或导入并使用您喜欢的标签库。

本章包含以下主题：

  • 查看您的代码
  • 设置查看参数
  • 设置编码参数
  • 自定义键盘快捷方式
  • 设置编码参数
  • 设置“验证程序”参数
  • 管理标签库
  • 将自定义标签导入 Dreamweaver
  • 将外部 HTML 编辑器用于 Dreamweaver
下一页


查看您的代码

您可以通过多种方式查看当前文档的源代码：您可以通过打开“代码”视图在“文档”窗口中显示源代码，可以拆分“文档”窗口同时显示页面和关联的代码，或者可以在代码检查器（一个单独的编码窗口）中工作。

备注： “代码”视图和代码检查器具有相同的功能。

本节包含更改代码查看方式的说明。

若要在“文档”窗口中查看代码，请执行以下操作：

选择“查看”>“代码”。

若要在单独的窗口中查看代码，请执行以下操作：

选择“窗口”>“其他”>“代码检查器”。

若要在“文档”窗口中同时进行编码和以可视化的方式编辑页面，请执行以下操作：
  1. 选择“查看”>“代码和设计”。

    2. 代码显示在顶部窗格中，页面显示在底部窗格中。

  2. 若要在顶部显示页面，请选择“查看”>“在顶部查看设计视图”。
  3. 若要调整“文档”窗口中窗格的大小，请将拆分条拖到所需的位置。

    4. 拆分条位于两个窗格之间。

当在“设计”视图中进行更改时，“代码”视图自动更新。但是，在“代码”视图中进行更改之后，您必须通过单击“设计”视图并按 F5 键手动更新“设计”视图中的文档。


设置查看参数

您可以通过“查看”>“代码视图选项”菜单来设置文本换行、显示代码行号、高亮显示无效 HTML 代码、设置代码元素的语法颜色及设置缩进。

若要设置“代码”视图和代码检查器的选项，请执行以下操作：
  1. 在“代码”视图或代码检查器中至少显示一页。
  2. 选择“查看”>“代码视图选项”。

    3. 即会出现一个弹出式菜单，其中每个已设置的选项旁边都有一个选中标记。

  3. 从菜单中选择以下任意选项：
    • 自动换行对代码进行换行，以便您查看代码时无需水平滚动。此选项不插入换行符；它只是使代码更易于查看。
    • 行号 在代码的旁边显示行号。
    • 高亮显示无效 HTML使 Dreamweaver 以黄色高亮显示浏览器不支持的任何无效 HTML。当选择一个无效的标签时，属性检查器显示有关如何更正该错误的信息。
    • 语法颜色打开和关闭代码颜色。若要更改颜色方案，请参见设置“代码颜色”参数。
    • 自动缩进当您在编写代码过程中按回车键时使代码自动缩进。若要更改缩进间距或自动缩进的标签，请参见设置代码格式参数。

      • 如果选择已选中的选项，则关闭该选项。否则，便是设置了该选项。


设置编码参数

您可以在 Dreamweaver 中设置以下编码参数：

  • “代码格式设置”参数选择确定常见的代码格式设置选项，例如行长度和缩进。请参见设置代码格式参数。您还可以对现有的 HTML 文档应用新格式设置参数选择。请参见将新格式设置参数应用于现有的文档。
  • “代码提示”参数选择允许您启用或禁用“代码提示”功能，并允许您自定义所显示的提示。当在“代码”视图中键入文本时，“代码提示”功能为您提供内联帮助。例如，如果您键入一个起始的标签括号 (<)，则会出现一个菜单列出可能的标签。您可以从菜单上列出的提示中选择一个标签并按回车键将其自动输入，而不用手动键入标签的其余部分。请参见设置“代码提示”参数。
  • “代码改写”参数选择确定当打开 HTML 或脚本文档时 Dreamweaver 对您的代码进行哪些（如果存在）更改。请参见设置“代码改写”参数。
  • “代码颜色”参数选择允许您为代码元素（例如标签、注释和脚本）设置特殊的格式设置和语法颜色。请参见设置“代码颜色”参数。

若要设置高级参数选择，请使用标签库编辑器（请参见管理标签库）。


设置代码格式参数

您可以通过指定格式设置参数选择（例如缩进、行长度以及标签和属性名称的大小写）更改代码的外观。

请注意，除了“大小写自动转换”之外的所有参数选择只影响新文档和新添加到现有文档的部分。也就是说，当您打开一个以前创建的 HTML 文档时，这些格式设置选项将不会应用于该文档；若要对现有的 HTML 文档重新进行格式设置，请使用“应用源格式”命令。有关更多信息，请参见将新格式设置参数应用于现有的文档。

若要设置代码格式参数，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“代码格式”或“Dreamweaver”>“参数选择”>“代码格式”(Mac OS X)。

    2. 即会出现“代码格式”对话框。

  2. 在该对话框中调整以下任意设置：

    3. 使用指定是使用空格缩进还是使用 Tab 键缩进。

    缩进大小确定缩进的大小。如果“使用”设置为空格，则大小以空格为单位；如果“使用”设置为 Tab 键，则大小以 Tab 键为单位。

    制表符大小确定制表符的大小（以字符空格为单位度量）。

    自动换行每当行达到指定的列宽度时添加“硬”回车。（Dreamweaver 只在添加硬回车后不会更改文档在浏览器中外观的位置插入硬回车，因此某些行的长度可能大于“自动换行”选项中指定的值。）与之相反，“代码”视图中的“换行”选项对超过窗口宽度的行添加一个“软”回车。

    换行符类型指定承载远程站点的远程服务器的类型（Windows、Macintosh 或 UNIX）。选择正确的换行符类型可以确保您的 HTML 源代码在远程服务器上能够正确显示。（对于 FTP，此设置只应用于二进制传输模式；Dreamweaver ASCII 传输模式将忽略此设置。如果使用 ASCII 模式下载文件，则 Dreamweaver 根据计算机的操作系统设置换行符；如果使用 ASCII 模式上载文件，则换行符都设置为“CR LF”。）当您使用只识别某些换行符的外部文本编辑器时，此设置也有用。例如，如果“记事本”是您的外部编辑器，则使用“CR LF (Windows)”；如果“SimpleText”是您的外部编辑器，则使用“CR (Macintosh)”。

    默认标签大小写和默认属性大小写控制标签和属性名称的大小写。这些选项应用于您在“文档”窗口中插入或编辑的标签和属性，但是它们不能应用于您在“代码”视图中直接输入的标签和属性，也不能应用于打开的文档中的标签和属性（除非您还选择了一个或全部两个“大小写自动转换”选项）。

    大小写自动转换：“标签”和“属性”指定是否在任何时候（包括当您打开现有的 HTML 文档时）都强制使用您指定的大小写选项。当您选择其中的一个选项时，打开文档中的所有标签或属性立即转换为指定的大小写，同样，从这时起打开的每个文档中的所有标签或属性也都转换为指定的大小写（直到您再次取消对此选项的选择为止）。您在“代码”视图和快速标签编辑器中键入的标签或属性也转换为指定的大小写，使用“插入”栏插入的标签或属性同样也转换为指定的大小写。例如，如果您想让标签名称总是转换为小写，则在“标签的大小写”选项中指定小写字母，然后选择“大小写自动转换：标签”选项。于是当您打开包含大写标签名称的文档时，Dreamweaver 将它们全部转换为小写。

    居中指定元素应该使用 div align="center" 还是 center 进行居中。两者都是 HTML 4.0 转换规范的一部分，但是支持 center 的浏览器范围更广。


将新格式设置参数应用于现有的文档

您在“代码格式”参数选择中指定的代码格式设置选项只应用于用 Dreamweaver 创建的任何新文档。若要将新的格式设置参数应用于现有的文档，请使用“应用源格式”命令。

若要将新格式设置参数应用于现有的文档，请执行以下操作：
  1. 在 Dreamweaver 中打开该文档。
  2. 选择“命令”>“应用源格式”。


设置“代码提示”参数

“代码提示”使您可以在输入代码时快速插入标签名称、属性和值。若要设置这些参数选择，请选择“编辑”>“参数选择”>“代码提示”或“Dreamweaver”>“参数选择”>“代码提示”(Mac OS X)。

提示： 即使禁用了“代码提示”，您也可以通过在 Windows 中按 Ctrl+ 空格组合键在“代码”视图或代码检查器中显示弹出式提示。

若要设置“代码提示”参数，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“代码提示”或“Dreamweaver”>“参数选择”>“代码提示”(Mac OS X)。

    2. 即会出现“代码提示”对话框。

  2. 在该对话框中调整以下任意设置：

    3. 启用标签自动完成启用标签的自动完成功能。

    启用代码提示当在“代码”视图中输入代码时启用代码提示功能。拖动“延迟”滑块设置程序显示适当的提示之前经过的时间（以秒为单位）。

    菜单允许您设置在键入代码时具体要显示哪种类型的代码提示。您可以使用全部或部分菜单。


设置“代码改写”参数

“代码改写”参数选择确定在打开文档时 Dreamweaver 进行哪些操作。当您在“代码”视图中编辑 HTML 或脚本时，这些参数选择不起作用。

如果您关闭改写选项，则 Dreamweaver 在“文档”窗口中对它本该改写的 HTML 显示无效标记项。

如果您要从 Microsoft Word 导入 HTML 文档，则可以使用“清理 Word HTML”命令删除任何多余的 HTML 代码。有关更多信息，请参见清理 Microsoft Word HTML。

若要设置“代码改写”参数，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“代码改写”或“Dreamweaver”>“参数选择”>“代码改写”(Mac OS X)。

    2. 即会出现“代码改写”对话框。

  2. 在该对话框中调整以下任意设置：

    3. 修复非法嵌套标签或未结束标签改写重叠的标签。例如，将 <b><i>text</b></i> 改写为 <b><i>text</i></b>。如果缺少右引号或右括号，则此选项还将插入右引号或右括号。

    粘贴时重命名表单项目确保表单对象不会具有重复的名称。

    删除多余的结束标签删除没有对应开始标签的结束标签。

    修正或删除标签时发出警告显示 Dreamweaver 试图更正的技术上无效的 HTML 的摘要。摘要记录问题的位置（使用行号和列号），以便您可以找到更正并确保它是按预期方式呈现的。

    从不改写代码：在带有扩展的文件中允许您防止 Dreamweaver 改写具有指定文件扩展名的文件中的代码。对于包含第三方标签的文件，此选项特别有用。

    使用 % 将 URL 中的特殊字符编码确保 URL 只包含合法的字符。

    使用 & 将属性值中的 <、>、& 和 " 编码确保 URL 只包含合法的字符。


设置“代码颜色”参数

语法颜色帮助您在较大的文档中标识代码块。您可以为代码元素（例如注释和脚本）和一般标签设置语法颜色参数选择。若要设置特定标签的颜色参数选择，请在标签库编辑器中编辑标签定义。有关更多信息，请参见编辑库、标签和属性。

若要设置“代码颜色”参数，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“代码颜色”或“Dreamweaver”>“参数选择”>“代码颜色”(Mac OS X)。
  2. 选择一个文档类型，然后单击“编辑颜色方案”。

    3. 即会出现“编辑颜色方案”对话框。

  3. 选择一项并设置其文本颜色、背景颜色和样式（粗体、斜体或下划线）。

    4. 您可以在“预览”窗格中预览颜色方案。

  4. 完成后，单击“确定”。


自定义键盘快捷方式

您可以在 Dreamweaver 中使用自己喜欢的键盘快捷方式。如果您习惯使用特定的键盘快捷方式（例如 Ctrl+ Enter 组合键添加一个换行符，Ctrl+G 组合键转到代码中的特定位置，或 Shift+F6 组合键验证一个文件），则可以使用键盘快捷方式编辑器将它们添加到 Dreamweaver 中。有关更多信息，请参见使用快捷键编辑器。


默认以“代码”视图打开文件

您可以配置 Dreamweaver 自动以“代码”视图而不是“设计”视图打开具有特定扩展名的文件。

当您打开一个通常不包含任何 HTML 的文件类型（例如，JavaScript 文件）时，该文件将在“代码”视图（或代码检查器）而不是设计视图中打开。您可以编辑该文件，并将其另存为一个 HTML 文件或非 HTML 文件。

若要设置非 HTML 文件的默认视图，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“文件类型/编辑器”或“Dreamweaver”>“参数选择”>“文件类型/编辑器”(Mac OS X)。
  2. 在“在代码视图中打开”文本框中，键入自动以“代码”视图打开的文件扩展名。在每种文件类型之间放置一个空格。

列出的默认文件扩展名有 .js、.txt 和 .asa。您可以添加任意多的文件扩展名。

相关主题

使用外部编辑器


设置“验证程序”参数

您可以在 Dreamweaver 中使用验证程序快速定位代码中的标签或语法错误。（请参见验证标签）。您可以指定验证程序应该检查的基于标签的语言、验证程序应该检查的特定问题、以及验证程序应该报告的错误类型。

若要设置“验证程序”参数，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“验证程序”或“Dreamweaver”>“参数选择”>“验证程序”(Mac OS X)。
  2. 选择要检查的标签库。

    3. 某些标签库是在其他标签库的基础之上建立的。例如，如果您选择 HTML 4.0，则会自动选择 HTML 3.2 和 HTML 2.0，因为如果没有它们，HTML 4.0 的定义将是不完整的。

    备注： 如果您在单个文档中既检查 CFML 又检查 HTML，则验证程序不能确定数字符号 (#) 的意义。这是因为在 CFML 中，# 是错误，## 是正确；而在 HTML 中，## 是错误，# 是正确。

  3. 单击“选项”。

    4. 即会出现“验证程序选项”对话框。

  4. 选择每种要包括在验证程序报告中的错误类型的显示选项。
  5. 选择验证程序应该检查的项目。
  6. 单击“确定”关闭“验证程序选项”对话框，然后单击“确定”关闭“参数选择”对话框。


管理标签库

您可以在 Dreamweaver 中使用标签库编辑器管理标签库。标签库编辑器允许您添加和删除标签库、标签和属性，设置标签库的属性以及编辑标签和属性。

若要打开标签库编辑器，请选择“编辑”>“标签库”。“标签库编辑器”如下所示。（此对话框的内容根据所选的标签有所变化。）

本节涵盖以下主题：

  • 添加库、标签和属性
  • 编辑库、标签和属性
  • 删除库、标签和属性

另请参见将自定义标签导入 Dreamweaver。


添加库、标签和属性

您可以在 Dreamweaver 中使用标签库编辑器将标签库、标签和属性添加到标签库中。

备注： 若要导入标签，请参见将自定义标签导入 Dreamweaver。

若要添加标签库，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，单击加号 (+) 按钮并选择“新建标签库”。

    2. 即会出现“新建标签库”对话框。

  2. 在“库名称”文本框中，输入一个名称（例如“PHP Tags”）。
  3. 单击“确定”。
若要将一个或多个标签添加到标签库，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，单击加号 (+) 按钮并选择“新建标签”。

    2. 即会出现“新建标签”对话框。

  2. 在“标签库”弹出式菜单中，选择一个标签库（例如“CFML Tags”）。

    3. 默认情况下，“标签库”框中显示在标签编辑器中选择的标签库。

  3. 在“标签名称”文本框中，输入标签的名称。

    4. 如果要添加多个标签，则输入这些标签的名称，用逗号和空格分隔（例如“cfgraph, cfgraphdata”）。

  4. 若要添加每个标签时都具有匹配的结束标签 (</...>)，则选择“具有匹配的结束标签”。
  5. 单击“确定”。
若要将一个或多个属性添加到标签，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，单击加号 (+) 按钮并选择“新建属性”。

    2. 即会出现“新建属性”对话框。

  2. 在“标签库”弹出式菜单中，选择一个标签库。

    3. 默认情况下，“标签库”文本框中显示在标签编辑器中选择的标签库。

  3. 在“标签”弹出式菜单中，选择一个标签（例如“cfgraph”）。

    4. 默认情况下，“标签”框中显示在标签编辑器中选择的标签。

  4. 在“属性名称”文本框中，输入属性的名称（例如“type”）。

    5. 若要添加多个属性，请输入这些属性的名称，用逗号和空格分隔。

  5. 单击“确定”。

相关主题

管理标签库

编辑库、标签和属性

删除库、标签和属性


编辑库、标签和属性

您可以使用标签库编辑器设置标签库的属性以及对库中的标签和属性进行编辑，不管是它们的属性和值，还是它们的格式（为了在代码中易于识别）。

若要设置标签库的属性，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，从“标签”弹出式菜单中选择一个标签库。
  2. 在“用于”框中，选择每个应该使用该标签库的文档类型。

    3. 标签库中的标签只在您此处选择的文档类型中可用。

  3. 如果标签库中的标签需要前缀，则在“标签前缀”文本框中输入前缀。
  4. 如果已完成了在标签库编辑器中的更改，则单击“确定”。
若要编辑标签库中的标签，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，在“标签”弹出式菜单中打开一个标签库，然后选择一个标签。
  2. 设置以下任意“标签格式”选项：
    • 换行符指定 Dreamweaver 在何处插入标签的换行符。
    • 内容指定 Dreamweaver 如何插入标签的内容；即是否将换行符和格式设置规则应用于内容。
    • 大小写指定特定标签的大小写。从“默认”、“小写”、“大写”或“混合大小写”中进行选择。如果选择“混合大小写”，则将出现“标签名称混合大小写”对话框。输入 Dreamweaver 应该如何插入标签（例如 getProperty）并单击“确定”。
    • 设置默认值设置所有标签的默认大小写。在出现的“默认标签大小写”对话框中，选择“<大写字母>”或“<小写字母>”，然后单击“确定”。

      • 提示： 您可能要将默认大小写设置为小写字母以遵循 XML 和 XHTML 标准。

若要编辑标签的属性，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，在“标签”弹出式菜单中打开一个标签库，打开一个标签，然后选择一个标签属性。
  2. 在“属性大小写”弹出式菜单中，选择“默认”、“小写”、“大写”或“混合大小写”。

    3. 如果您选择“混合大小写”，则在“属性名称混合大小写”对话框中，输入 Dreamweaver 应该如何插入属性（例如 onClick）。单击“确定”。

    单击“设置默认值”链接设置所有属性的默认大小写。

  3. 在“属性类型”弹出式菜单中，选择属性的类型。

    4. 如果您选择“已枚举”，则在“值”文本框中为该属性输入每个允许的值。用逗号分隔每个值（不使用空格）。例如，对于 cfgraph 标签的类型属性，输入“bar,horizontalBar,line,pie”。

相关主题

管理标签库

添加库、标签和属性

删除库、标签和属性


删除库、标签和属性

您可以使用标签库编辑器删除标签库、标签和属性。

若要删除库、标签或属性，请执行以下操作：
  1. 在标签库编辑器（“编辑”>“标签库”）中，在“标签”弹出式菜单中选择一个标签库、标签或属性。
  2. 单击减号 (-) 按钮。
  3. 如果要求您确认删除，则单击“确定”。

    4. 即会将该项从“标签”弹出式菜单中删除。

  4. 如果您不想永久删除某项，则单击“取消”。

    5. 标签库编辑器关闭，未删除该项，也不保存打开标签库编辑器后您在其中进行的任何更改。

  5. 如果要永久删除该项，则单击“确定”。

相关主题

管理标签库

添加库、标签和属性

编辑库、标签和属性


将自定义标签导入 Dreamweaver

您可以将自定义标签导入 Dreamweaver 中，以便它们成为创作环境的组成部分。例如，当您开始在“代码”视图中键入自定义标签时，“代码提示”功能自动列出标签的属性并允许您选择一个。

本节涵盖以下主题：

  • 从 XML 文件导入标签
  • 导入自定义 ASP.NET 标签
  • 从文件导入 JSP 标签
  • 从服务器 (web.xml) 导入 JSP 标签
  • 导入 JRun 标签


从 XML 文件导入标签

您可以从 XML 文档类型定义 (DTD) 文件或架构导入标签。

若要从 XML DTD 或架构导入标签，请执行以下操作：
  1. 打开标签库编辑器（“编辑”>“标签库”）。
  2. 单击加号 (+) 按钮并选择“DTD 架构”>“导入 XML DTD 或架构文件”。
  3. 输入文件，或者 DTD 或架构文件的 URL。
  4. 输入要用于该标签的前缀。

    5. 前缀用于将页上的标签标识为特定标签库的一部分。

  5. 单击“确定”。


导入自定义 ASP.NET 标签

您可以将自定义 ASP.NET 标签导入 Dreamweaver 中。

在开始之前，确保自定义标签安装于在“站点定义”对话框中定义的测试服务器上（请参见指定可在哪里处理动态页）。编译标签（.dll 文件）必须放置在站点根目录的 bin 文件夹中。非编译标签（.ascx 文件）可以贮留在服务器上的任何虚拟目录或子目录中。有关更多信息，请参见 Microsoft ASP.NET 文档。

若要将 ASP.NET 自定义标签导入 Dreamweaver，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 ASP.NET 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 单击加号 (+) 按钮并选择以下选项之一：
    • 若要从应用程序服务器导入所有 ASP.NET 自定义标签，请选择“ASP.NET”>“导入所有 ASP.NET 自定义标签”。
    • 若要从应用程序服务器只导入某些自定义标签，请选择“ASP.NET”>“导入所选的 ASP.NET 自定义标签”。

      • 即会出现“导入所选的 ASP.NET 自定义标签”对话框，列出安装在应用程序服务器上的每个 ASP.NET 自定义标签。按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 单击列表中的标签，然后单击“确定”。


从文件导入 JSP 标签

您可以从多种文件类型将 JSP 标签库导入 Dreamweaver。

若要将 JSP 标签库导入 Dreamweaver，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 JSP 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 单击加号 (+) 按钮并选择“JSP”>“从文件 (*.tld、*.jar、*.zip) 导入”。
  4. 指定包含标签库的 .tld、.jar 或 .zip 文件。
  5. 输入一个 URI 以标识该标签库。

    6. URI（统一资源标识符）通常由维护该标签库的组织的 URL 组成。该 URL 不用于访问该组织，它用于唯一标识该标签库。

  6. 输入要用于该标签的前缀。

    7. 前缀用于将页上的标签标识为特定标签库的一部分。

  7. 单击“确定”。


从服务器 (web.xml) 导入 JSP 标签

您可以从服务器导入 JSP 标签。

若要从服务器导入 JSP 标签，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 JSP 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 单击加号 (+) 按钮并选择“JSP”>“从服务器 (web.xml) 导入”。

    4. 即会出现“从服务器导入”对话框。

  4. 选择一个标签库。
  5. 输入一个 URI 以标识该标签库。

    6. URI（统一资源标识符）通常由维护该标签库的组织的 URL 组成。该 URL 不用于访问该组织，它用于唯一标识该标签库。

  6. 单击“确定”。


导入 JRun 标签

如果您使用 Macromedia JRun，则可以将您的 JRun 标签导入 Dreamweaver。

若要将 JRun 标签导入 Dreamweaver，请执行以下操作：
  1. 在 Dreamweaver 中打开一个 JSP 页。
  2. 打开标签库编辑器（“编辑”>“标签库”）。
  3. 在标签库编辑器中，单击加号 (+) 按钮并选择“JSP”>“从文件夹导入 JRun 服务器标签”。
  4. 指定一个包含 JRun 标签的文件夹。
  5. 输入一个 URI 以标识该标签库。
  6. 输入要用于该标签的前缀。

    7. 前缀用于将页上的标签标识为特定标签库的一部分。

  7. 如果完成了更改，则单击“确定”关闭标签库编辑器。


将外部 HTML 编辑器用于 Dreamweaver

您可以在 Dreamweaver 中启动外部 HTML 或文本编辑器来编辑当前文档的源代码，然后切换回 Dreamweaver 继续以图形方式进行编辑。Dreamweaver 检测任何已在外部保存到文档的更改并提示您在返回时重新载入文档。

您可以使用以下集成 HTML 编辑器：Macromedia HomeSite（仅限 Windows）或 BBEdit（仅限 Macintosh）。您还可以使用任何其他文本编辑器，例如“记事本”、SimpleText、vi、emacs 和 TextPad。


使用集成 HTML 编辑器

当安装 Dreamweaver 时，您可以在 Windows 中安装 HomeSite 或在 Macintosh 上安装 BBEdit 试用版。Dreamweaver 和这两种产品紧密集成。

由于这种集成，您可在 Dreamweaver 和 HomeSite/BBEdit 中编辑文档，从一个应用程序切换到另一个，并且文档自动同步保存在两个应用程序中。除此之外，两个程序都跟踪当前的选择；例如，如果您在 Dreamweaver 中选择了文本并切换到 BBEdit，相同的元素也在 BBEdit 中选中。


使用 HomeSite（仅限 Windows）

您不需要启用 HomeSite 的集成；当安装程序时将自动集成 HomeSite。

若要使用 HomeSite，请执行以下操作：
  1. 选择“编辑”>“用 HomeSite 进行编辑”。
  2. 在 HomeSite 中编辑文档并保存您的更改。
  3. 若要返回 Dreamweaver，请单击编辑器工具栏中的“Dreamweaver”。


此空间故意保留为空白


使用外部编辑器

您可以在 Dreamweaver 中打开其他外部编辑器，但是文档不像在 HomeSite 或 BBEdit 中那样同步保存在两个应用程序中。当在外部编辑器中完成更改后，您必须在 Dreamweaver 中手动刷新文档。

若要选择外部 HTML 编辑器，请执行以下操作：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后选择“文件类型/编辑器”。
  2. （仅限 Macintosh）若要使用 BBEdit 以外的 HTML 编辑器，请取消对“启用 BBEdit 集成”选项的选择。若要使用 BBEdit，保留对“启用 BBEdit 集成”的选择并跳过其余的步骤。
  3. 单击“外部代码编辑器”文本框旁边的“浏览”按钮并选择一个文本编辑器。
  4. 在“重载修改过的文件”选项中，指定当 Dreamweaver 检测到对 Dreamweaver 中打开的文档从外部进行了更改时 Dreamweaver 应该执行哪些操作。
  5. 在“运行时先保存文件”选项中，指定 Dreamweaver 应该总是在启动编辑器之前保存当前的文档、从不保存文档、还是每次启动外部编辑器时提示询问是否保存文档。
若要启动外部 HTML 编辑器，请执行以下操作：

选择“编辑”>“用 [编辑器名称] 进行编辑”。

相关主题

默认以“代码”视图打开文件

设置外部图像编辑器参数

为媒体文件启动外部编辑器


设置“标签库编辑器”对话框选项

此对话框用于添加、编辑和删除标签库、标签和属性及导入标签库。

任务

添加库、标签和属性

编辑库、标签和属性

删除库、标签和属性

将自定义标签导入 Dreamweaver

上一页


Dreamweaver 中的编码

Macromedia Dreamweaver MX 提供功能全面的编码环境，这一编码环境是为各种 Web 开发类型（范围从编写简单的 HTML 页面到设计、测试和部署复杂的 Web 应用程序）而专门设计的。

本章包含以下主题：

  • 关于 Dreamweaver 编码环境
  • 编写和编辑代码
  • 拷贝和粘贴代码
  • 搜索并替换标签和属性
  • 访问语言参考

有关从 Macromedia 主站点迁移到 Dreamweaver 的信息，请访问 Dreamweaver MX 支持中心。

相关主题

设置您的编码环境

优化和调试代码

在设计视图中编辑代码

下一页


关于 Dreamweaver 编码环境

Dreamweaver 中的编码环境使您具有对页面中代码的完全访问权限。本节涵盖以下主题：

  • 支持的文件类型
  • Dreamweaver 如何从各方面帮助您充分利用您的代码
  • 关于可自由导入导出的 HTML 格式
  • 关于由服务器行为插入的代码
相关主题

查看您的代码


支持的文件类型

对于客户端编码，您可以在 Dreamweaver 中处理多种文件类型，包括 HTML、XML、层叠样式表 (CSS)、JavaScript、VBScript、无线标记语言 (WML)、扩展数据标记语言 (EDML)、Dreamweaver 模板 (.dwt) 和文本。

对于服务器端编码，您可以处理以下文件类型：ColdFusion、ColdFusion 组件 (.cfc)、ASP.NET Visual Basic、ASP.NET C#、ASP VBScript、ASP JavaScript、JSP 和 PHP。您还可以创建独立的 C#、Visual Basic 和 Java 文件。

相关主题

Dreamweaver 如何从各方面帮助您充分利用您的代码

关于可自由导入导出的 HTML 格式


Dreamweaver 如何从各方面帮助您充分利用您的代码

Dreamweaver 在其编码环境和可视化环境中均生成有效的、简洁的代码。Dreamweaver 还将以下因素考虑在内，即代码是您亲自编写的、还是由其他编辑器生成的。Dreamweaver 永远不重写您的代码。例如，Dreamweaver 不更改空白或更改属性的大小写。如果您选择“查看”>“代码视图选项”>“高亮显示无效 HTML”选项，Dreamweaver 将以黄色高亮显示所有错误。此外，您还可以选择根据您指定的条件清理您的代码。您还可以自定义 Dreamweaver 设置代码格式的方式。有关更多信息，请参见设置编码参数。

相关主题

关于可自由导入导出的 HTML 格式

关于由服务器行为插入的代码


关于可自由导入导出的 HTML 格式

通过可自由导入导出的 HTML 格式，您可以在基于文本的 HTML 编辑器和 Dreamweaver 之间转移文档，并且对文档的原始 HTML 源代码的内容和结构只有很小的影响或没有任何影响。其主要功能如下：

  • 默认情况下，在您从外部编辑器切换回 Dreamweaver 时，或者当您打开不是用 Dreamweaver 创建的 HTML 文档时，Dreamweaver 重写重叠的标签、添加必需的结束标签并删除多余的结束标签。不过，Dreamweaver 不在代码中进行其他任何更改，甚至在代码无效的情况下也不会进行更改（只要浏览器可以正确呈现该无效代码）。

    • 您可以禁用代码重写（请参见设置“代码改写”参数）。

  • Dreamweaver 不会更改它没有识别的标签（包括 XML 标签），因为它不具有用来判断这些标签的条件。如果不可识别的标签与另一个标签重叠（例如 <MyNewTag><b>text</MyNewTag></b>），则 Dreamweaver 将它标记为一个错误，但不重写该代码。
  • 此外，您还可以选择设置 Dreamweaver 以黄色高亮显示浏览器不支持的无效 HTML。在您选择高亮显示的部分后，属性检查器显示与如何纠正该错误有关的信息。
  • Dreamweaver 允许您启动第三方文本编辑器以编辑当前文档。有关更多信息，请参见将外部 HTML 编辑器用于 Dreamweaver。

相关主题

Dreamweaver 如何从各方面帮助您充分利用您的代码


关于由服务器行为插入的代码

在您开发动态页并从“服务器行为”面板中选择一个服务器行为时，Dreamweaver 将一个或多个代码块（或“参与者”）插入您的页面，以令服务器行为可以行使其功能。

如果您更改参与者中的代码，则您可能会无法继续使用可视化工具来编辑或删除服务器行为。Dreamweaver 查找页面代码中的特定模式以检测服务器行为并在“服务器行为”面板中显示它们。如果您以任何方式更改参与者的代码，包括更改单词间距和换行符，则 Dreamweaver 可能会无法继续检测服务器行为并在“服务器行为”面板中显示该行为。但是，服务器行为仍存在于该页面上，并且您可以在 Dreamweaver 的编码环境中编辑它。

相关主题

Dreamweaver 如何从各方面帮助您充分利用您的代码

为可视化开发优化工作区


编写和编辑代码

Dreamweaver 提供若干种功能，可帮助您高效率地编写和编辑代码。本节涵盖以下功能：

  • 使用代码提示
  • 使用代码片断
  • 使用插入栏迅速插入代码
  • 使用标签选择器插入标签
  • 使用标签编辑器编辑标签
  • 用标签检查器编辑标签
  • 缩进代码块
  • 拷贝和粘贴代码
  • 插入 HTML 注释
  • 在您的页面中列出 JavaScript 和 VBScript 函数


使用代码提示

通过代码提示，您可以在代码视图（或代码检查器）中键入时插入和编辑代码。在您键入某些字符时，将显示一个列表，列出完成您的条目所需的建议选项。您可以使用该功能插入或编辑代码，或只是查看某一标签的可用属性、某一函数的可用参数或某一对象的可用方法。

您可以设置代码提示在显示选项列表前等待多长时间，指定要包括在标签列表中的标签，或者一起关闭多个代码提示。有关更多信息，请参见设置“代码提示”参数。

若要使用代码提示插入标签，请执行以下操作：
  1. 键入左尖括号 (<) 以显示标签列表。
  2. 按 Esc 键以关闭该列表。
  3. 向下滚动该列表并双击一个标签以插入该标签。
  4. 如果该标签支持属性，则按空格键以显示该标签的允许属性的列表。选择一个属性并按 Enter 键。
  5. 键入该属性的值；或者，如该属性只接受某些值，则从该属性的允许值的列表中选择一个值。
  6. 对于您想要为该标签添加的每一属性，重复前两个步骤，确保您在一个值及其后引号 (") 之间没有按空格键。
  7. 在最后的属性值对后，为该标签键入右尖括号 (>)。
若要编辑一个标签，请执行以下任一操作：
  • 若要添加一个属性，将插入点置于标签右尖括号 (>) 的左侧，并且按空格键以显示该标签的所有支持属性的列表。按照前面的说明插入属性及其值。
  • 若要更改属性、删除属性和添加属性，请按照前面的说明进行操作。
  • 若要更改值、删除值和添加值，请按照前面的说明进行操作。
若要插入或编辑某一函数或对象的代码，请执行以下操作：
  1. 选择“编辑”>“参数选择”>“代码提示”或“Dreamweaver”>“参数选择”>“代码提示”(Mac OS X)，然后设置参数选择以在显示时没有任何延迟。
  2. 在代码视图（或代码检查器）中，像往常一样键入函数或对象代码。

    3. 只要您键入代码提示所适用的关键字或字符，就将出现完成选项的弹出式菜单。根据需要从该列表中进行选择并按 Enter 键。

若要配置或禁用代码提示，请参见设置“代码提示”参数。


使用代码片断

使用代码片断，您可以存储内容以便快速重复使用。您可以创建和插入 HTML、JavaScript、CFML、ASP、JSP 等的代码片断。Dreamweaver 还包含一些预定义的代码片断，您可以使用它们来作为起始点。

您可以确定是希望代码片断环绕选定内容，还是令其只作为代码块存在。例如，您可能要链接到一页，该页在您的站点中出现多次，但它被附加到其他对象和文本上。您可以选择一个对象，在“代码片断”面板中右键单击 (Windows) 或在按住 Control 键的同时单击应加上(Macintosh)一个代码片断，然后从弹出式菜单中选择“插入”。该链接的代码将环绕选定内容。您还可以给您的代码片断加上注释，以帮助其他人正确使用这些代码片断。

若要插入代码片断，请执行以下操作：
  1. 将插入点置于文档中的所需位置；若要插入环绕选定内容的代码片断，请在文档中进行选择。
  2. 在“代码片断”面板（“窗口”>“代码片断”）中，双击该代码片断。

    3. 您还可以用右键单击 (Windows) 或在按住 Control 键的同时单击加上(Macintosh)该代码片断，然后从弹出式菜单中选择“插入”。

若要创建代码片断，请执行以下操作：
  1. 在“代码片断”面板中，单击该面板底部的“新建代码片断”图标。

    2. 随即显示“代码片断”对话框。

  2. 完成该对话框并单击“确定”。

    3. 有关更多信息，请参见设置“代码片断”对话框选项。

若要编辑或删除一个代码片断，请执行以下操作：
  1. 在“代码片断”面板中，选择一个代码片断并单击面板底部的“编辑代码片断”或“删除”图标。

    2. 您可以根据其工具提示识别“编辑代码片断”或“删除”图标。

若要创建代码片断文件夹和管理代码片断，请执行以下操作：
  1. 在“代码片断”面板中，单击该面板底部的“新建代码片断文件夹”图标。
  2. 根据需要将代码片断拖入新文件夹或其他文件夹中。
若要与小组其他成员共享一个代码片断，请执行以下操作：
  1. 在 Dreamweaver MX 应用程序文件夹的 Configuration\Snippets 文件夹中，查找您要共享的代码片断。
  2. 将该代码片断拷贝到您的计算机或网络计算机上的共享文件夹中。
  3. 让小组中的其他成员将该代码片断拷贝到他们自己的 Configuration\Snippets 文件夹中。

具有对该共享文件夹的访问权限的任何人士现在都可以从该文件夹添加、编辑和删除代码片断。


使用插入栏迅速插入代码

您可以使用插入栏迅速将代码添加到您的页面中。您只需确定插入点在代码中的位置，然后单击插入栏中的图标即可。在您单击一个图标时，代码可以立即出现在您的页面中，或者可以显示一个对话框，要求您提供完成该代码所需的更多信息。

若要确定每一图标所代表的功能，请将鼠标置于该图标上并等待工具提示显示出来。根据您在 Dreamweaver 中打开的文档类型的不同，插入栏中提供的图标的数目和类型也将有所不同。插入栏中提供的图标的数目和类型还取决于您正使用的是代码视图还是设计视图。

尽管插入栏提供常用标签的集合，但这一集合并不是很全面。若要从更全面的标签集合中进行选择，请使用标签选择器 (使用标签选择器插入标签)。


使用标签选择器插入标签

您可以使用标签选择器将 Dreamweaver 标签库（包括 ColdFusion 标签库和 ASP.NET 标签库）中的任何标签插入您的页面中。有关标签库的更多信息，请参见管理标签库。

若要使用标签选择器插入标签，请执行以下操作：
  1. 确定插入点在代码中的位置，用右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh)，然后选择“插入标签”。

    2. 即会显示标签选择器。左窗格包含支持的标签库的列表，右窗格显示选定标签库文件夹中的单独的标签。

  2. 从列表中选择一个标签。
  3. 如果您想要查看该标签的语法和用法信息，则单击“标签信息”按钮。

    4. 如果有这样的信息，在对话框中将显示该标签的帮助信息。

  4. 如果您需要与该标签有关的参考信息，则单击“?”图标。

    5. 如果有这样的信息，在“参考”面板中将显示该标签的参考信息。

  5. 单击“插入”将选定标签插入代码中。

    6. 不要求附加信息的标签（这些标签出现在右窗格中，用尖括号括起来，例如 <HTML></HTML>）被插入文档中插入点所在处。所有其他标签均显示其自己的标签编辑器。

  6. 如果标签编辑器打开，则输入附加信息并单击“确定”。

    7. 请参见使用标签编辑器编辑标签。


使用标签编辑器编辑标签

通过标签编辑器，您可以使用对话框指定或编辑某一标签的属性。如果您使用标签选择器插入一个标签，并且该标签要求附加信息，则其标签编辑器自动出现。如果不是这样的话，以下过程说明如何为某一标签打开标签编辑器。有关更多信息，请参见使用标签选择器插入标签。

若要访问某一标签的标签编辑器，请执行以下操作：
  1. 将插入点放置在标签中。
  2. 右击 (Windows) 或按住 Control 键的同时单击 (Macintosh)，然后从弹出式菜单中选择“编辑标签”。
  3. 进行更改并单击“确定”。

提示： 若要获得与标签编辑器内的标签有关的更多信息，请单击“标签信息”。


用标签检查器编辑标签

您可以使用标签检查器在属性表（它类似于在其他集成开发环境 (IDE) 中提供的那些属性表）中编辑标签。

若要使用标签检查器编辑一个标签，请执行以下操作：
  1. 确保标签检查器已打开（“窗口”>“标签检查器”）。
  2. 在代码视图（或代码检查器）中，单击标签内的任何地方。

    3. 如果该标签支持属性，则 Dreamweaver 在标签检查器的属性表中显示这些属性及其当前值。

  3. 在属性表中对该标签进行更改。

    4. 单击属性名称以键入一个值；或者，如果该属性接受预定义的值，则从列表中进行选择。

  4. 如果该属性接受来源于动态内容（例如数据库）的值，则单击选定属性行末尾的闪电图标并选择该来源。

    5. 有关定义动态内容来源的信息，请参见定义动态内容源。

  5. 单击面板中的其他地方以更新您的文档中的标签。


缩进代码块

当您在代码视图或代码检查器中编写和编辑代码时，您可以缩进代码块，直观地将该代码块与其余代码区分开来，使其更易于找到。

若要缩进一个代码块，请执行以下操作：
  1. 选择您要缩进的代码块行。（您必须选择整行。）
  2. 选择“编辑”>“缩进代码”。

代码即被缩进。选择“编辑”>“凸出代码”可以将已缩进的代码返回到未缩进状态。


拷贝和粘贴代码

您可以从其他的应用程序或从代码视图本身拷贝并粘贴源代码。您可以将源代码作为文本拷贝和粘贴，也可以在不改动标签的情况下将源代码作为代码拷贝和粘贴。

若要将源代码作为文本拷贝和粘贴，请执行以下操作：
  1. 从 Dreamweaver 或其他应用程序中拷贝代码。
  2. 将插入点直接置于设计视图中，然后选择“编辑”>“粘贴”。
若要在不改动标签的情况下拷贝和粘贴源代码，请执行以下操作：
  1. 从 Dreamweaver 或其他应用程序中拷贝代码。

    2. 若要从设计视图拷贝，请选择“编辑”>“拷贝为 HTML”。

  2. 执行以下操作之一：
    • 在代码视图中，确定插入点的位置，然后选择“编辑”>“粘贴”。如果您正使用设计视图，则按 F5 键更新文档的显示。
    • 在设计视图中，确定插入点的位置，然后选择“编辑”>“粘贴为 HTML”。


插入 HTML 注释

注释是您在 HTML 代码中插入的描述性文本，用来解释该代码或提供其他信息。注释文本只出现在代码视图中，并且将不在浏览器的 Web 页中显示。

若要插入注释，请执行以下操作：
  1. 在代码视图或设计视图中，将插入点放置在您要插入注释的地方。
  2. 单击插入栏上“常用”标签的“注释”图标。

    3. 使用工具提示可以识别“注释”图标。

    • 在代码视图中，Dreamweaver 在页面中插入 <!-- --> 标签。在标签内输入您的注释。
    • 在设计视图中，Dreamweaver 显示“注释”对话框。输入您的注释，然后单击“确定”。

若要在设计视图中显示注释标记，请选择“查看”>“可视化助理”>“不可见元素”。确保在“不可见元素”参数选择中选择了注释，否则将不出现注释标记。

若要添加到现有注释，请执行以下操作之一：
  • 在设计视图中选择注释标记并在属性检查器中输入文本。
  • 在代码中找到注释并直接向它添加文本。


在您的页面中列出 JavaScript 和 VBScript 函数

您可以在代码视图中查看打开的页面中的所有 JavaScript 或 VBScript 函数。

若要查看页面中的脚本函数，请执行以下操作：
  1. 在代码视图中打开文档
  2. 确保文档工具栏已显示出来（“查看”>“工具栏”>“文档”）。
  3. 单击工具栏中的“代码导航”图标。

    4. 该图标由一对大括号 ({ }) 组成。

    备注： 该图标在设计视图中被禁用。

如果您的代码包含 JavaScript 或 VBScript 函数，则它们将出现在弹出式菜单中。若要以字母顺序查看列出的函数，在按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh) 的同时单击“代码导航”按钮。

若要转到您的代码中的函数，请执行以下操作：

从“代码导航”弹出式菜单中选择一种函数。该函数在代码视图（或代码检查器）中将被高亮显示出来。


搜索并替换标签和属性

您可以使用 Dreamweaver 搜索并替换代码中的标签和属性。本节涵盖以下主题：

  • 关于 HTML 源代码搜索
  • 搜索标签和属性
  • 搜索包含在特定标签中的文本
  • 保存搜索模式
  • 关于常规表达式


关于 HTML 源代码搜索

使用“查找”或“替换”对话框中的“源代码”选项搜索 HTML 源代码中的特定文本字符串。例如，在以下代码中搜索 black dog 将生成两个匹配项（在 alt 属性中和在第一句中）。

<img src="barnaby.gif" width="100" height="100"
alt="Barnaby, a black dog."><br>
We saw several black dogs in the park yesterday.The black
<a href="barnaby.html">dog</a> we liked best was called Barnaby.

black dog 短语也出现在第二句中，但它并不与搜索匹配，因为此短语被链接断开了。

有关更多信息，请参见搜索和替换文本。

相关主题

搜索标签和属性

搜索包含在特定标签中的文本

保存搜索模式

关于常规表达式


搜索标签和属性

使用“查找”或“替换”对话框中的“特定标签”选项搜索特定的标签、属性和属性值。例如，您可以搜索不具有 alt 属性的所有 img 标签。

若要执行标签搜索，请执行以下操作：
  1. 选择“编辑”>“查找和替换”，指定要搜索的文件。
  2. 从“查找内容”弹出式菜单中选择“特定标签”选项。
  3. 从“查找内容”弹出式菜单旁的弹出式菜单中选择特定标签，输入一个标签，或者选择[任何标签]。

    4. 如果您只想搜索指定标签的所有匹配项，则按下减号 (-) 按钮并跳到第 6 步。否则，继续执行第 4 步。

  4. 使用以下标签修饰符之一限制搜索：
    • 含有属性选择一个属性，该属性必须在该标签内才能进行匹配。您可为该属性指定特殊值或选择[任何值]。
    • 不含属性选择一个属性，该属性不能在该标签内才能进行匹配。例如，选择此选项以搜索不具有 ALT 属性的所有 IMG 标签。
    • 包含指定文本或标签，该文本或标签必须包含在原始标签内才能进行匹配。例如，在代码 <b><font face="Arial">heading 1</font></b> 中，font 标签包含在b标签内。
    • 不包含指定文本或标签，该文本或标签不能包含在原始标签内才能进行匹配。
    • 在标签中指定一个标签，目标标签必须在该标签内才能进行匹配。
    • 不在标签中指定一个标签，目标标签不能在该标签内才能进行匹配。
  5. 单击加号 (+) 按钮并重复第 4 步以进一步限制搜索。
  6. 开始执行搜索：
    • 单击“查找下一个”可以在当前文档中高亮显示该标签的下一个实例，如果在多个文档中进行搜索，则在随后的任何文档中进行查找。
    • 单击“查找全部”可以生成当前文档中该标签的所有实例的列表，如果您正搜索一个目录或站点，则生成包含该标签的文档的列表。该列表出现在“结果”面板的“搜索”标签中。

相关主题

搜索包含在特定标签中的文本

保存搜索模式

关于常规表达式


搜索包含在特定标签中的文本

使用“查找”或“替换”对话框中的“文本（高级）”选项，搜索在一组标签区块内或不在一组标签区块内的特定文本字符串。例如，您可以在 <title> 标签间搜索单词 Untitled，以找到您的站点上的所有无标题页。

若要执行高级文本搜索，请执行以下操作：
  1. 选择“编辑”>“查找和替换”，指定要搜索的文件。
  2. 从“查找内容”弹出式菜单中选择“文本（高级）”。
  3. 在“查找内容”弹出式菜单旁的文本域中键入您要搜索的文本。

    4. 例如，键入 Untitled 一词。

  4. 选择“在标签中”或“不在标签中”，然后从相邻的弹出式菜单中选择一个标签。

    5. 例如，选择“在标签中”，然后选择 title。

  5. 单击加号 (+) 按钮限制搜索只在具有特定属性的标签中进行。

    6. 因为 <title> 标签不具有任何属性，所以您不需要使用此选项在您的站点上查找所有无标题的页面。

  6. 开始执行搜索：
    • 单击“查找下一个”可以在当前文档中高亮显示该文本的下一个实例，如果在多个文档中进行搜索，则在随后的任何文档中进行查找。
    • 单击“查找全部”可以生成当前文档中该文本的所有实例的列表，如果您正搜索一个目录或站点，则生成包含该标签的文档的列表。该列表出现在“结果”面板的“搜索”标签中。

相关主题

搜索标签和属性

保存搜索模式

关于常规表达式


保存搜索模式

您可以通过单击“查找”或“替换”对话框中的“保存查询”图标（磁盘图标），保存搜索模式以供以后使用。如果您经常执行相同的搜索并且不想每次都重新建立该搜索模式，保存查询不失为一个好主意。例如，您可能想要从文档中除去用其他可视化 HTML 编辑器创建的非标准标签，或者想要在 Web 上发布文档前确认文件中的所有图像都具有 height、width 和 alt 属性。

若要保存搜索模式，请执行以下操作：
  1. 在“查找和替换”对话框（“编辑”>“查找和替换”）中，设置搜索参数。

    2. 如果您执行标签或高级文本搜索，请参见搜索标签和属性或搜索包含在特定标签中的文本，了解与设置附加搜索参数有关的信息。

  2. 单击“保存查询”图标（磁盘图标）。

    3. 保存查询的默认位置是 Dreamweaver 应用程序文件夹内的 Configuration/Queries 文件夹。

  3. 在出现的对话框中，为该文件提供一个标识查询的名称并单击“保存”。

    4. 例如，如果搜索模式涉及查找不具有 alt 属性的 img 标签，则您可以将该查询命名为 img_no_alt.dwr。查找以扩展名 .dwq 结尾的查询；替换以扩展名 .dwr 结尾的查询。

若要重新调用一个搜索模式，请执行以下操作：
  1. 选择“编辑”>“查找和替换”。
  2. 单击“装载查询”按钮（文件夹图标）。

    3. “装载查询”对话框自动在 Configuration/Queries 文件夹中打开。如果您已在其他地方保存查询，则您可以定位到其他的文件夹。

  3. 选择一个查询文件，然后单击“打开”。

    4. 如果您位于“查找”对话框中，则只提供“查找”查询（.dwq 文件）。如果您位于“替换”对话框中，则同时提供“查找”查询（.dwq 文件）和“替换”查询（.dwr 文件）。

  4. 单击“查找下一个”、“查找全部”、“替换”或“替换全部”可以启动搜索。

相关主题

搜索标签和属性

搜索包含在特定标签中的文本

关于常规表达式


关于常规表达式

常规表达式是以文本描述字符组合的模式。在搜索中使用常规表达式可以有助于描述一些概念，例如“以‘The’开始的句子”和“包含数字的属性值”。下表列出了在常规表达式中使用的特殊字符、其含义和用法示例。

若要搜索包含该表中某一特殊字符的文本，请在特殊字符前面附加一个反斜杠，令其“转义”。例如，若要在 some conditions apply* 短语中搜索实际的星号，您的搜索模式应类似于：apply\*。如果您没有令星号转义，您将找到“apply”的所有匹配项（以及“appl”、“applyy”、和“applyyy”的所有匹配项），而不只是后面跟有星号的那些匹配项。

字符 | 匹配 | 示例
^ | 输入或行的起始部分。 | ^T 匹配“This good earth”中的“T”，但不匹配“Uncle Tom’s Cabin”中的“T”
$ | 输入或行的结尾部分。 | h$ 匹配“teach”中的“h”，但不匹配“teacher”中的“h”
* | 0 个或多个前置字符。 | um* 匹配“rum”中的“um”、“yummy”中的“umm”和“huge”中的“u”
+ | 1 个或多个前置字符。 | um+ 匹配“rum”中的“um”和“yummy”中的“umm”，但在“huge”中没有任何匹配项
? | 前置字符最多出现一次（即，指示前置字符是可选的）。 | st?on 匹配“Johnson”中的“son”、“Johnston”中的“ston”，但在“Appleton”或“tension”中没有任何匹配项
. | 除换行符外的任何单字符。 | .an 匹配短语“bran muffins can be tasty”中的“ran”和“can”
x|y | x 或 y。 | FF0000|0000FF 匹配 bgcolor=”#FF0000” 中的“FF0000”以及 font color=”#0000FF” 中的“0000FF”
{n} | 恰好 n 个前置字符。 | o{2} 匹配“loom”中的“oo”和“mooooo”中的前两个 o，但在“money”中没有任何匹配项
{n,m} | 至少 n 个、至多 m 个前置字符。 | F{2,4} 匹配“#FF0000”中的“FF”和“#FFFFFF”中的前 4 个 F
[abc] | 用括号括起来的字符中的任何一个字符。用连字符指定某一范围的字符（例如，[a-f] 等效于 [abcdef]）。 | [e-g] 匹配“bed”中的“e”、“folly”中的“f”和“guard”中的“g”
[^abc] | 未在括号中括起来的任何字符。用连字符指定某一范围的字符（例如，[^a-f] 等效于[^abcdef]）。 | [^aeiou] 最初匹配“orange”中的“r”、“book”中的“b”和“eek!”中的“k”
\b | 词边界（例如空格或回车符）。 | \bb 匹配“book”中的“b”，但在“goober”或“snob”中没有任何匹配项
\B | 非词边界。 | \Bb 匹配“goober”中的“b”，但在“book”中没有任何匹配项
\d | 任何数字字符。等效于 [0-9]。 | \d 匹配“C3PO”中的“3”和“apartment 2G”中的“2”
\D | 任何非数字字符。等效于 [^0-9]。 | \D 匹配“900S”中的“S”和“Q45”中的“Q”
\f | 换页符。 |
\n | 换行符。 |
\r | 回车符。 |
\s | 任何单个空白字符，包括空格、制表符、换页符或换行符。 | \sbook 匹配“blue book”中的“book”，但在“notebook”中没有任何匹配项
\S | 任何单个非空白字符。 | \Sbook 匹配“notebook”中的“book”，但在“blue book”中没有任何匹配项
\t | 制表符。 |
\w | 任何字母数字字符，包括下划线。等效于 [A-Za-z0-9_]。 | b\w* 匹配“the barking dog”中的“barking”以及“the big black dog”中的“big”和“black”
\W | 任何非字母数字字符。等效于 [^A-Za-z0-9_]。 | \W 匹配“Jake & Mattie”中的“&”和“100%”中的“%”
Ctrl+Enter 或 Shift+Enter (Windows)、或者 Control+Return 或 Shift+Return 或 Command+ Return (Macintosh) | 回车符。确保如果没有使用常规表达式，则在搜索时取消对“忽略空白差别”的选择。请注意，这匹配特定字符，而不是一般意义上的换行符；例如，它不匹配 <br> 标签或 <p> 标签。回车符作为空格出现在文档窗口中，而不是作为换行符出现在文档窗口中。 |

使用括号在常规表达式内分隔以后要引用的分组；使用 $1、$2、$3 等（在“查找”域中使用 ($)，在“替换”域中使用反斜杠 (\)）以表示第一个、第二个、第三个和更后面的括号分组。例如，通过搜索 (\d+)\/(\d+)\/(\d+) 并用 $2/$1/$3 替换它，可以在由斜杠分隔的日期中交换日和月（以便在美国样式日期和欧洲样式日期之间进行转换）。

相关主题

搜索标签和属性

搜索包含在特定标签中的文本

保存搜索模式


访问语言参考

“参考”面板向您提供用于标记语言、JavaScript 对象和 CSS 样式（以及它们的属性）的快速参考工具。“参考”面板向您提供与您正在代码视图（或代码检查器）中处理的特定标签、对象或样式有关的信息。

若要打开“参考”面板，请执行以下操作：
  1. 在代码视图中，用右键单击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 一个标签、属性或关键字。
  2. 从弹出式菜单中选择“引用”。

“参考”面板打开并显示与您所单击的标签、属性或关键字有关的信息。若要调整“参考”面板中文本的大小，请从选项菜单（面板右上方的小箭头）中选择“大字体”、“中等字体”或“小字体”。

“书籍”弹出式菜单显示参考材料出自的书籍的名称。若要显示来自其他书籍的标签、对象或样式，请从“书籍”弹出式菜单中选择不同的书籍。

“标签”、“对象”或“样式”（取决于您已选择的书籍）弹出式菜单显示您在代码视图（或代码检查器）中选择的标签、对象或样式。若要查看与其他标签、对象或样式有关的信息，请从该菜单中选择新的一项。

“标签”、“对象”或“样式”弹出式菜单的旁边是一个菜单，该菜单中包含您选择的标签的属性列表。默认选择是“Description”，它显示所选标签的说明。您还可以从该菜单中选择一个属性，以查看与该属性有关的更多信息。


参考资料

本节提供了本章中介绍的对话框和面板的有关信息。


设置“代码片断”对话框选项

此对话框用于为“代码片断”面板创建或编辑代码片断。

过程
  1. 在“名称”文本框中，输入代码片断的名称。

    2. 备注： 代码片断名称不能包含在文件名中无效的字符，例如斜杠（/ 或 \）、特殊字符或双引号 (“)。

  2. （可选）在“描述”文本框中，输入代码片断的描述性文本。描述性文本可以使其他小组成员更易于使用代码片断。
  3. 对于“代码片断类型”，选择“环绕选定内容”或“插入块”。
  4. 如果您选择“环绕选定内容”，则完成以下任意文本框：
    • 前插入 键入或粘贴您要在当前选定内容前插入的代码。若要设置块之间的默认空间，请在开始文本的末尾和结尾文本的开始处按 Enter 键。
    • 后插入 输入您要在选定内容后插入的代码。
  5. 如果您选择“插入块”，则将您的代码键入或粘贴到“代码”框中。
  6. （可选）在“预览”窗格中，选择一个预览类型：“代码”或“设计”。

    7. 如果您选择“设计”，Dreamweaver 呈现代码并在“代码片断”面板的“预览”窗格中向您显示它。如果您选择“代码”，则 Dreamweaver 只在“预览”窗格中显示代码。

  7. 单击“确定”。

备注： 因为代码片断只能作为开始块和结束块创建，所以您可以使用它们环绕其他标签和内容。这十分适用于插入特殊格式、链接、导航元素和脚本块。只需高亮显示您要环绕的内容，然后插入代码片断。

相关主题

使用代码片断


设置“注释”对话框选项

此对话框用于在设计视图中将 HTML 注释输入到页面中。

过程

输入注释并单击“确定”。

相关主题

插入 HTML 注释


设置“注释”属性检查器选项

此属性检查器用于修改页面中的 HTML 注释。

过程

修改该注释。

相关主题

插入 HTML 注释

上一页


优化和调试代码

您可以使用 Macromedia Dreamweaver MX 来优化和调试代码。例如，您可以验证标签、使文档符合 XHTML 标准，或调试 JavaScript。

本章涵盖以下主题：

  • 清理代码
  • 验证标签和括号是否对称
  • 验证标签
  • 使页符合 XHTML
  • 使用 JavaScript 调试器
  • 使用 ColdFusion 调试器
下一页


清理代码

使用“清理 HTML”或“清理 XHTML”命令可删除空标签、合并嵌套 font 标签，以及通过其他方法改善杂乱或不可读的 HTML/XHTML 代码的可读性。

对于 XHTML 文档，“清理 XHTML”命令可以修正语法错误、将标签属性的大小写特性设置为小写，以及添加或报告标签所缺少的必需属性。（当执行“清理 XHTML”命令后，将出现一个对话框，其中列出了不具有 alt 属性的 img 和 area 标签的数量。）

若要清理从 Microsoft Word 文档生成的 HTML，请参见清理 Microsoft Word HTML。

若要清理代码，请执行以下操作：
  1. 打开一个文档。
    • 如果该文档为 HTML 格式，请选择“命令”>“清理 HTML”。
    • 如果该文档为 XHTML 格式，请选择“命令”>“清理 XHTML”。
  2. 在出现的对话框中，从以下选项中进行选择：
    • 删除空标签区块用于删除中间没有内容的所有标签。例如，<b></b> 和 <font color="FF0000"></font> 被认为是空标签，但 <b>some text</b> 中的 <b> 标签则不被认为是空标签。
    • 删除冗余的嵌套标签用于删除所有冗余的标签。例如，在代码 <b>This is what I <b>really</b> wanted to say </b> 中，“really”一词两侧的 b 标签为冗余标签，将被删除。
    • 删除非 Dreamweaver HTML 注释用于删除所有不是由 Dreamweaver 插入的注释。例如，<!--begin body text--> 会被删除，但 <!-- #BeginEditable "doctitle" --> 则不会被删除，因为它是对模板中可编辑区域的开头进行标记的 Dreamweaver 注释。
    • 删除 Dreamweaver 特殊标记
    • 删除特殊标签用于删除在邻近文本域中指定的标签。使用此选项可删除由其他可视化编辑器插入的自定义标签以及其他您不希望在站点中出现的标签（例如，blink）。请用逗号分隔多个标签（例如，font, blink）。
    • 在情况允许下合并嵌套 <font> 标签用于合并两个或多个控制相同范围文本的 font 标签。例如，<font size="7"><font color="#FF0000">big red</font></font> 将被更改为 <font font="7" font="#FF0000">big red</font>。
    • 完成时显示日志会在清理完成时立即显示一个警告框，其中包含有关对文档所做更改的详细信息。
  3. 单击“确定”。

    4. 根据文档的大小和所选选项的数量，可能需要几秒钟时间才能完成清理。


验证标签和括号是否对称

当您在代码视图或代码检查器中编写和编辑代码时，可以检查并确保该页上的标签或括号 ({ }) 对称。通过检查标签是否对称，可以确保所有标签都有匹配的开始标签和结束标签。当您在代码中使用多个嵌套级别（例如，有些表嵌套在其他表内）时，这种检查会特别有用。

若要检查标签是否对称，请执行以下操作：
  1. 在代码视图中打开该文档。
  2. 将插入点放在嵌套代码中要进行检查的地方。
  3. 选择“编辑”>“选择父标签”。

    4. 两侧的匹配标签在代码中高亮显示。如果您继续选择“编辑”>“选择父标签”且您的标签已对称，则 Dreamweaver 最终将高亮显示最外面的 <html> 和 </html> 标签。

若要检查括号是否对称，请执行以下操作：
  1. 在代码视图中打开该文档。
  2. 将插入点放在嵌套代码中要进行检查的地方。
  3. 选择“编辑”>“使括号对称”。

    4. 两侧的匹配标签在代码中高亮显示。如果再次选择“编辑”>“使括号对称”，则将高亮显示上次所选内容两侧的匹配标签。


验证标签

您可以使用 Dreamweaver 验证程序来查明代码是否有标签或语法错误。该验证程序支持多种基于标签的语言，其中包括若干版本的 HTML、XHTML、ColdFusion 标记语言 (CFML)、JavaServer Page (JSP) 和无线标记语言 (WML)。您还可以验证 XML 文档。

备注： 若要对文档进行辅助功能验证，请参见对您的 Web 站点进行辅助功能测试。

您可以设置该验证程序的参数选择，例如指定该验证程序应依据哪些基于标签的语言来进行检查、该验证程序应检查哪些特定问题以及该验证程序应报告哪些类型的错误。有关更多信息，请参见设置“验证程序”参数。

您可以为当前文档或选定标签运行该验证程序。

若要运行该验证程序，请执行以下操作：
  1. 执行以下操作之一：
    • 对于 XML（或 XHTML）文件，选择“文件”>“检查页”>“验证为 XML”。
    • 否则，选择“文件”>“检查页”>“验证标签”。

      • “结果”面板的“验证”标签显示“没有错误或警告”消息，或者列出找到的语法错误。

  2. 双击文档中的某一错误信息以将其高亮显示。
  3. 在报告中右击 (Windows) 或按住 Control 键并单击 (Macintosh)，将其保存为 XML 文件或者在浏览器（利用它可打印报告）中查看该报告。


使页符合 XHTML

本节介绍 XML 及 XHTML、XHTML 要求、XHTML 的层叠样式表 (CSS) 要求以及如何创建符合 XHTML 的文档。

本节涵盖以下主题：

  • 关于 XML 和 XHTML
  • 关于由 Dreamweaver 生成的 XHTML 代码
  • 将层叠样式表 (CSS) 用于 XHTML
  • 使文档符合 XHTML


关于 XML 和 XHTML

可扩展标记语言（即 XML）定义信息的结构或信息在数据库中存储的方式。例如，用于烹饪的 XML 语言可能包含 <recipe> 标签，而 <recipe> 可能包含用于 <header>、<ingredients> 和 <instructions> 的标签。XML 的强大功能在于可以将信息存储在数据库中并从数据库中检索信息，可以按多种格式呈现信息，而且可以将信息用于多种多样的目的（例如用于 Web 页、手持计算机、手机；或者用于食谱、食谱卡俱乐部或者有关芫荽叶的书籍）。

可扩展超文本标记语言（即 XHTML）是以 XML 应用程序形式重新组织的 HTML。它与 HTML 4.01 基本相同，但更加严格与简洁。


XHTML 的优点

通常，利用 XHTML，您可以实现 XML 的优点，同时还能确保 Web 文档的向后和向前兼容性。下面是使用 XHTML 的一些具体原因：

  • XHTML 将会取代 HTML。如果要让您的 Internet Web 站点在将来可以查看并正确地呈现，那么现在就开始用 XHTML 编码将是一种明智的选择。
  • XHTML 将可以在多种设备上（而不仅仅是在 PC 上）运行。
  • XHTML 是一种 XML 语言，因此它为可扩展性提供了潜在的机会。您还可以使用标准的 XML 工具来查看、编辑和验证 XHTML 文档。
  • XHTML 文档可以使用依赖于 HTML 文档对象模型或 XML 文档对象模型的应用程序，如脚本和 applets。
  • XHTML 要求高质量的代码。这将减少不同用户代理（如 Web 浏览器）呈现 Web 文档的不同方式之间的差异，因为这些差异大多是因为格式设置不正确或不适当的代码而造成的。


从 HTML 迁移到 XHTML

XHTML 与浏览器以及其他支持 HTML 4 的用户代理和支持 XML 的用户代理一起工作。因此，切换到 XHTML 不会损失任何用户，而且也不必非要等到 XML 用户代理被广大用户所接受后再进行迁移。由于 XHTML 与 HTML 是如此相似，因此从 HTML切换到 XHTML 并不难。


XHTML 的 Web 资源

有关 XHTML 的更多信息，请参见 WWW 联合会 (W3C) Web 站点，它包含有关 XHTML 1.1 - 基于模块的 XHTML (http://www.w3.org/TR/xhtml11/) 和 XHTML 1.0 (http://www.w3c.org/TR/xhtml1/) 的规范以及基于 Web 的文件 (http://validator.w3.org/) 和本地文件 (http://validator.w3.org/file-upload.html) 的 XHTML 验证程序站点。

相关主题

关于由 Dreamweaver 生成的 XHTML 代码

将层叠样式表 (CSS) 用于 XHTML

使文档符合 XHTML


关于由 Dreamweaver 生成的 XHTML 代码

Dreamweaver 在生成 XHTML 代码和清理现有 XHTML 代码时会自动符合多数 XHTML 要求。对于剩余的少数 XHTML 要求，Dreamweaver 为您提供了所需的工具。

备注： 本节所述的一些要求也是不同 HTML 版本中的要求。

下表说明了 Dreamweaver 自动符合的 XHTML 要求。

XHTML 要求
为了满足此要求，Dreamweaver 会执行以下操作...
当文档的字符编码是默认的 UTF-8 之外的编码时，文档必须具有 XML 声明。
在 XHTML 文档中添加一个 XML 声明并指定编码；例如：
<?xml version="1.0" encoding="iso-8859-1"?>
文档中的根元素之前必须有 DOCTYPE 声明，而该声明必须引用 XHTML 的三个文档类型定义 (DTD) 文件（严格、过渡或框架页）之一。
在 XHTML 文档中添加一个 XHTML DOCTYPE：
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
或者，如果 XHTML 文档包含框架页：
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
文档的根元素必须为“html”，而 html 元素必须指定 XHTML 命名空间。
在 html 元素中添加 namespace 属性，如下所示：
<html xmlns="http://www.w3.org/1999/xhtml">
标准的文档必须包含文档头、标题和正文结构元素。框架页文档必须包含文档头、标题和框架页结构元素。
在标准文档中包含文档头、标题和正文元素；在框架页文档中包含文档头、标题和框架页元素。
文档中的所有元素必须正确嵌套：
<p>This is a <i>bad example.</p></i>
<p>This is a <i>good example.</i></p>
生成正确嵌套的代码，并且在清理 XHTML 时更正代码中不是由 Dreamweaver 生成的嵌套。
所有元素和属性名称必须为小写。
在它所生成的 XHTML 代码中以及在清理 XHTML 时，强制 HTML 元素和属性名称成为小写，而不管您设置的标签和属性大小写参数选择。
每个元素都必须有结束标签，除非在 DTD 中将其声明为 EMPTY。
在它所生成的代码中并且在清理 XHTML 时插入结束标签。
空元素必须有结束标签，或者开始标签必须以 /> 结束。例如，<br> 无效；正确的形式为 <br></br> 或 <br/>。以下元素为空元素：area、base、basefont、br、col、frame、hr、img、input、isindex、link、meta 和 param。
为了向后兼容不支持 XML 的浏览器，/> 前必须有一个空格（例如 <br />，而不是 <br/>）。
在它所生成的代码中以及在清理 XHTML 时，如果插入空元素，则在空标签中的结束斜杠添加一个空格。
属性无法进行最小化；例如，<td nowrap> 无效；正确的形式为 <td nowrap="nowrap">。
它会影响以下属性：checked、compact、declare、defer、disabled、ismap、multiple、noresize、noshade、nowrap、readonly 和 selected。
在它所生成的代码中以及在清理 XHTML 时，插入完整的属性-值对。
注意：如果 HTML 浏览器不支持 HTML 4，则当这些布尔属性以完整形式出现时，它可能无法解释这些属性。
所有属性值都必须引起来。
在它所生成的代码中以及在清理 XHTML 时，将属性值引起来。
以下元素必须具有 ID 属性和名称属性：a、applet、form、frame、iframe、img 和 map。例如，<a name="intro">Introduction</a> 无效；正确的形式为
<a id="intro">Introduction</a> 或 <a id="section1" name="intro">Introduction</a>。
在 Dreamweaver 所生成的代码中以及在清理 XHTML 时，只要属性检查器设置名称属性，就会将名称和 ID 属性设置为相同的值。
对于具有枚举类型的值的属性，值必须为小写。
枚举类型的值是允许值的指定列表中的值，例如，align 属性具有以下允许值：center、justify、left 和 right。
在它所生成的代码中以及在清理 XHTML 时，强制枚举类型的值成为小写。
所有脚本和样式元素都必须具有类型属性。
（自 HTML 4 开始已经要求脚本元素具有类型属性，而语言属性在此期间则变得不太重要。）
在它所生成的代码中以及在清理 XHTML 时，设置脚本元素中的类型和语言属性以及样式元素中的类型属性。
所有 img 和 area 元素都必须具有 alt 属性。
在它生成的代码中设置这些属性，并且在清理 XHTML 时报告缺少的 alt 属性。

相关主题

关于 XML 和 XHTML

将层叠样式表 (CSS) 用于 XHTML

使文档符合 XHTML


将层叠样式表 (CSS) 用于 XHTML

对于某些 CSS 样式，HTML 用户代理（如 Web 浏览器）可能会与 XML 用户代理产生不同的视觉或听觉效果。下面是减少这种差异的一些规则：

  • CSS 样式表中的元素和属性名称应使用小写。

    • 在 Dreamweaver 生成的代码中以及在清理 XHTML 时，Dreamweaver 会强制使 XHTML 文档中的样式元素和属性名称成为小写，而不论您的参数选择如何设置。

  • HTML 分析器会推断出 tbody 元素，但 XML 分析器则不会。因此，如果定义 tbody 样式，请将 tbody 元素添加到表中。
  • CSS 为 HTML 和 XML 文档定义不同的符合规则；因此，请注意 HTML 规则适用于作为 HTML 提交的 XHTML 文档，而 XML 规则适用于作为 XML 提交的 XHTML 文档。

备注： 在指定 XHTML 命名空间的文档中，浏览器和其他用户代理应继续将 class 属性和 ID 属性识别为类型 ID 的属性。因此，您可以继续使用速记“.”语法来引用选择器的 CSS 类（例如 P.note）；并且可以使用速记“#”选择器语法，即使用户代理不读取 DTD。

相关主题

关于 XML 和 XHTML

关于由 Dreamweaver 生成的 XHTML 代码

使文档符合 XHTML


使文档符合 XHTML

本节介绍如何使新文档符合 XHTML 以及如何使现有 HTML 文档符合 XHTML。

若要新建符合 XHTML 的文档，请执行以下操作：
  1. 选择“文件”>“新建”。

    2. 出现“新建文档”对话框。

  2. 选择一种文档类型。
  3. 选择“使文档符合 XHTML”选项。
  4. 单击“确定”。
若要以默认方式创建符合 XHTML 的文档，请执行以下操作：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后选择“新建文档”类别。
  2. 在“新建文档”类别中，选择一种文档类型并选择“使文档符合 XHTML”选项。
  3. 单击“确定”。
若要使现有 HTML 文档符合 XHTML，请执行以下操作：

打开一个文档。

  • 对于不含框架的文档，选择“文件”>“转换”>“XHTML”。
  • 对于包含框架的文档，选择一个框架并选择“文件”>“转换”>“XHTML”。若要转换整个文档，请对每个框架以及框架页文档重复此步骤。

备注： 由于模板的实例必须与它所基于的模板使用相同的语言，因此不能转换模板的实例。例如，XHTML 模板的实例将始终是 XHTML；HTML 模板的实例将始终是 HTML，而不能转换为 XHTML 或其他任何语言。

相关主题

关于 XML 和 XHTML

关于由 Dreamweaver 生成的 XHTML 代码

将层叠样式表 (CSS) 用于 XHTML


使用 JavaScript 调试器

JavaScript 调试器会帮助您隔离客户端 JavaScript 代码中的错误。您可以在代码视图（或代码检查器）中编写代码，然后运行该调试器来检查代码是否存在语法和逻辑错误。如果该页包含一个或多个语法错误，浏览器会显示一则错误信息；如果该页包含逻辑错误，则该页将无法正常工作，但浏览器不会显示错误信息。

您可以将 JavaScript 调试器与 Microsoft Internet Explorer 和 Netscape Navigator 4.0（而不是 Netscape Navigator 6.0）一起使用。

调试器会首先检查代码是否存在语法错误，然后与浏览器一起运行，以帮助您发现任何逻辑错误。如果存在逻辑错误，则可以在程序运行的同时使用“JavaScript 调试器”对话框来检查变量和文档属性。您可以在代码中设置断点（与警告语句相似），以停止执行程序并在一个变量列表中显示 JavaScript 对象和属性的值。您也可以跳至下一个语句或跳进一个函数调用来查看变量值的变化。

本节涵盖以下主题：

  • 运行 JavaScript 调试器
  • 查找语法错误
  • 查找和修正逻辑错误
  • 设置断点
  • 逐句调试代码
  • 观察和编辑变量值


运行 JavaScript 调试器

在编写完 JavaScript 代码后，可以启动 JavaScript 调试器来检查是否存在错误。该调试器会首先检查是否存在语法错误，然后在浏览器中打开您的页，使您可以检查是否存在逻辑错误。

若要开始调试，请执行以下操作：
  1. 选择“文件”>“在浏览器中调试”，然后从列表中选择一个浏览器。

    2. 在 Windows 中，选择 Internet Explorer 或 Netscape Navigator。在 Macintosh 中，选择 Netscape。

    如果调试器发现语法错误，它将停下来，在“JavaScript 语法错误”窗口中列出该错误。有关更多信息，请参见查找语法错误。

  2. 如果使用 Netscape Navigator，请在出现的调试器警告框中单击“确定”，然后在“Java 安全性”对话框中单击“授予”。

    3. 备注： 如果您已经接受 Macromedia 安全证书，则“Java 安全性”对话框可能不会出现。

  3. （仅限 Windows）如果使用 Internet Explorer，请在“Java 安全性”对话框中单击“是”，然后在出现的调试器警告框中单击“确定”。

    4. 备注： 由于该调试器使用 Internet 协议与浏览器进行连接（它实际上并不建立网络连接，也不连接到任何 Internet 服务器），所以安全性对话框是必需的。

“JavaScript 调试器”对话框随浏览器窗口一起出现。调试器会自动在代码中的第一行停止。

下图显示了“JavaScript 调试器”对话框中的工具栏：

若要运行调试器，请执行以下操作：

在“JavaScript 调试器”对话框的顶部，单击“运行”按钮。

若要停止调试器，请执行以下操作：

在“JavaScript 调试器”对话框的顶部，单击“停止调试”按钮。“JavaScript 调试器”对话框关闭。

相关主题

查找语法错误

查找和修正逻辑错误

设置断点

逐句调试代码

观察和编辑变量值


查找语法错误

如果调试器发现页中存在语法错误，它会停下来，在“JavaScript 语法错误”对话框中列出这些错误，如下图所示：

若要查看错误说明，请执行以下操作：

在“JavaScript 语法错误”对话框中选择一个错误。该错误的说明将出现在“详细描述”框中。

若要转到代码中的选定错误，请执行以下操作之一：
  • 双击该错误。
  • 单击“转到行”。

代码在代码视图中高亮显示（或者，如果代码视图未打开，则在代码检查器中高亮显示）。

相关主题

运行 JavaScript 调试器

查找和修正逻辑错误


查找和修正逻辑错误

当您启动调试器时，“JavaScript 调试器”对话框将打开，并在代码中的第一行停止执行浏览器。您还可以在代码中的任意行设置其他断点。调试器会在每个断点处停止执行代码，使您有机会在变量列表窗格中查看 JavaScript 对象和属性的值。

当调试器在断点处停止时，您可以逐句调试代码（一次执行一个语句）。这样，您就可以查看程序是否按照预期的方式执行。调试器甚至可以跳进链接的代码。例如，如果代码包含指向源文件的链接，则调试器会跳进源文件，并且在“JavaScript 调试器”对话框中显示该源文件。当逐句调试代码时，可以观察变量的值在整个程序中的变化情况。

相关主题

运行 JavaScript 调试器

设置断点

逐句调试代码

观察和编辑变量值


设置断点

断点在代码中标记出要让程序停止执行的位置。当您设置断点后，会在“JavaScript 调试器”对话框的左侧空白处标有一个小红点。当程序在该断点处停止执行时，该红点上会出现一个小箭头，此时您可以检查存在于该点的对象和属性。这样，您就可以快速查明 JavaScript 代码中错误的来源。

断点只能在 JavaScript 代码（在 script 标签之间）中或在包含事件处理程序的行上设置。如果在其他地方设置断点，Dreamweaver 将自动在代码中的下一个有效行上设置断点（或者，如果该行上已经设置了断点，则将插入点放在此处）。如果在可设置断点的地方不存在有效行，您将听到嘟嘟声。

若要设置断点，请执行以下操作：
  1. 在“JavaScript 调试器”对话框中，将插入点放在代码行上需要断点的地方。
  2. 在工具栏中，单击“设置/删除断点”按钮。
  3. 若要删除断点，请再次单击“设置/删除断点”按钮。
若要删除所有断点，请执行以下操作之一：
  • 在“JavaScript 调试器”对话框的顶部，单击“删除所有断点”按钮。
  • 在代码视图（或代码检查器）中，选择“编辑”>“删除所有断点”。

相关主题

运行 JavaScript 调试器

查找和修正逻辑错误

逐句调试代码

观察和编辑变量值


逐句调试代码

您可以“逐句调试”代码，一次执行一个语句并查看其结果。例如，您可以跳过一个 if 条件，并查看程序是在条件语句中的第一行还是在 if 语句后的下一个可执行行停止。

当调试器在包含函数调用的语句处停止时，您可以检查该函数并确保它正确执行。如果该函数正确，则可以跳出该函数，让调试器持续运行到该函数返回时为止。程序将在该函数调用位置后的下一个语句处再次停止。如果您试图跳进包含非标准 JavaScript 函数的语句，则 JavaScript 调试器会跳过该语句。

若要跳过语句，请执行以下操作：

在“JavaScript 调试器”对话框的顶部，单击“跳过”按钮。

当程序在任意语句（包括有函数调用的语句）处停止时，您可以跳过该语句继续执行，并且在下一个语句前暂停。

若要跳进函数，请执行以下操作：

在“JavaScript 调试器”对话框的顶部，单击“跳进”按钮。

若要跳出函数，请执行以下操作：

在“JavaScript 调试器”对话框的顶部，单击“跳出”按钮。

只有当调试器处于用户定义的函数中时，才能使用“跳出”。“跳出”会使函数定义中的其余语句被执行。调试器将在下一个语句处暂停。

相关主题

运行 JavaScript 调试器

查找和修正逻辑错误

设置断点

观察和编辑变量值


观察和编辑变量值

若要在逐句调试代码时检查变量的值，请使用位于“JavaScript 调试器”对话框底部的变量列表窗格。当您添加一个变量后，它的名称会出现在左列中；当程序在断点处停止执行时或者当您跳进代码后，右列会显示它的当前值。

下图显示几个变量的当前值：

若要在变量列表中添加变量，请执行以下操作之一：
  • 在“JavaScript 调试器”对话框的代码部分选择该变量的名称。单击加号 (+) 按钮并按 Enter 键。
  • 单击加号 (+) 按钮，键入要观察的变量的名称，然后按 Enter 键。

当您逐句调试代码时，值会出现在每个变量的旁边。如果变量是具有属性的对象，则可以展开该变量以显示其属性和值。若要展开变量，请在列表中单击该变量旁边的加号 (+) 按钮 (Windows) 或三角形按钮 (Macintosh)。每当您逐句调试代码时，展开的变量都会自动折叠。

若要从列表中删除变量，请执行以下操作：
  1. 在变量列表中选择该项。
  2. 单击减号 (-) 按钮。
若要编辑一个值，请执行以下操作：
  1. 在变量列表中选择该项。
  2. 在值列表中单击该值。
  3. 在出现的文本框中键入一个新值。
    这是所描述的功能的图片。

相关主题

运行 JavaScript 调试器

查找和修正逻辑错误

设置断点

逐句调试代码


使用 ColdFusion 调试器

当开发 Macromedia ColdFusion 应用程序时，可以配置 ColdFusion 在浏览器中显示相应信息，以帮助您调试该应用程序。例如，如果页包含错误，那么当您在浏览器中打开该页时，ColdFusion 会在 ColdFusion 页的底部显示错误的可能原因。如果您是将 Macromedia ColdFusion MX 用作 Dreamweaver 测试服务器的 ColdFusion 开发人员，则无需退出 Dreamweaver 即可查看此信息并修正该页。

备注： Macintosh 不支持此功能。Macintosh 开发人员可以使用“在浏览器中预览”(F12) 在另外一个浏览器中打开 ColdFusion 页。如果该页包含错误，有关错误可能原因的信息将出现在该页的底部。

在开始之前，确保已经在 ColdFusion 管理员中启用调试设置。有关更多信息，请参见 Dreamweaver 中的 ColdFusion“帮助”（“帮助”>“使用 ColdFusion”）。另外，请确保 Dreamweaver 测试服务器正在运行 ColdFusion MX。有关 Dreamweaver 测试服务器的更多信息，请参见“指定用于处理动态页的文件夹”。

若要调试 ColdFusion 页，请执行以下操作：
  1. 在 Dreamweaver 中打开该 ColdFusion 页。
  2. 单击文档工具栏上的“服务器调试”图标（带有地球仪和闪电图形的图标），或者选择“查看”>“服务器调试”。

    3. Dreamweaver 从 ColdFusion MX 服务器中请求该文件，然后在内部的 Internet Explorer 浏览器窗口中显示该文件。如果该页包含错误，错误的可能原因将出现在该页的底部。

    与此同时，“服务器调试”面板打开。该面板提供了大量的有用信息，例如服务器对其进行处理以呈现该页的所有页、在该页上执行的所有 SQL 查询以及所有服务器变量和它们的值（如果有）。该面板还会提供执行时间摘要。

  3. 如果“异常”类别出现在“服务器调试”面板上，则单击加号 (+) 图标展开该类别。

    4. 如果服务器遇到该页的问题，则“异常”类别会出现。展开该类别，对问题进行详细了解。

  4. 在“服务器调试”面板的“位置”列中，单击该页的 URL，在代码视图中打开该页并修正该页。

    5. 如果 Dreamweaver 可以定位该页，该页将打开，而问题行会在该页中高亮显示。如果 Dreamweaver 无法定位该页，它会向您询问其位置。

  5. 修正错误，将文件保存到服务器，然后单击“浏览”。

    6. Dreamweaver 在内部浏览器中再次呈现该页，并且更新“服务器调试”面板。如果该页不存在其他问题，则“异常”类别将不会重新出现在此面板上。

  6. 若要退出调试模式，请切换到代码视图（“查看”>“代码”）或设计视图（“查看”>“设计”）。

为了确保每次在内部浏览器中显示页时都刷新调试信息，请确保 Internet Explorer 将在每次请求文件时检查该文件的较新版本。在 Internet Explorer 中，选择“工具”>“Internet 选项”，选择“常规”选项卡，然后单击“Internet 临时文件”区域中的“设置”按钮。在“设置”对话框中，选择“每次访问此页时检查”选项。


设置 JavaScript 调试器选项

此调试器用于隔离客户端 JavaScript 代码中的错误。

任务

运行 JavaScript 调试器

查找和修正逻辑错误

设置断点

逐句调试代码

观察和编辑变量值

上一页


在设计视图中编辑代码

尽管 Macromedia Dreamweaver MX 允许您直观地创建和编辑 Web 页面，而无需为基础源代码操心，但有时候您可能需要编辑源代码以更好地控制您的 Web 页面或解决 Web 页面上出现的问题。

例如，假设您选择文档中的文本并应用新字体，但此操作只对一半的句子产生影响。通过查看代码，您发现结束 </font> 标签位于句子的中间。一旦将 </font> 移到句尾后，问题就解决了。

本章面向那些喜欢在设计视图中工作、但同时也想要快速访问代码的人士。Dreamweaver 使您可在设计视图中工作的同时编辑代码。

本章包含以下主题：

  • 使用属性检查器编辑代码
  • 使用标签编辑器编辑代码
  • 使用快速标签编辑器编辑代码
  • 使用标签选择器编辑代码
  • 编辑脚本
  • 使用 server-side include（服务器端包括）
下一页


使用属性检查器编辑代码

您可以使用属性检查器检查并编辑页面上文本或对象的属性。

若要使用属性检查器，请执行以下操作：
  1. 在文本中单击或选择页面上的对象。

    2. 文本或对象的属性检查器显示在文档窗口的下方。如果看不到属性检查器，则选择“窗口”>“属性”。

  2. 在属性检查器中对属性进行更改。


使用标签编辑器编辑代码

您可以使用标签编辑器检查和编辑页面上各对象的属性。

若要使用标签编辑器，请执行以下操作：
  1. 右击页面上的对象 (Windows) 或在按住 Control 键的同时单击页面上的对象 (Macintosh)，然后从弹出式菜单中选择“编辑标签”。

    2. 随即出现该对象的标签编辑器。

  2. 对对象的属性进行更改，然后单击“确定”。


使用快速标签编辑器编辑代码

您可以使用快速标签编辑器在不退出“设计”视图的情况下快速检查并编辑 HTML 标签。若要打开快速标签编辑器，请按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)。

本节包含以下主题：

  • 关于快速标签编辑器
  • 使用快速标签编辑器插入 HTML 标签
  • 使用快速标签编辑器编辑 HTML 标签
  • 使用快速标签编辑器将 HTML 应用于选定内容
  • 使用提示菜单


关于快速标签编辑器

快速标签编辑器具有三种模式：

  • “插入 HTML”模式插入新 HTML 代码
  • “编辑标签”模式编辑现有标签
  • “环绕标签”模式用新标签环绕当前选定内容

快速标签编辑器打开时所采用的模式取决于设计视图中当前的选定内容。在所有这三种模式中，使用快速标签编辑器的基本过程是相同的：打开编辑器，输入或编辑标签和属性，然后关闭编辑器。

您可以在快速标签编辑器处于活动状态的情况下，通过按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh) 在不同模式间切换。

如果您在快速标签编辑器中使用了任何无效的 HTML，Dreamweaver 将根据需要尝试通过插入结束引号和结束尖括号帮助您修改该 HTML。

若要执行更全面的 HTML 编辑，请使用代码视图。有关更多信息，请参见Dreamweaver 中的编码。

相关主题

使用快速标签编辑器插入 HTML 标签

使用快速标签编辑器编辑 HTML 标签

使用快速标签编辑器将 HTML 应用于选定内容

使用提示菜单


使用快速标签编辑器插入 HTML 标签

您可以使用快速标签编辑器在您的文档中插入 HTML 标签。

若要使用快速标签编辑器插入 HTML 标签，请执行以下操作：
  1. 在设计视图中，在页面上单击以将插入点放置于您要插入代码的地方。
  2. 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)。

    3. 快速标签编辑器以“插入 HTML”模式打开。
    这是所描述的功能的图片。

  3. 输入 HTML 标签并按 Enter 键。

    4. 标签被插入您的代码中。

  4. 按 Esc 键以在不进行任何更改的情况下退出。

相关主题

关于快速标签编辑器

使用快速标签编辑器编辑 HTML 标签

使用快速标签编辑器将 HTML 应用于选定内容

使用提示菜单


使用快速标签编辑器编辑 HTML 标签

您可以使用快速标签编辑器编辑文档中的 HTML 标签。

若要使用快速标签编辑器编辑 HTML 标签，请执行以下操作：
  1. 在设计视图中选择一个对象。

    2. 您还可以从文档窗口底部的标签选择器中选择要编辑的标签。有关更多信息，请参见使用标签选择器编辑代码。

  2. 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)。

    3. 快速标签编辑器以“编辑标签”模式打开。

  3. 输入新属性，编辑现有属性，或者编辑标签的名称。
  4. 按 Tab 键可以从一个属性前移到下一个属性；按 Shift+Tab 组合键可以返回到上一个属性。

    5. 默认情况下，在您按 Tab 键或 Shift+Tab 组合键后更改将被应用于文档。若要禁用自动更新，请选择“编辑”>“参数选择”>“快速标签编辑器”或“Dreamweaver”>“参数选择”>“快速标签编辑器”(Mac OS X)。随即显示快速标签编辑器“参数选择”对话框。取消对“编辑时立即应用更改”选项的选择，然后单击“确定”。有关更多信息，请参见设置快速标签编辑器参数。

  5. 若要关闭快速标签编辑器并应用所有更改，请按 Enter 键。
  6. 若要退出且不再进行任何更改，请按 Esc 键。

相关主题

关于快速标签编辑器

使用快速标签编辑器插入 HTML 标签

使用快速标签编辑器将 HTML 应用于选定内容

使用提示菜单


使用快速标签编辑器将 HTML 应用于选定内容

您可以使用快速标签编辑器用开始和结束 HTML 标签环绕文档中的选定内容。

若要使用快速标签编辑器将 HTML 应用于选定内容，请执行以下操作：
  1. 在设计视图中选择不含格式的文本或对象。

    2. 如果您选择包括开始或结束 HTML 标签的文本或对象，则快速标签编辑器将以“编辑标签”模式打开。

  2. 按 Ctrl+T 组合键 (Windows) 或 Command+T 组合键 (Macintosh)，或者在属性检查器中单击“快速标签编辑器”按钮。

    3. 快速标签编辑器以“环绕标签”模式打开。

  3. 输入单个开始标签，例如 <font="verdana">，然后按 Enter 键。

    4. 该标签被插入到当前选定内容的起始处，并在结尾处插入匹配的结束标签。

  4. 按 Esc 键以在不进行任何更改的情况下退出。

相关主题

关于快速标签编辑器

使用快速标签编辑器插入 HTML 标签

使用快速标签编辑器编辑 HTML 标签

使用提示菜单


使用提示菜单

在快速标签编辑器中，您可以访问某个属性的提示菜单，该菜单将列出您正编辑或插入的标签的所有有效属性。如果 Dreamweaver 不识别您正编辑的标签，则提示菜单包含 Dreamweaver 为所有标签识别的所有属性。

您还可以在快速标签编辑器中禁用提示菜单或调整菜单弹出前的延迟。

若要查看某一标签的有效属性的列表，在快速标签编辑器中编辑属性名称时暂停几秒钟。随即显示提示菜单，菜单中列出您正编辑的标签的所有有效属性。

按如下所示使用提示菜单：

  • 在您开始键入属性名称时，提示菜单滚动以高亮显示以您键入的字母起始的第一个属性名称。
  • 若要在菜单中上移和下移高亮显示的内容，请使用上箭头键和下箭头键或使用滚动条。
  • 若要选择高亮显示的属性名称，请按 Enter 键。您还可以在菜单中双击某一属性名称。
  • 若不选择项即退出提示菜单，请按 Esc 键或继续键入即可。

如果在输入或编辑某一标签名称时暂停，将出现类似的提示菜单，菜单中列出标签名称而不是属性名称。

若要禁用提示菜单或更改提示菜单出现前的延迟，请执行以下操作：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后选择“快速标签编辑器”。

    2. 随即显示快速标签编辑器“参数选择”对话框。

  2. 若要禁用提示菜单，请取消对“启用标签提示”选项的选择。
  3. 若要更改菜单弹出前的延迟，请调整“延迟”滑块。

    4. 有关更多信息，请参见设置快速标签编辑器参数。

  4. 单击“确定”。

相关主题

关于快速标签编辑器

使用快速标签编辑器编辑 HTML 标签


使用标签选择器编辑代码

您可以在不退出设计视图的情况下使用标签选择器选择、编辑或删除标签。标签选择器位于“文档”窗口底部的状态栏中并显示如下所示的一系列标签。

若要编辑一个标签，请执行以下操作：
  1. 在文档中单击。

    2. 在插入点应用的标签显示在标签选择器中。

  2. 在标签选择器中右击标签 (Windows) 或在按住 Control 键的同时单击标签 (Macintosh)。

    3. 随即显示一个弹出式菜单。

  3. 从该菜单中选择“编辑标签”。

    4. 随即出现快速标签编辑器。有关更多信息，请参见使用快速标签编辑器编辑 HTML 标签。

若要删除一个标签，请执行以下操作：
  1. 在文档中单击。

    2. 在插入点应用的标签显示在标签选择器中。

  2. 在标签选择器中右击标签 (Windows) 或在按住 Control 键的同时单击标签 (Macintosh)。

    3. 随即显示一个弹出式菜单。

  3. 从该菜单中选择“删除标签”。
若要选择由标签表示的对象，请执行以下操作：
  1. 在文档中单击。

    2. 在插入点应用的标签显示在标签选择器中。

  2. 在标签选择器中单击一个标签。

    3. 由该标签表示的对象在页面上被选定。

提示： 使用此方法可以选择单独的表行（tr 标签）或单元格（td 标签）。


编辑脚本

您可以在代码视图和设计视图中使用客户端 JavaScript 和 VBScript。本节涵盖以下主题：

  • 在设计视图中写入客户端脚本
  • 链接到外部脚本文件
  • 在设计视图中编辑脚本


在设计视图中写入客户端脚本

您可以在不退出设计视图的情况下为您的页面写入 JavaScript 或 VBScript。在开始编辑前，确保 Dreamweaver 在页面上显示脚本标签。若要显示脚本标签，请选择“查看”>“可视化助理”>“不可见元素”。

若要在设计视图中插入客户端脚本，请执行以下操作：
  1. 将插入点放置于您需要脚本的地方。
  2. 选择“插入”>“脚本对象”>“脚本”。

    3. 随即显示“脚本”对话框。

  3. 完成该对话框并单击“确定”。

    4. 有关更多信息，请参见设置“脚本”对话框选项。

相关主题

链接到外部脚本文件

在设计视图中编辑脚本


链接到外部脚本文件

您可以在不退出设计视图的情况下，在您的文档中创建指向外部脚本文件的链接。在开始编辑前，确保 Dreamweaver 在页面上显示脚本标签。若要显示脚本标签，请选择“查看”>“可视化助理”>“不可见元素”。

若要链接到外部脚本文件，请执行以下操作：
  1. 将插入点放置于您需要脚本的地方。
  2. 选择“插入”>“脚本对象”>“脚本”。

    3. 随即显示“脚本”对话框。

  3. 单击“确定”，不在“内容”框中键入任何内容。
  4. 在文档窗口的设计视图中选择脚本标签。
  5. 在属性检查器中，单击文件夹图标以浏览到并选择外部脚本文件，或在“源文件”框中键入文件名。

相关主题

在设计视图中写入客户端脚本

在设计视图中编辑脚本


在设计视图中编辑脚本

您可以在不退出“设计”视图的情况下编辑脚本。在开始编辑前，确保 Dreamweaver 在页面上显示脚本标签。若要显示脚本标签，请选择“查看”>“可视化助理”>“不可见元素”。

若要在设计视图中编辑脚本，请执行以下操作：
  1. 选择脚本标签。
  2. 在属性检查器中，单击“编辑”按钮。

    3. 在“脚本属性”对话框中随即出现该脚本。

    如果您已链接到外部脚本文件，则该文件自动在代码视图中打开，您可以在其中进行编辑。

    备注： 如果在脚本标签间存在代码，则“脚本属性”对话框将打开，即使还有指向某一外部脚本文件的链接。

  3. 对脚本进行编辑并单击“确定”。

    4. 有关更多信息，请参见设置“脚本属性”对话框选项。

相关主题

在设计视图中写入客户端脚本

链接到外部脚本文件


使用 server-side include（服务器端包括）

server-side include（服务器端包括）是对 Web 服务器的指令，它指示 Web 服务器在将页面提供给浏览器前在 Web 页面中包含指定的文件。您可以使用 Dreamweaver 在您的页面中插入 server-side include（服务器端包括），编辑 include（包含），或者预览包含 include（包含）的页面。

本节涵盖以下主题：

  • 关于 server-side include（服务器端包括）
  • 插入 server-side include（服务器端包括）
  • 编辑 server-side include（服务器端包括）的内容


关于 server-side include（服务器端包括）

在您打开位于 Web 服务器上的文档时，该服务器处理 include（包含）指令并创建新文档，在新文档中 include（包含）指令被所包括的文件的内容代替。然后服务器将此新文档发送给您的浏览器。但当您在浏览器中直接打开一个本地文档时，因为没有服务器可以处理该文档中的 include（包含）指令，所以浏览器不处理这些指令即打开该文档，并且应该包括在内的文件并未在该浏览器中出现。因此，如果不使用 Dreamweaver，可能很难查看到本地文件在放置到服务器后对访问者的显示效果。

但通过使用 Dreamweaver，无论是在设计视图中还是在浏览器中预览时，您都可以预览文档，查看到文档在放置到服务器后的显示效果。

将 server-side include（服务器端包括）放置于文档中将插入对外部文件的引用；它不在当前文档中插入指定文件的内容。Dreamweaver 在设计视图中显示外部文件的内容，这使其更便于设计页面。

您不能在文档中直接编辑包括的文件。若要编辑 server-side include（服务器端包括）的内容，您必须直接编辑您所包括的文件。对外部文件的所有更改都将自动反映在包括该文件的每一文档中。

有两种类型的 server-side include（服务器端包括）：“虚拟”类型和“文件”类型。选择使用哪一类型取决于您所使用的 Web 服务器类型：

  • 如果您的服务器是 Apache Web 服务器，则选择“虚拟”类型。（这是 Dreamweaver 中的默认选择。）在 Apache 中，“虚拟”可以适用于所有情况，而“文件”只适用于某些情况。
  • 如果您的服务器是 Microsoft Internet Information Server (IIS)，则选择“文件”。（“虚拟”只在某些特定的情况下才用于 IIS。）但可惜的是，IIS 不允许您包括在文件夹层次结构中高于当前文件夹的文件夹中的文件，除非在服务器上已安装了特殊的软件。如果您需要在 IIS 服务器上包括来自文件夹层次结构中更高层次的文件夹中的文件，请向您的系统管理员咨询以了解是否安装了必需的软件。
  • 对于其他类型的服务器，或者如果您不知道您正使用哪一类型的服务器，请向您的系统管理员咨询以了解要使用的选项。

某些服务器经过配置，可以检查所有文件以查看它们是否包含 server-side include（服务器端包括）；而其他一些服务器经过配置，只检查具有特定文件扩展名的文件，例如 .shtml、.shtm 或 .inc。如果某一 server-side include（服务器端包括）不适用于您，请向您的系统管理员咨询以了解您是否需要在使用 include（包含）的文件的名称中使用特殊扩展名。（例如，如果该文件名为 canoe.html，则您可能需要将其重命名为 canoe.shtml。）如果您希望您的文件保留 .html 或 .htm 扩展名，请要求您的系统管理员对服务器进行配置，以检查所有文件（而不只是具有某一扩展名的文件）是否具有 server-side include（服务器端包括）。但由于为 server-side include（服务器端包括）分析文件需要多花一些时间，所以服务器进行分析的那些页面可能要比其他页面稍晚一点才可供使用；因此某些系统管理员将不提供对所有文件进行分析的选项。

相关主题

插入 server-side include（服务器端包括）

编辑 server-side include（服务器端包括）的内容


插入 server-side include（服务器端包括）

您可以使用 Dreamweaver 在您的页面中插入 server-side include（服务器端包括）。

若要插入 server-side include（服务器端包括），请执行以下操作：
  1. 选择“插入”>“脚本对象”>“服务器端包括”。
  2. 在显示的对话框中，浏览到并选择一个文件。
若要更改所包括的文件，请执行以下操作：
  1. 在文档窗口中选择 server-side include（服务器端包括）。
  2. 打开属性检查器（“窗口”>“属性”）。
  3. 执行以下操作之一：
    • 单击文件夹图标并浏览到要包括的新文件，然后选择该文件。
    • 在文本框中，键入要包括的新文件的路径和文件名。

相关主题

关于 server-side include（服务器端包括）

编辑 server-side include（服务器端包括）的内容


编辑 server-side include（服务器端包括）的内容

您可以使用 Dreamweaver 编辑 server-side include（服务器端包括）。若要编辑与包括的文件关联的内容，您必须打开该文件。

若要编辑 server-side include（服务器端包括），请执行以下操作：
  1. 在设计视图或代码视图中选择 server-side include（服务器端包括），然后在属性检查器中单击“编辑”。

    2. 包括的文件在新的文档窗口中打开。

  2. 编辑该文件，然后保存它。

    3. 所做更改将立即在当前文档以及您打开的包括该文件的所有随后文档中反映出来。

相关主题

关于 server-side include（服务器端包括）

插入 server-side include（服务器端包括）


参考资料

本节提供在本章中介绍的几个对话框和属性检查器的有关信息。


设置快速标签编辑器参数

通过此对话框可以控制是否在“文档”窗口中自动更新您在“快速标签编辑器”中所进行的编辑。此外，利用此对话框还可以控制快速标签编辑器的提示菜单。

过程
  1. 若要在“编辑标签”模式中的各属性之间移动时自动更新文档，请选择“编辑时立即应用更改”选项。

    2. 如果禁用此选项，则您必须按 Enter 键才可以将所做更改应用于文档。（通过按 Enter 键应用的多个更改在“历史记录”面板中显示为单个步骤，并且可以通过单个“撤消”操作撤消。）

    备注： 在“插入 HTML”模式和“环绕标签”模式中将忽略此选项。在这两个模式中，您必须始终按 Enter 键以将您的更改应用于文档。

  2. 若要禁用提示菜单，请取消对“启用标签提示”选项的选择。
  3. 若要在快速标签编辑器中更改菜单弹出前的延迟，请调整“延迟”滑块。

相关主题

使用快速标签编辑器编辑代码


设置“脚本”对话框选项

此对话框用于将客户端脚本插入代码中。

过程
  1. 从“语言”弹出式菜单中选择脚本撰写语言。

    2. 如果您正使用 JavaScript 并且不能确定所用的版本，则选择 JavaScript 而不是 JavaScript1.1 或 JavaScript1.2。

  2. 在“内容”文本框中输入您的脚本代码。

    3. 您不需要包括开始和结束 script 标签。

相关主题

编辑脚本


设置“脚本属性”对话框选项

此对话框用于修改页面上的脚本。

过程
  1. 在“语言”文本框中，指定 JavaScript 或 VBScript 作为脚本语言。
  2. 在“类型”文本框中，指定脚本的类型，脚本类型可以是客户端或服务器端。
  3. 在“源文件”文本框中，指定外部链接的脚本文件。

    4. 单击文件夹图标以选择该文件，或者键入路径。

  4. 在“脚本”文本框中，编辑或写入您的脚本。
  5. 单击“确定”以应用所做编辑。

相关主题

在设计视图中编辑脚本


设置脚本属性检查器选项

此属性检查器用于检查和修改页面上的脚本。

过程
  1. 在“语言”文本框中，指定 JavaScript 或 VBScript 作为脚本语言。
  2. 在“类型”文本框中，指定脚本的类型，脚本类型可以是客户端或服务器端。
  3. 在“源文件”文本框中，指定外部链接的脚本文件。

    4. 单击文件夹图标以选择该文件，或者键入路径。

  4. 单击“编辑”以修改脚本。

    5. 有关更多信息，请参见设置“脚本属性”对话框选项。

相关主题

在设计视图中编辑脚本


设置 server-side include（服务器端包括）属性检查器选项

此属性检查器用于在设计视图中检查和修改 server-side include（服务器端包括）。

过程
  1. 若要更改在文档中包括的文件，请执行以下操作之一：
    • 单击文件夹图标并浏览到和选择要包括的新文件。
    • 在文本框中，键入要包括的新文件的路径和文件名。
  2. 若要编辑 server-side include（服务器端包括），单击“编辑”按钮，在新的文档窗口中编辑打开的文件，然后保存该文件。

    3. 所做更改将立即在当前文档以及您打开的包括该文件的所有随后文档中反映出来。

相关主题

插入 server-side include（服务器端包括）

编辑 server-side include（服务器端包括）的内容

关于 server-side include（服务器端包括）


设置 ColdFusion 标签属性检查器选项

此属性检查器用于在设计视图中检查和修改 ColdFusion 标签。

过程
  1. 单击“属性”按钮以编辑标签的属性或添加新属性。
  2. 如果该标签在其开始标签和结束标签之间有内容，则单击“内容”按钮以编辑该内容。

    3. 只有当选定标签不是空标签时（即，它具有开始标签和结束标签），才显示“内容”按钮。

  3. 如果该标签包含条件表达式，则在“表达式”文本框中对表达式进行更改。


设置 ASP 脚本属性检查器选项

此属性检查器用于在设计视图中检查和修改 ASP 服务器端脚本。

过程
  1. 单击“编辑”按钮。
  2. 在显示的对话框中编辑 ASP 服务器端脚本。
  3. 单击“确定”以应用所做编辑。
上一页


设计页面布局

使用 Dreamweaver 中的可视化设计工具创建复杂的页面布局。

此部分包含以下各章：

  • 使用表格显示内容
  • 在布局视图中对页进行布局
  • 使用框架


使用表格显示内容

表格是用于在 HTML 页上显示表格式数据以及对文本和图形进行布局的强有力的工具。表格由一行或多行组成；每行又由一个或多个单元格组成。虽然 HTML 代码中通常不明确指定列，但 Dreamweaver 允许您像操作行和单元格那样来操作列。

在创建表格之后，就可以方便地修改其外观和结构。您可以执行以下任意操作：

  • 添加内容
  • 添加、删除、拆分及合并行和列
  • 修改表格、行或单元格属性以添加颜色和对齐
  • 拷贝和粘贴单元格

备注： 许多设计人员使用表格对 Web 页进行布局。Dreamweaver 提供两种方式来查看和操作表格：标准视图和布局视图。在标准视图中，表格显示为行和列的网格，而布局视图允许您在将表格用作基础结构的同时在网页上绘制、移动方框以及调整方框的大小（请参见在布局视图中对页进行布局）。

本章包含以下几节：

  • 插入表格
  • 向表格单元格添加内容
  • 导入表格式数据
  • 选择表格元素
  • 设置表格和单元格的格式
  • 调整表格的大小
  • 更改列宽和行高
  • 添加及删除行和列
  • 嵌套表格
  • 剪切、拷贝和粘贴单元格
  • 对表格进行排序
  • 导出表格数据
  • 参考资料
下一页


插入表格

使用“插入”栏或“插入”菜单来创建一个新表格。有关在 Dreamweaver 中创建有辅助功能的表格的信息，请参见为辅助功能而创作。

若要插入表格，请执行以下操作：
  1. 在文档窗口的设计视图中，将插入点放在需要表格出现的位置。

    2. 备注： 如果您的文档不包含任何内容，则只能将插入点放置在文档的开头。

  2. 执行以下操作之一：
    • 单击“插入”栏“常用”类别中的“表格”按钮。
    • 选择“插入”>“表格”。

      • 即会出现“插入表格”对话框。

  3. 按需要输入新值。

    4. 有关更多信息，请参见设置“插入表格”对话框选项。
    这是所描述的功能的图片。


向表格单元格添加内容

您可以像在表格外部添加文本和图像那样在表格单元格中添加文本和图像。

有关更多信息，请参见插入文本和设置文本格式和插入图像。

当在表格中添加或编辑内容时，使用键盘在表格中定位可以节省不少时间。

若要使用键盘从一个单元格移动到另一个单元格，请执行以下任意操作：
  • 按 Tab 键移动到下一个单元格。

    • 在表格的最后一个单元格中按 Tab 键会自动在表格中另外添加一行。

  • 按 Shift 键 + Tab 键移动到上一个单元格。
  • 按箭头键上下左右移动。


导入表格式数据

可以将在另一个应用程序（例如 Microsoft Excel）中创建并以分隔文本的格式（其中的项以制表符、逗号、冒号、分号或其他分隔符隔开）保存的表格式数据导入到 Dreamweaver 中并设置为表格的格式。

若要导入表格数据，请执行以下操作：
  1. 执行以下操作之一：
    • 选择“文件”>“导入”>“表格式数据”。
    • 选择“插入”>“表格对象”>“导入表格式数据”。

      • 即会出现“导入表格式数据”对话框。
      这是所描述的功能的图片。

  2. 在该对话框中，输入有关包含数据的文件的信息。

    3. 有关更多信息，请参见设置“导入表格式数据”对话框选项。

相关主题

显示数据库记录


选择表格元素

可以一次选择整个表、行或列。还可以在表格中选择一个连续的单元格块。在选择了表格或单元格之后，您可以执行以下操作：

  • 修改所选单元格或它们中所包含文本的外观。请参见设置表格和单元格的格式。
  • 拷贝和粘贴单元格。请参见剪切、拷贝和粘贴单元格。

您还可以选择表格中多个不相邻的单元格并修改这些单元格的属性。不能拷贝或粘贴不相邻的单元格组。

若要选择整个表格，请执行以下操作之一：
  • 单击表格的左上角或者单击右边或底部边缘的任意位置。
  • 单击表格单元格，然后在文档窗口左下角的标签选择器中选择 table 标签。
  • 单击表格单元格，然后选择“修改”>“表格”>“选择表格”。
  • 单击表格单元格，然后在标签检查器中选择 table 标签。

    • 所选表格的下边缘和右边缘出现选择控制点。
    这是所描述的功能的图片。

若要选择行或列，请执行以下操作：
  1. 定位鼠标指针使其指向行的左边缘或列的上边缘。
  2. 当鼠标指针变为选择箭头时，单击以选择行或列，或进行拖动以选择多个行或列。
    这是所描述的功能的图片。
若要选择单个单元格，请执行以下操作之一：
  • 单击单元格，然后在文档窗口左下角的标签选择器中选择 td 标签。
  • 单击单元格，然后选择“编辑”>“全选”。

    • 提示： 选择了单元格后再次选择“编辑”>“全选”可以选择整个表格。

  • 单击表格单元格，然后在标签检查器中选择 td 标签。
若要选择一行或矩形的单元格块，请执行以下操作之一：
  • 从一个单元格拖到另一个单元格。
  • 单击一个单元格，然后按住 Shift 键单击另一个单元格。

    • 这两个单元格定义的直线或矩形区域中的所有单元格都将被选中。
    这是所描述的功能的图片。

若要选择不相邻的单元格，请执行以下操作：

在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击要选择的单元格、行或列。

如果按住 Ctrl 键或 Command 键单击尚未选中的单元格、行或列，则会将其选中。如果它已经被选中，则再次单击会将其从选择中删除。


设置表格和单元格的格式

可以通过设置表格及表格单元格的属性或将预先设置的设计应用于表格来更改表格的外观。请参见查看和设置表格属性、查看和设置单元格、行和列的属性和使用设计方案对表格进行格式设置。

若要设置表格中文本的格式，可以对所选的文本应用格式设置或使用样式。请参见插入文本和设置文本格式。


关于表格格式设置中的冲突

当在设计视图中对表格进行格式设置时，您可以设置整个表格或表格中所选行、列或单元格的属性。如果将整个表格的某个属性（例如背景颜色或对齐）设置为一个值，而将单个单元格的属性设置为另一个值，则单元格格式设置优先于行格式设置，行格式设置又优先于表格格式设置。

表格格式设置的优先顺序如下：

  1. 单元格
  2. 行
  3. 表格

例如，如果将单个单元格的背景颜色设置为蓝色，然后将整个表格的背景颜色设置为黄色，则蓝色单元格不会变为黄色，因为单元格格式设置优先于表格格式设置。

备注： 当设置列的属性时，Dreamweaver 更改对应于该列中每个单元格的 td 标签的属性。


查看和设置表格属性

当选择了某个表格后，属性检查器允许您查看和更改表格属性。

若要查看表格属性，请执行以下操作：
  1. 选择该表格。
  2. 选择“窗口”>“属性”打开属性检查器。
若要查看所有表格的属性，请执行以下操作：

如果属性检查器未展开，则单击右下角的扩展箭头查看所有属性。

若要在属性检查器中设置表格的格式，请执行以下操作：
  1. 选择一个表格。有关更多信息，请参见选择表格元素。
  2. 选择“窗口”>“属性”打开属性检查器。
  3. 通过设置属性更改表格的格式设置。

    4. 有关更多信息，请参见设置表格属性。

相关主题

使用设计方案对表格进行格式设置


查看和设置单元格、行和列的属性

当选择了一个或一组单元格时，属性检查器允许您查看和更改单元格属性。

备注： 当设置列的属性时，Dreamweaver 更改对应于该列中每个单元格的 td 标签的属性。但是，当设置行的某些属性时，Dreamweaver 更改 tr 标签的属性而不是更改行中每个 td 标签的属性。在将同一种格式应用于行中的所有单元格时，将格式应用于 tr 标签会产生更简明易懂的 HTML 代码。

若要查看表格元素属性，请执行以下操作：
  1. 在行或列中选择一个或一组单元格。
  2. 选择“窗口”>“属性”打开属性检查器。
若要查看所有单元格、行或列的属性，请执行以下操作：

如果属性检查器未展开，则单击右下角的扩展箭头查看所有属性。

若要在属性检查器中对表格元素进行格式设置，请执行以下操作：
  1. 选择一个单元格、行或列。有关更多信息，请参见选择表格元素。
  2. 选择“窗口”>“属性”打开属性检查器。
  3. 通过设置属性更改表格元素的格式设置。

    4. 有关更多信息，请参见设置单元格、行和列属性。

相关主题

选择表格元素


使用设计方案对表格进行格式设置

使用“表格格式设置”命令将预先设置的设计快速应用到表格。然后，您可以选择选项进一步自定义该设计。

备注： 只有简单的表格才能使用预先设置的设计进行格式设置。您不能使用这些设计对包含合并单元格（colspan 或 rowspan）、列组或其他特殊格式设置（这些特殊格式设置使表格无法形成简单的矩形单元格网格）的表格进行格式设置。

若要使用预先设置的表格设计，请执行以下操作：
  1. 选择一个表格，然后选择“命令”>“表格格式设置”。

    2. 即会出现“表格格式设置”对话框。
    这是所描述的功能的图片。

  2. 按需要自定义选项。

    3. 有关更多信息，请参见设置“表格格式设置”对话框选项。

  3. 单击“应用”或“确定”用所选的设计对表格进行格式设置。


调整表格的大小

您可以调整整个表格或单个行和列的大小。当调整整个表格的大小时，表格中的所有单元格按比例更改大小。

备注： 如果表格的单元格指定了明确的宽度或高度，则调整表格大小会在文档窗口中更改单元格的可视大小，而不更改这些单元格的指定宽度和高度。

若要调整表格的大小，请执行以下操作：
  1. 选择表格。
  2. 执行以下操作之一：
    • 若要在水平方向调整表格的大小，请拖动右边的选择控制点。
    • 若要在垂直方向调整表格的大小，请拖动底部的选择控制点。
    • 若要在两个方向调整表格的大小，请拖动右下角的选择控制点。

相关主题

选择表格元素

更改列宽和行高


更改列宽和行高

通过使用属性检查器或拖动列或行的边框，您可以更改列宽或行高。您还可以使用代码视图直接在 HTML 代码中更改单元格的宽度和高度。

如果调整大小比较麻烦，可以清除列宽或行高并重新开始。

提示： 您可以按像素或百分比指定宽度和高度，并且可以在像素和百分比之间互相转换。有关更多信息，请参见查看和设置表格属性。

若要以可视方式调整列或行的大小，请执行以下操作之一：
  • 若要更改列宽，选择该列，然后拖动该列的右边框。

    • 如果该列不是表格中最右边的一列，则相邻列的宽度也将更改，使表格总宽度保持不变。如果该列是最右边的一列，则表格的总宽度将发生变化，并且所有的列将按比例变宽或变窄。

  • 若要更改行高，选择该行，然后拖动该行的下边框。
若要使用属性检查器设置列宽或行高，请执行以下操作：
  1. 选择列或行。
  2. 选择“窗口”>“属性”打开属性检查器。
  3. 通过设置属性更改表格元素的格式设置。

    4. 有关更多信息，请参见设置单元格、行和列属性。

若要清除所有已设置的宽度或高度，请执行以下操作：
  1. 选择表格。
  2. 执行以下操作之一：
    • 若要清除所有指定的宽度，请选择“修改”>“表格”>“清除单元格宽度”或单击属性检查器中的“清除列宽”按钮。
      这是所描述的功能的图片。
    • 若要清除所有指定的高度，请选择“修改”>“表格”>“清除单元格高度”或单击属性检查器中的“清除行高”按钮。
      这是所描述的功能的图片。

相关主题

选择表格元素

调整表格的大小

Dreamweaver 中的编码


添加及删除行和列

若要添加及删除行和列，请使用“修改”>“表格”子菜单中的命令。

提示： 在表格的最后一个单元格中按 Tab 键会自动在表格中另外添加一行。

若要添加行或列，请执行以下操作：
  1. 单击一个单元格。
  2. 执行以下操作之一：
    • 若要在当前单元格的上面添加一行，请选择“修改”>“表格”>“插入行”。
    • 若要在当前单元格的左边添加一列，请选择“修改”>“表格”>“插入列”。
    • 若要一次添加多行或多列，或者在当前单元格的下面添加行或在其右边添加列，请选择“修改”>“表格”>“插入行或列”。

      • 即会出现“插入行或列”对话框。

  3. 如果选择“插入行或列”，则在该对话框中输入必要的信息，然后单击“确定”。

    4. 有关更多信息，请参见设置“插入行或列”对话框选项。

若要删除行或列，请执行以下操作：
  1. 单击要删除的行或列中的一个单元格。
  2. 执行以下操作之一：
    • 若要删除行，请选择“修改”>“表格”>“删除行”。
    • 若要删除列，请选择“修改”>“表格”>“删除列”。

提示： 另外，您还可以选择完整的行或列，然后选择“编辑”>“清除”或按 Delete 键；整个行或列将从表格中删除。

若要使用属性检查器添加或删除行或列，请执行以下操作：
  1. 选择整个表格。
  2. 在属性检查器中，执行以下操作之一：
    • 增加或减少“行数”值以添加或删除行。

      • Dreamweaver 在表格的底部添加和删除行。

    • 增加或减少“列数”值以添加或删除列。

      • Dreamweaver 在表格的右边添加和删除列。

      备注： 当删除包含数据的行和列时，Dreamweaver 不发出警告。

相关主题

选择表格元素

插入重复表格

显示多个行为


拆分和合并单元格

使用属性检查器或“修改”>“表格”子菜单中的命令拆分或合并单元格。只要整个选择部分的单元格形成一行或一个矩形，您便可以合并任意数目的相邻的单元格，以生成一个跨多个列或行的单元格。您可以将单元格拆分成任意数目的行或列，而不管它是否是合并的。Dreamweaver 将自动重新构造表格（添加任何必需的 COLSPAN 或 ROWSPAN 属性），以创建指定的排列方式。

在下面的插图中，已将前两行中间的单元格合并，因此它们跨两行。

另一种合并和拆分单元格的方法是使用 Dreamweaver 中提供的增加和减少单元格所跨行数或列数的工具。

若要合并表格中的两个或多个单元格，请执行以下操作：
  1. 选择单元格。所选的单元格必须是连续的，并且形状必须为矩形。

    2. 在下面的插图中，所选部分是矩形的单元格，因此可以合并这些单元格。
    这是所描述的功能的图片。

    在下面的插图中，所选部分不是矩形，因此不能合并这些单元格。
    这是所描述的功能的图片。

  2. 选择“修改”>“表格”>“合并单元格”，或单击属性检查器中的“合并单元格”按钮。

    3. 单个单元格的内容放置在最终的合并单元格中。所选的第一个单元格的属性将应用于合并的单元格。

若要拆分单元格，请执行以下操作：
  1. 单击单元格。
  2. 选择“修改”>“表格”>“拆分单元格”，或单击属性检查器中的“拆分单元格”按钮。
  3. 在“拆分单元格”对话框中，指定如何拆分单元格。

    4. 有关更多信息，请参见设置“拆分单元格”对话框选项。

若要增加或减少单元格所跨的行或列的数目，请执行以下操作：
  1. 选择一个单元格。
  2. 选择“修改”>“表格”>“增加行宽”或“修改”>“表格”>“增加列宽”；或者“修改”>“表格”>“减少行宽”或“修改”>“表格”>“减少列宽”。


嵌套表格

嵌套表格是在另一个表格的单元格中的表格。可以像对其他任何表格一样对嵌套表格进行格式设置；但是，其宽度受它所在单元格的宽度的限制。

若要在表格单元格中嵌套表格，请执行以下操作：
  1. 单击现有表格中的一个单元格。
  2. 选择“插入”>“表格”。
  3. 在“插入表格”对话框中，为嵌套表格指定所需的属性，然后单击“确定”。


剪切、拷贝和粘贴单元格

您可以一次剪切、拷贝或粘贴单个表格单元格或多个单元格，并保留单元格的格式设置。

您可以在插入点或替换现有表格中的所选部分粘贴单元格。若要粘贴多个表格单元格，剪贴板的内容必须和表格的结构或表格中将粘贴这些单元格的所选部分兼容。

若要剪切或拷贝表格单元格，请执行以下操作：
  1. 选择表格中的一个或多个单元格。所选的单元格必须是连续的，并且形状必须为矩形。

    2. 在下面的插图中，所选部分是矩形的单元格，因此可以剪切或拷贝这些单元格。
    这是所描述的功能的图片。

    在下面的插图中，所选部分不是矩形，因此不能剪切或拷贝这些单元格。
    这是所描述的功能的图片。

  2. 使用“编辑”>“剪切”或“编辑”>“拷贝”来剪切或拷贝单元格。

    3. 如果您选择了整个行或列并选择“编辑”>“剪切”，则将从表格中删除整个行或列（而不仅仅是单元格的内容）。

若要粘贴表格单元格，请执行以下操作：
  1. 选择要粘贴单元格的位置。
    • 若要用您正在粘贴的单元格替换现有的单元格，请选择一组与剪贴板上的单元格具有相同布局的现有单元格。例如，如果您拷贝或剪切了一块 3 x 2 的单元格，则可以选择另一块 3 x 2 的单元格通过粘贴进行替换。
    • 若要在特定单元格上方粘贴一整行单元格，请单击该单元格。
    • 若要在特定单元格左侧粘贴一整列单元格，请单击该单元格。
    • 若要用粘贴的单元格创建一个新表格，请将插入点放置在表格之外。

      • 备注： 如果剪贴板中的单元格不到一整行或一整列，并且您单击某个单元格然后粘贴剪贴板中的单元格，则您所单击的单元格和与它相邻的单元格可能（根据它们在表格中的位置）被您粘贴的单元格替换。

  2. 选择“编辑”>“粘贴”。

    3. 如果您将整个行或列粘贴到现有的表格中，则这些行或列将被添加到该表格中。如果您粘贴单个单元格，则将替换所选单元格的内容。如果您在表格外进行粘贴，则这些行、列或单元格用于定义一个新表格。

若要删除单元格内容，但使单元格保持原样，请执行以下操作：
  1. 选择一个或多个单元格。（确保所选部分不是完全由完整的行或列组成的。）
  2. 选择“编辑”>“清除”或按 Delete 键。

备注： 如果在您选择“编辑”>“清除”或按 Delete 键时只选择了完整的行或列，则将从表格中删除整个行或列，而不仅仅是它们的内容。

若要删除包含合并单元格的行或列，请执行以下操作：
  1. 选择要删除的行或列。
  2. 选择“修改”>“表格”>“删除行”或“修改”>“表格”>“删除列”。


对表格进行排序

您可以根据单个列的内容对表格中的行进行排序。您还可以根据两个列的内容执行更加复杂的表格排序。

您不能对包含 COLSPAN 或 ROWSPAN 属性的表格（即包含合并单元格的表格）进行排序。（有关更多信息，请参见拆分和合并单元格。）

若要对表格进行排序，请执行以下操作：
  1. 选择表格（或单击任意单元格）。
  2. 选择“命令”>“排序表格”。

    3. 即会出现“排序表格”对话框。

  3. 在“排序表格”对话框中，指定如何对表格进行排序。

    4. 有关更多信息，请参见设置“排序表格”对话框选项。


导出表格数据

您可以将表格数据从 Dreamweaver 导出到文本文件中，相邻单元格的内容由分隔符隔开。您可以将逗号、冒号、分号或空格用作分隔符。

当导出表格时，将导出整个表格，您不能选择导出部分表格。如果只需要表格中的某些数据（例如前六行或前六列），则拷贝包含这些数据的单元格，将这些单元格粘贴到表格外（创建新表格），然后导出该新表格。

若要导出表格，请执行以下操作：
  1. 请将插入点放置在表格中的任意单元格中。
  2. 选择“文件”>“导出”>“表格”。

    3. 即会出现“导出表格”对话框。
    这是所描述的功能的图片。

  3. 在“导出表格”对话框中，指定导出表格的选项。

    4. 有关更多信息，请参见设置“导出表格”对话框选项。

  4. 单击“导出”。
  5. 在出现的对话框中，输入文件的名称，然后单击“保存”。


参考资料

本节提供在本章介绍的对话框和检查器的有关信息。


设置“插入表格”对话框选项

此对话框允许您在插入表格之前指定其属性。

若要填写“插入表格”对话框，请执行以下操作：
  1. 指定以下选项：

    2. “行数”确定表格具有的行的数目。

    “列数”确定表格具有的列的数目。

    “单元格填充”确定单元格内容和单元格边界之间的像素数。

    “单元格间距”确定相邻的表格单元格之间的像素数。

    提示： 如果您没有明确指定单元格间距和单元格边距的值，则大多数浏览器按单元格边距设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器显示的表格没有边距和间距，请将“单元格填充”和“单元格间距”设置为 0。

    “宽度”以像素为单位或按占浏览器窗口宽度的百分比指定表格的宽度。

    “边框”指定表格边框的宽度（以像素为单位）。

    提示： 如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边界，请选择“查看”>“可视化助理”>“表格边框”。

  2. 单击“确定”创建表格。

若要插入表格而无需指定这些选项，请关闭“常规”参数选择中的“插入对象时显示对话框”选项。请参见设置“常规”参数。

相关主题

插入表格


设置“导入表格式数据”对话框选项

此对话框允许您指定有关表格式数据文件的信息，并指定要使用这些数据创建的表格的属性。

若要填写“导入表格式数据”对话框，请执行以下操作：
  1. 指定以下选项：

    2. “数据文件”是要导入的文件的名称。单击“浏览”按钮选择一个文件。

    “分隔符”是正在导入的文件中所使用的分隔符。

    如果您选择“其他”，则一个文本框出现在弹出式菜单的右侧。输入您的文件中使用的分隔符。

    备注： 确保指定保存数据文件时使用的分隔符。如果未能做到，则无法正确地导入文件，您的数据也无法在表格中进行正确的格式设置。

    “表格宽度”是将创建的表格的宽度。选择“匹配内容”使每个列足够宽以适应该列中最长的文本字符串。选择“指定宽度”将以像素为单位或按占浏览器窗口宽度的百分比指定固定的表格宽度。

    “单元格填充”是单元格内容和单元格边界之间的像素数。

    “单元格间距”是相邻的表格单元格之间的像素数。

    提示： 如果您没有明确指定单元格间距和单元格边距的值，则大多数浏览器按单元格边距设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器显示的表格没有边距和间距，请将“单元格填充”和“单元格间距”设置为 0。

    “格式化首行”确定应用于表格首行的格式设置（如果存在）。从四个格式设置选项中进行选择：无格式、粗体、斜体或加粗斜体。

    “边框”以像素为单位指定表格边框的宽度。

    提示： 如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边界，请选择“查看”>“可视化助理”>“表格边框”。

  2. 单击“确定”。

相关主题

导入表格式数据


设置表格属性

此属性检查器允许您设置表格的属性。

若要设置表格属性，请执行以下操作：
  1. 设置以下任一选项：

    2. “表格 ID”是表格的 ID。

    “行”和“列”是表格中行和列的数目。

    “宽”和“高”是以像素为单位或按占浏览器窗口宽度的百分比计算的表格的宽度和高度。

    备注： 通常不需要设置表格的高度。

    “边距”是单元格内容和单元格边界之间的像素数。

    “间距”是相邻的表格单元格之间的像素数。

    提示： 如果您没有明确指定单元格间距和单元格边距的值，则大多数浏览器按单元格边距设置为 1，单元格间距设置为 2 显示表格。若要确保浏览器显示的表格没有边距和间距，请将“单元格填充”和“单元格间距”设置为 0。

    “对齐”确定表格相对于同一段落中其他元素（例如文本或图像）的显示位置。“左对齐”沿其他元素的左侧对齐表格（因此同一段落中的文本在表格的右侧换行）；“右对齐”沿其他元素的右侧对齐表格（文本在表格的左侧换行）；“居中对齐”将表格居中（文本显示在表格的上方和/或下方）。“默认”指示浏览器应该使用其默认对齐方式。

    提示： 当将对齐方式设置为“默认”时，其他内容不显示在表格的旁边。若要在其他内容旁边显示表格，请使用“左对齐”或“右对齐”。

    “边框”指定表格边框的宽度（以像素为单位）。

    提示： 如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边界，请选择“查看”>“可视化助理”>“表格边框”。

    “清除列宽”和“清除行高”按钮从表格中删除所有显式指定的行高或列宽值。

    “将表格宽度转换成像素”和“将表格高度转换成像素”按钮将表格中每个列的宽度或高度设置为以像素为单位的当前宽度（还将整个表格的宽度设置为以像素为单位的当前宽度）。

    “将表格宽度转换成百分比”和“将表格高度转换成百分比”按钮将表格中每个列的宽度或高度设置为按占文档窗口宽度百分比表示的当前宽度（还将整个表格的宽度设置为按占文档窗口宽度百分比表示的当前宽度）。

    “背景颜色”是表格的背景颜色。

    “边框颜色”是表格边框的颜色。

    “背景图像”是表格的背景图像。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

查看和设置表格属性

使用颜色

链接文件和文档

选择表格元素

查看和设置单元格、行和列的属性


设置单元格、行和列属性

此属性检查器允许您设置表格元素（单元格、行和列）的属性。

备注： 当设置列的属性时，Dreamweaver 更改对应于该列中每个单元格的 td 标签的属性。但是，当设置行的某些属性时，Dreamweaver 更改 tr 标签的属性而不是更改行中每个 td 标签的属性。当将同一种格式应用于行中的所有单元格时，将格式应用于 tr 标签会产生更简明易懂的 HTML 代码。

若要设置表格元素的属性，请执行以下操作：
  1. 设置以下任一选项：

    2. “水平”指定单元格、行或列内容的水平对齐方式。您可以将内容对齐到单元格的左侧、右侧或使之居中对齐，也可以指示浏览器使用其默认的对齐方式（通常常规单元格为左对齐，标题单元格为居中对齐）。

    “垂直”指定单元格、行或列内容的垂直对齐方式。您可以将内容对齐到单元格的顶端、中间、底部或基线，或者指示浏览器使用其默认的对齐方式（通常是居中对齐）。

    “宽”和“高”是以像素为单位或按占整个表格宽度或高度百分比计算的所选单元格的宽度和高度。若要指定百分比，请在值后面使用百分比符号 (%)。若要让浏览器根据单元格的内容以及其他列和行的宽度和高度确定适当的宽度或高度，请将此域留空（默认设置）。

    默认情况下，浏览器选择一列的宽度来容纳列中最宽的图像或最长的行。这就是为什么当您将内容添加到某个列时，该列有时变得比表格中其他列宽得多的原因。

    默认情况下，浏览器选择一行的高度来容纳该行中的所有文本和图像。

    备注： 您可以按占表格总高度的百分比指定一个高度，但是浏览器中行可能不以指定的百分比高度显示。

    “背景”（上面的文本域）是单元格、列或行背景图像的文件名。单击文件夹图标浏览到某个图像，或使用“指向文件”图标选择某个图像文件。

    “背景颜色”（下面的颜色样本和文本域）是使用颜色选择器选择的单元格、列或行的背景颜色。

    “边框”是单元格的边框颜色。

    “合并单元格”按钮将所选的单元格、行或列合并为一个单元格（请参见拆分和合并单元格）。只有当单元格形成矩形或直线的块时才可以合并这些单元格。

    “拆分单元格”按钮分开一个单元格，创建两个或多个单元格。请参见拆分和合并单元格。一次只能拆分一个单元格；如果选择的单元格多于一个，则此按钮将禁用。

    “不换行”可以防止换行，从而使给定单元格中的所有文本都在一行上。如果启用了“不换行”，则当您键入数据或将数据粘贴到单元格时单元格会加宽来容纳所有数据。（通常，单元格在水平方向扩展以容纳单元格中最长的单词或最宽的图像，然后根据需要在垂直方向进行扩展以容纳其他内容。）

    “标题”将所选的单元格格式设置为表格标题单元格。默认情况下，表格标题单元格的内容为粗体并且居中。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

查看和设置单元格、行和列的属性

选择表格元素

查看和设置表格属性

使用颜色

链接文件和文档


设置“表格格式设置”对话框选项

此对话框允许您选择预先设置好格式的表格设计应用到表格中。

若要填写“表格格式设置”对话框，请执行以下操作：
  1. 从左边的列表中选择设计方案。

    2. 示例表格显示所选设计的示例。

  2. 指定以下选项：

    3. “行颜色”选项指定应用于行的颜色，以及颜色交替的频率。

    “第一行”选项指定表格第一行（可能包含列标题）的对齐方式、文本样式、背景颜色和文本颜色。

    “最左列”选项指定表格最左列（可能包含行标题）的对齐方式和文本样式。

    “边框”是表格边框的宽度（以像素为单位）。

    提示： 如果您没有明确指定边框的值，则大多数浏览器按边框设置为 1 显示表格。若要确保浏览器显示的表格没有边框，请将“边框”设置为 0。若要在边框设置为 0 时查看单元格和表格边界，请选择“查看”>“可视化助理”>“表格边框”。

    “将所有属性套用至 TD 标签而不是 TR 标签”将设计应用于表格单元格（td 标签）而不是表格行（tr 标签）。

    默认情况下，“表格格式设置”对话框中指定的格式设置应用于整个行而不是单个单元格。在将同一种格式应用于行中的所有单元格时，将格式应用于 tr 标签会产生更简明易懂的 HTML 代码。但是，此选项允许您将格式设置应用于单个单元格（如果这是您的编码偏好的话）。有关更多信息，请参见设置表格和单元格的格式。

  3. 执行以下操作之一：
    • 单击“应用”在不关闭对话框的情况下将格式设置应用于您的表格。然后对格式设置进行更改，或者单击“确定”或“取消”关闭对话框。
    • 单击“确定”将格式设置应用于您的表格并关闭对话框。


设置“插入行或列”对话框选项

此对话框允许您将一个或多个行或列插入到表格中。

若要填写“插入行或列”对话框，请执行以下操作：
  1. 指定以下选项：

    2. “插入”指示是插入行还是列。

    “行数”或“列数”是要插入的行或列的数目。

    “位置”指定新行或新列应该显示在所选单元格所在行或列的前面还是后面。

  2. 单击“确定”。

相关主题

添加及删除行和列


设置“拆分单元格”对话框选项

此对话框允许您指定如何拆分表格单元格。

若要填写“拆分单元格”对话框，请执行以下操作：
  1. 指定以下选项：

    2. “把单元格拆分成”指定将单元格拆分成行还是列。

    “行数”/“列数”指定将单元格拆分成多少行或列。

  2. 单击“确定”。


设置“排序表格”对话框选项

此对话框用于指定表格的排序方式。

若要填写“排序表格”对话框，请执行以下操作：
  1. 指定以下选项：

    2. “排序方式”确定哪个列的值将用于对表格的行进行排序。

    “顺序”确定是按字母还是按数字顺序以及是以升序（A 到 Z，小数字到大数字）还是降序对列进行排序。

    当列的内容是数字时，选择“按数字顺序”。如果按字母顺序对一组由一位或两位数组成的数字进行排序，则会将这些数字作为单词进行排序（排序结果如 1、10、2、20、3、30），而不是将它们作为数字进行排序（排序结果如 1、2、3、10、20、30）。

    “再按”/“顺序”确定在不同列上第二种排序方法的排序顺序。在“再按”弹出式菜单中指定应用第二种排序方法的列，并在“顺序”弹出式菜单中指定第二种排序方法的排序顺序。

    “排序包含第一行”指定表格的第一行应该包括在排序中。如果第一行是标题，不应移动，则不选择此选项。

    “对 THEAD 行（如果存在）进行排序”指定使用与 body 行相同的条件对表格 thead 部分（如果存在）中的所有行进行排序。（请注意，即使在排序后 thead 行仍将保留在 thead 部分中并仍显示在表格的顶部。）有关 thead 标签的信息，请参见“参考”面板（选择“帮助”>“参考”）。

    “对 TFOOT 行（如果存在）进行排序”指定使用与 body 行相同的条件对表格 tfoot 部分（如果存在）中的所有行进行排序。（请注意，即使在排序后 tfoot 行仍将保留在 tfoot 部分中并仍显示在表格的底部。）有关 tfoot 标签的信息，请参见“参考”面板（选择“帮助”>“参考”）。

    “排序的行保留 TR 属性”指定排序后表格行的属性（例如颜色）应该保持与相同内容的关联。如果表格行使用两种交替的颜色，则取消选择此选项以确保排序后的表格仍具有颜色交替的行。如果行属性特定于每行的内容，则选择此选项以确保这些属性保持与排序后表格中正确的行关联在一起。

  2. 单击“应用”或“确定”。


设置“导出表格”对话框选项

此对话框允许您设置分隔符和换行符样式以通过从表格中导出数据来创建文本文件。

若要填写“导出表格”对话框，请执行以下操作：
  1. 指定以下选项：

    2. “分隔符”指定应该使用哪个分隔符字符在导出的文件中隔开各项。

    “换行符”指定您将在哪个操作系统中打开导出的文件：Windows、Macintosh 还是 UNIX。（不同的操作系统具有不同的指示文本行结尾的方式。）

  2. 单击“导出”。
上一页


在布局视图中对页进行布局

Dreamweaver 为您提供了对 Web 页进行布局的多种不同的方法。

创建页布局的一种常用的方法是使用 HTML 表格对元素进行定位。但是，使用表格进行布局不太方便，因为最初创建表格是为了显示表格数据，而不是用于对 Web 页进行布局。

为了简化使用表格进行页布局的过程，Dreamweaver提供了布局视图。在布局视图中，您可以使用表格作为基础结构来设计您的页，但是却避免了使用传统的方法创建基于表格的设计时经常出现的一些问题。例如，在布局视图中您可以在页上方便地绘制布局单元格，然后将这些单元格移动到所需的位置。您还可以方便地创建固定宽度的布局和自动伸展为整个浏览器窗口宽度的布局（请参见设置列宽度）。

您仍可以以传统方式使用表格对页进行布局（请参见使用表格显示内容），或使用层对页进行布局然后将它们转换为表格（请参见将表和层用于布局）。但是，布局视图是设置页布局的最简单的方法。

备注： 在布局视图中，您不能使用在“标准”视图中可以使用的“插入表格”和“绘制层”工具。若要使用这些工具，您必须先切换到“标准”视图。

本章包含以下几节：

  • 关于布局单元格和表格
  • 切换到和切换出布局视图
  • 绘制布局单元格和表格
  • 将内容添加到布局单元格中
  • 移动布局单元格和表格及调整它们的大小
  • 设置布局单元格和表格的格式
  • 设置列宽度
  • 设置布局视图参数
  • 参考资料
下一页


关于布局单元格和表格

在布局视图中，您可以在添加内容之前对页进行布局。例如，您可以沿页的顶部绘制一个单元格放置标题图形，在页的左边绘制另一个单元格放置导航条，在右边绘制第三个单元格放置内容。

（另一种方法是只有当您准备要放置内容时才绘制每一单元格。这种方法提供了最大的灵活性；它将布局表格中更多空白空间保留更长一段时间，这样可以使您更方便地移动单元格或调整单元格的大小。）

当您不在布局表格中绘制布局单元格时，Dreamweaver 会自动创建一个布局表格以容纳该单元格。布局单元格不能存在于布局表格之外。

您可以在一个布局表格中使用多个布局单元格对页进行布局，这是进行 Web 页布局最常用的方法，或者您可以使用多个布局表格进行更复杂的布局。使用多个布局表格会将您的布局隔离为多个部分，这样每个部分不会受其他部分中所进行更改的影响。

您还可以通过将一个新的布局表格放置在现有的布局表格中进行布局表格嵌套。当布局中某一部分的行或列不与布局中另一部分的行或列对齐时，该结构使您可以简化表格结构。例如，使用嵌套布局表格您可以方便地创建一个两列布局，左边一列有四行，右边一列有三行。有关更多信息，请参见绘制嵌套布局表格。


切换到和切换出布局视图

在绘制布局表格或布局单元格之前，必须从标准视图切换到布局视图。

提示： 如果您在标准视图中创建了一个表格，然后切换到布局视图，则结果布局表格可能包含空布局单元格。您需要先删除这些空布局单元格才能创建新的布局单元格或移动布局单元格。当您创建一个要在布局视图中进行编辑的新布局时，在布局视图中创建该表格要比在标准视图中创建简单一些。

若要切换到布局视图，请执行以下操作：
  1. 如果“设计”视图不可见，请选择“查看”>“设计”或“查看”>“代码和设计”。

    2. 在代码视图中不能启用或禁用布局视图。

  2. 选择“查看”>“表格视图”>“布局视图”或单击插入栏“布局”类别中的“布局视图”按钮。（在Dreamweaver 4 样式的浮动工作区中，插入栏是垂直方向的，与布局相关的项显示在面板的底部，而不是一个单独的分类。）

    3. 沿“设计”视图的顶部显示一个标有“布局视图”的灰色栏，指示您正处于“布局”视图中。如果您的页上存在表格，则它们显示为布局表格。

若要切换出布局视图，请执行以下操作：
  1. 如果“设计”视图不可见，请选择“查看”>“设计”或“查看”>“代码和设计”。

    2. 在代码视图中不能启用或禁用布局视图。

  2. 选择“查看”>“表格视图”>“标准视图”或单击插入栏“布局”类别中的“标准视图”按钮。


绘制布局单元格和表格

在布局视图中，您可以在页上绘制布局单元格和布局表格。当您不在布局表格中绘制布局单元格时，Dreamweaver 会自动创建一个布局表格以容纳该单元格。布局单元格不能存在于布局表格之外。

备注： 当Dreamweaver自动创建布局表格时，该表格最初显示为填满整个设计视图，即使您更改文档窗口的大小也是如此。这种全窗默认布局表格使您可以在设计视图中的任意位置绘制布局单元格。您可以将该表格设置为特定的大小，方法是单击表格边框然后拖动表格的调整大小控制点。

若要绘制布局单元格，请执行以下操作：
  1. 确保您正在布局视图中（请参见切换到和切换出布局视图），然后单击插入栏“布局”分类中的“绘制布局单元格”按钮
    这是所描述的功能的图片。
    。（在Dreamweaver 4 样式的浮动工作区中，插入栏是垂直方向的，与布局相关的项显示在面板的底部，而不是一个单独的分类。）

    2. 鼠标指针变为加号 (+)。

  2. 将鼠标指针放置在页上要开始绘制单元格的位置上，然后拖动指针以创建布局单元格。若要创建多个单元格而不用每次都单击“绘制布局单元格”按钮，请按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 并拖动指针来创建每个布局单元格。

页上显示的单元格外框为蓝色。（蓝色是布局单元格的默认外框颜色。若要更改外框颜色，请参见设置布局视图参数。）如果显示布局表格标签，则每个单元格的宽度都显示在列顶部的列标题区域中（请参见设置布局视图参数）。有关列宽度的更多信息，请参见设置列宽度。

出现明亮的网格线，从新布局单元格的边缘向外延伸到包含该单元格的布局表格的边缘。这些线可以帮助您将新单元格和以前的单元格对齐，并帮助您显现基础 HTML 表格的结构。

Dreamweaver将新单元格的边缘与旁边现有单元格的边缘自动靠齐。（布局单元格不能重叠。）如果绘制单元格靠近包含它的布局表格的边缘，则单元格的边缘也会与该表格的边缘自动靠齐。若要临时禁用靠齐，可在绘制单元格时按住 Alt 键 (Windows) 或 Option 键 (Macintosh)。

若要绘制布局表格，请执行以下操作：
  1. 确保您正在布局视图中。然后执行以下操作之一：
    • 若要绘制一个布局表格，请单击插入栏“布局”分类中的“绘制布局表格”按钮
      这是所描述的功能的图片。
      。鼠标指针变为加号 (+)。
    • 若要绘制多个布局表格而不必重复单击“绘制布局表格”按钮，请在单击“绘制布局表格”按钮时按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh)。绘制完一个布局表格之后，您可以立即绘制另一个。
  2. 将鼠标指针放置在页上，然后拖动指针以创建布局表格。

    3. 如果页上没有其他内容，则新表格自动定位在该页的左上角。

页上显示的表格外框为绿色。（绿色是布局表格的默认外框颜色。若要更改外框颜色，请参见设置布局视图参数。）一个标有布局表格 的标签出现在您所绘制的每个表格的顶部，用来帮助您选择表格以及将它和页上的其他元素进行区分。

如果显示布局表格标签，则表格的宽度（以像素为单位，或按占页宽度的百分比表示）显示在表格顶部的列标题区域中（请参见设置布局视图参数）。有关表格和列宽度的更多信息，请参见设置列宽度。

您可以在页布局的空白区域中创建布局表格，也可以在现有布局单元格和表格的周围或嵌套在现有布局表格中创建布局表格。表格不能互相重叠，但一个表格可以完全包含在另一个表格当中。有关更多信息，请参见绘制嵌套布局表格。

提示： 您不能在现有内容旁边绘制布局表格。如果您的页上已包含内容，则只能在现有内容的下方绘制新的布局表格。如果您尝试在现有内容之下绘制布局表格但是出现禁止绘制鼠标指针，请重新调整文档窗口的大小以使现有内容底部和窗口底部之间产生更多的空白空间。


绘制嵌套布局表格

您可以将一个布局表格绘制在另一个布局表格中，创建嵌套表格。对外部表格所进行的更改不会影响嵌套表格中的单元格；例如，当您更改外部表格中行或列的大小时，内部表格中单元格的大小不发生变化。

您可以插入多级嵌套表格。嵌套布局表格的大小不能超过包含它的表格。

备注： 如果您在未绘制任何布局单元格之前在页的中央绘制一个布局表格，则绘制的表格将自动嵌套在一个更大的表格中。

若要绘制嵌套布局表格，请执行以下操作：
  1. 确保您正在布局视图中，然后单击
    这是所描述的功能的图片。
    插入栏“布局”分类中的“绘制布局表格”按钮。

    2. 鼠标指针变为加号 (+)。

  2. 指向现有布局表格中的空白（灰色）区域，然后拖动指针以创建嵌套布局表格。

    3. 备注： 您不能在布局单元格中创建布局表格。您只能在现有布局表格的空白区域中或在现有单元格周围创建嵌套布局表格。

若要在现有布局单元格或表格周围绘制布局表格，请执行以下操作：
  1. 确保您正在布局视图中，然后单击插入栏“布局”分类中的“绘制布局表格”按钮。

    2. 鼠标指针变为加号 (+)。

  2. 在一组现有布局单元格或表格的周围绘制一个矩形。

    3. 出现一个新的嵌套布局表格，围起现有的单元格或表格。

    提示： 若要使现有布局单元格紧贴到新嵌套表格的一个角上，请在靠近该单元格一角的位置开始拖动；新表格的一角将靠齐到该单元格的一角上。您不能在布局单元格的中央开始拖动，因为您不能完全在一个布局单元格中创建布局表格。


将布局单元格靠齐到网格

您可以打开Dreamweaver网格将其用作绘制布局的可视化向导。您可以让页元素在移动时自动靠齐到网格，还可以通过指定网格设置更改网格或控制靠齐行为。不管网格是否可见，靠齐都将发挥作用。

若要显示或隐藏网格，请执行以下操作：

选择“查看”>“网格”>“显示网格”。

若要启用或禁用靠齐，请执行以下操作：

选择“查看”>“网格”>“靠齐到网格”。

若要更改网格设置，请执行以下操作：
  1. 选择“查看”>“网格”>“网格设置”。

    2. 即会出现“网格设置”对话框。
    这是所描述的功能的图片。

  2. 按需要设置选项。

    3. 有关更多信息，请参见设置“网格设置”对话框选项。

  3. 单击“确定”。


将内容添加到布局单元格中

在布局视图中您可以将文本、图像和其他内容添加到布局单元格中，就象在标准视图中将内容添加到表格单元格一样。单击您要添加内容的单元格，然后键入文本或插入其他内容。

您可以将内容插入布局单元格中，而不是布局表格的空白（灰色）区域，因此在可以添加内容之前，必须先创建布局单元格（请参见绘制布局单元格和表格）。

当您添加宽度大于布局单元格的内容时，该单元格将自动扩展。当单元格扩展时，该单元格所在的列也随之扩展，这可能会改变周围单元格的大小。该列的列标题区域变为显示代码中显示的宽度，后面的括号中是该列的可视宽度（屏幕上显示的宽度）。（有关列宽度的更多信息，请参见设置列宽度。）

若要将文本添加到布局单元格，请执行以下操作：

将插入点放置在您要添加文本的布局单元格中，然后执行以下操作之一：

  • 在单元格中键入文本。当进行键入时，单元格将按需要自动扩展。
  • 粘贴从其他文档拷贝的文本。使用“粘贴”命令。有关更多信息，请参见插入 HTML 文本和设置 HTML 文本格式。
若要将图像添加到布局单元格中，请执行以下操作：
  1. 将插入点放置在您要添加图像的布局单元格中。
  2. 执行下列操作之一：
    • 单击插入栏“常用”类别中的“插入图像”按钮。
    • 选择“插入”>“图像”。
  3. 在“选择图像”对话框中，选择一个图像文件。

有关更多信息，请参见插入图像。


清除自动设置的单元格高度

当创建布局单元格时，Dreamweaver自动指定单元格的高度，使单元格以您绘制的高度显示，即使单元格是空的也是如此。在将内容插入到单元格之后，您可能不再需要指定的高度，因此您可以从表格中删除显式单元格高度。

若要清除单元格高度，请执行以下操作之一：
  • 在列标题菜单中选择“清除单元格高度”。

    • Dreamweaver清除该表格中指定的所有高度。某些表格单元格在垂直方向上可能会收缩。
    这是所描述的功能的图片。

  • 通过单击表格顶部的标签选择该布局表格，然后单击属性检查器中的“清除行高”按钮。

    • Dreamweaver清除该表格中指定的所有高度。


移动布局单元格和表格及调整它们的大小

为了调整页布局，您可以对布局单元格和嵌套布局表格进行移动并调整它们的大小。（最外面的布局表格只能调整大小。）

布局单元格不能重叠。对单元格进行移动或调整大小之后，该单元格不能跨包含它的布局表格的边框。布局单元格不能小于其内容的大小。

调整布局表格的大小后，该布局表格不能小于包含所有其单元格的最小矩形的大小。调整布局表格的大小后还不能使其与其他表格或单元格重叠。

若要调整布局单元格的大小，请执行以下操作：
  1. 选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。

    2. 该单元格周围出现选择控制点。

  2. 拖动选择控制点来调整单元格的大小。
    这是所描述的功能的图片。

    3. 单元格边缘与其他单元格的边缘自动靠齐。

若要移动布局单元格，请执行以下操作：
  1. 选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。

    2. 该单元格周围出现选择控制点。

  2. 执行下列操作之一：
    • 将该单元格拖到其布局表格中的另一个位置。
    • 按箭头键移动该单元格，每次移动 1 个像素。在按住 Shift 键的同时按箭头键移动该单元格，每次 10 个像素。
若要调整布局表格的大小，请执行以下操作：
  1. 通过单击表格顶部的标签选择一个表格。

    2. 该表格周围出现选择控制点。

  2. 拖动选择控制点来调整表格的大小。

    3. 表格边缘与其他单元格和表格的边缘自动靠齐。

若要移动布局表格，请执行以下操作：
  1. 通过单击表格顶部的标签选择一个表格。

    2. 该表格周围出现选择控制点。

  2. 执行下列操作之一：
    • 将表格拖到页上的另一个位置。

      • 备注： 只有当布局表格嵌套在另一个布局表格中时，您才可以移动该布局表格。

    • 按箭头键移动该表格，每次移动 1 个像素。在按住 Shift 键的同时按箭头键移动该表格，每次 10 个像素。

相关主题

若要在移动单元格和表格或调整它们的大小时将 Dreamweaver 网格用作参考线，请参见将布局单元格靠齐到网格。


设置布局单元格和表格的格式

您可以通过使用属性检查器来更改任何布局单元格或表格的外观。


设置布局单元格的格式

您可以在属性检查器中设置布局单元格的多种属性，包括宽度和高度、背景颜色以及单元格内容的对齐方式。

若要在属性检查器中设置布局单元格的格式，请执行以下操作：
  1. 选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。
  2. 通过选择“窗口”>“属性”打开属性检查器。
  3. 通过设置属性更改单元格的格式设置。

    4. 有关更多信息，请参见设置布局单元格属性。


设置布局表格的格式

您可以在属性检查器中设置布局表格的多种属性，包括宽度、高度、填充和间距。

若要设置布局表格的格式，请执行以下操作：
  1. 选择一个表格，方法是单击该表格顶部的标签，或者单击标签选择器中的 <table> 标签。
  2. 通过选择“窗口”>“属性”打开属性检查器。
  3. 通过设置属性更改表格的格式设置。

    4. 有关更多信息，请参见设置布局表格属性。


设置列宽度

“布局”视图中的列可以具有固定的宽度，或者其宽度可以自动扩展以填充浏览器窗口中尽量大的部分（“自动伸展”）。如果显示布局表格标签，则有关宽度的信息将显示在所选表格每列顶部的列标题区域中（请参见设置布局视图参数）。

固定宽度的列具有特定数值的宽度，例如 300 像素；该宽度显示在列标题区域中（除非该列太窄以致于无法显示该数字）。自动伸展列的宽度随着浏览器窗口的宽度自动变化；自动伸展列的列标题区域显示波浪线而不是数字。如果您的布局中包括自动伸展列，则该布局始终在访问者浏览器窗口的整个宽度上显示。

备注： 您为列指定的宽度适用于该列中的所有单元格。

在给定的布局表格中，您只能让一个列自动伸展。常见的布局是让页上包含主要内容的列自动伸展，这会将所有其他列自动设置为固定宽度。

例如，假设您的布局在页的左边有一个较宽的图像，在右边有一列文本。您可能将左边的列设置为固定宽度，让侧栏区域自动伸展。

当您让某个列自动伸展时，Dreamweaver会在固定宽度的列中插入间隔图像以确保这些列保持应有的宽度，除非您指定不使用间隔图像。间隔图像是透明的图像，用于控制间距，它在浏览器窗口中是不可见的。有关更多信息，请参见使用间隔图像。

备注： 在布局完成之前让某个列自动伸展可能会对表格布局产生意想不到的效果。为了防止列变得出乎意料得宽或窄，在让某个列自动伸展之前，请先创建完整的布局，并在使列自动伸展时使用间隔图像。（但是，如果每个列都包含其他内容，可以使该列保持所需的宽度，则无需使用间隔图像。）

有时，“布局”视图中显示的列的可视宽度与 HTML 代码中指定的宽度不匹配。在这种情况下，列标题区域中将显示两个数字。（有关不一致宽度的更多信息，请参见设置布局表格属性。）

若要让某个列自动伸展，请执行以下操作之一：
  • 在固定宽度列顶部的列标题区域中，从列标题菜单中选择“列设置为自动伸展”。在给定的表格中您只能让一个列自动伸展。
    这是所描述的功能的图片。
  • 在列中选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。然后在属性检查器中单击“自动伸展”。
若要将某个列设置为固定宽度，请执行以下操作之一：
  • 在自动伸展列顶部的列标题区域中，从列标题菜单中选择“使列宽度固定”。

    • “使列宽度固定”（在代码中）为该列指定一个宽度，该宽度与该列的当前可视宽度匹配。

  • 在列中选择一个单元格，方法是单击该单元格的边缘，或者在按住 Ctrl 键 (Windows) 或 Command 键 (Macintosh) 的同时单击该单元格中的任何位置。然后在属性检查器中单击“固定”并键入数值。

    • 如果您输入的数值小于列内容的宽度，则 Dreamweaver 将自动设置宽度以匹配内容的宽度。

若要设置 HTML 代码中指定的单元格的宽度以匹配单元格的可视宽度，请执行以下操作：

从任何列的列标题菜单中选择“使单元格宽度一致”。

相关主题

设置布局视图参数

设置布局表格属性


使用间隔图像

间隔图像（也叫做间隔 GIF）是透明的图像，用来控制自动伸展表格中的间距。间隔图像由一个单像素的透明 GIF 图像组成，向外伸展到指定像素数的宽度。浏览器绘制的表格列不能窄于该列的单元格中所包含的最宽图像，因此在表格列中放置间隔图像要求浏览器至少应该保持该列与该图像一样宽。

当您设置某列自动伸展时，Dreamweaver将自动添加间隔图像，除非您指定不使用任何间隔图像。如果愿意，您可以在每个列中手动插入和删除间隔图像。包含间隔图像的列在列标题区域中具有双线。

备注： 如果选择不在自动伸展的表格中使用间隔图像，则固定宽度的列可能会改变大小，如果不包含内容，它们甚至会从设计视图中完全消失。（即使这些列不显示在“设计”视图中，它们仍将存在于代码中。）

当您在列中插入间隔图像或将列设置为自动伸展时，将出现一个对话框，询问您要如何设置间隔图像文件。如果您已经在Dreamweaver参数选择中为该站点设置了间隔图像，则不出现该对话框（请参见设置布局视图参数）。

您可以手动插入和删除特定列中的间隔图像或删除页中的所有间隔图像。

若要设置间隔图像，请执行以下操作：
  1. 使列自动伸展，或从列标题菜单中选择“添加间隔图像”。
    这是所描述的功能的图片。

    2. 即会出现“选择间隔图像”对话框。

  2. 选择其中的一个选项。

    3. 有关更多信息，请参见设置“选择间隔图像”对话框选项。

  3. 单击“确定”。
若要将间隔图像插入到列中，请执行以下操作：

从列标题菜单中选择“添加间隔图像”。

间隔图像被插入到该列中。该图像是不可见的，但该列可能稍有移位，顶部显示双线指示它包含一个间隔图像。

若要从列中删除间隔图像，请执行以下操作：

从列标题菜单中选择“删除间隔图像”。

间隔图像被删除。列可能会产生移位。

若要从表格中删除所有间隔图像：

执行下列操作之一：

  • 在表格中任何列的列标题菜单中选择“删除所有间隔图像”。
  • 在布局表格属性检查器中单击“删除所有间隔图像”按钮。
    这是所描述的功能的图片。

整个表格的布局可能会产生移位。如某些列中没有内容，则这些列可能从设计视图中完全消失。


设置布局视图参数

使用“参数选择”对话框中的“布局视图”分类来指定有关间隔图像文件和有关Dreamweaver用来绘制布局表格和布局单元格的颜色的信息。

默认情况下，一个标有布局表格 的标签显示在布局视图中每个布局表格的顶部，一组列宽度控件显示在当前选中的布局表格的顶部。如果愿意，您可以不让这些标签和控件显示出来。

备注： 即使当显示标签时，页顶部的布局表格在选中时也不具有标签。页顶部布局表格的标签只在该表格未选中时显示。

若要设置布局视图参数，请执行以下操作：
  1. 选择“编辑”>“参数选择”。
  2. 从“分类”列表中选择“布局视图”。
  3. 按需要进行更改。

    4. 有关更多信息，请参见设置“布局视图参数选择”对话框选项。

  4. 单击“确定”关闭该对话框。
若要关闭布局视图中的布局表格标签和列宽度控件，请执行以下操作：

选择“查看”>“表格视图”>“显示布局表格标签”。


参考资料

本节提供此章中介绍的有关对话框和检查器的信息。


设置布局单元格属性

此属性检查器允许您设置布局单元格的属性。

若要设置布局单元格的属性，请执行以下操作：
  1. 设置以下任意选项：

    2. 固定将单元格设置为固定宽度。在旁边的文本框中输入宽度（以像素为单位）（请参见设置列宽度）。

    自动伸展使单元格自动伸展（请参见设置列宽度）。

    高度是单元格的高度（以像素为单位）。

    背景颜色是布局单元格的背景颜色。单击颜色框并在颜色选择器中选择一种颜色，或在旁边的文本框中输入对应于某种颜色的十六进制数字。

    水平设置单元格内容的水平对齐。您可以将该对齐设置为“左对齐”、“居中对齐”、“右对齐”或“默认”。

    垂直设置单元格内容的垂直对齐。您可以将该对齐设置为“顶端”、“中间”、“底部”、“基线”或“默认”。

    不换行防止单词换行。当选择了此选项后，布局单元格按需要加宽以适应文本，而不是在新的一行上继续该文本。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

设置布局单元格和表格的格式


设置布局表格属性

此属性检查器允许您设置布局表格的属性。

若要设置布局表格的属性，请执行以下操作：
  1. 设置以下任意选项：

    2. 固定将表格设置为固定宽度。在旁边的文本框中输入宽度（以像素为单位）（请参见设置列宽度）。

    自动伸展使表格最右边的列自动伸展（请参见设置列宽度）。

    高度是表格的高度（以像素为单位）。

    单元格边距设置布局单元格内容和单元格边框之间的空间量（以像素为单位）。

    如果您更改单元格边距时一个带有括号的数字显示在布局表格的某个列标题中，则使用下面所述的“使单元格宽度一致”选项。

    单元格间距设置相邻布局单元格之间的空间量（以像素为单位）。

    如果您更改单元格间距时一个带有括号的数字显示在布局表格的某个列标题中，则使用下面所述的“使单元格宽度一致”选项。

    清除行高删除布局表格中所有单元格的显式高度设置。

    即使某些单元格是空的，Dreamweaver也会在您绘制单元格时指定显式单元格高度以显示您的布局。因此，您应该先将内容放置到布局单元格后才单击该按钮；否则，空单元格将在垂直方向收缩。

    备注： “清除行高”可能会对布局表格中的空白（灰色）区域（即不包含任何单元格的区域）产生意想不到的效果。特别是某些空白行可能从表格中被完全删除，表格看上去在垂直方向发生收缩。

    使单元格宽度一致如果您的布局中有固定宽度的单元格，则该选项使 HTML 代码中的单元格宽度与它们在屏幕上的外观宽度匹配。

    当您单击“使单元格宽度一致”时，Dreamweaver将重置表格中每个单元格在 HTML 中指定的宽度以匹配该单元格中内容的宽度。

    例如，如果您将布局单元格的宽度设置为 200 像素（或绘制一个 200 像素宽的布局单元格），然后添加宽度伸展为 250 像素的内容，则两个数字都显示在该单元格列顶部的标题区域中：引号中的“200”（代码中指定的宽度）和括号中的 (250)（可视宽度，也就是单元格当前在您的屏幕中显示时所呈现的宽度）。单击“使单元格宽度一致”将代码中指定的宽度更改为 250 以匹配可视宽度。

    删除所有间隔图像从您的布局表格中删除间隔图像（用来在布局中控制间距的透明图像）。（有关更多信息，请参见使用间隔图像。）

    备注： “删除间隔图像”可能导致表格中的某些列变得非常窄。通常情况下，您应该在适当的位置保留间隔图像，除非每个列都包含其他内容可以将该列保持在所需的宽度。

    删除嵌套删除嵌套在另一个布局表格中的布局表格，而不丢失它的任何内容。

    内部的布局表格消失；它包含的布局单元格成为外部表格的一部分。

  2. 如果您在文本框中输入了值，则可以按 Tab 键或Enter 键 (Windows) 或 Return 键 (Macintosh) 来应用该值。

相关主题

设置布局单元格和表格的格式


设置“选择间隔图像”对话框选项

如果您正在使列自动伸展，则此对话框允许您选择是否使用间隔图像以及使用哪一个间隔图像。

如果您正在将间隔图像添加到列，则此对话框允许您选择使用哪一个间隔图像。

若要填写“选择间隔图像”对话框，请执行以下操作：
  1. 选择以下选项之一：

    2. 创建间隔图像文件创建一个 GIF 图像以用作间隔图像，并允许您选择一个存储该间隔图像文件的文件夹，例如您站点的图像文件夹。这是推荐的选项，除非您已经为站点创建了一个间隔图像文件。

    使用现有的间隔图像文件允许您指定现有的间隔图像文件用于自动伸展表格中。间隔图像应该是单像素的透明 GIF。

    不要对自动伸展表格使用间隔图像指定 Dreamweaver 应该避免向表格自动添加间隔图像。（如果您插入间隔图像时没有使列自动伸展，则不会出现此选项。）如果您选择此选项，则布局中固定宽度的列可能收缩为一个较小的宽度，或甚至收缩为零宽度；间隔图像帮助将布局的结构维持在最初绘制它时的状态。只有当您已经将足够的内容放置在固定宽度的列中以防止它们收缩时或者已经手动添加了间隔图像时，才使用此选项。

  2. 单击“确定”。

相关主题

使用间隔图像


设置“布局视图参数选择”对话框选项

此对话框允许您设置布局视图参数选择。

若要填充“布局视图参数选择”对话框，请执行以下操作：
  1. 指定以下任意选项：

    2. 自动插入间隔图像指定Dreamweaver是否应该在您将列设置为自动伸展时自动插入间隔图像（请参见设置列宽度）。

    间隔图像为您的站点设置间隔图像文件。从“站点”菜单中选择一个站点，然后单击“创建”按钮创建一个新的间隔图像文件，或单击“浏览”按钮定位该站点中现有的间隔图像文件。

    单元格外框设置布局单元格外框的颜色。

    单元格高亮设置当移动鼠标指针指向某个单元格时该布局单元格外框变为的颜色。

    表格外框设置布局表格外框的颜色。

    表格背景设置用于布局表格中没有布局单元格的区域的颜色。

  2. 单击“确定”。

相关主题

设置布局视图参数

上一页


使用框架

框架提供将一个浏览器窗口划分为多个区域、每个区域都可以显示不同 HTML 文档的方法。使用框架的最常见的情况就是，一个框架显示包含导航控件的文档，而另一个框架显示含有内容的文档。

例如，您的框架布局可能由 3 个框架组成：一个较窄的框架位于侧面，其中包含导航条；一个框架横放在顶部，其中包含 Web 站点的徽标和标题；一个大框架占据了页面的其余部分，其中包含主要内容。这些框架中的每一个都显示单独的 HTML 文档。

在此示例中，当访问者浏览站点时，在顶部框架中显示的文档永远不更改。侧面框架导航条包含链接；单击其中某一链接会更改主要内容框架的内容，但侧面框架本身的内容保持静态。无论访问者在左侧单击了哪一个链接，右侧主要内容框架都会显示适当的文档。

有关设计和使用框架的所有方式的详细论述以及对它们进行硬编码所需的代码，并不在本章论述的范围之内。如果您需要有关在高级框架布局中使用的代码的详细信息，请参见有关框架和框架集的手册。

本章包含以下几节：

  • 关于框架和框架集
  • 决定是否使用框架
  • 关于在 Dreamweaver 中创建基于框架的 Web 页
  • 创建框架和框架集
  • 选择框架和框架集
  • 保存框架和框架集文件
  • 查看和设置框架属性
  • 查看和设置框架集属性
  • 控制具有链接的框架内容
  • 处理不能显示框架的浏览器
  • 将 JavaScript 行为用于框架
  • 参考资料
下一页


关于框架和框架集

框架是浏览器窗口中的一个区域，它可以显示与浏览器窗口的其余部分中所显示内容无关的 HTML 文档。

框架集是 HTML 文件，它定义一组框架的布局和属性，包括框架的数目、框架的大小和位置以及在每个框架中初始显示的页面的 URL。框架集文件本身不包含要在浏览器中显示的 HTML 内容，但 noframes 部分除外（请参见处理不能显示框架的浏览器）；框架集文件只是向浏览器提供应如何显示一组框架以及在这些框架中应显示哪些文档的有关信息。

要在浏览器中查看一组框架，请输入框架集文件的 URL；浏览器随后打开要显示在这些框架中的相应文档。通常将一个站点的框架集文件命名为 index.html，以便当访问者未指定文件名时默认显示该名称。

请注意，框架不是文件。您很可能会以为当前显示在框架中的文档是构成框架的一部分，但该文档实际上并不是框架的一部分 - 任何框架都可以显示任何文档。

备注： 页面一词含义较为宽泛，既可以表示单个 HTML 文档，也可以表示给定时刻浏览器窗口中的全部内容，即使当时同时显示有几个 HTML 文档。例如，短语“使用框架的页面”通常表示一组框架以及最初在这些框架中显示的文档。

在 Dreamweaver 中，您可以用以下两种方式之一创建框架集：

  • 要创建一个框架集，其中一个框架显示当前文档，请使用“插入条的框架”类别。
  • 要创建一个框架集，其所有框架均为空，请在“新建文档”对话框中使用“框架集”类别。

您可以通过属性检查器设置所有框架和框架集的格式。您可以启用或禁用滚动、设置宽度和高度、命名每个框架等。有关更多信息，请参见查看和设置框架属性。

如果一个站点在浏览器中显示为包含三个框架的单个页面，则它实际上至少由四个单独的 HTML 文档组成：框架集文件以及三个文档，这三个文档包含在这些框架内初始显示的内容。当您在 Dreamweaver 中设计使用框架集的页面时，您必须保存全部这四个文件，以便该页面可以在浏览器中正常工作。有关如何成功创建使用框架的 Web 页的更多信息，请参见关于在 Dreamweaver 中创建基于框架的 Web 页。


决定是否使用框架

框架的最常见用途就是导航。一组框架通常包括一个含有导航条的框架和另一个要显示主要内容页面的框架。

但是，框架的设计可能比较复杂；并且在许多情况下，您可以创建没有框架的 Web 页，它可以达到使用一组框架所能达到的许多同样效果。例如，如果您想让导航条显示在页面的左侧，则既可以用一组框架代替您的页面，也可以只是在站点中的每一页上包含该导航条。(Dreamweaver 可以帮助您创建使用相同布局的多个页面；请参见关于 Dreamweaver 模板。）下图显示了具有类似框架布局的页面设计，但在设计中并没有使用框架。

许多专业 Web 设计人员不喜欢使用框架，并且许多浏览 Web 的人也不喜欢框架。在大多数情况下，这种反感是因为遇到了那些使用框架效果不佳或不必要地使用框架的站点（例如，每当访问者单击导航按钮时就重新加载导航框架内容的框架集）。如果框架使用得法（例如，在允许其他框架的内容发生更改的同时，使一个框架中的导航控件保持静态），则这些框架对于某些站点可能非常有用。

并不是所有的浏览器都提供良好的框架支持，框架对于无法导航的访问者而言可能难以显示。所以，如果您确实要使用框架，应始终在您的框架集中提供 noframes 部分，以方便不能查看这些框架的访问者。您最好还要提供指向站点的无框架版本的显式链接，以用于那些虽然其浏览器支持框架但不喜欢使用框架的访问者。

使用框架具有以下优点：

  • 访问者的浏览器不需要为每个页面重新加载与导航相关的图形。
  • 每个框架都具有自己的滚动条（如果内容太大，在窗口中显示不下），因此访问者可以独立滚动这些框架。（例如，当框架中的内容页面较长时，如果导航条位于不同的框架中，那么向下滚动到页面底部的访问者就不需要再滚动回顶部来使用导航条。）

使用框架具有以下缺点：

  • 可能难以实现不同框架中各元素的精确图形对齐。
  • 对导航进行测试可能很耗时间。
  • 各个带有框架的页面的 URL 不显示在浏览器中，因此访问者可能难以将特定页面设为书签（除非您提供了服务器代码，允许访问者加载特定页面的带框架版本。）

相关主题

控制具有链接的框架内容

处理不能显示框架的浏览器


关于在 Dreamweaver 中创建基于框架的 Web 页

Dreamweaver 允许您查看和编辑与一组框架关联的所有文档，这一切都可以在一个“文档”窗口中完成。此方法使您可以在编辑带有框架的页面时大致看到它们在浏览器中的显示方式。但是，在您熟练使用它们之前，此方法的某些方面可能会令人混淆。

尤其要记住，每个框架都显示单独的 HTML 文档。即使文档是空的，您也必须将它们全部保存以预览它们（因为只有当框架集包含要在每个框架中显示的文档的 URL 时，才可以准确预览该框架集）。

要确保框架集在浏览器中正确显示，请执行以下操作：
  1. 创建框架集并指定要在每个框架中显示的文档（请参见创建框架和框架集）。
  2. 保存将要在框架中显示的每个文件。请记住，每个框架都显示单独的 HTML 文档，每个文档都必须保存。还要保存框架集文件。（请参见保存框架和框架集文件。）
  3. 为每个框架和框架集设置属性。这包括命名每个框架、设置滚动和不滚动选项等。（请参见查看和设置框架属性和查看和设置框架集属性。）

    4. 提示： 您还可以设置框架的 title 属性以改进辅助功能。（请注意，title 属性与 name 属性不同。）若要设置 title 属性，请选择该框架并选择“修改”>“编辑标签”；然后选择“样式表/辅助功能”类别并在“标题”文本框中输入标题。也可以启用用于框架的辅助功能创作选项；有关更多信息，请参见为辅助功能而创作。

  4. 确保在属性检查器中为所有链接设置了“目标”属性，以便所链接的内容显示在正确区域中（请参见控制具有链接的框架内容）。


创建框架和框架集

在 Dreamweaver 中有两种创建框架集的方法：您既可以自己设计框架集，也可以从若干预定义的框架集中选择。选择预定义的框架集将自动设置创建布局所需的所有框架集和框架，它是迅速创建基于框架的布局的最简单方法。您只能在“文档”窗口的“设计”视图中插入预定义的框架集。


创建预定义的框架集

通过预定义的框架集，您可以很容易地选择您要创建的框架集类型。

创建预定义的框架集有两种方法：使用插入条和使用“新建文档”对话框。通过插入条，您可以创建框架集并在某一新框架中显示当前文档；“新建文档”对话框创建新的空框架集。

预定义的框架集图标（位于插入条的“框架”类别中和“新建文档”对话框的“框架集”类别中）提供应用于当前文档的每个框架集的可视化表示形式。

当您使用插入条应用框架集时，Dreamweaver 将自动设置该框架集，以便在某一框架中显示当前文档（插入点所在的文档）。预定义的框架集图标的蓝色区域表示当前文档，而白色区域表示将显示其他文档的框架。

要创建预定义的框架集并在某一框架中显示现有文档，请执行以下操作：
  1. 将插入点放置在文档中。
  2. 执行下列操作之一：
    • 在插入条的“框架”类别中，单击预定义框架集的图标。
    • 从“插入”>“框架”子菜单中选择预定义的框架集。
要创建新的空预定义框架集，请执行以下操作：
  1. 选择“文件”>“新建”。
  2. 在“新建文档”对话框中，选择“框架集”类别。
  3. 从“框架集”列表选择框架集。
  4. 单击“创建”。


创建和编辑框架集

在创建框架集或使用框架前，通过选择“查看”>“可视化助理”>“框架边框”，使框架边框在“文档”窗口的“设计”视图中可见。

若要创建框架集，请执行以下操作：

从“修改”>“框架集”子菜单选择拆分项（例如“拆分左框架”或“拆分右框架”）。

窗口被拆分成几个框架，并且您开始操作的文档显示在某一框架中。

要将一个框架拆分成几个更小的框架，请执行以下操作：
  • 要拆分插入点所在的框架，从“修改”>“框架集”子菜单选择拆分项。
  • 要以垂直或水平方式拆分一个框架或一组框架，请将框架边框从“设计”视图的边缘拖入“设计”视图的中间。
  • 要使用不在“设计”视图边缘的框架边框拆分一个框架，请在按住 Alt 键的同时拖动框架边框 (Windows) 或在按住 Option 键的同时拖动框架边框 (Macintosh)。
  • 要将一个框架拆分成四个框架，请将框架边框从“设计”视图一角拖入框架的中间。

    • 提示： 要创建三个框架，则首先创建两个框架，然后拆分其中一个框架。不编辑框架集代码是很难合并两个相邻框架的，所以将四个框架转换成三个框架要比将两个框架转换成三个框架更难。

若要删除一个框架，请执行以下操作：

将边框框架拖离页面或拖到父框架的边框上。

如果正被删除的框架中的文档有未保存的内容，则 Dreamweaver 将提示您保存该文档。

备注： 您不能通过拖动边框完全删除一个框架集。要删除一个框架集，请关闭显示它的“文档”窗口。如果该框架集文件已保存，则删除该文件。


关于嵌套的框架集

在另一个框架集之内的框架集称作嵌套的框架集。一个框架集文件可以包含多个嵌套的框架集。大多数使用框架的 Web 页实际上都使用嵌套的框架，并且在 Dreamweaver 中大多数预定义的框架集也使用嵌套。如果在一组框架里，不同行或不同列中有不同数目的框架，则要求使用嵌套的框架集。

例如，最常见的框架布局在顶行有一个框架（框架中显示公司的徽标），并且在底行有两个框架（一个导航框架和一个内容框架）。此布局要求嵌套的框架集：一个两行的框架集，在第二行中嵌套了一个两列的框架集。

Dreamweaver 会根据需要自动嵌套框架集；如果您在 Dreamweaver 中使用框架拆分工具，则您就不需要考虑哪些框架将被嵌套、哪些框架不被嵌套这样的细节。有关框架拆分工具的更多信息，请参见创建和编辑框架集。

有两种方法可在 HTML 中嵌套框架集：内部框架集可以与外部框架集在同一文件中定义，也可以在不同文件中单独定义。Dreamweaver 中每个预定义的框架集均在同一文件中定义其所有框架集。

这两种类型的嵌套均产生相同的视觉效果；如果没有看到代码，很难判断使用的是哪种类型的嵌套。在 Dreamweaver 中使用外部框架集文件的最常见情况如下：使用“在框架中打开”命令在框架内打开框架集文件时，可能导致设置链接目标时出现问题。通常最简单的方法是在单个文件中定义所有的框架集。


选择框架和框架集

要更改框架或框架集的属性，首先要选择您要更改的框架或框架集。您既可以在“文档”窗口中选择框架或框架集，也可以通过“框架”面板进行选择。

当您选择框架或框架集时，在“框架”面板和“文档”窗口的“设计”视图中都会在框架或框架集周围显示一个选择轮廓。


在“框架”面板中选择框架和框架集

“框架”面板提供框架集内各框架的可视化表示形式。您可以在“框架”面板中单击框架或框架集，从而在文档中选定该框架或框架集，然后您可以在属性检查器中查看或编辑选定项的属性。有关更多信息，请参见查看和设置框架属性和查看和设置框架集属性。

“框架”面板能够显示框架集的层次结构，而这种层次在“文档”窗口中的显示可能不够直观。在“框架”面板中，环绕每个框架集的边框非常粗；而环绕每个框架的是较细的灰线，并且每个框架由框架名称标识。

要显示“框架”面板，请执行以下操作：

选择“窗口”>“其他”>“框架”。

要在“框架”面板中选择一个框架，请执行以下操作：

在“框架”面板中单击框架。

要在“框架”面板中选择一个框架集，请执行以下操作：

在“框架”面板中单击环绕框架集的边框。


在“文档”窗口中选择框架和框架集

在“文档”窗口的“设计”视图中，在选定了一个框架后，其边框被虚线环绕；在选定了一个框架集后，该框架集内各框架的所有边框都被淡颜色的虚线环绕。

备注： 将插入点放置在显示在框架内的文档中并不等同于选择一个框架。有多种不同的操作（例如设置框架属性）要求您必须选择框架。

当您选择框架或框架集时，属性检查器将显示选定项的属性，这使您可以更改这些属性（请参见查看和设置框架属性和查看和设置框架集属性）。

要在“文档”窗口中选择一个框架，请执行以下操作：

在“设计”视图中，按住 Alt 键的同时单击框架内部 (Windows) 或在按住 Option 和 Shift 键的同时单击框架内部 (Macintosh)。

要在“文档”窗口中选择一个框架集，请执行以下操作：

在“设计”视图中，单击框架集的某一内部框架边框。（要执行这一操作，框架边框必须是可见的；如果看不到框架边框，则选择“查看”>“可视化助理”>“框架边框”以使框架边框可见。）

备注： 在“框架”面板中选择框架集通常比在“文档”窗口中选择框架集容易。有关更多信息，请参见在“框架”面板中选择框架和框架集。

要选择不同的框架或框架集，请执行以下操作之一：
  • 要在当前选定内容的同一层次级别上选择下一框架（框架集）或前一框架（框架集），请在按住 Alt 键的同时按下左箭头键或右箭头键 (Windows)，或在按住 Command 键的同时按下左箭头键或右箭头键 (Macintosh)。使用这些键，您可以用框架和框架集在框架集文件中定义的顺序依次显示这些框架和框架集。
  • 要选择父框架集（包含当前选定内容的框架集），请在按住 Alt 键的同时按上箭头键 (Windows) 或在按住 Command 键的同时按上箭头键 (Macintosh)。
  • 要选择当前选定框架集的第一个子框架或框架集（即，按其在框架集文件中定义顺序中的第一个），按住 Alt 键的同时按下箭头键 (Windows) 或在按住 Command 键的同时按下箭头键 (Macintosh)。


在框架中打开文档

您可以通过将新内容插入框架的空文档中，或通过在框架中打开现有文档，来指定框架的初始内容。

要在框架中打开现有文档，请执行以下操作：
  1. 将插入点放置在框架中。
  2. 选择“文件”>“在框架中打开”。
  3. 选择要在框架中打开的文档并单击“确定”(Windows)、“选择”(Mac OS X) 或“打开”(Mac OS 9)。

    4. 该文档随即显示在框架中。

  4. 要令该文档成为在浏览器中打开框架集时在框架中显示的默认文档，请保存该框架集。有关更多信息，请参见保存框架和框架集文件。


保存框架和框架集文件

在浏览器中预览框架集前，您必须保存框架集文件以及要在框架中显示的所有文档。您可以单独保存每个框架集文件和带框架的文档，您也可以同时保存框架集文件和框架中出现的所有文档。

在您使用 Dreamweaver 中的可视工具创建一组框架时，框架中显示的每个新文档将获得一个默认文件名。例如，第一个框架集文件被命名为“UntitledFrameset-1”，而框架中第一个文档被命名为“UntitledFrame-1”。

在您选择某一保存命令后，将出现一个对话框，准备用其默认文件名保存文档。因为默认文件名十分类似，所以您可能很难确定您正保存哪个文档。要确定您正保存的文档属于哪个框架，可以从“文档”窗口（“设计”视图）中的框架选择轮廓看出来。

要保存框架集文件，请执行以下操作：
  1. 在“框架”面板或“文档”窗口中选择框架集。
  2. 选择下列项之一：
    • 要保存框架集文件，请选择“文件”>“保存框架集”。
    • 要将框架集文件另存为新文件，请选择“文件”>“框架集另存为”。

      • 如果以前没有保存过该框架集文件，则这两个命令是等效的。

要保存在框架中显示的文档，请执行以下操作：

在框架中单击，然后选择“文件”>“保存框架”或选择“文件”>“框架另存为”。

要保存与一组框架关联的所有文件，请执行以下操作：

选择“文件”>“保存所有框架”。

该命令将保存在框架集中打开的所有文档，包括框架集文件和所有带框架的文档。如果该框架集文件未保存过，则在“设计”视图中框架集的周围将出现粗边框，并且出现一个对话框，您可从中选择文件名。然后，对于尚未保存的每个框架，在框架的周围都将显示粗边框，并且出现一个对话框，您可从中选择文件名。

备注： 如果您使用“文件”>“在框架中打开”在框架中打开文档，则当您保存框架集时，您在框架中打开的文档将成为在该框架中显示的默认文档。如果您不希望该文档成为默认文档，则不要保存框架集文件。


查看和设置框架属性

使用属性检查器可以查看和设置大多数框架属性。要更改框架的背景颜色，请设置该框架中文档的背景颜色。

要查看或设置框架属性，请执行以下操作：
  1. 通过执行以下操作之一选择框架：
    • 在“文档”窗口的“设计”视图中，按住 Alt 键的同时单击一个框架 (Windows) 或在按住 Shift 和 Option 键的同时单击一个框架 (Macintosh)。
    • 在“框架”面板中单击框架。
  2. 如果属性检查器尚未打开，则选择“窗口”>“属性”打开属性检查器。
    这是所描述的功能的图片。
  3. 要看到所有框架属性，请单击属性检查器右下角中的扩展箭头。

    4. 有关如何在框架属性检查器中设置特定选项的信息，请参见设置框架属性检查器选项。

要更改框架中文档的背景颜色，请执行以下操作：
  1. 将插入点放置在框架中。
  2. 选择“修改”>“页面属性”。
  3. 单击“背景”弹出式菜单以选择一种颜色。

相关主题

查看和设置框架集属性

设置文档属性


查看和设置框架集属性

使用属性检查器可以查看和设置大多数框架集属性。要设置选定框架集的标题，请使用“页面属性”对话框或“文档”窗口工具栏中的“标题”域。

要查看或设置框架集属性，请执行以下操作：
  1. 通过执行以下操作之一选择框架集：
    • 在“文档”窗口的“设计”视图中单击框架集中两个框架之间的边框。
    • 在“框架”面板中单击围绕框架集的边框。
  2. 如果属性检查器尚未打开，则选择“窗口”>“属性”打开属性检查器。
  3. 要看到所有框架集属性，请单击属性检查器右下角中的扩展箭头。
    这是所描述的功能的图片。

    4. 有关如何在框架集属性检查器中设置特定选项的信息，请参见设置框架集属性检查器选项。

要设置框架集文档的标题，请执行以下操作：
  1. 通过执行以下操作之一选择框架集：
    • 在“文档”窗口的“设计”视图中单击框架集中两个框架之间的边框。
    • 在“框架”面板中单击围绕框架集的边框。
  2. 在“文档”工具栏的“标题”域中，键入文档的名称。

    3. 当访问者在浏览器中查看框架集时，标题显示在浏览器的标题栏中。

相关主题

查看和设置框架属性

设置文档属性

使用文档工具栏


控制具有链接的框架内容

要在一个框架中使用链接以打开另一个框架中的文档，您必须设置链接目标。链接的 target 属性指定在其中打开链接的内容的框架或窗口。例如，如果您的导航条位于左框架，并且您希望链接的材料显示在右侧的主要内容框架中，则您必须将主要内容框架的名称指定为每个导航条链接的目标。当访问者单击导航链接时，将在主框架中打开指定的内容。

要选择将在其中打开文件的框架，请使用属性检查器中的“目标”弹出式菜单。您可以设置要代替在其他框架中所显示文档的文件，设置要代替整个框架集出现的文件，设置要出现在链接原本所在框架中的文件（通过不选择目标），或者设置要在新的浏览器窗口中打开的文件。

若要设置目标框架，请执行以下操作：
  1. 在“设计”视图中，选择文本或对象。
  2. 在属性检查器的“链接”域中，执行以下操作之一：
    • 单击文件夹图标并选择要链接到的文件。
    • 拖动“指向文件”图标以选择要链接到的文件。
  3. 在“目标”弹出式菜单中，选择链接的文档应在其中显示的框架或窗口。
    • 如果您在属性检查器中命名了框架，则框架名称将出现在此菜单中。选择一个命名框架以打开该框架中链接的文档。

      • 备注： 只有当您在框架集内编辑文档时才显示框架名称。当您在文档自身的“文档”窗口中编辑该文档时（在框架集之外），框架名称不显示在“目标”弹出式菜单中。如果您正编辑框架集外的文档，则您可以将目标框架的名称键入“目标”文本框中。

    • _blank 在新的浏览器窗口中打开链接的文档，同时保持当前窗口不变。
    • _parent 在显示链接的框架的父框架集中打开链接的文档，同时替换整个框架集。
    • _self 在当前框架中打开链接，同时替换该框架中的内容。
    • _top 在当前浏览器窗口中打开链接的文档，同时替换所有框架。

      • 提示： 如果您正链接到您的站点外的某一页面，请始终使用 target="_top" 或 target="_blank" 来确保该页面不会显示为您站点的一部分。

相关主题

设置框架属性检查器选项


处理不能显示框架的浏览器

Dreamweaver 允许您指定要在不支持框架的基于文本的浏览器和较旧的图形浏览器中显示的内容。此类内容存储在框架集文件中，用 noframes 标签括起来。当不支持框架的浏览器加载该框架集文件时，浏览器只显示用 noframes 标签括起来的内容。

备注： noframes 区域中的内容应该不只是“您应升级到可以处理框架的浏览器”这样的注释。某些人士会因一些合理的原因而使用不允许其查看框架的系统。尝试尽可能使此类访问者也可以访问您的内容。

要为不支持框架的浏览器提供内容，请执行以下操作：
  1. 选择“修改”>“框架集”>“编辑无框架内容”。

    2. Dreamweaver 将清除“设计”视图中的内容，并且在“设计”视图顶部将显示“无框架内容” 字样。

  2. 要创建无框架内容，请执行以下操作之一：
    • 在“文档”窗口中，像处理普通文档一样键入或插入内容。
    • 选择“窗口”>“代码检查器”，将插入点置于 noframes 标签中的 body 标签之间，然后键入内容的 HTML 代码。
  3. 再次选择“修改”>“框架集”>“编辑无框架内容”以返回到框架集文档的普通视图。


将 JavaScript 行为用于框架

有几个特别适合用于框架的 JavaScript 行为和与导航相关的命令。

“设置框架文本”用您指定的内容代替给定框架的内容和格式。内容可以包括任何有效的 HTML。使用此操作可以动态显示框架中的信息。（请参见设置框架文本。）

“转到 URL”在当前窗口中或在指定框架中打开新页面。此操作尤其适用于通过一次单击更改两个或多个框架的内容。（请参见转到 URL。）

“插入导航条”命令将导航条添加到页面上；在插入导航条后，您可以将行为附加到其图像上，并设置基于访问者的操作显示哪个图像。例如，您可能想要按朝上或朝下的状态显示按钮图像，以便让访问者知道正在查看站点的哪个页面。（请参见插入导航条。）

“插入跳转菜单”命令使您可以设置当单击时在浏览器窗口中打开文件的链接的菜单列表。您还可以设置要在其中打开文档的特定目标窗口或框架。（请参见插入跳转菜单。）


参考资料

本节提供本章中介绍的有关对话框和检查器的信息。


设置框架属性检查器选项

使用属性检查器可以命名一个框架并设置边框和边距。

提示： 要令链接更改其他框架的内容，您必须命名目标框架。要令以后创建跨框架链接更容易一些，请在创建框架时命名每个框架。

若要指定选定框架的属性，请执行以下操作：
  1. 命名框架。

    2. “框架名称”是链接的 target 属性或脚本在引用该框架时所用的名称。

    备注： 框架名称必须是单个单词；允许使用下划线 (_)，但不允许使用连字符 (-)、句点 (.) 和空格。框架名称必须以字母起始（而不能以数字起始）。框架名称区分大小写。不要使用 JavaScript 中的保留字（例如 top 或 navigator）作为框架名称。

  2. 根据需要更改以下选项：

    3. “源文件”指定在框架中显示的源文档。单击文件夹图标可以浏览到一个文件并选择一个文件。您还可以在框架中打开一个文件，方法是：将插入点放置在框架中并选择“文件”>“在框架中打开”。

    “滚动”指定在框架中是否显示滚动条。将此选项设置为“默认”将不设置相应属性的值，从而使各个浏览器使用其默认值。大多数浏览器默认为“自动”，这意味着只有在浏览器窗口中没有足够空间来显示当前框架的完整内容时才显示滚动条。

    “不能调整大小”令访问者无法通过拖动框架边框在浏览器中调整框架大小。（您始终可以在 Dreamweaver 中调整边框大小；该选项仅适用于在浏览器中查看框架的访问者。）

    “边框”在浏览器中查看框架时显示或隐藏当前框架的边框。为框架选择“边框”选项将重写框架集的边框设置。选项为“是”（显示边框）、“否”（隐藏边框）和“默认值”；大多数浏览器默认为显示边框，除非父框架集已将“边框”设置为“否”。只有当共享该边框的所有框架都将“边框”设置为“否”时，或者当父框架集的“边框”属性设置为“否”并且共享该边框的框架都将“边框”设置为“默认值”时，边框才是隐藏的。

    “边框颜色”为所有框架的边框设置边框颜色。此颜色应用于和框架接触的所有边框，并且重写框架集的指定边框颜色。

    备注： 关于给定边框颜色应用到哪些框架边框有一个基础逻辑，但该逻辑十分复杂；理解为什么某些边框在指定边框颜色后还会更改颜色可能十分困难。有关指定边框颜色的效果的详细信息，请参见有关框架和框架集的书籍。

  3. 您可以根据需要设置以下边距选项（如果看不到边距选项，则单击属性检查器右下角的扩展箭头）：

    4. “边距宽度”以像素为单位设置左边距和右边距的宽度（框架边框和内容之间的空间）。

    “边距高度”以像素为单位设置上边距和下边距的高度（框架边框和内容之间的空间）。

    备注： 设置框架的边距宽度和高度并不等同于在“修改”>“页面属性”对话框中设置边距。

相关主题

查看和设置框架属性

设置框架集属性检查器选项


设置框架集属性检查器选项

使用框架集属性可以设置框架集的边框和框架大小。

设置框架属性将重写框架集中该属性的设置。例如，在框架中设置的边框属性将重写在框架集中设置的边框属性。

要设置框架的粗略大小，请在“文档”窗口的“设计”视图中拖动框架边框。然后使用属性检查器指定准确大小，并且指定当浏览器窗口大小不允许框架以全大小显示时，浏览器分配给框架的行或列的大小。

要指定选定框架集的边框属性，请执行以下操作：

根据需要更改以下选项：

“边框”确定在浏览器中查看文档时在框架周围是否应显示边框。要显示边框，则选择“是”；要使浏览器不显示边框，则选择“否”。要允许浏览器确定如何显示边框，则选择“默认值”。

“边框宽度”指定框架集中所有边框的宽度。

“边框颜色”设置边框的颜色。使用颜色选择器选择一种颜色，或者键入颜色的十六进制值。

要设置选定框架集的各行和各列的框架大小，请执行以下操作：
  1. 在“行列选择范围”区域左侧的标签上单击以选择一行，或者在顶部的标签上单击以选择一列。
    这是所描述的功能的图片。
  2. 在“值”域中，输入选定行的高度或选定列的宽度。
  3. 要指定浏览器分配给每个框架的空间大小，请从“单位”菜单中选择以下选项：

    4. “像素”将选定列或行的大小设置为一个绝对值。对于应始终保持相同大小的框架（例如导航条）而言，此选项是最佳选择。在为以百分比或相对值指定大小的框架分配空间前，为以像素为单位指定大小的框架分配空间。设置框架大小的最常用方法是将左侧框架设定为固定像素宽度，将右侧框架大小设置为相对大小，这样在分配像素宽度后，右侧框架能够伸展以占据所有剩余空间。

    备注： 如果所有宽度都是以像素为单位指定的，而指定的宽度对于访问者查看框架集所使用的浏览器而言太宽或太窄，则框架将按比例伸缩以填充可用空间。这同样适用于以像素为单位指定的高度。因此，将至少一个宽度和高度指定为相对大小通常是一个不错的主意。

    “百分比”指定选定列或行应相当于其框架集的总宽度或总高度的百分比。以“百分比”为单位的框架分配空间是在以“像素”为单位的框架之后，但在将单位设置为“相对”的框架之前。

    “相对”指定在为“像素”和“百分比”框架分配空间后，为选定列或行分配其余可用空间；剩余空间在大小设置为“相对”的框架中按比例划分。

    备注： 当您从“单位”菜单中选择“相对”时，您在“值”域中输入的所有数字均消失；如果您想要指定一个数字，则必须重新输入。不过，如果只有一行或一列设置为“相对”，则不需要输入数字，因为该行或列在其他行和列已分配空间后，将接受所有剩余空间。为了确保完全的跨浏览器兼容性，您可以在“值”域中输入 1；这等效于不输入任何值。

    框架的空间分配是十分复杂的；有关详细信息，请参见有关框架和框架集的书籍。

上一页


添加内容

使用 Dreamweaver 中的可视化工具向 Web 页添加各种内容。添加元素并设置元素的格式，这些元素包括文本、图像、颜色、影片、声音和其他媒体形式等，以确保有障碍的访问者也能够访问您的页面。

此部分包含以下各章：

  • 插入文本和设置文本格式
  • 插入图像
  • Dreamweaver 与其他应用程序的集成
  • 插入媒体
  • Dreamweaver 和辅助功能


插入文本和设置文本格式

Macromedia Dreamweaver MX 提供了多种向文档中添加文本和设置文本格式的方法。本章描述如何插入文本、设置字体类型、大小、颜色和对齐属性，以及如何使用 HTML 样式和层叠样式表 (CSS) 样式创建和应用您自己的自定义样式。

本章包含以下主题：

  • 插入 HTML 文本和设置 HTML 文本格式
  • 设置文本格式
  • 使用 HTML 样式设置文本格式
  • 关于层叠样式表
  • 将 CSS 样式转换为 HTML 标签
  • 搜索和替换文本
  • 参考资料
下一页


插入 HTML 文本和设置 HTML 文本格式

Dreamweaver 中的格式设置与使用标准字处理程序类似。使用“文本”>“段落格式”子菜单或属性检查器中的“格式”弹出菜单可设置文本块的默认格式样式（“段落”、“已编排格式”、“标题 1”、“标题 2”等等）。若要更改所选文本的字体、大小、颜色和对齐方式，请使用“文本”菜单或属性检查器。若要应用文本格式（如粗体、斜体、代码、下划线等），请使用“文本”>“样式”子菜单。

也可以组合几个标准的 HTML 标签，构成单个样式（称为 HTML 样式）。例如，可以使用标签和属性组合来手动应用 HTML 格式，并将该格式保存为 HTML 样式；该样式存储在“HTML 样式”面板中。当下次想使用该 HTML 标签组合设置文本格式时，只需从“HTML 样式”面板中选择已保存的样式。HTML 样式几乎受所有 Web 浏览器的支持，并且比手动设置文本格式更节省时间。

另一种样式称为 CSS 样式（CSS 表示层叠样式表），它使您可以应用文本和页面格式，并具有自动更新的优点。CSS 样式可直接存储在文档中，如果要获得更多功能和灵活性，也可将其存储在外部样式表中。如果将外部样式表附加到多个网页，则所有网页都会自动反映对该样式表所做的任何更改。若要访问 CSS 样式，请使用“CSS 样式”面板或文本属性检查器的 CSS 模式。 有关如何使用文本属性检查器应用 HTML 或 CSS 样式的更多信息，请参见 设置文本属性选项

手动 HTML 格式和 HTML 样式使用标准 HTML 标签（如 b、i、font 和 code）来应用格式，所有常见的 Web 浏览器都支持这些标签。CSS 样式为具体某个类中的所有文本定义格式，或者为具体某个 HTML 标签（如h1、h2、p 或 li）重新定义格式。支持 CSS 样式的 Web 浏览器只有 Netscape Navigator 4.0 和更高版本以及 Microsoft Internet Explorer 4.0 和更高版本。

可以在同一页面中使用 CSS 样式、HTML 样式和手动 HTML 格式。格式按不同的等级应用：手动 HTML 格式覆盖 HTML 样式或 CSS 样式所应用的格式，而嵌套在文档中的 CSS 样式覆盖外部 CSS 样式。请参见关于层叠样式表。


将文本添加到文档

有多种方法可以将文本添加到 Dreamweaver 文档。可以直接在 Dreamweaver 文档窗口中键入文本，也可以从其他文档中剪切并粘贴或导入文本。

若要将文本添加到文档，请执行下列操作之一：
  • 直接在“文档”窗口中键入文本。
  • 从其他应用程序中拷贝文本，切换到 Dreamweaver，将插入点定位在“文档”窗口的“设计”视图中，然后选择“编辑”>“粘贴”。Dreamweaver 不保留在其他应用程序中应用的文本格式，但它确实保留换行符。


从其他文档中导入文本

通过首先将文件（如 Microsoft Excel 文件或数据库文件）保存为分隔文本文件，可将表格式数据导入到文档中。有关如何导入表格式数据和设置表格式数据格式的其他信息，请参见插入文本和设置文本格式中的导入表格式数据。

还可以从 Microsoft Word HTML 文档中导入文本。有关如何导入 Word HTML 文档的信息，请参见打开现有文档。

导入表格式数据：
  1. 选择“文件”>“导入”>“导入表格式数据”，或选择“插入”>“表格式数据”。

    2. 出现“导入表格”对话框。

    浏览所需的文件或在文本框中输入它的名称。

  2. 选择将文件保存为分隔文本时使用的分隔符。选项包括“制表符”、“逗点”、“分号”、“冒号”和“其他”。

    3. 如果选择“其他”，则该选项旁边将出现一个空白域。输入用作分隔符的字符。

  3. 使用其余的选项格式化或定义要向其中导入数据的表格。
  4. 完成后单击“确定”。


在字符之间添加空格

HTML 只允许字符之间包含一个空格；若要在文档中添加其他空格，必须插入连续空格。

可以设置一个在文档中自动添加连续空格的参数选择。若要设置此参数选择，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后在“常规”类别中确保选中“允许多个连续的空格”。

若要插入连续空格，请执行下列操作之一：
  • 在“插入”栏中，选择“字符”，然后单击“非换行的空格”图标。
  • 选择“插入”>“特殊字符”>“不换行空格”。
  • 按 Control+Shift+空格键 (Windows) 或 Option+空格键 (Macintosh)。


添加段落间距

Dreamweaver 的工作机制与许多字处理程序类似：按 Enter 键 (Windows) 或 Return 键 (Macintosh) 可创建一个新段落。Web 浏览器在段落之间自动插入一个空白空格行。通过插入一个换行符，可以在段落之间添加一个空格行。

添加段落换行：
  • 按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
若要添加换行符，请执行下列操作之一：
  • 按 Shift+Enter 键 (Windows) 或 Shift+Return 键 (Macintosh)。
  • 在“插入”栏中，选择“字符”，然后单击“换行符”图标。
  • 选择“插入”>“特殊字符”>“换行符”。


设置文本格式

可以将 HTML 文本格式应用于一个字母，或者使用“文本”>“段落格式”命令或属性检查器中的选项建立整个站点。这种手动格式取代或覆盖 HTML 样式或 CSS 样式所设置的格式。

当应用 HTML 文本格式时，可以使用属性检查器和“文本”菜单中的命令，如“文本”>“段落格式”和“文本”>“样式”。

相关主题

使用 HTML 样式设置文本格式

创建 HTML 样式

创建新的 CSS 样式


设置和更改字体和样式

使用属性检查器或“文本”菜单中的选项可以设置或更改所选文本的字体特性。可以设置字体类型、样式（如粗体或斜体）和大小。

在使用属性检查器应用粗体或斜体样式时，Dreamweaver 自动分别应用 <strong> 或 <em> 标签。如果正在为使用 3.0 或更早版本的浏览器的查看者设计页面，则应该在“参数选择”对话框（“编辑”>“参数选择”）的“常规”类别中更改此参数选择。

HTML 字体大小是相对而不是特定的点数。用户为他们的浏览器设置默认字体的点数；这是用户在属性检查器或“文本”>“大小”子菜单中选择“默认”或“3”时所看到的字体大小。大小 1 和 2 显得比默认字体小；大小 4 到 7 显得比默认字体大。此外，Windows 中的字体通常显得比 Macintosh 中的字体大，尽管 Macintosh Internet Explorer 5 与 Windows 使用相同的默认字体大小。

提示： 一个确保字体大小一致的方法是使用 CSS 样式并且以像素为单位设置字体大小。有关 CSS 的更多信息，请参见关于层叠样式表。

相关主题

修改字体组合

设置或更改字体特性：
  1. 选择文本。如果未选择文本，更改将应用于随后键入的文本。
  2. 从下列选项中选择：
    • 若要更改字体，请从属性检查器或“文本”>“字体”子菜单中选择字体组合。

      • 选择“默认”删除先前应用的字体；“默认”应用所选文本的默认字体（或者是浏览器的默认字体，或者是在 CSS 样式表中指定给该标签的字体）。

    • 若要更改字体样式，请单击属性检查器中的“粗体”或“斜体”，或者从“文本”>“样式”子菜单中选择字体样式（“粗体”、“斜体”、“下划线”等）。
    • 若要更改字体大小，请从属性检查器或“文本”>“大小”子菜单中选择大小（从 1 到 7）。
    • 若要增加或减小所选文本的大小，请从属性检查器或“文本”>“改变大小”子菜单中选择相对大小（+1 或 -1 到 + 4 或 -3）。

      • 备注： 这些数字指示与基准字体大小的相对差值。默认基准字体值为 3。因此，+4 值产生的字体大小是 3 + 4（即 7）。字体大小和的最大值是 7。如果试图将它们设置得更高，它们显示为 7。Dreamweaver 不显示 basefont 标签（该标签位于 head 部分），但字体大小应在浏览器中正确显示。若要对此进行测试，请比较设置为 3 的文本和设置为 +3 的文本。


修改字体组合

使用“编辑字体列表”命令可以设置出现在属性检查器和“文本”>“字体”子菜单中的字体组合。

字体组合决定了浏览器在网页中显示文本的方式。浏览器使用用户系统上安装的字体组合中的第一种字体；如果未安装字体组合中的任何一种字体，则浏览器按用户的浏览器参数选择指定的方式显示文本。

修改字体组合：
  1. 选择“文本”>“字体”>“编辑字体列表”。
  2. 从对话框顶部的列表中选择字体组合。

    3. 所选组合中的字体在对话框左下角的“选择的字体”列表中列出。右侧是系统上安装的所有可用字体的列表。

  3. 从下列选项中选择：
    • 若要向字体组合中添加字体或从中删除字体，请单击“选择的字体”列表和“可用字体”列表之间的箭头按钮（<< 或 >>）。
    • 若要添加或删除字体组合，请单击对话框顶部的加号 (+) 和减号 (-)。
    • 若要添加系统上未安装的字体，请在“可用字体”列表下面的文本域中键入字体名称，然后单击 << 按钮将它添加到组合中。添加系统上未安装的字体在很多情况下都很有用，例如，当在 Macintosh 上开发网页时指定仅限 Windows 使用的字体。
    • 若要在列表中上下移动字体组合，请单击对话框顶部的箭头按钮。
向字体列表中添加新组合：
  1. 选择“文本”>“字体”>“编辑字体列表”。
  2. 从“可用字体”列表中选择一种字体，然后单击 << 按钮将该字体移动到“选择的字体”列表。
  3. 对组合中随后的每个字体重复第 2 步。

    4. 若要添加系统上未安装的字体，请在“可用字体”列表下面的文本域中键入字体名称，然后单击 << 按钮将该字体添加到组合中。添加系统上未安装的字体在很多情况下都很有用，例如，当在 Macintosh 上开发网页时指定仅限 Windows 使用的字体。

  4. 选择完特定的字体后，从“可用字体”菜单中选择一个一般字体家族，然后单击 << 按钮将该一般字体家族移动到“选择的字体”列表。

    5. 一般字体家族包括：cursive、fantasy、monospace、sans-serif 和 serif。如果用户的系统上没有“选择的字体”列表中的任何字体，则文本以一般字体家族的关联默认字体显示。例如，大多数系统上的默认等宽字体是 Courier。


设置段落格式

使用属性检查器中的“格式”弹出菜单或“文本”>“段落格式”子菜单可以应用标准段落和标题标签。

对段落应用标题标签时，Dreamweaver 自动添加下一行文本作为标准段落。若要更改此设置，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后在“常规”类别中的“编辑选项”下确保取消选中“标题后切换到普通段落”。

相关主题

创建 HTML 样式

设置文本属性选项

定义 CSS 类型属性

应用段落或标题标签：
  1. 将插入点放在段落中，或者选择段落中的一些文本。
  2. 使用“文本”>“段落格式”子菜单或属性检查器中的“格式”弹出菜单，选择一个选项：
    • 选择段落格式（例如，“标题 1”、“标题 2”、“已编排格式”等）。与所选样式关联的 HTML 标签（例如，表示“标题 1”的 h1、表示“标题 2”的 h2、表示“已编排格式”文本的 pre等）应用于整个段落。
    • 选择“无”删除段落格式。


对齐文本

使用属性检查器或“文本”>“对齐”子菜单可以对齐页面上的文本。使用“文本”>“对齐”>“居中对齐”命令可以将页面元素居中对齐。

对齐文本：
  1. 选择要对齐的文本，或者只需将指针插到文本开头。
  2. 单击属性检查器中的对齐选项（“左对齐”、“右对齐”或“居中对齐”），或者选择“文本”>“对齐”，然后选择对齐命令。
将元素居中对齐：
  1. 选择要居中对齐的元素（图像、插件、表格或其他页面元素）。
  2. 选择“文本”>“对齐”>“居中对齐”。

备注： 可以对齐和居中对齐整个文本块；不能对齐和居中对齐标题或段落的某一部分。


缩进文本

使用“缩进”命令可以将 blockquote HTML 标签应用于文本段落，缩进页面两侧的文本。

缩进文本和取消缩进：
  1. 将插入点放在要缩进的段落中。
  2. 单击属性检查器中的“缩进”或“凸出”按钮，选择“文本”>“缩进”或“凸出”，或从上下文菜单中选择“列表”>“缩进”或“凸出”。

备注： 可以对段落应用多重缩进。每选择一次该命令，文本就从文档的两侧进一步缩进。


更改文本颜色

可以更改所选文本的颜色，使新颜色覆盖“页面属性”中设置的文本颜色。（如果未在“页面属性”中设置任何文本颜色，则默认文本颜色为黑色。）

更改文本颜色：
  1. 选择文本。
  2. 从下列选项中选择：
    • 单击属性检查器中的颜色选择器，从浏览器安全色面板中选择一种颜色。
    • 选择“文本”>“颜色”。出现系统颜色选择器对话框。选择一种颜色，然后单击“确定”。
    • 直接在属性检查器域中输入颜色名称或十六进制数字。
    • 若要定义默认文本颜色，请使用“修改”>“页面属性”命令。请参见定义默认文本颜色。
使文本返回到默认颜色：
  1. 在属性检查器中，单击颜色框打开网页安全色面板。
  2. 单击删除线按钮（位于右上角的白色方形按钮，中间有一条红线）。


创建项目列表和编号列表

在“文档”窗口中键入时，可以用现有文本或新文本创建编号（排序）列表、项目符号（不排序）列表和定义列表。定义列表不使用项目符号点或数字这样的前导字符，通常用在词汇表或说明中。列表还可以嵌套。嵌套列表是包含其他列表的列表。例如，可能希望编号或项目符号列表嵌套在其他编号列表中。

有关如何为整个列表或特定列表项设置特定列表类型和其它列表项（例如，重置编号或在编号列表中使用罗马数字，或设置方形项目符号）的信息，请参阅设置列表属性选项。

创建新列表：
  1. 在 Dreamweaver 文档中，将插入点放在要添加列表的位置，然后执行下列操作之一：
    • 单击属性检查器中的“项目列表”或“编号列表”按钮。
    • 选择“文本”>“列表”，然后选择所需的列表类型：“项目列表”、“编号列表”或“定义列表”。

      • 指定列表项的前导字符出现在文档窗口中。

  2. 键入列表项文本，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh) 创建其他列表项。
  3. 若要完成列表，按两次 Enter 键 (Windows) 或按两次 Return 键 (Macintosh)。
使用现有文本创建列表：
  1. 选择一系列段落组成一个列表。
  2. 单击属性检查器中的“项目列表”或“编号列表”按钮，或选择“文本”>“列表”，然后选择所需的列表类型：“项目列表”、“编号列表”或“定义列表”。
创建嵌套列表：
  1. 选择要嵌套的列表项。
  2. 单击属性检查器中的“缩进”按钮，或选择“文本”>“缩进”。

    3. Dreamweaver 缩进文本并创建一个单独的列表，该列表具有原始列表的 HTML 属性。

  3. 按照以上使用的同一过程，对缩进的文本应用新的列表类型或样式。


插入日期

Dreamweaver 提供了一个方便的日期对象，该对象使您可以用任何格式插入当前日期（包含或不包含时间），您可以选择在每次保存文件时都自动更新该日期。

备注： “插入日期”对话框中显示的日期和时间不是当前日期，也不反映访问者在显示您的站点时所看到的时期/时间。它们只是说明此信息的显示方式的示例。

将当前日期插入到文档中：
  1. 在“文档”窗口中，将插入点放在要插入日期的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“日期”。
    • 在“插入”栏中，选择“标准”，然后单击“日期”按钮。
  3. 在出现的对话框中，选择星期格式、日期格式和时间格式。
  4. 如果希望在每次保存文档时都更新插入的日期，请选择“储存时自动更新”。如果希望日期在插入后变成纯文本并永远不自动更新，请取消选择该选项。
  5. 单击“确定”插入日期。

提示： 如果选择了“储存时自动更新”，则在日期格式插入到文档中后可以对其进行编辑，方法是单击已设置格式的文本，然后在属性检查器中选择“编辑日期格式”。


插入特殊字符

某些特殊字符在 HTML 中以名称或数字的形式表示，它们被称为实体。HTML 包含版权符号 (&copy;)、“与”符号 (&amp;)、注册商标符号 (&reg;) 等字符的实体名称。每个实体都有一个名称（如 &mdash;）和一个数字等效值（如 &#151;）。

提示： HTML 在代码中使用尖括号 <>，但您可能需要表示大于或小于这样的特殊字符，而不要 Dreamweaver 将它们解释为代码。这种情况下，请使用 &gt; 表示大于 (>)，使用 &it; 表示小于 (<)。

遗憾的是，许多浏览器（尤其是旧版本的浏览器以及除 Navigator 和 Internet Explorer 外的浏览器）无法正确显示很多已命名的实体。

通过在“插入”栏中选择“字符”类别，可以插入几个 HTML 实体形式的特殊字符。

将特殊字符插入到文档中：
  1. 在“文档”窗口中，将插入点放在要插入特殊字符的位置。
  2. 执行下列操作之一：
    • 从“插入”>“字符”子菜单中选择字符名称。
    • 在“插入”栏中，选择“字符”类别并选择所需的字符。

提示： 还有很多其他特殊字符可供使用；若要选择其中的某个字符，请选择“插入”>“字符”>“更多”或在“插入”栏中选择“插入更多字符”图标，选择一个字符，然后单击“确定”。


使用水平线

水平线对于组织信息很有用。在页面上，可以使用一条或多条水平线以可视方式分隔文本和对象。

创建水平线：
  1. 在“文档”窗口中，将插入点放在要插入水平线的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“水平线”。
    • 在“插入”栏中，选择“标准”，然后单击“水平线”按钮。
修改水平线：
  1. 在“文档”窗口中，选择水平线。
  2. 选择“窗口”>“属性”打开属性检查器，然后根据需要对属性进行修改。

    3. 宽和高以像素为单位或以页面尺寸百分比的形式指定水平线的高度和宽度。

    对齐指定水平线的对齐方式（“默认”、“左对齐”、“居中对齐”或“右对齐”）。只有当水平线的宽度小于浏览器窗口的宽度时，该设置才适用。

    阴影指定绘制水平线时是否带阴影。取消选择此选项将使用纯色绘制水平线。


使用 HTML 样式设置文本格式

通过设置 HTML 样式，可以快速一致地将字体格式应用于文档中的文本。HTML 样式可由单个或多个 HTML 字体标签属性（如颜色、字体、大小）以及其他格式属性（如粗体或斜体）组成。例如，可以为字体为 Arial、大小为 4+ 的绿色斜体文本创建一个 HTML 样式。然后可以快速应用该样式，方法是选择希望该样式应用于的文本，然后从“HTML 样式”面板中选择该 HTML 样式。

由于 HTML 样式只包含字体标签，因此可使用不支持层叠样式表 (CSS) 的浏览器（如 3.0 及更早版本的浏览器）查看。

HTML 样式的一个缺点是对 HTML 样式所做的更改不自动在文档中更新。如果应用了一个样式，后来又更改了它，则必须对文本重新应用该样式才能更新格式设置。

与 CSS 样式不同，HTML 样式格式只影响应用它的文本或使用所选 HTML 样式创建的文本。如果希望能够更改格式并自动更新该格式的所有实例，请使用 CSS 样式；请参见关于层叠样式表。

可以使用“HTML 样式”面板设置站点中使用的 HTML 样式，然后与其他用户、本地站点或远程站点共享这些样式。有关信息，请参见在其他站点中使用您的 HTML 样式。

若要显示“HTML 样式”面板，请执行下列操作之一：
  • 选择“窗口”>“HTML 样式”。
  • 按 Control + F11 键 (Windows) 或 Command + F11 键 (Macintosh)。
  • 单击启动器中的“HTML 样式”图标。


使用“HTML 样式”面板

“HTML 样式”面板显示可供当前本地站点使用的 HTML 样式。

HTML 样式有两种类型：“段落样式”和“所选样式”。可通过“HTML 样式”面板第一列中的符号来识别它们：

段落样式前面有一个段落标记，该样式使您可以设置段落格式。

所选样式前面有一个 a，该样式使您可以设置所选文本的格式。“HTML 样式”面板中的头两个样式“清除所选样式”和“清除段落样式”使您可以删除选择应用该样式的文本中的所有格式标签。

在上面的“HTML 样式”面板中，注意其中的“粗体”样式。样式前的加号 (+) 指示样式将格式添加到需应用它的文本。如果样式没有加号，则在应用所选样式之前将清除任何现有样式。例如，使用 HTML 样式“a+ 红色”时将向任何已应用于所选文本的格式中添加红色；而使用 HTML 样式“强调”时，在应用此样式之前将清除任何现有格式。

查看现有 HTML 样式的样式属性：
  1. 在“HTML 样式”面板中，选择一种样式。
  2. 在“HTML 样式”面板中，右击 (Windows) 或按住 Control 键并单击 (Macintosh) 然后从上下文菜单中选择“编辑”，或者双击 HTML 样式并从上下文菜单中选择“编辑”。
  3. 在“定义 HTML 样式”对话框中，指定样式设置。

    4. “应用到”选项确定样式是应用于所选文本（“选定范围”）还是当前文本块（“段落”）。“当应用时”选项确定是将样式设置添加到原始文本格式中（“添加到现有样式”），还是从现有格式中删除并用新设置替换（“清除现有样式”）。

应用现有 HTML 样式：

在“HTML 样式”面板中，选择一种样式。

  • 如果选中了面板底部的“自动应用”复选框，则单击一次该样式。
  • 如果未选中“自动应用”复选框，则单击该样式，然后单击“应用”。
清除文档中的格式设置：
  1. 选择已设置格式的文本。
  2. 在“HTML 样式”面板中，单击“清除段落样式”或“清除所选样式”。

    3. “清除段落样式”删除文档中当前文本块的任何格式设置。“清除所选样式”删除所选文本的任何格式设置。

备注： 使用“清除段落样式”和“清除所选样式”可以删除任何格式设置（CSS 格式设置除外），不论原始格式设置是如何应用的（例如，通过“HTML 样式”面板或属性检查器）。

从“HTML 样式”面板中删除样式：
  1. 在“HTML 样式”面板中，取消选择复选框以关闭“自动应用”选项。
  2. 选择 HTML 样式。
  3. 单击面板右下角的“删除样式”（垃圾桶）图标。


创建 HTML 样式

可以用两种方法创建样式：可以设置文档中的文本格式，然后基于所选文本创建样式，或者可以在“HTML 样式”面板中通过选择要应用的格式属性来创建样式。

创建新的 HTML 样式：
  1. 在“HTML 样式”面板中，单击“新建样式”图标；也可以选择“文本”>“HTML 样式”>“新建样式”。

    2. 出现“定义 HTML 样式”对话框。
    这是所描述的功能的图片。

  2. 在“名称”文本框中，输入样式名称。
  3. 在“应用到”下，执行下列操作之一选择该样式的应用方式：
    • 若要设置所选样式，请选择“选定范围”。
    • 若要设置段落样式，请选择“段落”。

      • 备注： 段落样式应用于插入点所在的整个文本块，与实际选择的文本无关。

  4. 对于“当应用时”，选择是在所选文本或段落的现有样式基础上应用 HTML 样式，还是先清除所选文本或段落的格式设置，然后再应用新的 HTML 样式。

    5. 备注： 样式的应用等级如下：HTML 样式优先于 CSS 样式，而 CSS 样式优先于外部 CSS 样式。有关更多信息，请参见关于层叠样式表。

  5. 在“字体属性”下，使用弹出菜单选择要应用的格式选项。
  6. 如果要创建段落样式，请在“段落属性”下的“格式”弹出菜单中选择一个段落标记（如“段落”、“标题 1”、“已编排格式”）。
  7. 对于“对齐方式”，单击左对齐、居中对齐或右对齐按钮以设置所需的段落对齐方式。
  8. 单击“确定”。

    9. 该样式随即添加到“HTML 样式”列表中。

基于现有文本创建新的 HTML 样式：
  1. 在文档中，选择或创建包含要对新 HTML 样式使用的格式设置的文本。

    2. 提示： 可以使用属性检查器查看和应用格式设置，然后将格式设置保存为 HTML 样式。

  2. 在“HTML 样式”面板中，单击右下角的“新建样式”图标 (+)。

    3. 出现“定义 HTML 样式”对话框。

  3. 在“名称”文本框中，输入样式名称。
  4. 在“应用到”下，执行下列操作之一选择该样式的应用方式：
    • 若要设置所选样式，请选择“选定范围”。
    • 若要设置段落样式，请选择“段落”。

      • 备注： 段落样式应用于插入点所在的整个文本块，与实际选择的文本无关。

  5. 对于“当应用时”，选择是在所选文本或段落的现有样式基础上应用 HTML 样式，还是先清除所选文本或段落的格式设置，然后再应用新的 HTML 样式。

    6. 备注： 样式的应用等级如下：HTML 样式优先于 CSS 样式，而 CSS 样式优先于外部 CSS 样式。有关更多信息，请参见关于层叠样式表。

  6. 如果要创建段落样式，请在“段落属性”下的“格式”弹出菜单中选择一个段落标记（如“段落”、“标题 1”、“已编排格式”）。
  7. 对于“对齐方式”，单击左对齐、居中对齐或右对齐按钮以设置所需的段落对齐方式。
  8. 单击“确定”。


应用 HTML 样式

应用样式非常简单，就是选择希望应用该样式的文本或段落，然后在“HTML 样式”面板中选择该样式。

应用 HTML 样式：
  1. 在“HTML 样式”面板的左下角确保选择了“自动应用”以自动应用所选样式。
  2. 在“文档”窗口中，执行下列操作之一选择希望应用该样式的文本：
    • 将插入点放在段落中的任何位置以应用段落样式。
    • 使用光标选择希望应用所选样式的文本。
  3. 在“HTML 样式”面板中，单击要应用于文本的 HTML 样式。

    4. 文本在“文档”窗口中自动更新。


编辑 HTML 样式

编辑 HTML 样式时，Dreamweaver 不自动更新先前使用 HTML 样式设置了格式的文本。若要将样式更新为先前设置了格式的文本，必须手动重新应用该样式。

编辑现有 HTML 样式：
  1. 确保“文档”窗口中未选择任何文本。
  2. 在“HTML 样式”面板中，确保取消选择了“自动应用”复选框。

    3. 如果打开“自动应用”选项，则在“HTML 样式”面板中选择 HTML 样式时将会应用该样式。

  3. 在“HTML 样式”面板中，执行下列操作之一：
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后从上下文菜单中选择“编辑”。
    • 双击该样式。

      • 出现“定义 HTML 样式”对话框。

  4. 在该对话框中，设置该样式的样式属性选项。
  5. 若要将它重置为默认选项，请单击“清除”。


在其他站点中使用您的 HTML 样式

您可以使用“HTML 样式”面板记录在您的站点中使用的 HTML 样式，然后与其他用户、本地站点或远程站点共享这些样式。

HTML 样式自动存储在本地站点的 Library 文件夹中一个名为 Styles.xml 的文件中。可以将 Styles.xml 文件从一个本地站点的 Library 文件夹拷贝到另一个本地站点的 Library 文件夹中，并重新使用所创建的样式。

备注： 每个站点只能包含一个 Styles.xml 文件；因此，如果已经在 Styles.xml 文件将拷贝到的站点中创建了新的 HTML 样式，则要拷贝到那个站点的文件将替换现有文件。您不会丢失已应用的任何格式更改，而且还可以通过在文档中选择文本并定义新的 HTML 样式来重新创建样式。

与其他站点或用户共享您的 HTML 样式：
  1. 选择“窗口”>“站点”或“站点”>“站点文件”，在“站点文件”视图中打开“站点”面板。
  2. 在“站点”面板中，找到并打开 Library 文件夹。

    3. 您将发现一个名为 styles.xml 的文件。该文件包含站点的所有 HTML 样式。可以像处理站点中的其他文件那样上传、获取、存回、取出和拷贝此文件。还可以为 styles.xml 文件创建设计说明。必须先取出 styles.xml 文件后才能创建或编辑远程站点的样式。

    有关如何使用这些选项的更多信息，请参见设置远程文件夹。


关于层叠样式表

层叠样式表 (CSS) 是一系列格式规则，它们控制网页内容的外观。使用 CSS 样式可以非常灵活并更好地控制确切的网页外观，从精确的布局定位到特定的字体和样式。

CSS 样式使您可以控制许多仅使用 HTML 无法控制的属性。例如，可以指定自定义列表项目符号并指定不同的字体大小和单位（像素、点数等等）。通过使用 CSS 样式和以像素为单位设置字体大小，可以确保以更一致的方式在多个浏览器中处理页面布局和外观。除了设置文本格式外，还可以控制网页中块级别元素的格式和定位。例如，可以设置边距、边框、其他文本周围的浮动文本等等。

CSS 样式规则由两部分组成：选择器和声明。选择器是样式名称（如 TR 或 P），而声明则用于定义样式元素。声明由两部分组成：属性（如 font-family）和值（如 Helvetica）。术语“级联”是指对同一个网页应用多个样式表的能力。例如，可以创建一个样式表来应用颜色，创建另一样式表来应用边距，然后将两者应用于同一个网页以创建所需的设计。

CSS 样式表的主要优点是提供便利的更新功能；更新 CSS 样式时，使用该样式的所有文档的格式都自动更新为新样式。

在 Dreamweaver 中，“CSS 样式”面板用于创建、查看样式属性以及将样式属性附加到文档。有关如何使用“CSS 样式”面板的信息，请参见使用“CSS 样式”面板。除了所创建的样式和样式表外，还可以使用 Dreamweaver 附带的样式表对文档应用样式。请参见创建基于 Dreamweaver 设计文件的文档。

在 Dreamweaver 中可以定义下列类型的 CSS 样式表：

  • 自定义 CSS 样式（也称为类样式）使您可以将样式属性设置为任何文本范围或文本块。请参见应用自定义 (Class) CSS 样式。
  • HTML 标签样式重定义特定标签（如 h1）的格式。创建或更改 h1 标签的 CSS 样式时，所有用 h1 标签设置了格式的文本都立即更新。
  • CSS 选择器样式重定义具体某个标签组合的格式（如每当 h2 标题出现在表格单元格内时都应用 td h2），或重定义包含特定 id 属性的所有标签的格式（如 #myStyle 应用于所有包含属性值对 ID="myStyle" 的标签）。

CSS 样式表驻留在文档的 head 区域中。CSS 样式可定义 HTML 标签的格式属性，由 class 属性标识的文本范围。Dreamweaver MX 识别现有文档中定义的样式，只要这些样式符合 CSS 样式准则。

提示： 若要显示 Dreamweaver 中包含的 O’Reilly CSS 参考指南，请单击工具栏上的“参考”按钮，然后从弹出菜单中选择“O’Reilly CSS 参考”。

手动 HTML 格式覆盖通过 CSS（或 HTML）样式应用的格式。要使 CSS 样式能够控制段落格式，必须删除所有手动 HTML 格式或 HTML 样式。

在“文档”窗口中可以查看所应用的大部分样式属性。也可在浏览器窗口中预览文档以查看它的应用情况。有些 CSS 样式属性在 Microsoft Internet Explorer 4.0 和 Netscape Navigator 4.0 中呈现的外观不相同，有些目前不受任何浏览器支持。

在“CSS 样式”面板中工作时，可以使用 Dreamweaver 的“设计时间样式表”功能。此功能使您可以在 Dreamweaver 中设计页面时隐藏或显示样式表属性（例如查看一个包含专为 Navigator 或 Internet Explorer 设计的样式的文档）。有关如何使用设计时间样式表的信息，请参见使用设计时间样式表。


使用“CSS 样式”面板

使用“CSS 样式”面板可以创建 CSS 样式、查看 CSS 样式的属性以及将 CSS 样式应用于文档中的元素。

若要打开“CSS 样式”面板，请执行下列操作之一：
  • 选择“窗口”>“CSS 样式”。
  • 按 Shift+F11 键。

位于“CSS 样式”面板顶部的“应用样式”和“编辑样式”单选按钮使您可以选择与当前文档关联的不同 CSS 样式视图。

使用“应用样式”视图可以选择应用于文档元素的类样式。“应用样式”视图只显示自定义 (class) 样式。该窗格中不显示重定义的 HTML 样式和选择器样式。由于它们与 HTML 标签关联，因此它们的样式属性自动应用于文档中受定义的样式影响的任何标签。例如，如果为表格标签定义样式属性，则文档中的表将自动用所选的样式定义更新。

“编辑样式”视图使您可以查看与当前文档关联的样式的样式定义。“编辑样式”视图显示自定义 (class) CSS 样式、重定义的 HTML 标签和 CSS 选择器样式的样式定义。“编辑样式”视图还可用于查看已应用于文档的设计时间样式表。

创建或附加 CSS 样式表时，样式的名称和属性会出现在“CSS 样式”面板的“编辑样式”视图中。“编辑样式”列出了所有样式标签中定义的所有选择器以及外部链接或导入的样式表。“应用样式”使您可以查看当前文档中应用的样式，以及附加的外部样式表中的可用样式。

创建自定义 (class) 样式时，它出现在“CSS 样式”面板和“文本”>“CSS 样式”子菜单中。

下列按钮位于“CSS 样式”面板的底部：

“附加样式表”打开“链接外部样式表”对话框。选择要链接到或导入到当前文档中的外部样式表。有关附加外部样式表的信息，请参见创建和链接到外部 CSS 样式表。

“新建 CSS 样式”打开“新建 CSS 样式”对话框。使用“新建 CSS 样式”对话框可以选择要创建的样式类型。例如，若要创建类样式，可以重定义一个 HTML 标签或定义一个 CSS 选择器。有关如何创建新样式的信息，请参见创建新的 CSS 样式。

“编辑样式表”打开“CSS 样式定义”对话框。编辑当前文档或外部样式表中的任何样式。有关如何更新样式表的信息，请参见编辑 CSS 样式。

“删除 CSS 样式”删除“CSS 样式”面板中的所选样式，并删除该样式应用于的任何元素中的格式设置。

备注： 右击 (Windows) 或按住 Control 键并单击 (Macintosh)“CSS 样式”面板，可打开用于处理 CSS 样式表命令的选项的上下文菜单。


创建新的 CSS 样式

创建一个 CSS 样式来自动完成 HTML 标签的格式设置或 class 属性所标识的文本范围的格式设置。

创建新的 CSS 样式：
  1. 将插入点放在文档中，然后执行以下操作之一打开“新建 CSS 样式”对话框：
    • 在“CSS 样式”面板（“窗口”>“CSS 样式”）中，单击面板右下角区域中的“新建 CSS 样式”按钮 (+)。
    • 在文本属性检查器中，根据需要单击“切换 CSS/HTML 模式”按钮以切换到“CSS 模式”，然后在“CSS 样式”弹出式菜单中选择“新建 CSS 样式”。
    • 选择“文本”>“CSS 样式”>“新建 CSS 样式”。

      • 随即出现“新建 CSS 样式”对话框。

  2. 定义您要创建的 CSS 样式的类型：
    • 若要创建可作为 class 属性应用于文本范围或文本块的自定义样式，请选择“创建自定义样式 (Class)”，然后在“名称”域中输入样式名称。

      • 备注： 自定义样式 (Class) 名称必须以句点开头，并且可以包含任何字母和数字组合。例如 .myhead1。如果您没有输入开头的句点，Dreamweaver 将自动为您输入。

    • 若要重定义特定 HTML 标签的默认格式，请选择“重定义 HTML 标签”，然后在“标签”域中输入一个 HTML 标签，或从弹出菜单中选择一个标签。
    • 若要为具体某个标签组合或所有包含特定 Id 属性的标签定义格式，请选择“使用 CSS 选择器”，然后在“选择器”域中输入一个或多个 HTML 标签，或从弹出式菜单中选择一个标签。弹出菜单中提供的选择器包括 a:active、a:hover、a:link 和 a:visited。
  3. 选择定义样式的位置：
    • 若要创建外部样式表，请选择“新建样式表文件”。
    • 若要在当前文档中嵌入样式，请选择“仅对该文档”。
  4. 单击“确定”。

    5. 出现“CSS 样式定义”对话框。

  5. 选择要为新 CSS 样式设置的样式选项。
  6. 设置完样式属性后，单击“确定”。

有关特定 CSS 样式设置的信息，请参阅下列主题：

  • 定义 CSS 类型属性
  • 定义 CSS 样式背景属性
  • 定义 CSS 样式块属性
  • 定义 CSS 样式“盒子”属性
  • 定义 CSS 样式边框属性
  • 定义 CSS 样式列表属性
  • 定义 CSS 样式定位属性
  • 定义 CSS 样式扩展属性


应用自定义 (Class) CSS 样式

自定义 (Class) CSS 样式是唯一可以应用于文档中的任何文本（与控制文本的标签无关）的 CSS 样式类型。与当前文档关联的所有自定义 (Class) 样式都显示在“CSS 样式”面板的“应用样式”视图中以及文本属性检查器的 CSS 模式中。

您会看到大多数样式都立即更新了，但您应在浏览器中预览页面，验证样式是否是按预期的方式应用的。将两个或更多的 CSS 样式应用于同一文本时，这些样式可能发生冲突并产生意外的结果。有关更多信息，请参见关于冲突的样式。

应用自定义 CSS 样式：
  1. 在文档中，选择要将 CSS 样式应用于的文本。

    2. 将插入点放在段落中将样式应用于整个段落。

    如果在单个段落中选择一个文本范围，则 CSS 样式只影响所选范围。

    若要指定要应用 CSS 样式的确切标签，请在位于“文档”窗口左下角的标签选择器中选择标签。

  2. 若要应用类样式，请执行下列操作之一：
    • 在“CSS 样式”面板（“窗口”>“CSS 样式”）中，选择“应用样式”，然后在“CSS 样式”列表中单击要应用的样式的名称。
    • 在文本属性检查器中，根据需要单击“切换 CSS/HTML 模式”按钮以切换到“CSS 模式”，然后在“CSS 样式”弹出式菜单中选择要应用的类样式。
    • 在“文档”窗口中，右击 (Windows) 或在按住 Control 键的同时单击 (Macintosh) 所选文本，在上下文菜单中选择“CSS 样式”，然后选择要应用的样式。
    • 选择“文本”>“CSS 样式”，然后在子菜单中选择要应用的样式。
将自定义样式从选定内容中删除：

选择要从中删除样式的对象或文本，然后执行以下操作之一：

  • 在文本属性检查器中，根据需要单击“切换 CSS/HTML 模式”按钮以切换到“CSS 模式”，然后在“CSS 样式”弹出式菜单中选择“无 CSS 样式”。
  • 在“CSS 样式”面板中，选择“应用样式”视图，然后选择“无 CSS 样式”。


创建和链接到外部 CSS 样式表

CSS 样式表是一个包含样式和格式规范的外部文本文件。编辑外部 CSS 样式表时，链接到该 CSS 样式表的所有文档全部更新以反映所做的更改。可以导出文档中包含的 CSS 样式以创建新的 CSS 样式表，然后附加或链接到外部样式表以应用那里所包含的样式。

除了创建的 CSS 样式表外，还可以使用 Dreamweaver 附带的 CSS 样式表附加到站点中的页面。有关如何使用 Dreamweaver 附带的设计样式表的信息，请参见创建基于 Dreamweaver 设计文件的文档。

有关如何应用样式的信息，请参见应用自定义 (Class) CSS 样式。

链接到或导出外部 CSS 样式表：
  1. 执行下列操作之一打开“CSS 样式”面板：
    • 选择“窗口”>“CSS 样式”。
    • 按 Shift + F11 键。
    • 单击启动器中的“CSS 样式”图标。
  2. 在“CSS 样式”面板中，单击“附加样式表”按钮。

    3. 出现“链接外部样式表”。

  3. 在“链接外部样式表”对话框中，执行下列操作之一：
    • 单击“浏览”(Windows) 或“选择”(Macintosh) 浏览到外部 CSS 样式表，或在“文件/URL”框中键入样式表的路径。
  4. 在“添加为”中，选择其中的一个选项：
    • 若要创建当前文档和外部样式表之间的链接，请选择“链接”。该选项在 HTML 代码中创建一个 link href 标签，并引用已发布的样式表所在的 URL。Microsoft Internet Explorer 和 Netscape Navigator 都支持此方法。
    • 若要引用外部样式表，请选择“导入”。该选项在 HTML 代码中创建一个 @import 标签，并引用已发布的样式表所在的 URL。此方法对 Netscape Navigator 无效。
  5. 单击“确定”。

    6. 外部 CSS 样式表的名称随即出现在“CSS 样式”面板的“编辑样式”视图中，而自定义 (Class) 样式出现在“应用样式”视图中，前面有一个外部样式表标识符。


编辑 CSS 样式

应用于文档的内部和外部样式编辑起来都很容易。在“编辑样式”视图中，选择要更改的样式，然后打开“CSS 样式定义”对话框并修改该样式。

对控制文档文本的 CSS 样式表进行编辑时，会立刻重新设置该 CSS 样式表控制的所有文本的格式。对外部样式表的编辑影响与它链接的所有文档。

可以设置一个外部编辑器来编辑样式表。有关如何设置外部编辑器的信息，请参见为媒体文件启动外部编辑器。

备注： 如果计算机上安装了 TopStyle（Bradbury Software 开发的 CSS 编辑器），Dreamweaver 会自动检测到它并将它设置为 .css 文件的外部编辑器。Dreamweaver 附带了 Topstyle 的测试版。

编辑 CSS 样式：
  1. 在“CSS 样式”面板中，单击“编辑样式”单选按钮查看当前文档中的样式。
  2. 单击要编辑的样式以选中它，然后执行下列操作之一：
    • 双击所选样式。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑”。
    • 单击位于“CSS 样式”面板底部的“编辑样式表”按钮。

      • “CSS 样式定义”对话框随即打开。

  3. 根据需要修改样式，然后单击“确定”。


编辑 CSS 样式表

CSS 样式表通常包含一个或多个样式。可在 CSS 样式表中编辑单个样式（请参见编辑 CSS 样式），但有时需要编辑多个样式。

“编辑样式表”对话框使您可以以多种方式处理样式表。可以使用它链接到外部 CSS 样式表，创建新的 CSS 样式表，编辑现有的 CSS 样式表，或者拷贝或删除 CSS 样式表。

编辑 CSS 样式表：
  1. 在“CSS 样式”面板中，选择“编辑样式”。
  2. 在“样式”列表中，单击要编辑的样式表以选中它，然后执行下列操作之一：
    • 单击位于“CSS 样式”面板底部的“编辑样式表”按钮。
    • 右击样式表，然后选择“编辑样式表”，然后在出现的对话框中，选择要编辑的样式表，然后单击“编辑”。

      • 所选 CSS 样式表的样式随即出现在对话框中。

  3. 在对话框中，选择要编辑的样式，然后单击“编辑”。

    4. 出现“CSS 样式定义”对话框。

  4. 根据需要修改样式，然后单击“确定”。


使用设计时间样式表

设计时间样式表使您可以在 Dreamweaver 文档中工作时显示或隐藏 CSS 样式表所应用的设计。例如，可以使用此选项在设计页面时包括或排除只限于 Macintosh 或只限于 Windows 的样式表。

只有当您正在 Dreamweaver 文档中工作时，设计时间样式表才能得到应用；当页面显示在浏览器窗口中时，只有实际附加到或嵌套在文档中的样式才出现在浏览器中。

在设计时显示或隐藏 CSS 样式表：
  1. 执行下列操作之一打开“设计时间样式表”对话框：
    • 在“CSS 样式”面板中右击，在上下文菜单中选择“设计时间样式表”。
    • 选择“文本”>“CSS 样式”>“设计时间样式表”。
  2. 在对话框中，设置显示或隐藏所选样式表的选项。
    • 若要在设计时显示 CSS 样式表，请单击“只在设计时显示”上方的加号 (+) 按钮，然后在“选择样式表”对话框中浏览到要显示的 CSS 样式表。
    • 若要隐藏 CSS 样式表，请单击“设计时隐藏”上方的加号 (+) 按钮，然后在“选择样式表”对话框中浏览到要隐藏的 CSS 样式表。
    • 若要从任一列表中删除样式表，请单击要删除的样式表，然后单击相应的减号 (-) 按钮。
  3. 单击“确定”关闭对话框。

“CSS 样式”面板用所选样式表的名称以及一个指示器（“隐藏”或“设计”）更新以反映样式表的状态。


导出样式以创建 CSS 样式表

可以从文档中导出样式以创建新的 CSS 样式表。然后，可链接到其他文档以应用这些样式。

从文档中导出 CSS 样式并创建 CSS 样式表：
  1. 选择“文件”>“导出”>“导出 CSS 样式”或选择“文本”>“导出样式表”。

    2. 出现“导出样式为 CSS 文件”对话框。

  2. 输入样式的名称，然后单击“保存”。

    3. 样式随即保存为 CSS 样式表。


关于冲突的样式

将两个或更多的 CSS 样式应用于同一文本时，这些样式可能发生冲突并产生意外的结果。浏览器根据以下规则应用样式属性：

  • 如果将两种样式应用于同一文本，浏览器显示这两种样式的所有属性，除非特定的属性发生冲突。例如，一种样式可能将蓝色指定为文本颜色，而另一种样式可能指定红色。
  • 如果应用于同一文本的两种样式的属性发生冲突，则浏览器显示最里面的样式（离文本本身最近的样式）的属性。
  • 如果有直接冲突，则 CSS 样式（使用 class 属性应用的样式）中的属性取代 HTML 标签样式中的属性。

在下面的示例中，为 h1 定义的样式可以指定所有 h1 段落的字体、大小和颜色，但应用于该段落的自定义 CSS 样式 .Blue 取代 H1 样式中的颜色设置。另一个自定义 CSS 样式 .Red 取代 .Blue，因为它位于 .Blue 样式的内部。

<h1><span class="Blue">该段落受自定义样式 .Blue 和 HTML 标签样式 h1
的控制。<span class="Red">但这个句子受 .Red 样式的控制。</span>
现在，我们返回到 .Blue 样式。</span></h1>


将 CSS 样式转换为 HTML 标签

如果使用 CSS 样式指定了文本格式（如家族、大小、颜色和字体修饰），后来决定想使该格式可在 3.0 浏览器中查看，这时可以使用“文件”>“转换”>“兼容 3.0 浏览器”命令将尽可能多的样式信息转换为 HTML 标签。

备注： 并非所有 CSS 样式都可以转换为 HTML，因为 HTML 标签并不包括或支持 CSS 中可能有的所有属性。

将使用 CSS 样式的文件转换为 3.0 浏览器兼容文件：
  1. 选择“文件”>“转换”>“兼容 3.0 浏览器”。
  2. 在出现的对话框中，选择“CSS 样式转换成 HTML 标记”。

    3. 当选择“层转为表格”选项时，Dreamweaver 用一个保留原始定位的表替换所有层。

    CSS 样式在可能的位置被替换为 b 和 font 等 HTML 标签。任何无法转换为 HTML 的 CSS 标签都被删除。有关转换和删除的样式的信息，请参见CSS 到 HTML 标记转换表。

  3. 单击“确定”。Dreamweaver 在一个新的无标题窗口中打开转换后的文件。

备注： 每次更改原始文件时，都必须执行此转换过程以更新 3.0 兼容文件。因此，最好仅在对原始文件完全满意之后再执行此过程。


CSS 到 HTML 标记转换表

下表中列出的 CSS 属性通过“文件”>“转换”>“兼容 3.0 浏览器”命令转换为 HTML 标记。 （请参见将 CSS 样式转换为 HTML 标签。）表中未列出的属性将被删除。

CSS 属性 | 转换为
color | FONT COLOR
font-family | FONT FACE
font-size | FONT SIZE="[1-7]"
font-style:oblique | I
font-style:italic | I
font-weight | B
list-style-type:square | UL TYPE="square"
list-style-type:circle | UL TYPE="circle"
list-style-type:disc | UL TYPE="disc"
list-style-type:upper-roman | OL TYPE="I"
list-style-type:lower-roman | OL TYPE="i"
list-style-type:upper-alpha | OL TYPE="A"
list-style-type:lower-alpha | OL TYPE="a"
list-style | UL TYPE 或 OL TYPE（取适用的那个）
text-align | P ALIGN 或 DIV ALIGN（取适用的那个）
text-decoration:underline | U
text-decoration:line-through | STRIKE


检查拼写

使用“文本”菜单中的“检查拼写”命令可以检查当前文档中的拼写。“检查拼写”命令忽略 HTML 标签和属性值。

默认情况下，拼写检查器使用美国英语拼写字典。若要更改字典，请选择“编辑”>“参数选择”>“常规”或“Dreamweaver”>“参数选择”>“常规”(Mac OS X)，然后在“拼写字典”弹出菜单中选择要使用的字典。其他语言的字典可从 Dreamweaver 技术支持中心下载。

检查和更正拼写：
  1. 选择“文本”>“检查拼写”或按 Shift+F7 键。

    2. 当 Dreamweaver 遇到无法识别的字时，将出现“检查拼写”对话框。

  2. 在“检查拼写”对话框中，根据所需的差异处理方法选择相应的选项：

    3. “添加到私人”将无法识别的字添加到个人字典。

    “忽略”忽略无法识别的字的此实例。

    “忽略全部”忽略无法识别的字的所有实例。

    “更改”将无法识别的字的此实例替换为您在“更改为”文本框中键入的文本或“建议”列表中的选定内容。

    “全部更改”以相同的方式替换无法识别的字的所有实例。


搜索和替换文本

可以在当前文档、所选文件、目录或整个站点中搜索文本、由特定标签环绕的文本或 HTML 标签和属性。可以使用不同的命令搜索文件，以及搜索文件中的文本和/或 HTML 标签：“本地站点中定位”和“远端站点中定位”搜索文件，而“编辑”>“查找和替换”搜索文件中的文本和标签。

搜索文档中的文本和/或 HTML：
  1. 从下列选项中选择：
    • 在“设计”视图中，从“文档”窗口或“站点”面板中，选择“编辑”>“查找和替换”。
    • 在“代码”视图中，右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后从上下文菜单中选择“查找和替换”。
  2. 在出现的“查找”或“替换”对话框中，使用“查找在”选项指定要搜索的文件：
    • “当前文档”将搜索范围限制在活动文档。只有当在“文档”窗口处于活动状态下选择“查找和替换”，或者从代码检查器的上下文菜单中选择“查找和替换”时，该选项才可用。
    • “整个当前本地站点”将搜索范围扩展到当前站点中的所有 HTML 文档、库文件和文本文档。选择“整个当前本地站点”后，当前站点的名称出现在弹出菜单的右侧。如果这不是您要搜索的站点，请从“站点”面板的当前站点弹出菜单中选择一个不同的站点。
    • “站点中选定的文件”将搜索范围限制在“站点”面板中当前选定的文件和文件夹。只有在“站点”面板处于活动状态（即位于“文档”窗口的前面）时选择“查找和替换”，该选项才可用。
    • “文件夹”将搜索范围限制在特定的文件组。选择“文件夹”后，单击文件夹图标浏览并选择要搜索的目录。
  3. 使用“查找内容”选项指定要执行的搜索类型。
    • “源代码”使您可以在 HTML 源代码中搜索特定的文本字符串。请参见搜索并替换标签和属性。
    • “文本”使您可以在“文档”窗口中搜索特定的文本字符串。文本搜索忽略任何中断字符串的 HTML。例如，对 the black dog 的搜索与 the black dog 和 the <i>black</i> dog 都匹配。
    • “文本（高级）”使您可以搜索或者在标签内或者不在标签内的特定文本字符串。例如，在包含以下 HTML 的文档中，搜索不在 i 内的 tries 将只找到该单词的第二个实例：John <i>tries</i> to get his work done on time, but he doesn't always succeed.He tries very hard.请参见搜索包含在特定标签中的文本。
    • “指定标签”使您可以搜索特定的标签、属性和属性值，如所有 valign 设置为 top 的 td 标签。请参见搜索标签和属性。

      • 备注： 按 Control+Enter 键或 Shift+Enter 键 (Windows) 或 Control+Return 键、Shift+Return 键或 Command+Return 键 (Macintosh) 可以在文本搜索域中添加换行符，使您可以搜索回车符。如果不使用正则表达式，则执行此搜索时请确保取消选择“忽略空白差别”选项。注意，此搜索专门查找回车符，而不是仅查找换行符匹配项；例如，它不查找 <br> 标签或 <p> 标签。回车符在“设计”视图中显示为空格而不是换行符。

  4. 使用下列选项扩展或限制搜索范围：
    • “区分大小写”选项将搜索范围限制在与要查找的文本的大小写完全匹配的文本。例如，如果搜索 the brown derby，则不会找到 The Brown Derby。

      • 备注： “忽略空白差别”选项在被选中后将所有空白视为单个空格以便进行匹配。例如，选择该选项后，this text 与 this text 匹配，但不与 this text 匹配。如果选择了“使用正则表达式”选项，则该选项不可用；必须显式编写正则表达式以忽略空白。注意，<p> 和 <br> 标签不算作空白。

    • “使用正则表达式”选项使搜索字符串中的特定字符和短字符串（如 ?、*、\w 和 \b）被解释为正则表达式运算符。例如，对 the b\w*\b dog 的查找与 the black dog 和 the barking dog 都匹配。请参见关于常规表达式。

      • 备注： 如果您在“代码”视图中工作并对文档进行了更改，然后试图查找和替换源代码以外的任何内容，这时会出现一个对话框，通知您 Dreamweaver 正在同步两个视图然后再进行搜索。有关同步视图的更多信息，请参见查看您的代码。

相关主题

搜索和替换文本


参考资料

本节提供有关本章中介绍的对话框、属性检查器和面板的信息。


设置文本属性选项

文本属性检查器显示文档中选择的文本的当前格式属性。可以通过设置新选项更改格式。样式立即应用于文本。

可以使用文本属性检查器应用 HTML 格式或层叠样式表 (CSS) 格式。HTML 格式使您可以选择文本格式选项（如字体、大小、粗体和斜体），而 CSS 格式使您可以将 CSS 类样式应用于所选文本。

在使用属性检查器应用粗体或斜体样式时，Dreamweaver 自动分别应用 <strong> 或 <em> 标签。如果正在为使用 3.0 或更早版本的浏览器的查看者设计页面，则应该在“参数选择”对话框（“编辑”>“参数选择”）的“常规”类别中更改此参数选择。

有关如何创建类样式的信息，请参阅创建新的 CSS 样式

若要切换文本格式模式，请执行以下操作：

在属性检查器中，单击“切换 CSS/HTML 模式”按钮。

设置 CSS 格式选项：
  1. 如果属性检查器尚未打开，请将其打开（“窗口”>“属性”）。
  2. 选择要设置格式的文本。
  3. 在属性检查器中，如果尚未选择“CSS 模式”，请单击“切换 CSS/HTML 模式”按钮切换到“CSS 模式”。
  4. 设置要应用于所选文本的 CSS 选项。

    5. “格式”设置所选文本的段落样式。“段落”应用 <p> 标签的默认格式，“标题 1”添加 H1 标签，等等。

    “CSS 样式”显示当前应用于所选文本的类样式。如果没有对选定内容应用过任何样式，则弹出式菜单显示“无 CSS 样式”。如果已对选定内容应用了多个样式，则弹出菜单是空的。

    使用“CSS 样式”弹出式菜单执行下列任何操作：

    • 选择要应用于选定内容的类样式。
    • 选择“无 CSS 样式”删除当前应用的 CSS 样式。
    • 选择“新建 CSS 样式”打开“新建 CSS 样式”对话框，创建一个将自动应用于所选文本的新样式。如果没有选择任何文本，则样式将应用于包含插入点的段落或块级标签。
    • 选择“编辑 CSS 样式”打开“编辑样式表”对话框来编辑 CSS 样式。有关更多信息，请参阅编辑 CSS 样式。
    • 选择“附加样式表”以将 CSS 样式表附加到您的文档。有关更多信息，请参阅创建和链接到外部 CSS 样式表。

      • “粗体”根据在“参数选择”对话框的“常规”类别中设置的样式参数选择，将 <b> 或 <strong> 应用于选定的文本。

      “斜体”根据在“参数选择”对话框的“常规”类别中设置的样式参数选择，将 <i> 或 <em> 应用于选定的文本。

      有关设置“常规”参数选择的信息，请参见设置“常规”参数。

若要设置 HTML 格式选项，请执行以下操作：
  1. 如果属性检查器尚未打开，请将其打开（“窗口”>“属性”）。
  2. 选择要设置格式的文本。
  3. 在属性检查器中，如果尚未选择“HTML 模式”，请单击“切换 CSS/HTML 模式”按钮切换到“HTML 模式”。
  4. 设置要应用于所选文本的选项。

    5. “格式”设置所选文本的段落样式。“段落”应用 <p> 标签的默认格式，“标题 1”添加 H1 标签，等等。

    “字体组合”对文本应用所选字体组合。使用弹出菜单选择要应用的字体组合，或选择“编辑字体列表”创建或编辑字体组合。

    “大小”应用特定的字体大小（1 到 7）或相对于基准字体大小（默认值是 3）的字体大小（+ 或 -1 到 + 或 -7）。

    “文本颜色”以所选颜色显示文本。单击颜色框选择网页安全色，或在相邻的文本域中输入十六进制值（例如 #FF0000）。

    “粗体”根据在“参数选择”对话框的“常规”类别中设置的样式参数选择，将 <b> 或 <strong> 应用于选定的文本。

    “斜体”根据在“参数选择”对话框的“常规”类别中设置的样式参数选择，将 <i> 或 <em> 应用于选定的文本。

    有关设置“常规”参数选择的信息，请参见设置“常规”参数。

    左对齐、居中对齐和右对齐应用各自的对齐方式。

    “链接”使您可以创建所选文本的超文本链接。单击文件夹图标浏览到站点中的文件；键入 URL；将“指向文件”图标拖到“站点”面板中的文件；或将文件从“站点”面板拖到框中。

    “目标”使您可以指定将链接文档加载到的框架或窗口：

    • “_blank”将链接文件加载到未命名的新浏览器窗口中。
    • “_parent”将链接文件加载到包含链接的父框架页或窗口中。如果包含链接的框架不是嵌套的，则链接文件加载到整个浏览器窗口中。
    • “_self”将链接文件加载到链接所在的同一框架或窗口中。此目标是隐式的，因此通常不需要指定它。
    • “_top”将链接文件加载到整个浏览器窗口中，并由此删除所有框架。

      • “项目列表”创建所选文本的项目列表。如果未选择文本，则启动一个新的项目列表。

      编号列表创建所选文本的编号列表。如果未选择文本，则启动一个新的编号列表。

      “列表项目”打开“列表属性”对话框。请参阅设置列表属性选项。

      缩进和凸出通过应用或删除 blockquote 标签缩进或删除所选文本的缩进。在列表中，缩进创建一个嵌套列表，而删除缩进则取消嵌套列表。

相关主题

设置段落格式

设置和更改字体和样式

创建新的 CSS 样式

设置“常规”参数


设置列表属性选项

使用“列表属性”对话框可以设置整个列表或个别列表项的外观。可以设置编号样式、重置计数或设置个别列表项或整个列表的项目符号样式选项。

有关如何使用层叠样式表设置列表属性的信息，请参阅定义 CSS 样式列表属性。

设置整个列表的列表属性：
  1. 在“文档”窗口中，创建至少一个列表项。新样式将自动应用于添加到列表的其它项。
  2. 将插入点放到列表项的文本中后，选择“文本”>“列表”>“属性”打开“列表属性”对话框。
  3. 在出现的对话框中，设置要用来定义列表的选项：

    4. “列表类型”指定列表属性，而“列表项目”指定列表中的个别项。使用弹出菜单选择项目符号、编号、目录或菜单列表。根据所选的“列表类型”，对话框中将出现不同的选项。

    “样式”确定用于编号列表或项目列表的编号或项目符号的样式。所有列表项都将具有该样式，除非为列表项指定新样式。

    “开始计数”设置第一个编号列表项的值。

  4. 单击“确定”设置选项并关闭对话框。
设置列表项的列表属性：
  1. 在“文档”窗口中，将插入点放在要影响的列表项的文本中
  2. 选择“文本”>“列表”>“属性”。
  3. 在出现的对话框的“列表项目”下，设置要用来定义列表项的选项：

    4. “新建样式”使您可以指定所选列表项的样式。“新建样式”弹出菜单中的样式与“列表类型”弹出菜单中显示的列表类型相关。例如，如果“列表项目”弹出菜单显示“项目列表”，则“新建样式”弹出菜单中只有项目符号选项可用。

    “重设计数”使您可以设置用来给列表项编号的特定数字。

  4. 单击“确定”设置选项并关闭对话框。


设置 CSS 样式参数

CSS 样式参数选择控制 Dreamweaver 如何编写定义 CSS 样式的代码。CSS 样式可以以速记形式来编写，有些人觉得这种形式使用起来更容易。但某些旧版本的浏览器不能正确解释速记。

显示 CSS 样式表格式参数选择
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从“分类”列表中选择“CSS 样式”。
  2. 设置要应用的 CSS 样式选项：

    3. “使用速记”使您可以选择 Dreamweaver 以速记形式编写的 CSS 样式属性。

    “当编辑 CSS 样式时使用速记”控制 Dreamweaver 是否以速记形式重新编写现有样式。

    选择“如果原来使用速记”使 Dreamweaver 将所有样式保留原样。

    选择“依据以上设置”使 Dreamweaver 以速记形式重新为“使用速记”中选择的属性编写样式。

  3. 单击“确定”。


定义 CSS 类型属性

使用“CSS 样式定义”对话框中的“类型”类别可以定义 CSS 样式的基本字体和类型设置。

另见关于层叠样式表和编辑 CSS 样式。

定义 CSS 样式的类型设置：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“类型”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “字体”为样式设置字体家族（或家族系列）。浏览器使用用户系统上安装的字体系列中的第一种字体显示文本。为了与 Internet Explorer 3.0 兼容，首先列出 Windows 字体。两种浏览器都支持字体属性。

    “大小”定义文本大小。可以通过选择数字和度量单位选择特定的大小，也可以选择相对大小。以像素为单位可以很好地防止浏览器破坏文本。两种浏览器都支持大小属性。

    “样式”将“正常”、“斜体”或“偏斜体”指定为字体样式。默认设置是“正常”。两种浏览器都支持样式属性。

    “行高”设置文本所在行的高度。该设置传统上称为“前导”。选择“正常”自动计算字体大小的行高，或输入一个确切的值并选择一种度量单位。两种浏览器都支持行高属性。

    “修饰”向文本中添加下划线、上划线或删除线，或使文本闪烁。正常文本的默认设置是“无”。链接的默认设置是“下划线”。将链接设置设为无时，可以通过定义一个特殊的类删除链接中的下划线。两种浏览器都支持修饰属性。

    “粗细”对字体应用特定或相对的粗体量。“正常”等于 400；“粗体”等于 700。两种浏览器都支持粗细属性。

    “变量”设置文本的小型大写字母变量。Dreamweaver 不在“文档”窗口中显示该属性。Internet Explorer 支持变量属性，但 Navigator 不支持。

    “大小写”将选定内容中的每个单词的首字母大写或将文本设置为全部大写或小写。两种浏览器都支持大小写属性。

    “颜色”设置文本颜色。两种浏览器都支持颜色属性。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式背景属性

使用“CSS 样式定义”对话框的“背景”类别可以定义 CSS 样式的背景设置。可以对网页中的任何元素应用背景属性。例如，创建一个样式，将背景颜色或背景图像添加到任何页面元素中，比如在文本、表格、页面等的后面。还可以设置背景图像的位置。另见关于层叠样式表和编辑 CSS 样式。

定义背景设置：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“背景”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “背景颜色”设置元素的背景颜色。两种浏览器都支持背景颜色属性。

    “背景图像”设置元素的背景图像。两种浏览器都支持背景图像属性。

    “重复”确定是否以及如何重复背景图像。两种浏览器都支持重复属性。

    “不重复”在元素开始处显示一次图像。

    “重复”在元素的后面水平和垂直平铺图像。

    “横向重复”和“纵向重复”分别显示图像的水平带区和垂直带区。图像被剪辑以适合元素的边界。

    备注： 使用“重复”属性重定义 body 标签并设置不平铺或重复的背景图像。

    “附件”确定背景图像是固定在它的原始位置还是随内容一起滚动。注意，某些浏览器可能将“固定”选项视为“滚动”。Internet Explorer 支持该选项，但 Netscape Navigator 不支持。

    水平位置和垂直位置指定背景图像相对于元素的初始位置。这可以用于将背景图像与页面中心垂直和水平对齐。如果附件属性为“固定”，则位置相对于“文档”窗口而不是元素。Internet Explorer 支持该属性，但 Netscape Navigator 不支持。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式块属性

使用“CSS 样式定义”对话框的“区块”类别可以定义标签和属性的间距和对齐设置。

定义块设置：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“区块”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “单词间距”设置单词的间距。若要设置特定的值，在弹出菜单中选择“值”，然后输入一个数值。在第二个弹出菜单中，选择度量单位（例如，选择像素、点数等）。

    备注： 可以指定负值，但显示取决于浏览器。Dreamweaver 不在“文档”窗口中显示该属性。

    “字母间距”增加或减少字母或字符的间距。若要减少字符间距，请指定一个负值（例如 -4）。字母间距设置覆盖对齐的文本设置。Internet Explorer 4 和更高版本以及 Netscape Navigator 6 支持“字母间距”属性。

    “垂直对齐”指定它应用于的元素的垂直对齐方式。仅当应用于 <img> 标签时，Dreamweavertag 才在“文档”窗口中显示该属性。

    “文本对齐”设置元素中的文本对齐方式。两种浏览器都支持“文本对齐”属性。

    “文本缩进”指定第一行文本缩进的程度。可以使用负值创建凸出，但显示取决于浏览器。仅当标签应用于块级元素时，Dreamweaver 才在“文档”窗口中显示该属性。两种浏览器都支持“文本缩进”属性。

    “空格”确定如何处理元素中的空格。从下面三个选项中选择：“正常”收缩空格；“保留”的处理方式与文本被括在 pre 标签中一样（即保留所有空白，包括空格、制表符和回车）；“不换行”指定仅当遇到 br 标签时文本才换行。Dreamweaver 不在“文档”窗口中显示该属性。Netscape Navigator 和 Internet Explorer 5.5 支持“空格”属性。

    “显示”指定是否以及如何显示元素。“无”关闭它被指定给的元素的显示。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式“盒子”属性

使用“CSS 样式定义”对话框的“盒子”类别可以为控制元素在页面上的放置方式的标签和属性定义设置。

可以在应用填充和边距设置时将设置应用于元素的各个边，也可以使用“全部相同”设置将相同的设置应用于元素的所有边。

定义元素在页面上的放置方式：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“盒子”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “宽和高”设置元素的宽度和高度。

    “浮动”设置其它元素（如文本、层、表格等）在哪个边围绕元素浮动。其它元素按通常的方式环绕在浮动元素的周围。两种浏览器都支持“浮动”属性。

    “清除”定义不允许层的边。如果清除边上出现层，则带清除设置的元素移到该层的下方。两种浏览器都支持“清除”属性。

    “填充”指定元素内容与元素边框（如果没有边框，则为边距）之间的空格量。取消选择“全部相同”选项可设置元素各个边的填充。

    “全部相同”将相同的填充属性设置为它应用于的元素的“上”、“右”、“下”和“左”。

    “边界”指定一个元素的边框（如果没有边框，则为填充）与另一个元素之间的空格量。仅当应用于块级元素（段落、标题、列表等）时，Dreamweaver 才在“文档”窗口中显示该属性。取消选择“全部相同”可设置元素各个边的边距。

    “全部相同”将相同的边距属性设置为它应用于的元素的“上”、“右”、“下”和“左”。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式边框属性

使用“CSS 样式定义”对话框的“边框”类别可以定义元素周围的边框的设置（如宽度、颜色和样式）。

设置元素的边框样式：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“边框”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “样式”设置边框的样式外观。样式的显示方式取决于浏览器。Dreamweaver 在“文档”窗口中将所有样式呈现为实线。两种浏览器都支持样式属性。取消选择“全部相同”可设置元素各个边的边框样式。

    “全部相同”将相同的边框样式属性设置为它应用于的元素的“上”、“右”、“下”和“左”。

    “宽度”设置元素边框的粗细。两种浏览器都支持“宽度”属性。取消选择“全部相同”可设置元素各个边的边框宽度。

    “全部相同”将相同的边框宽度设置为它应用于的元素的“上”、“右”、“下”和“左”。

    “颜色”设置边框的颜色。可以分别设置每个边的颜色，但显示取决于浏览器。取消选择“全部相同”可设置元素各个边的边框颜色。

    “全部相同”将相同的边框颜色设置为它应用于的元素的“上”、“右”、“下”和“左”。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式列表属性

“CSS 样式定义”对话框的“列表”类别为列表标签定义列表设置（如项目符号大小和类型）。

定义列表样式：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框，选择“列表”，然后选择所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “类型”设置项目符号或编号的外观。两种浏览器都支持“类型”。

    “项目符号图像”使您可以为项目符号指定自定义图像。单击“浏览”(Windows) 或“选择”(Macintosh) 通过浏览选择图像，或键入图像的路径。

    “位置”设置列表项文本是否换行和缩进（外部）以及文本是否换行到左边距（内部）。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式定位属性

“定位”样式属性使用“层”参数选择中定义层的默认标签，将标签或所选文本块更改为新层。（请参阅设置层参数。）

设置层定位属性：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“定位”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “类型”确定浏览器应如何来定位层，如下所示：

    “绝对”使用“定位”框中输入的坐标，相对于页面左上角来放置层。

    “相对”使用“定位”框中输入的坐标，相对于对象在文档的文本流中的位置来放置层。该选项不显示在“文档”窗口中。

    “静态”将层放在它在文本流中的位置。

    “显示”确定层的初始显示条件。如果不指定可见性属性，则默认情况下大多数浏览器都继承父级的值。选择以下可见性选项之一：

    “继承”继承层父级的可见性属性。如果层没有父级，则它将是可见的。

    “可见”显示层的内容，而不管父级的值是什么。

    “隐藏”隐藏层的内容，而不管父级的值是什么。

    “Z 轴”确定层的堆叠顺序。编号较高的层显示在编号较低的层的上面。值可以为正，也可以为负。（使用“层”面板更改层的堆叠顺序更容易；请参阅更改层的层叠顺序。）

    “溢出（仅限于 CSS 层）”确定在层的内容超出它的大小时将发生的情况。这些属性控制如何处理此扩展，如下所示：

    “可见”增加层的大小，使它的所有内容均可见。层向右下方扩展。

    “隐藏”保持层的大小并剪辑任何超出的内容。不提供任何滚动条。

    “滚动”在层中添加滚动条，不论内容是否超出层的大小。专门提供滚动条可避免滚动条在动态环境中出现和消失所引起的混乱。该选项不显示在“文档”窗口中，并且仅适用于支持滚动条的浏览器。受 Internet Explorer 和 Netscape Navigator 6 的支持。

    “自动”使滚动条仅在层的内容超出它的边界时才出现。该选项不显示在“文档”窗口中。

    “定位”指定层的位置和大小。浏览器如何解释位置取决于“类型”设置。如果层的内容超出指定的大小，则大小值被覆盖。

    位置和大小的默认单位是像素。对于 CSS 层，还可以指定下列单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）、(ems)、(exs) 或 %（父级值的百分比）。这些缩写的后面必须紧跟值，中间没有空格：例如，3mm。

    “剪辑”定义层的可见部分。如果指定了剪辑区域，可以通过脚本语言（如 JavaScript）访问它，并操作属性以创建像擦除这样的特殊效果。通过使用时间轴和“改变属性”行为可以设置这些擦除效果。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


定义 CSS 样式扩展属性

“扩展”样式属性包括过滤器、分页和光标选项，它们中的大部分不受任何浏览器的支持，或者仅受 Internet Explorer 4.0 和更高版本的支持。

指定扩展属性：
  1. 如果“CSS 样式”面板尚未打开，请打开该面板（按 Shift + F11 键）。
  2. 执行下列操作之一打开“CSS 样式定义”对话框：
    • 添加一个新样式。有关详细信息，请参阅创建新的 CSS 样式。
    • 双击一个现有样式以打开它进行编辑。
  3. 在“CSS 样式定义”对话框中，选择“扩展”，然后设置所需的样式属性。

    4. 将下列任意属性保留为空（如果它们对于样式并不重要）：

    “分页”在打印期间在样式所控制的对象之前或者之后强行分页。选择要在弹出菜单中设置的选项。此选项不受任何 4.0 浏览器的支持，但可能受未来的浏览器的支持。

    “光标”当指针位于样式所控制的对象上时改变指针图像。选择要在弹出菜单中设置的选项。Internet Explorer 4.0 和更高版本以及 Netscape Navigator 6 支持该属性。

    “过滤器”对样式所控制的对象应用特殊效果（包括模糊和反转）。从弹出菜单中选择一种效果。

  4. 设置完这些选项后，在面板左侧选择另一个 CSS 类别以设置其它的样式属性，或单击“确定”。


设置 CSS 样式表编辑选项

使用“编辑样式表”对话框可以编辑所选 CSS 样式表。

有关如何打开“编辑样式表”对话框的信息，请参阅编辑 CSS 样式表。

编辑 CSS 样式表：
  1. 在“编辑样式表”对话框中，选择要编辑的外部样式表的名称，然后单击“编辑”。

    2. 所选样式表的名称和已定义的样式出现在对话框中。

  2. 在对话框中，选择要编辑的样式，然后单击“编辑”。

    3. 出现“CSS 样式定义”对话框。

  3. 在“CSS 样式定义”对话框中选择编辑样式的选项。
  4. 更新完样式表中的样式后，单击“保存”。
上一页


插入图像

图像通常用来添加图形界面（例如导航按钮）、具有视觉感染力的内容（例如照片）或交互式设计元素（例如鼠标经过图像或图像地图）。

在 Macromedia Dreamweaver MX 中，您可以在“设计”视图或“代码”视图中将图像插入文档。在 Dreamweaver 文档中添加图像时，可以设置或修改图像属性并直接在“文档”窗口中查看所做的更改。

若要建立一个高效的 Web 设计工作流程，您可以选择图像编辑器参数选择，然后当您在 Dreamweaver 中工作时自动启动它来编辑图像。

本章包含以下几节：

  • 关于图像
  • 插入图像
  • 调整图像大小
  • 创建鼠标经过图像
  • 使用外部图像编辑器
  • 将行为应用于图像
  • 参考资料
下一页


关于图像

虽然存在很多种图形文件格式，但 Web 页中通常使用的只有三种，即 GIF、JPEG 和 PNG。目前，GIF 和 JPEG 文件格式的支持情况最好，大多数浏览器都可以查看它们。

由于 PNG 文件具有较大的灵活性并且文件大小较小，所以它对于几乎任何类型的 Web 图形都是最适合的；但是，Microsoft Internet Explorer（4.0 和更高版本）和 Netscape Navigator（4.04 和更高版本）只能部分支持 PNG 图像的显示。因此，除非您正在为使用支持 PNG 格式的浏览器的特定目标用户进行设计，否则请使用 GIF 或 JPEG 以迎合更多人的需求。

GIF（图形交换格式）文件最多使用 256 种颜色，最适合显示色调不连续或具有大面积单一颜色的图像，例如导航条、按钮、图标、徽标或其他具有统一色彩和色调的图像。

JPEG（联合图像专家组标准）文件格式是用于摄影或连续色调图像的高级格式，这是因为 JPEG 文件可以包含数百万种颜色。随着 JPEG 文件品质的提高，文件的大小和下载时间也会随之增加。通常可以通过压缩 JPEG 文件在图像品质和文件大小之间达到良好的平衡。

PNG（可移植网络图形）文件格式是一种替代 GIF 格式的无专利权限制的格式，它包括对索引色、灰度、真彩色图像以及 alpha 通道透明的支持。PNG 是 Macromedia Fireworks MX 固有的文件格式。PNG 文件可保留所有原始层、矢量、颜色和效果信息（例如阴影），并且在任何时候所有元素都是完全可编辑的。文件必须具有 .png 文件扩展名才能被 Macromedia Dreamweaver MX 识别为 PNG 文件。

备注： 不同浏览器对 PNG 的支持是不一致的；因此，如果使用 PNG 文件，您还应该将它们导出为 GIF 或 JPEG，以确保它们具有 Web 版本。


插入图像

在您将图像插入 Dreamweaver 文档时，Dreamweaver 自动在 HTML 源代码中生成对该图像文件的引用。为了确保此引用的正确性，该图像文件必须位于当前站点中。如果图像文件不在当前站点中，Dreamweaver 会询问您是否要将此文件拷贝到当前站点中。

您还可以将图像作为动态内容添加；有关信息，请参见将图像动态化。

若要插入图像，请执行以下操作：
  1. 在“文档”窗口中，将插入点放置在您要显示图像的地方，然后执行以下操作之一：
    • 在“插入”栏的“常用”类别中，单击“图像”图标。
      这是所描述的功能的图片。
    • 在“插入”栏的“常用”类别中，将“图像”图标拖入“文档”窗口中（或者，如果您正处理代码，则拖入“代码”视图窗口中）。
    • 选择“插入”>“图像”。
    • 将图像从“资源”面板（“窗口”>“资源”）拖到“文档”窗口中的所需位置；然后跳到第 3 步。
    • 将图像从“站点”面板拖到“文档”窗口中的所需位置；然后跳到第 3 步。
    • 将图像从桌面拖到“文档”窗口中的所需位置；然后跳到第 3 步。
  2. 在出现的对话框中执行下列操作之一：
    • 选择“文件系统”以选择一个图形文件。
    • 选择“数据源”以选择一个动态图像源文件。
  3. 浏览以选择您要插入的图像或内容源文件。

    4. 如果您正在一个未保存的文档中工作，则 Dreamweaver 生成一个对图像文件的 file:// 引用。将文档保存到站点中的任何位置后，Dreamweaver 将该引用转换为文档相对路径。

  4. 在属性检查器（“窗口”>“属性”）中，设置该图像的属性。

    5. 有关更多信息，请参见设置图像属性。

相关主题

设置背景图像或背景页面颜色

使用间隔图像


插入图像占位符

图像占位符是在准备好将最终图形添加到 Web 页之前使用的图形。

您可以定义占位符的某些属性：您可以设置占位符的大小和颜色，以及为占位符提供文本标签。当在 Dreamweaver 的“文档”窗口中查看图像占位符时，将显示图像占位符的颜色、大小属性和标签文字。

当在浏览器窗口中查看时，不显示标签文字和大小文本。

若要插入图像占位符，请执行以下操作：
  1. 在“文档”窗口中，将插入点放置在要插入占位符图形的位置。
  2. 执行下列操作之一：
    • 在“插入”栏中，选择“常用”，然后单击“图像占位符”图标。
      这是所描述的功能的图片。
    • 在“插入”栏中，选择“常用”，然后将“图像占位符”图标拖到“文档”窗口中。
    • 选择“插入”>“图像占位符”。

      • “图像占位符”对话框随即显示。

  3. 在该对话框中，为图像占位符选择选项。

    4. 有关设置这些选项的详细信息，请参见完成“图像占位符”对话框。

  4. 单击“确定”。

相关主题

替换图像占位符

调整图像大小

设置图像占位符属性

在 Fireworks 中更新 Dreamweaver 图像占位符.


替换图像占位符

图像占位符不是在浏览器中显示的图形图像。在您发布站点之前，应该用适用于 Web 的图形文件（例如 GIF 或 JPEG）替换所有添加的图像占位符。

如果您具有 Fireworks MX，则可以根据 Dreamweaver 图像占位符创建新的图形。新图像设置为与占位符图像相同的大小。您可以编辑该图像，然后在 Dreamweaver 中替换它。有关在 Fireworks MX 中创建替换图像的信息，请参见在 Fireworks 中更新 Dreamweaver 图像占位符。

若要更新图像源文件，请执行以下操作：
  1. 在“文档”窗口中执行下列操作之一：
    • 双击图像占位符
    • 单击图像占位符将其选中，然后在属性检查器（“窗口”>“属性”）中单击“源文件”域旁的文件夹图标

      • 即会出现“图像源文件”对话框。

  2. 在此对话框中，导航到要使用它替换图像占位符的图像。
  3. 单击“确定”。

    4. 选定图像即出现在文档中。


对齐图像

使用图像属性检查器设置图像相对于同一段落或行中其他元素的对齐方式。

备注： HTML 不提供某些字处理应用程序中提供的文本环绕图像轮廓换行的方法

您可以将图像与同一行中的文本、另一个图像、插件或其他元素对齐。您还可以使用对齐按钮（左对齐、右对齐、居中对齐）设置图像的水平对齐方式。

“默认值”通常指定基线对齐。（根据站点访问者的浏览器的不同，默认值也会有所不同。）

“基线和底部”将文本（或同一段落中的其他元素）的基线与选定对象的底部对齐。

“顶端”将图像的顶端与当前行中最高项（图像或文本）的顶端对齐。

“中间”将图像的中部与当前行的基线对齐。

“文本上方”将图像的顶端与文本行中最高字符的顶端对齐。

“绝对中间”将图像的中部与当前行中文本的中部对齐。

“绝对底部”将图像的底部与文本行（这包括字母下部，例如在字母 g 中）的底部对齐。

“左对齐”将所选图像放置在左边，文本在图像的右侧换行。如果左对齐文本在行上处于对象之前，它通常强制左对齐对象换到一个新行。

“右对齐”将图像放置在右边，文本在对象的左侧换行。如果右对齐文本在行上处于对象之前，它通常强制右对齐对象换到一个新行。


调整图像大小

您可以在 Dreamweaver 的“文档”窗口的“设计”视图中以可视化的形式调整元素的大小，这些元素包括图像、插件、Macromedia Shockwave 或 Flash 影片、applets 和 ActiveX 控件等。可视调整大小可帮助您确定元素在不同尺寸时如何影响布局。

调整大小将元素的 width 和 height 属性更改回其原始大小。当您调整元素大小时，属性检查器的“宽”和“高”域显示该元素当前的宽度和高度。元素的文件大小不发生变化。

如果您增加或减少位图元素（例如 GIF、JPEG 和 PNG 图像）的 width 和 height 属性，则该元素可能会变形。若要保持相同的纵横比，请在调整位图大小的同时按住 Shift 键。但是，建议只有在以确定布局为目的时才在 Dreamweaver 中以可视的方式调整位图的大小。确定了理想的图像大小之后，在图像编辑应用程序中编辑该文件。对图像进行编辑还可以减少其文件大小，从而缩短下载时间。

若要调整元素的大小，请执行以下操作：
  1. 在“文档”窗口中选择该元素（例如，一个图像或 Shockwave 影片）。

    2. 元素的底部、右侧及右下角出现调整大小手柄。如果未出现调整大小手柄，则单击要调整大小的元素以外的部分然后重新选择它，或在标签选择器中单击相应的标签以选择该元素。

  2. 执行下列操作之一，调整元素的大小：
    • 若要调整元素的宽度，请拖动右侧的选择控制点。
    • 若要调整元素的高度，请拖动底部的选择控制点。
    • 若要同时调整元素的宽度和高度，请拖动顶角的选择控制点。
    • 若要在调整元素尺寸时保持元素的比例（其宽高比），请在按住 Shift 键的同时拖动顶角的选择控制点。

以可视方式最小可以将元素大小调整到 8 x 8 像素。若要将元素的宽度和高度调整到更小的大小（例如 1 x 1 像素），请使用属性检查器输入数值。

若要将已调整大小的元素返回到原始尺寸，请在属性检查器中删除“宽”和“高”域中的值，或者单击“重设大小”按钮。


创建鼠标经过图像

鼠标经过图像是一种在浏览器中查看并使用鼠标指针移过它时发生变化的图像。鼠标经过图像实际上由两个图像组成：主图像（当首次载入页时显示的图像）和次图像（当鼠标指针移过主图像时显示的图像）。鼠标经过图像中的这两个图像应大小相等；如果这两个图像大小不同，Dreamweaver 将自动调整第二个图像的大小以匹配第一个图像的属性。

您不能在 Dreamweaver 的“文档”窗口中看到鼠标经过图像的效果。若要看到鼠标经过图像的效果，请按 F12 键在浏览器中预览该页，然后将鼠标指针滑过该图像。

鼠标经过图像自动设置为响应 onMouseOver 事件。有关设置图像以响应不同事件（例如，鼠标单击）或有关编辑鼠标经过图像以显示不同图像的信息，请参见交换图像。

鼠标经过图像的一种较为复杂的形式是导航条。若要创建导航条，请使用“插入”>“交互式图像”>“导航条”命令（请参见插入导航条）。

若要创建鼠标经过图像，请执行以下操作：
  1. 在“文档”窗口中，将插入点放置在要显示鼠标经过图像的位置。
  2. 使用以下方法之一插入鼠标经过图像：
    • 在“插入”栏中，选择“常用”，然后单击“鼠标经过图像”图标。
    • 在“插入”栏中，选择“常用”，然后将“鼠标经过图像”图标拖到“文档”窗口中的所需位置。
    • 选择“插入”>“交互式图像”>“鼠标经过图像”。

      • 随即显示“插入鼠标经过图像”对话框。

  3. 在“图像名称”文本框中，键入鼠标经过图像的名称。
  4. 在“原始图像”文本框中，单击“浏览”并选择您要在载入页时显示的图像，或在文本框中输入图像文件的路径。
  5. 在“鼠标经过图像”文本框中，单击“浏览”并选择您要在鼠标指针滑过原始图像时显示的图像，或在文本框中输入图像文件的路径。
  6. 如果您希望图像预先载入浏览器的缓存中，以便用户将鼠标指针滑过图像时不发生延迟，请选择“预先载入图像”选项。
  7. 在“替代文本”中，为使用只显示文本的浏览器的访问者输入描述该图像的文本。（可选）
  8. 在“单击时，转到 URL”文本框中，单击“浏览”并选择文件，或者键入在用户单击鼠标经过图像时要打开的文件的路径。

    9. 备注： 如果您不为该图像设置链接，Dreamweaver 将在 HTML 源代码中插入一个空链接 (#)，该链接上将附加鼠标经过图像行为。如果删除该空链接，鼠标经过图像将不再起作用。

  9. 单击“确定”关闭“插入鼠标经过图像”对话框。
  10. 请选择“文件”>“在浏览器中预览”，或按 F12 键。
  11. 在浏览器中，将鼠标指针移过原始图像。

    12. 显示应切换到鼠标经过图像。


使用外部图像编辑器

在 Dreamweaver 中工作时，您可以在外部图像编辑器中打开选定的图像；在保存了编辑完的图像文件并返回到 Dreamweaver 时，可以在“文档”窗口中看到您对图像所做的任何更改。

您可以使用 Macromedia Fireworks 作为外部图像编辑器。Fireworks 3 和更高版本使用“设计备注”跟踪原始 PNG 文件在本地硬盘上的存储位置；在 Fireworks 中打开该图像时，“设计备注”使您能够编辑原始的 PNG 文件。

如果您将任何其他图像编辑应用程序设置为外部图像编辑器并从 Dreamweaver 中启动该编辑器，则该应用程序启动并打开所选的图像。使用图像编辑器修改图像，保存所做的更改，然后在 Dreamweaver 中查看更新的图像。

如果图像文件是从 PNG 文件生成的，则可以手动打开原始文件，进行更改，然后保存更改后的图像。Dreamweaver 在您返回时仍会在“文档”窗口中更新该图像。

如果在返回到 Dreamweaver 窗口后没有看到更新的图像，则选择该图像，然后在属性检查器中单击“刷新”按钮。

相关主题

设置外部图像编辑器参数

启动外部图像编辑器


启动外部图像编辑器

选择“编辑”>“参数选择”>“文件类型/编辑器”或“Dreamweaver”>“参数选择”>“文件类型/编辑器”(Mac OS X) 为您指定的图像文件类型设置外部图像编辑器。有关选择图像编辑器的更多信息，请参见设置外部图像编辑器参数。

若要启动外部图像编辑器，请执行以下操作之一：
  • 双击要编辑的图像。
  • 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要编辑的图像，然后选择“编辑以”>“浏览”并选择一个编辑器。
  • 选择要编辑的图像，然后在属性检查器中单击“编辑”。
  • 在“站点”面板中双击图像文件，启动主图像编辑器。如果您尚未指定图像编辑器，Dreamweaver 将启动该文件类型的默认编辑器。

    • 备注： 当您从“站点”面板打开图像时，Fireworks 集成功能不会起作用；Fireworks 不打开原始 PNG 文件。若要使用 Fireworks 的集成功能，请从“文档”窗口内打开图像。


将行为应用于图像

您可以将任何可用行为应用于图像或图像热点。在您将一个行为应用于热点时，Dreamweaver 将 HTML 源代码插入 area 标签中。以下三种行为是专门应用于图像的：预先载入图像、交换图像和恢复交换图像。

“预先载入图像”将不会立即出现在页面上的图像（例如那些将通过时间轴、行为、层或 JavaScript 换入的图像）载入浏览器缓存中。这样可防止当图像应该出现时由于下载而导致延迟。请参见预先载入图像。

“交换图像”通过更改 img 标签的 SRC 属性将一个图像与另一个图像交换。使用此动作可创建按钮鼠标经过图像和其他图像效果（包括一次交换多个图像）。请参见交换图像。

“恢复交换图像”将最后一组交换的图像恢复为以前的源文件。每次您将“交换图像”动作附加到某个对象时 Dreamweaver 都默认自动添加该动作；您从不需要手动选择它。请参见恢复图像交换。

您还可以使用行为创建更复杂的导航系统，例如导航条或跳转菜单。请参见创建导航条和创建跳转菜单。


参考资料

本节提供有关本章中介绍的面板、对话框和检查器的信息。

设置图像属性

完成“图像占位符”对话框

设置图像占位符属性

设置外部图像编辑器参数


设置图像属性

此属性检查器允许您设置图像的属性。如果您没有看到下面所示的所有图像属性，则单击右下角的扩展箭头

若要设置图像属性，请执行以下操作：
  1. 设置以下任一选项：
    • 使用缩略图下面的文本域设置名称，以便在使用 Dreamweaver 行为（例如“交换图像”）或脚本撰写语言（例如 JavaScript 或 VBScript）时可以引用该图像。

      • “宽”和“高”以像素为单位指定图像的宽度和高度。当您在页中插入图像时，Dreamweaver 自动用图像的原始尺寸更新这些域。您可以用以下单位指定图像大小：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）和诸如 2in+5mm 的单位组合；在 HTML 源代码中，Dreamweaver 将这些值转换为像素。

      如果您设置的“宽”和“高”的值与图像的实际宽度和高度不相符，则该图像在浏览器中可能不会正确显示。（若要恢复为原始值，请单击“宽”和“高”域标签。）

      备注： 您可以更改这些值来缩放该图像实例的显示大小，但这不会缩短下载时间，因为浏览器在缩放图像前下载所有图像数据。若要缩短下载时间并确保所有图像实例以相同大小显示，请使用图像编辑应用程序缩放图像。

      “源文件”指定图像的源文件。单击文件夹图标以浏览到源文件，或者键入路径。

      有关动态图像源文件的信息，请参见将图像动态化。

      “链接”指定图像的超链接。将“指向文件”图标拖到“站点”面板中的某个文件，单击文件夹图标浏览到站点上的某个文档，或手动键入 URL。 有关创建链接的信息，请参见创建链接。

      “对齐”对齐同一行上的图像和文本。请参见对齐图像。

      “替代”指定只显示文本的浏览器或已设置为手动下载图像的浏览器中代替图像显示的替代文本。对于使用语音合成器（用于只显示文本的浏览器）的有视觉障碍的用户，将大声读出该文本。在某些浏览器中，当鼠标指针滑过图像时也会显示该文本。

      “地图名称”和“热点工具”允许您标注和创建客户端图像地图。请参见创建图像地图。

      “垂直边距”和“水平边距”沿图像的边缘添加边距（以像素为单位）。 “垂直边距”沿图像的顶部和底部添加边距。“水平边距”沿图像左侧和右侧添加边距。

      “目标”指定链接的页应当在其中载入的框架或窗口。（当图像没有链接到其他文件时，此选项不可用。）当前框架集中所有框架的名称都显示在“目标”列表中。也可选用下列保留目标名：

      _blank，将链接的文件载入一个未命名的新浏览器窗口中。

      _parent，将链接的文件载入含有该链接的框架的父框架集或父窗口中。如果含有该链接的框架不是嵌套的，则在浏览器全屏窗口中载入链接的文件。

      _self，将链接的文件载入该链接所在的同一框架或窗口中。此目标为默认值，因此通常不需要指定它。

      _top，在整个浏览器窗口中载入所链接的文件，因而会删除所有框架。

      “低品质源”指定在载入主图像之前应该载入的图像。许多设计人员使用主图像的 2 位（黑和白）版本，因为它可以迅速载入并使访问者对他们等待看到的内容有所了解。

      “边框”是以像素为单位的图像边框的宽度。默认为无边框。

      “编辑”启动您在“外部编辑器”参数选择中指定的图像编辑器并打开选定的图像。有关设置外部图像编辑器的信息，请参见使用外部图像编辑器。

      “重设大小”将“宽”和“高”的值重置为图像的原始大小。


完成“图像占位符”对话框

此对话框用于创建图像占位符图形。

若要完成该对话框，请设置所需选项：
  1. 在“名称”文本框中，输入要作为图像占位符的标签文字显示的文本。这是可选域；如果不想显示标签文字，可将此域留空。

    2. 名称必须以字母开头，并且只能包含字母和数字；不允许使用空格和高位 ASCII 字符。

  2. 在“宽度”和“高度”文本框中，以像素为单位键入数字以设置图像大小。（必需）
  3. 对于“颜色”，执行以下操作之一以应用颜色：（可选）
    • 使用颜色选择器选择一种颜色。
    • 键入颜色的十六进制值（例如 #FF0000）。
    • 键入网络安全色名称（例如 red）。
  4. 在“替换文本”中，为使用只显示文本浏览器的访问者输入描述该图像的文本。（可选）
  5. 单击“确定”。

    6. 文档中即会出现图像占位符。

    备注： HTML 代码中将自动插入一个包含空 src 属性的图像标签。


设置图像占位符属性

若要设置图像占位符的属性，请在“文档”窗口中选择图像占位符；然后选择“窗口”>“属性”以显示属性检查器。若要看到所有属性，请单击右下角的扩展箭头。

使用属性检查器为占位符图像设置名称、宽度、高度、图像源文件、替代文本说明、对齐方式和颜色。

在占位符属性检查器中，灰色域和“对齐”文本域被禁用。在您用图像替换占位符时，可以在图像属性检查器中设置这些属性。

若要设置图像属性，请执行以下操作：

设置以下任一选项：

“宽”和“高”以像素为单位设置图像占位符的宽度和高度。

备注： 在值和单位类型之间不要保留空格。例如，若要将宽度或高度设置为两英寸，请输入 2in。

“源文件”指定图像的源文件。对于占位符图像，此文本框为空。单击“浏览”按钮来为占位符图形选择替换图像。

“链接”为图像占位符指定超链接。将“指向文件”图标拖到“站点”面板中的某个文件、单击文件夹图标浏览到站点上的某个文档、或手动键入 URL。

“替代”指定在只显示文本的浏览器或已设置为手动下载图像的浏览器中代替图像显示的替代文本。对于使用语音合成器（用于只显示文本的浏览器）的视力上有障碍的用户，将大声读出该文本。在某些浏览器中，当鼠标指针滑过图像时还将显示该文本。

“创建”令您启动 Fireworks MX 以创建替换图像。如果在您的计算机上还没有安装 Fireworks MX，则“创建”按钮将被禁用。有关在 Fireworks 中创建替换图像的信息，请参见在 Fireworks 中更新 Dreamweaver 图像占位符。

“重设大小”将“宽”和“高”的值重置为图像的原始大小。

“颜色”令您可以为图像占位符指定颜色。


设置外部图像编辑器参数

使用“文件类型/编辑器”参数选择选择用于启动和编辑图形文件的图像编辑器。您可以设置编辑器打开哪些文件类型；并且可以选择多个图像编辑器。例如，可以令 Dreamweaver 在您要编辑 GIF 时启动 Fireworks，而在您要编辑 JPG 或 JPEG 时启动不同的图像编辑器。

若要为现有文件类型设置外部图像编辑器，请执行以下操作：
  1. 通过执行以下操作之一打开“文件类型/编辑器”参数选择对话框：
    • 选择“编辑”>“参数选择”或者“Dreamweaver”>“参数选择”(Mac OS X)，然后从左边的“类别”列表中选择“文件类型/编辑器”。
    • 选择“编辑”>“用外部编辑器编辑”并选择“文件类型/编辑器”。
  2. 在“扩展名”列表中，选择您要为其设置外部编辑器的文件扩展名。
  3. 单击“编辑器”列表上方的加号 (+) 按钮。
  4. 在“选择外部编辑器”对话框中，浏览到您要作为此文件类型的编辑器启动的应用程序。
  5. 在“参数选择”对话框中，如果您希望该编辑器成为此文件类型的主编辑器，则单击“设为主要”。
  6. 如果您想要为此文件类型设置其他编辑器，则重复第 3 步和第 4 步。

    7. 当您选择要编辑此图像类型时，Dreamweaver 自动使用主编辑器。您可以在“文档”窗口中为该图像从上下文菜单中选择列出的其他编辑器。

若要将新文件类型添加到“扩展名”列表中，请执行以下操作：
  1. 在“文件类型/编辑器”参数选择对话框中，单击“扩展名”列表上方的加号 (+) 按钮。

    2. 在“扩展名”列表中随即显示一个文本框。

  2. 键入您要为其启动编辑器的文件类型的文件扩展名。
  3. 若要为该文件类型选择外部编辑器，请单击“编辑器”列表上方的加号 (+) 按钮。
  4. 在出现的对话框中，选择您要用来编辑此图像类型的应用程序。
  5. 如果您希望该编辑器成为此图像类型的主编辑器，则单击“设为主要”。
若要更改现有编辑器参数，请执行以下操作：
  1. 在“文件类型/编辑器”参数选择对话框中，在“扩展名”列表内选择要更改的文件类型以查看现有编辑器。
  2. 在“编辑器”列表中，选择您要对其进行操作的编辑器，然后执行以下操作之一：
    • 单击“编辑器”列表上方的加号 (+) 或删除 (-) 按钮以添加或删除编辑器。
    • 单击“设为主要”按钮，更改默认情况下启动以用于编辑的编辑器。

有关外部编辑器参数选择中其他选项的更多信息，请参见为媒体文件启动外部编辑器。

上一页


Dreamweaver 与其他应用程序的集成

Macromedia Fireworks MX 和 Macromedia Flash MX 是强大的 Web 开发工具，它们用于创建可在 Web 页中查看的图形和 SWF 影片。Macromedia Dreamweaver MX 与这些工具紧密集成，使您能够简化 Web 设计工作流程。

若要建立 Dreamweaver 与 Flash 或 Fireworks 之间的顺利集成，请确保在定义 Dreamweaver 站点时启用“设计备注”。默认情况下，此选项将在站点定义设置中预先选定。有关启用“设计备注”的信息，请参见启用和禁用设计备注。

当您将文件从 Fireworks 或 Flash 直接导入到 Dreamweaver 定义站点时，包含对 PNG 或 Flash 创作文件 (FLA) 的引用的“设计备注”将自动随可在 Web 上发布的文件（GIF、JPEG 或 SWF）导出至该站点。

您可以在 Dreamweaver 文档中方便地插入 Fireworks 图像或表和 Flash 影片。在 Dreamweaver 文档中进行插入后，还可以利用 Dreamweaver 与 Fireworks 或 Flash 之间的集成功能对图像或影片进行更改。

在 Dreamweaver 中工作时，您也可以通过插入图像占位符图形而后对其进行更新来开始图形制作过程。有关图像占位符的信息，请参见插入图像占位符。当您在 Dreamweaver 中插入图像占位符后，就可以启动 Fireworks MX 来创建新的图形。在 Fireworks 中，您可以设计图形，添加热点或行为（或者您需要的任意元素）。然后，可以将图形另存为 PNG 并将其导出为可在 Web 上发布的图形文件（如 GIF 或 JPEG）;如果是切片表，则将其导出为 HTML 和图像。

当您返回到 Dreamweaver 时，替换图像或 Fireworks 表会在文档中更新。

本章包含以下节：

指定 Fireworks 源文件的启动和编辑参数

使用 Dreamweaver 和 Fireworks 工作

编辑 Fireworks 图像或表

创建网站相册

使用 Dreamweaver 和 Flash

在 Dreamweaver 中编辑 Flash 影片

下一页


关于 Fireworks 和 Flash 集成

可自由导入导出的编辑和“设计备注”使 Dreamweaver 能够将操作与 Fireworks 和 Flash 集成。可自由导入导出的编辑确保代码更新在 Dreamweaver 和这些其他应用程序之间正确地传输，以便实现保留变换行为或与其他文件的链接等功能，而“设计备注”则使 Dreamweaver 能够定位导出的图像或影片文件的相应源文档。有关使用 Dreamweaver 中的“设计备注”的信息，请参见将 Fireworks 和 Flash 中的设计备注用于 Dreamweaver。

除了位置信息之外，“设计备注”还包含其他有关所导出的文件的相关信息。例如，当导出一个 Fireworks 表时，Fireworks 将为该表中的每个导出图像文件编写一个“设计备注”。如果导出的文件包含热点或变换，这些热点或变换的 JavaScript 将包含在 Fireworks 所导出的 HTML 文档中。

为了获得最佳效果，在为 Web 发布开发图形和影片时，请将 Fireworks 和 Flash 源以及可在 Web 上发布的文件保存在一个 Dreamweaver 定义站点中。这将确保共享该站点的任何用户都能够在 Dreamweaver 中工作并在编辑 Fireworks 图像或表（或编辑 SWF 影片）时定位源文档。

若要建立与这些应用程序顺利集成的工作流程，关键是要先设置工作环境。有关设置 Dreamweaver 和 Fireworks 工作环境的信息，请参见使用 Dreamweaver 和 Fireworks 工作。有关设置 Dreamweaver 和 Flash 工作环境的信息，请参见使用 Dreamweaver 和 Flash。


使用 Dreamweaver 和 Fireworks 工作

Dreamweaver 和 Fireworks 识别并共享多种相同的文件编辑，其中包括对链接、图像映射、表切片等的更改。这两种应用程序一起提供了在 HTML 页中编辑、优化和放置 Web 图形文件的简化工作流程。

若要设置集成的工作环境，必须完成一些预备任务，例如在 Dreamweaver 中定义本地站点和确保“设计备注”已对该站点启用。如果您没有更改默认设置，“设计备注”将自动启用。

您还必须将 Fireworks 设置为首要的外部图像编辑器，使 Dreamweaver 方便地启动 Fireworks 来进行编辑。有关将 Fireworks 设置为外部编辑器的信息，请参见使用外部图像编辑器。

若要确保启动和编辑的顺利集成，当准备好导出 Fireworks HTML 和图形文件时，请将它们导出至 Dreamweaver 站点文件夹。当您将 GIF 或 JPEG 图形从 Fireworks 导出至 Dreamweaver 站点文件夹时，Fireworks 将在同一文件夹中创建一个名为 _notes 的文件夹。此文件夹包含“设计备注”，即带有 Macromedia 备注文件扩展名 (.mno) 的小型文件。

“设计备注”包含有关 Fireworks 所导出的图形文件的信息。当您在 Dreamweaver 中启动并编辑 Fireworks 图像或表时，Dreamweaver 将使用此信息定位源 PNG。有关指定 Dreamweaver 是否自动启动可用的 PNG 文件的信息，请参见指定 Fireworks 源文件的启动和编辑参数。

当您在 Dreamweaver 文档中选择一个从 Fireworks 导出的图像并且该图像具有相应的 .mno 文件时，属性检查器将显示 Fireworks 图标和该文件的源路径。

如果将 Fireworks 设置为 Dreamweaver 的外部图像编辑器，那么当需要编辑图像时，可以毫不费力地在 Dreamweaver 和 Fireworks 之间切换。在 Dreamweaver 参数选择中，将 Fireworks 设置为 GIF、PNG 和 JPEG 等图形文件类型的首要编辑器。有关设置图像编辑器的信息，请参见设置外部图像编辑器参数。


指定 Fireworks 源文件的启动和编辑参数

Fireworks 启动和编辑参数选择使您能够指定在从其他应用程序（如 Dreamweaver）中启动 Fireworks 文件时如何处理源 PNG 文件。

当启动和优化 Fireworks 图像时，只有在一些特定的情况下，Dreamweaver 才识别 Fireworks 启动和编辑参数选择。具体而言，您所启动并优化的图像必须不属于 Fireworks 表的一部分并且不包含源 PNG 文件的正确“设计备注”路径。在其他所有情况（包括 Fireworks 图像的所有启动和编辑情况）下，Dreamweaver 都会自动启动源 PNG 文件，并且会在无法找到该源文件时提示您定位该文件。

若要指定 Fireworks 的启动和编辑参数，请执行以下操作：
  1. 在 Fireworks 中，选择“编辑”>“参数选择”或“Fireworks”>“参数选择”(Mac OS X)，然后单击“启动和编辑”选项卡 (Windows) 或从弹出式菜单中选择“启动和编辑”(Macintosh)。
  2. 指定在编辑或优化放置在外部应用程序中的 Fireworks 图像时所使用的首选选项：

    3. 始终使用源 PNG自动启动在“设计备注”中定义为所放置图像的源的 Fireworks PNG 文件。源 PNG 及其相应的放置图像都会得到更新。

    永不使用源 PNG自动启动放置的 Fireworks 图像，而不管源 PNG 文件是否存在。只有放置的图像才会得到更新。

    启动时询问使您每次都能够指定是否启动源 PNG 文件。当编辑或优化放置的图像时，Fireworks 将显示一则消息，提示您做出启动和编辑的决定。您也可以通过此消息指定全局的启动和编辑参数选择。


在 Dreamweaver 文档中插入 Fireworks 图像

Fireworks 图形可以通过多种方法放入 Dreamweaver 文档。您可以使用“插入图像”命令将 Fireworks 导出图形直接放入 Dreamweaver 文档，也可以利用 Dreamweaver 图像占位符创建新的 Fireworks 图形。

若要在 Dreamweaver 文档中插入 Fireworks 图像，请执行以下操作：
  1. 在 Dreamweaver 文档中，将插入点放在要让图像出现的地方，然后执行以下操作之一：
    • 选择“插入”>“图像”。
    • 在“插入”条的“常用”类别中，单击“图像”按钮或将其拖到文档中。
  2. 导航至所需的 Fireworks 导出文件，然后单击“确定”(Windows) 或“打开”(Macintosh)。

    3. 备注： 如果该 Fireworks 文件不在当前的 Dreamweaver 站点中，将显示一则消息，询问您是否要将该文件拷贝到根文件夹。单击“是”。


在 Fireworks 中更新 Dreamweaver 图像占位符

您可以在 Dreamweaver 文档中创建一个占位符图像，然后启动 Fireworks 来设计图形图像或 Fireworks 表以替换该占位符图像。有关插入图像占位符的信息，请参见插入图像占位符。

若要通过图像占位符创建新图像，您的系统上必须安装 Dreamweaver MX 和 Fireworks MX。Fireworks 识别下面这些您在 Dreamweaver 中使用图像占位符时可能已设置的图像占位符设置：图像大小，它与 Fireworks 画布尺寸相关；图像 ID，Fireworks 将它用作您创建的源文件和导出文件的默认文档名称；文本对齐以及 Fireworks 所识别的行为（如交换图像、弹出式菜单、导航条和设置文本）。Fireworks 还识别您在 Dreamweaver 中工作时附加到图像占位符的链接。

备注： 虽然在 Fireworks 中无法看见已添加到图像占位符的链接，但这些链接会保留下来。如果您在 Fireworks MX 中绘制一个热点并添加一个链接，将不会删除您已在 Dreamweaver 中添加到图像占位符的链接；但是，如果您在 Fireworks 中的新图像上绘制出一个切片，则将在您替换图像占位符时删除 Dreamweaver 文档中的链接。

由于 Fireworks 不识别以下图像占位符设置，它们会在图像占位符属性检查器中被禁用：图像对齐方式、颜色、Vspace 与 Hspace 以及映射。

在 Fireworks MX 中，创建新的图像，然后单击“完成”。Fireworks 提示您将该文件另存为 PNG 文件（源文档），并且以可在 Web 上发布的格式（如 GIF、JPEG）（如果是切片图像，则以 HTML 和图像的形式）导出该文件。该新图像或 Fireworks 表会自动替换 Dreamweaver 文档中的图像占位符。

若要在 Fireworks 中编辑 Dreamweaver 占位符图像，请执行以下操作：
  1. 确保您已经将 Fireworks 设置为 .png 文件的图像编辑器。有关信息，请参见设置外部图像编辑器参数。
  2. 在“文档”窗口中，单击图像占位符以将其选定。
  3. 执行以下操作之一以启动 Fireworks 来进行编辑：
    • 在属性检查器中单击“创建”。
    • 按 Ctrl (Windows) 或 Command (Macintosh)，然后双击该图像占位符。
    • 右击该图像占位符，然后选择“在 Fireworks 中创建图像”。

      • Fireworks 以“从 Dreamweaver 编辑”模式启动。
      这是所描述的功能的图片。

  4. 使用 Fireworks 选项设计图像。
  5. 完成后，单击“完成”。

    6. 出现“另存为”对话框。Fireworks 提示您保存该 PNG 文件。

  6. 在“保存位置”域中，选择您定义为 Dreamweaver 本地站点文件夹的文件夹。

    7. 如果在 Dreamweaver 文档中插入图像占位符时已经将其命名，Fireworks 将用该名称填充“文件名”域。如果需要，可以更改该名称。

  7. 单击“保存”以保存该 PNG 文件。

    8. 出现“导出”对话框。使用此对话框可将图像导出为 GIF。

  8. 在该对话框中，为“保存位置”选择 Dreamweaver 本地站点文件夹。
  9. “名称”文本域会自动更新为用于 PNG 文件的同一名称。如果需要，输入相应文本以更改该名称。
  10. 对于“保存类型”，请选择要导出的文件的类型，例如“仅限图像”或“HTML 和图像”。
  11. 单击“保存”以保存导出的文件。

    12. 该文件被保存，此时焦点返回到 Dreamweaver。在 Dreamweaver 文档中，导出的文件或 Fireworks 表替换了图像占位符。


编辑 Fireworks 图像或表

您可以启动 Fireworks 来编辑在 Dreamweaver 文档中插入的图像。当启动并编辑图像或属于 Fireworks 表的一部分的图像切片时，Dreamweaver 会启动 Fireworks 和从其中导出该图像或表的 PNG 文件。

当该图像属于 Fireworks 表的一部分时，只要 HTML 代码中存在 <!--fw table--> 注释，就可以启动整个 Fireworks 表进行编辑。如果源 PNG 是使用 Dreamweaver 样式 HTML 和图像设置从 Fireworks 导出至 Dreamweaver 站点的，该 Fireworks 表注释将自动插入到 HTML 代码中。

若要启动和编辑放置在 Dreamweaver 中的 Fireworks 图像，请执行以下操作：
  1. 在 Dreamweaver 中，选择“窗口”>“属性”以打开属性检查器（如果它尚未打开）。
  2. 单击图像或图像切片以将其选定。

    3. 属性检查器根据选定项将选定内容识别为 Fireworks 图像或表，并显示 PNG 源文件的名称。

  3. 若要启动 Fireworks 来进行编辑，请执行以下操作之一：
    • 在属性检查器中单击“编辑”。
    • 按住 Ctrl (Windows) 或 Command (Macintosh) 并双击选定图像。
    • 右击 (Windows) 或按住 Ctrl 键并单击 (Macintosh) 选定的图像，然后从上下文菜单中选择“用 Fireworks 编辑”。

      • Fireworks 启动，并打开关联的 PNG 进行编辑。

      备注： 如果 Fireworks 无法定位源文件，则将提示您定位该 PNG 源文件。当处理 Fireworks 源文件时，更改会保存到源文件和导出的文件中；否则，只有导出的文件会得到更新。

  4. 在 Fireworks 中编辑源 PNG。
  5. 完成编辑后，单击“完成”。

    6. Fireworks 将更改保存在 PNG 文件中，导出已更新的图像（或 HTML 和图像），然后将焦点返回到 Dreamweaver。在 Dreamweaver 中，出现已更新的图像或表。


在 Dreamweaver 中打开 Fireworks 弹出式菜单

Fireworks 支持基于图像的弹出式菜单和基于 HTML 的弹出式菜单。Dreamweaver 仅支持基于 HTML 的弹出式菜单。在 Dreamweaver 中，您可以打开 Fireworks 弹出式菜单并对所有菜单项属性（除了基于图像的弹出式菜单的背景图像外）进行编辑。

Dreamweaver 中的“显示弹出式菜单”行为使您能够编辑或更新基于 Fireworks HTML 的弹出式菜单的内容。您可以添加、删除或更改菜单项，重新排列菜单项，也可以设置菜单在页中的位置。有关在 Dreamweaver 中设置或修改弹出式菜单选项的信息，请参见显示弹出式菜单。

如果要编辑的弹出式菜单是基于图像的弹出式菜单，而您要保留基于图像的单元格背景，则应在 Fireworks 中（而不是在 Dreamweaver 中）编辑弹出式菜单。

若要编辑基于图像的弹出式菜单中的背景图像，请选择要更新的图像，然后单击“编辑”。有关编辑 Fireworks 图像的信息，请参见编辑 Fireworks 图像或表。

若要打开 Fireworks 弹出式菜单，请执行以下操作：
  1. 在 Dreamweaver 文档中，选择将触发该弹出式菜单的热点或图像。
  2. 打开“行为”面板 (Shift+F3)（如果它尚未打开），然后在“动作”列表中双击“显示弹出式菜单”。

    3. 出现“显示弹出式菜单”对话框。

  3. 对该弹出式菜单做出所需的更改。
  4. 修改完该弹出式菜单后，单击“确定”。


启动 Fireworks 来优化图像

您可以从 Dreamweaver 中启动 Fireworks 来对放置的 Fireworks 图像和动画进行快速的导出更改，例如调整图像大小或更改文件类型。Fireworks 允许您更改导出图像的优化设置、动画设置以及大小和区域。

若要更改放置在 Dreamweaver 中的 Fireworks 图像的优化设置，请执行以下操作：
  1. 在 Dreamweaver 中，选择所需的图像并选择“命令”>“在 Fireworks 中优化图像”。
  2. 在出现提示时，指定是否启动放置图像的源 Fireworks 文件。
  3. 在 Fireworks 中，在“优化”对话框中做出所需的编辑：
    • 若要编辑优化设置，请单击“选项”选项卡。有关更多信息，请参见《使用 Fireworks》。
    • 若要编辑导出的图像的大小和区域，请单击“文件”选项卡。
  4. 编辑完图像后，单击“更新”。

    5. 当单击“更新”后，将使用新的优化设置导出图像，更新放置在 Dreamweaver 中的 GIF 或 JPEG，并保存 PNG 源文件（如果已选定源文件）。

    如果您更改了图像的格式，Dreamweaver 链接检查器会提示您更新对该图像的引用。例如，如果将名为 my_image 的图像的格式从 GIF 更改为 JPEG，在出现此提示时单击“确定”即会将站点中对 my_image.gif 的所有引用更改为 my_image.jpg。


在 Dreamweaver 文档中插入 Fireworks HTML 代码

Fireworks 中的“导出”命令使您能够将优化的图像和 HTML 文件导出并保存至所需的 Dreamweaver 站点文件夹中的某一位置。然后可以在 Dreamweaver 中插入该文件。

有关将 Fireworks 文件导出为 HTML 的信息，请参见《使用 Fireworks》。

Dreamweaver 允许您将 Fireworks 生成的 HTML 代码随关联的图像、切片和 JavaScript 一起插入到文档中。这一插入功能使您可以方便地在 Fireworks 中创建设计元素，然后将这些元素纳入现有的 Dreamweaver 文档。

若要将 Fireworks HTML 插入到 Dreamweaver 文档中，请执行以下操作：
  1. 在 Dreamweaver 中，将插入点放置在文档中要让 Fireworks HTML 代码开始的地方。
  2. 执行以下操作之一：
    • 选择“插入”>“交互式图像”>“Fireworks HTML”。
    • 在“插入”条的“常用”类别中，单击“插入 Fireworks HTML”按钮。
  3. 在出现的对话框中单击“浏览”以选择所需的 Fireworks HTML 文件。
  4. 选择“插入后删除文件”选项，以便在该操作完成后将原始 Fireworks HTML 文件移至“回收站”(Windows) 或“垃圾箱”(Macintosh)。

    5. 如果在插入 Fireworks HTML 文件后不再需要该文件，则应使用此选项。此选项不影响与该 HTML 文件关联的源 PNG 文件。

    备注： 如果该 HTML 文件位于网络驱动器上，则会将其永久删除，而不是移至“回收站”或“垃圾箱”。

  5. 单击“确定”，将 HTML 代码随其关联的图像、切片和 JavaScript 一起插入到 Dreamweaver 文档中。


将 Fireworks HTML 粘贴到 Dreamweaver 中

若要在 Dreamweaver 中放置 Fireworks 生成的图像或表，一种较快的方法是拷贝 Fireworks HTML 代码并直接将其粘贴到 Dreamweaver 文档中。

若要拷贝 Fireworks HTML 并将其粘贴到 Dreamweaver 中，请执行以下操作：
  1. 在 Fireworks 中，选择“编辑”>“拷贝 HTML 代码”。
  2. 按照向导的指导完成导出 HTML 和图像的设置。当出现提示时，将您的 Dreamweaver 站点文件夹指定为导出图像的目标。

    3. 向导会将图像导出至指定的目标并将 HTML 代码拷贝到剪贴板上。

  3. 在 Dreamweaver 中，将插入点放置在文档中要粘贴 HTML 代码的地方，然后选择“编辑”>“粘贴”。

    4. 与导出的 Fireworks 文件关联的所有 HTML 和 JavaScript 代码都被拷贝到 Dreamweaver 文档中，而指向图像的所有链接都得到更新。

若要将 Fireworks HTML 导出并粘贴到 Dreamweaver 中，请执行以下操作：
  1. 在 Fireworks 中，选择“文件”>“导出”。
  2. 在“导出”对话框中，将您的 Dreamweaver 站点文件夹指定为导出图像的目标。
  3. 在“另存为”弹出式菜单中选择“HTML 和图像”。
  4. 在“HTML”弹出式菜单中，选择“拷贝到剪贴板”，然后单击“保存”。
  5. 在 Dreamweaver 中，将插入点放置在文档中要粘贴导出的 HTML 代码的地方，然后选择“编辑”>“粘贴”。

    6. 与导出的 Fireworks 文件关联的所有 HTML 和 JavaScript 代码都被拷贝到 Dreamweaver 文档中，而指向图像的所有链接都得到更新。


更新放置在 Dreamweaver 中的 Fireworks HTML

在 Fireworks 中，“文件”>“更新 HTML”命令提供了启动和编辑功能的一种替代方法，用以更新放置在 Dreamweaver 中的 Fireworks 文件。利用“更新 HTML”，您可以在 Fireworks 中编辑源 PNG 图像，然后自动更新任何放置在 Dreamweaver 文档中的导出 HTML 代码和图像文件。即使是在 Dreamweaver 未运行时，此命令仍允许您更新 Dreamweaver 文件。

若要更新放置在 Dreamweaver 中的 Fireworks HTML，请执行以下操作：
  1. 在 Fireworks 中，打开源 PNG 并对其做出所需的编辑。
  2. 选择“文件”>“保存”
  3. 在 Fireworks 中，选择“文件”>“更新 HTML”。
  4. 导航至包含要更新的 HTML 的 Dreamweaver 文件，然后单击“打开”。
  5. 导航至要将更新后的图像文件放置到的文件夹目标，然后单击“选择”(Windows) 或“选取”(Macintosh)。

    6. Fireworks 更新 Dreamweaver 文档中的 HTML 和 JavaScript 代码。Fireworks 还会导出与 HTML 关联的已更新图像并将这些图像放置到指定的目标文件夹。

    如果 Fireworks 无法找到匹配的 HTML 代码来更新，它将为您提供一个选项来将新的 HTML 代码插入到 Dreamweaver 文档中。Fireworks 将新代码的 JavaScript 部分放置在文档的开头，将 HTML 表或指向该图像的链接放置在末尾。


创建网站相册

Dreamweaver 中的“创建网站相册”命令使您能够自动生成一个 Web 站点，该站点将显示给定文件夹中图像的“相册”。此命令使用 JavaScript 来调用 Fireworks，后者为该文件夹中的每个图像创建一个缩略图和一个较大尺寸的图像。然后，Dreamweaver 创建一个 Web 页，它包含所有缩略图以及指向较大图像的链接。若要使用“创建网站相册”，您的系统上必须安装 Dreamweaver 和 Fireworks 4（或更高版本）。

在开始之前，将相册的所有图像放置在一个文件夹中。（该文件夹不必位于站点中。）此外，请确保图像文件名以“创建网站相册”命令可识别的扩展名（.gif、.jpg、.jpeg、.png、.psd、.tif 或 .tiff）结尾。带有无法识别的文件扩展名的图像不会包含在相册中。

若要创建网站相册，请执行以下操作：
  1. 在 Dreamweaver 中，选择“命令”>“创建网站相册”。
  2. 在“相册标题”文本域中输入一个标题。该标题将显示在包含缩略图的页面的顶部的灰色矩形中。

    3. 如果需要，可以在“副标信息”和“其他信息”文本域中输入最多两行附加文本，该文本将直接在标题下显示。

  3. 单击“源图像文件夹”文本域旁的“浏览”按钮，选择包含源图像的文件夹。然后单击“目标文件夹”文本域旁的“浏览”按钮，选择（或创建）一个目标文件夹，用以放置所有导出的图像和 HTML 文件。

    4. 目标文件夹不应该已包含相册óó如果已包含相册，并且如果任何新图像与先前使用的图像同名，则可能会覆盖现有的缩略图和图像文件。

  4. 指定缩略图图像的显示选项：
    • 从“缩略图大小”弹出式菜单中选择缩略图图像的大小。图像将按比例缩放，以创建适合具有指定像素尺寸的方框的缩略图。
    • 若要在相应的缩略图下显示每个原始图像的文件名，请选择“显示文件名”。
    • 输入显示缩略图的表的列数。
  5. 从“缩略图格式”弹出式菜单中选择缩略图图像的格式：

    6. GIF WebSnap 128 创建 GIF 缩略图，这些缩略图使用包含多达 128 色的 Web 适应性调色板。

    GIF WebSnap 256 创建 GIF 缩略图，这些缩略图使用包含多达 256 色的 Web 适应性调色板。

    JPEG -品质较高创建品质较高且文件大小较大的 JPEG 缩略图。

    JPEG - 文件较小创建品质较低且文件大小较小的 JPEG 缩略图。

  6. 从“相片格式”弹出式菜单中选择大尺寸图像的格式。对于每个原始图像，将创建一个具有指定格式的大尺寸图像。您为大尺寸图像指定的格式可以不同于为缩略图指定的格式。

    7. 备注： 由于 GIF 和 JPEG 之外的原始文件格式可能无法在所有浏览器中正确显示，所以“创建网站相册”命令不允许您将原始图像文件用作大尺寸图像。请注意，如果原始图像是 JPEG 文件，则所生成的大尺寸图像的文件大小可能比原始文件大（或者其品质比原始文件低）。

  7. 选择大尺寸图像的缩放百分比。

    8. 如果将“缩放”设置为 100%，将创建与原始图像等大的大尺寸图像。请注意，缩放百分比将应用于所有图像；如果原始图像的大小不一样，那么按同一百分比缩放就可能不会产生所需的效果。

  8. 选择“为每张相片建立导览页面”，为每个源图像创建一个 Web 页，该 Web 页包含标为“后退”、“主页”、“前进”的导航链接。

    9. 如果选择此选项，缩略图会链接到导航页。如果不选择此选项，缩略图链接将直接链接到大尺寸图像。

  9. 单击“确定”以创建网站相册的 HTML 和图像文件。

    10. Fireworks 启动（如果它尚未运行）并创建缩略图和大尺寸图像。如果所包含的图像文件数目较大，这可能会需要几分钟的时间。当处理完成后，Dreamweaver 将再次处于活动状态并创建包含缩略图的页。

  10. 当出现声明“相册已经建立”的对话框时，单击“确定”。相册页出现之前可能需要等待几秒钟。各缩略图根据文件名按字母顺序显示。
    这是所描述的功能的图片。

备注： 如果在处理开始后单击 Dreamweaver 对话框中的“取消”按钮，创建相册的进程并不会停止；这只会防止 Dreamweaver 显示主相册页。


使用 Dreamweaver 和 Flash

您可以在 Dreamweaver 文档中方便地插入 Flash 影片（SWF 文件）。然后可以使用属性检查器设置 SWF 文件在 Web 页中的播放和显示选项。有关在 Dreamweaver 中插入 Flash 影片的信息，请参见插入 Flash 影片。

Dreamweaver 中的链接检查器使您可以方便地编辑插入到 Dreamweaver 文档中的文件（包括 Flash 影片）中的链接。您可以更新 SWF 影片中的链接，然后更新 Flash 创作文档中的更改。有关信息，请参见更新 SWF 文件中的链接。

如果已安装 Macromedia Flash MX 和 Dreamweaver MX，也可以更新已放置在 Dreamweaver 文档中的影片。当您的计算机上已安装这两种应用程序，并且已经在 Dreamweaver 文档中选择 SWF 影片时，属性检查器将显示活动的“编辑”按钮。如果没有安装 Flash MX，“编辑”按钮会被禁用。

当单击“编辑”时，Dreamweaver 会启动 Flash，而 Flash 将尝试定位选定的 SWF 文件的 Flash 创作文件 (.FLA)。当您将该 SWF 文件导出至 Dreamweaver 站点时，有关该初始源文件的信息会自动存储在该 SWF 文件的“设计备注”中（如果已经为该 Dreamweaver 站点启用“设计备注”）。如果 Flash 无法定位 Flash 创作文件，则会提示您定位该文件。您不能直接更新 SWF 文件；如果要更新 SWF 文件，请对源文件做出更改，然后将其导出为 SWF 电影文件。

当成功启动要编辑的源文档后，您可以在 Flash 中工作，对影片做出更改。完成更改后，单击“完成”。Flash 更新 Flash 创作文档，重新导出该影片文件并关闭，然后将焦点返回到 Dreamweaver 文档。您可以通过单击属性检查器中的“播放”来查看文档中已更新的 SWF，也可以通过按 F12 键在浏览器窗口中对该页进行预览。

相关主题

在 Dreamweaver 中编辑 Flash 影片

更新 SWF 文件中的链接


在 Dreamweaver 中编辑 Flash 影片

您不能直接编辑 SWF 文件，如果要对导出的 SWF 做出更改，请选择 Dreamweaver 文档中的 Flash 影片占位符，然后在属性检查器中单击“编辑”。“编辑”会启动 Flash，而且如果源文档 (FLA) 的路径可用，还会启动 FLA 文件。当编辑完成后，Flash 会保存 FLA 源文档中的更改并重新导出 SWF 影片文件。

若要启动和编辑从 Dreamweaver 中插入的 Flash 影片，请执行以下操作：
  1. 在 Dreamweaver 中，选择“窗口”>“属性”以打开属性检查器（如果它尚未打开）。
  2. 在 Dreamweaver 文档中，执行以下操作之一：
    • 单击 Flash 影片占位符以将其选定；然后在属性检查器中单击“编辑”。
      这是所描述的功能的图片。
    • 按住 Ctrl (Windows) 或 Command (Macintosh) 并双击要编辑的影片的影片占位符。
    • 右击 (Windows) 或按住 Control 并单击 (Macintosh) 所需的影片，然后从上下文菜单中选择“用 Flash 编辑”。

      • Dreamweaver 启动 Flash，然后打开 FLA 文件让您进行编辑或者提示您打开该文件（如果它无法找到该 FLA 文件）。

      备注： 如果 FLA 文件或 SWF 文件被锁定，Dreamweaver 会提示您取出该文件、取消请求或查看该文件。

  3. 在 Flash 中编辑该影片。“文档”窗口指示您正在修改来自 Dreamweaver 的影片。
    这是所描述的功能的图片。
  4. 完成编辑后，单击“完成”。

    5. 如果单击“完成”，则会将更改保存到源 FLA 文件并更新 SWF 文件。


更新 SWF 文件中的链接

您可以在 Dreamweaver“站点地图”视图中更新 SWF 文件中的链接。有关“站点地图”视图的信息，请参见使用站点地图。在创建站点地图之前，必须先设置站点的主页。在“站点地图”视图中，为了更新 SWF 文件中的链接，需要显示关联的文件。默认情况下，站点地图不显示关联文件，有关显示关联文件的信息，请参见显示和隐藏站点地图文件。

选择要更新的链接，然后根据要执行的操作（更改单个链接或更改整个站点内的链接）选择一个更改链接选项。

当执行启动和编辑时，SWF 文件中已经由 Dreamweaver 更新的所有链接都会转达给 FLA 源文档。Dreamweaver 会自动在“设计备注”中记录对 SWF 文件的所有链接更改，当 Flash 将这些更改传递到 FLA 文件时，它将从“设计备注”中删除这些更改。

若要更新 SWF 文件中的 URL 链接，请执行以下操作：
  1. 设置站点的主页（如果尚未设置主页）。为了生成站点地图，需要设置主页。
  2. 打开“站点地图”视图。
  3. 若要显示关联的文件，请选择“查看”>“显示相关文件”(Windows) 或“站点”>“显示站点地图”>“显示相关文件”(Macintosh)。

    4. 该链接出现在 SWF 文件之下。

  4. 通过执行以下操作之一更改链接：
    • 若要更改选定的 SWF 中的链接，请右击该链接，选择“更改链接”，然后在出现的对话框中的 URL 域中键入新的 URL 路径。
    • 若要更新该链接的所有实例，请选择“站点”>“更改站点内所有指定链接”，然后在出现的对话框上：在“将所有链接更改为”域中浏览到（或键入）所更改的链接的路径，并且在“新链接”域中浏览到（或键入）新的 URL 路径。
  5. 单击“确定”。
上一页


插入媒体

Macromedia Dreamweaver 使您可以迅速、方便地向您的 Web 站点添加声音和影片。您可以并入和编辑多媒体文件和对象，例如 Macromedia Flash 和 Shockwave 影片、Java applets、QuickTime、Active X 和音频文件。您可以将“设计备注”附加到这些对象上，以便于您和您的小组成员之间的交流。您还可以在 Dreamweaver 自身内插入 Flash 按钮和文本对象。

本章包含以下几节：

  • 插入和播放媒体对象
  • 为媒体文件启动外部编辑器
  • 将“设计备注”与媒体对象一起使用
  • 关于 Flash 内容
  • 插入 Flash 按钮对象
  • 插入 Flash 文本对象
  • 插入 Flash 影片
  • 插入 Shockwave 影片
  • 添加视频
  • 向页面添加声音
  • 插入 Netscape Navigator 插件内容
  • 插入 ActiveX 控件
  • 插入 Java applets
  • 使用行为控制媒体
  • 参考资料
下一页


插入和播放媒体对象

您可以在 Dreamweaver 文档中插入 Flash 影片或对象、QuickTime 或 Shockwave 影片、Java applets、ActiveX 控件或者其他音频或视频对象。

您使用插入栏或“插入”菜单的“媒体”类别选择您要在文档中插入的对象类型。Flash 影片和对象、Shockwave、Java applets 和 ActiveX 具有定义的按钮。使用 Netscape Navigator 插件按钮插入其他媒体文件。有关更多信息，请参见插入 Netscape Navigator 插件内容。

若要在页面中插入媒体对象，请执行以下操作：
  1. 在文档窗口中，将插入点放置在您要插入对象的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击您要插入的对象类型的按钮，或将其拖入文档窗口中。
      这是所描述的功能的图片。
    • 从“插入”>“媒体”或“插入”>“交互式图像”子菜单中选择适当的对象。

在大多数情况下，将显示一个对话框，您可从中选择源文件并为媒体对象指定某些参数。

提示： 若要不显示此类对话框，请选择“编辑”>“参数选择”>“常规”或“Dreamweaver”>“参数选择”>“常规”(Mac OS X)，然后取消对“插入对象时显示对话框”选项的选择。若要忽略为显示对话框设置的任何参数选择，请在插入对象的同时按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。（例如，若要在不指定文件的情况下为 Shockwave 影片插入占位符，请在按住 Ctrl 键或 Option 键的同时单击 Shockwave 按钮。）

Dreamweaver 自动插入必需的 HTML 源代码以使该对象或占位符出现在页面上。若要指定源文件，请设置尺寸以及其他参数和属性，为每一对象使用属性检查器。


为媒体文件启动外部编辑器

您可以在“站点”面板中双击大多数文件以直接编辑它们。如果是 HTML 文件，则它将在 Dreamweaver 中打开。如果是其他类型的文件，例如图像文件，则它将在适当的外部编辑器（例如 Macromedia Fireworks）中打开。

Dreamweaver 无法直接处理的每一文件类型均可与您的系统上提供的一个或多个外部编辑器相关联。您在“站点”面板上双击文件时启动的编辑器称作主编辑器。您可以在“文件类型/编辑器”参数选择中设置哪一编辑器与一种文件类型相关联。

如果有多个编辑器与该文件类型相关联，则可以为特定文件启动第二个编辑器。在“站点”面板上右击文件名 (Windows) 或在按住 Control 键的同时单击文件名 (Macintosh)，然后从上下文菜单的“打开方式”子菜单中选择一个编辑器。

若要明确指定对于给定的文件类型应启动哪些外部编辑器，请选择“编辑”>“参数选择”，并从“类别”列表中选择“文件类型/编辑器”。文件扩展名（例如 .gif、.wav 和 .mpg）在左侧的“扩展名”下列出。选定扩展名的关联编辑器在右侧的“编辑器”下列出。

您还可以浏览以查找用来编辑您的文件的外部编辑器。在文档窗口的设计视图中右击文件 (Windows) 或在按住 Control 键的同时单击文件 (Macintosh)，然后选择“编辑以”>“浏览”，或者选择该文件后选择“编辑”>“以外部编辑器编辑”。

若要将文件类型添加到“文件类型/编辑器”参数选择的扩展名列表中，请执行以下操作：
  1. 单击“扩展名”列表上方的加号 (+) 按钮。
  2. 输入文件类型扩展名（包括扩展名起始处的句点），或者输入用空格分隔的几个相关扩展名。

    3. 例如，可以输入 .css，png .jpg。

若要为给定文件类型添加编辑器，请执行以下操作：
  1. 在“扩展名”列表中选择文件类型扩展名。
  2. 单击“编辑器”列表上方的加号 (+) 按钮。
  3. 在显示的对话框中，选择要添加到“编辑器”列表的应用程序。

    4. 例如，选择 Excel 的应用程序图标以将该应用程序添加到您的“编辑器”列表中。

若要从该列表中删除文件类型，请执行以下操作：
  1. 在“扩展名”列表中选择文件类型。

    2. 备注： 在删除一个文件类型后您不能撤消该删除操作，所以删除文件类型时一定要慎重。

  2. 单击“扩展名”列表上方的减号 (-) 按钮。
若要令一个编辑器成为某一文件类型的主编辑器，请执行以下操作：
  1. 选择该文件类型。
  2. 选择编辑器（如果该编辑器不在列表中，则添加它）。
  3. 单击“设为主要”。
若要解除一个编辑器与某一文件类型的关联，请执行以下操作：
  1. 在“扩展名”列表中选择文件类型。
  2. 在“编辑器”列表中选择编辑器。
  3. 单击“编辑器”列表上方的减号 (-) 按钮。


将“设计备注”与媒体对象一起使用

与 Dreamweaver 中的其他对象一样，您可以将“设计备注”添加到媒体对象中。有关使用“设计备注”的更多信息，请参见使用设计备注。

若要将“设计备注”添加到某一媒体对象中，请执行以下操作：
  1. 在文档窗口中右击对象 (Windows) 或在按住 Control 键的同时单击对象 (Macintosh)。

    2. 备注： 您必须在将“设计备注”添加到任何对象前定义您的站点（请参见启用和禁用设计备注）。

  2. 从上下文菜单中选择“设计备注”。
  3. 在“设计备注”中输入您所需的信息。

    4. 提示： 您还可以从“站点”面板将“设计备注”添加到媒体对象，方法是：选择该文件，显示上下文菜单，然后从上下文菜单中选择“设计备注”。


关于 Flash 内容

Macromedia Flash 技术是实现和传递基于矢量的图形和动画的首要解决方案。Flash 播放器在 PC 上既可作为 Netscape Navigator 上的插件，也可作为 Microsoft Internet Explorer 上的 ActiveX 控件，此外它还集成到了 Netscape Navigator、Microsoft Internet Explorer 和 America Online 的最新版本中。

无论您是否具有 Flash，Dreamweaver 都附带了可以使用的 Flash 对象。您可以使用这些对象创建可以插入到 Dreamweaver 文档中的 Flash 按钮和 Flash 文本。如果您具有 Flash，请参见使用 Dreamweaver 和 Flash，了解如何以集成的方式使用这些应用程序的信息。

在使用 Dreamweaver 提供的 Flash 命令前，您应该对三种不同的 Flash 文件类型有所了解：

Flash 文件 (.fla) 是所有项目的源文件，在 Flash 程序中创建。此类型的文件只能在 Flash 中打开（而不是在 Dreamweaver 或浏览器中打开）。您可以在 Flash 中打开 Flash 文件，然后将它导出为 SWF 或 SWT 文件以在浏览器中使用。

Flash 影片文件 (.swf) 是 Flash (.fla) 文件的压缩版本，已进行了优化以便于在 Web 上查看。此文件可以在浏览器中播放并且可以在 Dreamweaver 中进行预览，但不能在 Flash 中编辑此文件。这是您使用 Flash 按钮和文本对象时创建的文件类型。有关更多信息，请参见插入 Flash 按钮对象、插入 Flash 文本对象和插入 Flash 影片。

Flash 模板 (.swt) 文件使您可以修改和替换 Flash 影片文件中的信息。这些文件用于 Flash 按钮对象中，使您能够用自己的文本或链接修改模板，以便创建要插入在您的文档中的自定义 SWF。在 Dreamweaver 中，可以在 Dreamweaver/Configuration/Flash Objects/Flash Buttons 和 Flash Text 文件夹中找到这些模板文件。

您可以从 Macromedia Exchange for Dreamweaver Web 站点下载新的按钮模板并将它们放置在 Flash Button 文件夹中。有关创建新按钮模板的更多信息，请参见 Macromedia Web 站点。


插入 Flash 按钮对象

Flash 按钮对象是基于 Flash 模板的可更新按钮。您可以自定义 Flash 按钮对象，并添加文本、背景颜色以及指向其他文件的链接。在使用设计视图或代码视图时可以插入 Flash 按钮。

备注： 在插入 Flash 按钮或文本对象前，必须保存您的文档。

您使用“插入 Flash 按钮”对话框从一组设计好的 Flash 按钮中进行选择。您可以在“示例”域中查看按钮的示例。单击该示例以查看按钮在浏览器中是如何行使功能的。在定义 Flash 按钮时（例如，更改文本或字体选项），“示例”域不会自动更新以反映所做的更改。当关闭对话框并在“设计”视图中查看按钮时，将会体现出这些更改。

若要插入 Flash 按钮对象，请执行以下操作：
  1. 在文档窗口中，将插入点放置在您要插入 Flash 按钮的地方。
  2. 若要打开“插入 Flash 对象”对话框，请执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“Flash 按钮”图标。
      这是所描述的功能的图片。
    • 在插入栏中，选择“媒体”，然后将“Flash 按钮”图标拖入文档窗口中，如果您正在处理代码，也可以将图标拖入代码视图窗口中。
    • 选择“插入”>“交互式图像”>“Flash 按钮”。

      • “插入 Flash 按钮”对话框随即显示。
      这是所描述的功能的图片。

  3. 从“样式”列表中选择您所需的按钮样式。
  4. 在“按钮文本”域中（可选），键入您要显示的文本。

    5. 只有在选定按钮定义了 {Button Text} 参数后，此域才接受更改。这显示在“示例”域中。在您预览文件时，您键入的文本代替 {Button Text}。

  5. 在“字体”弹出式菜单中，选择您要使用的字体。

    6. 如果您的系统上没有提供按钮的默认字体，则从弹出式菜单中选择另一种字体。您将不会在“示例”域中看到您选择的字体，但您可以单击“应用”以将按钮插入到页面中，从而查看文本的大致情形。

  6. 在“大小”域中，输入字体大小的数字值。
  7. 在“链接”域中（可选），输入该按钮的文档相对或绝对链接。
  8. 在“目标”域中（可选），指定链接的文档将在其中打开的位置。您可以在弹出式菜单中选择框架或窗口选项。只有在框架页中编辑 Flash 对象时，才列出框架名称。
  9. 在“背景颜色”域中（可选），设置 Flash 影片的背景颜色。使用颜色选择器或键入 Web 十六进制值（例如 #FFFFFF）。
  10. 在“另存为”域中，输入用来保存此新 SWF 文件的文件名。

    11. 您可使用默认文件名（例如 button1.swf）或键入新文件名。如果该文件包含文档相对链接，则您必须将该文件保存到与当前 HTML 文档相同的目录中，以保持文档相对链接的有效性。

  11. 单击“获取更多样式”以转到 Macromedia Exchange 站点并下载更多按钮样式。

    12. 有关更多信息，请参见添加功能扩展 Dreamweaver。

  12. 单击“应用”或“确定”以将 Flash 按钮插入到文档窗口中。

提示： 选择“应用”可以在设计视图中看到更改，同时令对话框仍处于打开状态；这样您就可以继续对按钮进行更改。


修改 Flash 按钮对象

您可以修改 Flash 按钮对象的属性和内容。

若要修改 Flash 按钮对象，请执行以下操作：
  1. 在文档窗口中，单击 Flash 按钮对象以选择它。
  2. 如果属性检查器尚未打开，则打开属性检查器。

    3. 属性检查器显示 Flash 按钮属性。您可以使用属性检查器修改按钮的 HTML 属性，例如宽度、高度和背景颜色。

  3. 若要对内容进行更改，请使用以下方法之一显示“插入 Flash 按钮”对话框：
    • 双击 Flash 按钮对象。
    • 在属性检查器中单击“编辑”。
    • 右击 (Windows) 或在按住 Control 键的同时单击 (Macintosh)，然后从上下文菜单中选择“编辑”。
  4. 在“插入 Flash 按钮”对话框中，在插入 Flash 按钮对象中介绍的各域内进行编辑。

    5. 在设计视图中，通过使用调整大小手柄可以很容易地调整对象的大小。您可以通过在属性检查器中选择“重设大小”，将该对象返回到其初始大小（请参见调整图像大小）。


在文档中播放 Flash 按钮对象

您可以在 Dreamweaver 文档窗口中预览 Flash 按钮。

若要在文档窗口中查看 Flash 按钮对象播放，请执行以下操作：
  1. 在处于设计视图中时，在文档中选择 Flash 按钮对象。
  2. 在属性检查器中单击“播放”。
  3. 单击“停止”可以结束预览。

备注： 在 Flash 按钮对象正在播放时您不能编辑它。

在浏览器中预览您的文档以查看 Flash 按钮的准确外观也是个不错的主意。


插入 Flash 文本对象

Flash 文本对象允许您创建和插入只包含文本的 Flash 影片。这使您可以使用自己选择的设计器字体和文本创建较小的矢量图形影片。

若要插入 Flash 文本对象，请执行以下操作：
  1. 在文档窗口中，将插入点放置在您要插入 Flash 文本的地方。
  2. 若要打开“插入 Flash 文本”对话框，请执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“Flash 文本”图标。
      这是所描述的功能的图片。
    • 在插入栏中，选择“媒体”，然后将“Flash 文本”图标拖到文档窗口（或者如果您正处理代码，则拖到代码视图窗口）。
    • 选择“插入”>“交互式图像”>“Flash 文本”。

      • “插入 Flash 文本”对话框随即显示出来。
      这是所描述的功能的图片。

  3. 从“字体”弹出式菜单中选择一种字体。

    4. 此菜单列出在您的系统上当前加载的所有 TrueType 字体。

  4. 在“大小”域中输入字体大小；这些字体大小是以点为单位的。
  5. 通过单击适当的样式按钮，指定样式属性（例如粗体或斜体）和文本对齐方式。
  6. 在“颜色”域中，通过使用颜色选择器或输入 Web 十六进制值（例如 #FFFFFF），设置文本的颜色。
  7. 在“转滚颜色”域中，设置当鼠标指针经过 Flash 文本对象时显示的颜色。使用颜色选择器或输入 Web 十六进制值（例如 #FFFFFF）。
  8. 在“文本”域中输入您所需的文本。

    9. 若要查看在“文本”域中显示的字体样式，请选择“显示字体”。

  9. 如果您想要将一个链接与 Flash 文本对象关联，请在“链接”域中输入文档相对或绝对链接。

    10. 因为浏览器不能识别 Flash 影片中的站点相对链接，所以不接受站点相对链接。如果您使用文档相对链接，请确保将 SWF 文件保存到与 HTML 文件相同的目录上。（浏览器不同，它们对文档相对链接的解释也不同，因此保存到相同目录中可确保链接正确工作。）

  10. 如果您已输入链接，则可以在“目标”域中为该链接指定要转到的目标框架或目标窗口。
  11. 在“背景颜色”域中，选择文本的背景颜色。使用颜色选择器或输入 Web 十六进制值（例如 #FFFFFF）。
  12. 在“另存为”域中，输入文件的名称。

    13. 您可以使用默认文件名（例如 tex1.swf）或键入新名称。如果文件包含文档相对链接，则您必须将该文件保存到与当前 HTML 文档相同的目录中，以保持文档相对链接的有效性。

  13. 单击“应用”或“确定”可以将 Flash 文本插入文档窗口中。

    14. 如果您单击“应用”，则对话框保持打开状态，并且您可以在您的文档中预览文本。

若要修改或播放 Flash 文本对象，所采用的步骤与您对 Flash 按钮进行修改或播放所采用的步骤相同（请参见修改 Flash 按钮对象）。


插入 Flash 影片

当您将 Flash 影片插入文档时，Dreamweaver 同时使用 object 标记（该标记是 Microsoft Internet Explorer 为 ActiveX 控件定义的）和 embed 标记（由 Netscape Navigator 定义）以在所有浏览器中都获得最佳效果。当您在属性检查器中对影片进行更改时，Dreamweaver 会将您采用的各项映射为 object 和 embed 标记的适当参数。

若要插入 Flash 影片，请执行以下操作：
  1. 在文档窗口的设计视图中，将插入点放置在您要插入影片的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“插入 Flash”图标。
      这是所描述的功能的图片。
    • 在插入栏中，选择“媒体”，然后将“插入 Flash”图标拖到文档窗口中。
    • 选择“插入”>“媒体”>“Flash”。
  2. 在显示的对话框中，选择 Flash 影片文件 (.swf)。

    3. Flash 占位符随即出现在文档窗口中（与 Flash 按钮和文本对象不同）。有关设置 Flash 影片属性的信息，请参见设置 Flash 和 Shockwave 影片属性。

若要在文档窗口中预览 Flash 影片，请执行以下操作：
  1. 在“文档”窗口中，单击 Flash 占位符以选择您要预览的 Flash 影片。
  2. 在属性检查器中，单击“播放”按钮。单击“停止”可以结束预览。您还可以通过按 F12 键在浏览器中预览 Flash 影片。

提示： 若要预览某一页面中的所有 Flash 内容，请按下 Control+Alt+Shift+P 组合键 (Windows) 或 Shift+Option+Command+P 组合键 (Macintosh)。所有 Flash 对象和影片都将被设置为“播放”。


插入 Shockwave 影片

Shockwave 作为 Web 上用于交互式多媒体的 Macromedia 标准，是一种经压缩的格式，使得在 Macromedia Director 中创建的多媒体文件能够被快速下载，而且可以在大多数常用浏览器中进行播放。

播放 Shockwave 影片的软件既可作为 Netscape Navigator 插件提供，也可作为 ActiveX 控件提供。当您插入 Shockwave 影片时，Dreamweaver 同时使用 object 标记（用于 ActiveX 控件）和 embed 标记（用于插件）以在所有浏览器中都获得最佳效果。当您在属性检查器中对影片进行更改时，Dreamweaver 会将您采用的各项映射为 object 和 embed 标记的适当参数。

若要插入 Shockwave 影片，请执行以下操作：
  1. 在文档窗口中，将插入点放置在您要插入 Shockwave 影片的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“Shockwave”图标。
      这是所描述的功能的图片。
    • 在插入栏中，选择“媒体”，然后将“Shockwave”图标拖到文档窗口中（或者如果您正处理代码，则拖到代码视图窗口中）。
    • 选择“插入”>“媒体”>“Shockwave”。
  2. 在显示的对话框中，选择一个影片文件。
  3. 在属性检查器中，在“宽”和“高”框中分别输入影片的宽度和高度。

    4. 有关其他属性的信息，请参见设置 Flash 和 Shockwave 影片属性。


添加视频

您可以通过不同方式和使用不同格式将视频添加到 Web 页面。视频可被下载给用户，或者可以对视频进行流式处理以便在下载它的同时播放它。Web 上用于视频文件传输的最常见流式处理格式有 RealMedia、QuickTime 和 Windows Media。您必须下载辅助应用程序以查看这些格式。使用这些格式，您可以同时对音频和视频进行流式处理。

如果您想要包括可被下载而不是被流式处理的简短的剪辑，则您可以链接到该剪辑或将该剪辑嵌入到您的页面中。这些剪辑通常采用 AVI 或 MPEG 文件格式。

您可以使用 Director 创建 Shockwave 影片或 Flash，从而创建用于 Web 的交互式、低带宽的多媒体演示。使用 Flash，文件大小将非常小，并且该技术可以在许多平台上采用。（当然，用户在查看这些文件前必须先下载免费的播放器插件）。


向页面添加声音

有几种不同类型的声音文件和格式，并且将声音添加到 Web 页面有几种不同的方法。在确定采用哪一格式和方法添加声音前，需要考虑以下一些因素：添加声音的目的、您的观众、文件大小、声音品质和不同浏览器中的差异。

备注： 浏览器不同，处理声音文件的方式也会有很大差异和不一致的地方。您最好将声音文件添加到 Flash 影片，然后嵌入 SWF 文件以改善一致性。


关于音频文件格式

下表描述了较为常见的音频文件格式以及每一种格式在 Web 设计上的一些优缺点。

.midi 或 .mid（乐器数字接口）格式用于器乐。许多浏览器都支持 MIDI 文件并且不要求插件。尽管其声音品质非常好，但根据访问者的声卡的不同，声音效果也会有所不同。很小的 MIDI 文件也可以提供较长时间的声音剪辑。MIDI 文件不能被录制并且必须使用特殊的硬件和软件在计算机上合成。

.wav（Waveform 扩展名）格式文件具有较好的声音品质，许多浏览器都支持此类格式文件并且不要求插件。您可以从 CD、磁带、麦克风等录制您自己的 WAV 文件。但是，其较大的文件大小严格限制了可以在您的 Web 页面上使用的声音剪辑的长度。

.aif（音频交换文件格式，即 AIFF）格式与 WAV 格式类似，也具有较好的声音品质，大多数浏览器都可以播放它并且不要求插件；您还可以从 CD、磁带、麦克风等录制 AIFF 文件。但是，其较大的文件大小严格限制了您可以在您的 Web 页面上使用的声音剪辑的长度。

.mp3（运动图像专家组音频，即 MPEG-音频层-3）格式是一种压缩格式，它可令声音文件明显缩小。其声音品质非常好：如果正确录制和压缩 MP3 文件，其质量甚至可以和 CD 质量相媲美。这一新技术使您可以对文件进行“流式处理”，以便访问者不必等待整个文件下载完成即可收听该文件。但是，其文件大小要大于 Real Audio 文件，因此通过普通电话线连接下载整首歌曲可能仍要花较长的时间。若要播放 MP3 文件，访问者必须下载并安装辅助应用程序或插件，例如 QuickTime、Windows Media Player 或 RealPlayer。

.ra、.ram、.rpm 或 Real Audio 格式具有非常高的压缩程度，文件大小要小于 MP3。全部歌曲文件可以在合理的时间范围内下载。因为可以在普通的 Web 服务器上对这些文件进行“流式处理”，所以访问者在文件完全下载完之前即可听到声音。其声音品质比 MP3 文件声音品质要差，但新推出的播放器和编码器在声音品质方面已有显著改善。访问者必须下载并安装 RealPlayer 辅助应用程序或插件才可以播放这些文件。


链接到音频文件

链接到音频文件是将声音添加到 Web 页面的一种简单而有效的方法。这种集成声音文件的方法可以使访问者能够选择他们是否要收听该文件，并且使文件可用于最广范围的观众。（某些浏览器可能不支持嵌入的声音文件。）请参见嵌入声音文件。

若要创建指向某一音频文件的链接，请执行以下操作：
  1. 选择您要用作指向音频文件的链接的文本或图像。
  2. 在属性检查器中，单击文件夹图标以进行浏览来找到音频文件，或者在“链接”域中键入文件的路径和名称。


嵌入声音文件

嵌入音频将声音播放器直接并入页面中，但只有在访问您站点的访问者具有所选声音文件的适当插件后，声音才可以播放。如果您想要将声音用作背景音乐，或者想要对声音演示本身进行更多控制，则可以嵌入文件。例如，您可以设置音量、播放器在页面上显示的方式以及声音文件的开始点和结束点。

若要嵌入音频文件，请执行以下操作：
  1. 在设计视图中，将插入点放置在您要嵌入文件的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“插件”图标。
    • 在插入栏中，选择“媒体”，然后将“插件”图标拖到文档窗口中（或者如果您正处理代码，则拖到代码视图窗口中）。
    • 选择“插入”>“媒体”>“插件”。

      • 有关插件对象的更多信息，请参见插入 Netscape Navigator 插件内容。

  2. 在属性检查器中，单击文件夹图标以进行浏览来找到音频文件，或者在“链接”域中键入文件的路径和名称。
  3. 通过在适当的域中输入值或者通过在“文档”窗口中调整插件占位符的大小，输入宽度和高度。

    4. 这些值确定音频控件在浏览器中以多大的大小显示。例如，尝试采用 144 个像素的宽度和 60 个像素的高度，以查看音频播放器在 Navigator 和 Internet Explorer 中显示的情形。


插入 Netscape Navigator 插件内容

插件可以增强 Netscape Navigator 的功能，提供以多种格式查看媒体内容的方式。插件可用来在您的 Web 站点上播放和显示内容文件。例如，典型的插件包括 RealPlayer 和 QuickTime，而一些内容文件本身包括 MP3 和 QuickTime 影片。

在您创建 Navigator 插件的内容后，您可以使用 Dreamweaver 将该内容插入 HTML 文档。Dreamweaver 使用 embed 标记来标记对该内容文件的引用。

若要插入 Navigator 插件内容，请执行以下操作：
  1. 在文档窗口的设计视图中，将插入点放置在您要插入内容的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“插件”图标。
      这是所描述的功能的图片。
    • 选择“插入”>“媒体”>“插件”。
  2. 在显示的对话框中，为 Navigator 插件选择内容文件。

有关可用属性的信息，请参见设置 Netscape Navigator 插件属性。


在“文档”窗口中播放插件

您可以直接在“文档”窗口的“设计”视图中预览基于 Navigator 插件（即，使用 embed 标记的元素）的影片和动画。（您不能在文档窗口中预览基于 ActiveX 控件的影片或动画。）您可以同时播放所有插件元素，以查看用户实际看到的页面效果；或者您也可以单独播放每一元素，以确保您嵌入了正确的媒体元素。

若要播放影片，必须在您的计算机上安装正确的插件。在 Dreamweaver 启动时，它自动搜索所有已安装的插件，它首先在 Configuration/Plugins 文件夹中查找，然后在所有已安装的浏览器的插件文件夹中查找。

若要在文档窗口中播放插件内容，请执行以下操作：
  1. 通过选择“插入”>“媒体”>“Shockwave”、“插入”>“媒体”>“Flash”或“插入”>“媒体”>“插件”，插入一个或多个媒体元素。
  2. 若要播放插件内容，请执行以下操作：
    • 选择您已插入的媒体元素之一，然后选择“查看”>“插件”>“播放”或在属性检查器中单击“播放”按钮。
    • 选择“查看”>“插件”>“播放全部”以播放基于插件的选定页面上的所有媒体元素。

备注： “播放全部”仅应用于当前文档；例如，它不应用于框架页中的其他文档。

若要停止播放插件内容，请执行以下操作：

选择媒体元素并选择“查看”>“插件”>“停止”，或者在属性检查器中单击“停止”按钮。

您还可以选择“查看”>“插件”>“停止全部”以停止播放全部插件内容。


Navigator 插件答疑

如果您遵守上述步骤在文档窗口中播放插件内容，但某些插件内容不播放，则尝试执行以下操作：

  • 确保在您的计算机上安装了关联的插件，并且内容与您具有的插件版本兼容。
  • 在文本编辑器中打开文件 Configuration/Plugins/UnsupportedPlugins.txt，查看文件中是否列出了有问题的插件。此文件记录在 Dreamweaver 中导致问题并因此不受支持的插件。（如果您在使用特定插件时出现问题，请考虑将其添加到该文件中。）
  • 检查您是否具有足够的内存（在 Macintosh 上，检查分配给 Dreamweaver 的内存是否足够）。某些插件要求额外的 2 到 5 MB 的内存才可以运行。


插入 ActiveX 控件

ActiveX 控件（以前称作 OLE 控件）是可以充当浏览器插件的可重复使用的组件，有些像微型的应用程序。ActiveX 控件在 Windows 系统上的 Internet Explorer 中运行，但它们不在 Macintosh 系统上或 Netscape Navigator 中运行。Dreamweaver 中的 ActiveX 对象使您可为访问者的浏览器中的 ActiveX 控件提供属性和参数。

Dreamweaver 使用 object 标记在页面上标记 ActiveX 控件将显示的位置，并且为 ActiveX 控件提供参数。

若要插入 ActiveX 控件内容，请执行以下操作：
  1. 在文档窗口中，将插入点放置在您要插入内容的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“ActiveX”图标。
      这是所描述的功能的图片。
    • 在插入栏中，选择“媒体”，然后将“ActiveX”图标拖到文档窗口（或者如果您正处理代码，则拖到代码视图窗口）。
    • 选择“插入”>“媒体”>“ActiveX”。

      • 出现的图标标记出 Internet Explorer 中 ActiveX 控件将在页面上出现的位置。

有关可用属性的信息，请参见设置 ActiveX 属性。


插入 Java applets

Java 是一种编程语言，通过它可以开发可嵌入 Web 页中的小型应用程序（applets）。

在创建了 Java applets 后，您可以使用 Dreamweaver 将其插入 HTML 文档中。Dreamweaver 使用 applet 标记来标记对此 applets 文件的引用。

若要插入 Java applets，请执行以下操作：
  1. 在文档窗口中，将插入点放置在您要插入 applets 的地方，然后执行以下操作之一：
    • 在插入栏中，选择“媒体”，然后单击“applets”图标。
      这是所描述的功能的图片。
    • 在插入栏中，选择“媒体”，然后将“applets”图标拖到文档窗口（或者如果您正处理代码，则拖到代码视图窗口）。
    • 选择“插入”>“媒体”>“applets”。您还可以将“Flash 按钮”图标拖到文档窗口。
  2. 在出现的对话框中，选择包含 Java applets 的文件。

有关可用属性的信息，请参见设置 Java applets 属性。


使用行为控制媒体

您可以将行为添加到您的页面上以开始和停止各种媒体对象。

“控制 Shockwave 或 Flash”使您可以播放、停止、倒带或转到 Shockwave 或 Flash 影片中的框架（请参见控制 Shockwave 或 Flash）。

“播放声音”使您可以播放声音；例如，只要用户将鼠标指针置于某一链接上，您就可以播放声音效果（请参见播放声音）。

“检查插件”使您可以查看您站点上的访问者是否安装有所需的插件，然后根据其是否具有正确的插件将他们转到不同的 URL。这仅适用于 Netscape Navigator 插件，因为“检查插件行为”不检查 ActiveX 控件。有关更多信息，请参见检查插件。


参考资料

本节提供在本章中介绍的各对话框和属性检查器的有关信息。


设置 Flash 对象属性

Flash 对象（在 Dreamweaver 中生成的按钮和文本对象）的属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到更多的属性。

“名称”指定用来标识按钮以进行脚本撰写的名称。在属性检查器最左侧的未标记域中输入名称。

“宽”和“高”以像素为单位指定对象的宽度和高度。您还可以指定以下单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（相对于父对象宽度或高度的百分比）。缩写必须紧跟在值之后，中间不留空格（例如 3mm）。

“文件”指定指向 Flash 对象文件的路径。单击文件夹图标以浏览到某一文件，或者键入路径。

“编辑”打开 Flash 对象对话框，可以对选定的 Flash 对象进行编辑。

“重设大小”将选定的按钮重设为初始影片大小。

“垂直边距”和“水平边距”指定按钮上、下、左、右空白的像素数。

“品质”为定义该按钮的 object 和 embed 标记设置 quality 参数。设置越高，影片的观看效果就越好；但这要求更快的处理器以使影片在屏幕上正确显示。“低品质”设置意味着更看重速度而非外观，而“高品质”设置意味着更看重外观而非速度。“自动低品质”意味着首先看重速度，但如有可能则改善外观。“自动高品质”意味着首先看重这两种品质，但根据需要可能会因为速度而影响外观。

“比例”为定义按钮或文本对象的 object 和 embed 标记设置 scale 参数。此参数定义影片在由 width 和 height 值为该影片定义的区域内显示的方式。选项有“默认（全部显示）”、“无边框”和“严格匹配”。“全部显示”使在指定区域中可以看到整个影片，同时保持影片的纵横比并避免扭曲；背景颜色的边框可以出现在影片的两侧。“无边框”近似于“全部显示”，只是影片的某些部分可能会被剪掉。使用“严格匹配”，整个影片将填充指定区域，但不保持影片的纵横比并且可能会出现扭曲。

“对齐”定义对象在页面上的对齐方式。有关每一选项的说明，请参见第624页的对齐图像。

“背景颜色”指定对象的背景颜色。

“播放/停止”使您可以在文档窗口中预览 Flash 对象。单击绿色的“播放”按钮可以播放模式查看对象；单击红色的“停止”按钮可以结束影片播放并能够编辑对象。

“参数”打开一个对话框，可以在其中输入附加参数（请参见使用参数控制媒体对象）。


使用参数控制媒体对象

使用“参数”对话框可为 Shockwave 和 Flash 影片、ActiveX 控件、Navigator 插件和 Java applets 定义的特定参数输入值。这些参数与 object、embed 和 applet 标记一起使用。参数设置特定于所插入的对象类型的属性。例如，Flash 影片对象可以具有用于对象标记的品质参数 <param name=”quality” value=”best”> 。“参数”对话框是在属性检查器中提供的。有关您正使用的对象所需的参数的信息，请参见其相关文档。

备注： 现在尚没有用于标识 ActiveX 控件的数据文件的广泛接受标准。请查询您正使用的 ActiveX 控件的有关文档，了解要使用哪些参数。

若要打开“参数”对话框，请执行以下操作：
  1. 在文档窗口中选择可具有参数的对象（例如 Shockwave 影片、ActiveX 控件、Navigator 插件或 Java applets）。
  2. 使用以下方法之一打开对话框：
    • 右击对象 (Windows) 或在按住 Control 键的同时单击对象 (Macintosh)，然后从上下文菜单中选择“参数”。
    • 如果属性检查器尚未打开，则打开它；单击在属性检查器下半部分中提供的“参数”按钮。（确保属性检查器已被展开。）
若要在“参数”对话框中输入参数的值，请执行以下操作：
  1. 单击加号 (+) 按钮。
  2. 在“参数”列中输入参数的名称。
  3. 在“值”列中输入该参数的值。
若要删除参数，请执行以下操作：

选择一个参数并按减号 (-) 按钮。

若要对参数重新排序，请执行以下操作：

选择某一参数并使用上箭头和下箭头按钮。


设置 Flash 和 Shockwave 影片属性

为了确保在 Internet Explorer 和 Netscape Navigator 中都获得最佳结果，Dreamweaver 同时使用 object 和 embed 标记插入 Flash 和 Shockwave 影片。（object 标记是 Microsoft 为 ActiveX 控件定义的；embed 标记是 Navigator 为插件定义的。）若要在属性检查器中查看以下属性，请选择一个 Flash 影片或 Shockwave 影片。另请参见关于 Flash 内容和插入 Shockwave 影片。

若要查看所有 Flash 影片属性，请单击右下角的扩展箭头。

“名称”指定用来标识影片以进行脚本撰写的名称。在属性检查器最左侧的未标记域中输入名称。

“宽”和“高”以像素为单位指定影片的宽度和高度。您还可以指定以下单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（相对于父对象的值的百分比）。缩写必须紧跟在值之后，中间不留空格（例如 3mm）。

“文件”指定指向 Flash 或 Shockwave 影片文件的路径。单击文件夹图标以浏览到某一文件，或者键入路径。

“源文件”指定指向 Flash 源文档 (FLA) 的路径（在 Dreamweaver MX 和 Flash MX 都安装在您的计算机上的情况下）。若要编辑 Flash 影片文件 (SWF)，请更新影片的源文档。

“编辑”使您启动 Macromedia Flash MX 以更新 FLA 文件。如果您的计算机上没有加载 Macromedia Flash MX，此按钮将被禁用。有关编辑插入的 Flash 影片的信息，请参见在 Dreamweaver 中编辑 Flash 影片。

“重设大小”将选定影片返回到其初始大小。

“循环”，在选中该选项时影片将连续播放；如果没有选中该选项，则影片在播放一次后即停止播放。

“自动播放”，如果选中该选项，则在加载页面时自动播放影片。

“垂直边距”和“水平边距”指定影片上、下、左、右空白的像素数。

“品质”在影片播放期间控制抗失真。设置越高，影片的观看效果就越好；但这要求更快的处理器以使影片在屏幕上正确显示。“低品质”设置意味着更看重速度而非外观，而“高品质”设置意味着更看重外观而非速度。“自动低品质”意味着首先看重速度，但如有可能则改善外观。“自动高品质”意味着首先看重这两种品质，但根据需要可能会因为速度而影响外观。

“比例”确定影片如何适合在宽度和高度域中设置的尺寸。“默认值”设置显示整个影片。

“无边框”使影片适合设定的尺寸，因此无边框显示并维持原始的纵横比。

“严格匹配”对影片进行缩放以适合设定的尺寸，而不管纵横比如何。

“对齐”确定影片在页面上的对齐方式。有关每一对齐选项的说明，请参见对齐图像。

“背景颜色”指定影片区域的背景颜色。在不播放影片时（在加载时和在播放后）也显示此颜色。

“参数”打开一个对话框，可在其中输入传递给影片的附加参数。有关添加或删除参数的更多信息，请参见使用参数控制媒体对象。影片必须已设计好，可以接收这些附加参数。


设置 Netscape Navigator 插件属性

在插入 Netscape Navigator 插件的内容后（请参见插入 Netscape Navigator 插件内容），使用属性检查器为这些内容设置参数。若要在属性检查器中查看以下属性，请选择某一 Netscape Navigator 插件对象。

属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到所有属性。

“名称”指定用来标识插件以进行脚本撰写的名称。在属性检查器最左侧的未标记域中输入名称。

“宽”和“高”以像素为单位指定在页面上分配给对象的宽度和高度。 您还可以指定以下单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（相对于父对象宽度和高度的百分比）。缩写必须紧跟在值之后，中间不留空格（例如 3mm）。

“源文件”指定源数据文件。单击文件夹图标以浏览到某一文件，或者输入文件名。

“插件 URL”指定 pluginspace 属性的 URL。输入用户可以从中下载插件的站点的完整 URL。如果正查看您的页面的用户不具有该插件，则浏览器尝试从该 URL 下载它。

“对齐”确定对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“垂直边距”和“水平边距”以像素为单位指定插件上、下、左、右的空白量。

“边框”指定环绕插件周围的边框的宽度。

“参数”打开一个对话框，在其中可输入传递给 Netscape Navigator 插件的附加参数（请参见使用参数控制媒体对象）。许多插件都受到特殊参数的控制。例如，Flash 插件包括用于 bgcolor、salign 和 scale 的参数。

您还可以通过单击“属性”按钮，查看指派给选定插件的属性。您可以在此对话框中编辑、添加和删除各种属性，如宽度和高度。


设置 ActiveX 属性

在插入 ActiveX 对象后（请参见插入 ActiveX 控件），使用属性检查器设置 object 标记的属性以及 ActiveX 控件的参数。在属性检查器中单击“参数”以输入未在属性检查器中显示的属性的名称和值。现在尚没有用于 ActiveX 控件的参数的广泛接受标准格式；若要弄清楚要使用哪些参数，请查询您正使用的 ActiveX 控件的有关文档。

属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到所有属性。

“名称”指定用来标识 ActiveX 控件以进行脚本撰写的名称。在属性检查器最左侧的未标记域中输入名称。

“宽”和“高”以像素为单位指定对象的宽度和高度。您还可以指定以下单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（相对于父对象宽度和高度的百分比）。缩写必须紧跟在值之后，中间不留空格（例如 3mm）。

“类 ID”为浏览器标识 ActiveX 控件。输入一个值或从弹出式菜单中选择一个值。在加载页面时，浏览器使用该类 ID 来确定与该页面关联的 ActiveX 控件所需的 ActiveX 控件的位置。如果浏览器未找到指定的 ActiveX 控件，则它将尝试从“基址”指定的位置中下载它。

“嵌入”为该 ActiveX 控件在 object 标记内添加 embed 标记。如果 ActiveX 控件具有等效的 Netscape Navigator 插件，则 embed 标记激活该插件。Dreamweaver 将您作为 ActiveX 属性输入的值指派给等效的 Netscape Navigator 插件。

“对齐”确定对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“参数”打开一个对话框，在其中可输入传递给 ActiveX 对象的附加参数（请参见使用参数控制媒体对象）。许多 ActiveX 控件都受到特殊参数的控制。

“源文件”定义如果启用了“嵌入”选项，将要用于 Netscape Navigator 插件的数据文件。如果您没有输入值，则 Dreamweaver 将尝试根据已输入的 ActiveX 属性确定该值。

“垂直边距”和“水平边距”以像素为单位指定对象上、下、左、右的空白量。

“基址”指定包含该 ActiveX 控件的 URL。如果在访问者的系统中尚未安装 ActiveX 控件，则 Internet Explorer 从该位置下载它。 如果您没有指定“基址”参数并且如果您的访问者尚未安装相应的 ActiveX 控件，则浏览器不能显示 ActiveX 对象。

“替代图像”指定在浏览器不支持 object 标记的情况下要显示的图像。只有在取消对“嵌入”选项的选择后此选项才可用。

“数据”为要加载的 ActiveX 控件指定数据文件。许多 ActiveX 控件（例如 Shockwave 和 RealPlayer）不使用此参数。


设置 Java applets 属性

在插入 Java applets 后（请参见插入 Java applets），使用属性检查器设置参数。若要在属性检查器中查看以下属性，请选择某一 Java applets 。

属性检查器最初显示最常用的属性。单击右下角的扩展箭头可以看到所有属性。

“名称”指定用来标识 applets 以进行脚本撰写的名称。在属性检查器最左侧的未标记域中输入名称。

“宽”和“高”以像素为单位指定 applets 的宽度和高度。您还可以指定以下单位：pc（十二点活字）、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（相对于父对象宽度或高度的百分比）。缩写必须紧跟在值之后，中间不留空格（例如 3mm）。

“代码”指定包含该 applets 的 Java 代码的文件。单击文件夹图标以浏览到某一文件，或者输入文件名。

“基址”标识包含选定 applets 的文件夹。在您选择了一个 applets 后，此域被自动填充。

“对齐”确定对象在页面上的对齐方式。有关每一选项的说明，请参见对齐图像。

“替代”指定如果用户的浏览器不支持 Java applets 或者已禁用 Java，将要显示的替代内容（通常为一个图像）。如果您输入文本，Dreamweaver 将用 applet 标记的 alt 属性显示该文本。如果您选择一个图像，Dreamweaver 将在开始和结束 applet 标记之间插入 img 标记。

备注： 若要指定在 Netscape Navigator（已禁用 Java）和 Lynx（基于文本的浏览器）中均可查看的替代内容，请选择一个图像，然后在代码检查器中手动将 alt 属性添加到 img 标记中。

“垂直边距”和“水平边距”以像素为单位指定 applets 上、下、左、右的空白量。

“参数”打开一个对话框，可在其中输入传递给 applets 的附加参数。请参见使用参数控制媒体对象。许多 applets 都受到特殊参数的控制。

上一页


Dreamweaver 和辅助功能

辅助功能是指使 Web 站点和 Web 产品可供具有视觉、听觉、运动和其他残疾的人士使用。Macromedia Dreamweaver MX 提供了使产品可用的工具，并且还提供帮助您创作可用内容的工具。

软件产品和 Web 站点的辅助功能示例包括屏幕阅读器支持、图形的等效文本、键盘快捷方式、将显示颜色更改为高对比度等。

随着访问 Web 的残疾人士不断增多，开发人员使他们的产品和 Web 站点可供所有潜在用户使用便越来越重要。为了这一目的，美国政府和其他组织已经建立了法规和准则来确保开发人员产生可用的内容。有关两项重要倡议的更多信息，请参见“WWW 联合会 Web 辅助功能倡议 和“联邦康复法案第 508 款”。

如果您是需要使用 Dreamweaver 辅助功能的 Dreamweaver Web 设计者，本章将告诉您有关 Dreamweaver 屏幕阅读器支持、键盘导航和操作系统辅助功能支持的信息。

如果您是需要创建可用内容的 Dreamweaver Web 设计者，本章将告诉您有关使用 Dreamweaver“辅助功能”对话框和对站点进行辅助功能测试的信息。

如果要设计可用的 Web 站点，您需要了解辅助功能要求，并不断做出许多主观的决定。Dreamweaver 会帮助您创建可用的 Web 站点。例如，Dreamweaver 使您能够添加图像的等效文本，甚至会在您忘记这样做时提醒您。但是，没有任何创作工具能够实现该开发流程的自动化。设计者需要考虑具有残疾的用户如何与 Web 页进行交互。确保 Web 站点可供使用的最佳方法是精心的规划、开发、测试和评估。

本章包含以下主题：

  • 使用 Dreamweaver 辅助功能
  • 为辅助功能而创作
  • 对您的 Web 站点进行辅助功能测试
下一页


使用 Dreamweaver 辅助功能

Dreamweaver 提供了使它可供具有残疾的用户使用的功能。具体而言，Dreamweaver 支持屏幕阅读器、操作系统辅助功能和键盘导航。

备注： Dreamweaver 4 工作区和 Dreamweaver 5 工作区模式都支持 Dreamweaver 辅助功能，但我们建议您使用 Dreamweaver 4 工作区。若要更改模式，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后从左侧的“类别”列表中选择“常规”。单击“更改工作区”按钮，选择“Dreamweaver 4 工作区”，然后单击“确定”。


将屏幕阅读器用于 Dreamweaver

屏幕阅读器会朗读计算机屏幕上显示的文字。它还会在创作过程中朗读在辅助功能标签或属性中提供的非文本信息，例如应用程序中的按钮标签文字或图像说明。

从 Freedom Scientific 和 Window Eyes 屏幕阅读器到 GW Micro，Dreamweaver 都支持 JAWS for Windows。作为 Dreamweaver 用户，您可以使用屏幕阅读器来协助您创建 Web 页。屏幕阅读器会从“文档”窗口的左上角开始朗读。


使用操作系统辅助功能

Dreamweaver 支持 Windows 操作系统的高对比度设置。您可以通过 Windows 控制面板激活此选项。当高对比度启用后，它会按以下方式影响 Dreamweaver：

  • 对话框和面板使用系统颜色设置。

    • 例如，如果您将颜色设置为“黑底白字”，则所有 Dreamweaver 对话框和面板都会显示为白色的前景色和黑色的背景颜色。

  • “代码”视图语法颜色被禁用。

    • “代码”视图使用系统窗口和窗口文本颜色而忽略“参数选择”中的颜色设置。例如，如果您将系统颜色设置为“黑底白字”，然后在“参数选择”>“代码颜色”中更改文本颜色，则 Dreamweaver 会忽略在“参数选择”中设置的颜色并以白色前景色和黑色背景颜色显示代码文本。

  • 设计视图使用您在“修改”>“页面属性”中设置的背景颜色和文本颜色，使您设计的页面像浏览器一样呈现颜色。


使用键盘导航 Dreamweaver

您可以使用键盘来导航 Dreamweaver 浮动面板、属性检查器、对话框、框架和表，而无需使用鼠标。

本节涵盖以下主题：

  • 第 671页的“导航面板”
  • 第 671页的“导航属性检查器”
  • 第 672页的“导航对话框”
  • 导航框架
  • 第 672页的“导航表”


导航面板

您可以使用键盘来导航面板。

备注： Windows 仅支持使用 Tab 键和箭头键。

若要导航面板，请执行以下操作：
  1. 在“文档”窗口中，按 Control+Alt+Tab 可将焦点切换到某一面板。

    2. 面板标题栏周围的白色轮廓指示焦点位于该面板。屏幕阅读器会朗读具有焦点的面板标题栏。

  2. 再次按 Control+Alt+Tab 可将焦点切换到下一面板。

    3. 继续切换，直到焦点位于您要在其中工作的面板。

  3. 如有必要，按 Control+Alt+Shift+Tab 将焦点切换到前一个面板。
  4. 如果您要在其中工作的面板尚未打开，请使用 Windows 菜单中列出的键盘快捷方式显示适当的面板，然后按 Control+Alt+Tab 将焦点切换到该面板。

    5. 如果您要在其中工作的面板已打开但未展开，请将焦点置于该面板标题栏，然后按空格键。再次按空格键可折叠该面板。

  5. 按 Tab 键在该面板上的各个选项之间移动。

    6. 选项周围的虚轮廓线指示焦点位于该选项。

  6. 正确地使用箭头键：
    • 如果某一选项包含若干选择，请使用箭头键滚动查看这些选择，然后按空格键做出选择。
    • 如果面板组中有选项卡可以打开其他面板，请将焦点置于打开的选项卡，然后使用左箭头键或右箭头键打开其他选项卡。当打开一个新的选项卡后，按 Tab 键便可在该面板上的各个选项之间移动。


导航属性检查器

您可以使用键盘导航属性检查器并对文档做出更改。

备注： Windows 仅支持使用 Tab 键和箭头键。

若要导航属性检查器，请执行以下操作：
  1. 按 Control+F3 显示属性检查器（如果它不可见）。
  2. 按 Control+Alt+Tab，直到将焦点切换到属性检查器。
  3. 按 Tab 键在各个属性检查器选项之间移动。
  4. 适当地使用箭头键在选项的各项选择之间移动，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh) 做出选择。
  5. 在必要时按 Control+Tab (Windows) 或 Option+Tab (Macintosh) 打开和关闭属性检查器的展开部分，或者在焦点位于右下部的展开箭头时按空格键。


导航对话框

您可以使用键盘来导航对话框。

备注： Windows 仅支持使用 Tab 键和箭头键。

若要导航对话框，请执行以下操作：
  1. 按 Tab 键在对话框中的各个选项之间移动。
  2. 使用箭头键在选项的各项选择之间移动。

    3. 例如，如果选项有弹出式菜单，请将焦点移动到该选项，然后使用向下箭头键在各个选项之间移动。

  3. 如果该对话框包含“类别”列表，请按 Control+Tab (Windows) 或 Option+Tab (Macintosh) 将焦点切换到“类别”列表，然后使用箭头键在列表中向上或向下移动。
  4. 再次按 Control+Tab (Windows) 或 Option+Tab (Macintosh) 以切换到某一类别的选项。
  5. 按 Enter 键 (Windows) 或 Return 键 (Macintosh) 退出该对话框。


导航框架

如果您的文档包含框架，则可以使用箭头键将焦点切换到框架上。

备注： Windows 仅支持使用 Tab 键和箭头键。

若要选择一个框架，请执行以下操作：
  1. 将插入点放在“文档”窗口中。
  2. 按 Alt+向上箭头键，以选择当前具有焦点的框架。

    3. 虚线指示具有焦点的框架。

  3. 继续按 Alt+向上箭头键，将焦点切换到框架集，如果存在嵌套框架集，则切换到父框架集。
  4. 按 Alt+向下箭头键，将焦点切换到子框架集或该框架集中的一个框架。
  5. 当焦点位于单个框架中时，按 Alt+左箭头键或右箭头键在各个框架之间移动。
  6. 按 Alt+向下箭头键，将插入点放在“文档”窗口中。


导航表

当选择一个表后，可以使用键盘在该表中导航。

备注： Windows 仅支持使用 Tab 键和箭头键。

若要导航表，请执行以下操作：
  1. 在“文档”窗口中，执行下列操作之一以选择表：
    • 如果插入点位于单元格的左侧，请按 Shift+右箭头键。
    • 如果插入点位于单元格的右侧，请按 Shift+左箭头键。
  2. 按向下箭头将光标定位在第一个单元格。
  3. 如有必要，使用箭头键或按 Tab 键移动到其他单元格。

    4. 提示： 如果在最右侧的单元格中按 Tab 键，则会将另一行添加到表中。

  4. 若要选择一个单元格，请在插入点位于该单元格时按 Control+A。
  5. 若要退出该表，请使用“全选”命令（在 Windows 中为 Control+A，在 Macintosh 中为 Option+A）两次，然后按向上箭头键、左箭头键或右箭头键。


为辅助功能而创作

Dreamweaver 帮助您创建可用的页面，这些页面包含可用于屏幕阅读器并符合政府准则的有用内容。

如果您激活辅助功能对话框（请参见激活辅助功能对话框），则每当您插入页面元素时，Dreamweaver 都会提示您输入辅助功能属性。

备注： 若要查看为辅助功能设计的示例页，请选择“文件”>“新建”。在“新建文档”对话框中，选择“类别”列表上的“页面设计（辅助功能）”，然后从“页面设计（辅助功能）”列表中选择一个页面。有关更多信息，请参见使用“新建文档”对话框。


开发适用于屏幕阅读器的内容

为了使信息可供屏幕阅读器和您的 Web 站点用户使用，Dreamweaver 使您可以方便地添加页面图形元素的等效文本，并使您能够用 HTML 为屏幕阅读器和其他辅助技术标记表和表单。

例如，您可以在文档中添加产品图像并关联有关“男孩”的红色大号夹克的说明。然后，当该图像在页面上向具有视觉残疾的用户显示时，屏幕阅读器会朗读该说明，这样用户就知道在页面上显示的是哪一种产品。

当您按激活辅助功能对话框中所述的方法激活辅助功能对话框时，Dreamweaver 会提示您为图形元素和辅助功能相关标记添加等效的文本。


激活辅助功能对话框

当您创建可用的页面时，需要将标签文字和说明等信息与页面对象相关联，以使您的内容可供所有用户使用。为了实现这一目的，请激活辅助功能对话框，这样 Dreamweaver 就会向您提示需要为辅助功能添加的信息。当您插入已为其激活相应辅助功能对话框的对象时，这些对话框便会出现。

若要激活辅助功能对话框，请执行以下操作：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)。

    2. “参数选择”对话框出现。

  2. 从左侧的类别列表中选择“辅助功能”。

    3. “参数选择”对话框显示辅助功能选项。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置辅助功能用户参数选择选项。

  4. 单击“确定”。

对于您选择的每个元素，当您在文档中插入该元素时，一个辅助功能对话框会提示您输入辅助功能标签和属性。

有关向 Web 站点添加可用内容的更多信息，请参见以下几节：

  • 插入可用的图像
  • 插入可用的表单对象
  • 插入可用的框架
  • 插入可用的媒体对象
  • 插入可用的表


插入可用的图像

当您插入图像并且已经在辅助功能参数选择中选择“图像”选项时，Dreamweaver 会提示您输入使该图像可用的信息。

备注： 若要使图像占位符和交互图像（如翻滚图像和导航条）可用，请在插入图像时输入替换文本。有关更多信息，请参见插入图像。

若要插入可用的图像，请执行以下操作：
  1. 将插入点放在“文档”窗口中希望图像出现的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“图像”。
    • 单击“插入”栏“常用”选项卡的“图像”按钮。
    • 将“图像”图标从“插入”栏拖入文档。

      • 出现“图像源”对话框。

  3. 单击“浏览”选择一个文件或键入图像文件的路径。

    4. 如果您正在未保存的文档中工作，Dreamweaver 会生成对该图像文件的文件位置引用。当您将文档保存在站点中的任意位置时，Dreamweaver 会转换对文档相关路径的引用。

  4. 单击“确定”。

    5. 出现“图像标签辅助功能属性”对话框。
    这是所描述的功能的图片。

  5. 在“替换文本”和“详细说明”文本框中输入值。

    6. 有关更多信息，请参见设置“图像标签辅助功能属性”对话框选项。

    备注： 根据您的需要，可以在其中一个或两个文本框中输入。

  6. 单击“确定”。

    7. 该图像出现在文档中。

    备注： 当您按“取消”时，该图像将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

若要编辑图像的辅助功能值，请执行以下操作：
  1. 在“文档”窗口中，选择图像。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的图像属性。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑标签代码”。
    • 编辑属性检查器中的 Alt 值。


插入可用的表单对象

当您插入表单对象并且已经在辅助功能参数选择中选择“表单对象”选项时，Dreamweaver 会提示您输入使表单对象可用的信息。

若要添加可用的表单对象，请执行以下操作：
  1. 在文档中，将插入点放在希望表单出现的位置。
  2. 执行以下操作之一插入表单对象：
    • 选择“插入”>“表单对象”，然后选择要插入的表单对象。
    • 选择“插入”栏上的“通用”选项卡，然后单击一个对象按钮。
    • 选择“插入”栏上的“表单”选项卡，然后将适当的图标拖到文档中。

      • 出现“输入标签辅助功能属性”对话框。
      这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“对象标签辅助功能属性”对话框选项。

  4. 单击“确定”。

    5. 备注： 如果您按“取消”，该表单对象将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

  5. 如果 Dreamweaver 询问您是否要插入表单标签，请单击“是”。

    6. 该表单对象出现在文档中。

若要编辑表单对象的辅助功能值，请执行以下操作：
  1. 在“文档”窗口中，选择该对象。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的属性。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑标签代码”。
若要使可用表单对象成为动态，请执行以下操作：
  1. 在“文档”窗口中，选择要使其成为动态的表单对象。
  2. 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑标签代码”。
  3. 根据需要编辑属性，使该对象成为动态。

备注： 不能使用“绑定”面板添加可用的动态表单对象。


插入可用的框架

当您插入框架集并且已经在辅助功能参数选择中选择“图像”选项时，Dreamweaver 会提示您为每个框架输入一个名称，以使其可以使用。

若要插入可用的框架集，请执行以下操作：
  1. 将插入点放置在文档中。
  2. 执行下列操作之一插入框架集：
    • 选择“插入”>“框架”，然后选择一个框架集。
    • 单击“插入”条中的“框架”选项卡，然后单击适当的框架集按钮。
    • 单击“插入”条中的“框架”选项卡，然后将适当的框架集图标拖到文档中。

      • 框架集出现在文档中，而“框架标签辅助功能属性”对话框随即出现。
      这是所描述的功能的图片。

  3. 从弹出式菜单中选择一个框架，然后输入该框架的名称。

    4. 有关更多信息，请参见设置“框架标签辅助功能属性”对话框选项。

    提示： 选择“窗口”>“其他”>“框架”以查看您正在命名的框架的关系图。

  4. 重复上一步骤，直到您命名每个框架。
  5. 单击“确定”。

    6. 备注： 如果您按“取消”时，该框架集将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

若要编辑框架的辅助功能值，请执行以下操作：
  1. 如果您当前正在查看设计，请显示文档的“代码”视图或“拆分”视图。
  2. 选择“窗口”>“其他”>“框架”，打开“框架”面板。
  3. 将插入点放在一个框架中，以选择该框架。

    4. Dreamweaver 高亮显示代码中的框架标签。

  4. 执行下列操作之一：
    • 在“代码”视图中编辑代码。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑标签代码”。


插入可用的媒体对象

当您插入一个媒体对象并且已经在辅助功能参数选择中选择“媒体”选项时，Dreamweaver 会提示您输入使该媒体对象可用的信息。

若要插入可用的媒体对象，请执行以下操作：
  1. 将插入点放在“文档”窗口中希望该媒体对象出现的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“媒体”，然后选择一个项。
    • 单击“插入”栏上的“媒体”选项卡，然后单击一个对象按钮。
    • 单击“插入”栏上的“媒体”选项卡，然后将适当的图标拖动到该文档中。

      • 出现“选择文件”或“插入 Flash”对话框。

      备注： 对于 Active X 对象，会出现辅助功能对话框。对于这些对象，请跳至下一步。

  3. 完成“选择文件”或“插入 Flash”对话框，然后单击“确定”。

    4. 出现“对象标签辅助功能属性”对话框。
    这是所描述的功能的图片。

  4. 完成该对话框。

    5. 有关更多信息，请参见设置“对象标签辅助功能属性”对话框选项。

  5. 单击“确定”。

    6. 媒体对象随即出现在文档中。

    备注： 如果您按“取消”，一个媒体对象占位符将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

若要编辑媒体对象的辅助功能值，请执行以下操作：
  1. 在“文档”窗口中选择该对象。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的属性。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑标签代码”。


插入可用的表

当您插入表并且已经在辅助功能参数选择中选择“表”选项时，Dreamweaver 会提示您为每个表输入一个名称，以使其可以使用。

若要插入可用的表，请执行以下操作：
  1. 将插入点放在“文档”窗口中希望该表出现的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“表”。
    • 单击“插入”栏“常用”选项卡上的“表”按钮。
    • 将“表”图标从“插入”栏的“常用”选项卡拖到文档中。

      • 出现“插入具有辅助功能属性的表格”对话框。
      这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“插入具有辅助功能属性的表”对话框选项。

  4. 单击“确定”。

    5. 表格即出现在文档中。

    备注： 如果您按“取消”，则该表不会出现在文档中。

若要编辑表的辅助功能规则，请执行以下操作：
  1. 在文档窗口中，选择表格。
  2. 执行下列操作之一：
    • 在“代码”视图中编辑适当的表属性。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)，然后选择“编辑标签代码”。


对您的 Web 站点进行辅助功能测试

要确保您的站点可供所有用户使用，最佳的方法是按照 1998 年康复法案的第 508 款辅助功能准则设计您的站点。然后，使用 Dreamweaver 的报告功能检查您已经在站点中实施这些准则。

您可以对当前文档、选定文件、文件夹或整个站点运行辅助功能报告。

若要对当前文档运行辅助功能报告，请执行以下操作：
  1. 打开要检查的文档。
  2. 选择“文件”>“检查页”>“检查辅助功能”。

    3. 报告结果出现在“站点报告”面板（在“结果”面板组中）上。

若要对选定内容运行辅助功能报告，请执行以下操作：
  1. 执行以下操作之一选择您要检查的内容：
    • 打开一个文档。
    • 在“站点”面板上选择文件。
    • 从“站点”面板的“站点”弹出式菜单中选择一个站点。

      • 备注： 若要对文件夹运行辅助功能报告，您无需立即选择文件夹；您可以在“报告”对话框中选择文件夹。

  2. 选择“站点”>“报告”

    3. 出现“报告”对话框。
    这是所描述的功能的图片。

  3. 从“报告”弹出式菜单中选择要报告的内容，然后选择“辅助功能”。

    4. 备注： 如果从“报告”弹出式菜单中选择“文件夹”，则单击“浏览”以选择一个文件夹。

  4. 单击“运行”。

    5. 报告结果出现在“站点报告”面板（在“结果”面板组中）上。

若要查看和编辑所报告的问题，请执行以下操作：
  1. 对选定的 Web 站点内容运行辅助功能报告 - 如果您尚未这样做。

    2. 报告结果出现在“站点报告”面板（在“结果”面板组中）上。选择该报告中的任一行，然后单击“站点报告”面板左侧的“更多信息”按钮，以获取问题的描述和有关如何修正该问题的建议。

    信息出现在“参考”面板（在“代码”面板组中）上。

  2. 双击报告中的任一行，在“文档”窗口中查看相应的代码。

    3. 备注： 如果您处于“设计”视图中，Dreamweaver 会将显示更改为拆分视图，以在代码中显示报告的问题。

  3. 在“文档”窗口的“代码”视图中，向适当的标签进行属性编辑或添加，使您的内容符合辅助功能准则。

    4. 若要借助于代码编辑器来进行编码，请选择代码，右击 (Windows) 或按住 Control 并单击 (Macintosh)，然后选择代码编辑器。有关标签和属性的更多信息，请参见“参考”面板（在“代码”面板组中）上的“O'Reilly HTML 参考”，然后选择一个标签。

若要保存辅助功能报告，请执行以下操作：

单击“站点报告”面板左侧的“保存”按钮。


关于此功能

Dreamweaver MX 中的辅助功能验证功能利用 UsableNet 提供的技术。在开发易于使用的软件，使可用性和辅助功能测试及修复过程自动化这一领域，UsableNet 处于行业领先的地位。有关辅助功能测试的进一步帮助，请试用 UsableNet LIFT for Macromedia Dreamweaver，它是用于开发可用 Web 站点的完整解决方案。UsableNet Lift for Macromedia Dreamweaver 包括用于复杂表、表单和图像的修复向导；全局 ALT 编辑器；可自定义的报告；以及一个新增的活动监控模式，它确保内容在页生成的过程中即可使用。从 http://www.usablenet.com可请求获取 Lift for Macromedia Dreamweaver 的演示版


设置辅助功能用户参数选择选项

此对话框用于激活辅助功能对话框并启用面板的大字体显示。

过程
  1. 在“插入时显示属性”下，选择要为其激活辅助功能对话框的元素。

    2. 对于每个选定的元素，一个辅助功能对话框都会在您将该元素插入文档时提示您输入辅助功能标签或属性。

  2. 如果要使用大字体，请选择“使 Dreamweaver 使用大字体”复选框。
  3. 如果无法使用屏幕阅读器，则取消选择“屏幕外呈现”复选框。
  4. 单击“确定”。

相关主题

激活辅助功能对话框


设置“图像标签辅助功能属性”对话框选项

此对话框用于设置图像标签辅助功能选项。根据您的需要，可以输入一项或两项属性。屏幕阅读器会朗读图像的 Alt 属性。

过程
  1. 在“替换”文本框中，为图像输入一个名称或一段简短描述。

    2. 屏幕阅读器会朗读您在此处输入的信息。您的输入应限制在 50 个字符左右。对于较长的描述，请考虑在“长描述”文本框中提供链接，指向提供该图像更多信息的文件。

  2. 在“长描述”文本框中，输入当用户单击图像时显示的文件的位置，或者单击文件夹按钮以浏览到该文件。

    3. 该域提供指向与图像相关（或提供有关图像的更多信息）的文件的链接。

  3. 单击“确定”。

    4. 备注： 如果您按“取消”，该图像将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

相关主题

插入可用的图像


设置“输入标签辅助功能属性”对话框选项

此对话框用于设置表单对象辅助功能选项。屏幕阅读器会朗读该对象的“标签文字”属性。

过程
  1. 在“标签文字”文本框中输入该表单对象的名称。
  2. 选择一种样式：

    3. 用标签标记环绕会在表单项的两边添加一个标签标记，如下所示：

    <label>
<input type="radio" name="radiobutton" value="radiobutton">
RadioButton1</label>

使用 for 附加标签标记使用“for”属性在表单项两侧添加一个标签标记，如下所示：

<input type="radio" name="radiobutton" value="radiobutton" id="radiobutton">
<label for="radiobutton">RadioButton2</label>

此选项会使浏览器用焦点矩形呈现与复选框和单选按钮关联的文本，并使用户能够通过在关联文本中的任意位置（而不仅是在复选框或单选按钮控件上）单击来选择该复选框和单选按钮。

    备注： 这是辅助功能的参数选择，但是浏览器不同，该功能也可能会有所不同。

无标签标记不使用标签标记，如下所示：

<input type="radio" name="radiobutton" value="radiobutton">
RadioButton3
  3. 为标签选择相对于表单对象的位置：“在表单项后”或“在表单项前”。
  4. 在“快捷键”文本框中输入等效的键盘键（一个字母），用以在浏览器中选择表单对象。

    5. 使用 Control 键 (Windows) 和快捷键来访问该对象。例如，如果您输入 B 作为快捷键，则使用 Control+B 在浏览器中选择该对象。

  5. 在“Tab 键索引”文本框中输入一个数字以指定该表单对象的 Tab 键顺序。

    6. 当您的页面上有其他链接和表单对象，并且需要用户用 Tab 键以特定顺序通过这些对象时，设置 Tab 键顺序就会非常有用。如果为一个对象设置 Tab 键顺序，则一定要为所有对象设置 Tab 键顺序。

  6. 单击“确定”。

    7. 备注： 如果您按“取消”，该表单对象将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

相关主题

插入可用的表单对象


设置“框架标签辅助功能属性”对话框选项

此对话框用于设置框架辅助功能选项。屏幕阅读器会朗读该框架的名称。

过程
  1. 从弹出式菜单中选择一个框架。
  2. 为该框架输入一个有意义的名称。

    3. 提示： 选择“窗口”>“其他”>“框架”以查看您所命名的框架的关系表。

  3. 对于每个框架重复以上步骤。
  4. 单击“确定”。

    5. 备注： 如果您按“取消”，该框架集将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

如果您没有对该对话框做出任何更改就按“确定”，则 Dreamweaver 会为该框架提供与其名称相同的标题。框架名称与其位置相对应。

相关主题

插入可用的框架


设置“对象标签辅助功能属性”对话框选项

此对话框用于设置媒体对象辅助功能选项。屏幕阅读器会朗读该对象的标题。

过程
  1. 在“标题”文本框中输入媒体对象的标题。
  2. 在“快捷键”文本框中输入等效的键盘键（一个字母），用以在浏览器中选择表单对象。

    3. 使用 Control 键 (Windows) 和快捷键来访问该对象。例如，如果您输入 B 作为快捷键，则使用 Control+B 在浏览器中选择该对象。

  3. 在“Tab 键索引”文本框中输入一个数字以指定表单对象的 Tab 键顺序。

    4. 当您的页面上有其他链接和表单对象，并且需要用户用 Tab 键以特定顺序通过这些对象时，设置 Tab 键顺序就会非常有用。如果为一个对象设置 Tab 键顺序，则一定要为所有对象设置 Tab 键顺序。

  4. 单击“确定”。

    5. 备注： 如果您按“取消”，一个媒体对象占位符将出现在文档中，但 Dreamweaver 不会将它与辅助功能标签或属性相关联。

相关主题

插入可用的媒体对象


设置“插入具有辅助功能属性的表”对话框选项

此对话框用于设置表辅助功能选项。屏幕阅读器会朗读标题和摘要。

过程
  1. 完成标准的表域：“行数”、“列数”、“单元格填充”、“单元格间距”、“宽度”和“边框”。

    2. 有关更多信息，请参见插入表格。

  2. 在“标题”文本框中输入一个将在表外显示的标题。
  3. 为该标题选择一个相对于表的“对齐”选项。
  4. 在“摘要”文本框中输入表的说明。

    5. 屏幕阅读器会朗读摘要文本，但它不会出现在用户的浏览器中。

  5. 从“标题”弹出式菜单中选择一个标题选项，以帮助屏幕阅读器用户跟踪表格信息：
    • “无”对表不启用列或行标题
    • “列”使表的第一列成为标题列，以便您为表中的每个行 输入一个标题。
    • “行”使表的第一行成为标题行，以便您为表中的每个列 输入一个标题。
    • “两者”使您能够在表中输入列标题和行标题。
  6. 单击“确定”。

    7. 备注： 如果您按“取消”，则该表不会出现在文档中。

相关主题

插入可用的表

上一页


使用行为和动画

许多 Web 页只包含文本和图像，没有任何交互式元素。在 Dreamweaver 中使用 JavaScript 行为和分层动画时间轴，提供互动功能和动画以使访问者更感兴趣。

此部分包含以下各章：

  • 使用 JavaScript 行为
  • 制作层动画


使用 JavaScript 行为

Dreamweaver 行为将 JavaScript 代码放置在文档中以允许访问者与 Web 页进行交互，从而以多种方式更改页或引起某些任务的执行。行为是事件和由该事件触发的动作的组合。在“行为”面板中，通过指定一个动作然后指定触发该动作的事件，可将行为添加到页中。

备注： 行为代码是客户端 JavaScript 代码；即它运行于浏览器中，而不是服务器上。

实际上，事件是浏览器生成的消息，指示页的访问者执行了某种操作。例如，当访问者将鼠标指针移动到某个链接上时，浏览器为该链接生成一个 onMouseOver 事件；然后浏览器查看是否存在当为该链接生成该事件时浏览器应该调用的 JavaScript 代码（这些代码是在被查看的页中指定的）。为不同的页元素定义不同的事件；例如，在大多数浏览器中，onMouseOver 和 onClick 是与链接关联的事件，而 onLoad 是与图像和文档的 body 部分关联的事件。

动作是由预先编写的 JavaScript 代码组成的，这些代码执行特定的任务，例如打开浏览器窗口、显示或隐藏层、播放声音或停止 Shockwave 影片。随 Macromedia Dreamweaver MX 提供的动作是由 Dreamweaver 工程师精心编写的，以提供最大的跨浏览器兼容性。

在将行为附加到页元素之后，只要对该元素发生了您所指定的事件，浏览器就会调用与该事件关联的动作（JavaScript 代码）。（可以用来触发给定动作的事件随浏览器的不同而有所不同。）例如，如果将弹出消息动作附加到某个链接并指定它将由 onMouseOver 事件触发，那么只要某人在浏览器中用鼠标指针指向该链接，就将在对话框中弹出您的消息。

单个事件可以触发多个不同的动作，您可以指定这些动作发生的顺序。

Dreamweaver MX 提供大约二十多个行为动作；您可以在 Macromedia Exchange Web 站点以及第三方开发人员站点上找到更多的动作。（请参见下载并安装第三方行为。）如果精通 JavaScript，您可以编写自己的行为动作。有关编写行为动作的更多信息，请参见《扩展 Dreamweaver》。

备注： 行为 和动作 这两个术语是 Dreamweaver 术语，而不是 HTML 术语。从浏览器的角度看，动作与任何其他一块 JavaScript 代码完全相同。

本章包含以下几节：

  • 使用“行为”面板
  • 关于事件
  • 应用行为
  • 关于行为和文本
  • 将行为附加到时间轴
  • 更改行为
  • 更新行为
  • 创建新动作
  • 下载并安装第三方行为
  • 使用 Dreamweaver自带的行为动作
下一页


使用“行为”面板

使用“行为”面板将行为附加到页元素（更具体地说是附加到标签）并修改以前所附加行为的参数。有关行为是什么以及它们如何工作的背景信息，请参见使用 JavaScript 行为的开头部分。有关如何将行为附加到事件的信息，请参见应用行为。

若要打开“行为”面板，请选择“窗口”>“行为”。

已附加到当前所选页元素的行为显示在行为列表中（面板的主区域），按事件以字母顺序排列。如果同一个事件有多个动作，则将以在列表上出现的顺序执行这些动作。如果行为列表中没有显示任何行为，则没有行为附加到当前所选的页元素。

“行为”面板具有以下选项：

动作 (+) 是一个弹出式菜单，其中包含可以附加到当前所选元素的多个动作。当您从此列表中选择某个动作时，将出现一个对话框，您可以在其中指定该动作的参数。如果所有动作都灰显，则没有所选元素可以生成的事件。

删除 (-) 从行为列表中删除所选的事件和动作。

上下箭头按钮将特定事件的所选动作在行为列表中向上或向下移动。给定事件的动作是以特定的顺序执行的。可以为特定的事件更改动作的顺序 - 例如，可以更改“onLoad 事件的多个动作的发生顺序，但是所有 onLoad 动作在行为列表中都靠在一起。对于不能在列表中上下移动的动作将禁用箭头按钮。

事件（当您单击行为列表中所选事件名称旁边的箭头按钮时出现的菜单）是一个弹出式菜单，其中包含可以触发该动作的所有事件。只有在选择了行为列表中的某个事件时才显示此菜单。根据所选对象的不同，显示的事件也有所不同。如果未显示预期的事件，则检查是否选择了正确的页元素或标签。（若要选择特定的标签，请使用文档窗口底部左侧的标签选择器。）同时确保您在“显示事件”子菜单中选择了正确的浏览器。

备注： 括号中的事件名称只用于链接；选择这些事件名称之一将向所选的页元素自动添加一个空链接，并将行为附加到该链接而不是元素本身。在 HTML 代码中，空链接被指定为 a href="javascript:;"。

显示事件（“事件”菜单中的子菜单）指定当前行为应该在其中起作用的浏览器。您在此菜单中进行的选择确定哪些事件将显示在“事件”弹出式菜单中。通常，较早的浏览器比较新的浏览器支持的事件要少，并且在大多数情况下您选择的目标浏览器越普通，所显示的事件越少，因为只显示在所有请求浏览器中都可用的事件。例如，如果您选择“3.0 或更新的浏览器”，那么您可以选择的事件仅限于那些在所有 Netscape Navigator 和 Microsoft Internet Explorer 3.0 版和更高版本的浏览器中都可用的事件，这将是一个非常有限的事件列表。


关于事件

每个浏览器都提供一组事件，这些事件可以与“行为”面板的动作 (+) 弹出式菜单中列出的动作相关联。当 Web 页的访问者与页进行交互时（例如，单击某个图像），浏览器生成事件；这些事件可用于调用引起动作发生的 JavaScript 函数。（没有用户交互也可以生成事件，例如设置页每 10 秒钟自动重新载入。）Dreamweaver 提供许多可以使用这些事件触发的常用动作。

有关每个浏览器所提供的事件的名称和说明，请参见 Dreamweaver 支持中心 的内容。

请注意，大多数事件只能用于特定的页元素。若要查明对于给定的页元素给定的浏览器支持哪些事件，请在您的文档中插入该页元素并向其附加一个行为，然后查看“行为”面板中的“事件”弹出式菜单。若要更详细、更进一步地了解具体哪些标签可以在给定的浏览器中与给定的事件一起使用，请在 Dreamweaver/Configuration/Behaviors/Events 文件夹的某个文件中搜索该事件。


应用行为

您可以将行为附加到整个文档（即附加到 body 标签），还可以附加到链接、图像、表单元素或多种其他 HTML 元素中的任何一种。您选择的目标浏览器确定给定的元素支持哪些事件。例如，对于每个元素，Internet Explorer 4.0 比 Navigator 4.0 或任何 3.0 版的浏览器具有更多的事件。

备注： 您不能将行为附加到纯文本。有关更多信息，请参见关于行为和文本。

您可以为每个事件指定多个动作。动作以它们在“行为”面板的“动作”列中列出的顺序发生。有关更改动作顺序的信息，请参见更改行为。

若要附加行为，请执行以下操作：
  1. 在页上选择一个元素，例如一个图像或一个链接。

    2. 若要将行为附加到整个页，请在文档窗口底部左侧的标签选择器中单击 <body> 标签。

  2. 选择“窗口”>“行为”打开“行为”面板。
  3. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择一个动作。

    4. 不能选择菜单中灰显的动作。它们灰显的原因可能是当前文档中不存在所需的对象。例如，如果文档中没有时间轴，则“播放时间轴”动作将灰显；如果文档不包含 Shockwave 或 Flash 影片，则“控制 Shockwave 或 Flash”动作将灰显。如果所选的对象无可用事件，则所有动作都灰显。

    当您选择某个动作时，将出现一个对话框，显示该动作的参数和说明。

  4. 为该动作输入参数，然后单击“确定”。

    5. Dreamweaver 提供的所有动作都可以用于 4.0 和更高版本的浏览器中。某些动作不能用于较早版本的浏览器中。请参见使用 Dreamweaver自带的行为动作。

  5. 触发该动作的默认事件显示在“事件”栏中。如果这不是所需的触发事件，则从“事件”弹出式菜单中选择另一个事件。（若要打开“事件”弹出式菜单，请在“行为”面板中选择一个事件或动作，然后单击显示在事件名称和动作名称之间的向下的黑色箭头。）

    6. 根据所选对象和在“显示事件”子菜单中指定的浏览器的不同，显示在“事件”弹出式菜单中的事件将有所不同。如果页上尚不存在相关的对象或所选的对象不能接收事件，则这些事件将灰显。如果未显示预期的事件，则检查是否选择了正确的对象，或在“显示事件”弹出式菜单中更改目标浏览器。

    如果要将行为附加到某个图像，则一些事件（例如 onMouseOver）显示在括号中。这些事件仅用于链接。当选择其中之一时，Dreamweaver 在图像周围使用 a 标签来定义一个空链接。在属性检查器的“链接”文本框中，该空链接表示为 javascript:;。如果要将其变为一个指向另一页的真正链接，您可以更改链接值，但是如果删除了 JavaScript 链接却未用另一个链接来代替它，则将删除该行为。


关于行为和文本

您不能将行为附加到纯文本。诸如 p 和 span 等标签不能在浏览器中生成事件，因此无法从这些标签触发动作。

但是，您可以将行为附加到链接。因此，若要将行为附加到文本，最简单的方法就是向文本添加一个空链接（不指向任何内容），然后将行为附加到该链接上。请注意，如果这样做，您的文本将显示为链接。如果实在不想让它显示为链接，可以更改链接颜色并删除下划线，但这样站点访问者可能不知道可以点击该文本。

若要将某个行为附加到所选的文本，请执行以下操作：
  1. 在属性检查器的“链接”域中输入 javascript:;。一定要包括冒号和分号。

    2. 备注： 如果愿意，您可以在“链接”域中改用数字符号 (#)。使用数字符号的问题在于当访问者单击该链接时，某些浏览器可能跳到页的顶部。单击 JavaScript 空链接不会在页上产生任何效果，因此 JavaScript 方法通常更可取。

  2. 在文本仍处于选中状态时打开“行为”面板（“窗口”>“行为”）。
  3. 从动作弹出式菜单中选择一个动作，输入该动作的参数，然后选择一个触发该动作的事件。有关详细信息，请参见应用行为。
若要更改链接文本的外观使它看上去不是一个链接，请执行以下操作：
  1. 选择“查看”>“代码”打开文档窗口的代码视图。
  2. 查找该链接。
  3. 在该链接的 a href 标签中，插入以下属性：style="text-decoration:none; color:black"。

    4. 此属性设置将禁用下划线并将文本的颜色设置为黑色。（当然，如果周围的文本是其他颜色，则使用该颜色而不是黑色。）

    请注意，此属性是一个内联 CSS 样式。应用于单个链接的内联样式覆盖应用于该链接的其他 CSS 样式，但不对该链接外的部分产生任何影响。若要更改页上各处或整个站点中链接文本的外观，请使用 CSS 样式为链接创建一个新的样式。有关详细信息，请参见插入文本和设置文本格式。


将行为附加到时间轴

若要在时间轴中特定的帧位置触发行为（而不是通过访问者的交互触发行为），请将该行为放置在时间轴中。（有关创建时间轴的信息，请参见制作层动画。）例如，您可以在时间轴的第 15 帧开始播放声音。

只有一种事件可以触发时间轴中的动作：达到一定帧数目的动画（例如一个 onFrame7 事件）。

该行为可以影响页上的任何对象，而不仅仅是时间轴中的对象。在浏览器中预览时间轴以查看该行为的工作情况。您不能在 Dreamweaver 中预览行为。

若要将某个行为放置到时间轴中，请执行以下操作：
  1. 在“时间轴”面板的“行为”通道中单击某个帧。
  2. 使用“行为”面板选择一个在该帧位置执行的动作。

    3. 该动作显示在“行为”面板中，同时还显示一个事件，指示触发该动作所在位置的帧编号。减号 (-) 显示在时间轴帧的“行为”通道中。


更改行为

在附加了行为之后，您可以更改触发动作的事件、添加或删除动作以及更改动作的参数。

若要更改行为，请执行以下操作：
  1. 选择一个附加有行为的对象。
  2. 选择“窗口”>“行为”打开“行为”面板。

    3. 多个行为按事件以字母的顺序显示在面板上。如果同一个事件有多个动作，则以执行的顺序显示这些动作。

  3. 从以下选项中选择：
    • 若要编辑动作的参数，请双击该行为名称或将其选中并按Enter 键 (Windows) 或 Return 键 (Macintosh)；然后更改对话框中的参数并单击“确定”。
    • 若要更改给定事件的多个动作的顺序，请选择某个动作然后单击上下箭头按钮。
    • 若要删除某个行为，请将其选中然后单击减号 (-) 按钮或按 Delete 键。


更新行为

如果您的页包含用 Dreamweaver 1 或 Dreamweaver 2 创建的行为，则当您在当前版本的 Dreamweaver 中打开该页时不对这些行为进行自动更新。但是，当您（按照下面的步骤）对页中出现的一个行为进行更新时，此页中所有其他地方出现的该行为都将进行更新。在 Dreamweaver 3 中创建的行为无需修改就可以用在 Dreamweaver 4 中。

若要更新页中的行为，请执行以下操作：
  1. 选择一个附加有该行为的元素。
  2. 打开“行为”面板。
  3. 双击该行为。
  4. 在该行为的对话框中单击“确定”。

该行为在此页中所出现的每一处都将进行更新。


创建新动作

动作是由 JavaScript 和 HTML 代码组成的。如果您精通 JavaScript，则可以编写新动作并将它们添加到“行为”面板的动作弹出式菜单中。有关更多信息，请参见《扩展 Dreamweaver》。


下载并安装第三方行为

Dreamweaver 最有用的功能之一就是它的扩展性，即它为精通 JavaScript 的用户提供了编写 JavaScript 代码的机会，这些代码可以扩展 Dreamweaver 的功能。很多这些用户选择将他们的扩展提交到 Macromedia Exchange for Dreamweaver Web 站点与其他用户共享。

若要从 Exchange 站点下载和安装新行为，请执行以下操作：
  1. 打开“行为”面板并从“动作”(+) 弹出式菜单中选择“获取更多行为”。

    2. 您的主浏览器打开，出现 Exchange 站点。（您必须连接到 Web 才能下载行为。）

  2. 浏览或搜索扩展包。
  3. 下载并安装所需的扩展包。

    4. 有关详细信息，请参见添加功能扩展 Dreamweaver。


使用 Dreamweaver自带的行为动作

Dreamweaver 自带的行为动作是为在 Netscape Navigator 4.0 和更高版本以及 Internet Explorer 4.0 和更高版本中使用而编写的。其中大多数行为动作也可用于 Netscape Navigator 版本 3.0 和更高版本。（与层相关的行为在 Navigator 3.0 中不起作用。）此外大多数这些行为动作在 Internet Explorer 版本 3.0 中运行时偶尔会发生问题。

备注： Dreamweaver 动作是经过精心编写的，以便在尽可能多的浏览器中发挥作用。如果您从 Dreamweaver 动作中手工删除代码，或用您自己的代码将其替换，则可能会失去跨浏览器兼容性。

尽管 Dreamweaver 动作经过了精心的编写以提供最大的跨浏览器兼容性，但某些动作仍不能在较早的浏览器中发挥作用。另外，某些浏览器根本不支持 JavaScript，还有很多人在浏览 Web 时经常关闭浏览器中的 JavaScript 功能。为了获得最佳的跨平台效果，可提供一个包括在无脚本标签中的替换界面，以使没有 JavaScript 的访问者仍然能够使用您的站点。


调用 JavaScript

“调用 JavaScript”动作允许您使用“行为”面板指定当发生某个事件时应该执行的自定义函数或 JavaScript 代码行。（您可以自己编写 JavaScript 或使用 Web 上多个免费的 JavaScript 库中提供的代码。）

若要使用“调用 JavaScript”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“调用 JavaScript”。
  3. 准确键入要执行的 JavaScript，或键入函数的名称。

    4. 例如，若要创建一个“后退”按钮，您可以键入 if(history.length>0){history.back()}。如果您已将代码封装在一个函数中，则只需键入该函数的名称（例如 hogback()）。

  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    6. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


改变属性

使用“改变属性”动作更改对象某个属性（例如层的背景颜色或表单的动作）的值。您可以更改的属性是由浏览器决定的；在 Internet Explorer 4.0 中可以通过此行为更改的属性比 IE 3.0 或 Navigator 3.0 或 4.0 多得多。例如，您可以动态设置层的背景颜色。

备注： 只有在您非常熟悉 HTML 和 JavaScript 的情况下才使用此动作。

若要使用“改变属性”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“更改属性”。
  3. 从“对象类型”弹出式菜单中选择您要更改其属性的对象的类型。

    4. “命名对象”弹出式菜单马上列出所有所选类型的命名对象。

  4. 从“命名对象”弹出式菜单中选择一个对象。
  5. 从“属性”弹出式菜单中选择一个属性，或在文本域中输入该属性的名称。

    6. 若要查看每个浏览器中可以更改的属性，请从浏览器弹出式菜单中选择不同的浏览器或浏览器版本。如果您正在键入属性名称，则一定要使用该属性的准确 JavaScript 名称（请记住 JavaScript 属性是区分大小写的）。

  6. 在“新值”域中为该属性输入新值，然后单击“确定”。
  7. 检查默认事件是否是所需的事件。（当该事件发生时，将执行动作并更改属性。）

    8. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


检查浏览器

使用“检查浏览器”动作可根据访问者不同类型和版本的浏览器将他们转到不同的页。例如，您可能想要使用 Navigator 4.0 或更高版本浏览器的访问者转到一页，让使用 Internet Explorer 4.0 或更高版本的访问者转到另一页，并让使用任何其他类型浏览器的访问者留在当前页上。

将此行为附加到几乎与任何浏览器都兼容的页（该页不使用任何其他 JavaScript）的 body 标签将十分有用；这样，已关闭 JavaScript 功能的访问者在访问此页时仍可以看到内容。

另一个办法是将此行为附加到一个空链接（例如 <a href="javascript:;">）并让该动作根据访问者浏览器的类型和版本确定链接的目标。

若要使用“检查浏览器”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“检查浏览器”。
  3. 确定您要如何区分访问者：根据浏览器类型；根据浏览器版本；还是既根据类型又根据版本。

    4. 例如，是否要让所有具有 4.0 版浏览器的访问者看到一页，而让所有其他人看到另外一页？或者让 Netscape Navigator 用户看到一页而让 Internet Explorer 用户看到另外一页。

  4. 指定一个 Netscape Navigator 版本。
  5. 在相邻的弹出式菜单中，选择如果浏览器是您指定的 Netscape Navigator 版本或更高版本时应该进行何种操作，如果是其他情况时应该进行何种操作。

    6. 选项包括“转到 URL”、“转到替代 URL”和“留在此页”。

  6. 指定一个 Internet Explorer 版本。
  7. 在相邻的弹出式菜单中，选择如果浏览器是您指定的 Internet Explorer 版本或更高版本时应该进行何种操作，如果是其他情况时应该进行何种操作。

    8. 选项包括“转到 URL”、“转到替代 URL”和“留在此页”。

  8. 从“其他浏览器”弹出式菜单中选择一个选项以指定如果浏览器既不是 Navigator 也不是 Internet Explorer 时应该进行何种操作。（例如，该访问者可能正在使用一个诸如 Lynx 的基于文本的浏览器。）

    9. “留在此页”是用于 Navigator 和 IE 之外浏览器的最佳选项，因为它们大多数不支持 JavaScript - 如果它们不能读取此行为，它们无论如何都会留在此页上。

  9. 在对话框底部的文本域中输入 URL 和替代 URL 的路径和文件名。如果您输入一个远程 URL，除了输入 WWW 地址之外您还必须输入 http:// 前缀。
  10. 单击“确定”。
  11. 检查默认事件是否是所需的事件。

    12. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。请记住此行为的目的是检查是否存在不同的浏览器版本，因此最好选择一个在 3.0 和更高版本的浏览器上都起作用的事件。


检查插件

使用“检查插件”动作根据访问者是否安装了指定的插件这一情况将他们发送到不同的页。例如，您可能想让安装有 Shockwave 的访问者转到一页，让未安装该软件的访问者转到另一页。

备注： 不能使用 JavaScript 在 Internet Explorer 中检测特定的插件。但是，选择 Flash 或 Director 会将相应的 VBScript 代码添加到您的页上以在 Windows 上的 IE 中检测这些插件。Macintosh 上的 Internet Explorer 中不能实现插件检测。

若要使用“检查插件”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“检查插件”。
  3. 从“插件”弹出式菜单中选择一个插件，或单击“输入”并在相邻的域中键入插件的确切名称。

    4. 您必须使用 Navigator 的“关于插件”页上以粗体指定的确切插件名称。（在 Windows 中，选择“Navigator 帮助”>“关于插件”命令；在 Macintosh 上，从 Apple 菜单中选择“关于插件”。）

  4. 在“如果有，转到 URL”域中，为具有该插件的访问者指定一个 URL。

    5. 如果您指定一个远程 URL，则必须在地址中包括 http:// 前缀。

    若要让具有该插件的访问者留在同一页上，请将此域留空。

  5. 在“否则，转到 URL”域中，为不具有该插件的访问者指定一个替代 URL。

    6. 若要让不具有该插件的访问者留在同一页上，请将此域留空。

  6. Macintosh 上的 Internet Explorer 中不能实现插件检测，在 Windows 上的 Internet Explorer 中也检测不到大多数插件。默认情况下，当不能实现检测时，访问者被发送到“否则”域中列出的 URL。若要改为将访问者发送到第一个（“如果有”）URL，则选择“如果无法检测，总是转到第一个 URL”选项。选择此选项实际意味着“假设访问者具有该插件，除非浏览器显式指出该插件不存在”。

    7. 通常，如果插件内容对于您的页是必不可少的一部分，请选择“如果无法检测，总是转到第一个 URL”选项；浏览器通常会提示不具有该插件的访问者下载该插件。如果插件内容对于您的页不是必要的，请保留此选项的未选中状态。

    此选项只适用于 Internet Explorer；Navigator 始终可以检测到插件。

  7. 单击“确定”。
  8. 检查默认事件是否是所需的事件。

    9. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


控制 Shockwave 或 Flash

使用“控制 Shockwave 或 Flash”动作来播放、停止、倒带或转到 Macromedia Shockwave 或 Macromedia Flash 影片中的帧。

若要使用“控制 Shockwave 或 Flash”动作，请执行以下操作：
  1. 选择“插入”>“媒体”>“Shockwave”或“插入”>“媒体”>“Flash”分别插入 Shockwave 或 Flash 影片。
  2. 选择“窗口”>“属性”并在上面最左边的域（在 Shockwave 或 Flash 图标旁边）中输入影片的名称。若要用“控制 Shockwave 或 Flash”动作对影片进行控制，您必须对该影片进行命名。
  3. 选择要用于控制 Shockwave 或 Flash 影片的项。例如，如果您具有用于播放影片的“播放”按钮的图像，则选择该图像。
  4. 打开“行为”面板（“窗口”>“行为”）。
  5. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“控制 Shockwave 或 Flash”。

    6. 出现一个参数对话框。

  6. 从“影片”弹出式菜单中选择一个影片。

    7. Dreamweaver 自动列出当前文档中所有 Shockwave 和 Flash 影片的名称。（具体来说，Dreamweaver 列出文件名以 .dcr、.dir、.swf 或 .spl 结尾的影片，这些文件扩展名在 object 或 embed 标签中。）

  7. 选择播放、停止、倒带或转到影片中的帧。“播放”选项从动作发生的帧开始播放影片。
  8. 单击“确定”。
  9. 检查默认事件是否是所需的事件。

    10. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“事件”弹出式菜单的“显示事件”子菜单中更改目标浏览器。


拖动层

“拖动层”动作允许访问者拖动层。使用此动作创建拼板游戏、滑块控件和其他可移动的界面元素。

您可以指定访问者可以向哪个方向拖动层（水平、垂直或任意方向），访问者应该将层拖动到的目标、如果层在目标一定数目的像素范围内是否将层靠齐到目标，当层接触到目标时应该执行的操作和其他更多的选项。

因为在访问者可以拖动层之前必须先调用“拖动层”动作，所以请确保触发该动作的事件发生在访问者试图拖动层之前。最佳的方法是（使用 onLoad 事件）将“拖动层”附加到 body 对象上，虽然您也可以使用 onMouseOver 事件将它附加到填满整个层的链接上（例如图像周围的链接）。

若要使用“拖动层”动作，请执行以下操作：
  1. 选择“插入”>“层”或单击“插入”栏上的“绘制层”按钮并在“文档”窗口的“设计”视图中绘制一个层。
  2. 通过单击文档窗口底部标签选择器中的 <body> 选择 body 标签。
  3. 打开“行为”面板。
  4. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“拖动层”。

    5. 如果“拖动层”不可用，则可能是因为您选择了层。因为层在两个 4.0 版本的浏览器中都不接受事件，所以您必须选择一个不同的对象 - 如 body 标签或链接（a 标签）- 或者在“显示事件”弹出式菜单中将目标浏览器更改为 IE 4.0。

  5. 在“层”弹出式菜单中，选择要使其可拖动的层。
  6. 从“移动”弹出式菜单中选择“限制”或“不限制”。

    7. 不限制移动适用于拼板游戏和其他拖放游戏。对于滑块控件和可移动的布景（例如文件抽屉、窗帘和小百叶窗），请选择限制移动。

  7. 对于限制移动，在“上”、“下”、“左”和“右”域中输入值（以像素为单位）。

    8. 这些值是相对于层的起始位置的。如果限制在矩形区域中的移动，则在所有四个域中都输入正值。如果只允许垂直移动，则在“上”和“下”域中输入正值，在“左”和“右”域中输入 0。如果只允许水平移动，则在“左”和“右”域中输入正值，在“上”和“下”域中输入 0。

  8. 在“左”和“上”域中为拖放目标输入值（以像素为单位）。

    9. 拖放目标是一个点，您想要访问者将层拖动到该点上。当层的左坐标和上坐标与在“左”和“上”域中输入的值匹配时便认为层已经到达拖放目标。这些值是与浏览器窗口的左上角相对的。单击“取得目前位置”用层的当前位置自动填充这些域。

  9. 在“靠齐距离”域中输入一个值（以像素为单位）确定访问者必须放目标多近，才能将层靠齐到目标。

    10. 较大的值可以使访问者较容易找到拖放目标。

  10. 对于简单的拼板游戏和布景处理，您可以到此为止了。若要定义层的拖动控制点、在拖动层时跟踪层的移动以及当放下层时触发一个动作，请单击“高级”标签。
  11. 若要指定访问者必须单击层的特定区域才能拖动层，请从“拖动控制点”弹出式菜单中选择“层内区域”；然后输入左坐标和上坐标以及拖动控制点的宽度和高度。

    12. 此选项用于层中的图像具有提示拖动元素（例如一个标题条或抽屉把）的情况。如果要让访问者单击层的任何位置都可以拖动层，则不要设置此选项。

  12. 选择任何要使用的“拖动时”选项：
    • 如果层在被拖动时应该移动到堆叠顺序的顶部，则选择“将层移至最前”。如果选择此选项，则使用弹出式菜单选择是否将层保留在最前面或将其恢复到它在堆叠顺序中的原位置。
    • 在“调用 JavaScript”域中输入 JavaScript 代码或函数名称（例如 monitorLayer()）以在拖动层时重复执行该代码或函数。例如，您可以编写一个函数，该函数监视层的坐标并在一个文本域中显示提示（如“您正在接近目标”或“您离拖放目标还很远”）。请参见收集有关可拖动层的信息。
  13. 在第二个“调用 JavaScript”域中输入 JavaScript 代码或函数名称（例如 evaluateLayerPos()）以在放下层时执行该代码或函数。如果只有在层到达拖放目标时才执行该 JavaScript，则选择“只有在靠齐时”。
  14. 单击“确定”。
  15. 检查默认事件是否是所需的事件。

    16. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。请记住 3.0 版的浏览器不支持层。

备注： 您不能将“拖动层”动作附加到具有 onMouseDown 或 onClick 事件的对象。


收集有关可拖动层的信息

当将“拖动层”动作附加到某个对象时，Dreamweaver 将 MM_dragLayer() 函数插入到您的文档的 head 部分。除了将层注册为可拖动之外，此函数还会为每个可拖动的层定义三项属性：MM_LEFTRIGHT、MM_UPDOWN 和 MM_SNAPPED，您可以在自己的 JavaScript 函数中使用这些属性确定层的相对水平位置、层的相对垂直位置以及层是否达到拖动目标。

备注： 此处提供的信息仅供有经验的 JavaScript 编程人员使用。

例如，下面的函数在一个叫做 curPosField 的表单域中显示 MM_UPDOWN 属性的值（层当前的垂直位置）。（因为表单域在 Navigator 和 Internet Explorer 中都是动态的，即您可以在页完成载入之后更改它们的内容，所以它们非常适合用于显示不断更新的信息。）

function getPos(layername){
   var layerRef = MM_findObj(layername);
   var curVertPos = layerRef.MM_UPDOWN;
   document.tracking.curPosField.value = curVertPos;
}

您可以编写一个函数根据该值距离拖放区域的远近程度在表单域中显示消息，或者您可以调用另一个函数根据该值显示或隐藏层，而不是在表单域中显示 MM_UPDOWN 或 MM_LEFTRIGHT 的值。只要具有足够的想像力和 JavaScript 技巧，您几乎可以以任何方式响应 MM_UPDOWN 或 MM_LEFTRIGHT 的值。

当页上有多个层并且所有这些层都必须到达它们的目标后访问者才可以前进到下一页或下一个任务时，读取 MM_SNAPPED 属性将特别有用。例如，您可以编写一个函数对 MM_SNAPPED 值为 true 的层进行计数，并在每放下一个层时都调用该函数。当已靠齐的计数达到所需的数目时，您可以将访问者送到下一页或显示一条祝贺消息。

如果您曾使用 onMouseOver 事件将“拖动层”动作附加到多个层中的链接，则您必须对 MM_dragLayer() 函数进行微小的更改，以防止已靠齐的层的 MM_SNAPPED 属性在鼠标指针滑过该层时被重置为 false。（如果您使用“拖动层”来创建图片拼板游戏就可能发生这种情况，因为访问者很可能在放置其他块时将鼠标指针滑过已靠齐的块。）MM_dragLayer() 函数不能防止此行为的发生，因为有时这是我们所希望的，例如当您要为单个层设置多个拖放目标时。

若要防止已靠齐的层重新对齐，请执行以下操作：
  1. 在对代码进行任何更改之前先制作文档的备份拷贝。（您可以在 Dreamweaver 中的“站点”面板，或者在 Windows 资源管理器 (Windows) 或 Finder (Macintosh) 中完成此操作。）
  2. 选择“编辑”>“查找”。
  3. 在“查找内容”弹出式菜单中选择“HTML 源代码”。
  4. 在相邻的文本域中键入 (!curDrag)。
  5. 单击“查找下一个”。

    6. 如果 Dreamweaver 询问是否要从文档的开头继续查找，单击“是”。Dreamweaver 找到一个内容如下的语句：

    if (!curDrag) return false;
  6. 关闭“查找”对话框，然后在文档窗口的代码视图中或代码检查器中修改该语句，修改后为：
    7. if (!curDrag || curDrag.MM_SNAPPED != null) return false;

    两个管道符 (||) 表示“或”，curDrag 是表示被注册为可拖动的层的变量。该语句的意思是“如果 curDrag 不是一个对象，或者如果它已具有 MM_SNAPPED 值，则不要继续执行函数的其余部分。”


转到 URL

“转到 URL”动作在当前窗口或指定的框架中打开一个新页。此动作对通过一次单击更改两个或多个框架的内容特别有用。还可以在时间轴中调用此动作在指定的时间间隔后跳到一个新页。

若要使用“转到 URL”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“转到 URL”。
  3. 从“打开在”列表中选择 URL 的目标。

    4. “打开在”列表自动列出当前框架集中所有框架的名称以及主窗口。如果没有任何框架，则主窗口是唯一的选项。

    备注： 如果任何框架命名为 top、blank、self 或 parent，则此动作可能产生意想不到的结果。浏览器有时将这些名称误认为保留的目标名称。

  4. 单击“浏览”选择要打开的文档，或在“URL”域中输入该文档的路径和文件名。
  5. 重复第 3 步和第 4 步在其他框架中打开其他文档。
  6. 单击“确定”。
  7. 检查默认事件是否是所需的事件。

如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


跳转菜单

当您使用“插入”>“表单对象”>“跳转菜单”创建跳转菜单时，Dreamweaver 创建一个菜单对象并向其附加一个“跳转菜单”（或“跳转菜单转到”）行为。通常不需要手动将“跳转菜单”动作附加到对象。有关跳转菜单和如何创建它们的信息，请参见插入跳转菜单。

您可以通过以下两种方式中的任意一种编辑现有的跳转菜单：

  • 您可以通过在“行为”面板中双击现有的“跳转菜单”动作编辑和重新排列菜单项、更改要跳转到的文件、以及更改这些文件在其中打开的窗口。
  • 通过选择该菜单并使用属性检查器中的“列表值”按钮，您可以在菜单中编辑这些项，就象在任何菜单中编辑项一样。有关详细信息，请参见创建弹出式菜单。
若要使用“行为”面板编辑跳转菜单，请执行以下操作：
  1. 如果您的文档中没有跳转菜单对象，则创建一个跳转菜单对象。
  2. 选择该跳转菜单对象并打开“行为”面板。
  3. 在“动作”列中双击“跳转菜单”。
  4. 在“跳转菜单”对话框中进行所需的更改，然后单击“确定”。


跳转菜单转到

“跳转菜单转到”动作与“跳转菜单”动作密切关联；“跳转菜单转到”允许您将一个“转到”按钮和一个跳转菜单关联起来。（在您使用此动作之前，文档中必须已存在一个跳转菜单。）单击“转到”按钮打开在该跳转菜单中选择的链接。通常情况下，并不是跳转菜单都需要一个“转到”按钮；从跳转菜单中选择一项通常会引起 URL 的载入，不需要任何进一步的用户操作。但是如果访问者选择已在跳转菜单中选择的同一项，则不发生跳转。通常情况下这不会有多大关系，但是如果跳转菜单出现在一个框架中，而跳转菜单项链接到其他框架中的页，则通常需要使用“转到”按钮，以允许访问者重新选择已在跳转菜单中选择的项。

若要添加一个“跳转菜单转到”动作，请执行以下操作：
  1. 选择一个对象用作“转到”按钮（通常是一个按钮图像），并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“跳转菜单转到”。
  3. 在“选择跳转菜单”弹出式菜单中，选择“转到”按钮要激活的菜单。
  4. 单击“确定”。


打开浏览器窗口

使用“打开浏览器窗口”动作在一个新的窗口中打开 URL。您可以指定新窗口的属性（包括其大小）、特性（它是否可以调整大小、是否具有菜单条等）和名称。例如，您可以使用此行为在访问者单击缩略图时在一个单独的窗口中打开一个较大的图像；使用此行为，您可以使新窗口与该图像恰好一样大。

如果不指定该窗口的任何属性，在打开时它的大小和属性与启动它的窗口相同。指定窗口的任何属性都将自动关闭所有其他未显式打开的属性。例如，如果您不为窗口设置任何属性，它将以 640 x 480 像素的大小打开并具有导航条、地址工具栏、状态栏和菜单条。如果您将宽度显式设置为 640、将高度设置为 480 并不设置其他属性，则该窗口将以 640 x 480 像素的大小打开，并且不具有任何导航条、地址工具栏、状态栏、菜单条、调整大小手柄和滚动条。

若要使用“打开浏览器窗口”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“打开浏览器窗口”。
  3. 单击“浏览”选择一个文件，或输入要显示的 URL。
  4. 设置以下任意选项：

    5. 窗口宽度指定窗口的宽度（以像素为单位）。

    窗口高度指定窗口的高度（以像素为单位）。

    导航工具栏是浏览器按钮（包括“后退”、“前进”、“主页”和“重新载入”）所在的行。

    地址工具栏是浏览器选项（包括地址域）所在的行。

    状态栏是位于浏览器窗口底部的区域，在该区域中显示消息（例如剩余的载入时间以及与链接关联的 URL）。

    菜单条是浏览器窗口 (Windows) 或桌面 (Macintosh) 上显示菜单（例如“文件”、“编辑”、“查看”、“转到”和“帮助”）的区域。如果要让访问者能够从新窗口导航，您应该显式设置此选项。如果您不设置此选项，则在新窗口中用户只能关闭或最小化窗口 (Windows) 或者关闭窗口或退出应用程序 (Macintosh)。

    需要时显示滚动条指定如果内容超出可视区域应该显示滚动条。如果不显式设置此选项，则不显示滚动条。如果“调整大小手柄”选项也关闭，则访问者将不容易看到超出窗口原始大小以外的内容。（虽然他们可以拖动窗口的边缘使窗口滚动。）

    调整大小手柄指定用户应该能够调整窗口的大小，方法是拖动窗口的右下角或单击右上角的最大化按钮 (Windows) 或大小框 (Macintosh)。如果未显式设置此选项，则调整大小控件将不可用，右下角也不能拖动。

    窗口名称是新窗口的名称。如果您要通过 JavaScript 使用链接指向新窗口或控制新窗口，则应该对新窗口进行命名。此名称不能包含空格或特殊字符。

  5. 单击“确定”。
  6. 检查默认事件是否是所需的事件。

    7. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


播放声音

使用“播放声音”动作来播放声音。例如，您可能要在每次鼠标指针滑过某个链接时播放一段声音效果，或在页载入时播放音乐剪辑。

备注： 浏览器可能需要用某种附加的音频支持（例如音频插件）来播放声音。因此，具有不同插件的不同浏览器所播放声音的效果通常会有所不同。很难准确地预测出站点的访问者对您提供的声音感受如何。

若要使用“播放声音”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“播放声音”。
  3. 单击“浏览”选择一个声音文件，或在“播放声音”域中输入路径和文件名。
  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    6. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


弹出消息

“弹出消息”动作显示一个带有您指定的消息的 JavaScript 警告。因为 JavaScript 警告只有一个按钮（“确定”），所以使用此动作可以提供信息，而不能为用户提供选择。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其他表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.

备注： 您不能控制 JavaScript 警告的外观；这是由访问者的浏览器决定的。如果您希望对消息的外观进行更多的控制，可考虑使用“打开浏览器窗口”行为。有关详细信息，请参见打开浏览器窗口。

若要使用“弹出消息”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“弹出消息”。
  3. 在“消息”域中输入您的消息。
  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    6. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


预先载入图像

“预先载入图像”动作将不立即出现在页上的图像（例如那些将通过时间轴、行为或 JavaScript 换入的图像）载入浏览器缓存中。这防止当图像该出现时由于下载导致的延迟。

备注： “交换图像”动作自动预先载入当您在“交换图像”对话框中选择“预先载入图像”选项时所有高亮显示的图像，因此当使用“交换图像”时您不需要手动添加预先载入图像。

若要使用“预先载入图像”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“预先载入图像”。
  3. 单击“浏览”选择要预先载入的图像文件，或在“图像源文件”域中输入图像的路径和文件名。
  4. 单击对话框顶部的加号 (+) 按钮将图像添加到“预先载入图像”列表中。

    5. 备注： 如果在输入下一个图像之前您没有单击加号按钮，则列表中您刚选择的图像将被所选择的下一个图像替换。

  5. 对所有剩下的要预先载入当前页的图像重复第 3 步和第 4 步。
  6. 若要从“预先载入图像”列表中删除某个图像，请在列表中选择该图像，然后单击减号 (-) 按钮。
  7. 单击“确定”。
  8. 检查默认事件是否是所需的事件。

    9. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


设置导航条图像

使用“设置导航条图像”动作将某个图像变为导航条图像，或更改导航条中图像的显示和动作。（有关更多信息，请参见插入导航条。）

使用“设置导航条图像”对话框的“基本”标签创建或更新导航条图像或图像组、更改当单击导航条按钮时显示的 URL，以及选择在其中显示 URL 的其他窗口。

使用“设置导航条图像”对话框的“高级”标签根据当前按钮的状态更改文档中其他图像的状态。默认情况下，单击导航条中的一个元素将使导航条中的所有其他元素自动返回到它们的一般状态；如果您想将某个图像在所选图像处于按下状态或滑过状态时设置为不同的状态，则使用“高级”标签。

若要编辑“设置导航条图像”动作，请执行以下操作：
  1. 选择导航条中要编辑的图像，然后打开“行为”面板。
  2. 在“行为”面板的“动作”列中，双击与您正在更改的事件关联的“设置导航条图像”动作。
  3. 在“设置导航条图像”对话框的“基本”标签中，选择图像编辑选项。
若要为某个导航条按钮设置多个图像，请执行以下操作：
  1. 选择导航条中要编辑的图像，然后打开“行为”面板。
  2. 在“行为”面板的“动作”列中，双击与您正在更改的事件关联的“设置导航条图像”动作。
  3. 单击“设置导航条图像”对话框的“高级”标签。
  4. 在“当元素显示时”弹出式菜单中，选择一个图像状态。有关图像状态的信息，请参见创建导航条。
    • 如果您想要在一个用户单击了所选的图像之后更改另一个图像的显示，则选择“按下图像”。
    • 如果您想要在鼠标指针滑过所选的图像时更改另一个图像的显示，则选择“鼠标经过图像或按下时鼠标经过图像”。
  5. 在“同时设定图像”列表中，选择页上要设置的另一个图像。
  6. 单击“浏览”选择要显示的图像文件，或在“变成图像文件”域中键入图像文件的路径。
  7. 如果您在第 4 步中选择了“鼠标经过图像或按下时鼠标经过图像”，则具有附加的选项。在“按下时，变成图像文件”文本域中，单击“浏览”选择图像文件或键入要显示的图像文件的路径。


设置框架文本

“设置框架文本”动作允许您动态设置框架的文本，用您指定的内容替换框架的内容和格式设置。该内容可以包含任何有效的 HTML 代码。使用此动作动态显示信息。

虽然“设置框架文本”动作将替换框架的格式设置，但您可以选择“保留背景颜色”以保留页背景和文本颜色属性。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其他表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.
若要创建框架页，请执行以下操作：

选择“修改”>“框架页”>“拆分左框架”、“拆分右框架”、“拆分上框架”或“拆分下框架”。

有关更多信息，请参见创建框架和框架集。

若要使用“设置框架文本”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“设置文本”>“设置框架文本”。
  3. 在“设置框架文本”对话框中，从“框架”弹出式菜单中选择目标框架。
  4. 单击“获取当前 HTML”按钮将当前目标框架的内容拷贝到 body 部分。
  5. 在“新建 HTML”域中输入消息，然后单击“确定”。
  6. 检查默认事件是否是所需的事件。如果不是，则从弹出式菜单中选择另一个事件。

    7. 如果未看到所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


设置层文本

“设置层文本”动作用您指定的内容替换页上现有层的内容和格式设置。该内容可以包括任何有效的 HTML 源代码。

虽然“设置层文本”将替换层的内容和格式设置，但保留层的属性，包括颜色。通过在“设置层文本”对话框的“新建 HTML”域中包括 HTML 标签，可对内容进行格式设置。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其他表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.
若要创建层，请执行以下操作：
  1. 选择“插入”>“层”。

    2. 有关更多信息，请参见在页面上创建层。

  2. 在属性检查器中键入层的名称。
若要附加一个“设置层文本”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“设置文本”>“设置层文本”。
  3. 在“设置层文本”对话框中，使用“层”弹出式菜单选择目标层。
  4. 在“新建 HTML”域中输入消息，然后单击“确定”。
  5. 检查默认事件是否是所需的事件。如果不是，则从弹出式菜单中选择另一个事件。

    6. 如果未看到所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


设置状态栏文本

“设置状态栏文本”动作在浏览器窗口底部左侧的状态栏中显示消息。例如，您可以使用此动作在状态栏中说明链接的目标而不是显示与之关联的 URL。若要查看状态消息的示例，请将您的鼠标滑过 Dreamweaver 帮助中的任何导航按钮。但是，请注意，访问者常常会忽略或注意不到状态栏中的消息（而且并不是所有的浏览器都提供设置状态栏文本的完全支持）；如果您的消息非常重要，请考虑将其显示为弹出式消息或层文本。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其他表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.
若要使用“设置状态栏文本”动作，请执行以下操作：
  1. 选择一个对象并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“设置文本”>“设置状态栏文本”。
  3. 在“设置状态栏文本”对话框中，在“消息”域中键入您的消息。

    4. 保持该消息简明扼要。如果消息不能完全放在状态栏中，浏览器将截断消息。

  4. 单击“确定”。
  5. 检查默认事件是否是所需的事件。

    6. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


设置文本域文本

“设置文本域文本”动作用您指定的内容替换表单文本域的内容。

您可以在文本中嵌入任何有效的 JavaScript 函数调用、属性、全局变量或其他表达式。若要嵌入一个 JavaScript 表达式，请将其放置在大括号 ({}) 中。若要显示大括号，请在它前面加一个反斜杠 (\{)。

示例

The URL for this page is {window.location}, and today is {new Date()}.
若要创建命名的文本域，请执行以下操作：
  1. 选择“插入”>“表单对象”>“文本域”。

    2. 如果 Dreamweaver 提示您添加一个表单标签，则单击“是”。有关更多信息，请参见创建交互式表单。

  2. 在属性检查器中，为该文本域键入一个名称。确保该名称在页上是唯一的（不要对同一页上的多个元素使用相同的名称，即使它们在不同的表单上也应如此）。
若要使用“设置文本域文本”动作，请执行以下操作：
  1. 选择一个文本域并打开“行为”面板。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“设置文本”>“设置文本域文本”。
  3. 在“设置文本域文本”对话框中，从“文本域”弹出式菜单中选择目标文本域。
  4. 在“新建文本”域中输入文本，然后单击“确定”。
  5. 检查默认事件是否是所需的事件。如果不是，则从弹出式菜单中选择另一个事件。

    6. 如果未看到所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


显示－隐藏层

“显示－隐藏层”动作显示、隐藏或恢复一个或多个层的默认可见性。此动作用于在用户与页进行交互时显示信息。例如，当用户将鼠标指针滑过一个植物的图像时，您可以显示一个层给出有关该植物的生长季节和地区、需要多少阳光、可以长到多大等详细信息。

“显示－隐藏层”还可用于创建预先载入层，即一个最初挡住页的内容的较大的层，在所有页组件都完成载入后该层即消失。

若要使用“显示－隐藏层”动作，请执行以下操作：
  1. 选择“插入”>“层”或单击插入栏中的“层”按钮，然后在文档窗口中绘制一个层。

    2. 重复此步骤来创建其他的层。

  2. 在文档窗口中单击取消对层的选择，然后打开“行为”面板。
  3. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“显示－隐藏层”。

    4. 如果“显示－隐藏层”不可用，则可能是因为您选择了层。因为层在两个 4.0 版本的浏览器中都不接受事件，所以您必须选择一个不同的对象 - 如 body 标签或链接（a 标签）- 或者在“显示事件”弹出式菜单中将目标浏览器更改为 IE 4.0。

  4. 在“命名的层”列表中选择要更改其可见性的层。
  5. 单击“显示”以显示该层、“隐藏”以隐藏该层、或“默认”以恢复层的默认可见性。
  6. 对所有剩下的此时要更改其可见性的层重复第 4 步和第 5 步。（您可以通过单个行为更改多个层的可见性。）
  7. 单击“确定”。
  8. 检查默认事件是否是所需的事件。

    9. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。

当在 Netscape Navigator 浏览器窗口中查看时，层可能会收缩以适应内容。若要防止这种情况的发生，请将文本或图像添加到层中，或设置层剪贴值。

若要创建预先载入层，请执行以下操作：
  1. 在插入栏的“常用”分类中单击“绘制层”按钮，然后在文档窗口的设计视图中绘制一个较大的层。

    2. 该层一定要覆盖页上的所有内容。

  2. 在“层”面板中，将该层名称拖到层列表的顶部以指定该层应该在堆叠顺序的最前面。
  3. 如果未选择，则选择该层，并使用层属性检查器中最左边的域将其命名为“loading”。
  4. 在层仍处于选中状态时，在属性检查器中将层的背景颜色设置为与页背景相同的颜色。
    这是所描述的功能的图片。
  5. 如果需要，在层中（该层现在应该挡住其余的页内容）单击并键入消息。

    6. 例如“请稍候，正在载入页”或“正在载入...”。这些消息提示访问者正在发生的操作，以便他们知道该页包含内容。

  6. 单击文档窗口左下角标签选择器中的 <body> 标签。
  7. 在“行为”面板中，从动作弹出式菜单中选择“显示－隐藏层”。
  8. 从“命名的层”列表中选择名为“loading”的层。
  9. 单击“隐藏”。
  10. 单击“确定”。
  11. 确保行为列表中“显示－隐藏层”动作旁边列出的事件是 onLoad。（如果不是，选择该事件并单击显示在事件和动作之间的向下指的三角形。从弹出式菜单的事件列表中选择 onLoad。）


显示弹出式菜单

使用“显示弹出式菜单”行为来创建或编辑 Dreamweaver 弹出式菜单，或者打开并修改已插入 Dreamweaver 文档的 Fireworks 弹出式菜单。

通过在“显示弹出式菜单”对话框中设置选项来创建水平或垂直弹出式菜单。您可以使用此对话框来设置或修改弹出式菜单的颜色、文本和位置。

备注： 您必须使用 Dreamweaver 属性检查器中的“编辑”按钮来编辑 Fireworks 基于图像的弹出式菜单中的图像。但是，您可以使用“显示弹出式菜单”命令来更改基于图像的弹出式菜单中的文本。有关在 Fireworks MX 中编辑图像的信息，请参见Dreamweaver 与其他应用程序的集成。

若要查看文档中的弹出式菜单，您必须在浏览器窗口中打开该文档，然后将鼠标指针滑过触发图像或链接。

若要使用“显示弹出式菜单”动作，请执行以下操作：
  1. 选择要附加该行为的对象并打开“行为”面板 (Shift+F3)。
  2. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“显示弹出式菜单”。
  3. 在出现的“显示弹出式菜单”对话框中，使用以下标签来设置弹出式菜单的选项：

    4. 内容允许您设置单个菜单项的名称、结构、URL 和目标。

    外观使您能够设置菜单一般状态和滑过状态的外观以及设置菜单项文本的字体选择。

    高级允许您设置菜单单元格的属性。例如，您可以设置单元格的宽度和高度、单元格颜色和边框宽度、文本缩进以及在用户将鼠标指针移到触发器上后菜单出现之前的延迟时间长度。

    位置允许您设置菜单相对于触发图像或链接的放置位置。


添加、删除和更改弹出式菜单项的顺序

使用“显示弹出式菜单”对话框的“内容”标签创建菜单项。您还可以使用此标签删除现有项或更改它们在菜单上出现的顺序。

若要添加弹出式菜单项，请执行以下操作：
  1. 在“内容”标签中，通过执行以下操作创建一个弹出式菜单项：

    2. 在“文本”域中，选择默认文本（“新建项目”），然后键入要显示在弹出式菜单中的文本。

  2. 按需要设置其他选项：

    3. 如果您希望在单击该菜单项时打开另一个文件，则在“链接”域中键入文件路径或单击文件夹图标并浏览到您要打开的文档。

    如果您要设置文档打开的位置（例如在新窗口中或在特定的框架中），则在“目标”弹出式菜单中选择所需的位置。

    备注： 如果想要作为目标的框架未出现在“目标”弹出式菜单中，则关闭“显示弹出式菜单”对话框，然后在文档窗口中选择该框架的名称。

  3. 单击加号 (+) 按钮将其他项添加到“显示弹出式菜单”预览列表中。

    4. 添加完菜单项后，单击“确定”接受默认的设置或选择另一个显示弹出式菜单标签来设置其他的选项。

若要创建子菜单项，请执行以下操作：

在“显示弹出式菜单”列表中，选择要将其创建为子菜单项的项，然后进行以下操作之一：

  • 若要在菜单列表中缩进项，请单击“缩进项”按钮。
  • 若要删除缩进，请单击“凸出项”按钮。

    • 备注： 您不能使列表中的第一个菜单项成为子菜单项。

若要更改菜单中某个项的顺序，请执行以下操作：

在“显示弹出式菜单”列表中，选择您要向上或向下移动的项，然后单击“上移项”或“下移项”箭头将项移动到想要其出现的位置。

若要从菜单中删除某项，请执行以下操作：
  1. 在“内容”标签中，选择您要从“显示弹出式菜单”列表中删除的菜单项。
  2. 单击减号 (-) 按钮。


设置弹出式菜单的外观

在创建了菜单项之后，使用“显示弹出式菜单”的“外观”标签设置弹出式菜单的方向、字体属性和按钮状态属性。

备注： “外观”标签的预览窗格大致显示您在此标签中设置的选项。

若要设置弹出式菜单的外观，请执行以下操作：
  1. 在“外观”标签顶部的弹出式菜单中，选择“垂直菜单”或“水平菜单”来设置菜单的方向。
  2. 设置所需的文本格式设置选项：

    3. 在“字体”弹出式菜单中，选择您要应用于菜单项的字体。

    备注： 如果要应用的字体不在字体列表中，则使用“编辑字体列表”选项将所需的字体添加到字体列表中。为了确保按需要的外观显示菜单，您应该选择站点访问者很可能具有的字体。

    设置菜单项文本的字体大小、样式属性、以及文本对齐或版面调整选项。

  3. 在“一般状态”和“滑过状态”框中，使用颜色选择器设置菜单项按钮的文本和单元格颜色。
  4. 设置完外观选项后，单击“确定”或选择另一个显示弹出式菜单标签来设置其他的选项。


设置高级外观选项

使用“高级”标签中的选项指定菜单单元格的其他属性。例如，您可以设置菜单按钮的宽度、高度、单元格间距或边距、缩进文本以及设置边框属性。

若要设置弹出式菜单的高级格式设置属性，请执行以下操作：
  1. 单击“高级”标签，然后设置要应用于菜单项的选项：

    2. 单元格宽度为菜单按钮设置一个特定的宽度（以像素为单位）。单元格宽度是根据最宽的项自动设置的；若要增加单元格宽度，请在弹出式菜单中选择“像素”然后输入一个比在“单元格宽度”文本框中显示的值更大的值。

    单元格高度为菜单按钮设置一个特定的高度（以像素为单位）。若要增加单元格高度，请在弹出式菜单中选择“像素”然后输入一个比在“单元格高度”文本框中显示的值更大的值。

    单元格边距指定单元格内容和其边框之间的像素数。

    单元格间距指定相邻单元格之间的像素数。

    文本缩进允许您指定菜单项中的文本在单元格中缩进多少（以像素为单位）。

    菜单延迟设置从用户将鼠标指针移动到触发图像或链接上到菜单出现之间的时间长度。该值以毫秒为单位，因此默认设置 1000 相当于 1 秒。对于所需的每秒延迟，都添加 000；例如，对于 3 秒延迟，请键入 3000。

    弹出式菜单边框确定菜单中项周围是否显示边框。如果要在菜单项周围显示边框，则确保选中了“显示边框”复选框。

    边框宽度设置边框的宽度（以像素为单位）。

    阴影、边框颜色和高亮显示允许选择这些边框选项的颜色。阴影和高亮显示不反映在预览中。

  2. 当完成了高级外观选项的设置后，请单击“确定”或选择另一个显示弹出式菜单标签来设置其他的选项。


设置弹出式菜单在文档中的位置

使用位置选项设置弹出式菜单相对于触发图像或链接的位置。您还可以设置当用户将鼠标指针移开触发器之后该菜单是否隐藏。

若要设置弹出式菜单位置选项，请执行以下操作：
  1. 在“显示弹出式菜单”对话框中，单击“位置”标签。
  2. 通过执行以下操作之一设置弹出式菜单的位置：
    • 选择一个预先设置的选项。
    • 设置自定义位置坐标，方法是在“X”文本框中键入一个数字设置水平坐标，在“Y”文本框中键入一个数字设置垂直坐标。坐标以菜单的左上角为基准计算。
  3. 若要在鼠标指针不在其上时隐藏弹出式菜单，请确保选中了“在发生 onMouseOut 事件时隐藏菜单”。若要让菜单显示，则取消对该选项的选择。
  4. 创建或修改完弹出式菜单之后，单击“确定”。


修改弹出式菜单

“显示弹出式菜单”行为允许您编辑或更新弹出式菜单的内容。您可以添加、删除或更改菜单项、重新安排它们或设置菜单相对于触发图像或链接的放置位置。

若要打开一个现有的基于 HTML 的弹出式菜单，请执行以下操作：
  1. 在 Dreamweaver 文档中，选择触发该弹出式菜单的链接或图像。
  2. 如果尚未打开“行为”面板，则将其打开 (Shift + F3)，然后在“动作”列表中双击“显示弹出式菜单”。

    3. 出现“显示弹出式菜单”对话框。

  3. 对弹出式菜单进行所需的更改。
  4. 在完成对弹出式菜单的修改后，单击“确定”。

有关设置弹出式菜单选项的详细信息，请参见显示弹出式菜单。


交换图像

“交换图像”动作通过更改 img 标签的 src 属性将一个图像和另一个图像进行交换。使用此动作创建按钮鼠标经过图像和其他图像效果（包括一次交换多个图像）。插入鼠标经过图像会自动将一个“交换图像”行为添加到您的页中。

备注： 因为只有 src 属性受此动作的影响，所以您应该换入一个与原图像具有相同尺寸（高度和宽度）的图像。否则，换入的图像显示时会进行压缩或展开以适应原图像的尺寸。

若要使用“交换图像”动作，请执行以下操作：
  1. 选择“插入”>“图像”或单击插入栏的“图像”按钮来插入一个图像。
  2. 在属性检查器中，在最左边的文本框中为该图像输入一个名称。

    3. 如果您未为图像命名，“交换图像”动作仍将起作用；当您将该行为附加到某个对象时，它将为未命名的图像自动命名。但是，如果所有图像都预先命名，则在“交换图像”对话框中就更容易区分它们。

  3. 重复第 1 步和第 2 步插入其他图像。
  4. 选择一个对象（通常是您将交换的图像）并打开“行为”面板。
  5. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“交换图像”。
  6. 从“图像”列表中，选择要更改其源的图像。
  7. 单击“浏览”选择新图像文件，或在“设定源文件为”文本框中输入新图像的路径和文件名。
  8. 对所有要更改的其他图像重复第 6 步和第 7 步。同时对所有要更改的图像使用相同的“交换图像”动作；否则，相应的“恢复交换图像”动作就不能全部恢复它们。
  9. 选择“预先载入图像”选项在载入页时将新图像载入到浏览器的缓存中。

    10. 这防止当图像该出现时由于下载而导致的延迟。

  10. 单击“确定”。
  11. 检查默认事件是否是所需的事件。

    12. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


恢复图像交换

“恢复交换图像”动作将最后一组交换的图像恢复为它们以前的源文件。每次您将“交换图像”动作附加到某个对象时都会自动添加该动作；如果您在附加“交换图像”时选择了“恢复”选项，则您从不需要手动选择“恢复交换图像”动作。


转到时间轴帧

“转到时间轴帧”动作将播放头移动到指定的帧。您可以在“时间轴”面板的“行为”通道中使用此动作让时间轴的某一部分循环一定的次数、创建“倒带”链接或按钮，或者让用户跳到动画中的其他部分。

若要使用“转到时间轴帧”动作，请执行以下操作：
  1. 选择“窗口”>“时间轴”打开“时间轴”面板，并确保您的文档包含一个时间轴。

    2. 如果没有在“时间轴”面板中看到任何紫色的动画条，则您的文档不包含时间轴。请参见使用时间轴动画移动层。

  2. 选择要将该行为附加到的对象。

    3. 若要将该行为附加到时间轴中的某个帧，则在所需的帧位置单击“行为”通道。

  3. 打开“行为”面板。
  4. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“时间轴”>“转到时间轴帧”。（如果此动作灰显，则您的文档不包含时间轴。）
  5. 从“时间轴”弹出式菜单中选择一个时间轴。
  6. 在“转到帧”文本框中输入一个帧编号。
  7. 如果要将此动作添加到时间轴的“行为”通道中并要时间轴的一部分循环，则在“循环”文本框中输入该部分应该循环的次数。

    8. 如果未将“转到时间轴帧”附加到时间轴中的帧，则必须将此文本框留空。

  8. 单击“确定”。
  9. 检查默认事件是否是所需的事件。

    10. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


“播放时间轴”和“停止时间轴”

使用“播放时间轴”和“停止时间轴”动作让访问者通过单击链接或按钮开始和停止时间轴，或在用户滑过链接、图像或其他对象时自动开始和停止时间轴。当您在“时间轴”面板中选择“自动播放”时，“播放时间轴”动作通过 onLoad 事件自动附加到 body 标签。

若要使用“播放时间轴”和“停止时间轴”动作，请执行以下操作：
  1. 选择“窗口”>“时间轴”打开“时间轴”面板，并确保您的文档包含一个时间轴。

    2. 如果没有在“时间轴”面板中看到任何紫色的动画条，则您的文档不包含时间轴。请参见使用时间轴动画移动层。

  2. 选择一个对象并打开“行为”面板。
  3. 单击加号 (+) 按钮并从“动作”弹出式菜单中选择“播放时间轴”或“停止时间轴”。
  4. 从弹出式菜单中选择您要播放或停止的时间轴或者选择停止所有时间轴。
  5. 单击“确定”。
  6. 检查默认事件是否是所需的事件。

    7. 如果不是，则从弹出式菜单中选择另一个事件。如果未列出所需的事件，则在“显示事件”弹出式菜单中更改目标浏览器。


检查表单

“检查表单”动作检查指定文本域的内容以确保用户输入了正确的数据类型。使用 onBlur 事件将此动作附加到单个文本域，在用户填写表单时对域进行检查；或使用 onSubmit 事件将其附加到表单，在用户单击“提交”按钮时同时对多个文本域进行检查。将此动作附加到表单防止表单提交到服务器后任何指定的文本域包含无效的数据。

若要使用“检查表单”动作，请执行以下操作：
  1. 选择“插入”>“表单”或单击插入栏的“表单”按钮插入一个表单。
  2. 选择“插入”>“表单对象”>“文本域”或单击插入栏的“文本域”按钮来插入文本域。

    3. 重复此步骤以插入其他文本域。

  3. 执行以下操作之一：
    • 若要在用户填写表单时检查单个域，请选择文本域并选择“窗口”>“行为”。
    • 若要在用户提交表单时检查多个域，请在文档窗口左下角的标签选择器中单击 <form> 标签并选择“窗口”>“行为”。
  4. 从动作弹出式菜单中选择“检查表单”。
  5. 执行以下操作之一：
    • 如果您要检查单个域，则从“命名的域”列表中选择您已在文档窗口中选择的同一个域。
    • 如果您要检查多个域，则从“命名的域”列表中选择某个文本域。
  6. 如果该域必须包含某种数据，则选择“必需”选项。
  7. 从以下“接受”选项中选择一个：
    • 如果该域是必需的但不需要包含任何特定种类的数据，则使用“任何数据”。 （如果没有选择“必需”选项，则“任何数据”选项就没有意义了，也就是说它与该域上未附加“检查表单”动作一样。）
    • 使用“电子邮件地址”检查该域是否包含一个 @ 符号。
    • 使用“数字”检查该域是否只包含数字。
    • 使用“数字从”检查该域是否包含指定范围内的数字。
  8. 如果要检查多个域，对要检查的任何其他域重复第 6 步和第 7 步。
  9. 单击“确定”。

    10. 如果在用户提交表单时检查多个域，则 onSubmit 事件自动出现在“事件”弹出式菜单中。

  10. 如果要检查单个域，则检查默认事件是否是 onBlur 或onChange。

    11. 如果不是，则从弹出式菜单中选择 onBlur 或 onChange。当用户从域移开时，这两个事件都触发“检查表单”动作。它们之间的区别是 onBlur 不管用户是否在该域中键入内容都会发生，而 onChange 只有在用户更改了该域的内容时才发生。当您指定了该域是必需的时，最好使用 onBlur 事件。

上一页


制作层动画

层是一种 HTML 页面元素，您可以将它定位在页面上的任意位置。层可以包含文本、图像或其他任何可在 HTML 文档正文中放入的内容。

利用Dreamweaver，您可以在不进行任何 JavaScript 或 HTML 编码的情况下放置层和制作层动画。您可以将层前后放置，隐藏某些层而显示其他层，以及在屏幕上移动层。您可以在一个层中放置背景图像，然后在该层的前面放置第二个层，它包含带有透明背景的文本。这样就可以制作层渐进和渐出的动画。

利用层可以非常灵活地放置内容。但是，Microsoft Internet Explorer 4.0 和 Netscape Navigator 4.0 之前的 Web 浏览器无法显示层，而版本 4 浏览器显示层的方式并不完全一致。若要确保所有人都能够查看您的 Web 页，可以使用层设计页，然后将层转换为表。有关更多信息，请参见将表和层用于布局。但是，如果您所面对的访问者很可能使用最新的浏览器，则可以完全用层来设计布局，而无需将层转换为表。

备注： 如果您不熟悉如何使用层和 CSS，我们建议您使用表或布局视图来设计页面布局（请参见使用表格显示内容和在布局视图中对页进行布局）。利用布局视图可以方便地通过以表作为基础结构来实现页面布局。

本章包含以下几节：

  • 关于层的 HTML 代码
  • 在页面上创建层
  • 嵌套层
  • 操作层
  • 向层添加内容
  • 查看和设置层属性
  • 将表和层用于布局
  • 制作层动画
  • 使用行为操作制作层动画
下一页


关于层的 HTML 代码

当您在文档中放置层时，Dreamweaver将在代码中插入该层的 HTML 标签。您可以选择让Dreamweaver将 div 标签或 span 标签用于您的层。默认情况下，Dreamweaver会使用 div 标签创建层。

备注： 您还可以使用另外两种标签来创建层：layer 和 ilayer。但是，这些标签仅在 Netscape Navigator 4 中受到支持；Internet Explorer 不支持这些标签，而 Netscape 在较新的浏览器中也不再支持这些标签。Dreamweaver识别 layer 和 ilayer 标签，但不使用这些标签来创建层。

若要更改默认标签，请参见设置层参数。

div 和 span 标签之间的区别在于浏览器不支持层在 div 标签之前和之后放置额外的换行符；也就是说，div 标签是块级别的元素，而 span 标签则是内联元素。大多数情况下，在不支持层的浏览器中，最好让层内容出现在自己的段落中，因此大多数情况下最好使用 div 而不是 span。若要进一步提高在较早浏览器中的可读性，应注意放置层代码的位置。

定义层的代码可以位于 HTML 文件正文中的任意位置。当您在Dreamweaver中绘制一个层时，该层会显示在您绘制它的地方，但Dreamweaver将在页开头且紧接在 body 标签之后插入该层的代码。（如果您使用的是“插入层”命令而不是绘制层，层代码将在插入点处插入。）如果您创建一个嵌套层，Dreamweaver会在定义父层的标签内插入代码。

备注： 无论您使用的是哪一种标签，4.0 版之前的 Internet Explorer 和 Netscape Navigator 都将显示层的内容但不定位层。层的内容出现在层的代码所在的那一点；例如，如果层的代码位于页的开头，那么在不支持层的浏览器中，层的内容将出现在页的开头。

下面是一个层的 HTML 代码示例：

<div id="Layer1" style="position:absolute; visibility:inherit; width:200px; height:115px; z-index:1">
</div>

下面是嵌套在另一个层中的层的 HTML 代码示例：

<div id="Parent" style="position:absolute; left:56px; top:54px; width:124px; height:158px; z-index:1;">
Content inside the parent layer.
<div id="Nested" style="position:absolute; left:97px; top:114px; width:54px; height:69px; z-index:1;">
  Content inside the nested layer.
  </div>
</div>

您可以设置页面上层的属性，其中包括 x 和 y 坐标、z 轴（也称作层叠顺序）以及可见性。有关更多信息，请参见查看和设置层属性。


在页面上创建层

Dreamweaver使您可以方便地在页面上创建层并精确地将层定位。

若要创建层，请执行以下操作之一：
  • 若要绘制层，请单击插入栏上的“绘制层”按钮，然后在文档窗口的设计视图中通过拖动来绘制层。
  • 若要在文档中的特定位置插入层的代码，请将插入点放入文档窗口，然后选择“插入”>“层”。

    • 如果正在显示不可见元素，那么每当您在页面上放置一个层时，一个层代码标记就会出现在设计视图中。如果层代码标记不可见，而您想要看到这些标记，请选择“查看”>“可视化助理”>“不可见元素”。

    备注： 当启用“不可见元素”选项后，页面上的元素可能看起来出现了位置移动。但是，不可见元素不会出现在浏览器中，因此当您在浏览器中查看页面时，所有可见元素都会在正确的位置上出现。

若要连续绘制多个层，请执行以下操作：
  1. 单击“插入”栏上的“绘制层”按钮。
  2. 通过按住 Ctrl 键并拖动 (Windows) 或通过按住 Command 键并拖动 (Macintosh) 来绘制各个层。

    3. 只要不松开 Ctrl 或 Command 键，就可以继续绘制新的层。

相关主题

关于“层”面板

设置层参数

防止层重叠

设置“不可见元素”参数


关于“层”面板

通过“层”面板可以管理文档中的层。若要打开“层”面板，请选择“窗口”>“其他”>“层”。层显示为按 z 轴顺序排列的名称列表；首先创建的层出现在列表的底部，最新创建的层出现列表的顶部。嵌套的层显示为连接到父层的名称。单击加号 (+) 或减号 (-) 图标 (Windows) 或扩展箭头 (Macintosh) 显示或隐藏嵌套的层。

使用“层”面板可防止重叠，更改层的可见性，将层嵌套或层叠，以及选择一个或多个层。

相关主题

在页面上创建层

设置层参数

嵌套层

选择层

查看和设置层属性

更改层的层叠顺序

更改层可见性

防止层重叠


设置层参数

使用“参数选择”对话框中的“层”类别可指定新建层的默认设置。

若要查看或设置层参数选择，请执行以下操作：
  1. 选择“编辑”>“参数选择”或“Dreamweaver MX”>“参数选择”(Mac OS X)。
  2. 从“类别”列表中选择“层”。
  3. 做出必要的更改。

    4. 有关更多信息，请参见设置“层参数选择”对话框选项。

  4. 单击“确定”关闭对话框。

相关主题

嵌套层

选择层

更改层的层叠顺序

更改层可见性

防止层重叠


嵌套层

嵌套层是其代码包含在另一个层中的层。嵌套通常用于将层组织在一起。嵌套层随其父层一起移动，并且可以设置为继承其父级的可见性。

若要创建嵌套层，请在另一个层中插入或绘制一个层，或者使用“层”面板。若要在绘制在另一个层中开始的层时强制层自动嵌套，请选择层参数选择中的“嵌套”选项。有关更多信息，请参见设置层参数。

备注： 当您在页面上使用嵌套层时，请使用 Netscape 调整大小修复命令（“命令”>“添加/删除 Netscape 调整大小修复”）。否则，当访问者在 Netscape Navigator 4 版中调整浏览器窗口的大小时，层会失去它们的位置。您可以设置一个参数选择选项，以始终插入 Netscape 调整大小修复命令；有关更多信息，请参见设置“层参数选择”对话框选项。

若要创建嵌套层，请执行以下操作之一：
  • 若要插入嵌套层，请将插入点放入现有层中并选择“插入”>“层”。
  • 若要绘制嵌套层，请单击插入栏上的“绘制层”按钮，然后通过拖动在现有层中绘制一个层。如果已经在层参数选择中禁用“嵌套”，请通过按住 Alt 键并拖动 (Windows) 或按住 Option 键并拖动 (Macintosh) 在现有层中绘制一个层。

    • 提示： 在不同的浏览器中，嵌套层的外观可能会有所不同。当创建嵌套层时，请在设计过程中频繁地检查它们在不同浏览器中的外观。

若要使用“层”面板将现有层嵌套在另一个层中，请执行以下操作：
  1. 选择“窗口”>“其他”>“层”，打开“层”面板。
  2. 在“层”面板中选择一个层，然后通过按住 Ctrl 键并拖动 (Windows) 或按住 Command 键并拖动 (Macintosh) 将层移动到“层”面板上的目标层。当目标层的名称突出显示时，请松开鼠标按钮。


操作层

当处理页面布局时，可以对层进行选择、移动、大小调整和对齐。在对一个层进行移动、大小调整或对齐之前，必须先选择该层。

若要防止在对层进行移动和大小调整时使层相互重叠，请使用“防止重叠”选项（请参见防止层重叠）。


选择层

选择一个或多个层后即可对它们进行操作或更改它们的属性。

若要选择一个层，请执行以下操作之一：
  • 在“层”面板中单击该层的名称。
  • 单击一个层的选择柄。如果选择柄不可见，请在该层中的任意位置单击以显示该选项柄。
    这是所描述的功能的图片。
  • 单击一个层的边框。
  • 在一个层中按住 Ctrl-Shift 键并单击 (Windows) 或按住 Command-Shift 键并单击 (Macintosh)。如果已选定多个层，此操作会取消选定其他所有层而只选择您所单击的层。
  • 单击层代码标记（在设计视图中），它表示层在 HTML 代码中的位置。如果层代码标记不可见，请选择“查看”>“可视化助理”>“不可见元素”。
若要选择多个层，请执行以下操作之一：
  • 按住 Shift 键并单击“层”面板上的两个或更多个名称。
  • 在两个或更多个层的边框内（或边框上）按住 Shift 键并单击。

当选定多个层时，最后选定层的大小调整柄将以黑色突出显示。其他层的大小调整柄则以白色显示。


调整层大小

您可以调整单个层的大小，也可以同时调整多个层的大小以使其具有相同的宽度和高度。

如果已启用“防止重叠”选项，那么在调整层的大小时将无法使该层与另一个层重叠（请参见防止层重叠）。

若要调整选定层的大小，请执行以下操作之一：
  • 若要通过拖动来调整大小，请拖动该层的任一大小调整柄。
  • 若要一次调整一个像素的大小，请在按箭头键时按住 Ctrl 键 (Windows) 或 Option 键 (Macintosh)。

    • 备注： 箭头键移动层的右边框和下边框；对于此方法，不能使用上边框和左边框来调整大小。

  • 若要按网格靠齐增量来调整大小，请在按箭头键时按住 Shift-Ctrl 键 (Windows) 或 Shift-Option (Macintosh) 键。有关设置网格靠齐增量的信息，请参见将层靠齐到网格。
  • 在属性检查器中，键入宽度 (W) 和高度 (H) 的值。

调整层的大小会更改该层的宽度和高度。它并不定义该层的多少内容是可见的。若要定义一个层中的可见区域，请参见查看和设置层属性。

若要同时调整多个层的大小，请执行以下操作：
  1. 在设计视图中选择两个或更多个层。
  2. 执行以下操作之一：
    • 选择“修改”>“对齐”>“设成宽度相同”或“修改”>“对齐”>“设成高度相同”。

      • 首先选定的层符合最后一个选定层（黑色突出显示）的宽度或高度。

    • 在属性检查器中的“多个层”下输入宽度和高度值。这些值将应用于所有选定层。


移动层

您可以按照在基本的图形应用程序中移动对象的相同方法在设计视图中移动层。

如果已启用“防止重叠”选项，那么在移动层时将无法使层相互重叠。请参见防止层重叠。

若要移动一个或多个选定层，请执行以下操作之一：
  • 若要通过拖动来移动，请拖动最后一个选定层（黑色突出显示）的选择柄。
  • 若要一次移动一个像素，请使用箭头键。按箭头键时按住 Shift 键可按当前网格靠齐增量来移动层。有关设置网格靠齐增量的信息，请参见将层靠齐到网格。


对齐层

使用层对齐命令可利用最后一个选定层的边框来对齐一个或多个层。

当对层进行对齐时，未选定的子层可能会因为其父层被选定并移动而移动。若要避免这种情况，请不要使用嵌套层。

若要对齐两个或更多个层，请执行以下操作：
  1. 选择层。
  2. 选择“修改”>“对齐”，然后选择一个对齐选项。

例如，如果选择“对齐上缘”，所有层都会像它们的上边框与最后一个选定层（黑色突出显示）的上边框处于同一垂直位置一样移动。


将层靠齐到网格

网格是用作在文档窗口的设计视图中对层进行绘制、定位或大小调整的可视化向导。您可以使页面元素在您移动它们时自动靠齐到网格，并通过指定网格设置来更改网格或控制靠齐行为。无论网格是否可见，都可以使用靠齐。

若要显示或隐藏网格，请执行以下操作：

选择“查看”>“网格”>“显示网格”。

若要启用或禁用靠齐，请执行以下操作：

选择“查看”>“网格”>“靠齐到网格”。

若要更改网格设置，请执行以下操作：
  1. 选择“查看”>“网格”>“网格设置”。

    2. 出现“网格设置”对话框。

  2. 根据需要设置选项。

    3. 有关更多信息，请参见设置“网格设置”对话框选项。

  3. 单击“确定”。


向层添加内容

在层中放置对象之前，必须在层中放置插入点。

若要在层中放置插入点，请执行以下操作：

在该层边框内的任意位置单击。

该层的边框会突出显示，并且选择柄将出现，但该层本身尚未选定。有关选择层的信息，请参见选择层。


查看和设置层属性

您可以在属性检查器中查看和设置层的各种属性。

若要查看所有层属性，请执行以下操作：
  1. 选择一个层。有关选择层的信息，请参见选择层。
  2. 选择“窗口”>“属性”，打开属性检查器。
  3. 如果属性检查器未展开，请单击右下角的展开箭头以查看所有属性。
    这是所描述的功能的图片。
若要用属性检查器设置层属性，请执行以下操作：
  1. 选择一个层。有关选择层的信息，请参见选择层。
  2. 选择“窗口”>“属性”，打开属性检查器。
  3. 通过设置属性来更改层的属性。

    4. 有关更多信息，请参见设置层属性。


查看和设置多个层的属性

当您选择两个或更多个层时，层属性检查器会显示文本属性以及全部层属性的一部分，从而允许您同时修改多个层。

若要选择多个层，请执行以下操作：

选择层时请按下 Shift 键。有关选择层的信息，请参见选择层。

若要查看多个层的所有属性，请执行以下操作：
  1. 选择多个层。
  2. 选择“窗口”>“属性”，打开属性检查器。
  3. 如果属性检查器未展开，请单击右下角的展开箭头以查看所有属性。
    这是所描述的功能的图片。
若要用属性检查器同时设置多个层的属性，请执行以下操作：
  1. 选择多个层。
  2. 选择“窗口”>“属性”，打开属性检查器。
  3. 通过设置属性来更改层的属性。

    4. 有关更多信息，请参见设置多个层的属性。

相关主题

查看和设置层属性

选择层

设置文本属性选项


更改层的层叠顺序

使用属性检查器或“层”面板可更改层的层叠顺序。“层”面板列表顶部的层将位于层叠顺序的顶部，并且会出现在其他层之前。

在 HTML 代码中，层的层叠顺序或 z 轴确定层在浏览器中的绘制顺序。您可以使用“层”面板或属性检查器来更改每个层的 z 轴。

若要在“层”面板中更改层的层叠顺序，请执行以下操作：

选择“窗口”>“其他”>“层”，打开“层”面板。然后执行以下操作之一：

  • 选择一个层，然后将该层向上或向下拖至所需的层叠顺序。当您移动层时会出现一条线，它指示该层将出现的位置。当放置线出现在层叠顺序中的所需位置时，请松开鼠标按钮。
  • 在 Z 列，单击您所更改的层的编号。如果键入比现有编号大的编号，该层将在层叠顺序中上移；如果键入较小的编号，该层将在层叠顺序中下移。
若要用属性检查器更改层的层叠顺序，请执行以下操作：
  1. 选择“窗口”>“其他”>“层”，打开“层”面板以查看当前层叠顺序。
  2. 在“层”面板或文档窗口中选择一个层。
  3. 在层属性检查器中，将一个数字键入 Z 轴文本框。
    • 键入一个较大的数字可将该层在层叠顺序中上移。
    • 键入一个较小的数字可将该层在层叠顺序中下移。


更改层可见性

当处理文档时，可以使用“层”面板手动显示和隐藏层，以查看页如何在不同的条件下显示。

备注： 当前选定层始终会变为可见，它在选定时将出现在其他层的前面。

若要更改层可见性，请执行以下操作：
  1. 选择“窗口”>“其他”>“层”，打开“层”面板。
  2. 单击一个层的眼形图标以更改其可见性。
    • 眼睛睁开表示该层是可见的。
    • 眼睛闭合表示该层是不可见的。
    • 如果没有眼形图标，该层通常会继承其父级的可见性。（如果层没有嵌套，父级就是文档正文，而文档正文始终是可见的。）另外，如果未指定可见性，则不会显示眼形图标（这在属性检查器中表示为“默认”可见性）。
      这是所描述的功能的图片。
若要同时更改所有层的可见性，请执行以下操作：
  1. 选择“窗口”>“其他”>“层”，打开“层”面板。
  2. 单击位于列顶部的标头眼形图标。

    3. 备注： 此过程可以将所有层设置为“可见”或“隐藏”，但不能设置为“继承”。

相关主题

有关设置新层默认可见性的信息，请参见设置层参数。


将表和层用于布局

某些 Web 设计人员不愿意使用表或布局视图来创建布局（请参见使用表格显示内容和在布局视图中对页进行布局），而倾向于使用层和表。利用Dreamweaver，您可以使用层创建布局，然后（如果您希望这样）将层转换为表（因为 3.0 浏览器不支持层）。您可以在层和表之间来回转换，以调整布局并优化网页设计。

在模板文档或已应用模板的文档中，不能将层转换为表或将表转换为层，相反，应该在非模板文档中创建布局，然后在将该文档另存为模板之前进行转换。

您不能转换单个表或层，而只能将整个页的层转换为表以及将整个页的表转换为层。

如果要从使用层的文件生成单独的 3.0 浏览器兼容文件，请使用“文件”菜单中的“转换”选项（请参见转换为兼容 3.0 浏览器）。

备注： 从层转换为表可能会生成包含大量空单元格的表。


在层和表之间转换

您可以使用层创建布局，然后将层转换为表，以使您的布局可以在较早的浏览器中进行查看。

若要将层转换为表，请执行以下操作：
  1. 选择“修改”>“转换”>“层到表”。
  2. 在出现的对话框中，选择所需的选项。

    3. 有关更多信息，请参见设置“将层转换为表”对话框选项。

  3. 单击“确定”。

    4. 层转换为一个表。

若要将表转换为层，请执行以下操作：
  1. 选择“修改”>“转换”>“表到层”。
  2. 在出现的对话框中，选择所需的选项。

    3. 有关更多信息，请参见设置“将表转换为层”对话框选项。

  3. 单击“确定”。

    4. 表转换为层。空单元格不会转换为层（除非它们具有背景颜色）。

    备注： 位于表外的页面元素也会放入层中。


防止层重叠

由于表单元格不能重叠，Dreamweaver无法从重叠层创建表。如果您要将一个文档中的层转换为表以兼容 3.0 浏览器，请使用“防止重叠”选项来约束层的移动和定位，使层不会重叠。

若要防止层重叠，请执行以下操作之一：
  • 选择“层”面板上的“防止重叠”选项。
  • 选择“修改”>“排列”>“防止层重叠”。

当启用该选项后，可以在现有层前面创建层，在现有层上移动层或调整层大小，或者将某个层嵌套在现有层中。如果您在创建重叠层后激活此选项，请拖动每个重叠层以使其离开其他层。当您启用“防止层重叠”选项后，Dreamweaver不会自动修正页面上的现有重叠层。

当启用此选项和靠齐后，如果靠齐会使两个层重叠，则层将不会靠齐到网格。相反，层将靠齐到最接近的层的边缘。

备注： 即使在启用“防止重叠”选项后，仍可以执行某些操作来将层重叠。如果您使用“插入”菜单插入一个层，在属性检查器中输入数字或者通过编辑 HTML 源代码来重定位层，则可以在此选项已启用时使层重叠或嵌套。如果出现重叠，请在设计视图中拖动各重叠层以使其分离。


转换为兼容 3.0 浏览器

您可以将使用层或 CSS 的页转换为使用表和 HTML 标记，以使该页与 3.0 版的浏览器兼容。Dreamweaver 在保留初始文档的同时会另外创建一个已转换的文档。

通常，只有在您对初始文档的布局感到完全满意后，才应转换文档；否则，每当更改初始文档时，都必须转换该文档。

若要转换文件以用于 3.0 浏览器，请执行以下操作：
  1. 选择“文件”>“转换”>“兼容 3.0 浏览器”。
  2. 在出现的对话框中，选择是将层转换为表，将 CSS 样式转换为 HTML 标记（字符样式）还是这两种转换都执行。
  3. 单击“确定”。

Dreamweaver在一个新的无标题窗口中打开转换后的文件。如果选择“将层转换为表”或“两者皆是”，所有层都将被替换为一个表，它保留了内容的初始定位。

备注： 不能转换重叠的层，也不能转换页面外左侧或顶部的层。

如果选择“将 CSS 样式转换为 HTML 标记”或“两者皆是”，CSS 标记将在可能的情况下被替换为 HTML 字符样式。任何无法转换为 HTML 的 CSS 标记都将被删除。有关哪些样式将被转换以及哪些样式将被删除的信息，请参见CSS 到 HTML 标记转换表。

制作层动画的时间轴代码将被删除。与层无关的时间轴代码（例如对图像源文件执行的行为或更改）将继续按照指定的方式执行。时间轴会自动倒回第 1 帧。有关时间轴的更多信息，请参见使用时间轴动画移动层。


制作层动画

动态 HTML（即 DHTML）是指 HTML 与特定的脚本撰写语言的组合，您可以使用该脚本撰写语言更改 HTML 元素的样式或定位属性。在Dreamweaver中，时间轴使用动态 HTML 来更改层和图像在一段时间内的属性。使用时间轴可创建不需要任何 ActiveX 控件、插件或 Java Applet（但需要 JavaScript）的动画。

备注： 动态 一词在与 Web 相关的不同上下文中具有不同含义。不要将动态 HTML 与动态 Web 页的概念相混淆，后者表示在向访问者提供 Web 页之前由服务器端代码动态生成的 Web 页。有关创建动态页的更多信息，请参见Dreamweaver 动态页设计工作流程。

利用时间轴，您可以更改层的位置、大小、可见性和层叠顺序。（时间轴的层功能只能在 4.0 或更高版本的浏览器中使用。）对于要在页加载后执行的其他操作，时间轴也非常有用。例如，时间轴可以更改图像标签的源文件，因此一段时间内有不同的图像出现在页面上。

若要查看由时间轴生成的 JavaScript 代码，请打开文档窗口的代码视图。时间轴代码位于 MM_initTimelines 函数中（在文档的 head 部分的 script 标签中）。

当编辑包含时间轴的文档的 HTML 时，请确保没有移动、重命名或删除时间轴所引用的任何内容。


使用“时间轴”面板

“时间轴”面板显示层和图像的属性在一段时间内如何更改。选择“窗口”>“其他”>“时间轴”可打开“时间轴”面板。

“时间轴”弹出式菜单指定当前在“时间轴”面板中显示文档的哪些时间轴。

播放栏显示当前在文档窗口中显示时间轴的哪一帧。

帧编号指示帧的序号。“后退”和“播放”按钮之间的数字是当前帧编号。您可以通过设置帧的总数和每秒帧数 (fps) 来控制动画的持续时间。每秒 15 帧这一默认设置是比较适当的平均速率，可用于在通常的 Windows 和 Macintosh 系统上运行的大多数浏览器。

备注： 较快的速率可能不会提高性能。浏览器始终会播放动画的每一帧，即使它们无法达到指定的帧速率。如果帧速率超过浏览器可以支持的速率，则将被忽略。

上下文菜单包含各种与时间轴相关的命令。

“行为”通道是应该在时间轴中特定帧处执行的行为的通道。

动画条显示每个对象的动画的持续时间。一个行可以包含表示不同对象的多个条。不同的条无法控制同一帧中的同一对象。

关键帧是动画条中已经为对象指定属性（如位置）的帧。Dreamweaver会计算关键帧之间帧的中间值。小圆标记表示关键帧。

“动画”通道显示用于制作层和图像动画的条。


播放选项

下面是用于查看动画的播放选项。

倒带将播放栏移至时间轴中的第一帧。

后退将播放栏向左移动一帧。单击“后退”并按住鼠标按钮可向后播放时间轴。

播放将播放栏向右移动一帧。单击“播放”并按住鼠标按钮可向前播放时间轴。

自动播放使时间轴于当前页在浏览器中加载时自动开始播放。“自动播放”将一个行为附加到页的 body 标签，它在页加载时执行“播放时间轴”操作。

循环使当前时间轴于页在浏览器中打开时无限地循环。“循环”在动画的最后一帧之后将“转到时间轴帧”行为插入到“行为”通道中。在“行为”通道中双击该行为的标记可编辑此行为的参数并更改循环的次数。


使用时间轴动画移动层

最常见的时间轴动画都涉及到沿着一条轨迹移动层。时间轴只能移动层。若要使图像或文本移动，请使用插入栏上的“绘制层”按钮创建一个层，然后在该层中插入图像、文本或其他任何类型的内容（请参见在页面上创建层）。

时间轴也可以更改层和图像的其他属性；有关更多信息，请参见用时间轴更改图像和层的属性。

若要使用时间轴制作层动画，请执行以下操作：
  1. 将层移至它在动画开始时应处于的位置。
  2. 选择“窗口”>“其他”>“时间轴”。
  3. 选择您要制作动画的层。

    4. 确保您已选择了所需的元素。单击层标记或层选择柄，或者使用“层”面板选择一个层。有关更多信息，请参见操作层。当选定一个层后，它的周围将出现调整柄，如下图所示。
    这是所描述的功能的图片。

    在层中单击会将一个闪烁的插入点放入层中，但不会选定该层。

  4. 选择“修改”>“时间轴”>“在时间轴上添加对象”，或者简单地将选定层拖至“时间轴”面板中。

    5. 一个条将出现在时间轴的第一个通道中。层的名称将在该条中出现。

  5. 单击位于条末端的关键帧标记。
  6. 在页面上将层移至它在动画结束时应处于的位置。

    7. 将出现一条线，它显示文档窗口中动画的轨迹。

  7. 如果要让层沿曲线移动，请选择其动画条，然后按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 动画条中部的一个帧，从而在您单击的帧处添加一个关键帧，或者单击动画条中部的一个帧并从上下文菜单中选择“添加关键帧”。

    8. 重复此步骤，定义其他关键帧。

  8. 按住“播放”按钮，预览页面上的动画。

    9. 重复此过程，在时间轴上添加其他层和图像并创建更为复杂的动画。


通过拖动轨迹创建时间轴

如果要用复杂的轨迹创建动画，更为有效的方法可能是记录您拖动层时经过的轨迹，而不是创建各个关键帧。

若要通过拖动轨迹来创建时间轴，请执行以下操作：
  1. 选择一个层。
  2. 将该层移至它在动画开始时应处于的位置。

    3. 确保您已选定该层；如果插入点位于该层中，则说明尚未选定该层。若要选择一个层，请单击层标记或层的选择柄，或者使用“层”面板。有关更多信息，请参见操作层。

  3. 选择“修改”>“时间轴”>“记录层的轨迹”。
  4. 在页面上拖动层以创建轨迹。
  5. 当到达动画应停止的点时释放该层。

    6. Dreamweaver在时间轴上添加一个动画条，其中包含适当数量的关键帧。

  6. 在“时间轴”面板中，单击“倒带”按钮；然后按住“播放”按钮预览动画。


修改时间轴

定义完时间轴的基本组成部分后，可以进行一些更改，如添加和删除帧、更改动画开始时间等。

若要修改时间轴，请执行以下任一操作：

若要使动画的播放时间更长，请将结束帧标记向右拖动。动画中的所有关键帧都会移动，以保持它们的相对位置不变。若要防止其他关键帧移动，请按住 Alt 键并拖动 (Windows) 或按住 Option 键并拖动 (Macintosh) 结束帧标记。

  • 若要使层更早或更晚地到达某一关键帧位置，请在动画条中将关键帧向左或向右移动。
  • 若要更改动画的开始时间，请选择一个或多个与该动画关联的动画条（按 Shift 可一次选择多个动画条），然后向左或向右移动。
  • 若要移动整个动画轨迹的位置，请选择整个动画条，然后在页面上拖动该对象。Dreamweaver会调整所有关键帧的位置。在整个动画条上所做出的任何更改将更改所有关键帧。
  • 若要在时间轴上添加或删除帧，请选择“修改”>“时间轴”>“添加帧”或“修改”>“时间轴”>“删除帧”。
  • 若要使时间轴于页在浏览器中打开时自动播放，请单击“自动播放”。“自动播放”会向页附加一个行为，该行为将在页加载时执行“播放时间轴”操作。
  • 若要使时间轴连续循环，请单击“循环”。“循环”将“转到时间轴帧”操作插入到动画最后一帧后的“行为”通道。您可以编辑此行为的参数以定义循环的次数。


用时间轴更改图像和层的属性

除了用时间轴移动层之外，您还可以更改层的可见性、大小和层叠顺序并更改图像的源文件。

若要用时间轴更改图像和层的属性，请执行以下操作：
  1. 在“时间轴”面板中，执行以下操作之一：
    • 在控制要更改的对象的动画条中选择一个现有关键帧。（起始帧和结束帧始终是关键帧。）
    • 单击动画条中部的一个帧并选择“修改”>“时间轴”>“添加关键帧”，创建一个新的关键帧。或者，可以通过按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 动画条中的一个帧来创建一个新的关键帧。
  2. 通过执行以下操作之一定义对象的新属性：
    • 若要更改图像的源文件，请单击属性检查器中“源文件”文本框旁的文件夹图标，然后浏览到新图像并将其选定。
    • 若要更改层的可见性，请从属性检查器“可见性”文本框中的弹出式菜单选择“继承”、“可见”或“隐藏”。或者，您也可以使用“层”面板中的眼形图标。请参见更改层可见性。
    • 若要更改层的大小，请拖动该层的大小调整柄或在属性检查器的“宽”和“高”文本框中输入新的值。并非所有浏览器都会动态更改层的大小。
    • 若要更改层的层叠顺序，请在“Z 轴”文本框中输入新值，或使用“层”面板更改当前层的层叠顺序（请参见更改层的层叠顺序）。
  3. 按住“播放”按钮以查看动画。


使用多个时间轴

与尝试用一个时间轴控制页面上的所有操作相比，使用单独的时间轴来控制页的各个离散部分会更容易一些。例如，一个页可能包含多个互动元素，每个元素都触发不同的时间轴。

若要管理多个时间轴，请执行以下任一操作：
  • 若要新建时间轴，请选择“修改”>“时间轴”>“添加时间轴”。
  • 若要删除选定的时间轴，请选择“修改”>“时间轴”>“删除时间轴”。这将永久删除选定时间轴中的所有动画。
  • 若要重命名选定时间轴，请选择“修改”>“时间轴”>“重命名时间轴”，或者在“时间轴”面板的“时间轴”弹出式菜单中输入新的名称。
  • 若要在“时间轴”面板中查看另一个时间轴，请从“时间轴”面板的“时间轴”弹出式菜单中选择一个新的时间轴。


拷贝和粘贴动画

一旦有您喜爱的动画序列，就可以将其拷贝并粘贴到当前时间轴的另一区域、同一文档中的另一时间轴或者另一文档中的时间轴。您还可以同时拷贝并粘贴多个序列。

若要剪切（或拷贝）并粘贴动画序列，请执行以下操作：
  1. 单击一个动画条以选择一个序列。若要选择多个序列，请按住 Shift 键并单击多个动画条；若要选择所有序列，请按 Ctrl +A 键 (Windows) 或 Command+A 键 (Macintosh)。
  2. 拷贝或剪切选定内容。
  3. 执行以下操作之一：
    • 将播放栏移至当前时间轴中的另一处。
    • 从“时间轴”弹出式菜单中选择另一个时间轴。
    • 打开另一个文档或创建一个新文档，然后在“时间轴”面板中单击。
  4. 将选定内容粘贴到时间轴中。

    5. 同一对象的动画条不能重叠，因为一个层不能同时处于两个位置（一个图像也不能同时具有两个不同的源）。如果您所粘贴的动画条与同一对象的另一动画条重叠，Dreamweaver会自动将选定内容移至第一个不重叠的帧。

在将动画序列粘贴到另一文档时，应牢记两条原则：

  • 如果您拷贝层的动画序列且新文档包含同名的层，Dreamweaver 会将动画属性应用于新文档中的现有层。
  • 如果您拷贝层的动画序列且新文档不包含同名的层，Dreamweaver会将层和它的内容随动画序列一起从初始文档中拷贝下来。若要将粘贴的动画序列应用于新文档中的另一个层，请从上下文菜单中选择“更改对象”并从弹出式菜单中选择第二个层的名称。如果需要，删除所粘贴的层。请参见将动画序列应用于另一对象。


将动画序列应用于另一对象

为了节约时间，您可以只创建一次动画序列，然后将其应用于文档中剩余的每个层。

若要将现有动画序列应用于其他对象，请执行以下操作：
  1. 在“时间轴”面板中，选择动画序列并将其拷贝。
  2. 单击“时间轴”面板的任一帧，然后在该帧处粘贴动画序列。
  3. 右击 (Windows) 或按住 Ctrl键并单击 (Macintosh) 粘贴的动画序列，然后从上下文菜单中选择“更改对象”。
  4. 在出现的对话框中，从弹出式菜单中选择另一对象并单击“确定”。
  5. 对于要遵循同一动画序列的其他所有对象，重复第 2 步到第 4 步。

创建动画序列后，您也可以改变关于制作哪一个层的动画的决定；只需执行上面的第 3 步和第 4 步即可（不必进行拷贝或粘贴）。


重命名时间轴

若要重命名当前在“时间轴”面板中显示的时间轴，请执行以下操作：
  1. 选择“修改”>“时间轴”>“重命名时间轴”。
  2. 在“重命名时间轴”对话框中输入新的名称。

如果您的文档包含“播放时间轴”行为操作（例如，如果它包含访问者必须单击才能启动时间轴的按钮），则必须编辑该行为以反映新的时间轴名称。


时间轴动画小技巧

以下建议可以提高动画的性能并使动画更易于创建：

  • 显示和隐藏层，而不是更改多图像动画的源文件。由于新的图像必须进行下载，所以切换图像的源文件会降低动画的速度。如果所有图像都在动画运行前在隐藏层中同时下载，将不会出现明显的停顿，并且不会缺少图像。
  • 扩展动画条以创建更顺畅的动作。如果动画断断续续并且图像在不同位置之间跳动，请拖动该层动画条的结束帧，使动作延伸到更多的帧。通过延长动画条，可以在运动的开始点和结束点之间创建更多的数据点，同时也会使对象更为缓慢地移动。请尝试增加每秒帧数 (fps) 以提高速度，但应注意在普通系统上运行的大多数浏览器都不能支持超过 15 fps 的动画速度。请在不同的系统上用不同的浏览器对动画进行测试，以找到最佳的设置。
  • 不要制作大型位图的动画。制作大型图像的动画会导致动画速度减慢。相反，应创建合成图像，并移动图像中较小的部分。例如，可以通过仅制作汽车轮胎的动画来显示汽车的运动。
  • 创建简单的动画。不要创建对当前浏览器要求过高的动画。即使在系统或 Internet 性能降低时，浏览器始终会播放时间轴动画中的每一帧。


使用行为操作制作层动画

将以下行为操作附加到链接、按钮或其他对象，以控制时间轴和层。若要创造有吸引力的效果，可以在“行为”通道中放置包含这些操作的行为。例如，您可以让时间轴自行停止。有关更多信息，请参见第 693页的“将行为附加到时间轴” 和第 689页的“使用 JavaScript 行为” 。

拖动层让访问者拖动层。使用该操作可创建拼板游戏、滑块控件以及其他可移动的用户界面元素。请参见第 699页的“拖动层” 。

显示隐藏层显示、隐藏或恢复一个或多个层的默认可见性。对于在访问者与页交互时显示信息方面，此操作相当有用。请参见第 710页的“显示－隐藏层” 。

播放时间轴和停止时间轴让访问者通过单击链接或按钮来启动和停止时间轴。当访问者指向链接、图像或其他对象时，这些操作也可以自动启动和停止时间轴。请参见第 717页的““播放时间轴”和“停止时间轴”” 。

跳转到时间轴上某帧使时间轴跳转到某个帧。“时间轴”面板上的“循环”复选框在动画的最后一帧后添加“跳转到时间轴上某帧”操作，使其转到第 1 帧并重新开始播放动画。请参见第 716页的“转到时间轴帧” 。

设置层文本将页面上现有层的内容和格式设置替换为您指定的内容。其内容可以包含任何有效的 HTML。请参见第 708页的“设置层文本” 。


参考资料

本节提供有关在本章介绍的对话框和检查器的信息。


设置“层参数选择”对话框选项

此对话框用于设置层参数选择。

若要填写“层参数选择”对话框，请执行以下操作：

  1. 指定以下任一选项：

    2. 标签设置在创建层时 Dreamweaver 要使用的 HTML 标签。其选项为 div（默认）和 span。

    可见性确定层在默认情况下是否可见。其选项为“默认”、“继承”、“可见”和“隐藏”。有关这些选项的更多信息，请参见设置层属性。

    宽和高指定您使用“插入”>“层”创建的层的默认宽度和高度（以像素为单位）。

    背景颜色指定默认的背景颜色。请从颜色选择器中选择颜色。

    背景图像指定默认的背景图像。单击“浏览”可在计算机上查找图像文件。

    嵌套：在层中创建时嵌套指定从现有层边界内的某点开始绘制的层是否应该是嵌套层。当绘制层时，按下 Alt 键 (Windows) 或 Option 键 (Macintosh) 可临时更改此设置。

    Netscape 4 兼容性：插入层时添加调整大小修复在文档的 head 内容中插入 JavaScript 代码以修正 Netscape 4 浏览器中的一个已知问题，该问题使层在访问者调整浏览器窗口大小时失去它们的定位。每当调整浏览器窗口大小时，JavaScript 会强制页重新加载，从而将层重分配到正确的位置。您也可以手动添加或删除 JavaScript 代码，方法是选择“命令”>“添加/删除 Netscape 调整大小修复”。

  2. 单击“确定”。

相关主题

设置层参数


设置“网格设置”对话框选项

此对话框用于编辑网格设置。

若要填写“网格设置”对话框，请执行以下操作：
  1. 根据需要设置以下选项：

    2. 颜色指定网格线的颜色。请单击色样表并从颜色选择器中选择一种颜色，或者在文本框中键入一个十六进制数字。

    显示网格使网格在设计视图中可见。

    靠齐到网格使页面元素靠齐到网格线。

    间距控制网格线的间距。在文本框中输入一个数字并从菜单中选择“像素”、“英寸”或“厘米”。

    显示指定网格线是显示为线条还是显示为点。

  2. 单击“应用”可应用更改而不关闭对话框，单击“确定”可应用更改并关闭对话框。

    3. 备注： 如果未选择“显示网格”，将不会显示网格，并且看不到更改。

相关主题

将层靠齐到网格

使用颜色


设置层属性

使用属性检查器可查看和设置层的属性。

若要设置层的属性，请执行以下操作：
  1. 设置以下任一选项：

    2. 层 ID 用于指定一个名称，以便在“层”面板和 JavaScript 代码中标识该层。请输入一个名称。只应使用标准的字母数字字符，而不要使用空格、连字符、斜杠或句号等特殊字符。每个层都必须有它自己的唯一名称。

    左和上（左侧和顶部）指定层的左上角相对于页面（如果嵌套，则为父层）左上角的位置。

    宽和高指定层的宽度和高度。

    备注： 如果层的内容超过指定大小，层的底边缘（按照在Dreamweaver设计视图中的显示）会延伸以容纳这些内容。（如果“溢出”属性没有设置为“可见”，那么当层在浏览器中出现时，底边缘将不会延伸。）

    位置和大小的默认单位为像素 (px)。您也可以指定以下单位：pc (pica)、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（父层相应值的百分比）。这些缩写必须紧跟值，中间不留空格：例如，3mm 表示 3 毫米。

    Z 轴确定层的 z 轴（即层叠顺序）。在浏览器中，编号较大的层出现在编号较小的层的前面。值可以为正，也可以为负。当更改层的层叠顺序时，使用“层”面板要比输入特定的 z 轴更为简便（请参见更改层的层叠顺序）。

    Netscape 层（使用 layer 或 ilayer 标签的层）可以相对于页面上的其他层进行层叠。当您选择 Netscape 层时，属性检查器的右下角会出现两个附加的选项。请从右下角中的新弹出式菜单选择另一个层的名称（只有已定义的层名称才会出现在此菜单中）；然后使用上/下选项定义指定层应出现在当前层之上（之前）还是当前层之下（之后）。请注意，不能同时为某一给定层指定“上/下”层叠顺序和 z 轴。

    可见性指定该层最初是否是可见的。请从下列选项中选择：

    • “默认”不指定可见性属性。当未指定可见性时，大多数浏览器都会默认为“继承”。
    • “继承”使用该层父级的可见性属性。
    • “可见”显示该层的内容，而不管父级的值是什么。
    • “隐藏”隐藏这些层的内容，而不管父级的值是什么。请注意，用 ilayer 创建的隐藏层会像它们是可见层一样占用相同的空间。

      • 使用脚本撰写语言（如 JavaScript）可控制可见性属性并动态地显示层的内容。

      背景图像指定层的背景图像。单击其文件夹图标可浏览到一个图像文件并将其选定。

      背景颜色指定层的背景颜色。如果将此选项留为空白，则可以指定透明的背景。

      标签指定用来定义该层的 HTML 标签。

      溢出（仅限 div 和 span）控制当层的内容超过层的指定大小时如何在浏览器中显示层。“可见”指示在层中显示额外的内容；实际上，该层会通过延伸来容纳额外的内容。“隐藏”指定不在浏览器中显示额外的内容。“滚动”指定浏览器应在层上添加滚动条，而不管是否需要滚动条。“自动”使浏览器仅在需要时（即，当层的内容超过其边界时）才显示层的滚动条。

    备注： 溢出选项在不同的浏览器中具有不同程度的支持。

    使用左、上或页 X、页 Y（仅限 layer 和 ilayer）用于指定是相对于层的父级还是相对于页来定位层。“左、上”选项相对于层父级的左上角来放置层。“页 X、页 Y”选项相对于页面左上角将层放置于某一绝对位置，而不考虑父层的位置。

    剪辑定义层的可见区域。指定左侧、顶部、右侧和底边坐标可在层的坐标空间中定义一个矩形（从层的左上角开始计算）。层经过“剪辑”后，只有指定的矩形区域才是可见的。例如，若要使一个层中 50 像素宽 75 像素高的矩形区域可见而其他内容均不可见，请将“左”设置为 0，将“上”设置为 0，将“右”设置为 50 并将“下”设置为 75。

    备注： 虽然层叠样式表规范为 clip 指定了不同的语义，但Dreamweaver解释 clip 的方式与大多数浏览器相同。

    源文件（仅限 layer 和 ilayer）用于在层中显示另一个 HTML 文档。单击其文件夹图标可浏览到该文档并将其选定。请注意，Dreamweaver不在层中显示另一文档。

  2. 如果已经在文本框中输入值，请按 Tab 键或 Enter 键 (Windows) 或者 Return 键 (Macintosh) 应用该值。

相关主题

查看和设置层属性


设置多个层的属性

使用属性检查器可查看和设置层的属性。

若要同时设置多个层的属性，请执行以下操作：
  1. 设置以下任一选项：

    2. 左和上（左侧和顶部）指定层的左上角相对于页（如果嵌套，则为父层）的左上角的位置。

    宽和高指定层的宽度和高度。

    备注： 如果任何层的内容超过指定的大小，该层的底边缘（按照在Dreamweaver设计视图中的显示）会延伸以容纳这些内容。（如果“溢出”属性没有设置为“可见”，那么当层在浏览器中出现时，底边缘将不会延伸。）

    位置和大小的默认单位为像素 (px)。您也可以指定以下单位：pc (pica)、pt（点）、in（英寸）、mm（毫米）、cm（厘米）或 %（父层相应值的百分比）。这些缩写必须紧跟值，中间不留空格：例如，3mm 表示 3 毫米。

    可见性指定这些层最初是否是可见的。请从下列选项中选择：

    • “默认”不指定可见性属性。当未指定可见性时，大多数浏览器都会默认为“继承”。
    • “继承”使用这些层的父级的可见性属性。
    • “可见”显示这些层的内容，而不管父级的值是什么。
    • “隐藏”隐藏这些层的内容，而不管父级的值是什么。请注意，用 ilayer 创建的隐藏层会像它们是可见层一样占用相同的空间。

      • 使用脚本撰写语言（如 JavaScript）可控制可见性属性并动态地显示层的内容。

      标签指定用来定义这些层的 HTML 标签。

      背景图像指定这些层的背景图像。单击其文件夹图标可浏览到一个图像文件并将其选定。

      背景颜色指定这些层的背景颜色。如果将此选项留为空白，则可以指定透明的背景。

  2. 如果已经在文本框中输入值，请按 Tab 键或 Enter 键 (Windows) 或者 Return 键 (Macintosh) 应用该值。

相关主题

查看和设置多个层的属性


设置“将层转换为表”对话框选项

此对话框用于将层转换为表，以更好地兼容较早的浏览器。

若要填写“将层转换为表”对话框，请执行以下操作：

  1. 指定以下任一选项：

    2. 最精确为每个层创建一个单元格，并附加保留层之间的空间所必需的任何单元格。

    最小：折叠空单元格指定如果层定位在指定数目的像素内，则层的边缘应对齐。如果选择此选项，结果表将包含较少的空行和空列，但可能不与您的布局精确匹配。

    使用透明 GIF 用透明的 GIF 填充表的最后一行。这将确保该表在所有浏览器中以相同的列宽显示。

    当启用此选项后，不能通过拖动表列来编辑结果表。当禁用此选项后，结果表将不包含透明 GIF，但在不同的浏览器中可能会具有不同的列宽。

    置于页面中央将结果表放置在页面的中央。

    如果禁用此选项，表将在页面的左边缘开始。

  2. 选择所需的布局工具，然后单击“确定”。

相关主题

将表和层用于布局


设置“将表转换为层”对话框选项

此对话框用于将层转换为表，以更好地兼容较早的浏览器。

若要填写“将表转换为层”对话框，请执行以下操作：

  1. 指定以下任一选项：

    2. 显示网格和靠齐到网格使您能够使用网格来协助将层定位（请参见将层靠齐到网格）。

    防止层重叠在创建、移动层和调整层大小时约束层的位置，使层不会重叠（请参见防止层重叠）。

    显示层面板显示“层”面板（请参见关于“层”面板）。

  2. 单击“确定”。

表转换为层。空单元格不会转换为层（除非它们具有背景颜色）。

备注： 位于表外的页面元素也会放入层中。

相关主题

将表和层用于布局

上一页


使用多页

将各页链接到一起，并在各页之间重复使用设计元素和布局。然后测试您的站点。

此部分包含以下各章：

  • 链接与导航
  • 管理站点资源、库和模板
  • 测试站点


链接与导航

在设置了存储 Web 站点文档的 Dreamweaver 站点和创建了 HTML 页后，您需要创建从您的文档到其他文档的连接。

Macromedia Dreamweaver MX 提供多种创建超文本链接的方法，可创建到文档、图像、多媒体文件或可下载软件的链接。可以建立到文档内任意位置的任何文本或图像（包括标题、列表、表、层或框架中的文本或图像）的链接。

若要直观地查看文件是如何链接在一起的，可使用站点地图。在站点地图中，可以向站点添加新文档、创建和删除文档链接以及检查到相关文件的链接（请参见使用站点地图）。

链接的创建与管理有几种不同的方法。有些 Web 设计者喜欢在工作时创建一些指向尚未建立的页面或文件的链接；而另一些设计者则倾向于首先创建所有的文件和页面，然后再添加相应的链接。另一种管理链接的方法是创建代替最终文件的“占位符”页面，使用这种方法可以快速添加链接，而且可在实际完成所有页面之前对这些链接进行检查。有关检查链接的更多信息，请参见检查页面或站点内的链接。

本章包含以下几节：

关于文档位置和路径

创建链接

管理链接

创建跳转菜单

创建导航条

创建图像地图

向链接附加行为

下一页


关于文档位置和路径

掌握从作为链接起点的文档到作为链接目标的文档之间的文件路径，对于创建链接至关重要。

每个网页都有一个唯一的地址，称作统一资源定位器 (URL)。（有关 URL 的更多信息，请参见 WWW 联合会 (World Wide Web Consortium) 网页上的命名和编址。）不过，当创建本地链接（即从一个文档到同一站点上另一个文档的链接）时，通常不指定要链接到的文档的完整 URL，而是指定一个起自当前文档或站点根文件夹的相对路径。

链接路径的三种类型如下所示：

  • 绝对路径（例如 http://www.macromedia.com/support/dreamweaver/contents.html）。请参见绝对路径。
  • 文档相对路径（例如 dreamweaver/contents.html）。请参见文档相对路径。
  • 站点根目录相对路径（例如 /support/dreamweaver/contents.html）。请参见站点根目录相对路径。

使用 Dreamweaver，可以方便地选择要为链接创建的文档路径的类型。请参见链接文件和文档。

备注： 最好使用您最喜欢和最得心应手的链接类型：站点相对路径或文档相对路径。与键入路径相比，浏览到链接能确保输入的路径始终正确。


绝对路径

绝对路径提供所链接文档的完整 URL，而且包括所使用的协议（如对于网页，通常使用 http://）。例如，http://www.macromedia.com/support/dreamweaver/contents.html 就是一个绝对路径。

必须使用绝对路径，才能链接到其他服务器上的文档。尽管对本地链接（即到同一站点内文档的链接）也可使用绝对路径链接，但不建议采用这种方式，因为一旦将此站点移动到其他域，则所有本地绝对路径链接都将断开。对本地链接使用相对路径还能在需要在站点内移动文件时，提供更大的灵活性。

备注： 当插入图像（非链接）时：如果使用图像的绝对路径，而图像又驻留在远程服务器而不在本地硬盘驱动器上，则将无法在文档窗口中查看该图像。此时，必须在浏览器中预览该文档才能看到它。只要情况允许，对于图像，请使用文档或站点根目录相对路径。有关更多信息，请参见插入图像。


文档相对路径

文档相对路径对于大多数 Web 站点的本地链接来说，是最适用的路径。在当前文档与所链接的文档处于同一文件夹内，而且可能保持这种状态的情况下，文档相对路径特别有用。文档相对路径还可用来链接到其他文件夹中的文档，方法是利用文件夹层次结构，指定从当前文档到所链接的文档的路径。

文档相对路径的基本思想是省略掉对于当前文档和所链接的文档都相同的绝对 URL 部分，而只提供不同的路径部分。

  • 若要链接到与当前文档处在同一文件夹中的其他文件，只需输入文件名即可。
  • 若要链接到当前文档所在文件夹的子文件夹中的文件，只需提供子文件夹的名称，后跟一个正斜杠 (/)，再后是该文件的名称即可。
  • 若要链接到当前文档所在文件夹的父文件夹中的文件，请在文件名前添加 ../（此处的 “..”表示“在文件夹层次结构中上移一级”）。

例如，假设一个站点的结构如下：

若要从 contents.html 链接到其他文件：
  • 若要从 contents.html 链接到 hours.html（两个文件在同一文件夹中），文件名就是相对路径：hours.html。
  • 若要链接到 tips.html（在名为 resources 的子文件夹中），可使用相对路径 resources/tips.html。

    • 每个正斜杠 (/) 表示在文件夹层次结构中下移一级。

  • 若要链接到 index.html（在父文件夹中，contents.html 向上一级），可使用相对路径 ../index.html。

    • 每个 ../ 表示在文件夹层次结构中上移一级。

  • 若要链接到 catalog.html（在父文件夹的其他子文件夹中），可使用相对路径 ../products/catalog.html。

    • 其中 ../ 向上移至父文件夹；products/ 向下移至 products 子文件夹中。

备注： 应始终先保存新文件，然后再创建文档相对路径，因为如果没有一个确切的起点，文档相对路径无效。如果在保存文件之前创建文档相对路径，Dreamweaver 将临时使用以 file:// 开头的绝对路径，直至该文件被保存；当保存文件时，Dreamweaver 将 file:// 路径转换为相对路径。

若成组地移动一组文件，例如移动整个文件夹时，该文件夹内所有文件保持彼此间的相对路径不变，此时不需要更新这些文件间的文档相对链接。但是，当移动含有文档相对链接的单个文件，或者移动文档相对链接所链接到的单个文件时，则必须更新这些链接。（如果使用“站点”面板移动或重命名文件，则 Dreamweaver 将自动更新所有相关链接。）


站点根目录相对路径

站点根目录相对路径提供从站点的根文件夹到文档的路径。如果在处理使用多个服务器的大型 Web 站点，或者在使用承载有多个不同站点的服务器，则可能需要使用这些类型的路径。不过，如果您不熟悉此类型的路径，最好坚持使用文档相对路径。

站点根目录相对路径以一个正斜杠开始，该正斜杠表示站点根文件夹。例如，/support/tips.html 是文件 (tips.html) 的站点根目录相对路径，该文件位于站点根文件夹的 support 子文件夹中。

在某些 Web 站点中，需要经常在不同文件夹之间移动 HTML 文件，在这种情况下，站点根目录相对路径通常是指定链接的最佳方法。移动含有根目录相对链接的文档时，不需要更改这些链接；例如，如果 HTML 文件对相关文件（如图像）使用根目录相对链接，则移动 HTML 文件后，其相关文件链接依然有效。但是，如果移动或重命名根目录相对链接所链接的文档，即使文档彼此之间的相对路径没有改变，仍必须更新这些链接。

例如，如果移动某个文件夹，则指向该文件夹中文件的所有根目录相对链接都必须更新。（如果使用“站点”面板移动或重命名文件，则 Dreamweaver 将自动更新所有相关链接。）

若要使用站点根目录相对路径，请首先在 Dreamweaver 中定义一个本地文件夹，方法是选择一个本地根文件夹，作为服务器上文档根目录的等效项（请参见设置 Dreamweaver 站点）。

Dreamweaver 用该文件夹来确定文件的站点根目录相对路径。

备注： 根目录相对链接由服务器（而非浏览器）进行解释，因此如果在浏览器中打开一个使用根目录相对链接的本地页面，而没有在 Dreamweaver 中使用“在浏览器中预览”，则这些链接不起作用。当使用“在浏览器中预览”命令预览使用根目录相对链接的文档时，Dreamweaver 临时将这些链接（仅仅是所预览文件中包含的链接）转换为使用文档相对路径。不过，一次只能预览一页使用根目录相对链接的页面，如果单击所预览页面上的链接继续向下浏览，则由于下一页的根目录相对链接尚未转换，因而浏览器无法继续打开此类链接。在框架集中预览使用根目录相对链接的页面存在类似问题。

若要预览使用根目录相对链接的一组页面，请执行下列操作之一：
  • 将这些文件放在远程服务器上，并从该处查看这些文件。
  • （仅适用于 Windows）选择“编辑”>“参数选择”，再从左侧的类别列表中选择“在浏览器中预览”，然后选择“使用本地服务器预览”。

    • 备注： 若要使用此选项，则本地计算机上必须正在运行 Web 服务器。


创建链接

用于创建超文本链接的 HTML 标签称作锚记或 a 标签。Dreamweaver 为从其创建链接的对象、文本或图像创建锚记。使用 a href 标签可以创建链接到其他文档和文件的链接，以及链接到单个文档特定位置的链接。

例如，如果在“文档”窗口选择文本 Home Page，然后创建一个到文件 home.htm 的链接，则该链接的 HTML 源代码类似如下所示：

<a href="home.htm">Home Page</a>

如果创建链接到文档中特定位置的链接，请首先创建一个命名锚记
（例如，a name="MainMenu"）。然后在该页内创建一个引用该命名锚记的链接
（例如，a href="#MainMenu"）。

创建链接之前，一定要清楚文档相对路径、站点根目录相对路径以及绝对路径的工作方式（请参见关于文档位置和路径）。

在一个文档中可以创建几种类型的链接：

  • 链接到其他文档或文件（如图形、影片、PDF 或声音文件）的链接。请参见链接文件和文档。
  • 命名锚记链接，此类链接跳转至文档内的特定位置。请参见链接到文档中的特定位置。
  • 电子邮件链接，此类链接新建一个收件人地址已经填好的空白电子邮件。请参见创建超链接。
  • 空链接和脚本链接，此类链接使您能够在对象上附加行为，或者创建执行 JavaScript 代码的链接。请参见创建空链接和脚本链接。

使用 Dreamweaver，可以用多种方式创建本地链接（指同一站点中文档之间的链接）：

  • 使用站点地图查看、创建、更改或删除链接。
  • 在“文档”窗口中，选择文本或页面元素，然后使用“修改”>“建立链接”选择要链接到的文件。
  • 使用属性检查器，方法是选择文档中的文本或页面元素，然后使用属性检查器文件夹图标，或者使用“点到文件”图标，来选择要链接到的文件，或者键入该文件的路径。

    • 备注： 键入指向某个文件的 URL 或路径，可能会导致输入的路径不正确，从而造成链接不起作用。若要确保路径正确无误，请使用文件夹图标浏览到所需链接。

  • 在“文档”窗口中，选择文本或页面元素，从上下文菜单中选择“建立链接”，然后选择要链接到的文件。

若要创建外部链接（到其他站点上文档的链接），必须在属性检查器中键入绝对路径（包括适当的协议）。创建外部链接时，一定要输入完整的路径（包括 http://）。


链接文件和文档

属性检查器和“点到文件”图标可用于创建从图像、对象或文本到其他文档或文件的链接。有关使用站点地图创建链接的信息，请参见在站点地图中创建和修改链接。

若要使用属性检查器的文件夹图标或链接文本框链接文档：
  1. 在“文档”窗口的“设计”视图中选择文本或图像。
  2. 打开属性检查器（“窗口”>“属性”），然后执行下列操作之一：
    这是所描述的功能的图片。
    • 单击“链接”文本框右侧的文件夹图标，以通过浏览选择一个文件。

      • 在 URL 域中显示链接文档的路径。使用“选择 HTML 文件”对话框中的“相对于”弹出式菜单，指示该路径是文档相对路径还是根目录相对路径，然后单击“选择”。

      备注： 在“相对于”域中更改路径类型后，Dreamweaver 将所做选择作为以后任何链接的默认路径类型，直至再次更改路径类型。

    • 在“链接”文本框中键入文档的路径和文件名。

      • 若要链接到站点内的文档，请输入文档相对路径或站点根目录相对路径。若要链接到站点外的文档，请输入包含协议（如 http://）的绝对路径。此种方法可用于输入尚未创建的文件的链接。

  3. 从“目标”弹出式菜单中，选择文档的打开位置。

    4. 若要使所链接的文档出现在当前窗口或框架以外的其他位置，可从属性检查器的“目标”弹出式菜单中选择一个选项：

    • _blank，在一个未命名的新浏览器窗口中载入所链接的文档。
    • _parent，在该链接所在框架的父框架或父窗口中载入所链接的文档。如果包含链接的框架不是嵌套框架，则所链接的文档载入整个浏览器窗口。
    • _self，在链接所在的同一框架或窗口中载入所链接的文档。此目标为默认值，因此通常不需要指定它。
    • _top，在整个浏览器窗口中载入所链接的文档，因而会删除所有框架。

      • 提示： 如果页面上的所有链接都设置为同一目标，则可以选择“插入”>“Head 标签”>“基础”，然后选择目标信息来指定该目标，这样只需设置一次即可。有关定位框架的信息，请参见控制具有链接的框架内容。

若要使用“点到文件”图标链接文档，请执行以下操作：
  1. 在“文档”窗口的“设计”视图中选择文本或图像。
  2. 拖动属性检查器中“链接”文本框右侧的“点到文件”图标，然后指向另一个打开的文档、已打开文档中的可见锚记，或者指向“站点”面板中的一个文档。

    3. “链接”文本框将更新，以显示该链接。

    备注： 只有当“文档”窗口中的文档未最大化时，才能链接到打开的文档。如果指向打开的文档，则在进行选择时，该文档移至屏幕的最前面。

  3. 释放鼠标按钮。
若要从已打开文档中的选定内容创建链接：
  1. 在“文档”窗口中选择文本。
  2. 按下 Shift 键，从选定内容处开始拖动。

    3. 在拖动过程中，出现“点到文件”图标。

  3. 指向其他打开的文档、已打开文档中的可见锚记，或者指向“站点”面板中的一个文档。

    4. 备注： 只有当“文档”窗口中的文档未最大化时，才能链接到打开的文档。如果指向打开的文档，则在进行选择时，该文档移至屏幕的最前面。

  4. 释放鼠标按钮。
若要使用站点地图和“点到文件”图标链接文档：
  1. 展开“站点”面板，然后通过按下“站点地图”图标并选择“地图”和“文件”，同时显示“站点文件”和“站点地图”视图。
  2. 在站点地图中选择一个 HTML 文件。

    3. 在该文件旁边出现“点到文件”图标。

  3. 拖动“点到文件”图标，并指向站点地图中另一个文件，或者指向“站点文件”视图中的某个本地文件。
  4. 释放鼠标按钮。

    5. 名称为所链接文件名称的超文本链接被置于所选 HTML 文件的底部。在构建站点并想快速创建跨站点的链接时，此方法尤其好用。


链接到文档中的特定位置

通过首先创建命名锚记，可使用属性检查器链接到文档的特定部分。命名锚记使您可以在文档中设置标记，这些标记通常放在文档的特定主题处或顶部。然后可以创建到这些命名锚记的链接，这些链接可快速将访问者带到指定位置。

创建到命名锚记的链接的过程分为两步。首先，创建命名锚记，然后创建到命名锚记的链接。

若要创建命名锚记，请执行以下操作：
  1. 在“文档”窗口的“设计”视图中，将插入点放在需要命名锚记的地方。
  2. 执行下列操作之一：
    • 选择“插入”>“命名锚记”。
    • 按下 Control+Alt+A（在 Windows 中）；或者按下 Command+Option+A（在 Macintosh 中）。
    • 在“插入”栏中选择“常用”选项卡，然后单击“命名锚记”按钮。

      • 出现“命名锚记”对话框。
      这是所描述的功能的图片。

  3. 在“锚记名称”域，键入该锚记的名称。

    4. 有关更多信息，请参阅设置“命名锚记”选项。

    锚记标记在插入点处出现。

    备注： 如果看不到锚记标记，可选择“查看”>“可视化助理”>“不可见元素”。

若要链接到命名锚记：
  1. 在“文档”窗口的“设计”视图中，选择要从其创建链接的文本或图像。
  2. 在属性检查器的“链接”文本框中，键入一个数字符号 (#) 和锚记名称。例如：
    • 若要链接到当前文档中的名为“top” 的锚记，请键入 #top。
    • 若要链接到同一文件夹内其他文档中的名为“top” 的锚记，请键入 filename.html#top。

      • 备注： 锚记名称区分大小写。

若要使用点到文件方法链接到命名锚记，请执行以下操作：
  1. 打开含有所需命名锚记的文档。

    2. 备注： 如果看不见锚记，可选择“查看”>“可视化助理”>“不可见元素”，使该锚记成为可见锚记。

  2. 在“文档”窗口的“设计”视图中，选择要从其创建链接的文本或图像。（如果这是其他打开文档，则必须切换到该文档。）
  3. 执行下列操作之一：
    • 单击属性检查器中“链接”文本框右侧的“点到文件”图标，然后将其拖到要链接到的锚记上：可以是同一文档中的锚记，也可以是其他打开文档中的锚记。
    • 在“文档”窗口中，按住 Shift 键进行拖动，从所选文本或图像拖动到要链接到的锚记：可以是同一文档中的锚记，也可以是其他打开文档中的锚记。


创建超链接

还可添加链接到其他文件的超链接文本。

若要使用“超链接”命令添加超链接：
  1. 将插入点放在文档中希望出现超链接的位置。
  2. 执行如下操作之一，显示“插入超链接”对话框：
    • 选择“插入”>“超链接”。
    • 选择“插入”栏上的“常用”选项卡，然后单击“超链接”按钮。

      • 出现“超链接”对话框。
      这是所描述的功能的图片。

  3. 完成此对话框的相关内容。

    4. 有关更多信息，请参阅设置超链接选项。

  4. 单击“确定”。


创建电子邮件链接

单击电子邮件链接时，该链接打开一个新的空白邮件窗口（使用的是与用户浏览器相关联的邮件程序）。在电子邮件消息窗口中，“收件人”域自动更新为显示电子邮件链接中指定的地址。

若要使用“插入电子邮件链接”命令创建电子邮件链接，请执行以下操作：
  1. 在“文档”窗口的“设计”视图中，将插入点放在希望出现电子邮件链接的位置，或者选择要作为电子邮件链接出现的文本或图像。
  2. 执行下列操作之一，插入该链接：
    • 选择“插入”>“电子邮件链接”。
    • 选择“插入”栏中的“通用”选项卡，然后单击“插入电子邮件链接”按钮。

      • 出现“电子邮件链接”对话框。
      这是所描述的功能的图片。

  3. 完成此对话框的相关内容。

    4. 有关更多信息，请参阅设置“电子邮件链接”选项。

  4. 单击“确定”。
若要使用属性检查器创建电子邮件链接：
  1. 在“文档”窗口的“设计”视图中选择文本或图像。
  2. 在属性检查器的“链接”文本框中，键入 mailto:，后面跟电子邮件地址。

    3. 在冒号和电子邮件地址之间不能键入任何空格。例如，键入 mailto:jdoe@macromedia2.com。


创建空链接和脚本链接

最为人所熟知的链接类型是链接到文档和命名锚记的链接（在链接文件和文档和链接到文档中的特定位置中分别作了说明），但除此之外，还有其他一些链接类型。

空链接是未指派的链接。空链接用于向页面上的对象或文本附加行为。创建空链接后，可向空链接附加行为，以便当鼠标指针滑过该链接时，交换图像或显示层。有关向对象附加行为的信息，请参见应用行为。

脚本链接执行 JavaScript 代码或调用 JavaScript 函数。它非常有用，能够在不离开当前网页的情况下为访问者提供有关某项的附加信息。脚本链接还可用于在访问者单击特定项时，执行计算、表单验证和其他处理任务。

若要创建空链接：
  1. 在“文档”窗口的“设计”视图中选择文本、图像或对象。
  2. 在属性检查器中，将 javascript:;（javascript 一词后依次接一个冒号和一个分号）键入“链接”文本框。
若要创建脚本链接：
  1. 在“文档”窗口的“设计”视图中选择文本、图像或对象。
  2. 在属性检查器的“链接”文本框中，键入 javascript:，后面跟一些 JavaScript 代码或函数调用。

    3. 例如，在“链接”文本框中键入 javascript:alert('This link leads to the index')，可生成这样一个链接：单击该链接时，会显示一个含有消息 This link leads to the index 的 JavaScript 警告框。

    备注： 因为在 HTML 中 JavaScript 代码放在双引号中（作为 href 属性的值），所以在脚本代码中必须使用单引号，或者可通过在双引号前添加反斜杠，将所有双引号“转义”（例如，\"This link leads to the index\"）。


管理链接

每当在本地站点内移动或重命名文档时，Dreamweaver 可更新起自以及指向文档的链接。当将整个站点（或其中完全独立的一个部分）存储在本地硬盘上时，此项功能最适用。Dreamweaver 不更改远程文件夹中的文件，除非将这些本地文件放在或者存回到远程服务器上。

若要在 Dreamweaver 中启用链接管理，请执行以下操作：
  1. 选择“编辑”>“参数选择”，或者选择“Dreamweaver”>“参数选择”(Mac OS X)。

    2. 出现“参数选择”对话框。

  2. 从左侧的分类列表中选择“常规”。

    3. 出现“常规”参数选择选项。
    这是所描述的功能的图片。

  3. 在“文档选项”部分，从“移动文件时更新链接”弹出式菜单中选择“总是”或者“提示”。

    4. 若选择“总是”，则每当移动或重命名选定文档时，Dreamweaver 将自动更新起自和指向该文档的所有链接。（有关删除文件的方法的详尽说明，请参见在整个站点范围内更改链接。）

    如果选择“提示”，Dreamweaver 将首先显示一个对话框，列出此更改影响到的所有文件。单击“更新”可更新这些文件中的链接，而单击“不更新”将保留原文件不变。

  4. 单击“确定”。

为了加快更新过程，Dreamweaver 可创建一个缓存文件，用以存储有关本地文件夹中所有链接的信息。在“站点定义”对话框中选择“缓存”选项，就会创建此缓存文件。以后在使用 Dreamweaver 添加、更改或删除到本地站点上文件的链接时，此缓存文件将以不可见的方式更新。

若要为站点创建缓存文件，请执行以下操作：
  1. 选择“站点”>“编辑站点”。

    2. 出现“编辑站点”对话框。

  2. 选择一个站点，然后单击“编辑”。
  3. 从左侧的类别列表中选择“本地信息”。

    4. “站点定义”对话框显示“本地信息”选项。

  4. 在“本地信息”类别中，选中“启用缓存”复选框。

启动 Dreamweaver 之后，第一次更改或删除指向本地文件夹中文件的链接时，Dreamweaver 会提示您载入缓存。如果单击“是”，则载入缓存，并且 Dreamweaver 会更新指向刚刚更改的文件的所有链接。如果单击“否”，则将所做更改记入缓存，但并不载入该缓存，而且 Dreamweaver 也不更新链接。

在较大型的站点上，载入此缓存可能需要一段时间，其中的大部分时间用于将本地站点上文件的时间戳与缓存中记录的时间戳进行比较，以确定缓存是否过期。如果没有在 Dreamweaver 之外更改任何文件，则当“停止”按钮出现时，可以放心地单击该按钮。

若要重新创建站点缓存：

在“站点”面板中，选择“站点”>“重建站点缓存”。


在站点地图中创建和修改链接

可以通过在站点地图中添加、更改和删除链接来修改站点的结构。Dreamweaver 自动更新站点地图以显示对站点所做的更改。

若要添加链接，请执行下列操作之一：
  • 将某个页面从 Windows 资源管理器或 Macintosh Finder 拖动到站点地图中的一页上。

    • 备注： 确保“站点”面板已停靠，然后单击“展开”箭头。按下“站点地图”按钮，然后选择“文件和地图”。

  • 在站点地图中选择一个 HTML 页面，如果在 Windows 中，则接着选择“站点”>“链接到已有文件”，如果在 Macintosh 中，则选择“站点”>“站点地图视图”>“链接到已有文件”，或者从上下文菜单中选择“链接到已有文件”。
  • 在站点地图中选择一个 HTML 页面，如果在 Windows 中，则接着选择“站点”>“链接到新文件”，如果在 Macintosh 中，则选择“站点”>“站点地图视图”>“链接到新文件”，或者从上下文菜单中选择“链接到新文件”。
  • 在站点地图中选择一个 HTML 页面，出现“点到文件”图标。将此图标拖动到想要链接的对象上：可以是“站点文件”视图中的文件、打开的 Dreamweaver 文档，也可以是桌面上打开文档中的命名锚记。

    • 备注： 有关更多信息，请参见链接文件和文档。

若要更改链接，请执行以下操作：
  1. 在站点地图中，选择要更改的链接所指向的页面（以便当前链接到此页面的文档指向其他页面），然后执行下列操作之一：
    • 选择“站点”>“更改链接”（在 Windows 中）；或者选择“站点”>“站点地图视图”>“更改链接”（在 Macintosh 中）。

      • 备注： 使用“站点”面板的“站点”菜单。

    • 右击（在 Windows 中）或者按下 Control 键的同时单击（在 Macintosh 中），然后从上下文菜单中选择“更改链接”。
  2. 通过浏览找到希望链接指向的文件，或者键入 URL。
  3. 单击“确定”。
若要删除链接，请执行下列操作之一：
  • 在站点地图中选择该页，然后选择“站点”>“删除链接”（在 Windows 中）；或者选择“站点”>“站点地图视图”>“删除链接”（在 Macintosh 中）。

    • 备注： 使用“站点”面板的“站点”菜单。

  • 在站点地图中选定该页，右击（在 Windows 中）或者按下 Control 键的同时单击（在 Macintosh 中），然后从上下文菜单中选择“删除链接”。

    • 删除链接不会删除该文件，但会从指向该链接的页面上的 HTML 源代码中删除该链接。

若要打开链接源：

在站点地图中选择一个文件，然后执行以下操作之一：

  • 选择“站点”>“打开链接源”（在 Windows 中）；或者选择“站点”>“站点地图视图”>“打开链接源”（在 Macintosh 中）。
  • 右击（在 Windows 中）或者按下 Control 键的同时单击（在 Macintosh 中），然后从上下文菜单中选择“打开链接源”。

    • 在“文档”窗口中打开属性检查器和含有此链接的源文件，同时该链接以高亮显示。


在整个站点范围内更改链接

除了每当移动或重命名文件时让 Dreamweaver 自动更新链接外，您还可以手动更改所有链接（包括电子邮件链接、FTP 链接、空链接和脚本链接），以指向其他位置。

任何时候都可使用此选项（例如，可能已经在整个站点内将“本月电影”这个词链接到了 /movies/july.html，而到了 8 月 1 日，则必须将那些链接更改为指向 /movies/august.html），不过此选项尤其适用于删除其他文件所链接到的某个文件。

若要在整个站点范围内更改链接，请执行以下操作：
  1. 在“站点”面板的“本地”视图中选择一个文件。

    2. 备注： 如果更改的是电子邮件链接、FTP 链接、空链接或脚本链接，则不需要选择文件。

  2. 选择“站点”>“更改站点内所有指定链接”。

    3. 出现“更改站点内所有指定链接”对话框。
    这是所描述的功能的图片。

  3. 完成此对话框的相关内容。

    4. 有关更多信息，请参阅设置“更改站点内所有指定链接”选项。

  4. 单击“确定”。

    5. Dreamweaver 更新链接到选定文件的所有文档，使这些文档指向新文件，并沿用文档已经使用的路径格式（例如，如果旧路径为文档相对路径，则新路径也为文档相对路径）。不论链接类型是文档相对链接还是根目录相对链接，Dreamweaver 都会自动更新该链接。

在整个站点范围内更改某个链接后，所选文件就成为独立文件（即本地硬盘上没有任何文件指向该文件）。这时可安全地删除此文件，而不会破坏本地 Dreamweaver 站点中的任何链接。

备注： 因为在本地进行这些更改，所以必须手动删除远程文件夹中的相应独立文件，然后放入或存回链接已经更改的所有文件；否则，站点的访问者将看不到这些更改。


创建跳转菜单

跳转菜单是文档中的弹出式菜单，对站点访问者可见，并列出链接到文档或文件的选项。可以创建到整个 Web 站点内文档的链接、到其他 Web 站点上文档的链接、电子邮件链接、到图形的链接，也可以创建到可在浏览器中打开的任何文件类型的链接。

跳转菜单可包含三个基本部分：

  • 菜单选择提示，如菜单项的类别说明，或一些指导信息等，例如“选择其中一项：”。（可选）
  • 所链接菜单项的列表：用户选择某个选项，则链接的文档或文件被打开。（必需）
  • “前往”按钮。（可选）


插入跳转菜单

若要在文档中插入跳转菜单，请使用“跳转菜单”表单对象。

若要创建跳转菜单，请执行以下操作：
  1. 打开一个文档，然后将插入点放在“文档”窗口中。
  2. 执行下列操作之一：
    • 选择“插入”>“表单对象”>“跳转菜单”。
    • 选择“插入”栏中的“表单”选项卡，然后单击“跳转菜单”按钮。

      • 出现“插入跳转菜单”对话框。
      这是所描述的功能的图片。

  3. 完成此对话框的相关内容。

    4. 有关更多信息，请参阅设置“插入跳转菜单”选项。

  4. 单击“确定”。

    5. 在文档中出现跳转菜单。


编辑跳转菜单项

若要更改跳转菜单项，请使用属性检查器或“行为”面板。可更改列表顺序或项所链接到的文件，也可添加、删除或重命名项。

若要更改链接文件的打开位置，或者添加或更改菜单选择提示，则必须使用“行为”面板（请参见跳转菜单）。

若要使用属性检查器编辑跳转菜单项，请执行以下操作：
  1. 如果属性检查器尚未打开，请选择“窗口”>“属性”打开它。
  2. 在“文档”窗口的“设计”视图中，单击跳转菜单对象以选定它。

    3. 在属性检查器中出现“列表/菜单”图标。

  3. 在属性检查器中，单击“列表值”按钮。

    4. 出现“列表值”对话框。
    这是所描述的功能的图片。

  4. 根据需要对菜单项进行更改，然后单击“确定”。


解决跳转菜单可能出现的问题

用户选择跳转菜单项后，如果用户再次导航回该页面，或者如果“打开 URL 于”域指定一个框架，则无法重新选择此菜单项。解决此问题有两个途径：

  • 使用菜单选择提示（如类别），或用户说明（如“选择其中一项：”）。在选择每个菜单后，自动重新选择菜单选择提示。
  • 使用“前往”按钮，该按钮允许用户重新访问当前所选链接。

备注： 由于这些选项应用于整个跳转菜单，因此在“插入跳转菜单”对话框中，每个跳转菜单只能选择这些选项中的一项。


创建导航条

导航条由图像或图像组组成，这些图像的显示内容随用户操作而变化。导航条通常为在站点上的页面和文件之间移动提供一条简捷的途径。

使用“插入导航条”命令之前，须首先为各个导航项目的显示状态创建一组图像。（可将导航条项目视为按钮，因为单击它时，导航条项目将用户带到其他页面。）

导航条项目有四种状态：

  • 一般：指用户尚未单击或尚未与此项目交互时所显示的图像。

    • 例如，此种状态的项目看起来未被单击过。
    这是所描述的功能的图片。

  • 滑过：指鼠标指针滑过“一般”图像时所显示的图像。项目的外观发生变化（例如变得更亮），以便让用户知道可与这个项目进行交互。
    这是所描述的功能的图片。
  • 按下：指项目被单击后所显示的图像。

    • 例如，用户单击某项目后，载入一个新的页面，而导航条仍然显示，只是被单击的项目变暗，表示它曾被选择过。

  • 按下时鼠标经过：指在项目被单击后，鼠标指针滑过“按下”图像时，所显示的图像。

    • 例如，项目变淡或变灰。此状态可作为一个给用户的可视提示，告诉他们在站点的这一部分，此项目不能再被单击。

不必包含所有这四种状态的导航条图像；例如，可以只选用“一般”和“按下”这两种状态。

您可执行下列操作：创建一个导航条、将导航条拷贝到站点内的其他页面、将导航条与框架一起使用以及编辑页面的行为以便在访问页面时显示不同的状态。


插入导航条

插入导航条时，须命名导航条项目，并选择要用于它们的图像。

若要创建导航条，请执行以下操作：
  1. 执行下列操作之一：
    • 选择“插入”>“交互式图像”>“导航条”。
    • 选择“插入”栏中的“常用”选项卡，然后单击“插入导航条”按钮。

      • 出现“插入导航条”对话框。
      这是所描述的功能的图片。

  2. 完成此对话框的相关内容。

    3. 有关更多信息，请参阅设置“导航条”选项。

  3. 单击“确定”。


修改导航条

为文档创建导航条后，可使用“修改导航条”命令向导航条添加图像，或从导航条中删除图像。此命令可用于更改图像或图像组、更改单击项目时所打开的文件、选择在不同的窗口或框架中打开文件以及重新排序图像。

若要修改导航条，请执行以下操作：
  1. 选择“修改”>“导航条”。

    2. 出现“修改导航条”对话框。
    这是所描述的功能的图片。

  2. 在“导航条项目”列表中，选择要编辑的项目。
  3. 根据需要进行更改。

    4. 有关更多信息，请参阅设置“导航条”选项。

  4. 单击“确定”。


创建图像地图

图像地图指已被分为多个区域（或称“热点”）的图像。当用户单击某个热点时，会发生某种操作（例如，打开一个新文件）。使用图像属性检查器可通过图形方式创建或编辑客户端图像地图。

客户端图像地图将超文本链接信息存储在 HTML 文档中，而不是像服务器端图像地图那样，存储在单独的地图文件中。当站点访问者单击图像中的热点时，相关 URL 被直接发送到服务器。这样使得客户端图像地图比服务器端图像地图要快，因为服务器不必解释访问者的单击位置。Navigator 2.0 及后续版本、NCSA Mosaic 2.1 和 3.0 以及 Internet Explorer 的所有版本都支持客户端图像地图。

Dreamweaver 并不改变现有文档中对服务器端图像地图的引用；在同一文档中，可以同时使用客户端图像地图和服务器端图像地图。不过，同时支持这两种图像地图类型的浏览器赋予客户端图像地图以优先权。若要在文档中包含服务器端图像地图，必须编写相应的 HTML 代码。


插入客户端图像地图

在插入客户端图像地图时，请创建一个热点，然后定义用户单击此热点时所打开的链接。

备注： 可以创建多个热点，但它们是同一图像地图的一部分。

若要创建客户端图像地图，请执行以下操作：
  1. 在“文档”窗口中，选择图像。
  2. 在属性检查器中，单击右下角的展开箭头，查看所有属性。
  3. 在“地图名称”域中，为此图像地图键入一个唯一名称。

    4. 备注： 如果在同一文档中使用多个图像地图，要确保每个地图都有唯一名称。

  4. 若要定义图像地图区域，请执行下列操作之一：
    • 选择圆形工具，并将鼠标指针拖至图像上，创建一个圆形热点。
    • 选择矩形工具，并将鼠标指针拖至图像上，创建一个矩形热点。
    • 选择多边形工具，在各个顶点上单击一下，定义一个不规则形状的热点。然后单击箭头工具封闭此形状。

      • 创建热点后，出现热点属性检查器。

  5. 完成热点属性检查器中的有关内容。

    6. 有关更多信息，请参阅设置热点属性检查器选项。

  6. 完成绘制图像地图后，在该文档的空白区域单击，以便更改属性检查器。


修改图像地图

对在图像地图中所创建的热点进行编辑很容易。可以移动热点，调整热点大小，或者在层之间向上或向下移动热点。

还可以将含有热点的图像从一个文档拷贝到其他文档，或者拷贝某图像中的一个或多个热点，然后将其粘贴到其他图像上；这样就将与该图像关联的热点也拷贝到了新文档中。

若要选择图像地图中的多个热点：
  1. 使用指针热点工具选择一个热点。
  2. 执行下列操作之一：
    • 按下 Shift 键的同时单击要选择的其他热点。
    • 按 Control+A（在 Windows 中）或者按 Command+A（在 Macintosh 中），选择所有的热点。
若要移动热点：
  1. 使用指针热点工具选择要移动的热点。
  2. 执行下列操作之一：
    • 将此热点拖动到新区域。
    • 用 Shift + 箭头键将热点向选定方向一次移动 10 个像素。
    • 使用箭头键将热点向选定方向一次移动 1 个像素。
若要调整热点的大小，请执行以下操作：
  1. 用指针热点工具选择要调整大小的热点。
  2. 拖动热点选择器手柄，更改热点的大小或形状。


向链接附加行为

可为文档中的任何链接附加行为（请参见应用行为）。在文档中插入链接项目时，有如下几种行为可供选择：

设置状态栏文字，用于确定消息的文本，并将其显示在浏览器窗口左下部的状态栏中。例如，可用此操作在状态栏中描述链接的目标，而不显示与该链接关联的 URL。（请参见设置状态栏文本。）

打开浏览器窗口，用于在新窗口中打开 URL。可以指定新窗口的属性，包括窗口的大小、属性（大小是否可调整、是否有菜单栏等等）和名称。（请参见打开浏览器窗口。）

跳转菜单，用于编辑跳转菜单。可更改菜单列表、指定其他链接文件或者更改打开所链接文档的浏览器位置。（请参见第 702页的“跳转菜单”。）

设置导航条图像，用于更改导航条的行为。可用此行为对图像在导航条上的显示方式进行自定义。例如，当鼠标指针滑过部分导航条时，导航条或文档中其他图像的显示内容会改变。（请参见第 706页的“设置导航条图像”。）


参考资料

本节包含本章所介绍的对话框的有关信息。


设置“命名锚记”选项

此对话框用于为命名锚记提供名称。

过程
  1. 为命名锚记输入一个名称。

    2. 锚记名不能含有空格，而且不应置于层内。

  2. 按下“确定”。

相关主题

链接到文档中的特定位置


设置超链接选项

此对话框用于创建超链接。

过程
  1. 在“文本”域中，输入要在文档中作为超链接显示的文本。
  2. 在“链接”文本框中，输入要链接到的文件的名称，或者单击文件夹图标以通过浏览选择该文件。
  3. 在“目标”弹出式菜单的“目标”域中，选择应该用于打开该文件的窗口。

    4. 当前文档中所有已命名框架的名称都显示在此弹出式列表中。如果指定的框架不存在，当文档在浏览器中打开时，所链接的页面载入一个新窗口，该窗口使用您所指定的名称。

    也可选用下列保留目标名：

    • _blank，将链接的文件载入一个未命名的新浏览器窗口中。
    • _parent，将链接的文件载入含有该链接的框架的父框架集或父窗口中。如果含有该链接的框架不是嵌套的，则在浏览器全屏窗口中载入链接的文件。
    • _self，将链接的文件载入该链接所在的同一框架或窗口中。此目标为默认值，因此通常不需要指定它。
    • _top，在整个浏览器窗口中载入所链接的文件，因而会删除所有框架。
  4. 在“Tab 键索引”域中，输入 Tab 键顺序的编号。
  5. 在“标题”域中，输入超链接的标题。
  6. 在“访问键”域中，输入键盘等价键（一个字母）以便在浏览器中选择该超链接。

相关主题

创建超链接


设置“电子邮件链接”选项

此对话框用于创建电子邮件链接。

过程
  1. 在“文本”域中，键入或编辑要在文档中作为电子邮件链接出现的文本。
  2. 在“电子邮件”域中，键入该邮件将发送到的电子邮件地址。
  3. 单击“确定”。

相关主题

创建超链接


设置“更改站点内所有指定链接”选项

此对话框用于更改指向站点内文件的链接。

过程
  1. 在“更改到如下文件的所有链接”文本框旁，单击文件夹图标，然后通过浏览选择要更改其链接的文件。

    2. 备注： 如果更改的是电子邮件链接、FTP 链接、空链接或脚本链接，请键入要更改的链接的完整文本。

  2. 在“更改为到如下文件的链接”域旁边，单击文件夹图标，通过浏览选择要链接到的新文件。

    3. 如果更改的是电子邮件链接、FTP 链接、空链接或脚本链接，请键入替换链接的完整文本。例如，若要更新指向旧地址的所有电子邮件链接，可在“更改到如下文件的所有链接”文本框中键入 mailto:juser@isp.com，然后在“更改为到如下文件的链接”文本框中键入 mailto:juser-interface@isp.com。

  3. 单击“确定”。

相关主题

在整个站点范围内更改链接


设置“插入跳转菜单”选项

此对话框用于设置跳转菜单。

过程
  1. 单击加号 (+) 按钮添加一个菜单项。

    2. 再次单击该按钮添加另一个菜单项。选定一个菜单项，然后单击减号 (-) 按钮将其删除。

  2. 选定一个菜单项，然后用箭头键在列表中向上或向下移动此菜单项。
  3. 在“文本”域中，为菜单项键入要在菜单列表中出现的文本。

    4. 若要使用菜单选择提示（如“选择其中一项”），可在第一个菜单项的“文本”域中输入选择提示文本。

  4. 在“选择时，前往的 URL”域中，单击文件夹图标并通过浏览找到要打开的文件，或者在文本框中键入该文件的路径。
  5. 在“打开 URL 于”弹出式菜单中，选择文件的打开位置：
    • 如果选择“主窗口”，则在同一窗口中打开文件。
    • 如果选择“框架”，则在所选框架中打开文件。

      • 备注： 如果想要定位的框架未出现在“打开 URL 于”弹出式菜单中，请关闭“插入跳转菜单”对话框，然后在文档中命名该框架。有关命名框架的信息，请参阅查看和设置框架属性。

  6. 在“菜单名称”文本框中，键入菜单项的名称。
  7. 选择“选项”下的“菜单之后插入前往按钮”，可添加一个“前往”按钮，而非菜单选择提示。
  8. 如果要使用菜单选择提示（如“选择其中一项”），请选择“选项”下的“更改 URL 后选择第一个项目”。
  9. 单击“确定”。

相关主题

插入跳转菜单

解决跳转菜单可能出现的问题


设置“导航条”选项

此对话框用于命名导航条项目并选择导航条项目所用的图像。

过程
  1. 在“项目名称”文本框中，键入导航条项目的名称（例如 Home）。

    2. 每一个项目都对应一个按钮，该按钮具有一组状态图像，最多可达四个。项目名称在“导航条项目”列表中显示。用箭头按钮排列项目在导航条中的位置。

  2. 在“一般图像”文本框中，单击“浏览”以选择最初将显示的图像。

    3. 备注： 此域为必需项，其他图像状态选项为可选项。

  3. 在“鼠标经过图像”文本框中，单击“浏览”，以选择当一般图像显示时如果用户鼠标指针滑过项目所显示的图像。
  4. 在“按下图像”文本框中，单击“浏览”，以选择用户单击项目后显示的图像。
  5. 在“按下时鼠标经过图像”文本框中，单击“浏览”，以选择当用户将鼠标指针滑过按下图像时所显示的图像。
  6. 在“替换文本”文本框中，输入项目的描述性名称。

    7. 替换文本在纯文本浏览器或设为手动下载图像的浏览器中，替代图像出现在应显示图像的位置。屏幕阅读器读取替换文本，而且有些浏览器在用户鼠标滑过导航条项目时显示替换文本。

  7. 在“按下时，前往的 URL”文本框中，单击“浏览”按钮，以选择要打开的链接文件，然后从弹出式菜单中选择打开文件的位置。选择下列操作之一：
    • 选择“主窗口”在同一窗口中打开文件。
    • 如果导航条在框架集中，则选择要在其中打开文件的框架。

      • 备注： 如果想要使用的框架未在弹出式菜单中出现，可关闭“插入导航条”对话框，然后命名该框架（请参阅查看和设置框架属性）。

  8. 选择“预先载入图像”，可在载入页面时下载图像。

    9. 如果未选择此选项，在用户鼠标指针滑过鼠标经过图像时可能会出现延迟。

  9. 选择“初始时显示‘按下图像’”，可在显示页面时，以按下状态显示所选项目，而不是以默认的“一般”状态显示。

    10. 例如，当载入主页时，导航条上的“主页”项目应处于按下状态。

    选择此选项时，在“导航条项目”列表中该项目后面出现一个星号。

  10. 在“插入”弹出式菜单中，可选择在文档中是垂直插入还是水平插入导航条项目。
  11. 选中“使用表格”复选框，可以表的形式插入导航条项目。
  12. 单击加号 (+) 按钮向导航条添加另一个项目，然后重复上述步骤定义该项目。
  13. 完成导航条项目的添加及定义后，单击“确定”。

相关主题

插入导航条

修改导航条


设置热点属性检查器选项

此对话框用于创建客户端图像地图。

过程
  1. 在热点属性检查器的“链接”文本框中，单击文件夹图标并通过浏览选择在用户单击该热点时要打开的文件，或者键入此文件的名称。

    2. 如果链接到同一站点内的文件，请输入相对于您的文档的路径。（以 file:// 开始的文件名不是相对路径文件名。）

  2. 在“目标”弹出式菜单的“目标”域中，选择应该用于打开该文件的窗口。

    3. 当前文档中所有已命名框架的名称都显示在此弹出式列表中。如果指定的框架不存在，当文档在浏览器中打开时，所链接的页面载入一个新窗口，该窗口使用您所指定的名称。也可选用下列保留目标名：

    _blank，将链接的文件载入一个未命名的新浏览器窗口中。

    _parent，将链接的文件载入含有该链接的框架的父框架集或父窗口中。如果含有该链接的框架不是嵌套的，则在浏览器全屏窗口中载入链接的文件。

    _self，将链接的文件载入该链接所在的同一框架或窗口中。此目标为默认值，因此通常不需要指定它。

    _top，在整个浏览器窗口中载入所链接的文件，因而会删除所有框架。

    备注： 只有当所选热点包含链接时，目标选项才可用。

  3. 在“替换文本”域中，键入希望在纯文本浏览器或设为手动下载图像的浏览器中作为替换文本出现的文本。

    4. 有些浏览器在用户鼠标指针暂停于该热点之上时，将此文本显示为工具提示。

  4. 重复第 4 步到第 7 步，定义该图像地图中的其他热点。
  5. 完成绘制图像地图后，在文档中的空白区域单击以更改属性检查器。

相关主题

创建图像地图

上一页


管理站点资源、库和模板

随着 Web 站点开发的进行，您积累的资源会越来越多。在某些情况下，您可能在多个站点上使用同一资源，或者可能在所有站点上使用一组您特别喜欢的资源。在 Macromedia Dreamweaver MX 中，您可以使用“资源”面板来协助管理站点资源。“资源”面板使您可以轻松地跟踪和预览已存储在站点中的几种资源，如图像、影片、颜色、脚本和链接。您可以轻松地将一种资源从“资源”面板直接拖动到当前文档并将其插入到某一页中。

还可以从“资源”面板访问两种特殊类型的资源 - 库和模板。库项目和模板是链接资源：编辑库项目或模板将更新已应用这些资源的所有文档。当您想在整个站点或者多个站点上重复使用特定内容或设计元素时，请使用库项目和模板。库项目用于个别的设计元素，如站点的版权信息或徽标。模板使您可以控制较大的设计区域。模板作者设计页面并定义该页的哪些区域可以接受设计或内容编辑。

本章包含下列主题：

  • 使用“资源”面板
  • 管理“资源”面板
  • 使用“库”项目
  • 创建、管理和编辑库项目
  • 关于 Dreamweaver 模板
  • 创建 Dreamweaver 模板
  • 关于定义模板区域
  • 创建基于模板的文档
  • 创建嵌套模板
  • 编辑和更新模板
  • 导出和导入模板 XML 内容
下一页


使用“资源”面板

资源包括存储在站点中的各种元素，如图像或影片文件。

可以从各种来源获取资源。例如，您可能在应用程序（如 Macromedia Fireworks 或 Macromedia Flash）中创建资源，从同事或客户那里接收资源，从剪辑作品 CD 中拷贝资源，或者从某个图形 Web 站点拷贝图像。有关规划和收集资源的更多信息，请参见关于站点规划和设计。

可以通过两种方式使用“资源”面板：将其用作站点中易于访问的资源列表（“站点”列表），或者将其作为一种对最常用资源进行组织的方式（“收藏”列表）。“资源”面板自动将站点资源放入“站点”列表。您可以向“收藏”列表添加任何资源。

大多数“资源”面板操作在“站点”列表和“收藏”列表中的工作方式相同。但是，有几个任务只能在“收藏”列表中执行（请参见设置资源的“收藏”列表）。


打开“资源”面板

使用“资源”面板可以查看当前站点中的资源或者查看已保存到“收藏”列表中的资源。

必须首先定义一个本地站点，然后才能在“资源”面板中查看资源。

打开“资源”面板：

选择“窗口”>“资源”。

出现“资源”面板。默认情况下，“图像”类别处于选定状态。


选取资源类别

与“站点”面板相比，“资源”面板能够帮助您更方便地管理和组织站点资源。资源被分类并显示在列表中。

若要查看特定类别的资源，请单击适当的图标。Dreamweaver 显示下列资源类别：

“图像”是 GIF、JPEG 或 PNG 格式的图像文件。有关图像的信息，请参见插入图像。

“颜色”是站点的文档和样式表中使用的颜色，包括文本颜色、背景颜色和链接颜色。

“URL”是当前站点文档中的外部链接。此类别包括下列类型的链接：FTP、gopher、HTTP、HTTPS、JavaScript、电子邮件 (mailto) 和本地文件 (file://)。

“Flash”影片是任何版本的 Macromedia Flash 格式文件。“资源”面板仅显示 SWF 文件（压缩的 Flash 文件），而不显示 FLA （Flash 源）文件。请参见关于 Flash 内容。

“Shockwave”影片是任何版本的 Macromedia Shockwave 格式文件。请参见插入 Shockwave 影片。

“影片”是 QuickTime 或 MPEG 格式文件。请参见插入媒体。

“脚本”是 JavaScript 或 VBScript 文件。请注意，HTML 文件（而不是独立的 JavaScript 或 VBScript 文件）中的脚本不出现在“资源”面板中。有关在 Macromedia Dreamweaver 中使用 JavaScript 的信息，请参见使用 JavaScript 调试器。

“模板”提供了一种方便的方法，用于在多个页面上重复使用同一页面布局，以及在模板被修改时修改附着到该模板的所有页面上的布局。请参见关于 Dreamweaver 模板。

“库”项目是在多个页面中使用的元素；当修改一个库项目时，包含该项目的所有页面都将被更新。请参见使用“库”项目。

备注： “资源”面板中仅显示属于这些类别的文件。某些其他类型的文件有时也称为资源，但这些文件不在面板中显示。


在“资源”面板中查看资源

“资源”面板提供了两种查看资源的方式：“站点”列表和“收藏”列表 - 前者显示站点中的所有资源，后者仅显示已明确选择的资源。

在这两个列表中，资源均被分成多个类别：通过单击面板左侧的类别按钮之一选取要列出哪种类别的资源。“站点”列表和“收藏”列表都可用于除模板和库项目之外的所有资源类别。

“站点”列表显示站点中作为文件存在的所有资源以及站点的任何文档中使用的所有颜色和 URL。

下面的大多数过程都可以在“站点”列表或“收藏”列表中执行。

查看“站点”列表：

单击“资源”面板顶部的“站点”。

备注： 在“模板”和“库”类别中，“站点”和“收藏”选项不可用。

查看“收藏”列表：

单击“资源”面板顶部的“收藏”。

“收藏”列表为空，直到您向其中显式添加资源。

显示特定类别的资源：

单击适当的类别图标，然后单击“站点”或“收藏”。例如，如果要显示站点中的所有图像，则单击“图像”图标，然后单击“站点”。

预览资源：

在“资源”面板中选取资源。

面板顶部的预览区域将显示该资源的可视化预览。例如，当您选择一个影片资源时，预览区域将显示一个图标。若要查看该影片，请单击预览区域右上角的“播放”按钮（绿色三角形）。

更改预览区域的大小：

向上或向下拖动拆分条（在预览区域和资源列表之间）。


刷新“资源”面板

“资源”面板可能需要花几秒钟才能创建“站点”列表，因为它必须读取站点缓存以创建该列表。

某些更改不会立即出现在“资源”面板中：

  • 当您在站点中添加或删除资源时，所做的更改不会立即出现在“资源”面板中，直到您单击“刷新站点列表”按钮刷新“站点”列表为止。如果您在 Dreamweaver 外部添加或移除资源（例如，使用 Windows 资源管理器或 Finder），则必须重新生成站点缓存以更新“资源”面板。
  • 当您删除站点中特定颜色或 URL 的唯一实例时，或者当您保存一个包含尚未在站点中使用的颜色或 URL 的新文件时，所做更改在您刷新“站点”列表之前不会出现在“资源”面板中。
手动刷新“站点”列表：
  1. 在“资源”面板中单击“站点”查看“站点”列表。
  2. 单击“资源”面板底部的“刷新站点列表”按钮。
    这是所描述的功能的图片。

    3. 将按需要创建或更新站点缓存，并且“资源”面板将更新以显示站点资源。

手动重新生成站点缓存并刷新“站点”列表：

按住 Control 键 (Windows) 或 Command 键 (Macintosh) 并在“资源”面板列表中单击，然后选择“刷新站点列表”。


将资源添加到页面

可以将大多数类型的资源插入到文档中，方法是将它们拖动到“文档”窗口中的“代码”视图或“设计”视图，或者使用“插入”按钮。您可以插入颜色和 URL，也可以将它们应用于“设计”视图中的选定文本。（还可以将 URL 应用于“设计”视图中的其他元素，如图像。）模板应用于整个文档。

将资源插入文档：
  1. 将插入点放置在“设计”视图中您希望资源出现的位置。
  2. 选择“窗口”>“资源”打开“资源”面板（如果它还没有打开）。
  3. 为您要插入的资源类型选择资源类别。

    4. 选择除“模板”之外的任何类别。只能将模板应用于整个文档；不能将它插入文档中。

  4. 选择“站点”或“收藏”并定位所需的资源。

    5. 对于库项目，没有“站点”或“收藏”列表；如果插入的是库项目，则跳过此步骤。

  5. 执行下列操作之一：
    • 将资源从面板拖动到文档。可以将脚本拖动到“文档”窗口的文件头内容区域；如果该区域未显示，则选择“查看”>“文件头内容”。
    • 在面板中选择资源，然后单击“插入”。

      • 资源即被插入文档中。（如果资源为颜色，则该颜色将在插入点开始应用；也就是说，随后键入的内容将以该颜色显示。）


使用“资源”面板应用颜色

“资源”面板中的颜色表示已应用于站点中各种元素的颜色，这些元素包括文本、表格边框和背景颜色等。可以使用“颜色”类别中的颜色样本将所选的颜色一致地应用于页面中的对象。

有关如何将颜色添加到“颜色”类别的信息，请参见创建新颜色或 URL 以添加到“收藏”列表。

更改文档中选定文本的颜色：
  1. 在文档中选择文本。
  2. 在“资源”面板中选择“颜色”类别。
    这是所描述的功能的图片。
  3. 选择所需的颜色。
  4. 单击“应用”。


使用“资源”面板在文档中添加 URL 链接

您可以使用“资源”面板将 URL 链接插入文档或者将 URL 链接应用于选定文本。

将链接添加到文档中的选定内容：
  1. 选择要应用 URL 的文本或图像。
  2. 在“资源”面板中选择“URL”类别，然后定位所需的 URL。
    这是所描述的功能的图片。
  3. 执行下列操作之一：
    • 将 URL 从面板拖动到“设计”视图中的选定内容。
    • 选择 URL，然后单击“插入”按钮。
将链接添加到文档：
  1. 将插入点放置在文档中您要添加 URL 的位置。
  2. 在“资源”面板中选择“URL”类别，然后定位所需的 URL。
    这是所描述的功能的图片。
  3. 执行下列操作之一：
    • 将 URL 从面板拖动到“设计”视图中的选定内容。
    • 选择 URL，然后单击“插入”按钮。


选择和编辑资源

“资源”面板使您可以同时选择多个资源。它还提供了开始编辑资源的快速方法。

选择多个资源：

通过单击一个资源选择该资源。然后以下列方法之一选择其他资源：

  • 按 Shift 键单击可选择一系列连续的资源。
  • 按住 Control 键 (Windows) 或 Command 键 (Macintosh) 并单击可以将个别资源添加到选定内容（不管该资源是否与现有的选定内容相邻）。按住 Control 键或 Command 键并单击选定的资源可取消选择该资源。
编辑资源：
  1. 执行下列操作之一：
    • 双击资源。
    • 选择资源，然后单击“编辑”。

      • 对于某些类型的资源（如图像），编辑资源时将启动一个外部编辑应用程序。对于颜色和 URL，编辑资源时只能在“收藏”列表中更改资源值。（您不能在“站点”列表中编辑颜色和 URL。）对于模板和库项目，编辑资源时您可以在 Dreamweaver 内部更改资源。

      如果没有为需要使用外部编辑器的资源打开外部编辑器，则选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，选择“文件类型/编辑器”类别，并且确保已为该资源的文件类型定义了外部编辑器。请参见为媒体文件启动外部编辑器。

  2. 根据需要更改资源。
  3. 完成对资源的编辑后，执行下列操作之一：
    • 如果该资源是基于文件的资源（除颜色和 URL 以外的任何资源），则保存它（使用编辑该资源时所用的任何编辑器）并将它关闭。
    • 如果该资源是 URL，则在“编辑 URL”对话框中完成编辑后单击“确定”。

      • 如果该资源是颜色，则当您挑选颜色时 Dreamweaver 颜色选择器将自动退出。（若要在不挑选颜色的情况下退出颜色选择器，请按 Escape 键。）


使用“资源”面板的“库”类别

“资源”面板的“库”类别显示当前站点库中的所有项目。

有关更改或更新库项目的信息，请参见编辑库项目。

在“资源”面板中创建新的空白库项目：
  1. 确保没有在“文档”窗口中选择任何内容。

    2. 如果选择了内容，则该内容将被放入新的库项目中。

  2. 单击“资源”面板底部的“新建库项目”按钮。

    3. 一个新的、无标题的库项目将被添加到面板中的列表。

  3. 在该项目仍处于选定状态时，输入项目名称。
将库项目添加到文档：
  1. 在“文档”窗口中，将指针放置在您要插入库项目的位置。
  2. 在“资源”面板中选择“库”类别，然后定位所需的库项目。
  3. 执行下列操作之一：
    • 将库项目从面板拖动到“设计”视图中的选区。
    • 选择该库项目，然后单击“插入”按钮。
编辑“库”项目：

从列表中选择一个库项目，然后单击“编辑”按钮，或者在列表中双击项目名称。

删除库项目：
  1. 在“资源”面板中选择库项目。
  2. 单击“删除”按钮或按下 Delete 键，然后确认要删除该库项目。

    3. 该库项目即被从站点中删除。

相关主题

使用“资源”面板


通过“资源”面板使用模板

可以使用“资源”面板的“模板”类别来创建新模板并管理现有模板。

有关创建和编辑模板的更多详细信息，请参见创建 Dreamweaver 模板。有关使用“资源”面板管理资源的更多信息，请参见使用“资源”面板。

使用“资源”面板创建新的空模板
  1. 选择“窗口”>“模板”。

    2. 出现“资源”面板，其中的“模板”类别处于选定状态。

  2. 在“资源”面板中，单击“资源”面板底部的“新建模板”按钮。
    这是所描述的功能的图片。

    3. 一个新的、无标题模板将被添加到面板中的模板列表。

  3. 在模板仍处于选定状态时，输入模板的名称。
  4. 这将在“资源”面板和 Templates 文件夹中创建一个新的空模板，但并不创建 .dwt 文件。若要开始定义可编辑区域，请单击“资源”面板底部的“编辑”按钮。

    5. 有关定义可编辑模板区域的信息，请参见插入可编辑区域。

编辑模板文件：
  1. 选择“窗口”>“资源”，然后单击“模板”图标查看模板。

    2. “资源”面板底部列出了站点的所有可用模板。顶部区域显示选定模板的预览。

  2. 在“名称”列表中，执行下列操作之一：
    • 双击模板名称。
    • 单击“资源”面板底部的“编辑”按钮。
      这是所描述的功能的图片。
  3. 在“文档”窗口中编辑模板。根据需要在模板中创建可编辑区域（请参见关于定义模板区域）。
  4. 选择“文件”>“保存”保存已编辑的模板。

    5. 备注： 如果尚未定义任何可编辑区域，则 Dreamweaver 将警告您该模板不包含可编辑区域。即使模板不包含可编辑区域，您也可以对它进行保存或修改；但是，在模板具有可编辑区域之前，您将不能修改基于该模板的文档。

将模板应用于活动文档：
  1. 打开要应用模板的文档。
  2. 在“资源”面板中选择“模板”类别，然后定位要应用的模板。
    这是所描述的功能的图片。
  3. 执行下列操作之一：
    • 将模板从面板拖动到“文档”窗口。
    • 选择模板并单击“应用”按钮。

      • 备注： 您必须将文档中的现有内容指定给模板的可编辑区域，否则 Dreamweaver 将放弃该内容。

在“资源”面板中重命名模板：
  1. 单击模板的名称以选择该模板。
  2. 再次单击模板的名称以便使文本可选，然后输入一个新名称。

    3. 备注： 这种重命名方式与在 Windows 资源管理器 (Windows) 或 Finder (Macintosh) 中对文件进行重命名的方式相同。对于 Windows 资源管理器和 Finder，请确保在前后两次单击之间稍微暂停一下。不要双击该名称，因为这样会打开模板进行编辑。

  3. 在“资源”面板中的另一个区域中单击，或者按 Enter 键 (Windows) 或 Return 键 (Macintosh) 使更改生效。
  4. Dreamweaver 将询问是否要更新基于此模板的文档。
    • 若要更新站点中所有基于此模板的文档，请单击“更新”。
    • 如果不想更新基于此模板的任何文档，则单击“不更新”。您选择不予更新的文档仍将基于原始模板（未分离）。若要在以后更新此文档，请打开该文档并选择“修改”>“模板”>“刷新”。
删除模板文件：
  1. 在“资源”面板中选择模板。
  2. 单击“删除”按钮并确认要删除该模板。

    3. 如果删除模板文件，则无法对其进行检索。该模板文件将被从站点中删除。基于此模板的文档不会与此模板分离；它们将该模板文件保持在被删除前所具有的结构和可编辑区域中。

    若要将这种文档变成没有可编辑区域或锁定区域的正常 HTML 文件，请使用“修改”>“模板”>“从模板中分离”。有关更多信息，请参见从模板分离文档。


使用资源和站点

您可能想在“站点”面板中定位与“资源”面板中的资源相对应的文件。这在有些时候会很有用，例如当您要向远程站点传输资源或者从远程站点传输资源时。

“资源”面板显示当前站点中的所有资源（属于可识别的类型）。（当前站点是包含活动文档的站点。）若要将当前站点中的资源用于另外的站点，您必须将该资源拷贝到另外的站点。可以一次拷贝一个单独的资源、一组单独的资源或整个收藏夹。

备注： “站点”面板可能与“资源”面板显示不同的站点。这是因为“资源”面板与活动文档相关联。若要确定“资源”面板正在显示哪个站点，请查看面板的标题条。

在“站点”面板中定位资源的文件：

在“资源”面板中右击 (Windows) 或按住 Control 键并单击 (Macintosh) 资源的名称或图标，然后从上下文菜单中选择“在站点定位”。

出现“站点”面板，其中的资源文件处于选定状态。

“在站点定位”不可用于颜色和 URL，因为它们不与站点中的文件相对应。

请注意，“在站点定位”定位与资源本身对应的文件；它不定位使用该资源的文件。

从“站点”列表或“收藏”列表向另外的站点拷贝资源：
  1. 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 要拷贝的资源的图标或名称。

    2. 在“收藏”列表中，除了可以拷贝单独的资源以外，还可以拷贝收藏夹。（有关收藏夹的信息，请参见将资源归类到收藏夹中。）

  2. 从上下文菜单中选择“拷贝到站点”，并从子菜单中选择目标站点名称。（子菜单列出已定义的所有站点。）

    3. 资源被拷贝到指定的站点，并拷贝到与其在当前站点中所处位置相对应的位置。Dreamweaver 还将根据需要在目标站点的层次结构中创建新文件夹。

    资源还被添加到指定站点的“收藏”列表。

    当在目标站点中打开文档时，“资源”面板将切换到该站点，并显示已拷贝的资源。

    备注： 如果所拷贝的资源是颜色或 URL，则该资源只会出现在另一个站点的“收藏”列表中，而不会出现在另一个站点的“站点”列表中。这是因为没有与颜色或 URL 相对应的文件，所以没有要拷贝到另一个站点中的文件。


管理“资源”面板

默认情况下，给定类别中的资源按名称的字母顺序列出。资源名称可以是文件名（对于图像）、十六进制数字（对于颜色）或 URL。也可以按其他几种条件中的任意一种列出资源。

按不同顺序列出资源：

单击某个列标题。

例如，若要根据类型对图像列表进行排序（以便使所有 GIF 图像在一起，所有 JPEG 图像在一起，等等），请单击“类型”列标题。

更改列的宽度：
  1. 将指针定位在分隔两个列标题的线上。
  2. 拖动该线可更改列宽。


设置资源的“收藏”列表

“资源”面板的大多数操作在“收藏”列表中与在“站点”列表中相同（请参见使用“资源”面板）。但是，有几种任务只能在“收藏”列表中执行。

因为“资源”面板的“站点”列表总是显示站点内的所有可识别资源，所以该列表对于一些大型站点来说可能会变得难以使用。如果将常用的资源添加到“收藏”列表，就可以将相关的资源归成一类，给它们起别名以提醒您它们的用途，并方便地在“资源”面板中查找它们。

备注： “收藏”资源不是作为单独的文件存储在磁盘上的；它们是对“站点”列表中资源的引用。Dreamweaver 跟踪在“收藏”列表中显示“站点”列表中的哪些资源。


在“收藏”列表中添加和删除资源

有若干种向站点的“收藏”列表中添加资源的方法。

若要向“收藏”列表中添加资源，请执行下列操作之一：
  • 在“站点”列表中选择一种或多种资源，并单击“添加到收藏夹”按钮。
    这是所描述的功能的图片。
  • 在“站点”列表中选择一种或多种资源，然后从上下文菜单中选择“添加到收藏夹”。
  • 右击 (Windows) 或按住 Control 键并单击 (Macintosh)“文档”窗口的“设计”视图中的一个元素，然后选择上下文菜单命令将该元素添加到适当的“收藏”类别。

    • 例如，可以选择一个图像并从上下文菜单中选择“添加到图像收藏”。请注意，文本的上下文菜单中包含“添加到颜色收藏”或“添加到 URL 收藏”，具体取决于文本是否附着了链接。同时还要注意，只有符合“资源”面板中类别之一的元素才可以添加到“收藏”列表中。

  • 在“站点”面板中选择一个或多个文件，然后从上下文菜单中选择“添加到收藏夹”。不符合“资源”面板中的类别的文件被忽略。

无论您选择哪种方法，资源都被添加到“收藏”列表中，并且“资源”面板显示“收藏”列表。

备注： 模板和库项目没有“收藏”列表。

从“收藏”列表中删除资源：
  1. 在“收藏”列表中选择一种或多种资源（或一个收藏夹）。
  2. 单击“资源”面板底部的“从收藏中删除”按钮。
    这是所描述的功能的图片。

    3. 资源将被从“收藏”列表中删除，但它们仍出现在“站点”列表中。如果删除一个收藏夹，则该文件夹及其中的所有资源都被从“收藏”列表中删除。


创建新颜色或 URL 以添加到“收藏”列表

可以使用“资源”面板向“收藏”列表中添加新颜色或 URL。请注意，不能向“站点”列表中添加新颜色或 URL；“站点”列表中只包含站点中已经在使用的资源。

创建新颜色：
  1. 单击“颜色”类别按钮。
    这是所描述的功能的图片。
  2. 单击“收藏”显示“收藏”列表。
  3. 单击“新建颜色”按钮。
    这是所描述的功能的图片。
  4. 使用颜色选择器选择一种颜色。

    5. 若要从颜色选择器中退出而不选择颜色，请按 Escape 键或单击颜色选择器顶部的灰色条。（有关使用颜色选择器的更多信息，请参见使用颜色。）

  5. 如果需要，给颜色起一个别名。
创建新 URL：
  1. 单击“URL”类别按钮。
    这是所描述的功能的图片。
  2. 单击“收藏”显示“收藏”列表。
  3. 单击“新建 URL”按钮。
    这是所描述的功能的图片。
  4. 在“添加 URL”对话框中输入一个 URL 和一个昵称，并单击“确定”。


为喜爱的资源创建别名

可以给“收藏”列表中的资源起别名。然后显示该资源的别名而不是其文件名或值。例如，如果某颜色名为 #999900，则可以使用一个更具描述性的别名，如 PageBackgroundColor 或 ImportantTextColor。

可以只给“收藏”列表中的资源起别名。在“站点”列表中，资源用其真实的文件名（或者在资源为颜色和 URL 的情况下，用其值）列出。

给喜爱的资源起别名：
  1. 单击包含该资源的类别。
  2. 单击“收藏”显示“收藏”列表。
  3. 执行下列操作之一：
    • 在“资源”面板中右击 (Windows) 或按住 Control 键并单击 (Macintosh) 资源的名称或图标，然后从上下文菜单中选择“编辑别名”。
    • 单击一次资源的名称，暂停，然后再次单击。（不要双击。）
  4. 为该资源键入一个别名，然后按 Enter 键 (Windows) 或 Return 键 (Macintosh)。

    5. 该别名出现在“昵称”列中。


将资源归类到收藏夹中

在“收藏”列表的给定类别中，可以创建命名的资源组 - 称作收藏夹。例如，如果有一组在电子商务站点的许多目录页面上都使用的图像，可以将它们归类到一起，放入一个称为 CatalogImages 的文件夹中。

备注： 将资源放入收藏夹并不会更改资源文件在磁盘上的位置。

创建收藏夹：
  1. 单击“收藏”（位于“资源”面板的顶部）显示“收藏”列表。
  2. 单击“新建收藏夹”按钮。
    这是所描述的功能的图片。
  3. 给该文件夹命名。
  4. 将资源拖动到文件夹中。


使用“库”项目

库是一种特殊的 Dreamweaver 文件，其中包含您已创建以便放在网页上的单独的“资源”或资源拷贝的集合。如果只是想让页面具有相同的标题和脚注，但具有不同的页面布局，请使用库项目存储标题和脚注。库项目是可以在多个页面中重复使用的存储页面元素；每当更改某个库项目的内容时，您都可以更新所有使用该项目的页面。

可以在库中存储各种各样的页面元素，如图像、表格、声音和 Flash 影片。

使用库项目时，Dreamweaver 不是在网页中插入库项目，而是向库项目中插入一个链接。如果以后需要更改库项目，例如更改某些文本或图像，则更新库项目时将自动在任何已经插入该库项目的页面中更新库的实例。

相关主题

创建库项目

在文档中插入库项目

编辑库项目

使文档中的库项目可编辑


创建、管理和编辑库项目

库是一种用来存储想要在整个网站上经常重复使用或更新的页面元素（如图像、文本和其他对象）的方法。这些元素称为库项目。

将库项目放在文档中时，Dreamweaver 向文档中插入该项目的 HTML 源代码拷贝，并添加一个包含对原始外部项目的引用的 HTML 注释。对外部库项目的引用使您可以一次更新整个站点上的内容，方法是更改该库项目，然后使用“修改”>“库”子菜单中的更新命令。

Dreamweaver 将库项目存储在每个站点的本地根文件夹内的 Library 文件夹中。每个站点都有自己的库；若要将库项目从一个站点拷贝到另外的站点，请使用“资源”面板的“拷贝到站点”命令。有关更多信息，请参见使用“资源”面板的“库”类别。

备注： 如果库项目中包含链接，链接可能无法在新站点中工作。此外，库项目中的图像不会被拷贝到新站点中。

这里有一个可以如何使用库项目的范例：假定您在为某公司生成一个大型站点。公司想让其广告语出现在站点的每个页面上，但是销售部门还没有最后确定广告语的文字。如果创建一个包含该广告语的库项目并在每个页面上使用，那么当销售部门提供该广告语的最终版本时，您可以更改该库项目并自动更新每一个使用它的页面。

库项目还可以包含行为，但对于编辑库项目中的行为有特殊要求；请参见编辑库项目中的行为。库项目不能包含时间轴和样式表，因为这些元素的代码属于 head 部分。


创建库项目

可以从文档 body 部分中的任意元素创建库项目，这些元素包括文本、表格、表单、Java applets、插件、ActiveX 元素、导航条和图像。

对于链接项（如图像），库只存储对该项的引用。原始文件必须保留在指定的位置，才能使库项目正确工作。尽管如此，在库项目中存储图像还是很有用的；例如，可以在库项目中存储一个完整的 img 标记，它将使您可以方便地在整个站点中更改图像的 alt 文本，甚至更改它的 src 属性。但是，不要使用这种方法更改图像的 width 和 height 属性，除非您还使用图像编辑器来更改图像的实际大小。

创建库项目：
  1. 选择文档的一部分并另存为库项目。
  2. 执行下列操作之一：
    • 选择“窗口”>“库”并将选定内容拖动到“资源”面板的“库”类别中。
    • 单击“资源”面板底部的“新建库项目”按钮（在“库”类别中）。
    • 选择“修改”>“库”>“增加对象到库”。
  3. 输入新的库项目的名称。

    4. 每个库项目都在站点本地根文件夹的“库”文件夹中保存为一个单独的文件（文件扩展名为 .lbi）。


在文档中插入库项目

当向页面添加库项目时，将把实际内容以及对该库项目的引用一起插入到文档中。

在文档中插入库项目：
  1. 将插入点放在“文档”窗口中。
  2. 选择“窗口”>“库”。

    3. 出现“资源”面板，显示“库”类别。

  3. 从“资源”面板向“文档”窗口拖动一个库项目，或者选择一个项目并单击“插入”按钮。

    4. 若要在文档中插入库项目的内容而不包括对该项目的引用，请在从“资源”面板的“库”类别中向外拖动项目时按 Control 键 (Windows) 或 Option 键 (Macintosh)。如果用这种方法插入项目，则可以在文档中编辑该项目，但当更新使用该库项目的页面时，文档不会随之更新。


编辑库项目

当更改库项目时，可以选择更新使用该项目的所有文档。如果选择不更新，那么文档将保持与库项目的关联；可以在以后选择“修改”>“库”>“刷新页面”来更新它们。

对库项目的其他种类的更改包括：重命名项目以断开其与文档或模板的连接，从站点的库中删除项目，以及重新创建丢失的库项目。

备注： 编辑库项目时，“CSS 样式”面板和“时间轴”面板都不可用，因为库项目中只能包含 body 元素，而时间轴和 CSS 样式表代码却可以插入到文档的 head 部分。“页面属性”对话框也不可用，因为库项目中不能包含 body 标记或其属性。

编辑库项目：
  1. 选择“窗口”>“库”。

    2. 出现“资源”面板的“库”类别。

  2. 选择库项目。

    3. 库项目的预览出现在“资源”面板的顶部。（不能在预览中进行任何编辑。）

  3. 单击“资源”面板底部的“编辑”按钮。或者，也可以双击库项目。

    4. Dreamweaver 将打开一个用于编辑该库项目的新窗口。此窗口非常类似于“文档”窗口，但它的“设计”视图的背景为灰色，表示您正在编辑库项目而不是文档。

  4. 编辑库项目然后保存更改。
  5. 在出现的对话框中，选择是否更新本地站点上那些使用编辑过的库项目的文档：
    • 选择“更新”将更新本地站点中所有包含编辑过的库项目的文档。
    • 选择“不更新”将不更改任何文档，直到使用“修改”>“库”>“刷新当前页”或“刷新页面”再行更改。
更改当前文档以使用所有库项目的当前版本：

选择“修改”>“库”>“刷新当前页”。

更新整个站点或所有使用特定库项目的文档：
  1. 选择“修改”>“库”>“刷新页面”。

    2. 即会出现“更新页面”对话框。

  2. 在“查看”弹出式菜单中执行下列操作之一：
    • 选择“整个站点”，然后从相邻的弹出式菜单中选择站点名称。这会更新所选站点中的所有页面，使其使用所有库项目的当前版本。
    • 选择“文件使用”，然后从相邻的弹出式菜单中选择库项目名称。这会更新当前站点中所有使用所选库项目的页面。
  3. 请确保在“更新”选项中选择了“库项目”。（若要同时更新模板，请确保“模板”也被选中。有关更多信息，请参见更新基于模板的文档。）
  4. 单击“开始”。

    5. Dreamweaver 按照指示更新文件。如果选择了“显示记录”选项，Dreamweaver 将提供关于它试图更新的文件的信息，包括它们是否成功更新的信息。

在“资源”面板中重命名库项目：
  1. 单击一次该库项目的名称以将其选中。
  2. 稍作暂停之后，再次单击。
  3. 当名称变为可编辑时，输入一个新名称。

    4. 备注： 这种重命名方法与在 Windows 资源管理器 (Windows) 或 Finder (Macintosh) 中重命名文件的方法一样。对于 Windows 资源管理器和 Finder，请确保在前后两次单击之间稍作暂停。不要双击名称；那样将打开库项目进行编辑。

  4. 单击别处或者按 Enter 键 (Windows) 或 Return 键 (Macintosh)。
  5. Dreamweaver 将询问是否要更新使用该项目的文档。
    • 若要更新站点中所有使用该项目的文档，请单击“更新”。
    • 若要避免更新任何使用该项目的文档，请单击“不更新”。
从库中删除库项目：
  1. 在“资源”面板的“库”类别中选择该项目。
  2. 单击“删除”按钮并确认想要删除该项目。

    3. 请务必小心；删除一个库项目后，将无法使用“撤消”来找回它。但可以重新创建它，如下一过程所述。

    删除库项目时将从库中删除该项，但不会更改任何使用该项的文档的内容。

重新创建缺少或已删除的库项目：
  1. 在某个文档中选择该项目的一个实例。
  2. 在属性检查器中单击“重新创建”按钮。


使文档中的库项目可编辑

如果您已经向文档中添加了库项目，并想专门针对该页编辑此项目，则必须断开文档中的项目和库之间的链接。在使库项目的实例可编辑之后，如果库项目发生更改，该实例将无法更新。

使库项目可编辑：
  1. 在当前文档中选择库项目。
  2. 在属性检查器中单击“从源文件中分离”。

    3. 所选的库项目实例将不再高亮显示（如果已使其高亮显示），并且当原始库项目更改时，它也不会再更新。


编辑库项目中的行为

当创建一个库项目，并且它包括一个附有 Dreamweaver 行为的元素时，Dreamweaver 会将该元素及其事件处理程序（指定哪个事件触发动作，如 onClick、onLoad 或 onMouseOver，以及事件发生时调用哪个动作的属性）拷贝到库项目文件。Dreamweaver 不会将关联的 JavaScript 函数拷贝到库项目中。相反，当向文档中插入库项目时，Dreamweaver 将自动向该文档的 head 部分插入适当的 JavaScript 函数（如果此处没有这些函数）。

备注： 如果手工编写 JavaScript 代码（也就是说，如果不使用 Dreamweaver 行为进行创建），并且如果使用“调用 JavaScript”行为执行代码，则可以使代码成为库项目的一部分。如果不使用 Dreamweaver 行为来执行代码，将不会把代码保留为库项目的一部分。

若要编辑库项目中的行为，必须首先在文档中插入该项目，然后使该项目在此文档中可编辑。在进行所需的更改之后，即可重新创建该库项目，用文档中的已编辑项目来替换库中的项目。

有关行为的更多信息，请参见使用 JavaScript 行为。

编辑库项目中的行为：
  1. 打开包含该库项目的文档。

    2. 请注意库项目的名称以及它所包含的准确的标记。在第 8 步和第 9 步中将用到该信息。

  2. 选择该库项目并在属性检查器中单击“从源文件中分离”。
  3. 选择附着了该行为的元素。
  4. 选择“窗口”>“行为”打开“行为”面板。在“行为”面板中双击想要更改的动作。
  5. 在出现的对话框中进行必要的更改，然后单击“确定”。
  6. 选择“窗口”>“库”打开“资源”面板的“库”类别。
  7. 请确保您已经记录了原始库项目的准确名称；然后选择该原始库项目，再通过单击“资源”面板中的“删除”按钮来删除它。
  8. 在“文档”窗口中选择组成该库项目的所有元素。

    9. 小心选择与原始库项目中完全相同的元素。

  9. 在“资源”面板中单击“新建库项目”按钮，并给新项目起一个与在第 7 步中删除的项目相同的名称。

    10. 务必使用完全相同的拼写和大小写。

  10. 若要更新站点的其他文档中的库项目，请选择“修改”>“库”>“更新页面”。
  11. 在“更新页面”对话框的“查看”弹出式菜单中选择“文件使用”。
  12. 在相邻的弹出式菜单中，选择刚创建的库项目的名称。
  13. 在“更新”选项中，确保选择了“库项目”，然后单击“开始”。
  14. 当完成更新时，单击“关闭”退出“更新页面”对话框。


关于 Dreamweaver 模板

Dreamweaver 模板是一种特殊类型的文档，用于设计“锁定的”页面布局。模板创作者设计页面布局，并在模板中创建可在基于模板的文档中进行编辑的区域。在模板中，设计者控制哪些页面元素可以由模板用户（如作家、图形艺术家，或其他 Web 开发者）进行编辑。有关创作模板的信息，请参见创建 Dreamweaver 模板。有关基于模板创建页面的信息，请参见创建基于模板的文档。

模板最强大的用途之一在于一次更新多个页面。从模板创建的文档与该模板保持连接状态（除非您以后分离该文档）。可以修改模板并立即更新所有基于该模板的文档中的设计。

模板控制基于模板的文档的可编辑区域和固定区域。可以在文档中包括数种类型的模板区域。有关这些类型的模板区域的信息，请参见关于定义模板区域。

可以向基于模板的文档中添加层叠样式表 (CSS)、时间轴或行为，因为 Dreamweaver 自动在文档的 head 部分插入可编辑区域。

“代码”视图和“设计”视图中都启用了与模板相关的操作（如添加可编辑区域）。有些模板自定义选项只能在“代码”视图中使用。 有关添加模板表达式的信息，请参见编写模板表达式。

如果想存储关于模板的附加信息（如创作者、最后一次更改的时间或作出某些布局决定的原因），可以为模板创建一个“设计备注”文件。基于模板的文档不继承模板的“设计备注”。（有关更多信息，请参见在设计备注中保存文件信息。）


关于定义模板区域

模板确定文档的基本结构，并包含诸如文本、图像、页面布局、样式和可编辑区域之类的元素。

将文档另存为模板时，Dreamweaver 自动锁定文档的大部分区域。模板创作者定义基于模板的文档中的哪些区域可编辑，方法是在模板中插入可编辑区域或可编辑参数。创建模板时，可编辑区域和锁定区域都可以更改。但是，在基于模板的文档中，模板用户只能在可编辑区域中进行更改；无法修改锁定区域。

共有四种类型的模板区域：可编辑区域、重复区域、可选区域和可编辑标记属性。

可编辑区域是基于模板的文档中的未锁定区域；它是模板用户可以编辑的部分。模板创作者可以将模板的任何区域定义为可编辑的。要让模板生效，它应该至少包含一个可编辑区域；否则，基于该模板的页面将无法编辑。有关插入可编辑区域的信息，请参见插入可编辑区域。

重复区域是文档中设置为重复的部分。例如，可以重复一个表格行。通过重复表格行，可以允许模板用户创建扩展列表，同时使设计处于模板创作者的控制之下。在基于模板的文档中，使用重复区域控制选项添加或删除重复区域的拷贝。可以在模板中插入两种类型的重复区域 - 重复区域和重复表格。有关在模板中插入重复区域的信息，请参见在模板中创建重复区域。有关创建重复表格的信息，请参见插入重复表格。有关在基于模板的页面中使用重复区域的信息，请参见添加、删除重复区域项以及更改其顺序

可选区域是设计者在模板中定义为可选的部分，用于保存有可能在基于模板的文档中出现的内容（如可选文本或图像）。在基于模板的页面上，通常由内容编辑器控制内容是否显示。有关在模板中设置可选区域的信息，请参见插入可选区域。有关在基于模板的页面中编辑可选区域的信息，请参见修改可选区域模板参数。

可编辑标记属性使您可以在模板中解锁标记属性，以便该属性可以在基于模板的页面中编辑。例如，可以“锁定”在文档中出现的图像，但让页面创作者将对齐设为左对齐、右对齐或居中对齐。有关设置可编辑标记属性的信息，请参见在模板中定义可编辑标签属性。有关在基于模板的页面中编辑标记的信息，请参见修改模板属性。


关于模板参数

可以使用模板参数来定义可选区域、可编辑标记属性或设置想要传递到附着文档的值。

创建模板参数使您可以定义一些值，以便控制基于模板的文档中的内容。需要为每个参数定义名称、数据类型和默认值。每个参数都必须有一个唯一的名称且区分大小写。

模板参数作为实例参数传递到文档，并可以通过“修改”>“模板属性”命令访问。大多数情况下，模板用户可以编辑参数的默认值，以便自定义出现在基于模板的文档中的内容。在其他情况下，模板创作者还可以使用计算文本表达式，根据表达式中的值来确定出现在文档中的内容。 有关信息，请参见编写模板表达式。


编辑 HTML 标签外的代码

一些服务器脚本被插入到文档的起始或结尾处（在 <html> 标记之前或 </html> 标记之后）。此类脚本要求在模板和基于模板的文档中特殊处理。正常情况下，如果对模板中 <html> 标记之前或 </html> 标记之后的脚本代码进行更改，这些更改将不会拷贝到基于该模板的文档中。如果模板主体内部的其他服务器脚本依赖于没有拷贝的脚本，则这将导致服务器错误。结果，如果您更改模板中 <html> 标记之前或 </html> 标记之后的脚本，Dreamweaver 将发出警告。

若要避免此问题，可以在模板的 head 部分插入下列代码：

<!-- TemplateInfo codeOutsideHTMLIsLocked="true" -->

如果模板中包含这些代码，则对 <html> 标签之前或 </html> 标签之后的脚本所作的更改将被拷贝到基于该模板的文档中。但是，将不再允许编辑基于该模板的文档中的那些脚本。因而，可以选择能够在模板中或在基于该模板的文档中编辑这些脚本，但不能同时选择两者。


关于模板中的链接

若要在模板文件中创建链接，可以使用属性检查器中的文件夹图标或“指向文件”图标；不要键入要链接到的文件的名称。如果键入名称，链接可能不能工作。本节解释 Dreamweaver 如何处理模板中的链接。

当从现有页面创建模板文件并将该页另存为模板时，Dreamweaver 将更新链接，使其与以前指向相同的文件。因为模板保存在 Templates 文件夹中，当将页面另存为模板时，文档相对链接的路径将更改。在 Dreamweaver 中，当基于该模板创建新文档并保存新文档时，所有文档相对链接将被更新以继续指向正确的文件。

但是，当向模板文件中添加新的文档相对链接时，如果在属性检查器中的链接文本框中键入路径，很容易输入错误的路径名。正确的路径是从 Templates 文件夹到链接文档的路径，而不是从基于模板的文档的文件夹到链接文档的路径。

有关使用“指向文件”图标进行链接的信息，请参见链接文件和文档。

备注： 有些情况下（如模板中的事件处理程序中的文件路径），不能使用文件夹图标或“指向文件”图标；在这些情况下，必须输入正确的路径名。


在“设计”视图中查看模板

在模板文件和基于模板的文档中，可编辑区域出现在“文档”窗口的“设计”视图中，并且周围环绕预设高亮颜色的矩形边框。（有关设置高亮颜色参数选择的信息，请参见设置模板高亮显示参数。）每个区域的左上角都出现一个小的选项卡，显示每个定义区域的名称。模板区域也包括在高亮显示的边框内。可编辑内容和锁定内容都可以更改。

模板文件可以由“文档”窗口中的 <<模板>> 标题和 .dwt 文件扩展名来标识。


在“代码”视图中查看模板

在“代码”视图中，模板中的可编辑和锁定 HTML 源代码都可以更改。可编辑内容在 HTML 中用注释 <!-- TemplateBeginEditable> 和 <!-- TemplateEndEditable --> 标记。这些注释之间的任何内容都可以在基于模板的文档中编辑。上一范例中，可编辑区域的 HTML 源代码可能类似于下列形式：

<table width="75%"  border="1"  cellspacing="0" cellpadding="0">
  <tr bgcolor="#333366">
    <td>名称</td>
    <td><font color="#FFFFFF">地址</font></td>
    <td><font color="#FFFFFF">电话号码</font></td>
  </tr>
  <!-- TemplateBeginEditable name="LocationList" -->
  <tr>
    <td>输入名称</td>
    <td>输入地址</td>
    <td>输入电话</td>
  </tr>
  <!-- TemplateEndEditable -->
</table>


在“设计”视图中查看基于模板的文档

在基于模板的文档中，除可编辑区域的边框之外，整个页面都是由不同颜色的边框环绕的，右上角的选项卡给出该文档所基于的模板的名称。这个高亮显示的矩形是用于提醒您该文档是基于模板的，并且您不能更改可编辑区域之外的任何内容。

备注： 当禁用高亮显示时，如果您尝试在基于模板的文档中编辑锁定区域，鼠标指针将更改，表示您不能在锁定区域内单击。


在“代码”视图中查看基于模板的文档

在“代码”视图中，派生自模板的文档的可编辑区域用与不可编辑区域中的代码不同的颜色显示；可以只更改可编辑区域中的代码或可编辑参数。

可编辑内容在 HTML 中由 Dreamweaver 注释 <!-- InstanceBeginEditable> 和 <!-- InstanceEndEditable --> 标记。这些注释之间的所有内容都是可编辑的。

可编辑区域的 HTML 源代码可能类似于下列形式：

<!-- InstanceBeginEditable name="head" -->
<!-- InstanceEndEditable -->
</head>

<body bgcolor="#FFFFFF" leftmargin="0">
<table width="75%"  border="1"  cellspacing="0" cellpadding="0">
  <tr bgcolor="#333366">
    <td>名称</td>
    <td><font color="#FFFFFF">地址</font></td>
    <td><font color="#FFFFFF">电话号码</font></td>
  </tr>
  <!-- InstanceBeginEditable name="LocationList" -->
  <tr>
    <td>输入名称</td>
    <td>输入地址</td>
    <td>输入电话</td>
  </tr>
  <!-- InstanceEndEditable -->
</table>
</body>
<!-- InstanceEnd -->

不可编辑文本的默认设置是灰色，您可以在“参数选择”对话框中为可编辑区域和不可编辑区域定义不同的颜色。选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择” (Mac OS X)，然后选择“代码颜色”。有关更多信息，请参见为模板文档设置代码颜色参数。

备注： Dreamweaver 禁止您在“文档”窗口的“代码”视图中的锁定区域内键入内容。


创建 Dreamweaver 模板

可以从现有文档（如 HTML、Macromedia ColdFusion 或 Microsoft Active Server Pages 文档）创建模板，或者从新建的空文档创建模板。

“新建文档”对话框（“文件”>“新建”）提供了用于创建新模板和基于模板的页面的几种选项。有关信息，请参见使用“新建文档”对话框。

Dreamweaver 用文件扩展名 .dwt 来保存模板。模板被保存在站点的本地根文件夹中的一个特殊 Templates 文件夹中。如果该 Templates 文件夹在站点中尚不存在，Dreamweaver 将在您保存新建模板时自动创建该文件夹。

备注： 不要将模板移动到 Templates 文件夹之外或者将任何非模板文件放在 Templates 文件夹中。此外，不要将 Templates 文件夹移动到本地根文件夹之外。这样做将在模板中的路径中引起错误。

相关主题

将文档另存为模板

插入可编辑区域

创建嵌套模板


将文档另存为模板

可以从新建文档或现有文档中创建模板。

如果将模板区域插入到一个尚未另存为模板的文档中，Dreamweaver 会告知您文档将自动另存为模板。

创建模板：
  1. 在“文档”窗口中打开想要另存为模板的文档，方法是执行下列操作之一：
    • 若要打开一个现有文档，请选择“文件”>“打开”并选择该文档。
    • 若要打开一个新的空文档，请选择“文件”>“新建”。在打开的对话框中选择“基本页”或“动态页”。在文档列表中选择想要使用的页面类型，然后单击“创建”。
  2. 文档打开时，选择“文件”>“另存为模板”。

    3. 备注： 除非您选择了“不再显示此对话框”，否则您将收到一个警告，表示您正在保存的文档中没有可编辑区域。单击“确定”将文档另存为模板，或单击“取消”退出此对话框而不创建模板。

  3. 在出现的对话框中，从“站点”弹出式菜单中选择一个用来保存模板的站点，并在“另存为”文本框中为模板输入一个唯一的名称。
    这是所描述的功能的图片。
  4. 单击“保存”。

    5. 模板文件被保存在站点的 Templates 文件夹中，文件扩展名为 .dwt。

使用“资源”面板创建新模板：
  1. 如果尚未打开“资源”模板，则打开它（使用“窗口”>“资源”命令或按 F11 键）。
  2. 选择“模板”类别。
  3. 单击“资源”面板中的“新建模板”按钮。

    4. “名称”列表中将添加一个新文档。文档名称被高亮显示。

  4. 为该文档键入一个名称。
  5. 在“资源”面板中单击“编辑”按钮。

    6. 在“文档”窗口中打开一个模板文档。

    有关在模板中创建可编辑区域的信息，请参见插入可编辑区域。


创建可编辑区域

可编辑模板区域控制基于模板的页面中的哪些区域可以编辑。

可以将整个表格或单独的表格单元格标记为可编辑的，但不能将多个表格单元格标记为单个可编辑区域。如果 <td> 被选定，则可编辑区域中包括单元格周围的区域；如果未选定，则可编辑区域将只影响单元格中的内容。

层和层内容是单独的元素；使层可编辑时可以更改层的位置及其内容，而使层的内容可编辑时只能更改层的内容而不是位置。若要选择层的内容，请在该层内单击并选择“编辑”>“全选”。若要选择该层，请确保显示了不可见元素，然后单击代表层的位置的图标。有关层的更多信息，请参见制作层动画。


插入可编辑区域

在插入可编辑区域之前，应该将您正在其中工作的文档另存为模板。如果您在文档（而不是模板文件）中插入一个可编辑区域，Dreamweaver 会警告您该文档将自动另存为模板。

定义可编辑模板区域：
  1. 在“文档”窗口中，执行下列操作之一选择区域：
    • 选择想要设置为可编辑区域的文本或内容。
    • 将插入点放在想要插入可编辑区域的地方。
  2. 执行下列操作之一插入可编辑区域：
    • 选择“插入”>“模板对象”>“可编辑区域”。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 所选文本或对象，然后从上下文菜单中选择“新建可编辑区域”。
    • 在“插入”栏中选择“模板”，然后单击“可编辑区域”按钮。

      • 出现“新建可编辑区域”对话框。

  3. 在“名称”文本框中为该区域输入唯一的名称。（不能对特定模板中的多个可编辑区域使用相同的名称。）

    4. 备注： 不要在“名称”域中使用特殊字符。

  4. 单击“确定”。

    5. 可编辑区域在模板中由高亮显示的矩形边框围绕，该边框使用在参数选择中设置的高亮颜色。有关设置模板高亮显示选项的信息，请参见设置模板高亮显示参数。

    该区域左上角的选项卡显示该区域的名称。如果在文档中插入空白的可编辑区域，则该区域的名称会出现在该区域内部。


删除可编辑区域

如果已经将模板文件的一个区域标记为可编辑，而现在想要再次锁定它（使其不可编辑），请使用“删除模板标记”命令。

备注： 不能锁定基于模板的文件内的区域；只能锁定模板文件中的区域。

删除可编辑区域：
  1. 在文档或标签选择器中，选择想要更改的可编辑区域。
  2. 选择“修改”>“模板”>“删除模板标记”。

    3. 现在，该区域不再是可编辑区域。


创建重复区域

重复区域在基于模板的文档中添加所选区域的多个拷贝。可以使用重复区域来控制想要在页面中重复的区域的布局（如目录项和说明布局），或者重复数据行（如项目列表）。

可以使用两种重复区域模板对象：

“重复区域”让您可以重复区域，但不包括可编辑区域。但是，可以在重复区域中插入可编辑区域以使其可编辑。

下面的范例显示模板中的重复区域。在基于此模板的文档中，用户能够重复高亮显示的表格行以扩展表格。

“重复表”让您可以定义表格并定义重复区域的每个单元格中哪里是可编辑区域。可以定义选项以控制将哪些行包括在重复区域中。

相关主题

在模板中创建重复区域

插入重复表格

添加、删除重复区域项以及更改其顺序


在模板中创建重复区域

重复区域是可以根据需要在基于模板的页面中拷贝任意次数的模板部分。重复区域通常用于表格；但是，也可以为其他页面元素定义重复区域。

重复区域不是可编辑区域。若要使重复区域中的内容可编辑（例如，让用户可以在表格单元格中输入文本），必须在重复区域内插入可编辑区域。有关创建可编辑区域的信息，请参见插入可编辑区域。有关创建可编辑重复表格的信息，请参见插入重复表格。

在模板中插入重复区域：
  1. 在“文档”窗口中执行下列操作之一：
    • 选择想要设置为重复区域的文本或内容。
    • 将插入点放入文档中想要插入重复区域的地方。
  2. 执行下列操作之一创建重复区域：
    • 选择“插入”>“模板对象”>“重复区域”。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 所选内容，然后从上下文菜单中选择“新建重复区域”。
    • 在“插入”栏的“模板”类别中单击“重复区域”按钮。

      • 出现“重复区域”对话框。

  3. 在“名称”文本框中为模板区域输入唯一的名称。（不能对一个模板中的多个重复区域使用相同的名称。）

    4. 备注： 命名区域时，不要使用特殊字符。

  4. 单击“确定”。

    5. 重复区域被插入到文档中。

    备注： 重复区域在基于模板的文档中是不可编辑的，除非其中包含可编辑区域。有关插入可编辑区域的信息，请参见插入可编辑区域。


插入重复表格

可以使用重复表格来定义包括表格格式的可编辑区域的重复区域。可以定义表格属性，并设置哪些表格单元格可编辑。

插入重复表格：
  1. 在“文档”窗口中，将插入点放在文档中想要插入重复表格的位置。
  2. 执行下列操作之一：
    • 选择“插入”>“模板对象”>“重复表”。
    • 右击 (Windows) 或按住 Control 键并单击 (Macintosh) 所选内容，然后从上下文菜单中选择“新建重复表格”。
    • 在“插入”栏的“模板”类别中，单击“重复表”按钮。

      • 出现“插入重复表格”对话框。
      这是所描述的功能的图片。

  3. 按需要输入新值。

    4. 有关更多信息，请参见设置“插入重复表格”对话框选项。

  4. 单击“确定”。


在重复区域中设置替换的背景颜色

可以通过替换表格行的背景颜色来自定义重复表格。

设置替换的表格行背景颜色：
  1. 在“文档”窗口中选择重复区域表格行。
  2. 单击“文档”工具栏中的“显示代码视图”或“显示代码视图和设计视图”按钮，以便可以访问所选表格行的代码。
  3. 在“代码”视图中编辑 <tr> 标签，使其包括下列代码：
    4. <tr bgcolor="@@(_index & 1) ?'#FFFFFF' :'#CCCCCC'@@">

可以用其他颜色值替换 #FFFFFF 和 #CCCCCC 十六进制值。

这是一个包含替换背景表格行颜色的表格的代码范例：

<table width="75%"  border="1"  cellspacing="0" cellpadding="0">
<tr><th>名称</th><th>电话号码</th><th>电子邮件地址</th></tr>

<!-- TemplateBeginRepeat name="contacts" -->
<tr bgcolor="@@(_index & 1) ?'#FFFFFF' :'#CCCCCC' @@">
<td> <!-- TemplateBeginEditable name="name" --> 名称 <!-- TemplateEndEditable -->
</td>
<td> <!-- TemplateBeginEditable name="phone" --> 电话 <!-- TemplateEndEditable -->
</td>
<td> <!-- TemplateBeginEditable name="email" --> 电子邮件 <!-- TemplateEndEditable -->
</td>
</tr>
  <!-- TemplateEndRepeat -->

</table>


定义可编辑标签属性

使用“使属性可编辑”命令可以使模板用户能够在从模板创建的文档中修改指定的标签属性。例如，您可以在模板文档中设置背景颜色，但仍允许模板用户为自己创建的页面设置不同的背景颜色。用户只能更新您定义为可编辑的属性。

创建可编辑标签属性时将在代码中插入一个模板参数。该属性的初始值在模板文档中设置；当创建基于模板的文档时，它将继承该参数。模板用户即可在文档中编辑该参数。

支持下列数据类型：文本、布尔值 (真/假)、颜色和 URL。有关设置可编辑标签属性的信息，请参见在模板中定义可编辑标签属性。

有关在基于模板的文档中编辑标签的信息，请参见修改模板属性。


在模板中定义可编辑标签属性

可以为一个页面元素设置多个可编辑属性。只有当前为该元素设置的标签属性会出现在“属性”弹出式菜单中。例如，对于图像标记来说，宽度和高度属性可能是仅有的出现在菜单中的属性。

如果想要令其可编辑的属性没有列在“属性”弹出式菜单中，请单击“添加”将该属性添加到列表中。

定义可编辑标签属性：
  1. 在“文档”窗口中，选择想要为其设置可编辑标签属性的项目。
  2. 选择“修改”>“模板”>“使属性可编辑”。
  3. 在出现的对话框中执行下列操作之一：
    • 如果想要使其可编辑的属性列在“属性”弹出式菜单中，请选定它。
    • 如果想要使其可编辑的属性没有列在“属性”弹出式菜单中，请单击“添加”，然后在打开的对话框中输入想要添加的属性名称，再单击“确定”。
  4. 请确保“使属性可编辑”选项被选定。

    5. 完成对话框中的各个域以设置需要的值。

  5. 在“标签文字”文本框中，为属性输入唯一的名称。

    6. 提示： 若要使以后标识特定的可编辑标签属性变得更加容易，请使用标识元素和属性的标签。例如，可以将具有可编辑源的图像标为 logoSrc，或者将 body 标签的可编辑背景颜色标为 bodyBgcolor。

  6. 在“类型”弹出式菜单中，选择该属性所允许具有的值的类型，方法是设置下列选项之一：
    • 若要让用户为属性输入文本值，请选择“文本”。例如，可以使用带有 align 属性的文本；然后，用户就可以将该属性的值设置为左对齐、右对齐 或居中对齐。
    • 若要设置元素的链接（如图像的文件路径），请选择“URL”。使用 URL 可以让 Dreamweaver 自动更新链接中使用的路径。如果用户将图像移动到新的文件夹，则会出现“更新链接”对话框。
    • 若要使颜色选择器可用于选择值，请选择“颜色”。
    • 若要让模板用户可以键入数值以更新属性（例如，更改图像的高度或宽度值），请选择“数字”。
  7. “默认”域在模板中显示所选标签属性的值。在此域中输入一个新值，为基于模板的文档中的参数设置一个不同的初始值。
  8. 如果想要更改所选标记的其他属性，请重复第 3 步到第 7 步。
  9. 单击“确定”。


使可编辑标记属性不可编辑

可以将先前标为可编辑的标记标为不可编辑。在模板中进行更改并更新派生自该模板的页面。

重置可编辑标记属性：
  1. 在模板文档中，单击与可编辑属性相关联的元素，或使用标签选择器来选择标记。
  2. 选择“修改”>“模板”>“使属性可编辑”。
  3. 在“属性”弹出式菜单中，选择您要影响的属性。
  4. 取消选择“使属性可编辑”复选框。
  5. 单击“确定”。


关于可选区域

可选区域是模板中的区域，可将其设置为在基于模板的文档中显示或隐藏。当想要为在文档中显示内容设置条件时，请使用可选区域。可以为模板参数设置特定值，或在模板中定义条件语句。根据您在模板中定义的条件，用户可以在他们创建的文档中编辑参数并控制可选区域是否显示。

可以在“新建可选区域”对话框中或直接在“代码”视图中创建模板参数和表达式。当使用“可选区域”模板对象时，Dreamweaver 将在代码中插入模板注释。

模板参数在 head 部分中定义：

<!-- TemplateParam name="departmentImage" type="boolean" value="true" -->

在插入可选区域的位置，将出现类似于下列代码的代码：

<!-- TemplateBeginIf cond="departmentImage" -->
<p><img src="/images/airfare_on.gif" width="85" height="22"> </p>
<!-- TemplateEndIf -->

可以在基于模板的文档中访问和编辑您为可选区域创建的模板参数，方法是使用“模板属性”对话框（“修改”>“模板属性”）。

有两种可选区域对象：一种让模板创作者可以控制显示和隐藏哪些区域，而不让用户编辑内容；而另一种让模板用户编辑内容并设置区域显示还是隐藏。

相关主题

插入可选区域

修改模板属性

编写模板表达式


插入可选区域

使用可选区域可以控制不一定在基于模板的文档中显示的内容。可选区域是由条件语句控制的。可选区域的模板选项卡在单词 if 之后。根据模板中设置的条件，模板用户可以定义该区域在他们所创建的页面中是否可见。

可编辑的可选区域让模板用户可以在可选区域内编辑内容。例如，如果可选区域中包括图像或文本，模板用户即可设置该内容是否显示，并根据需要对该内容进行编辑。可编辑区域是由条件语句控制的。您可以在“新建可选区域”对话框中创建模板参数和表达式，或通过在“代码”视图中键入参数和条件语句来创建。

插入可选区域：
  1. 在“文档”窗口中，选择想要设置为可选区域的元素。
  2. 执行下列操作之一：
    • 在“插入”栏中选择“模板”类别，然后选择“可选区域”按钮。
    • 选择“插入”>“模板对象”>“可选区域”。
    • 右击所选内容，并在上下文菜单中选择“新建可选区域”。
  3. 为可选区域定义选项。

    4. 有关定义可选区域的信息，请参见设置“新建可选区域”对话框选项。

  4. 单击“确定”。
插入可编辑的可选区域：
  1. 在“文档”窗口中，将指针放在想要插入可选区域的地方。

    2. 提示： 不能环绕选定内容来创建可编辑的可选区域。应插入区域，然后在该区域内插入内容。

  2. 执行下列操作之一打开“新建可选区域”对话框：
    • 在“插入”栏中选择“模板”类别，然后选择“可编辑的可选区域”按钮。
    • 选择“插入”>“模板对象”>“可编辑的可选区域”。
    • 右击所选内容，并在上下文菜单中选择“可编辑的可选区域”。

      • 出现“新建可选区域”对话框。

  3. 为可选区域定义选项。

    4. 有关定义可选区域的信息，请参见设置“新建可选区域”对话框选项。

  4. 单击“确定”。


修改可选区域

在模板中插入可选区域之后，可以编辑该区域的设置。例如，可以对是否显示内容默认值的设置进行更改，将参数链接到现有可选区域，或者修改模板表达式。

重新打开“新建可选区域”对话框：
  1. 如果属性检查器尚未打开，请将其打开。
  2. 在“文档”窗口中执行下列操作之一：
    • 在“设计”视图中，单击想要修改的可编辑区域的模板选项卡。
    • 在“设计”视图中，单击模板区域内的内容，然后在标签选择器中单击模板标记 <mmtemplate:if>。
    • 在“代码”视图中，单击想要修改的模板区域的注释标记。
  3. 在属性检查器中单击“编辑”。

    4. 出现“新建可选区域”对话框。

  4. 进行所需更改，然后单击“确定”。


创建基于模板的文档

在设置了模板设计之后，即可向空文档或已包含内容的文档应用模板。

若要基于模板创建新文档，可以使用“资源”面板或“新建文档”对话框。“资源”面板列出当前 Dreamweaver 站点中的模板。可以在“资源”面板的“模板”类别中右击，以创建新模板或者从模板创建新文档。

在“新建文档”对话框中，可以从任何当前已定义的 Dreamweaver 站点中选择模板，并从它创建新文档。当基于模板创建新文档时，可以选择是否仍然将文档附着在模板上。默认情况下，当更改模板时，所有附着的文档都将更新以反映模板的更改。如果在创建新文档时取消选择“当模板改变时更新页面”选项，新文档将创建为信纸：一个独立的 HTML 文件，没有任何模板区域。对模板所作的更新不会更改文档。

在“新建文档”对话框中创建基于模板的文档：
  1. 选择“文件”>“新建”打开“新建文档”对话框。
  2. 在“新建文档”对话框中选择“模板”选项卡。
  3. 在“模板用于”列表中选择包含想要使用的模板的站点。

    4. 站点模板列出所作的更新，以显示所选站点中的模板。

  4. 在该列表中选择想要使用的模板。
  5. 单击“创建”创建一个基于模板的新页面。

    6. 文档在“文档”窗口中打开。

从“资源”面板中的模板创建新文档：
  1. 如果“资源”面板尚未打开，请将其打开 (F11)。
  2. 在“资源”模板中，单击“模板”图标查看站点模板。

    3. 提示： 如果您刚刚创建了想要应用的模板，可能需要单击“刷新”按钮才能看到。

  3. 右击想要应用的模板，然后选择“从模板新建”。

    4. 在“文档”窗口中打开文档。


在基于模板的页面中编辑内容

在模板文档和基于模板的文档中，都可以容易地标识和选择模板区域。可编辑模板区域列在“修改”>“模板”子菜单的底部。

重复区域内的可编辑区域不会出现在该菜单中。必须通过在“文档”窗口中查找选项卡式的边框来定位这些区域。

有关在基于模板的文档中定位和修改可编辑标记的信息，请参见修改模板属性。

在文档中查找可编辑区域并选择它

选择“修改”>“模板”，然后从该子菜单底部的列表中选择区域的名称。

可编辑区域在文档中被选定。


修改模板属性

在模板中创建参数时，基于该模板的文档将自动继承这些参数以及它们的初始值设置。模板用户可以在“模板属性”对话框中更新可编辑标记属性以及其他模板参数（如可选区域设置）。

有关在模板中创建可编辑标记的信息，请参见在模板中定义可编辑标签属性。有关创建可选区域的信息，请参见插入可选区域。

修改可编辑标记属性：
  1. 打开基于模板的文档，然后选择“修改”>“模板属性”。

    2. 即会打开“模板属性”对话框。下面的范例显示了两种模板属性。一种是可选区域，另一种是模板的背景颜色的可编辑标记属性。
    这是所描述的功能的图片。

  2. 在“名称”列表中选择属性。

    3. 对话框的底部区域将更新，以显示所选属性的标签及其指定值。
    这是所描述的功能的图片。

  3. 在属性标签右侧的域中，编辑该值以修改文档中的属性。

    4. 备注： 域名称和可更新的值在模板中定义。不出现在“名称”列表中的属性在文档中不可更新。

  4. 如果正在嵌套模板中定义可编辑标记属性，请执行下列操作之一设置是否将参数传递到基于该嵌套模板的文档中：
    • 选中“允许嵌套模板以控制此”复选框，将可编辑属性传递到基于该嵌套模板的文档；该参数将出现在基于该嵌套模板的文档的“模板属性”对话框中。
    • 若要防止传递该参数，请不要选中此选项。


修改可选区域模板参数

  1. 打开基于模板的文档，然后选择“修改”>“模板属性”。

    2. 即会打开“模板属性”对话框。

  2. 在“名称”列表中选择一个属性。

    3. 该对话框将更新以显示所选属性的标签及其指定值。
    这是所描述的功能的图片。

  3. 选择“显示”复选框以显示文档中的可选区域，或取消选择该复选框将其隐藏。

    4. 备注： 域名称和默认设置在模板中定义。

  4. 选中“允许嵌套模板以控制此”复选框，将可编辑属性传递到基于该嵌套模板的文档。


添加、删除重复区域项以及更改其顺序

使用重复区域控件可以添加、删除项或更改项的顺序。当添加重复区域项时，将添加整个重复区域的拷贝。为了更新重复区域中的内容，原始模板的重复区域中必须包括一个可编辑区域。

也可以在“修改”>“模板”菜单和“编辑”>“重复项”菜单中找到用于编辑重复区域的选项。

添加、删除重复区域或更改重复区域的顺序：

将插入点放在重复区域中将其选定，然后执行下列操作之一：

  • 单击加号 (+) 按钮在当前所选项下面添加一个重复区域。
  • 单击减号 (-) 按钮删除所选重复区域项。
  • 单击“向下箭头”按钮将所选项向下移动一个位置。
  • 单击“向上箭头”按钮将所选项向上移动一个位置。
  • 选择“修改”>“模板”>“重复项”，然后从菜单中选择一个选项。可以使用此菜单插入新的重复项或移动所选项的位置。
剪切、拷贝和删除项：

将插入点放在重复区域中，将其选定，然后执行下列操作之一：

  • 选择“编辑”>“重复项”>“剪切重复项”剪切重复项。
  • 选择“编辑”>“重复项”>“拷贝重复项”拷贝重复项。
  • 选择“编辑”>“重复项”>“删除重复项”删除重复项。
  • 选择“编辑”>“粘贴”粘贴重复项。

    • 粘贴操作将插入新项；它并不替换现有项。


关于嵌套模板

嵌套模板是指其设计和可编辑区域都基于另一个模板的模板。若要创建嵌套模板，必须首先保存原始模板或基本模板，然后基于该模板创建新文档，最后将该文档另存为模板。在新模板中，可以在原来在基本模板中定义为可编辑的区域中进一步定义可编辑区域。

嵌套模板对于控制共享许多设计元素的站点页面中的内容很有用，但在各页之间有些差异。例如，基本模板中可能包含更宽广的设计区域，并且可以由站点的许多内容提供者使用，而嵌套模板可能进一步定义站点内特定部分页面中的可编辑区域。

基本模板中的可编辑区域被传递到嵌套模板，并在根据嵌套模板创建的页面中保持可编辑，除非在这些区域中插入了新的模板区域。

对基本模板所做的更改在基于基本模板的模板中自动更新，并在所有基于主模板和嵌套模板的文档中自动更新。

例如：Global Car Rental（全球汽车租赁）站点的基本模板中包含两个可编辑区域，分别名为 body 和 footer：

为了创建嵌套模板，我们已经基于该模板创建了一个新文档，然后将该文档保存为模板并命名为 globalNested。在嵌套模板中，我们更改了名为 body 的可编辑区域。我们在左列中插入一幅图形，在右列中插入了一个新的可编辑区域。

当您在传递到嵌套模板的可编辑区域内添加新的可编辑区域时，该可编辑区域的高亮颜色变为橙色。您在可编辑区域中添加的内容（如左列的图形）在基于该嵌套模板的文档中不再是可编辑的。蓝色的高亮显示可编辑区域（无论是添加到嵌套模板的还是从基本模板传递的）在基于该嵌套模板的文档中仍然是可编辑的。您没有在其中插入可编辑区域的模板区域作为可编辑区域传递到基于模板的文档。

相关主题

控制嵌套模板中的可编辑区域


创建嵌套模板

您可以通过保存一个基于模板的文档，然后创建该文档的新模板来创建嵌套模板。嵌套模板使您可以创建基本模板的变体。您可以嵌套多个模板来定义更加精确的布局。

创建嵌套模板：

  1. 从想要作为嵌套模板的基础的模板创建一个文档，方法是执行下列操作之一：
    • 在“资源”面板的“模板”类别中右击想要从其创建新文档的模板，然后选择“从模板新建”。
    • 选择“文件”>“新建”。在“新建文档”对话框中，单击“模板”选项卡并选择包含想要使用的模板的站点；然后在文档列表中双击该模板以创建新文档。

      • “文档”窗口中即会出现一个新文档。

  2. 选择“文件”>“另存为模板”或在“插入”栏中单击“创建嵌套模板”按钮，将新文档另存为模板。
  3. 在新模板中添加其他内容和可编辑区域。
  4. 保存该模板。

    5. 在基于嵌套模板的文档中，可以添加或更改从基本模板传递的可编辑区域（以及在新模板中创建的可编辑区域）中的内容。


将模板应用到现有文档

当您将模板应用到包含现有内容的文档时，Dreamweaver 将尝试将现有内容与模板中的区域进行匹配。如果您应用的是现有模板之一的修订版本，则名称可能会匹配。Dreamweaver 将文档中可编辑区域的名称与新模板中可编辑区域的名称进行比较；对于每个匹配的区域名称，Dreamweaver 会将该区域的现有内容放入同名的新区域中。

如果您将模板应用到一个尚未应用过模板的文档时，将没有可编辑区域可以进行比较，于是会出现不匹配。

Dreamweaver 跟踪这些不匹配名称并将它们列在“不一致的区域名称”对话框中。然后，您可以选择将当前页的内容移动到哪些区域，或者可以选择删除不匹配的内容。如果您想要保留这些内容，请从对话框的弹出式菜单中选择可编辑区域的名称；否则，请选择“不在任何地方”，这将放弃未解决的内容。

将模板应用到现有文档：
  1. 选择“文件”>“打开”打开想要将模板应用到的文档。
  2. 执行下列操作之一：
    • 在“文档”窗口中单击，然后选择“修改”>“模板”>“套用模板到页”。从列表中选择一个模板并单击“选择”。
    • 在“资源”面板的“模板”类别中选择模板，然后单击“应用”按钮。
    • 将模板从“资源”面板的“模板”类别拖动到“文档”窗口的“设计”视图。
  3. 如果文档中有不能自动指定到模板区域的内容，则会出现“不一致的区域名称”对话框。它将列出要应用的模板中的所有可编辑区域。可以使用它来为内容选择目标。

    4. 有关将现有内容移动到文档可编辑区域的信息，请参见解决不一致的区域名称。


从模板分离文档

若要更改基于模板的文档的锁定区域，必须将该文档从模板分离。将文档分离之后，整个文档都将变为可编辑的。

从模板分离文档：
  1. 打开想要分离的基于模板的文档。
  2. 选择“修改”>“模板”>“从模板中分离”。

    3. 文档被从模板分离，所有模板代码都被删除。


编辑和更新模板

保存模板时，Dreamweaver 会询问它是否应该更新所有附着到该模板的文档。可以使用“修改”>“模板”>“刷新页面”命令。Dreamweaver 在该模板所在的站点中更新基于模板的文档。Dreamweaver 将自动更新基于该模板的文档，包括基于您正在更新的模板的嵌套模板。


更新 Dreamweaver 4 模板

在 Dreamweaver 的当前版本中，可以继续使用在 Dreamweaver 4 中创建的模板。Dreamweaver 不会自动更改 Dreamweaver 4 模板文件中的模板语法，因此这些文件可以同时用于 Dreamweaver 4 和 Dreamweaver MX。但是，如果您使用 Dreamweaver MX 在 Dreamweaver 4 模板中插入新的模板区域，它将使用新的 Dreamweaver MX 模板语法，并且您将不再能够在 Dreamweaver 4 中使用该模板。


更新基于模板的文档

当您更改模板时，Dreamweaver 将提示您更新基于该模板的文档。您还可以使用更新命令来手动更新当前文档或整个站点。使用更新命令与重新应用模板相同。

打开并修改附着的模板：
  1. 对于“文档”窗口中基于模板的文档，选择“修改”>“模板”>“打开附加模板”。
  2. 根据需要修改模板的内容。若要修改模板的页面属性，请选择“修改”>“页面属性”。（基于模板的文档将继承该模板的页面属性。）
  3. 保存您的文档。Dreamweaver 提示您更新基于该模板的页面。
将模板更改应用到文档：

选择“修改”>“模板”>“刷新当前页”。

更新整个站点或所有使用附着模板的文档：
  1. 选择“修改”>“模板”>“刷新页面”。

    2. 即会出现“更新页面”对话框。

  2. 在“查看”弹出式菜单中执行下列操作之一：
    • 选择“整个站点”，然后从相邻的弹出式菜单中选择站点名称。这将把所选站点中的所有页面更新到相应的模板。
    • 选择“文件使用”，然后从相邻的弹出式菜单中选择模板名称。这将更新当前站点中使用所选模板的所有页面。
  3. 请确保在“更新”选项中选定了“模板”。
  4. 单击“开始”。

    5. Dreamweaver 按照指示更新文件。如果选择了“显示记录”选项，Dreamweaver 将提供关于它试图更新的文件的信息，包括它们是否成功更新的信息。


检查模板语法

当保存模板时，Dreamweaver 自动检查模板语法。如果语法格式错误，则会出现一个错误信息对话框。错误信息将描述错误并指出代码中存在错误的特定行。

您可以在保存模板之前使用“检查模板语法”命令检查模板语法。例如，如果您在“代码”视图中手动添加模板参数或表达式，可使用该命令检查代码是否遵循正确的语法。

若要检查模板语法是否有效，请执行下列操作之一：

选择“修改”>“模板”>“检查模板语法”。

相关主题

编写模板表达式

关于“表达式对象模型”

模板标记语法


关于 XML

可扩展标记语言 (XML) 是一种用于结构化文档的标记语言。可以将它看作使您可以定义标记的广义化的 HTML。XML 是从标准通用标记语言 (SGML) 衍生而来的。与 SGML 类似，XML 是一种用于定义标记集以及它们之间关系的语言。

XML 中的标记与 HTML 标签类似，由标记名称和可选属性组成，并用尖括号括起来。与 HTML 相同，内容包含在开始标记和结束标记（其中标记名称前面有一个斜杠）之间。一个语法上的差别是：在 XML 中，空标记（只使用单个标记的标记，如 <img>，而不是包含文本或其他内容的开始标记和结束标记）必须以斜杠结束，且该斜杠刚好位于结束尖括号之前。例如，XML 中的 <img> 标记可能会类似于下列范例：

<img src="test.png" />

XML 在语法上比 HTML 还要严格；没有严格遵守 XML 语法的文件会被 XML 解析程序拒绝。

XML 提供了一种标记文字字符串的方法，能够包括不应被分析的标记。这种方法涉及到一个称为 CDATA 部分的元素，它包括一个由方括号括起来的文字字符串。方括号中的任何内容都被 XML 解析程序跳过。Dreamweaver 导出的 XML 大量使用 CDATA 部分。


导出和导入模板 XML 内容

基于模板的文档中包含一组由名称/值对表示的数据。每一对由可编辑区域的名称及该区域的内容组成。假设您的模板中包含三个可编辑区域：item_number、item_price 和 item_color。通过提供模板的名称和名称/值对，即可完全描述基于该模板的文档。

Dreamweaver 使您可以将名称/值对导出到 XML 文件中，这样您就可以在 Dreamweaver 外部（例如，在 XML 编辑器或文本编辑器中，或者在数据库应用程序中）使用数据了。反之，如果您的 XML 文档经过适当地组织，则可以将该文档中的数据导入到基于 Dreamweaver 模板的文档中。有关更多信息，请参见关于 XML。

将文档的可编辑区域导出为 XML：
  1. 选择“文件”>“打开”，然后打开一个基于模板并包含可编辑区域的文档。
  2. 选择“文件”>“导出”>“作为 XML 的数据模板”。
  3. 在“以 XML 形式导出模板数据”对话框中的“符号”下面，选择下列选项之一：
    • 如果文档中包含重复区域或模板参数，请选择“使用标准 Dreamweaver XML 标签”。
    • 对于不包含重复区域或模板参数的模板，请选择“使用可编辑区域名称作为 XML 标签”。
  4. 单击“确定”。
  5. 在随后出现的对话框中输入 XML 文件的名称并单击“保存”。

    6. Dreamweaver 生成一个 XML 文件，其中包含文档的参数和可编辑区域（包括重复区域或可选区域内的可编辑区域）中的资料。此 XML 文件中包括原始模板的名称以及每个模板区域的名称和内容。

    备注： 不可编辑区域中的内容不会导出到此 XML 文件中。

导入 XML 内容：
  1. 选择“文件”>“导入”>“XML 到模板”。
  2. 在“导入 XML”对话框中选择 XML 文件并单击“打开”。

Dreamweaver 基于 XML 文件中指定的模板创建一个新的文档。它还使用 XML 文件中的数据填充该文档中每个可编辑区域的内容。结果文档出现在新的“文档”窗口中。

请注意，如果您的 XML 文件并非完全按照 Dreamweaver 所期望的方式设置，您可能无法导入数据。此问题的一个解决方法是从 Dreamweaver 导出一个空白 XML 文件，这样您将得到一个结构完全正确的 XML 文件。然后从原始 XML 文件向导出的 XML 文件中拷贝数据。结果生成一个包含适当数据且结构正确的 XML 文件，为导入操作做好准备。

相关主题

导出不具有模板标记的站点


使用 XML 标记注释

Dreamweaver 让您可以使用标准 Dreamweaver XML 标记导出 XML 内容。

如果您理解 XML 语法，那么查看标记注释的最简单方法就是查看一个范例。下列 XML 代码是从一个文档导出的，该文档基于一个名为 newstemplate 的模板。该文档中包含一个已定义的可编辑区域，名为 News_Story（以及一个默认的可编辑区域 doctitle，它包含文档的 title 标记）。

标准的 Dreamweaver XML 标记使用一个名为 item 的标记。item 标记有一个 name 属性，该属性给出可编辑区域的名称；该标记还包含一个 CDATA 部分，它包含可编辑区域的内容。在本范例中，具有 name="doctitle"属性的 item 标记标识该文档的标题，而具有 name="News_Story" 属性的 item 标记标识可编辑区域。

<?xml version="1.0"?>
<templateItems template="/Templates/newstemplate.dwt">
   <item name="doctitle">
      <![CDATA[<title>今日标题新闻</title>]]>
   </item>
   <item name="News_Story">
      <![CDATA[<p>此处为新闻的具体内容。</p>]]>
   </item>
</templateItems>


设置“库”高亮显示参数

您可以通过设置“标记色彩”参数选择来自定义库项目的高亮颜色，并显示或隐藏库项目的高亮显示。

更改库项目的高亮颜色：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后选择“标记色彩”类别。
  2. 单击“库项目”颜色框并使用颜色选择器来选择一种高亮颜色（或在文本框中输入高亮颜色的十六进制值）。有关使用颜色选择器的信息，请参见使用颜色。
  3. 选择“显示”以在“文档”窗口中显示高亮库颜色。
  4. 单击“确定”关闭“参数选择”对话框。
在“文档”窗口中查看高亮颜色：

选择“查看”>“可视化助理”>“不可见元素”。

只有在启用了“查看”>“可视化助理”>“不可见元素”，并且在“标记色彩”参数选择中启用了适当选项时，高亮颜色才会出现在文档窗口中。

相关主题

设置“标记色彩”参数


设置库项目属性

使用库项目属性可以指定项目的源文件，使其可编辑或在文档中编辑其实例后重新创建原始库项目。若要打开属性检查器，请在文档中选择库项目。

有关库项目的更多信息，请参见导出和导入模板 XML 内容。

“Src”显示库项目源文件的文件名和位置。不能编辑此信息。

“打开”打开库项目的源文件进行编辑。这等同于在“资源”面板中选择项目并单击“编辑”按钮。

“从源文件中分离”用于断开所选库项目及其源文件之间的链接。当分离一个项目时，它可以在文档中进行编辑，但它不再是库项目并且不能在更改原始库项目时更新。

“重新创建”用当前选定内容改写原始库项目。使用此选项可以在丢失或意外删除原始库项目时重新创建库项目。


设置模板高亮显示参数

在“设计”视图中，可以使用 Dreamweaver 高亮显示参数选择来自定义模板的可编辑区域和锁定区域周围边框的高亮颜色。可编辑区域的颜色出现在模板和基于该模板的文档中。

更改模板高亮颜色：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后选择“标记色彩”类别。
  2. 单击“可编辑区域”颜色框并使用颜色选择器选择一种高亮颜色（或在文本框中输入该高亮颜色的十六进制值）。此过程对于“嵌套可编辑”和“锁定的区域”完全相同。有关使用颜色选择器的信息，请参见使用颜色。
  3. 单击“显示”选项在“文档”窗口中启用或禁用颜色显示。

    4. “嵌套可编辑”没有“显示”选项；它的显示由“可编辑区域”选项控制。

  4. 单击“确定”。
在“文档”窗口中查看高亮颜色：

选择“查看”>“可视化助理”>“不可见元素”。

只有在启用了“查看”>“可视化助理”>“不可见元素”并且在“标记色彩”参数选择中启用了适当的选项时，高亮颜色才会出现在文档窗口中。

备注： 如果显示了不可见元素，但未显示高亮颜色，请选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)，然后确保选定了适当的高亮颜色旁边的“显示”选项。还要确保所需的颜色在页面背景颜色上可见。（如果您患有色盲，您可能需要将高亮颜色从默认值更改为更显著的颜色。）

相关主题

设置“标记色彩”参数


为模板文档设置代码颜色参数

可以为模板和其他 HTML 文档中的格式设置代码设置颜色参数。颜色参数选择控制如何在“代码”视图中对 HTML 标记和脚本进行颜色编码。可以使用颜色参数选择来控制在“代码”视图中显示的文本的文本颜色、背景颜色和样式属性。

还可以使用“参数选择”的“代码颜色”类别来设置自己的配色方案，以便在“代码”视图中查看文档时可以轻松地区分模板区域。

为模板设置“代码”视图配色方案：
  1. 选择“编辑”>“参数选择”或“Dreamweaver”>“参数选择”(Mac OS X)。
  2. 在“类别”列表中选择“代码颜色”，再在“文档类型”列表中选择“HTML”，然后单击“编辑颜色方案”。
  3. 在随后出现的对话框的“样式”列表中选择“模板标记”。
  4. 为“代码”视图文本设置颜色、背景颜色和样式属性，方法是执行下列操作之一：
    • 如果想要更改文本颜色，请在“文本颜色”文本框中键入想要应用于所选文本的颜色的十六进制值，或者使用颜色选择器来选择一种应用于文本的颜色。在“背景颜色”域进行相同操作，添加或更改所选文本的现有背景颜色。
    • 如果想要向所选代码添加样式属性，请单击“B”（粗体）、“I”（斜体）或“U”（下划线）按钮来设置所需样式。

相关主题

设置“代码颜色”参数


设置“插入重复表格”对话框选项

此对话框允许您在插入重复表格之前指定其属性。

完成“插入重复表格”对话框
  1. 指定下列选项：

    2. “行数”确定表格中的行数。

    “列数”确定表格中的列数。

    “单元格填充”确定单元格的内容与其边框之间的像素数。

    “单元格间距”确定相邻表格单元格之间的像素数。

    提示： 当您没有明确为单元格间距和单元格填充指定值时，大多数浏览器显示表格的方式类似于将单元格填充设置为 1 而将单元格间距设置为 2。若要确保浏览器在显示表格时没有填充或间距，请将“单元格填充”和“单元格间距”设置为 0。

    “宽度”以像素为单位指定表格的宽度，或者以浏览器窗口宽度的百分比来指定表格宽度。

    “边框”以像素为单位指定表格边框的宽度。

    提示： 当您没有明确为边框指定值时，大多数浏览器显示表格的方式类似于将边框设置为 1。若要确保浏览器在显示表格时不带边框，请将“边框”设置为 0。若要查看边框设置为 0 时的单元格和表格边框，请选择“查看”>“可视化助理”>“表格边框”。

    “重复表格行”指定表格中的哪些行包括在重复区域中。

    “起始行”将输入的行号设置为包括在重复区域中的第一行。

    “结束行”将输入的行号设置为包括在重复区域中的最后一行。

    “区域名称”让您为重复区域定义唯一的名称。

  2. 单击“确定”插入表格。


设置“新建可选区域”对话框选项

您可以使用“新建可选区域”对话框来创建模板参数并为模板区域定义条件语句（If...else 语句）。可以使用简单的真/假操作，或定义更复杂的条件语句和表达式。

“高级”选项卡中的选项允许模板创作者将多个可选区域链接到一个已命名的参数。在基于模板的文档中，两个参数将作为一个整体显示或隐藏。例如，可以显示销售产品的“出清存货”图像和销售价格文本区域。还可以使用“高级”选项卡编写一个用来计算可选区域的值的模板表达式，并根据该值来显示或隐藏可选区域。有关编写表达式的更多信息，请参见编写模板表达式。

创建模板参数：
  1. 在“新建可选区域”对话框的“基本”选项卡中，把参数的名称输入“名称”域。
  2. 选择“按默认值显示”复选框以设置要在文档中显示的选定区域。取消选择该复选框将把默认值设置为假。
  3. 单击“确定”。

    4. 备注： 若要为参数设置不同的值，请在“代码”视图中文档的 head 部分定位该参数，然后编辑它的值。

链接可选区域参数：
  1. 在“新建可选区域”对话框的“高级”选项卡中选择“使用参数”。
  2. 在“使用参数”选项右侧的弹出式菜单中，选择要与选定内容链接的现有参数。
用模板表达式控制可选区域的显示：
  1. 在“新建可选区域”对话框的“高级”选项卡中选择“输入表达式”。
  2. 在文本框中输入表达式。

    3. 提示： Dreamweaver 自动在您输入的文本两侧插入双引号。

  3. 单击“确定”。


解决不一致的区域名称

可以使用“不一致的区域名称”对话框将文档中的内容指定给模板区域。可以通过将该内容指定给模板区域或放弃该内容来解决不一致性。

当要应用的模板和要将该模板应用到的文档不具有匹配的可编辑区域名称时，即会出现此对话框。如果将模板应用到从未应用过模板因而不包含可编辑区域名称的文档，则可能发生这种情况；或者，当您将模板应用到附着到另一个模板并且包含不同的可编辑区域名称、可编辑标记属性或模板参数的文档时，也会发生这种情况。

若要解决不一致性，必须指示 Dreamweaver 将文档内容移到什么位置，或指示 Dreamweaver 放弃该内容。

单击“取消”可以取消将模板应用到文档的操作。如果您对站点中的模板比较熟悉，可以通过将要应用的模板中的区域名称与文档中的模板区域进行比较来解决不一致性。然后，可以添加与新模板文件中的区域同名的新区域，方法是更新原始模板或者改变新模板中的区域名称以匹配文档中的区域。有关在文档中定位模板区域的信息，请参见在基于模板的页面中编辑内容。

将现有内容指定给新文档中的可编辑区域：
  1. 在“不一致的区域”对话框中选择未解决的区域。在“将内容移到新区域”弹出式菜单中，选择新模板中要将现有内容移到其中的区域，或者选择“不在任何地方”将该内容从文档中删除。
  2. 若要将所有未解决的内容移到选定的区域，请单击“用于所有内容”。
  3. 单击“确定”。
撤消模板更改：

将模板应用到文档后，如果得到的不是您预期的效果，则可以使用“编辑”>“撤消应用模板”回复到应用模板前的文档状态。


导出不具有模板标记的站点

如果不想在导出到其他站点的基于模板的文档中包含模板标记，请使用“导出不具有模板标记的站点”命令。

删除已导出站点中的模板标记：
  1. 选择“修改”>“模板”>“不带标记导出”。

    2. 即会出现“导出不具有模板标记的站点”对话框。

  2. 在“文件夹”文本域中，输入要将文件导出到的文件夹的文件路径，或者单击“浏览”并选择该文件夹。

    3. 必须在当前站点外部选择一个将该站点解压缩到的文件夹。

  3. 如果需要，选择其他文件导出选项。

    4. 若要保存已导出的基于模板的文档的 XML 版本，请选择“保留模板数据文件”，然后单击“确定”。

    若要将更改更新到以前导出的文件，请选择“只解压缩已更改的文件”。

相关主题

导出和导入模板 XML 内容


控制嵌套模板中的可编辑区域

嵌套模板是从它所基于的模板继承可编辑区域的模板。默认情况下，基本模板中的所有可编辑模板区域都通过嵌套模板传递到基于该嵌套模板的文档。这意味着，如果在基本模板中创建一个可编辑区域，再创建一个嵌套模板，只要您没有在嵌套模板的该区域中插入任何新的模板区域，该可编辑区域将会出现在基于嵌套模板的文档中。

使用嵌套模板时，将得到基于该嵌套模板的文档中某个区域是否可编辑的即时反馈。传递的可编辑区域具有蓝色边框。如果在可编辑区域中插入模板标记，该边框将更改为橙色，表示该区域不会传递到文档。

仅当您不想在可编辑区域中插入新的模板对象，并且不想将该区域在基于嵌套模板的文档中变为可编辑区域时，才需要下面的代码。这些代码在模板区域中插入一个空白字符串。

防止可编辑区域传递到嵌套模板：
  1. 在“代码”视图中，定位要防止其传递的可编辑区域的模板注释标记。
  2. 输入 @@”“@@。


编写模板表达式

模板表达式是用于计算或估算值的语句。可以在“代码”视图或“新建可选区域”对话框中定义表达式。

有两种以代码形式定义表达式的方式：使用 <!-- TemplateExpr:expr =“您的表达式”--> 注释，或 @@您的表达式@@。在模板中插入表达式。应用模板时，Dreamweaver 计算表达式并在基于模板的文档中显示其值。

可以使用表达式存储值并在文档中显示它。例如，表达式可能像一个参数的值一样简单，如 @@ParamA@@，也可能复杂到需要计算用于替换表格行背景颜色的值，如 @@(_index&1) ? red :blue @@。

您还可以为假设和多重假设条件定义表达式。当表达式被用在条件语句中时，它将计算为真或假。如果条件为真，则将显示可选区域；如果条件为假，则不显示。

可以使用“插入可选区域”命令编写基本模板表达式；有关插入可选区域的信息，请参见插入可选区域。可以在“代码”视图中直接定义更复杂的条件，如多重假设条件或计算的文本条件。若要查看多重假设代码范例，请参见创建“多重假设”条件。

在代码中编写模板表达式时，“设计”视图中将出现表达式标记。若要在“设计”视图中编辑表达式，请选择该标记并在属性检查器中修改该项。

模板表达式语言是 JavaScript 的一个小子集，并使用 JavaScript 语法和优先级规则。可以使用 JavaScript 运算符来编写这样的表达式：

@@firstName+lastName@@

支持下列功能和运算符：

  • 数字文本、字符串文本（仅限于双引号语法）和布尔值文本（true 或 false）
  • 变量引用（请参见“已定义变量的表达式对象模型”）
  • 域引用（“点”运算符）
  • 一元运算符： +, -, ~, !
  • 二元运算符： +, -, *, /, %, &, |, ^, &&, ||, <, <=, >, >=, ==, !=, <<, >>
  • 条件运算符： ?:
  • 括号： ()

使用下列类型：布尔型、IEEE 64 位浮点型、字符串和对象。唯一可用的对象是由关于“表达式对象模型”定义的对象。

Dreamweaver 模板不支持使用 JavaScript“空”类型和“未定义”类型。而且不允许将标量类型隐式转换为对象；因此，表达式 "abc".length 将引起错误，而不是得出值 3。


关于“表达式对象模型”

“表达式对象模型”定义可以在表达式中使用的变量。定义了下列变量：

_document | 包含文档级模板数据。除了几个提供文档内置信息的域以外，模板中的每个参数都有一个域。
_repeat | 仅为出现在重复区域内的表达式定义。提供关于区域的内置信息： _index 当前项的数字索引（从 0 开始） _numRows 该重复区域内的总项数 _isFirst 如果当前项是其重复区域内的第一项，则为真 _isLast 如果当前项是其重复区域内的最后一项，则为真 _prevRecord 前一项的 "_repeat" 对象。访问该区域内第一项的此属性是一个错误。 _nextRecord 下一项的 "_repeat" 对象。访问该区域内最后一项的此属性是一个错误。 _parent 在嵌套的重复区域内，该项给出封闭（外层）重复区域的 _repeat 对象。在嵌套的重复区域外部访问此属性是一个错误。

在表达式计算过程中，_document 对象和 _repeat 对象的所有域都默认为可用。例如，为访问文档的标题参数，可以输入 title 而不是 _document.title。

在出现域冲突的情况下，_repeat 对象的域优先于 _document 对象的域。因此，不需要明确引用 _document 或 _repeat，除非可能需要在重复区域内使用 _document 引用被重复区域参数隐藏了的文档参数。

使用嵌套的重复区域时，只有最内层重复区域的域为默认为可用。外层区域必须使用 _parent 明确引用。


创建“多重假设”条件

下面的范例讲述了如何定义名为 “Dept”的参数、如何设置初始值以及如何定义用来确定显示哪个徽标的多重假设条件。

以下是在模板的 head 部分输入的代码范例：

<!-- TemplateParam name= “Dept” type = “number” value = “1”>

此条件语句检查指定给 Dept 参数的值。如果条件为真或匹配，则显示适当的图像。

<!-- TemplateBeginMultipleIf -->
<!-- 检查 Dept 的值并显示适当的图像-->

<!-- TemplateBeginClause cond = “Dept  == 1”> <img src = “.../sales.gif”> <!-- TemplateEndIfClause-->
<!-- TemplateBeginIfClause cond = “Dept == 2”> <img src = “.../support.gif”> <!-- TemplateEndIfClause-->
<!-- TemplateBeginIfClause cond = “Dept == 3”> <img src = “.../hr.gif”> <!-- TemplateEndIfClause-->
<!-- TemplateBeginIfClause cond = “Dept != 3”> <img src = “.../spacer.gif”> <!-- TemplateEndIfClause-->

<!-- TemplateEndMultipleIf -->

创建文档后，模板参数将自动传递到该文档。模板用户可以通过在“模板属性”对话框（“修改”>“模板属性”）中编辑“Dept”参数的值，确定显示哪个图像。


模板标记语法

下面是一般语法规则和用于定义模板和模板实例（文档）区域的注释标记列表。当您插入模板对象时，Dreamweaver 将自动在代码中插入模板标记。如果您要添加自己的模板区域，可以直接在“代码”视图中输入它们。


一般规则：

无论哪里出现空格，都可以用任何数量的空白（空格、制表符和换行符）代替。除了在注释开头和结尾，空白都是强制性的。

可以以任何顺序给出属性。例如，在 TemplateParam 中，可以在名称之前指定类型。

注释和属性名称是区分大小写的。

所有属性都必须加引号。可以使用单引号或双引号。

相关主题

检查模板语法


模板标记：

下列标记定义模板区域：

<!-- TemplateBeginEditable name="..." -->
<!-- TemplateEndEditable -->

<!-- TemplateParam name="..." type="..." value="..." -->

<!-- TemplateBeginRepeat name="..." -->
<!-- TemplateEndRepeat -->

<!-- TemplateBeginIf cond="..." -->
<!-- TemplateEndIf -->

<!-- TemplateBeginPassthroughIf cond="..." -->
<!-- TemplateEndPassthroughIf -->

<!-- TemplateBeginMultipleIf -->
<!-- TemplateEndMultipleIf -->

<!-- TemplateBeginPassthroughMultipleIf -->
<!-- TemplateEndPassthroughMultipleIf -->

<!-- TemplateBeginIfClause cond="..." -->
<!-- TemplateEndIfClause -->

<!-- TemplateBeginPassthroughIfClause cond="..." -->
<!-- TemplateEndPassthroughIfClause -->

<!-- TemplateExpr expr="..."-->（相当于 @@...@@）

<!-- TemplatePassthroughExpr expr="..." -->

<!-- TemplateInfo codeOutsideHTMLIsLocked="..." -->


实例标记：

下列标记定义基于模板的文档区域：

<!-- InstanceBegin template="..." codeOutsideHTMLIsLocked="..." -->
<!-- InstanceEnd -->
<!-- InstanceBeginEditable name="..." -->
<!-- InstanceEndEditable -->
<!-- InstanceParam name="..." type="..." value="..." passthrough="..." -->
<!-- InstanceBeginRepeat name="..." -->
<!-- InstanceEndRepeat -->
<!-- InstanceBeginRepeatEntry -->
<!-- InstanceEndRepeatEntry -->

上一页


测试站点

在将站点上传到服务器供浏览之前，最好先在本地对其进行测试。（实际上，在站点建设过程中，最好不断地对站点进行测试并解决出现的问题，以便尽早发现问题，避免重复出错。）

应该确保在目标浏览器中，页面如预期的那样显示和工作，而且没有断开的链接，页面下载也不占用太长时间。还可以通过运行站点报告测试整个站点并解决出现的问题。

下面的指南将帮助您为您站点的访问者们提供愉快的访问经历：

  • 确保页面在目标浏览器中能够如预期的那样工作，并确保这些页面在其他浏览器中要么工作正常，要么“得体地拒绝工作”。

    • 页面在不支持样式、层、插件或 JavaScript 的浏览器中应清晰可读且功能正常（请参见检查浏览器的兼容性）。对于在较早版本的浏览器中根本无法运行的页面，应考虑使用“检查浏览器”行为，自动将访问者重定向到另外的页面（请参见检查浏览器）。

  • 应尽可能多地在不同的浏览器和平台上预览页面。

    • 这使您有机会查看布局、颜色、字体大小和默认浏览器窗口大小的区别，这些区别在目标浏览器检查中是无法预见的（请参见在浏览器中预览页面）。

  • 检查站点是否有断开的链接，并修复断开的链接。

    • 由于其他站点也在重新设计、重新组织，所以您所链接到的页面可能已被移动或删除。可运行链接检查报告对链接进行测试（请参见检查页面或站点内的链接、修复断开的链接、在 Dreamweaver 中打开链接的文档或使用“报告”测试站点）。

  • 监测页面的文件大小以及下载这些页面所占用的时间（请参见设置下载时间和大小）。

    • 要知道对于由大型表格组成的页面，在整张表完全载入之前，访问者将什么也看不到。应考虑将大型表格分为几部分，如果不可能这样做，请考虑将少量内容（例如欢迎辞或广告横幅）放在表以外的页面顶部，这样在下载表的同时，用户可以查看这些内容。

  • 运行一些站点报告来测试并解决整个站点的问题。

    • 这样可以检查整个站点是否存在问题，例如无标题文档、空标签以及冗余的嵌套标签等（请参见使用“报告”测试站点）。

  • 在完成对大部分站点的大部分发布以后，应继续对站点进行更新和维护。

    • 站点的发布（即推出站点投入使用）可以多种方式完成，而且是一个持续的过程。这一过程的一个重要部分是定义并实现一个版本控制系统，既可以使用 Macromedia Dreamweaver MX 中所包含的工具，也可以通过某个外部的版本控制应用程序来定义和实现此系统。

  • 使用可在 Macromedia Web 站点上找到的 Macromedia Dreamweaver 论坛。

    • 这些论坛是很好的资源，可以获取有关各种浏览器、平台等信息。您还可以与其他 Dreamweaver 用户讨论技术问题并共享有用的提示。

本章包括以下章节：

  • 检查浏览器的兼容性
  • 使用“行为”检测浏览器和插件
  • 在浏览器中预览页面
  • 检查页面或站点内的链接
  • 修复断开的链接
  • 在 Dreamweaver 中打开链接的文档
  • 设置下载时间和大小
  • 使用“报告”测试站点
下一页


检查浏览器的兼容性

Dreamweaver 使您能够使用所有浏览器都支持的元素（例如图像和段落文本）和只有较新浏览器才支持的元素（例如样式和层）来建构网页。

“检查目标浏览器”功能对文档中的 HTML 进行测试，检查是否有目标浏览器所不支持的任何标签或属性。此检查对文档不作任何方式的更改。

“检查目标浏览器”功能使用名为“浏览器配置文件”的文本文件确定特定浏览器所支持的标签。Dreamweaver 包含 Netscape Navigator 2.0 及其更高版本、Microsoft Internet Explorer 2.0 及其更高版本和 Opera 2.1 及其更高版本的预定义配置文件。要修改现有配置文件或新建配置文件，请参见 http://www.macromedia.com/support/dreamweaver/ 上的“Dreamweaver 自定义”(Customizing Dreamweaver) 一节。

可在文档、目录或整个站点上运行目标浏览器检查。

备注： 运行目标浏览器检查并不检查站点中的脚本。

若要运行目标浏览器检查：
  1. 请从下列方法中选择其一：
    • 若对当前文档运行该检查，首先要保存您的文件。Dreamweaver 对文件的最新保存版本（不包含未保存的更改）执行该检查，而不包含未保存的更改。
    • 若要对目录或站点运行该检查，可从“站点”面板中的“当前站点”弹出式菜单中选择一个站点。Dreamweaver 对该文件夹中以及其中的任何文件夹中的所有 HTML 文件执行目标浏览器检查。只可对本地文件执行目标浏览器检查。
  2. 选择“文件”>“检查页”>“检查目标浏览器”。

    3. 如果尚未选择主浏览器，Dreamweaver 将提示您进行选择。

  3. 从浏览器列表中，选择目标浏览器，检查站点时将依据该浏览器。
  4. 单击“检查”。

    5. 报告将显示在“目标浏览器检查”面板（在“结果”面板组中）中。

  5. 若要保存该报告，请单击“目标浏览器检查”面板中的“保存报告”按钮。

    6. 备注： 目标浏览器报告为临时文件，若不保存，将会丢失。


使用“行为”检测浏览器和插件

可以使用行为来确定访问者所使用的浏览器，以及他们是否安装有某个特定插件。有关行为的更多信息，请参见使用 JavaScript 行为。

检查浏览器根据访问者浏览器的类型和版本，引导他们前往不同的页面（请参见检查浏览器）。例如，您可能希望这样：如果访问者有 Netscape Navigator 4.0 或更高版本，则使他们前往某一个页面；如果访问者有 Microsoft Internet Explorer 4.0 或更高版本，则使他们前往另一个页面；如果访问者有任何其他种类的浏览器，则使他们停留在当前页面。

检查插件根据访问者是否安装有指定插件，引导他们前往不同的页面（请参见检查插件）。例如，您可能希望这样：如果访问者有 Macromedia Shockwave，则使他们前往某一页面；而如果没有，则使他们前往另一个页面。


在浏览器中预览页面

在设计和创建页面的过程中，最好经常通过在浏览器中预览页面来对其进行测试。采用此策略，您可以及早发现错误，避免重复出错。

任何时候都可在目标浏览器中预览文档，而不需要先保存该文档。在您的浏览器已安装了必需的插件或 ActiveX 控件的情况下，与浏览器相关的所有功能（包括 JavaScript 行为、文档相对链接和绝对链接、ActiveX 控件和 Netscape Navigator 插件）都会起作用。

当在本地浏览器中预览文档时，不显示用根目录相对路径所链接的内容（除非您在“参数选择”中选择“用临时文件预览”选项，请参见在浏览器中预览页面）。这是由于浏览器不能识别站点根目录，而服务器能够识别。若要预览用根目录相对路径所链接的内容，请将此文件放在远程服务器上，然后选择“文件”>“在浏览器中预览”来查看它（请参见站点根目录相对路径）。

最多可定义 20 个用于预览的浏览器。您定义的所有浏览器都显示在“在浏览器中预览”菜单上。最好在下列浏览器中预览：Internet Explorer 4.0、Netscape Navigator 4.0 和至少一个纯文本浏览器（如 Lynx）。

若要在浏览器中预览文档，请执行下列操作之一：
  • 选择“文件”>“在浏览器中预览”，然后选择所列浏览器中的一个。

    • 如果您尚未选择浏览器，请选择“编辑”>“参数选择”，或者选择“Dreamweaver”>“参数选择”(Mac OS X)，然后选择左边的“在浏览器中预览”类别，以选择一个浏览器（请参见设置“在浏览器中预览参数选择”选项）。

  • 按 F12 键在主浏览器中显示当前文档。
  • 按 Control+F12（在 Windows 中）或 Command+F12（在 Macintosh 中）可在候选浏览器中显示当前文档。
若要在浏览器中测试链接：
  1. 请选择“文件”>“在浏览器中预览”，或按 F12 键。
  2. 单击活动的链接，以验证每个链接都工作正常。
若要设置或更改主浏览器或候选浏览器的参数选择，请执行以下操作：
  1. 选择下列方法之一打开“在浏览器中预览”选项：
    • 选择“编辑”>“参数选择”或者“Dreamweaver”>“参数选择”(Mac OS X)，然后从左边的类别列表中选择“在浏览器中预览”。
    • 选择“文件”>“在浏览器中预览”>“编辑浏览器列表”。

      • 出现带有“在浏览器中预览”选项的“参数选择”对话框。
      这是所描述的功能的图片。

  2. 按需要进行更改。

    3. 有关更多信息，请参见设置“在浏览器中预览参数选择”选项。

  3. 单击“确定”。


检查页面或站点内的链接

修复大型站点上断开的链接（即所沿路径不再有效或指向不存在文件的链接）是一个单调乏味又费时费力的工作。这是因为大型站点可以包含到内部文档和外部文档的上百个链接，而且这些链接可能会随时间的推移而改变。孤立的文件（指仍然存在于站点内，但是站点内没有其他文件链接到该文件）也可能是个问题，因为它们占据磁盘空间，而且可能使处理此站点的其他小组成员迷惑不解。

“检查链接”功能可用来在打开的文件、本地站点的某一部分或者整个本地站点中搜索断开的链接和未被引用的文件。Dreamweaver 只验证那些指向站点内文档的链接；Dreamweaver 将出现在选定文档中的外部链接编辑成一个列表，但并不验证它们。

在 Dreamweaver 检查完指定文件中的链接后，它打开“链接检查器”面板（在“结果”面板组中）。此对话框显示一个列有断开的链接、外部链接（Dreamweaver 不能检查的链接）和孤立文件的列表。有关更多信息，请参见在 Dreamweaver 中打开链接的文档。

若要检查当前文档内的链接：
  1. 将此文件保存在本地 Dreamweaver 站点中的某个位置。
  2. 选择“文件”>“检查页”>“检查链接”。

    3. 报告出现在“链接检查器”面板中（在“结果”面板组中）。

  3. 若要保存此报告，请单击“链接检查器”面板中的“保存报告”按钮。

    4. 备注： 目标浏览器报告为临时文件，若不保存，将会丢失。

若要检查本地站点某一部分中的链接：
  1. 在“站点”面板中，从“当前站点”弹出式菜单中选择一个站点。
  2. 在“本地”视图中，选择要检查的文件或文件夹。
  3. 执行下列操作之一，启动该检查：
    • 右击（在 Windows 中）或者在按下 Control 键的同时单击（在 Macintosh 中）一个选定文件，然后再从上下文菜单中选择“检查链接”>“选定的文件/文件夹”。
    • 选择“文件”>“检查页”>“检查链接”。

      • 报告出现在“链接检查器”面板中（在“结果”面板组中）。

  4. 在“链接检查器”面板中，从“显示”弹出式菜单中选择某个特定链接报告，可查看其他报告。

    5. 可选的报告类型有“断开的链接”和“外部链接”。当检查整个站点的链接时可检查“孤立的文件”（请参见下一个过程）。

  5. 若要保存报告，请单击“链接检查器”面板中的“保存报告”按钮。
若要检查整个站点中的链接：
  1. 在“站点”面板中，从“当前站点”弹出式菜单中选择一个站点。
  2. 选择“站点”>“检查站点内所有链接”。

    3. 报告出现在“链接检查器”面板中（在“结果”面板组中）。

  3. 在“链接检查器”面板中，从“显示”弹出式菜单中选择某个特定链接报告，可查看其他报告。

    4. 可选择的报告类型有“断开的链接”、“外部链接”和“孤立的文件”。

  4. 一个适合所选报告类型的文件列表出现在“链接检查器”对话框中。

    5. 备注： 如果选择的报告类型为“孤立的文件”，可以直接从“链接检查器”面板中删除孤立文件，方法是从该列表中选中一个文件后按 Delete 键。

    一个适合所选报告类型的文件列表出现在“链接检查器”面板中。

  5. 若要保存报告，请单击“链接检查器”面板中的“保存报告”按钮。


修复断开的链接

当在 Dreamweaver 中检查链接时，“链接检查器”面板显示一份报告，该报告包括断开的链接、外部链接和孤立的文件（如果您选择的是检查整个站点的话）（请参见检查页面或站点内的链接）。

可直接在“链接检查器”面板中修复断开的链接和图像引用，也可以从此列表中打开文件，然后在属性检查器中修复链接。

若要在“链接检查器”面板中修复链接：
  1. 运行链接检查报告（请参见检查页面或站点内的链接）。
  2. 在“链接检查器”面板（在“结果”面板组中）中的“断开的链接”列（而不是“文件”列），选择该断开的链接。

    3. 一个文件夹图标出现在此断开的链接旁边。

  3. 单击文件夹图标以浏览到要链接的正确文件，或者键入正确的路径和文件名。
  4. 按 Tab 键或者 Enter 键（在 Windows 中）；或者按 Return 键（在 Macintosh 中）。

    5. 如果还有对同一文件的其他断开的引用，会出现一个对话框提示您修复其他文件中的这些引用。单击“是”，则 Dreamweaver 更新列表中引用此文件的所有文档。单击“否”，则 Dreamweaver 只更新当前引用。

备注： 如果为此站点打开了“启用文件存回和取出”，则 Dreamweaver 将尝试取出需要更改的文件。如果不能取出文件，Dreamweaver 将显示一个警告对话框，并且不更改断开的引用。请参见使用存回/取出。

若要在属性检查器中修复链接，请执行以下操作：
  1. 运行链接检查报告（请参见检查页面或站点内的链接）。
  2. 在“链接检查器”面板中（在“结果”面板组中）双击“文件”列中的某个条目。

    3. Dreamweaver 打开该文档，选择有问题的图像或链接，并在属性检查器中高亮显示其路径和文件名。（如果未出现属性检查器，请选择“窗口”>“属性”将其打开。）

  3. 若要在属性检查器中设置新路径和文件名，请单击文件夹图标以浏览到正确的文件，或者在高亮显示文本上直接键入。

    4. 如果您正在更新一个图像引用，而显示的新图像的大小不正确，请单击属性检查器中的“W”和“H”标签，或者单击“刷新”按钮，重置高度和宽度值。“W”和“H”标签由粗体变为常规类型。

  4. 保存此文件。

链接修复后，该链接的条目在“链接检查器”列表中不再显示。如果在“链接检查器”中输入新的路径或文件名后（或者在属性检查器中保存更改后），某一条目依然显示在列表中，这表明 Dreamweaver 找不到新文件，仍然认为该链接是断开的。


在 Dreamweaver 中打开链接的文档

在 Dreamweaver 内链接是不活动的，即无法通过在“文档”窗口中单击链接打开该链接所指向的文档。

若要在 Dreamweaver 中打开链接的文档，请执行下列操作之一：
  • 选中链接，再选择“修改”>“打开链接指向的页面”。
  • 按下 Control 键（在 Windows 中）或者按下 Command 键（在 Macintosh 中）同时双击选中的链接。

备注： 链接的文档必须驻留在本地磁盘上。


设置下载时间和大小

Dreamweaver 根据页面的全部内容（包括所有链接的对象，例如图像和插件）来计算大小。Dreamweaver 根据“状态栏”参数选择中输入的连接速度估计下载时间。实际下载时间因一般的 Internet 条件不同而有所不同。

检查某一特定网页的下载时间时，一个不错的标准是“8 秒钟原则”。即，大多数用户等待载入一个页面的时间不会超过 8 秒钟。

若要设置下载时间和下载页面大小参数：
  1. 选择“编辑”>“参数选择”，或者选择“Dreamweaver”>“参数选择”(Mac OS X)。

    2. “参数选择”对话框出现。

  2. 从位于左侧的“类别”列表中选择“状态栏”。

    3. “状态栏”参数选择的选项出现。
    这是所描述的功能的图片。

  3. 选择用于计算下载时间的连接速度。

    4. 在美国的平均连接速度是 28.8。如果是为 Intranet 设计页面，可能要选择 1500（T1 速度）。

    有关“状态栏”参数选择的更多信息，请参见设置“状态栏”参数。

  4. 单击“确定”。


使用“报告”测试站点

在测试站点时，通过使用“报告”命令，可以为多个 HTML 属性编辑和生成报告。此命令使您能够检查外部链接、可合并嵌套字体标签、遗漏的替换文本、冗余的嵌套标签、可移除的空标签和无标题文档。在发布站点之前，您可以检查所选文档或者整个站点是否存在这些 HTML 问题。

运行报告后，可将报告保存为 XML 文件，然后将其导入模板实例、数据库或电子表格中，再将其打印出来或在 Web 站点上进行显示。还可以通过 Macromedia Dreamweaver Exchange Web 站点向 Dreamweaver 添加其他不同的报告类型（请参见添加功能扩展 Dreamweaver）。

若要将“报告”命令与“存回/取出”系统和“设计备注”一起使用，请参见使用报告改进工作流程。

若要运行报告以测试站点：
  1. 选择“站点”>“报告”。

    2. 出现“报告”对话框。
    这是所描述的功能的图片。

  2. 选择要报告的类别和要运行的报告类型。

    3. 有关更多信息，请参见设置“报告”对话框选项。

  3. 单击“运行”，创建报告。

    4. 根据所选要报告的内容，可能会提示您保存文件、定义站点或选择文件夹（如果尚未执行这些操作的话）。

    结果列表出现在“站点报告”面板（在“结果”面板组中）中。

若要使用和保存报告：
  1. 若要对结果进行排序，请单击要按其排序的列标题。

    2. 可以按文件名、行号或说明进行排序。

  2. 选择报告中的一项，然后双击，在“文档”窗口中打开该文件。
  3. 单击“保存报告”保存该报告。

    4. 保存报告时，可将报告导入模板实例、数据库或电子表格中，再将其打印出来，或在 Web 站点上进行显示。

提示： 运行 HTML 报告后，使用“清理 HTML”命令，更正报告列出的所有 HTML 错误。


参考资料

本节提供本章介绍的对话框的有关信息。


设置“在浏览器中预览参数选择”选项

此对话框用于为“在浏览器中预览”类别设置用户参数选择。此对话框显示当前定义的主浏览器和候选浏览器以及它们的设置。

过程
  1. 若要向列表添加浏览器，请单击加号 (+) 按钮，完成“添加浏览器”对话框，然后单击“确定”。

    2. 新浏览器的名称出现在列表中。

  2. 若要从列表中删除浏览器，请选择要删除的浏览器，然后单击减号 (-) 按钮。

    3. 浏览器名称从列表中消失。

  3. 若要更改选定浏览器的设置，请单击“编辑”按钮，在“编辑浏览器”对话框中进行更改，然后单击“确定”。
  4. 选择“主浏览器”或“候选浏览器”选项，可指定所选浏览器是主浏览器还是候选浏览器。

    5. 按 F12 键可打开主浏览器；按 Control+F12（在 Windows 中）或 Command+F12（在 Macintosh 中）可打开候选浏览器。

  5. 选择“用临时文件预览”选项，可为预览和服务器调试创建临时拷贝。

    6. 如果要直接更新文档，可撤销对此选项的选择。

相关主题

在浏览器中预览页面


设置“报告”对话框选项

此对话框用于运行关于文档或站点的报告。您可以运行报告来改进工作流程、测试站点和检查辅助功能。

过程
  1. 从“报告在”弹出式菜单中选择要报告的内容。

    2. 备注： 只有在“站点”面板中已经有选定文件的情况下，才能运行“站点中选定的文件”报告。

  2. 在“工作流程”部分，选择要运行的报告类型。

    3. 可运行这两个报告中的一个或两个：

    • “取出者”，创建一个报告，列出某特定小组成员取出的所有文档。
    • “设计备注”，创建一个报告，列出选定文档或站点的所有设计备注。
  3. 在 HTML 部分，选择一个报告类型，以便运行报告来测试站点。

    4. 可运行下列报告中的任意一种：

    • “可合并嵌套字体标签”，创建一个报告，列出所有可以为清理代码而合并的嵌套字体标签。

      • 例如，将报告 <font color="#FF0000"><font size="4">STOP!</font></font>。

    • “没有替换文本”，创建一个报告，列出所有没有替换文本的 img 标签。

      • 在纯文本浏览器或设为手动下载图像的浏览器中，替换文本替代图像出现在应显示图像的位置上。屏幕阅读器读取替换文本，而且有些浏览器可在用户鼠标滑过图像时显示替换文本。

    • “多余的嵌套标签”，创建一个报告，详细列出应该清理的嵌套标签。

      • 例如，将报告 <i> The rain <i> in</i> Spain stays mainly in the plain</i>。

    • “可移除的空标签”，创建一个报告，详细列出所有可以为清理 HTML 代码而移除的空标签。

      • 例如，可能在“代码”视图中已删除了某项或图像，却留下了应用于该项的标签。

    • 无标题文档，创建一个报告，列出在选定参数中找到的所有无标题的文档。Dreamweaver 报告所有具有默认标题、重复标题或缺少 title 标签的文档。
  4. 如果您选择了“取出者”或“设计备注”，则请单击“报告设置”按钮。否则，跳过这一步。

    5. 备注： 如果您同时选择了两种报告类型，则需要单击“报告设置”按钮两次。选择一个报告，单击“报告设置”，输入设置；然后选择另一个报告，单击“报告设置”，输入设置。

    • 对于“取出者”，请输入小组成员的名称，然后单击“确定”，返回“报告”对话框。
    • 对于“设计备注”，请输入一对或多对名称和值，然后从相应的弹出式菜单中选择对比值。然后单击“确定”，返回“报告”对话框。
  5. 单击“运行”以创建报告。

    6. 根据所选要报告的内容，可能会提示您保存文件、定义站点或选择文件夹（如果尚未执行这些操作的话）。

相关主题

对您的 Web 站点进行辅助功能测试

使用“报告”测试站点

使用报告改进工作流程

上一页


生成动态页

使用 Dreamweaver 中的 Web 应用程序开发工具，向页面添加动态内容。

本部分包含以下各章：

  • 为可视化开发优化工作区
  • Dreamweaver 动态页设计工作流程
  • 存储和检索页面数据
  • 定义动态内容源
  • 向 Web 页中添加动态内容
  • 显示数据库记录
  • 使用 ColdFusion 组件
  • 使用 Web 服务
  • 添加自定义服务器行为
  • 创建交互式表单


为可视化开发优化工作区

您可优化 Macromedia Dreamweaver MX 工作区以可视地开发 Web 应用程序。例如，可以使用面板快速地生成动态页，并且可以在工作时查看页面上的活动数据。

本章包含下列章节：

  • 显示有用的面板
  • 在 Dreamweaver 中查看数据库结构
  • 在“设计”视图中查看活动数据
  • 在不显示活动数据的“设计”视图中工作
  • 在浏览器中预览动态页
  • 限制显示在 Dreamweaver 中的数据库信息
下一页


显示有用的面板

单击“插入”栏中的“应用程序”选项卡，以显示一组使您能够将动态内容和服务器行为添加到页面中的按钮，如图所示。

显示的图标的数量和类型取决于在“文档”窗口中打开的文档类型。“插入”栏中包括可将下列项添加到页面中的按钮：

  • 记录集
  • 动态文本或表
  • 向数据库插入记录或更新其中记录的表单
  • 记录导航条

如果您切换到“代码”视图（“查看”>“代码”），附加的面板可能会显示以允许您在页面中插入代码。例如，如果在“代码”视图中查看 JSP 页，则在”插入”栏上出现一个 JSP 面板，如图所示：

若要知道”插入”栏上每个图标表示的功能，请将鼠标光标移到图标上。工具提示即会出现，如图所示：

如果希望为页面定义动态内容的源，并将该内容添加到页面中，请选择“窗口”>“数据绑定”。“绑定”面板即会出现，如下所示：

有关更多信息，请参见设置“绑定”面板选项。

如果希望向动态页添加服务器端逻辑，请选择“窗口”>“服务器行为”。“服务器行为”面板将出现，如图所示：

服务器行为是在设计时插入到动态页中的指令组，这些指令在运行时于服务器上执行。有关更多信息，请参见设置“服务器行为”面板选项。

如果希望研究数据库或创建数据库连接，请选择“窗口”>“数据库”。“数据库”面板将出现，如图所示：

有关更多信息，请参见设置“数据库”面板选项。

如果要检查、添加或修改 JavaBean、Macromedia ColdFusion 组件或 Web 服务的代码，请选择“窗口”>“组件”。“组件”面板将出现，如图所示：

备注： “组件”面板只有在您打开 ColdFusion、JSP 或 ASP.NET 页时才被启用。另外，文档有可能不支持某些组件。例如，ColdFusion 文档不支持 JavaBeans。

有关更多信息，请参见设置“组件”面板选项。


在 Dreamweaver 中查看数据库结构

在连接到数据库后，可在 Dreamweaver 中查看其结构。例如，您可查看数据库中表、列、视图和预存过程的名称。Dreamweaver 也可识别每张表的主键和每一列的数据类型。您甚至可查看存储在数据库表中的数据。

若要查看数据库结构：
  1. 打开“数据库”面板（“窗口”>“数据库”）。

    2. Dreamweaver 会用已为其创建连接的所有数据库填充“数据库”面板。如果您正在开发 ColdFusion 站点，Dreamweaver 会用已在“ColdFusion 管理员”中为其定义了数据源的所有数据库填充该面板。

    备注： Dreamweaver 可搜索您为当前站点定义的 ColdFusion 服务器。请参见指定可在哪里处理动态页。

    如果在该面板中没有显示任何数据库，则您必须创建一个数据库连接。有关更多信息，请参见连接到数据库。

  2. 若要显示数据库中的表、预存过程和视图，请单击列表中连接旁的加号 (+) 图标。
  3. 若要显示表中的列，请单击表格。

    4. 列图标可反映数据类型，也可指示主键。

  4. 若要查看表中的数据，请右击（在 Windows 中）或按住 Control 的同时单击（在 Macintosh 中）列表中的表格，然后从弹出式菜单中选择“查看数据”。


在“设计”视图中查看活动数据

默认情况下，“设计”视图（“查看”>“设计”）可向您提供没有动态内容的页面的可视化表示形式。如果您正在设计动态页，则默认视图并不理想，因为动态内容会彻底改变页面的布局。

若要查看动态内容可如何影响页面的布局，请选择“查看”>“活动数据”。Dreamweaver 将在“设计”视图中显示具有动态内容的完整页面。下面的插图显示了禁用“活动数据”的动态页：

下面的插图显示了启用“活动数据”的同一页：

当在“设计”视图中启用“活动数据”后，可进行以下操作：

  • 使用页面设计工具调整页面的布局
  • 添加、编辑或删除动态内容
  • 添加、编辑或删除服务器行为

备注： 链接在“设计”视图中不起作用。若要测试链接，请使用“在浏览器中预览”功能。（请参见在浏览器中预览动态页。）

在您对页面进行更改，影响到动态内容时，可通过单击“刷新”按钮（环形箭头图标）刷新该页面。Dreamweaver 也可自动为您刷新页面。有关更多信息，请参见刷新页。

相关主题

显示活动数据的要求

拷贝相关文件

向页提供所需参数

“实时数据”视图答疑

在不显示活动数据的“设计”视图中工作


显示活动数据的要求

若要在“设计”视图中查看活动数据，您必须进行以下操作：

  • 定义一个文件夹以处理动态页。有关说明，请参见指定可在哪里处理动态页。

    • 在启用“活动数据”后，打开的文档的一份临时拷贝将被发送到该文件夹进行处理。结果页将被返回并显示在“设计”视图中，服务器上的那份临时拷贝则被删除。

    如果在启用“活动数据”时该页显示错误信息，请确保“站点定义”对话框中的 URL 前缀是正确的。有关更多信息，请参见“关于 URL 前缀” 在第 403。

  • 将相关文件（如果有的话）拷贝到该文件夹。有关更多信息，请参见拷贝相关文件。
  • 向页提供用户通常将提供的所有参数。有关说明，请参见向页提供所需参数。

如果在运行“实时数据”视图时遇到困难，请参见“实时数据”视图答疑。

相关主题

在“设计”视图中查看活动数据

在不显示活动数据的“设计”视图中工作


拷贝相关文件

有些动态页依赖于其他文件才可正常运行。必须将所有相关文件（包括 server-side includes 以及诸如图像文件和 JSP 类文件的相关文件）都上传到为处理动态页所定义的文件夹（请参见指定可在哪里处理动态页）中。您在“设计”视图中启用“活动数据”时，Dreamweaver 不会将相关文件自动拷贝到该文件夹。

备注： “活动数据”可支持 server-side includes 以及诸如 global.asa (ASP) 和 application.cfm (ColdFusion) 的应用程序文件中的代码。请确保在启用“活动数据”之前将这些文件上传到服务器。

若要将相关文件拷贝到应用程序服务器：
  1. 打开“站点”面板（“窗口”>“站点文件”），然后单击“展开”按钮（面板工具条上的最后一个图标）。

    2. “站点”面板将展开到最大。

  2. 单击展开的“站点”窗口工具栏上的“应用程序服务器”图标（左起第二个图标）。

    3. 应用程序服务器的根文件夹将出现在“远程站点”下。

  3. 在“本地文件夹”下，选择相关文件。
  4. 单击工具条上蓝色的向上箭头，将这些文件拷贝到应用程序服务器，或将这些文件拖动到“远程站点”下的相应文件夹中。

只需为站点进行一次此操作，除非您要添加更多的相关文件，在这种情况下，您必须也将它们拷贝到该文件夹。

相关主题

在“设计”视图中查看活动数据

显示活动数据的要求

向页提供所需参数

刷新页

“实时数据”视图答疑


向页提供所需参数

为了生成动态内容，有些页需要来自用户的参数，例如，页需要记录的 ID 号才可找到并显示该记录。没有这种数据，Dreamweaver 将无法生成在“设计”视图中显示的动态内容。

如果页需要来自用户的参数，您必须按以下步骤提供参数。

若要向页提供应来自用户的数据：
  1. 在“文档”窗口中，从“查看”菜单选择“设置活动数据”。

    2. “设置活动数据”对话框将出现。
    这是所描述的功能的图片。

  2. 完成对话框设置，然后单击“确定”。

    3. 有关更多信息，请参见设置“设置活动数据”对话框选项。

如果在“设置活动数据”对话框中指定 GET 方法，则在“设计”视图工具条上将显示一个文本框。使用此文本框输入不同的 URL 参数，然后单击“刷新”按钮（环形箭头图标），查看这些参数对页面的影响效果。

按以下格式输入每个 URL 参数：

name=value;

在此格式中，name 是页所需的 URL 参数名称，而 value 是该参数具有的值。有关更多信息，请参见了解 URL 参数。

相关主题

在“设计”视图中查看活动数据

显示活动数据的要求

拷贝相关文件

刷新页

“实时数据”视图答疑


刷新页

在启用“活动数据”的情况下，如果希望在进行了影响动态内容的更改后刷新页，请单击文档工具条上的“刷新”按钮（环形箭头图标）。

也可以选择工具条上的“自动刷新”选项。在启用此选项的情况下，无论何时进行了影响动态内容的更改，页面都会刷新。如果您的数据库连接速度较慢，当在“活动数据”窗口中工作时，可能会希望禁用此选项。

相关主题

在“设计”视图中查看活动数据

显示活动数据的要求

拷贝相关文件

向页提供所需参数

“实时数据”视图答疑


“实时数据”视图答疑

“实时数据”视图的许多问题可归因于在“站点定义”对话框（“站点”>“编辑站点”）中缺少值或其中的值不正确。

请检查“站点定义”对话框的“应用程序服务器”类别。“远端文件夹”框应指定一个能够处理动态页的文件夹（请参见指定可在哪里处理动态页）。如果在硬盘上运行的是 IIS 或 PWS，则下面是一个合适的远端文件夹示例：

C:\Inetpub\wwwroot\myapp\

请验证“URL 前缀”框指定了对应于（或“映射”到）远端文件夹的 URL。例如，如果您的本地计算机上正在运行的是 PWS 或 IIS，则下列远端文件夹具有以下 URL 前缀：

远端文件夹 | URL 前缀
C:\Inetpub\wwwroot\ | http://localhost/
C:\Inetpub\wwwroot\myapp\ | http://localhost/myapp/
C:\Inetpub\wwwroot\fs\planes | http://localhost/fs/planes

有关更多信息，请参见关于 URL 前缀。

相关主题

在“设计”视图中查看活动数据

显示活动数据的要求

拷贝相关文件

向页提供所需参数

刷新页


在不显示活动数据的“设计”视图中工作

如果禁用了“活动数据”，或者暂时与应用程序服务器断开了连接，您仍可在“设计”视图中处理动态页。Dreamweaver 可使用占位符可视地表示页面中的动态内容。例如，表示从数据库提取的动态文本的占位符使用语法 {RecordsetName.ColumnName}，其中 Recordset 是记录集的名称，而 ColumnName 是从记录集中选择的列的名称。

有时，表示动态文本的占位符的长度会破坏“设计”视图中页面的布局。可通过使用空的大括号作为占位符来解决这个问题。

若要使用空的大括号作为动态文本的占位符：
  1. 选择“编辑”>“参数选择”>“不可见元素”或者选择“Dreamweaver”>“参数选择”>“不可见元素”(Mac OS X)。
  2. 在“将动态文本显示为”弹出式菜单中，选择 {}。
  3. 单击“确定”。

相关主题

在“设计”视图中查看活动数据

显示活动数据的要求


在浏览器中预览动态页

Web 应用程序开发人员经常通过在 Web 浏览器中快速、频繁地检查页来对页进行调试。Dreamweaver 通过“在浏览器中预览”命令 (F12) 来适应这种工作风格。该命令可使您快速地在浏览器中查看动态页，而不需先将这些动态页上传到服务器。

提示： 也可以在处理页时，使用“设计”视图快速地检查页。“设计”视图可显示页的完全可编辑的可视化表示形式，包括活动数据。有关更多信息，请参见在“设计”视图中查看活动数据。

当使用此命令时，在将页显示于浏览器中之前，Dreamweaver 会在 Web 服务器上运行该页的临时拷贝。（Dreamweaver 随后从服务器中删除该临时文件。）

若要预览动态页，您必须完成“站点定义”对话框的“测试服务器”类别。有关更多信息，请参见指定可在哪里处理动态页。

“在浏览器中预览”不会上传诸如结果页或详细页的相关页、诸如图像文件的相关文件或 server-side includes。若要上传缺少的文件，请选择“窗口”>“站点”以打开“站点”面板，在“本地文件夹”下选择该文件，然后单击工具条上的蓝色向上箭头，将该文件拷贝到 Web 服务器文件夹中。


限制显示在 Dreamweaver 中的数据库信息

类似 Oracle 的大型数据库系统的高级用户应限制在设计时由 Dreamweaver 检索和显示的数据库项的数量。Oracle 数据库可能包含 Dreamweaver 在设计时无法处理的项。您可在 Oracle 中创建一个架构，然后在 Dreamweaver 中使用它在设计时筛选掉不必要的项。

备注： 在 Microsoft Access 中无法创建架构或目录。

限制在设计时 Dreamweaver 检索的信息数量后，其他用户可能会从中受益。有些数据库包含几十张、甚至数百张表，您可能不希望 Dreamweaver 在您工作时将其全部列出。例如，在 Dreamweaver 的“记录集”对话框中，单击“表”弹出式菜单可列出指定数据库中的所有表。如果该数据库包含几十张表，则该列表将很长，而且难于使用。如果该数据库包含数百张表，在某些系统上，Dreamweaver 可能要花费很长时间来检索它们。架构或目录可限制在设计时 Dreamweaver 获取的数据库项的数量。

必须在数据库系统中创建架构或目录后，才能将其应用于 Dreamweaver 中。请查询数据库系统文档或向系统管理员咨询。

如果正在开发的是 ColdFusion 应用程序，将无法在 Dreamweaver 中应用架构或目录。

如果您正在开发的是 ColdFusion 应用程序之外的其他应用程序，则若要在 Dreamweaver 中应用架构或目录，请执行以下操作：
  1. 在 Dreamweaver 中打开动态页，然后打开“数据库”面板（“窗口”>“数据库”）。

    2. 如果数据库连接已经存在，则连接的列表将显示在该面板中。右击（在 Windows 中）或按住 Control 的同时单击（在 Macintosh 中）连接，然后从弹出式菜单中选择“编辑连接”。对应于该连接的对话框将会出现。

    如果不存在连接，请单击加号 (+) 按钮，然后创建连接。有关更多信息，请参见连接到数据库。

  2. 在该连接的对话框中，单击“高级”。

    3. “限制”对话框将出现。

  3. 指定架构或目录，然后单击“确定”。


设置“绑定”面板选项

此面板用于为页定义动态内容源以及向页添加该内容。

任务

定义动态内容源

向 Web 页中添加动态内容

更改或删除内容源

将格式应用于数据


设置“服务器行为”面板选项

此面板用于向页添加 Dreamweaver 服务器行为、编辑服务器行为以及新建服务器行为。

任务

显示数据库记录

生成主/详细页

生成搜索数据库的页面

建立修改数据库的页

生成对站点访问进行限制的页

删除动态内容

添加自定义服务器行为


设置“数据库”面板选项

“数据库”面板用于创建数据库连接、检查数据库以及将数据库相关代码插入到页中。

任务

在 Dreamweaver 中查看数据库结构

连接到数据库


设置“组件”面板选项

“组件”面板用于创建和检查组件，以及将组件代码插入到页中。

备注： 该面板不能在“设计”视图中工作。

任务

定义 JavaBeans（仅限于 JSP）

使用 ColdFusion 组件

使用 Web 服务


设置“设置活动数据”对话框选项

此对话框用于向页提供应来自用户的数据，以便 Dreamweaver 可在“设计”视图中显示具有活动数据的页。

过程
  1. 在“URL 请求”区域，单击加号 (+) 按钮，然后输入页所需要的参数。

    2. 为每个参数指定名称和测试值。

  2. 在“方法”弹出式菜单中，选择页所需的 HTML 构成方法：POST 或 GET。
  3. 在“初始化脚本”文本区域中，请包括希望在页运行前插入到其顶端的所有源代码。

    4. 初始化脚本通常由设置阶段变量的代码组成。有关更多信息，请参见了解阶段变量。

  4. 若要保存当前页的设置，请单击“保存此文档的设置”。

    5. 备注： 若要保存设置，必须启用“设计注释”（“文件”>“设计注释”）。

  5. 单击“确定”。

相关主题

向页提供所需参数

在“设计”视图中查看活动数据

了解表单参数

了解 URL 参数


设置“限制”对话框选项

此对话框用于使用预定义的数据库架构或目录来限制在设计时 Dreamweaver 检索的数据库项的数量。

必须在数据库应用程序中首先创建架构或目录后，才能将其应用于 Dreamweaver 中。 请查询数据库系统文档或向系统管理员咨询。

备注： 在 Microsoft Access 中无法创建架构或目录。

过程

指定架构或目录，然后单击“确定”。

相关主题

限制显示在 Dreamweaver 中的数据库信息

上一页


Dreamweaver 动态页设计工作流程

Macromedia Dreamweaver MX 所提供的关键益处在于使用户能够在没有编程语言使用经验的情况下创建动态 Web 站点。Dreamweaver 的可视工具使您可以开发动态 Web 站点，而不必亲手编写创建支持显示动态内容所必需的复杂编程逻辑，这些内容存储在数据库中。Dreamweaver 使您可以使用几种流行的 Web 编程语言和服务器技术中的任意一种来创建动态 Web 站点。这些语言和技术包括 Macromedia ColdFusion、ASP.NET、Microsoft ASP、JavaServer Page (JSP) 和 PHP。

本章概述了要成功设计和创建动态 Web 站点所必须遵循的几个关键步骤。在每一节的结尾处，都可以找到开发动态页所需的特定过程的参考资料。开发动态网页的五个关键步骤包括：

  • 设计页面
  • 创建动态内容的源
  • 向网页添加动态内容
  • 增强动态页的功能
  • 测试和调试页
下一页


设计页面

在设计任何 Web 站点（无论是静态还是动态的）时的一个关键步骤是页面视觉效果的设计。当向网页中添加动态元素时，页面的设计对于其可用性至关重要。请仔细考虑用户将如何既与各个页面又与整个 Web 站点进行交互。

将动态内容合并到网页的常用方法是创建一个表示内容的表，然后将动态内容导入该表的一个或多个单元格中。利用此方法，可以用一种结构化的格式来表示各种类型的信息。

有关设计页面的信息，请参见下列章节：

  • 在布局视图中对页进行布局
  • 使用表格显示内容
  • 插入文本和设置文本格式
  • 插入图像


创建动态内容的源

动态 Web 站点需要一个内容源，在将数据显示在网页上之前，动态 Web 站点需要从该内容源提取这些数据。在 Dreamweaver 中，这些数据源可以是数据库、请求变量、服务器变量、表单变量或预存过程。

可以在网页中使用这些内容源之前，必须：

  • 创建动态内容源（如数据库）与处理该页面的应用程序服务器之间的连接
  • 指定要显示数据库中的什么信息，或指定希望在该页面中包括什么变量
  • 使用 Dreamweaver 的指向并单击 (point-and-click) 界面选择动态内容元素并将其插入到选定页面

Dreamweaver 使您可以更容易地连接到数据库并创建从中提取动态内容的记录集。“记录集”是数据库查询的结果。它提取请求的特定信息，并允许在指定页面内显示该信息。根据包含在数据库中的信息和要显示的内容来定义记录集。

不同的技术供应商可能使用不同的术语来表示记录集。在 ASP 和 ColdFusion 中，记录集被定义为查询。在 JSP 中，记录集被称为结果集。ASP.NET 将记录集称为数据集。如果使用的是其他数据源，如用户输入或服务器变量，则 Dreamweaver 中定义的该数据源的名称与数据源名称本身相同。

若要在 Dreamweaver 中使用内容源，请使用“绑定”面板来创建数据源。“绑定”面板（如下图所示）使您可以为数据库和其他变量类型创建数据源。创建数据源后，该数据源存储在“绑定”面板中，可以从该面板中选择此数据源并将其插入当前页面中。

若要在 Dreamweaver 中创建记录集，请使用“记录集”对话框。可以从“插入”栏的“服务器”面板或者从“绑定”面板启动“记录集”对话框。该简单的“记录集”对话框使您可以选择现有数据库连接，并使您可以通过选择要将其数据包括在记录集中的表来创建数据库查询。甚至还可以使用该对话框的“筛选”部分为查询创建简单的搜索和返回条件。可以在“记录集”对话框内测试查询，并可以进行任何必要的调整，然后再将其添加到“绑定”面板。

建立数据库连接并定义记录集后，该记录集将出现在“绑定”面板中。从该面板中可以将记录集导入到已定义站点内的任何网页中。下面的插图显示的是“绑定”面板，面板中打开的是某雇员数据库的记录集。可以将任何显示的值插入到网页中，方法是先选中该项，然后单击面板底部的“插入”按钮。该选中项将被插入到页面内的指定占位符处。

有关数据库和创建数据库连接所需过程的信息，请参见下列章节：

  • 定义动态内容源
  • 数据库初学者指南
  • 在 Windows 中设置 DSN


向网页添加动态内容

定义记录集或其他数据源并将其添加到“绑定”面板后，可以将该记录集所代表的动态内容插入到页面中。Dreamweaver 的菜单型 (menu-driven) 界面使添加动态内容元素非常简单，只需从“数据绑定”面板中选择动态内容源，然后将其插入到当前页面内的适当文本、图像或表单对象中即可。

将动态内容元素或其他服务器行为插入到页面中时，Dreamweaver 会将一段服务器端脚本插入到该页面的源代码中。该脚本指示服务器从定义的数据源中检索数据，然后将数据呈现在该网页中。

若要在网页中放置动态内容，请：

  • 将其放在“代码”或“设计”视图中光标所指定的插入点处。
  • 替换文本字符串或其他占位符。
  • 将其插入到 HTML 属性中。例如，动态内容可以定义图像的 src 属性或表单域的 value 属性。

有关将动态内容添加到页面的详细过程，请参见：

  • 向 Web 页中添加动态内容
  • 创建交互式表单


增强动态页的功能

除了添加动态内容外，Dreamweaver 还使您可以轻松地将复杂的应用程序逻辑合并到网页中。可以使用服务器行为实现此目的。“服务器行为”是预定义的服务器端代码片段，这些代码向网页添加应用程序逻辑，从而提供更强的交互性能和功能。Dreamweaver 服务器行为允许您向 Web 站点添加应用程序逻辑，而不必您亲自编写代码。随 Dreamweaver MX 提供的服务器行为支持 ColdFusion、ASP、ASP.NET、JSP 和 PHP 文档类型。

服务器行为经过精心编写和仔细测试，以达到快速、安全和可靠的目的。Dreamweaver 的内置服务器行为被设计为支持跨平台 Web 页，适用于所有浏览器。


向页面添加服务器行为

若要向页面添加服务器行为，请从“插入”栏或“服务器行为”面板中选择它们。如果使用“插入”栏，请单击“应用程序”选项卡，然后单击一个服务器行为按钮。若要使用“服务器行为”面板，请选择“窗口”>“服务器行为”，然后单击面板上的加号 (+) 按钮，并从弹出式菜单中选择服务器行为。下面的插图显示“插入”栏中可用的“服务器行为”按钮。

Dreamweaver 提供指向并单击 (point-and-click) 界面，这种界面使得将动态内容和复杂行为应用到页面就象插入文本和设计元素一样简单。可使用的服务器行为如下所述：

  • 定义来自现有数据库的记录集。所定义的记录集随后存储在“绑定”面板中。
  • 在一个页面上显示多条记录。可以选择整个表、包含动态内容的各个单元格或各行，并指定要在每个页面视图中显示的记录数。
  • 创建动态表并将其插入到页面中，然后将该表与记录集相关联。以后可以分别使用“属性”检查器和“重复区域服务器行为”来修改表的外观和重复区域。
  • 在页面中插入动态文本对象。插入的文本对象是来自预定义记录集的项，可以对其应用任何 Dreamweaver MX 数据格式。
  • 创建记录导航和状态控件、主/详细页面以及用于更新数据库中信息的表单。
  • 显示来自数据库记录的多条记录。
  • 创建记录集导航链接，这种链接允许用户查看来自数据库记录的前面或后面的记录。
  • 添加记录计数器，以帮助用户跟踪返回了多少条记录以及它们在返回结果中所处的位置。

还可以通过编写您自己的服务器行为，或者安装由第三方编写的服务器行为来扩展 Dreamweaver 服务器行为。

有关使用服务器行为增强网页功能的更多信息，请参见下列章节：

  • 显示数据库记录
  • 生成搜索数据库的页面
  • 建立修改数据库的页
  • 生成对站点访问进行限制的页
  • 添加自定义服务器行为


测试和调试页

可以在 Web 上使用动态页或整个 Web 站点之前，需要测试其功能。测试站点提供帮助您测试 Web 站点可用性和跨平台兼容性的指南。有关为有听觉障碍、视觉障碍和其他障碍的人士设计 Web 站点的更多信息，请参见Dreamweaver 和辅助功能。您应该熟悉此章描述的问题，并考虑应用程序的功能可能会对有残疾的人士产生什么影响。


测试动态内容

Dreamweaver 使您可以使用“活动数据”窗口预览和编辑动态内容。

备注： 链接在“活动数据”窗口中不起作用。若要测试链接，请使用 Dreamweaver 的“在浏览器中预览”这一功能。（请参见在浏览器中预览页面。）

显示动态内容时，可以执行下列任务：

  • 使用 Dreamweaver 的页面设计工具调整页面布局
  • 添加、编辑或删除动态内容
  • 添加、编辑或删除服务器行为

为了实现此功能，Dreamweaver 在服务器上运行动态页，然后再将其显示在“动态数据”窗口中。每当切换到“活动数据”窗口时，打开文档的一个临时拷贝就被发送到应用程序服务器进行处理。结果页返回并显示在“活动数据”窗口中，然后删除服务器上的临时拷贝。

可以通过选择“查看”菜单中的“活动数据”，在“文档”窗口和“活动数据”窗口之间切换。如果页面需要来自用户的数据（例如在主页面中选定的记录的 ID 号），您可以在“设置活动数据”对话框中自己向此页面提供该数据。

若要输入活动数据参数：
  1. 对页面进行必要的更改。
  2. 如果页面需要来自使用 GET 方法的 HTML 表单的 URL 参数，请在工具栏的文本框中输入名称/值对，然后单击“刷新”按钮（环形箭头图标）。

    3. 以下列格式输入测试数据：

    name=value;

在此格式中，name 是页面需要的 URL 参数名，value 是该参数所具有的值。

也可以在“设置活动数据”对话框（“查看”>“设置活动数据”）中定义名称/值对，并将其与页面一起保存。
  3. 如果页面需要刷新，请单击“刷新”按钮。


编辑页面上的动态内容

通过更改提供动态内容的服务器行为可以修改该动态内容，或者通过完全删除该服务器行为可以将该动态内容从页面移除。例如，可以编辑记录集服务器行为，以便向页面返回更多的记录。

在“服务器行为”面板中列出了页面上的动态内容。例如，如果向页面中添加了某记录集，则“服务器行为”面板将其以如下方式列出：

记录集(myRecordset)

如果向页面中添加另一个记录集，则“服务器行为”面板以如下方式列出这两个记录集：

记录集(mySecondRecordset)
记录集(myRecordset)
若要编辑提供动态内容的服务器行为：
  1. 打开“服务器行为”面板（“窗口”>“服务器行为”）。
  2. 在“服务器行为”面板中单击加号 (+) 按钮以显示服务器行为，然后双击该服务器行为。

    3. 出现用于定义原始数据源的对话框。

  3. 在该对话框中进行更改，然后单击“确定”。

也可以使用属性检查器编辑页面上的记录集。打开属性检查器（“窗口”>“属性”），然后在“服务器行为”面板（“窗口”>“服务器行为”）中选择该记录集。下面是一个记录集的属性检查器：


删除动态内容

向页面添加动态内容后，可以通过在页面上选中该动态内容然后按 Delete 键来删除它。也可以通过在“服务器行为”面板中选择该动态内容，然后单击减号 (-) 按钮来删除它。

备注： 此操作移除页面中从数据库检索该动态内容的服务器端脚本。它并不删除数据库中的该数据。
上一页


存储和检索页面数据

基于 Web 的应用程序和动态 Web 站点都需要一个可以从中检索数据的内容源。不论是数据还是数据源都可以采取多种形式。通常，数据由返回到网页的文本或数字信息组成，并以某种形式显示给用户。

本章包含以下各节：

  • 用数据库存储内容
  • 收集用户提交的数据
  • 访问阶段变量中存储的数据
下一页


用数据库存储内容

通过用数据库存储内容可以使 Web 站点的设计与要显示给站点用户的内容分开。不必为每个页面都编写单独的 HTML 文件，只需为要表示的不同类型的信息编写一个页面或模板即可。通过使用数据库，只需将内容上传到数据库中，然后动态地检索该内容以响应用户的请求即可向 Web 站点提供新的内容。将内容信息存储在数据库中的主要优势是：能够在单个源中更新信息，然后将此更改传播到整个 Web 站点，而不必搜索可能包含该信息的所有页面并手工编辑每个页面。

根据必须存储的数据的数量和复杂性，数据库可以有多种形式。Windows 计算机上通常安装的数据库是 Microsoft Access。对于数据库方面的新手，Access 提供了一种易于使用的界面以便对数据库表进行操作。虽然可以将 Access 用作多数 Web 站点应用程序的数据源，但要注意 Access 的文件大小被限制在 2 GB 以内，并且并发用户数限制为 255 个。因此，可以选择 Access 用于 Web 站点开发和公司工作组。但如果预计有较大的用户群体会访问该站点，则请规划使用专为支持这种站点而设计的数据库，以满足预期用户数的访问要求。

对于在其数据建模时需要较大程度的灵活性，并且要求可以支持大量并发用户群体的 Web 站点，一般都使用基于服务器的关系型数据库（通常称作 RDBMS）。用于存储基于 Web 的应用程序和动态站点的内容的常用关系型数据库包括 MySQL、Microsoft SQL Server 和 Oracle。

无论选用哪种数据库来支持 Web 站点，都可以用 Dreamweaver 来设计 Web 表单，以便向数据库中插入数据，以及更新或删除数据库中的数据。

如要了解有关数据库的更多内容，请参见数据库初学者指南。


访问数据库中存储的数据

网页不能对数据库中存储的数据进行直接访问，而是需要与记录集进行交互。记录集是从数据库中提取的信息或记录的子集。该信息子集是通过数据库查询提取出来的。查询是一种专门用于从数据库中查找和提取特定信息的搜索语句。Macromedia Dreamweaver MX 使用结构化查询语言 (SQL) 来生成查询。尽管不需要学习 SQL（发音为“sequel ”）也能用 Dreamweaver 来创建简单的查询，但是有了这种易于理解的语言的基础知识后，可以创建更为高级的查询，并因此可在设计动态页方面提供更大的灵活性。如要学习有关 SQL 的基础知识，请参见SQL 入门。

SQL 查询可以生成只包括某些列、只包括某些记录，或者既包括列也包括记录的记录集。记录集也可以包括数据库表中所有的记录和列。但由于应用程序很少要用到数据库中的每个数据片段，所以应该努力使记录集尽可能的小。由于 Web 服务器会将记录集临时放在内存中，所以使用较小的记录集将占用较少内存，并可以潜在地改善服务器的性能。


收集用户提交的数据

可以用网页来收集用户提供的信息，将其存储在服务器的内存中，然后根据用户的输入用这些信息来创建动态响应。收集信息最常用的工具是 HTML 表单和超文本链接选择。

HTML 表单可以收集来自用户的信息并将其存储在服务器的内存中。HTML 表单可以将信息作为表单参数或 URL 参数来发送。如果将表单的 method 属性设为 POST，则浏览器会将表单的值包括在发送给服务器的消息的正文中。如果将表单的 method 属性设为 GET，则浏览器会将表单值追加到 action 属性中指定的 URL 中，并将信息发送给服务器。

超文本链接也可以收集来自用户的信息并将其存储在服务器的内存中。通过将值追加到锚记中指定的 URL 上，可以指定当用户单击链接（如某个参数选择）时要提交的值。当用户单击该链接时，浏览器会将 URL 和追加的值一起发送给服务器。

这一节描述如何创建用于 Web 应用程序的表单和 URL 参数。本节讨论以下主题：

  • 了解表单参数
  • 了解 URL 参数
  • 使用 HTML 链接创建 URL 参数
  • 使用 HTML 链接创建 URL 参数
  • 检索表单和 URL 参数


了解表单参数

表单参数是由使用 POST 或 GET 方法的 HTML 表单发送给服务器的。使用 POST 方法时，参数是在消息的正文中发送的。与此相反，GET 方法将参数追加到请求的 URL 上。

可使用 Dreamweaver 快速设计向服务器发送表单参数的 HTML 表单。有关说明，请参见创建交互式表单。注意您所选择的从浏览器向服务器传输信息的方法。下面的示例举例说明一个将表单方法设为 POST 的表单的属性检查器：

表单参数采用其相应表单对象的名称。例如，如果表单中包含一个名为 txtLastName 的文本域，则当用户单击“提交”按钮时，将有如下表单参数发送给服务器：

txtLastName=enteredvalue

如果 Web 应用程序需要一个精确的参数值（例如当该应用程序根据几种选项之一来执行一项操作时），则可以用单选按钮、复选框，或者列表/菜单表单对象来控制用户可以提交的可能值。这样可以防止用户错误地键入某些信息并引起应用程序错误。下面的示例描述一个提供三种选择的弹出式菜单表单：

每个菜单选项对应一个作为表单参数提交给服务器的硬编码值。“列表值”对话框（显示在下面）将每个列表项都与一个值（“Add”、“Update”或“Delete”）匹配起来：


了解 URL 参数

URL 参数是追加到 URL 上的一个名称/值对。参数以问号 (?) 开始并采用 name=value的格式。如果存在多个 URL 参数，则参数之间用一个 (&) 符隔开。下面的示例显示带有两个名称/值对的 URL 参数：

http://server/path/document?name1=value1&name2=value2

URL 参数用于将用户提供的信息从浏览器传递到服务器。当服务器收到请求，而且参数被追加到请求的 URL 上时，服务器在将请求的页提供给浏览器之前，于处理该页时放置这些参数。

在该示例中，可以将应用程序设想为一家基于 Web 的店面。由于希望招徕最大范围的可能顾客，所以站点的开发人员将站点设计得可以支持多种外币。用户登录到该站点之后，他们可以选择使用哪种货币来查看所列商品的价格。

  1. 浏览器向服务器请求该页的 report.cfm。该请求包括 URL 参数 Currency=“euro”。Currency=“euro ”变量指定所有检索到的货币数值都以欧盟的欧元为单位来显示。
  2. 服务器将 URL 参数临时存储在内存中。
  3. report.cfm 页读取并使用该参数来检索以欧元为单位的商品价格。这些货币数值既可以存储在反映不同货币的数据库表中，也可以从与每种商品相关联的单一货币形式转换为应用程序支持的任何货币形式。
  4. 服务器将 report.cfm 页发送给浏览器，并以请求的货币形式显示商品的价格。当该用户终止会话时，服务器将删除 URL 参数的值，释放服务器内存以存放登录进该站点的新用户的请求。
    下图显示应用程序服务器如何处理 URL 参数。

当将 HTTP 的 GET 方法与 HTML 表单一起使用时，将创建 URL 参数。GET 方法指定在提交表单时将参数值追加到 URL 请求上。

URL 参数的典型应用包括根据用户的喜好对 Web 站点进行个性化设置。例如，由用户名和密码组成的 URL 参数可用于验证用户身份，并只显示该用户已经订阅的信息。这种应用的常见示例包括一些金融 Web 站点，这些站点可根据用户以前所选的股票代码来显示个人的股票价格。Web 应用程序开发人员通常使用 URL 参数将值传递给应用程序内的变量。例如，可以将搜索语句传递给 Web 应用程序中的 SQL 变量以产生搜索结果。


使用 HTML 链接创建 URL 参数

在 HTML 链接内部创建 URL 参数，包括使用 HTML 锚记的 href 属性。通过切换到“代码”视图（“查看”>“代码”），可以在属性中直接输入 URL 参数。在下面的示例中，三个链接用三个可能值（Add、Update 和 Delete）来创建一个单独的 URL 参数 (action)。根据用户所单击链接的不同，会将不同的参数值发送给服务器，并且会执行不同的请求操作：

<a href=”http://www.mysite.com/myfiles/
   index.asp?action=Add”>添加一条记录</a>
<a href=”http://www.mysite.com/myfiles/
   index.asp?action=Update”>更新一条记录</a>
<a href=”http://www.mysite.com/myfiles/
   index.asp?action=Delete”>删除一条记录</a>

可以用 Dreamweaver 的属性检查器来创建同样的 URL 参数，方法是选定该链接并选择“窗口”>“属性”。在下面的示例中，URL 参数是在属性检查器中输入的：


检索表单和 URL 参数

创建完表单或 URL 参数后，Dreamweaver 可以读取该值并将其用在 Web 应用程序中。有关更多信息，请参见定义 URL 参数。

在 Dreamweaver 中定义了表单或 URL 参数之后，可将其值插入到页面中。有关更多信息，请参见向 Web 页中添加动态内容。


访问阶段变量中存储的数据

阶段变量提供了一种机制，通过这种机制，用户信息得以存储和访问，供 Web 应用程序所使用。通常，阶段变量存储信息（通常是由用户提交的表单或 URL 参数），并使该信息在用户访问的持续时间中对应用程序的所有页都可用。例如，当用户登录进一个 Web 门户（从该门户可访问电子邮件、股票报价、天气预报和每日新闻）之后，Web 应用程序会将登录信息存储在一个阶段变量中，该变量在所有站点页面中标识该用户。这样，当用户浏览整个站点时，他们可以只看到他们已经选中的内容类型。阶段变量还可以提供一种超时形式的安全机制，这种机制在用户帐户长时间不活动的情况下，终止该用户的会话。如果用户忘记从 Web 站点注销，这种机制还会释放服务器内存和处理资源。

阶段变量通常用于存储用户显示的参数选择、多部分问卷的答案、在所谓“购物车”应用程序中选购的商品，以及网上游戏的所得分数等。

这一节描述下列阶段变量主题：

  • 了解阶段变量
  • 收集信息以存储在阶段变量中
  • 将信息存储在阶段变量中
  • 存储在阶段变量中的信息的示例
  • 从阶段变量中检索数据


了解阶段变量

Web 服务器（或者更准确地说，HTTP 协议）是无状态的，即它们不跟踪连接到它们的浏览器，也不跟踪用户的各个页面请求。Web 服务器每次接收对网页的请求，并通过向用户的浏览器发送相关页面做出响应后，Web 服务器都会“忘记”进行请求的浏览器和它发送出去的网页。当同一用户稍后请求一个相关页时，Web 服务器会发送该页，而并不知道它发给该用户的上一页是什么。

HTTP 的无状态本性使它成为一种简单而易于实现的协议，因此也使得越高级的 Web 应用程序（如个性化所生成的内容）越难实现。例如，为了给单个用户自定义站点内容，必须首先标识出该用户。许多 Web 站点使用一些用户名/密码登录表单来实现此目的。如果需要显示多个自定义的页面，则必需一种跟踪登录用户的机制，因为多数用户将不能接受为站点的每一页都提供其用户名/密码。

为了能够创建复杂的 Web 应用程序和在所有站点页间存储用户提供的数据，许多应用程序服务器技术都包括对“会话管理”的支持。会话管理使 Web 应用程序能够在多个 HTTP 请求之间维护状态，使用户对网页的请求在给定时间段内可视作同一交互会话的一部分。

阶段变量存储着用户的会话生命周期的信息。当用户第一次打开应用程序中的某一页时，用户会话开始。当用户一段时间内不再打开该应用程序中的其他页时，或者用户明确终止该会话时（通常是通过单击“注销”链接），会话结束。在会话存在期间，会话特定于单个用户，每个用户都有单独的会话。

阶段变量用于存储 Web 应用程序中每页都能访问的信息。信息可以多种多样，如用户名称、首选字体大小，或者是指示用户是否成功登录的标记等。阶段变量的另一个常见用途是保存连续分数，比如在网上测验中到目前为止用户答对的题数，或者到目前为止，用户从网上目录中选择的产品。

请注意，阶段变量只有在用户的浏览器配置成接受 Cookie 时才起作用。当首次对会话进行初始化时，服务器创建一个唯一标识该用户的会话 ID 号，然后将包含该 ID 号的 Cookie 发送到用户的浏览器。当用户请求服务器上的另一页时，服务器会读取浏览器中的 Cookie 以识别该用户并检索存储在服务器内存中的该用户的阶段变量。


收集信息以存储在阶段变量中

创建阶段变量前，必须先获得要存储的信息，然后才能将其发送到服务器进行存储。这一节描述如何用 HTML 表单或包含 URL 参数的超文本链接来收集信息并将其发送给服务器。信息的获取来源还包括：存储在用户计算机上的 Cookie、用户浏览器发送的带有页面请求的 HTTP 标头，或者数据库。


将 URL 参数存储在阶段变量中

在下列示例中，产品目录使用硬编码的 URL 参数（用超文本链接创建的）将产品信息发送回服务器，以存储在阶段变量中。当用户单击“Add to shopping cart”链接时，产品 ID（该示例中为 3202）将存储在阶段变量中，而用户可以继续采购。当用户继续浏览到付款页时，即可检索出存储在阶段变量中的产品编号。


将表单参数存储在阶段变量中

在该示例中，一个基于表单的测验页将选定的信息发送回服务器，在服务器上， marks.cfm 页对该测验进行评分，并把正确答案的数量存储在阶段变量中。


将信息存储在阶段变量中

信息发送给服务器后，通过向由 URL 或表单参数指定的页中添加适合于服务器模型的代码，即可将信息存储在阶段变量中。请参考“destination”页，该页既可在 HTML 表单的 action 属性中指定，也可在起始页上超文本链接的 href 属性中指定。

每种 HTML 语法如下所示：

<form action="destination.html" method="get" name="myform"> </form>
<param name="href"value="destination.html">

所用的服务器技术和用于获取信息的方法共同确定了使用什么代码将信息存储在阶段变量中。每种服务器技术的基础语法如下所示：

ColdFusion

<CFSET session.variable_name = value>

ASP 和 ASP.NET

<% Session("variable_name") = value %>

value 表达式通常是如 Request.Form(“lastname”) 之类的服务器表达式。例如，如果使用名为 product 的 URL 参数（或使用利用 get 方法并且文本域名为 product 的 HTML 表单）收集信息，则下列语句将信息存储在一个名为 prodID 的阶段变量中：

ColdFusion

<CFSET session.prodID = url.product>

ASP 和 ASP.NET

<% Session("prodID") = Request.QueryString("product") %>

如果使用包含 post 方法和名为 txtProduct 的文本域的 HTML 表单来收集信息，则下列语句会将信息存储在阶段变量中：

ColdFusion

<CFSET session.prodID = form.txtProduct>

ASP 和 ASP.NET

<% Session("prodID") = Request.Form("txtProduct") %>


存储在阶段变量中的信息的示例

假定您正在处理一个拥有大量老年访问者的站点。在 Dreamweaver 中，您向起始页中添加了两个链接，使用户可以对该站点的文本大小进行自定义。如果需要较大的、易读的文本，用户可以单击一个链接；如果需要常规大小的文本，用户可以单击另一个链接：

每个链接都有一个名为 fontsize 的 URL 参数，它可以将用户的文本首选设置提交给服务器，如下面的 Macromedia ColdFusion 示例所示：

<a href="resort.cfm?fontsize=large">较大文本</a><br>
<a href="resort.cfm?fontsize=small">普通文本</a>

您决定将用户的文本首选设置存储在阶段变量中，并用其设置用户请求的每一页上的字体大小。

在靠近目标页顶端的地方，输入下列代码来创建名为 font_pref 的会话，其中存储用户的字体大小首选设置。

ColdFusion

<CFSET session.font_pref = url.fontsize>

ASP 和 ASP.NET

<% Session("font_pref") = Request.QueryString("fontsize") %>

当用户单击超文本链接时，该页将 URL 参数中用户的文本首选设置发送给目标页。目标页中的代码将该 URL 参数存储在 font_pref 阶段变量中。在该用户会话的持续时间内，应用程序中的所有页都将检索该值，并显示选定的字体大小。


从阶段变量中检索数据

将值存储在阶段变量中后，即可用 Dreamweaver 从阶段变量中检索该值并用在 Web 应用程序中。有关更多信息，请参见定义阶段变量。

在 Dreamweaver 中定义了阶段变量后，可以将其值插入到某个页面中。有关更多信息，请参见向 Web 页中添加动态内容。

上一页


定义动态内容源

动态 Web 站点要求有一个可从中检索和显示动态内容的数据源。Macromedia Dreamweaver MX 允许使用数据库、请求变量、URL 变量、服务器变量、表单变量、预存过程以及其它动态内容源。根据数据源的不同，您可检索新内容以满足某个请求，也可修改页面以满足用户需要。

本章讲述将数据库和变量定义为动态内容源的过程。要了解有关本章所讨论的技术的更多信息，请参考HTML 和 Web 技术资源。

本章包含以下几节：

  • 了解动态内容源
  • 定义记录集
  • 定义 URL 参数
  • 定义阶段变量
  • 定义应用程序变量
  • 定义服务器变量
  • 缓存内容源
  • 更改或删除内容源
  • 将记录集从一个页面拷贝到另一个页面
下一页


了解动态内容源

动态内容源是一个可从中检索和显示在网页中使用的动态内容的信息存储区。动态内容源不仅包括存储在数据库中的信息，还包括通过 HTML 表单提交的值、服务器对象中包含的值、JavaBeans 属性值以及其它内容源。

在 Dreamweaver 中定义的任何内容源都被添加到“绑定”面板的内容源列表中。创建内容源并将其加到“绑定”面板后，就可以很容易地将其插入到当前所选的页面中。


定义记录集

将数据库用作动态网页的内容源时，必须首先创建一个要在其中存储检索数据的记录集。记录集在存储内容的数据库和生成网页的应用程序服务器之间起一种桥梁作用。记录集由数据库查询返回的数据组成，并且临时存储在应用程序服务器的内存中，以便进行快速数据检索。当服务器不再需要记录集时，就会将其丢弃。

记录集本身是从指定数据库中检索到的数据的集合。它可以包括完整的数据库表格，也可以包括表格的行和列的子集。这些行和列通过在记录集中定义的数据库查询进行检索。数据库查询是用结构化查询语言 (SQL) 编写的。而 SQL 是一种简单的、可用来在数据库中检索、添加和删除数据的语言。使用 Dreamweaver 附带的 SQL 创建器，您可以在不了解 SQL 的情况下创建简单查询。不过，如果想创建复杂的 SQL 查询，则需要学习 SQL 并手动编写输入到 Dreamweaver 中的 SQL 语句。

备注： Microsoft ASP.NET 将记录集称为“数据集”。如果您使用的是 ASP.NET 文档类型，则特定于 ASP.NET 的对话框和菜单选项使用标签“数据集”。Dreamweaver 文档一般将这两种类型都称作“记录集”，但是，在专门描述 ASP.NET 功能时使用的是“数据集”。

有关使用数据库和 SQL 的更多信息，请参见以下章节：数据库初学者指南和SQL 入门。

定义用于 Dreamweaver 的记录集之前，必须先创建数据库连接并在数据库中输入数据（如果数据库中还没有数据的话）。如果尚未定义站点的数据库连接，请参考数据库连接一章中有关您正在针对其进行开发的服务器技术的内容，并按照创建数据库连接的说明进行操作。

以下各章描述了用于 Dreamweaver 所支持的所有服务器技术的数据库连接：

  • ColdFusion 开发人员的数据库连接
  • ASP 开发人员的数据库连接
  • ASP.NET 开发人员的数据库连接
  • 用于 JSP 开发人员的数据库连接
  • 适用于 PHP 开发人员的数据库连接

本节包含以下主题：

  • 不通过编写 SQL 来创建记录集
  • 通过编写 SQL 来创建高级记录集
  • 使用“数据库项”树创建 SQL 查询


不通过编写 SQL 来创建记录集

本节描述如何使用 Dreamweaver 的“记录集”对话框（该对话框使您无须手动输入 SQL 语句即可创建记录集）定义记录集。使用此方法定义记录集与从“记录集”对话框的弹出式菜单中选取数据库连接和表格一样容易。

如果您想自己编写 SQL 语句，请使用“高级记录集”对话框。（请参见通过编写 SQL 来创建高级记录集）。

不通过编写 SQL 来定义记录集：
  1. 在“文档”窗口中打开要使用记录集的页面。
  2. 选择“窗口”>“绑定”以显示“绑定”面板。
  3. 在“绑定”面板中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    4. 出现“简单记录集”对话框。如果开发的是 Macromedia ColdFusion MX 或 ASP.NET 站点，则该“记录集”对话框与下图所示的对话框略有不同。如果出现的是“高级记录集”对话框，请单击“简单”按钮切换到“简单记录集”对话框。
    这是所描述的功能的图片。

  4. 完成该对话框。

    5. 有关完成“记录集”对话框的说明，请参见以下各节中适合您的文档类型的一节：

    • 设置“简单记录集”对话框选项。
    • 设置“简单记录集”对话框选项：ColdFusion。
    • 设置“简单数据集”对话框选项：ASP.NET。
  5. 单击“测试”按钮执行查询，并确保该查询检索到自己想要的信息。

    6. 如果定义了使用用户输入的参数的过滤器，则单击“测试”按钮时将显示“测试值”对话框。在“测试值”文本框中输入一个值，然后单击“确定”。记录集实例成功创建时，将出现一个显示从该记录集中提取的数据的表格。

  6. 单击“确定”将该记录集添加到“绑定”面板的可用内容源列表中。


通过编写 SQL 来创建高级记录集

“高级记录集”对话框使您能够编写自己的 SQL 语句，或使用图形化的“数据库项”树来创建 SQL 语句。

备注： 如果编写的 SQL 语句用于 ASP.NET 文档类型，请参考编写用于 ASP.NET 的 SQL中有关 ASP.NET 特定规则的内容。

通过编写 SQL 来定义记录集：
  1. 在“文档”窗口中打开要使用记录集的页面。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 在“绑定”面板中，单击加号 (+) 按钮并从弹出式菜单中选择“记录集（查询）”。

    4. 出现“高级记录集”对话框。如果开发的是 ColdFusion MX 或 ASP.NET 站点，则该“记录集”对话框与下图所示的对话框略有不同。如果出现的是“简单记录集”对话框，请单击“高级”按钮切换到“高级记录集”对话框。
    这是所描述的功能的图片。

  4. 完成该对话框。

    5. 有关完成“记录集”对话框的说明，请参见以下各节中适合您的文档类型的一节：

    • 设置“高级记录集”对话框。
    • 设置“高级记录集”对话框：ASP.NET” 。
    • 设置“高级记录集”对话框选项：ColdFusion。
  5. 单击“测试”按钮执行查询，并确保该查询检索到自己想要的信息。

    6. 如果定义了使用用户输入的参数的过滤器，则单击“测试”按钮时将显示“测试值”对话框。在“测试值”文本域中输入一个值并单击“确定”。记录集实例成功创建时，将出现一个显示该记录集中数据的表格。

  6. 单击“确定”将该记录集添加到“绑定”面板的可用内容源列表中。


编写用于 ASP.NET 的 SQL

当在“高级数据集”对话框中编写 SQL 语句时，您必须了解以下特定于 ASP.NET 的条件：


参数

用于引用参数的语法因所用的数据库连接而异。连接类型有以下几种：

OLE DB

使用 OLE DB 连接至数据库时，必须使用问号 (?) 引用参数。例如：

SELECT * FROM Employees WHERE HireDate > ?

Microsoft SQL Server

使用 .NET 框架随附的 Managed Data Provider for SQL Server 连接至 Microsoft SQL Server 时，必须命名所有参数。例如：

SELECT * FROM Employees WHERE HireDate > @hireDate


在 SQL 语句内插入代码

在为 ASP.NET 编写的 SQL 语句内插入代码时，必须将所有字符串括在引号 (“ “) 中，并将代码括在括号 ( ) 中：

SELECT * FROM Employees WHERE HireDate >“+ (Request.queryString(“hireDate”))


ASP.NET 中的数据库连接

要了解有关 ASP.NET 中的数据库连接的更多信息，请参见ASP.NET 开发人员的数据库连接。


使用“数据库项”树创建 SQL 查询

可以使用“数据库项”的“指点”界面创建复杂的 SQL 查询，而不必将 SQL 语句手动键入到 SQL 文本框中。“数据库项”树使您可以选取数据库对象，并使用 SQL SELECT、WHERE 和 ORDER BY 子句链接它们。创建 SQL 查询后，即可使用对话框的“变量”部分定义任何变量。

以下各示例讲述了两种 SQL 语句以及使用“高级记录集”对话框的“数据库项”树创建它们的步骤。


选取表格

本例选取 Employees 表格的全部内容。定义查询的 SQL 语句如下所示：

SELECT * FROM Employees
创建此查询：
  1. 展开 Tables 分支以显示所选数据库中的全部表格。
  2. 选取 Employees 表格。
  3. 单击“选择”按钮。
  4. 单击“确定”将记录集添加到“绑定”面板中。


从表格中选取特定行并对结果进行排序

下例从 Employees 表格中选取两行，并使用必须定义的变量选取职业类型。然后，按雇员姓名对结果进行排序。

SELECT emplNo, emplName
FROM Employees
WHERE emplJob = 'varJob'
ORDER BY emplName
创建此查询：
  1. 展开 Tables 分支以显示所选数据库中的全部表格，然后展开 Employees 表格以显示单独的表格行。
  2. 按下列步骤生成 SQL 语句：
    • 选取 emplNo 并单击“SELECT”按钮。
    • 选取 emplName 并单击“SELECT”按钮。
    • 选取 emplJob 并单击“WHERE”按钮。
    • 选取 emplName 并单击“ORDER BY”按钮。
  3. 将插入点放在 SQL 文本区域中的 WHERE emplJob 后面，然后键入 ='varJob'（包括等于号）。
  4. 定义变量 'varJob'，方法为单击“变量”区域中的加号 (+) 按钮，然后在“名称”、“默认值”和“运行时值”列中分别输入下列值：varJob、CLERK、Request("job")。
  5. 单击“确定”将记录集添加到“绑定”面板中。


定义 URL 参数

URL 参数存储用户输入的检索信息。若要定义 URL 参数，请创建使用 GET 方法提交数据的表单或超文本链接。信息附加到所请求页面的 URL 后面并传送到服务器。使用 URL 变量时，查询字符串包含一个或多个与表单域相关联的名称/值对。这些名称/值对附加在 URL 后面。

开始之前，请确保将表单或 URL 参数传递到服务器。有关说明，请参见了解表单参数。

定义 URL 参数：
  1. 在“文档”窗口中打开要使用该变量的页面。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 在“绑定”面板中单击加号 (+) 按钮，然后从弹出式菜单中选择下列选项之一：

    文档类型
    “绑定”面板中用于 URL 变量的菜单项
    ASP
    请求变量 > Request.QueryString
    ColdFusion
    URL 变量
    JSP
    请求变量
    PHP
    URL 变量

    4. 显示“URL 变量”对话框。
    这是所描述的功能的图片。

  4. 在文本域中输入 URL 变量的名称并单击“确定”。

    5. URL 变量的名称通常是用于获得变量值的 HTML 表单域或对象的名称。

  5. URL 变量即会出现在“绑定”面板中。
    这是所描述的功能的图片。

定义 URL 变量后，即可在当前所选页面中使用其值。有关更多信息，请参见向 Web 页中添加动态内容。


定义表单参数

表单参数存储包含在网页的 HTTP 请求中的检索信息。如果创建使用 POST 方法的表单，则通过该表单提交的数据将传递到服务器。开始之前，请确保将表单参数传递到服务器。有关说明，请参见存储和检索页面数据。

定义表单参数：
  1. 在“文档”窗口中打开要使用该变量的页面。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 在“绑定”面板中单击加号 (+) 按钮，然后从弹出式菜单中选择下列选项之一：

    文档类型
    “绑定”面板中用于表单变量的菜单项
    ASP
    请求变量 > Request.Form
    ColdFusion
    表单变量
    JSP
    请求变量
    PHP
    表单变量

    4. 显示“表单变量”对话框：
    这是所描述的功能的图片。

  4. 在对话框中输入表单变量的名称并单击“确定”。

    5. 表单参数的名称通常是用于获得其值的 HTML 表单域或对象的名称。

  5. 表单参数即会出现在“绑定”面板中。
    这是所描述的功能的图片。

将表单参数定义为内容源后，即可在页面中使用其值。有关更多信息，请参见存储和检索页面数据。


定义阶段变量

可以使用阶段变量存储和显示在用户访问（或会话）期间保持的信息。服务器为每个用户创建不同的阶段对象并保持一段固定时间，或直至该对象被明确终止。有关更多信息，请参见访问阶段变量中存储的数据。

因为阶段变量在整个用户会话期间持续，并且当用户从 Web 站点内的一个页面移到另一页面时仍持续存在，所以这些变量非常适于存储用户参数选择。阶段变量还可用于在页面的 HTML 代码中插入值、将值指定给本地变量或提供计算条件表达式所需的值。

定义页面的阶段变量之前，必须先在源代码中创建它们。有关说明，请参见以下两节中的内容：

  • 收集用户提交的数据
  • 访问阶段变量中存储的数据

在 Web 应用程序的源代码中创建阶段变量后，即可使用 Dreamweaver 检索变量值并将其用在网页中。

定义预定义的阶段变量：
  1. 在源代码中创建一个阶段变量并为其指定值。

    2. 例如，下面的 ASP 范例实例化一个叫做 username 的会话，并为其指定值 Cornelius：

    <% Session(username) = "Cornelius" %>
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 单击加号 (+) 按钮并从弹出式菜单中选择“阶段变量”。
  4. 输入在源代码中定义的变量名称。

    5. 在本例中，即为 username。

  5. 单击“确定”。

    6. 阶段变量即会出现在“绑定”面板中。
    这是所描述的功能的图片。

定义了阶段变量后，就可以在页面中使用它的值。有关更多信息，请参见向 Web 页中添加动态内容。


定义应用程序变量

在 ASP 和 ColdFusion 中，可以使用应用程序变量来存储和显示某些信息，这些信息在应用程序的生存期内被保持并且在用户改变时仍持续存在。应用程序的生存期是指从第一个用户在该应用程序中请求页面到 Web 服务器停止工作之间的一段时间。（应用程序被定义为一个虚拟目录及其子目录中的所有文件）。

因为应用程序变量在应用程序的整个生存期内存在，并且在用户改变时仍持续存在，所以它们非常适合于存储所有用户都需要的信息，如当前时间和日期。应用程序变量的值在应用程序代码中定义。

备注： JSP 或 PHP 中没有应用程序对象。

定义用于页面的应用程序变量：
  1. 在“文档”窗口中打开动态文档类型。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 单击加号 (+) 按钮并从弹出式菜单中选取“应用程序变量”。
  4. 输入在应用程序源代码中定义的变量名称。
  5. 单击“确定”。

    6. 应用程序变量即会出现在“绑定”面板中。

    定义了应用程序变量后，就可以在页面中使用它的值。有关更多信息，请参见向 Web 页中添加动态内容。


定义服务器变量

可以将服务器变量定义为动态内容源，以便在 Web 应用程序中使用。

服务器变量因文档类型而异，其中包括表单变量、URL 变量、阶段变量和应用程序变量。有关这些变量类型的更多信息，请参见以下各节：

  • 定义 URL 参数
  • 定义表单参数
  • 定义阶段变量
  • 定义应用程序变量

本节讨论可定义为内容源的用于不同文档类型的服务器变量。文档类型及其相关章节如下所示：

  • 定义 ASP 服务器变量
  • 定义 ColdFusion 服务器变量
  • 定义 JSP 服务器变量
  • 定义 JavaBeans（仅限于 JSP）


定义 ASP 服务器变量

可以将下列 ASP 服务器变量定义为动态内容源：Request.Cookie、Request.QueryString、Request.Form、Request.ServerVariables 和 Request.ClientCertificates。

定义用于 ASP 页面的服务器变量：
  1. 打开“绑定”（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出式菜单中选择“请求变量”。

    3. 显示“请求变量”对话框。
    这是所描述的功能的图片。

  3. 从“类型”弹出式菜单中选择一个请求集合。

    4. 例如，如果您想访问 Request.ServerVariables 集合中的信息，则请选择“服务器变量”。如果想访问 Request.Form 集合中的信息，则选择“表单”。

    有关这些变量的更多信息，请参见设置“请求变量”对话框选项：ASP。

  4. 指定您想访问的集合中的变量。

    5. 例如，如果想访问 Request.ServerVariables("HTTP_USER_AGENT") 变量中的信息，则输入参数 HTTP_USER_AGENT。如果想访问 Request.Form("lastname") 变量中的信息，则输入参数 lastname。

  5. 单击“确定”。

    6. 服务器变量即会出现在“绑定”面板中。
    这是所描述的功能的图片。


定义 ColdFusion 服务器变量

可以将下列 ColdFusion 服务器变量定义为动态内容源：客户端、Cookie、CGI、服务器和本地变量。

客户端变量使数据与特定的客户端相关联。当用户在应用程序中从一个页面移动到另一个页面或从一个会话移动到另一个会话时，客户端变量将保持应用程序的状态。保持状态指的是将一个页面（或会话）的信息保留到下一个页面（或会话），以便应用程序“记住”用户和用户以前的选择和参数选择。

Cookie 变量访问由浏览器传递给服务器的 Cookie。

CGI 变量提供有关运行 ColdFusion 的服务器、请求页面的浏览器的信息以及其它有关处理环境的信息。

服务器变量可以由服务器上的所有客户端和应用程序访问。它们将一直持续到服务器被停止。

本地变量是在 ColdFusion 页面中用 CFSET 标记或 CFPARAM 标记创建的。

定义用于 ColdFusion 页面的服务器变量：
  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出式菜单中选择“服务器变量”。
  3. 输入变量名称。

    4. 有关可能存在的名称项的更多信息，请单击“帮助”按钮。

  4. 单击“确定”。

    5. ColdFusion 服务器变量即会出现在“绑定”面板中。

有关更多信息，请参见：

  • 定义 URL 参数
  • 定义阶段变量
  • 定义应用程序变量
  • 向 Web 页中添加动态内容


定义 PHP 服务器变量

定义用于 PHP 页面的服务器变量：
  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出式菜单中选择变量。
  3. 输入变量名称。
  4. 单击“确定”。

    5. PHP 服务器变量即会出现在“绑定”面板中。

    有关更多信息，请参见定义 URL 参数和向 Web 页中添加动态内容。


定义 JSP 服务器变量

可以将请求变量定义为 JSP 页面的动态内容源。

定义用于 JSP 页面的请求变量：
  1. 打开“绑定”面板（“窗口”>“绑定”）。
  2. 单击加号 (+) 按钮并从弹出式菜单中选择“请求变量”。
  3. 输入变量名称。
  4. 单击“确定”。

    5. JSP 服务器变量即会出现在“绑定”面板中。

    有关更多信息，请参见定义 URL 参数和向 Web 页中添加动态内容。


定义 JavaBeans（仅限于 JSP）

JavaBeans 是多层 JSP 应用程序的结构元素。JavaBeans 通常用作中间“商业逻辑”层（它旨在将表示逻辑和数据访问逻辑隔离）的组成部分。在这些应用程序中，由 JavaBeans（也称为“Beans”）而不是 JSP 页面包含直接访问数据库的逻辑。

在 Dreamweaver 中，JavaBeans 被视为 JSP 页面的动态内容源并出现在“绑定”面板中。可以在“绑定”面板中双击 JavaBeans 以查看它们的属性，然后将属性拖到页面中以创建动态数据引用。

还可以将 JavaBeans 集合（一组 JavaBeans）定义为动态内容源。不过，使用 JavaBeans 集合时，Dreamweaver 只支持重复区域和动态绑定。

Bean 类的拷贝（或者是包含 Bean 类的 .zip 或 .jar 文件的拷贝）必须驻留在下列位置：

  • 在运行 Dreamweaver 的系统中，Bean 类的拷贝必须驻留在 Dreamweaver 的 Configuration/Classes 文件夹或系统的 classpath 中。（Dreamweaver 在设计时使用该类拷贝。）
  • 在运行 JSP 应用程序服务器的系统中，Bean 类必须驻留在应用程序服务器的 classpath 中。（应用程序服务器在运行时使用该类拷贝。）应用程序服务器的 classpath 因应用程序服务器而异，但是一般情况下，classpath 指向一个带有 Classes/Bean 子文件夹的 WEB-INF 文件夹。

如果 Dreamweaver 和应用程序服务器都在同一个系统中运行，并且应用程序服务器使用的是系统 classpath（而不是内部 classpath），则单个 JavaBeans 类拷贝可以驻留在计算机的系统 classpath 中。应用程序服务器和 Dreamweaver 都将使用该类拷贝。否则，JavaBeans 类的拷贝必须驻留在计算机的两个路径中，如上所述。

文件夹结构必须与 JavaBeans 软件包相匹配。例如，如果 JavaBeans 软件包名为 com.ardvark.myBean，则必须将该软件包存储在 classpath 的 /com/ardvark/ 中或 Dreamweaver 的 Configuration/Classes 文件夹中。

定义用于 JSP 页面的 JavaBean：
  1. 选择“窗口”>“绑定”显示“绑定”面板。
  2. 单击加号 (+) 按钮并从弹出式菜单中选择“JavaBean”。

    3. 随即出现“JavaBean”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框并单击“确定”。

    4. 有关说明，请参见设置“本地变量”对话框选项。

  4. 新定义的 Bean 即会出现在“绑定”面板中。
定义用于 JSP 页面的 JavaBean 集合：
  1. 选择“窗口”>“绑定”显示“绑定”面板。
  2. 单击加号 (+) 按钮并从弹出式菜单中选择“JavaBean 集合”。

    3. 出现“JavaBean 集合”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框并单击“确定”。

    4. 有关完成该对话框的说明，请参见设置“JavaBean 集合”对话框选项。

  4. 新定义的 JavaBean 集合出现在“绑定”面板中。


缓存内容源

可以将动态内容源缓存（或存储）在“设计备注”中。这样，即使您无法访问存储动态内容源的数据库或应用程序服务器，也可以在站点中工作。通过消除对数据库和应用程序服务器的网络重复访问，缓存还可能会加快开发速度。

若要缓存内容源，请单击“绑定”面板右上角的箭头按钮，并在弹出式菜单中切换“缓存”。

如果对其中一个内容源进行了更改，可以单击“绑定”面板右上角的“刷新”按钮（圆形箭头图标）刷新缓存。（如果看不到该按钮，请展开面板。）


更改或删除内容源

可以更改或删除任何现有的动态内容源 - 即“绑定”面板中列出的任何内容源。

在“绑定”面板中更改或删除内容源不会 更改或删除页面中该内容的任何实例。而只是将它作为可能的页面内容源进行更改或删除。若要编辑或删除页面中的内容实例，请参见更改动态内容和删除动态内容。

在“绑定”面板中更改内容源：
  1. 在“绑定”面板中，双击您想要编辑的内容源的名称。
  2. 在出现的对话框中进行更改。
  3. 如果对所做的工作感到满意，请单击“确定”。
从“绑定”面板中删除内容源：
  1. 在“绑定”面板中，从列表中选取内容源。
  2. 单击减号 (-) 按钮。


将记录集从一个页面拷贝到另一个页面

在定义的站点内，可以将记录集从一个页面拷贝到另一个页面。

将记录集拷贝到另一个页面：
  1. 在“绑定”面板或“服务器行为”面板中选取记录集。
  2. 右击该记录集并从弹出式菜单中选择“拷贝”。
  3. 打开您想要向其拷贝记录集的页面。
  4. 右击“绑定”面板或“服务器行为”工具栏，并从弹出式菜单中选择“粘贴”。


参考资料

本节讲述本章中介绍的对话框和面板，并描述适用于各个对话框和面板的域和设置。您还可以单击每个对话框的“帮助”按钮来查看该对话框的信息。联机帮助面板将显示适合该对话框的信息和设置。


设置“绑定”面板选项

该面板用于定义和编辑动态内容源、向页面添加动态内容以及将数据格式应用于动态文本。使用“绑定”面板的方式取决于您想要执行的任务。下列主题描述了各项任务使用“绑定”面板的方式。

相关主题

定义记录集

定义 URL 参数

定义阶段变量

定义应用程序变量

定义服务器变量

定义 JavaBeans（仅限于 JSP）

缓存内容源

更改或删除内容源

将记录集从一个页面拷贝到另一个页面

向 Web 页中添加动态内容

将 HTML 属性动态化


设置“简单记录集”对话框选项

此对话框将记录集定义为动态内容源，而不必手动编写 SQL 语句代码。

过程
  1. 在“名称”文本框中，输入记录集的名称。

    2. 通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其它对象名称区分开。例如：rsPressReleases

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出式菜单中选取一个连接。

    3. 如果列表中未出现连接，请单击“定义”创建连接。

  3. 在“表格”弹出式菜单中，选取为记录集提供数据的数据库表格。

    4. 弹出式菜单显示指定数据库中的所有表格。

  4. 若要使记录集中只包括某些表格列，请单击“已选定”，然后按住 Control 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。
  5. 若要只包括某些表格记录，请按照下列步骤完成“过滤器”部分：
    • 在第一个弹出式菜单中，选取数据库表格中的列，以将其与定义的测试值进行比较。
    • 在第二个弹出式菜单中选取一个条件表达式，以便将每个记录中的选定值与测试值进行比较。
    • 在第三个弹出式菜单中选取“输入的值”。
    • 在文本框中输入测试值。

      • 如果记录中的指定值符合筛选条件，则将该记录包括在记录集中。

  6. 如果要对记录进行排序，请选取要作为排序依据的列，然后指定是按升序（1、2、3... 或 A、B、C...）还是按降序对记录进行排序。
  7. 单击“测试”连接到数据库并创建数据源实例。

    8. 出现显示返回数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”关闭数据源。

  8. 单击“确定”。

    9. 新定义的记录集即会出现在“绑定”面板中。

相关主题

不通过编写 SQL 来创建记录集

通过编写 SQL 来创建高级记录集

数据库初学者指南


设置“简单记录集”对话框选项：ColdFusion

使用此对话框可将用于 ColdFusion 文档类型的记录集定义为动态内容源，而无须手动编写 SQL 语句代码。

备注： 如果创建的是用于 ColdFusion 5 或更早版本的记录集，则使用其它文档类型（如 ASP 和 JSP）通用的普通“简单记录集”对话框。

过程
  1. 在“名称”文本框中，输入记录集的名称。

    2. 通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其它对象名称区分开。例如：rsPressReleases

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“数据源”弹出式菜单中选取数据源。

    3. 如果弹出式菜单中未出现数据源，则需要创建 ColdFusion 数据源。

  3. 如果需要，在“用户名”和“密码”文本框中，输入 ColdFusion 应用程序服务器的用户名和密码。

    4. 访问 ColdFusion 中的数据源时可能需要用户名和密码。如果您没有访问 ColdFusion 中的数据源所需的用户名和密码，请与单位的 ColdFusion 管理员联系。

  4. 在“表格”弹出式菜单中，选取为记录集提供数据的数据库表格。

    5. “表格”弹出式菜单显示指定数据库中的所有表格。

  5. 若要在记录集中包括表格列的子集，请单击“已选定”，然后按住 Control 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。
  6. 通过创建过滤器可以进一步限制从表格中返回的记录：
    • 在第一个弹出式菜单中，选取数据库表格中的列，以将其与定义的测试值进行比较。
    • 在第二个弹出式菜单中选取一个条件表达式，以便将每个记录中的选定值与测试值进行比较。
    • 在第三个弹出式菜单中选取“输入的值”。
    • 在文本框中输入测试值。

      • 如果记录中的指定值符合筛选条件，则将该记录包括在记录集中。

  7. 如果要对记录进行排序，请选取要作为排序依据的列，然后指定是按升序（1、2、3... 或 A、B、C...）还是按降序对记录进行排序。
  8. 单击“测试”连接到数据库并创建数据源实例。

    9. 出现显示返回数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”关闭测试记录集。

  9. 单击“确定”。

    10. 新定义的 ColdFusion 记录集即会出现在“绑定”面板中。

相关主题

ColdFusion 开发人员的数据库连接

不通过编写 SQL 来创建记录集

通过编写 SQL 来创建高级记录集

数据库初学者指南


设置“简单数据集”对话框选项：ASP.NET

使用此对话框可以将数据集（在其它动态文档类型中通常称作“记录集”）定义为动态内容源，而无须手动编写 SQL 语句代码。

过程
  1. 在“名称”文本框中，输入数据集的名称。

    2. 通常的做法是在数据集名称前添加前缀 ds，以将其与代码中的其它对象名称区分开。例如：dsPressReleases

    注意数据集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出式菜单中选取一个连接。

    3. 如果列表中未出现连接，请单击“定义”创建连接。

  3. 在“表格”弹出式菜单中，选取为数据集提供数据的数据库表格。

    4. 弹出式菜单显示指定数据库中的所有表格。

  4. 若要在数据集中包含表格列的子集，请单击“已选定”，然后按住 Control 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 列表中的列，以选择所需列。
  5. 若要只包括某些表格记录，请按照下列步骤完成“过滤器”部分：
    • 在第一个弹出式菜单中，选取数据库表格中的列，以将其与定义的测试值进行比较。
    • 在第二个弹出式菜单中选取一个条件表达式，以便将每个记录中的选定值与测试值进行比较。
    • 在第三个弹出式菜单中选取“输入的值”。
    • 在文本框中输入测试值。

      • 如果记录中的指定值符合筛选条件，则将该记录包括在数据集中。

  6. 如果要对记录进行排序，请选取要作为排序依据的列，然后指定是按升序（1、2、3... 或 A、B、C...）还是按降序对记录进行排序。
  7. 如果由于某种原因而导致数据集查询失败，则可以指定一个页面，以将用户重定向至该页面。例如，如果在查询过程中数据库变得不可用并且未能返回页面的数据集，则可以显示一个含有到站点主页的链接的错误信息页面。
  8. 单击“测试”连接到数据库并创建数据源实例。

    9. 出现显示返回数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”关闭数据集。

  9. 单击“确定”。

    10. 新定义的数据集即会出现在“绑定”面板中。

相关主题

ASP.NET 开发人员的数据库连接

不通过编写 SQL 来创建记录集

通过编写 SQL 来创建高级记录集

数据库初学者指南


设置“高级记录集”对话框

使用此对话框可以将记录集定义为动态内容源，方法是编写自定义的 SQL 语句，或使用图形化的“数据库项”树创建 SQL 语句。

过程
  1. 在“名称”文本框中，输入记录集的名称。

    2. 通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其它对象名称区分开。例如：rsPressRelease

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出式菜单中选取一个连接。
  3. 在 SQL 文本区域中输入一个 SQL 语句，或使用对话框底部的图形化“数据库项”树从所选的数据集生成一个 SQL 语句。

    4. 有关编写 SQL 语句的更多信息，请参见SQL 入门和使用“数据库项”树创建 SQL 查询。

如果想要使用“数据库项”树生成 SQL 语句，请执行下列操作：

  • 确保 SQL 文本区域为空。
  • 展开树的分支直到找到所需的数据库对象，例如表格中的列或数据库中的预存过程。
  • 选取该数据库对象并单击树右侧的按钮之一。

    • 例如，如果选取表格列，则可用的按钮是“SELECT”、“WHERE”和“ORDER BY”。单击这些按钮之一将关联的子句添加到 SQL 语句中。

您还可以使用在预存过程中预定义的 SQL 语句，方法是从“数据库项”树中选取该预存过程并单击“过程”按钮。Dreamweaver 自动填充“SQL”和“变量”区域。

  1. 如果 SQL 语句包含变量，请在“变量”区域中定义它们的值，方法是单击加号 (+) 按钮并输入变量名称、默认值（如果未返回运行时值，则变量应取该值）和运行时值。

    2. 如果 SQL 语句包含变量，请确保“变量”框的“默认值”列包含有效的测试值。

    运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。有关 URL 和表单参数的更多信息，请参见存储和检索页面数据。

    “运行时值”列中的 URL 参数。

    服务器模型 | URL 参数的运行时值表达式
ASP | Request.QueryString(“formFieldName”)
JSP | request.getParameter("formFieldName")
PHP | #formFieldName#

    “运行时值”列中的表单参数：

    服务器模型 | 表单参数的运行时值表达式
ASP | Request.Form(“formFieldName”)
JSP | request.getParameter("formFieldName")
PHP | #formFieldName#

  2. 单击“测试”连接到数据库并创建一个记录集实例。

    3. 如果 SQL 语句包含变量，则在单击“测试”前，请确保“变量”框的“默认值”列包含有效的测试值。

    如果成功，将出现一个显示记录集中数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”清除该记录集。

  3. 如果对所做的工作感到满意，请单击“确定”。

相关主题

ASP 开发人员的数据库连接

用于 JSP 开发人员的数据库连接

适用于 PHP 开发人员的数据库连接

通过编写 SQL 来创建高级记录集

使用“数据库项”树创建 SQL 查询

使用预存过程修改数据库

数据库初学者指南

SQL 入门


设置“高级记录集”对话框：ASP.NET

使用此对话框可以将数据集定义为动态内容源，方法是编写自定义的 SQL 语句，或使用“数据库项”树创建 SQL 语句。

过程
  1. 在“名称”文本框中，输入数据集的名称。

    2. 通常的做法是在数据集名称前添加前缀 ds，以将其与代码中的其它对象名称区分开。例如：dsPressRelease

    注意数据集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“连接”弹出式菜单中选取一个连接。
  3. 在 SQL 文本区域中输入一个 SQL 语句，或使用对话框底部的“数据库项”树从所选的数据库表格生成 SQL 语句。

    4. 有关编写用于 ASP.NET 的 SQL 语句的更多信息，请参见：

    • 编写用于 ASP.NET 的 SQL
    • 使用“数据库项”树创建 SQL 查询
    • SQL 入门

如果想要使用“数据库项”树生成 SQL 语句，请执行下列操作：

  • 确保 SQL 文本区域为空。
  • 展开树的分支直到找到所需的数据库对象，例如表格中的列或数据库中的预存过程。
  • 选取该数据库对象并单击树右侧的按钮之一。

    • 例如，如果选取表格列，则可用的按钮是“SELECT”、“WHERE”和“ORDER BY”。单击这些按钮之一将关联的子句添加到 SQL 语句中。

    您还可以使用在预存过程中预定义的 SQL 语句，方法是从“数据库项”树中选取该预存过程并单击“过程”按钮。Dreamweaver 将自动填充“SQL”和“参数”区域。

  1. 如果由于某种原因而导致数据集查询失败，则可以指定一个页面，以将用户重定向至该页面。例如，如果在查询过程中数据库变得不可用并且未能返回页面的数据集，则可以显示一个含有到站点主页的链接的错误信息页面。
  2. 如果 SQL 语句包含参数，请在“参数”区域中定义它们的值，方法是单击加号 (+) 按钮并输入参数名称和默认值（如果未返回运行时值，则参数应取该值）。

    3. 如果 SQL 语句包含参数，请确保“参数”框的“默认值”列包含有效的测试值。

    使用“页面参数”可以为您编写的 SQL 中的运行时值引用提供默认值。例如，下面的 SQL 语句将基于雇员的 ID 值选取一个雇员记录。您可以将默认值分配给此参数，确保总是返回运行时值。在本例中，FormFieldName 指的是用户可以在其中输入他们的雇员 ID 的表单域：

    “SELECT * FROM Employees WHERE EmpID = “ + (Request.Form(“FormFieldName”))

    “添加页面参数”对话框应包含一个与下面类似的名称/值对：

    名称 | 默认值
FormFieldName | 0001

    运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。有关 URL 和表单参数的更多信息，请参见存储和检索页面数据。

  3. 单击“测试”连接到数据库并创建一个记录集实例。

    4. 如果 SQL 语句包含运行时引用，则在单击“测试”前，请确保“页面参数”域的“默认值”列包含有效的测试值。

    如果成功，则出现一个显示数据集中数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”清除该数据集。

  4. 如果对所做的工作感到满意，请单击“确定”。

相关主题

ASP.NET 开发人员的数据库连接

通过编写 SQL 来创建高级记录集

编写用于 ASP.NET 的 SQL

使用“数据库项”树创建 SQL 查询

使用预存过程修改数据库

数据库初学者指南

SQL 入门


设置“高级记录集”对话框选项：ColdFusion

使用“高级记录集”对话框可以编写自定义的 SQL 查询，也可以在使用指点界面的同时使用“数据库项”树创作 SQL 查询。

备注： 如果创建的是用于 ColdFusion 5 或更早版本的高级记录集，则使用其他文档类型（如 ASP 和 JSP）通用的普通“高级记录集”对话框。

过程
  1. 在“名称”文本框中，输入记录集的名称。

    2. 通常的做法是在记录集名称前添加前缀 rs，以将其与代码中的其它对象名称区分开。例如：rsPressReleases

    注意记录集名称只能包含字母、数字和下划线字符 (_)。不能使用特殊字符或空格。

  2. 从“数据源”弹出式菜单中选取数据源。

    3. 如果该弹出式菜单列表中未出现数据源，则需要首先创建 ColdFusion 数据源。有关更多信息，请参见ColdFusion 开发人员的数据库连接。

  3. 如果需要，在“用户名”和“密码”文本框中，输入 ColdFusion 应用程序服务器的用户名和密码。

    4. 访问 ColdFusion 中的数据源时可能需要用户名和密码。如果您没有访问 ColdFusion 中的数据源所需的用户名和密码，请与单位的 ColdFusion 管理员联系。

  4. 在 SQL 文本区域中输入一个 SQL 语句，或使用该对话框底部的图形化“数据库项”树从所选的记录集生成一个 SQL 语句。

    5. 有关更多信息，请参见SQL 入门和使用“数据库项”树创建 SQL 查询

如果想要使用“数据库项”树生成 SQL 语句，请执行下列操作：

  • 确保 SQL 文本区域为空。
  • 展开树的分支直到找到所需的数据库对象，例如表格中的列。
  • 选取该数据库对象并单击树右侧的按钮之一。

    • 例如，如果选取表格列，则可用的按钮是“SELECT”、“WHERE”和“ORDER BY”。单击这些按钮之一将关联的子句添加到 SQL 语句中。

  1. 如果 SQL 语句包含参数，请在“参数”区域中定义它们的值，方法是单击加号 (+) 按钮并输入参数名称和默认值（如果未返回运行时值，则参数应取该值)。

    2. 如果 SQL 语句包含参数，请确保“参数”框的“默认值”列包含有效的测试值。

    使用“页面参数”可以为您编写的 SQL 中的运行时值引用提供默认值。例如，下面的 SQL 语句将基于雇员的 ID 值选取一个雇员记录。您可以将默认值分配给此参数，确保总是返回运行时值。在本例中，FormFieldName 指的是用户可以在其中输入他们的雇员 ID 的表单域：

    SELECT * FROM Employees WHERE EmpID = + (Request.Form(#FormFieldName#))

“添加页面参数”对话框应包含一个与下面类似的名称/值对：

    名称 | 默认值
FormFieldName | 0001

运行时值通常是用户在 HTML 表单域中输入的 URL 或表单参数。有关 URL 和表单参数的更多信息，请参见检索表单和 URL 参数。
  2. 单击“测试”连接到数据库并创建一个记录集实例。

    3. 如果 SQL 语句包含运行时引用，则在单击“测试”前，请确保“页面参数”域的“默认值”列包含有效的测试值。

    如果成功，将出现一个显示记录集中数据的表格。每行包含一条记录，而每列表示该记录中的一个域。单击“确定”清除该记录集。

  3. 如果对所做的工作感到满意，请单击“确定”。

相关主题

ColdFusion 开发人员的数据库连接

通过编写 SQL 来创建高级记录集

使用“数据库项”树创建 SQL 查询

使用预存过程修改数据库

数据库初学者指南

SQL 入门


设置“请求变量”对话框选项：ASP

此对话框用于将 ASP 请求变量定义为动态内容源。

过程
  1. 从“类型”弹出式菜单中选择一个请求集合。

    2. 例如，如果您想访问 Request.ServerVariables 集合中的信息，则请选择“服务器变量”。如果想访问 Request.Form 集合中的信息，则选择“表单”。

    请求集合详述如下：

    QueryString 集合检索附加到发送页面 URL 的信息（例如，当该页面包含使用 GET 方法的 HTML 表单时）。查询字符串由一个或多个名称/值对（例如 last=Smith、first=Winston）组成，这些名称/值对使用一个问号 (?) 附加到 URL 后面。如果查询字符串包含多个名称/值对，则用 & 符号将它们合并在一起。有关更多信息，请参见了解 URL 参数。

    Form 集合检索表单信息，该信息包含在使用 POST 方法的 HTML 表单所发送的 HTTP 请求的正文中。有关更多信息，请参见了解表单参数。

    ServerVariables 集合检索预定义环境变量的值。该集合含有一个很长的变量列表，包括 CONTENT_LENGTH（HTTP 请求中所提交内容的长度，可以用它查看表单是否为空）和 HTTP_USER_AGENT（提供有关用户浏览器的信息）。

    例如，Request.ServerVariables("HTTP_USER_AGENT") 包含有关提交浏览器的信息，如 Mozilla/4.07 [en] (WinNT; I) 表示 Netscape Navigator 4.07 浏览器。

    有关 ASP 服务器环境变量的完整列表，请参见与 Microsoft Personal Web Server (PWS) 或 Internet Information Server (IIS) 一起安装的在线文档。

    Cookie 集合检索在 HTTP 请求中发送的 Cookie 的值。例如，假设页面读取用户系统上的一个名为“readMe”的 Cookie。在服务器上，该 Cookie 的值将存储在变量 Request.Cookies("readMe") 中。

    ClientCertificate 集合从浏览器发送的 HTTP 请求中检索认证域。X.509 标准中指定了认证域。

  2. 指定集合中想要访问的变量。

    3. 例如，如果想访问 Request.ServerVariables("HTTP_USER_AGENT") 变量中的信息，则输入参数 HTTP_USER_AGENT。如果想访问 Request.Form("lastname") 变量中的信息，则输入参数 lastname。

  3. 单击“确定”。

    4. 请求变量即会出现在“绑定”面板中。

相关主题

了解表单参数

定义 URL 参数

定义 ASP 服务器变量


设置“添加参数”或“编辑参数”对话框选项

使用“添加参数”对话框可以定义 SQL 语句中包含的参数，方法是输入参数的名称和默认值（如果未返回运行时值，则参数应取该值）。

过程
  1. 从“名称”弹出式菜单中选择一个参数名称。
  2. 在“默认参数”文本框中输入一个参数值。
  3. 单击“确定”。

相关主题

设置“高级记录集”对话框选项：ColdFusion

设置“高级记录集”对话框：ASP.NET

设置 ColdFusion MX“预存过程”对话框选项

在 ColdFusion 中运行预存过程

在 ASP.NET 中运行预存过程

竚“祘”

检索表单和 URL 参数


设置“请求变量”对话框选项 (JSP)

此对话框用于将 JSP 请求变量定义为页面的动态内容源。

定义 JSP 请求变量：
  1. 输入变量名称。

    2. 请求变量通常是表单或 URL 参数。如果参数是通过 HTML 表单传递的，则变量名称就是用于获取该变量值的表单域或对象的名称。

  2. 单击“确定”。

    3. JSP 请求变量即会出现在“绑定”面板中。

相关主题

定义 URL 参数

定义阶段变量


设置“阶段变量”对话框选项

此对话框用于将阶段变量定义为页面的动态内容源。

定义阶段变量：
  1. 输入阶段变量的名称，即它在应用程序源代码中的名称。

    2. 有关更多信息，请参见将信息存储在阶段变量中

  2. 单击“确定”。

    3. 新定义的阶段变量即会出现在“绑定”面板中。

相关主题

定义阶段变量

定义服务器变量


设置“应用程序变量”对话框选项

此对话框将应用程序变量定义为页面的动态内容源。

定义应用程序变量：
  1. 在“名称”文本框中，输入应用程序变量的名称，即它在应用程序源代码中的名称。
  2. 单击“确定”。

    3. 新定义的应用程序变量即会出现在“绑定”面板中。

相关主题

定义应用程序变量

定义服务器变量


设置“URL 变量”对话框选项：ColdFusion

此对话框用于将 ColdFusion URL 变量定义为页面的动态内容源。

定义 ColdFusion URL 变量：
  1. 在“名称”文本框中，输入 URL 变量的名称。

    2. 通常情况下，该变量名称是用于获取该变量值的 HTML 表单域或对象的名称。

  2. 单击“确定”。

    3. 新定义的 ColdFusion URL 变量即会出现在“绑定”面板中。

相关主题

使用 HTML 链接创建 URL 参数

定义 URL 参数

定义 ColdFusion 服务器变量


设置“表单变量”对话框选项：ColdFusion

此对话框用于将 ColdFusion 表单变量定义为页面的动态内容源。

定义 ColdFusion 表单变量：
  1. 在“名称”文本框中，输入表单变量的名称。

    2. 该变量名称是用于获取该变量值的 HTML 表单域或对象的名称。

  2. 单击“确定”。

    3. ColdFusion 表单变量即会出现在“绑定”面板中。

相关主题

定义 URL 参数

定义服务器变量


设置“客户端变量”对话框：ColdFusion

此对话框用于将 ColdFusion 客户端变量定义为页面的动态内容源。

定义 ColdFusion 客户端变量：
  1. 在“名称”文本框中输入变量名称。

    2. 例如，如果您想访问 Client.LastVisit ColdFusion 变量中的信息，请输入 LastVisit。

    客户端变量是在代码中创建的、用于将数据和特定客户端关联的变量。当用户在应用程序中从一个页面移动到另一个页面或从一个会话移动到另一个会话时，客户端变量将保持应用程序的状态。

    客户端变量可以是用户定义的，也可以是内置的。下表列出了内置的 ColdFusion 客户端变量：

    变量 | 描述
Client.CFID | 每个连接到服务器的客户端的递增 ID。
Client.CFTOKEN | 随机生成的用于唯一标识特定客户端的编号。
Client.URLToken | 不使用 Cookie 时，在模板之间传递的 CFID 和 CFTOKEN 的组合。
Client.LastVisit | 记录客户端所进行的最后一次访问的时间戳。
Client.HitCount | 单个客户端的页面请求数（使用 CFID 和 CFTOKEN 跟踪）。
Client.TimeCreated | 记录第一次为特定客户端创建 CFID 和 CFTOKEN 时的时间戳。

  2. 单击“确定”。

    3. 新定义的 ColdFusion 客户端变量即会出现在“绑定”面板中。

相关主题

定义 ColdFusion 服务器变量


设置“Cookie 变量”对话框选项

此对话框用于定义 ColdFusion Cookie 变量。

定义 ColdFusion Cookie 变量：
  1. 在“名称”文本框中输入 Cookie 变量的名称。

    2. Cookie 变量即会在代码中创建，并访问由浏览器传递给服务器的 Cookie 中包含的信息。

  2. 单击“确定”。

Cookie 变量即会出现在“绑定”面板中。

相关主题

定义 ColdFusion 服务器变量


设置“CGI 变量”对话框选项

此对话框用于定义 ColdFusion CGI 变量。

定义 ColdFusion CGI 变量：
  1. 在“名称”文本框中输入变量名称。

    2. 例如，如果您想访问 CGI.HTTP_REFERER 变量中的信息，请输入 HTTP_REFERER。

    下表列出了在服务器中创建的最常见的 ColdFusion CGI 变量：

    变量 | 描述
SERVER_SOFTWARE | 回复请求（以及运行网关）的信息服务器软件的名称和版本。格式：名称/版本。
SERVER_NAME | 服务器的主机名、DNS 别名或出现在自引用的 URL 中的 IP 地址。
GATEWAY_INTERFACE | 该服务器遵守的 CGI 规范的修订版。格式：CGI/修订版。
SERVER_PROTOCOL | 此请求附带的信息协议的名称和修订版。格式：协议/修订版。
SERVER_PORT | 该请求发送到的端口号。
REQUEST_METHOD | 发送该请求时使用的方法。对于 HTTP，即为 Get、Head、Post 等。
PATH_INFO | 客户端提供的额外路径信息。可以通过后跟额外信息的虚拟路径名访问脚本。额外信息作为 PATH_INFO 发送。
PATH_TRANSLATED | 服务器提供 PATH_INFO 的转换版本，它采用该路径并对其执行任何虚拟-物理映射。
SCRIPT_NAME | 所执行脚本的虚拟路径；用于自引用的 URL。
QUERY_STRING | 引用此脚本的 URL 中问号 (?) 后面的查询信息。
REMOTE_HOST | 发送请求的主机名。如果服务器没有该项信息，它将设置 REMOTE_ADDR，但不设置 REMOTE_HOST。
REMOTE_ADDR | 发送请求的远程主机的 IP 地址。
AUTH_TYPE | 如果服务器支持用户身份验证，并且脚本是受保护的，则此变量是用于验证用户的、协议特定的身份验证方法。
REMOTE_USER AUTH_USER | 如果服务器支持用户身份验证，并且脚本是受保护的，则此变量为已验证有效的用户名。（也可用作 AUTH_USER。）
REMOTE_IDENT | 如果 HTTP 服务器支持 RFC 931 标识，此变量将设置为从服务器检索到的远程用户名。此变量仅用于日志记录。
CONTENT_TYPE | 对于含有附加信息的查询（如 HTTP POST 和 PUT），此变量为数据的内容类型。
CONTENT_LENGTH | 客户端提供的内容的长度。

    下表列出了由浏览器创建并传递给服务器的最常见的 CGI 变量：

    变量 | 描述
HTTP_REFERER | 引用文档。它指的是链接到或提交表单数据的文档。
HTTP_USER_AGENT | 客户端当前用于发送请求的浏览器。格式：软件/版本 库/版本。
HTTP_IF_MODIFIED_SINCE | 最后一次修改页面的时间。浏览器负责发送此变量，通常是响应已发送 LAST_MODIFIED HTTP 标题的服务器。此变量可用于利用浏览器端的缓存。

  2. 单击“确定”。

    3. CGI 变量即会出现在“绑定”面板中。

相关主题

定义 ColdFusion 服务器变量


设置“服务器变量”对话框选项

此对话框用于定义 ColdFusion 服务器变量。

定义 ColdFusion 服务器变量：
  1. 在“名称”文本框中输入服务器变量的名称。

    2. 例如，如果您想访问 Server.Trademark 变量中存储的信息，请输入 Trademark 作为变量名称。

    所有访问该服务器的客户端以及运行在该服务器上的任何应用程序都可以访问服务器变量。这些变量将一直持续到服务器停止工作。它们是用 ColdFusion CFSET 或 CFPARAM 标记创建的（借助于 CFLOCK）。

    服务器变量可以是用户定义的，也可以是内置的。下表列出了内置的 ColdFusion 服务器变量：

    变量 | 描述
Server.ColdFusion.ProductName | ColdFusion 产品名。
Server.ColdFusion.ProductVersion | ColdFusion 版本号。
Server.ColdFusion.ProductLevel | ColdFusion 版本（企业版、专业版）
Server.ColdFusion.SerialNumber | 当前安装的 ColdFusion 版本的序列号
Server.OS.Name | 服务器上运行的操作系统的名称（Windows NT、Windows 2000、Linux）
Server.OS.AdditionalInformation | 有关已安装的操作系统的附加信息（服务包、更新）
Server.OS.Version | 已安装的操作系统的版本。
Server.OS.BuildNumber | 已安装的操作系统的版本号。

  2. 单击“确定”。

    3. ColdFusion 服务器变量即会出现在“绑定”面板中。

相关主题

定义 ColdFusion 服务器变量


设置“本地变量”对话框选项

此对话框用于定义 ColdFusion 本地变量。

定义 ColdFusion 本地变量：
  1. 在“名称”文本框中输入本地变量的名称。

    2. 本地变量是用 ColdFusion 页面中的 CFSET 或 CFPARAM 标记创建的。

  2. 单击“确定”。

    3. 该本地变量即会出现在“绑定”面板中。

相关主题

定义 ColdFusion 服务器变量


设置“JavaBean”对话框选项

此对话框用于将 JavaBean 定义为页面的动态内容源。

定义 JavaBean：
  1. 输入 JavaBean 的名称。
  2. 选择 JavaBean 的范围。
  3. 选择 JavaBean 的类。

    4. 若要列出 .zip 或 .jar 文件中的类，请单击“浏览”并选取该文件。

    类以下面的格式表示：

    packagename.classname
  4. 如果您想为某个 JavaBean 属性提供默认值，请从列表中选取该属性并在列表下面的“默认值”框中输入一个值。

    5. 您还可以单击“默认值”框旁边的闪电图标，将属性的默认值设置为动态值。

  5. 单击“确定”。

    6. JavaBean 即会出现在“绑定”面板中。

相关主题

定义 JavaBeans（仅限于 JSP）


设置“JavaBean 集合”对话框选项

此对话框用于将 JavaBean 集合定义为页面的动态内容源。

定义 JavaBean 集合：
  1. 从“集合类”弹出式菜单中选择集合的类。

    2. 类以下面的格式表示：

    packagename.classname

若要列出 .zip 或 .jar 文件中的类，请单击“浏览”并选取该文件。
  2. 从“索引属性”弹出式菜单中选择集合的一个索引属性。
  3. Dreamweaver 在“项类”文本框中显示默认名称。如果列出的名称不正确，请输入正确的名称。
  4. 从“范围”弹出式菜单中选择 Bean 的范围。
  5. 单击“确定”。

    6. 新定义的内容源即会出现在“绑定”面板中。

相关主题

定义 JavaBeans（仅限于 JSP）

上一页


向 Web 页中添加动态内容

定义一个或多个动态内容源后，可以使用这些源向网页中添加动态内容。内容源可以包括记录集中的列、HTML 表单提交的值、服务器对象中包含的值或其它数据。有关更多信息，请参见定义动态内容源。

在 Macromedia Dreamweaver MX 中，几乎可以将动态内容放在 Web 页或其 HTML 源代码的任何地方：

  • 可以将动态内容放在插入点处。
  • 可以用动态内容替换文本字符串。
  • 可以将其插入到 HTML 属性中。

    • 例如，动态内容可以定义图像的 src 属性或表单域的 value 属性。

本章包含以下几节：

  • 将文本动态化
  • 将图像动态化
  • 将 HTML 属性动态化
  • 将 ActiveX、Flash 和其它对象参数动态化
  • 更改动态内容
下一页


关于添加动态内容

通过在“绑定”面板中选择一种内容源来向页面中添加动态内容。Dreamweaver 在页面的源代码中插入一个服务器端脚本，以指示服务器在浏览器请求该页面时，将内容源中的数据传输到页面的 HTML 源代码中。

通常有多种将给定的页面元素动态化的方法。例如，若要将图像动态化，可以使用“绑定”面板、属性检查器或“插入”菜单中的“图像”命令。本章描述了将各种页面元素动态化的最有效的方法。

默认情况下，一个 HTML 页面一次只能显示一条记录。若要显示记录集中的其它记录，可以添加一个链接以便逐条显示记录（请参见创建记录集导航链接），也可以创建重复区域以便在单个页面上显示多条记录（请参见显示多个行为）。


将文本动态化

可以用动态文本替换现有文本，也可以将动态文本放置在页面的某个给定插入点处。

动态文本采用应用于现有文本或插入点的任何文本格式。例如，如果层叠样式表 (CSS) 样式影响所选的文本，则替换该文本的动态内容也将受到这种样式的影响。可以使用任何一种 Dreamweaver 文本格式设置工具添加或更改动态内容的文本格式。将印刷和页面布局元素应用于动态数据。

还可以将数据格式应用于动态文本。例如，如果数据中含有日期，则可以指定一种特定的日期格式，如适用于美国访问者的 04/17/00 或适用于加拿大访问者的 17/04/00。 将格式应用于数据.

可以用动态文本替换页面上的常规文本，也可以在页面上的插入点处添加动态文本。

添加动态文本：
  1. 通过选择“窗口”>“绑定”打开“绑定”面板。
  2. 请确保“绑定”面板列出了您要使用的内容源。

    3. 内容源应包含纯文本（ASCII 文本）。纯文本包括 HTML。如果列表中没有内容源，或者可用的内容源不能满足您的需要，请单击加号 (+) 按钮以定义新的内容源。请参见定义动态内容源。

  3. 在“设计”视图中，选择页面上的文本，或者单击您要添加动态文本的位置。
  4. 在“绑定”面板上，从列表中选择一种内容源。如果选择记录集，请在记录集中指定所需的列。
    这是所描述的功能的图片。
  5. 单击“插入”，或将内容源拖到页面上。

如果您现在使用的是“设计”视图并且启用了“动态数据”（“查看”>“动态数据”)，则动态内容将出现在页面上。

如果禁用了“动态数据”，则会出现一个占位符。（如果选择了页面上的文本，则占位符会替换所选文本）。表示记录集内容的占位符使用下面的语法：{RecordsetName.ColumnName}，其中 Recordset 是记录集的名称，而 ColumnName 是从该记录集中选择的列的名称。

有时，表示动态文本的占位符的长度会破坏文档窗口中的页面布局。可通过使用空的大括号作为占位符来解决这个问题。

创建动态文本占位符：
  1. 选择“编辑”>“参数选择”>“不可见元素”或“Dreamweaver”>“参数选择”>“不可见元素”(Mac OS X)。
  2. 在“显示动态文本于”弹出式菜单中选择 { }。
  3. 单击“确定”。


将图像动态化

可以将页面上的图像动态化。例如，假设您要设计一个页面，上面显示将要在慈善拍卖会上拍卖的物品。每个页面都将包含描述性文本和一件物品的一张照片。虽然每件物品的页面总体布局都一样，但照片（和描述性文本）会有所不同。

将图像动态化：
  1. 在设计视图中打开页面（“查看”>“设计”），将插入点放置在页面上您希望图像出现的位置，然后选择“插入”>“图像”。

    2. “选择图像源”对话框出现。
    这是所描述的功能的图片。

    在 Macintosh 中，对话框会有所不同：
    这是所描述的功能的图片。

  2. 单击“数据源”选项 (Windows) 或“数据源”按钮 (Macintosh)。

    3. 出现内容源列表。

  3. 从该列表中选择一种内容源。

    4. 内容源应是一个包含图像文件路径的记录集。根据站点的文件结构的不同，这些路径可以是绝对路径、文档相对路径或根目录相对路径。

    备注： Dreamweaver MX 目前还不支持存储在数据库中的二进制图像。

    如果列表中没有记录集，或者可用的记录集不能满足您的需要，请定义新的记录集。有关说明，请参见定义记录集。

  4. 单击“确定”。


将 HTML 属性动态化

通过将 HTML 属性绑定到数据可以动态地更改页面的外观。例如，通过将表格的 background 属性绑定到记录集中的域，可以更改表格的背景图像。

可以使用“绑定”面板或属性检查器绑定 HTML 属性。以上两种方法描述如下。

使用“绑定”面板将 HTML 属性动态化：
  1. 通过选择“窗口”>“绑定”打开“绑定”面板。
  2. 确保“绑定”面板列出了您要使用的数据源。

    3. 内容源应包含与您要绑定的 HTML 属性相适合的数据。如果列表中没有出现任何内容源，或者可用的内容源不能满足您的需要，请单击加号 (+) 按钮以定义新的数据源。有关说明，请参见定义动态内容源。

  3. 在“设计”视图中选择 HTML 对象。

    4. 例如，若要选择 HTML 表格，请在表格内单击一下，然后在位于文档窗口左下方的标签选择器内单击 <table> 标签。

  4. 在“绑定”面板中，从列表中选择一种内容源。
  5. 在“绑定到”框中，从弹出式菜单中选择一种 HTML 属性。
  6. 单击“绑定”。

当该页面下次在应用程序服务器中运行时，数据源的值将会赋给该 HTML 属性。

使用属性检查器将 HTML 属性动态化：
  1. 在“设计”视图中选择一个 HTML 对象，然后打开属性检查器（“窗口”>“属性”）。

    2. 例如，若要选择 HTML 表格，请在表格内单击一下，然后在位于文档窗口左下方的标签选择器内单击 <table> 标签。

  2. 在属性检查器的“标准”视图中，如果您要绑定的属性旁边有一个文件夹图标，请单击该文件夹图标以打开一个文件选择对话框，然后单击“数据源”选项以显示数据源列表。跳至第 6 步。
  3. 在“标准”视图中，如果您要绑定的属性旁边没有文件夹图标，请单击检查器左侧的“列表”标签（两个标签中位置较低的那个）。

    4. 属性检查器的“列表”视图随即出现。
    这是所描述的功能的图片。

  4. 如果“列表”视图中未列出您要绑定的属性，请单击加号 (+) 按钮，然后输入属性的名称，或者单击小箭头按钮，然后从弹出式菜单中选择该属性。
  5. 若要将属性值动态化，请单击该属性，然后单击位于该属性行末端的闪电图标或文件夹图标。如果单击了闪电图标，则将会出现一个数据源列表。

    6. 下面是一个范例：
    这是所描述的功能的图片。

    如果单击了文件夹图标，则将会出现一个文件选择对话框。单击“数据源”选项以显示内容源列表。

  6. 从内容源列表中选择一种内容源。

    7. 该内容源应包含与您要绑定的 HTML 属性相适合的数据。如果列表中没有出现任何内容源，或者可用的内容源不能满足您的需要，请定义新的数据源。有关说明，请参见存储和检索页面数据。

  7. 单击“确定”。

当该页面下次在应用程序服务器中运行时，数据源的值将会赋给该 HTML 属性。


将 ActiveX、Flash 和其它对象参数动态化

可以将 Java applets 和插件的参数动态化，也可以将 ActiveX、Flash、Shockwave、Director 和生成器对象的参数动态化。

开始之前，请确保记录集中的域包含与您要绑定的对象参数相适合的数据。

将对象参数动态化：
  1. 在“设计”视图中，选择页面上的一个对象，然后打开属性检查器（“窗口”>“属性”）。下面是一个 Flash 对象的属性检查器：
    这是所描述的功能的图片。
  2. 单击“参数”按钮。

    3. “参数”对话框随即出现。
    这是所描述的功能的图片。

  3. 如果列表中没有出现您需要的参数，请单击加号 (+) 按钮然后在“参数”列中输入参数名称。
  4. 单击参数的“值”列，然后单击闪电图标以指定一个动态值。

    5. 将出现数据源列表。

  5. 从该列表中选择一种数据源。

    6. 该数据源应包含与您要绑定的对象参数相适合的数据。如果列表中没有出现任何数据源，或者可用的数据源不能满足您的需要，请定义新的数据源。有关说明，请参见定义动态内容源。

  6. 单击“确定”。


更改动态内容

通过对提供内容的服务器行为进行编辑，可以更改页面上的动态内容。例如，您可以编辑记录集服务器行为，以便向页面提供更多的记录。

“服务器行为”面板中列出了页面上的动态内容。例如，如果向页面中添加了一个记录集，“服务器行为”面板将以如下方式将其列出：

记录集(myRecordset)

如果您向页面中添加其它记录集，则“服务器行为”面板将以如下方式列出这两个记录集：

记录集(mySecondRecordset)
记录集(myRecordset)

若要编辑提供动态内容的服务器行为，请在“服务器行为”面板中双击该服务器行为。用于定义原始数据源的那个对话框就会出现。在该对话框中进行更改，然后单击“确定”。

还可以使用属性检查器编辑页面上的记录集。打开属性检查器（“窗口”>“属性”），然后在“服务器行为”面板（“窗口”>“服务器行为”）中选择该记录集。下面是记录集的属性检查器：

如果在“动态数据”窗口内编辑记录集时未选定“自动刷新”选项，则必须刷新页面才能看到所做的更改。若要刷新页面，请单击“刷新”按钮或选择“查看”>“刷新活动数据”。


删除动态内容

向页面添加动态内容后，可以通过在页面上选择该动态内容然后按 Delete 键来删除它。还可以通过在“服务器行为”面板中选择该动态内容，然后单击减号 (-) 按钮来删除它。

备注： 此操作将删除页面中的从数据库检索该动态内容的服务器端脚本。它并不删除数据库中的数据。


设置“动态文本”对话框选项

此对话框用于添加动态内容或将现有文本动态化。

设置“动态文本”对话框选项：
  1. 从数据源列表中选择一种数据源。

    2. 数据源应包含文本信息。如果列表中没有出现任何数据源，或者可用的数据源不能满足您的需要，请单击加号 (+) 按钮以定义新的数据源。有关说明，请参见显示数据库记录。

  2. 如果需要，请为该文本选择一种数据格式。

    3. 有关更多信息，请参见将格式应用于数据。

  3. 如果需要，请修改 Dreamweaver 插入到页面中的代码以显示动态文本。
  4. 单击“确定”。

相关主题

将文本动态化

定义记录集


设置“动态数据”对话框选项

此对话框用于将 HTML 属性动态化。

将 HTML 属性动态化：
  1. 从数据源列表中选择一种数据源。

    2. 该数据源应包含与您要绑定的 HTML 属性相适合的数据。如果列表中没有出现任何数据源，或者可用的数据源不能满足您的需要，请定义新的数据源。有关说明，请参见显示数据库记录。

  2. 如果需要，请为该文本选择一种数据格式。

    3. 有关更多信息，请参见将格式应用于数据。

  3. 如果需要，请修改 Dreamweaver 插入到页面中的代码以显示动态文本。
  4. 单击“确定”。

相关主题

将 HTML 属性动态化


记录集的属性检查器

此属性检查器用于修改选定的记录集。

修改选定的记录集：

编辑所有选项。在检查器中选择了新的选项之后，Dreamweaver 会更新该页面。

可用选项因服务器模型而异。

相关主题

更改动态内容


为 ColdFusion 预存过程、ASP 命令和 JSP 可调用对象设置属性检查器

此属性检查器用于修改选定的预存过程。

修改选定的预存过程：

编辑所有选项。在检查器中选择了新的选项之后，Dreamweaver 会更新该页面。

可用选项因服务器技术而异。

相关主题

更改动态内容


为 JSP 已准备语句设置属性检查器

此属性检查器用于修改选定的 JSP 已准备语句。

修改选定的 JSP 已准备语句：

编辑所有选项。在检查器中选择了新的选项之后，Dreamweaver 会更新该页面。

相关主题

更改动态内容


为重复区域设置属性检查器

此属性检查器用于修改选定的重复区域。

修改选定的重复区域：

更改以下各项：

  • 重复区域的名称
  • 为重复区域提供记录的记录集
  • 显示的记录数

选择了新的选项之后，Dreamweaver 会更新该页面。

相关主题

更改动态内容

显示多个行为

上一页


显示数据库记录

显示数据库记录涉及检索储存在数据库或其他内容源中的信息，以及将这些信息呈现到网页上。Macromedia Dreamweaver MX 提供了许多显示动态内容的方法，并提供了若干内置的服务器行为，使您可以增强动态内容的演示，并使用户能够更轻松地查找和导航从数据库返回的信息。

Dreamweaver 提供了下列服务器行为和格式元素，使您可以增强动态内容的显示：

格式使您可以将不同类型的数字、货币、日期和时间以及百分比值应用于动态文本。

重复的区域服务器行为使您可以显示多个从数据库查询返回的项，还可指定每页显示的记录数。

记录集导航服务器行为使您可以插入导航元素，使用户能够移动到从记录集返回的下一组或前一组记录。例如，如果使用“重复的区域”服务器对象选择每页显示 10 条记录，并且记录集返回 40 条记录，则一次可以浏览 10 条记录。

记录集状态栏服务器行为使您可以包括计数器，向用户显示相对于返回的总记录数他们在记录集中的位置。

显示区域服务器行为使您可以根据当前显示的记录的相关性，选择显示或隐藏页面上的项目。例如，如果用户已导航到记录集中的最后一条记录，您可以隐藏“下一个”链接，而只显示“前一个”记录链接。

本章包含以下几节：

  • 将印刷和页面布局元素应用于动态数据
  • 将格式应用于数据
  • 创建记录集导航链接
  • 基于记录集结果显示和隐藏区域
  • 显示多个行为
  • 创建 ASP.NET 数据网格或数据列表网页控件
  • 创建记录计数器
下一页


将印刷和页面布局元素应用于动态数据

Dreamweaver 的强大功能体现在它可以在结构化页面中显示动态数据，并通过 HTML 和 CSS 应用印刷格式。若要将格式应用于 Dreamweaver 中的动态数据，请使用 Dreamweaver 的格式设置工具格式化动态数据的表格和占位符。当数据从数据源插入时，它会自动采用您指定的字体、段落和表格格式设置。

若要了解 Dreamweaver 的格式设置功能，以及如何将其应用于动态数据元素，请参见使用表格显示内容和插入文本和设置文本格式。


将格式应用于数据

Dreamweaver 附带了若干预定义的数据格式，它们可以应用于动态数据元素。数据格式的样式包括日期和时间、货币、数字以及百分比格式。

例如，如果记录集中某项的价格显示为 10.989，则选择 Dreamweaver 的“货币 - 用 2 位小数表示”格式后，该价格在页面上显示为 $10.99。这种格式使用两个小数位接受并显示数字。如果数字具有两位以上的小数位，该数据格式会将数字四舍五入到最接近的数。如果数字不带小数位，该数据格式会添加一个小数点和两个零。

将数据格式应用于动态内容：
  1. 在“活动数据”窗口中选择动态内容，或者在“文档”窗口中选择它的占位符。
  2. 选择“窗口”>“绑定”显示“绑定”面板。
  3. 单击“格式”列中的向下箭头按钮。

    4. 如果未看见向下箭头，请展开面板。

  4. 从“格式”弹出菜单中选择所需的数据格式类别。

    5. 确保选择的数据格式适合要格式化的数据类型。例如，“货币”格式仅在动态数据是由数字数据构成时才有效。注意，对于同一数据不能应用多个格式。

  5. 验证是否正确应用了格式，方法是在“活动数据”窗口或浏览器中预览页面。


自定义现有的数据格式

可以自定义 Dreamweaver 的现有数据格式，或者创建自己的数据格式。

自定义数据格式：
  1. 在“设计”视图中打开包含动态数据的页面。
  2. 选择要自定义其格式的动态数据。
  3. 选择“窗口”>“绑定”显示“绑定”面板。

    4. 动态文本被您选定的绑定数据项将高亮显示。

  4. 单击“格式”列中的向下箭头，展开可用数据格式的弹出菜单。

    5. 如果未看见向下箭头，请展开面板。

  5. 从弹出菜单中选择“编辑格式列表”。

    6. “编辑格式列表”对话框随即出现。

  6. 完成对话框并单击“确定”。

    7. 有关说明请参见完成“编辑格式列表”对话框。


创建新的数据格式

可以创建新的数据格式，以便与可能要显示的任何动态数据类型相适应。

创建新的数据格式：
  1. 在“设计”视图中打开包含动态数据的页面。
  2. 选择要为其创建自定义格式的动态数据。
  3. 选择“窗口”>“绑定”显示“绑定”面板，然后单击“格式”列中的向下箭头。

    4. 如果未看见向下箭头，请展开面板。

  4. 从弹出菜单中选择“编辑格式列表”。

    5. “编辑格式列表”对话框随即出现。

  5. 单击加号 (+) 按钮并选择一种格式类型。
  6. 定义格式，然后单击“确定”。
  7. 在“名称”列中输入新格式的名称。
  8. 单击“确定”关闭“编辑格式列表”对话框。


创建记录集导航链接

记录集导航链接使用户可以从一个记录移到下一个，或者从一组记录移到下一组。例如，在设计了每次显示五条记录的页面后，可能需要添加诸如“下一个”或“前一个”这类使用户可以显示后五条或前五条记录的链接。

Dreamweaver 允许创建四种类型的导航链接以遍历记录集：第一个、前一个、下一个和最后一个。一个页面可以包含任意数量的上述链接，只要它们都使用单一记录集。在同一页中无法添加遍历另一个记录集的链接。

备注： Microsoft ASP.NET 将记录集称作数据集。如果处理 ASP.NET 文档类型，则特定于 ASP.NET 的对话框和菜单选项都使用“数据集”标签。Dreamweaver 文档通常将这两种类型都称作记录集，但在专门描述 ASP.NET 的功能时会使用“数据集”的叫法。

记录集导航链接需要下列动态元素：

  • 要导航的记录集
  • 页面上用来显示记录的动态内容
  • 页面上用作可单击导航条的文本或图像
  • 用于导航记录集的一组“移动到记录”服务器行为

后两个元素可以通过“记录导航条”服务器对象添加，或者分别通过 Dreamweaver 设计工具和“服务器行为”面板添加。


通过“数据集导航条”服务器行为创建导航条

使用“数据集导航条”服务器行为，只需一个操作就可以创建数据集导航条。服务器对象在页面上添加以下构造块：

  • 包含文本或图像链接的 HTML 表格
  • 一组“移到”服务器行为
  • 一组“显示区域”服务器行为

“数据集导航条”的文本版本看起来像这样：

“数据集导航条”的图像版本看起来像这样：

在将导航条放到页面上之前，请确保页面包含要导航的记录集和用于显示记录的页面布局。

在将导航条放到页面上之后，可以按照自己的喜好使用 Dreamweaver 的设计工具来自定义它。还可以编辑“移到”和“显示区域”服务器行为，方法是在“服务器行为”面板中双击它们。

如果要使用 Dreamweaver 设计工具和“服务器行为”面板逐个地构建导航条，请参见创建自定义的数据集导航条。

使用服务器对象创建数据集导航条：
  1. 在“设计”视图中，将插入点放在页面上您希望显示导航条的位置。
  2. 显示“数据集导航条”对话框（“插入”>“应用程序对象”>“数据集导航条”）。

    3. 显示出“插入数据集导航条”对话框。
    这是所描述的功能的图片。

  3. 从“记录集”弹出菜单中选择要导航的记录集。
  4. 从“显示方式”部分中选择用以在页面上显示导航链接的格式。“文本”选项在页面上放置文本链接，而“图像”选项则使您可以使用图形图像作为链接。

    5. 在导航条的图像版本中，Dreamweaver 使用自己的图像文件。在将导航条放到页面上之后，您可以用自己的图像文件替换这些图像。

  5. 单击“确定”。

    6. Dreamweaver 创建包含文本或图像链接的表。单击这些链接后，用户可以遍历所选记录集。当显示记录集中的第一条记录时，会隐藏“第一个”和“前一个”链接或图像。当显示记录集中的最后一条记录时，会隐藏“下一个”和“最后一个”链接或图像。

    使用 Dreamweaver 设计工具可以自定义导航条的布局。


创建自定义的数据集导航条

如果与通过“数据集导航条”服务器对象创建的简单表格相比，您要创建的数据集导航条所使用的布局和格式化样式更复杂，您可能更愿意创建自己的导航条。为此，您必须首先以文本或图像的形式创建所需的导航链接，并将它们放在页面的设计视图中，然后为每个导航链接分配单独的服务器行为。

可以分配给导航链接的单独服务器行为有：

  • 移到第一页
  • 移到最后一页
  • 移到下一页
  • 移到前一页

如果您更喜欢使用 Dreamweaver 的内置“数据集导航条”服务器对象创建导航条，请参见第926页的“通过“数据集导航条”服务器行为创建导航条”。


导航条设计任务

创建自定义导航条时，首先要使用 Dreamweaver 的网页设计工具创建它的可视表示形式。您不必为文本字符串或图像创建链接，Dreamweaver 会为您创建一个。

为其创建导航条的页面中必须包含要导航的记录集。有关更多信息，请参见定义记录集。

简单的数据集导航条可能如下图所示，它包含用图像创建的链接按钮或其他内容元素：

在将记录集添加到页面，并且创建了导航条之后，应该将单独的服务器行为应用于每个导航元素。例如，在典型的数据集导航条中，包含下列与适当行为匹配的链接：

导航链接 | 服务器行为
转到第一页 | 移到第一页
转到前一页 | 移到前一页
转到下一页 | 移到下一页
转到最后一页 | 移到最后一页

给记录导航链接分配服务器行为：
  1. 在“设计”视图中，选择页面上您希望用作记录导航链接的文本字符串或图像。
  2. 打开“服务器行为”面板（“窗口”>“服务器行为”），然后单击加号 (+) 按钮。
  3. 从弹出菜单中选择“记录集分页”，然后从列出的服务器行为中选择适合于该链接的服务器行为。

    4. 注意，如果记录集中包含大量记录，则当用户单击“移到最后一条记录”链接时，可能要花费较长时间来运行该服务器行为。

  4. 在“记录集”弹出菜单中，选择包含记录的记录集。
  5. 单击“确定”。


基于记录集结果显示和隐藏区域

Dreamweaver 包含一组允许基于记录集返回的结果来显示或隐藏区域的服务器行为。例如，在通过“前一个”和“下一个”记录链接来导航结果页的页面中，可以指定在除第一个结果页外的所有其他页面上显示“前一个”记录链接（因为在第一个页面之前不存在结果），以及在除最后一个结果页外的所有其他页面上显示“下一个”记录链接（因为在最后一个页面之后不存在结果）。

还可以基于记录集是否为空来指定是显示区域还是隐藏区域。如果记录集为空（例如，在未找到与查询相匹配的记录时），可以显示一条消息通知用户没有记录返回。这在创建依靠用户输入的搜索词来运行查询的搜索页时尤其有用。同样，如果在连接到数据库方面有问题，或者当用户的用户名和密码与服务器识别的不匹配时，可以显示错误信息。

“显示区域”服务器行为有：

  • 如果记录集为空则显示
  • 如果记录集非空则显示
  • 如果是第一页则显示
  • 如果不是第一页则显示
  • 如果是最后一页则显示
  • 如果不是最后一页则显示
仅在需要时显示区域：
  1. 在“设计”视图中，选择页面上要显示或要隐藏的区域。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮。
  3. 从弹出菜单中选择“显示区域”，然后选择一个列出的服务器行为。
  4. 单击“确定”。


显示多个行为

“重复区域”服务器行为允许在页面中显示记录集中的多条记录。任何动态数据选择都可以转变成重复的区域。然而，最常见的区域是表格、表格行或一系列表格行。

以下示例说明了如何将“重复区域”服务器行为应用于表格行，它指定每页显示九条记录。行本身显示四种不同的记录：市/县、省/自治区、街道地址和邮政编码。

若要创建像上面这样的表格，必须创建包含动态内容的表格，并将“重复区域”服务器行为应用于包含动态内容的表格行。当应用程序服务器处理页面时，会根据“重复区域”服务器对象中指定的次数重复该行，并在每一个新行中插入不同的记录。

为其创建导航条的页面中必须包含要导航的记录集。有关更多信息，请参见定义记录集。

创建重复的区域：
  1. 在“设计”视图中，选择包含动态内容的区域。

    2. 可以选定任意内容，包括表格、表格行甚至一段文本。

    若要精确选择页面上的区域，可以使用文档窗口左边角上的标签选择器。例如，如果区域为表行，则在页面上的该行内单击，然后单击标签选择器最右侧的 <tr> 标记以选择该表行。

  2. 选择“窗口”>“服务器行为”显示“服务器行为”面板。
  3. 单击加号 (+) 按钮，并选择“重复区域”。

    4. “重复区域”对话框随即出现。
    这是所描述的功能的图片。

  4. 从弹出菜单中选择要使用的记录集的名称。
  5. 选择每页显示的记录数。
  6. 单击“确定”。

    7. 在“文档”窗口中，重复的区域周围随即出现一个选项卡式的灰色细轮廓。在“活动数据”窗口（“查看”>“活动数据”）中，灰色轮廓消失，而且选定内容扩展以显示您指定的记录数。


使用“重复区域”服务器行为创建表格

“动态表”服务器对象允许创建包含动态内容的表格，还允许从单个对话框应用“重复区域”行为。该服务器对象特别有用，因为它用记录集中的动态内容填充表格并同时应用“重复区域”服务器行为。

备注： 使用 ASP.NET 文档类型时，“动态表”服务器对象不可用。若要创建包含动态内容和重复区域的表格，必须手动插入表格，从“绑定”面板插入动态内容，并根据需要应用重复区域服务器行为。有关更多信息，请参见显示多个行为。

创建动态表：
  1. 选择“插入”>“应用程序对象”>“动态表”以显示“动态表”对话框。

    2. “动态表格”对话框随即出现。
    这是所描述的功能的图片。

  2. 从“记录集”弹出菜单中选择要使用的记录集。
  3. 选择每页显示的记录数。
  4. 此时可以输入表格边框、单元格填充和单元格间距的值。

    5. “动态表”对话框会保留您为表格边框、单元格边距和单元格间距输入的值。如果您处理的项目需要若干具有同样外观的动态表格，您可能需要输入表格布局值，因为这会进一步简化页面开发。注意，在通过属性检查器插入表格后，仍可以调整这些值。

  5. 单击“确定”。

    6. 一个表格和在相关记录集中定义的动态内容的占位符随即插入到页面中。
    这是所描述的功能的图片。

    在本例中，记录集包含四条记录：FIRSTNAME、LASTNAME、TITLE 以及 DEPARTMENT。表格的“标题”行用每条记录项的名称填充。可以使用所需的任何描述性文本对标题进行编辑，或者用具有代表性的图像替换它们。


创建记录计数器

记录计数器为用户提供了遍历一组记录时的参考信息。通常情况下，记录计数器显示返回的记录总数以及正在查看的当前记录。例如，如果记录集返回 40 条单独的记录，并且每页显示 8 条记录，则位于首页上的记录计数器将显示“Displaying records 1-8 of 40”（总共 40 条记录，当前显示 1 - 8 条）。

若要为页面创建记录计数器，必须首先创建该页的记录集、包含动态内容的适当页面布局以及数据集导航条。有关如何创建上述元素并将其添加到页面的更多信息，请参见以下各节：

  • 定义记录集
  • 创建记录集导航链接
  • 显示多个行为
  • 使用“重复区域”服务器行为创建表格

在页面中具备了上述元素了，就可以创建记录计数器了。


使用“记录集导航条”对象创建记录计数器

“记录集导航条”对象在页面上创建显示当前记录状态的文本项。

使用“记录集导航条”服务器对象：
  1. 将光标放在希望插入记录计数器的位置。
  2. 选择“插入”>“应用程序对象”>“记录集导航条”。

    3. 随即显示“插入数据集导航状态”对话框。
    这是所描述的功能的图片。

    从“记录集”弹出菜单中选择要使用的记录集。

  3. 单击“确定”。

    4. “记录集导航条”服务器对象随即插入一个类似于下图所示的文本记录计数器：
    这是所描述的功能的图片。

    可以使用 Dreamweaver 的网页设计工具来自定义记录计数器。

    在“活动数据”窗口或浏览器中查看计数器时，它的外观类似于下面这样：
    这是所描述的功能的图片。


创建自定义记录计数器

可以使用单独的记录计数行为来创建自定义记录计数器。创建自定义记录计数器使您可以创建比“记录集导航条”服务器对象所插入的简单表格（仅有一行）要复杂的记录计数器。可以通过多种巧妙方式排列设计元素，并将适当的服务器行为应用于每个元素。

您可以使用“记录集导航条”服务器对象创建简单的记录计数器。该服务器对象插入一个完整的记录计数器，通过 Dreamweaver 的网页设计工具可以对该计数器应用文本格式。有关这种记录计数器的更多信息，请参见第933页的“使用“记录集导航条”对象创建记录计数器”。

“记录计数”服务器行为有：

  • 显示开始记录号
  • 显示结束记录号
  • 显示全部记录

若要为页面创建自定义记录计数器，必须首先创建该页的记录集、包含动态内容的适当页面布局以及数据集导航条。有关如何创建上述元素并将其添加到页面的更多信息，请参见以下各节：

  • 定义记录集
  • 创建记录集导航链接
  • 显示多个行为
  • 使用“重复区域”服务器行为创建表格

在页面中具备了上述元素后，就可以创建自定义记录计数器了。

本例创建的记录计数器看起来类似于在上一节使用“记录集导航条”对象创建记录计数器中创建的计数器。本例中的记录计数器会显示为：

Displaying records StartRowthru EndRow of RecordSet.RecordCount.

本例中，用 san-serif 字体表示的文本代表将要插入到页面中的记录计数器占位符。

创建自定义记录计数器：
  1. 在“设计”视图中，在页面上键入计数器的文本。该文本可以是您选择的任何内容。
    2. Displaying records thru of .
  2. 将插入点放在文本字符串的最后。
  3. 打开“服务器行为”面板（“窗口”>“服务器行为”）。
  4. 单击左上角的加号 (+) 按钮，然后单击“显示记录计数”。在这个子菜单中，选择“显示总记录数”。“显示总记录数”行为随即插入到页面中，而且一个占位符插入到插入点所在的位置。文本字符串现在应显示为：
    5. Displaying records thru of {Recordset1.RecordCount}
  5. 将插入点放在单词 records 之后，然后从“服务器行为”>加号 (+) 按钮>“记录计数”面板中选择“显示开始记录计数号”。文本字符串现在应显示为：
    6. Displaying records {StartRow_Recordset1} thru of {Recordset1.RecordCount}.
  6. 现在将插入点放在单词 thru 和 of 之间，然后从“服务器行为”>加号 (+) 按钮>“记录计数”面板中选择“显示开始记录计数号”。文本字符串现在应显示为：
    7. Displaying records {StartRow_Recordset1} thru {EndRow_Recordset1} of
{Recordset1.RecordCount}.
  7. 确认计数器是否能正常运行，方法是在“活动数据”窗口（“查看”>“活动数据”）中查看页面，计数器看起来应类似于下面的示例：
    8. Displaying records 1 thru 8 of 40.

    如果结果页面中有移到下一组记录的导航链接，则单击该链接时，记录计数器的显示应更新为：

    Showing records 9 thru 16 of 40.

    链接在“活动数据”窗口中不起作用。若要测试链接，可以使用 Dreamweaver 的“在浏览器中预览”功能。请确保在“参数选择”（“编辑”>“参数选择”>“在浏览器中预览”或“Dreamweaver”>“参数选择”>“在浏览器中预览”(Mac OS X)）中选择了“使用活动数据服务器预览”选项，然后选择“文件”>“在浏览器中预览”。


创建 ASP.NET 数据网格或数据列表网页控件

ASP.NET 的数据网格和数据列表控件为显示不同数据类型（尤其是数据库中的动态内容）提供了大量选项，并简化了将数据源绑定到控件的过程。对于数据网格控件和数据列表控件，Dreamweaver 都支持它们作为服务器行为。这些控件提供了下列功能：

数据网格创建多列数据绑定网格。该控件允许定义各种类型的列，不仅可以编排网格的内容，还可以添加特定的功能（编辑按钮列、超链接列等等）。

数据列表通过模板显示来自数据源的项目。通过对组成控件的不同组件的模板进行操作，可以自定义控件的外观。


将数据网格添加到页面

Dreamweaver 的数据网格使您可以插入 ASP.NET 的数据网格网页控件。数据网格控件将表格呈现为多列网格，并且可以包含用于定义单元格内容布局的不同列类型（异类列），其中包括绑定、按钮和模板列等等。另外，数据网格还支持交互功能，例如列排序、列编辑和列命令等。数据网格中可用的列类型有：

数据网格列类型 | 说明
简单数据域 | “简单数据域”列在 ASP.NET 中称为“绑定列”，它使您可以指定要显示的数据源域，以及该域在用于 .NET 格式表达式时使用的数据格式。
自由格式 | “自由格式”列在 ASP.NET 中称为“模板列”，它使您可以创建 HTML 文本和服务器控件的组合，为列设计自定义布局。自由格式列中的控件可以是数据绑定控件。自由格式列在定义网格内容的布局和功能方面为您提供了更大的灵活性。原因是，您可以完全控制数据的显示方式，以及用户与网格中的行交互时所发生的事情。
超链接 | “超链接列”显示超链接形式的信息。它的典型用法是显示超链接形式的数据（如客户编号或产品名称），用户单击超链接后，可以导航到一个单独的页面，上面提供了有关该项目的详细信息。
编辑、更新、取消按钮 | “编辑、更新、取消按钮”列在 ASP.NET 中称为“编辑命令列”，它允许用户对数据网格行中的信息进行就地编辑。为此，需要创建“编辑、更新、取消”列。在运行时，该列会显示一个带“编辑”标签的按钮。当用户单击“编辑”按钮时，在文本框这类可编辑控件中会显示行数据，并且“编辑”按钮被替换为“更新”按钮和“取消”按钮。
删除按钮 | “删除按钮”使用户可以通过单击按钮删除特定的行。

有关数据网格控件以及如何使用它来格式化动态数据的更多信息，请访问下列网站：

  • Microsoft MSDN )
  • Microsoft ASP.NET )

插入“数据网格”服务器行为之前，必须为数据网格定义数据集（其他文档类型称之为“记录集”）。有关更多信息，请参见定义记录集。

将数据网格对象添加到页面：
  1. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“数据网格”。

    2. “数据网格”对话框随即出现。
    这是所描述的功能的图片。

  2. 完成“数据网格”对话框，然后单击“确定”。

    3. 有关如何完成“数据网格”对话框的说明，请参见设置 ASP.NET 的“数据网格对象”对话框。

有关更多信息，请单击对话框中的“帮助”按钮。在“文档”窗口中，数据网格的周围会出现一个选项卡式的灰色轮廓。而在“活动数据”窗口（“查看”>“活动数据”）中，灰色轮廓消失，并且对象的占位符被替换为指定的数据网格。


将数据列表添加到页面

Dreamweaver 的“数据列表”服务器行为允许在页面中插入 ASP.NET 数据列表控件。数据列表控件用于实现数据源基于表单的前端，并允许在网格中显示数据。在网格中，每条记录都呈现在不同的行上，并且可以同时显示多行。

有关数据列表控件以及如何使用它来格式化动态数据的更多信息，请访问下列网站：

  • Microsoft MSDN )
  • Microsoft ASP.NET )

插入“数据列表”服务器行为之前，必须为数据列表定义数据集（其他文档类型称之为“记录集”）。有关更多信息，请参见定义记录集。

将数据列表对象添加到页面：
  1. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“数据列表”。

    2. “数据列表”对话框随即出现。
    这是所描述的功能的图片。

  2. 完成“数据列表”对话框，然后单击“确定”。

    3. 有关如何完成“数据列表”对话框的说明，请参见设置 ASP.NET“数据列表对象”对话框选项。

在“文档”窗口中，数据列表对象的周围会出现一个选项卡式的灰色轮廓。而在“活动数据”窗口（“查看”>“活动数据”）中，灰色轮廓消失，并且对象的占位符被指定的数据列表取代。


修改数据网格或数据列表对象

有四种方法可以修改数据网格和数据列表对象：

  • 在“设计”视图中，单击数据网格或数据列表左上角的图标切换到编辑模式，然后在所显示的任何选项卡式区域中添加或修改内容

    • 备注： 还可以将动态内容源从“绑定”面板拖到选项卡式区域

  • 在“设计”视图中，选择对象，然后使用属性检查器更改其属性
  • 双击“服务器行为”面板中的对象，然后在打开的对话框中更改其属性
  • 在“代码”视图中，选择页面上的数据网格或数据列表，然后使用它的标记对话框更改其属性


参考资料

本节提供有关本章中介绍的面板、对话框和检查器的信息。


完成“插入数据集导航条”对话框

该对话框的作用是创建数据集导航条并将其添加到页面。

过程
  1. 选择要导航的记录集。
  2. 选择文本或图像链接。

    3. 在导航条的图像版本中，Dreamweaver 使用它自己的图像文件。如果愿意，您可以在将导航条放到页面上之后，用自己的图像文件替代它们。

  3. 单击“确定”。

    4. Dreamweaver 随即生成包含文本或图像链接的表，单击这些链接可以遍历选定记录集。

相关主题

通过“数据集导航条”服务器行为创建导航条

创建记录集导航链接


完成“移动到”服务器行为的对话框

这些对话框用于添加使用户可以遍历记录集记录的链接。

过程
  1. 如果没有在页面上选择任何内容，从弹出菜单中选择一个链接。
  2. 选择包含要逐页浏览的记录的记录集。

    3. 备注： 如果记录集中包含大量记录，则当用户单击“移到最后一条记录”链接时，可能要花费较长时间来运行该服务器行为。

  3. 单击“确定”。

相关主题

创建自定义的数据集导航条


完成“重复区域”对话框

该对话框的作用是创建并添加重复的区域，使您可以在页面上显示多条记录。

过程
  1. 指定包含要在重复区域中显示的数据的记录集。
  2. 指定每页显示的记录数。

    3. 如果指定的每页记录数是有限的，并且所请求的记录数可能超过此数目，则添加记录导航链接以使用户能够显示其他记录。请参见第925页的“创建记录集导航链接”。

  3. 单击“确定”。

相关主题

显示多个行为


完成“插入数据集导航状态”对话框

该对话框的作用是创建记录计数器并将其添加到页面。

过程
  1. 选择要跟踪的记录集。
  2. 单击“确定”。

Dreamweaver 随即创建记录计数器并将它添加到页面。

相关主题

使用“记录集导航条”对象创建记录计数器


完成“编辑格式列表”对话框

使用该对话框可以创建新的数据格式，或者自定义现有的数据格式。

过程
  1. 若要创建新的数据格式，请单击加号 (+) 按钮。
  2. 若要编辑现有的数据格式，请从列表中选择该格式，然后单击“编辑”。

    3. 备注： 有些数据格式没有可供自定义的参数。

  3. 完成对话框并单击“确定”。

    4. 有关说明，请参见完成“货币”、“数字”或“百分比”对话框。

  4. 如果创建新格式，请为其指定名称。
  5. 如果修改现有的格式，需要时可以更改其名称。方法是，在列表中单击它的名称，然后进行修改。
  6. 若要删除数据格式，请在列表中单击该格式，然后单击减号 (-) 按钮。
  7. 单击“确定”关闭“编辑格式列表”对话框。

相关主题

自定义现有的数据格式

创建新的数据格式


完成“货币”、“数字”或“百分比”对话框

这些对话框的作用是定义数据格式。

过程
  1. 更改下列任何参数：
    • 小数点后显示的位数
    • 是否在小数的开头部分放置前导零
    • 是否对负值使用括号或减号
    • 是否将位数分组
  2. 单击“确定”。

相关主题

完成“编辑格式列表”对话框

自定义现有的数据格式

创建新的数据格式


设置 ASP.NET 的“数据网格对象”对话框

“数据网格对象”对话框使您可以创建数据网格对象并将其添加到 ASP.NET 页面。

过程
  1. 数据网格对象的 ID 属性（或标签）。

    2. 该域中预先填充了一个值。可以更改数据网格的值。但是，如果将该域的值设置成现有的 ID 值，系统会提示您输入新的属性值。

  2. 选择与数据网格关联的数据集。

    3. 数据网格将从这个数据集中检索信息。Dreamweaver 会用所选数据集中的所有域的绑定列填写“网格列”框。

  3. 指定要显示的记录数。
  4. 选择要实现的页面导航链接类型。
    • “到前一页和下一页的链接”项添加“下一页”和“前一页”链接。
    • “到每一页的编号链接”项添加页码链接，例如“1 2 3 4 5 n...”。
  5. 删除不想要的网格列。方法是，在“网格列”框中选定它们，然后单击减号 (-) 按钮将它们删除。
  6. 可以编辑剩余的网格列。方法是，在“网格列”框中选择某列，然后设置其属性。

    7. 若要更改数据网格的列类型，请单击“编辑”按钮并从弹出菜单中选择列类型。随即出现一个特定于所选列类型的对话框。指定所选数据网格列的内容和格式。列类型有：

    数据网格列类型 | 说明
简单数据域 | “简单数据域”列在 ASP.NET 中称为“绑定列”，它使您可以指定要显示的数据源域，以及该域在用于 .NET 格式表达式时使用的数据格式。
自由格式 | “自由格式”列在 ASP.NET 中称为“模板列”，它使您可以创建 HTML 文本和服务器控件的组合，为列设计自定义布局。自由格式列中的控件可以是数据绑定控件。自由格式列在定义网格内容的布局和功能方面为您提供了更大的灵活性。原因是，您可以完全控制数据的显示方式，以及用户与网格中的行交互时所发生的事情。
超链接 | “超链接列”显示超链接形式的信息。它的典型用法是显示超链接形式的数据（如客户编号或产品名称），用户单击超链接后，可以导航到一个单独的页面，上面提供了有关该项目的详细信息。
编辑、更新、取消按钮 | “编辑、更新、取消按钮”列在 ASP.NET 中称为“编辑命令列”，它允许用户对数据网格行中的信息进行就地编辑。为此，需要创建“编辑、更新、取消”列。在运行时，该列会显示一个带“编辑”标签的按钮。当用户单击“编辑”按钮时，在文本框这类可编辑控件中会显示行数据，并且“编辑”按钮被替换为“更新”按钮和“取消”按钮。
删除按钮 | “删除按钮”使用户可以通过单击按钮删除特定的行。

  7. 对于要更改的每一列重复第 6 步。
  8. 若要更改数据网格中的列顺序，请在“网格列”框中选择某列，然后单击向上箭头或向下箭头，使该列在数据网格中左移或右移。
  9. 单击“确定”关闭对话框并创建数据网格。

相关主题

将数据网格添加到页面


设置“简单数据域”对话框选项

“简单数据域”列（在 ASP.NET 中称为绑定列）使您可以指定要显示的数据源域，以及该域在用于 .NET 格式表达式时使用的数据格式。

过程
  1. “标题”文本框使您可以在网格的标题行或脚注行中插入标题（数据网格的标题行或脚注行的显示是由数据网格属性检查器控制的）。
  2. 从“数据域”弹出菜单中选择用来填充数据网格列的数据集列。
  3. 单击“只读”复选框以指定数据网格不允许添加、更新或删除权限。
  4. 从“提交为”弹出菜单中选择数据类型。

相关主题：

将数据网格添加到页面

修改数据网格或数据列表对象

设置 ASP.NET 数据网格的属性检查器


设置“自由格式”对话框选项

“自由格式”选项（在 ASP.NET 中称为模板列）使您可以创建 HTML 文本和服务器控件的组合，为列设计自定义布局。自由格式列中的控件可以是数据绑定控件。自由格式列在定义网格内容的布局和功能方面为您提供了更大的灵活性。原因是，您可以完全控制数据的显示方式，以及用户与网格中的行交互时所发生的事情。

过程：
  1. “标题”文本框使您可以在网格的标题行或脚注行中插入标题（数据网格的标题行或脚注行的显示是由数据网格属性检查器控制的）。
  2. 从“模板”弹出菜单中选择用于自由格式数据网格的模板。
  3. 单击“添加数据域”按钮，选择用来填充网格列的数据集列。

    4. “添加数据域”对话框随即出现。在该对话框中选择数据集列并单击“确定”后，Dreamweaver 会在“内容”框中添加适当的数据绑定表达式。

  4. 对自由格式列进行格式化。方法是，在“内容”框中用 HTML 标记将绑定表达式括起来。
  5. 从“提交为”弹出菜单中选择数据类型。

相关主题

将数据网格添加到页面

修改数据网格或数据列表对象

设置 ASP.NET 数据网格的属性检查器


设置“超链接列”对话框选项

“超链接列”显示超链接形式的信息。它的典型用法是显示超链接形式的数据（如客户编号或产品名称），用户单击超链接后，可以导航到一个单独的页面，上面提供了有关该项目的详细信息。

过程
  1. 在“标题”文本框中输入列的名称。
  2. 从“超链接文本”部分，选择“静态文本”或“数据域”选项。如果选择“静态文本”，请在“静态文本”文本框中输入超链接的文本。如果选择“数据域”，请从“数据域”弹出菜单中选择提供超链接文本的数据集列。
  3. 从“链接页”部分，选择“静态 URL”或“数据域”选项。如果选择“静态 URL”，请在“静态 URL”文本框中输入目标页面的 URL（可以使用“静态 URL”文本框右侧的浏览按钮浏览到目标页面）。如果选择“数据域”，请从“数据域”弹出菜单中选择提供 URL 的数据集列。
  4. 如果使用“数据域”选项创建超链接，可以通过“格式字符串”域为超链接文本指定格式表达式。有关格式表达式的更多信息，请参考相应的 ASP.NET 文档中的数据网格 String.Format 方法。
  5. 单击“确定”。

相关主题：

将数据网格添加到页面

修改数据网格或数据列表对象

设置 ASP.NET 数据网格的属性检查器


设置“编辑、更新、取消按钮”框选项

“编辑、更新、取消按钮”列（在 ASP.NET 中称为“编辑命令列”）允许用户对数据网格行中的信息进行就地编辑。为此，需要创建“编辑、更新、取消”列。在运行时，该列会显示一个带“编辑”标签的按钮。当用户单击“编辑”按钮时，在文本框这类可编辑控件中会显示行数据，并且“编辑”按钮被替换为“更新”按钮和“取消”按钮。

过程
  1. 在“标题”文本框中输入列的名称。
  2. 从“按钮类型”弹出菜单中选择链接按钮或普通按钮。在运行时，该列会显示一个带“编辑”标签的按钮。链接按钮使用文本链接，而普通按钮则使用图像。
  3. 从“更新表格”弹出菜单中选择用户将修改其数据的数据库表。
  4. 从“主键”弹出菜单中选择与表关联的主键。
  5. 从“提交为”弹出菜单中选择数据类型。
  6. 单击“确定”。

相关主题

将数据网格添加到页面

修改数据网格或数据列表对象

设置 ASP.NET 数据网格的属性检查器


设置“删除按钮”框选项

“删除按钮”（在 ASP.NET 中也称为按钮列）允许用户通过单击按钮删除特定的行。

过程
  1. 在“标题”文本框中输入列的名称。
  2. 从“按钮类型”弹出菜单中选择链接按钮或普通按钮。在运行时，该列会显示一个带“删除”标签的按钮。链接按钮使用文本链接，而普通按钮则使用图像。
  3. 从“删除自”弹出菜单中选择用户将删除其数据的数据库表。
  4. 从“主键”弹出菜单中选择与表关联的主键。
  5. 从“提交为”弹出菜单中选择数据类型。
  6. 单击“确定”。

相关主题

将数据网格添加到页面

修改数据网格或数据列表对象

设置 ASP.NET 数据网格的属性检查器


设置 ASP.NET“数据列表对象”对话框选项

该对话框创建 ASP.NET 数据列表对象并将其添加到页面。这种对象仅适用于 ASP.NET 文档类型。

过程
  1. 如果愿意，更改数据列表的名称。

    2. Dreamweaver 为数据列表提供了默认名称。

  2. 将一个数据集与该数据列表关联。

    3. 可以选择现有的数据集或输入任意值。默认情况下选择列表中的第一个数据集。

  3. 若要组织表格中的项目，请选择“组织表格中各项”选项。

    4. 如果使用表格，请指定表格中的列数。如果列数大于一，请指定表格单元格的填充顺序：选择“自上而下换行”选项可使数据水平换行；而选择“从左到右换行”则使数据垂直换行。

  4. 执行下列操作指定要在数据列表中显示的数据：
    • 首先，为“模板”列表选择“项目”模板。“项目”模板表示列表中除标题和脚注行之外的所有行。
    • 第二步，单击“将数据域添加到内容”按钮。“添加数据域”对话框随即出现。
    • 第三步，选择数据集列并单击“确定”关闭对话框。Dreamweaver 在“数据列表对象”对话框的“内容”框中添加适当的数据绑定表达式。
    • 第四步，在“内容”框中，用 HTML 标记将绑定表达式括起来，对要显示的数据设置格式。
  5. 根据需要，调整数据列表的布局。

    6. 可以控制数据列表的布局。方法是，从“模板”列表中的模板进行选择，然后在“内容”文本框中添加 HTML 标记。可用的模板有：

    模板 | 说明
标题 | 在列表开头呈现的文本和控件。
项 | 为数据源中的每一行呈现一次的 HTML 元素和控件。
交替项 | 类似于“项目模板”元素，但在数据列表中每隔一行呈现一次。如果使用该模板，通常会为它创建不同的外观，例如与“项目模板”具有不同的背景颜色等。
编辑项 | 编辑状态下项目的布局。该模板通常包含文本框之类的编辑控件。
选择项 | 用户在数据列表中选择某项时呈现的元素。典型的用法是以可视方式用背景颜色或字体颜色标记行。您也可以通过显示数据源中的其他域来展开该项。
分隔符 | 在各项之间呈现的元素。典型的例子可能是一条线（使用 <HR> 元素）。
脚注 | 在列表最后呈现的文本和控件。

  6. 单击“确定”关闭对话框并创建数据列表。

相关主题

将数据列表添加到页面

修改数据网格或数据列表对象


设置“添加数据域”对话框选项

该对话框使您可以将数据集列与数据网格对象或数据列表对象关联。

过程

选择数据集列（“数据域”）并单击“确定”。

相关主题

设置 ASP.NET 的“数据网格对象”对话框

设置 ASP.NET“数据列表对象”对话框选项


设置 ASP.NET 数据网格的属性检查器

该属性检查器修改数据网格，使您可以更改数据网格的名称、调整单元格边距和单元格间距值以及显示列的标题或脚注。

过程

可以修改下列任何设置：

“数据网格”框使您可以更改数据网格的名称。

“高级”按钮使您可以打开“数据网格对象”对话框。

有关更多信息，请参见设置 ASP.NET 的“数据网格对象”对话框。

“单元格填充”框使您可以调整网格单元格的单元格边距。

“单元格间距”框使您可以调整网格单元格的单元格间距。

“显示列标题”选项使您可以打开或关闭标题。

“显示列脚注”选项使您可以打开或关闭脚注。

相关主题

将数据网格添加到页面


设置 ASP.NET 数据列表的属性检查器

该属性检查器使您可以修改页面上的 ASP.NET 数据列表。

过程

可以修改下列任何设置：

“数据列表”框使您可以更改数据列表的名称。

“高级”按钮使您可以打开“数据列表对象”对话框。

“显示列标题”选项打开和关闭标题。

“显示列脚注”选项打开和关闭脚注。

相关主题

将数据列表添加到页面

上一页


使用 ColdFusion 组件

ColdFusion 组件 (CFC) 使您可以将应用程序和商业逻辑封装成独立的、可重用的单元。CFC 还提供了一种创建 Web 服务的快速而简单的方法。

您可以使用 Macromedia Dreamweaver MX 创建和修改 CFC。还可以使用 Dreamweaver 生成使用 CFC 的网页。

备注： 只能在 Macromedia ColdFusion MX 中使用 CFC。ColdFusion 5 不支持 CFC。

本章包含以下几节：

  • 了解 ColdFusion 组件
  • 在 Dreamweaver 中可视地创建组件
  • 在 Dreamweaver 中查看 ColdFusion 组件
  • 在 Dreamweaver 中编辑 ColdFusion 组件
  • 生成使用 ColdFusion 组件的网页
下一页


了解 ColdFusion 组件

ColdFusion 组件是用 ColdFusion 标记语言 (CFML) 编写的可重用的软件单元。CFC 能够帮助您使代码可重用并易于维护。

本节描述 CFC 的优点。后面章节描述 Dreamweaver 如何帮助您使用 CFC。有关 CFC 标签和语法的信息，请参见 Dreamweaver 中的 ColdFusion 帮助（“帮助”>“使用 ColdFusion”）。

ColdFusion 组件旨在为开发人员提供一种简单而强大的方法来封装 Web 站点的元素。通常，您应该将组件用于应用程序或商业逻辑。对表示元素（如自定义的问候、动态菜单等）使用自定义标签。

与许多其他类型的构造相比，动态站点经常能从可互换的部分受益。例如，动态站点可以重复运行同一个查询，或者计算购物车页上的总价格，并在每次添加项目时重新计算总价格。这些任务可由组件来完成。您可以在对应用程序的其他部分影响最小的情况下修复、改进、扩展甚至替换某个组件。

假设一家网上商店根据订单价格计算运费。低于 $20 的订单运费为 $4；在 $20 至 $40 之间的订单运费为 $6，依此类推。您可以在购物车页和结帐页中同时插入计算运费的逻辑，但那样会将 HTML 表示代码和 CFML 逻辑代码混合在一起，并且通常会使代码难以维护和重用。

您决定创建一个称作 Pricing 的 ColdFusion 组件，该组件中有一个称作 ShippingCharge 的函数。该函数将价格作为参数并返回运费。例如，如果参数值为 32.80，则函数返回 6。

在购物车页和结帐页中都插入一个特殊标签以调用 ShippingCharge 函数。当请求其中任何一页时，就调用该函数并将运费返回到该页。

如果后来商店宣布了一种特殊的促销方法：$100 以上的所有订单免费送货。您只要在一个地方 - Pricing 组件的 ShippingCharge 函数 - 更改运输价格，使用该函数的所有页将自动得到精确的运费。


在 Dreamweaver 中可视地创建组件

您可以使用 Dreamweaver 可视地定义一个 ColdFusion 组件及其函数。Dreamweaver 创建 .cfc 文件并为您插入必要的 CFML 标签。

备注： 根据组件的不同，您可能需要手动完成某些代码。

可视地创建 ColdFusion 组件：
  1. 在 Dreamweaver 中打开 ColdFusion 页。
  2. 在“组件”面板（“窗口”>“组件”）中，从弹出式菜单中选择“CF 组件”。
  3. 在“组件”面板中，单击加号 (+) 按钮。

    4. 打开“创建组件”对话框。

  4. 完成该对话框并单击“确定”。

    5. 有关更多信息，请参见设置“创建组件”对话框选项。

Dreamweaver 编写一个 .cfc 文件并将其保存在您指定的文件夹中。新组件还出现在“组件”面板中（单击“刷新”后）。

若要删除一个组件，您必须手动从服务器中删除 .cfc 文件。


在 Dreamweaver 中查看 ColdFusion 组件

Dreamweaver 提供了一种方法，可以可视地检查为站点定义的 ColdFusion 组件。Dreamweaver 读取位于服务器上的 .cfc 文件并在“组件”面板中易于导航的树状视图内显示有关信息。

备注： Dreamweaver 在测试服务器中查找组件（请参见指定可在哪里处理动态页）。如果您想查看位于其他服务器中的组件，请更改测试服务器的设置。

具体而言，您可以在 Dreamweaver 中执行下列任一操作：

  • 列出为站点定义的所有 ColdFusion 组件
  • 研究每个组件的函数和参数
  • 检查用作 Web 服务的函数的属性
在 Dreamweaver 中查看 ColdFusion 组件：
  1. 在 Dreamweaver 中打开任何一个 ColdFusion 页。
  2. 在“组件”面板（“窗口”>“组件”）中，从弹出式菜单中选择“CF 组件”。
  3. 单击面板中的“刷新”按钮以检索组件。

    4. Dreamweaver 显示服务器中的组件包。一个组件包就是一个包含 CFC 文件的文件夹。

    如果现有的组件包没有出现，则单击面板工具栏中的“刷新”按钮。

  4. 单击组件包名称旁边的加号 (+) 图标以查看包中存储的组件。
  5. 若要列出某个组件的函数，请单击组件名称旁边的加号 (+) 图标。
  6. 若要查看函数采用的参数、参数类型以及它们是必需的还是可选的，请在树状视图中打开该函数的分支。

    7. 没有参数的函数旁边没有加号 (+) 图标。

  7. 若要快速查看参数、函数、组件或包的详细信息，请在树状视图中选择该项，然后单击面板工具栏中的“获取详细信息”图标。

    8. 还可以右击该项 (Windows) 或在按住 Control 键的同时单击该项 (Macintosh)，然后从弹出式菜单中选择“获取详细信息”。

    Dreamweaver 在消息框中显示有关该项的详细信息。


在 Dreamweaver 中编辑 ColdFusion 组件

Dreamweaver 提供了一种简化的方法来编辑为您的站点定义的 ColdFusion 组件的代码。例如，您无须离开 Dreamweaver 即可添加、更改或删除任何组件函数。

若要使用此功能，您的开发环境必须按如下方式进行设置：

  • ColdFusion MX 必须是在本地运行。
  • 在 Dreamweaver 的高级“站点定义”对话框中，“测试服务器”类别中指定的“访问类型”必须是“本地/网络”。
  • 在高级“站点定义”对话框中，您的本地根文件夹的路径必须与测试服务器文件夹的路径相同（例如 c:\Inetpub\wwwroot\cf_projects\myNewApp\）。您可以通过选择“站点”>“编辑站点”来检查和更改这两个路径。
  • 组件必须存储在硬盘上的本地站点文件夹或该文件夹的任何子文件夹中。

在编辑 CFC 之前，请先在 Dreamweaver 中打开任何 ColdFusion 页，并在“组件”面板中显示组件。若要显示组件，请打开“组件”面板（“窗口”>“组件”），从面板的弹出式菜单中选择“CF 组件”，并单击面板上的“刷新”按钮。

ColdFusion MX 是在本地运行的，因此 Dreamweaver 可显示硬盘中的组件包。有关更多信息，请参见在 Dreamweaver 中查看 ColdFusion 组件。

编辑组件：
  1. 通常在编辑组件文件时，需要打开包并在树状视图中双击该组件的名称。

    2. Dreamweaver 在“代码”视图中打开组件的文件。

  2. 若要编辑特定的函数、参数或属性，请在树状视图中双击该项。
  3. 在代码视图中手动进行更改。
  4. 保存文件（“文件”>“保存”）。

若要查看“组件”面板中的任何新函数，请单击面板工具栏中的“刷新”按钮来刷新视图。


生成使用 ColdFusion 组件的网页

在网页中使用组件函数的一种方法是在该页中写入该页被请求时可以调用函数的代码。您可以使用 Dreamweaver 来帮助您编写这些代码。

备注： 有关使用组件的其他方法，请参见 Dreamweaver 中的 ColdFusion 帮助（“帮助”>“使用 ColdFusion”）。

在网页中使用 ColdFusion 组件：
  1. 在 Dreamweaver 中，打开将使用组件函数的 ColdFusion 页。
  2. 切换到代码视图（“查看”>“代码”）。
  3. 打开“组件”面板（“窗口”>“组件”），然后从面板的弹出式菜单中选择“CF 组件”。
  4. 找到您需要的组件并使用下列技巧之一将其插入：
    • 将一个函数从树状视图拖动到页中。Dreamweaver 在页中插入代码以调用函数。
    • 在面板中选择该函数并单击面板工具栏中的“插入”图标（右边的第二个图标）。Dreamweaver 在页中的插入点处插入代码。
  5. 如果您插入的是带参数的函数，请手动完成参数代码。

    6. 有关更多信息，请参见 Dreamweaver 中的 ColdFusion 帮助（“帮助”>“使用 ColdFusion”）。

  6. 保存该页（“文件”>“保存”）。


参考资料

本节提供了有关本章中介绍的对话框和面板的信息。


设置“创建组件”对话框选项

该对话框的目的是创建新的 ColdFusion 组件。

有关该对话框中每个域的可能值的更多信息，请参见 Dreamweaver 中的 ColdFusion 帮助（“帮助”>“使用ColdFusion”）。

过程
  1. 在“组件”部分输入组件的详细信息。

    2. 只能使用字母、数字或带下划线的字符。

    “名称”框指定 .cfc 文件名。输入名称时不要指定 .cfc 文件扩展名。

    “组件目录”框指定将要保存该组件的位置。选择 Web 应用程序的根文件夹（如 \Inetpub\wwwroot\myapp\）或它的任何子文件夹。

  2. 如果您想为该组件定义一个或多个函数，请从“部分”列表中选择“函数”，单击加号 (+) 按钮，然后输入新函数的详细信息。

    3. 提示： 如果您从“访问”菜单中选择“远程”，则该函数可用作 Web 服务。

    请确保在“返回值类型”框中指定该函数返回的值的类型。

  3. 如果您想为函数定义一个或多个参数，请从“部分”列表中选择“参数”，从弹出式菜单中选择该函数，单击加号 (+) 按钮，然后在右边输入新参数的详细信息。
  4. 单击“确定”创建该组件。
  5. 如果使用的是远程开发服务器，请将 CFC 文件和任何相关文件（如那些用于实现函数或包含文件的文件）上传到该远程服务器。

    6. 上传文件可以确保 Dreamweaver 的功能（如“实时数据”视图和“在浏览器中预览”）正常工作。

相关主题

在 Dreamweaver 中可视地创建组件

了解 ColdFusion 组件


设置“CF 组件”面板选项

此面板的目的是查看和编辑 ColdFusion 组件。还可以使用此面板向页面添加调用某个组件的函数的代码。

备注： 只有在 Dreamweaver 中查看 ColdFusion 页时，此面板才可用。

任务
  • 在 Dreamweaver 中查看 ColdFusion 组件
  • 在 Dreamweaver 中编辑 ColdFusion 组件
  • 生成使用 ColdFusion 组件的网页

相关主题

了解 ColdFusion 组件

上一页


使用 Web 服务

Web 服务是新兴技术，它使 Web 页可以访问分布式应用程序。通过将对信息和应用程序功能的访问作为服务提供给用户，Web 服务可作为服务流提供和出售，这种服务流支持从任意平台进行范围广泛的访问。连接到 Web 服务的 Web 页通称作使用者，而服务本身称作发布者。Macromedia Dreamweaver MX 使您可以创建作为 Web 服务使用者的页面和站点。Dreamweaver 当前支持使用 ColdFusion、ASP.NET 和 Java Server Page (JSP) 文档类型创建 Web 服务使用者。具体而言，Dreamweaver 允许您执行以下 Web 服务开发任务：

  • 选择可用于 Internet 的 Web 服务
  • 生成 Web 服务代理，该代理允许 Web 页与 Web 服务发布者通信

    • 代理（也称为抽象类）包含 Web 服务的域、方法和属性，并使它们可用于本地寄存的页。当您为页面生成代理时，Dreamweaver 使您可以在“组件”面板中查看它们。

  • 将方法和数据类型拖入页面的代码中

在创建使用 Web 服务的 Web 页前，您必须熟悉要使用的应用程序的基础服务器技术以及该应用程序需要的编程结构。

Dreamweaver 允许您创作可以访问 Web 服务并利用这些服务提供的功能的 Web 页。此外，您可以使用 Macromedia ColdFusion MX 创建并发布 Web 服务以进行部署。

本章讨论以下主题：

  • 了解 Web 服务
  • 安装和配置代理生成器
  • 使用 WSDL 说明添加 Web 服务代理
  • 向页面添加 Web 服务
  • 编辑 UDDI Web 服务站点列表
下一页


了解 Web 服务

通过 Web 服务，不论应用程序使用哪种操作系统或编程语言，都可以在 Internet 上进行通信并共享信息。以下是 Web 服务及其提供的信息和功能的示例：

  • 用户身份验证和授权
  • 信用卡验证
  • 金融市场服务，能够返回与指定的股票行情收录器符号关联的股票价格
  • 允许用户联机订购和购买产品的采购服务
  • 基于所选的兴趣、位置或其他个人信息提供新闻或其他信息类型的信息服务

Web 服务将功能作为一种 Web 页根据需要连接并使用的服务提供给用户，从而使开发人员和服务提供商可以更灵活地设计并部署功能强大的分布式应用程序。


Web 服务的各部分

Web 服务由以下基本组件构成：

  • 服务发布者提供宿主应用程序并使它们可供使用。Web 服务既可以免费提供，也可以作为收费服务提供。
  • 服务经纪人负责维护服务提供商的注册表，其中包含所提供服务的说明以及指向其应用程序的链接。
  • 服务使用者是访问和使用远程 Web 服务的 Web 页。


查找 Web 服务发布者

Web 服务本身是由服务发布者提供的。通常，服务发布者通过基于 Web 的注册表（它维护您可以访问的可用服务的目录），使其 Web 服务可用。许多 Web 站点提供此类目录，这些站点包括：

  • X Methods
  • IBM Business Registry
  • Microsoft UDDI 注册表

这些注册表使用通用描述、发现和集成 (UDDI) 服务。这是一个开放的电子商务服务注册表，它为企业提供一个论坛，在这里企业可以描述他们自己以及他们向其他企业提供的商品或服务。一组称作运营商的公司维护该注册表。运营商保证在他们之间以及与此项服务的用户共享与注册者有关的所有公共信息，并且保证在 UDDI 服务网络的多个对等节点间维持互操作性。除了公共 Web 服务之外，还有通过订阅提供的专用 UDDI 注册表。

UDDI 规范基于现有的 Internet 标准，从而确保它可用于各种平台和实现。


Web 服务软件组件

为了使 Web 页可以访问和使用 Web 服务，此 Web 页必须与该服务通信，并且具有该服务提供的功能、它可以调用的方法以及服务返回的参数的说明。Web 服务描述语言 (WSDL) 是基于 XML 的服务说明。每一 Web 服务均提供 WSDL，它描述如何绑定到该服务、Web 页可以调用的方法以及数据输入和输出。WSDL 可以驻留在某一文件中，也可以在运行时由 Web 服务生成。

请求该服务的 Web 页和该 Web 服务本身之间的通信使用简单对象访问协议 (SOAP)。SOAP 是基于 XML 的协议，它使 Web 客户端可以访问并调用 Web 服务的方法和参数。


Web 服务信息和规范

若要了解有关 Web 服务以及使这些服务成为可能的基础技术的更多信息，请访问以下 Web 站点：

  • WSDL specification（WSDL 规范）
  • UDDI specification （UDDI 规范）
  • XML specification （XML 规范）
  • SOAP specification （SOAP 规范）


Dreamweaver Web 服务工作流程

若要使用 Dreamweaver 创建使用 Web 服务的页面或站点，您必须执行以下任务：

  1. 安装和配置代理生成器。

    2. 代理生成器能够生成 Web 服务代理，这是 Web 页用来与 Web 服务发布者通信的软件组件。Web 服务代理是从描述该 Web 服务的 WSDL 生成的。根据您想要开发 Web 服务使用者所采用的服务器技术，您可能需要安装和配置支持该技术的代理生成器。

    Dreamweaver 附带预配置的 AXIS，它是支持 JSP Web 服务开发的 Apache SOAP 代理生成器。如果您要开发 ColdFusion 6 页面，则 Web 服务代理生成器已包括在 ColdFusion 服务器中。通过建立与 ColdFusion 服务器的连接，您将能够访问该代理生成器。

    如果您要开发用于 ASP.NET 的 Web 服务页，则必须安装 ASP.NET SDK，它可以从 Microsoft 获得。

    有关安装和配置 Dreamweaver 未提供的代理生成器的信息，请参见安装和配置代理生成器。

  2. 使用浏览器，查看 Web 服务的基于 Web 的注册表。

    3. Web 服务的来源有若干种，从 Web 服务注册表站点到简单的列表都有。注册表使用 UDDI，这是让服务提供商和请求者能够找到彼此并进行事务处理的标准。UDDI 使企业可以在 Web 上找到满足其要求的服务。例如，使用 UDDI，您可以指定某些条件（如某一服务的最低价格）或者要返回的特定信息。

  3. 在找到并选择提供所需功能的 Web 服务后，在“添加 Web 服务”对话框中输入 WSDL 的 URL。
  4. 根据服务发布者的 WSDL 说明，为该 Web 服务生成代理。

    5. 若要将 Web 服务嵌入 Web 页中，您必须创建代理。代理向 Web 页提供与 Web 服务通信以及访问 Web 服务所提供方法的必需信息。

    若要从 WSDL 文件创建代理，请使用代理生成器。在创建代理后，您可以在以下两个位置之一安装它：

    • 在您正在其上开发 Web 服务使用者的本地计算机上。
    • 在运行应用程序服务器的服务器计算机上。若要部署 Web 页并使其与 Web 服务发布者通信，您必须在服务器上安装代理。

      • 有关更多信息，请参见安装和配置代理生成器。

  5. 使用 Dreamweaver，将 Web 服务添加到某一页上并编辑所需的参数和方法，以便于利用该服务的功能。

    6. 有关更多信息，请参见向页面添加 Web 服务。


安装和配置代理生成器

Dreamweaver 安装支持 JSP Web 服务的 AXIS 代理生成器。AXIS 是通过 Apache SOAP 项目分发的开放源代码的代理生成器。此外，您可以添加支持其他供应商的 Web 服务实现或新 Web 服务技术的代理生成器。本节介绍如何获取代理生成器并配置它们以和 Dreamweaver 一起使用。

若要了解有关 AXIS 的更多信息，请参见 Apache AXIS Web 站点。


获取附加代理生成器

如果您想要安装未随 Dreamweaver 一起提供的代理生成器，您必须从供应商处获取该代理生成器和所有相关软件组件。您应该能够从供应商的 Web 站点下载所有必需的文件。

某些代理生成器创建依赖其他软件库的代理，因此必须正确安装这些软件库以便代理生成器可以访问它们。例如，AXIS 代理生成器创建依赖 Apache SOAP 库的代理，而 Apache SOAP 库又依赖其他软件库（请注意，默认情况下，使用 AXIS 所需的所有必要软件都随 Dreamweaver 一起安装）。在选择代理生成器时，请参考提供的文档，并确保您具有所有必需的软件组件和库，以便您可以正确安装和配置它们。

在正确安装和配置代理生成器后，您必须将它配置为能与 Dreamweaver 一起使用。

备注： 当前，用 Dreamweaver 进行 Web 服务的开发被限制在 Windows 环境内。若要在 Macintosh 上开发访问 Web 服务的页面，您必须使用单独的应用程序服务器，此服务器运行在 Windows NT/2000/XP 或 UNIX 上，而 Web 服务代理及其应用程序环境将在其上运行。

若要配置代理生成器以便和 Dreamweaver 一起使用，请执行以下操作：
  1. 选择“窗口”>“组件”以打开“组件”面板。
    这是所描述的功能的图片。
  2. 在“组件”面板中，从面板左上角的弹出式菜单中选择“Web 服务”，然后单击加号 (+) 按钮并选择“使用 WSDL 添加”。

    3. 随即显示“使用 WSDL 添加”对话框。
    这是所描述的功能的图片。

  3. 在“使用 WSDL 添加”对话框中，从“代理生成器”弹出式菜单中选择“编辑代理生成器列表”。随即显示“代理生成器”对话框。
    这是所描述的功能的图片。
  4. 单击“新建”，从弹出式菜单中选择代理生成器，然后单击“完成”。

    5. 如果您想要使用的代理生成器未在列表中出现，则选择“默认代理生成器”以显示“默认代理生成器”对话框。

  5. 您可以通过“默认代理生成器”对话框配置选定的代理生成器，您也可以配置新的代理生成器。根据您选择的代理生成器的不同，对话框的文本框也将有所不同。完成对话框设置，然后单击“确定”。
    这是所描述的功能的图片。

    6. 有关完成该对话框的文本框设置的信息，请参见设置“默认代理生成器”对话框选项。

  6. 完成对“默认代理生成器”的设置后，单击“确定”。

    7. 在 Dreamweaver 读取 Web 服务的 WSDL 说明时，Dreamweaver 将执行以下与“默认代理生成器”的各域有关的操作：

    • 将 WSDL 作为输入读取以查找 Web 服务。
    • 通过指定的运行时环境生成 Web 服务代理。
    • 使用指定的编译器编译代理。
    • 将代理源代码和编译的代理输出到指定的目标文件夹中。


使用 WSDL 说明添加 Web 服务代理

在指定了代理生成器并配置了您想要支持的 Web 服务的服务器模型后，您需要查找提供所需功能的 Web 服务并为该服务生成代理。

若要选择 Web 服务并通过其 WSDL 文件生成代理，请执行以下操作：
  1. 打开您要将 Web 服务添加到的页。
  2. 选择“窗口”>“组件”以打开“组件”面板。
  3. 在“组件”面板中，从该面板左上角的弹出式菜单中选择“Web 服务”，然后单击加号 (+) 按钮并选择“使用 WSDL 添加”。

    4. 随即显示“使用 WSDL 添加”对话框。
    这是所描述的功能的图片。

  4. 指定您要使用的 WSDL 文件的 URL。

    5. 如果您知道 WSDL 文件的 URL，则在“WSDL 的 URL”文本框中输入它。

    如果您不知道 WSDL 文件的 URL，则您可以浏览 Web 服务的目录。找到所需的 Web 服务后，将该 Web 服务的 URL 拷贝并粘贴到 WSDL 编辑框中。若要启动 Web 浏览器，请单击 UDDI 浏览按钮并选择列出的 Web 服务注册表之一。Dreamweaver 将启动该浏览器并打开选定的注册表。找到您要使用的 Web 服务，将其 WSDL 文件的 URL 拷贝到剪贴板中（在 Windows 中使用 Ctrl+C 组合键，在 Macintosh 中使用 Command+C 组合键）。返回到“Web 服务选择器”并将该 URL 粘贴到对话框中。

    您可以编辑 Web 服务注册表的列表以包括附加的 Web 服务目录或特定的 Web 服务提供商。有关更多信息，请参见编辑 UDDI Web 服务站点列表。

  5. 从“代理生成器”弹出式菜单中选择支持所需 Web 服务的服务器模型的代理生成器。

    6. 确保在您的系统上安装并配置了代理生成器。有关更多信息，请参见安装和配置代理生成器。

  6. 单击“确定”。

    7. 代理生成器为 Web 服务创建代理并对其进行内部检查。内部检查是一个过程，在此过程中，代理生成器查询 Web 服务代理的内部结构并通过 Dreamweaver 使其接口、方法和属性可供使用。

该 Web 服务现在可用于此站点，并且出现在“组件”面板中。有关更多信息，请参见向页面添加 Web 服务。


向页面添加 Web 服务

在选择 Web 服务、生成其代理并将其添加到“组件”面板后，您可以将它插入页面中。下面的插图显示该“组件”面板，其中已添加了 Web 服务代理 Helloworld。Helloworld 代理提供一个方法 sayHello，该方法打印 “Hello World!”。

以下示例使用 ColdFusion 实例化 HelloWorld Web 服务。若要了解有关创建 Web 服务的更多信息，并查看使用 .NET 和 JSP 的更多示例，请访问 Macromedia Support Center。

若要向页面添加 Web 服务，请执行以下操作：
  1. 在“文档”窗口的“代码”视图中，将 sayHello 方法拖入页面的 HTML 中。

    2. Dreamweaver 将该方法和伪参数添加到页面中。

  2. 按照 Web 服务的要求，使用适当的服务实例名称、数据类型和参数值编辑插入的代码。该 Web 服务应提供数据类型和参数值的说明。

    3. 在下面所示的 ColdFusion 示例中，该 Web 服务括在 <cfinvoke> 标签里。当在 ColdFusion 中开发 Web 服务时，使用 <cfinvoke> 实例化该 Web 服务并调用其方法。

    <html>
<head>
<title>Web Service</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<cfinvoke
webservice="http://velcro-qa-7:8100/helloworld/HelloWorld.cfc?wsdl"
method="sayHello"
returnvariable="aString">
</cfinvoke>

</body>
</html>
  3. 如果您想要将返回值绑定到可视化元素，则切换到“设计”视图并将可视化元素放置到可以接受数据绑定的页面上。然后切换回“代码”视图并输入适当的代码将返回值绑定到可视化元素上。在创建 Web 服务时，请参考技术提供商的文档以了解实例化服务并向页面显示返回值所用的正确语法。

    4. 在此示例中，为变量 aString 返回的值是使用 ColdFusion <cfoutput> 标签的输出。这将向页面显示“The web service says:Hello world!”一句。

    <html>
<head>
<title>Web Service</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<cfinvoke
webservice="http://velcro-qa-7:8100/helloworld/HelloWorld.cfc?wsdl"
method="sayHello"
returnvariable="aString">
</cfinvoke>

The web service says:<cfoutput>#aString#</cfoutput>
</body>
</html>
  4. 当您将 Web 页部署到生产服务器时，Dreamweaver 自动将这些页、代理和所有必需的库拷贝到 Web 服务器中。

    5. 备注： 如果用来开发应用程序的代理所安装的计算机不是开发页面所用的计算机，或者您使用的站点管理工具没有将所有相关文件都拷贝到服务器上，则您一定要部署代理和所有相关库文件。否则，您的页面将不能与 Web 服务应用程序通信。


编辑 UDDI Web 服务站点列表

“Web 服务选择器”提供基于 UDDI 的 Web 服务目录列表，您可以从中选择 Web 服务。您可以编辑该列表以添加或删除 Web 服务目录。

若要编辑 Web 服务站点列表，请执行以下操作：
  1. 在 Dreamweaver 中，选择“窗口”>“组件”以打开“组件”面板。
  2. 在“组件”面板中，从该面板左上角的弹出式菜单中选择“Web 服务”，然后单击加号 (+) 按钮以添加 Web 服务。

    3. 随即显示“使用 WSDL 添加”对话框。

  3. 在“Web 服务选择器”中，单击地球图标并从弹出式菜单中选择“编辑 UDDI 站点列表”。

    4. 随即显示“UDDI 站点”对话框。
    这是所描述的功能的图片。

  4. 从“UDDI 站点”对话框中，您可以添加新 Web 服务站点，编辑现有站点的名称和 URL，并且删除不需要的站点。

    5. 若要删除现有站点，在列表中选择它并单击“删除”按钮。若要添加新站点或修改现有站点，请单击“新建”或“编辑”按钮并完成下面所示的对话框的设置。
    这是所描述的功能的图片。


参考资料

本节提供有关本章中介绍的面板和对话框的信息。


设置“Web 服务选择器”对话框选项

此对话框使您可以选择 Web 服务并生成支持页面访问该服务的代理。

过程
  1. 设置以下选项：

    2. WSDL 文件的 URL：输入 WSDL 文件的 URL 或本地文件路径。此信息由 Dreamweaver 作为输入读取，并且用于为 Web 服务生成代理和脚本撰写信息。

    代理生成器：选择支持您选定的文档类型的代理生成器以生成 Web 服务代理。

    “浏览器”按钮：从包含纯英文名称的 URL 的菜单中进行选择，这些 URL 指向 UDDI 注册表和 WSDL 文件的其他重要储备库。选择了一个菜单项后，浏览器将出现并打开选定的 URL。随即“选择编辑浏览器列表”打开用于编辑浏览器参数选择的对话框。

  2. 单击“确定”。

相关主题

使用 WSDL 说明添加 Web 服务代理


设置“代理生成器”对话框选项

通过此对话框，您可以定义新的代理生成器，或者修改、删除或复制现有的代理生成器。

若要定义、修改或删除代理生成器，请执行以下操作：

  1. 执行以下任何操作：
    • 若要将代理生成器添加到该列表，请单击“新建”并完成对生成的对话框的设置。

      • 有关更多信息，请参见设置“默认代理生成器”对话框选项。

    • 若要从列表中删除代理生成器，请单击“删除”。
    • 若要修改代理生成器，请在列表中选择它并单击“编辑”。在生成的对话框中进行更改。

      • 有关更多信息，请参见设置“默认代理生成器”对话框选项。

    • 若要创建代理生成器的副本，请在列表中选择该代理生成器并单击“复制”。
  2. 单击“完成”。

相关主题

安装和配置代理生成器


设置“默认代理生成器”对话框选项

通过此对话框，您可以设置默认代理生成器的属性。

若要配置默认的代理生成器，请执行以下操作：
  1. 设置下列属性：

    2. 名称 在弹出式菜单中出现的代理生成器实例的名称。

    支持的服务器模型 代理生成器支持的服务器模型的列表。可以使用加号 (+) 和减号 (-) 按钮编辑该列表。

    单击加号按钮将显示“选取服务器模型”对话框。从可用服务器模型列表中选择一个服务器模型，然后单击“确定”。

    生成代理命令 根据 WSDL 信息生成代理源代码。在代理生成器命令中可以采用以下标记：

    标记 | 说明
$$WSDLFILE | WSDL 文件的名称。
$$SITEROOT | 站点的根文件夹。
$$JAVA | 指定向 Dreamweaver 提供的 Java 运行时。
$$JAVAC | 指定向 Dreamweaver 提供的 Java 编译器。
$$CONFIGDIR | Dreamweaver 的配置目录。
$$COMPILEDIR | 指定在其中编译生成的代理类的临时目录，并用于将此临时文件夹添加到该类路径以进行编译。

    编译代理命令：将代理源代码编译成可执行代码。

    对编译的代理进行内部检查 从弹出式菜单中选择内部检查器，以便对编译的代理进行内部检查。

    目标文件夹 经过编译的 Web 服务代理及其源代码将输出到的文件夹。

  2. 单击“确定”。

相关主题

安装和配置代理生成器

使用 WSDL 说明添加 Web 服务代理


设置“选取服务器模型”对话框选项

通过“选取服务器模型”对话框，您可以选择指定代理生成器支持的服务器模型。

若要选择服务器模型，请执行以下操作：
  1. 从列表中选择一个服务器模型。在按 Ctrl 键的同时从列表中进行选择，可以选取多个服务器模型。
  2. 单击“确定”。

相关主题

安装和配置代理生成器

使用 WSDL 说明添加 Web 服务代理


设置“UDDI 站点”对话框选项

通过“UDDI 站点”对话框，您可以添加、编辑或删除 UDDI 目录，以便更加方便地浏览 Web 服务。

若要添加新站点或编辑现有站点，请执行以下操作：
  1. 单击“新建”按钮以显示“新建 UDDI 站点”对话框，或者单击“编辑”按钮以显示“编辑 UDDI 站点”对话框。
  2. 如果您知道 UDDI Web 站点的名称和 URL，请将这些信息输入提供的域中。

    3. 您还可以单击“地址”域旁的浏览器按钮（地球图标），从而启动 Web 浏览器以定位 UDDI 站点。

  3. 在您输入了 UDDI Web 站点的名称和 URL 后，单击“确定”。

    4. 新的或修改后的 UDDI 站点将出现在“UDDI 站点”对话框的站点列表中。

  4. 单击“完成”。
若要删除一个站点，请执行以下操作：
  1. 从列表中选择一个站点。
  2. 单击“删除”按钮从列表中删除选定站点。
  3. 单击“完成”。

相关主题

编辑 UDDI Web 服务站点列表


“ColdFusion 代理生成器”对话框

ColdFusion 代理生成器是不可配置的。

相关主题

安装和配置代理生成器

使用 WSDL 说明添加 Web 服务代理


设置“使用代理类添加”对话框

通过此对话框，您可在使用 .NET 开发框架时选择本地 .NET DLL 阅读器对 Web 服务代理进行内部检查。

若要选择代理类阅读器，请执行以下操作：
  1. 在文本框中输入代理类阅读器的位置。可以通过单击文本框右侧的“浏览”按钮浏览该文件。
  2. 从弹出式菜单中选择您要使用的代理阅读器。默认的代理阅读器是 .NET DLL 阅读器。
  3. 单击“确定”。

相关主题

安装和配置代理生成器

设置“默认代理生成器”对话框选项

上一页


添加自定义服务器行为

Macromedia Dreamweaver MX 提供了一组内置的服务器行为，使您能够方便地向站点添加动态功能。如果要扩展 Dreamweaver 的功能，可以创建适合开发需要的新服务器行为，也可以从 Macromedia Exchange Web 站点获取服务器行为。

本章包含下列章节：

  • 安装其他服务器行为
  • 创建服务器行为
  • 编辑和修改服务器行为代码
下一页


安装其他服务器行为

许多 Macromedia 的合作伙伴以及独立开发人员创建了自定义服务器行为，以便满足特定的 Web 开发需要。您可以从Macromedia Exchange for Dreamweaver Web 站点访问和下载这些自定义服务器行为。

利用 Macromedia Exchange Web 站点获取的服务器行为以及其他功能扩展，您能够轻松地向 Dreamweaver 添加新功能。每个服务器行为都包括简短说明、用户评论和讨论组，在其中可以张贴问题并获取对所下载服务器行为的支持。

若要访问 Macromedia Exchange：
  1. 在 Dreamweaver MX 中，选择“帮助”>“Dreamweaver Exchange”。

    2. 浏览器将打开 Macromedia Exchange for Dreamweaver 网页。

  2. 使用您的 Macromedia ID 登录该 Exchange，或者如果您尚未创建自己的 Macromedia
    Exchange ID，请按照说明开设一个 Macromedia 帐户。

备注： 您也可以单击加号 (+) 按钮并选择“获取更多服务器行为”，从“服务器行为”面板（“窗口”>“行为”）访问 Macromedia Exchange。

若要在 Dreamweaver 中安装服务器行为或其他功能扩展：
  1. 通过选择“帮助”>“管理功能扩展”启动功能扩展管理器。
  2. 在功能扩展管理器中，选择“文件”>“安装软件包”。

    3. 有关更多信息，请参见功能扩展管理器的联机帮助。


创建服务器行为

如果您是一位精通 ColdFusion、ASP.NET、JavaScript、VBScript、PHP 或 Java 的开发人员，则可以编写自己的服务器行为。创建服务器行为的步骤包括下列任务：

  • 编写一个或多个执行所需操作的代码块。

    • 有关利用 Dreamweaver 的“服务器行为创建器”创建服务器行为的信息，请参见使用“服务器行为创建器”。有关 Dreamweaver 服务器行为所支持的语法的信息，请参见编写代码块。

  • 指定代码块在页面的 HTML 源代码内的插入位置。

    • 有关在页面内定位代码块的信息，请参见定位代码块。

  • 如果服务器行为要求为参数指定值，则创建一个对话框，提示使用该行为的 Web 开发人员提供一个适当的值。

    • 有关使用对话框向服务器行为提供参数值的信息，请参见为自定义服务器行为创建对话框。

  • 在将该服务器行为提供给其他人之前，对其进行测试。

    • 有关测试服务器行为的指导原则，请参见测试服务器行为。


使用“服务器行为创建器”

“服务器行为创建器”用于添加由服务器行为插入到页中的代码块。

若要编写服务器行为代码块：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出式菜单中选择“新建服务器行为”。
  2. “新建服务器行为”对话框出现。
    这是所描述的功能的图片。
  3. 从“文档类型”弹出式菜单中，选择正在为其开发服务器行为的文档类型。
  4. 在“名称”文本框中，输入该服务器行为的名称。
  5. 若要拷贝现有服务器行为以添加到正在创建的行为，请选择“拷贝现有服务器行为”复选框。

    6. 当选中此复选框时，可用服务器行为列表将显示在“要拷贝的行为”弹出式菜单中。

  6. 单击“确定”。

    7. 显示“服务器行为创建器”对话框。
    这是所描述的功能的图片。

  7. 若要添加新的代码块，请单击加号 (+) 按钮。

    8. 显示“新建代码块”对话框。
    这是所描述的功能的图片。

  8. 输入想要创建的代码块名称。
  9. 在“代码块”文本框中，输入实现服务器行为所必需的代码。当在此文本框中输入代码时，仅可插入单个标签或代码块。如果需要输入多个标签或代码块，必须在“服务器行为创建器”对话框中创建同样多的单个代码块。
  10. 如果服务器行为需要运行时参数，可以单击“在代码块中插入参数”按钮，将参数包含在代码中。显示“在代码块中插入参数”对话框。
  11. 在参数“名称”弹出式菜单中输入参数的名称，然后单击“确定”。

    12. 该参数被插入到代码块中的插入点处，该插入点是定义此参数前由光标创建的。

  12. 从“插入代码”弹出式菜单中选择一个选项，指定嵌入代码块的位置。

    13. 有关更多信息，请参见定位代码块。

  13. 可以使用“高级”选项面板来指定有关所创建服务器的其他信息。

    14. 单击“高级”按钮，显示高级选项。
    这是所描述的功能的图片。

    “标识符”，指定是否应将代码块视为标识符。

    默认情况下，所有代码块都是标识符。如果 Dreamweaver 在文档的任何地方发现标识符代码块，则将该行为在“服务器行为”面板中列出。“标识符”复选框用于指定代码块是否应被视为标识符。

    服务器行为代码块中至少有一个必须为标识符。如果相同的代码块被用于另一个服务器行为，或者如果代码块的作用是页内自然发生的常用的部分功能，那么代码块不应 为标识符。

    “服务器行为标题”，指定行为显示在“服务器行为”面板中时，用来表示该行为的标题。

    当页面设计者单击“服务器行为”面板的加号 (+) 按钮时，新服务器行为的标题将出现在弹出式菜单中。当设计者将服务器行为的实例应用于文档时，该行为将出现在“服务器行为”面板中的已应用行为列表中。“服务器行为标题”对话框用于指定加号 (+) 弹出式菜单和已应用行为列表的内容。

    该对话框中的初始值为“新建服务器行为”对话框中提供的名称。定义参数后，该名称自动更新，以便参数出现在服务器行为名称后面的括号中。

    设置阶段变量 (@@Name@@, @@Value@@)

如果用户接受默认值，括号前面的所有内容（例如，“设置阶段变量”）将出现在加号 (+) 弹出式菜单中。名称和参数将出现在已应用行为列表中，例如，设置阶段变量 ("abcd", "5")。

“选定代码块”，指定当用户在“服务器行为”面板中选择行为时将选定的代码块。

当应用服务器行为时，行为中的代码块之一将被指定为“选定代码块”。如果该应用服务器行为，然后在“服务器行为”面板中选择该行为，则 Dreamweaver 将在“文档”窗口中自动选择指定的代码块。默认情况下，Dreamweaver 将选择不在 html 标签上方的第一个代码块。如果所有代码块都在 html 标签上方，则 Dreamweaver 将选择第一个代码块。高级用户可以指定哪个代码块是选定的代码块。
  14. 若要创建更多的代码块，请根据需要重复步骤 7 至 13。
  15. 如果服务器行为要求向其提供参数，则需要创建一个对话框来接受应用行为人所提供的参数。

    16. 若要创建接受用户输入参数的对话框，请参见第 980页的“为自定义服务器行为创建对话框”。

  16. 在完成所创建的服务器行为要求的上述步骤之后，单击“确定”。

    17. 创建服务器行为后，该行为将在“服务器行为”面板中列出。测试服务器行为并确保其正确运行。

有关其他信息，请参见以下章节：

  • 编写代码块
  • 在服务器行为中使用参数
  • 条件式代码块
  • 重复代码块
  • 编码指导原则
  • 定位代码块


编写代码块

在“服务器行为创建器”中创建的代码块封装在服务器行为中，该服务器行为显示在“服务器行为”面板中。代码可以是指定服务器模型的任何有效的运行时代码。例如，如果选择 ColdFusion 作为自定义服务器行为的文档类型，则编写的代码必须是能在 ColdFusion 应用程序服务器上运行的有效的 ColdFusion 代码。


输入代码块

可以直接在“服务器行为创建器”中创建代码块，也可以从其他来源拷贝和粘贴代码。在“服务器行为创建器”中创建的每个代码块都必须为单个标签或脚本块。如果需要插入多标签代码块，请将它们拆分为单独的代码块。


包含参数

可以在运行时代码中包含参数并由页面设计者提供参数值。为此，请在代码中输入参数标记，如下所示：

@@参数名@@

有关更多信息，请参见在服务器行为中使用参数。


代码块的应用条件和重复元素

如果希望代码块或部分代码块仅在某些条件适用时才执行，请使用以下语法：

<@ if (表达式 1) @>
   代码块 1
[<@ elseif (表达式 2) @>
   代码块 2]*
[<@ else @>
   代码块 3]
<@ endif @>

方括号 ([ ]) 表示可选代码，星号 (*) 表示零个或更多实例。条件表达式是任何有效的 JavaScript 条件表达式，并且可能包含服务器行为参数。有关更多信息，请参见条件式代码块。

如果希望代码块或部分代码块重复使用多次，请使用以下语法：

<@ loop (@@参数 1@@,@@参数 2@@) @>
   代码块
<@endloop@>

“loop”指令采用以逗号分隔的参数数组列表作为参数。重复文本将被拷贝 n 次，其中 n 是参数数组参数的长度。如果指定多个参数数组参数，则所有数组的长度必须相同。在第 i 次循环计算时，参数数组的第 i 个元素将替换代码块中的相关参数实例。有关更多信息，请参见重复代码块。

有关编码的一般信息，请参见第 978页的“编码指导原则”。


在服务器行为中使用参数

可以在服务器行为代码中包含参数，并在将服务器行为代码插入到页面前，让页面设计者提供必需的参数值。若要让页面设计者提供参数值，请在代码内输入参数标记，如下所示：

@@参数名@@

下面的 ASP 服务器行为示例包含参数 formParam，这要求插入该行为的人员提供表单对象的名称：

<% Session("lang_pref") = Request.Form("formParam"); %>
若要创建允许用户提供必需值的参数：
  1. 将 formParam 字符串包含在参数标记中：
    2. <% Session("lang_pref") = Request.Form("@formParam@@"); %>
  2. 创建可以提示设计者提供表单对象名称的对话框。有关更多信息，请参见为自定义服务器行为创建对话框。


条件式代码块

Dreamweaver 使您能够开发包含控制语句的代码块，这些代码块将有条件地执行。“服务器行为创建器”使用 if、elseif 和 else 语句，并可能包含服务器行为参数。这使您能够根据服务器行为参数间的 OR 关系值插入替换文本块。if、elseif 和 else 语句如下所示。请注意，方括号 ([ ]) 表示可选代码，星号 (*) 表示零个或更多实例：

<@ if (表达式 1) @>
   条件文本 1
[<@ elseif (表达式 2) @>
   条件文本 2]*
[<@ else @>
   条件文本 3]
<@ endif @>

条件表达式可以是任何能够使用 JavaScript eval() 函数进行计算的 JavaScript 表达式，并可能包含用 @@'s 进行标记的服务器行为参数。（@@'s 是区分参数和 JavaScript 变量与关键字所必需的。）

可以在条件指令中嵌套任意数量的条件或循环指令（请参见重复代码块）。例如，可以指定如果表达式为真，则执行循环。

备注： 忽略每个“@>”后的换行符。


有效使用条件表达式

当在 insertText XML 标签使用 if、else 和 elseif 指令时，将对参与者文本进行预处理，以解析 if 指令并确定将在结果中包含哪一文本。if 和 elseif 指令采用表达式作为参数。条件表达式与 JavaScript 条件表达式情况相同，而且也可以包含服务器行为参数。诸如此类的指令使您可以根据服务器行为参数的值或者相互之间的关系来选择替换代码块。

例如，下面所示的 JSP 代码来自使用条件代码块的 Dreamweaver MX 服务器行为：

@@rsName@@.close();
<conditonal_code>
@@rsName@@_hasData = @@rsName@@.next();

如果服务器行为使用普通的记录集，则 <conditonal_code> 占位符将被替换为：

@@rsName@@ = Statement@@rsName@@.executeQuery();

如果服务器行为使用来自可调用对象的记录集，它将改用下列代码：

@@callableName@@.execute();

@@rsName@@ = @@callableName@@.getResultSet();

如果为可调用对象添加服务器行为，则用户应在服务器行为的“参数”对话框中输入 @@callableName@@ 参数的值。否则，@@callableName@@ 参数将为空。因此，可以将 @@callableName@@ 作为 if 参数来重写以前的插入文本。在此示例中，如果为 @@callableName@@ 参数提供了一个值，则选择第一个条件代码块（包含 getResultSet() 方法）：

@@rsName@@.close();
<@ if (@@callableName@@ != '') @>
@@callableName@@.execute();
@@rsName@@ = @@callableName@@.getResultSet();@ else @>
@@rsName@@ = Statement@@rsName@@.executeQuery();
<@ endif @>
@@rsName@@_hasData = @@rsName@@.next();


重复代码块

创建服务器行为时，可以使用循环结构将某个代码块重复指定的次数。循环语法为：

<@ loop (@@参数 1@@,@@参数 2@@,@@参数 3@@,@@参数 n@@) @>
   代码块
<@endloop@>

“loop”指令采用逗号分隔的参数数组列表作为参数。在这种情况下，参数数组参数使用户能够为单个参数提供多个值。重复文本将被拷贝 n 次，其中 n 是参数数组参数的长度。如果指定多个参数数组参数，则所有数组的长度必须相同。在第 i 次循环计算时，参数数组的第 i 个元素将替换代码块中的相关参数实例。

当以后创建服务器行为对话框（请参见为自定义服务器行为创建对话框）时，可以向该对话框添加控件，使页面设计者能够创建参数数组。Dreamweaver 包括一个简单的数组控件，可用于创建对话框。这个称作“文本域逗号分隔列表”的控件可以通过“服务器行为创建器”获得。若要创建更为复杂的用户界面元素，请参见 API 文档，以创建包含控件（例如，网格控件）的对话框来创建数组。

“loop”指令无法嵌套，但是条件指令（请参见条件式代码块）却可以嵌套在“loop”指令中。

下面的示例显示如何使用这样的重复代码块来创建服务器行为（示例为用于访问预存过程的 ColdFusion 行为）：

<CFSTOREDPROC procedure="AddNewBook"
   datasource=#MM_connection_DSN#
   username=#MM_connection_USERNAME#
   password=#MM_connection_PASSWORD#>
<CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryID#"
   cfsqltype="CF_SQL_INTEGER">
<CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
   cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>

在该示例中，CFSTOREDPROC 标签可以包含零个或多个 CFPROCPARAM 标签。但是，如果不支持“loop”指令，则没有办法在插入的 CFSTOREDPROC 标签内包括 CFPROCPARAM 标签。如果在不使用“loop”指令的情况下，将该示例创建为服务器行为，则该示例需要分成两部分：主 CFSTOREDPROC 标签，以及有多个涉及类型的 CFPROCPARAM 标签。

使用“loop”指令可以将相同的过程按如下方式编写：

<CFSTOREDPROC procedure="@@procedure@@"
datasource=#MM_@@conn@@_DSN#
username=#MM_@@conn@@_USERNAME#
password=#MM_@@conn@@_PASSWORD#>
<@ loop (@@paramName@@,@@value@@,@@type@@) @>
   <CFPROCPARAM type="IN"
   dbvarname="@@paramName@@"
   value="@@value@@"
   cfsqltype="@@type@@">
<@endloop@>
</CFSTOREDPROC>

在上述示例以及条件代码块的情况下，@> 后面的换行符将被忽略。

如果用户在“服务器行为”对话框中输入下列参数值：

procedure = "proc1"
conn = "connection1"
paramName = ["@CategoryId", "@Year", "@ISBN"]
value = ["#Form.CategoryId#", "#Form.Year#", "#Form.ISBN#"]
type = ["CF_SQL_INTEGER", "CF_SQL_INTEGER", "CF_SQL_VARCHAR"]

则服务器行为将下列运行时代码插入页面：

<CFSTOREDPROC procedure="proc1"
datasource=#MM_connection1_DSN#
username=#MM_connection1_USERNAME#
password=#MM_connection1_PASSWORD#>

<CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryId#"
   cfsqltype="CF_SQL_INTEGER">
<CFPROCPARAM type="IN" dbvarname="@Year" value="#Form.Year#"
   cfsqltype="CF_SQL_INTEGER">
<CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
   cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>

备注： 除非是作为条件指令表达式的一部分，否则，参数数组不能在循环外使用。


使用“loop”指令的 _length 和 _index 变量

“loop”指令包括两个内置变量，可用于嵌入的 if 条件。这两个变量为：_length 和 _index。_length 变量计算“loop”指令处理的数组长度，而 _index 变量计算“loop”指令的当前索引。为了确保这两个变量仅被识别为指令，而不是作为传递到循环中的实际参数，请不要将这两个变量中的任何一个包含在 @@'s 中。

使用内置变量的一个示例是将它们应用于 Page 指令的 import 属性。import 属性要求用逗号分隔的导入源。如果 loop 指令围绕整个 import 属性展开执行，您可能希望只在第一次循环迭代中输出属性名称 import=（这将包含右双引号 (“)，而在最后一次循环迭代中不需要输出逗号）。使用内置变量可将此表示为：

<@loop (@@Import@@)@>
<@ if(_index == 0)@>import="
<@endif@>@@Import@@<@if (_index == _length-1)@>"<@else@>,
<@ endif @>
<@endloop@>


编码指导原则

一般来说，服务器行为代码应当紧凑、可靠。Web 应用程序开发人员对添加到他们页面中的代码非常敏感。请遵照广泛接受的文档类型语言（ColdFusion、ASP.NET、JavaScript、VBScript、PHP、Visual Basic 或 Java）的编码惯例。在编写注释时，请考虑可能需要理解代码的不同技术用户，如 Web 和交互程序的设计者或者其他 Web 应用程序开发人员。请包含正确描述代码目的的注释以及有关将其包含在页面内的任何特殊说明。


错误检查

一项重要的要求就是错误检查。服务器行为代码应当妥善处理错误情况。尝试预见所有可能性。例如，如果参数请求失败怎么办？如果查询没有返回记录怎么办？


使用唯一的名称

代码应当清楚标识并且避免与现有代码的名称冲突。例如，如果页面包含一个名为 hideLayer() 的函数和名为 ERROR_STRING 的全局变量，而服务器行为插入的代码也使用了这两个名称，则该服务器行为可能与现有代码冲突。


为代码的函数和全局变量创建前缀

为插入页面的运行时函数和全局变量创建您自己的前缀。约定之一就是使用首字母大写。请不要使用 MM_ 前缀：这是仅为 Macromedia 使用而保留的。Macromedia 会在所有函数和全局变量之前添加前缀 MM_，以避免与您的代码冲突。

var MM_ERROR_STRING = "...";
function MM_hideLayer() {


避免相似的代码块

请确保自己代码块中的代码不要与其他代码块中的代码太类似。如果某代码块看起来与页面上的另一个代码块非常类似，“服务器行为”面板可能会错误地将第一个代码块标识为第二个代码块的实例（或反之）。一个简单的解决方法是给代码块添加注释，使它更具有唯一性。


定位代码块

在“服务器行为创建器”中编写代码块后，必须指定将其插入到页面 HTML 源代码中的何处。

在“插入代码”弹出式菜单中，可以选择将代码块插入到以下位置：开始 <html> 标签上方、结束 </html> 标签的下方、相对于页面中的另一个标签或者相对于页面设计者选择的标签。

若要将代码块定位在 <html> 标签上方：
  1. 在“插入代码”弹出式菜单中，请选择“<html> 标签上方”。
  2. 在“相对位置”弹出式菜单中选择一个选项，指定标签上方的某个位置。

    3. 可以将代码块插入到文件开头，恰好在打开记录集的代码块之前，恰好在打开记录集的代码块之后，或者恰好在 <html> 标签上方。也可以指定自定义位置。

  3. 若要指定自定义位置，请从“相对位置”弹出式菜单中选择“自定义位置”，然后为代码块分配高度。

    4. Dreamweaver 为插入到 <html> 标签上方的所有打开记录集的代码块分配高度 50。如果两个或多个代码块的高度相同相当，则 Dreamweaver 随机地设置代码块间的顺序。

    如果需要按照特定顺序插入多个代码块，请使用“自定义位置”选项。例如，如果要在打开记录集的代码块后依次插入三个代码块，可以为第一个代码块输入高度 60，为第二个代码块输入 65，为第三个代码块输入 70。

若要将代码块定位在结束 </html> 标签下方：
  1. 在“插入代码”弹出式菜单中，选择“</html> 标签下方”。
  2. 在“相对位置”弹出式菜单中选择一个选项，指定标签下方的某个位置。

    3. 可以将代码块插入到恰好在 </html> 标签之后，恰好在关闭记录集的代码块之前，恰好在关闭记录集的代码块之后，或者恰好在文件结尾前。也可以指定自定义位置。

  3. 若要指定自定义位置，请从“相对位置”弹出式菜单中选择“自定义位置”，然后为代码块分配高度。

    4. Dreamweaver 为插入到 </html> 标签下方的所有关闭记录集的代码块分配高度 50。如果两个或多个代码块的高度相同相当，则 Dreamweaver 随机地设置代码块间的顺序。

    如果需要按照特定顺序插入多个代码块，请使用“自定义位置”选项。例如，如果要在关闭记录集的代码块之前依次插入三个代码块，可以为第一个代码块输入高度 30，为第二个代码块输入 35，为第三个代码块输入 40。

若要相对于页面上的另一个标签定位代码块：
  1. 在“插入代码”弹出式菜单中，请选择“相对于特定标签”。
  2. 在“标签”文本框中，输入该标签或从弹出式菜单中进行选择。

    3. 如果输入标签，请不要包括尖括号 (< >)。

  3. 在“相对位置”弹出式菜单中选择一个选项，指定相对于该标签的某个位置。

    4. 可以将代码块插入到恰好在开始标签之前，或者恰好在结束标签之后。也可以用代码替换该标签；将代码作为标签属性的值插入（出现一个让您选择属性的对话框）；或者将代码插入开始标签中。

若要相对于页面设计者的选定标签定位代码块：
  1. 在“插入代码”弹出式菜单中，选择“相对于选定内容”。
  2. 在“相对位置”弹出式菜单中选择一个选项，指定相对于选定内容的某个位置。

    3. 可以将代码块插入到恰好在选定内容之前或之后。也可以用代码块替换选定内容，或者围绕选定内容排列代码块。

    若要围绕选定内容排列代码块，则选定内容必须包含开始和结束标签，且其中不包含任何内容，如下所示：

    <CFIF Day="Monday"></CFIF>

    代码块的开始标签部分被插入到选定内容的开始标签之前，而代码块的结束标签部分被插入到选定内容的结束标签之后。


为自定义服务器行为创建对话框

服务器行为经常要求页面设计者提供参数值。该值必须在将服务器行为代码插入到页面之前插入。为此，可以创建一个对话框来提示实现服务器行为的人员输入参数值。

通过定义代码中由设计者提供的参数，可以创建该对话框。在定义所有参数之后，可以生成一个服务器行为对话框。

备注： 如果指定代码应当相对于页面设计者选择的特定标签进行插入（即，在“插入代码”弹出式菜单中选择“相对于特定标签”），那么将在不需干预的情况下，向代码块添加一个参数。该参数向行为对话框添加一个标签菜单，供页面设计者选择标签。

若要在服务器行为代码中创建参数：

在代码中希望插入所提供参数值的位置输入参数标记。参数语法为：

@@参数名@@

例如，如果服务器行为包含以下代码块：

<% Session("lang_pref") = Request.Form(“Form_Object_Name”); %>

若要让页面设计者提供 Form_Object_Name 的值，请在参数标记 (@@) 中包含该字符串：

<% Session("lang_pref") = Request.Form(“Form_Object_Name@@”); %>

也可以高亮显示该字符串，然后单击“在代码块中插入参数”按钮。输入参数名称，然后单击“确定”。Dreamweaver 用包含在参数标记内的指定参数名称替换高亮显示字符串的所有实例。

Dreamweaver 使用参数标记中包含的字符串来标记所生成对话框上的控件（请参见下面的过程）。在上面的示例中，Dreamweaver 创建带有下列标签的对话框：

备注： 服务器行为代码中的参数名称不能有任何空格。因此，对话框标签不能有任何空格。如果要在标签中包含空格，可以编辑生成的 HTML 文件。

若要为服务器行为创建对话框：
  1. 在“服务器行为创建器”中，单击“下一步”。

    2. 将出现一个对话框，该对话框列出在代码中定义的所有由设计者提供的参数。
    这是所描述的功能的图片。

  2. 如果愿意，可以通过选择参数并单击向上或向下箭头来更改对话框控件的显示顺序。
  3. 如果愿意，可以通过选择参数并在“显示为”列中选择另一个控件来更改该参数的控件。
  4. 单击“确定”。

对于您定义的每个由设计者提供的参数，Dreamweaver 都生成一个具有带标签控件的对话框。若要查看该对话框，请单击“服务器行为”面板（“窗口”>“服务器行为”）上的加号 (+) 按钮，然后从弹出式菜单中选择该服务器行为。

若要编辑您创建的服务器行为的对话框：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出式菜单中选择“编辑服务器行为”。
  2. 从列表中选择该服务器行为，并单击“打开”。

    3. 将出现包含该服务器行为的“服务器行为创建器”。

  3. 单击“下一步”。

    4. 将出现一个对话框，该对话框列出在代码中定义的所有由设计者提供的参数。

  4. 如果愿意，可以通过选择参数并单击向上或向下箭头来更改对话框控件的显示顺序。
  5. 如果愿意，可以通过选择参数并在“显示为”列中选择另一个控件来更改该参数的控件。
  6. 单击“确定”。


测试服务器行为

Macromedia Exchange 建议您对创建的每个服务器行为执行下列测试：

  • 从“服务器行为”面板应用行为。如果该行为有对话框，请在每个域中输入有效数据，然后单击“确定”。验证在应用该行为时没有错误发生。验证该服务器行为的运行时代码是否出现在代码检查器中。
  • 再次应用该服务器行为，并在每个对话框域中输入无效数据。尝试下列操作：将域保留为空白，使用大数或负数，使用无效字符（例如 /、?、:、* 等等），以及在数字域使用字母。可以编写格式验证例程来处理无效数据（验证例程涉及手工编码，这超出了本书的范围）。

在将服务器行为成功地应用于页面后，请验证下列内容：

  • 检查“服务器行为”面板，确保该服务器行为名称出现在添加到页面的行为的列表中。
  • 验证服务器端脚本图标是否出现在页面上（如果适用的话）。一般服务器端脚本图标是金色的盾牌。若要查看该图标，请启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）。
  • 在“代码视图”（“查看”>“代码”）中，验证没有生成任何无效代码。

另外，如果服务器行为将代码插入与数据库建立连接的文档，请创建一个测试数据库来测试插入到文档中的代码。通过定义查询来验证连接，这些查询应生成不同的数据集以及不同大小的数据集。

最后，将页面上传到服务器并在浏览器中打开。查看页面的 HTML 源代码并验证服务器端脚本不生成任何无效的 HTML。


编辑和修改服务器行为代码

您可以编辑用“服务器行为创建器”创建的任何服务器行为，其中包括从 Macromedia Exchange Web 站点下载的服务器行为以及由其他第三方开发人员创作的服务器行为。

如果您将一个服务器行为应用于页面，然后在 Dreamweaver 中编辑该行为，则原有行为的实例将不再出现在“服务器行为”面板中。“服务器行为”面板将搜寻页面，查找与已知服务器行为代码相匹配的代码。如果面板已知的服务器行为代码发生更改，则面板将不再识别页面上该行为的以前版本。

如果希望原有版本和新版本的行为同时出现在面板中，请单击“服务器行为”面板上的加号 (+) 按钮，选择“新建服务器行为”并创建原有服务器行为的拷贝。


编辑服务器行为

若要编辑用“服务器行为创建器”创建的服务器行为的代码，请执行以下操作：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出式菜单中选择“编辑服务器行为”。

    2. “编辑服务器行为”对话框出现，显示当前服务器技术的所有行为。
    这是所描述的功能的图片。

  2. 选择该服务器行为并单击“编辑”。

    3. “服务器行为创建器”对话框出现。
    这是所描述的功能的图片。

  3. 选择适当的代码块并修改要插入到页面中的代码。
  4. 如果愿意，可更改参数标记或向代码添加参数标记。

    5. 有关说明，请参见第 980页的“为自定义服务器行为创建对话框”。

  5. 如果愿意，可以在“插入代码”弹出式菜单中选择另一个选项，更改代码块在页面 HTML 源代码中的插入位置。

    6. 有关说明，请参见第 978页的“定位代码块”。

  6. 如果已修改的代码不包含任何由设计者提供的参数，请单击“确定”。

    7. Dreamweaver 将重新生成不包含对话框的服务器行为。新的服务器行为出现在“服务器行为”面板的加号 (+) 弹出式菜单中。

  7. 如果已修改的代码的确包含由设计者提供的参数，请单击“下一步”。

    8. Dreamweaver 将询问您是否要创建一个新对话框来改写原有的对话框。更改后单击“确定”。

Dreamweaver 将所有更改保存在服务器行为的 EDML 文件中。


参考资料

本节提供本章中介绍的面板和对话框的有关信息。


完成“新建服务器行为”对话框

该对话框使您能够选择在为其开发服务器行为的文档类型，并命名此新的服务器行为。

若要完成“新建服务器行为”对话框：
  1. 从弹出式菜单中选择文档类型。
  2. 为该服务器行为输入名称。
  3. 如果希望新的服务器基于随 Dreamweaver 提供的某个服务器行为，请选择“拷贝现有服务器行为”选项，并在“要拷贝的行为”弹出式菜单中选择 Dreamweaver 服务器行为。
  4. 单击“确定”。

“新建服务器行为创建器”将出现。

相关主题

创建服务器行为

使用“服务器行为创建器”

参考资料


完成“服务器行为创建器”对话框

若要完成“服务器行为创建器”对话框：
  1. 单击加号 (+) 按钮，输入代码块名称并单击“确定”，以开始一个代码块。

    2. 命名代码块的约定之一如下所示：

    行为的名称_代码块的名称

这里提供了一个示例：

MoveToRecord_Init
  2. 在“代码块”文本区域，输入将要插入到页面中的运行时代码。

    3. 运行时代码必须是单个标签块或者脚本块。如果需要插入多个标签或脚本块，请将它们拆分成单独的代码块。也可以从其他页面拷贝和粘贴代码。

    有关更多信息，请参见以下章节：

    • 编写代码块
    • 在服务器行为中使用参数
    • 条件式代码块
    • 重复代码块
    • 编码指导原则
  3. 通过使用“插入代码”弹出式菜单，指定代码块在页面的 HTML 源代码中的插入位置。

    4. 相对于页面中的标签或者页面设计者选定的标签插入代码块。 有关更多信息，请参见第 978页的“定位代码块”。

  4. 若要指定更高级的设置，请单击“高级”。

    5. 一旦指定每个代码块的源代码和插入位置，服务器行为就被完全定义了。在大多数情况下，不必再指定其他任何信息。

    如果您是一位高级用户，您可能希望通过单击“服务器行为创建器”中的“高级”按钮来修改其他参数。此时生成器将展开，显示几个新选项。
    这是所描述的功能的图片。

    “标识符”，指定代码块是否应被视为标识符。

    默认情况下，所有代码块都是标识符。如果 Dreamweaver 在文档的任何地方发现标识符代码块，则将该行为在“服务器行为”面板中列出。“标识符”复选框用于指定代码块是否应视为标识符。

    服务器行为代码块中至少有一个必须为标识符。如果为下列情况之一，则代码块不应为标识符：同一个代码块被其他服务器行为使用；或者代码块非常简单，可能会在页面上自然发生。

    “服务器行为标题”，指定“服务器行为”面板中的行为的标题。

    当页面设计者单击“服务器行为”面板上的加号 (+) 按钮时，新的服务器行为标题将出现在弹出式菜单中。当设计者将服务器行为的实例应用于文档时，该行为将出现在“服务器行为”面板中的已应用行为列表中。“服务器行为标题”对话框用于指定加号 (+) 弹出式菜单和已应用行为列表的内容。

    该对话框中的初始值为“新建服务器行为”对话框中提供的名称。定义参数后，该名称自动更新，以便参数出现在服务器行为名称后面的括号中。

    设置阶段变量 (@@Name@@, @@Value@@)

如果用户接受默认值，括号前面的所有内容（例如，“设置阶段变量”）将出现在加号 (+) 弹出式菜单中。名称和参数将出现在已应用行为列表中，例如，设置阶段变量 ("abcd", "5")。

“选定代码块”，指定当用户在“服务器行为”面板中选择行为时将选定的代码块。

当应用服务器行为时，行为中的代码块之一将被指定为“选定代码块”。如果该应用服务器行为，然后在“服务器行为”面板中选择该行为，则 Dreamweaver 将在“文档”窗口中自动选择指定的代码块。默认情况下，Dreamweaver 将选择不在 html 标签上方的第一个代码块。如果所有代码块都在 html 标签上方，则 Dreamweaver 将选择第一个代码块。高级用户可以指定哪个代码块是选定的代码块。
  5. 为服务器行为中的每个代码块重复步骤 1 至 4。
  6. 如果两个或多个代码块的插入位置相同，可以通过单击向上或向下箭头来更改它们之间的相对位置。
  7. 如果您在代码中未定义任何由设计者提供的参数，请单击“确定”。

    8. Dreamweaver 创建不包含对话框的服务器行为。新的服务器行为将出现在“服务器行为”面板的加号 (+) 菜单中。

  8. 如果在代码中的确定义了由设计者提供的参数，Dreamweaver 将提示您在创建该行为之前配置服务器行为的对话框。

    9. 有关更多信息，请参见第 980页的“为自定义服务器行为创建对话框”。

相关主题

创建服务器行为

使用“服务器行为创建器”

编写代码块

在服务器行为中使用参数

条件式代码块

重复代码块

编码指导原则

定位代码块

为自定义服务器行为创建对话框


完成“在代码块中插入参数”对话框

该对话框用于使用参数标记替换代码块中选定字符串的所有实例。

备注： 在使用该对话框之前，请在代码块中先选择一个字符串。

过程
  1. 输入参数名称。

    2. 示例：Session

  2. 单击“确定”。

Dreamweaver 用参数标记（例如，@@Session@@）替换代码块中选定字符串的所有实例。

相关主题

在服务器行为中使用参数

为自定义服务器行为创建对话框


完成“新建代码块”对话框

该对话框用于在“服务器行为创建器”中命名和创建代码块。

过程

输入名称并单击“确定”。

相关主题

使用“服务器行为创建器”


完成“生成行为对话框”对话框

该对话框为要求用户输入的自定义服务器行为生成一个对话框。也用于编辑这样的对话框。

当该对话框打开时，将列出代码中定义的所有应提供的参数。 有关更多信息，请参见为自定义服务器行为创建对话框。

过程
  1. 若要更改对话框控件的显示顺序，请选定参数，然后单击向上或向下箭头。
  2. 若要更改参数控件，请选定该参数，然后在“显示为”列中选择另一个控件。
  3. 单击“确定”。

Dreamweaver 为自定义服务器行为生成一个对话框，或者更新现有对话框。

相关主题

为自定义服务器行为创建对话框

在服务器行为中使用参数

使用“服务器行为创建器”


完成“编辑服务器行为”对话框

该对话框使您能够选择要编辑的服务器行为。

若要编辑服务器行为：
  1. 选择一种文档类型和服务器行为。
  2. 单击“编辑”。

    3. “编辑服务器行为”对话框出现，该对话框使您能够编辑服务器行为。有关更多信息，请参见编辑服务器行为。

相关主题

编辑和修改服务器行为代码

使用“服务器行为创建器”

定位代码块

上一页


创建交互式表单

表单使您可以与 Web 站点的访问者进行交互或从他们那里收集信息。表单从用户收集信息，然后将这些信息提交给服务器进行处理。表单可以包含允许用户进行交互的各种对象。这些表单对象包括文本域、列表框、复选框和单选按钮。form 标签包括一些参数，使用这些参数可以指定到处理表单数据的服务器端脚本或应用程序的路径，而且还可以指定在将数据从浏览器传输到服务器时要使用的 HTTP 方法。

当访问者将信息输入 Web 站点表单并单击提交按钮时，这些信息将被发送到服务器，服务器端脚本或应用程序在该处对这些信息进行处理。服务器通过将请求信息发送回用户，或基于该表单内容执行一些操作来进行响应。通常，通过通用网关接口 (GGI) 脚本、ColdFusion 页、Java Server Page (JSP) 或 ASP 来处理信息。请注意，如果不使用服务器端脚本或应用程序来处理表单数据，就无法收集这些数据。

Macromedia Dreamweaver MX 允许您创建各种表单对象，包括文本域、密码域、单选按钮、复选框、弹出式菜单以及可单击的图像（如“提交”按钮）。

Dreamweaver 还包括“验证表单”行为，以验证访问者提供的信息。例如，可以检查电子邮件地址是否包含“ @ ”符号，或者必需域是否包含项。

本章包含以下几节：

  • 关于表单对象
  • 创建表单
  • 理解表单对象
  • 插入复选框和单选按钮
  • 添加列表和菜单
  • 添加表单按钮
  • 关于表单设计
  • 使用客户端 JavaScript 函数处理表单
  • 将行为与表单一起使用
  • 创建动态表单对象
下一页


关于表单对象

在 Dreamweaver 中，表单输入类型称为表单对象。可以通过选择“插入”>“表单对象”来插入表单对象，或者通过从下图显示的“插入”栏的“表单”面板访问表单对象来插入表单对象。

“表单”栏提供下列按钮：

“表单”在文档中插入表单。Dreamweaver 在 HTML 源代码中插入开始和结束 form 标签。任何其他表单对象，如文本域、按钮等，都必须插入到两个 form 标签之中，这样所有浏览器才能正确处理这些数据。

“文本域”在表单中插入文本域。文本域可接受任何类型的字母数字项。输入的文本可以显示为单行、多行或者显示为项目符号或星号（用于保护密码）。

“隐藏域”在文档中插入一个可以存储用户数据的域。隐藏域使您可以存储用户输入的信息，如姓名、电子邮件地址或购买意向，然后在该用户下次访问站点时使用这些数据。

“复选框”在表单中插入复选框。复选框允许在一组选项中选择多项，用户可以选择任意多个适用的选项。

“单选按钮”在表单中插入单选按钮。单选按钮代表互相排斥的选择。选择一组中的某个按钮，就会取消选择该组中的所有其他按钮。例如，用户可以选择“是”或“否”。

“单选按钮组”插入共享同一名称的单选按钮的集合。

“列表/菜单”使您可以在列表中创建用户选项。“列表”选项在滚动列表中显示选项值，并允许用户在列表中选择多个选项。“菜单”选项在弹出式菜单中显示选项值，而且只允许用户选择一个选项。

“跳转菜单”插入可导航的列表或弹出式菜单。跳转菜单允许您插入一种菜单，在这种菜单中的每个选项都链接到文档或文件。请参见创建跳转菜单。

“图像域”使您可以在表单中插入图像。可以使用图像域替换“提交”按钮，以生成图形化按钮。

“文件域”在文档中插入空白文本域和“浏览”按钮。文件域使用户可以浏览到其硬盘上的文件，并将这些文件作为表单数据上传。

“按钮”在表单中插入文本按钮。按钮在单击时执行任务，如提交或重置表单。可以为按钮添加自定义名称或标签，或者使用预定义的“提交”或“重置”标签之一。


创建表单

Dreamweaver 的“插入”栏使您可以创建表单并将诸如文本域、按钮、列表框和单选按钮等对象添加到表单。

若要向文档添加表单，请执行以下操作：
  1. 将插入点放在希望表单出现的位置。
  2. 选择“插入”>“表单”，或选择“插入”栏上的“表单”类别，然后单击“表单”图标。

    3. Dreamweaver 插入一个表单。当页面处于“设计”视图中时，用红色的虚轮廓线指示表单。如果没有看到此轮廓线，请检查是否选中了“查看”>“可视化助理”>“不可见元素”。
    这是所描述的功能的图片。

  3. 在“文档”窗口中，单击该表单轮廓以选择该表单，或者在标签选择器中选择 <form> 标签。标签选择器位于“文档”窗口的左下角。
  4. 在“属性检查器”的“表单名称”域中，键入一个唯一名称以标识该表单。

    5. 命名表单后，就可以使用脚本语言（如 JavaScript 或 VBScript）引用或控制该表单。如果不命名表单，则 Dreamweaver 使用语法 formn 生成一个名称，并在向页面中添加每个表单时递增 n 的值。
    这是所描述的功能的图片。

  5. 在属性检查器的“操作”域中，指定到处理该表单的动态页或脚本的路径。可以在“操作”域键入完整路径，也可以单击文件夹图标定位到包含该脚本或应用程序页的适当文件夹。

    6. 如果指定到动态页的路径，则该 URL 路径将类似于以下示例：

    http://www.mysite.com/应用程序名称/process.cfm
  6. 在“方法”弹出式菜单中，选择将表单数据传输到服务器的方法。表单“方法”有：

    POST
    在 HTTP 请求中嵌入表单数据。
    GET
    将值追加到请求该页的 URL 中。
    默认
    使用浏览器的默认设置将表单数据发送到服务器。通常，默认方法为 GET 方法。

    7. 请注意，您所使用的 Web 或应用程序服务器可能会限制您对方法的选择。有关更多信息，请与您所在组织的服务器管理员联系。

    不要使用 GET 方法发送长表单。URL 的长度限制在 8,192 个字符以内。如果发送的数据量太大，数据将被截断，从而导致意外的或失败的处理结果。而且，在发送机密用户名和密码、信用卡号或其他机密信息时，不要使用 GET 方法。用 GET 方法传递信息不安全。

  7. “MIME 类型”弹出式菜单使您可以指定对提交给服务器进行处理的数据使用 MIME 编码类型。

    8. 默认设置 application/x-www-form-urlencode 通常与 POST 方法协同使用。如果要创建文件上传域，请指定 multipart/form-data MIME 类型。

  8. “目标”弹出式菜单指定一个窗口，在该窗口中显示调用程序所返回的数据。

    9. 如果命名的窗口尚未打开，则打开一个具有该名称的新窗口。目标值有：

    _blank，在未命名的新窗口中打开目标文档。

    _paren t，在显示当前文档的窗口的父窗口中打开目标文档。

    _self，在提交表单所使用的窗口中打开目标文档。

    _top，在当前窗口的窗体内打开目标文档。此值可用于确保目标文档占用整个窗口，即使原始文档显示在框架中。


理解表单对象

表单对象是允许用户输入数据的机制。在创建表单对象之前，必须首先在页面中插入表单。

提示： 如果尚未创建表单便尝试插入表单对象，则 Dreamweaver 将显示消息：“是否添加表单标签？”选择“是”，则 Dreamweaver 为该对象创建表单标签。

可以添加到表单的表单对象有：

文本域，接受任何类型的字母数字文本项。该文本可以显示为单行、多行，对于私有信息，也可以显示为一系列点或星号（例如，用于保护密码）。

隐藏域，存储用户输入的信息，如姓名、电子邮件地址或偏爱的查看方式，并在该用户下次访问此站点时使用这些数据。

按钮，在单击时执行操作。通常，这些操作包括提交或重置表单。可以为按钮添加自定义名称或标签，或使用预定义的“提交”或“重置”标签之一。

复选框，允许在一组选项中选择多项。用户可以选择任意多个适用的选项。

单选按钮，代表互相排斥的选择。在某单选按钮组（由两个或多个共享同一名称的按钮组成）中选择一个按钮，就会取消选择该组中的所有其他按钮。例如，用户订阅表单可能要求您选择“男”或“女”。

列表/菜单，在允许用户选择多个选项的滚动列表中显示选项值。“菜单”选项在只允许用户选择一项的弹出式菜单中显示选项值。

跳转菜单，是可导航的列表或弹出式菜单，它使您可以插入一种菜单，这种菜单中的每个选项都链接到文档或文件。请参见创建跳转菜单。

文件域，使用户可以浏览到其计算机上的文件并将这些文件作为表单数据上传。

图像域，使您可以在表单中插入图像。图像域可用于生成图形化按钮（例如，“提交”或“重置”按钮）。


使用表单域

表单域使用户可以在表单中输入文本。有三种类型的表单域：

  • 文本域（用户在此处输入响应）。
  • 文件域（用户在此处输入要上传到服务器的文件的路径）。
  • 隐藏域（存储用户在其他域中输入的信息）。

在向表单中添加域时，可以指定域的长度、域包含的行数、用户最多可输入的字符数以及该域是否为密码域等。


创建文本域

文本域是用户在其中输入响应的表单对象。有三种类型的文本域：

单行文本域通常提供单字或短语响应，如姓名或地址。

多行文本域为访问者提供一个较大的区域，供其输入响应。可以指定访问者最多可输入的行数以及对象的字符宽度。如果输入的文本超过这些设置，则该域将按照换行属性中指定的设置进行滚动。

密码域是特殊类型的文本域。当用户在密码域中键入时，所输入的文本被替换为星号或项目符号，以隐藏该文本，保护这些信息不被看到。

请注意，使用密码域发送到服务器的密码和其他信息并未加密。所传输的数据可能会以字母数字文本形式被截获并被读取。因此，应始终对要保密的数据进行加密。

若要创建单行或密码文本域：
  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“文本域”。

    3. 文档中出现一个文本域，而且显示“文本域”属性检查器。
    这是所描述的功能的图片。

  3. 在属性检查器的“文本域”域中，为文本域输入一个唯一名称。

    4. 所选名称必须在该表单内唯一标识该文本域。表单对象名称不能包含空格或特殊字符。可以使用字母数字字符和下划线 (_) 的任意组合。请注意，分配给“文本域”的标签是将存储该域的值（输入的数据）的变量名。这是发送给服务器进行处理的值。

  4. 在“字符宽度”域中，执行下列操作之一：
    • 接受默认设置，将文本域的长度设置为 20 个字符。
    • 指定文本域的最大长度。文本域的最大长度是该域一次最多可显示的字符数。例如，如果“字符宽度”设置为 20（默认值），而用户输入 100 个字符，则在该文本域中只能看到其中的 20 个字符。请注意，虽然无法在该域中看到这些字符，但域对象可以识别它们，而且它们会被发送到服务器进行处理。
  5. 在“最大字符数”域中输入一个值，该值用于限定用户可在文本域中输入的最大字符数。这个值定义文本域的大小限制，而且用于验证该表单。

    6. 如果将“最大字符数”域保留为空白，则用户可以输入任意数量的文本。如果文本超过域的字符宽度，文本将滚动显示。如果用户输入超过最大字符数，则表单产生警告声。

  6. 选择“单行”或“密码”指定要创建的文本域的类型。

    7. 也可以选择创建多行文本域。有关创建多行文本域的说明，请参见创建多行文本域。

  7. 如果希望在域中显示默认文本值，请在属性检查器的“初始值”域中输入默认文本。

    8. 在用户浏览器中首次载入此表单时，文本域中将显示此文本。例如，通过包含说明或示例值，可以指示用户在域中输入信息。

  8. 若要为页面内的域添加标签，请将插入点放在该对象的旁边，然后输入需要的任何文本。

可以将文本格式设置应用于表单对象标签。有关更多信息，请参见设置和更改字体和样式。下面的示例显示标签文字为“请输入您的用户名：”的单行文本域。请注意，“文本域属性”检查器在“字符宽度”域中指定该域最多可显示 30 个字符，但它最多可保存 50 个字符。


创建多行文本域

多行文本域使您可以输入多行文本。在创建多行文本域时，可以指定用户可输入的文本行数。

若要创建多行文本域：
  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“文本域”。

    3. 在文档中插入了一个文本域，而且显示“文本域”属性检查器。
    这是所描述的功能的图片。

  3. 在属性检查器的“文本域”域中，为文本域输入一个唯一名称。

    4. 所选名称必须在该表单内唯一标识该文本域。表单对象名称不能包含空格或特殊字符。可以使用字母数字字符和下划线 (_) 的任意组合。请注意，分配给“文本域”的标签是将存储该域的值（输入的数据）的变量名。这是发送给服务器进行处理的值。

  4. 在“字符宽度”域中，执行下列操作之一：
    • 接受默认设置，将文本域的长度设置为 20 个字符。
    • 指定文本域的最大长度。文本域的最大长度是该域一次最多可显示的字符数。例如，如果“字符宽度”设置为 20（默认值），而用户输入 100 个字符，则在该文本域中只能看到其中的 20 个字符。请注意，虽然无法在该域中看到这些字符，但域对象可以识别它们，而且它们会被发送到服务器进行处理。
  5. 选择“多行”指定要创建的文本域的类型。
  6. 在“行数”域中指定要显示的最大行数。

    7. 默认情况下设置的是两行的文本域。

  7. 从“换行”弹出式菜单中，选择一种设置，确定当用户输入的信息太多，无法在定义的文本区域内显示时，如何显示用户的输入内容。换行选项包括：

    8. “关闭或默认”，防止文本换行到下一行。当用户输入的内容超过文本区域的右边界时，文本将向左侧滚动。用户必须按 Return 键才能将插入点移动到文本区域的下一行。

    “虚拟”，在文本区域中设置自动换行。当用户输入的内容超过文本区域的右边界时，文本换行到下一行。当提交数据进行处理时，自动换行并不应用到数据中。数据作为一个数据字符串进行提交。

    “物理”，在文本区域设置自动换行，当提交数据进行处理时，也对这些数据设置自动换行。

  8. 如果希望在域中显示默认文本值，请在属性检查器的“初始值”域中输入默认文本。

    9. 在用户浏览器中首次载入此表单时，文本域中将显示此文本。例如，通过包含说明或示例值，可以指示用户在域中输入信息。

  9. 若要为页面内的域添加标签，请将插入点放在该对象的旁边，然后输入需要的任何文本。

    10. 可以将文本格式设置应用于表单对象标签。有关更多信息，请参见设置和更改字体和样式。


创建文件上传域

您可以创建文件上传域，文件上传域使用户可以选择其计算机上的文件，如字处理文档或图形文件，并将该文件上传到服务器。文件域类似于其他文本域，只是文件域还包含一个“浏览”按钮。用户可以手动输入要上传的文件的路径，也可以使用“浏览”按钮定位和选择该文件。

文件域要求使用 POST 方法将文件从浏览器传输到服务器。该文件被发送到表单的“操作”域中所指定的地址。

备注： 在使用文件域之前，请与服务器管理员联系，确认允许使用匿名文件上传。

若要在表单中创建文件域：
  1. 在页面中插入表单（“插入”>“表单”）。
  2. 选择该表单。将显示该表单的属性检查器。
  3. 将表单“方法”设置为 POST。
  4. 从“MIME 类型”弹出式菜单中，选择 multipart/form-data。
    这是所描述的功能的图片。
  5. 将插入点放在表单轮廓内，然后选择“插入”>“表单对象”>“文件域”，或单击“插入”栏“表单”选项卡中的“插入文件域”图标。

    6. 在表单中插入了一个文件域。

  6. 在属性检查器的“文件域名称”域中，为该文件域对象输入名称。
  7. 在“字符宽度”域中，指定希望该域最多可显示的字符数。
  8. 在“最大字符数”域中，指定该域最多可容纳的字符数。

    9. 如果用户通过浏览来定位文件，则文件名和路径可超过指定的“最大字符数”的值。但是，如果用户尝试键入文件名和路径，则文件域仅允许键入“最大字符数”值所指定的字符数。

下面的示例说明一个简单的文件域。请注意，属性检查器的“最大字符数”域已经设置为 75，而“字符宽度”设置为 30，这就意味着用户只能看到文件路径中的 30 个字符。请仔细考虑用户将上传的文件类型，以及他们是否需要能够在文件域的文本框内查看整个文件路径。


创建隐藏域

隐藏域是用来收集有关用户的信息的文本域。在提交表单时，该域中存储的信息将被发送回服务器。

在您插入隐藏域时，Dreamweaver 会在文档中创建标记。如果您插入隐藏域，但未看到标记，请选择“查看”>“可视化助理”>“不可见元素”查看标记。

若要创建隐藏域：
  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“隐藏域”。

    3. 文档中出现一个标记。

  3. 在属性检查器的“隐藏域”域中，为该域键入一个唯一名称。
  4. 在“值”域中，键入要分配给该域的值。


插入复选框和单选按钮

复选框和单选按钮表单对象设置预定义的选择对象。用户可单击复选框或单选按钮进行选择。


了解复选框和单选按钮

复选框对每个单独的响应进行“关闭”和“打开”状态切换。因此，用户可以从复选框组中选择多个选项。下面的示例通过显示三个选中的复选框项来说明这一点：冲浪、山地自行车和漂流。

单选按钮作为一个组使用，提供彼此排斥的选项值。用户在单选按钮组内只能选择一个选项。在下面的示例中，“漂流”是当前选择的选项。如果用户单击“冲浪”，就会自动取消选择“漂流”按钮。


插入复选框

复选框允许用户从一组选项中选择多个选项。

若要插入复选框：
  1. 将插入点放在表单轮廓内，然后执行下列操作之一：
    • 选择“插入”>“表单对象”>“复选框”。
    • 在“插入”栏的“表单”类别中，单击“插入复选框”图标。
  2. 在属性检查器的“复选框名称”域中，为该复选框键入一个唯一的描述性名称。
  3. 在“选定值”域中，为复选框键入值。

    4. 例如，在一项调查中，可以将值 4 设置为表示非常同意，值 1 设置为表示强烈反对。

  4. 对于“初始状态”，如果希望在浏览器中首次载入该表单时有一个选项显示为选中状态，请单击“已选中”。


插入单选按钮

在要求用户从一组选项中只能选择一个选项时，请使用单选按钮。单选按钮通常成组地使用。一个组中的所有单选按钮必须具有相同的名称，而且必须包含不同的域值。

若要将多个单选按钮作为一组插入：
  1. 将插入点放在表单轮廓内：
  2. 使用下列方法之一，插入“单选按钮组”表单对象：
    • 单击“表单”选项卡，然后单击“单选按钮组”图标。
    • 选择“插入”>“表单对象”>“单选按钮组”。

      • 出现“单选按钮组”对话框。
      这是所描述的功能的图片。

  3. 完成“单选按钮组”对话框，然后单击“确定”。

    4. 有关说明，请参见设置“单选按钮组”对话框选项。

Dreamweaver 在 HTML 表单内插入单选按钮组。如果尚未在页面中插入表单，则 Dreamweaver 将为您插入一个。如果愿意，可以更改组的布局。还可以使用属性检查器或直接在“代码”视图中编辑单选按钮。

若要逐个插入单选按钮，请执行以下操作：
  1. 将插入点放在表单轮廓内。
  2. 通过选择“插入”>“表单对象”>“单选按钮”来插入单选按钮表单对象。
  3. 在属性检查器的“单选按钮名称”域中，为该组选项键入一个描述性名称。

    4. 如果要在表单中创建多个单选按钮交互对象，请确保每组单选按钮都具有唯一名称。但是，如果要插入单独的单选按钮来创建组，则必须为每个单选按钮添加标签

  4. 在“选定值”域中，输入当用户选择此单选按钮时将发送到服务器端脚本或应用程序的值。例如，可以在“选定值”域中键入滑雪，指示用户选择滑雪。
  5. 对于“初始状态”，如果希望在浏览器中首次载入该表单时有一个选项显示为选中状态，请单击“已选中”。


添加列表和菜单

列表和菜单使您可以在有限的空间内为用户提供许多选项。列表提供一个滚动条，它使用户可浏览许多项，并进行多重选择。下拉式菜单仅显示一个项，该项也是活动选项。用户只能从菜单中选择一项。


创建滚动列表

滚动列表使您可以在有限的空间中显示多个选项。用户可以滚动整个列表，并选择其中的多个项。

若要创建滚动列表：
  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“列表/菜单”，然后选择所生成的“列表/菜单”元素（如果需要的话）。

    3. 在表单轮廓内出现“列表/菜单”表单对象，而且还会显示“列表/菜单属性”检查器。在下面的插图中，“列表/菜单属性”检查器显示“动态”按钮。此按钮用于创建动态列表/菜单表单对象，而且只有在以前已经选择了动态文档类型时，才显示该按钮。
    这是所描述的功能的图片。

  3. 在属性检查器的“列表/菜单”域中，为该列表输入一个唯一名称。
  4. 在“类型”下，选择“列表”。
  5. 在“高度”域中，输入一个数字，指定该列表将显示的行（或项）数。

    6. 如果您指定的数字小于该列表包含的选项数，则出现滚动条。

  6. 如果希望允许用户选择该列表中的多个项，请选中“允许多选”（位于“选项”旁边）。
  7. 单击“列表值”添加选项。

    8. 出现“列表值”对话框。
    这是所描述的功能的图片。

  8. 将插入点放在“项目标签”域中后，输入要在该列表中显示的文本。
  9. 在“值”域中，输入在用户选择该项时将发送到服务器的数据。
  10. 若要向选项列表中添加其他项，请单击加号 (+) 按钮，然后重复步骤 7 和 8。
  11. 完成向列表中添加项后，单击“确定”，关闭“列表值”对话框。

    12. 出现属性检查器。在“初始化时选定”域中会看到这些选项。

  12. 为了在默认情况下使列表中的一项处于选中状态，请在属性检查器的“初始化时选定”域中选择该项。
    这是所描述的功能的图片。


创建弹出式菜单

弹出式菜单使访问者可以从由多个项组成的列表中选择一项。当您的空间有限，但需要显示许多菜单项时，弹出式菜单非常有用。请注意，当菜单表单在浏览器中显示，只有一个选项是可见的。若要显示其他选项，用户可单击向下箭头以显示整个列表。

备注： 弹出式菜单表单元素与图形弹出式菜单不同。有关创建、编辑、显示和隐藏图形弹出式菜单的信息，请参见显示弹出式菜单。

若要创建弹出式菜单：
  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“列表/菜单”，然后选择所生成的“列表/菜单”元素（如果需要的话）。

    3. 在表单轮廓内出现“列表/菜单”表单对象，而且还会显示“列表/菜单属性”检查器。
    这是所描述的功能的图片。

  3. 在属性检查器的“列表/菜单”域中，为该菜单输入一个唯一名称。
  4. 在“类型”下，选择“菜单”。
  5. 单击“列表值”添加选项。

    6. 出现“列表值”对话框。
    这是所描述的功能的图片。

  6. 将插入点放入“项目标签”域以后，输入要在该菜单中显示的文本。
  7. 在“值”域中，输入在用户选择该项时将发送到服务器的数据。
  8. 若要向选项列表中添加其他项，请单击加号 (+) 按钮，然后重复步骤 6 和 7。
  9. 完成向菜单中添加项后，单击“确定”，关闭“列表值”对话框。
  10. 为了在默认情况下使列表中的一项处于选中状态，请在属性检查器的“初始化时选定”域中选择该项。
    这是所描述的功能的图片。


添加表单按钮

表单按钮控制表单操作。使用表单按钮将输入表单的数据提交到服务器，或者重置该表单。还可以将其他已经在脚本中定义的处理任务分配给按钮。例如，表单按钮可以根据指定的值计算所选商品的总价。


插入标准表单按钮

标准表单按钮为浏览器的默认按钮样式，它包含您要显示的文本。标准表单按钮通常标记为“提交”、“重置”或“发送”。

若要创建文本按钮：
  1. 将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“按钮”，或者单击“表单”面板中的“按钮”图标。

    3. Dreamweaver 在表单中插入“按钮”表单对象，并显示“按钮属性”检查器。
    这是所描述的功能的图片。

  3. 在属性检查器的“按钮名称”域中，为该按钮输入名称。

    4. 请注意，有两个保留的名称：“提交表单”，它提交表单数据进行处理；“重设表单”，它将所有表单域重设为其原始值。

  4. 在属性检查器的“标签文字”域输入希望在该按钮上显示的文本。
  5. 从“动作”部分选择一种操作。可用的操作有：

    6. “提交表单”，在单击该按钮时提交表单进行处理。

    “重设表单”，在单击该按钮时，重设表单。

    “无”，在单击该按钮时，根据处理脚本激活一种操作。若要指定某种操作，请从“文档”窗口的状态栏选择 Form 标签来选择该表单，并显示“表单属性”检查器。在“动作”弹出式菜单中，选择处理该表单的脚本或页面。


创建图形化“提交”按钮

可以使用指定的图像作为按钮图标。如果使用图像来执行任务而不是提交数据，则需要将某种行为附加到表单对象。可以使用 Dreamweaver 的“行为”面板将某种行为分配给按钮，或者可使用客户端 JavaScript 来执行某种操作。

若要了解如何将某种行为附加到对象，请参见应用行为。

若要创建图形化“提交”按钮：
  1. 在文档中，将插入点放在表单轮廓内。
  2. 选择“插入”>“表单对象”>“图像域”。
  3. 在图像域的属性检查器中，将“图像域”域中的文本更改为“提交”。
  4. 通过单击 SRC 域的文件夹图标，然后浏览到图像文件，来选择要用作按钮的图像。
  5. 在“替换文本”域中，输入要替代图像显示的任何文本，该文本适用于纯文本浏览器或者设置为手动下载图像的浏览器。


关于表单设计

可以使用换行符、段落标记、预格式化的文本或表来设置表单的格式。不能将表单插入另一个表单中，即标签不能交迭，但是可以在一个页面中包含多个表单。

在设计表单时，请记住使用描述性文本标记表单域，以使用户知道自己正在对什么内容作出响应，例如，“请键入您的姓名”是要求输入姓名信息。


在表单中插入表

可以通过在表单中插入表，设计更富吸引力的表单。使用表为表单对象和域标签提供结构。表可以更容易地垂直和水平对齐选项。当在表单中使用表时，请确保所有的 table 标签都位于两个 form 标签之间。


使用客户端 JavaScript 函数处理表单

表单由 form 标签的 action 属性中指定的脚本或应用程序进行处理。若要查看与表单关联的操作，请选择该表单，然后在属性检查器中查看。“动作”域指向关联的操作。

最简单的表单使用 JavaScript 或 VBScript 在客户端执行表单处理（这与将表单数据发送到服务器进行处理相反）。例如，在页面底部可以有一个小表单，仅包含两个标记为“是”和“否”的单选按钮以及一个“提交”按钮。表单操作可以是在文档的 head 部分定义的 JavaScript 函数，在用户选择“是”时显示一条警告信息，当用户选择“否”时显示另一条警告信息：

function processForm(){
   if (document.forms[0].elements[0].checked){
      alert('Yes');
   }else{
      alert('No');
   }
}
若要将客户端 JavaScript 函数用作表单操作：
  1. 选择表单中的“提交”按钮。
  2. 将“调用 JavaScript”行为附加到该按钮上（请参见调用 JavaScript）。
  3. 在附加该行为时出现的“JavaScript”文本框中，输入 processForm()。
  4. 将 processForm() JavaScript 函数（类似上面所示的函数）添加到文档的 head 部分。

可以使用客户端脚本撰写处理很多表单处理任务，但是不能保存用户输入的数据或者将数据发送给其他人。若要保存数据或者将数据传输到其他应用程序进行处理，则需要使用服务器端脚本或应用程序。通用网关接口 (CGI) 脚本是处理表单数据的最常见类型的服务器端脚本撰写机制。有多个 Web 站点免费为您提供可使用的 CGI 脚本。承载您的站点的 Internet 服务提供商 (ISP) 可能会提供执行许多常见任务的 CGI 脚本。这些任务包括收集电子邮件地址或允许访问者通过 Web 表单向您发送意见等。


将行为与表单一起使用

通过使用在选定表单或表单对象时“行为”面板中出现的任何行为，可以将行为附加到表单或表单对象。只有在将文本域插入文档后，才能使用“验证表单”和“设置文本域文字”行为。在将“验证表单”行为附加到表单对象时，必须指定要验证哪个文本域。例如，如果将“验证表单”附加到“提交”按钮，则可以指定为“名称”创建的文本域，以检查用户在“名称”域中输入的文本。

在应用行为时，需要确保文档中的每个表单对象（以及其他每个对象）都具有唯一名称。如果两个不同的对象使用相同的名称，即使这些对象位于不同表单中，行为也可能无法正常工作。

下面解释的是两种表单特定的行为。有关其他行为的信息，请参见使用 JavaScript 行为。

“验证表单”检查指定文本域中的内容，以确保用户输入了正确类型的数据。（请参见检查表单。）

“设置文本域文字”将指定文本域中的内容替换为您所指定的内容。（请参见设置文本域文本。）


创建动态表单对象

可以创建动态 HTML 表单，以便既显示来自数据库的记录，也收集用户提供的信息。例如，表单可以显示从数据库表中检索到的供应商联系信息。

动态表单可以简化站点维护工作。例如，许多站点使用 HTML 表单菜单使用户能够跳转到该站点的其他区域。通常，这类菜单会在站点的多个地方出现。如果菜单是动态的，则可以向数据库表中添加一次新菜单项来更新站点上的所有菜单。

列表/菜单是常见的动态表单对象。还可以创建和使用动态单选按钮、复选框、文本域和图像域。

本节描述如何使表单对象成为动态对象。

备注： Dreamweaver MX 不为 ASP.NET 提供下列动态表单对象：动态文本域、动态复选框、动态列表/菜单或者动态单选按钮组。


创建动态列表/菜单

可以用数据库中的项动态地填充列表或菜单表单对象。

若要添加动态列表/菜单：
  1. 在页面上的 HTML 表单内单击。
  2. 选择“插入”>“表单对象”>“列表/菜单”

    3. Dreamweaver 在页面中插入一个“列表/菜单”表单对象。

  3. 选择该“列表/菜单”表单对象。

    4. 出现“列表/菜单”属性检查器。
    这是所描述的功能的图片。

  4. 在“列表/菜单”属性检查器中，单击“动态”按钮显示“动态列表/菜单”对话框。完成该对话框，然后单击“确定”。
    这是所描述的功能的图片。

    5. 有关完成“动态列表/菜单”对话框域设置的说明，请参见设置“动态列表/菜单”对话框选项。

  5. 单击“确定”。

    6. Dreamweaver 在 HTML 表单中插入动态列表/菜单。可以使用“服务器行为”面板或属性检查器编辑该菜单，或者可直接编辑该菜单的源代码。


使现有列表/菜单成为动态的

可以使现有的列表/菜单表单成为动态的。

若要使现有列表/菜单成为动态的：
  1. 选择要使之为动态对象的列表/菜单表单对象。
  2. 在属性检查器中，单击“动态”按钮。

    3. 出现“动态列表/菜单”对话框。

  3. 完成该对话框，然后单击“确定”。

    4. 有关完成“动态列表/菜单”对话框域设置的说明，请参见设置“动态列表/菜单”对话框选项。


使文本域和图像域成为动态的

可以使表单上的文本域和图像域成为动态的。

若要使文本域成为动态的：
  1. 选择页面上 HTML 表单中的文本域。
  2. 选择“窗口”>“服务器行为”以显示“服务器行为”面板。
  3. 单击加号 (+) 按钮，然后从弹出式菜单中选择“动态元素”>“动态文本域”。

    4. 出现“动态文本域”对话框。

  4. 完成该对话框，然后单击“确定”。

    5. 有关说明，请参见设置“动态文本域”对话框选项。

当在浏览器中查看该表单时，该文本域将显示动态内容。

若要使图像域成为动态的：
  1. 将插入点放在页面上希望显示图像域的地方，然后选择“插入”>“表单对象”>“图像域”。

    2. 出现“选择图像源文件”对话框。

  2. 单击“数据源”选项（在 Windows 中）或“数据源”按钮（在 Macintosh 中）。

    3. 出现数据源列表。

  3. 从该列表中选择一个数据源。

    4. 数据源应该是包含到图像文件路径的记录集。根据站点的文件结构，路径可以是绝对路径、文档相对路径或根目录相对路径。

    备注： Dreamweaver 当前不支持存储在数据库中的二进制图像。

    如果列表中没有出现任何记录集，或者可用记录集都不满足您的要求，请定义新的记录集。有关说明，请参见定义记录集。

  4. 单击“确定”。

当在浏览器中查看该表单时，图像域将显示动态选择的图像。


使复选框成为动态的

在表单中使用复选框可以允许用户从一列可用项中选择多个项。若要创建动态复选框，必须已经指定了动态文档类型，而且已经将记录集或其他动态内容源与该页面相关联。数据源必须为布尔形式，如 Yes/No 或者 true/false。

若要动态地预先选择某个复选框：
  1. 选择复选框表单对象。
  2. 在属性检查器中，单击“动态”按钮。

    3. 出现“动态复选框”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框，然后单击“确定”。

    4. 有关说明，请参见完成“动态复选框”对话框。

当在浏览器中查看该表单时，该复选框将显示为选中或未选中状态，这具体取决于数据。


使单选按钮成为动态的

可以根据记录集中的值动态地预先选择某个单选按钮。若要创建动态复选框，必须已经指定了动态文档类型，而且已经将记录集或其他动态内容源与该页面相关联。

若要动态地预先选择某个单选按钮：
  1. 确保页面至少有一组单选按钮。

    2. 可以通过选择“插入”栏的“表单”选项卡上的“单选按钮组”图标来创建一个单选按钮组。有关更多信息，请参见插入单选按钮。

  2. 在“服务器行为”面板中，单击加号 (+) 按钮，然后选择“动态表单元素”>“动态单选按钮组”。

    3. 出现“动态单选按钮组”对话框。所显示的对话框外观上可能与下面示例中所示的不同，这取决于所使用的文档类型。
    这是所描述的功能的图片。

  3. 完成该对话框，然后单击“确定”。

    4. 有关如何完成“动态单选按钮组”对话框的说明，请参见：

    设置“动态单选按钮组”对话框选项

    设置“动态单选按钮组”对话框选项：ColdFusion


参考资料

本节提供有关本章介绍的对话框的信息。


设置“单选按钮组”对话框选项

“单选按钮组”对话框创建一组在 HTML 表单中使用的单选按钮。

过程
  1. 在“名称”文本框中，输入该单选按钮组的名称。

    2. 如果希望这些单选按钮将参数传递回服务器，则这些参数将与该名称相关联。例如，如果将组命名为 myGroup，并将表单方法设置为 GET（即，希望当用户单击提交按钮时，表单传递 URL 参数而不是表单参数），则会在 URL 中将表达式 myGroup=”选中的值” 传递给服务器。

  2. 单击加号 (+) 按钮向组添加单选按钮。

    3. 如果需要，可以为新按钮输入标签和选定值。

  3. 单击向上或向下箭头重新排序这些按钮。
  4. 如果希望在浏览器中打开页面时，某特定单选按钮处于选中状态，请在“选取值等于”框中输入一个等于该单选按钮值的值。

    5. 可以输入静态值，或者通过单击该框旁边的闪电图标，然后选择包含可能选定值的记录集，来指定动态值。无论在何种情况下，所指定的值都应与组中单选按钮之一的选定值相匹配。若要查看单选按钮的选定值，请选择每个单选按钮，然后打开其属性检查器（“窗口”>“属性”）。

  5. 选择希望 Dreamweaver 如何布局这些按钮。

    6. Dreamweaver 可以使用换行符或表来设置这些按钮的布局。如果选择表选项，则 Dreamweaver 创建一个单列表，并将这些单选按钮放在左侧，将标签放在右侧。

  6. 单击“确定”。

Dreamweaver 在 HTML 表单中插入该单选按钮组。如果尚未在页面中插入表单，则 Dreamweaver 将为您插入一个。可以使用任何布局或格式设置工具精确调整该组的布局。

相关主题

插入单选按钮

使单选按钮成为动态的

定义记录集

了解表单参数

了解 URL 参数

使用 HTML 链接创建 URL 参数


设置“动态单选按钮组”对话框选项：ColdFusion

“动态单选按钮组”对话框使您可以根据记录集或其他动态内容源的值，预先选择组中单选按钮的值。

过程
  1. 从“单选按钮组”弹出式菜单中选择单选按钮组和表单。
  2. 单击“选取值等于”域旁边的闪电图标。

    3. 显示“动态数据”对话框。

  3. 从可用动态内容源列表中选择记录集或其他动态内容源。还可以使用格式化弹出式菜单格式化所选的数据项，并可以具体指定要用于页面内该数据占位符的标签。
  4. 单击“确定”关闭“动态数据”对话框。
  5. 单击“确定”关闭“动态单选按钮组”对话框，并在“单选按钮组”中插入动态内容占位符。

相关主题

使单选按钮成为动态的

定义记录集

了解表单参数

了解 URL 参数


设置“动态单选按钮组”对话框选项

“动态单选按钮组”对话框使您可以在显示页面时，或者在 HTML 表单中显示记录时，动态地预先选择按钮组中的某个单选按钮。

过程
  1. 在“单选按钮组”弹出式菜单中，选择页面中的表单和单选按钮组。

    2. “单选按钮值”域将显示该组内所有单选按钮的值。

  2. 从显示的值列表中选择要动态预先选择的值。该值将显示在“值”域中。
  3. 单击“选取值等于”框旁边的闪电图标，然后选择包含该组中单选按钮的可能选定值的记录集。

    4. 所选的记录集应包含与单选按钮的选定值匹配的值。若要查看单选按钮的选定值，请选择每个单选按钮，然后打开其属性检查器（“窗口”>“属性”）。

  4. 单击“确定”。

相关主题

使单选按钮成为动态的

插入单选按钮

定义记录集

了解表单参数

了解 URL 参数

使用 HTML 链接创建 URL 参数


设置“动态文本域”对话框选项

“动态文本域”对话框创建动态文本域。

过程
  1. 从“文本域”弹出式菜单中选择要设置为动态对象的文本域。
  2. 单击“将值设置为”框旁边的闪电图标，然后从数据源列表中选择一个数据源。

    3. 该数据源应包含文本信息。如果列表中没有出现任何数据源，或者可用的数据源不满足要求，请单击加号 (+) 按钮定义新的数据源。有关说明，请参见了解动态内容源。

  3. 单击“确定”。
相关主题

使文本域和图像域成为动态的

设置“文本域”属性检查器

定义记录集

了解表单参数

了解 URL 参数

使用 HTML 链接创建 URL 参数


完成“动态复选框”对话框

此对话框允许您基于布尔值预先选择某复选框。

过程
  1. 如果希望在记录中的域等于某个特定值时复选框处于选中状态，请执行下列操作：
    • 单击“选取，如果：”框旁边的闪电图标，然后从数据源列表中选择该域。

      • 该数据源必须包含布尔数据，如 Yes 和 No，或者 true 和 false。如果列表中没有出现任何数据源，或者可用的数据源不满足要求，请单击加号 (+) 按钮定义新的数据源。有关说明，请参见了解动态内容源。

    • 在“等于”框中，输入一个值，如果要使该复选框显示为选中状态，则该域必须包含此值。

      • 例如，如果希望在记录中的特定域等于 Yes 时，该复选框显示为选中状态，请在“等于”框中输入 Yes。

      备注： 在用户单击表单的“提交”按钮时，这个值也会返回到服务器。

  2. 单击“确定”。

相关主题

使复选框成为动态的

插入复选框


设置“动态列表/菜单”对话框选项

“动态列表/菜单”对话框允许您用数据库或其他内容源的内容填充列表/菜单表单对象。

过程
  1. 在“菜单”弹出式菜单中，选择要使之成为动态对象的列表/菜单表单对象。
  2. 在“来自记录集的选项”弹出式菜单中，选择要用作内容源的记录集。该域还允许您以后编辑静态和动态列表/菜单项。
  3. “静态选项”域允许您在列表或菜单中输入默认项。对话框的这一部分还允许您在添加动态内容后编辑列表/菜单表单对象中的静态项。

    4. 使用加号 (+) 和减号 () 按钮在列表中添加和删除项。项的顺序与“初始列表值”对话框中的顺序相同。在浏览器中载入页面时，列表中的第一个项是选中项。使用向上或向下箭头按钮重新排列列表中的项。

  4. 在“值”弹出式菜单中，选择包含菜单项值的域。
  5. 在“标签文字”弹出式菜单中，选择包含菜单项标签文字的域。
  6. 如果希望在浏览器中打开页面或者在表单中显示记录时，某个特定菜单项处于选中状态，请在“选取值等于”框中输入一个等于该菜单项的值的值。

    7. 可以输入静态值，或者可通过单击该框旁边的闪电图标，然后从数据源列表中选择动态值来指定动态值。无论在何种情况下，所指定的值都应该与菜单项值之一匹配。

  7. 单击“确定”。

相关主题

添加列表和菜单

创建动态列表/菜单

使现有列表/菜单成为动态的

定义记录集

了解表单参数

了解 URL 参数

使用 HTML 链接创建 URL 参数


设置“文本域”属性检查器

若要在属性检查器中显示文本域属性，请在表单中选择一个文本域。另请参见“创建文本域” 在第 993。

“文本域”分配域的名称。每个文本域都必须有一个唯一名称。

“字符宽度”设置域中最多可显示的字符数。此数字可以小于“最大字符数”，“最大字符数”指定在域中最多可输入的字符数。

“最大字符数/行数”对于单行文本域，设置在域中最多可输入的字符数；对于多行文本域，设置域的高度。使用“最大字符数”将邮政编码限制为 5 位数，将密码限制为 10 个字符，等等。

“类型”指定域为单行、多行还是密码域。

  • 选择“单行”将产生 type 属性设置为 text 的 input 标签。“字符宽度”设置映射为 size 属性，“最大字符数”设置映射为 maxlength 属性。
  • 选择“密码”将产生 type 属性设置为 password 的 input 标签。“字符宽度”和“最大字符数”设置映射为的属性与在单行文本域中的属性相同。当用户在密码文本域中键入时，输入内容显示为项目符号或星号，以保护它不被其他人看到。
  • 选择“多行”将产生 textarea 标签。“字符宽度”设置映射为 cols 属性，“行数”设置映射为 rows 属性。

“初始值”指定在首次载入表单时域中显示的值。


设置“列表/菜单属性”检查器选项

若要在属性检查器中显示列表/菜单属性，请在表单中选择一个列表或弹出式菜单。另请参见“添加列表和菜单” 在第 1001。

“列表/菜单”分配列表或菜单的名称。此域是必需的，而且名称必须是唯一的。

“类型”指示该对象是弹出式菜单还是滚动列表。对于列表，可设置高度（一次可显示的项数），并指示用户是否可从列表中选择多个项。

“列表值”打开“初始列表值”对话框，以便可向列表或弹出式菜单中添加项。列表中的每项都有一个标签（在列表中显示的文本）和一个值（选中该项时，发送给处理应用程序的值）。如果没有指定值，则将标签文字发送给处理应用程序。

使用加号 (+) 和减号 () 按钮在列表中添加和删除项。项的顺序与“初始列表值”对话框中的顺序相同。在浏览器中载入页面时，列表中的第一个项是选中项。使用向上或向下箭头按钮重新排列列表中的项。


设置“列表/菜单”对话框选项

“初始列表值”对话框使您可以向列表或弹出式菜单中添加项。列表中的每项都有一个标签（在列表中显示的文本）和一个值（选中该项时，发送给处理应用程序的值）。如果没有指定值，则将标签文字发送给处理应用程序。

使用加号 (+) 和减号 () 按钮在列表中添加和删除项。项的顺序与“初始列表值”对话框中的顺序相同。在浏览器中载入页面时，列表中的第一个项是选中项。使用向上或向下箭头按钮重新排列列表中的项。


在属性检查器中设置“按钮”属性选项

“按钮名称”分配按钮的名称。“提交”和“重置”是两个保留名称，“提交”通知表单将表单数据提交给处理应用程序或脚本，“重置”将所有表单域重置为其原始值。

“标签文字”确定按钮上显示的文本。

“操作”确定单击该按钮时发生的操作。可以将按钮设计为清除它所在表单的内容、提交表单的内容或者什么都不做。选择“提交表单”会自动将按钮的名称设置为“提交”。选择“重置表单”会自动将按钮的名称设置为“重置”。“无”表示当单击该按钮时，既不会发生提交操作，也不会发生重置操作。


更正未知的输入类型

当 Dreamweaver 遇到不可识别的输入类型时，出现“输入名称属性”检查器。通常由于出现键入错误或其他数据输入错误，才会出现这种情况。

如果在属性检查器中将该域类型更改为 Dreamweaver 可识别的值，例如更正拼写错误后，属性检查器将更新以显示该可识别类型的属性。

“输入名称”分配域的名称。此域是必需的，而且名称必须是唯一的。

“类型”设置域的输入类型。此域的内容反映 HTML 源代码中当前出现的输入类型值。

“值”设置域的值。

“参数”打开“参数”对话框，以便可查看域的当前属性以及添加或移除属性。

上一页


迅速开发应用程序

Web 应用程序通常赋予页面一定的功能，例如使用户可以搜索数据库的页面，使用户可以插入、更新或删除数据库中的数据的页面，以及限制对某一 Web 站点的访问的页面。使用 Dreamweaver 可以迅速建立所有此类页面。

此部分包含以下各章：

  • 生成主/详细页
  • 生成搜索数据库的页面
  • 建立修改数据库的页
  • 生成对站点访问进行限制的页


生成主/详细页

使用 Macromedia Dreamweaver MX 可以创建以两个明细级别表示信息的页面集。本章以下各节描述如何生成主/详细页：

  • 关于主/详细页
  • 快速生成主/详细页
  • 逐块生成主/详细页
  • 修改主/详细页
下一页


关于主/详细页

主页是指列出了记录以及每条记录的相应链接的页面。当用户单击一个链接时，就会打开一个显示有关该记录的更多信息的详细页。例如，下面是一个虚构公司的 Intranet 站点主页：

当用户单击某个已链接的“查看”图标时，就会打开一个详细页：

结果页是一种常见类型的主页。不过，它与本节所描述的主页不同，因为结果页上的记录列表不是由您（设计人员）决定的，而是由用户决定的。（用户通过执行数据库搜索来决定记录列表。）有关此类主页的更多信息，请参见生成搜索数据库的页面。

详细页可用于更新或删除显示的记录。有关更新和删除页面的更多信息，请参见建立更新记录的页和建立删除记录的页。

主页是由下列块组成的：

  • 记录集
  • 显示多条记录的页面布局
  • “转到详细信息页”服务器行为，用于打开详细页并传递用户所单击记录的 ID

详细页是由下列块组成的：

  • 显示单个记录的页面布局
  • 保留记录的详细信息的记录集
  • 从数据库表中检索特定记录的记录集过滤器，或移动到记录集中特定记录的“移至特定记录”服务器行为。


快速生成主/详细页

使用主/详细页集应用程序对象可以快速生成主/详细页。

备注： PHP 和 ASP.NET 不支持此应用程序对象。

用应用程序对象完成主/详细页集：
  1. 创建一个空主页并向其中添加记录集。

    2. 确保该记录集不仅包含主页所需的所有列，还包含详细页所需的所有列。

    记录集可以由设计人员在设计时定义（请参见定义记录集），也可以由用户在运行时定义（请参见生成搜索数据库的页面）。

    通常，主页上的记录集提取数据库表格中的少数几列，而详细页上的记录集提取同一表格中的更多列以提供额外的详细信息。

  2. 在“设计”视图中打开主页，然后选择“插入”>“应用程序对象”>“主详细页集”。

    3. 随即出现“主详细页集”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“主详细页集”对话框选项。

  4. 单击“确定”。

    5. 应用程序对象将创建一个详细页（如果尚未创建），并且同时向主页和详细页中添加动态内容和服务器行为。

  5. 自定义主页和详细页的布局以符合需要。

    6. 使用 Macromedia Dreamweaver MX 页面设计工具可以完全地自定义每个页面的布局。还可以在“服务器行为”面板中双击服务器行为对其进行编辑。


逐块生成主/详细页

本节描述不使用“主/详细页集”应用程序对象如何生成主/详细页集。有关使用应用程序对象的说明，请参见快速生成主/详细页。

若要完成主/详细页集，需要完成下列任务：

  • 创建一个空主页并为其定义一个记录集。
  • 在主页上显示记录。
  • 将用户所选记录的 ID 传递到详细页。
  • 在数据库中查找记录并在详细页上显示该记录。


创建主页并为其定义记录集

第一步是创建一个空主页并向其中添加一个记录集。

记录集可以由设计人员在设计时定义（请参见定义记录集），也可以由用户在运行时定义（请参见生成搜索数据库的页面）。

确保该记录集不仅包含主页所需的所有列，还包含详细页所需的所有列。

通常，主页上的记录集提取数据库表格中的少数几列，而详细页上的记录集提取同一表格中的更多列以提供额外的详细信息。


在主页上显示记录

创建一个空主页并为其定义记录集后，必须在该页面上显示记录。

在主页上显示记录：
  1. 创建页面布局以显示多条记录，并把记录集列绑定到该页面。

    2. 普通的方法是：先在主页上创建一个两行的 HTML 表，然后将数目有限的记录集列从“绑定”面板（“窗口”>“绑定”）上拖动到该表的第二行中。（使用第一行显示表格的列标题。）

  2. 创建重复区域以同时显示多条记录。

    3. 重复区域通常应用于包含动态内容的表行。


打开详细页并将记录的 ID 传递给它

创建主页并在其中显示记录后，必须创建用于打开详细页并将用户所选记录的 ID 传递给它的链接。

PHP、ASP.NET 和 ColdFusion 用户必须使用 URL 参数在代码中创建一个链接。有关更多信息，请参见使用 HTML 链接创建 URL 参数。将锚记标签放置在想要用作链接的动态内容周围。

打开详细页，并将包含用户所单击记录的 ID 的 URL 参数传递给它（仅适用于 ASP 和 JSP 用户）：
  1. 在主页上的重复区域中，选择要兼作链接的动态内容。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，然后从弹出式菜单中选择“转到详细信息页”。

    3. “转到详细信息页”对话框随即出现。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“转到详细信息页”对话框选项。

  4. 单击“确定”。

    5. Dreamweaver 在所选文本周围放置一个特殊链接。当用户单击该链接时，“转到详细信息页”服务器行为将一个包含记录 ID 的 URL 参数传递到详细页。例如，如果 URL 参数的名称为 id，详细页的名称为 customerdetail.asp，则当用户单击该链接时，URL 看起来应该像下面这样：

    http://www.mysite.com/customerdetail.asp?id=43

    URL 的第一部分 http://www.mysite.com/customerdetail.asp 用于打开详细页。第二部分 ?id=43 是 URL 参数。它告诉详细页要查找和显示哪个记录。术语 id 是 URL 参数的名称，43 是它的值。在本例中，URL 参数包含记录的 ID 号，即 43。

    有关 URL 参数的更多信息，请参见了解 URL 参数。


查找请求的记录并在详细页上显示

完成主页后，必须在数据库中查找请求的记录并将其显示在详细页上。该过程由两个步骤组成：首先，定义一个记录集以保留单个记录（即主页请求的记录）；然后，将记录集列绑定到页面上。

查找请求的记录并在详细页上显示：
  1. 切换到详细页。
  2. 在“绑定”面板中，单击加号 (+) 按钮，然后从弹出式菜单中选择“记录集”或“数据集”(ASP.NET)。

    3. 随即出现简单对话框。如果出现的是高级对话框，请单击“简单”进行切换。

  3. 命名该记录集，然后选择一个连接和将向记录集提供数据的数据库表。
  4. 在“列”区域中，选择要包括在记录集中的表格列。

    5. 详细页上的记录集可以与主页上的记录集相同，也可以不同。通常，详细页记录集的列数更多，可以显示更多的详细信息。

    如果记录集不同，则详细页上的记录集至少应包含一个与主页上的记录集相同的列。这个公共列通常是记录 ID 列，但也可以是相关表格的连结域。

    若要在记录集中仅包括某些表列，请单击“选定的”，然后在列表中按住 Control 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 所需的列以将其选定。

  5. 如下所示完成“筛选”部分，以便查找和显示结果页所传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出式菜单中选择数据库表格中的列，该列包含与主页传递的 URL 参数值相匹配的值。

      • 例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。

    • 从第一个菜单旁边的弹出式菜单中选择等号（它应该已被选定）。
    • 从第三个弹出式菜单中选择 URL 参数。

      • 主页通过 URL 参数将标识用户所选内容的信息传递到详细页。

    • 在第四个文本框中，输入主页传递的 URL 参数的名称。

      • 例如，如果主页用于打开详细页的 URL 是 www.mysite.com/customerdetail.asp?id=43，则请输入 id。

      您还可以用下面的方法获得该名称：切换到主页，打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“转到详细信息页”服务器行为。检查“传递 URL 参数”的名称。

  6. 单击“确定”。

    7. 记录集随即出现在“绑定”面板中。

  7. 通过下面的方法将记录集列绑定到详细页：在“绑定”面板上选择列（“窗口”>“绑定”），然后将其拖到页面上。


修改主/详细页

用服务器行为创建主/详细页后，请使用“服务器行为”面板修改页面上的各种生成块。有关更多信息，请参见编辑服务器行为。

如果用应用程序对象创建了页面，则还必须使用“服务器行为”面板编辑应用程序对象插入到页面中的生成块。应用程序对象将下列生成块添加到主页中：

  • 基本表格，其中包含重复区域以显示多条记录
  • 记录集导航条
  • 记录计数器
  • “转到详细信息页”服务器行为，用于打开详细页并传递用户所单击记录的 ID

应用程序对象还将下列生成块添加到详细页中：

  • 基本表格，用于显示单个记录
  • 已过滤的记录集，用于查找和显示用户在主页上单击的记录


设置“主详细页集”对话框选项

此对话框用于创建主页和相应的详细页。

过程
  1. 在“记录集”弹出式菜单中，确保已选择了包含要在主页上显示的记录的记录集。
  2. 在“主页域”区域，选择要在主页上显示的记录集列。

    3. 默认情况下，Dreamweaver 选择记录集中的所有列。如果记录集包含唯一键列，如 recordID，则将其选定并单击减号 (-) 按钮使之不在页面上显示。

  3. 若要更改列在主页上的显示顺序，请选择列表中的列并单击向上或向下箭头。

    4. 在主页上，记录集列会在表格中水平排列。单击向上箭头可将列向左移动；单击向下箭头可将列向右移动。

  4. 在“以此链接到详细页”下拉式菜单中，选择记录集中的一个列，该列将显示一个值并且该值也用作到详细页的链接。

    5. 例如，如果要使主页上的每个产品名称都有一个到详细页的链接，请选择包含产品名称的记录集列。

  5. 在“传递唯一键”弹出式菜单中，选择记录集中包含标识记录的值的列。

    6. 通常，所选的列就是记录 ID 号。此值被传递到详细页使之能够标识用户所选的记录。

  6. 如果唯一键列不是数值，请取消选择“数值”复选框。

    7. 备注： 默认情况下选择此选项；并非所有型号的服务器都显示该选项。

  7. 指定要在主页上显示的记录数。
  8. 在“详细页名称”框中，单击“浏览”并定位已创建的详细页文件，或输入一个名称让应用程序对象为您创建一个详细页文件。
  9. 在“详细页域”区域，选择要在详细页上显示的列。

    10. 默认情况下，Dreamweaver 选择主页记录集中的所有列。如果该记录集包含唯一键列，如 recordID，则将其选定并单击减号 (-) 按钮使之不在详细页上显示。

  10. 若要更改列在详细页上的出现顺序，请选择列表中的列并单击向上或向下箭头。

    11. 在详细页上，记录集列会在表格中垂直排列。单击向上箭头可将列向上移动；单击向下箭头可将列向下移动。

  11. 单击“确定”。

    12. 应用程序对象将创建一个详细页（如果尚未创建），并且同时向主页和详细页中添加动态内容和服务器行为。

相关主题

快速生成主/详细页


设置“转到详细信息页”对话框选项

此对话框用于创建一个链接（该链接可以打开一个详细页并传递一个记录 ID），以便可以找到所需的记录并将其在详细页上显示。

过程
  1. 在“详细信息页”框中，单击“浏览”并定位详细页。
  2. 从“记录集”和“列”弹出式菜单中选择记录集和列，以指定要传递到详细页的值。

    3. 通常，该值对于记录是唯一的，如记录的唯一键 ID。

  3. 如果需要，可选择“URL 参数”或“表单参数”选项将现有的页面参数传递到详细页。
  4. 单击“确定”。

Dreamweaver 将在该页面中插入一个特殊链接。当用户单击该链接时，一个包含记录 ID 的 URL 参数将被传递到详细页。

相关主题

打开详细页并将记录的 ID 传递给它

查找请求的记录并在详细页上显示

逐块生成主/详细页

上一页


生成搜索数据库的页面

可以使用 Macromedia Dreamweaver MX 生成一组页面，使用户可以搜索您的数据库。

本章包含以下几节：

  • 创建搜索页
  • 生成结果页
  • 创建结果页的详细页
  • 使用相关页（仅适用于 ASP 和 JSP 用户）
下一页


关于搜索/结果页

至少需要两个页面才能将此功能添加到 Web 应用程序。第一个页面包含用户可以在其中输入搜索参数的 HTML 表单。尽管该页并不执行任何实际的操作，但它被称为“搜索页”。

所需要的第二个页面是结果页，它是页集中担负主要工作的页。结果页执行下列任务：

  • 读取搜索页提交的搜索参数
  • 连接到数据库并查找记录
  • 生成含有找到的记录的记录集
  • 显示记录集的内容

或者，您还可以添加详细页。详细页为用户提供有关结果页上的特定记录的更多信息。

如果只有一个搜索参数，Dreamweaver 会让您将搜索功能添加到 Web 应用程序，而不必使用 SQL 查询和变量。可以简单地设计页面并完成几个对话框。如果您有多个搜索参数，则需要编写一条 SQL 语句并为其定义多个变量。


创建搜索页

Web 上的搜索页通常包含用户在其中输入搜索参数的表单域。用户单击表单的“搜索”按钮时，搜索参数即发送到服务器上的结果页。由服务器上的结果页（而不是浏览器上的搜索页）负责从数据库检索记录。

若要开始完成您的 Web 应用程序的这个部分，请创建两个页面：搜索页和结果页 - 前者使用户可以输入搜索参数，后者显示找到的记录。甚至可以将二者合并成一个页面。搜索页最低限度必须具有一个带有“提交”按钮的 HTML 表单。

将 HTML 表单添加到搜索页：
  1. 打开搜索页，并从“插入”菜单中选择“表单”。

    2. 将在页面上创建一个空表单。可能必须启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）才可看到表单的边界，边界是用细红线表示的。

  2. 从“插入”菜单中选择“表单对象”，为用户添加用以输入搜索参数的表单对象。

    3. 表单对象包含文本域、列表/菜单、复选框和单选按钮。可以添加任意多的表单对象以帮助用户细化搜索操作。但是请记住，搜索页上搜索参数的数目越多，SQL 语句就将越复杂。

    有关表单对象的更多信息，请参见创建交互式表单。

  3. 在表单上添加一个“提交”按钮（“插入”>“表单对象”>“按钮”）。
  4. 如果您愿意，可以通过以下方法更改“提交”按钮的标签文字：选择该按钮，打开属性检查器（“窗口”>“属性”），并在“标签文字”框中输入一个新值。

    5. 例如，下面是一个标签文字为“搜索”的按钮的属性检查器：
    这是所描述的功能的图片。

    下一步，您将告诉表单当用户单击“提交”按钮时向何处发送搜索参数。

  5. 通过在文档窗口底部的标签选择器中选择 <form> 标记来选择表单，如下所示：
    这是所描述的功能的图片。
  6. 在该表单的属性检查器上的“动作”框中，输入将实施数据库搜索的结果页的文件名。
  7. 在“方法”弹出式菜单中，选择下列方法之一确定表单如何将数据发送到服务器：
    • “GET”通过将表单数据作为查询字符串附加到 URL 来发送这些数据。由于 URL 的长度限制为 8192 个字符，因此不要将 GET 方法用于很长的表单。
    • “POST”在消息体中发送表单数据。
    • “默认”使用浏览器的默认方法（通常为 GET）。

搜索页就完成了。下一步将完成结果页。请参见生成结果页。


生成结果页

用户输入搜索参数后，应用程序必须从数据库中检索记录。此工作是由结果页完成的。

下面是结果页的工作：

  • 从搜索页获取搜索参数。
  • 连接到数据库并查找记录。
  • 使用找到的记录生成记录集。
  • 显示记录集的内容。

如果搜索页只有一个搜索参数（例如只有一个文本域），则无需 SQL 查询和变量即可生成结果页。只需创建一个基本的记录集，然后在其中添加过滤器，以便排除不能满足搜索页所发送的搜索参数的记录。有关说明，请参见只使用一个搜索参数进行搜索。

如果搜索页包含多个搜索参数，则需要编写一个 SQL 语句并为其定义多个变量。有关说明，请参见使用多个搜索参数进行搜索。


只使用一个搜索参数进行搜索

如果搜索页只向服务器提交一个搜索参数，那么您无需 SQL 查询和变量即可生成结果页。可以创建一个具有过滤器的基本记录集，该过滤器能够排除不能满足搜索页所提交的搜索参数的记录。

备注： 如果具有多个搜索条件，则必须使用高级“记录集”对话框定义记录集。简单的“记录集”对话框只支持一个搜索条件。有关更多信息，请参见使用多个搜索参数进行搜索。

创建保留搜索结果的记录集：
  1. 在文档窗口中打开结果页。
  2. 通过下列方法创建一个新记录集：打开“绑定”面板（“窗口”>“绑定”），单击加号 (+) 按钮，并从弹出式菜单中选择“记录集”或“数据集”(ASP.NET)。
  3. 确保出现简单的“记录集”或“数据集”对话框。
    这是所描述的功能的图片。

    4. 如果出现的是高级对话框，则通过单击“简单”按钮切换到简单对话框。

  4. 输入记录集的名称并选择一个连接。

    5. 应该连接到包含希望用户搜索的数据的数据库。

  5. 在“表格”弹出式菜单中，选择要在数据库中搜索的表。

    6. 备注： 在单参数搜索中，可以只在一个表格中查找记录。若要同时搜索多个表，必须使用高级的“记录集”对话框并定义一个 SQL 查询。

  6. 若要只在记录集中包含某些表格列，请单击“选定的”，然后通过在列表中按住 Control 键并单击 (Windows) 或按住 Command 键并单击 (Macintosh) 所需列来选择它们。

    7. 选择那些包含要在结果页中显示的信息的列。

暂时使“记录集”或“数据集”对话框保持打开状态。下一步将使用该对话框获取搜索页发送的参数，并创建一个记录集过滤器以排除不满足参数的记录。

创建记录集过滤器：
  1. 从“筛选”区域中的第一个弹出式菜单中，选择要与搜索页发送的搜索参数进行比较的表中的列。

    2. 例如，如果搜索页发送的值是城市名，则在包含城市名的表中选择列。

  2. 从第一个菜单旁边的弹出式菜单中，选择等号（它应该为默认值）。

    3. 此选择声明用户只需要这样的记录：在这些记录中，选定的表格列与搜索页中指定的列完全相同。

  3. 从第三个弹出式菜单中，选择“表单变量”（如果搜索页上的表单使用 POST 方法），或者选择“URL 参数”（如果搜索页上的表单使用 GET 方法）。

    4. 此弹出式菜单指定搜索页发送的值当前存储在服务器的什么位置。在 ASP 中，如果搜索表单使用 POST 方法，则该值存储在 Request.Form 集合中。如果搜索表单使用 GET 方法，则该值存储在 Request.QueryString 集合中。

  4. 在第四个框中，输入接受搜索页上的搜索参数的表单对象的名称。

    5. 可以通过下面的方法获取此名称：切换到搜索页，单击表单上的表单对象以选择它，并在属性检查器中检查对象的名称。

    例如，假设您希望创建一个只包括到特定国家的探险旅程的记录集。假设表中有一个称为 TRIPLOCATION 的列。另外还假设搜索页上的 HTML 表单使用 GET 方法并包含一个称为 Location 的菜单/列表对象（它显示国家/地区列表）。您的“筛选”部分应如下所示：
    这是所描述的功能的图片。

  5. 如果需要，请单击“测试”，输入一个测试值，然后单击“确定”连接到数据库并创建一个记录集实例。

    6. 测试值模拟本来应由搜索页返回的值。单击“确定”关闭记录集。

  6. 如果您对该记录集感到满意，则单击“确定”。

Dreamweaver 在页面中插入一个服务器端脚本，该脚本在服务器上运行，它检查数据库表格中的每个记录。如果记录中的指定域满足过滤条件，则将该记录包含在记录集中。有效的脚本将生成一个只包含搜索结果的记录集。

下一步是在结果页上显示记录集。有关更多信息，请参见显示记录。


使用多个搜索参数进行搜索

如果搜索页向服务器提交多个搜索参数，则必须为结果页编写一个 SQL 查询并在 SQL 变量中使用搜索参数。

Dreamweaver 将该 SQL 查询插入到页面中并且在服务器上运行该页后，将检查数据库表格中的每个记录。如果记录中的指定域满足 SQL 查询条件，则将该记录包含在记录集中。有效的 SQL 查询将生成一个只包含搜索结果的记录集。

例如，现场销售人员可能知道某个区域中哪些客户的收入超过某一水平。在搜索页上的表单中，销售伙伴输入一个地理区域和最低收入水平，然后单击“提交”按钮将这两个值发送到服务器。在服务器上，这两个值被传递给结果页的 SQL 语句，然后该语句创建一个记录集，其中只包含指定区域中收入超过指定水平的客户。

使用 SQL 在数据库中查找记录：
  1. 在 Dreamweaver 中打开结果页，然后通过下面的方法创建一个新记录集：打开“绑定”面板（“窗口”>“绑定”），单击加号 (+) 按钮，然后从弹出式菜单中选择“记录集”或“数据集”(ASP.NET)。
  2. 确保出现高级“记录集”或“数据集”对话框。
    这是所描述的功能的图片。

    3. 如果出现的是简单对话框，则请通过单击“高级”按钮切换到高级对话框。

  3. 输入记录集的名称并选择一个连接。

    4. 应该连接到包含希望用户搜索的数据的数据库。

  4. 在 SQL 文本区域中输入一条 Select 语句。

    5. 确保该语句包含一个 Where 子句，并且该子句的变量中含有搜索参数。在下面的范例中，变量称为 varLastName 和 varDept：

    SELECT EMPLOYEEID, FIRSTNAME, LASTNAME, DEPARTMENT, EXTENSION
FROM EMPLOYEE WHERE LASTNAME LIKE 'varLastName' AND DEPARTMENT
LIKE 'varDept'

若要减少键入量，可以使用高级“记录集”对话框底部的数据库项树。有关说明，请参见通过编写 SQL 来创建高级记录集。

有关 SQL 语法的帮助，请参见SQL 入门。
  5. 通过单击“变量”区域中的加号 (+) 按钮并输入变量名、默认值（没有运行时值返回时变量应采用的值）和运行时值（通常为含有浏览器发送的值的服务器对象，如请求变量），将搜索参数的值赋给 SQL 变量。

    6. 在下面的 ASP 范例中，搜索页上的 HTML 表单使用 GET 方法并包含一个称为“LastName”的文本域和一个称为“Department”的文本域。
    这是所描述的功能的图片。

    在 Macromedia ColdFusion 中，运行时值将为 #LastName# 和 #Department#。在 JSP 中，运行时值将为 request.getParameter("LastName") 和 request.getParameter("Department")。

  6. 如果需要，请单击“测试”使用默认的变量值创建一个记录集实例。

    7. 默认值模拟本来应由搜索页返回的值。单击“确定”关闭测试记录集。

  7. 如果您对该记录集感到满意，则单击“确定”。


显示记录

创建记录集以保留搜索结果后，您可能希望在结果页上显示这些信息。显示记录只是将单个列从“绑定”面板拖动到结果页上。可以添加导航链接以便在记录集中向前和向后移动，或者可以创建重复区域在页面上显示多条记录。还可以将链接添加到详细页。

有关显示页面动态内容的更多信息，请参见：

  • 创建结果页的详细页
  • 向 Web 页中添加动态内容
  • 显示数据库记录


创建结果页的详细页

您的搜索页集合可包括一个详细页，以显示有关结果页上的特定记录的更多信息。在结果页上，通常在重复区域显示记录，而且每个记录都有一个链接。当用户单击某个链接时，详细页将打开并显示有关所选记录的更多信息。

本节包含以下主题：

修改结果页以使用详细页

使用服务器行为生成详细页（仅适用于 ASP 和 JSP 用户）

使用过滤后的记录集生成详细页


修改结果页以使用详细页

结果页应具有一个重复区域，以便同时显示多条记录，而且重复区域中的每条记录都应具有到详细页的链接。该链接不仅必须打开详细页，还必须告知详细页用户选择了哪条记录。“转到详细信息页”服务器行为能够创建这种链接（仅适用于 ASP 和 JSP 用户）。

PHP、ASP.NET 和 ColdFusion 用户必须使用 URL 参数在代码中创建一个链接。有关更多信息，请参见使用 HTML 链接创建 URL 参数。

修改结果页以使用详细页（仅适用于 ASP 和 JSP 用户）：
  1. 创建一个空的详细页（“文件”>“新建”）并命名该文件。

    2. 暂时将该页面放在一边，以后会继续处理它。

  2. 在 Dreamweaver 中打开结果页。
  3. 确保结果显示在重复区域中。

    4. 有关说明，请参见显示多个行为。

  4. 在重复区域中，选择要兼作链接的文本或图像。

    5. 如果您正在“活动数据”窗口中工作，则在显示的第一个区域中选择文本或图像。

    备注： 所选的文本或图像可以是动态的。

  5. 通过下面的方法创建到详细页的链接：打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后从弹出式菜单中选择“转到详细信息页”。

    6. 出现“转到详细信息页”对话框。
    这是所描述的功能的图片。

  6. 完成该对话框。

    7. 有关更多信息，请参见设置“转到详细信息页”对话框选项。

  7. 单击“确定”。

结果页将值通过 URL 参数传递给详细页，该参数只是一个变量，它被追加到用于打开详细页的 URL 的末尾。例如，如果 URL 参数称为 id，详细页称为 customerdetail.asp，则当用户单击链接时，URL 看起来应该像下面这样：

http://www.mysite.com/customerdetail.asp?id=43

URL 的第一部分 http://www.mysite.com/customerdetail.asp 用于打开详细页。第二部分 ?id=43 就是 URL 参数。它告知详细页要查找并显示哪条记录。术语 id 是 URL 参数的名称，而 43 是它的值。在本例中，URL 参数包含记录的 ID 号，即 43。


使用服务器行为生成详细页（仅适用于 ASP 和 JSP 用户）

修改结果页以便使用详细页后，请完成详细页。可以结合使用常规记录集和服务器行为来生成详细页，或者可以只使用过滤后的记录集生成详细页。本节描述如何生成第一种详细页（仅适用于 ASP 和 JSP 用户）。若要学习如何生成第二种详细页，请参见使用过滤后的记录集生成详细页。

第一步，使用 Dreamweaver 设计工具布置详细页。有关更多信息，请参见生成主/详细页。

第二步，为页面定义一个记录集，或者从结果页拷贝和粘贴记录集。详细页将从此记录集中提取记录的详细信息。有关说明，请参见定义记录集和将记录集从一个页面拷贝到另一个页面。

第三步，将记录集列绑定到该页面。在“绑定”面板中（“窗口”>“绑定”），选择记录集中的列并将其拖到页面上。

第四步，添加服务器行为，读取结果页传递的 URL 参数中的记录 ID 并检索记录。如果省略该步骤，服务器将检索记录集中的第一条记录。

使用服务器行为检索特定记录（仅适用于 ASP 和 JSP 用户）：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）中，单击加号 (+) 按钮，从弹出式菜单中选择“移至记录”，然后选择“移至特定记录”。

    2. 出现“移至特定记录”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关更多信息，请参见设置“移至特定记录”对话框选项。

  3. 单击“确定”。

浏览器下次请求该页面时，该页将读取浏览器所传递的 URL 参数中的记录 ID，并移动到记录集中的指定记录。


使用过滤后的记录集生成详细页

另一种生成详细页的方法是过滤记录集，以便只留下一条记录 - 即用户在结果页上选择的记录。此方法可以提高应用程序的性能，原因是记录集只包含一条记录。

第一步，使用 Dreamweaver 设计工具布置页面。有关更多信息，请参见生成主/详细页。

第二步，为页面定义一个记录集，或者从结果页拷贝和粘贴记录集。详细页将从此记录集中提取记录的详细信息。有关说明，请参见定义记录集和将记录集从一个页面拷贝到另一个页面。

第三步，创建一个记录集过滤器以检索在结果页上指定的记录。如果您使用简单的“记录集”对话框创建一个记录集，则可以使用“筛选”框创建过滤器。如果使用高级“记录集”对话框，则可以修改 SQL 查询以创建过滤器。

使用记录集过滤器检索特定记录：
  1. 确保详细页包含记录集。
  2. 通过在“绑定”面板（“窗口”>“绑定”）中双击记录集的名称来打开记录集。
  3. 确保出现简单的“记录集”或“数据集”对话框。

    4. 如果出现的是高级对话框，则通过单击“简单”切换到简单对话框。如果 Dreamweaver 通知您无法切换（通常是由于您的查询太复杂，以至于无法在简单对话框中显示），则您必须使用 SQL 查询查找记录；请跳到本节的下一个过程。

  4. 如下所示完成“筛选”部分，以查找和显示在结果页传递的 URL 参数中指定的记录：
    • 从“筛选”区域的第一个弹出式菜单中，选择数据库表格中的列，该列包含与结果页传递的 URL 参数值相匹配的值。

      • 例如，如果 URL 参数包含一个记录 ID 号，则选择包含记录 ID 号的列。

    • 从第一个菜单旁边的弹出式菜单中，选择等于号（它应该已被选定）。
    • 从第三个弹出式菜单中，选择“URL 参数”。

      • 结果页通过 URL 参数将标识用户所选内容的信息传递到详细页。

    • 在第四个文本框中，输入结果页传递的 URL 参数的名称。

      • 例如，如果结果页用来打开详细页的 URL 是 www.mysite.com/customerdetail.asp?id=43，则输入 id。

      如果使用了结果页上的“转到详细信息页”服务器行为，则还可以通过下面的方法获取该名称：切换到结果页，打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“转到详细信息页”服务器行为。检查“传递 URL 参数”名称。

  5. 单击“确定”。
  6. 如果尚未完成，则通过下面的方法将记录集列绑定到页面：在“绑定”面板（“窗口”>“绑定”）中选择列并将其拖动到页面上。
使用 SQL 查询检索特定记录：
  1. 确保详细页包含记录集。
  2. 通过在“绑定”面板（“窗口”>“绑定”）中双击记录集的名称来打开记录集。
  3. 确保出现高级“记录集”对话框。

    4. 如果出现的是简单的“记录集”对话框，则通过单击“高级”按钮切换到高级“记录集”对话框。

  4. 在 SQL 语句中添加一条 Where 子句以查找用户在结果页上选择的记录。

    5. Where 子句应包含一个变量以保留在 URL 参数中传递的值。在下面的范例中，变量称为 varDept：

    SELECT * FROM EMPLOYEES
WHERE DEPARTMENT = 'varDept'

有关 SQL 语法的帮助，请参见第1115页的“SQL 入门”。
  5. 可以通过下面的方法将结果页在 URL 参数中传递的值赋予变量：单击“变量”区域中的加号 (+) 按钮并输入变量名称、默认值（在未返回任何运行时值的情况下变量应采用的值）和运行时值。

    6. 在下面的 ASP 范例中，结果页传递一个称为 Department 的 URL 参数。
    这是所描述的功能的图片。

  6. 单击“确定”。
  7. 如果尚未完成，则通过下面的方法将记录集列绑定到页面：在“绑定”面板（“窗口”>“绑定”）中选择列并将其拖动到页面上。


使用相关页（仅适用于 ASP 和 JSP 用户）

在某些情况下，可能希望显示一个既不是搜索页、结果页，也不是详细页的页面，但又不希望丢失页面已经从 HTML 表单或 URL 参数接收的信息。请不要使用标准链接来打开相关页，而改用“转到相关页”服务器行为创建链接。生成的链接打开相关页，并将现有参数传递到该页。例如，可以将搜索参数从一个页面传递到另一个页面，从而使用户不必再次输入搜索参数。

备注： 此服务器行为只适用于 ASP 和 JSP 页。

在向页面添加“转到相关页”服务器行为之前，请确保该页接收来自 HTML 表单的参数（换句话说，表单的 ACTION 属性指定该页），或接收来自 URL 参数的参数（例如，当该页是另一个具有“转到相关页”服务器行为的页面的链接目标时）。

创建将现有表单参数传递到相关页的链接：
  1. 在该页上，选择用作到相关页的链接的文本字符串或图像。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击加号 (+) 按钮并从弹出式菜单中选择“转到相关页”。

    3. 随即出现“转到相关页”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“转到相关页”对话框选项。

  4. 单击“确定”。

当用户单击新链接时，该页面使用 URL 参数将参数传递到相关页。例如，假设有一个称为“lastname”的表单参数，相关页称为 special_offer.asp。当用户单击链接时，该 URL 应类似于以下内容：

http://www.mysite.com/special_offer.asp?lastname=Anderson

URL 的第一部分 http://www.mysite.com/special_offer.asp 用于打开相关页。第二部分 ?lastname=Anderson 是将原始表单参数传递到相关页的 URL 参数。


设置“移至特定记录”对话框选项

此对话框的目的是在记录集中查找特定记录。

过程
  1. 在“移至记录”弹出式菜单中，选择为详细页定义的记录集。
  2. 在“其中的列”弹出式菜单中，选择包含结果页所传递的值的列。

    3. 例如，如果结果页传递一个记录 ID 号，则选择包含记录 ID 号的列。

  3. 在“匹配 URL 参数”文本框中，输入结果页所传递的 URL 参数的名称。

    4. 例如，如果结果页用于打开详细页的 URL 是 www.mysite.com/customerdetail.asp?id=43，则在“匹配 URL 参数”文本框中输入 id。

    您还可以通过下面的方法获取该名称：切换到结果页，打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“转到详细信息页”服务器行为。检查“传递 URL 参数”名称。

  4. 单击“确定”。

相关主题

使用服务器行为生成详细页（仅适用于 ASP 和 JSP 用户）

设置“转到详细信息页”对话框选项

逐块生成主/详细页


设置“转到相关页”对话框选项

此对话框的目的是创建打开相关页并将现有参数传递到该页的链接。

在将“转到相关页”服务器行为添加到页面时，请确保该页从另一个页面接收表单或 URL 参数。服务器行为的工作是将这些参数传递到第三个页面。例如，可以将结果页接收的搜索参数传递到另一个页面，从而使用户不必再次输入搜索参数。

另外，可以在页面上选择用作到相关页的链接的文本或图像，或者可以将光标放在该页上而无须选择任何内容，Dreamweaver 将为您插入链接文本。

过程
  1. 在“相关页”框中，单击“浏览”并定位相关页文件。

    2. 如果当前页向自身提交数据，则输入当前页的文件名。

  2. 如果希望传递的参数被直接使用 GET 方法从 HTML 表单接收，或者列在该页的 URL 中，则请选择“URL 参数”选项。
  3. 如果希望传递的参数被直接使用 POST 方法从 HTML 表单接收，则请选择“表单参数”选项。
  4. 单击“确定”。

当单击新链接时，页面使用查询字符串将参数传递到相关页。

相关主题

使用相关页（仅适用于 ASP 和 JSP 用户）

了解表单参数

了解 URL 参数

上一页


建立修改数据库的页

Macromedia Dreamweaver MX 附带一组允许用户通过他们的 Web 浏览器添加、更新和删除记录的服务器行为。您还可以使用应用程序对象创建完全可操作的 HTML 表单来插入或更新记录。

本章包含以下几节：

  • 建立插入记录的页
  • 建立更新记录的页
  • 建立删除记录的页
  • 使用预存过程修改数据库
  • 使用 ASP 命令修改数据库
  • 使用 JSP 已准备语句修改数据库
下一页


建立插入记录的页

您的应用程序可以包含一个允许用户向数据库中插入新记录的页。例如，下面的页在一个雇员数据库中插入一个新记录：

插入页需要两个构造块：

  • 一个允许用户输入数据的 HTML 表单
  • 一个更新数据库的“插入记录”服务器行为

您可以使用“插入记录表单”应用程序对象通过单个操作添加这两个构造块，或者您可以使用 Dreamweaver 表单工具和“服务器行为”面板分别添加它们。

备注： 插入页一次只能包含一个记录编辑服务器行为。例如，您不能将“更新记录”或“删除记录”服务器行为添加到插入页。


快速建立插入页

您可以使用“插入记录表单”应用程序对象通过单个操作添加插入页的基本构造块。该应用程序对象将 HTML 表单和“插入记录”服务器行为添加到页中。

您还可以使用表单工具和“服务器行为”面板分别添加这些构造块。有关更多信息，请参见逐块建立插入页。

在将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具按需要自定义表单，或使用“服务器行为”面板编辑“插入记录”服务器行为。

若要用“插入记录表单”应用程序对象建立插入页，请执行以下操作：
  1. 在“设计”视图中打开该页，然后选择“插入”>“应用程序对象”>“插入记录表单”。

    2. 即会出现“插入记录表单”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关说明，请参见设置“插入记录表单”对话框选项。

  3. 单击“确定”。

Dreamweaver 将 HTML 表单和“插入记录”服务器行为添加到您的页。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具随意地自定义该表格。（确保所有表单对象都保持在表单的边界内。）

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“插入记录”行为。


逐块建立插入页

您可以使用表单工具和“服务器行为”面板分别添加插入页的基本构造块。

您还可以使用“插入记录表单”应用程序对象一次添加所有构造块。有关更多信息，请参见快速建立插入页。

第一步是将 HTML 表单添加到页以便让用户输入数据。

若要将 HTML 表单添加到插入页，请执行以下操作：
  1. 创建一个新页（“文件”>“新建”）并使用 Dreamweaver 设计工具对您的页进行布局。
  2. 将插入点放置在需要表单出现的位置，然后从“插入”菜单中选择“表单”，添加一个 HTML 表单。

    3. 即会在页上创建一个空表单。您可能需要打开“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  3. 对 HTML 表单进行命名；方法是单击文档窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    4. 您不需要指定表单的 action 或 method属性来指示当用户单击“提交”按钮时向何处及如何发送记录数据。“插入记录”服务器行为会为您设置这些属性。

  4. 为数据库表格中要插入记录的每个列添加表单对象（“插入”>“表单对象”）。

    5. 表单对象用于数据输入。为了实现该目的经常会使用文本域，但是您也可以使用列表/菜单、复选框和单选按钮。

    有关表单对象的更多信息，请参见创建交互式表单。

  5. 向表单添加一个“提交”按钮（“插入”>“表单对象”>“按钮”）。
  6. 如果愿意，可以更改“提交”按钮的标签；方法是选择该按钮，打开属性检查器（“窗口”>“属性”），然后在“标签文字”框中输入一个新值。

    7. 例如，这里是一个标为“插入记录”的按钮的属性检查器：
    这是所描述的功能的图片。

下一步是添加“插入记录”服务器行为以在数据库表格中插入记录。

若要添加服务器行为以在数据库表格中插入记录，请执行以下操作：

在“服务器行为”面板中（“窗口”>“服务器行为”）单击加号 (+) 按钮并从弹出式菜单中选择“插入记录”（ASP.NET 用户选择“提交表单时插入记录”）。

即会出现“插入记录”对话框。

  1. 完成该对话框。

    2. 有关说明，请参见：

    设置“插入记录”对话框选项（ASP 和 JSP 用户）

    设置“插入记录”对话框选项（PHP 用户）

    设置“插入记录”对话框选项（ColdFusion 用户）

    设置“提交表单时插入记录”对话框选项（ASP.NET 用户）

  2. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。


建立更新记录的页

您的应用程序可以包含允许用户更新数据库表格中现有记录的页。更新页通常是一个与结果页一同工作的详细信息页。结果页允许用户选择要更新的记录，然后将选择传递到更新页。

更新页具有三个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集
  • 一个允许用户修改记录数据的 HTML 表单
  • 一个用于更新数据库表格的“更新记录”服务器行为

您可以使用“更新记录表单”应用程序对象通过单个操作将 HTML 表单和服务器行为添加到页中，或者您可以使用 Dreamweaver 表单工具和“服务器行为”面板分别添加它们。

备注： 更新页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“删除记录”服务器行为添加到更新页。


标识要更新的记录

当用户要更新某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用更新页。有关创建搜索页和结果页的说明，请参见生成搜索数据库的页面。

结果页通过向更新页传递一个 URL 参数来通知更新页更新哪个记录。因此，确保结果页具有一个“转到详细信息页”服务器行为，该行为将更新页命名为详细信息页。有关说明，请参见修改结果页以使用详细页。


检索要更新的记录

在结果页将标识要更新记录的 URL 参数传递到更新页之后，更新页必须读取该参数，从数据库表格中检索该记录，然后将其临时存储在一个记录集中。

若要检索要更新的记录，请执行以下操作：
  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“记录集”或“数据集”(ASP.NET)。

    2. 如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  2. 对记录集进行命名，并使用“连接”和“表格”弹出式菜单指定要更新的数据所在的位置。
  3. 单击“已选定”选项并选择一个键列（通常是记录 ID 列）和包含要更新数据的列。
  4. 配置“筛选”区域，以便键列的值等于结果页传递的相应 URL 参数的值。

    5. 这种过滤器创建一个只包含结果页指定记录的记录集。例如，如果您的键列（其名称为 PRID）包含记录 ID 信息，并且结果页在名为 id 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域的外观应该如下所示：
    这是所描述的功能的图片。

    有关更多信息，请参见使用过滤后的记录集生成详细页。

  5. 单击“确定”。

当用户在结果页上选择一个记录时，更新页将生成一个只包含所选记录的记录集。


快速完成更新页

您可以使用“更新记录表单”应用程序对象通过单个操作添加更新页的最后两个构造块。该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到页中。

在您可以使用应用程序对象之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。（请参见标识要更新的记录和检索要更新的记录。）

您还可以使用表单工具和“服务器行为”面板分别添加 HTML 表单和“更新记录”服务器行为。（请参见逐块完成更新页。）

在应用程序对象将构造块放置到页上之后，您可以使用 Dreamweaver 设计工具按需要自定义表单，或使用“服务器行为”面板编辑“更新记录”服务器行为。

若要用“更新记录表单”应用程序对象建立更新页，请执行以下操作：
  1. 在设计视图中打开该页，然后选择“插入”>“应用程序对象”>“更新记录表单”。

    2. 即会出现“更新记录表单”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关说明，请参见设置“更新记录表单”对话框选项或设置“更新记录表单”对话框选项（ASP.NET 用户）。

  3. 单击“确定”。

该应用程序对象将 HTML 表单和“更新记录”服务器行为添加到您的页中。表单对象是在一个基本表格中进行布局的，您可以使用 Dreamweaver 页面设计工具自定义该表格。（确保所有表单对象都保持在表单的边界内。）

若要编辑服务器行为，请打开“服务器行为”面板（“窗口”>“服务器行为”），然后双击“更新记录”行为。


逐块完成更新页

您可以使用表单工具和“服务器行为”面板分别添加更新页的最后两个基本构造块。

在您可以添加构造块之前，您的 Web 应用程序必须能够识别要更新的记录，并且您的更新页必须能够检索它。（请参见标识要更新的记录和检索要更新的记录。）

您还可以使用“更新记录表单”应用程序对象一次添加其余的构造块。（请参见快速完成更新页。）

第一步是将 HTML 表单添加到页以便让用户修改数据。

若要将 HTML 表单添加到更新页，请执行以下操作：
  1. 创建一个新页（“文件”>“新建”）。
  2. 使用 Dreamweaver 设计工具对您的页进行布局。
  3. 通过将插入点放置在需要表单出现的位置然后从“插入”菜单中选择“表单”，添加一个 HTML 表单。

    4. 即会在页上创建一个空表单。您可能需要打开“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  4. 对 HTML 表单进行命名；方法是单击文档窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    5. 您不需要指定表单的 action 或method属性来指示当用户单击“提交”按钮时向何处及如何发送记录数据。“更新记录”服务器行为会为您设置这些属性。

  5. 为数据库表中要更新的每个列添加一个表单对象（“插入”>“表单对象”）。

    6. 表单对象用于数据输入。为了实现该目的经常会使用文本域，但是您也可以使用列表/菜单、复选框和单选按钮。

    每个表单对象都应该在早先定义的记录集中具有一个对应的列。唯一的例外就是唯一键列，该列没有对应的表单对象。

    有关表单对象的更多信息，请参见创建交互式表单。

  6. 向表单添加一个“提交”按钮（“插入”>“表单对象”>“按钮”）。
  7. 如果愿意，可以更改“提交”按钮的标签；方法是选择该按钮，打开属性检查器（“窗口”>“属性”），然后在“标签文字”框中输入一个新值。

    8. 例如，这里是一个标为“更新记录”的按钮的属性检查器：
    这是所描述的功能的图片。

下一步是通过将表单对象绑定到数据库表格列在表单中显示记录。

若要在表单中显示记录，请执行以下操作：
  1. 确保您定义了一个记录集来保存用户要更新的记录。

    2. 有关更多信息，请参见检索要更新的记录。

  2. 将数据库表格列从“绑定”面板（“窗口”>“绑定”）拖到它在页上对应的表单对象。

    3. 有关更多信息，请参见将 ActiveX、Flash 和其它对象参数动态化。

最后一步是添加“更新记录”服务器行为以在用户修改记录后更新数据库表格。

若要添加服务器行为来更新数据库表格，请执行以下操作：
  1. 在“服务器行为”面板中（“窗口”>“服务器行为”），单击加号 (+) 按钮并从弹出式菜单中选择“更新记录”。

    2. 即会出现“更新记录”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关说明，请参见：

    设置“更新记录”对话框选项（ASP 和 JSP 用户）

    设置“更新记录”对话框选项（ColdFusion 用户）

    设置“更新记录”对话框选项（PHP 用户）

    设置“更新记录”对话框选项（ASP.NET 用户）

  3. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库中的记录。


建立删除记录的页

您的应用程序可以包含一个允许用户删除数据库表格中现有记录的页。删除页通常是一个与结果页一同工作的详细信息页。结果页允许用户选择要删除的记录，然后将选择传递到删除页。

删除页具有四个构造块：

  • 一个用于从数据库表格中检索记录的过滤记录集
  • 一个要删除数据的只读显示
  • 一个将删除命令发送给服务器的“提交”按钮
  • 一个更新数据库表格的“删除记录”服务器行为

备注： 删除页一次只能包含一个记录编辑服务器行为。例如，您不能将“插入记录”或“更新记录”服务器行为添加到删除页。


标识要删除的记录

当用户要删除某个记录时，他们必须首先在数据库中找到该记录。因此，您需要一个搜索页和一个结果页以便使用删除页。有关创建搜索页和结果页的说明，请参见生成搜索数据库的页面。

结果页通过向删除页传递一个 URL 参数来通知删除页要删除的记录。因此，确保结果页具有一个“转到详细信息页”服务器行为，该行为将删除页命名为详细信息页。有关说明，请参见修改结果页以使用详细页。


检索要删除的记录

在结果页将标识要删除记录的 URL 参数传递到删除页之后，删除页必须读取该参数，从数据库表格中检索该记录，然后将该记录临时存储在一个记录集中。

若要检索要删除的记录，请执行以下操作：
  1. 在“绑定”面板（“窗口”>“绑定”）中，单击加号 (+) 按钮并选择“记录集”或“数据集”(ASP.NET)。

    2. 如果出现高级对话框，则单击“简单”按钮打开简单对话框。

  2. 对记录集进行命名，并使用“连接”和“表格”弹出式菜单指定要删除的数据所在的位置。
  3. 在“列”区域中，选择“全部”选项选择数据库表格中的所有列。
  4. 配置“筛选”区域，以便键列的值等于结果页传递的相应 URL 参数的值。

    5. 这种过滤器创建一个只包含结果页指定记录的记录集。例如，如果您的键列（其名称为 PRID）包含记录 ID 信息，并且结果页在名为 id 的 URL 参数中传递相应的记录 ID 信息，则您的“筛选”区域的外观应该如下所示：
    这是所描述的功能的图片。

    有关更多信息，请参见使用过滤后的记录集生成详细页。

  5. 单击“确定”。

当用户在结果页上选择一个记录时，删除页将生成一个只包含所选记录的记录集。

下一步您将添加要删除数据的只读显示。


显示要删除的数据

在用户删除记录之前对其进行显示以确认用户确实要删除该记录是一个很好的做法。

若要添加要删除记录的只读显示，请执行以下操作：
  1. 确保您定义了一个记录集来保存用户要删除的记录。

    2. 有关更多信息，请参见检索要删除的记录。

  2. 将一个列从“绑定”面板（“窗口”>“绑定”）拖到页上。

    3. 页上即会出现动态内容。您可以将动态内容按原样放在页上，也可以将其放在一个 HTML 表格中。有关更多信息，请参见将文本动态化。


将删除命令发送到服务器

删除页使用“提交”按钮将删除命令发送到服务器。若要向您的页中添加“提交”按钮，您必须创建一个 HTML 表单。该表单只能包含“提交”按钮。

若要在删除页上添加“提交”按钮，请执行以下操作：
  1. 在设计视图中，将插入点放置在要“提交”按钮出现的位置，然后从“插入”菜单中选择“表单”。

    2. 即会在页上创建一个空表单。您可能需要打开“不可见元素”（“查看”>“可视化助理”>“不可见元素”）来查看表单的边界，边界是由红色的细线表示的。

  2. 对 HTML 表单进行命名；方法是单击文档窗口底部的 <form> 标签以选中表单，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    3. 您不需要指定表单的 action 或method属性来指示当用户单击“提交”按钮时向何处及如何发送记录数据。“删除记录”服务器行为会为您设置这些属性。

  3. 向表单添加一个“提交”按钮（“插入”>“表单对象”>“按钮”）。
  4. 如果愿意，可以更改“提交”按钮的标签文字；方法是选择该按钮，打开属性检查器（“窗口”>“属性”），然后在“标签文字”框中输入一个新值。

    5. 例如，这里是一个标为“删除记录”的按钮的属性检查器：
    这是所描述的功能的图片。

下一步，添加“删除记录”服务器行为在用户单击“提交”按钮之后更新数据库表格。


从数据库表格中删除记录

最后一步是添加“删除记录”服务器行为在用户单击“提交”按钮之后更新数据库表格。

若要添加服务器行为以删除数据库表格，请执行以下操作：
  1. 在“服务器行为”面板中（“窗口”>“服务器行为”），单击加号 (+) 按钮并从弹出式菜单中选择“删除记录”。

    2. 即会出现“删除记录”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关更多信息，请参见：

    设置“删除记录”对话框选项（ASP 和 JSP 用户）

    设置“删除记录”对话框选项（ColdFusion 用户）

    设置“删除记录”对话框选项（PHP 用户）

    设置“删除记录”对话框选项（ASP.NET 用户）

  3. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表格中的记录。


使用预存过程修改数据库

您可以使用预存过程修改数据库。预存过程是一种可以重复使用的数据库项，用于在数据库上执行某些操作。预存过程包含具有一定功能的 SQL 代码，较为典型的是插入、更新或删除记录的 SQL 代码。预存过程还可以改变数据库本身的结构。例如，您可以使用预存过程添加表格列，或者甚至可以删除表格。

一个预存过程还可以调用另一个预存过程，以及接受输入参数并以输出参数的形式向调用过程返回多个值。

您可以重复使用预存过程的单个编译的版本来多次执行数据库操作，从这种意义上说，预存过程是可以重复使用的。如果您知道将多次执行某个数据库任务（即不同的应用程序将执行相同的任务），则使用预存过程执行该任务可以使数据库操作更有效。

备注： mySQL 和 Microsoft Access 数据库不支持预存过程。

在您使用预存过程修改数据库之前，确保预存过程包含以某种方式修改数据库的 SQL。若要在数据库中创建并存储一个 SQL，请查询您的数据库文档和一本好的 Transact-SQL 手册。

使用预存过程的步骤随服务器模型的不同而有所变化。


在 ColdFusion 中运行预存过程

当在 Dreamweaver 中处理 Macromedia ColdFusion 页时，您必须将“预存过程”服务器行为添加到页以运行预存过程。

若要将预存过程添加到 ColdFusion 页，请执行以下操作：
  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板中，单击加号 (+) 按钮，然后选择“预存过程”。

    3. 即会出现“预存过程”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. ColdFusion 4 和 ColdFusion MX 的对话框是不同的。

    有关 ColdFusion 4 的说明，请参见设置 ColdFusion 4“预存过程”对话框选项。有关 ColdFusion MX 的说明，请参见设置 ColdFusion MX“预存过程”对话框选项。

  4. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ColdFusion 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。


在 ASP 中运行预存过程

当在 Dreamweaver 页中处理 ASP 页时，您必须将命令对象添加到页以运行预存过程。有关命令对象的更多信息，请参见了解 ASP 命令对象。

若要将预存过程添加到 ASP 页，请执行以下操作：
  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板中，单击加号 (+) 按钮，然后选择“命令（预存过程）”。

    3. 即会出现“命令”对话框。

  3. 输入命令的名称，选择一个到包含预存过程的数据库的连接，然后从“类型”弹出式菜单中选择“预存过程”。
  4. 选择您的预存过程，方法是展开“数据库项”框中的“预存过程”分支，从列表中选择预存过程，然后单击“过程”按钮。
  5. 在“变量”表格中输入任何所需的参数。

    6. 您不需要为任何 RETURN_VALUE 变量输入任何参数。

  6. 单击“确定”。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 ASP 代码，当在服务器上运行该页时，将创建在数据库中运行预存过程的命令对象。预存过程接着执行数据库操作，例如插入记录。

默认情况下，该代码将命令对象的“Prepared”属性设置为 true，这使应用程序服务器在每次运行预存过程时重复使用对象的单个编译的版本。如果您知道将多次执行该命令，则具有该对象的单个编译的版本可以提高数据库操作的效率。但是，如果该命令只执行一两次，则使用单个编译的版本实际上可能会降低 Web 应用程序的效率，因为系统必须暂停以编译该命令。若要更改设置，请切换到代码视图并将“Prepared”属性更改为 false。

备注： 并不是所有数据库提供程序都支持已准备命令。如果您的数据库不支持，当运行此页时，您可能会得到一条错误信息。切换到代码视图并将“Prepared”属性更改为 false。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。


在 ASP.NET 中运行预存过程

当在 Dreamweaver 中处理 ASP.NET 页时，您必须将“预存过程”服务器行为添加到页以执行预存过程。

若要将预存过程添加到 ASP.NET 页，请执行以下操作：
  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板中，单击加号 (+) 按钮，然后选择“预存过程”。

    3. 即会出现“预存过程”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关更多信息，请参见设置“预存过程”对话框选项。

  4. 单击“确定”。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 ASP.NET 代码，当在服务器上运行该页时，将执行数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录或执行查询。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。


在 JSP 中运行预存过程

当在 Dreamweaver 中处理 JSP 页时，您必须将“可调用”服务器行为添加到页以运行预存过程。

若要将预存过程添加到 JSP 页，请执行以下操作：
  1. 在 Dreamweaver 中，打开将运行预存过程的页。
  2. 在“绑定”面板中，单击加号 (+) 按钮，然后选择“可调用（预存过程）”。

    3. 即会出现“可调用（预存过程）”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关说明，请参见设置“可调用（预存过程）”对话框选项。

  4. 单击“确定”。

在关闭了“可调用（预存过程）”对话框之后，Dreamweaver 在您的页中插入 JSP 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

如果预存过程接受参数，则您可以创建一个页，该页通过预存过程收集参数值并将参数值提交到页。例如，您可以创建一个使用 URL 参数或 HTML 表单从用户收集参数值的页。


使用 ASP 命令修改数据库

您可以使用 Dreamweaver 创建在数据库中插入、更新或删除记录的 ASP 命令对象。您可以向命令对象提供在数据库上执行操作的 SQL 语句。

您还可以向该对象提供执行操作的预存过程。有关更多信息，请参见在 ASP 中运行预存过程。


了解 ASP 命令对象

命令对象是在数据库上执行某些操作的服务器对象。该对象可以包含任何有效的 SQL 语句，包括返回记录集的语句或在数据库中插入、更新或删除记录的语句。如果 SQL 语句添加或删除表格中的列，则命令对象可以改变数据库的结构。您还可以使用命令对象在数据库中运行预存过程。

应用程序服务器可以重复使用命令对象的单个编译的版本多次执行命令，从这种意义上说，命令对象是可以重复使用的。通过将命令对象的“Prepared”属性设置为 true 可以使该命令能够重复使用，如下面的 VBScript 语句所示：

mycommand.Prepared = true

如果您知道将多次执行该命令，则具有该对象的单个编译的版本可以使数据库操作更加有效。

备注： 并不是所有数据库提供程序都支持已准备命令。如果您的数据库不支持，则当您将此属性设置为 true 时，它可能返回一个错误。它甚至可能忽略准备命令的请求并将“Prepared”属性设置为 false。

命令对象是由 ASP 页上的脚本创建的，但是 Dreamweaver 允许您创建命令对象而无需编写一行 ASP 代码。本节的其余部分介绍如何在 Dreamweaver 中使用快速应用程序开发 (RAD) 工具创建编辑数据库记录的 ASP 命令对象。


创建使用 SQL 编辑数据库的命令

您可以使用 ASP 命令对象，该命令对象使用 SQL 语句在数据库中插入、更新或删除记录。

若要创建命令对象，请执行以下操作：
  1. 在 Dreamweaver 中，打开将运行该命令的 ASP 页。
  2. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“命令”。

    3. 即会出现“命令”对话框。

  3. 为该命令输入一个名称，选择到数据库的连接（该数据库包含您要编辑的记录），然后选择需要该命令执行的编辑操作（插入、更新或删除）。

    4. Dreamweaver 根据您选择的操作类型为您启动 SQL 语句。例如，这里是选择了“插入”后的对话框：
    这是所描述的功能的图片。

  4. 完成 SQL 语句。

    5. 有关编写修改数据库的 SQL 语句的信息，请查询 Transact-SQL 手册。

  5. 使用“变量”区域定义任何 SQL 变量。

    6. 例如，下面是包含三个 SQL 变量的插入语句。这三个变量的值是由传递到页的 URL 参数提供的，如在“变量”区域的“运行时值”列中定义的那样。
    这是所描述的功能的图片。

    在关闭了该对话框之后，Dreamweaver 在您的页中插入 ASP 代码，当在服务器上运行该页时，将创建在数据库中插入、更新或删除记录的命令。

    默认情况下，该代码将命令对象的“Prepared”属性设置为 true，这使应用程序服务器在每次运行命令时重复使用对象的单个编译的版本。若要更改此设置，请切换到代码视图并将“Prepared”属性更改为 false。

在上面的示例中，下一步您可能要创建一个带有 HTML 表单的页，以便用户可以输入记录数据。HTML 表单将包含三个文本域（txtFirstName、txtLastName 和 txtDept）和一个提交按钮。同样，该表单将使用 GET 方法并将文本域值提交到包含您的命令的页。


使用 JSP 已准备语句修改数据库

您可以使用 Dreamweaver 创建在数据库中插入、更新或删除记录的 JSP 已准备语句。向已准备语句提供在数据库上执行操作的 SQL。


了解 JSP 已准备语句

JSP 已准备语句是包含 SQL 语句的可重复使用的服务器对象。您可以将任何有效的 SQL 语句放置在已准备语句中。例如，已准备语句可以包含返回记录集的 SQL 语句，或在数据库中插入、更新或删除记录的语句。

应用程序服务器使用已准备语句对象的单个实例多次查询数据库，从这种意义上说，已准备语句是可以重复使用的。与 JSP 语句对象不同，不为每个新的数据库查询创建已准备语句对象的新实例。如果您知道将多次执行该语句，则具有该对象的单个实例可以使数据库操作更有效并且占用更少的服务器内存。

已准备语句对象是由 JSP 页上的 Java Scriptlet 创建的。但是，Dreamweaver 允许您创建已准备语句而无需编写一行 Java 代码。

如果您对代码感兴趣，则以下 Scriptlet 创建一个已准备语句：

String myquery = “SELECT * FROM EMPLOYEES WHERE DEPARTMENT = ?”;
PreparedStatement mystatement = connection.prepareStatement(myquery);

第一行将 SQL 语句存储在一个名为“myquery”的字符串变量中，问号充当 SQL 变量值的占位符。第二行创建一个名为“mystatement”的已准备语句对象。

下一步，将值分配给 SQL 变量，如下所示：

mystatement.setString(1, request.getParameter(“myURLparam”));

setString 方法将值分配给变量并采用两个参数。第一个参数通过变量的位置指定受影响的变量（这里是 SQL 语句中的第一个位置）。第二个参数指定变量的值。在本例中，该值是由传递到页的 URL 参数提供的。

备注： 您必须使用不同的方法将非字符串值分配给 SQL 变量。例如，如果要将整数分配给变量，您将使用 mystatement.setInt() 方法。

最后，生成记录集，如下所示：

ResultSet myresults = mystatement.execute();

本节的其余部分介绍如何在 Dreamweaver 中使用快速应用程序开发 (RAD) 工具创建 JSP 已准备语句。这些工具允许您创建已准备语句而无需编写一行 JSP 代码。


创建编辑数据库记录的已准备语句

您可以使用 JSP 已准备语句在数据库中插入、更新或删除记录。

若要创建已准备语句，请执行以下操作：
  1. 在 Dreamweaver 中，打开将运行命令的 JSP 页。
  2. 打开“服务器行为”面板（“窗口”>“服务器行为”），单击加号 (+) 按钮，然后选择“已准备（插入、更新、删除）”。

    3. 即会出现“已准备（插入、更新、删除）”对话框：
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关说明，请参见设置“已准备（插入、更新、删除）”对话框选项。

  4. 单击“确定”。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 JSP 代码，当在服务器上运行该页时，将创建在数据库中插入、更新或删除记录的已准备语句。


设置“插入记录表单”对话框选项

此对话框用于建立一个使用户可以在数据库中插入新记录的页。

过程
  1. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    2. 如果您需要定义连接，则单击“定义”按钮。

  2. 在“插入到表格”弹出式菜单中，选择应向其插入记录的数据库表格。
  3. 如果您使用 ColdFusion，则输入用户名和密码。
  4. 在“插入后，转到”文本框中，输入将记录插入表格后要打开的页或单击“浏览”按钮浏览到该文件。
  5. 如果您使用 ASP.NET，则可以指定一个成功时转到的页和一个失败时转到的页。或者您可以选择在失败时显示调试信息。

    6. 如果您选择“失败时显示调试信息”，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示： 在开发过程中使用“失败时显示调试信息”选项，而后在页处于活动状态时使用“如果失败，则转到”选项。

  6. 在“表单域”区域中，指定您要包括在插入页的 HTML 表单上的表单对象，以及每个表单对象应该更新数据库表格中的哪些列。

    7. 默认情况下，Dreamweaver 为数据库表格中的每个列创建一个表单对象。如果您的数据库为创建的每个新记录都自动生成唯一键 ID，则删除对应于该键列的表单对象，方法是在列表中将其选中然后单击减号 (-) 按钮。这消除了表单的用户输入已存在的 ID 值的风险。

    您还可以更改 HTML 表单上表单对象的顺序，方法是在列表中选中某个表单对象然后单击对话框右侧的向上或向下箭头。

  7. 指定每个数据输入域在 HTML 表单上的显示方式；方法是单击“表单域”表格中的一行，然后在表格下面的框中输入以下信息：
    • 在“标签文字”框中，输入显示在数据输入域旁边的描述性标签文字。默认情况下，Dreamweaver 在该标签中显示表格列的名称。
    • 在“显示为”弹出式菜单中，选择一个表单对象充当数据输入域。您可以选择“文本域”、“文本区域”、“菜单”、“复选框”、“单选按钮组”和“文本”。对于只读项，请选择“文本”。您还可以选择“密码域”、“文件域”和“隐藏区域”。

      • 备注： “隐藏域”插入在表单的结尾。

    • 在“提交为”弹出式菜单中，选择您的数据库表格接受的数据格式。例如，如果表格列只接受数字数据，则选择“数字”。
    • 设置表单对象的属性。根据您选择作为数据输入域的表单对象的不同，您具有不同的选项。对于文本域、文本区域和文本，您可以输入初始值。对于菜单和单选按钮组，将打开另一个对话框来设置属性。对于复选框，选择“已选中”或“未选中”选项。
    • 如果您使用 ASP.NET，则可以选择使用 Web 表单控件。
  8. 单击“确定”。

Dreamweaver 将 HTML 表单和“插入记录”服务器行为添加到您的页。

相关主题

快速建立插入页

设置“动态单选按钮组”对话框选项：ColdFusion

设置“动态单选按钮组”对话框选项

设置“动态文本域”对话框选项

完成“动态复选框”对话框

设置“动态列表/菜单”对话框选项


设置“表单元素属性”对话框选项

此对话框用于设置页上表单元素的属性以允许用户更新数据库中的记录。

过程
  1. 根据您计划创建表单元素的方式，选择“手动”或“来自数据库”。
  2. 单击加号 (+) 按钮添加元素。
  3. 为该元素输入标签文字和值。
  4. 在“选定值等于”文本框中，如果要在浏览器中打开页时或在表单中显示记录时选择特定的元素，则输入一个等于该元素值的值。

    5. 您可以输入静态值，或者通过单击闪电图标，然后从数据源列表中选择一个动态值来指定动态值。在任何一种情况下，您指定的值都应该和其中一个元素的值匹配。


设置“插入记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中插入记录。

在添加此服务器行为之前，页中必须包含带有“提交”按钮的 HTML 表单。

过程
  1. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    2. 如果您需要定义连接，则单击“定义”按钮。

  2. 在“插入到表格”弹出式菜单中，选择应向其插入记录的数据库表格。
  3. 在“插入后，转到”框中，输入在将记录插入表格后要打开的页或单击“浏览”浏览到该文件。
  4. 在“获取值自”弹出式菜单中，选择用于输入数据的 HTML 表单。

    5. Dreamweaver 自动选择页上的第一个表单。

  5. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    6. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  6. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

逐块建立插入页


设置“插入记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中插入记录。

在添加此服务器行为之前，页中必须包含带有“提交”按钮的 HTML 表单。

过程
  1. 从“提交值，自”弹出式菜单中选择一个表单。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 在“插入表格”弹出式菜单中，选择要向其中插入记录的数据库表格。
  4. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    5. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“插入后，转到”文本框中，输入将记录插入表格后要打开的页或单击“浏览”按钮浏览到该文件。
  6. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

逐块建立插入页


设置“插入记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中插入记录。

在添加此服务器行为之前，页中必须包含带有“提交”按钮的 HTML 表单。

过程
  1. 从“提交值，自”弹出式菜单中选择一个表单。
  2. 在“数据源”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 输入您的用户名和密码。
  4. 在“插入到表格”弹出式菜单中，选择要向其中插入记录的数据库表格。
  5. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    6. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  6. 在“插入后，转到”文本框中，输入将记录插入表格后要打开的页或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

逐块建立插入页


设置“提交表单时插入记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中插入记录。

在添加此服务器行为之前，页中必须包含带有“提交”按钮的 HTML 表单。

过程
  1. 从“提交值，自”弹出式菜单中选择一个表单。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    3. 如果您需要定义连接，则单击“定义”按钮。

  3. 在“插入到表格”弹出式菜单中，选择要向其中插入记录的数据库表格。
  4. 指定要向其中插入记录的数据库列，从“值”弹出式菜单中选择将插入记录的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    5. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“如果成功，则转到”文本框中，输入预存过程成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  6. 在“如果失败，则转到”文本框中，输入如果预存过程失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 如果要在预存过程失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    8. 如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示： 在开发过程中使用调试选项，而后在站点处于活动状态时使用“如果失败，则转到”选项。

  8. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过填写 HTML 表单并单击“提交”按钮在数据库表格中插入记录。

相关主题

逐块建立插入页


设置“更新记录表单”对话框选项

此对话框用于建立一个允许用户更新数据库中记录的页。

过程

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要更新的记录。有关更多信息，请参见标识要更新的记录。
  • 您必须将逻辑添加到更新页，允许它从数据库中检索用户选定的记录准备进行更新。有关说明，请参见检索要更新的记录。

实现了这些前提条件之后，您可以按以下步骤完成该对话框：

  1. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    2. 如果您需要定义连接，则单击“定义”按钮。

  2. 在“要更新的表格”弹出式菜单中，选择包含要更新的记录的数据库表格。
  3. 在“选取记录自”弹出式菜单中，指定包含显示在 HTML 表单上的记录的记录集。
  4. 在“唯一键列”弹出式菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表格中的记录。

    5. 如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候它也接受文本值。

  5. 在“更新后，转到”文本框中，输入在表格中更新记录之后打开的页。
  6. 在“表单域”区域中，指定每个表单对象应该更新数据库表格中的哪些列。

    7. 默认情况下，Dreamweaver 为数据库表格中的每个列创建一个表单对象。如果您的数据库为创建的每个新记录都自动生成唯一键 ID，则删除对应于该键列的表单对象，方法是在列表中将其选中然后单击减号 (-) 按钮。这消除了表单的用户输入已存在的 ID 值的风险。

    您还可以更改 HTML 表单上表单对象的顺序，方法是在列表中选中某个表单对象然后单击对话框右侧的向上或向下箭头。

  7. 指定每个数据输入域在 HTML 表单上的显示方式；方法是单击“表单域”表格中的一行，然后在表格下面的框中输入以下信息：
    • 在“标签文字”框中，输入显示在数据输入域旁边的描述性标签文字。默认情况下，Dreamweaver 在该标签中显示表格列的名称。
    • 在“显示为”弹出式菜单中，选择一个表单对象充当数据输入域。您可以选择“文本域”、“文本区域”、“菜单”、“复选框”、“单选按钮组”和“文本”。对于只读项，请选择“文本”。您还可以选择“密码域”、“文件域”和“隐藏区域”。

      • 备注： “隐藏域”插入在表单的结尾。

    • 在“提交为”弹出式菜单中，选择您的数据库表格需要的数据格式。例如，如果表格列只接受数字数据，则选择“数字”。
    • 设置表单对象的属性。根据您选择作为数据输入域的表单对象的不同，您具有不同的选项。对于文本域、文本区域和文本，您可以输入初始值。对于菜单和单选按钮组，将打开另一个对话框来设置属性。对于复选框，选择“已选中”或“未选中”选项。
  8. 通过选择另一个表单域行并输入标签文字、显示为值和提交为值来设置其他表单对象的属性。

    9. 对于菜单和单选按钮组，打开另一个对话框来设置属性。 对于复选框，定义一个复选框当前记录的值和给定值的比较以确定当显示记录时是否选中了该复选框。

  9. 单击“确定”。

Dreamweaver 将 HTML 表单和“更新记录”服务器行为添加到您的页中。

相关主题

快速完成更新页

设置“动态单选按钮组”对话框选项：ColdFusion

设置“动态单选按钮组”对话框选项

设置“动态文本域”对话框选项

完成“动态复选框”对话框

设置“动态列表/菜单”对话框选项


设置“更新记录表单”对话框选项

此对话框用于建立一个允许用户更新数据库中记录的页。

过程

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要更新的记录。有关更多信息，请参见标识要更新的记录。
  • 您必须将逻辑添加到更新页，允许它从数据库中检索用户选定的记录准备进行更新。有关说明，请参见检索要更新的记录。

实现了这些前提条件之后，您可以按以下步骤完成该对话框：

  1. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    2. 如果您需要定义连接，则单击“定义”按钮。

  2. 在“表格”弹出式菜单中，选择包含要更新的记录的数据库表格。
  3. 在“选取记录自”弹出式菜单中，指定包含显示在 HTML 表单上的记录的记录集。
  4. 在“唯一键列”弹出式菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表格中的记录。
  5. 在“提交唯一键为”弹出式菜单中，选择一个数据类型。
  6. 在“如果成功，则转到”文本框中，输入预存过程成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 在“如果失败，则转到”文本框中，输入如果预存过程失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  8. 如果要在预存过程失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    9. 如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示： 在开发过程中使用调试选项，而后在站点处于活动状态时使用“如果失败，则转到”选项。

  9. 在“表单域”区域中，指定每个表单对象应该更新数据库表格中的哪些列。

    10. 默认情况下，Dreamweaver 为数据库表格中的每个列创建一个表单对象。如果您的数据库为创建的每个新记录都自动生成唯一键 ID，则删除对应于该键列的表单对象，方法是在列表中将其选中然后单击减号 (-) 按钮。这消除了表单的用户输入已存在的 ID 值的风险。

    您还可以更改 HTML 表单上表单对象的顺序，方法是在列表中选中某个表单对象然后单击对话框右侧的向上或向下箭头。

  10. 指定每个数据输入域在 HTML 表单上的显示方式；方法是单击“表单域”表格中的一行，然后在表格下面的框中输入以下信息：
    • 在“标签文字”框中，输入显示在数据输入域旁边的描述性标签文字。默认情况下，Dreamweaver 在该标签中显示表格列的名称。
    • 在“显示为”弹出式菜单中，选择一个表单对象充当数据输入域。您可以选择“文本域”、“文本区域”、“菜单”、“复选框”、“单选按钮组”和“文本”。对于只读项，请选择“文本”。您还可以选择“密码域”、“文件域”和“隐藏区域”。

      • 备注： “隐藏域”插入在表单的结尾。

    • 在“提交为”弹出式菜单中，选择您的数据库表格需要的数据格式。例如，如果表格列只接受数字数据，则选择“数字”。
    • 设置表单对象的属性。根据您选择作为数据输入域的表单对象的不同，您具有不同的选项。对于文本域、文本区域和文本，您可以输入初始值。对于菜单和单选按钮组，将打开另一个对话框来设置属性。对于复选框，选择“已选中”或“未选中”选项。
  11. 通过选择另一个表单域行并输入标签文字、显示为值和提交为值来设置其他表单对象的属性。

    12. 对于菜单和单选按钮组，打开另一个对话框来设置属性。 对于复选框，定义一个复选框当前记录的值和给定值的比较以确定当显示记录时是否选中了该复选框。

  12. 单击“确定”。

Dreamweaver 将 HTML 表单和“更新记录”服务器行为添加到您的页中。

相关主题

快速完成更新页

设置“动态单选按钮组”对话框选项：ColdFusion

设置“动态单选按钮组”对话框选项

设置“动态文本域”对话框选项

完成“动态复选框”对话框

设置“动态列表/菜单”对话框选项


设置“更新记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中更新记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要更新的记录。有关更多信息，请参见标识要更新的记录。
  • 您必须将逻辑添加到更新页，允许它从数据库中检索用户选定的记录准备进行更新。有关说明，请参见检索要更新的记录。
  • 您必须将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

过程
  1. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    2. 如果您需要定义连接，则单击“定义”按钮。

  2. 在“要更新的表格”弹出式菜单中，选择包含您正在更新的记录的数据库表格。
  3. 在“选取记录自”弹出式菜单中，指定包含显示在 HTML 表单上的记录的记录集。
  4. 在“唯一键列”弹出式菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表格中的记录。

    5. 如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候它也接受文本值。

  5. 在“更新后，转到”文本框中，输入在表格中更新记录之后打开的页。
  6. 在“获取值自”弹出式菜单中，选择用于编辑记录数据的 HTML 表单。

    7. Dreamweaver 自动选择页上的第一个表单。

  7. 指定要更新的数据库列，从“值”弹出式菜单中选择将更新该列的表单对象，然后从“提交为”弹出式菜单中为该表单对象选择数据类型。

    8. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  8. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库表格中的记录。

相关主题

逐块完成更新页


设置“更新记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中更新记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要更新的记录。有关更多信息，请参见标识要更新的记录。
  • 您必须将逻辑添加到更新页，允许它从数据库中检索用户选定的记录准备进行更新。有关说明，请参见检索要更新的记录。
  • 您必须将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

过程
  1. 从“提交值，自”弹出式菜单中选择一个表单。
  2. 在“数据源”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 输入您的用户名和密码。
  4. 在“更新表格”弹出式菜单中，选择包含您正在更新的记录的数据库表格。
  5. 指定要更新的数据库列，从“值”弹出式菜单中选择将更新该列的表单对象，从“提交为”弹出式菜单中为该表单对象选择数据类型，（如果要将此列标识为主键）并选择“主键”。

    6. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  6. 在“更新后，转到”框中，输入在表格中更新记录后打开的页或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库表格中的记录。

相关主题

逐块完成更新页


设置“更新记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中更新记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要更新的记录。有关更多信息，请参见标识要更新的记录。
  • 您必须将逻辑添加到更新页，允许它从数据库中检索用户选定的记录准备进行更新。有关说明，请参见检索要更新的记录。
  • 您必须将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页。

实现了这些前提条件之后，您可以完成“更新记录”对话框。

过程
  1. 从“提交值，自”弹出式菜单中选择一个表单。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 在“更新表格”弹出式菜单中，选择包含您正在更新的记录的数据库表格。
  4. 指定要更新的数据库列，从“值”弹出式菜单中选择将更新该列的表单对象，从“提交为”弹出式菜单中为该表单对象选择数据类型，（如果要将此列标识为主键）并选择“主键”。

    5. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“更新后，转到”框中，输入在表格中更新记录后打开的页或单击“浏览”按钮浏览到该文件。
  6. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库表格中的记录。

相关主题

逐块完成更新页


设置“更新记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中更新记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要更新的记录。有关更多信息，请参见标识要更新的记录。
  • 您必须将逻辑添加到更新页，允许它从数据库中检索用户选定的记录准备进行更新。有关说明，请参见检索要更新的记录。
  • 您必须将 HTML 表单添加到更新页以允许用户修改数据。有关说明，请参见逐块完成更新页。

实现了这些前提条件之后，您可以完成“更新记录”对话框

过程
  1. 从“提交值，自”弹出式菜单中选择一个表单。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    3. 如果您需要定义连接，则单击“定义”按钮。

  3. 在“更新表格”弹出式菜单中，选择包含您正在更新的记录的数据库表格。
  4. 指定要更新的数据库列，从“值”弹出式菜单中选择将更新该列的表单对象，从“提交为”弹出式菜单中为该表单对象选择数据类型，（如果要将此列标识为主键）并选择“主键”。

    5. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

    为表单中的每个表单对象重复该过程。

  5. 在“如果成功，则转到”文本框中，输入预存过程成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  6. 在“如果失败，则转到”文本框中，输入如果预存过程失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 如果要在预存过程失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    8. 如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示： 在开发过程中使用调试选项，而后在站点处于活动状态时使用“如果失败，则转到”选项。

  8. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过修改显示在 HTML 表单中的信息并单击“提交”按钮更新数据库表格中的记录。

相关主题

逐块完成更新页


设置“删除记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中删除记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要删除的记录。有关更多信息，请参见标识要删除的记录。
  • 您必须将逻辑添加到删除页，允许它从数据库中检索用户选定的记录准备进行删除。有关说明，请参见检索要删除的记录。

    • 另外，您可以在页上显示记录，这样用户可以在删除记录之前查看该记录。有关说明，请参见显示要删除的数据。

  • 您必须将带有“提交”按钮的 HTML 表单添加到删除页才能将删除命令发送到服务器。有关说明，请参见将删除命令发送到服务器。

实现了这些前提条件之后，您可以完成“删除记录”对话框。

过程
  1. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    2. 如果您需要定义连接，则单击“定义”按钮。

  2. 在“从表格中删除”弹出式菜单中，选择包含要删除的记录的数据库表格。
  3. 在“选取记录自”弹出式菜单中，指定包含要删除的记录的记录集。
  4. 在“唯一键列”弹出式菜单中，选择一个键列（通常是记录 ID 列）来标识数据库表格中的记录。

    5. 如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候它也接受文本值。

  5. 在“提交此表单以删除”弹出式菜单中，指定具有将删除命令发送到服务器的“提交”按钮的 HTML 表单。
  6. 在“删除后，转到”框中，输入在从数据库表格中删除记录后打开的页或单击“浏览”按钮浏览到该文件。

    7. Dreamweaver 自动选择页上的第一个表单。

  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表格中的记录。


设置“删除记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中删除记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要删除的记录。有关更多信息，请参见标识要删除的记录。
  • 您必须将逻辑添加到删除页，允许它从数据库中检索用户选定的记录准备进行删除。有关说明，请参见检索要删除的记录。

    • 另外，您可以在页上显示记录，这样用户可以在删除记录之前查看该记录。有关说明，请参见显示要删除的数据。

  • 您必须将带有“提交”按钮的 HTML 表单添加到删除页才能将删除命令发送到服务器。有关说明，请参见将删除命令发送到服务器。

实现了这些前提条件之后，您可以完成“删除记录”对话框。

过程
  1. 在“先检查是否定义了变量”弹出式菜单中，选择“主键值”。

    2. 如果您要检查一个变量（该变量不是标识要删除记录的那个变量），则选中该变量，然后输入其名称。

    Dreamweaver 检查是否定义了该变量。

  2. 在“数据源”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 输入您的用户名和密码。
  4. 在“表格”弹出式菜单中，选择包含要删除的记录的数据库表格。
  5. 在“主键列”弹出式菜单中，选择一个键列在数据库表格中标识该记录。

    6. 如果该值是一个数字，则选择“数字”选项。键列通常只接受数值，但有时候它也接受文本值。

  6. 在“主键值”弹出式菜单中，选择标识要删除记录的变量，然后输入其名称。
  7. 在“删除后，转到”框中，输入在从数据库表格中删除记录后打开的页或单击“浏览”按钮浏览到该文件。
  8. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表格中的记录。


设置“删除记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中删除记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要删除的记录。有关更多信息，请参见标识要删除的记录。
  • 您必须将逻辑添加到删除页，允许它从数据库中检索用户选定的记录准备进行删除。有关说明，请参见检索要删除的记录。

    • 另外，您可以在页上显示记录，这样用户可以在删除记录之前查看该记录。有关说明，请参见显示要删除的数据。

  • 您必须将带有“提交”按钮的 HTML 表单添加到删除页才能将删除命令发送到服务器。有关说明，请参见将删除命令发送到服务器。

实现了这些前提条件之后，您可以完成“删除记录”对话框。

过程
  1. 在“提交此表单以删除”弹出式菜单中，指定具有将删除命令发送到服务器的“提交”按钮的 HTML 表单。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 在“表格”弹出式菜单中，选择包含要删除的记录的数据库表格。
  4. 在“主键列”弹出式菜单中，选择一个键列在数据库表格中标识该记录。
  5. 在“值”弹出式菜单中，指定标识要删除的记录的变量。
  6. 在“删除后，转到”文本框中，输入在从数据库表格中删除记录后打开的页或单击“浏览”按钮浏览到该文件。
  7. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表格中的记录。


设置“删除记录”对话框选项

此对话框用于将服务器行为添加到包含 HTML 表单的页，以便当用户单击表单上的“提交”按钮时可以在数据库表格中删除记录。

在开始之前，您必须完成以下任务：

  • 您必须建立一个或多个页，该（这些）页允许用户查找要删除的记录。有关更多信息，请参见标识要删除的记录。
  • 您必须将逻辑添加到删除页，允许它从数据库中检索用户选定的记录准备进行删除。有关说明，请参见检索要删除的记录。

    • 另外，您可以在页上显示记录，这样用户可以在删除记录之前查看该记录。有关说明，请参见显示要删除的数据。

  • 您必须将带有“提交”按钮的 HTML 表单添加到删除页才能将删除命令发送到服务器。有关说明，请参见将删除命令发送到服务器。

实现了这些前提条件之后，您可以完成“删除记录”对话框。

过程
  1. 在“先检查是否定义了变量”弹出式菜单中，选择“主键值”。

    2. 如果您要检查一个变量（该变量不是标识要删除记录的那个变量），则选中该变量，然后输入其名称。

    Dreamweaver 检查是否定义了该变量。

  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    3. 如果您需要定义连接，则单击“定义”按钮。

  3. 在“表格”弹出式菜单中，选择包含要删除的记录的数据库表格。
  4. 在“主键列”弹出式菜单中，选择一个键列在数据库表格中标识该记录。
  5. 在“提交主键作为”弹出式菜单中，选择一个数据类型。

    6. 数据类型是数据库表格中的列所需的数据种类（文本、数字、布尔型复选框值）。

  6. 在“主键值”弹出式菜单中，选择标识要删除记录的变量，然后输入其名称。
  7. 在“如果成功，则转到”文本框中，输入预存过程成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  8. 在“如果失败，则转到”文本框中，输入如果预存过程失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  9. 如果要在预存过程失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    10. 如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示： 在开发过程中使用调试选项，而后在站点处于活动状态时使用“如果失败，则转到”选项。

  10. 单击“确定”。

Dreamweaver 将服务器行为添加到页，该页允许用户通过单击表单上的“提交”按钮删除数据库表格中的记录。


设置“命令（预存过程）”对话框选项

此对话框用于在您的页中插入 ASP 命令对象。

您要做什么？

  • 了解 ASP 命令对象，请参见了解 ASP 命令对象。
  • 使用带有命令对象的 SQL 语句，请参见创建使用 SQL 编辑数据库的命令。
  • 使用带有命令对象的预存过程，请参见在 ASP 中运行预存过程。

相关主题

使用预存过程修改数据库


设置 ColdFusion 4“预存过程”对话框选项

此对话框用于将预存过程插入您的 ColdFusion 页中。

过程
  1. 输入预存过程的名称。
  2. 选择一个到包含预存过程的数据库的连接。

    3. 如果您需要定义连接，则单击“定义”按钮。

  3. 如果预存过程返回记录集，则选择“返回具有以下名称的记录集”复选框，然后输入记录集的名称，最后单击“测试”按钮查看预存过程返回的记录集。

    4. Dreamweaver 运行预存过程并显示记录集（如果存在）。

    备注： 如果预存过程返回记录集并采用参数，则您必须在“变量”框的“默认值”列中输入一个值以测试该预存过程。

  4. 选择您的预存过程；方法是展开“数据库项”框中的“预存过程”分支，从列表中选择预存过程，然后单击“过程”按钮。

    5. Dreamweaver 自动填写“过程”和“变量”框。

  5. 单击加号 (+) 在“变量”表格中输入任何所需的参数。

    6. 您不需要为任何 RETURN_VALUE 变量输入任何参数。

    备注： 您必须为任何预存过程输入参数输入测试值。

  6. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ColdFusion 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

使用预存过程修改数据库

在 ColdFusion 中运行预存过程


设置 ColdFusion MX“预存过程”对话框选项

此对话框用于将预存过程插入您的 ColdFusion 页中。

过程
  1. 在“数据源”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  2. 输入 ColdFusion 数据源用户名和密码。
  3. 从“过程”弹出式菜单中选择一个预存过程。

    4. Dreamweaver 自动填写任何参数。

  4. 如果需要进行更改，则选择某个参数，然后单击“编辑”按钮。

    5. 即会出现“编辑预存过程变量”对话框。若要完成此对话框，请参见设置“预存过程变量”对话框选项。

    备注： 您必须为任何预存过程输入参数输入测试值。

  5. 如果预存过程采用参数，则单击加号按钮添加页参数。

    6. 即会出现“添加参数”对话框。若要完成此对话框，请参见设置“添加参数”或“编辑参数”对话框选项。

    备注： 您必须为每个预存过程参数返回值输入对应的页参数。除非有对应的返回值，否则不要添加页参数。

    如果需要，再次单击加号 (+) 按钮添加另一个页参数。

  6. 选择一个页参数，然后单击减号 (-) 按钮删除该参数（如果需要）或单击“编辑”对该参数进行更改。

    7. 即会出现“编辑参数”对话框。若要完成此对话框，请参见设置“添加参数”或“编辑参数”对话框选项。

  7. 如果预存过程返回记录集，则选择“返回具有以下名称的记录集”复选框，然后输入记录集的名称，最后单击“测试”按钮查看预存过程返回的记录集。

    8. Dreamweaver 运行预存过程并显示记录集（如果存在）。

    备注： 如果预存过程返回记录集并采用参数，则您必须在“变量”框的“默认值”列中输入一个值以测试该预存过程。

    提示： 您可以使用不同的测试值生成不同的记录集。如果要更改测试值，则对“参数”单击“编辑”按钮，然后更改“测试值”；或者对“页参数”单击“编辑”按钮，然后更改“默认”值。

  8. 如果预存过程返回状态代码返回值，则选择“返回具有以下名称的状态代码”复选框，然后输入状态代码的名称。
  9. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ColdFusion 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

使用预存过程修改数据库

在 ColdFusion 中运行预存过程


设置“预存过程变量”对话框选项

此对话框用于添加或编辑预存过程参数。

过程
  1. 您正在编辑的变量的名称显示在“名称”域中。
  2. 从弹出式菜单中选择一个方向。

    3. 预存过程可能具有输入值、输出值、或者既具有输入值又具有输出值。

  3. 从弹出式菜单中选择一个 SQL 类型。
  4. 输入返回变量。
  5. 输入运行时值。
  6. 输入测试值。

相关主题

设置 ColdFusion MX“预存过程”对话框选项

在 ColdFusion 中运行预存过程


设置“预存过程”对话框选项

此对话框用于将预存过程插入您的 ASP.NET 页中。

过程
  1. 输入预存过程的名称。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。

    3. 如果您需要定义连接，则单击“定义”按钮。

  3. 从“过程”弹出式菜单中选择一个预存过程。

    4. Dreamweaver 自动填写任何参数。

  4. 如果预存过程返回记录集，则选择“返回数据集”复选框，然后单击“测试”按钮查看预存过程返回的记录集。
  5. 选择一个参数，然后单击“编辑”按钮（如果您需要进行更改）或单击“删除”按钮删除该参数。

    6. 有关更多信息，请参见设置“编辑预存过程变量”对话框选项。

  6. 在“如果成功，则转到”文本框中，输入预存过程成功运行后所显示的页的位置或单击“浏览”按钮浏览到该位置。
  7. 在“如果失败，则转到”文本框中，输入如果预存过程失败所显示的页的位置或单击“浏览”按钮浏览到该位置。
  8. 如果要在预存过程失败时显示调试信息，则选择“失败时显示调试信息”复选框。

    9. 如果选择了此选项，则 Dreamweaver 将忽略“如果失败，则转到”选项。

    提示： 在开发过程中使用调试选项，而后在站点处于活动状态时使用“如果失败，则转到”选项。

  9. 单击“确定”。

在关闭了“预存过程”对话框之后，Dreamweaver 在您的页中插入 ASP.NET 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

使用预存过程修改数据库

在 ASP.NET 中运行预存过程


设置“编辑预存过程变量”对话框选项

此对话框用于编辑预存过程参数。您可以按需要更改值。

过程
  1. 您正在编辑的变量的名称显示在“名称”域中。
  2. 从弹出式菜单中选择变量类型。
  3. 输入变量的大小。
  4. 从弹出式菜单中选择一个方向。

    5. 预存过程可能具有输入值、输出值、或者既具有输入值又具有输出值。

  5. 输入测试值。
  6. 输入一个值。
  7. 单击“生成”按钮生成值。

    8. 即会出现“生成值”对话框。若要完成此对话框，请参见设置“生成值”对话框选项。

  8. 单击“确定”。

相关主题

设置“预存过程”对话框选项

在 ASP.NET 中运行预存过程


设置“生成值”对话框选项

此对话框用于生成您的预存过程值。

过程
  1. 从弹出式菜单中选择一个来源。
  2. 输入默认值。
  3. 单击“确定”。

相关主题

设置“编辑预存过程变量”对话框选项

设置“预存过程”对话框选项

在 ASP.NET 中运行预存过程


设置“可调用（预存过程）”对话框选项

此对话框用于将预存过程插入您的 JSP 页中。

过程
  1. 输入预存过程的名称。
  2. 在“连接”弹出式菜单中，选择一个到包含预存过程的数据库的连接。
  3. 在“数据库项”文本框中，展开“预存过程”分支，从列表中选择预存过程，然后单击“过程”按钮。

    4. Dreamweaver 将自动填写“可调用文本”和“变量”框。

  4. 如果预存过程返回记录集，则选择“返回具有以下名称的记录集”复选框，然后输入记录集的名称，最后单击“测试”按钮查看预存过程返回的记录集。

    5. Dreamweaver 运行预存过程并显示记录集（如果存在）。

    备注： 如果预存过程返回记录集并采用参数，则您必须在“变量”框的“默认值”列中输入一个值以测试该预存过程。

在关闭了“可调用（预存过程）”对话框之后，Dreamweaver 在您的页中插入 JSP 代码，当在服务器上运行该页时，将调用数据库中的预存过程。预存过程接着执行数据库操作，例如插入记录。

相关主题

使用预存过程修改数据库

在 JSP 中运行预存过程


设置“已准备（插入、更新、删除）”对话框选项

此对话框用于创建在数据库中插入、更新或删除记录的已准备语句。

过程
  1. 输入已准备语句的名称，选择到包含要编辑记录的数据库的连接，然后选择需要已准备语句执行的编辑操作 ó 插入、更新或删除。

    2. Dreamweaver 根据您选择的操作类型为您启动 SQL 语句。例如，这里是选择了“插入”后的对话框：
    这是所描述的功能的图片。

  2. 完成 SQL 语句。

    3. 有关编写修改数据库的 SQL 语句的信息，请查询 Transact-SQL 手册。

  3. 使用“变量”区域定义任何 SQL 变量。

    4. 例如，下面是包含三个 SQL 变量的插入语句。这三个变量的值是由传递到页的 URL 参数提供的，如在“变量”区域的“运行时值”列中定义的那样。
    这是所描述的功能的图片。

在关闭了该对话框之后，Dreamweaver 在您的页中插入 JSP 代码，当在服务器上运行该页时，将创建在数据库中插入、更新或删除记录的已准备语句。

在上面的示例中，下一步您可能要创建一个带有 HTML 表单的页，以便用户可以输入记录数据。HTML 表单将包含三个文本域（txtFirstName、txtLastName 和 txtDept）和一个提交按钮。同样，该表单将使用 GET 方法并将文本域值提交到包含您的已准备语句的页。

相关主题

创建编辑数据库记录的已准备语句

了解 JSP 已准备语句

上一页


生成对站点访问进行限制的页

您可以使用 Macromedia Dreamweaver MX 生成以下对站点访问进行限制的页：

  • 要求用户在首次访问站点时进行注册的页（请参见生成注册页）
  • 让注册用户登录到站点的页（请参见生成登录页）
  • 只有授权用户才能查看的页（请参见生成只有授权用户才能访问的页）

备注： Dreamweaver 没有针对 ASP.NET 或 PHP 页的身份验证服务器行为。
下一页


生成注册页

Web 应用程序可以包含要求用户在首次访问站点时进行注册的页。

备注： Dreamweaver 没有针对 ASP.NET 或 PHP 页的身份验证服务器行为。

例如，以下页要求首次访问的用户进行注册：

注册页由以下构造块组成：

  • 存储有关用户的登录信息的数据库表。
  • 让用户选择用户名和密码的 HTML 表单。

    • 您也可以使用该表单来获取用户的其他个人信息。

  • 用于更新站点用户数据库表的“插入记录”服务器行为。
  • 用于确保用户输入的用户名没有被其他用户使用的“检查新用户名”服务器行为。

备注： 您可以删除或更改添加到页上的任何服务器行为的属性（请参见编辑服务器行为）。


存储有关用户的登录信息

注册页需要使用数据库表来存储用户输入的登录信息。请确保数据库表包含用户名和密码列。如果您希望登录的用户具有不同的访问权限，请包含一个访问权限列（请参见在用户数据库中存储访问特权）。

如果要为站点的所有用户设置一个通用的密码，请配置数据库应用程序（Microsoft Access、Microsoft SQL Server、Oracle 等），使其在默认情况下将该密码输入到每个新的用户记录中。在大多数数据库应用程序中，每当新建一个记录时，可以将一个列设置为默认值。将该默认值设置为密码。

您还可以使用数据库表来存储有关用户的其他有用信息。


让用户选择用户名和密码

您可以在注册页中添加一个 HTML 表单，以让用户选择用户名和密码（如果适用）。

若要让用户选择用户名和密码，请执行以下操作：
  1. 创建一个新页（“文件”>“新建”），然后使用 Dreamweaver 设计工具设计注册页的布局。
  2. 添加一个 HTML 表单，方法是将插入点放在希望该表单出现的地方并从“插入”菜单中选择“表单”。

    3. 即会在该页上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）才能看到该表单的边界（用红色细线来表示）。

  3. 命名该 HTML 表单，方法是单击文档窗口底部的 <form> 标签，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    4. 您不必为该表单指定 action 或 method 属性来指示它在用户单击“提交”按钮时向哪里以及如何发送记录数据。“插入记录”服务器行为会为您设置这些属性（请参见更新数据库中的用户表）。

  4. 添加文本域（“插入”>“表单对象”>“文本域”），以便让用户输入用户名和密码。

    5. 该表单还可以包含更多的表单对象，以记录其他个人数据。

    应该在每个表单对象的旁边添加标签文字（以文本或图像的形式），让用户知道它们的用途。还应该通过将表单对象放入 HTML 表来排列这些对象。有关表单对象的更多信息，请参见创建交互式表单。

  5. 在该表单上添加一个“提交”按钮（“插入”>“表单对象”>“按钮”）。
  6. 如果需要，请更改“提交”按钮的标签文字，方法是选择该按钮，打开属性检查器（“窗口”>“属性”），然后在“标签文字”框中输入新值。

    7. 例如，下面是标签文字为“Register”的按钮的属性检查器：
    这是所描述的功能的图片。

下一步是添加“插入记录”服务器行为，以便将记录插入到数据库中的用户表。


更新数据库中的用户表

您可以添加“插入记录”服务器行为，以更新数据库中的用户表。

若要更新数据库中的用户表，请执行以下操作：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击加号 (+) 按钮并从弹出式菜单中选择“插入记录”。

    2. 出现“插入记录”对话框。

  2. 使用“连接”和“插入到表格”弹出式菜单指定数据库中的用户表。
  3. 在“插入后，转到”对话框中，输入在记录插入到表中后所打开的页。
  4. 在“获取值自”弹出式菜单中，选择用于获取用户的用户名和密码的 HTML 表单。

    5. Dreamweaver 会自动选择您的页上的第一个表单。

  5. 指定表单上的每个对象将更新数据库表中的内容，方法是在“表单元素”列表中选择一个表单对象，然后从“列”弹出式菜单中选择一个表列，并从“提交为”弹出式菜单中选择一种数据类型。

    6. 数据类型是数据库表中的列所接受的数据种类（文本、数值、布尔型复选框值）。密码列或用户名列通常接受文本。

    例如，在“表单元素”列表中，单击密码文本域，选择应在其中存储密码的数据库表列，然后选择“文本”数据类型。

    对于“表单元素”列表中的每个表单对象重复上述过程。

  6. 单击“确定”。

最后一步是确保用户名没有被其他注册用户使用。


确保选定的用户名是唯一的

您可以添加一个服务器行为来确保输入的用户名没有被其他注册用户使用。

当用户单击注册页上的“提交”按钮时，该服务器行为将对用户输入的用户名和存储在注册用户数据库表中的用户名进行比较。如果没有在数据库表中找到匹配的用户名，该服务器行为通常会执行插入记录操作。如果找到匹配的用户名，该服务器行为将取消插入记录操作并打开一个新页（通常是提示用户该用户名已被使用的页）。

若要确保选定的用户名是唯一的，请执行以下操作：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击加号 (+) 按钮并从弹出式菜单中选择“用户身份验证”>“检查新用户名”。

    2. 出现“检查新用户名”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关指导请参见设置“检查新用户名”对话框选项。

  3. 单击“确定”。

Dreamweaver 在注册页上添加一个服务器行为，它将先检查访问者提交的用户名是否是唯一的，然后才将该访问者的信息添加到注册用户数据库中。


生成登录页

Web 应用程序可以包含让注册用户登录站点的页。

备注： Dreamweaver 没有针对 ASP.NET 或 PHP 页的身份验证服务器行为。

例如，以下页要求注册用户登录：

登录页由以下构造块组成：

  • 注册用户的数据库表
  • 让用户输入用户名和密码的 HTML 表单
  • 确保输入的用户名和密码有效的“登录用户”服务器行为

当用户成功登录时，将为该用户创建一个包含其用户名的阶段变量。

备注： 您可以删除或更改添加到页上的任何服务器行为的属性（请参见编辑服务器行为）。


创建注册用户的数据库表

您需要使用注册用户的数据库表来验证在登录页中输入的用户名和密码是否有效。请使用数据库应用程序和注册页创建该表。有关更多信息，请参见生成注册页。


让用户登录

您可以在页上添加一个 HTML 表单，以让用户通过输入用户名和密码来进行登录。

若要让用户登录，请执行以下操作：
  1. 创建一个新页（“文件”>“新建”）并使用 Dreamweaver 设计工具设计登录页的布局。
  2. 添加一个 HTML 表单，方法是将插入点放在希望该表单出现的地方并从“插入”菜单中选择“表单”。

    3. 即会在该页上创建一个空表单。您可能需要启用“不可见元素”（“查看”>“可视化助理”>“不可见元素”）才能看到该表单的边界（用红色细线来表示）。

  3. 命名该 HTML 表单，方法是单击文档窗口底部的 <form> 标签，打开属性检查器（“窗口”>“属性”），然后在“表单名称”框中输入一个名称。

    4. 您不必为该表单指定 action 或 method 属性来指示它在用户单击“提交”按钮时向哪里以及如何发送记录数据。“插入记录”服务器行为会为您设置这些属性（请参见检查用户名和密码）。

  4. 在该表单上添加一个用户名和一个密码文本域（“插入”>“表单对象”>“文本域”）。

    5. 在每个文本域旁边添加标签文字（以文本或图像的形式），然后将这些文本域放入 HTML 表并将该表的 border 属性设置为 0，以排列这些文本域。

  5. 在该表单上添加一个“提交”按钮（“插入”>“表单对象”>“按钮”）。
  6. 如果需要，请更改“提交”按钮的标签文字，方法是选择该按钮，打开属性检查器（“窗口”>“属性”），然后在“标签文字”框中输入新值。

    7. 例如，下面是标签文字为“Log In”的按钮的属性检查器：
    这是所描述的功能的图片。

下一步是添加“登录用户”服务器行为，以确保输入的用户名和密码有效。


检查用户名和密码

您可以添加“登录用户”服务器行为来确保用户输入的用户名和密码有效。

当用户单击登录页上的“提交”按钮时，“登录用户”服务器行为将对用户输入的值和注册用户的值进行比较。如果这些值匹配，该服务器行为会打开一个页（通常是站点的起始页）。如果这些值不匹配，该服务器行为会打开另一个页（通常是提示用户登录尝试已失败的页）。

若要检查用户名和密码，请执行以下操作：
  1. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击加号 (+) 按钮并从弹出式菜单中选择“用户身份验证”>“登录用户”。

    2. 出现“登录用户”对话框。
    这是所描述的功能的图片。

  2. 完成该对话框。

    3. 有关指导请参见设置“登录用户”对话框选项。

  3. 单击“确定”。

Dreamweaver 在登录页上添加一个服务器行为，它将确保访问者输入的用户名和密码有效。


生成只有授权用户才能访问的页

Web 应用程序可以包含只有授权用户才能访问的受保护页。

备注： Dreamweaver 没有针对 ASP.NET 或 PHP 页的身份验证服务器行为。

例如，如果用户试图通过在浏览器中键入受保护页的 URL 来绕过登录页，则该用户将被重定向到另一页。同样，如果将页的授权级别设置为“管理员”，则只有具有“管理员”访问特权的用户才能查看该页。如果已登录的用户试图访问不具有正确访问特权的受保护页，则该用户将被重定向到另一页。

您也可以使用授权级别在向新注册的用户授予站点的完全访问权限之前对他们进行审查。例如，您可能需要在允许用户访问站点的成员页之前接收付款。为此，可以用“成员”授权级别保护成员页，而仅向新注册的用户授予“来宾”特权。当收到用户的付款后，可以将用户的访问特权升级为“成员”（在注册用户的数据库表中）。

如果您不打算使用授权级别，只需在页面上添加“限制对页的访问”服务器行为即可保护站点上的任何页。该服务器行为会将尚未成功登录的任何用户重定向到另一页。

如果您确实打算使用授权级别，则可以用以下构造块保护站点上的任意页：

  • 用户数据库表中的附加列，用于存储每个用户的访问特权
  • 用于将未授权的用户重定向到另一页的“限制对页的访问”服务器行为

在这种情况下，该服务器行为会将所有不具有所需访问特权的用户重定向到另一页。

在以上两种情况下，可以在受保护的页上添加一个链接，让用户注销并清除任何阶段变量。有关更多信息，请参见注销用户。


将未授权的用户重定向到另一页

为了防止未授权的用户访问某一页，可以在该页上添加“限制对页的访问”服务器行为。如果用户试图通过在浏览器中键入受保护页的 URL 来绕过登录页，或者如果用户已登录但试图访问不具有正确访问特权的受保护页，该服务器行为就会将用户重定向到另一页。

备注： “限制对页的访问”服务器行为只能保护 HTML 页。它不保护其他站点资源，如图像文件和音频文件。

如果要为站点上的多个页授予相同的访问权限，可以拷贝一个页的访问权限，然后将其粘贴到另一个页。

若要将未授权的用户重定向到另一页，请执行以下操作：
  1. 打开要保护的页。
  2. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击加号 (+) 按钮并从弹出式菜单中选择“用户身份验证”>“限制对页的访问”。

    3. 出现“限制对页的访问”对话框。
    这是所描述的功能的图片。

  3. 完成该对话框。

    4. 有关指导请参见设置“限制对页的访问”对话框选项。

  4. 单击“确定”。

Dreamweaver 在页上添加一个服务器行为，它只允许授权用户查看该页。

若要拷贝一个页的访问权限并将其拷贝到站点上的其他页，请执行以下操作：
  1. 打开受保护的页并选择在“服务器行为”面板中列出的“限制对页的访问”服务器行为（而不是加号 (+) 弹出式菜单中的这一服务器行为）。
  2. 单击该面板右上角的箭头按钮，然后从弹出式菜单中选择“拷贝”。

    3. “限制对页的访问”服务器行为被拷贝到系统的剪贴板上。

  3. 按照同一方式打开另一个要保护的页。
  4. 在“服务器行为”面板（“窗口”>“服务器行为”）上，单击右上角的箭头按钮并从弹出式菜单中选择“粘贴”。
  5. 对于每个要保护的页重复第 3 步和第 4 步。


在用户数据库中存储访问特权

只有在需要让某些登录用户具有不同的访问特权时，该构造块才是必需的。如果您只要求用户登录，则不需要存储访问特权。

如果您需要让某些登录用户具有不同的访问特权，请确保用户数据库表包含一个列来指定每个用户的访问权限（“来宾”、“用户”、“管理员”等）。每个用户的访问特权应该由站点管理员在数据库中输入。

在大多数数据库应用程序中，每当新建一个记录时，可以将一个列设置为默认值。将该默认值设置为站点上最常用的访问特权（例如“来宾”），然后手动更改例外的情况（例如，将“来宾”更改为“管理员”）。用户现在即可访问所有管理员页。

确保数据库中的每个用户都具有单一的访问特权（例如“来宾”或“管理员”），而不是多项特权（例如“用户、管理员”）。如果要为您的页设置多项访问特权（例如，所有来宾和管理员都可以查看该页），则在页级别（而不是在数据库级别）设置这些特权。有关更多信息，请参见将未授权的用户重定向到另一页。


注销用户

当用户成功登录后，将创建一个包含其用户名的阶段变量。当用户退出站点时，可以使用“注销用户”服务器行为来清除该阶段变量并将用户重定向到另一页（通常是“再见”或“谢谢”页）。

当用户单击链接或者当指定页加载时，可以调用“注销用户”服务器行为。

若要添加用于让用户注销的链接，请执行以下操作：
  1. 在页上选择要用作该链接的文本或图像。
  2. 在“服务器行为”面板上，单击加号 (+) 按钮并选择“用户身份验证”>“注销用户”。

    3. 出现“注销用户”对话框。

  3. 指定在用户单击该链接时所打开的页。

    4. 该页通常是“再见”或“谢谢”页。

  4. 单击“确定”。
若要在特定页加载时注销用户，请执行以下操作：
  1. 打开将在 Dreamweaver 中加载的页。

    2. 该页通常是“再见”或“谢谢”页。

  2. 在“服务器行为”面板上，单击加号 (+) 按钮并选择“用户身份验证”>“注销用户”。

    3. 出现“注销用户”对话框。

  3. 选择“当页载入时注销”选项。
  4. 单击“确定”。


设置“检查新用户名”对话框选项

此对话框用于在用户注册页上添加一个服务器行为，它将先验证访问者提交的用户名是唯一的，然后才将该访问者添加到注册用户数据库中。

过程

在开始之前，必须先完成以下任务：

  • 在注册页上添加一个 HTML 表单，以便让用户选择选择用户名和密码。有关说明，请参见让用户选择用户名和密码。
  • 在页上添加一个“插入记录”服务器行为，用以更新包含注册用户登录信息的数据库。有关说明，请参见更新数据库中的用户表。

当具备这些先决条件时，就可以按如下方式完成该对话框：

  1. 在“用户名域”弹出式菜单中，选择访问者用来输入用户名的表单文本域。
  2. 在“如果已存在，则转到”框中，指定在数据库表中找到匹配的用户名时所打开的页。

    3. 所打开的页应提示用户该用户名已被使用，并且让用户重试。

  3. 单击“确定”。

当用户单击注册页上的“提交”按钮时，该服务器行为将对用户输入的用户名和存储在注册用户数据库表中的用户名进行比较。如果没有在数据库表中找到匹配的用户名，该服务器行为通常会执行插入记录操作。如果找到匹配的用户名，该服务器行为将取消插入记录操作并打开一个新页（通常是提示用户该用户名已被使用的页）。

相关主题

确保选定的用户名是唯一的

生成注册页


设置“登录用户”对话框选项

此对话框用于在登录页上添加一个服务器行为，它确保访问者输入的用户名和密码有效。

过程

在开始之前，必须先在注册页上添加一个 HTML 表单，用以让用户输入用户名和密码。有关说明，请参见让用户登录。当具备该先决条件后，就可以按如下方式完成“登录用户”对话框：

  1. 指定访问者在输入用户名和密码时所使用的表单和表单对象。
  2. 如果您使用的是 Macromedia ColdFusion，则输入数据源用户名和密码。
  3. 指定包含所有注册用户的用户名和密码的数据库表和列。

    4. 该服务器行为将对访问者在登录页上输入的用户名及密码和这些列中的值进行比较。

  4. 指定在登录过程成功时所打开的页。

    5. 所指定的页通常是站点的起始页。

  5. 指定在登录过程失败时所打开的页。

    6. 所指定的页通常会提示用户登录过程已失败，并且让用户重试。

  6. 如果要让用户在试图访问受限页时前进到登录页，并且在登录后返回到该受限页，请选择“转到前一 URL”选项。

    7. 如果用户未先登录就试图通过打开受限页来访问站点，则受限页可以使该用户前进到登录页。当用户成功登录后，登录页会将该用户重定向到原来使用户前进到登录页的受限页。

    当您在这些页上完成“限制对页的访问”服务器行为的对话框后，确保在“如果访问被拒绝，则转到”框中指定登录页。有关更多信息，请参见设置“限制对页的访问”对话框选项。

  7. 指定是仅根据用户名和密码还是同时根据授权级别来授予对该页的访问权。

    8. 有关更多信息，请参见生成只有授权用户才能访问的页。

  8. 单击“确定”。

当用户单击登录页上的“提交”按钮时，“登录用户”服务器行为将对用户输入的值和注册用户的值进行比较。如果这些值匹配，该服务器行为会打开一个页（通常是站点的起始页）。如果这些值不匹配，该服务器行为会打开另一个页（通常是提示用户登录过程已失败的页）。

相关主题

检查用户名和密码

生成登录页


设置“限制对页的访问”对话框选项

此对话框用于在页上添加一个服务器行为，它只允许授权用户查看该页。

过程
  1. 如果您只希望让具有特定访问特权的用户查看该页，请选择“用户名、密码和访问级别”并指定该页的授权级别。

    2. 例如，通过在授权级别列表中选择“管理员”，可以指定只有那些具有“管理员”特权的用户才能查看该页。

    若要在该列表中添加授权级别，请单击“定义”。在出现的“定义访问级别”列表中，输入一个新的授权级别并单击加号 (+) 按钮。Dreamweaver 会存储该级别，使您不必为每个页键入该级别。确保您输入的字符串精确匹配用户数据库中的字符串。

  2. 如果要为一个页设置多个授权级别，请按住 CTRL 键并单击 (Windows) 或按住 Command 并单击 (Macintosh) 该列表中的级别。

    3. 例如，您可以指定任何具有“来宾”、“成员”或“管理员”特权的用户都能够查看该页。

  3. 指定在未授权用户试图打开受保护页时所打开的页。

    4. 确保您选择的页本身并不受保护。

  4. 单击“确定”。

Dreamweaver 添加一个服务器行为，如果用户试图通过在浏览器中键入受保护页的 URL 来绕过注册页，或者如果用户已登录但试图访问不具有正确访问特权的受保护页，该服务器行为就会将用户重定向到另一页。

相关主题

将未授权的用户重定向到另一页

生成只有授权用户才能访问的页


设置“定义访问级别”对话框选项

此对话框用于在“限制对页的访问”对话框的授权级别列表中添加授权级别。

过程
  1. 在“名称”文本框中，输入新的授权级别。

    2. 确保该授权级别的字符串精确匹配存储在数据库中的字符串。例如，如果数据库中的授权列包含值“Administrator”，则在“名称”框中输入“Administrator”（而不是“Admin”）。

  2. 单击加号 (+) 按钮，将该级别添加到列表中
  3. 单击“确定”返回到“限制对页的访问”对话框。

Dreamweaver 会存储新建的授权级别，以用于其他页。

相关主题

设置“限制对页的访问”对话框选项

将未授权的用户重定向到另一页

生成只有授权用户才能访问的页


设置“注销用户”对话框选项

此对话框用于注销用户并清除在用户登录时创建的阶段变量。

当用户单击链接或者当指定页加载时，可以调用“注销用户”服务器行为。

过程
  1. 如果已选择文本或图像作为注销链接，则指定在用户单击该链接时所打开的页。

    2. 该页通常是“再见”或“谢谢”页。

  2. 如果要在页加载时注销用户，请选择“当页载入时注销”选项。
  3. 单击“确定”。

Dreamweaver 在页上添加该服务器行为。

相关主题

注销用户

上一页


附录

获取开发您的 Web 应用程序所需的更多帮助。

此部分包含以下各章：

  • 数据库初学者指南
  • SQL 入门
  • 在 Windows 中设置 DSN
  • 快速参考：Macromedia ASP.NET 标签


数据库初学者指南

本附录适用于对数据库或数据库连接有很少或没有使用经验的 Macromedia Dreamweaver MX 用户。本附录解释一般性概念，而非特定的操作过程。若要了解这些概念在实践中如何应用，请参阅帮助系统的其余部分。

本附录描述如何设计数据库，但不涉及如何在如 Microsoft Access 或 SQL Server 等应用程序中创建数据库。您的数据库系统所附带的印刷或联机文档描述了该过程。

本附录包含以下章节：

  • 关于数据库
  • 数据库设计基础
  • 理解数据库连接
下一页


关于数据库

数据库的基本组成单位是记录。记录被视为单个实体的相关数据的集合。例如，一个曲棍球商用卡可以称为一条记录：该卡集中了某名运动员的姓名、照片、运动队和相关的统计信息。用数据库术语表示，上述各条相关信息都可以称为一个域：每条曲棍球卡“记录”都具有姓名域、照片域、运动队域以及各种统计信息域。

共享相同域的记录的集合称为表，因为此类信息可方便地以表的格式表示：每一列代表一个域，每一行代表一条记录。实际上，词汇“列”和词汇“域”是同义的，词汇“行”和词汇“记录”是同义的。

一个数据库可包含多个表，每个表具有唯一的名称。这些表可以是相关的，也可以是彼此独立的。

从一个或多个表中提取的数据子集称为记录集（在 ASP.NET 中称为数据集）。记录集也是一种表，因为它是共享相同列的记录的集合。例如，列有运动员姓名和司职位置的曲棍球运动队花名册可以称为记录集：它由所有可能与运动员相关的信息（如得分、助攻、罚球记录等等）的子集组成。

若要创建记录集，需要运行数据库查询。查询由搜索条件组成。例如，查询可指定记录集中仅包含特定列或仅包含特定记录。有关更多信息，请参见定义记录集。

相关主题

数据库设计基础

理解数据库连接


数据库设计基础

数据库设计是构建任何数据库驱动的 Web 站点的第一步。本节提供一个案例研究，来解释基本的数据库设计原则。该案例研究涉及一个由名为 Arrow Aircraft Services 的虚构公司委托开发的 Web 应用程序。该公司经营一小队私人拥有的商用喷气式飞机。

本节包含以下主题：

  • 研究 Arrow Aircraft 的业务规则和策略
  • 研究 Arrow Aircraft 的功能要求
  • 用户将向数据库询问什么问题？
  • 选择数据库中包含的表
  • 选择每个表中的列
  • 定义表之间的关系
  • 创建数据库


研究 Arrow Aircraft 的业务规则和策略

假设根据某份合同，您受雇为 Arrow Aircraft Services 构建一个 Web 应用程序。在开始设计数据库之前，您需要确保理解了该组织的所有将影响应用程序的业务规则和策略。本节描述了 Arrow Aircraft Services 的简化的业务规则和策略。

Arrow Aircraft 经营一队五架分属不同所有者的不同大小和型号的商用喷气机。每架喷气机最多可有八位部分所有者（已购买该飞机股份的公司或个人）。不需要全年使用商用喷气机的人士比较欢迎此类安排方式。

部分所有者（或者也可称为“股份持有者”）需要向 Arrow Aircraft 支付以下费用：

  • 与所有者持有的飞机股份成比例的月管理费，用于抵销飞行员、保险和飞机库成本
  • 用于抵销所有诸如维护、引擎备用和餐饮等直接成本的每小时“占用”费

作为交换，股份持有者告诉 Arrow Aircraft 何时需要飞往何地，Arrow Aircraft 负责其他事情，包括雇用航班和地勤人员以及为航班人员准备餐饮。Arrow Aircraft 要求至少提前 8 小时提出申请才能准备一次飞行。

Arrow Aircraft 保证每架飞机每年的“占用小时数”达到 800 小时。占用小时数是指喷气机处于飞行中而且被至少一个乘客所占用的小时数。占用小时数在乘客搭载的飞机起飞前六分钟（一个小时的十分之一）开始计算，到飞机降落后六分钟结束。

每架飞机最多可有八位所有者。例如，一个个人或公司可购买一架喷气机的 1/5 股权（或 1/5 股份）。由于 Arrow Aircraft 保证每年 800 小时的占用飞行小时数，因此持有 1/5 股份的所有者具有 160 小时的占用小时数（800 小时 / 5 = 160 小时）。


研究 Arrow Aircraft 的功能要求

Arrow Aircraft 雇用您构建具有以下功能的 Web 应用程序：

  • 允许任何飞机股份持有者请求飞机进行飞行
  • 向公司的“飞行运作部门”提供开始准备飞机飞行所需的所有信息，包括股份持有者请求的详细信息（路线、出发日期和时间、餐饮需求等）、股份持有者的剩余占用小时数以及对于建议行程可用的飞机
  • 允许“飞行运作部门”预订飞机以防止日程冲突


用户将向数据库询问什么问题？

在您熟悉了所建议的有关该 Web 应用程序的功能后，您可以与该数据库的用户们一起协商，并提出以下问题：“您将向数据库询问什么问题？”

您从一些飞机股份持有者那里了解到他们希望询问数据库以下问题：

  • 我还剩下多少占用小时数？
  • 我的飞机在特定日期或特定日期范围是否可用？

在某股份持有者请求飞机后，“飞行运作部门”的雇员将询问数据库以下问题：

  • 该股份持有者希望飞往何地？
  • 飞行路线是单程、往返还是途经多个城市？“飞行运作部门”需要这些信息以开始制定飞行计划（查看天气预报、提出飞行计划等）并估计总占用小时数。
  • 该股份持有者剩余的占用小时数是否足够用于计划的路线？
  • 该股份持有者希望何时出发？
  • 该股份持有者的飞机是什么型号？
  • 该飞机是否可用于计划的路线？
  • 该股份持有者随行乘客有多少？
  • 他们将携带多少行李 - 轻（手提行李）、普通（每位乘客一个手提箱）或重（每位乘客有多个手提箱）？
  • 该股份持有者的餐饮需求如何？
  • 该飞机的每小时占用费如何？
  • 我在何处能联系到该股份持有者以确认本次飞行和估计的费用？


选择数据库中包含的表

在了解到用户将询问数据库的问题后，可思考应如何构造数据库才能最圆满地回答他们的问题。第一步是选择数据库中的表。

在关系数据库中，所有数据都表示在表的行和列中。每个表都描述了诸如人员、对象或事件的相关实体的集合。每行都描述实体的一个匹配项，每列都描述实体的一个属性。例如，人员的姓氏、对象的颜色或事件的日期。

可为 Arrow Aircraft 数据库选择以下五个表：

  • 一个飞机表，描述由 Arrow Aircraft 经营的所有商用喷气机
  • 一个飞机预订表，列出喷气机已被预订或无法飞行的所有日期
  • 一个股份持有者表，描述拥有喷气机股份的所有公司和个人
  • 一个路线表，描述股份持有者请求的所有路线
  • 一个飞行表，描述路线的各段行程（“航程”）。


选择每个表中的列

下一步是选择每个表中的列。这些列描述了表中每个实体的属性。

选择列时的一个很好的经验规则是避免重复的数据。例如，在 Arrow Aircraft 应用程序中，您知道股份持有者姓名一定会与路线数据一起用于回答以下“飞行运作部门”问题：“股份持有者对特定路线的餐饮需求如何？”

一种方法是使股份持有者表和路线表都具有股份持有者的名字和姓氏列。但是，这不但使两个表中的姓名数据重复，而且将在路线表中若干次重复这些数据（在股份持有者每次请求新路线时，都必须在路线表中输入股份持有者的姓名）。此方法将增加数据输入的工作，带来出错的机会，并会危及数据的完整性（在数据库的一部分中进行更改，在数据库的其他部分也必须进行更改）。

一个好得多的解决方案是在一个表（股份持有者表）中仅输入一次股份持有者的名字和姓氏。当需要回答上面的“飞行运作部门”问题时，您可以使用 SQL 表达式将股份持有者表与路线表联接。

确保每个表都有一个主键列。主键列包含的值对于每一行都是唯一的。这使您能够在搜索数据库时准确地找到所需的行。大多数主键列由 ID 号组成，但也可使用自然的主键，例如政府规定的编号或飞机序列号。

经过一番思考后，为 Arrow Aircraft 数据库中的表选择了以下属性和主键：


定义表之间的关系

在定义了表中的基本列和主键后，可开始定义表之间的关系。定义了关系后，就可在 Dreamweaver MX 中编写 SQL 语句，以合并两个表的数据（请参见联接表）。

例如，由 Arrow Aircraft 经营的每架飞机都有若干个股份持有者。您希望在飞机表中的每架飞机与股份持有者表中的股份持有者之间建立类似于“一对多”的关系。这将使您不必在股份持有者表中输入和跟踪冗余的飞机数据。

在一对多数据库关系中，一个表中的单个行与另一个表中的多个行相关。您可通过使提供多个行的表（在上述示例中，就是股份持有者表）中包括外键来定义这种关系。外键是所包含的值与另一个表主键列中的值相匹配的列。飞机表的主键称为 ac_serial。因此，在股份持有者表中包括称为 ac_serial 的外键将定义一个“一架飞机对多个股份持有者”的关系。

在了解了客户的功能要求和公司的业务规则及策略后，您决定在数据库中定义以下一对多关系：

  • 每架飞机有多位股份持有者
  • 每架飞机有多次预订
  • 每架飞机有多条路线
  • 每位股份持有者有多条路线
  • 每条路线可有多段行程（或航程）

下面是添加了定义这些关系的外键后修订的表关系图：

这些关系图称为 E-R 关系图或实体关系关系图。


创建数据库

最后的设计步骤是使用类似 Microsoft Access、SQL Server、Oracle9i 或 MySQL 的数据库系统创建数据库。请参考您的数据库系统文档以获取更多信息。


理解数据库连接

如果您计划将数据库与 Web 应用程序一起使用，至少需要创建一个数据库连接。如果没有数据库连接，应用程序将不知道在何处找到数据库或如何与之连接。可通过提供应用程序与数据库建立联系所需的信息或“参数”，在 Dreamweaver 中创建数据库连接。

备注： 在 Dreamweaver MX 中，不需要为 ColdFusion 页创建数据库连接，可使用“ColdFusion 管理员”中定义的 ColdFusion 数据源进行连接。

本节用常规术语讨论数据库连接。有关在 Dreamweaver MX 中创建连接的详尽说明，请参见连接到数据库。


与数据库相接

存储在数据库中的数据通常有专有的格式，就象字处理器文件中的文本以专有格式存储一样。例如，数据在 Microsoft Access 中类似于此处显示的形式：

相同的数据库在“记事本”中类似于此处显示的形式：

您的 Web 应用程序与“记事本”或其他任何应用程序一样，在试图访问未知格式的数据时面临同样的问题：应用程序无法解释这些数据。这就需要在 Web 应用程序与数据库之间存在一个软件接口，以允许应用程序和数据库互相进行通信。

三种常见接口可以使应用程序与数据库进行通信。第一种称为“开放式数据库连接”（或 ODBC）；第二种称为 OLE DB（对象链接和嵌入数据库）；第三种称为“Java 数据库连接”（或 JDBC）。

这些接口的工作类似于翻译人员。例如，当在联合国进行英语演讲时，一名翻译人员为说法语的代表进行翻译，同时另一名翻译人员为说德语的代表进行翻译。与此类似，您可为“说”OLE DB 的应用程序使用一种接口，为“说”ODBC 的 Web 应用程序使用另一种接口，还可为“说”JDBC 的应用程序使用另外一种接口。ColdFusion MX 和 JSP 应用程序使用 JDBC，ASP 和 ASP.NET 应用程序使用 OLE DB，而 ColdFusion 4 或 5 应用程序使用 ODBC 和 OLE DB。

由于具有内置的 OLE DB/ODBC“翻译人员”（解释程序），ASP 应用程序（而非 ASP.NET 应用程序）可流利地“说”ODBC。例如，假设您希望通过使用 ODBC 接口使应用程序与 Microsoft Access 数据库进行通信。在 ASP 中，如果仅指定 ODBC 接口，而没有指定 OLE DB 接口，默认情况下，应用程序将使用 OLE DB/ODBC 解释程序将 OLE DB 翻译为 ODBC，然后它将使用您所指定的 ODBC/Access 解释程序将 ODBC 翻译为 Access 能够理解的内容。

以下插图可帮助您理解该过程：

备注： SQL 服务器和 DB2 分别是 Microsoft 和 IBM 的基于服务器的数据库系统。


使用数据库驱动程序与数据库相接

ODBC、OLE DB 和 JDBC 接口由数据库驱动程序（在 OLE DB 中称为“数据提供程序”）实现，这些接口仅是软件片段。当 Web 应用程序与数据库进行通信时，应用程序是通过驱动程序的中间作用实现通信的。

数据库驱动程序是特定于数据库的。例如，可以使用 Microsoft Access、SQL Server 和 dBase 驱动程序。与此类似，您可使用 OLE DB 提供程序，例如用于 SQL Server 的 OLE DB 提供程序。您的数据库决定了您的选择。

驱动程序由诸如 Microsoft 和 Oracle 等数据库供应商编写，也可由各个第三方软件供应商编写。Microsoft 为最流行的数据库软件包（如 Microsoft Access、Microsoft SQL Server 和 Oracle）提供许多 ODBC 驱动程序和 OLE DB 提供程序。ODBC 驱动程序仅运行于 Windows 平台，自动随 Microsoft Office 和 Windows 2000 安装，也可随 Microsoft 数据访问组件 (MDAC) 2.5、2.6 和 2.7 软件包安装。这些软件包可从 Microsoft Web 站点 免费下载。MDAC 2.6 可安装许多 OLE DB 提供程序。

备注： 首先安装 MDAC 2.5，然后安装 MDAC 2.6。

若要了解您的 Windows 系统上安装了哪些 ODBC 驱动程序，请参见查看安装在 Windows 系统上的 ODBC 驱动程序。

因为 Macintosh 很少用作数据库平台，所以很少有用于它的 ODBC 驱动程序。

一些常见 JDBC 驱动程序包括用于 Microsoft SQL Server 数据库的 i-net JDBC 驱动程序、用于 Oracle 数据库的 Oracle Thin 驱动程序和用于 IBM DB2 数据库的 JDBC Driver for DB2。有关 JDBC 驱动程序及其供应商的更多信息，请访问 Sun Web 站点 上 JDBC 驱动程序的可搜索数据库。

此处是用于各种类型 Web 应用程序的数据库接口及一些常见的数据库驱动程序：

Web 应用程序 | 数据库接口 | 常见驱动程序
ColdFusion MX JSP | JDBC | Sun JDBC-ODBC 驱动程序 用于 SQL Server 的 i-net Sprinta JDBC 驱动程序 Oracle Thin JDBC 驱动程序
ColdFusion 4 或 5 | ODBC 或 OLE DB | ColdFusion 本身的驱动程序 Microsoft Access Driver Microsoft SQL Server Driver
ASP | ODBC 或 OLE DB | Microsoft Access Driver Microsoft SQL Server Driver Microsoft SQL Server Provider Microsoft ODBC for Oracle
ASP.NET | OLE DB | Microsoft Jet Provider Microsoft SQL Server Provider Microsoft Oracle 提供程序
PHP | 特定于 MySQL | MySQL 驱动程序


查看安装在 Windows 系统上的 ODBC 驱动程序

如果您需要特定的 ODBC 驱动程序，并且您的 Web 服务器运行于 Windows 系统上，则可方便地知道系统上是否安装有所需的 ODBC 驱动程序。

若要查看 Windows 系统上安装的 ODBC 驱动程序：
  1. 按以下步骤打开“ODBC 数据源管理器”：
    • 在 Windows 95、98 或 NT 中，选择“开始”>“设置”>“控制面板”，然后双击“ODBC 数据源”图标。根据系统的不同，该图标也可能称为 ODBC 或“32 位 ODBC”。
    • 在 Windows 2000 中，选择“开始”>“设置”>“控制面板”>“管理工具”>“数据源”。
    • 在 Windows XP 中，选择“开始”>“控制面板”>“性能和维护”>“管理工具”>“数据源 (ODBC)”。
  2. 单击“驱动程序”选项卡。

    3. 将会出现系统上所安装的 ODBC 驱动程序的列表。
    这是所描述的功能的图片。


调用数据库驱动程序

应用程序必须调用数据库驱动程序才能建立与数据库的双向通信。Web 应用程序通过使用连接字符串来调用驱动程序。连接字符串由建立到数据库的连接所需的全部信息（或参数）组成。连接字符串可用类似于以下示例的最简单形式指定驱动程序和数据库：

Driver={Microsoft Access Driver (*.mdb)};
DBQ=C:\Inetpub\wwwroot\Scaal\scaalcoffee.mdb

ASP 连接字符串可包含指定 OLE DB 提供程序的 Provider 参数。如果省略此参数，默认情况下，ASP 为 ODBC 驱动程序使用 OLE DB 提供程序。在上面的示例中，用于 ODBC 驱动程序的 OLE DB 提供程序将与 ODBC 驱动程序 (Microsoft Access Driver) 进行通信，而 Microsoft Access Driver 又将与 Access 数据库 (scaalcoffee.mdb) 进行通信。

根据驱动程序的不同，连接字符串中的参数可能不同。下面是一个用于名为 Cases 的 SQL Server 数据库的连接字符串，Cases 位于名为 Hoover 的服务器上：

Driver={SQL Server};Server=Hoover;Database=Cases;
UID=DanaS;PWD=Queequeg

备注： UID 表示用户 ID，PWD 表示密码。

Dreamweaver 通过向您提供可在其中输入不同连接参数的对话框，简化了向页面中插入连接字符串的过程。例如，此处显示在开发 JSP 应用程序时，定义连接的对话框的外观：

在完成对话框设置并单击“确定”后，Dreamweaver 将连接字符串插入到站点的包含文件中。


在连接字符串中使用 DSN

可在一些连接中指定数据源名称 (DSN)。DSN 是在 Windows 中为连接字符串创建的一种快捷方式。定义后，就可以通过名称引用连接字符串了。例如，连接字符串可能由以下参数组成：

Driver={SQL Server};Server=Clinic-6;Database=Patients;
UID=dholmes;PWD=stetson2

在 Windows 中使用上面的参数定义一个称为 patients 的 DSN 后，就可以通过指定单个参数在应用程序中使用该连接字符串了：

dsn=patients

如果应用程序服务器运行于 Windows 系统上，并且您在该系统中定义了 DSN，则可以使用该 DSN 定义 ASP 或 ColdFusion 4 或 5 连接。

如果您不具有对服务器的物理访问权限，无法在其上定义 DSN，则您必须使用连接字符串来连接到该数据库。

有关更多信息，请参见在 Windows 中设置 DSN。

上一页


SQL 入门

本附录说明如何使用“结构化查询语言”（Structured Query Language，SQL）为动态页创建记录集。SQL（发音是 sequel）是一种用来从数据库中读取数据以及将数据写入数据库中的语言。虽然该语言仅使用几个关键字和一些非常简单的语法规则，但仍然允许您执行复杂的数据库操作。

本附录包含以下章节：

  • 语法基础知识
  • 定义记录集的列
  • 限制记录集中的记录
  • 对记录集中的记录进行排序
  • 联接表

相关主题：

关于数据库

数据库设计基础

定义记录集

备注： Macromedia 不为第三方技术（如 SQL）提供技术支持。
下一页


语法基础知识

最常用的 SQL 语句之一是 SELECT 语句，它可从一个或多个数据库表中提取指定列，以生成一个记录集。下面是 SELECT 语句的基本语法：

SELECT ColumnName FROM TableName

可以在语句中添加换行符、制表符和其他空白，以使逻辑关系更加清晰：SQL 忽略所有空白。下面是一个有效语句的示例：

SELECT PaidDues
   FROM Members

下列关键字标识常用的 SQL 命令：

关键字 | 说明
SELECT | 从数据库中检索指定的记录
INSERT | 在数据库表中添加新记录
UPDATE | 更改指定数据库记录中的值
DELETE | 移除指定的数据库记录

下列关键字使 SQL 语句更精确：

关键字 | 说明
FROM | 为操作指定数据源
WHERE | 为操作设置一个或多个条件
ORDER BY | 按指定顺序对记录集行进行排序
GROUP BY | 按指定的选择列表项将记录集进行分组

下列运算符指定条件并执行逻辑和数字运算功能：

运算符 | 意义
= | 等于
LIKE | 类似于（支持通配符）
<> | 不等于
NOT LIKE | 不类似于（支持通配符）
< | 小于
> | 大于
<= | 小于或等于
>= | 大于或等于
AND | 两个条件都必须满足，如：上海 AND 北京
OR | 至少必须满足其中一个条件，如：老张 OR 老王
NOT | 排除后跟的条件，如：巴黎 NOT 法国

如果比较的项是文本，请将其放在单引号中，如下例中所示：

...WHERE Country = 'Germany'

如果比较的项是日期，而且使用的是 Microsoft Access 数据库，请将日期放在两个 # 符号之间：

...WHERE DateOfBirth < #01/01/1970#

其他数据库可能有其自己的日期约定。请查看数据库系统的文档。

一些数据库系统可能在其产品中使用非标准的 SQL 语法。请查看数据库系统的文档。


定义记录集的列

可使用 SQL 为页面定义记录集。记录集是从数据库中提取的记录的子集。有关更多信息，请参见关于数据库。

下面是用来定义记录集的列的基本 SQL 语法：

SELECT ColumnName1, ColumnName2, ColumnNameX FROM TableName

如果要在记录集中包含某个表的所有列，可以使用通配符 *，如下所示：

SELECT * FROM TableName

例如，假设有一个名为 Customers 的表。若要提取所有列，可键入下列 SELECT 语句：

SELECT * FROM Customers

假设只需要 Customers 表内以下两列中包含的数据：YearBorn 列和 DateLastPurchase 列。若要创建只包含这两列中数据的记录集，可键入下列 SELECT 语句：

SELECT YearBorn, DateLastPurchase
FROM Customers


限制记录集中的记录

使用 WHERE 子句限制记录集中的记录数。例如，可能只希望包含年薪高于 50,000 美元的那些客户。假设表中有名为 Earnings 的列，该列列出了每位客户的收入。所使用的 SELECT 语句应如下所示：

SELECT YearBorn, DateLastPurchase FROM Customers
WHERE Earnings > 50000

可以在 WHERE 子句中指定一个或多个条件，以筛选出数据库中的记录。以下章节描述使用 WHERE 子句筛选记录的方法：

  • 根据两个值是否相等筛选记录
  • 根据两个值之间的相似性筛选记录
  • 根据值的范围筛选记录
  • 根据组合搜索条件筛选记录


根据两个值是否相等筛选记录

可以根据参数的值与记录列的值是否相等来筛选数据库中的记录。

假设决定让用户按部门搜索数据库。则必须满足下列逻辑关系才能生成搜索结果记录集：

  • 检查数据库表中的一个记录。
  • 如果该记录“department”列中的值等于用户提交的部门名称，则在搜索结果记录集中包含该记录。
  • 检查表中的下一条记录。

可以使用下列 WHERE 子句表达这种逻辑关系：

WHERE ColumnName = ParameterValue

ParameterValue 是包含搜索参数的 SQL 变量。在 Web 应用程序中，用户通常使用 HTML 表单提供此参数。

可以完全用 SQL 表达这种数据库查询，如下所示：

SELECT FIRSTNAME, LASTNAME, DEPARTMENT, EMAIL
FROM EMPLOYEES
WHERE DEPARTMENT = 'varDept'

此 SQL 语句在雇员表中查找 DEPARTMENT 值等于 varDept 变量中所包含值的所有记录。例如，如果用户指定 Operations 作为部门名称，则该 SQL 语句可能生成下列记录集：


根据两个值之间的相似性筛选记录

可以根据参数值与记录列的值的相似性，对数据库中的记录进行筛选。

在指定搜索参数的值时，使用相似性而不是相等性，可以给予用户更大的灵活性。例如，搜索字不需要区分大小写。如果用户输入“ohio”，而表列中包含值“Ohio”，则产生匹配。

而且，相似性允许使用通配符，以便用户可以搜索字母或搜索单词中的一部分。例如，如果用户输入“m”，而且表列中包含值“Morgan”、“Macy”和“Michelson”，则可在 SQL 语句中使用通配符，以便与所有这三个项匹配。

标准通配符是百分号 (%)：

...WHERE LastName LIKE 'Mc%'

假设决定让用户按姓氏搜索数据库。则必须满足下列逻辑关系才能生成搜索结果记录集：

  • 检查数据库表中的一个记录。
  • 如果该记录“Last name”列中的值包含类似于用户提交的值，则在结果记录集中包含该记录。
  • 检查表中的下一条记录。

可以使用下列 WHERE 子句表达这种逻辑关系：

WHERE ColumnName LIKE ParameterValue

ParameterValue 是包含搜索参数的 SQL 变量。在 Web 应用程序中，用户通常使用 HTML 表单提供此参数。

可以完全用 SQL 表达这种数据库查询，如下所示：

SELECT FIRSTNAME, LASTNAME, DEPARTMENT, EMAIL
FROM EMPLOYEES
WHERE DEPARTMENT LIKE 'varLastName'

如果要使用户能够搜索部分单词，可组合使用变量和通配符。这种情况下使用的 SQL 通配符是百分号 (%)。示例如下：

...WHERE LASTNAME LIKE 'varLastName%'

例如，如果用户键入“s”作为搜索参数，则姓氏以字母“s”开头的所有记录都包含在记录集中，如下面的示例所示：

如果用户指定 “sm” 作为搜索参数，则只有姓氏以字母“sm” 开头的那些记录包含在记录集中：


根据值的范围筛选记录

可以根据记录列的值是否在两个参数值的范围之间来筛选数据库中的记录。

假设决定让用户按日期范围来搜索数据库。则必须满足下列逻辑关系才能生成搜索结果记录集：

  • 检查数据库表中的一个记录。
  • 如果该记录 “date”列中的值在用户提交的两个日期值之间，则在结果记录集中包含该记录。
  • 检查表中的下一条记录。

可以使用下列 WHERE 子句表达这种逻辑关系：

WHERE ColumnName BETWEEN ParameterValue1 AND ParameterValue2

ParameterValue1 和 ParameterValue2 是包含搜索参数的 SQL 变量。在 Web 应用程序中，用户通常使用 HTML 表单提供这些参数。

以下示例说明如何用 SQL 表达这种数据库查询：

SELECT FIRSTNAME, LASTNAME, DEPARTMENT, STARTDATE
FROM EMPLOYEES
WHERE STARTDATE BETWEEN #varStartRange# AND #varEndRange#

例如，如果用户输入“7/1/99”和“12/31/99”作为范围参数，则 1999 年下半年加盟的所有雇员都将包含在记录集中，如下面的示例中所示：


根据组合搜索条件筛选记录

本节描述如何根据组合搜索条件在搜索结果记录集中包含记录。在 SQL 中可以使用 AND、OR 和 NOT 逻辑运算符组合搜索条件。

如果希望所有条件都为 true，记录才能包含在记录集中，请使用 AND 运算符，如下所示：

...WHERE LASTNAME LIKE 'varLastName' AND DEPARTMENT LIKE 'varDept'

如果希望只要其中任何一个条件为 true，记录就可以包含在记录集中，请使用 OR 运算符，如下所示：

...WHERE LASTNAME LIKE 'varLastName' OR DEPARTMENT LIKE 'varDept'

如果希望其中一个条件为 true，而另一个条件不为 true，请使用 NOT 运算符，如下所示：

...WHERE DEPARTMENT LIKE 'varDept' AND NOT COUNTRY LIKE 'varCountry'

可以使用括号组合搜索条件：

...WHERE (DEPARTMENT LIKE 'varDept' AND STARTDATE < #varStart#)
OR STARTDATE BETWEEN #varStartRange# AND #varEndRange#


对记录集中的记录进行排序

使用 ORDER BY 子句对记录集中的记录进行排序。例如，假设希望按客户收入从最低到最高对记录集中的记录进行排序。在 SQL 中，按如下所示对记录进行排序：

SELECT LastName, FirstName, Earnings FROM Customers
ORDER BY Earnings

默认情况下，ORDER BY 子句按升序（1、2、3... 或 A、B、C...）对记录进行排序。如果希望按降序对记录进行排序，从最高收入到最低收入，请使用 DESC 关键字，如下所示：

ORDER BY Earnings DESC


联接表

可以使用一个 SELECT 语句从数据库的多个表中检索数据。该语句联接表，并返回一个包含每个表中所选数据的记录集。

例如，公司数据库可能包含两个表，一个表是有关雇员的个人数据，另一个表是有关公司部门的数据。如果要生成一个显示雇员姓名、电话号码和部门的雇员名录，则必须同时从两个表中检索信息。

为此，请创建一个联接，指定要包含的所有表以及表彼此之间如何关联。示例如下：

SELECT FIRSTNAME, LASTNAME, PHONE, DEPTNAME
FROM EMPLOYEES, DEPARTMENTS
WHERE EMPLOYEES.DEPT_ID = DEPARTMENTS.DEPT_ID

备注： 使用点标记可以更精确地标识列。例如，EMPLOYEES.DEPT_ID 指 EMPLOYEES 表中的 DEPT_ID 列。

第一行指定要检索的列。前三列 FIRSTNAME、LASTNAME、PHONE 存在于 EMPLOYEES 表中，而第四列 DEPTNAME 只存在于 DEPARTMENTS 表中。

第二行指定要从中检索数据的两个表：EMPLOYEES 和 DEPARTMENTS。

最后一行指定要在两个表中进行联接和检索的记录。每个表中都有一个名为 DEPT_ID 的列。（在 DEPARTMENTS 表中，该列为主键。有关更多信息，请参见定义表之间的关系。）WHERE 子句将一个表中 DEPT_ID 的值与另一个表中 DEPT_ID 的值进行比较。如果找到匹配项，则将 EMPLOYEES 表中该记录的所有域与 DEPARTMENTS 表中该记录的所有域相联接。然后，对合并数据进行筛选，以创建由 FIRSTNAME、LASTNAME、PHONE 和 DEPTNAME 列组成的新记录。最后，将新记录添加到记录集中。

在一些数据库系统中使用稍有不同的联接语法可能会更好。例如，下列 SQL 语句使用 SQL 关键字 INNER JOIN...ON 来获得与上例相同的结果：

SELECT FIRSTNAME, LASTNAME, PHONE, DEPTNAME
FROM EMPLOYEES INNER JOIN DEPARTMENTS
ON EMPLOYEES.DEPT_ID = DEPARTMENTS.DEPT_ID

请查阅数据库系统的文档来确定应使用的联接语法。

相关主题

定义表之间的关系

上一页


在 Windows 中设置 DSN

DSN 是一种用于建立数据库连接（请参见理解数据库连接）的 Windows 快捷方式。必须依照本附录中的描述在计算机或远程服务器上设置 DSN 后，才能在 Web 应用程序中使用它。

只有数据库位于支持 ODBC 数据源名称 (DSN) 的系统中时，本附录才适用，这些系统包括如 Microsoft Windows 和 Windows NT，但不包括 Macintosh。

本附录包含下列章节：

  • 了解 DSN
  • 创建 DSN
下一页


了解 DSN

DSN 是表示一组数据库连接参数的单词标识符。这些参数包括服务器名称、指向数据库的路径或数据库名称、要使用的 ODBC 驱动程序、用户名和密码（如果有的话）。

例如，假设有一个名为 Precinct 的 Microsoft SQL Server 数据库，该数据库位于叫做 Kojak 的服务器上。为了能够访问该数据库，必须输入用户名“columbo”和密码“savalas7”。在使用这些参数定义一个名为“ourcops”的 DSN 之后，可以通过在 Dreamweaver MX 中输入单词 ourcops 创建连接，而不必输入所有的其他参数。

相关主题

创建 DSN


创建 DSN

若要创建 DSN，在运行应用程序服务器的 Windows 计算机上必须安装有用于您的数据库的 ODBC 驱动程序。ODBC（即开放式数据库连接）是一个使应用程序和数据库进行通信的软件媒介。有关更多信息，请参见与数据库相接。

确保系统中有适用于您的数据库的驱动程序。 有关 Windows 95、98 或 NT 系统中的 ODBC 驱动程序的列表，请选择“开始”>“设置”>“控制面板”，然后双击“ODBC 数据源”图标。（根据您的系统，该图标也可能称为 ODBC 或 32 位 ODBC。）单击“驱动程序”选项卡时，将看到安装在系统上的驱动程序列表。在 Windows 2000 中，选择“开始”>“设置”>“控制面板”>“管理工具”>“数据源”，然后单击“驱动程序”选项卡。在 Windows XP 中，选择“开始”>“控制面板”>“性能和维护”>“管理工具”>“数据源 (ODBC)”，然后单击“驱动程序”选项卡。

如果所需要的驱动程序尚未安装，则请下载并安装 Microsoft 数据访问组件 (MDAC) 2.5 和 2.6 软件包，这些软件包可以从 Microsoft Web 站点免费下载。这些软件包包含最常见数据库的最新 Microsoft ODBC 驱动程序。

备注： 首先安装 MDAC 2.5，然后安装 MDAC 2.6。

如果 MDAC 中没有用于您的数据库的 ODBC 驱动程序，请与您的数据库供应商联系。

若要创建 DSN：
  1. 按照如下步骤打开 Windows 的“ODBC 数据源管理器”：
    • 在 Windows 95、98 或 NT 中，选择“开始”>“设置”>“控制面板”，然后双击“ODBC 数据源”图标。根据您的系统，该图标也可能称作 ODBC 或 32 位 ODBC。
    • 在 Windows 2000 中，选择“开始”>“设置”>“控制面板”>“管理工具”>“数据源”。
    • 在 Windows XP 中，选择“开始”>“控制面板”>“性能和维护”>“管理工具”>“数据源 (ODBC)”。
  2. 在创建 DSN 连接所使用的 Dreamweaver 对话框中，单击“定义”按钮。

    3. 出现“ODBC 数据源管理器”：
    这是所描述的功能的图片。

  3. 单击“系统DSN”选项卡。

    4. 该选项卡显示当前您的系统中的 DSN 列表。

  4. 单击“添加”，向列表中添加新的 DSN。

    5. 出现“创建新数据源”对话框，列出当前您的系统上载入的所有驱动程序。

  5. 从该列表中选择一个驱动程序，然后单击“完成”。

    6. 例如，如果您的数据库是 Microsoft Access 文件，请选择 Microsoft Access Driver (*.mdb)。如果您的产品的驱动程序没有显示在列表中，则应从供应商的 Web 站点下载该驱动程序并安装它。

  6. 在显示的对话框中，输入 DSN 的名称，并指定连接参数。

    7. 用于指定参数的对话框根据所选择驱动程序的不同而有所不同。对于 Microsoft Access Driver，请输入一个名称，单击“选择”，在硬盘上找到该数据库文件，然后单击“确定”。

  7. 单击“确定”关闭该对话框。

    8. 这个新的 DSN 就被添加到了系统 DSN 列表中。

上一页


快速参考：Macromedia ASP.NET 标签

Macromedia Dreamweaver MX 使用一组自定义标签来在 ASP.NET 页中创建服务器行为。您也可以在自己的 ASP.NET 页中使用这些标签。

本附录介绍以下 Macromedia 自定义标签：

  • MM:DataSet
  • MM:If

Dreamweaver 还使用以下标签来创建服务器行为：

  • MM:Insert
  • MM:Update
  • MM:Delete

最后，如果标签包含采用参数的 SQL 语句或预存过程，请使用以下两种标签来指定参数值：

  • Parameters
  • Parameter

备注： 与 Microsoft ASP.NET 标签相似，每个 Macromedia 自定义标签都需要 runat="server" 属性。

有关这些标签及其属性的详细说明，请访问 Dreamweaver 支持中心。

下一页


MM:DataSet

使用 MM:DataSet 标签可创建数据集。ASP.NET 数据集与 ASP 记录集非常类似。


示例

<MM:DataSet
id="fruitsDS"
runat="server"
CommandText=”SELECT name, color FROM fruits”
ConnectionString=<%# MM_NOTD_STRING %>
/>


必需的指令

<%@ Register TagPrefix="MM" Namespace="DreamweaverCtrls" Assembly="DreamweaverCtrls,version=1.0.0.0,publickeyToken=836f606ede05d46a,culture=neutral" %>

如果将使用参数标签，则通常（但不是始终）会需要以下指令：

<%@ Import Namespace="System.Data" %>
<%@ Import Namespace="System.Data.SqlClient" %>
<%@ Import Namespace="System.Data.OleDb" %>


属性

CommandText

必需。指定 SQL 语句或预存过程的名称。SQL 语句可以通过将问号用作占位符来进行参数化。请参见Parameters。

ConnectionString

必需。指定连接字符串，该字符串包含连接到数据库所需的信息。

CreateDataSet

可选。真或假。如果为假，则不创建任何数据集。默认为真。

Expression

可选。真或假。用于控制在何时执行 CommandText 语句。如果为假，则不执行 CommandText 语句。您可以通过编程来切换该值。

IsStoredProcedure

可选。真或假。用于指明 CommandText 的性质。默认值为假。

PageSize

可选。整数。当 CreateDataSet 为真时，可以将记录分为固定大小的组（页）。请参见“CurrentPage”。不要同时设置 PageSize/CurrentPage 和 StartRecord/MaxRecords。如果同时指定这两组属性，则将采用前者 (PageSize/CurrentPage)。

CurrentPage

可选。整数。当使用 PageSize 时，可以指定特定页（记录集）。第一页的索引为零。请参见“PageSize”。

StartRecord

可选。整数。相对于数据集中第一个记录的偏移量（第一个记录的索引为零）。当 CreateDataSet 为真时，可以随 MaxRecords 属性一起检索记录的子集。不要同时设置 PageSize/CurrentPage 和 StartRecord/MaxRecords。如果同时指定这两组属性，则将采用前者 (PageSize/CurrentPage)。如果 PageSize 大于零，则 StartRecord 会自动按照 (PageSize * CurrentPage) 来计算。

MaxRecords

可选。整数。用于指定从 StartRecord 偏移量开始可以检索多少个记录。请参见“StartRecord”。

GetRecordCount

可选。真或假。当使用 PageSize 时，可以关闭记录计数功能以提高性能。如果该页从不使用 RecordCount 或 LastPage 属性，则无需计算记录数量。默认值为真。

RecordCountCommandText

可选。若要在 GetRecordCount 为真时提高性能，可以指定一个显式 SQL 语句来获取记录计数。该语句的形式应该是 SELECT COUNT (*) FROM...，可以包含 WHERE 子句，但不包含参数。

EndRecord

可选。只读。用于获取 (CurrentPage + 1) * PageSize 和 RecordCount 的最小值。

LastPage

可选。只读。当使用 PageSize 且 GetRecordCount 为真时，可以获取最后一页从零开始的索引。

RecordCount

可选。只读。当 CreateDataSet 和 GetRecordCount 都为真时，可以获取由 CommandText 表达式生成的记录总数。

theDS

可选。只读。使您可以访问这样的数据集，它包含作为将 CreateDataSet 设置为真的结果而检索到的记录。

DefaultView

可选。只读。使您可以访问 theDS.Tables[0].DefaultView。

Debug

可选。真或假。如果执行此标签时引发异常，则允许您查看额外的提示。如果 Debug 属性为真，则将忽略 FailureURL（请参见“FailureURL”）。当开发页时，请将 Debug 设置为真，以获取有关该页的问题的可靠诊断信息。当将要部署页时，请将 Debug 设置为假，使外部访问者在该页出现问题时决不可能看到诊断信息和其他内部信息。

FailureURL

可选。用于指定在执行 CommandText 的过程中引发异常或给定属性发生冲突时所打开的页的 URL。

SuccessURL

可选。用于指定在 CommandText 语句的执行没有引发异常的情况下所打开的页的 URL。


MM:If

MM:If 标签用于控制是否在页上包含内容或逻辑。


示例

<MM:If
runat="server"
Expression="<%# (fruitsDS.CurrentPage == 0) %>">
   <ContentsTemplate>
   <font color='#CCCCCC'>Previous</font>
   </ContentsTemplate>
</MM:If>


必需的指令

<%@ Register TagPrefix="MM" Namespace="DreamweaverCtrls" Assembly="DreamweaverCtrls,version=1.0.0.0,publickeyToken=836f606ede05d46a,culture=neutral" %>


属性

Expression

必需。用于指定要解析的表达式。如果该表达式为真，则将使用此标签的内部内容。如果该表达式为假，则忽略内部内容。


MM:Insert

MM:Insert 标签用于在数据库中插入记录。


示例

<MM:Insert
runat="server"
CommandText="INSERT INTO fruits (name, color) VALUES (?, ?)"
ConnectionString='<%# MM_NOTD_STRING %>'
Expression=<%# Request.Form["MM_insert"] =="true"%>
Debug=”true”
CreateDataSet="false"
>
   <Parameters>
   <Parameter Value='<%# Request.Form["fruitName"] %>' />
   <Parameter Value='<%# Request.Form["fruitColor"] %>' />
   </Parameters>
</MM:Insert>


属性

MM:Insert 标签使用 MM:DataSet 标签所用的逻辑，因此它共享该标签的所有属性。有关更多信息，请参见MM:DataSet。请注意以下属性值：

Expression

如果将该属性设置为 false，则此标签不起作用。也就是说，将不执行在 CommandText 属性中指定的 SQL 语句或预存过程。您可以使用 Expression 属性控制插入操作在何时发生。例如，在执行插入操作之前，可能需要执行服务器端表单验证。在另一种情况下，只有在已经提交包含要插入的数据的表单时，该代码才会将 Expression 设置为 true。

CommandText

通常，它是插入记录的 INSERT SQL 语句或预存过程。

CreateDataSet

由于在执行 INSERT 语句后不会创建数据集，此属性通常设置为 false。但是，对于预存过程，可能会在执行插入操作后创建数据集。


MM:Update

MM:Update 标签用于更新数据库中的记录。


示例

<MM:Update
runat="server"
CommandText="UPDATE fruits SET color=?WHERE name=?"
ConnectionString='<%# MM_NOTD_STRING %>'
Expression=<%# Request.Form["MM_update"] =="true"%>
Debug=”true”
CreateDataSet="false"
>
   <Parameters>
   <Parameter Value='<%# Request.Form["fruitColor"] %>' />
   <Parameter Value='<%# Request.Form["updateNames"] %>' />
   </Parameters>
</MM:Update>


属性

MM:Update 标签使用 MM:DataSet 标签所用的逻辑，因此它共享该标签的所有属性。有关更多信息，请参见MM:DataSet。请注意以下属性值：

Expression

如果将该属性设置为 false，则此标签不起作用。也就是说，将不执行在 CommandText 属性中指定的 SQL 语句或预存过程。您可以使用 Expression 属性控制更新操作在何时发生。例如，在执行更新操作之前，可能需要执行服务器端表单验证。在另一种情况下，只有在已经提交包含要更新的数据的表单时，该代码才会将 Expression 设置为 true。

CommandText

通常，它是更新记录的 UPDATE SQL 语句或预存过程。

CreateDataSet

由于在执行 UPDATE 语句后不会创建数据集，此属性通常设置为 false。但是，对于预存过程，可能会在执行更新操作后创建数据集。


MM:Delete

MM:Delete 标签用于删除数据库中的记录。


示例

<MM:Delete
runat="server"
CommandText="DELETE FROM fruits WHERE name=?"
ConnectionString='<%# MM_NOTD_STRING %>'
Expression=<%# Request.Form["MM_delete"] =="true"%>
Debug=”true”
CreateDataSet="false"
>
   <Parameters>
   <Parameter Value='<%# Request.Form["deleteNames"] %>' />
   </Parameters>
</MM:Delete>


属性

MM:Delete 标签使用 MM:DataSet 标签所用的逻辑，因此它共享该标签的所有属性。有关更多信息，请参见MM:DataSet。请注意以下属性值：

Expression

如果将 Expression 设置为 false，则此标签不起作用。也就是说，将不执行在 CommandText 属性中指定的 SQL 语句或预存过程。您可以使用 Expression 属性控制删除操作在何时发生。例如，在执行删除操作之前，可能需要执行服务器端表单验证。

CommandText

通常，它是删除记录的 DELETE SQL 语句或预存过程。

CreateDataSet

由于在执行 DELETE 语句后不会创建数据集，此属性通常设置为 false。但是，对于预存过程，可能会在执行删除操作后创建数据集。


Parameters

Parameters 标签用于指定参数。在两种情况下可以指定参数：

  • 主标签的 CommandText 属性指定参数化的 SQL 语句（即，将问号 (?) 用作参数占位符的 SQL 语句）。

    • 备注： 参数化每一 SQL 语句的每一部分是不合法的。例如，可以参数化 SELECT 语句的 WHERE 子句，但不能参数化它的 ORDER BY 子句。通常，可以参数化 SQL 语句中的任意名称/值对。

  • CommandText 属性指定采用参数的预存过程。

在这两种情况下，提供参数值 Parameter 标签都与占位符以相同的顺序出现（请参见Parameter）。Parameter 标签的两边必须加 Parameters 标签。


Parameter

Parameter 标签用于指定参数值。


属性

Value

必需。赋给 Input 或 InputOutput 参数的值（请参见“Direction”）。在传递到数据库之前，该值将转换为适当的数据类型。这种转换取决于 Type 属性的设置。当 Direction 属性为 Output、InputOutput 或 ReturnValue，则将在执行 CommandText 后设置该值。

Direction

可选。用于指定以下值之一：Input、InputOutput、Output、ReturnValue。默认为 Input。

Name

可选。对于参数化的 SQL 语句，名称可以是任意字符串。通常，该名称与参数的含义相关（如 @deptName）并且以 @ 字符开头。不过，唯一的要求是 Parameter 标签出现的顺序必须与 SQL 语句中问号的顺序相对应。由于名称是可选的，您可以忽略该属性，在这种情况下，名称将设置为“parameter_”，并加上该参数在所提供的参数列表中从一开始的索引。

对于预存过程，名称必须匹配预存过程中的参数标记（例如 @id）。这意味着您必须在使用预存过程时提供该属性。如果需要类型为 ReturnValue 的参数，其 Parameter 标签必须出现在其他所有 Parameter 标签之前。

Size

可选。参数值的大小。它也称作列的宽度。如果未提供，则从 Type 和 Value 属性推断出该属性的值。

Type

可选。指定参数类型。您可以指定以下数据类型，其中每一种数据类型都可以按以下两种方式之一来表示。

(int)OleDbType.Boolean | "Boolean"
(int)OleDbType.UnsignedTinyInt | "UnsignedTinyInt"
(int)OleDbType.Char | "Char"
(int)OleDbType.DBTimeStamp | "DBTimeStamp"
(int)OleDbType.Decimal | "Decimal"
(int)OleDbType.Double | "Double"
(int)OleDbType.Single | "Single"
(int)OleDbType.Integer | "Integer"
(int)OleDbType.SmallInt | "SmallInt"
(int)OleDbType.BigInt | "BigInt"
(int)OleDbType.VarChar | "VarChar"
(int)OleDbType.UnsignedSmallInt | "UnsignedSmallInt"
(int)OleDbType.UnsignedInt | "UnsignedInt"
(int)OleDbType.UnsignedBigInt | "UnsignedBigInt"
(int)OleDbType.Currency | "Currency"
(int)OleDbType.DBDate | "DBDate"
(int)OleDbType.TinyInt | "TinyInt"
(int)OleDbType.DBTime | "DBTime"
(int)OleDbType.VarNumeric | "VarNumeric"

不支持以下 OleDbType 值：

(int)OleDbType.Guid | "Guid"
(int)OleDbType.Variant | "Variant"
上一页


商标

Afterburner、AppletAce、Attain、Attain Enterprise Learning System、Attain Essentials、Attain Objects for Dreamweaver、Authorware、Authorware Attain、Authorware Interactive Studio、Authorware Star、Authorware Synergy、Backstage、Backstage Designer、Backstage Desktop Studio、Backstage Enterprise Studio、Backstage Internet Studio、Design in Motion、Director、Director Multimedia Studio、Doc Around the Clock、Dreamweaver、Dreamweaver Attain、Drumbeat、Drumbeat 2000、Extreme 3D、Fireworks、Flash、Fontographer、FreeHand、FreeHand Graphics Studio、Generator、Generator Developer's Studio、Generator Dynamic Graphics Server、Knowledge Objects、Knowledge Stream、Knowledge Track、Lingo、Live Effects、Macromedia、Macromedia M Logo & Design、Macromedia Flash、Macromedia Xres、Macromind、Macromind Action、MAGIC、Mediamaker、Object Authoring、Power Applets、Priority Access、Roundtrip HTML、Scriptlets、SoundEdit、ShockRave、Shockmachine、Shockwave、Shockwave Remote、Shockwave Internet Studio、Showcase、Tools to Power Your Ideas、Universal Media、Virtuoso、Web Design 101、Whirlwind 和 Xtra 是 Macromedia, Inc. 的商标，并且可能已在美国或其他司法管辖区域（包括国际法管辖区域）内注册。本出版物涉及的其他产品名称、徽标、图案、标题、文字或短语可能是 Macromedia, Inc. 或其他实体的商标、服务标志或商品名称，并且可能已在某些司法管辖区域（包括国际法管辖区域）内注册。

本指南包含到第三方 Web 站点的链接，这些站点不受 Macromedia 的控制，并且 Macromedia 不对所链接的任何站点上的内容负责。如果您访问本指南中提到的第三方 Web 站点，则一切风险均由您自己承担。Macromedia 提供这些链接仅仅是为了方便，并不意味着 Macromedia 认可或接受对这些第三方站点上的内容负有任何责任。

下一页


Apple 免责声明

对于所提供的计算机软件包、任何针对特殊目的的适销性或适用性，APPLE COMPUTER, INC. 不做任何明示或暗示的担保。某些州不允许排除暗示担保，因此以上排除条款可能对您不适用。本担保为您提供特定的法律权利。根据各个州的不同情况，您也可能拥有其他法律权利。

版权所有 © 2002 Macromedia, Inc. 保留所有权利。未经 Macromedia, Inc. 事先书面许可，不得将本手册的全部或部分拷贝、影印、复制、翻译或转换为任何电子形式或可用机器读取的形式。

在网址 http://www.macromedia.com/go/thirdparty/ 可以找到第三方软件声明和/或附加条款和条件。


鸣谢

项目管理：Sheila McGinn

撰写：Chris Bedford、Kim Diezel、Jed Hartman、Charles Nadeau、Jennifer Rowe

编辑：Mary Ferguson、Mary Kraemer、Lisa Stanziano

产品管理：Patrice O'Neill

多媒体设计和制作：Aaron Begley、Benjamin Salles、Noah Zilberberg

打印和帮助设计和制作：Chris Basmajian、Caroline Branch、John Francis

Web 编辑和制作：George Brown、Rebecca Godbois、Jeff Harmon、Jon Varese

本地化项目经理: Bonnie Loo

特别感谢：Luciano Arruda、Jake Cockrell、Kristin Conradi、George Comninos、David Deming、Tonya Estes、Stephanie Goss、David Halbakken、Nick Halbakken、Wanda Huang、Narciso (nj) Jaramillo、Craig Jennings、Ken Karleskint、Sho Kuwamoto、David Lenoe、Jay London、Sam Mathews、Larry McLister、Susan Morrow、Masayo Noda、Dan Radigan、Mike Sundermeyer、Heidi Bauer Williams、Jorge Taylor、Lawrence Teschmacher、Venu Venugopal、 Luciano Arruda、Raymond Lim、Nivesh Rajbhandari、Scott Richards、Yoko Vogt、Vincent Truong、Ya Yang、Arky Tan、Jerry Wang、Masayo Noda、Yoko Shindo、Tim Hussey 和全体 Dreamweaver 工程和质量控制小组成员。

第一版：2002 年 7 月

Macromedia, Inc.
600 Townsend St.
San Francisco, CA 94103

帮助版本： 6.0.35

上一页


000_titl.htm

使用 Dreamweaver MX

版权所有 © 2002 Macromedia, Inc.
保留所有权利。
商标 和 鸣谢